Aspose.Cells for .NET

Aspose.Cells for .NET Documentation

Aspose.Cells for .NET API Reference

The Aspose.Cells class library provides the following namespaces:

Aspose.Cells Contains all classes of Aspose.Cells
Aspose.Cells.Charts Contains all classes of chart and sparkline
Aspose.Cells.Drawing Contains all classes of shapes and fill format
Aspose.Cells.Drawing.ActiveXControls Contains all classes of ActiveXControl.
Aspose.Cells.Drawing.Texts Contains all classes of text options.
Aspose.Cells.ExternalConnections Contains all classes of external connections
Aspose.Cells.Markup Contains all classes of smart tag
Aspose.Cells.Pivot Contains all classes of PivotTable
Aspose.Cells.Properties Contains all classes of document and worksheet properties
Aspose.Cells.Rendering Contains all classes of Rendering image and pdf
Aspose.Cells.Rendering.PdfSecurity Contains all security options of Rendering pdf
Aspose.Cells.Tables Contains all classes of Table(List Object)
Aspose.Cells.DigitalSignatures Contains all classes of DigitalSignature
Aspose.Cells.Vba Contains all classes of VBA project.
Aspose.Cells.Metadata Contains all classes of loading and saving metadata.
Aspose.Cells.Revisions Contains all classes of revision logs.
Aspose.Cells.Utility Contains all classes of utility.

The Aspose.Cells Grid Suite provides the following namespaces:

Aspose.Cells.GridDesktop Contains all classes of Aspose.Cells.GridDesktop
Aspose.Cells.GridDesktop.Data Contains all classes of Aspose.Cells.GridDesktop.Data
Aspose.Cells.GridDesktop.ToolBar Contains all classes of Aspose.Cells.GridDesktop.ToolBar
Aspose.Cells.GridWeb Contains all classes of Aspose.Cells.GridWeb
Aspose.Cells.GridWeb.Data Contains all classes of Aspose.Cells.GridWeb.Data
Aspose.Cells.GridWeb.Design Contains all classes of Aspose.Cells.GridWeb.Design (used for internal purpose)


Aspose.Cells

Aspose.Cells for .NET

Aspose.Cells Namespace

Namespace hierarchy

Classes

Class | Description
AboveAverage | Describe the AboveAverage conditional formatting rule. This conditional formatting rule highlights cells that are above or below the average for all values in the range.
AbstractCalculationEngine | Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.
AbstractCalculationMonitor | Monitor for user to track the progress of formula calculation.
AbstractTextLoadOptions | Common options for loading text values
AutoFilter | Represents autofiltering for the specified worksheet.
AutoFitterOptions | Represents all auto fitter options.
Border | Encapsulates the object that represents the cell border.
BorderCollection | Encapsulates a collection of Border objects.
CalculationCell | Represents the calculation relevant data about one cell which is being calculated.
CalculationData | Represents the required data when calculating one function, such as function name, parameters, ...etc.
CalculationOptions | Represents options for calculation.
Cell | Encapsulates the object that represents a single Workbook cell.
Cells | Encapsulates a collection of cell relevant objects, such as Cell, Row, ...etc.
CellsColor | Represents all types of color.
CellsException | The exception that is thrown when Aspose.Cells specified error occurs.
CellsFactory | Utility for instantiating classes of Cells model.
CellsHelper | Provides helper functions.
CellWatch | Represents Cell Watch Item in the 'watch window'.
CellWatchCollection | Represents the collection of cells on this worksheet being watched in the 'watch window'.
ColorFilter | Represents the color filter.
ColorScale | Describe the ColorScale conditional formatting rule. This conditional formatting rule creates a gradated color scale on the cells.
Column | Represents a single column in a worksheet.
ColumnCollection | Collects the objects that represent the individual columns in a worksheet.
Comment | Encapsulates the object that represents a cell comment.
CommentCollection | Encapsulates a collection of Comment objects.
ConditionalFormattingCollection | Encapsulates a collection of FormatCondition objects.
ConditionalFormattingIcon | Represents the custom icon of conditional formatting rule.
ConditionalFormattingIconCollection | Represents a collection of ConditionalFormattingIcon objects.
ConditionalFormattingResult | Represents the result of conditional formatting which applies to a cell.
ConditionalFormattingValue | Describes the values of the interpolation points in a gradient scale, dataBar or iconSet.
ConditionalFormattingValueCollection | Describes a collection of CFValueObject. Use only for icon sets.
CopyOptions | Represents the copy options.
CustomFilter | Represents the custom filter.
CustomFilterCollection | Represents the custom filters.
CustomImplementationFactory | Factory to create some instances which may be re-implemented by user for special purpose.
DataBar | Describe the DataBar conditional formatting rule. This conditional formatting rule displays a gradated data bar in the range of cells.
DataBarBorder | Represents the border of the data bars specified by a conditional formatting rule.
DataSorter | Summary description for DataSorter.
DataSorterKey | Represents the key of the data sorter.
DataSorterKeyCollection | Represents the key list of data sorter.
DateTimeGroupItem | Represents the datetime's group setting.
DeleteOptions | Represents the setting of deleting rows/columns.
DifSaveOptions | Represents the options of saving dif file.
DocxSaveOptions | Represents options of saving docx file.
DxfCollection | Represents the master differential formatting records.
DynamicFilter | Represents the dynamic filter.
ErrorCheckOption | Error check setting applied on certain ranges.
ErrorCheckOptionCollection | Represents all error check option.
ExportObjectEvent | The event triggered when exporting an object, such as Picture.
ExportTableOptions | Represents all export table options.
ExternalLink | Represents an external link in a workbook.
ExternalLinkCollection | Represents external links collection in a workbook.
FileFontSource | Represents the single TrueType font file stored in the file system.
FileFormatInfo | Contains data returned by FileFormatUtil file format detection methods.
FileFormatUtil | Provides utility methods for converting file format enums to strings or file extensions and back.
FilterColumn | Represents a filter for a single column. The Filter object is a member of the Filters collection
FilterColumnCollection | A collection of Filter objects that represents all the filters in an autofiltered range.
FindOptions | Represents find options.
FolderFontSource | Represents the folder that contains TrueType font files.
Font | Encapsulates the font object used in a spreadsheet.
FontConfigs | Specifies font settings
FontSetting | Represents a range of characters within the cell text.
FontSourceBase | This is an abstract base class for the classes that allow the user to specify various font sources
FormatCondition | Represents conditional formatting condition.
FormatConditionCollection | Represents conditional formatting. The FormatConditions can contain up to three conditional formats.
FormulaParseOptions | Represents options when parsing formula.
GlobalizationSettings | Represents the globalization settings.
HeaderFooterCommand | Represents the command of header/footer
HorizontalPageBreak | Encapsulates the object that represents a horizontal page break.
HorizontalPageBreakCollection | Encapsulates a collection of HorizontalPageBreak objects.
HtmlLoadOptions | Represents options when importing a html file.
HtmlSaveOptions | Represents the options for saving html file.
Hyperlink | Encapsulates the object that represents a hyperlink.
HyperlinkCollection | Encapsulates a collection of Hyperlink objects.
IconFilter | Represents icon filter.
IconSet | Describe the IconSet conditional formatting rule. This conditional formatting rule applies icons to cells according to their values.
ImageSaveOptions | Represents image save options
ImportTableOptions | Represents the options of importing data into cells.
IndividualFontConfigs | Font configs for each Workbook object.
InsertOptions | Represents the options of inserting.
InterruptMonitor | Represents all operator about the interrupt.
License | Provides methods to license the component.
LoadFilter | Represents the filter that provides options for loading data when loading workbook from template.
LoadOptions | Represents the options of loading the file.
MarkdownSaveOptions | Represents the save options for markdown.
MemoryFontSource | Represents the single TrueType font file stored in memory.
Metered | Provides methods to set metered key.
MultipleFilterCollection | Represents the multiple filter collection.
Name | Represents a defined name for a range of cells.
NameCollection | Represents a collection of all the Name objects in the spreadsheet.
NegativeBarFormat | Represents the color settings of the data bars for negative values that are defined by a data bar conditional formatting rule.
OdsLoadOptions | Represents the options of loading ods file.
OdsSaveOptions | Represents the options of saving ods file.
OoxmlSaveOptions | Represents the options of saving office open xml file.
Outline | Represents an outline on a worksheet.
PageSetup | Encapsulates the object that represents the page setup description. The PageSetup object contains all page setup options.
PaneCollection | Represents all Pane objects shown in the specified window.
PasteOptions | Represents the paste special options.
PdfSaveOptions | Represents the options for saving pdf file.
PptxSaveOptions | Represents the pptx save options.
ProtectedRange | A specified range to be allowed to edit when the sheet protection is ON.
ProtectedRangeCollection | Encapsulates a collection of ProtectedRange objects.
Protection | Represents the various types of protection options available for a worksheet. Only used in ExcelXP and above version.
QueryTable | Represents QueryTable information.
QueryTableCollection | A collection of QueryTableCollection objects that represent QueryTable collection information.
Range | Encapsulates the object that represents a range of cells within a spreadsheet.
RangeCollection | Encapsulates a collection of Range objects.
ReferredArea | Represents a referred area by the formula.
ReferredAreaCollection | Represents all referred cells and areas.
ReplaceOptions | Represent the replace options.
Row | Represents a single row in a worksheet.
RowCollection | Collects the objects that represent the individual rows in a worksheet.
SaveOptions | Represents all save options
Scenario | Represents an individual scenario.
ScenarioCollection | Represents the list of scenarios.
ScenarioInputCell | Represents input cell for the scenario.
ScenarioInputCellCollection | Represents the list of the scenario's input cells.
SpreadsheetML2003SaveOptions | Represents the options for saving Excel 2003 spreadml file.
StreamProviderOptions | Represents the stream options.
Style | Represents display style of excel document,such as font,color,alignment,border,etc.
StyleCollection | Obsolete.
StyleFlag | Represents flags which indicates applied formatting properties.
SubtotalSetting | Represents the setting of the subtotal .
SvgSaveOptions | Represents Svg save options
ThemeColor | Represents a theme color.
ThreadedComment | Represents the threaded comment.
ThreadedCommentAuthor | Represents the person who creates the threaded comments;
ThreadedCommentAuthorCollection | Represents all persons who .
ThreadedCommentCollection | Represents the list of threaded comments.
Top10 | Describe the Top10 conditional formatting rule. This conditional formatting rule highlights cells whose values fall in the top N or bottom N bracket, as specified.
Top10Filter | Represents the top 10 filter.
TxtLoadOptions | Represents the options for loading text file.
TxtSaveOptions | Represents the save options for csv/tab delimited/other text format.
UnionRange | Represents union range.
Validation | Represents data validation.settings.
ValidationCollection | Represents data validation collection.
VerticalPageBreak | Encapsulates the object that represents a vertical page break.
VerticalPageBreakCollection | Encapsulates a collection of VerticalPageBreak objects.
WarningInfo | Warning info
Workbook | Represents a root object to create an Excel spreadsheet.
WorkbookDesigner | Encapsulates the object that represents a designer spreadsheet.
WorkbookSettings | Represents all settings of the workbook.
Worksheet | Encapsulates the object that represents a single worksheet.
WorksheetCollection | Encapsulates a collection of Worksheet objects.
WriteProtection | Specifies write protection settings for a workbook.
XlsbSaveOptions | Represents the options for saving xlsb file.
XlsSaveOptions | Represents the save options for the Excel 97-2003 file format: xls and xlt.
XmlColumnProperty | Represents Xml Data Binding information.
XmlDataBinding | Represents Xml Data Binding information.
XmlMap | Represents Xml map information.
XmlMapCollection | A collection of XmlMap objects that represent XmlMap information.
XpsSaveOptions | Represents the additional options when saving the file as the Xps.

Interfaces

Interface | Description
ICellsDataTable | Represents data table.
ICustomFunction | Obsolete.
ICustomParser | Allows users to add their custom value parser for parsing string values to other proper cell value object.
IExportObjectListener | Allows users to manipulate objects while exporting.
IFilePathProvider | Represents the exported file path provider.
ISmartMarkerCallBack | Represents callback interface of processing smartmarker.
IStreamProvider | Represents the exported stream provider.
IWarningCallback | Callback interface of warning.
LightCellsDataHandler | Represents cells data handler for reading large spreadsheet files in light weight mode.
LightCellsDataProvider | Represents Data provider for saving large spreadsheet files in light weight mode.

Structures

Structure | Description
CellArea | Represent an area of cells.

Enumerations

Enumeration | Description
AutoFitMergedCellsType | Represents the type of auto fitting merged cells.
AutoFitWrappedTextType | Represents the type of auto fitting wrapped text.
BackgroundType | Enumerates cell background pattern types.
BorderType | Enumerates the border line and diagonal line types.
BuiltinStyleType | Represents all built-in style type
CalcModeType | Represents the mode type of calculating formulas.
CalculationPrecisionStrategy | Enumerates strategies for handling calculation precision. Because of the precision issue of IEEE 754 Floating-Point Arithmetic, some "seemingly simple" formulas may not be calculated as the expected result. Such as formula "=-0.45+0.43+0.02", when calculating operands by '+' operator directly, the result is not zero. For such kind of precision issue, some special strategies may give the expected result.
CellBorderType | Enumerates a cell's border type.
CellValueFormatStrategy | Specifies how to apply style for the value of the cell.
CellValueType | Specifies a cell value type.
ColorType | Represents all color type
ConsolidationFunction | Represents consolidation function.
ContentDisposition | The content disposition type.
CopyFormatType | Represents type of copying format when inserting rows.
CountryCode | Represents Excel country identifiers.
DataBarAxisPosition | Specifies the axis position for a range of cells with conditional formatting as data bars.
DataBarBorderType | Specifies the border type of a data bar.
DataBarFillType | Specifies how a data bar is filled with color.
DataBarNegativeColorType | Specifies whether to use the same border and fill color as positive data bars.
DateTimeGroupingType | Specifies how to group dateTime values.
DefaultEditLanguage | Represents the default edit language.
DirectoryType | Represents the directory type of the file name.
DisplayDrawingObjects | Represents whether and how to show objects in the workbook.
DynamicFilterType | Dynamic filter type.
EmfRenderSetting | Setting for rendering Emf metafile.
EncryptionType | Encryption Type. Only used by excel2003. We will encrypt 2007/2010 workbook using SHA AES the same as Excel does, and this EncryptionType will be ignored.
ErrorCheckType | Represents all error check type.
ExceptionType | Represents custom exception type code.
ExternalLinkType | Represents the type of external link.
FileFormatType | Enumerates spreadsheet file format types
FilterOperatorType | Custom Filter operator type.
FilterType | The filter type.
FontSchemeType | Represents the scheme type of the font.
FontSourceType | Specifies the type of a font source.
FontUnderlineType | Enumerates the font underline types.
FormatConditionType | Conditional format rule type.
FormatConditionValueType | Condition value type.
GridlineType | Enumerates grid line Type.
HeaderFooterCommandType | Represents the command type of header and footer.
HtmlCrossType | Represents five types of html cross string.
HtmlExportDataOptions | Represents the options for exporting html data.
HtmlHiddenColDisplayType | Represents two types of showing the hidden col in html.
HtmlHiddenRowDisplayType | Represents two types of showing the hidden row in html.
HtmlLinkTargetType | Represents the type of target attribute in HTML tag.
IconSetType | Icon set type for conditional formatting. The threshold values for triggering the different icons within a set are configurable, and the icon order is reversible.
LoadDataFilterOptions | Represents the options to filter data when loading workbook from template.
LoadFormat | Represents the load file format.
LookAtType | Represents look at type.
LookInType | Represents look in type.
MemorySetting | Memory usage options.
NumberCategoryType | Represents category type of cell's number formatting.
OoxmlCompliance | Allows to specify which OOXML specification will be used when saving in the Xlsx format.
OoxmlCompressionType | The Ooxml compression type
OperatorType | Represents the operator type of conditional format and data validation.
PageLayoutAlignmentType | Enumerates page layout alignment types.
PageOrientationType | Represents print orientation constants.
PaneStateType | Represents state of the sheet's pane.
PaperSizeType | Represents paper size constants.
ParameterType | Represents all parameters' type or return value type of function.
PasteType | Represents the paste special type.
PrintCommentsType | Represents the way comments are printed with the sheet.
PrintErrorsType | Represents print errors constants.
PrintingPageType | Indicates which pages will not be printed.
PrintOrderType | Represent print order constants.
PrintSizeType | Represents the printed chart size.
ProtectionType | Represents workbook/worksheet protection type.
RegexType | Represents the regex type for searching string.
RenameStrategy | Renames strategy when columns contains the duplicate names.
ResourceLoadingType | Represents how to loading the linked resource.
SaveFormat | Represents the format in which the workbook is saved.
SheetType | Specifies the worksheet type.
ShiftType | Represent the shift options when deleting a range of cells.
SortOnType | Sorted value type.
SortOrder | Represents sort order for the data range.
StyleModifyFlag | The style modified flags.
TargetModeType | Represents the type of target mode.
TextAlignmentType | Enumerates text alignment types.
TextCapsType | This type specifies the cap types of the text.
TextCrossType | Enumerates displaying text type when the text width is larger than cell width.
TextDirectionType | Represents the direction of the text flow for this paragraph.
TextOrientationType | Enumerates text orientation types.
TextStrikeType | This type specifies the strike type.
ThemeColorType | Enumerates the theme color types.
TimePeriodType | Used in a FormatConditionType.TimePeriod conditional formatting rule. These are dynamic time periods, which change based on the date the conditional formatting is refreshed / applied.
TxtLoadStyleStrategy | Specifies how to apply style for parsed values when converting string value to number or datetime.
TxtValueQuoteType | Specifies the type of using quotation marks for values in text format files.
UpdateLinksType | Represents how to update links to other workbooks when the workbook is opened.
ValidationAlertType | Represents the data validation alert style.
ValidationType | Represents data validation type.
ViewType | Represents the view type of the worksheet.
VisibilityType | Represents the states for sheet visibility.
WarningType | WaringType

Generated:2020-10-15 04:56:12,version:1.3.49.0


AboveAverage Class

Describe the AboveAverage conditional formatting rule. This conditional formatting rule highlights cells that are above or below the average for all values in the range.

For a list of all members of this type, see AboveAverage Members.

System.Object
Aspose.Cells.AboveAverage

public class AboveAverage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AboveAverage Members | Aspose.Cells Namespace


AboveAverage Members

AboveAverage overview

Public Instance Constructors

AboveAverage Constructor Initializes a new instance of the AboveAverage class.

Public Instance Properties

IsAboveAverage | Get or set the flag indicating whether the rule is an "above average" rule. 'true' indicates 'above average'. Default value is true.
IsEqualAverage | Get or set the flag indicating whether the 'aboveAverage' and 'belowAverage' criteria is inclusive of the average itself, or exclusive of that value. 'true' indicates to include the average value in the criteria. Default value is false.
StdDev | Get or set the number of standard deviations to include above or below the average in the conditional formatting rule. The input value must between 0 and 3 (include 0 and 3). Setting this value to 0 means stdDev is not set. The default value is 0.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

AboveAverage Class | Aspose.Cells Namespace


AboveAverage Constructor

Initializes a new instance of the AboveAverage class.

public AboveAverage();

See Also

AboveAverage Class | Aspose.Cells Namespace


AboveAverage Properties

The properties of the AboveAverage class are listed below. For a complete list of AboveAverage class members, see the AboveAverage Members topic.

Public Instance Properties

IsAboveAverage | Get or set the flag indicating whether the rule is an "above average" rule. 'true' indicates 'above average'. Default value is true.
IsEqualAverage | Get or set the flag indicating whether the 'aboveAverage' and 'belowAverage' criteria is inclusive of the average itself, or exclusive of that value. 'true' indicates to include the average value in the criteria. Default value is false.
StdDev | Get or set the number of standard deviations to include above or below the average in the conditional formatting rule. The input value must between 0 and 3 (include 0 and 3). Setting this value to 0 means stdDev is not set. The default value is 0.

See Also

AboveAverage Class | Aspose.Cells Namespace


IsAboveAverage Property

Aspose.Cells for .NET

AboveAverage.IsAboveAverage Property

Get or set the flag indicating whether the rule is an "above average" rule. 'true' indicates 'above average'. Default value is true.

public bool IsAboveAverage {get; set;}

See Also

AboveAverage Class | Aspose.Cells Namespace


IsEqualAverage Property

Aspose.Cells for .NET

AboveAverage.IsEqualAverage Property

Get or set the flag indicating whether the 'aboveAverage' and 'belowAverage' criteria is inclusive of the average itself, or exclusive of that value. 'true' indicates to include the average value in the criteria. Default value is false.

public bool IsEqualAverage {get; set;}

See Also

AboveAverage Class | Aspose.Cells Namespace


StdDev Property

Aspose.Cells for .NET

AboveAverage.StdDev Property

Get or set the number of standard deviations to include above or below the average in the conditional formatting rule. The input value must between 0 and 3 (include 0 and 3). Setting this value to 0 means stdDev is not set. The default value is 0.

public int StdDev {get; set;}

See Also

AboveAverage Class | Aspose.Cells Namespace


AbstractCalculationEngine Class

Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.

For a list of all members of this type, see AbstractCalculationEngine Members.

System.Object
Aspose.Cells.AbstractCalculationEngine

public abstract class AbstractCalculationEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

User should not modify any part of the Workbook directly in this implementation(except the calculated result of the custom function, which can be set by CalculationData.CalculatedValue property). Otherwise unexpected result or Exception may be caused. If user needs to change other data than calculated result in the implementation for some custom functions, for example, change cell's formula, style, ...etc., user should gather those data in this implementation and change them out of the scope of formula calculation.

Example

[C#]
public class MyEngine : AbstractCalculationEngine
{
    public override void Calculate(CalculationData data)
    {
        string funcName = data.FunctionName.ToUpper();
        if ("MYFUNC".Equals(funcName))
        {
            //do calculation for MYFUNC here
            int count = data.ParamCount;
            object res = null;
            for (int i = 0; i < count; i++)
            {
                object pv = data.GetParamValue(i);
                if (pv is ReferredArea)
                {
                    ReferredArea ra = (ReferredArea)pv;
                    pv = ra.GetValue(0, 0);
                }
                //process the parameter here
                //res = ...;
            }
            data.CalculatedValue = res;
        }
    }
}

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AbstractCalculationEngine Members | Aspose.Cells Namespace


AbstractCalculationEngine Members

AbstractCalculationEngine overview

Public Instance Properties

IsParamLiteralRequired | Indicates whether this engine needs the literal text of parameter while doing calculation. Default value is false.
ProcessBuiltInFunctions | Whether built-in functions that have been supported by the built-in engine should be checked and processed by this implementation. Default is false. If user needs to change the calculation logic of some built-in functions, this property should be set as true.

Public Instance Methods

Calculate | Calculates one function with given data.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

AbstractCalculationEngine Class | Aspose.Cells Namespace


AbstractCalculationEngine Properties

The properties of the AbstractCalculationEngine class are listed below. For a complete list of AbstractCalculationEngine class members, see the AbstractCalculationEngine Members topic.

Public Instance Properties

IsParamLiteralRequired | Indicates whether this engine needs the literal text of parameter while doing calculation. Default value is false.
ProcessBuiltInFunctions | Whether built-in functions that have been supported by the built-in engine should be checked and processed by this implementation. Default is false. If user needs to change the calculation logic of some built-in functions, this property should be set as true.

See Also

AbstractCalculationEngine Class | Aspose.Cells Namespace


IsParamLiteralRequired Property

Aspose.Cells for .NET

AbstractCalculationEngine.IsParamLiteralRequired Property

Indicates whether this engine needs the literal text of parameter while doing calculation. Default value is false.

public virtual bool IsParamLiteralRequired {get;}

Remarks

If this custom calculation engine requires the parameter's literal text, more stacks will be required to cache the literal text for parameters and Calculate() method may be called recursively to calculate the parameter's value. Commonly the literal text is not needed for calculating formulas and this method should return false for most implementations to get better performance.

See Also

AbstractCalculationEngine Class | Aspose.Cells Namespace


ProcessBuiltInFunctions Property

Aspose.Cells for .NET

AbstractCalculationEngine.ProcessBuiltInFunctions Property

Whether built-in functions that have been supported by the built-in engine should be checked and processed by this implementation. Default is false. If user needs to change the calculation logic of some built-in functions, this property should be set as true.

public virtual bool ProcessBuiltInFunctions {get;}

See Also

AbstractCalculationEngine Class | Aspose.Cells Namespace


AbstractCalculationEngine Methods

The methods of the AbstractCalculationEngine class are listed below. For a complete list of AbstractCalculationEngine class members, see the AbstractCalculationEngine Members topic.

Public Instance Methods

Calculate | Calculates one function with given data.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

AbstractCalculationEngine Class | Aspose.Cells Namespace


AbstractCalculationEngine.Calculate Method

Calculates one function with given data.

public abstract void Calculate(
CalculationData data
);

Parameters

data
the required data to calculate function such as function name, parameters, ...etc.

Remarks

User should set the calculated value for given data for all functions(including excel native functions) that he wants to calculate by himself in this implementation.

See Also

AbstractCalculationEngine Class | Aspose.Cells Namespace


AbstractCalculationMonitor Class

Monitor for user to track the progress of formula calculation.

For a list of all members of this type, see AbstractCalculationMonitor Members.

System.Object
Aspose.Cells.AbstractCalculationMonitor

public abstract class AbstractCalculationMonitor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Custom monitor to check possibility of StackOverflowException
public class MyCalculationMonitor : AbstractCalculationMonitor
{
    public override void BeforeCalculate(int sheetIndex, int rowIndex, int colIndex)
    {
        if(new StackTrace(false).FrameCount > 1000)
        {
            throw new Exception("Stop the formula calculation because risk of StackOverflowException");
        }
    }
}

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AbstractCalculationMonitor Members | Aspose.Cells Namespace


AbstractCalculationMonitor Members

AbstractCalculationMonitor overview

Public Instance Properties

CalculatedValue | Gets the newly calculated value of the cell. Should be used only in AfterCalculate.
OriginalValue | Gets the old value of the calculated cell. Should be used only in BeforeCalculate and AfterCalculate.
ValueChanged | Whether the cell's value has been changed after the calculation. Should be used only in AfterCalculate.

Public Instance Methods

AfterCalculate | Implement this method to do business after one cell has been calculated.
BeforeCalculate | Implement this method to do business before calculating one cell.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
OnCircular | Implement this method to do business when calculating one cell and circular references being encountered
ToString (inherited from Object) |

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


AbstractCalculationMonitor Properties

The properties of the AbstractCalculationMonitor class are listed below. For a complete list of AbstractCalculationMonitor class members, see the AbstractCalculationMonitor Members topic.

Public Instance Properties

CalculatedValue | Gets the newly calculated value of the cell. Should be used only in AfterCalculate.
OriginalValue | Gets the old value of the calculated cell. Should be used only in BeforeCalculate and AfterCalculate.
ValueChanged | Whether the cell's value has been changed after the calculation. Should be used only in AfterCalculate.

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


CalculatedValue Property

Aspose.Cells for .NET

AbstractCalculationMonitor.CalculatedValue Property

Gets the newly calculated value of the cell. Should be used only in AfterCalculate.

public object CalculatedValue {get;}

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


OriginalValue Property

Aspose.Cells for .NET

AbstractCalculationMonitor.OriginalValue Property

Gets the old value of the calculated cell. Should be used only in BeforeCalculate and AfterCalculate.

public object OriginalValue {get;}

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


ValueChanged Property

Aspose.Cells for .NET

AbstractCalculationMonitor.ValueChanged Property

Whether the cell's value has been changed after the calculation. Should be used only in AfterCalculate.

public bool ValueChanged {get;}

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


AbstractCalculationMonitor Methods

The methods of the AbstractCalculationMonitor class are listed below. For a complete list of AbstractCalculationMonitor class members, see the AbstractCalculationMonitor Members topic.

Public Instance Methods

AfterCalculate | Implement this method to do business after one cell has been calculated.
BeforeCalculate | Implement this method to do business before calculating one cell.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
OnCircular | Implement this method to do business when calculating one cell and circular references being encountered
ToString (inherited from Object) |

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


AbstractCalculationMonitor.AfterCalculate Method

Implement this method to do business after one cell has been calculated.

public virtual void AfterCalculate(
int sheetIndex,
int rowIndex,
int colIndex
);

Parameters

sheetIndex
Index of the sheet that the cell belongs to.
rowIndex
Row index of the cell
colIndex
Column index of the cell

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


AbstractCalculationMonitor.BeforeCalculate Method

Implement this method to do business before calculating one cell.

public virtual void BeforeCalculate(
int sheetIndex,
int rowIndex,
int colIndex
);

Parameters

sheetIndex
Index of the sheet that the cell belongs to.
rowIndex
Row index of the cell
colIndex
Column index of the cell

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


AbstractCalculationMonitor.OnCircular Method

Implement this method to do business when calculating one cell and circular references being encountered

public virtual bool OnCircular(
IEnumerator circularCellsData
);

Parameters

circularCellsData
IEnumerator to enumerate cells(represented by CalculationCell object) in the circular chain

Return Value

Whether the formula engine needs to calculate those cells in circular after this call. True to let the formula engine continue to do calculation for them. False to let the formula engine just mark those cells in circular as Calculated. At the meantime, user may set the expected value as calculated result for the cell in this implementation.

Remarks

To process circular references, please make sure the value of property WorkbookSettings.Iteration is true and WorkbookSettings.MaxIteration is greater than 0.

See Also

AbstractCalculationMonitor Class | Aspose.Cells Namespace


AbstractTextLoadOptions Class

Common options for loading text values

For a list of all members of this type, see AbstractTextLoadOptions Members.

System.Object
Aspose.Cells.LoadOptions
Aspose.Cells.AbstractTextLoadOptions
Aspose.Cells.HtmlLoadOptions
Aspose.Cells.TxtLoadOptions

public class AbstractTextLoadOptions : LoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AbstractTextLoadOptions Members | Aspose.Cells Namespace


AbstractTextLoadOptions Members

AbstractTextLoadOptions overview

Public Instance Properties

AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
ConvertDateTimeData | Gets or sets a value that indicates whether the string in text file is converted to date data.
ConvertNumericData | Gets or sets a value that indicates whether the string in text file is converted to numeric data.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
Encoding | Gets and sets the default encoding. Only applies for csv file.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
KeepPrecision | Indicates whether not parsing a string value if the length is 15.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
LoadStyleStrategy | Indicates the strategy to apply style for parsed values when converting string value to number or datetime.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPaperSize (inherited from LoadOptions) | Sets the default print paper size from default printer's setting.
ToString (inherited from Object) |

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


AbstractTextLoadOptions Properties

The properties of the AbstractTextLoadOptions class are listed below. For a complete list of AbstractTextLoadOptions class members, see the AbstractTextLoadOptions Members topic.

Public Instance Properties

AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
ConvertDateTimeData | Gets or sets a value that indicates whether the string in text file is converted to date data.
ConvertNumericData | Gets or sets a value that indicates whether the string in text file is converted to numeric data.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
Encoding | Gets and sets the default encoding. Only applies for csv file.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
KeepPrecision | Indicates whether not parsing a string value if the length is 15.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
LoadStyleStrategy | Indicates the strategy to apply style for parsed values when converting string value to number or datetime.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


ConvertDateTimeData Property

Aspose.Cells for .NET

AbstractTextLoadOptions.ConvertDateTimeData Property

Gets or sets a value that indicates whether the string in text file is converted to date data.

public bool ConvertDateTimeData {get; set;}

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


ConvertNumericData Property

Aspose.Cells for .NET

AbstractTextLoadOptions.ConvertNumericData Property

Gets or sets a value that indicates whether the string in text file is converted to numeric data.

public bool ConvertNumericData {get; set;}

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


Encoding Property

Aspose.Cells for .NET

AbstractTextLoadOptions.Encoding Property

Gets and sets the default encoding. Only applies for csv file.

public Encoding Encoding {get; set;}

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


KeepPrecision Property

Aspose.Cells for .NET

AbstractTextLoadOptions.KeepPrecision Property

Indicates whether not parsing a string value if the length is 15.

public bool KeepPrecision {get; set;}

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


LoadStyleStrategy Property

Aspose.Cells for .NET

AbstractTextLoadOptions.LoadStyleStrategy Property

Indicates the strategy to apply style for parsed values when converting string value to number or datetime.

public TxtLoadStyleStrategy LoadStyleStrategy {get; set;}

See Also

AbstractTextLoadOptions Class | Aspose.Cells Namespace


AutoFilter Class

Represents autofiltering for the specified worksheet.

For a list of all members of this type, see AutoFilter Members.

System.Object
Aspose.Cells.AutoFilter

public class AutoFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Creating a file stream containing the Excel file to be opened
FileStream fstream = new FileStream("C:\\book1.xls", FileMode.Open);
//Instantiating a Workbook object and open a stream.
Workbook workbook = new Workbook(fstream);
//Accessing the first worksheet in the Excel file
Worksheet worksheet = workbook.Worksheets[0];
//Creating AutoFilter by giving the cells range of the heading row
worksheet.AutoFilter.Range = "A1:B1";
//Filtering columns with specified values
worksheet.AutoFilter.Filter(1, "Bananas");
//Saving the modified Excel file.
workbook.Save("C:\\output.xls");
//Closing the file stream to free all resources
fstream.Close();

[Visual Basic]

'Creating a file stream containing the Excel file to be opened
Dim fstream As FileStream = New FileStream("C:\\book1.xls", FileMode.Open)
'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook(fstream)
'Accessing the first worksheet in the Excel file
Dim worksheet As Worksheet = workbook.Worksheets(0)
'Creating AutoFilter by giving the cells range of the heading row
worksheet.AutoFilter.Range = "A1:B1"
'Filtering columns with specified values
Worksheet.AutoFilter.Filter(1, "Bananas")
'Saving the modified Excel file
workbook.Save("C:\\output.xls")
'Closing the file stream to free all resources
fstream.Close()

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AutoFilter Members | Aspose.Cells Namespace


AutoFilter Members

AutoFilter overview

Public Instance Properties

FilterColumns | Gets the collection of the filter columns.
Range | Represents the range to which the specified AutoFilter applies.
Sorter | Gets the data sorter.

Public Instance Methods

AddDateFilter | Adds a date filter.
AddFillColorFilter | Adds a fill color filter.
AddFilter | Adds a filter for a filter column.
AddFontColorFilter | Adds a font color filter.
AddIconFilter | Adds an icon filter.
Custom | Overloaded. Filters a list with a custom criteria.
DynamicFilter | Adds a dynamic filter.
Equals (inherited from Object) |
Filter | Filters a list with specified criteria.
FilterTop10 | Filter the top 10 item in the list
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
MatchBlanks | Match all blank cell in the list.
MatchNonBlanks | Match all not blank cell in the list.
Refresh | Overloaded. Refresh auto filters to hide or unhide the rows.
RemoveDateFilter | Removes a date filter.
RemoveFilter | Overloaded. Removes a filter for a filter column.
SetRange | Sets the range to which the specified AutoFilter applies.
ShowAll | Unhide all rows.
ToString (inherited from Object) |

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter Properties

The properties of the AutoFilter class are listed below. For a complete list of AutoFilter class members, see the AutoFilter Members topic.

Public Instance Properties

FilterColumns | Gets the collection of the filter columns.
Range | Represents the range to which the specified AutoFilter applies.
Sorter | Gets the data sorter.

See Also

AutoFilter Class | Aspose.Cells Namespace


FilterColumns Property

Aspose.Cells for .NET

AutoFilter.FilterColumns Property

Gets the collection of the filter columns.

public FilterColumnCollection FilterColumns {get;}

See Also

AutoFilter Class | Aspose.Cells Namespace


Range Property

Aspose.Cells for .NET

AutoFilter.Range Property

Represents the range to which the specified AutoFilter applies.

public string Range {get; set;}

See Also

AutoFilter Class | Aspose.Cells Namespace


Sorter Property

Aspose.Cells for .NET

AutoFilter.Sorter Property

Gets the data sorter.

public DataSorter Sorter {get;}

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter Methods

The methods of the AutoFilter class are listed below. For a complete list of AutoFilter class members, see the AutoFilter Members topic.

Public Instance Methods

AddDateFilter | Adds a date filter.
AddFillColorFilter | Adds a fill color filter.
AddFilter | Adds a filter for a filter column.
AddFontColorFilter | Adds a font color filter.
AddIconFilter | Adds an icon filter.
Custom | Overloaded. Filters a list with a custom criteria.
DynamicFilter | Adds a dynamic filter.
Equals (inherited from Object) |
Filter | Filters a list with specified criteria.
FilterTop10 | Filter the top 10 item in the list
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
MatchBlanks | Match all blank cell in the list.
MatchNonBlanks | Match all not blank cell in the list.
Refresh | Overloaded. Refresh auto filters to hide or unhide the rows.
RemoveDateFilter | Removes a date filter.
RemoveFilter | Overloaded. Removes a filter for a filter column.
SetRange | Sets the range to which the specified AutoFilter applies.
ShowAll | Unhide all rows.
ToString (inherited from Object) |

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.AddDateFilter Method

Adds a date filter.

public void AddDateFilter(
int fieldIndex,
DateTimeGroupingType dateTimeGroupingType,
int year,
int month,
int day,
int hour,
int minute,
int second
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
dateTimeGroupingType
DateTimeGroupingType
year
The year.
month
The month.
day
The day.
hour
The hour.
minute
The minute.
second
The second.

Remarks

If DateTimeGroupingType is Year, only the param year effects. If DateTiemGroupingType is Month, only the param year and month effect.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.AddFillColorFilter Method

Adds a fill color filter.

public void AddFillColorFilter(
int fieldIndex,
BackgroundType pattern,
CellsColor foregroundColor,
CellsColor backgroundColor
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
pattern
The background pattern type.
foregroundColor
The foreground color.
backgroundColor
The background color.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.AddFilter Method

Adds a filter for a filter column.

public void AddFilter(
int fieldIndex,
string criteria
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
criteria
The specified criteria (a string; for example, "101"). It only can be null or be one of the cells' value in this column.

Remarks

MS Excel 2007 supports multiple selection in a filter column.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.AddFontColorFilter Method

Adds a font color filter.

public void AddFontColorFilter(
int fieldIndex,
CellsColor color
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
color
The CellsColor object.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.AddIconFilter Method

Adds an icon filter.

public void AddIconFilter(
int fieldIndex,
IconSetType iconSetType,
int iconId
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
iconSetType
The icon set type.
iconId
The icon id.

Remarks

Only supports to add the icon filter. Not supports checking which row is visible if the filter is icon filter.

See Also

AutoFilter Class | Aspose.Cells Namespace


Custom Method

Aspose.Cells for .NET

AutoFilter.Custom Method

Filters a list with a custom criteria.

Overload List

Filters a list with a custom criteria.

public void Custom(int,FilterOperatorType,object);

Filters a list with custom criteria.

public void Custom(int,FilterOperatorType,object,bool,FilterOperatorType,object);

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.Custom Method (Int32, FilterOperatorType, Object)

Filters a list with a custom criteria.

public void Custom(
int fieldIndex,
FilterOperatorType operatorType1,
object criteria1
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
operatorType1
The filter operator type
criteria1
The custom criteria

See Also

AutoFilter Class | Aspose.Cells Namespace | AutoFilter.Custom Overload List


AutoFilter.Custom Method (Int32, FilterOperatorType, Object, Boolean, FilterOperatorType, Object)

Filters a list with custom criteria.

public void Custom(
int fieldIndex,
FilterOperatorType operatorType1,
object criteria1,
bool isAnd,
FilterOperatorType operatorType2,
object criteria2
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
operatorType1
The filter operator type
criteria1
The custom criteria
isAnd
operatorType2
The filter operator type
criteria2
The custom criteria

See Also

AutoFilter Class | Aspose.Cells Namespace | AutoFilter.Custom Overload List


AutoFilter.DynamicFilter Method

Adds a dynamic filter.

public void DynamicFilter(
int fieldIndex,
DynamicFilterType dynamicFilterType
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
dynamicFilterType
Dynamic filter type.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.Filter Method

Filters a list with specified criteria.

public void Filter(
int fieldIndex,
string criteria
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
criteria
The specified criteria (a string; for example, "101").

Remarks

Aspose.Cells will remove all other filter setting on this field as Ms Excel 97-2003.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.FilterTop10 Method

Filter the top 10 item in the list

public void FilterTop10(
int fieldIndex,
bool isTop,
bool isPercent,
int itemCount
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
isTop
Indicates whether filter from top or bottom
isPercent
Indicates whether the items is percent or count
itemCount
The item count

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.MatchBlanks Method

Match all blank cell in the list.

public void MatchBlanks(
int fieldIndex
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.MatchNonBlanks Method

Match all not blank cell in the list.

public void MatchNonBlanks(
int fieldIndex
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).

See Also

AutoFilter Class | Aspose.Cells Namespace


Refresh Method

Aspose.Cells for .NET

AutoFilter.Refresh Method

Refresh auto filters to hide or unhide the rows.

Overload List

Refresh auto filters to hide or unhide the rows.

public int[] Refresh();

Gets all hidden rows' indexes.

public int[] Refresh(bool);

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.Refresh Method ()

Refresh auto filters to hide or unhide the rows.

public int[] Refresh();

Return Value

Returns all hidden rows' indexes.

See Also

AutoFilter Class | Aspose.Cells Namespace | AutoFilter.Refresh Overload List


AutoFilter.Refresh Method (Boolean)

Gets all hidden rows' indexes.

public int[] Refresh(
bool hideRows
);

Parameters

hideRows
If true, hide the filtered rows.

Return Value

Returns all hidden rows indexes.

See Also

AutoFilter Class | Aspose.Cells Namespace | AutoFilter.Refresh Overload List


AutoFilter.RemoveDateFilter Method

Removes a date filter.

public void RemoveDateFilter(
int fieldIndex,
DateTimeGroupingType dateTimeGroupingType,
int year,
int month,
int day,
int hour,
int minute,
int second
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
dateTimeGroupingType
DateTimeGroupingType
year
The year.
month
The month.
day
The day.
hour
The hour.
minute
The minute.
second
The second.

Remarks

If DateTimeGroupingType is Year, only the param year effects. If DateTiemGroupingType is Month, only the param year and month effect.

See Also

AutoFilter Class | Aspose.Cells Namespace


RemoveFilter Method

Aspose.Cells for .NET

AutoFilter.RemoveFilter Method

Remove the specific filter.

Overload List

Remove the specific filter.

public void RemoveFilter(int);

Removes a filter for a filter column.

public void RemoveFilter(int,string);

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.RemoveFilter Method (Int32)

Remove the specific filter.

public void RemoveFilter(
int fieldIndex
);

Parameters

fieldIndex
The specific filter index

See Also

AutoFilter Class | Aspose.Cells Namespace | AutoFilter.RemoveFilter Overload List


AutoFilter.RemoveFilter Method (Int32, String)

Removes a filter for a filter column.

public void RemoveFilter(
int fieldIndex,
string criteria
);

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).
criteria
The specified criteria (a string; for example, "101"). It only can be null or be one of the cells' value in this column.

See Also

AutoFilter Class | Aspose.Cells Namespace | AutoFilter.RemoveFilter Overload List


AutoFilter.SetRange Method

Sets the range to which the specified AutoFilter applies.

public void SetRange(
int row,
int startColumn,
int endColumn
);

Parameters

row
Row index.
startColumn
Start column index.
endColumn
End column Index.

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFilter.ShowAll Method

Unhide all rows.

public void ShowAll();

See Also

AutoFilter Class | Aspose.Cells Namespace


AutoFitMergedCellsType Enumeration

Represents the type of auto fitting merged cells.

public enum AutoFitMergedCellsType

Members

Member Name | Description | Value
None | Ignore merged cells. | 0
FirstLine | Only expands the height of the first row. | 1
LastLine | Only expands the height of the last row. | 2
EachLine | Only expands the height of each row. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


AutoFitterOptions Class

Represents all auto fitter options.

For a list of all members of this type, see AutoFitterOptions Members.

System.Object
Aspose.Cells.AutoFitterOptions

public class AutoFitterOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AutoFitterOptions Members | Aspose.Cells Namespace


AutoFitterOptions Members

AutoFitterOptions overview

Public Instance Constructors

AutoFitterOptions Constructor Initializes a new instance of the AutoFitterOptions class.

Public Instance Properties

AutoFitMergedCells | Obsolete. Indicates whether auto fit row height when the cells is merged in a row. The default value is false.
AutoFitMergedCellsType | Gets and set the type of auto fitting row height.
AutoFitWrappedTextType | Gets and sets the type of auto fitting wrapped text.
IgnoreHidden | Ignores the hidden rows/columns.
MaxRowHeight | Gets and sets the max row height(in unit of Point) when autofitting rows.
OnlyAuto | Indicates whether only fit the rows which height are not customed.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


AutoFitterOptions Constructor

Initializes a new instance of the AutoFitterOptions class.

public AutoFitterOptions();

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


AutoFitterOptions Properties

The properties of the AutoFitterOptions class are listed below. For a complete list of AutoFitterOptions class members, see the AutoFitterOptions Members topic.

Public Instance Properties

AutoFitMergedCells | Obsolete. Indicates whether auto fit row height when the cells is merged in a row. The default value is false.
AutoFitMergedCellsType | Gets and set the type of auto fitting row height.
AutoFitWrappedTextType | Gets and sets the type of auto fitting wrapped text.
IgnoreHidden | Ignores the hidden rows/columns.
MaxRowHeight | Gets and sets the max row height(in unit of Point) when autofitting rows.
OnlyAuto | Indicates whether only fit the rows which height are not customed.

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


AutoFitMergedCells Property

Aspose.Cells for .NET

AutoFitterOptions.AutoFitMergedCells Property

NOTE: This property is now obsolete.

Use AutoFitterOptions.AutoFitMergedCellsType property, instead.

Indicates whether auto fit row height when the cells is merged in a row. The default value is false.

public bool AutoFitMergedCells {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use AutoFitterOptions.AutoFitMergedCellsType property, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


AutoFitMergedCellsType Property

Aspose.Cells for .NET

AutoFitterOptions.AutoFitMergedCellsType Property

Gets and set the type of auto fitting row height.

public AutoFitMergedCellsType AutoFitMergedCellsType {get; set;}

Remarks

If the cells in merged in a row and auto fit the rows in MS Excel, MS Excel do not expand the row height. If this option is true, Aspose.Cells will expand the row height to fit the cells' data.

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


AutoFitWrappedTextType Property

Aspose.Cells for .NET

AutoFitterOptions.AutoFitWrappedTextType Property

Gets and sets the type of auto fitting wrapped text.

public AutoFitWrappedTextType AutoFitWrappedTextType {get; set;}

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


IgnoreHidden Property

Aspose.Cells for .NET

AutoFitterOptions.IgnoreHidden Property

Ignores the hidden rows/columns.

public bool IgnoreHidden {get; set;}

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


MaxRowHeight Property

Aspose.Cells for .NET

AutoFitterOptions.MaxRowHeight Property

Gets and sets the max row height(in unit of Point) when autofitting rows.

public double MaxRowHeight {get; set;}

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


OnlyAuto Property

Aspose.Cells for .NET

AutoFitterOptions.OnlyAuto Property

Indicates whether only fit the rows which height are not customed.

public bool OnlyAuto {get; set;}

See Also

AutoFitterOptions Class | Aspose.Cells Namespace


AutoFitWrappedTextType Enumeration

Represents the type of auto fitting wrapped text.

public enum AutoFitWrappedTextType

Members

Member Name | Description | Value
Default | Works as MS Excel. | 0
Paragraph | Auto fit width with the longest paragraph. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


BackgroundType Enumeration

Enumerates cell background pattern types.

public enum BackgroundType

Members

Member Name | Description | Value
DiagonalCrosshatch | Represents diagonal crosshatch pattern. | 9
DiagonalStripe | Represents diagonal stripe pattern. | 8
Gray6 | Represents 6.25% gray pattern | 18
Gray12 | Represents 12.5% gray pattern | 17
Gray25 | Represents 25% gray pattern. | 4
Gray50 | Represents 50% gray pattern. | 2
Gray75 | Represents 75% gray pattern. | 3
HorizontalStripe | Represents horizontal stripe pattern. | 5
None | Represents no background. | 0
ReverseDiagonalStripe | Represents reverse diagonal stripe pattern. | 7
Solid | Represents solid pattern. | 1
ThickDiagonalCrosshatch | Represents thick diagonal crosshatch pattern. | 10
ThinDiagonalCrosshatch | Represents thin diagonal crosshatch pattern. | 16
ThinDiagonalStripe | Represents thin diagonal stripe pattern. | 14
ThinHorizontalCrosshatch | Represents thin horizontal crosshatch pattern. | 15
ThinHorizontalStripe | Represents thin horizontal stripe pattern. | 11
ThinReverseDiagonalStripe | Represents thin reverse diagonal stripe pattern. | 13
ThinVerticalStripe | Represents thin vertical stripe pattern. | 12
VerticalStripe | Represents vertical stripe pattern. | 6

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Border Class

Encapsulates the object that represents the cell border.

For a list of all members of this type, see Border Members.

System.Object
Aspose.Cells.Border

public class Border

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Style style = cell.GetStyle();
//Set top border style and color
Border border = style.Borders[BorderType.TopBorder];
border.LineStyle = CellBorderType.Medium;
border.Color = Color.Red;
cell.SetStyle(style);

[Visual Basic]

Dim style as Style = cell.GetStyle()
'Set top border style and color
Dim border as Border = style.Borders(BorderType.TopBorder)
border.LineStyle = CellBorderType.Medium
border.Color = Color.Red
cell.SetStyle(style);

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Border Members | Aspose.Cells Namespace


Border Members

Border overview

Public Instance Properties

ArgbColor | Gets and sets the color with a 32-bit ARGB value.
Color | Gets or sets the Color of the border.
LineStyle | Gets or sets the cell border type.
ThemeColor | Gets and sets the theme color of the border.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Border Class | Aspose.Cells Namespace


Border Properties

The properties of the Border class are listed below. For a complete list of Border class members, see the Border Members topic.

Public Instance Properties

ArgbColor | Gets and sets the color with a 32-bit ARGB value.
Color | Gets or sets the Color of the border.
LineStyle | Gets or sets the cell border type.
ThemeColor | Gets and sets the theme color of the border.

See Also

Border Class | Aspose.Cells Namespace


ArgbColor Property

Aspose.Cells for .NET

Border.ArgbColor Property

Gets and sets the color with a 32-bit ARGB value.

public int ArgbColor {get; set;}

See Also

Border Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

Border.Color Property

Gets or sets the Color of the border.

public Color Color {get; set;}

See Also

Border Class | Aspose.Cells Namespace


LineStyle Property

Aspose.Cells for .NET

Border.LineStyle Property

Gets or sets the cell border type.

public CellBorderType LineStyle {get; set;}

See Also

Border Class | Aspose.Cells Namespace


ThemeColor Property

Aspose.Cells for .NET

Border.ThemeColor Property

Gets and sets the theme color of the border.

public ThemeColor ThemeColor {get; set;}

See Also

Border Class | Aspose.Cells Namespace


BorderCollection Class

Encapsulates a collection of Border objects.

For a list of all members of this type, see BorderCollection Members.

System.Object
Aspose.Cells.BorderCollection

public class BorderCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Instantiating a Workbook object
 Workbook workbook = new Workbook();

 //Adding a new worksheet to the Excel object
 workbook.Worksheets.Add();

 //Obtaining the reference of the newly added worksheet by passing its sheet index
 Worksheet worksheet = workbook.Worksheets[0];

 //Accessing the "A1" cell from the worksheet
 Cell cell = worksheet.Cells["A1"];

 //Adding some value to the "A1" cell
 cell.PutValue("Visit Aspose!");

 Style style = cell.GetStyle();

 //Setting the line style of the top border
 style.Borders[BorderType.TopBorder].LineStyle = CellBorderType.Thick;

 //Setting the color of the top border
 style.Borders[BorderType.TopBorder].Color = Color.Black;

 //Setting the line style of the bottom border
 style.Borders[BorderType.BottomBorder].LineStyle = CellBorderType.Thick;

 //Setting the color of the bottom border
 style.Borders[BorderType.BottomBorder].Color = Color.Black;

 //Setting the line style of the left border
 style.Borders[BorderType.LeftBorder].LineStyle = CellBorderType.Thick;

 //Setting the color of the left border
 style.Borders[BorderType.LeftBorder].Color = Color.Black;

 //Setting the line style of the right border
 style.Borders[BorderType.RightBorder].LineStyle = CellBorderType.Thick;

 //Setting the color of the right border
 style.Borders[BorderType.RightBorder].Color = Color.Black;

 cell.SetStyle(style);

 //Saving the Excel file
 workbook.Save("C:\\book1.xls");

 [VB.NET]

 'Instantiating a Workbook object
 Dim workbook As Workbook = New Workbook()

 'Adding a new worksheet to the Workbook object
 workbook.Worksheets.Add()

 'Obtaining the reference of the newly added worksheet by passing its sheet index
 Dim worksheet As Worksheet = workbook.Worksheets(0)

 'Accessing the "A1" cell from the worksheet
 Dim cell As Cell = worksheet.Cells("A1")

 'Adding some value to the "A1" cell
 cell.PutValue("Visit Aspose!")

 Dim style as Style = cell.GetStyle()

 'Setting the line style of the top border
 style.Borders(BorderType.TopBorder).LineStyle = CellBorderType.Thick

 'Setting the color of the top border
 style.Borders(BorderType.TopBorder).Color = Color.Black

 'Setting the line style of the bottom border
 style.Borders(BorderType.BottomBorder).LineStyle = CellBorderType.Thick

 'Setting the color of the bottom border
 style.Borders(BorderType.BottomBorder).Color = Color.Black

 'Setting the line style of the left border
 style.Borders(BorderType.LeftBorder).LineStyle = CellBorderType.Thick

 'Setting the color of the left border
 style.Borders(BorderType.LeftBorder).Color = Color.Black

 'Setting the line style of the right border
 style.Borders(BorderType.RightBorder).LineStyle = CellBorderType.Thick

 'Setting the color of the right border
 style.Borders(BorderType.RightBorder).Color = Color.Black

 cell.SetStyle(style)

 'Saving the Excel file
 workbook.Save("C:\book1.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

BorderCollection Members | Aspose.Cells Namespace


BorderCollection Members

BorderCollection overview

Public Instance Properties

DiagonalColor | Gets or sets the Color of Diagonal lines.
DiagonalStyle | Gets or sets the style of Diagonal lines.
Item | Gets the Border element at the specified index.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetColor | Sets the Color of all borders in the collection.
SetStyle | Sets the style of all borders of the collection.
ToString (inherited from Object) |

See Also

BorderCollection Class | Aspose.Cells Namespace


BorderCollection Properties

The properties of the BorderCollection class are listed below. For a complete list of BorderCollection class members, see the BorderCollection Members topic.

Public Instance Properties

DiagonalColor | Gets or sets the Color of Diagonal lines.
DiagonalStyle | Gets or sets the style of Diagonal lines.
Item | Gets the Border element at the specified index.

See Also

BorderCollection Class | Aspose.Cells Namespace


DiagonalColor Property

Aspose.Cells for .NET

BorderCollection.DiagonalColor Property

Gets or sets the Color of Diagonal lines.

public Color DiagonalColor {get; set;}

See Also

BorderCollection Class | Aspose.Cells Namespace


DiagonalStyle Property

Aspose.Cells for .NET

BorderCollection.DiagonalStyle Property

Gets or sets the style of Diagonal lines.

public CellBorderType DiagonalStyle {get; set;}

See Also

BorderCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

BorderCollection.Item Property

Gets the Border element at the specified index.

public Border this[
Aspose.Cells.BorderType borderType
] {get;}

Parameters

borderType
The border to be retrieved.

See Also

BorderCollection Class | Aspose.Cells Namespace


BorderCollection Methods

The methods of the BorderCollection class are listed below. For a complete list of BorderCollection class members, see the BorderCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetColor | Sets the Color of all borders in the collection.
SetStyle | Sets the style of all borders of the collection.
ToString (inherited from Object) |

See Also

BorderCollection Class | Aspose.Cells Namespace


BorderCollection.SetColor Method

Sets the Color of all borders in the collection.

public void SetColor(
Color color
);

Parameters

color
Borders' Color.

See Also

BorderCollection Class | Aspose.Cells Namespace


BorderCollection.SetStyle Method

Sets the style of all borders of the collection.

public void SetStyle(
CellBorderType style
);

Parameters

style
Borders' style

See Also

BorderCollection Class | Aspose.Cells Namespace


BorderType Enumeration

Enumerates the border line and diagonal line types.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum BorderType

Members

Member Name | Description | Value
BottomBorder | Represents bottom border line. | 8
DiagonalDown | Represents the diagonal line from top left to right bottom. | 16
DiagonalUp | Represents the diagonal line from bottom left to right top. | 32
LeftBorder | Represents left border line. | 1
RightBorder | Represents right border line exists. | 2
TopBorder | Represents top border line. | 4
Horizontal | Only for dynamic style,such as conditional formatting. | 128
Vertical | Only for dynamic style,such as conditional formatting. | 64

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


BuiltinStyleType Enumeration

Represents all built-in style type

public enum BuiltinStyleType

Members

Member Name | Description | Value
TwentyPercentAccent1 |  | 30
TwentyPercentAccent2 |  | 34
TwentyPercentAccent3 |  | 38
TwentyPercentAccent4 |  | 42
TwentyPercentAccent5 |  | 46
TwentyPercentAccent6 |  | 50
FortyPercentAccent1 |  | 31
FortyPercentAccent2 |  | 35
FortyPercentAccent3 |  | 39
FortyPercentAccent4 |  | 43
FortyPercentAccent5 |  | 47
FortyPercentAccent6 |  | 51
SixtyPercentAccent1 |  | 32
SixtyPercentAccent2 |  | 36
SixtyPercentAccent3 |  | 40
SixtyPercentAccent4 |  | 44
SixtyPercentAccent5 |  | 48
SixtyPercentAccent6 |  | 52
Accent1 |  | 29
Accent2 |  | 33
Accent3 |  | 37
Accent4 |  | 41
Accent5 |  | 45
Accent6 |  | 49
Bad |  | 27
Calculation |  | 22
CheckCell |  | 23
Comma |  | 3
Comma1 |  | 6
Currency |  | 4
Currency1 |  | 7
ExplanatoryText |  | 53
Good |  | 26
Header1 |  | 16
Header2 |  | 17
Header3 |  | 18
Header4 |  | 19
Hyperlink |  | 8
FollowedHyperlink |  | 9
Input |  | 20
LinkedCell |  | 24
Neutral |  | 28
Normal |  | 0
Note |  | 10
Output |  | 21
Percent |  | 5
Title |  | 15
Total |  | 25
WarningText |  | 11
RowLevel |  | 1
ColumnLevel |  | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CalcModeType Enumeration

Represents the mode type of calculating formulas.

public enum CalcModeType

Members

Member Name | Description | Value
Automatic |  | 0
AutomaticExceptTable |  | 1
Manual |  | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CalculationCell Class

Represents the calculation relevant data about one cell which is being calculated.

For a list of all members of this type, see CalculationCell Members.

System.Object
Aspose.Cells.CalculationCell

public class CalculationCell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

All objects provided by this class are for "read" purpose only. User should not change any data in the Workbook during the formula calculation process, Otherwise unexpected result or Exception may be caused.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CalculationCell Members | Aspose.Cells Namespace


CalculationCell Members

CalculationCell overview

Public Instance Properties

Cell | Gets the Cell object which is being calculated.
CellColumn | Gets the column index of the cell.
CellRow | Gets the row index of the cell.
Workbook | Gets the Workbook object.
Worksheet | Gets the Worksheet object where the cell is in.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetCalculatedValue | Sets the calculated value for the cell.
ToString (inherited from Object) |

See Also

CalculationCell Class | Aspose.Cells Namespace


CalculationCell Properties

The properties of the CalculationCell class are listed below. For a complete list of CalculationCell class members, see the CalculationCell Members topic.

Public Instance Properties

Cell | Gets the Cell object which is being calculated.
CellColumn | Gets the column index of the cell.
CellRow | Gets the row index of the cell.
Workbook | Gets the Workbook object.
Worksheet | Gets the Worksheet object where the cell is in.

See Also

CalculationCell Class | Aspose.Cells Namespace


Cell Property

Aspose.Cells for .NET

CalculationCell.Cell Property

Gets the Cell object which is being calculated.

public Cell Cell {get;}

See Also

CalculationCell Class | Aspose.Cells Namespace


CellColumn Property

Aspose.Cells for .NET

CalculationCell.CellColumn Property

Gets the column index of the cell.

public int CellColumn {get;}

See Also

CalculationCell Class | Aspose.Cells Namespace


CellRow Property

Aspose.Cells for .NET

CalculationCell.CellRow Property

Gets the row index of the cell.

public int CellRow {get;}

See Also

CalculationCell Class | Aspose.Cells Namespace


Workbook Property

Aspose.Cells for .NET

CalculationCell.Workbook Property

Gets the Workbook object.

public Workbook Workbook {get;}

See Also

CalculationCell Class | Aspose.Cells Namespace


Worksheet Property

Aspose.Cells for .NET

CalculationCell.Worksheet Property

Gets the Worksheet object where the cell is in.

public Worksheet Worksheet {get;}

See Also

CalculationCell Class | Aspose.Cells Namespace


CalculationCell Methods

The methods of the CalculationCell class are listed below. For a complete list of CalculationCell class members, see the CalculationCell Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetCalculatedValue | Sets the calculated value for the cell.
ToString (inherited from Object) |

See Also

CalculationCell Class | Aspose.Cells Namespace


CalculationCell.SetCalculatedValue Method

Sets the calculated value for the cell.

public void SetCalculatedValue(
object v
);

Remarks

User can set the calculated result by this method to ignore the automatic calculation for the cell.

See Also

CalculationCell Class | Aspose.Cells Namespace


CalculationData Class

Represents the required data when calculating one function, such as function name, parameters, ...etc.

For a list of all members of this type, see CalculationData Members.

System.Object
Aspose.Cells.CalculationData

public class CalculationData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

All objects provided by this class are for "read" purpose only. User should not change any data in the Workbook during the formula calculation process, Otherwise unexpected result or Exception may be caused.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CalculationData Members | Aspose.Cells Namespace


CalculationData Members

CalculationData overview

Public Instance Properties

CalculatedValue | Gets or sets the calculated value for this function.
Cell | Gets the Cell object where the function is in.
CellColumn | Gets the column index of the cell where the function is in.
CellRow | Gets the row index of the cell where the function is in.
FunctionName | Gets the function name to be calculated.
ParamCount | Gets the count of parameters
Workbook | Gets the Workbook object where the function is in.
Worksheet | Gets the Worksheet object where the function is in.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetParamText | Gets the literal text of the parameter at given index.
GetParamValue | Gets the represented value object of the parameter at given index.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

CalculationData Class | Aspose.Cells Namespace


CalculationData Properties

The properties of the CalculationData class are listed below. For a complete list of CalculationData class members, see the CalculationData Members topic.

Public Instance Properties

CalculatedValue | Gets or sets the calculated value for this function.
Cell | Gets the Cell object where the function is in.
CellColumn | Gets the column index of the cell where the function is in.
CellRow | Gets the row index of the cell where the function is in.
FunctionName | Gets the function name to be calculated.
ParamCount | Gets the count of parameters
Workbook | Gets the Workbook object where the function is in.
Worksheet | Gets the Worksheet object where the function is in.

See Also

CalculationData Class | Aspose.Cells Namespace


CalculatedValue Property

Aspose.Cells for .NET

CalculationData.CalculatedValue Property

Gets or sets the calculated value for this function.

public object CalculatedValue {get; set;}

Remarks

User should set this property in his custom calculation engine for those functions the engine supports, and the set value will be returned when getting this property later. The set value can be any value of those objects that can be set to a Cell(Cell.Value). And it can also be array of such kind of values, or a Range, Name, ReferredArea. Getting this property before setting will make the function be calculated by the default calculation engine of Aspose.Cells and the calculated value will be returned.

See Also

CalculationData Class | Aspose.Cells Namespace


Cell Property

Aspose.Cells for .NET

CalculationData.Cell Property

Gets the Cell object where the function is in.

public Cell Cell {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


CellColumn Property

Aspose.Cells for .NET

CalculationData.CellColumn Property

Gets the column index of the cell where the function is in.

public int CellColumn {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


CellRow Property

Aspose.Cells for .NET

CalculationData.CellRow Property

Gets the row index of the cell where the function is in.

public int CellRow {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


FunctionName Property

Aspose.Cells for .NET

CalculationData.FunctionName Property

Gets the function name to be calculated.

public string FunctionName {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


ParamCount Property

Aspose.Cells for .NET

CalculationData.ParamCount Property

Gets the count of parameters

public int ParamCount {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


Workbook Property

Aspose.Cells for .NET

CalculationData.Workbook Property

Gets the Workbook object where the function is in.

public Workbook Workbook {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


Worksheet Property

Aspose.Cells for .NET

CalculationData.Worksheet Property

Gets the Worksheet object where the function is in.

public Worksheet Worksheet {get;}

See Also

CalculationData Class | Aspose.Cells Namespace


CalculationData Methods

The methods of the CalculationData class are listed below. For a complete list of CalculationData class members, see the CalculationData Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetParamText | Gets the literal text of the parameter at given index.
GetParamValue | Gets the represented value object of the parameter at given index.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

CalculationData Class | Aspose.Cells Namespace


CalculationData.GetParamText Method

Gets the literal text of the parameter at given index.

public string GetParamText(
int index
);

Parameters

index
index of the parameter(0 based)

Return Value

literal text of the parameter

See Also

CalculationData Class | Aspose.Cells Namespace


CalculationData.GetParamValue Method

Gets the represented value object of the parameter at given index.

public object GetParamValue(
int index
);

Parameters

index
index of the parameter(0 based)

Return Value

If the parameter is plain value, then returns the plain value. If the parameter is reference, then returns ReferredArea object. If the parameter references to multiple datasets, then returns array of objects.

See Also

CalculationData Class | Aspose.Cells Namespace


CalculationOptions Class

Represents options for calculation.

For a list of all members of this type, see CalculationOptions Members.

System.Object
Aspose.Cells.CalculationOptions

public class CalculationOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CalculationOptions Members | Aspose.Cells Namespace


CalculationOptions Members

CalculationOptions overview

Public Instance Constructors

CalculationOptions Constructor Initializes a new instance of the CalculationOptions class.

Public Instance Properties

CalcStackSize | Specifies the stack size for calculating cells recursively. -1 for this property means the calculation will use WorkbookSettings.CalcStackSize of corresponding workbook.
CalculationMonitor | The monitor for user to track the progress of formula calculation.
CustomEngine | The custom formula calculation engine to extend the default calculation engine of Aspose.Cells.
CustomFunction | Obsolete. The custom formula calculation functions to extend the calculation engine.
IgnoreError | Indicates if you need to hide the error in calculating formulas. The error may be unsupported function, external links, etc.
PrecisionStrategy | Specifies the strategy for processing precision of calculation.
Recursive | Indicates whether calculate the dependent cells recursively when calculating one cell and it depends on other cells.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CalculationOptions Class | Aspose.Cells Namespace


CalculationOptions Constructor

Initializes a new instance of the CalculationOptions class.

public CalculationOptions();

See Also

CalculationOptions Class | Aspose.Cells Namespace


CalculationOptions Properties

The properties of the CalculationOptions class are listed below. For a complete list of CalculationOptions class members, see the CalculationOptions Members topic.

Public Instance Properties

CalcStackSize | Specifies the stack size for calculating cells recursively. -1 for this property means the calculation will use WorkbookSettings.CalcStackSize of corresponding workbook.
CalculationMonitor | The monitor for user to track the progress of formula calculation.
CustomEngine | The custom formula calculation engine to extend the default calculation engine of Aspose.Cells.
CustomFunction | Obsolete. The custom formula calculation functions to extend the calculation engine.
IgnoreError | Indicates if you need to hide the error in calculating formulas. The error may be unsupported function, external links, etc.
PrecisionStrategy | Specifies the strategy for processing precision of calculation.
Recursive | Indicates whether calculate the dependent cells recursively when calculating one cell and it depends on other cells.

See Also

CalculationOptions Class | Aspose.Cells Namespace


CalcStackSize Property

Aspose.Cells for .NET

CalculationOptions.CalcStackSize Property

Specifies the stack size for calculating cells recursively. -1 for this property means the calculation will use WorkbookSettings.CalcStackSize of corresponding workbook.

public int CalcStackSize {get; set;}

See Also

CalculationOptions Class | Aspose.Cells Namespace


CalculationMonitor Property

Aspose.Cells for .NET

CalculationOptions.CalculationMonitor Property

The monitor for user to track the progress of formula calculation.

public AbstractCalculationMonitor CalculationMonitor {get; set;}

See Also

CalculationOptions Class | Aspose.Cells Namespace


CustomEngine Property

Aspose.Cells for .NET

CalculationOptions.CustomEngine Property

The custom formula calculation engine to extend the default calculation engine of Aspose.Cells.

public AbstractCalculationEngine CustomEngine {get; set;}

See Also

CalculationOptions Class | Aspose.Cells Namespace


CustomFunction Property

Aspose.Cells for .NET

CalculationOptions.CustomFunction Property

NOTE: This property is now obsolete.

Use CustomEngine property instead.

The custom formula calculation functions to extend the calculation engine.

public ICustomFunction CustomFunction {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use CustomEngine property, AbstractCalculationEngine provides more convenient and flexible APIs for manipulating custom functions. This property will be removed 12 months later since August 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

CalculationOptions Class | Aspose.Cells Namespace


IgnoreError Property

Aspose.Cells for .NET

CalculationOptions.IgnoreError Property

Indicates if you need to hide the error in calculating formulas. The error may be unsupported function, external links, etc.

public bool IgnoreError {get; set;}

See Also

CalculationOptions Class | Aspose.Cells Namespace


PrecisionStrategy Property

Aspose.Cells for .NET

CalculationOptions.PrecisionStrategy Property

Specifies the strategy for processing precision of calculation.

public CalculationPrecisionStrategy PrecisionStrategy {get; set;}

See Also

CalculationOptions Class | Aspose.Cells Namespace


Recursive Property

Aspose.Cells for .NET

CalculationOptions.Recursive Property

Indicates whether calculate the dependent cells recursively when calculating one cell and it depends on other cells.

public bool Recursive {get; set;}

See Also

CalculationOptions Class | Aspose.Cells Namespace


CalculationPrecisionStrategy Enumeration

Enumerates strategies for handling calculation precision. Because of the precision issue of IEEE 754 Floating-Point Arithmetic, some "seemingly simple" formulas may not be calculated as the expected result. Such as formula "=-0.45+0.43+0.02", when calculating operands by '+' operator directly, the result is not zero. For such kind of precision issue, some special strategies may give the expected result.

public enum CalculationPrecisionStrategy

Members

Member Name | Description | Value
None | No strategy applied on calculation. When calculating just use the original double value as operand and return the result directly. Most efficient for performance and applicable for most cases. | 0
Round | Rounds the calculation result according with significant digits. | 1
Decimal | Uses decimal as operands when possible. Most inefficient for performance. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Cell Class

Encapsulates the object that represents a single Workbook cell.

For a list of all members of this type, see Cell Members.

System.Object
Aspose.Cells.Cell

public class Cell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

    Workbook excel = new Workbook();
    Cells cells = excel.Worksheets[0].Cells;

    //Put a string into a cell
    Cell cell = cells[0, 0];
    cell.PutValue("Hello");

    string first = cell.StringValue;

    //Put an integer into a cell
    cell = cells["B1"];
    cell.PutValue(12);

    int second = cell.IntValue;

    //Put a double into a cell
    cell = cells[0, 2];
    cell.PutValue(-1.234);

    double third = cell.DoubleValue;

    //Put a formula into a cell
    cell = cells["D1"];
    cell.Formula = "=B1 + C1";

    //Put a combined formula: "sum(average(b1,c1), b1)" to cell at b2
    cell = cells["b2"];
    cell.Formula = "=sum(average(b1,c1), b1)";

    //Set style of a cell
    Style style = cell.GetStyle();
    //Set background color
    style.BackgroundColor = Color.Yellow;
    //Set format of a cell
    style.Font.Name = "Courier New";
    style.VerticalAlignment = TextAlignmentType.Top;
 cell.SetStyle(style);

 [Visual Basic]

    Dim excel as Workbook = new Workbook()
    Dim cells as Cells = exce.Worksheets(0).Cells

    'Put a string into a cell
    Dim cell as Cell = cells(0, 0)
    cell.PutValue("Hello")

    Dim first as String = cell.StringValue

    //Put an integer into a cell
    cell = cells("B1")
    cell.PutValue(12)

    Dim second as Integer = cell.IntValue

    //Put a double into a cell
    cell = cells(0, 2)
    cell.PutValue(-1.234)

    Dim third as Double = cell.DoubleValue

    //Put a formula into a cell
    cell = cells("D1")
    cell.Formula = "=B1 + C1"

    //Put a combined formula: "sum(average(b1,c1), b1)" to cell at b2
    cell = cells("b2")
    cell.Formula = "=sum(average(b1,c1), b1)"

    //Set style of a cell
    Dim style as Style = cell.GetStyle()

    //Set background color
    style.BackgroundColor = Color.Yellow
    //Set font of a cell
    style.Font.Name = "Courier New"
    style.VerticalAlignment = TextAlignmentType.Top
    cell.SetStyle(style)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Cell Members | Aspose.Cells Namespace


Cell Members

Cell overview

Public Instance Properties

BoolValue | Gets the boolean value contained in the cell.
Column | Gets column number (zero based) of the cell.
ContainsExternalLink | Indicates whether this cell contains an external link. Only applies when the cell is a formula cell.
DateTimeValue | Gets the DateTime value contained in the cell.
DisplayStringValue | Gets the formatted string value of this cell.
DoubleValue | Gets the double value contained in the cell.
FloatValue | Gets the float value contained in the cell.
Formula | Gets or sets a formula of the Cell.
FormulaLocal | Get the locale formatted formula of the cell.
HtmlString | Gets and sets the html string which contains data and some formats in this cell.
IntValue | Gets the integer value contained in the cell.
IsArrayFormula | Indicates whether the cell formula is an array formula.
IsArrayHeader | Indicates the cell's formula is and array formula and it is the first cell of the array.
IsErrorValue | Checks if a formula can properly evaluate a result.
IsFormula | Represents if the specified cell contains formula.
IsInArray | Obsolete. Indicates whether the cell formula is an array formula.
IsInTable | Obsolete. Indicates whether this cell is part of table formula.
IsMerged | Checks if a cell is part of a merged range or not.
IsSharedFormula | Indicates whether the cell formula is part of shared formula.
IsStyleSet | Indicates if the cell's style is set. If return false, it means this cell has a default cell format.
IsTableFormula | Indicates whether this cell is part of table formula.
Name | Gets the name of the cell.
NumberCategoryType | Represents the category type of this cell's number formatting.
R1C1Formula | Gets or sets a R1C1 formula of the Cell.
Row | Gets row number (zero based) of the cell.
SharedStyleIndex | Gets cell's shared style index in the style pool.
StringValue | Gets the string value contained in the cell. If the type of this cell is string, then return the string value itself. For other cell types, the formatted string value (formatted with the specified style of this cell) will be returned. The formatted cell value is same with what you can get from excel when copying a cell as text(such as copying cell to text editor or exporting to csv).
StringValueWithoutFormat | Gets cell's value as string without any format.
Type | Represents cell value type.
Value | Gets the value contained in this cell.
Worksheet | Gets the parent worksheet.

Public Instance Methods

Calculate | Overloaded. Calculates the formula of the cell.
Characters | Returns a Characters object that represents a range of characters within the cell text.
Copy | Copies data from a source cell.
Equals | Overloaded. Checks whether this object refers to the same cell with another.
GetArrayRange | Gets the array range if the cell's formula is an array formula.
GetCharacters | Overloaded. Returns all Characters objects that represents a range of characters within the cell text.
GetConditionalFormattingResult | Get the result of the conditional formatting.
GetDependents | Get all cells which refer to the specific cell.
GetDisplayStyle | Overloaded. Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().
GetFormatConditions | Gets format conditions which applies to this cell.
GetFormula | Get the formula of this cell.
GetHashCode | Serves as a hash function for a particular type.
GetHeightOfValue | Gets the height of the value in unit of pixels.
GetHtmlString | Gets the html string which contains data and some formats in this cell.
GetLeafs | Get all cells which will be updated when this cell is modified. This method can only work after calling Workbook.CalculateFormula.
GetMergedRange | Returns a Range object which represents a merged range.
GetPrecedents | Gets all cells or ranges which this cell's formula depends on.
GetStringValue | Gets the string value by specific formatted strategy.
GetStyle | Overloaded. Gets the cell style.
GetTable | Gets the table which contains this cell.
GetType (inherited from Object) |
GetValidation | Gets the validation applied to this cell.
GetValidationValue | Gets the value of validation which applied to this cell.
GetWidthOfValue | Gets the width of the value in unit of pixels.
IsRichText | Indicates whether the cell string value is a rich text.
PutValue | Overloaded. Puts an boolean value into the cell.
RemoveArrayFormula | Remove array formula.
SetAddInFormula | Obsolete. Sets an Add-In formula to the cell.
SetArrayFormula | Overloaded. Sets an array formula to a range of cells.
SetCharacters | Sets rich text format of the cell.
SetFormula | Overloaded. Set the formula and the value of the formula.
SetSharedFormula | Overloaded. Sets a formula to a range of cells.
SetStyle | Overloaded. Sets the cell style.
ToString | Returns a string represents the current Cell object.

See Also

Cell Class | Aspose.Cells Namespace


Cell Properties

The properties of the Cell class are listed below. For a complete list of Cell class members, see the Cell Members topic.

Public Instance Properties

BoolValue | Gets the boolean value contained in the cell.
Column | Gets column number (zero based) of the cell.
ContainsExternalLink | Indicates whether this cell contains an external link. Only applies when the cell is a formula cell.
DateTimeValue | Gets the DateTime value contained in the cell.
DisplayStringValue | Gets the formatted string value of this cell.
DoubleValue | Gets the double value contained in the cell.
FloatValue | Gets the float value contained in the cell.
Formula | Gets or sets a formula of the Cell.
FormulaLocal | Get the locale formatted formula of the cell.
HtmlString | Gets and sets the html string which contains data and some formats in this cell.
IntValue | Gets the integer value contained in the cell.
IsArrayFormula | Indicates whether the cell formula is an array formula.
IsArrayHeader | Indicates the cell's formula is and array formula and it is the first cell of the array.
IsErrorValue | Checks if a formula can properly evaluate a result.
IsFormula | Represents if the specified cell contains formula.
IsInArray | Obsolete. Indicates whether the cell formula is an array formula.
IsInTable | Obsolete. Indicates whether this cell is part of table formula.
IsMerged | Checks if a cell is part of a merged range or not.
IsSharedFormula | Indicates whether the cell formula is part of shared formula.
IsStyleSet | Indicates if the cell's style is set. If return false, it means this cell has a default cell format.
IsTableFormula | Indicates whether this cell is part of table formula.
Name | Gets the name of the cell.
NumberCategoryType | Represents the category type of this cell's number formatting.
R1C1Formula | Gets or sets a R1C1 formula of the Cell.
Row | Gets row number (zero based) of the cell.
SharedStyleIndex | Gets cell's shared style index in the style pool.
StringValue | Gets the string value contained in the cell. If the type of this cell is string, then return the string value itself. For other cell types, the formatted string value (formatted with the specified style of this cell) will be returned. The formatted cell value is same with what you can get from excel when copying a cell as text(such as copying cell to text editor or exporting to csv).
StringValueWithoutFormat | Gets cell's value as string without any format.
Type | Represents cell value type.
Value | Gets the value contained in this cell.
Worksheet | Gets the parent worksheet.

See Also

Cell Class | Aspose.Cells Namespace


BoolValue Property

Aspose.Cells for .NET

Cell.BoolValue Property

Gets the boolean value contained in the cell.

public bool BoolValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


Column Property

Aspose.Cells for .NET

Cell.Column Property

Gets column number (zero based) of the cell.

public int Column {get;}

See Also

Cell Class | Aspose.Cells Namespace


ContainsExternalLink Property

Aspose.Cells for .NET

Cell.ContainsExternalLink Property

Indicates whether this cell contains an external link. Only applies when the cell is a formula cell.

public bool ContainsExternalLink {get;}

See Also

Cell Class | Aspose.Cells Namespace


DateTimeValue Property

Aspose.Cells for .NET

Cell.DateTimeValue Property

Gets the DateTime value contained in the cell.

public DateTime DateTimeValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


DisplayStringValue Property

Aspose.Cells for .NET

Cell.DisplayStringValue Property

Gets the formatted string value of this cell.

public string DisplayStringValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


DoubleValue Property

Aspose.Cells for .NET

Cell.DoubleValue Property

Gets the double value contained in the cell.

public double DoubleValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


FloatValue Property

Aspose.Cells for .NET

Cell.FloatValue Property

Gets the float value contained in the cell.

public float FloatValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


Formula Property

Aspose.Cells for .NET

Cell.Formula Property

Gets or sets a formula of the Cell.

public string Formula {get; set;}

Remarks

A formula string always begins with an equal sign (=). And please always use comma(,) as parameters delimiter, such as "=SUM(A1, E1, H2)".

Example

[C#]

Workbook excel = new Workbook();
Cells cells = excel.Worksheets[0];
cells["B6"].Formula = "=SUM(B2:B5, E1) + sheet1!A1";

[Visual Basic]

Dim excel As Workbook =  New Workbook()
Dim cells As Cells =  excel.Worksheets(0)
cells("B6").Formula = "=SUM(B2:B5, E1) + sheet1!A1"

See Also

Cell Class | Aspose.Cells Namespace


FormulaLocal Property

Aspose.Cells for .NET

Cell.FormulaLocal Property

Get the locale formatted formula of the cell.

public string FormulaLocal {get; set;}

See Also

Cell Class | Aspose.Cells Namespace


HtmlString Property

Aspose.Cells for .NET

Cell.HtmlString Property

Gets and sets the html string which contains data and some formats in this cell.

public string HtmlString {get; set;}

See Also

Cell Class | Aspose.Cells Namespace


IntValue Property

Aspose.Cells for .NET

Cell.IntValue Property

Gets the integer value contained in the cell.

public int IntValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsArrayFormula Property

Aspose.Cells for .NET

Cell.IsArrayFormula Property

Indicates whether the cell formula is an array formula.

public bool IsArrayFormula {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsArrayHeader Property

Aspose.Cells for .NET

Cell.IsArrayHeader Property

Indicates the cell's formula is and array formula and it is the first cell of the array.

public bool IsArrayHeader {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsErrorValue Property

Aspose.Cells for .NET

Cell.IsErrorValue Property

Checks if a formula can properly evaluate a result.

public bool IsErrorValue {get;}

Remarks

Only applies to formula cell.

See Also

Cell Class | Aspose.Cells Namespace


IsFormula Property

Aspose.Cells for .NET

Cell.IsFormula Property

Represents if the specified cell contains formula.

public bool IsFormula {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsInArray Property

Aspose.Cells for .NET

Cell.IsInArray Property

NOTE: This property is now obsolete.

Use IsArrayFormula instead.

Indicates whether the cell formula is an array formula.

public bool IsInArray {get;}

Remarks

NOTE: This class is now obsolete. Instead, please use Cell.IsArrayFormula to check whether the cell formula is an array formula. This property will be removed 12 months later since May 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cell Class | Aspose.Cells Namespace


IsInTable Property

Aspose.Cells for .NET

Cell.IsInTable Property

NOTE: This property is now obsolete.

Use IsTableFormula instead.

Indicates whether this cell is part of table formula.

public bool IsInTable {get;}

Remarks

NOTE: This class is now obsolete. Instead, please use Cell.IsTableFormula to check whether the cell formula is part of table formula. This property will be removed 12 months later since May 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cell Class | Aspose.Cells Namespace


IsMerged Property

Aspose.Cells for .NET

Cell.IsMerged Property

Checks if a cell is part of a merged range or not.

public bool IsMerged {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsSharedFormula Property

Aspose.Cells for .NET

Cell.IsSharedFormula Property

Indicates whether the cell formula is part of shared formula.

public bool IsSharedFormula {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsStyleSet Property

Aspose.Cells for .NET

Cell.IsStyleSet Property

Indicates if the cell's style is set. If return false, it means this cell has a default cell format.

public bool IsStyleSet {get;}

See Also

Cell Class | Aspose.Cells Namespace


IsTableFormula Property

Aspose.Cells for .NET

Cell.IsTableFormula Property

Indicates whether this cell is part of table formula.

public bool IsTableFormula {get;}

See Also

Cell Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

Cell.Name Property

Gets the name of the cell.

public string Name {get;}

Remarks

A cell name includes its column letter and row number. For example, the name of a cell in row 0 and column 0 is A1.

See Also

Cell Class | Aspose.Cells Namespace


NumberCategoryType Property

Aspose.Cells for .NET

Cell.NumberCategoryType Property

Represents the category type of this cell's number formatting.

public NumberCategoryType NumberCategoryType {get;}

See Also

Cell Class | Aspose.Cells Namespace


R1C1Formula Property

Aspose.Cells for .NET

Cell.R1C1Formula Property

Gets or sets a R1C1 formula of the Cell.

public string R1C1Formula {get; set;}

See Also

Cell Class | Aspose.Cells Namespace


Row Property

Aspose.Cells for .NET

Cell.Row Property

Gets row number (zero based) of the cell.

public int Row {get;}

Property Value

Cell row number

See Also

Cell Class | Aspose.Cells Namespace


SharedStyleIndex Property

Aspose.Cells for .NET

Cell.SharedStyleIndex Property

Gets cell's shared style index in the style pool.

public int SharedStyleIndex {get;}

See Also

Cell Class | Aspose.Cells Namespace


StringValue Property

Aspose.Cells for .NET

Cell.StringValue Property

Gets the string value contained in the cell. If the type of this cell is string, then return the string value itself. For other cell types, the formatted string value (formatted with the specified style of this cell) will be returned. The formatted cell value is same with what you can get from excel when copying a cell as text(such as copying cell to text editor or exporting to csv).

public string StringValue {get;}

See Also

Cell Class | Aspose.Cells Namespace


StringValueWithoutFormat Property

Aspose.Cells for .NET

Cell.StringValueWithoutFormat Property

Gets cell's value as string without any format.

public string StringValueWithoutFormat {get;}

See Also

Cell Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

Cell.Type Property

Represents cell value type.

public CellValueType Type {get;}

See Also

Cell Class | Aspose.Cells Namespace


Value Property

Aspose.Cells for .NET

Cell.Value Property

Gets the value contained in this cell.

public object Value {get; set;}

Remarks

Possible type:

null,

Boolean,

DateTime,

Double,

Integer

String.

For int value, it may be returned as an Integer object or a Double object. And there is no guarantee that the returned value will be kept as the same type of object always.

See Also

Cell Class | Aspose.Cells Namespace


Worksheet Property

Aspose.Cells for .NET

Cell.Worksheet Property

Gets the parent worksheet.

public Worksheet Worksheet {get;}

See Also

Cell Class | Aspose.Cells Namespace


Cell Methods

The methods of the Cell class are listed below. For a complete list of Cell class members, see the Cell Members topic.

Public Instance Methods

Calculate | Overloaded. Calculates the formula of the cell.
Characters | Returns a Characters object that represents a range of characters within the cell text.
Copy | Copies data from a source cell.
Equals | Overloaded. Checks whether this object refers to the same cell with another.
GetArrayRange | Gets the array range if the cell's formula is an array formula.
GetCharacters | Overloaded. Returns all Characters objects that represents a range of characters within the cell text.
GetConditionalFormattingResult | Get the result of the conditional formatting.
GetDependents | Get all cells which refer to the specific cell.
GetDisplayStyle | Overloaded. Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().
GetFormatConditions | Gets format conditions which applies to this cell.
GetFormula | Get the formula of this cell.
GetHashCode | Serves as a hash function for a particular type.
GetHeightOfValue | Gets the height of the value in unit of pixels.
GetHtmlString | Gets the html string which contains data and some formats in this cell.
GetLeafs | Get all cells which will be updated when this cell is modified. This method can only work after calling Workbook.CalculateFormula.
GetMergedRange | Returns a Range object which represents a merged range.
GetPrecedents | Gets all cells or ranges which this cell's formula depends on.
GetStringValue | Gets the string value by specific formatted strategy.
GetStyle | Overloaded. Gets the cell style.
GetTable | Gets the table which contains this cell.
GetType (inherited from Object) |
GetValidation | Gets the validation applied to this cell.
GetValidationValue | Gets the value of validation which applied to this cell.
GetWidthOfValue | Gets the width of the value in unit of pixels.
IsRichText | Indicates whether the cell string value is a rich text.
PutValue | Overloaded. Puts an boolean value into the cell.
RemoveArrayFormula | Remove array formula.
SetAddInFormula | Obsolete. Sets an Add-In formula to the cell.
SetArrayFormula | Overloaded. Sets an array formula to a range of cells.
SetCharacters | Sets rich text format of the cell.
SetFormula | Overloaded. Set the formula and the value of the formula.
SetSharedFormula | Overloaded. Sets a formula to a range of cells.
SetStyle | Overloaded. Sets the cell style.
ToString | Returns a string represents the current Cell object.

See Also

Cell Class | Aspose.Cells Namespace


Calculate Method

Aspose.Cells for .NET

Cell.Calculate Method

Calculates the formula of the cell.

Overload List

Calculates the formula of the cell.

public void Calculate(CalculationOptions);

Obsolete. Calculates the formula of the cell.

public void Calculate(bool,ICustomFunction);

See Also

Cell Class | Aspose.Cells Namespace


Cell.Calculate Method (CalculationOptions)

Calculates the formula of the cell.

public void Calculate(
CalculationOptions options
);

Parameters

options
Options for calculation

See Also

Cell Class | Aspose.Cells Namespace | Cell.Calculate Overload List


Cell.Calculate Method (Boolean, ICustomFunction)

NOTE: This method is now obsolete.

Use Calculate(CalculationOptions) method instead.

Calculates the formula of the cell.

public void Calculate(
bool ignoreError,
ICustomFunction customFunction
);

Parameters

ignoreError
Indicates if hide the error in calculating formulas. The error may be unsupported function, external links, etc.
customFunction
The custom formula calculation functions to extend the calculation engine.

Remarks

NOTE: This member is now obsolete. Instead, please use Calculate(CalculationOptions) method. This method will be removed 12 months later since August 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cell Class | Aspose.Cells Namespace | Cell.Calculate Overload List


Cell.Characters Method

Returns a Characters object that represents a range of characters within the cell text.

public FontSetting Characters(
int startIndex,
int length
);

Parameters

startIndex
The index of the start of the character.
length
The number of characters.

Return Value

Characters object.

Remarks

This method only works on cell with string value.

Example

[C#]
excel.Worksheets[0].Cells["A1"].PutValue("Helloworld");
excel.Worksheets[0].Cells["A1"].Characters(5, 5).Font.IsBold = true;
excel.Worksheets[0].Cells["A1"].Characters(5, 5).Font.Color = Color.Blue;

[Visual Basic]
excel.Worksheets(0).Cells("A1").PutValue("Helloworld")
excel.Worksheets(0).Cells("A1").Characters(5, 5).Font.IsBold = True
excel.Worksheets(0).Cells("A1").Characters(5, 5).Font.Color = Color.Blue

See Also

Cell Class | Aspose.Cells Namespace


Cell.Copy Method

Copies data from a source cell.

public void Copy(
Cell cell
);

Parameters

cell
Source Cell object.

See Also

Cell Class | Aspose.Cells Namespace


Equals Method

Aspose.Cells for .NET

Cell.Equals Method

Checks whether this object refers to the same cell with another cell object.

Overload List

Checks whether this object refers to the same cell with another cell object.

public bool Equals(Cell);

Checks whether this object refers to the same cell with another.

public override bool Equals(object);

See Also

Cell Class | Aspose.Cells Namespace


Cell.Equals Method (Cell)

Checks whether this object refers to the same cell with another cell object.

public bool Equals(
Cell cell
);

Parameters

cell
another cell object

Return Value

true if two cell objects refers to the same cell.

See Also

Cell Class | Aspose.Cells Namespace | Cell.Equals Overload List


Cell.Equals Method (Object)

Checks whether this object refers to the same cell with another.

public override bool Equals(
object obj
);

Parameters

obj
another object

Return Value

true if two objects refers to the same cell.

See Also

Cell Class | Aspose.Cells Namespace | Cell.Equals Overload List


Cell.GetArrayRange Method

Gets the array range if the cell's formula is an array formula.

public CellArea GetArrayRange();

Return Value

The array range.

Remarks

Only applies when the cell's formula is an array formula

See Also

Cell Class | Aspose.Cells Namespace


GetCharacters Method

Aspose.Cells for .NET

Cell.GetCharacters Method

Returns all Characters objects that represents a range of characters within the cell text.

Overload List

Returns all Characters objects that represents a range of characters within the cell text.

public FontSetting[] GetCharacters();

Returns all Characters objects that represents a range of characters within the cell text.

public FontSetting[] GetCharacters(bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetCharacters Method ()

Returns all Characters objects that represents a range of characters within the cell text.

public FontSetting[] GetCharacters();

Return Value

All Characters objects

See Also

Cell Class | Aspose.Cells Namespace | Cell.GetCharacters Overload List


Cell.GetCharacters Method (Boolean)

Returns all Characters objects that represents a range of characters within the cell text.

public FontSetting[] GetCharacters(
bool flag
);

Parameters

flag
Indicates whether applying table style to the cell if the cell is in the table.

Return Value

All Characters objects

See Also

Cell Class | Aspose.Cells Namespace | Cell.GetCharacters Overload List


Cell.GetConditionalFormattingResult Method

Get the result of the conditional formatting.

public ConditionalFormattingResult GetConditionalFormattingResult();

Remarks

Returns null if no conditional formatting is applied to this cell,

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetDependents Method

Get all cells which refer to the specific cell.

public Cell[] GetDependents(
bool isAll
);

Parameters

isAll
Indicates whether check other worksheets

See Also

Cell Class | Aspose.Cells Namespace


GetDisplayStyle Method

Aspose.Cells for .NET

Cell.GetDisplayStyle Method

Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().

Overload List

Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().

public Style GetDisplayStyle();

Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().

public Style GetDisplayStyle(bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetDisplayStyle Method ()

Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().

public Style GetDisplayStyle();

See Also

Cell Class | Aspose.Cells Namespace | Cell.GetDisplayStyle Overload List


Cell.GetDisplayStyle Method (Boolean)

Gets the display style of the cell. If the cell is conditional formatted, the display style is not same as the cell.GetStyle().

public Style GetDisplayStyle(
bool includeMergedBorders
);

Parameters

includeMergedBorders
Indicates whether checking borders of the merged cells.

See Also

Cell Class | Aspose.Cells Namespace | Cell.GetDisplayStyle Overload List


Cell.GetFormatConditions Method

Gets format conditions which applies to this cell.

public FormatConditionCollection[] GetFormatConditions();

Return Value

Returns FormatConditionCollection object

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetFormula Method

Get the formula of this cell.

public string GetFormula(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

the formula of this cell.

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetHashCode Method

Serves as a hash function for a particular type.

public override int GetHashCode();

Return Value

A hash code for current Cell object.

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetHeightOfValue Method

Gets the height of the value in unit of pixels.

public int GetHeightOfValue();

Return Value

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetHtmlString Method

Gets the html string which contains data and some formats in this cell.

public string GetHtmlString(
bool html5
);

Parameters

html5
Indicates whether the value is compatible for html5

Return Value

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetLeafs Method

Get all cells which will be updated when this cell is modified. This method can only work after calling Workbook.CalculateFormula.

public IEnumerator GetLeafs();

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetMergedRange Method

Returns a Range object which represents a merged range.

public Range GetMergedRange();

Return Value

Range object. Null if this cell is not merged.

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetPrecedents Method

Gets all cells or ranges which this cell's formula depends on.

public ReferredAreaCollection GetPrecedents();

Return Value

Returns all cells or ranges.

Remarks

Returns null if this is not a formula cell.

Example

[C#]

Workbook workbook = new Workbook();
Cells cells = workbook.Worksheets[0].Cells;
cells["A1"].Formula = "= B1 + SUM(B1:B10) + [Book1.xls]Sheet1!A1";
 ReferredAreas areas = cells["A1"].GetPrecedents();
for (int i = 0; i < areas.Count; i++)
{
    ReferredArea area = areas[i];
     StringBuilder stringBuilder = new StringBuilder();
     if (area.IsExternalLink)
     {
         stringBuilder.Append("[");
          stringBuilder.Append(area.ExternalFileName);
          stringBuilder.Append("]");
      }
      stringBuilder.Append(area.SheetName);
      stringBuilder.Append("!");
      stringBuilder.Append(CellsHelper.CellIndexToName(area.StartRow, area.StartColumn));
      if (area.IsArea)
       {
           stringBuilder.Append(":");
           stringBuilder.Append(CellsHelper.CellIndexToName(area.EndRow, area.EndColumn));
       }
       Console.WriteLine(stringBuilder.ToString());
    }
 workbook.Save(@"C:\Book2.xls");

[Visual Basic]

Dim workbook As Workbook = New Workbook()
Dim cells As Cells = workbook.Worksheets(0).Cells
cells("A1").Formula = "= B1 + SUM(B1:B10) + [Book1.xls]Sheet1!A1"
 Dim areas As ReferredAreas = cells("A1").GetPrecedents()
For i As Integer = 0 To areas.Count - 1
    Dim area As ReferredArea = areas(i)
    Dim stringBuilder As StringBuilder = New StringBuilder()
    If (area.IsExternalLink) Then
        stringBuilder.Append("[")
        stringBuilder.Append(area.ExternalFileName)
       stringBuilder.Append("]")
    End If
    stringBuilder.Append(area.SheetName)
    stringBuilder.Append("!")
    stringBuilder.Append(CellsHelper.CellIndexToName(area.StartRow, area.StartColumn))
    If (area.IsArea) Then
        stringBuilder.Append(":")
        stringBuilder.Append(CellsHelper.CellIndexToName(area.EndRow, area.EndColumn))
     End If
    Console.WriteLine(stringBuilder.ToString())
 Next
 workbook.Save("C:\Book2.xls")

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetStringValue Method

Gets the string value by specific formatted strategy.

public string GetStringValue(
CellValueFormatStrategy formatStrategy
);

Parameters

formatStrategy
The formatted strategy.

Return Value

See Also

Cell Class | Aspose.Cells Namespace


GetStyle Method

Aspose.Cells for .NET

Cell.GetStyle Method

Gets the cell style.

Overload List

Gets the cell style.

public virtual Style GetStyle();

If checkBorders is true, check whether other cells' borders will effect the style of this cell.

public Style GetStyle(bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetStyle Method ()

Gets the cell style.

public virtual Style GetStyle();

Return Value

Style object.

Remarks

To change the style of the cell, please call Cell.SetStyle() method after changing the style.

See Also

Cell Class | Aspose.Cells Namespace | Cell.GetStyle Overload List


Cell.GetStyle Method (Boolean)

If checkBorders is true, check whether other cells' borders will effect the style of this cell.

public Style GetStyle(
bool checkBorders
);

Parameters

checkBorders
Check other cells' borders

Return Value

Style object.

Remarks

See Also

Cell Class | Aspose.Cells Namespace | Cell.GetStyle Overload List


Cell.GetTable Method

Gets the table which contains this cell.

public ListObject GetTable();

Return Value

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetValidation Method

Gets the validation applied to this cell.

public Validation GetValidation();

Return Value

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetValidationValue Method

Gets the value of validation which applied to this cell.

public bool GetValidationValue();

Return Value

See Also

Cell Class | Aspose.Cells Namespace


Cell.GetWidthOfValue Method

Gets the width of the value in unit of pixels.

public int GetWidthOfValue();

Return Value

See Also

Cell Class | Aspose.Cells Namespace


Cell.IsRichText Method

Indicates whether the cell string value is a rich text.

public bool IsRichText();

See Also

Cell Class | Aspose.Cells Namespace


PutValue Method

Aspose.Cells for .NET

Cell.PutValue Method

Puts an boolean value into the cell.

Overload List

Puts an boolean value into the cell.

public void PutValue(bool);

Puts a DateTime value into the cell.

public void PutValue(DateTime);

Puts a double value into the cell.

public void PutValue(double);

Puts an integer value into the cell.

public void PutValue(int);

Puts an object value into the cell.

public void PutValue(object);

Puts a string value into the cell.

public virtual void PutValue(string);

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(string,bool);

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(string,bool,bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.PutValue Method (Boolean)

Puts an boolean value into the cell.

public void PutValue(
bool boolValue
);

Parameters

boolValue

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (DateTime)

Puts a DateTime value into the cell.

public void PutValue(
DateTime dateTime
);

Parameters

dateTime
Input value

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (Double)

Puts a double value into the cell.

public void PutValue(
double doubleValue
);

Parameters

doubleValue
Input value

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (Int32)

Puts an integer value into the cell.

public void PutValue(
int intValue
);

Parameters

intValue
Input value

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (Object)

Puts an object value into the cell.

public void PutValue(
object objectValue
);

Parameters

objectValue
input value

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (String)

Puts a string value into the cell.

public virtual void PutValue(
string stringValue
);

Parameters

stringValue
Input value

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (String, Boolean)

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(
string stringValue,
bool isConverted
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.PutValue Method (String, Boolean, Boolean)

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(
string stringValue,
bool isConverted,
bool setStyle
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.
setStyle
True: set the number format to cell's style when converting to other data type

See Also

Cell Class | Aspose.Cells Namespace | Cell.PutValue Overload List


Cell.RemoveArrayFormula Method

Remove array formula.

public void RemoveArrayFormula(
bool leaveNormalFormula
);

Parameters

leaveNormalFormula
True represents converting the array formula to normal formula.

See Also

Cell Class | Aspose.Cells Namespace


Cell.SetAddInFormula Method

NOTE: This method is now obsolete.

Use WorksheetCollection.RegisterAddInFunction and Cell.Formula/Cell.SetFormula() instead.

Sets an Add-In formula to the cell.

public void SetAddInFormula(
string addInFileName,
string addInFunction
);

Parameters

addInFileName
Add-In file name.
addInFunction
Add-In function name.

Remarks

Add-In file should be placed in the directory or sub-directory of Workbook Add-In library. For example, file name can be "Eurotool.xla" or "solver\solver.xla". NOTE: This class is now obsolete. Instead, please use Cell.Formula/Cell.SetFormula() to set cell formula with the Add-In functions after registering it by WorksheetCollection.RegisterAddInFunction(). This property will be removed 12 months later since January 2019. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]
 cells["h11"].SetAddInFormula("HRVSTTRK.xla", "=pct_overcut(F3:G3)");
 cells["h12"].SetAddInFormula("HRVSTTRK.xla", "=pct_overcut()");

 [Visual Basic]
 cells("h11").SetAddInFormula("HRVSTTRK.xla", "=pct_overcut(F3:G3)")
 cells("h12").SetAddInFormula("HRVSTTRK.xla", "=pct_overcut()")

See Also

Cell Class | Aspose.Cells Namespace


SetArrayFormula Method

Aspose.Cells for .NET

Cell.SetArrayFormula Method

Sets an array formula to a range of cells.

Overload List

Sets an array formula to a range of cells.

public void SetArrayFormula(string,int,int);

Sets an array formula to a range of cells.

public void SetArrayFormula(string,int,int,FormulaParseOptions);

Obsolete. Sets an array formula to a range of cells.

public void SetArrayFormula(string,int,int,bool,bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.SetArrayFormula Method (String, Int32, Int32)

Sets an array formula to a range of cells.

public void SetArrayFormula(
string arrayFormula,
int rowNumber,
int columnNumber
);

Parameters

arrayFormula
Array formula.
rowNumber
Number of rows to populate result of the array formula.
columnNumber
Number of columns to populate result of the array formula.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetArrayFormula Overload List


Cell.SetArrayFormula Method (String, Int32, Int32, FormulaParseOptions)

Sets an array formula to a range of cells.

public void SetArrayFormula(
string arrayFormula,
int rowNumber,
int columnNumber,
FormulaParseOptions options
);

Parameters

arrayFormula
Array formula.
rowNumber
Number of rows to populate result of the array formula.
columnNumber
Number of columns to populate result of the array formula.
options
Options for parsing the formula.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetArrayFormula Overload List


Cell.SetArrayFormula Method (String, Int32, Int32, Boolean, Boolean)

NOTE: This method is now obsolete.

Use FormulaParseOptions for more options instead.

Sets an array formula to a range of cells.

public void SetArrayFormula(
string arrayFormula,
int rowNumber,
int columnNumber,
bool isR1C1,
bool isLocal
);

Parameters

arrayFormula
Array formula.
rowNumber
Number of rows to populate result of the array formula.
columnNumber
Number of columns to populate result of the array formula.
isR1C1
whether the formula is R1C1 formula
isLocal
whether the formula is locale formatted

Remarks

NOTE: This class is now obsolete. Instead, please use Cell.SetArrayFormula(string,int,int,FormulaParseOptions). This property will be removed 12 months later since December 2019. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetArrayFormula Overload List


Cell.SetCharacters Method

Sets rich text format of the cell.

public void SetCharacters(
FontSetting[] characters
);

Parameters

characters
All Characters objects.

See Also

Cell Class | Aspose.Cells Namespace


SetFormula Method

Aspose.Cells for .NET

Cell.SetFormula Method

Set the formula and the value of the formula.

Overload List

Set the formula and the value of the formula.

public void SetFormula(string,FormulaParseOptions,object);

Obsolete. Set the formula and the value of the formula.

public void SetFormula(string,bool,bool,object);

Set the formula and the value of the formula.

public void SetFormula(string,object);

See Also

Cell Class | Aspose.Cells Namespace


Cell.SetFormula Method (String, FormulaParseOptions, Object)

Set the formula and the value of the formula.

public void SetFormula(
string formula,
FormulaParseOptions options,
object value
);

Parameters

formula
The formula.
options
Options for parsing the formula.
value
The value of the formula.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetFormula Overload List


Cell.SetFormula Method (String, Boolean, Boolean, Object)

NOTE: This method is now obsolete.

Use FormulaParseOptions for more options instead.

Set the formula and the value of the formula.

public void SetFormula(
string formula,
bool isR1C1,
bool isLocal,
object value
);

Parameters

formula
The formula.
isR1C1
Whether the formula is R1C1 formula.
isLocal
Whether the formula is locale formatted.
value
The value of the formula.

Remarks

NOTE: This class is now obsolete. Instead, please use Cell.SetFormula(string,FormulaParseOptions,object). This property will be removed 12 months later since December 2019. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetFormula Overload List


Cell.SetFormula Method (String, Object)

Set the formula and the value of the formula.

public void SetFormula(
string formula,
object value
);

Parameters

formula
The formula.
value
The value of the formula.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetFormula Overload List


SetSharedFormula Method

Aspose.Cells for .NET

Cell.SetSharedFormula Method

Sets a formula to a range of cells.

Overload List

Sets a formula to a range of cells.

public void SetSharedFormula(string,int,int);

Sets a formula to a range of cells.

public void SetSharedFormula(string,int,int,FormulaParseOptions);

Obsolete. Sets a formula to a range of cells.

public void SetSharedFormula(string,int,int,bool,bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.SetSharedFormula Method (String, Int32, Int32)

Sets a formula to a range of cells.

public void SetSharedFormula(
string sharedFormula,
int rowNumber,
int columnNumber
);

Parameters

sharedFormula
Shared formula.
rowNumber
Number of rows to populate the formula.
columnNumber
Number of columns to populate the formula.

Remarks

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetSharedFormula Overload List


Cell.SetSharedFormula Method (String, Int32, Int32, FormulaParseOptions)

Sets a formula to a range of cells.

public void SetSharedFormula(
string sharedFormula,
int rowNumber,
int columnNumber,
FormulaParseOptions options
);

Parameters

sharedFormula
Shared formula.
rowNumber
Number of rows to populate the formula.
columnNumber
Number of columns to populate the formula.
options
Options for parsing the formula.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetSharedFormula Overload List


Cell.SetSharedFormula Method (String, Int32, Int32, Boolean, Boolean)

NOTE: This method is now obsolete.

Use FormulaParseOptions for more options instead.

Sets a formula to a range of cells.

public void SetSharedFormula(
string sharedFormula,
int rowNumber,
int columnNumber,
bool isR1C1,
bool isLocal
);

Parameters

sharedFormula
Shared formula.
rowNumber
Number of rows to populate the formula.
columnNumber
Number of columns to populate the formula.
isR1C1
whether the formula is R1C1 formula
isLocal
whether the formula is locale formatted

Remarks

NOTE: This class is now obsolete. Instead, please use Cell.SetSharedFormula(string,int,int,FormulaParseOptions). This property will be removed 12 months later since December 2019. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetSharedFormula Overload List


SetStyle Method

Aspose.Cells for .NET

Cell.SetStyle Method

Sets the cell style.

Overload List

Sets the cell style.

public virtual void SetStyle(Style);

Apply the cell style.

public virtual void SetStyle(Style,StyleFlag);

Apply the cell style.

public virtual void SetStyle(Style,bool);

See Also

Cell Class | Aspose.Cells Namespace


Cell.SetStyle Method (Style)

Sets the cell style.

public virtual void SetStyle(
Style style
);

Parameters

style
The cell style.

Remarks

If the border settings are changed, the border of adjust cells will be updated too.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetStyle Overload List


Cell.SetStyle Method (Style, StyleFlag)

Apply the cell style.

public virtual void SetStyle(
Style style,
StyleFlag flag
);

Parameters

style
The cell style.
flag
The style flag.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetStyle Overload List


Cell.SetStyle Method (Style, Boolean)

Apply the cell style.

public virtual void SetStyle(
Style style,
bool explicitFlag
);

Parameters

style
The cell style.
explicitFlag
True, only overwriting formatting which is explicitly set.

See Also

Cell Class | Aspose.Cells Namespace | Cell.SetStyle Overload List


Cell.ToString Method

Returns a string represents the current Cell object.

public override string ToString();

Return Value

See Also

Cell Class | Aspose.Cells Namespace


CellArea Structure

Represent an area of cells.

For a list of all members of this type, see CellArea Members.

System.Object
System.ValueType
Aspose.Cells.CellArea

public struct CellArea : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Create Cell Area
CellArea ca = new CellArea();
ca.StartRow = 0;
ca.EndRow = 0;
ca.StartColumn = 0;
ca.EndColumn = 0;

[VB.NET]

'Create Cell Area
Dim ca As CellArea = New CellArea()
ca.StartRow = 0
ca.EndRow = 0
ca.StartColumn = 0
ca.EndColumn = 0

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellArea Members | Aspose.Cells Namespace


CellArea Members

CellArea overview

Public Static Methods

CreateCellArea Overloaded. Creates a cell area.

Public Instance Fields

EndColumn | Gets or set the end column of this area.
EndRow | Gets or set the end row of this area.
StartColumn | Gets or set the start column of this area.
StartRow | Gets or set the start row of this area.

Public Instance Methods

CompareTo | Internal use only.
Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Worksheet object.

See Also

CellArea Class | Aspose.Cells Namespace


CellArea Fields

The fields of the CellArea structure are listed below. For a complete list of CellArea structure members, see the CellArea Members topic.

Public Instance Fields

EndColumn | Gets or set the end column of this area.
EndRow | Gets or set the end row of this area.
StartColumn | Gets or set the start column of this area.
StartRow | Gets or set the start row of this area.

See Also

CellArea Class | Aspose.Cells Namespace


CellArea.EndColumn Field

Gets or set the end column of this area.

public int EndColumn;

See Also

CellArea Class | Aspose.Cells Namespace


CellArea.EndRow Field

Gets or set the end row of this area.

public int EndRow;

See Also

CellArea Class | Aspose.Cells Namespace


CellArea.StartColumn Field

Gets or set the start column of this area.

public int StartColumn;

See Also

CellArea Class | Aspose.Cells Namespace


CellArea.StartRow Field

Gets or set the start row of this area.

public int StartRow;

See Also

CellArea Class | Aspose.Cells Namespace


CellArea Methods

The methods of the CellArea structure are listed below. For a complete list of CellArea structure members, see the CellArea Members topic.

Public Static Methods

CreateCellArea Overloaded. Creates a cell area.

Public Instance Methods

CompareTo | Internal use only.
Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Worksheet object.

See Also

CellArea Class | Aspose.Cells Namespace


CellArea.CompareTo Method

Internal use only.

public int CompareTo(
object obj
);

Parameters

obj

Return Value

Implements

IComparable.CompareTo

See Also

CellArea Class | Aspose.Cells Namespace


CreateCellArea Method

Aspose.Cells for .NET

CellArea.CreateCellArea Method

Creates a cell area.

Overload List

Creates a cell area.

public static CellArea CreateCellArea(int,int,int,int);

Creates a cell area.

public static CellArea CreateCellArea(string,string);

See Also

CellArea Class | Aspose.Cells Namespace


CellArea.CreateCellArea Method (Int32, Int32, Int32, Int32)

Creates a cell area.

public static CellArea CreateCellArea(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
The start row.
startColumn
The start column.
endRow
The end row.
endColumn
The end column.

Return Value

Return a CellArea.

See Also

CellArea Class | Aspose.Cells Namespace | CellArea.CreateCellArea Overload List


CellArea.CreateCellArea Method (String, String)

Creates a cell area.

public static CellArea CreateCellArea(
string startCellName,
string endCellName
);

Parameters

startCellName
The top-left cell of the range.
endCellName
The bottom-right cell of the range.

Return Value

Return a CellArea.

See Also

CellArea Class | Aspose.Cells Namespace | CellArea.CreateCellArea Overload List


CellArea.ToString Method

Returns a string represents the current Worksheet object.

public override string ToString();

Return Value

See Also

CellArea Class | Aspose.Cells Namespace


CellBorderType Enumeration

Enumerates a cell's border type.

public enum CellBorderType

Members

Member Name | Description | Value
DashDot | Represents thin dash-dotted line. | 9
DashDotDot | Represents thin dash-dot-dotted line. | 11
Dashed | Represents dashed line. | 3
Dotted | Represents dotted line. | 4
Double | Represents double line. | 6
Hair | Represents hair line. | 7
MediumDashDot | Represents medium dash-dotted line. | 10
MediumDashDotDot | Represents medium dash-dot-dotted line. | 12
MediumDashed | Represents medium dashed line. | 8
None | Represents no line. | 0
Medium | Represents medium line. | 2
SlantedDashDot | Represents slanted medium dash-dotted line. | 13
Thick | Represents thick line. | 5
Thin | Represents thin line. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Cells Class

Encapsulates a collection of cell relevant objects, such as Cell, Row, ...etc.

For a list of all members of this type, see Cells Members.

System.Object
Aspose.Cells.Cells

public class Cells : IEnumerable, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 Workbook excel = new Workbook();
    Cells cells = excel.Worksheets[0].Cells;

    //Set default row height
    cells.StandardHeight = 20;
    //Set row height
    cells.SetRowHeight(2, 20.5);

    //Set default colum width
    cells.StandardWidth = 15;
    //Set column width
    cells.SetColumnWidth(3, 12.57);

    //Merge cells
    cells.Merge(5, 4, 2, 2);

    //Import data
    DataTable dt = new DataTable("Products");
 dt.Columns.Add("Product_ID",typeof(Int32));
 dt.Columns.Add("Product_Name",typeof(string));
 dt.Columns.Add("Units_In_Stock",typeof(Int32));
 DataRow dr = dt.NewRow();
 dr[0] = 1;
 dr[1] = "Aniseed Syrup";
 dr[2] = 15;
 dt.Rows.Add(dr);
 dr = dt.NewRow();
 dr[0] = 2;
 dr[1] = "Boston Crab Meat";
 dr[2] = 123;
 dt.Rows.Add(dr);
 cells.ImportDataTable(dt, true, 12, 12, 10, 10);

 //Export data
 DataTable outDataTable = cells.ExportDataTable(12, 12, 10, 10);

 [Visual Basic]

 Dim excel as Workbook = new Workbook()
    Dim cells as Cells = excel.Worksheets(0).Cells

    'Set default row height
    cells.StandardHeight = 20
    'Set row height
    cells.SetRowHeight(2, 20.5)

    'Set default colum width
    cells.StandardWidth = 15
    'Set column width
    cells.SetColumnWidth(3, 12.57)

    'Merge cells
    cells.Merge(5, 4, 2, 2)

    'Import data
    Dim dt as DataTable = new DataTable("Employee")
    dt.Columns.Add("Employee_ID",typeof(Int32))
 dt.Columns.Add("Employee_Name",typeof(string))
 dt.Columns.Add("Gender",typeof(string))
 Dim dr as DataRow = dt.NewRow()
 dr(0) = 1
 dr(1) = "John Smith"
 dr(2) = "Male"
 dt.Rows.Add(dr)
 dr = dt.NewRow()
 dr(0) = 2
 dr(1) = "Mary Miller"
 dr(2) = "Female"
 dt.Rows.Add(dr)
 cells.ImportDataTable(dt, true, 12, 12, 10, 10)

 'Export data
 Dim outDataTable as DataTable = cells.ExportDataTable(12, 12, 10, 10)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Cells Members | Aspose.Cells Namespace


Cells Members

Cells overview

Public Instance Properties

Columns | Gets the collection of Column objects that represents the individual columns in this worksheet.
Count | Gets the total count of instantiated Cell objects.
CountLarge | Gets the total count of instantiated Cell objects.
FirstCell | Gets the first cell in this worksheet.
IsDefaultRowHeightMatched | Indicates that row height and default font height matches
IsDefaultRowHidden | Indicates whether the row is default hidden.
Item | Overloaded. Gets Cell item within the worksheet
LastCell | Gets the last cell in this worksheet.
MaxColumn | Maximum column index of cell which contains data or style.
MaxDataColumn | Maximum column index of cell which contains data.
MaxDataRow | Maximum row index of cell which contains data.
MaxDisplayRange | Gets the max range which includes data, merged cells and shapes.
MaxRow | Maximum row index of cell which contains data or style.
MemorySetting | Gets or sets the memory usage option for this cells.
MergedCells | Gets the collection of merged cells.
MinColumn | Minimum column index of cell which contains data or style.
MinDataColumn | Minimum column index of cell which contains data.
MinDataRow | Minimum row index of cell which contains data.
MinRow | Minimum row index of cell which contains data or style.
MultiThreadReading | Gets or sets whether the cells data model should support Multi-Thread reading. Default value of this property is false. If there are multiple threads to read Row/Cell objects in this collection concurrently, this property should be set as true, otherwise unexpected result may be produced. Supporting Multi-Thread reading may degrade the performance for accessing Row/Cell objects from this collection.
OdsCellFields | Gets the list of fields of ods.
PreserveString | Gets or sets a value indicating whether all worksheet values are preserved as strings. Default is false.
Ranges | Gets the collection of Range objects created at run time.
Rows | Gets the collection of Row objects that represents the individual rows in this worksheet.
StandardHeight | Gets or sets the default row height in this worksheet, in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet, in unit of pixels.
StandardWidth | Gets or sets the default column width in the worksheet, in unit of characters.
StandardWidthInch | Gets or sets the default column width in the worksheet, in unit of inches.
StandardWidthPixels | Gets or sets the default column width in the worksheet, in unit of pixels.
Style | Gets and sets the default style.

Public Instance Methods

AddRange | Adds a range object reference to cells
ApplyColumnStyle | Applies formats for a whole column.
ApplyRowStyle | Applies formats for a whole row.
ApplyStyle | Applies formats for a whole worksheet.
CheckCell | Gets the Cell element or null at the specified cell row index and column index.
CheckColumn | Gets the Column element or null at the specified column index.
CheckRow | Gets the Row element or at the specified cell row index.
Clear | Clears all cell and row objects.
ClearContents | Overloaded. Clears contents of a range.
ClearFormats | Overloaded. Clears formatting of a range.
ClearRange | Overloaded. Clears contents and formatting of a range.
ConvertStringToNumericValue | Converts string data in cells to numeric value if possible.
CopyColumn | Copies data and formats of a whole column.
CopyColumns | Overloaded. Copies data and formats of a whole column.
CopyRow | Copies data and formats of a whole row.
CopyRows | Overloaded. Copies data and formats of some whole rows.
CreateRange | Overloaded. Creates a Range object from a range of cells.
DeleteBlankColumns | Overloaded. Delete all blank columns which do not contain any data.
DeleteBlankRows | Overloaded. Delete all blank rows which do not contain any data.
DeleteColumn | Overloaded. Deletes a column.
DeleteColumns | Deletes several columns.
DeleteRange | Deletes a range of cells and shift cells according to the shift option.
DeleteRow | Deletes a row.
DeleteRows | Overloaded. Deletes several rows.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
EndCellInColumn | Overloaded. Gets the last cell in this column.
EndCellInRow | Overloaded. Gets the last cell in this row.
Equals (inherited from Object) |
ExportArray | Exports data in the Cells collection to a two-dimension array object.
ExportDataTable | Overloaded. Exports data in the Cells collection to a DataTable object.
ExportDataTableAsString | Overloaded. Exports data in the Cells collection to a DataTable object.
ExportTypeArray | Exports cell value type in the Cells collection to a two-dimension array object.
Find | Overloaded. Finds the cell containing with the input object.
FindFormula | Obsolete. Finds the cell with the input string.
FindFormulaContains | Obsolete. Finds the cell with formula which contains the input string.
GetCell | Gets the Cell element or null at the specified cell row index and column index.
GetCellStyle | Get the style of given cell.
GetColumnWidth | Gets the width of the specified column in normal view
GetColumnWidthInch | Gets the width of the specified column in normal view, in units of inches.
GetColumnWidthPixel | Gets the width of the specified column in normal view, in units of pixel.
GetDependents | Get all cells which refer to the specific cell.
GetEnumerator | Gets the cells enumerator.
GetGroupedColumnOutlineLevel | Gets the outline level (zero-based) of the column.
GetGroupedRowOutlineLevel | Gets the outline level (zero-based) of the row.
GetHashCode (inherited from Object) |
GetLastDataRow | Gets the last row index of cell which contains data in the specified column.
GetMaxGroupedColumnOutlineLevel | Gets the max grouped column outline level (zero-based).
GetMaxGroupedRowOutlineLevel | Gets the max grouped row outline level (zero-based).
GetRow | Gets the Row element at the specified cell row index.
GetRowEnumerator | Gets the rows enumerator.
GetRowHeight | Gets the height of a specified row.
GetRowHeightInch | Gets the height of a specified row in unit of inches.
GetRowHeightPixel | Gets the height of a specified row in unit of pixel.
GetType (inherited from Object) |
GetViewColumnWidthPixel | Get the width in different view type.
GetViewRowHeight | Gets the height of a specified row.
GetViewRowHeightInch | Gets the height of a specified row in unit of inches.
GroupColumns | Overloaded. Groups columns.
GroupRows | Overloaded. Groups rows.
HideColumn | Hides a column.
HideColumns | Hide multiple columns.
HideGroupDetail | Collapses the grouped rows/columns.
HideRow | Hides a row.
HideRows | Hides multiple rows.
Import | Obsolete. Import data from data view.
ImportArray | Overloaded. Imports a two-dimension array of string into a worksheet.
ImportArrayList | Imports an arraylist of data into a worksheet.
ImportCSV | Overloaded. Import a CSV file to the cells.
ImportCustomObjects | Overloaded. Imports custom objects.
ImportData | Overloaded. Import data from custom data table.
ImportDataGrid | Overloaded. Imports a DataGrid into a worksheet.
ImportDataGridAsString | Imports a DataGrid into a worksheet. This method doesn't try to convert text into numeric values.
ImportDataReader | Overloaded. Imports data from a SqlDataReader object.
ImportDataRow | Imports a DataRow into the Excel file.
ImportDataTable | Overloaded. Imports a DataTable object into a worksheet.
ImportDataView | Overloaded. Imports a DataView into a worksheet.
ImportFormulaArray | Imports an array of formula into a worksheet.
ImportFromDataReader | Overloaded. Imports data from a SqlDataReader object.
ImportGridView | Imports a grid view to this cells.
ImportObjectArray | Overloaded. Imports an array of data into a worksheet.
ImportTwoDimensionArray | Overloaded. Imports a two-dimension array of data into a worksheet.
InsertColumn | Overloaded. Inserts a new column into the worksheet.
InsertColumns | Overloaded. Inserts some columns into the worksheet.
InsertCutCells | Insert cut range.
InsertRange | Overloaded. Inserts a range of cells and shift cells according to the shift option.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Overloaded. Inserts multiple rows into the worksheet.
IsBlankColumn | Checks whether given column is blank(does not contain any data).
IsColumnHidden | Checks whether a column at given index is hidden.
IsDeletingRangeEnabled | Check whether the range could be deleted.
IsRowHidden | Checks whether a row at given index is hidden.
LinkToXmlMap | Link to a xml map.
Merge | Overloaded. Merges a specified range of cells into a single cell.
MoveRange | Moves the range.
RemoveDuplicates | Overloaded. Removes duplicate rows in the sheet.
RemoveFormulas | Removes all formula and replaces with the value of the formula.
RetrieveSubtotalSetting | Retrieves subtotals setting of the range.
SetColumnWidth | Sets the width of the specified column in normal view.
SetColumnWidthInch | Sets column width in unit of inches in normal view.
SetColumnWidthPixel | Sets column width in unit of pixels in normal view.
SetRowHeight | Sets the height of the specified row.
SetRowHeightInch | Sets row height in unit of inches.
SetRowHeightPixel | Sets row height in unit of pixels.
SetViewColumnWidthPixel | Sets the width of the column in different view.
ShowGroupDetail | Uncollapses the grouped rows/columns.
Subtotal | Overloaded. Creates subtotals for the range.
TextToColumns | Splits the text in the column to columns.
ToString (inherited from Object) |
UngroupColumns | Ungroups columns.
UngroupRows | Overloaded. Ungroups rows.
UnhideColumn | Unhides a column
UnhideColumns | Unhide multiple columns.
UnhideRow | Unhides a row.
UnhideRows | Unhides the hidden rows.
UnMerge | Unmerges a specified range of merged cells.

See Also

Cells Class | Aspose.Cells Namespace


Cells Properties

The properties of the Cells class are listed below. For a complete list of Cells class members, see the Cells Members topic.

Public Instance Properties

Columns | Gets the collection of Column objects that represents the individual columns in this worksheet.
Count | Gets the total count of instantiated Cell objects.
CountLarge | Gets the total count of instantiated Cell objects.
FirstCell | Gets the first cell in this worksheet.
IsDefaultRowHeightMatched | Indicates that row height and default font height matches
IsDefaultRowHidden | Indicates whether the row is default hidden.
Item | Overloaded. Gets Cell item within the worksheet
LastCell | Gets the last cell in this worksheet.
MaxColumn | Maximum column index of cell which contains data or style.
MaxDataColumn | Maximum column index of cell which contains data.
MaxDataRow | Maximum row index of cell which contains data.
MaxDisplayRange | Gets the max range which includes data, merged cells and shapes.
MaxRow | Maximum row index of cell which contains data or style.
MemorySetting | Gets or sets the memory usage option for this cells.
MergedCells | Gets the collection of merged cells.
MinColumn | Minimum column index of cell which contains data or style.
MinDataColumn | Minimum column index of cell which contains data.
MinDataRow | Minimum row index of cell which contains data.
MinRow | Minimum row index of cell which contains data or style.
MultiThreadReading | Gets or sets whether the cells data model should support Multi-Thread reading. Default value of this property is false. If there are multiple threads to read Row/Cell objects in this collection concurrently, this property should be set as true, otherwise unexpected result may be produced. Supporting Multi-Thread reading may degrade the performance for accessing Row/Cell objects from this collection.
OdsCellFields | Gets the list of fields of ods.
PreserveString | Gets or sets a value indicating whether all worksheet values are preserved as strings. Default is false.
Ranges | Gets the collection of Range objects created at run time.
Rows | Gets the collection of Row objects that represents the individual rows in this worksheet.
StandardHeight | Gets or sets the default row height in this worksheet, in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet, in unit of pixels.
StandardWidth | Gets or sets the default column width in the worksheet, in unit of characters.
StandardWidthInch | Gets or sets the default column width in the worksheet, in unit of inches.
StandardWidthPixels | Gets or sets the default column width in the worksheet, in unit of pixels.
Style | Gets and sets the default style.

See Also

Cells Class | Aspose.Cells Namespace


Columns Property

Aspose.Cells for .NET

Cells.Columns Property

Gets the collection of Column objects that represents the individual columns in this worksheet.

public ColumnCollection Columns {get;}

See Also

Cells Class | Aspose.Cells Namespace


Count Property

Aspose.Cells for .NET

Cells.Count Property

Gets the total count of instantiated Cell objects.

public int Count {get;}

See Also

Cells Class | Aspose.Cells Namespace


CountLarge Property

Aspose.Cells for .NET

Cells.CountLarge Property

Gets the total count of instantiated Cell objects.

public long CountLarge {get;}

See Also

Cells Class | Aspose.Cells Namespace


FirstCell Property

Aspose.Cells for .NET

Cells.FirstCell Property

Gets the first cell in this worksheet.

public Cell FirstCell {get;}

See Also

Cells Class | Aspose.Cells Namespace


IsDefaultRowHeightMatched Property

Aspose.Cells for .NET

Cells.IsDefaultRowHeightMatched Property

Indicates that row height and default font height matches

public bool IsDefaultRowHeightMatched {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


IsDefaultRowHidden Property

Aspose.Cells for .NET

Cells.IsDefaultRowHidden Property

Indicates whether the row is default hidden.

public bool IsDefaultRowHidden {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

Cells.Item Property

NOTE: This property is now obsolete.

Use Cells.GetEnumerator() method to iterate all cells in this worksheet instead.

Gets Cell item within the worksheet

Overload List

Obsolete. Gets Cell item within the worksheet

public Cell this[int] {get;}

Gets the Cell element at the specified cell row index and column index.

public Cell this[int, int] {get;}

Gets the Cell element at the specified cell name.

public Cell this[string] {get;}

See Also

Cells Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

Cells.Item Property (Int32)

NOTE: This property is now obsolete.

Use Cells.GetEnumerator() method to iterate all cells in this worksheet instead.

Gets Cell item within the worksheet

public Cell this[
int index
] {get;}

Parameters

index
The zero based index of the element.

Property Value

The element at the specified index.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.GetEnumerator() method to iterate all cells in this worksheet. This property will be removed 12 months later since February 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

Cells.Item Property (Int32, Int32)

Gets the Cell element at the specified cell row index and column index.

public Cell this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

Example

[C#]

Cells cells = excel.Worksheets[0].Cells;
Cell cell = cells[0, 0];    //Gets the cell at "A1"

[Visual Basic]

Dim cells As Cells =  excel.Worksheets(0).Cells
Dim cell As Cell =  cells(0,0)  'Gets the cell at "A1"

See Also

Cells Class | Aspose.Cells Namespace | Cells.Item Overload List


Item Property (String)

Aspose.Cells for .NET

Cells.Item Property (String)

Gets the Cell element at the specified cell name.

public Cell this[
string cellName
] {get;}

Parameters

cellName
Cell name,including its column letter and row number, for example A5.

Example

[C#]

Cells cells = excel.Worksheets[0].Cells;
Cell cell = cells["A1"];    //Gets the cell at "A1"

[Visual Basic]

Dim cells As Cells =  excel.Worksheets(0).Cells
Dim cell As Cell =  cells("A1")  'Gets the cell at "A1"

See Also

Cells Class | Aspose.Cells Namespace | Cells.Item Overload List


LastCell Property

Aspose.Cells for .NET

Cells.LastCell Property

Gets the last cell in this worksheet.

public Cell LastCell {get;}

See Also

Cells Class | Aspose.Cells Namespace


MaxColumn Property

Aspose.Cells for .NET

Cells.MaxColumn Property

Maximum column index of cell which contains data or style.

public int MaxColumn {get;}

Remarks

Return -1 if there is no cell.

See Also

Cells Class | Aspose.Cells Namespace


MaxDataColumn Property

Aspose.Cells for .NET

Cells.MaxDataColumn Property

Maximum column index of cell which contains data.

public int MaxDataColumn {get;}

Remarks

Return -1 if there is not cell which contains data. Don't call this property repeatedly. This property will iterate all cells in a worksheet.

See Also

Cells Class | Aspose.Cells Namespace


MaxDataRow Property

Aspose.Cells for .NET

Cells.MaxDataRow Property

Maximum row index of cell which contains data.

public int MaxDataRow {get;}

Remarks

Return -1 if there is no cell which contains data.

See Also

Cells Class | Aspose.Cells Namespace


MaxDisplayRange Property

Aspose.Cells for .NET

Cells.MaxDisplayRange Property

Gets the max range which includes data, merged cells and shapes.

public Range MaxDisplayRange {get;}

See Also

Cells Class | Aspose.Cells Namespace


MaxRow Property

Aspose.Cells for .NET

Cells.MaxRow Property

Maximum row index of cell which contains data or style.

public int MaxRow {get;}

Remarks

Return -1 if there is no cell which contains data or style in the worksheet.

See Also

Cells Class | Aspose.Cells Namespace


MemorySetting Property

Aspose.Cells for .NET

Cells.MemorySetting Property

Gets or sets the memory usage option for this cells.

public MemorySetting MemorySetting {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


MergedCells Property

Aspose.Cells for .NET

Cells.MergedCells Property

Gets the collection of merged cells.

public ArrayList MergedCells {get;}

Remarks

In this collection, each item is a CellArea structure which represents an area of merged cells.

See Also

Cells Class | Aspose.Cells Namespace


MinColumn Property

Aspose.Cells for .NET

Cells.MinColumn Property

Minimum column index of cell which contains data or style.

public int MinColumn {get;}

See Also

Cells Class | Aspose.Cells Namespace


MinDataColumn Property

Aspose.Cells for .NET

Cells.MinDataColumn Property

Minimum column index of cell which contains data.

public int MinDataColumn {get;}

See Also

Cells Class | Aspose.Cells Namespace


MinDataRow Property

Aspose.Cells for .NET

Cells.MinDataRow Property

Minimum row index of cell which contains data.

public int MinDataRow {get;}

See Also

Cells Class | Aspose.Cells Namespace


MinRow Property

Aspose.Cells for .NET

Cells.MinRow Property

Minimum row index of cell which contains data or style.

public int MinRow {get;}

See Also

Cells Class | Aspose.Cells Namespace


MultiThreadReading Property

Aspose.Cells for .NET

Cells.MultiThreadReading Property

Gets or sets whether the cells data model should support Multi-Thread reading. Default value of this property is false. If there are multiple threads to read Row/Cell objects in this collection concurrently, this property should be set as true, otherwise unexpected result may be produced. Supporting Multi-Thread reading may degrade the performance for accessing Row/Cell objects from this collection.

public bool MultiThreadReading {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


OdsCellFields Property

Aspose.Cells for .NET

Cells.OdsCellFields Property

Gets the list of fields of ods.

public OdsCellFieldCollection OdsCellFields {get;}

See Also

Cells Class | Aspose.Cells Namespace


PreserveString Property

Aspose.Cells for .NET

Cells.PreserveString Property

Gets or sets a value indicating whether all worksheet values are preserved as strings. Default is false.

public bool PreserveString {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


Ranges Property

Aspose.Cells for .NET

Cells.Ranges Property

Gets the collection of Range objects created at run time.

public RangeCollection Ranges {get;}

See Also

Cells Class | Aspose.Cells Namespace


Rows Property

Aspose.Cells for .NET

Cells.Rows Property

Gets the collection of Row objects that represents the individual rows in this worksheet.

public RowCollection Rows {get;}

See Also

Cells Class | Aspose.Cells Namespace


StandardHeight Property

Aspose.Cells for .NET

Cells.StandardHeight Property

Gets or sets the default row height in this worksheet, in unit of points.

public double StandardHeight {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


StandardHeightPixels Property

Aspose.Cells for .NET

Cells.StandardHeightPixels Property

Gets or sets the default row height in this worksheet, in unit of pixels.

public int StandardHeightPixels {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


StandardWidth Property

Aspose.Cells for .NET

Cells.StandardWidth Property

Gets or sets the default column width in the worksheet, in unit of characters.

public double StandardWidth {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


StandardWidthInch Property

Aspose.Cells for .NET

Cells.StandardWidthInch Property

Gets or sets the default column width in the worksheet, in unit of inches.

public double StandardWidthInch {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


StandardWidthPixels Property

Aspose.Cells for .NET

Cells.StandardWidthPixels Property

Gets or sets the default column width in the worksheet, in unit of pixels.

public int StandardWidthPixels {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


Style Property

Aspose.Cells for .NET

Cells.Style Property

Gets and sets the default style.

public Style Style {get; set;}

See Also

Cells Class | Aspose.Cells Namespace


Cells Methods

The methods of the Cells class are listed below. For a complete list of Cells class members, see the Cells Members topic.

Public Instance Methods

AddRange | Adds a range object reference to cells
ApplyColumnStyle | Applies formats for a whole column.
ApplyRowStyle | Applies formats for a whole row.
ApplyStyle | Applies formats for a whole worksheet.
CheckCell | Gets the Cell element or null at the specified cell row index and column index.
CheckColumn | Gets the Column element or null at the specified column index.
CheckRow | Gets the Row element or at the specified cell row index.
Clear | Clears all cell and row objects.
ClearContents | Overloaded. Clears contents of a range.
ClearFormats | Overloaded. Clears formatting of a range.
ClearRange | Overloaded. Clears contents and formatting of a range.
ConvertStringToNumericValue | Converts string data in cells to numeric value if possible.
CopyColumn | Copies data and formats of a whole column.
CopyColumns | Overloaded. Copies data and formats of a whole column.
CopyRow | Copies data and formats of a whole row.
CopyRows | Overloaded. Copies data and formats of some whole rows.
CreateRange | Overloaded. Creates a Range object from a range of cells.
DeleteBlankColumns | Overloaded. Delete all blank columns which do not contain any data.
DeleteBlankRows | Overloaded. Delete all blank rows which do not contain any data.
DeleteColumn | Overloaded. Deletes a column.
DeleteColumns | Deletes several columns.
DeleteRange | Deletes a range of cells and shift cells according to the shift option.
DeleteRow | Deletes a row.
DeleteRows | Overloaded. Deletes several rows.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
EndCellInColumn | Overloaded. Gets the last cell in this column.
EndCellInRow | Overloaded. Gets the last cell in this row.
Equals (inherited from Object) |
ExportArray | Exports data in the Cells collection to a two-dimension array object.
ExportDataTable | Overloaded. Exports data in the Cells collection to a DataTable object.
ExportDataTableAsString | Overloaded. Exports data in the Cells collection to a DataTable object.
ExportTypeArray | Exports cell value type in the Cells collection to a two-dimension array object.
Find | Overloaded. Finds the cell containing with the input object.
FindFormula | Obsolete. Finds the cell with the input string.
FindFormulaContains | Obsolete. Finds the cell with formula which contains the input string.
GetCell | Gets the Cell element or null at the specified cell row index and column index.
GetCellStyle | Get the style of given cell.
GetColumnWidth | Gets the width of the specified column in normal view
GetColumnWidthInch | Gets the width of the specified column in normal view, in units of inches.
GetColumnWidthPixel | Gets the width of the specified column in normal view, in units of pixel.
GetDependents | Get all cells which refer to the specific cell.
GetEnumerator | Gets the cells enumerator.
GetGroupedColumnOutlineLevel | Gets the outline level (zero-based) of the column.
GetGroupedRowOutlineLevel | Gets the outline level (zero-based) of the row.
GetHashCode (inherited from Object) |
GetLastDataRow | Gets the last row index of cell which contains data in the specified column.
GetMaxGroupedColumnOutlineLevel | Gets the max grouped column outline level (zero-based).
GetMaxGroupedRowOutlineLevel | Gets the max grouped row outline level (zero-based).
GetRow | Gets the Row element at the specified cell row index.
GetRowEnumerator | Gets the rows enumerator.
GetRowHeight | Gets the height of a specified row.
GetRowHeightInch | Gets the height of a specified row in unit of inches.
GetRowHeightPixel | Gets the height of a specified row in unit of pixel.
GetType (inherited from Object) |
GetViewColumnWidthPixel | Get the width in different view type.
GetViewRowHeight | Gets the height of a specified row.
GetViewRowHeightInch | Gets the height of a specified row in unit of inches.
GroupColumns | Overloaded. Groups columns.
GroupRows | Overloaded. Groups rows.
HideColumn | Hides a column.
HideColumns | Hide multiple columns.
HideGroupDetail | Collapses the grouped rows/columns.
HideRow | Hides a row.
HideRows | Hides multiple rows.
Import | Obsolete. Import data from data view.
ImportArray | Overloaded. Imports a two-dimension array of string into a worksheet.
ImportArrayList | Imports an arraylist of data into a worksheet.
ImportCSV | Overloaded. Import a CSV file to the cells.
ImportCustomObjects | Overloaded. Imports custom objects.
ImportData | Overloaded. Import data from custom data table.
ImportDataGrid | Overloaded. Imports a DataGrid into a worksheet.
ImportDataGridAsString | Imports a DataGrid into a worksheet. This method doesn't try to convert text into numeric values.
ImportDataReader | Overloaded. Imports data from a SqlDataReader object.
ImportDataRow | Imports a DataRow into the Excel file.
ImportDataTable | Overloaded. Imports a DataTable object into a worksheet.
ImportDataView | Overloaded. Imports a DataView into a worksheet.
ImportFormulaArray | Imports an array of formula into a worksheet.
ImportFromDataReader | Overloaded. Imports data from a SqlDataReader object.
ImportGridView | Imports a grid view to this cells.
ImportObjectArray | Overloaded. Imports an array of data into a worksheet.
ImportTwoDimensionArray | Overloaded. Imports a two-dimension array of data into a worksheet.
InsertColumn | Overloaded. Inserts a new column into the worksheet.
InsertColumns | Overloaded. Inserts some columns into the worksheet.
InsertCutCells | Insert cut range.
InsertRange | Overloaded. Inserts a range of cells and shift cells according to the shift option.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Overloaded. Inserts multiple rows into the worksheet.
IsBlankColumn | Checks whether given column is blank(does not contain any data).
IsColumnHidden | Checks whether a column at given index is hidden.
IsDeletingRangeEnabled | Check whether the range could be deleted.
IsRowHidden | Checks whether a row at given index is hidden.
LinkToXmlMap | Link to a xml map.
Merge | Overloaded. Merges a specified range of cells into a single cell.
MoveRange | Moves the range.
RemoveDuplicates | Overloaded. Removes duplicate rows in the sheet.
RemoveFormulas | Removes all formula and replaces with the value of the formula.
RetrieveSubtotalSetting | Retrieves subtotals setting of the range.
SetColumnWidth | Sets the width of the specified column in normal view.
SetColumnWidthInch | Sets column width in unit of inches in normal view.
SetColumnWidthPixel | Sets column width in unit of pixels in normal view.
SetRowHeight | Sets the height of the specified row.
SetRowHeightInch | Sets row height in unit of inches.
SetRowHeightPixel | Sets row height in unit of pixels.
SetViewColumnWidthPixel | Sets the width of the column in different view.
ShowGroupDetail | Uncollapses the grouped rows/columns.
Subtotal | Overloaded. Creates subtotals for the range.
TextToColumns | Splits the text in the column to columns.
ToString (inherited from Object) |
UngroupColumns | Ungroups columns.
UngroupRows | Overloaded. Ungroups rows.
UnhideColumn | Unhides a column
UnhideColumns | Unhide multiple columns.
UnhideRow | Unhides a row.
UnhideRows | Unhides the hidden rows.
UnMerge | Unmerges a specified range of merged cells.

See Also

Cells Class | Aspose.Cells Namespace


Cells.AddRange Method

Adds a range object reference to cells

public void AddRange(
Range rangeObject
);

Parameters

rangeObject
The range object will be contained in the cells

See Also

Cells Class | Aspose.Cells Namespace


Cells.ApplyColumnStyle Method

Applies formats for a whole column.

public void ApplyColumnStyle(
int column,
Style style,
StyleFlag flag
);

Parameters

column
The column index.
style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

See Also

Cells Class | Aspose.Cells Namespace


Cells.ApplyRowStyle Method

Applies formats for a whole row.

public void ApplyRowStyle(
int row,
Style style,
StyleFlag flag
);

Parameters

row
The row index.
style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

See Also

Cells Class | Aspose.Cells Namespace


Cells.ApplyStyle Method

Applies formats for a whole worksheet.

public void ApplyStyle(
Style style,
StyleFlag flag
);

Parameters

style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

See Also

Cells Class | Aspose.Cells Namespace


Cells.CheckCell Method

Gets the Cell element or null at the specified cell row index and column index.

public Cell CheckCell(
int row,
int column
);

Parameters

row
Row index
column
Column index

Return Value

Return Cell object if a Cell object exists. Return null if the cell does not exist.

See Also

Cells Class | Aspose.Cells Namespace


Cells.CheckColumn Method

Gets the Column element or null at the specified column index.

public Column CheckColumn(
int columnIndex
);

Parameters

columnIndex
The column index.

Return Value

The Column object.

See Also

Cells Class | Aspose.Cells Namespace


Cells.CheckRow Method

Gets the Row element or at the specified cell row index.

public Row CheckRow(
int row
);

Parameters

row
Row index

Return Value

If the row object does exist return Row object, otherwise return null.

See Also

Cells Class | Aspose.Cells Namespace


Cells.Clear Method

Clears all cell and row objects.

public void Clear();

See Also

Cells Class | Aspose.Cells Namespace


ClearContents Method

Aspose.Cells for .NET

Cells.ClearContents Method

Clears contents of a range.

Overload List

Clears contents of a range.

public void ClearContents(CellArea);

Clears contents of a range.

public void ClearContents(int,int,int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ClearContents Method (CellArea)

Clears contents of a range.

public void ClearContents(
CellArea range
);

Parameters

range
Range to be cleared.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ClearContents Overload List


Cells.ClearContents Method (Int32, Int32, Int32, Int32)

Clears contents of a range.

public void ClearContents(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ClearContents Overload List


ClearFormats Method

Aspose.Cells for .NET

Cells.ClearFormats Method

Clears formatting of a range.

Overload List

Clears formatting of a range.

public void ClearFormats(CellArea);

Clears formatting of a range.

public void ClearFormats(int,int,int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ClearFormats Method (CellArea)

Clears formatting of a range.

public void ClearFormats(
CellArea range
);

Parameters

range
Range to be cleared.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ClearFormats Overload List


Cells.ClearFormats Method (Int32, Int32, Int32, Int32)

Clears formatting of a range.

public void ClearFormats(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ClearFormats Overload List


ClearRange Method

Aspose.Cells for .NET

Cells.ClearRange Method

Clears contents and formatting of a range.

Overload List

Clears contents and formatting of a range.

public void ClearRange(CellArea);

Clears contents and formatting of a range.

public void ClearRange(int,int,int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ClearRange Method (CellArea)

Clears contents and formatting of a range.

public void ClearRange(
CellArea range
);

Parameters

range
Range to be cleared.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ClearRange Overload List


Cells.ClearRange Method (Int32, Int32, Int32, Int32)

Clears contents and formatting of a range.

public void ClearRange(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ClearRange Overload List


Cells.ConvertStringToNumericValue Method

Converts string data in cells to numeric value if possible.

public void ConvertStringToNumericValue();

See Also

Cells Class | Aspose.Cells Namespace


Cells.CopyColumn Method

Copies data and formats of a whole column.

public void CopyColumn(
Cells sourceCells,
int sourceColumnIndex,
int destinationColumnIndex
);

Parameters

sourceCells
Source Cells object contains data and formats to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.

See Also

Cells Class | Aspose.Cells Namespace


CopyColumns Method

Aspose.Cells for .NET

Cells.CopyColumns Method

Copies data and formats of a whole column.

Overload List

Copies data and formats of a whole column.

public void CopyColumns(Cells,int,int,int);

Copies data and formats of a whole column.

public void CopyColumns(Cells,int,int,int,PasteOptions);

Copies data and formats of the whole columns.

public void CopyColumns(Cells,int,int,int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.CopyColumns Method (Cells, Int32, Int32, Int32)

Copies data and formats of a whole column.

public void CopyColumns(
Cells sourceCells0,
int sourceColumnIndex,
int destinationColumnIndex,
int columnNumber
);

Parameters

sourceCells0
Source Cells object contains data and formats to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.
columnNumber
The copied column number.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CopyColumns Overload List


Cells.CopyColumns Method (Cells, Int32, Int32, Int32, PasteOptions)

Copies data and formats of a whole column.

public void CopyColumns(
Cells sourceCells0,
int sourceColumnIndex,
int destinationColumnIndex,
int columnNumber,
PasteOptions pasteOptions
);

Parameters

sourceCells0
Source Cells object contains data and formats to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.
columnNumber
The copied column number.
pasteOptions
the options of pasting.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CopyColumns Overload List


Cells.CopyColumns Method (Cells, Int32, Int32, Int32, Int32)

Copies data and formats of the whole columns.

public void CopyColumns(
Cells sourceCells,
int sourceColumnIndex,
int sourceTotalColumns,
int destinationColumnIndex,
int destinationTotalColumns
);

Parameters

sourceCells
Source Cells object contains data and formats to copy.
sourceColumnIndex
Source column index.
sourceTotalColumns
The number of the source columns.
destinationColumnIndex
Destination column index.
destinationTotalColumns
The number of the destination columns.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CopyColumns Overload List


Cells.CopyRow Method

Copies data and formats of a whole row.

public void CopyRow(
Cells sourceCells,
int sourceRowIndex,
int destinationRowIndex
);

Parameters

sourceCells
Source Cells object contains data and formats to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.

See Also

Cells Class | Aspose.Cells Namespace


CopyRows Method

Aspose.Cells for .NET

Cells.CopyRows Method

Copies data and formats of some whole rows.

Overload List

Copies data and formats of some whole rows.

public void CopyRows(Cells,int,int,int);

Copies data and formats of some whole rows.

public void CopyRows(Cells,int,int,int,CopyOptions);

Copies data and formats of some whole rows.

public void CopyRows(Cells,int,int,int,CopyOptions,PasteOptions);

See Also

Cells Class | Aspose.Cells Namespace


Cells.CopyRows Method (Cells, Int32, Int32, Int32)

Copies data and formats of some whole rows.

public void CopyRows(
Cells sourceCells,
int sourceRowIndex,
int destinationRowIndex,
int rowNumber
);

Parameters

sourceCells
Source Cells object contains data and formats to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.
rowNumber
The copied row number.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CopyRows Overload List


Cells.CopyRows Method (Cells, Int32, Int32, Int32, CopyOptions)

Copies data and formats of some whole rows.

public void CopyRows(
Cells sourceCells0,
int sourceRowIndex,
int destinationRowIndex,
int rowNumber,
CopyOptions copyOptions
);

Parameters

sourceCells0
Source Cells object contains data and formats to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.
rowNumber
The copied row number.
copyOptions
The copy options.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CopyRows Overload List


Cells.CopyRows Method (Cells, Int32, Int32, Int32, CopyOptions, PasteOptions)

Copies data and formats of some whole rows.

public void CopyRows(
Cells sourceCells0,
int sourceRowIndex,
int destinationRowIndex,
int rowNumber,
CopyOptions copyOptions,
PasteOptions pasteOptions
);

Parameters

sourceCells0
Source Cells object contains data and formats to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.
rowNumber
The copied row number.
copyOptions
The copy options.
pasteOptions
the options of pasting.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CopyRows Overload List


CreateRange Method

Aspose.Cells for .NET

Cells.CreateRange Method

Creates a Range object from rows of cells or columns of cells.

Overload List

Creates a Range object from rows of cells or columns of cells.

public Range CreateRange(int,int,bool);

Creates a Range object from a range of cells.

public Range CreateRange(int,int,int,int);

Creates a Range object from an address of the range.

public Range CreateRange(string);

Creates a Range object from a range of cells.

public Range CreateRange(string,string);

See Also

Cells Class | Aspose.Cells Namespace


Cells.CreateRange Method (Int32, Int32, Boolean)

Creates a Range object from rows of cells or columns of cells.

public Range CreateRange(
int firstIndex,
int number,
bool isVertical
);

Parameters

firstIndex
First row index or first column index, zero based.
number
Total number of rows or columns, one based.
isVertical
True - Range created from columns of cells. False - Range created from rows of cells.

Return Value

A Range object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.CreateRange Overload List


Cells.CreateRange Method (Int32, Int32, Int32, Int32)

Creates a Range object from a range of cells.

public Range CreateRange(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range
firstColumn
First column of this range
totalRows
Number of rows
totalColumns
Number of columns

Return Value

A Range object

See Also

Cells Class | Aspose.Cells Namespace | Cells.CreateRange Overload List


Cells.CreateRange Method (String)

Creates a Range object from an address of the range.

public Range CreateRange(
string address
);

Parameters

address
The address of the range.

Return Value

A Range object

See Also

Cells Class | Aspose.Cells Namespace | Cells.CreateRange Overload List


Cells.CreateRange Method (String, String)

Creates a Range object from a range of cells.

public Range CreateRange(
string upperLeftCell,
string lowerRightCell
);

Parameters

upperLeftCell
Upper left cell name.
lowerRightCell
Lower right cell name.

Return Value

A Range object

See Also

Cells Class | Aspose.Cells Namespace | Cells.CreateRange Overload List


DeleteBlankColumns Method

Aspose.Cells for .NET

Cells.DeleteBlankColumns Method

Delete all blank columns which do not contain any data.

Overload List

Delete all blank columns which do not contain any data.

public void DeleteBlankColumns();

Delete all blank columns which do not contain any data.

public void DeleteBlankColumns(DeleteOptions);

See Also

Cells Class | Aspose.Cells Namespace


Cells.DeleteBlankColumns Method ()

Delete all blank columns which do not contain any data.

public void DeleteBlankColumns();

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteBlankColumns Overload List


Cells.DeleteBlankColumns Method (DeleteOptions)

Delete all blank columns which do not contain any data.

public void DeleteBlankColumns(
DeleteOptions options
);

Parameters

options
The options of deleting range.

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteBlankColumns Overload List


DeleteBlankRows Method

Aspose.Cells for .NET

Cells.DeleteBlankRows Method

Delete all blank rows which do not contain any data.

Overload List

Delete all blank rows which do not contain any data.

public void DeleteBlankRows();

Delete all blank rows which do not contain any data.

public void DeleteBlankRows(DeleteOptions);

See Also

Cells Class | Aspose.Cells Namespace


Cells.DeleteBlankRows Method ()

Delete all blank rows which do not contain any data.

public void DeleteBlankRows();

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteBlankRows Overload List


Cells.DeleteBlankRows Method (DeleteOptions)

Delete all blank rows which do not contain any data.

public void DeleteBlankRows(
DeleteOptions options
);

Parameters

options
The options of deleting range.

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteBlankRows Overload List


DeleteColumn Method

Aspose.Cells for .NET

Cells.DeleteColumn Method

Deletes a column.

Overload List

Deletes a column.

public void DeleteColumn(int);

Deletes a column.

public void DeleteColumn(int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.DeleteColumn Method (Int32)

Deletes a column.

public void DeleteColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteColumn Overload List


Cells.DeleteColumn Method (Int32, Boolean)

Deletes a column.

public void DeleteColumn(
int columnIndex,
bool updateReference
);

Parameters

columnIndex
Column index.
updateReference
Indicates if update references in other worksheets.

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteColumn Overload List


Cells.DeleteColumns Method

Deletes several columns.

public void DeleteColumns(
int columnIndex,
int totalColumns,
bool updateReference
);

Parameters

columnIndex
Column index.
totalColumns
Number of columns to be deleted.
updateReference
Indicates if update references in other worksheets.

See Also

Cells Class | Aspose.Cells Namespace


Cells.DeleteRange Method

Deletes a range of cells and shift cells according to the shift option.

public void DeleteRange(
int startRow,
int startColumn,
int endRow,
int endColumn,
ShiftType shiftType
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.
shiftType
Shift cells option.

See Also

Cells Class | Aspose.Cells Namespace


Cells.DeleteRow Method

Deletes a row.

public void DeleteRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

Cells Class | Aspose.Cells Namespace


DeleteRows Method

Aspose.Cells for .NET

Cells.DeleteRows Method

Deletes several rows.

Overload List

Deletes several rows.

public bool DeleteRows(int,int);

Deletes multiple rows in the worksheet.

public bool DeleteRows(int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.DeleteRows Method (Int32, Int32)

Deletes several rows.

public bool DeleteRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
The first row index to be deleted.
totalRows
Number of rows to be deleted.

Remarks

If the deleted range contains the top part(not whole) of the table(ListObject), the ranged could not be deleted and nothing will be done.It works as MS Excel.

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteRows Overload List


Cells.DeleteRows Method (Int32, Int32, Boolean)

Deletes multiple rows in the worksheet.

public bool DeleteRows(
int rowIndex,
int totalRows,
bool updateReference
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be deleted.
updateReference
Indicates if update references in other worksheets.

Return Value

See Also

Cells Class | Aspose.Cells Namespace | Cells.DeleteRows Overload List


Cells.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

Cells Class | Aspose.Cells Namespace


EndCellInColumn Method

Aspose.Cells for .NET

Cells.EndCellInColumn Method

Gets the last cell in this column.

Overload List

Gets the last cell in this column.

public Cell EndCellInColumn(short);

Gets the last cell with maximum column index in this range.

public Cell EndCellInColumn(int,int,short,short);

See Also

Cells Class | Aspose.Cells Namespace


Cells.EndCellInColumn Method (Int16)

Gets the last cell in this column.

public Cell EndCellInColumn(
short columnIndex
);

Parameters

columnIndex
Column index.

Return Value

Cell object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.EndCellInColumn Overload List


Cells.EndCellInColumn Method (Int32, Int32, Int16, Int16)

Gets the last cell with maximum column index in this range.

public Cell EndCellInColumn(
int startRow,
int endRow,
short startColumn,
short endColumn
);

Parameters

startRow
Start row index.
endRow
End row index.
startColumn
Start column index.
endColumn
End column index.

Return Value

Cell object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.EndCellInColumn Overload List


EndCellInRow Method

Aspose.Cells for .NET

Cells.EndCellInRow Method

Gets the last cell in this row.

Overload List

Gets the last cell in this row.

public Cell EndCellInRow(int);

Gets the last cell with maximum row index in this range.

public Cell EndCellInRow(int,int,int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.EndCellInRow Method (Int32)

Gets the last cell in this row.

public Cell EndCellInRow(
int rowIndex
);

Parameters

rowIndex
Row index.

Return Value

Cell object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.EndCellInRow Overload List


Cells.EndCellInRow Method (Int32, Int32, Int32, Int32)

Gets the last cell with maximum row index in this range.

public Cell EndCellInRow(
int startRow,
int endRow,
int startColumn,
int endColumn
);

Parameters

startRow
Start row index.
endRow
End row index.
startColumn
Start column index.
endColumn
End column index.

Return Value

Cell object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.EndCellInRow Overload List


Cells.ExportArray Method

Exports data in the Cells collection to a two-dimension array object.

public object[,] ExportArray(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be exported
totalColumns
Number of columns to be exported

Return Value

Exported cell value array object.

See Also

Cells Class | Aspose.Cells Namespace


ExportDataTable Method

Aspose.Cells for .NET

Cells.ExportDataTable Method

Exports data in the Cells collection to a DataTable object.

Overload List

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTable(int,int,int,int);

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTable(int,int,int,int,ExportTableOptions);

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTable(int,int,int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ExportDataTable Method (Int32, Int32, Int32, Int32)

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTable(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.

Return Value

Exported DataTable object.

Remarks

If you use this method to export a block of data, please be sure that the data in a column should be the same data type. Otherwise, use the ExportDataTableAsString method instead.

Example

[C#]

string designerFile = MapPath("Designer") + "\\List.xls";
Workbook excel = new Workbook(designerFile);
Worksheet sheet = excel.Worksheets[0];
DataTable dt = sheet.Cells.ExportDataTable(6, 1, 69, 4);
this.DataGrid1.DataSource = dt;
this.DataGrid1.DataBind();

[Visual Basic]

Dim designerFile As String = MapPath("Designer") + "\List.xls"
Dim excel As excel = New excel(designerFile)
Dim sheet As Worksheet = excel.Worksheets(0)
Dim dt As DataTable = sheet.Cells.ExportDataTable(6, 1, 69, 4)
Me.DataGrid1.DataSource = dt
Me.DataGrid1.DataBind()

See Also

Cells Class | Aspose.Cells Namespace | Cells.ExportDataTable Overload List


Cells.ExportDataTable Method (Int32, Int32, Int32, Int32, ExportTableOptions)

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTable(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
ExportTableOptions options
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
options
All export table options

Return Value

Exported DataTable object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ExportDataTable Overload List


Cells.ExportDataTable Method (Int32, Int32, Int32, Int32, Boolean)

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTable(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool exportColumnName
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
exportColumnName
Indicates whether the data in the first row are exported to the column name of the DataTable.

Return Value

Exported DataTable object.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ExportDataTable Overload List


ExportDataTableAsString Method

Aspose.Cells for .NET

Cells.ExportDataTableAsString Method

Exports data in the Cells collection to a DataTable object.

Overload List

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTableAsString(int,int,int,int);

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTableAsString(int,int,int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ExportDataTableAsString Method (Int32, Int32, Int32, Int32)

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTableAsString(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.

Return Value

Exported DataTable object.

Remarks

All data in the Cells collection are converted to strings.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ExportDataTableAsString Overload List


Cells.ExportDataTableAsString Method (Int32, Int32, Int32, Int32, Boolean)

Exports data in the Cells collection to a DataTable object.

public DataTable ExportDataTableAsString(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool exportColumnName
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
exportColumnName
Indicates whether the data in the first row are exported to the column name of the DataTable.

Return Value

Exported DataTable object.

Remarks

All data in the Cells collection are converted to strings.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ExportDataTableAsString Overload List


Cells.ExportTypeArray Method

Exports cell value type in the Cells collection to a two-dimension array object.

public CellValueType[,] ExportTypeArray(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be exported.
totalColumns
Number of columns to be exported.

Return Value

Exported CellValueType array object.

See Also

Cells Class | Aspose.Cells Namespace


Find Method

Aspose.Cells for .NET

Cells.Find Method

Finds the cell containing with the input object.

Overload List

Finds the cell containing with the input object.

public Cell Find(object,Cell);

Finds the cell containing with the input object.

public Cell Find(object,Cell,FindOptions);

See Also

Cells Class | Aspose.Cells Namespace


Cells.Find Method (Object, Cell)

Finds the cell containing with the input object.

public Cell Find(
object what,
Cell previousCell
);

Parameters

what
The object to search for. The type should be int,double,DateTime,string,bool.
previousCell
Previous cell with the same object. This parameter can be set to null if searching from the start.

Return Value

Cell object.

Remarks

Returns null (Nothing) if no cell is found.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Find Overload List


Cells.Find Method (Object, Cell, FindOptions)

Finds the cell containing with the input object.

public Cell Find(
object what,
Cell previousCell,
FindOptions findOptions
);

Parameters

what
The object to search for. The type should be int,double,DateTime,string,bool.
previousCell
Previous cell with the same object. This parameter can be set to null if searching from the start.
findOptions
Find options

Return Value

Cell object.

Remarks

Returns null (Nothing) if no cell is found.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Find Overload List


Cells.FindFormula Method

NOTE: This method is now obsolete.

Use Cells.Find(object,Cell,FindOptions) method instead.

Finds the cell with the input string.

public Cell FindFormula(
string formula,
Cell previousCell
);

Parameters

formula
The formula to search for.
previousCell
Previous cell with the same formula. This parameter can be set to null if searching from the start.

Return Value

Cell object.

Remarks

Returns null (Nothing) if no cell is found. NOTE: This member is now obsolete. Instead, please use Cells.Find(object,Cell,FindOptions) method with LookInType as LookInType.OnlyFormulas and LookAtType as LookAtType.EntireContent. This member will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace


Cells.FindFormulaContains Method

NOTE: This method is now obsolete.

Use Cells.Find(object,Cell,FindOptions) method instead.

Finds the cell with formula which contains the input string.

public Cell FindFormulaContains(
string formula,
Cell previousCell
);

Parameters

formula
The formula to search for.
previousCell
Previous cell with the same formula. This parameter can be set to null if searching from the start.

Return Value

Cell object.

Remarks

Returns null (Nothing) if no cell is found. NOTE: This member is now obsolete. Instead, please use Cells.Find(object,Cell,FindOptions) method with LookInType as LookInType.OnlyFormulas and LookAtType as LookAtType.Contains. This member will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetCell Method

Gets the Cell element or null at the specified cell row index and column index.

public Cell GetCell(
int row,
int column
);

Parameters

row
Row index
column
Column index

Return Value

Return Cell object if a Cell object exists. Return null if the cell does not exist.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetCellStyle Method

Get the style of given cell.

public Style GetCellStyle(
int row,
int column
);

Parameters

row
row index
column
column

Return Value

the style of given cell.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetColumnWidth Method

Gets the width of the specified column in normal view

public double GetColumnWidth(
int column
);

Parameters

column
Column index

Return Value

Width of column

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetColumnWidthInch Method

Gets the width of the specified column in normal view, in units of inches.

public double GetColumnWidthInch(
int column
);

Parameters

column
Column index

Return Value

Width of column

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetColumnWidthPixel Method

Gets the width of the specified column in normal view, in units of pixel.

public int GetColumnWidthPixel(
int column
);

Parameters

column
Column index

Return Value

Width of column in normal view.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetDependents Method

Get all cells which refer to the specific cell.

public Cell[] GetDependents(
bool isAll,
int row,
int column
);

Parameters

isAll
Indicates whether check other worksheets
row
The row index.
column
The column index.

Return Value

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetEnumerator Method

Gets the cells enumerator.

public IEnumerator GetEnumerator();

Return Value

The cells enumerator

Implements

IEnumerable.GetEnumerator

Remarks

When traversing elements by the returned Enumerator, the cells collection should not be modified(such as operations that will cause new Cell/Row be instantiated or existing Cell/Row be deleted). Otherwise the enumerator may not be able to traverse all cells correctly(some elements may be traversed repeatedly or skipped).

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetGroupedColumnOutlineLevel Method

Gets the outline level (zero-based) of the column.

public int GetGroupedColumnOutlineLevel(
int columnIndex
);

Parameters

columnIndex
The column index

Return Value

The outline level of the column

Remarks

If the column is not grouped, returns zero.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetGroupedRowOutlineLevel Method

Gets the outline level (zero-based) of the row.

public int GetGroupedRowOutlineLevel(
int rowIndex
);

Parameters

rowIndex
The row index.

Return Value

The outline level (zero-based) of the row.

Remarks

If the row is not grouped, returns zero.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetLastDataRow Method

Gets the last row index of cell which contains data in the specified column.

public int GetLastDataRow(
int column
);

Parameters

column
Column index.

Return Value

last row index.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetMaxGroupedColumnOutlineLevel Method

Gets the max grouped column outline level (zero-based).

public int GetMaxGroupedColumnOutlineLevel();

Return Value

The max grouped column outline level (zero-based)

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetMaxGroupedRowOutlineLevel Method

Gets the max grouped row outline level (zero-based).

public int GetMaxGroupedRowOutlineLevel();

Return Value

The max grouped row outline level (zero-based)

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetRow Method

Gets the Row element at the specified cell row index.

public Row GetRow(
int row
);

Parameters

row
Row index

Return Value

If the row object does exist return Row object, otherwise return null.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetRowEnumerator Method

Gets the rows enumerator.

public IEnumerator GetRowEnumerator();

Return Value

The rows enumerator.

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetRowHeight Method

Gets the height of a specified row.

public double GetRowHeight(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetRowHeightInch Method

Gets the height of a specified row in unit of inches.

public double GetRowHeightInch(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetRowHeightPixel Method

Gets the height of a specified row in unit of pixel.

public int GetRowHeightPixel(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetViewColumnWidthPixel Method

Get the width in different view type.

public int GetViewColumnWidthPixel(
int column
);

Parameters

column
The column index.

Return Value

the column width in unit of pixels

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetViewRowHeight Method

Gets the height of a specified row.

public double GetViewRowHeight(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

Cells Class | Aspose.Cells Namespace


Cells.GetViewRowHeightInch Method

Gets the height of a specified row in unit of inches.

public double GetViewRowHeightInch(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

Cells Class | Aspose.Cells Namespace


GroupColumns Method

Aspose.Cells for .NET

Cells.GroupColumns Method

Groups columns.

Overload List

Groups columns.

public void GroupColumns(int,int);

Groups columns.

public void GroupColumns(int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.GroupColumns Method (Int32, Int32)

Groups columns.

public void GroupColumns(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first column index to be grouped.
lastIndex
The last column index to be grouped.

See Also

Cells Class | Aspose.Cells Namespace | Cells.GroupColumns Overload List


Cells.GroupColumns Method (Int32, Int32, Boolean)

Groups columns.

public void GroupColumns(
int firstIndex,
int lastIndex,
bool isHidden
);

Parameters

firstIndex
The first column index to be grouped.
lastIndex
The last column index to be grouped.
isHidden
Specifies if the grouped columns are hidden.

See Also

Cells Class | Aspose.Cells Namespace | Cells.GroupColumns Overload List


GroupRows Method

Aspose.Cells for .NET

Cells.GroupRows Method

Groups rows.

Overload List

Groups rows.

public void GroupRows(int,int);

Groups rows.

public void GroupRows(int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.GroupRows Method (Int32, Int32)

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.

See Also

Cells Class | Aspose.Cells Namespace | Cells.GroupRows Overload List


Cells.GroupRows Method (Int32, Int32, Boolean)

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex,
bool isHidden
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.
isHidden
Specifies if the grouped columns are hidden.

See Also

Cells Class | Aspose.Cells Namespace | Cells.GroupRows Overload List


Cells.HideColumn Method

Hides a column.

public void HideColumn(
int column
);

Parameters

column
Column index.

See Also

Cells Class | Aspose.Cells Namespace


Cells.HideColumns Method

Hide multiple columns.

public void HideColumns(
int column,
int totalColumns
);

Parameters

column
Column index.
totalColumns
Column number.

See Also

Cells Class | Aspose.Cells Namespace


Cells.HideGroupDetail Method

Collapses the grouped rows/columns.

public void HideGroupDetail(
bool isVertical,
int index
);

Parameters

isVertical
True, collapse the grouped rows.
index
The row/column index

See Also

Cells Class | Aspose.Cells Namespace


Cells.HideRow Method

Hides a row.

public void HideRow(
int row
);

Parameters

row
Row index.

See Also

Cells Class | Aspose.Cells Namespace


Cells.HideRows Method

Hides multiple rows.

public void HideRows(
int row,
int totalRows
);

Parameters

row
The row index.
totalRows
The row number.

See Also

Cells Class | Aspose.Cells Namespace


Cells.Import Method

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader,int,int,ImportTableOptions) method, instead.

Import data from data view.

public int Import(
IDataReader dataReader,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

dataReader
The IDataReader object to be imported.
firstRow
First row index.
firstColumn
First column index.
options
The import options

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace


ImportArray Method

Aspose.Cells for .NET

Cells.ImportArray Method

Imports an array of double into a worksheet.

Overload List

Imports an array of double into a worksheet.

public void ImportArray(double[],int,int,bool);

Imports a two-dimension array of double into a worksheet.

public void ImportArray(double[,],int,int);

Imports an array of integer into a worksheet.

public void ImportArray(int[],int,int,bool);

Imports a two-dimension array of integer into a worksheet.

public void ImportArray(int[,],int,int);

Imports an array of string into a worksheet.

public void ImportArray(string[],int,int,bool);

Imports a two-dimension array of string into a worksheet.

public void ImportArray(string[,],int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportArray Method (Double[], Int32, Int32, Boolean)

Imports an array of double into a worksheet.

public void ImportArray(
double[] doubleArray,
int firstRow,
int firstColumn,
bool isVertical
);

Parameters

doubleArray
Double array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportArray Overload List


Cells.ImportArray Method (Double[,], Int32, Int32)

Imports a two-dimension array of double into a worksheet.

public void ImportArray(
double[,] doubleArray,
int firstRow,
int firstColumn
);

Parameters

doubleArray
Two-dimension double array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportArray Overload List


Cells.ImportArray Method (Int32[], Int32, Int32, Boolean)

Imports an array of integer into a worksheet.

public void ImportArray(
int[] intArray,
int firstRow,
int firstColumn,
bool isVertical
);

Parameters

intArray
Integer array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportArray Overload List


Cells.ImportArray Method (Int32[,], Int32, Int32)

Imports a two-dimension array of integer into a worksheet.

public void ImportArray(
int[,] intArray,
int firstRow,
int firstColumn
);

Parameters

intArray
Two-dimension integer array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportArray Overload List


Cells.ImportArray Method (String[], Int32, Int32, Boolean)

Imports an array of string into a worksheet.

public void ImportArray(
string[] stringArray,
int firstRow,
int firstColumn,
bool isVertical
);

Parameters

stringArray
String array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportArray Overload List


Cells.ImportArray Method (String[,], Int32, Int32)

Imports a two-dimension array of string into a worksheet.

public void ImportArray(
string[,] stringArray,
int firstRow,
int firstColumn
);

Parameters

stringArray
Two-dimension string array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportArray Overload List


Cells.ImportArrayList Method

Imports an arraylist of data into a worksheet.

public void ImportArrayList(
ArrayList arrayList,
int firstRow,
int firstColumn,
bool isVertical
);

Parameters

arrayList
Data arraylist.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.

See Also

Cells Class | Aspose.Cells Namespace


ImportCSV Method

Aspose.Cells for .NET

Cells.ImportCSV Method

Import a CSV file to the cells.

Overload List

Import a CSV file to the cells.

public void ImportCSV(Stream,TxtLoadOptions,int,int);

Import a CSV file to the cells.

public void ImportCSV(Stream,string,bool,int,int);

Import a CSV file to the cells.

public void ImportCSV(string,TxtLoadOptions,int,int);

Import a CSV file to the cells.

public void ImportCSV(string,string,bool,int,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportCSV Method (Stream, TxtLoadOptions, Int32, Int32)

Import a CSV file to the cells.

public void ImportCSV(
Stream stream,
TxtLoadOptions options,
int firstRow,
int firstColumn
);

Parameters

stream
The CSV file stream.
options
The load options for reading text file
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportCSV Overload List


Cells.ImportCSV Method (Stream, String, Boolean, Int32, Int32)

Import a CSV file to the cells.

public void ImportCSV(
Stream stream,
string splitter,
bool convertNumericData,
int firstRow,
int firstColumn
);

Parameters

stream
The CSV file stream.
splitter
The splitter
convertNumericData
Whether the string in text file is converted to numeric data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportCSV Overload List


Cells.ImportCSV Method (String, TxtLoadOptions, Int32, Int32)

Import a CSV file to the cells.

public void ImportCSV(
string fileName,
TxtLoadOptions options,
int firstRow,
int firstColumn
);

Parameters

fileName
The CSV file name.
options
The load options for reading text file
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportCSV Overload List


Cells.ImportCSV Method (String, String, Boolean, Int32, Int32)

Import a CSV file to the cells.

public void ImportCSV(
string fileName,
string splitter,
bool convertNumericData,
int firstRow,
int firstColumn
);

Parameters

fileName
The CSV file name.
splitter
The splitter
convertNumericData
Whether the string in text file is converted to numeric data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportCSV Overload List


ImportCustomObjects Method

Aspose.Cells for .NET

Cells.ImportCustomObjects Method

Imports custom objects.

Overload List

Imports custom objects.

public int ImportCustomObjects(ICollection,int,int,ImportTableOptions);

Imports custom objects.

public int ImportCustomObjects(ICollection,string[],bool,int,int,int,bool,string,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportCustomObjects Method (ICollection, Int32, Int32, ImportTableOptions)

Imports custom objects.

public int ImportCustomObjects(
ICollection list,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

list
The custom object
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
options
The import options.

Return Value

Total number of rows imported.

Remarks

The custom objects should be the same type.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportCustomObjects Overload List


Cells.ImportCustomObjects Method (ICollection, String[], Boolean, Int32, Int32, Int32, Boolean, String, Boolean)

Imports custom objects.

public int ImportCustomObjects(
ICollection list,
string[] propertyNames,
bool isPropertyNameShown,
int firstRow,
int firstColumn,
int rowNumber,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

list
The custom object
propertyNames
The property names.If it is null,we will import all properties of the object.
isPropertyNameShown
Indicates whether the property name will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
rowNumber
Number of rows to be imported.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

The custom objects should be the same type.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportCustomObjects Overload List


ImportData Method

Aspose.Cells for .NET

Cells.ImportData Method

Import data from custom data table.

Overload List

Import data from custom data table.

public int ImportData(ICellsDataTable,int,int,ImportTableOptions);

Import data from custom data table.

public int ImportData(DataTable,int,int,ImportTableOptions);

Import data from data view.

public int ImportData(DataView,int,int,ImportTableOptions);

Imports data from a IDataReader object.

public int ImportData(IDataReader,int,int);

Imports data from a IDataReader object.

public int ImportData(IDataReader,int,int,ImportTableOptions);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportData Method (ICellsDataTable, Int32, Int32, ImportTableOptions)

Import data from custom data table.

public int ImportData(
ICellsDataTable table,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

table
The custom data table.
firstRow
First row index.
firstColumn
First column index.
options
The import options

Return Value

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportData Overload List


Cells.ImportData Method (DataTable, Int32, Int32, ImportTableOptions)

Import data from custom data table.

public int ImportData(
DataTable table,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

table
The DataTable object to be imported.
firstRow
First row index.
firstColumn
First column index.
options
The import options

Return Value

Total number of rows imported.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportData Overload List


Cells.ImportData Method (DataView, Int32, Int32, ImportTableOptions)

Import data from data view.

public int ImportData(
DataView dataView,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

dataView
The DataView object to be imported.
firstRow
First row index.
firstColumn
First column index.
options
The import options

Return Value

Total number of rows imported.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportData Overload List


Cells.ImportData Method (IDataReader, Int32, Int32)

Imports data from a IDataReader object.

public int ImportData(
IDataReader reader,
int firstRow,
int firstColumn
);

Parameters

reader
The IDataReader object which contains data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

Return Value

Total number of rows imported.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportData Overload List


Cells.ImportData Method (IDataReader, Int32, Int32, ImportTableOptions)

Imports data from a IDataReader object.

public int ImportData(
IDataReader reader,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

reader
The IDataReader object which contains data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
options
The options of importing table.

Return Value

Total number of rows imported.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportData Overload List


ImportDataGrid Method

Aspose.Cells for .NET

Cells.ImportDataGrid Method

Imports a DataGrid into a worksheet.

Overload List

Imports a DataGrid into a worksheet.

public int ImportDataGrid(DataGrid,int,int,bool);

Imports a DataGrid into a worksheet.

public int ImportDataGrid(DataGrid,int,int,int,int,bool);

Imports a DataGrid into a worksheet.

public int ImportDataGrid(DataGrid,int,int,int,int,bool,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportDataGrid Method (DataGrid, Int32, Int32, Boolean)

Imports a DataGrid into a worksheet.

public int ImportDataGrid(
DataGrid dataGrid,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

dataGrid
The DataGrid object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataGrid Overload List


Cells.ImportDataGrid Method (DataGrid, Int32, Int32, Int32, Int32, Boolean)

Imports a DataGrid into a worksheet.

public int ImportDataGrid(
DataGrid dataGrid,
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool insertRows
);

Parameters

dataGrid
The DataGrid object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataGrid Overload List


Cells.ImportDataGrid Method (DataGrid, Int32, Int32, Int32, Int32, Boolean, Boolean)

Imports a DataGrid into a worksheet.

public int ImportDataGrid(
DataGrid dataGrid,
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool insertRows,
bool importStyle
);

Parameters

dataGrid
The DataGrid object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.
importStyle
Indicates whether importing the cell style.

Return Value

Total number of rows imported

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataGrid Overload List


Cells.ImportDataGridAsString Method

Imports a DataGrid into a worksheet. This method doesn't try to convert text into numeric values.

public int ImportDataGridAsString(
DataGrid dataGrid,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

dataGrid
The DataGrid object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

See Also

Cells Class | Aspose.Cells Namespace


ImportDataReader Method

Aspose.Cells for .NET

Cells.ImportDataReader Method

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a IDataReader object.

Overload List

Obsolete. Imports data from a IDataReader object.

public int ImportDataReader(IDataReader,bool,int,int,bool,string,bool);

Obsolete. Imports data from a OleDbDataReader object.

public int ImportDataReader(OleDbDataReader,bool,int,int,bool);

Obsolete. Imports data from a OleDbDataReader object.

public int ImportDataReader(OleDbDataReader,bool,int,int,bool,string,bool);

Obsolete. Imports data from a OleDbDataReader object.

public int ImportDataReader(OleDbDataReader,int,int,bool);

Obsolete. Imports data from a SqlDataReader object.

public int ImportDataReader(SqlDataReader,bool,int,int,bool);

Obsolete. Imports data from a SqlDataReader object.

public int ImportDataReader(SqlDataReader,bool,int,int,bool,string,bool);

Obsolete. Imports data from a SqlDataReader object.

public int ImportDataReader(SqlDataReader,int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportDataReader Method (IDataReader, Boolean, Int32, Int32, Boolean, String, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a IDataReader object.

public int ImportDataReader(
IDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

reader
The IDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataReader Method (OleDbDataReader, Boolean, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

public int ImportDataReader(
OleDbDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The OleDbDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataReader Method (OleDbDataReader, Boolean, Int32, Int32, Boolean, String, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

public int ImportDataReader(
OleDbDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

reader
The OleDbDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataReader Method (OleDbDataReader, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

public int ImportDataReader(
OleDbDataReader reader,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The OleDbDataReader object which contains data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataReader Method (SqlDataReader, Boolean, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a SqlDataReader object.

public int ImportDataReader(
SqlDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The SqlDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataReader Method (SqlDataReader, Boolean, Int32, Int32, Boolean, String, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a SqlDataReader object.

public int ImportDataReader(
SqlDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

reader
The SqlDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataReader Method (SqlDataReader, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a SqlDataReader object.

public int ImportDataReader(
SqlDataReader reader,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The SqlDataReader object which contains data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataReader Overload List


Cells.ImportDataRow Method

Imports a DataRow into the Excel file.

public void ImportDataRow(
DataRow dataRow,
int row,
int firstColumn
);

Parameters

dataRow
DataRow object.
row
Row index.
firstColumn
First column index.

See Also

Cells Class | Aspose.Cells Namespace


ImportDataTable Method

Aspose.Cells for .NET

Cells.ImportDataTable Method

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable object into a worksheet.

Overload List

Obsolete. Imports a DataTable object into a worksheet.

public int ImportDataTable(DataTable,bool,int,int);

Obsolete. Imports a DataTable object into a worksheet.

public int ImportDataTable(DataTable,bool,int,int,bool);

Obsolete. Imports a DataTable object into a worksheet.

public int ImportDataTable(DataTable,bool,int,int,bool,bool);

Obsolete. Imports a DataTable into a worksheet.

public int ImportDataTable(DataTable,bool,int,int,int,int);

Obsolete. Imports a DataTable into a worksheet.

public int ImportDataTable(DataTable,bool,int,int,int,int,bool);

Obsolete. Imports a DataTable into a worksheet.

public int ImportDataTable(DataTable,bool,int,int,int,int,bool,string);

Obsolete. Imports a DataTable into a worksheet.

public int ImportDataTable(DataTable,bool,int,int,int,int,bool,string,bool);

Obsolete. Imports a DataTable object into a worksheet.

public int ImportDataTable(DataTable,bool,string);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable object into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import.
firstColumn
The column number of the first cell to import.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable object into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import.
firstColumn
The column number of the first cell to import.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32, Boolean, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable object into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows,
bool convertStringToNumber
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import.
firstColumn
The column number of the first cell to import.
insertRows
Indicates whether extra rows are added to fit data.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32, Int32, Int32)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]

DataTable dt = new DataTable("Employee");
dt.Columns.Add("Employee_ID",typeof(Int32));
dt.Columns.Add("Employee_Name",typeof(string));
dt.Columns.Add("Gender",typeof(string));
DataRow dr = dt.NewRow();
dr[0] = 1;
dr[1] = "John Smith";
dr[2] = "Male";
dt.Rows.Add(dr);
dr = dt.NewRow();
dr[0] = 2;
dr[1] = "Mary Miller";
dr[2] = "Female";
dt.Rows.Add(dr);
cells.ImportDataTable(dt, true, 12, 12, 10, 10);

[Visual Basic]

Dim dt As DataTable =  New DataTable("Employee")
dt.Columns.Add("Employee_ID",Type.GetType(Int32))
dt.Columns.Add("Employee_Name",Type.GetType(String))
dt.Columns.Add("Gender",Type.GetType(String))
Dim dr As DataRow =  dt.NewRow()
dr(0) = 1
dr(1) = "John Smith"
dr(2) = "Male"
dt.Rows.Add(dr)
dr = dt.NewRow()
dr(0) = 2
dr(1) = "Mary Miller"
dr(2) = "Female"
dt.Rows.Add(dr)
cells.ImportDataTable(dt, True, 12, 12, 10, 10)

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
bool insertRows
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
rowNumber
Number of rows to be imported.
columnNumber
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32, Int32, Int32, Boolean, String)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
bool insertRows,
string dateFormatString
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
rowNumber
Number of rows to be imported.
columnNumber
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.

Return Value

Total number of rows imported.

Remarks

This method automatically format date time values. However, if the DateTable is very huge, this method may slow down the program. In this case, you'd better format the cell manually.NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, Int32, Int32, Int32, Int32, Boolean, String, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row. Default is true.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
rowNumber
Number of rows to be imported.
columnNumber
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

This method automatically format date time values. However, if the DateTable is very huge, this method may slow down the program. In this case, you'd better format the cell manually.NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


Cells.ImportDataTable Method (DataTable, Boolean, String)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead.

Imports a DataTable object into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
string startCell
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row.
startCell
The name of start cell to insert the DataTable, such as "A2".

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataTable,int,int,ImportTableOptions) method, instead. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataTable Overload List


ImportDataView Method

Aspose.Cells for .NET

Cells.ImportDataView Method

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

Imports a DataView into a worksheet.

Overload List

Obsolete. Imports a DataView into a worksheet.

public int ImportDataView(DataView,bool,int,int,bool);

Obsolete. Imports a DataView into a worksheet.

public int ImportDataView(DataView,bool,int,int,int,int,bool);

Obsolete. Imports a DataView into a worksheet.

public int ImportDataView(DataView,bool,int,int,int,int,bool,string);

Imports a DataView into a worksheet.

public int ImportDataView(DataView,int,int);

Obsolete.

public int ImportDataView(DataView,int,int,bool);

Obsolete. Imports a DataView into a worksheet.

public int ImportDataView(DataView,int,int,int,int);

Obsolete. Imports a DataView into a worksheet.

public int ImportDataView(DataView,int,int,int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportDataView Method (DataView, Boolean, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

Imports a DataView into a worksheet.

public int ImportDataView(
DataView dataView,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

dataView
The DataView object to be imported.
isFieldNameShown
Indicates whether the field name of the data view will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataView,int,int,ImportTableOptions) method. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportDataView Method (DataView, Boolean, Int32, Int32, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

Imports a DataView into a worksheet.

public int ImportDataView(
DataView dataView,
bool isFieldNameShown,
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool insertRows
);

Parameters

dataView
The DataView object to be imported.
isFieldNameShown
Indicates whether the field name of the data view will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataView,int,int,ImportTableOptions) method. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportDataView Method (DataView, Boolean, Int32, Int32, Int32, Int32, Boolean, String)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

Imports a DataView into a worksheet.

public int ImportDataView(
DataView dataView,
bool isFieldNameShown,
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
bool insertRows,
string numberFormatString
);

Parameters

dataView
The DataView object to be imported.
isFieldNameShown
Indicates whether the field name of the data view will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
rowNumber
Number of rows to be imported.
columnNumber
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.
numberFormatString
Number format string for cells.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataView,int,int,ImportTableOptions) method. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportDataView Method (DataView, Int32, Int32)

Imports a DataView into a worksheet.

public int ImportDataView(
DataView dataView,
int firstRow,
int firstColumn
);

Parameters

dataView
The DataView object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

Return Value

Total number of rows imported

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportDataView Method (DataView, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

public int ImportDataView(
DataView dataView,
int firstRow,
int firstColumn,
bool insertRows
);

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataView,int,int,ImportTableOptions) method. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportDataView Method (DataView, Int32, Int32, Int32, Int32)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

Imports a DataView into a worksheet.

public int ImportDataView(
DataView dataView,
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

dataView
The DataView object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataView,int,int,ImportTableOptions) method. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportDataView Method (DataView, Int32, Int32, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(DataView,int,int,ImportTableOptions) method instead.

Imports a DataView into a worksheet.

public int ImportDataView(
DataView dataView,
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool insertRows
);

Parameters

dataView
The DataView object to be imported.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
totalRows
Number of rows to be imported.
totalColumns
Number of columns to be imported.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(DataView,int,int,ImportTableOptions) method. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportDataView Overload List


Cells.ImportFormulaArray Method

Imports an array of formula into a worksheet.

public void ImportFormulaArray(
string[] stringArray,
int firstRow,
int firstColumn,
bool isVertical
);

Parameters

stringArray
Formula array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.

See Also

Cells Class | Aspose.Cells Namespace


ImportFromDataReader Method

Aspose.Cells for .NET

Cells.ImportFromDataReader Method

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

Overload List

Obsolete. Imports data from a OleDbDataReader object.

public int ImportFromDataReader(OleDbDataReader,bool,int,int,bool);

Obsolete. Imports data from a OleDbDataReader object.

public int ImportFromDataReader(OleDbDataReader,bool,int,int,bool,string,bool);

Obsolete. Imports data from a OleDbDataReader object.

public int ImportFromDataReader(OleDbDataReader,int,int,bool);

Obsolete. Imports data from a SqlDataReader object.

public int ImportFromDataReader(SqlDataReader,bool,int,int,bool);

Obsolete. Imports data from a SqlDataReader object.

public int ImportFromDataReader(SqlDataReader,bool,int,int,bool,string,bool);

Obsolete. Imports data from a SqlDataReader object.

public int ImportFromDataReader(SqlDataReader,int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportFromDataReader Method (OleDbDataReader, Boolean, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

public int ImportFromDataReader(
OleDbDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The OleDbDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportFromDataReader Overload List


Cells.ImportFromDataReader Method (OleDbDataReader, Boolean, Int32, Int32, Boolean, String, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

public int ImportFromDataReader(
OleDbDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

reader
The OleDbDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportFromDataReader Overload List


Cells.ImportFromDataReader Method (OleDbDataReader, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a OleDbDataReader object.

public int ImportFromDataReader(
OleDbDataReader reader,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The OleDbDataReader object which contains data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportFromDataReader Overload List


Cells.ImportFromDataReader Method (SqlDataReader, Boolean, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a SqlDataReader object.

public int ImportFromDataReader(
SqlDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The SqlDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportFromDataReader Overload List


Cells.ImportFromDataReader Method (SqlDataReader, Boolean, Int32, Int32, Boolean, String, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a SqlDataReader object.

public int ImportFromDataReader(
SqlDataReader reader,
bool isFieldNameShown,
int firstRow,
int firstColumn,
bool insertRows,
string dateFormatString,
bool convertStringToNumber
);

Parameters

reader
The SqlDataReader object which contains data.
isFieldNameShown
Indicates whether the field name of the data reader will be imported to the first row.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.
dateFormatString
Date format string for cells.
convertStringToNumber
Indicates if this method will try to convert string to number.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportFromDataReader Overload List


Cells.ImportFromDataReader Method (SqlDataReader, Int32, Int32, Boolean)

NOTE: This method is now obsolete.

Use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method, instead.

Imports data from a SqlDataReader object.

public int ImportFromDataReader(
SqlDataReader reader,
int firstRow,
int firstColumn,
bool insertRows
);

Parameters

reader
The SqlDataReader object which contains data.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
insertRows
Indicates whether extra rows are added to fit data.

Return Value

Total number of rows imported.

Remarks

NOTE: This member is now obsolete. Instead, please use Cells.ImportData(IDataReader, int, int,ImportTableOptions) method. This property will be removed 12 months later since December 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportFromDataReader Overload List


Cells.ImportGridView Method

Imports a grid view to this cells.

public int ImportGridView(
GridView gridView,
int firstRow,
int firstColumn,
ImportTableOptions options
);

Parameters

gridView
The grid view object.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
options
import options.

Return Value

The row number.

See Also

Cells Class | Aspose.Cells Namespace


ImportObjectArray Method

Aspose.Cells for .NET

Cells.ImportObjectArray Method

Imports an array of data into a worksheet.

Overload List

Imports an array of data into a worksheet.

public void ImportObjectArray(object[],int,int,bool);

Imports an array of data into a worksheet.

public void ImportObjectArray(object[],int,int,bool,int);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportObjectArray Method (Object[], Int32, Int32, Boolean)

Imports an array of data into a worksheet.

public void ImportObjectArray(
object[] objArray,
int firstRow,
int firstColumn,
bool isVertical
);

Parameters

objArray
Data array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportObjectArray Overload List


Cells.ImportObjectArray Method (Object[], Int32, Int32, Boolean, Int32)

Imports an array of data into a worksheet.

public void ImportObjectArray(
object[] objArray,
int firstRow,
int firstColumn,
bool isVertical,
int skip
);

Parameters

objArray
Data array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
isVertical
Specifies to import data vertically or horizontally.
skip
Skipped number of rows or columns.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportObjectArray Overload List


ImportTwoDimensionArray Method

Aspose.Cells for .NET

Cells.ImportTwoDimensionArray Method

Imports a two-dimension array of data into a worksheet.

Overload List

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(object[,],int,int);

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(object[,],int,int,bool);

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(object[,],object[,],int,int,TxtLoadOptions);

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(object[,],object[,],int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.ImportTwoDimensionArray Method (Object[,], Int32, Int32)

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(
object[,] objArray,
int firstRow,
int firstColumn
);

Parameters

objArray
Two-dimension data array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportTwoDimensionArray Overload List


Cells.ImportTwoDimensionArray Method (Object[,], Int32, Int32, Boolean)

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(
object[,] objArray,
int firstRow,
int firstColumn,
bool convertStringToNumber
);

Parameters

objArray
Two-dimension data array.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
convertStringToNumber
Indicates if this method will try to convert string to number.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportTwoDimensionArray Overload List


Cells.ImportTwoDimensionArray Method (Object[,], Object[,], Int32, Int32, TxtLoadOptions)

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(
object[,] objArray,
object[,] styles,
int firstRow,
int firstColumn,
TxtLoadOptions opts
);

Parameters

objArray
Two-dimension data array.
styles
Two-dimension data style.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
opts
Options for converting string values

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportTwoDimensionArray Overload List


Cells.ImportTwoDimensionArray Method (Object[,], Object[,], Int32, Int32, Boolean)

Imports a two-dimension array of data into a worksheet.

public void ImportTwoDimensionArray(
object[,] objArray,
object[,] styles,
int firstRow,
int firstColumn,
bool convertStringToNumber
);

Parameters

objArray
Two-dimension data array.
styles
Two-dimension data style.
firstRow
The row number of the first cell to import in.
firstColumn
The column number of the first cell to import in.
convertStringToNumber
Indicates if this method will try to convert string to number.

See Also

Cells Class | Aspose.Cells Namespace | Cells.ImportTwoDimensionArray Overload List


InsertColumn Method

Aspose.Cells for .NET

Cells.InsertColumn Method

Inserts a new column into the worksheet.

Overload List

Inserts a new column into the worksheet.

public void InsertColumn(int);

Inserts a new column into the worksheet.

public void InsertColumn(int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.InsertColumn Method (Int32)

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertColumn Overload List


Cells.InsertColumn Method (Int32, Boolean)

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex,
bool updateReference
);

Parameters

columnIndex
Column index.
updateReference
Indicates if references in other worksheets will be updated.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertColumn Overload List


InsertColumns Method

Aspose.Cells for .NET

Cells.InsertColumns Method

Inserts some columns into the worksheet.

Overload List

Inserts some columns into the worksheet.

public void InsertColumns(int,int);

Inserts some columns into the worksheet.

public void InsertColumns(int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.InsertColumns Method (Int32, Int32)

Inserts some columns into the worksheet.

public void InsertColumns(
int columnIndex,
int totalColumns
);

Parameters

columnIndex
Column index.
totalColumns
The number of columns.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertColumns Overload List


Cells.InsertColumns Method (Int32, Int32, Boolean)

Inserts some columns into the worksheet.

public void InsertColumns(
int columnIndex,
int totalColumns,
bool updateReference
);

Parameters

columnIndex
Column index.
totalColumns
The number of columns.
updateReference
Indicates if references in other worksheets will be updated.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertColumns Overload List


Cells.InsertCutCells Method

Insert cut range.

public void InsertCutCells(
Range cutRange,
int row,
int column,
ShiftType shiftType
);

Parameters

cutRange
The cut range.
row
The row.
column
The column.
shiftType
The shift type .

See Also

Cells Class | Aspose.Cells Namespace


InsertRange Method

Aspose.Cells for .NET

Cells.InsertRange Method

Inserts a range of cells and shift cells according to the shift option.

Overload List

Inserts a range of cells and shift cells according to the shift option.

public void InsertRange(CellArea,ShiftType);

Inserts a range of cells and shift cells according to the shift option.

public void InsertRange(CellArea,int,ShiftType);

Inserts a range of cells and shift cells according to the shift option.

public void InsertRange(CellArea,int,ShiftType,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.InsertRange Method (CellArea, ShiftType)

Inserts a range of cells and shift cells according to the shift option.

public void InsertRange(
CellArea area,
ShiftType shiftType
);

Parameters

area
Shift area.
shiftType
Shift cells option.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertRange Overload List


Cells.InsertRange Method (CellArea, Int32, ShiftType)

Inserts a range of cells and shift cells according to the shift option.

public void InsertRange(
CellArea area,
int shiftNumber,
ShiftType shiftType
);

Parameters

area
Shift area.
shiftNumber
Number of rows or columns to be inserted.
shiftType
Shift cells option.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertRange Overload List


Cells.InsertRange Method (CellArea, Int32, ShiftType, Boolean)

Inserts a range of cells and shift cells according to the shift option.

public void InsertRange(
CellArea area,
int shiftNumber,
ShiftType shiftType,
bool updateReference
);

Parameters

area
Shift area.
shiftNumber
Number of rows or columns to be inserted.
shiftType
Shift cells option.
updateReference
Indicates if update references in other worksheets.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertRange Overload List


Cells.InsertRow Method

Inserts a new row into the worksheet.

public void InsertRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

Cells Class | Aspose.Cells Namespace


InsertRows Method

Aspose.Cells for .NET

Cells.InsertRows Method

Inserts multiple rows into the worksheet.

Overload List

Inserts multiple rows into the worksheet.

public void InsertRows(int,int);

Inserts multiple rows into the worksheet.

public void InsertRows(int,int,InsertOptions);

Inserts multiple rows into the worksheet.

public void InsertRows(int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.InsertRows Method (Int32, Int32)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertRows Overload List


Cells.InsertRows Method (Int32, Int32, InsertOptions)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows,
InsertOptions options
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.
options
Indicates if references in other worksheets will be updated.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertRows Overload List


Cells.InsertRows Method (Int32, Int32, Boolean)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows,
bool updateReference
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.
updateReference
Indicates if references in other worksheets will be updated.

See Also

Cells Class | Aspose.Cells Namespace | Cells.InsertRows Overload List


Cells.IsBlankColumn Method

Checks whether given column is blank(does not contain any data).

public bool IsBlankColumn(
int columnIndex
);

Parameters

columnIndex
the column index

Return Value

true if given column does not contain any data

See Also

Cells Class | Aspose.Cells Namespace


Cells.IsColumnHidden Method

Checks whether a column at given index is hidden.

public bool IsColumnHidden(
int columnIndex
);

Parameters

columnIndex
column index

Return Value

true if the column is hidden.

See Also

Cells Class | Aspose.Cells Namespace


Cells.IsDeletingRangeEnabled Method

Check whether the range could be deleted.

public bool IsDeletingRangeEnabled(
int startRow,
int startColumn,
int totalRows,
int totalColumns
);

Parameters

startRow
The start row index of the range.
startColumn
The start column index of the range.
totalRows
The number of the rows in the range.
totalColumns
The number of the columns in the range.

Return Value

See Also

Cells Class | Aspose.Cells Namespace


Cells.IsRowHidden Method

Checks whether a row at given index is hidden.

public bool IsRowHidden(
int rowIndex
);

Parameters

rowIndex
row index

Return Value

true if the row is hidden

See Also

Cells Class | Aspose.Cells Namespace


Cells.LinkToXmlMap Method

Link to a xml map.

public void LinkToXmlMap(
string mapName,
int row,
int column,
string path
);

Parameters

mapName
name of xml map
row
row of the destination cell
column
column of the destination cell
path
path of xml element in xml map

See Also

Cells Class | Aspose.Cells Namespace


Merge Method

Aspose.Cells for .NET

Cells.Merge Method

Merges a specified range of cells into a single cell.

Overload List

Merges a specified range of cells into a single cell.

public void Merge(int,int,int,int);

Merges a specified range of cells into a single cell.

public void Merge(int,int,int,int,bool);

Merges a specified range of cells into a single cell.

public void Merge(int,int,int,int,bool,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.Merge Method (Int32, Int32, Int32, Int32)

Merges a specified range of cells into a single cell.

public void Merge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Merge Overload List


Cells.Merge Method (Int32, Int32, Int32, Int32, Boolean)

Merges a specified range of cells into a single cell.

public void Merge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool mergeConflict
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)
mergeConflict
Merge conflict merged ranges.

Remarks

Reference the merged cell via the address of the upper-left cell in the range. If mergeConflict is true and the merged range conflicts with other merged cells, other merged cells will be automatically removed.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Merge Overload List


Cells.Merge Method (Int32, Int32, Int32, Int32, Boolean, Boolean)

Merges a specified range of cells into a single cell.

public void Merge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
bool checkConflict,
bool mergeConflict
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)
checkConflict
Indicates whether check the merged cells intersects other merged cells
mergeConflict
Merge conflict merged ranges.

Remarks

Reference the merged cell via the address of the upper-left cell in the range. If mergeConflict is true and the merged range conflicts with other merged cells, other merged cells will be automatically removed.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Merge Overload List


Cells.MoveRange Method

Moves the range.

public void MoveRange(
CellArea sourceArea,
int destRow,
int destColumn
);

Parameters

sourceArea
The range which should be moved.
destRow
The dest row.
destColumn
The dest column.

See Also

Cells Class | Aspose.Cells Namespace


RemoveDuplicates Method

Aspose.Cells for .NET

Cells.RemoveDuplicates Method

Removes duplicate rows in the sheet.

Overload List

Removes duplicate rows in the sheet.

public void RemoveDuplicates();

Removes duplicate values in the range.

public void RemoveDuplicates(int,int,int,int);

Removes duplicate data of the range.

public void RemoveDuplicates(int,int,int,int,bool,int[]);

See Also

Cells Class | Aspose.Cells Namespace


Cells.RemoveDuplicates Method ()

Removes duplicate rows in the sheet.

public void RemoveDuplicates();

See Also

Cells Class | Aspose.Cells Namespace | Cells.RemoveDuplicates Overload List


Cells.RemoveDuplicates Method (Int32, Int32, Int32, Int32)

Removes duplicate values in the range.

public void RemoveDuplicates(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
The start row.
startColumn
The start column
endRow
The end row index.
endColumn
The end column index.

See Also

Cells Class | Aspose.Cells Namespace | Cells.RemoveDuplicates Overload List


Cells.RemoveDuplicates Method (Int32, Int32, Int32, Int32, Boolean, Int32[])

Removes duplicate data of the range.

public void RemoveDuplicates(
int startRow,
int startColumn,
int endRow,
int endColumn,
bool hasHeaders,
int[] columnOffsets
);

Parameters

startRow
The start row.
startColumn
The start column
endRow
The end row index.
endColumn
The end column index.
hasHeaders
Indicates whether the range contains headers.
columnOffsets
The column offsets.

See Also

Cells Class | Aspose.Cells Namespace | Cells.RemoveDuplicates Overload List


Cells.RemoveFormulas Method

Removes all formula and replaces with the value of the formula.

public void RemoveFormulas();

See Also

Cells Class | Aspose.Cells Namespace


Cells.RetrieveSubtotalSetting Method

Retrieves subtotals setting of the range.

public SubtotalSetting RetrieveSubtotalSetting(
CellArea ca
);

Parameters

ca
The range

Return Value

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetColumnWidth Method

Sets the width of the specified column in normal view.

public void SetColumnWidth(
int column,
double width
);

Parameters

column
Column index.
width
Width of column.Column width must be between 0 and 255.

Remarks

To hide a column, sets column width to zero.

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetColumnWidthInch Method

Sets column width in unit of inches in normal view.

public void SetColumnWidthInch(
int column,
double inches
);

Parameters

column
Column index.
inches
Number of inches.

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetColumnWidthPixel Method

Sets column width in unit of pixels in normal view.

public void SetColumnWidthPixel(
int column,
int pixels
);

Parameters

column
Column index.
pixels
Number of pixels.

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetRowHeight Method

Sets the height of the specified row.

public void SetRowHeight(
int row,
double height
);

Parameters

row
Row index.
height
Height of row.In unit of point It should be between 0 and 409.5.

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetRowHeightInch Method

Sets row height in unit of inches.

public void SetRowHeightInch(
int row,
double inches
);

Parameters

row
Row index.
inches
Number of inches. It should be between 0 and 409.5/72.

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetRowHeightPixel Method

Sets row height in unit of pixels.

public void SetRowHeightPixel(
int row,
int pixels
);

Parameters

row
Row index.
pixels
Number of pixels.

See Also

Cells Class | Aspose.Cells Namespace


Cells.SetViewColumnWidthPixel Method

Sets the width of the column in different view.

public void SetViewColumnWidthPixel(
int column,
int pixels
);

Parameters

column
The column index.
pixels
The width in unit of pixels.

See Also

Cells Class | Aspose.Cells Namespace


Cells.ShowGroupDetail Method

Uncollapses the grouped rows/columns.

public void ShowGroupDetail(
bool isVertical,
int index
);

Parameters

isVertical
True, uncollapses the grouped rows.
index
The row/column index

See Also

Cells Class | Aspose.Cells Namespace


Subtotal Method

Aspose.Cells for .NET

Cells.Subtotal Method

Creates subtotals for the range.

Overload List

Creates subtotals for the range.

public void Subtotal(CellArea,int,ConsolidationFunction,int[]);

Creates subtotals for the range.

public void Subtotal(CellArea,int,ConsolidationFunction,int[],bool,bool,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.Subtotal Method (CellArea, Int32, ConsolidationFunction, Int32[])

Creates subtotals for the range.

public void Subtotal(
CellArea ca,
int groupBy,
ConsolidationFunction function,
int[] totalList
);

Parameters

ca
The range
groupBy
The field to group by, as a zero-based integer offset
function
The subtotal function.
totalList
An array of zero-based field offsets, indicating the fields to which the subtotals are added.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Subtotal Overload List


Cells.Subtotal Method (CellArea, Int32, ConsolidationFunction, Int32[], Boolean, Boolean, Boolean)

Creates subtotals for the range.

public void Subtotal(
CellArea ca,
int groupBy,
ConsolidationFunction function,
int[] totalList,
bool replace,
bool pageBreaks,
bool summaryBelowData
);

Parameters

ca
The range
groupBy
The field to group by, as a zero-based integer offset
function
The subtotal function.
totalList
An array of zero-based field offsets, indicating the fields to which the subtotals are added.
replace
Indicates whether replace the current subtotals
pageBreaks
Indicates whether add page break between groups
summaryBelowData
Indicates whether add summary below data.

See Also

Cells Class | Aspose.Cells Namespace | Cells.Subtotal Overload List


Cells.TextToColumns Method

Splits the text in the column to columns.

public void TextToColumns(
int row,
int column,
int totalRows,
TxtLoadOptions options
);

Parameters

row
The row index.
column
The column index.
totalRows
The number of rows.
options
The split options.

See Also

Cells Class | Aspose.Cells Namespace


Cells.UngroupColumns Method

Ungroups columns.

public void UngroupColumns(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first column index to be ungrouped.
lastIndex
The last column index to be ungrouped.

See Also

Cells Class | Aspose.Cells Namespace


UngroupRows Method

Aspose.Cells for .NET

Cells.UngroupRows Method

Ungroups rows.

Overload List

Ungroups rows.

public void UngroupRows(int,int);

Ungroups rows.

public void UngroupRows(int,int,bool);

See Also

Cells Class | Aspose.Cells Namespace


Cells.UngroupRows Method (Int32, Int32)

Ungroups rows.

public void UngroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be ungrouped.
lastIndex
The last row index to be ungrouped.

Remarks

Only removes outer group info.

See Also

Cells Class | Aspose.Cells Namespace | Cells.UngroupRows Overload List


Cells.UngroupRows Method (Int32, Int32, Boolean)

Ungroups rows.

public void UngroupRows(
int firstIndex,
int lastIndex,
bool isAll
);

Parameters

firstIndex
The first row index to be ungrouped.
lastIndex
The last row index to be ungrouped.
isAll
True, removes all grouped info.Otherwise, remove the outer group info.

See Also

Cells Class | Aspose.Cells Namespace | Cells.UngroupRows Overload List


Cells.UnhideColumn Method

Unhides a column

public void UnhideColumn(
int column,
double width
);

Parameters

column
Column index.
width
Column width.

See Also

Cells Class | Aspose.Cells Namespace


Cells.UnhideColumns Method

Unhide multiple columns.

public void UnhideColumns(
int column,
int totalColumns,
double width
);

Parameters

column
Column index.
totalColumns
Column number
width
Column width.

Remarks

Only applies the column width to the hidden columns.

See Also

Cells Class | Aspose.Cells Namespace


Cells.UnhideRow Method

Unhides a row.

public void UnhideRow(
int row,
double height
);

Parameters

row
Row index.
height
Row height. The row's height will be changed only when the row is hidden and given height value is positive.

See Also

Cells Class | Aspose.Cells Namespace


Cells.UnhideRows Method

Unhides the hidden rows.

public void UnhideRows(
int row,
int totalRows,
double height
);

Parameters

row
The row index.
totalRows
The row number.
height
Row height. The row's height will be changed only when the row is hidden and given height value is positive.

See Also

Cells Class | Aspose.Cells Namespace


Cells.UnMerge Method

Unmerges a specified range of merged cells.

public void UnMerge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

See Also

Cells Class | Aspose.Cells Namespace


CellsColor Class

Represents all types of color.

For a list of all members of this type, see CellsColor Members.

System.Object
Aspose.Cells.CellsColor

public class CellsColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellsColor Members | Aspose.Cells Namespace


CellsColor Members

CellsColor overview

Public Instance Properties

Argb | Gets and sets the color from a 32-bit ARGB value.
Color | Gets and sets the RGB color.
ColorIndex | Gets and sets the color index in the color palette. Only applies of indexed color.
IsShapeColor | Gets and set the color which should apply to cell or shape.
ThemeColor | Gets the theme color. Only applies for theme color type.
Transparency | Gets and sets transparency as a value from 0.0 (opaque) through 1.0 (clear).
Type | The color type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetTintOfShapeColor | Set the tint of the shape color
ToString (inherited from Object) |

See Also

CellsColor Class | Aspose.Cells Namespace


CellsColor Properties

The properties of the CellsColor class are listed below. For a complete list of CellsColor class members, see the CellsColor Members topic.

Public Instance Properties

Argb | Gets and sets the color from a 32-bit ARGB value.
Color | Gets and sets the RGB color.
ColorIndex | Gets and sets the color index in the color palette. Only applies of indexed color.
IsShapeColor | Gets and set the color which should apply to cell or shape.
ThemeColor | Gets the theme color. Only applies for theme color type.
Transparency | Gets and sets transparency as a value from 0.0 (opaque) through 1.0 (clear).
Type | The color type.

See Also

CellsColor Class | Aspose.Cells Namespace


Argb Property

Aspose.Cells for .NET

CellsColor.Argb Property

Gets and sets the color from a 32-bit ARGB value.

public int Argb {get; set;}

See Also

CellsColor Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

CellsColor.Color Property

Gets and sets the RGB color.

public Color Color {get; set;}

See Also

CellsColor Class | Aspose.Cells Namespace


ColorIndex Property

Aspose.Cells for .NET

CellsColor.ColorIndex Property

Gets and sets the color index in the color palette. Only applies of indexed color.

public int ColorIndex {get; set;}

See Also

CellsColor Class | Aspose.Cells Namespace


IsShapeColor Property

Aspose.Cells for .NET

CellsColor.IsShapeColor Property

Gets and set the color which should apply to cell or shape.

public bool IsShapeColor {get; set;}

Remarks

The expression of the color of the cell and the shape is different. For example: the theme color with same tint value will be not same in the cell and the shape.

See Also

CellsColor Class | Aspose.Cells Namespace


ThemeColor Property

Aspose.Cells for .NET

CellsColor.ThemeColor Property

Gets the theme color. Only applies for theme color type.

public ThemeColor ThemeColor {get; set;}

See Also

CellsColor Class | Aspose.Cells Namespace


Transparency Property

Aspose.Cells for .NET

CellsColor.Transparency Property

Gets and sets transparency as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

CellsColor Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

CellsColor.Type Property

The color type.

public ColorType Type {get;}

See Also

CellsColor Class | Aspose.Cells Namespace


CellsColor Methods

The methods of the CellsColor class are listed below. For a complete list of CellsColor class members, see the CellsColor Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetTintOfShapeColor | Set the tint of the shape color
ToString (inherited from Object) |

See Also

CellsColor Class | Aspose.Cells Namespace


CellsColor.SetTintOfShapeColor Method

Set the tint of the shape color

public void SetTintOfShapeColor(
double tint
);

Parameters

tint

See Also

CellsColor Class | Aspose.Cells Namespace


CellsException Class

The exception that is thrown when Aspose.Cells specified error occurs.

For a list of all members of this type, see CellsException Members.

System.Object
System.Exception
System.ApplicationException
Aspose.Cells.CellsException

public class CellsException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellsException Members | Aspose.Cells Namespace


CellsException Members

CellsException overview

Public Instance Properties

Code | Represents custom exception code.
Data (inherited from Exception) |
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

See Also

CellsException Class | Aspose.Cells Namespace


CellsException Properties

The properties of the CellsException class are listed below. For a complete list of CellsException class members, see the CellsException Members topic.

Public Instance Properties

Code | Represents custom exception code.
Data (inherited from Exception) |
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

See Also

CellsException Class | Aspose.Cells Namespace


Code Property

Aspose.Cells for .NET

CellsException.Code Property

Represents custom exception code.

public ExceptionType Code {get;}

See Also

CellsException Class | Aspose.Cells Namespace


CellsFactory Class

Utility for instantiating classes of Cells model.

For a list of all members of this type, see CellsFactory Members.

System.Object
Aspose.Cells.CellsFactory

public class CellsFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellsFactory Members | Aspose.Cells Namespace


CellsFactory Members

CellsFactory overview

Public Instance Constructors

CellsFactory Constructor Initializes a new instance of the CellsFactory class.

Public Instance Methods

CreateStyle | Creates a new style.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

CellsFactory Class | Aspose.Cells Namespace


CellsFactory Constructor

Initializes a new instance of the CellsFactory class.

public CellsFactory();

See Also

CellsFactory Class | Aspose.Cells Namespace


CellsFactory Methods

The methods of the CellsFactory class are listed below. For a complete list of CellsFactory class members, see the CellsFactory Members topic.

Public Instance Methods

CreateStyle | Creates a new style.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

CellsFactory Class | Aspose.Cells Namespace


CellsFactory.CreateStyle Method

Creates a new style.

public Style CreateStyle();

Return Value

Returns a style object.

See Also

CellsFactory Class | Aspose.Cells Namespace


CellsHelper Class

Provides helper functions.

For a list of all members of this type, see CellsHelper Members.

System.Object
Aspose.Cells.CellsHelper

public class CellsHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellsHelper Members | Aspose.Cells Namespace


CellsHelper Members

CellsHelper overview

Public Static Properties

AltStartPath | Gets or sets the alternate startup path, which is referred to by some external formula references.
CustomImplementationFactory | Gets or sets the factory for creating instances with special implementation.
DPI | Gets the DPI of the machine.
FontDir | Obsolete. When generating PDF/XPS, specific font file directory can be set in the property. If it is not set , using %WINDOWS%\fonts by default.
FontDirs | Obsolete. When generating PDF/XPS, specific font file directories can be set in the property. If it is not set , using %WINDOWS%\fonts by default.
FontFiles | Obsolete. When generating PDF/XPS, specific font files can be set in the property. Such as "d:\myfonts\myArial.ttf"
LibraryPath | Gets or sets the library path which is referred to by some external formula references.
SignificantDigits | Gets and sets the number of significant digits. The default value is 17.
StartupPath | Gets or sets the startup path, which is referred to by some external formula references.

Public Static Methods

AddAddInFunction | Add addin function.
CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.
ConvertA1FormulaToR1C1 | Converts A1 formula of the cell to the r1c1 formula.
ConvertR1C1FormulaToA1 | Converts the r1c1 formula of the cell to A1 formula.
CreateSafeSheetName | Overloaded. Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with ' ', then return the rebuilt string value.
DetectFileFormat | Overloaded. Detects the file format type.
DetectLoadFormat | Overloaded. Detects the file load format.
GetDateTimeFromDouble | Convert the double value to the date time value.
GetDoubleFromDateTime | Convert the date time to double value.
GetTextWidth | Get width of text in unit of points.
GetUsedColors | Gets all used colors in the workbook.
GetVersion | Get the release version.
IsProtectedByRMS | Overloaded. Gets whether the file is protected by Microsoft Rights Management Server.
MergeFiles | Merges some large xls files to a xls file.
RowIndexToName | Gets row name according to row index.
RowNameToIndex | Gets row index according to row name.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper Properties

The properties of the CellsHelper class are listed below. For a complete list of CellsHelper class members, see the CellsHelper Members topic.

Public Static Properties

AltStartPath | Gets or sets the alternate startup path, which is referred to by some external formula references.
CustomImplementationFactory | Gets or sets the factory for creating instances with special implementation.
DPI | Gets the DPI of the machine.
FontDir | Obsolete. When generating PDF/XPS, specific font file directory can be set in the property. If it is not set , using %WINDOWS%\fonts by default.
FontDirs | Obsolete. When generating PDF/XPS, specific font file directories can be set in the property. If it is not set , using %WINDOWS%\fonts by default.
FontFiles | Obsolete. When generating PDF/XPS, specific font files can be set in the property. Such as "d:\myfonts\myArial.ttf"
LibraryPath | Gets or sets the library path which is referred to by some external formula references.
SignificantDigits | Gets and sets the number of significant digits. The default value is 17.
StartupPath | Gets or sets the startup path, which is referred to by some external formula references.

See Also

CellsHelper Class | Aspose.Cells Namespace


AltStartPath Property

Aspose.Cells for .NET

CellsHelper.AltStartPath Property

Gets or sets the alternate startup path, which is referred to by some external formula references.

public static string AltStartPath {get; set;}

See Also

CellsHelper Class | Aspose.Cells Namespace


CustomImplementationFactory Property

Aspose.Cells for .NET

CellsHelper.CustomImplementationFactory Property

Gets or sets the factory for creating instances with special implementation.

public static CustomImplementationFactory CustomImplementationFactory {get; set;}

See Also

CellsHelper Class | Aspose.Cells Namespace


DPI Property

Aspose.Cells for .NET

CellsHelper.DPI Property

Gets the DPI of the machine.

public static double DPI {get; set;}

Remarks

See Also

CellsHelper Class | Aspose.Cells Namespace


FontDir Property

Aspose.Cells for .NET

CellsHelper.FontDir Property

NOTE: This property is now obsolete.

Use FontConfigs.SetFontsFolder(string, bool) instead.

When generating PDF/XPS, specific font file directory can be set in the property. If it is not set , using %WINDOWS%\fonts by default.

public static string FontDir {get; set;}

Remarks

This member is now obsolete. Instead, please use SetFontFolder method with folder recursive to false. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace


FontDirs Property

Aspose.Cells for .NET

CellsHelper.FontDirs Property

NOTE: This property is now obsolete.

Use FontConfigs.SetFontFolders(string[], bool) instead.

When generating PDF/XPS, specific font file directories can be set in the property. If it is not set , using %WINDOWS%\fonts by default.

public static ArrayList FontDirs {get; set;}

Remarks

This member is now obsolete. Instead, please use SetFontFolders method with folder recursive to false. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace


FontFiles Property

Aspose.Cells for .NET

CellsHelper.FontFiles Property

NOTE: This property is now obsolete.

Use FontConfigs.SetFontSources(FontSourceBase[]) instead.

When generating PDF/XPS, specific font files can be set in the property. Such as "d:\myfonts\myArial.ttf"

public static ArrayList FontFiles {get; set;}

Remarks

This member is now obsolete. Instead, please use SetFontSources method. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace


LibraryPath Property

Aspose.Cells for .NET

CellsHelper.LibraryPath Property

Gets or sets the library path which is referred to by some external formula references.

public static string LibraryPath {get; set;}

See Also

CellsHelper Class | Aspose.Cells Namespace


SignificantDigits Property

Aspose.Cells for .NET

CellsHelper.SignificantDigits Property

Gets and sets the number of significant digits. The default value is 17.

public static int SignificantDigits {get; set;}

Remarks

Only could be 15 or 17 now.

See Also

CellsHelper Class | Aspose.Cells Namespace


StartupPath Property

Aspose.Cells for .NET

CellsHelper.StartupPath Property

Gets or sets the startup path, which is referred to by some external formula references.

public static string StartupPath {get; set;}

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper Methods

The methods of the CellsHelper class are listed below. For a complete list of CellsHelper class members, see the CellsHelper Members topic.

Public Static Methods

AddAddInFunction | Add addin function.
CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.
ConvertA1FormulaToR1C1 | Converts A1 formula of the cell to the r1c1 formula.
ConvertR1C1FormulaToA1 | Converts the r1c1 formula of the cell to A1 formula.
CreateSafeSheetName | Overloaded. Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with ' ', then return the rebuilt string value.
DetectFileFormat | Overloaded. Detects the file format type.
DetectLoadFormat | Overloaded. Detects the file load format.
GetDateTimeFromDouble | Convert the double value to the date time value.
GetDoubleFromDateTime | Convert the date time to double value.
GetTextWidth | Get width of text in unit of points.
GetUsedColors | Gets all used colors in the workbook.
GetVersion | Get the release version.
IsProtectedByRMS | Overloaded. Gets whether the file is protected by Microsoft Rights Management Server.
MergeFiles | Merges some large xls files to a xls file.
RowIndexToName | Gets row name according to row index.
RowNameToIndex | Gets row index according to row name.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.AddAddInFunction Method

Add addin function.

public static void AddAddInFunction(
string function,
int minCountOfParameters,
int maxCountOfParameters,
ParameterType[] paramersType,
ParameterType functionValueType
);

Parameters

function
The function name.
minCountOfParameters
Minimum number of parameters this function requires
maxCountOfParameters
Maximum number of parameters this function allows.
paramersType
The excepted parameters type of the function
functionValueType
The function value type.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.CellIndexToName Method

Gets cell name according to its row and column indexes.

public static string CellIndexToName(
int row,
int column
);

Parameters

row
Row index.
column
Column index.

Return Value

Name of cell.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.CellNameToIndex Method

public static void CellNameToIndex(
string cellName,
out int row,
out int column
);

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.ColumnIndexToName Method

Gets column name according to column index.

public static string ColumnIndexToName(
int column
);

Parameters

column
Column index.

Return Value

Name of column.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.ColumnNameToIndex Method

Gets column index according to column name.

public static int ColumnNameToIndex(
string columnName
);

Parameters

columnName
Column name.

Return Value

Column index.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.ConvertA1FormulaToR1C1 Method

Converts A1 formula of the cell to the r1c1 formula.

public static string ConvertA1FormulaToR1C1(
string formula,
int row,
int column
);

Parameters

formula
The A1 formula.
row
The row index of the cell.
column
The column index of the cell.

Return Value

The R1C1 formula.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.ConvertR1C1FormulaToA1 Method

Converts the r1c1 formula of the cell to A1 formula.

public static string ConvertR1C1FormulaToA1(
string r1c1Formula,
int row,
int column
);

Parameters

r1c1Formula
The r1c1 formula.
row
The row index of the cell.
column
The column index of the cell.

Return Value

The A1 formula.

See Also

CellsHelper Class | Aspose.Cells Namespace


CreateSafeSheetName Method

Aspose.Cells for .NET

CellsHelper.CreateSafeSheetName Method

Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with ' ', then return the rebuilt string value.

Overload List

Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with ' ', then return the rebuilt string value.

public static string CreateSafeSheetName(string);

Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with given character, then return the rebuilt string value.

public static string CreateSafeSheetName(string,char);

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.CreateSafeSheetName Method (String)

Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with ' ', then return the rebuilt string value.

public static string CreateSafeSheetName(
string nameProposal
);

Parameters

nameProposal
sheet name to be used

Return Value

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.CreateSafeSheetName Overload List


CellsHelper.CreateSafeSheetName Method (String, Char)

Checks given sheet name and create a valid one when needed. If given sheet name conforms to the rules of excel sheet name, then return it. Otherwise string will be truncated if length exceeds the limit and invalid characters will be replaced with given character, then return the rebuilt string value.

public static string CreateSafeSheetName(
string nameProposal,
char replaceChar
);

Parameters

nameProposal
sheet name to be used
replaceChar
character which will be used to replace invalid characters in given sheet name

Return Value

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.CreateSafeSheetName Overload List


DetectFileFormat Method

Aspose.Cells for .NET

CellsHelper.DetectFileFormat Method

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(Stream) instead.

Detects the format type of the file stored in the stream.

Overload List

Obsolete. Detects the format type of the file stored in the stream.

public static FileFormatType DetectFileFormat(Stream);

Obsolete. Detects the file format type.

public static FileFormatType DetectFileFormat(string);

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.DetectFileFormat Method (Stream)

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(Stream) instead.

Detects the format type of the file stored in the stream.

public static FileFormatType DetectFileFormat(
Stream stream
);

Parameters

stream
The stream

Return Value

The file format type.

Remarks

This member is now obsolete. Instead, please use DetectFileFormat property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.DetectFileFormat Overload List


CellsHelper.DetectFileFormat Method (String)

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(string) instead.

Detects the file format type.

public static FileFormatType DetectFileFormat(
string fileName
);

Parameters

fileName
the file name

Return Value

The file format type.

Remarks

This member is now obsolete. Instead, please use DetectFileFormat property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.DetectFileFormat Overload List


DetectLoadFormat Method

Aspose.Cells for .NET

CellsHelper.DetectLoadFormat Method

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(Stream) instead.

Detects the file load format.

Overload List

Obsolete. Detects the file load format.

public static LoadFormat DetectLoadFormat(Stream);

Obsolete. Detects the file load format.

public static LoadFormat DetectLoadFormat(string);

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.DetectLoadFormat Method (Stream)

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(Stream) instead.

Detects the file load format.

public static LoadFormat DetectLoadFormat(
Stream stream
);

Parameters

stream
The stream.

Return Value

Remarks

This member is now obsolete. Instead, please use DetectFileFormat property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.DetectLoadFormat Overload List


CellsHelper.DetectLoadFormat Method (String)

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(string) instead.

Detects the file load format.

public static LoadFormat DetectLoadFormat(
string fileName
);

Parameters

fileName
The file name.

Return Value

The load format.

Remarks

This member is now obsolete. Instead, please use DetectFileFormat property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.DetectLoadFormat Overload List


CellsHelper.GetDateTimeFromDouble Method

Convert the double value to the date time value.

public static DateTime GetDateTimeFromDouble(
double doubleValue,
bool date1904
);

Parameters

doubleValue
The double value.
date1904
Date 1904 system.

Return Value

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.GetDoubleFromDateTime Method

Convert the date time to double value.

public static double GetDoubleFromDateTime(
DateTime dateTime,
bool date1904
);

Parameters

dateTime
The date time.
date1904
Date 1904 system.

Return Value

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.GetTextWidth Method

Get width of text in unit of points.

public static double GetTextWidth(
string text,
Font font,
double scaling
);

Parameters

text
The text.
font
The font of the text.
scaling
The scaling of text.

Return Value

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.GetUsedColors Method

Gets all used colors in the workbook.

public static Color[] GetUsedColors(
Workbook workbook
);

Parameters

workbook
The workbook object.

Return Value

The used colors.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.GetVersion Method

Get the release version.

public static string GetVersion();

Return Value

The release version.

See Also

CellsHelper Class | Aspose.Cells Namespace


IsProtectedByRMS Method

Aspose.Cells for .NET

CellsHelper.IsProtectedByRMS Method

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(Stream).IsProtectedByRMS instead.

Gets whether the file is protected by Microsoft Rights Management Server.

Overload List

Obsolete. Gets whether the file is protected by Microsoft Rights Management Server.

public static bool IsProtectedByRMS(Stream);

Obsolete. Gets whether the file is protected by Microsoft Rights Management Server.

public static bool IsProtectedByRMS(string);

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.IsProtectedByRMS Method (Stream)

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(Stream).IsProtectedByRMS instead.

Gets whether the file is protected by Microsoft Rights Management Server.

public static bool IsProtectedByRMS(
Stream stream
);

Parameters

stream
The file stream.

Return Value

Remarks

This member is now obsolete. Instead, please use DetectFileFormat property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.IsProtectedByRMS Overload List


CellsHelper.IsProtectedByRMS Method (String)

NOTE: This method is now obsolete.

Use FileFormatUtil.DetectFileFormat(string) instead.

Gets whether the file is protected by Microsoft Rights Management Server.

public static bool IsProtectedByRMS(
string fileName
);

Parameters

fileName
The file name.

Return Value

Remarks

This member is now obsolete. Instead, please use DetectFileFormat property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

CellsHelper Class | Aspose.Cells Namespace | CellsHelper.IsProtectedByRMS Overload List


CellsHelper.MergeFiles Method

Merges some large xls files to a xls file.

public static void MergeFiles(
string[] files,
string cachedFile,
string destFile
);

Parameters

files
The files.
cachedFile
The cached file.
destFile
The dest file.

Remarks

This method only supports merging data, style and formulas to the new file. The cached file is used to store some temporary data.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.RowIndexToName Method

Gets row name according to row index.

public static string RowIndexToName(
int row
);

Parameters

row
Row index.

Return Value

Name of row.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellsHelper.RowNameToIndex Method

Gets row index according to row name.

public static int RowNameToIndex(
string rowName
);

Parameters

rowName
Row name.

Return Value

Row index.

See Also

CellsHelper Class | Aspose.Cells Namespace


CellValueFormatStrategy Enumeration

Specifies how to apply style for the value of the cell.

public enum CellValueFormatStrategy

Members

Member Name | Description | Value
None | Not formatted. | 0
CellStyle | Only formatted with the cell's original style. | 1
DisplayStyle | Formatted with the cell's displayed style. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CellValueType Enumeration

Specifies a cell value type.

public enum CellValueType

Members

Member Name | Description | Value
IsBool | Cell value is boolean. | 0
IsDateTime | Cell value is datetime. | 1
IsError | Cell contains error value | 2
IsNull | Blank cell. | 3
IsNumeric | Cell value is numeric. | 4
IsString | Cell value is string. | 5
IsUnknown | Cell value type is unknown. | 6

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CellWatch Class

Represents Cell Watch Item in the 'watch window'.

For a list of all members of this type, see CellWatch Members.

System.Object
Aspose.Cells.CellWatch

public class CellWatch

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellWatch Members | Aspose.Cells Namespace


CellWatch Members

CellWatch overview

Public Instance Constructors

CellWatch Constructor Initializes a new instance of the CellWatch class.

Public Instance Properties

CellName | Gets and sets the name of the cell.
Column | Gets and sets the column of the cell.
Row | Gets and sets the row of the cell.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellWatch Class | Aspose.Cells Namespace


CellWatch Constructor

Initializes a new instance of the CellWatch class.

public CellWatch();

See Also

CellWatch Class | Aspose.Cells Namespace


CellWatch Properties

The properties of the CellWatch class are listed below. For a complete list of CellWatch class members, see the CellWatch Members topic.

Public Instance Properties

CellName | Gets and sets the name of the cell.
Column | Gets and sets the column of the cell.
Row | Gets and sets the row of the cell.

See Also

CellWatch Class | Aspose.Cells Namespace


CellName Property

Aspose.Cells for .NET

CellWatch.CellName Property

Gets and sets the name of the cell.

public string CellName {get; set;}

See Also

CellWatch Class | Aspose.Cells Namespace


Column Property

Aspose.Cells for .NET

CellWatch.Column Property

Gets and sets the column of the cell.

public int Column {get; set;}

See Also

CellWatch Class | Aspose.Cells Namespace


Row Property

Aspose.Cells for .NET

CellWatch.Row Property

Gets and sets the row of the cell.

public int Row {get; set;}

See Also

CellWatch Class | Aspose.Cells Namespace


CellWatchCollection Class

Represents the collection of cells on this worksheet being watched in the 'watch window'.

For a list of all members of this type, see CellWatchCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.CellWatchCollection

public class CellWatchCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellWatchCollection Members | Aspose.Cells Namespace


CellWatchCollection Members

CellWatchCollection overview

Public Instance Constructors

CellWatchCollection Constructor Initializes a new instance of the CellWatchCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets and sets CellWatch by index.

Public Instance Methods

Add | Overloaded. Adds CellWatch with row and column.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CellWatchCollection Class | Aspose.Cells Namespace


CellWatchCollection Constructor

Initializes a new instance of the CellWatchCollection class.

public CellWatchCollection();

See Also

CellWatchCollection Class | Aspose.Cells Namespace


CellWatchCollection Properties

The properties of the CellWatchCollection class are listed below. For a complete list of CellWatchCollection class members, see the CellWatchCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets and sets CellWatch by index.

See Also

CellWatchCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

CellWatchCollection.Item Property

Gets and sets CellWatch by index.

Overload List

Gets and sets CellWatch by index.

public CellWatch this[int] {get;}

Gets and sets CellWatch by the name of the cell.

public CellWatch this[string] {get;}

See Also

CellWatchCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

CellWatchCollection.Item Property (Int32)

Gets and sets CellWatch by index.

public CellWatch this[
int index
] {get;}

Parameters

index
The index.

See Also

CellWatchCollection Class | Aspose.Cells Namespace | CellWatchCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

CellWatchCollection.Item Property (String)

Gets and sets CellWatch by the name of the cell.

public CellWatch this[
string cellName
] {get;}

Parameters

cellName
The name of the cell.

See Also

CellWatchCollection Class | Aspose.Cells Namespace | CellWatchCollection.Item Overload List


CellWatchCollection Methods

The methods of the CellWatchCollection class are listed below. For a complete list of CellWatchCollection class members, see the CellWatchCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds CellWatch with row and column.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CellWatchCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

CellWatchCollection.Add Method

Adds CellWatch with row and column.

Overload List

Adds CellWatch with row and column.

public int Add(int,int);

Adds

public int Add(string);

See Also

CellWatchCollection Class | Aspose.Cells Namespace


CellWatchCollection.Add Method (Int32, Int32)

Adds CellWatch with row and column.

public int Add(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

Returns the position of this item in the collection.

See Also

CellWatchCollection Class | Aspose.Cells Namespace | CellWatchCollection.Add Overload List


CellWatchCollection.Add Method (String)

Adds

public int Add(
string cellName
);

Parameters

cellName

Return Value

See Also

CellWatchCollection Class | Aspose.Cells Namespace | CellWatchCollection.Add Overload List


ColorFilter Class

Represents the color filter.

For a list of all members of this type, see ColorFilter Members.

System.Object
Aspose.Cells.ColorFilter

public class ColorFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ColorFilter Members | Aspose.Cells Namespace


ColorFilter Members

ColorFilter overview

Public Instance Properties

FilterByFillColor Flag indicating whether or not to filter by the cell's fill color.

Public Instance Methods

Equals (inherited from Object)
GetColor
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ColorFilter Class | Aspose.Cells Namespace


ColorFilter Properties

The properties of the ColorFilter class are listed below. For a complete list of ColorFilter class members, see the ColorFilter Members topic.

Public Instance Properties

FilterByFillColor Flag indicating whether or not to filter by the cell's fill color.

See Also

ColorFilter Class | Aspose.Cells Namespace


FilterByFillColor Property

Aspose.Cells for .NET

ColorFilter.FilterByFillColor Property

Flag indicating whether or not to filter by the cell's fill color.

public bool FilterByFillColor {get; set;}

See Also

ColorFilter Class | Aspose.Cells Namespace


ColorFilter Methods

The methods of the ColorFilter class are listed below. For a complete list of ColorFilter class members, see the ColorFilter Members topic.

Public Instance Methods

Equals (inherited from Object)
GetColor
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ColorFilter Class | Aspose.Cells Namespace


ColorFilter.GetColor Method

public Color GetColor(
WorksheetCollection sheets
);

Parameters

sheets

Return Value

See Also

ColorFilter Class | Aspose.Cells Namespace


ColorScale Class

Describe the ColorScale conditional formatting rule. This conditional formatting rule creates a gradated color scale on the cells.

For a list of all members of this type, see ColorScale Members.

System.Object
Aspose.Cells.ColorScale

public class ColorScale

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ColorScale Members | Aspose.Cells Namespace


ColorScale Members

ColorScale overview

Public Instance Properties

Is3ColorScale | Indicates whether conditional formatting is 3 color scale.
MaxCfvo | Get or set this ColorScale's max value object. Cannot set null or CFValueObject with type FormatConditionValueType.Min to it.
MaxColor | Get or set the max value object's corresponding color.
MidCfvo | Get or set this ColorScale's mid value object. Cannot set CFValueObject with type FormatConditionValueType.Max or FormatConditionValueType.Min to it.
MidColor | Get or set the mid value object's corresponding color.
MinCfvo | Get or set this ColorScale's min value object. Cannot set null or CFValueObject with type FormatConditionValueType.Max to it.
MinColor | Get or set the min value object's corresponding color.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ColorScale Class | Aspose.Cells Namespace


ColorScale Properties

The properties of the ColorScale class are listed below. For a complete list of ColorScale class members, see the ColorScale Members topic.

Public Instance Properties

Is3ColorScale | Indicates whether conditional formatting is 3 color scale.
MaxCfvo | Get or set this ColorScale's max value object. Cannot set null or CFValueObject with type FormatConditionValueType.Min to it.
MaxColor | Get or set the max value object's corresponding color.
MidCfvo | Get or set this ColorScale's mid value object. Cannot set CFValueObject with type FormatConditionValueType.Max or FormatConditionValueType.Min to it.
MidColor | Get or set the mid value object's corresponding color.
MinCfvo | Get or set this ColorScale's min value object. Cannot set null or CFValueObject with type FormatConditionValueType.Max to it.
MinColor | Get or set the min value object's corresponding color.

See Also

ColorScale Class | Aspose.Cells Namespace


Is3ColorScale Property

Aspose.Cells for .NET

ColorScale.Is3ColorScale Property

Indicates whether conditional formatting is 3 color scale.

public bool Is3ColorScale {get; set;}

See Also

ColorScale Class | Aspose.Cells Namespace


MaxCfvo Property

Aspose.Cells for .NET

ColorScale.MaxCfvo Property

Get or set this ColorScale's max value object. Cannot set null or CFValueObject with type FormatConditionValueType.Min to it.

public ConditionalFormattingValue MaxCfvo {get;}

See Also

ColorScale Class | Aspose.Cells Namespace


MaxColor Property

Aspose.Cells for .NET

ColorScale.MaxColor Property

Get or set the max value object's corresponding color.

public Color MaxColor {get; set;}

See Also

ColorScale Class | Aspose.Cells Namespace


MidCfvo Property

Aspose.Cells for .NET

ColorScale.MidCfvo Property

Get or set this ColorScale's mid value object. Cannot set CFValueObject with type FormatConditionValueType.Max or FormatConditionValueType.Min to it.

public ConditionalFormattingValue MidCfvo {get;}

See Also

ColorScale Class | Aspose.Cells Namespace


MidColor Property

Aspose.Cells for .NET

ColorScale.MidColor Property

Get or set the mid value object's corresponding color.

public Color MidColor {get; set;}

See Also

ColorScale Class | Aspose.Cells Namespace


MinCfvo Property

Aspose.Cells for .NET

ColorScale.MinCfvo Property

Get or set this ColorScale's min value object. Cannot set null or CFValueObject with type FormatConditionValueType.Max to it.

public ConditionalFormattingValue MinCfvo {get;}

See Also

ColorScale Class | Aspose.Cells Namespace


MinColor Property

Aspose.Cells for .NET

ColorScale.MinColor Property

Get or set the min value object's corresponding color.

public Color MinColor {get; set;}

See Also

ColorScale Class | Aspose.Cells Namespace


ColorType Enumeration

Represents all color type

public enum ColorType

Members

Member Name | Description | Value
Automatic | Automatic color. | 0
AutomaticIndex | It's automatic color,but the displayed color depends the setting of the OS System. | 1
RGB | The RGB color. | 2
IndexedColor | The color index in the color palette. | 3
Theme | The theme color. | 4

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Column Class

Represents a single column in a worksheet.

For a list of all members of this type, see Column Members.

System.Object
Aspose.Cells.Column

public class Column

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the first worksheet
Worksheet worksheet = workbook.Worksheets[0];
Style style = workbook.CreateStyle();

//Setting the background color to Blue
style.BackgroundColor = Color.Blue;

//Setting the foreground color to Red
style.ForegroundColor= Color.Red;

//setting Background Pattern
style.Pattern = BackgroundType.DiagonalStripe;

//New Style Flag
StyleFlag styleFlag = new StyleFlag();

//Set All Styles
styleFlag.All = true;

//Get first Column
Column column = worksheet.Cells.Columns[0];

//Apply Style to first Column
column.ApplyStyle(style, styleFlag);

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the first worksheet
Dim worksheet As Worksheet = workbook.Worksheets(0)

Dim style As Style = workbook.CreateStyle()

'Setting the background color to Blue
style.BackgroundColor = Color.Blue

'Setting the foreground color to Red
style.ForegroundColor = Color.Red

'setting Background Pattern
style.Pattern = BackgroundType.DiagonalStripe

'New Style Flag
Dim styleFlag As New StyleFlag()

'Set All Styles
styleFlag.All = True

'Get first Column
Dim column As Column = worksheet.Cells.Columns(0)

'Apply Style to first Column
column.ApplyStyle(style, styleFlag)

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Column Members | Aspose.Cells Namespace


Column Members

Column overview

Public Instance Properties

GroupLevel | Gets the group level of the column.
Index | Gets the index of this column.
IsHidden | Indicates whether the column is hidden.
Style | Gets the style of this column.
Width | Gets and sets the column width in unit of characters.

Public Instance Methods

ApplyStyle | Applies formats for a whole column.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Column Class | Aspose.Cells Namespace


Column Properties

The properties of the Column class are listed below. For a complete list of Column class members, see the Column Members topic.

Public Instance Properties

GroupLevel | Gets the group level of the column.
Index | Gets the index of this column.
IsHidden | Indicates whether the column is hidden.
Style | Gets the style of this column.
Width | Gets and sets the column width in unit of characters.

See Also

Column Class | Aspose.Cells Namespace


GroupLevel Property

Aspose.Cells for .NET

Column.GroupLevel Property

Gets the group level of the column.

public byte GroupLevel {get;}

See Also

Column Class | Aspose.Cells Namespace


Index Property

Aspose.Cells for .NET

Column.Index Property

Gets the index of this column.

public int Index {get;}

See Also

Column Class | Aspose.Cells Namespace


IsHidden Property

Aspose.Cells for .NET

Column.IsHidden Property

Indicates whether the column is hidden.

public bool IsHidden {get; set;}

See Also

Column Class | Aspose.Cells Namespace


Style Property

Aspose.Cells for .NET

Column.Style Property

Gets the style of this column.

public Style Style {get;}

Remarks

You have to call Column.ApplyStyle() method to save your changing with the row style, otherwise it will not effect.

See Also

Column Class | Aspose.Cells Namespace


Width Property

Aspose.Cells for .NET

Column.Width Property

Gets and sets the column width in unit of characters.

public double Width {get; set;}

See Also

Column Class | Aspose.Cells Namespace


Column Methods

The methods of the Column class are listed below. For a complete list of Column class members, see the Column Members topic.

Public Instance Methods

ApplyStyle | Applies formats for a whole column.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Column Class | Aspose.Cells Namespace


Column.ApplyStyle Method

Applies formats for a whole column.

public void ApplyStyle(
Style style,
StyleFlag flag
);

Parameters

style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

See Also

Column Class | Aspose.Cells Namespace


ColumnCollection Class

Collects the objects that represent the individual columns in a worksheet.

For a list of all members of this type, see ColumnCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ColumnCollection

public class ColumnCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the first worksheet
Worksheet worksheet = workbook.Worksheets[0];

//Add new Style to Workbook
Style style = workbook.CreateStyle();

//Setting the background color to Blue
style.ForegroundColor = Color.Blue;

//setting Background Pattern
style.Pattern = BackgroundType.Solid;

//New Style Flag
StyleFlag styleFlag = new StyleFlag();

//Set All Styles
styleFlag.All = true;

//Change the default width of first ten columns
for (int i = 0; i < 10; i++)
{
    worksheet.Cells.Columns[i].Width = 20;
}

//Get the Column with non default formatting
ColumnCollection columns = worksheet.Cells.Columns;

foreach (Column column in columns)
{
    //Apply Style to first ten Columns
    column.ApplyStyle(style, styleFlag);
}

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the first worksheet
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Add new Style to Workbook
Dim style As Style = workbook.CreateStyles()

'Setting the background color to Blue
style.ForegroundColor = Color.Blue

'setting Background Pattern
style.Pattern = BackgroundType.Solid

'New Style Flag
Dim styleFlag As New StyleFlag()

'Set All Styles
styleFlag.All = True

'Change the default width of first ten columns
For i As Integer = 0 To 9
    worksheet.Cells.Columns(i).Width = 20
Next i

'Get the Column with non default formatting
Dim columns As ColumnCollection = worksheet.Cells.Columns

For Each column As Column In columns
    'Apply Style to first ten Columns
    column.ApplyStyle(style, styleFlag)
Next column

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ColumnCollection Members | Aspose.Cells Namespace | Column


ColumnCollection Members

ColumnCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

Public Instance Methods

Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetByIndex | Obsolete. Gets the column object by the index.
GetColumnByIndex | Gets the Column object by the position in the list.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ColumnCollection Class | Aspose.Cells Namespace | Column


ColumnCollection Properties

The properties of the ColumnCollection class are listed below. For a complete list of ColumnCollection class members, see the ColumnCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

See Also

ColumnCollection Class | Aspose.Cells Namespace | Column


Item Property

Aspose.Cells for .NET

ColumnCollection.Item Property

Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

public Column this[
int columnIndex
] {get;}

See Also

ColumnCollection Class | Aspose.Cells Namespace | Column


ColumnCollection Methods

The methods of the ColumnCollection class are listed below. For a complete list of ColumnCollection class members, see the ColumnCollection Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetByIndex | Obsolete. Gets the column object by the index.
GetColumnByIndex | Gets the Column object by the position in the list.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ColumnCollection Class | Aspose.Cells Namespace | Column


ColumnCollection.GetByIndex Method

NOTE: This method is now obsolete.

Use Columns.GetColumnByIndex() method instead.

Gets the column object by the index.

public Column GetByIndex(
int index
);

Parameters

index

Return Value

Returns the column object.

Remarks

NOTE: This member is now obsolete. Instead, please use Columns.GetColumnByIndex() method. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

ColumnCollection Class | Aspose.Cells Namespace


ColumnCollection.GetColumnByIndex Method

Gets the Column object by the position in the list.

public Column GetColumnByIndex(
int index
);

Parameters

index
The position in the list.

Return Value

Returns the column object.

See Also

ColumnCollection Class | Aspose.Cells Namespace


Comment Class

Encapsulates the object that represents a cell comment.

For a list of all members of this type, see Comment Members.

System.Object
Aspose.Cells.Comment

public class Comment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Workbook workbook = new Workbook();
CommentCollection comments = workbook.Worksheets[0].Comments;

//Add comment to cell A1
int commentIndex = comments.Add(0, 0);
Comment comment = comments[commentIndex];
comment.Note = "First note.";
comment.Font.Name = "Times New Roman";

//Add comment to cell B2
comments.Add("B2");
comment = comments["B2"];
comment.Note = "Second note.";

[Visual Basic]

Dim workbook as Workbook = new Workbook()
Dim comments as CommentCollection = workbook.Worksheets(0).Comments

'Add comment to cell A1
Dim commentIndex as Integer = comments.Add(0, 0)
Dim comment as Comment = comments(commentIndex)
comment.Note = "First note."
comment.Font.Name = "Times New Roman"

'Add comment to cell B2
comments.Add("B2")
comment = comments("B2")
comment.Note = "Second note."

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Comment Members | Aspose.Cells Namespace


Comment Members

Comment overview

Public Instance Properties

Author | Gets and sets Name of the original comment author
AutoSize | Indicates if size of comment is adjusted automatically according to its content.
Column | Gets the column index of the comment.
CommentShape | Get a Shape object that represents the shape attached to the specified comment.
Font | Gets the font of comment.
Height | Represents the Height of the comment, in unit of pixels.
HeightCM | Represents the height of the comment, in unit of centimeters.
HeightInch | Represents the height of the comment, in unit of inches.
HtmlNote | Gets and sets the html string which contains data and some formats in this comment.
IsVisible | Represents if the comment is visible or not.
Note | Represents the content of comment.
Row | Gets the row index of the comment.
TextHorizontalAlignment | Gets and sets the text horizontal alignment type of the comment.
TextOrientationType | Gets and sets the text orientation type of the comment.
TextVerticalAlignment | Gets and sets the text vertical alignment type of the comment.
ThreadedComments | Gets the list of threaded comments;
Width | Represents the width of the comment, in unit of pixels.
WidthCM | Represents the width of the comment, in unit of centimeters.
WidthInch | Represents the width of the comment, in unit of inches.

Public Instance Methods

Characters | Returns a Characters object that represents a range of characters within the comment text.
Equals (inherited from Object) |
FormatCharacters | Format some characters with the font setting.
GetCharacters | Returns all Characters objects that represents a range of characters within the comment text.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Comment Class | Aspose.Cells Namespace


Comment Properties

The properties of the Comment class are listed below. For a complete list of Comment class members, see the Comment Members topic.

Public Instance Properties

Author | Gets and sets Name of the original comment author
AutoSize | Indicates if size of comment is adjusted automatically according to its content.
Column | Gets the column index of the comment.
CommentShape | Get a Shape object that represents the shape attached to the specified comment.
Font | Gets the font of comment.
Height | Represents the Height of the comment, in unit of pixels.
HeightCM | Represents the height of the comment, in unit of centimeters.
HeightInch | Represents the height of the comment, in unit of inches.
HtmlNote | Gets and sets the html string which contains data and some formats in this comment.
IsVisible | Represents if the comment is visible or not.
Note | Represents the content of comment.
Row | Gets the row index of the comment.
TextHorizontalAlignment | Gets and sets the text horizontal alignment type of the comment.
TextOrientationType | Gets and sets the text orientation type of the comment.
TextVerticalAlignment | Gets and sets the text vertical alignment type of the comment.
ThreadedComments | Gets the list of threaded comments;
Width | Represents the width of the comment, in unit of pixels.
WidthCM | Represents the width of the comment, in unit of centimeters.
WidthInch | Represents the width of the comment, in unit of inches.

See Also

Comment Class | Aspose.Cells Namespace


Author Property

Aspose.Cells for .NET

Comment.Author Property

Gets and sets Name of the original comment author

public string Author {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


AutoSize Property

Aspose.Cells for .NET

Comment.AutoSize Property

Indicates if size of comment is adjusted automatically according to its content.

public bool AutoSize {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


Column Property

Aspose.Cells for .NET

Comment.Column Property

Gets the column index of the comment.

public int Column {get;}

See Also

Comment Class | Aspose.Cells Namespace


CommentShape Property

Aspose.Cells for .NET

Comment.CommentShape Property

Get a Shape object that represents the shape attached to the specified comment.

public CommentShape CommentShape {get;}

See Also

Comment Class | Aspose.Cells Namespace


Font Property

Aspose.Cells for .NET

Comment.Font Property

Gets the font of comment.

public Font Font {get;}

See Also

Comment Class | Aspose.Cells Namespace


Height Property

Aspose.Cells for .NET

Comment.Height Property

Represents the Height of the comment, in unit of pixels.

public int Height {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


HeightCM Property

Aspose.Cells for .NET

Comment.HeightCM Property

Represents the height of the comment, in unit of centimeters.

public double HeightCM {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


HeightInch Property

Aspose.Cells for .NET

Comment.HeightInch Property

Represents the height of the comment, in unit of inches.

public double HeightInch {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


HtmlNote Property

Aspose.Cells for .NET

Comment.HtmlNote Property

Gets and sets the html string which contains data and some formats in this comment.

public string HtmlNote {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


IsVisible Property

Aspose.Cells for .NET

Comment.IsVisible Property

Represents if the comment is visible or not.

public bool IsVisible {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


Note Property

Aspose.Cells for .NET

Comment.Note Property

Represents the content of comment.

public string Note {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


Row Property

Aspose.Cells for .NET

Comment.Row Property

Gets the row index of the comment.

public int Row {get;}

See Also

Comment Class | Aspose.Cells Namespace


TextHorizontalAlignment Property

Aspose.Cells for .NET

Comment.TextHorizontalAlignment Property

Gets and sets the text horizontal alignment type of the comment.

public TextAlignmentType TextHorizontalAlignment {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


TextOrientationType Property

Aspose.Cells for .NET

Comment.TextOrientationType Property

Gets and sets the text orientation type of the comment.

public TextOrientationType TextOrientationType {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


TextVerticalAlignment Property

Aspose.Cells for .NET

Comment.TextVerticalAlignment Property

Gets and sets the text vertical alignment type of the comment.

public TextAlignmentType TextVerticalAlignment {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


ThreadedComments Property

Aspose.Cells for .NET

Comment.ThreadedComments Property

Gets the list of threaded comments;

public ThreadedCommentCollection ThreadedComments {get;}

See Also

Comment Class | Aspose.Cells Namespace


Width Property

Aspose.Cells for .NET

Comment.Width Property

Represents the width of the comment, in unit of pixels.

public int Width {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


WidthCM Property

Aspose.Cells for .NET

Comment.WidthCM Property

Represents the width of the comment, in unit of centimeters.

public double WidthCM {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


WidthInch Property

Aspose.Cells for .NET

Comment.WidthInch Property

Represents the width of the comment, in unit of inches.

public double WidthInch {get; set;}

See Also

Comment Class | Aspose.Cells Namespace


Comment Methods

The methods of the Comment class are listed below. For a complete list of Comment class members, see the Comment Members topic.

Public Instance Methods

Characters | Returns a Characters object that represents a range of characters within the comment text.
Equals (inherited from Object) |
FormatCharacters | Format some characters with the font setting.
GetCharacters | Returns all Characters objects that represents a range of characters within the comment text.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Comment Class | Aspose.Cells Namespace


Comment.Characters Method

Returns a Characters object that represents a range of characters within the comment text.

public FontSetting Characters(
int startIndex,
int length
);

Parameters

startIndex
The index of the start of the character.
length
The number of characters.

Return Value

Characters object.

See Also

Comment Class | Aspose.Cells Namespace


Comment.FormatCharacters Method

Format some characters with the font setting.

public void FormatCharacters(
int startIndex,
int length,
Font font,
StyleFlag flag
);

Parameters

startIndex
The start index.
length
The length.
font
The font setting.
flag
The flag of the font setting.

See Also

Comment Class | Aspose.Cells Namespace


Comment.GetCharacters Method

Returns all Characters objects that represents a range of characters within the comment text.

public ArrayList GetCharacters();

Return Value

All Characters objects

See Also

Comment Class | Aspose.Cells Namespace


CommentCollection Class

Encapsulates a collection of Comment objects.

For a list of all members of this type, see CommentCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.CommentCollection

public class CommentCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Workbook workbook = new Workbook();

CommentCollection comments = workbook.Worksheets[0].Comments;

[Visual Basic]

Dim workbook as Workbook = new Workbook()

Dim comments as CommentCollection = workbook.Worksheets(0).Comments

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CommentCollection Members | Aspose.Cells Namespace


CommentCollection Members

CommentCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Comment element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a comment to the collection.
AddThreadedComment | Overloaded. Adds a threaded comment.
Clear | Removes all comments;
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetThreadedComments | Overloaded. Gets the threaded comments by row and column index.
GetType (inherited from Object) |
RemoveAt | Overloaded. Removes the comment of the specific cell.
RemoveAt (inherited from CollectionBase) | Overloaded.
ToString (inherited from Object) |

See Also

CommentCollection Class | Aspose.Cells Namespace


CommentCollection Properties

The properties of the CommentCollection class are listed below. For a complete list of CommentCollection class members, see the CommentCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Comment element at the specified index.

See Also

CommentCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

CommentCollection.Item Property

Gets the Comment element at the specified index.

Overload List

Gets the Comment element at the specified index.

public Comment this[int] {get;}

Gets the Comment element at the specified row index and column index.

public Comment this[int, int] {get;}

Gets the Comment element at the specified cell.

public Comment this[string] {get;}

See Also

CommentCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

CommentCollection.Item Property (Int32)

Gets the Comment element at the specified index.

public Comment this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

CommentCollection.Item Property (Int32, Int32)

Gets the Comment element at the specified row index and column index.

public Comment this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

CommentCollection.Item Property (String)

Gets the Comment element at the specified cell.

public Comment this[
string cellName
] {get;}

Parameters

cellName
Cell name.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.Item Overload List


CommentCollection Methods

The methods of the CommentCollection class are listed below. For a complete list of CommentCollection class members, see the CommentCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a comment to the collection.
AddThreadedComment | Overloaded. Adds a threaded comment.
Clear | Removes all comments;
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetThreadedComments | Overloaded. Gets the threaded comments by row and column index.
GetType (inherited from Object) |
RemoveAt | Overloaded. Removes the comment of the specific cell.
RemoveAt (inherited from CollectionBase) | Overloaded.
ToString (inherited from Object) |

See Also

CommentCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

CommentCollection.Add Method

Adds a comment to the collection.

Overload List

Adds a comment to the collection.

public int Add(int,int);

Adds a comment to the collection.

public int Add(string);

See Also

CommentCollection Class | Aspose.Cells Namespace


CommentCollection.Add Method (Int32, Int32)

Adds a comment to the collection.

public int Add(
int row,
int column
);

Parameters

row
Cell row index.
column
Cell column index.

Return Value

Comment object index.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.Add Overload List


CommentCollection.Add Method (String)

Adds a comment to the collection.

public int Add(
string cellName
);

Parameters

cellName
Cell name.

Return Value

Comment object index.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.Add Overload List


AddThreadedComment Method

Aspose.Cells for .NET

CommentCollection.AddThreadedComment Method

Adds a threaded comment.

Overload List

Adds a threaded comment.

public int AddThreadedComment(int,int,string,ThreadedCommentAuthor);

Adds a threaded comment.

public int AddThreadedComment(string,string,ThreadedCommentAuthor);

See Also

CommentCollection Class | Aspose.Cells Namespace


CommentCollection.AddThreadedComment Method (Int32, Int32, String, ThreadedCommentAuthor)

Adds a threaded comment.

public int AddThreadedComment(
int row,
int column,
string text,
ThreadedCommentAuthor author
);

Parameters

row
Cell row index.
column
Cell column index.
text
The text of the comment
author
The user of this threaded comment.

Return Value

ThreadedComment object index.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.AddThreadedComment Overload List


CommentCollection.AddThreadedComment Method (String, String, ThreadedCommentAuthor)

Adds a threaded comment.

public int AddThreadedComment(
string cellName,
string text,
ThreadedCommentAuthor author
);

Parameters

cellName
The name of the cell.
text
The text of the comment
author
The user of this threaded comment.

Return Value

ThreadedComment object index.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.AddThreadedComment Overload List


CommentCollection.Clear Method

Removes all comments;

new public void Clear();

Implements

IList.Clear

See Also

CommentCollection Class | Aspose.Cells Namespace


GetThreadedComments Method

Aspose.Cells for .NET

CommentCollection.GetThreadedComments Method

Gets the threaded comments by row and column index.

Overload List

Gets the threaded comments by row and column index.

public ThreadedCommentCollection GetThreadedComments(int,int);

Gets the threaded comments by cell name.

public ThreadedCommentCollection GetThreadedComments(string);

See Also

CommentCollection Class | Aspose.Cells Namespace


CommentCollection.GetThreadedComments Method (Int32, Int32)

Gets the threaded comments by row and column index.

public ThreadedCommentCollection GetThreadedComments(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.GetThreadedComments Overload List


CommentCollection.GetThreadedComments Method (String)

Gets the threaded comments by cell name.

public ThreadedCommentCollection GetThreadedComments(
string cellName
);

Parameters

cellName
The name of the cell.

Return Value

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.GetThreadedComments Overload List


RemoveAt Method

Aspose.Cells for .NET

CommentCollection.RemoveAt Method

Removes the comment of the specific cell.

Overload List

Inherited from CollectionBase.

public void RemoveAt(int);

Removes the comment of the specific cell.

public void RemoveAt(int,int);

Removes the comment of the specific cell.

public void RemoveAt(string);

See Also

CommentCollection Class | Aspose.Cells Namespace


CommentCollection.RemoveAt Method (Int32, Int32)

Removes the comment of the specific cell.

public void RemoveAt(
int row,
int column
);

Parameters

row
The row index.
column
the column index.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.RemoveAt Overload List


CommentCollection.RemoveAt Method (String)

Removes the comment of the specific cell.

public void RemoveAt(
string cellName
);

Parameters

cellName
The name of cell which contains a comment.

See Also

CommentCollection Class | Aspose.Cells Namespace | CommentCollection.RemoveAt Overload List


ConditionalFormattingCollection Class

Encapsulates a collection of FormatCondition objects.

For a list of all members of this type, see ConditionalFormattingCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ConditionalFormattingCollection

public class ConditionalFormattingCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

Worksheet sheet = workbook.Worksheets[0];

//Get Conditional Formatting
ConditionalFormattingCollection cformattings = sheet.ConditionalFormattings;

//Adds an empty conditional formatting
int index = cformattings.Add();

//Get newly added Conditional formatting
FormatConditionCollection fcs = cformattings[index];

//Sets the conditional format range.
CellArea ca = new CellArea();

ca.StartRow = 0;

ca.EndRow = 0;

ca.StartColumn = 0;

ca.EndColumn = 0;

fcs.AddArea(ca);

ca = new CellArea();

ca.StartRow = 1;

ca.EndRow = 1;

ca.StartColumn = 1;

ca.EndColumn = 1;

fcs.AddArea(ca);

//Add condition.
int conditionIndex = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "=A2", "100");

//Add condition.
int conditionIndex2 = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "50", "100");

//Sets the background color.
FormatCondition fc = fcs[conditionIndex];

fc.Style.BackgroundColor = Color.Red;

//Saving the Excel file
workbook.Save("C:\\output.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

Dim sheet As Worksheet = workbook.Worksheets(0)

'Get Conditional Formatting
Dim cformattings As ConditionalFormattingCollection = sheet.ConditionalFormattings

'Adds an empty conditional formatting
Dim index As Integer = cformattings.Add()

'Get newly added Conditional formatting
Dim fcs As FormatConditionCollection = cformattings(index)

'Sets the conditional format range.
Dim ca As New CellArea()

ca.StartRow = 0

ca.EndRow = 0

ca.StartColumn = 0

ca.EndColumn = 0

fcs.AddArea(ca)

ca = New CellArea()

ca.StartRow = 1

ca.EndRow = 1

ca.StartColumn = 1

ca.EndColumn = 1

fcs.AddArea(ca)

'Add condition.
Dim conditionIndex As Integer = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "=A2", "100")

'Add condition.
Dim conditionIndex2 As Integer = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "50", "100")

'Sets the background color.
Dim fc As FormatCondition = fcs(conditionIndex)

fc.Style.BackgroundColor = Color.Red

'Saving the Excel file
workbook.Save("C:\output.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConditionalFormattingCollection Members | Aspose.Cells Namespace


ConditionalFormattingCollection Members

ConditionalFormattingCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the FormatConditions element at the specified index.

Public Instance Methods

Add | Adds a FormatConditions to the collection.
Clear (inherited from CollectionBase) |
Copy | Copies conditional formatting.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveArea | Remove all conditional formatting in the range.
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


ConditionalFormattingCollection Properties

The properties of the ConditionalFormattingCollection class are listed below. For a complete list of ConditionalFormattingCollection class members, see the ConditionalFormattingCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the FormatConditions element at the specified index.

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ConditionalFormattingCollection.Item Property

Gets the FormatConditions element at the specified index.

public FormatConditionCollection this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


ConditionalFormattingCollection Methods

The methods of the ConditionalFormattingCollection class are listed below. For a complete list of ConditionalFormattingCollection class members, see the ConditionalFormattingCollection Members topic.

Public Instance Methods

Add | Adds a FormatConditions to the collection.
Clear (inherited from CollectionBase) |
Copy | Copies conditional formatting.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveArea | Remove all conditional formatting in the range.
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


ConditionalFormattingCollection.Add Method

Adds a FormatConditions to the collection.

public int Add();

Return Value

FormatConditions object index.

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


ConditionalFormattingCollection.Copy Method

Copies conditional formatting.

public void Copy(
ConditionalFormattingCollection cfs
);

Parameters

cfs
The conditional formatting

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


ConditionalFormattingCollection.RemoveArea Method

Remove all conditional formatting in the range.

public void RemoveArea(
int startRow,
int startColumn,
int totalRows,
int totalColumns
);

Parameters

startRow
The start row of the range.
startColumn
The start column of the range.
totalRows
The number of rows of the range.
totalColumns
The number of columns of the range.

See Also

ConditionalFormattingCollection Class | Aspose.Cells Namespace


ConditionalFormattingIcon Class

Represents the custom icon of conditional formatting rule.

For a list of all members of this type, see ConditionalFormattingIcon Members.

System.Object
Aspose.Cells.ConditionalFormattingIcon

public class ConditionalFormattingIcon

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConditionalFormattingIcon Members | Aspose.Cells Namespace


ConditionalFormattingIcon Members

ConditionalFormattingIcon overview

Public Static Methods

GetIconImageData Get the icon set data

Public Instance Properties

ImageData | Gets the icon set data.
Index | Gets and sets the icon's index in the icon set.
Type | Gets and sets the icon set type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


ConditionalFormattingIcon Properties

The properties of the ConditionalFormattingIcon class are listed below. For a complete list of ConditionalFormattingIcon class members, see the ConditionalFormattingIcon Members topic.

Public Instance Properties

ImageData | Gets the icon set data.
Index | Gets and sets the icon's index in the icon set.
Type | Gets and sets the icon set type.

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


ImageData Property

Aspose.Cells for .NET

ConditionalFormattingIcon.ImageData Property

Gets the icon set data.

public byte[] ImageData {get;}

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


Index Property

Aspose.Cells for .NET

ConditionalFormattingIcon.Index Property

Gets and sets the icon's index in the icon set.

public int Index {get; set;}

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

ConditionalFormattingIcon.Type Property

Gets and sets the icon set type.

public IconSetType Type {get; set;}

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


ConditionalFormattingIcon Methods

The methods of the ConditionalFormattingIcon class are listed below. For a complete list of ConditionalFormattingIcon class members, see the ConditionalFormattingIcon Members topic.

Public Static Methods

GetIconImageData Get the icon set data

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


ConditionalFormattingIcon.GetIconImageData Method

Get the icon set data

public static byte[] GetIconImageData(
IconSetType type,
int index
);

Parameters

type
icon's type
index
icon's index

Return Value

See Also

ConditionalFormattingIcon Class | Aspose.Cells Namespace


ConditionalFormattingIconCollection Class

Represents a collection of ConditionalFormattingIcon objects.

For a list of all members of this type, see ConditionalFormattingIconCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ConditionalFormattingIconCollection

public class ConditionalFormattingIconCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Instantiating a Workbook object
 Workbook workbook = new Workbook();

 Worksheet sheet = workbook.Worksheets[0];

 //Get Conditional Formatting
 ConditionalFormattingCollection cformattings = sheet.ConditionalFormattings;

 //Adds an empty conditional formatting
 int index = cformattings.Add();

 //Get newly added Conditional formatting
 FormatConditionCollection fcs = cformattings[index];

 //Sets the conditional format range.
 CellArea ca = new CellArea();

 ca.StartRow = 0;

 ca.EndRow = 0;

 ca.StartColumn = 0;

 ca.EndColumn = 0;

 fcs.AddArea(ca);

 ca = new CellArea();

 ca.StartRow = 1;

 ca.EndRow = 1;

 ca.StartColumn = 1;

 ca.EndColumn = 1;

 fcs.AddArea(ca);

 //Sets condition
  int idx = fcs.AddCondition(FormatConditionType.IconSet);

  FormatCondition cond = fcs[idx];

  //Sets condition's type
  cond.IconSet.Type = IconSetType.ArrowsGray3;

 //Add custom iconset condition.
  ConditionalFormattingIcon cfIcon = cond.IconSet.CfIcons[0];

  cfIcon.Type = IconSetType.Arrows3;

  cfIcon.Index = 0;

  ConditionalFormattingIcon cfIcon1 = cond.IconSet.CfIcons[1];

   cfIcon1.Type = IconSetType.ArrowsGray3;

   cfIcon1.Index = 1;

   ConditionalFormattingIcon cfIcon2 = cond.IconSet.CfIcons[2];

   cfIcon2.Type = IconSetType.Boxes5;

   cfIcon2.Index = 2;

 //Saving the Excel file
 workbook.Save("C:\\output.xls");

 [VB.NET]

 'Instantiating a Workbook object
 Dim workbook As New Workbook()

 Dim sheet As Worksheet = workbook.Worksheets(0)

 'Get Conditional Formatting
 Dim cformattings As ConditionalFormattingCollection = sheet.ConditionalFormattings

 'Adds an empty conditional formatting
 Dim index As Integer = cformattings.Add()

 'Get newly added Conditional formatting
 Dim fcs As FormatConditionCollection = cformattings(index)

 'Sets the conditional format range.
 Dim ca As New CellArea()

 ca.StartRow = 0

 ca.EndRow = 0

 ca.StartColumn = 0

 ca.EndColumn = 0

 fcs.AddArea(ca)

 ca = New CellArea()

 ca.StartRow = 1

 ca.EndRow = 1

 ca.StartColumn = 1

 ca.EndColumn = 1

 fcs.AddArea(ca)

 //Sets condition
 Dim idx As Integer =fcs.AddCondition(FormatConditionType.IconSet)

 Dim cond As FormatCondition=fcs[idx]

 //Sets condition's type
 cfIcon.Type = IconSetType.ArrowsGray3

 'Add custom iconset  condition.
 Dim cfIcon As ConditionalFormattingIcon = cond.IconSet.CfIcons[0]

 cfIcon.Type = IconSetType.Arrows3

 cfIcon.Index=0

 Dim cfIcon1 As ConditionalFormattingIcon = cond.IconSet.CfIcons[1]

 cfIcon1.Type = IconSetType.ArrowsGray3

 cfIcon1.Index=1

 Dim cfIcon2 As ConditionalFormattingIcon = cond.IconSet.CfIcons[2]

 cfIcon2.Type = IconSetType.Boxes5

 cfIcon2.Index=2

 'Saving the Excel file
 workbook.Save("C:\output.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConditionalFormattingIconCollection Members | Aspose.Cells Namespace


ConditionalFormattingIconCollection Members

ConditionalFormattingIconCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the ConditionalFormattingIcon element at the specified index.

Public Instance Methods

Add | Overloaded. Adds ConditionalFormattingIcon object.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace


ConditionalFormattingIconCollection Properties

The properties of the ConditionalFormattingIconCollection class are listed below. For a complete list of ConditionalFormattingIconCollection class members, see the ConditionalFormattingIconCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the ConditionalFormattingIcon element at the specified index.

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ConditionalFormattingIconCollection.Item Property

Gets the ConditionalFormattingIcon element at the specified index.

public ConditionalFormattingIcon this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace


ConditionalFormattingIconCollection Methods

The methods of the ConditionalFormattingIconCollection class are listed below. For a complete list of ConditionalFormattingIconCollection class members, see the ConditionalFormattingIconCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds ConditionalFormattingIcon object.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

ConditionalFormattingIconCollection.Add Method

Adds ConditionalFormattingIcon object.

Overload List

Adds ConditionalFormattingIcon object.

public int Add(ConditionalFormattingIcon);

Adds ConditionalFormattingIcon object.

public int Add(IconSetType,int);

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace


ConditionalFormattingIconCollection.Add Method (ConditionalFormattingIcon)

Adds ConditionalFormattingIcon object.

public int Add(
ConditionalFormattingIcon cficon
);

Parameters

cficon
Returns the index of new object in the list.

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace | ConditionalFormattingIconCollection.Add Overload List


ConditionalFormattingIconCollection.Add Method (IconSetType, Int32)

Adds ConditionalFormattingIcon object.

public int Add(
IconSetType type,
int index
);

Parameters

type
The value type.
index
The Index.

Return Value

Returns the index of new object in the list.

See Also

ConditionalFormattingIconCollection Class | Aspose.Cells Namespace | ConditionalFormattingIconCollection.Add Overload List


ConditionalFormattingResult Class

Represents the result of conditional formatting which applies to a cell.

For a list of all members of this type, see ConditionalFormattingResult Members.

System.Object
Aspose.Cells.ConditionalFormattingResult

public class ConditionalFormattingResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConditionalFormattingResult Members | Aspose.Cells Namespace


ConditionalFormattingResult Members

ConditionalFormattingResult overview

Public Instance Properties

ColorScaleResult | Gets the display color of color scale.
ConditionalFormattingColorScale | Gets the ColorScale object.
ConditionalFormattingDataBar | Gets the DataBar object.
ConditionalFormattingIcon | Gets the image of icon set.
ConditionalStyle | Gets the conditional result style.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ConditionalFormattingResult Properties

The properties of the ConditionalFormattingResult class are listed below. For a complete list of ConditionalFormattingResult class members, see the ConditionalFormattingResult Members topic.

Public Instance Properties

ColorScaleResult | Gets the display color of color scale.
ConditionalFormattingColorScale | Gets the ColorScale object.
ConditionalFormattingDataBar | Gets the DataBar object.
ConditionalFormattingIcon | Gets the image of icon set.
ConditionalStyle | Gets the conditional result style.

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ColorScaleResult Property

Aspose.Cells for .NET

ConditionalFormattingResult.ColorScaleResult Property

Gets the display color of color scale.

public Color ColorScaleResult {get;}

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ConditionalFormattingColorScale Property

Aspose.Cells for .NET

ConditionalFormattingResult.ConditionalFormattingColorScale Property

Gets the ColorScale object.

public ColorScale ConditionalFormattingColorScale {get;}

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ConditionalFormattingDataBar Property

Aspose.Cells for .NET

ConditionalFormattingResult.ConditionalFormattingDataBar Property

Gets the DataBar object.

public DataBar ConditionalFormattingDataBar {get;}

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ConditionalFormattingIcon Property

Aspose.Cells for .NET

ConditionalFormattingResult.ConditionalFormattingIcon Property

Gets the image of icon set.

public ConditionalFormattingIcon ConditionalFormattingIcon {get;}

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ConditionalStyle Property

Aspose.Cells for .NET

ConditionalFormattingResult.ConditionalStyle Property

Gets the conditional result style.

public Style ConditionalStyle {get;}

See Also

ConditionalFormattingResult Class | Aspose.Cells Namespace


ConditionalFormattingValue Class

Describes the values of the interpolation points in a gradient scale, dataBar or iconSet.

For a list of all members of this type, see ConditionalFormattingValue Members.

System.Object
Aspose.Cells.ConditionalFormattingValue

public class ConditionalFormattingValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConditionalFormattingValue Members | Aspose.Cells Namespace


ConditionalFormattingValue Members

ConditionalFormattingValue overview

Public Instance Properties

IsGTE | Get or set the Greater Than Or Equal flag. Use only for icon sets, determines whether this threshold value uses the greater than or equal to operator. 'false' indicates 'greater than' is used instead of 'greater than or equal to'. Default value is true.
Type | Get or set the type of this conditional formatting value object. Setting the type to FormatConditionValueType.Min or FormatConditionValueType.Max will auto set "Value" to null.
Value | Get or set the value of this conditional formatting value object. It should be used in conjunction with Type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ConditionalFormattingValue Class | Aspose.Cells Namespace


ConditionalFormattingValue Properties

The properties of the ConditionalFormattingValue class are listed below. For a complete list of ConditionalFormattingValue class members, see the ConditionalFormattingValue Members topic.

Public Instance Properties

IsGTE | Get or set the Greater Than Or Equal flag. Use only for icon sets, determines whether this threshold value uses the greater than or equal to operator. 'false' indicates 'greater than' is used instead of 'greater than or equal to'. Default value is true.
Type | Get or set the type of this conditional formatting value object. Setting the type to FormatConditionValueType.Min or FormatConditionValueType.Max will auto set "Value" to null.
Value | Get or set the value of this conditional formatting value object. It should be used in conjunction with Type.

See Also

ConditionalFormattingValue Class | Aspose.Cells Namespace


IsGTE Property

Aspose.Cells for .NET

ConditionalFormattingValue.IsGTE Property

Get or set the Greater Than Or Equal flag. Use only for icon sets, determines whether this threshold value uses the greater than or equal to operator. 'false' indicates 'greater than' is used instead of 'greater than or equal to'. Default value is true.

public bool IsGTE {get; set;}

See Also

ConditionalFormattingValue Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

ConditionalFormattingValue.Type Property

Get or set the type of this conditional formatting value object. Setting the type to FormatConditionValueType.Min or FormatConditionValueType.Max will auto set "Value" to null.

public FormatConditionValueType Type {get; set;}

See Also

ConditionalFormattingValue Class | Aspose.Cells Namespace


Value Property

Aspose.Cells for .NET

ConditionalFormattingValue.Value Property

Get or set the value of this conditional formatting value object. It should be used in conjunction with Type.

public object Value {get; set;}

Remarks

If the value is string and start with "=", it will be processed as a formula, otherwise we will process it as a simple value.

See Also

ConditionalFormattingValue Class | Aspose.Cells Namespace


ConditionalFormattingValueCollection Class

Describes a collection of CFValueObject. Use only for icon sets.

For a list of all members of this type, see ConditionalFormattingValueCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ConditionalFormattingValueCollection

public class ConditionalFormattingValueCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConditionalFormattingValueCollection Members | Aspose.Cells Namespace


ConditionalFormattingValueCollection Members

ConditionalFormattingValueCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Get the CFValueObject element at the specified index.

Public Instance Methods

Add | Adds ConditionalFormattingValue object.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ConditionalFormattingValueCollection Class | Aspose.Cells Namespace


ConditionalFormattingValueCollection Properties

The properties of the ConditionalFormattingValueCollection class are listed below. For a complete list of ConditionalFormattingValueCollection class members, see the ConditionalFormattingValueCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Get the CFValueObject element at the specified index.

See Also

ConditionalFormattingValueCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ConditionalFormattingValueCollection.Item Property

Get the CFValueObject element at the specified index.

public ConditionalFormattingValue this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ConditionalFormattingValueCollection Class | Aspose.Cells Namespace


ConditionalFormattingValueCollection Methods

The methods of the ConditionalFormattingValueCollection class are listed below. For a complete list of ConditionalFormattingValueCollection class members, see the ConditionalFormattingValueCollection Members topic.

Public Instance Methods

Add | Adds ConditionalFormattingValue object.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ConditionalFormattingValueCollection Class | Aspose.Cells Namespace


ConditionalFormattingValueCollection.Add Method

Adds ConditionalFormattingValue object.

public int Add(
FormatConditionValueType type,
string value
);

Parameters

type
The value type.
value
The value.

Return Value

Returns the index of new object in the list.

See Also

ConditionalFormattingValueCollection Class | Aspose.Cells Namespace


ConsolidationFunction Enumeration

Represents consolidation function.

public enum ConsolidationFunction

Members

Member Name | Description | Value
Sum | Represents Sum function. | 0
Count | Represents Count function. | 1
Average | Represents Average function. | 2
Max | Represents Max function. | 3
Min | Represents Min function. | 4
Product | Represents Product function. | 5
CountNums | Represents Count Nums function. | 6
StdDev | Represents StdDev function. | 7
StdDevp | Represents StdDevp function. | 8
Var | Represents Var function. | 9
Varp | Represents Varp function. | 10
DistinctCount | Represents Distinct Count function. | 11

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ContentDisposition Enumeration

The content disposition type.

public enum ContentDisposition

Members

Member Name | Description | Value
Inline |  | 0
Attachment |  | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CopyFormatType Enumeration

Represents type of copying format when inserting rows.

public enum CopyFormatType

Members

Member Name | Description | Value
SameAsAbove | Formats same as above row. | 0
SameAsBelow | Formats same as below row. | 1
Clear | Clears formatting. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CopyOptions Class

Represents the copy options.

For a list of all members of this type, see CopyOptions Members.

System.Object
Aspose.Cells.CopyOptions

public class CopyOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CopyOptions Members | Aspose.Cells Namespace


CopyOptions Members

CopyOptions overview

Public Instance Constructors

CopyOptions Constructor CopyOptions constructor.

Public Instance Properties

ColumnCharacterWidth | Indicates whether copying column width in unit of characters.
CopyInvalidFormulasAsValues | If the formula is not valid for the dest destination, only copy values.
CopyNames | Indicates whether copying the names.
ExtendToAdjacentRange | Indicates whether extend ranges when copying the range to adjacent range.
KeepMacros | Indicates whether keeping macros;
ReferToDestinationSheet | When copying the range in the same file and the chart refers to the source sheet, False means the copied chart's data source will not be changed. True means the copied chart's data source refers to the destination sheet.
ReferToSheetWithSameName | When copying a worksheet to another workbook and the worksheet contains the formulas which refer to other worksheets in MS Excel, the copied formulas should refer to source workbook. But sometimes we have copied other worksheets and we hope the copied formulas refer to other worksheets with the name in the same workbook, please set this property as true.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CopyOptions Class | Aspose.Cells Namespace


CopyOptions Constructor

CopyOptions constructor.

public CopyOptions();

See Also

CopyOptions Class | Aspose.Cells Namespace


CopyOptions Properties

The properties of the CopyOptions class are listed below. For a complete list of CopyOptions class members, see the CopyOptions Members topic.

Public Instance Properties

ColumnCharacterWidth | Indicates whether copying column width in unit of characters.
CopyInvalidFormulasAsValues | If the formula is not valid for the dest destination, only copy values.
CopyNames | Indicates whether copying the names.
ExtendToAdjacentRange | Indicates whether extend ranges when copying the range to adjacent range.
KeepMacros | Indicates whether keeping macros;
ReferToDestinationSheet | When copying the range in the same file and the chart refers to the source sheet, False means the copied chart's data source will not be changed. True means the copied chart's data source refers to the destination sheet.
ReferToSheetWithSameName | When copying a worksheet to another workbook and the worksheet contains the formulas which refer to other worksheets in MS Excel, the copied formulas should refer to source workbook. But sometimes we have copied other worksheets and we hope the copied formulas refer to other worksheets with the name in the same workbook, please set this property as true.

See Also

CopyOptions Class | Aspose.Cells Namespace


ColumnCharacterWidth Property

Aspose.Cells for .NET

CopyOptions.ColumnCharacterWidth Property

Indicates whether copying column width in unit of characters.

public bool ColumnCharacterWidth {get; set;}

See Also

CopyOptions Class | Aspose.Cells Namespace


CopyInvalidFormulasAsValues Property

Aspose.Cells for .NET

CopyOptions.CopyInvalidFormulasAsValues Property

If the formula is not valid for the dest destination, only copy values.

public bool CopyInvalidFormulasAsValues {get; set;}

See Also

CopyOptions Class | Aspose.Cells Namespace


CopyNames Property

Aspose.Cells for .NET

CopyOptions.CopyNames Property

Indicates whether copying the names.

public bool CopyNames {get; set;}

See Also

CopyOptions Class | Aspose.Cells Namespace


ExtendToAdjacentRange Property

Aspose.Cells for .NET

CopyOptions.ExtendToAdjacentRange Property

Indicates whether extend ranges when copying the range to adjacent range.

public bool ExtendToAdjacentRange {get; set;}

Remarks

If it's true, only extends the range of the hyperlink,not adding a new hyperlink when copying hyperlinks to adjacent rows.

See Also

CopyOptions Class | Aspose.Cells Namespace


KeepMacros Property

Aspose.Cells for .NET

CopyOptions.KeepMacros Property

Indicates whether keeping macros;

public bool KeepMacros {get; set;}

Remarks

Only for copying workbook.

See Also

CopyOptions Class | Aspose.Cells Namespace


ReferToDestinationSheet Property

Aspose.Cells for .NET

CopyOptions.ReferToDestinationSheet Property

When copying the range in the same file and the chart refers to the source sheet, False means the copied chart's data source will not be changed. True means the copied chart's data source refers to the destination sheet.

public bool ReferToDestinationSheet {get; set;}

Remarks

The default value is false, it works as MS Excel.

See Also

CopyOptions Class | Aspose.Cells Namespace


ReferToSheetWithSameName Property

Aspose.Cells for .NET

CopyOptions.ReferToSheetWithSameName Property

When copying a worksheet to another workbook and the worksheet contains the formulas which refer to other worksheets in MS Excel, the copied formulas should refer to source workbook. But sometimes we have copied other worksheets and we hope the copied formulas refer to other worksheets with the name in the same workbook, please set this property as true.

public bool ReferToSheetWithSameName {get; set;}

Remarks

The default value is true.

See Also

CopyOptions Class | Aspose.Cells Namespace


CountryCode Enumeration

Represents Excel country identifiers.

public enum CountryCode

Members

Member Name | Description | Value
Default |  | 0
USA | United States | 1
Canada | Canada | 2
LatinAmeric | Latin America, except Brazil | 3
Russia | Russia | 7
Egypt | Egypt | 20
Greece | Greece | 30
Netherlands | Netherlands | 31
Belgium | Belgium | 32
France | France | 33
Spain | Spain | 34
Hungary | Hungary | 36
Italy | Italy | 39
Switzerland | Switzerland | 41
Austria | Austria | 43
UnitedKingdom | United Kingdom | 44
Denmark | Denmark | 45
Sweden | Sweden | 46
Norway | Norway | 47
Poland | Poland | 48
Germany | Germany | 49
Mexico | Mexico | 52
Brazil | Brazil | 55
Australia | Australia | 61
NewZealand | New Zealand | 64
Thailand | Thailand | 66
Japan | Japan | 81
SouthKorea | SouthKorea | 82
VietNam | Viet Nam | 84
China | People's Republic of China | 86
Turkey | Turkey | 90
India | India | 91
Algeria | Algeria | 213
Morocco | Morocco | 216
Libya | Libya | 218
Portugal | Portugal | 351
Iceland | Iceland | 354
Finland | Finland | 358
Czech | Czech Republic | 420
Taiwan | Taiwan | 886
Lebanon | Lebanon | 961
Jordan | Jordan | 962
Syria | Syria | 963
Iraq | Iraq | 964
Kuwait | Kuwait | 965
Saudi | Saudi Arabia | 966
UnitedArabEmirates | United Arab Emirates | 971
Israel | Israel | 972
Qatar | Qatar | 974
Iran | Iran | 981

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


CustomFilter Class

Represents the custom filter.

For a list of all members of this type, see CustomFilter Members.

System.Object
Aspose.Cells.CustomFilter

public class CustomFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomFilter Members | Aspose.Cells Namespace


CustomFilter Members

CustomFilter overview

Public Instance Constructors

CustomFilter Constructor Initializes a new instance of the CustomFilter class.

Public Instance Properties

Criteria | Gets and sets the criteria.
FilterOperatorType | Gets and sets the filter operator type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetCriteria | Sets the filter criteria.
ToString (inherited from Object) |

See Also

CustomFilter Class | Aspose.Cells Namespace


CustomFilter Constructor

Initializes a new instance of the CustomFilter class.

public CustomFilter();

See Also

CustomFilter Class | Aspose.Cells Namespace


CustomFilter Properties

The properties of the CustomFilter class are listed below. For a complete list of CustomFilter class members, see the CustomFilter Members topic.

Public Instance Properties

Criteria | Gets and sets the criteria.
FilterOperatorType | Gets and sets the filter operator type.

See Also

CustomFilter Class | Aspose.Cells Namespace


Criteria Property

Aspose.Cells for .NET

CustomFilter.Criteria Property

Gets and sets the criteria.

public object Criteria {get; set;}

See Also

CustomFilter Class | Aspose.Cells Namespace


FilterOperatorType Property

Aspose.Cells for .NET

CustomFilter.FilterOperatorType Property

Gets and sets the filter operator type.

public FilterOperatorType FilterOperatorType {get; set;}

See Also

CustomFilter Class | Aspose.Cells Namespace


CustomFilter Methods

The methods of the CustomFilter class are listed below. For a complete list of CustomFilter class members, see the CustomFilter Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetCriteria | Sets the filter criteria.
ToString (inherited from Object) |

See Also

CustomFilter Class | Aspose.Cells Namespace


CustomFilter.SetCriteria Method

Sets the filter criteria.

public void SetCriteria(
FilterOperatorType filterOperator,
object criteria
);

Parameters

filterOperator
filter operator type
criteria
filter criteria value

See Also

CustomFilter Class | Aspose.Cells Namespace


CustomFilterCollection Class

Represents the custom filters.

For a list of all members of this type, see CustomFilterCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.CustomFilterCollection

public class CustomFilterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomFilterCollection Members | Aspose.Cells Namespace


CustomFilterCollection Members

CustomFilterCollection overview

Public Instance Constructors

CustomFilterCollection Constructor Initializes a new instance of the CustomFilterCollection class.

Public Instance Properties

And | Indicates whether the two criteria have an "and" relationship.
Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the custom filter in the specific index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

CustomFilterCollection Class | Aspose.Cells Namespace


CustomFilterCollection Constructor

Initializes a new instance of the CustomFilterCollection class.

public CustomFilterCollection();

See Also

CustomFilterCollection Class | Aspose.Cells Namespace


CustomFilterCollection Properties

The properties of the CustomFilterCollection class are listed below. For a complete list of CustomFilterCollection class members, see the CustomFilterCollection Members topic.

Public Instance Properties

And | Indicates whether the two criteria have an "and" relationship.
Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the custom filter in the specific index.

See Also

CustomFilterCollection Class | Aspose.Cells Namespace


And Property

Aspose.Cells for .NET

CustomFilterCollection.And Property

Indicates whether the two criteria have an "and" relationship.

public bool And {get; set;}

See Also

CustomFilterCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

CustomFilterCollection.Item Property

Gets the custom filter in the specific index.

public CustomFilter this[
int index
] {get;}

Parameters

index
The index.

See Also

CustomFilterCollection Class | Aspose.Cells Namespace


CustomImplementationFactory Class

Factory to create some instances which may be re-implemented by user for special purpose.

For a list of all members of this type, see CustomImplementationFactory Members.

System.Object
Aspose.Cells.CustomImplementationFactory

public class CustomImplementationFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomImplementationFactory Members | Aspose.Cells Namespace


CustomImplementationFactory Members

CustomImplementationFactory overview

Public Instance Constructors

CustomImplementationFactory Constructor Initializes a new instance of the CustomImplementationFactory class.

Public Instance Methods

CreateCultureInfo | Create one CultureInfo by given id.
CreateMemoryStream | Overloaded. Create one instance of MemoryStream or custom implementation of MemoryStream.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace


CustomImplementationFactory Constructor

Initializes a new instance of the CustomImplementationFactory class.

public CustomImplementationFactory();

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace


CustomImplementationFactory Methods

The methods of the CustomImplementationFactory class are listed below. For a complete list of CustomImplementationFactory class members, see the CustomImplementationFactory Members topic.

Public Instance Methods

CreateCultureInfo | Create one CultureInfo by given id.
CreateMemoryStream | Overloaded. Create one instance of MemoryStream or custom implementation of MemoryStream.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace


CustomImplementationFactory.CreateCultureInfo Method

Create one CultureInfo by given id.

public virtual CultureInfo CreateCultureInfo(
int lcid
);

Parameters

lcid

Return Value

The CultureInfo instance.

Remarks

This implementation is useful for situations: 1. Some cultures may not be supported by user's environment and creating the required CultureInfo with given identifier may cause Exception. To avoid the exception, user may override this method to provide a valid CultureInfo instance for the unsupported one. 2. User may want to specify some custom properties for some cultures to get expected result for formatting. For this purpose user may override this method to provide the CultureInfo instance with user specified properties. Please note UseUserOverride property of the returned CultureInfo instance may influence the formatted result. If it is false, some properties of the returned CultureInfo instance may be overridden by our built-in formatting engine according to the formatting requirements of different scenarios. If it is true, we will not change any properties of it and use it to format values directly. So, if user has specified custom properties for the returned CultureInfo instance, please make sure its UseUserOverride is true.

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace


CreateMemoryStream Method

Aspose.Cells for .NET

CustomImplementationFactory.CreateMemoryStream Method

Create one instance of MemoryStream or custom implementation of MemoryStream.

Overload List

Create one instance of MemoryStream or custom implementation of MemoryStream.

public virtual MemoryStream CreateMemoryStream();

Create one instance of MemoryStream or custom implementation of MemoryStream.

public virtual MemoryStream CreateMemoryStream(int);

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace


CustomImplementationFactory.CreateMemoryStream Method ()

Create one instance of MemoryStream or custom implementation of MemoryStream.

public virtual MemoryStream CreateMemoryStream();

Return Value

The MemoryStream instance.

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace | CustomImplementationFactory.CreateMemoryStream Overload List


CustomImplementationFactory.CreateMemoryStream Method (Int32)

Create one instance of MemoryStream or custom implementation of MemoryStream.

public virtual MemoryStream CreateMemoryStream(
int capacity
);

Parameters

capacity
Initial capacity for the MemoryStream

Return Value

The MemoryStream instance.

See Also

CustomImplementationFactory Class | Aspose.Cells Namespace | CustomImplementationFactory.CreateMemoryStream Overload List


DataBar Class

Describe the DataBar conditional formatting rule. This conditional formatting rule displays a gradated data bar in the range of cells.

For a list of all members of this type, see DataBar Members.

System.Object
Aspose.Cells.DataBar

public class DataBar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

Worksheet sheet = workbook.Worksheets[0];

//Adds an empty conditional formatting
int index = sheet.ConditionalFormattings.Add();

FormatConditions fcs = sheet.ConditionalFormattings[index];

//Sets the conditional format range.
CellArea ca = new CellArea();

ca.StartRow = 0;

ca.EndRow = 2;

ca.StartColumn = 0;

ca.EndColumn = 0;

fcs.AddArea(ca);

//Adds condition.
int idx = fcs.AddCondtion(FormatConditionType.DataBar);

fcs.AddArea(ca);

FormatCondition cond = fcs[idx];

//Get Databar
DataBar dataBar = cond.DataBar;

dataBar.Color = Color.Orange;

//Set Databar properties
dataBar.MinCfvo.Type = FormatConditionValueType.Percentile;

dataBar.MinCfvo.Value = 30;

dataBar.ShowValue = false;

dataBar.BarBorder.Type = DataBarBorderType.DataBarBorderSolid;

dataBar.BarBorder.Color = Color.Plum;

 dataBar.BarFillType = DataBarFillType.DataBarFillSolid;

 dataBar.AxisColor = Color.Red;

 dataBar.AxisPosition = DataBarAxisPosition.DataBarAxisMidpoint;

 dataBar.NegativeBarFormat.ColorType = DataBarNegativeColorType.DataBarColor;

 dataBar.NegativeBarFormat.Color = Color.White;

 dataBar.NegativeBarFormat.BorderColorType = DataBarNegativeColorType.DataBarColor;

 dataBar.NegativeBarFormat.BorderColor = Color.Yellow;

//Put Cell Values
Aspose.Cells.Cell cell1 = sheet.Cells["A1"];

cell1.PutValue(10);

Aspose.Cells.Cell cell2 = sheet.Cells["A2"];

cell2.PutValue(120);

Aspose.Cells.Cell cell3 = sheet.Cells["A3"];

cell3.PutValue(260);

//Saving the Excel file
workbook.Save("D:\\book1.xlsx");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

Dim sheet As Worksheet = workbook.Worksheets(0)

'Adds an empty conditional formatting
Dim index As Integer = sheet.ConditionalFormattings.Add()

Dim fcs As FormatConditions = sheet.ConditionalFormattings(index)

'Sets the conditional format range.
Dim ca As New CellArea()

ca.StartRow = 0

ca.EndRow = 2

ca.StartColumn = 0

ca.EndColumn = 0

fcs.AddArea(ca)

'Adds condition.
Dim idx As Integer = fcs.AddCondtion(FormatConditionType.DataBar)

fcs.AddArea(ca)

Dim cond As FormatCondition = fcs(idx)

'Get Databar
Dim dataBar As DataBar = cond.DataBar

dataBar.Color = Color.Orange

'Set Databar properties
dataBar.MinCfvo.Type = FormatConditionValueType.Percentile

dataBar.MinCfvo.Value = 30

dataBar.ShowValue = False

dataBar.BarBorder.Type = DataBarBorderType.DataBarBorderSolid

dataBar.BarBorder.Color = Color.Plum

 dataBar.BarFillType = DataBarFillType.DataBarFillSolid

 dataBar.AxisColor = Color.Red

 dataBar.AxisPosition = DataBarAxisPosition.DataBarAxisMidpoint

 dataBar.NegativeBarFormat.ColorType = DataBarNegativeColorType.DataBarColor

 dataBar.NegativeBarFormat.Color = Color.White

 dataBar.NegativeBarFormat.BorderColorType = DataBarNegativeColorType.DataBarColor

 dataBar.NegativeBarFormat.BorderColor = Color.Yellow

'Put Cell Values
Dim cell1 As Aspose.Cells.Cell = sheet.Cells("A1")

cell1.PutValue(10)

Dim cell2 As Aspose.Cells.Cell = sheet.Cells("A2")

cell2.PutValue(120)

Dim cell3 As Aspose.Cells.Cell = sheet.Cells("A3")

cell3.PutValue(260)

'Saving the Excel file
workbook.Save("D:\book1.xlsx")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataBar Members | Aspose.Cells Namespace


DataBar Members

DataBar overview

Public Instance Properties

AxisColor | Gets the color of the axis for cells with conditional formatting as data bars.
AxisPosition | Gets or sets the position of the axis of the data bars specified by a conditional formatting rule.
BarBorder | Gets an object that specifies the border of a data bar.
BarFillType | Gets or sets how a data bar is filled with color.
Color | Get or set this DataBar's Color.
Direction | Gets or sets the direction the databar is displayed.
MaxCfvo | Get or set this DataBar's max value object. Cannot set null or CFValueObject with type FormatConditionValueType.Min to it.
MaxLength | Represents the max length of data bar .
MinCfvo | Get or set this DataBar's min value object. Cannot set null or CFValueObject with type FormatConditionValueType.Max to it.
MinLength | Represents the min length of data bar .
NegativeBarFormat | Gets the NegativeBarFormat object associated with a data bar conditional formatting rule.
ShowValue | Get or set the flag indicating whether to show the values of the cells on which this data bar is applied. Default value is true.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToImage | Render data bar in cell to image byte array.
ToString (inherited from Object) |

See Also

DataBar Class | Aspose.Cells Namespace


DataBar Properties

The properties of the DataBar class are listed below. For a complete list of DataBar class members, see the DataBar Members topic.

Public Instance Properties

AxisColor | Gets the color of the axis for cells with conditional formatting as data bars.
AxisPosition | Gets or sets the position of the axis of the data bars specified by a conditional formatting rule.
BarBorder | Gets an object that specifies the border of a data bar.
BarFillType | Gets or sets how a data bar is filled with color.
Color | Get or set this DataBar's Color.
Direction | Gets or sets the direction the databar is displayed.
MaxCfvo | Get or set this DataBar's max value object. Cannot set null or CFValueObject with type FormatConditionValueType.Min to it.
MaxLength | Represents the max length of data bar .
MinCfvo | Get or set this DataBar's min value object. Cannot set null or CFValueObject with type FormatConditionValueType.Max to it.
MinLength | Represents the min length of data bar .
NegativeBarFormat | Gets the NegativeBarFormat object associated with a data bar conditional formatting rule.
ShowValue | Get or set the flag indicating whether to show the values of the cells on which this data bar is applied. Default value is true.

See Also

DataBar Class | Aspose.Cells Namespace


AxisColor Property

Aspose.Cells for .NET

DataBar.AxisColor Property

Gets the color of the axis for cells with conditional formatting as data bars.

public Color AxisColor {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


AxisPosition Property

Aspose.Cells for .NET

DataBar.AxisPosition Property

Gets or sets the position of the axis of the data bars specified by a conditional formatting rule.

public DataBarAxisPosition AxisPosition {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


BarBorder Property

Aspose.Cells for .NET

DataBar.BarBorder Property

Gets an object that specifies the border of a data bar.

public DataBarBorder BarBorder {get;}

See Also

DataBar Class | Aspose.Cells Namespace


BarFillType Property

Aspose.Cells for .NET

DataBar.BarFillType Property

Gets or sets how a data bar is filled with color.

public DataBarFillType BarFillType {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

DataBar.Color Property

Get or set this DataBar's Color.

public Color Color {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


Direction Property

Aspose.Cells for .NET

DataBar.Direction Property

Gets or sets the direction the databar is displayed.

public TextDirectionType Direction {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


MaxCfvo Property

Aspose.Cells for .NET

DataBar.MaxCfvo Property

Get or set this DataBar's max value object. Cannot set null or CFValueObject with type FormatConditionValueType.Min to it.

public ConditionalFormattingValue MaxCfvo {get;}

See Also

DataBar Class | Aspose.Cells Namespace


MaxLength Property

Aspose.Cells for .NET

DataBar.MaxLength Property

Represents the max length of data bar .

public int MaxLength {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


MinCfvo Property

Aspose.Cells for .NET

DataBar.MinCfvo Property

Get or set this DataBar's min value object. Cannot set null or CFValueObject with type FormatConditionValueType.Max to it.

public ConditionalFormattingValue MinCfvo {get;}

See Also

DataBar Class | Aspose.Cells Namespace


MinLength Property

Aspose.Cells for .NET

DataBar.MinLength Property

Represents the min length of data bar .

public int MinLength {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


NegativeBarFormat Property

Aspose.Cells for .NET

DataBar.NegativeBarFormat Property

Gets the NegativeBarFormat object associated with a data bar conditional formatting rule.

public NegativeBarFormat NegativeBarFormat {get;}

See Also

DataBar Class | Aspose.Cells Namespace


ShowValue Property

Aspose.Cells for .NET

DataBar.ShowValue Property

Get or set the flag indicating whether to show the values of the cells on which this data bar is applied. Default value is true.

public bool ShowValue {get; set;}

See Also

DataBar Class | Aspose.Cells Namespace


DataBar Methods

The methods of the DataBar class are listed below. For a complete list of DataBar class members, see the DataBar Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToImage | Render data bar in cell to image byte array.
ToString (inherited from Object) |

See Also

DataBar Class | Aspose.Cells Namespace


DataBar.ToImage Method

Render data bar in cell to image byte array.

public byte[] ToImage(
Cell cell,
ImageOrPrintOptions imgOpts
);

Parameters

cell
Indicate the data bar in which cell to be rendered
imgOpts
ImageOrPrintOptions contains some property of output image

Return Value

See Also

DataBar Class | Aspose.Cells Namespace


DataBarAxisPosition Enumeration

Specifies the axis position for a range of cells with conditional formatting as data bars.

public enum DataBarAxisPosition

Members

Member Name | Description | Value
DataBarAxisAutomatic | Obsolete. Use DataBarAxisPosition.Automatic enum type method instead. Display the axis at a variable position based on the ratio of the minimum negative value to the maximum positive value in the range. Positive values are displayed in a left-to-right direction. Negative values are displayed in a right-to-left direction. When all values are positive or all values are negative, no axis is displayed. | 0
DataBarAxisMidpoint | Obsolete. Use DataBarAxisPosition.Midpoint enum type method instead. Display the axis at the midpoint of the cell regardless of the set of values in the range. Positive values are displayed in a left-to-right direction. Negative values are displayed in a right-to-left direction. | 1
DataBarAxisNone | Obsolete. Use DataBarAxisPosition.None enum type method instead. No axis is displayed, and both positive and negative values are displayed in the left-to-right direction. | 2
Automatic | Display the axis at a variable position based on the ratio of the minimum negative value to the maximum positive value in the range. Positive values are displayed in a left-to-right direction. Negative values are displayed in a right-to-left direction. When all values are positive or all values are negative, no axis is displayed. | 0
Midpoint | Display the axis at the midpoint of the cell regardless of the set of values in the range. Positive values are displayed in a left-to-right direction. Negative values are displayed in a right-to-left direction. | 1
None | No axis is displayed, and both positive and negative values are displayed in the left-to-right direction. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DataBarBorder Class

Represents the border of the data bars specified by a conditional formatting rule.

For a list of all members of this type, see DataBarBorder Members.

System.Object
Aspose.Cells.DataBarBorder

public class DataBarBorder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataBarBorder Members | Aspose.Cells Namespace


DataBarBorder Members

DataBarBorder overview

Public Instance Properties

Color | Gets or sets the border's color of data bars specified by a conditional formatting rule.
Type | Gets or sets the border's type of data bars specified by a conditional formatting rule.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DataBarBorder Class | Aspose.Cells Namespace


DataBarBorder Properties

The properties of the DataBarBorder class are listed below. For a complete list of DataBarBorder class members, see the DataBarBorder Members topic.

Public Instance Properties

Color | Gets or sets the border's color of data bars specified by a conditional formatting rule.
Type | Gets or sets the border's type of data bars specified by a conditional formatting rule.

See Also

DataBarBorder Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

DataBarBorder.Color Property

Gets or sets the border's color of data bars specified by a conditional formatting rule.

public Color Color {get; set;}

See Also

DataBarBorder Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

DataBarBorder.Type Property

Gets or sets the border's type of data bars specified by a conditional formatting rule.

public DataBarBorderType Type {get; set;}

See Also

DataBarBorder Class | Aspose.Cells Namespace


DataBarBorderType Enumeration

Specifies the border type of a data bar.

public enum DataBarBorderType

Members

Member Name | Description | Value
DataBarBorderNone | Obsolete. Use DataBarBorderType.None enum type method instead. The data bar has no border. | 0
DataBarBorderSolid | Obsolete. Use DataBarBorderType.Solid enum type method instead. The data bar has a solid border. | 1
None | The data bar has no border. | 0
Solid | The data bar has a solid border. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DataBarFillType Enumeration

Specifies how a data bar is filled with color.

public enum DataBarFillType

Members

Member Name | Description | Value
DataBarFillSolid | Obsolete. Use DataBarFillType.Solid enum type method instead. The data bar is filled with solid color. | 0
DataBarFillGradient | Obsolete. Use DataBarFillType.Gradient enum type method instead. The data bar is filled with a color gradient. | 1
Solid | The data bar is filled with solid color. | 0
Gradient | The data bar is filled with a color gradient. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DataBarNegativeColorType Enumeration

Specifies whether to use the same border and fill color as positive data bars.

public enum DataBarNegativeColorType

Members

Member Name | Description | Value
DataBarColor | Obsolete. Use DataBarNegativeColorType.Color enum type method instead. Use the color specified in the Negative Value and Axis Setting dialog box or by using the ColorType and BorderColorType properties of the NegativeBarFormat object. | 0
DataBarSameAsPositive | Obsolete. Use DataBarNegativeColorType.SameAsPositive enum type method instead. Use the same color as positive data bars. | 1
Color | Use the color specified in the Negative Value and Axis Setting dialog box or by using the ColorType and BorderColorType properties of the NegativeBarFormat object. | 0
SameAsPositive | Use the same color as positive data bars. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DataSorter Class

Summary description for DataSorter.

For a list of all members of this type, see DataSorter Members.

System.Object
Aspose.Cells.DataSorter

public class DataSorter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate a new Workbook object.
Workbook workbook = new Workbook("C:\\Book1.xls");
//Get the workbook datasorter object.
DataSorter sorter = workbook.DataSorter;
//Set the first order for datasorter object.
sorter.Order1 = Aspose.Cells.SortOrder.Descending;
//Define the first key.
sorter.Key1 = 0;
//Set the second order for datasorter object.
sorter.Order2 = Aspose.Cells.SortOrder.Ascending;
//Define the second key.
sorter.Key2 = 1;
//Create a cells area (range).
CellArea ca = new CellArea();
//Specify the start row index.
ca.StartRow = 0;
//Specify the start column index.
ca.StartColumn = 0;
//Specify the last row index.
ca.EndRow = 13;
//Specify the last column index.
ca.EndColumn = 1;
//Sort data in the specified data range (A1:B14)
sorter.Sort(workbook.Worksheets[0].Cells, ca);
//Save the excel file.
workbook.Save("C:\\outBook.xls");

[Visual Basic]

'Instantiate a new Workbook object.
Dim workbook As Workbook = New Workbook("C:\Book1.xls")
'Get the workbook datasorter object.
Dim sorter As DataSorter = workbook.DataSorter
'Set the first order for datasorter object
sorter.Order1 = Aspose.Cells.SortOrder.Descending
'Define the first key.
sorter.Key1 = 0
'Set the second order for datasorter object.
sorter.Order2 = Aspose.Cells.SortOrder.Ascending
'Define the second key.
sorter.Key2 = 1
'Create a cells area (range).
Dim ca As CellArea = New CellArea
'Specify the start row index.
ca.StartRow = 0
'Specify the start column index.
ca.StartColumn = 0
'Specify the last row index.
ca.EndRow = 13
'Specify the last column index.
ca.EndColumn = 1
'Sort the data in the specified data range (A1:B14)
sorter.Sort(workbook.Worksheets(0).Cells, ca)
'Save the excel file.
workbook.Save("C:\outBook.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataSorter Members | Aspose.Cells Namespace


DataSorter Members

DataSorter overview

Public Instance Properties

CaseSensitive | Gets and sets whether case sensitive when comparing string.
HasHeaders | Represents whether the range has headers.
Key1 | Represents first sorted column index(absolute position, column A is 0, B is 1, ...).
Key2 | Represents second sorted column index(absolute position, column A is 0, B is 1, ...).
Key3 | Represents third sorted column index(absolute position, column A is 0, B is 1, ...).
Keys | Gets the key list of data sorter.
Order1 | Represents sort order of the first key.
Order2 | Represents sort order of the second key.
Order3 | Represents sort order of the third key.
SortAsNumber | Indicates whether sorting anything that looks like a number.
SortLeftToRight | True means that sorting orientation is from left to right. False means that sorting orientation is from top to bottom. The default value is false.

Public Instance Methods

AddKey | Overloaded. Adds sorted column index and sort order.
Clear | Clear all settings.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Sort | Overloaded. Sorts the data of the area.
ToString (inherited from Object) |

See Also

DataSorter Class | Aspose.Cells Namespace


DataSorter Properties

The properties of the DataSorter class are listed below. For a complete list of DataSorter class members, see the DataSorter Members topic.

Public Instance Properties

CaseSensitive | Gets and sets whether case sensitive when comparing string.
HasHeaders | Represents whether the range has headers.
Key1 | Represents first sorted column index(absolute position, column A is 0, B is 1, ...).
Key2 | Represents second sorted column index(absolute position, column A is 0, B is 1, ...).
Key3 | Represents third sorted column index(absolute position, column A is 0, B is 1, ...).
Keys | Gets the key list of data sorter.
Order1 | Represents sort order of the first key.
Order2 | Represents sort order of the second key.
Order3 | Represents sort order of the third key.
SortAsNumber | Indicates whether sorting anything that looks like a number.
SortLeftToRight | True means that sorting orientation is from left to right. False means that sorting orientation is from top to bottom. The default value is false.

See Also

DataSorter Class | Aspose.Cells Namespace


CaseSensitive Property

Aspose.Cells for .NET

DataSorter.CaseSensitive Property

Gets and sets whether case sensitive when comparing string.

public bool CaseSensitive {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


HasHeaders Property

Aspose.Cells for .NET

DataSorter.HasHeaders Property

Represents whether the range has headers.

public bool HasHeaders {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


Key1 Property

Aspose.Cells for .NET

DataSorter.Key1 Property

Represents first sorted column index(absolute position, column A is 0, B is 1, ...).

public int Key1 {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


Key2 Property

Aspose.Cells for .NET

DataSorter.Key2 Property

Represents second sorted column index(absolute position, column A is 0, B is 1, ...).

public int Key2 {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


Key3 Property

Aspose.Cells for .NET

DataSorter.Key3 Property

Represents third sorted column index(absolute position, column A is 0, B is 1, ...).

public int Key3 {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


Keys Property

Aspose.Cells for .NET

DataSorter.Keys Property

Gets the key list of data sorter.

public DataSorterKeyCollection Keys {get;}

See Also

DataSorter Class | Aspose.Cells Namespace


Order1 Property

Aspose.Cells for .NET

DataSorter.Order1 Property

Represents sort order of the first key.

public SortOrder Order1 {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


Order2 Property

Aspose.Cells for .NET

DataSorter.Order2 Property

Represents sort order of the second key.

public SortOrder Order2 {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


Order3 Property

Aspose.Cells for .NET

DataSorter.Order3 Property

Represents sort order of the third key.

public SortOrder Order3 {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


SortAsNumber Property

Aspose.Cells for .NET

DataSorter.SortAsNumber Property

Indicates whether sorting anything that looks like a number.

public bool SortAsNumber {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


SortLeftToRight Property

Aspose.Cells for .NET

DataSorter.SortLeftToRight Property

True means that sorting orientation is from left to right. False means that sorting orientation is from top to bottom. The default value is false.

public bool SortLeftToRight {get; set;}

See Also

DataSorter Class | Aspose.Cells Namespace


DataSorter Methods

The methods of the DataSorter class are listed below. For a complete list of DataSorter class members, see the DataSorter Members topic.

Public Instance Methods

AddKey | Overloaded. Adds sorted column index and sort order.
Clear | Clear all settings.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Sort | Overloaded. Sorts the data of the area.
ToString (inherited from Object) |

See Also

DataSorter Class | Aspose.Cells Namespace


AddKey Method

Aspose.Cells for .NET

DataSorter.AddKey Method

Adds sorted column index and sort order with custom sort list.

Overload List

Adds sorted column index and sort order with custom sort list.

public void AddKey(int,SortOnType,SortOrder,object);

Adds sorted column index and sort order.

public void AddKey(int,SortOrder);

Adds sorted column index and sort order with custom sort list.

public void AddKey(int,SortOrder,string);

Adds sorted column index and sort order with custom sort list.

public void AddKey(int,SortOrder,string[]);

See Also

DataSorter Class | Aspose.Cells Namespace


DataSorter.AddKey Method (Int32, SortOnType, SortOrder, Object)

Adds sorted column index and sort order with custom sort list.

public void AddKey(
int key,
SortOnType type,
SortOrder order,
object customList
);

Parameters

key
The sorted column index(absolute position, column A is 0, B is 1, ...)
type
The sorted value type.
order
The sort order.
customList
The custom sort list.

Remarks

If type is SortOnType.CellColor or SortOnType.FontColor, the customList is Color.

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.AddKey Overload List


DataSorter.AddKey Method (Int32, SortOrder)

Adds sorted column index and sort order.

public void AddKey(
int key,
SortOrder order
);

Parameters

key
The sorted column index(absolute position, column A is 0, B is 1, ...)
order
The sort order

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.AddKey Overload List


DataSorter.AddKey Method (Int32, SortOrder, String)

Adds sorted column index and sort order with custom sort list.

public void AddKey(
int key,
SortOrder order,
string customList
);

Parameters

key
The sorted column index(absolute position, column A is 0, B is 1, ...)
order
The sort order.
customList
The custom sort list.

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.AddKey Overload List


DataSorter.AddKey Method (Int32, SortOrder, String[])

Adds sorted column index and sort order with custom sort list.

public void AddKey(
int key,
SortOrder order,
string[] customList
);

Parameters

key
The sorted column index(absolute position, column A is 0, B is 1, ...)
order
The sort order.
customList
The custom sort list.

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.AddKey Overload List


DataSorter.Clear Method

Clear all settings.

public void Clear();

See Also

DataSorter Class | Aspose.Cells Namespace


Sort Method

Aspose.Cells for .NET

DataSorter.Sort Method

Sort the data in the range.

Overload List

Sort the data in the range.

public void Sort();

Sort the data of the area.

public void Sort(Cells,CellArea);

Sorts the data of the area.

public void Sort(Cells,int,int,int,int);

See Also

DataSorter Class | Aspose.Cells Namespace


DataSorter.Sort Method ()

Sort the data in the range.

public void Sort();

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.Sort Overload List


DataSorter.Sort Method (Cells, CellArea)

Sort the data of the area.

public void Sort(
Cells cells,
CellArea area
);

Parameters

cells
The cells contains the data area.
area
The area needed to sort

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.Sort Overload List


DataSorter.Sort Method (Cells, Int32, Int32, Int32, Int32)

Sorts the data of the area.

public void Sort(
Cells cells,
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

cells
The cells contains the data area.
startRow
The start row of the area.
startColumn
The start column of the area.
endRow
The end row of the area.
endColumn
The end column of the area.

See Also

DataSorter Class | Aspose.Cells Namespace | DataSorter.Sort Overload List


DataSorterKey Class

Represents the key of the data sorter.

For a list of all members of this type, see DataSorterKey Members.

System.Object
Aspose.Cells.DataSorterKey

public class DataSorterKey

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataSorterKey Members | Aspose.Cells Namespace


DataSorterKey Members

DataSorterKey overview

Public Instance Properties

Color | Gets the sorted color.
IconId | Represents the id of the icon set type.
IconSetType | Represents the icon set type.
Index | Gets the sorted column index(absolute position, column A is 0, B is 1, ...).
Order | Indicates the order of sorting.
Type | Represents the type of sorting.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DataSorterKey Class | Aspose.Cells Namespace


DataSorterKey Properties

The properties of the DataSorterKey class are listed below. For a complete list of DataSorterKey class members, see the DataSorterKey Members topic.

Public Instance Properties

Color | Gets the sorted color.
IconId | Represents the id of the icon set type.
IconSetType | Represents the icon set type.
Index | Gets the sorted column index(absolute position, column A is 0, B is 1, ...).
Order | Indicates the order of sorting.
Type | Represents the type of sorting.

See Also

DataSorterKey Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

DataSorterKey.Color Property

Gets the sorted color.

public Color Color {get;}

Remarks

Only effects when SortOnType is SortOnType.CellColor or SortOnType.FontColor.

See Also

DataSorterKey Class | Aspose.Cells Namespace


IconId Property

Aspose.Cells for .NET

DataSorterKey.IconId Property

Represents the id of the icon set type.

public int IconId {get;}

Remarks

Only effects when SortOnType is SortOnType.Icon.

See Also

DataSorterKey Class | Aspose.Cells Namespace


IconSetType Property

Aspose.Cells for .NET

DataSorterKey.IconSetType Property

Represents the icon set type.

public IconSetType IconSetType {get;}

Remarks

Only effects when SortOnType is SortOnType.Icon.

See Also

DataSorterKey Class | Aspose.Cells Namespace


Index Property

Aspose.Cells for .NET

DataSorterKey.Index Property

Gets the sorted column index(absolute position, column A is 0, B is 1, ...).

public int Index {get;}

See Also

DataSorterKey Class | Aspose.Cells Namespace


Order Property

Aspose.Cells for .NET

DataSorterKey.Order Property

Indicates the order of sorting.

public SortOrder Order {get;}

See Also

DataSorterKey Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

DataSorterKey.Type Property

Represents the type of sorting.

public SortOnType Type {get;}

See Also

DataSorterKey Class | Aspose.Cells Namespace


DataSorterKeyCollection Class

Represents the key list of data sorter.

For a list of all members of this type, see DataSorterKeyCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.DataSorterKeyCollection

public class DataSorterKeyCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataSorterKeyCollection Members | Aspose.Cells Namespace


DataSorterKeyCollection Members

DataSorterKeyCollection overview

Public Instance Constructors

DataSorterKeyCollection Constructor Initializes a new instance of the DataSorterKeyCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets and sets DataSorterKey by index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

DataSorterKeyCollection Class | Aspose.Cells Namespace


DataSorterKeyCollection Constructor

Initializes a new instance of the DataSorterKeyCollection class.

public DataSorterKeyCollection();

See Also

DataSorterKeyCollection Class | Aspose.Cells Namespace


DataSorterKeyCollection Properties

The properties of the DataSorterKeyCollection class are listed below. For a complete list of DataSorterKeyCollection class members, see the DataSorterKeyCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets and sets DataSorterKey by index.

See Also

DataSorterKeyCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

DataSorterKeyCollection.Item Property

Gets and sets DataSorterKey by index.

public DataSorterKey this[
int index
] {get;}

Parameters

index
The index.

See Also

DataSorterKeyCollection Class | Aspose.Cells Namespace


DateTimeGroupingType Enumeration

Specifies how to group dateTime values.

public enum DateTimeGroupingType

Members

Member Name | Description | Value
Day | Group by day. | 0
Hour | Group by hour. | 1
Minute | Group by Minute. | 2
Month | Group by Month. | 3
Second | Group by Second. | 4
Year | Group by Year. | 5

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DateTimeGroupItem Class

Represents the datetime's group setting.

For a list of all members of this type, see DateTimeGroupItem Members.

System.Object
Aspose.Cells.DateTimeGroupItem

public class DateTimeGroupItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DateTimeGroupItem Members | Aspose.Cells Namespace


DateTimeGroupItem Members

DateTimeGroupItem overview

Public Instance Constructors

DateTimeGroupItem Constructor

Public Instance Properties

DateTimeGroupingType | Gets and sets the group type.
Day | Gets and sets the day of the grouped date time.
Hour | Gets and sets the hour of the grouped date time.
Minute | Gets and sets the minute of the grouped date time.
MinValue | Gets the min value.
Month | Gets and sets the month of the grouped date time.
Second | Gets and sets the second of the grouped date time.
Year | Gets and sets the year of the grouped date time.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


DateTimeGroupItem Constructor

public DateTimeGroupItem(
DateTimeGroupingType type,
int year,
int month,
int day,
int hour,
int minute,
int second
);

Parameters

type
year
month
day
hour
minute
second

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


DateTimeGroupItem Properties

The properties of the DateTimeGroupItem class are listed below. For a complete list of DateTimeGroupItem class members, see the DateTimeGroupItem Members topic.

Public Instance Properties

DateTimeGroupingType | Gets and sets the group type.
Day | Gets and sets the day of the grouped date time.
Hour | Gets and sets the hour of the grouped date time.
Minute | Gets and sets the minute of the grouped date time.
MinValue | Gets the min value.
Month | Gets and sets the month of the grouped date time.
Second | Gets and sets the second of the grouped date time.
Year | Gets and sets the year of the grouped date time.

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


DateTimeGroupingType Property

Aspose.Cells for .NET

DateTimeGroupItem.DateTimeGroupingType Property

Gets and sets the group type.

public DateTimeGroupingType DateTimeGroupingType {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


Day Property

Aspose.Cells for .NET

DateTimeGroupItem.Day Property

Gets and sets the day of the grouped date time.

public int Day {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


Hour Property

Aspose.Cells for .NET

DateTimeGroupItem.Hour Property

Gets and sets the hour of the grouped date time.

public int Hour {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


Minute Property

Aspose.Cells for .NET

DateTimeGroupItem.Minute Property

Gets and sets the minute of the grouped date time.

public int Minute {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


MinValue Property

Aspose.Cells for .NET

DateTimeGroupItem.MinValue Property

Gets the min value.

public DateTime MinValue {get;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


Month Property

Aspose.Cells for .NET

DateTimeGroupItem.Month Property

Gets and sets the month of the grouped date time.

public int Month {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


Second Property

Aspose.Cells for .NET

DateTimeGroupItem.Second Property

Gets and sets the second of the grouped date time.

public int Second {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


Year Property

Aspose.Cells for .NET

DateTimeGroupItem.Year Property

Gets and sets the year of the grouped date time.

public int Year {get; set;}

See Also

DateTimeGroupItem Class | Aspose.Cells Namespace


DefaultEditLanguage Enumeration

Represents the default edit language.

public enum DefaultEditLanguage

Members

Member Name | Description | Value
Auto | Represents auto detecting edit language according to the text itself. | 0
English | Represents English language. | 1
CJK | Represents Chinese, Japanese, Korean language. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DeleteOptions Class

Represents the setting of deleting rows/columns.

For a list of all members of this type, see DeleteOptions Members.

System.Object
Aspose.Cells.DeleteOptions

public class DeleteOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DeleteOptions Members | Aspose.Cells Namespace


DeleteOptions Members

DeleteOptions overview

Public Instance Constructors

DeleteOptions Constructor Initializes a new instance of the DeleteOptions class.

Public Instance Properties

UpdateReference Indicates if update references in other worksheets.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DeleteOptions Class | Aspose.Cells Namespace


DeleteOptions Constructor

Initializes a new instance of the DeleteOptions class.

public DeleteOptions();

See Also

DeleteOptions Class | Aspose.Cells Namespace


DeleteOptions Properties

The properties of the DeleteOptions class are listed below. For a complete list of DeleteOptions class members, see the DeleteOptions Members topic.

Public Instance Properties

UpdateReference Indicates if update references in other worksheets.

See Also

DeleteOptions Class | Aspose.Cells Namespace


UpdateReference Property

Aspose.Cells for .NET

DeleteOptions.UpdateReference Property

Indicates if update references in other worksheets.

public bool UpdateReference {get; set;}

See Also

DeleteOptions Class | Aspose.Cells Namespace


DifSaveOptions Class

Represents the options of saving dif file.

For a list of all members of this type, see DifSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.DifSaveOptions

public class DifSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DifSaveOptions Members | Aspose.Cells Namespace


DifSaveOptions Members

DifSaveOptions overview

Public Instance Constructors

DifSaveOptions Constructor Creates the options for saving DIF file.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DifSaveOptions Class | Aspose.Cells Namespace


DifSaveOptions Constructor

Creates the options for saving DIF file.

public DifSaveOptions();

See Also

DifSaveOptions Class | Aspose.Cells Namespace


DirectoryType Enumeration

Represents the directory type of the file name.

public enum DirectoryType

Members

Member Name | Description | Value
Volume | Represents an MS-DOS drive letter. It is followed by the drive letter. Or UNC file names, such as \\server\share\myfile.xls | 0
SameVolume | Indicates that the source workbook is on the same drive as the dependent workbook (the drive letter is omitted) | 1
DownDirectory | Indicates that the source workbook is in a subdirectory of the current directory. | 2
UpDirectory | Indicates that the source workbook is in the parent directory of the current directory. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DisplayDrawingObjects Enumeration

Represents whether and how to show objects in the workbook.

public enum DisplayDrawingObjects

Members

Member Name | Description | Value
DisplayShapes | Show all objects | 0
Placeholders | Show placeholders | 1
Hide | Hide all shapes. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


DocxSaveOptions Class

Represents options of saving docx file.

For a list of all members of this type, see DocxSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.DocxSaveOptions

public class DocxSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DocxSaveOptions Members | Aspose.Cells Namespace


DocxSaveOptions Members

DocxSaveOptions overview

Public Instance Constructors

DocxSaveOptions Constructor Represents the pptx save options.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DocxSaveOptions Class | Aspose.Cells Namespace


DocxSaveOptions Constructor

Represents the pptx save options.

public DocxSaveOptions();

See Also

DocxSaveOptions Class | Aspose.Cells Namespace


DxfCollection Class

Represents the master differential formatting records.

For a list of all members of this type, see DxfCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.DxfCollection

public class DxfCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DxfCollection Members | Aspose.Cells Namespace


DxfCollection Members

DxfCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the element at the specified index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

DxfCollection Class | Aspose.Cells Namespace


DxfCollection Properties

The properties of the DxfCollection class are listed below. For a complete list of DxfCollection class members, see the DxfCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the element at the specified index.

See Also

DxfCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

DxfCollection.Item Property

Gets the element at the specified index.

public Style this[
int index
] {get;}

Parameters

index
The specified index.

See Also

DxfCollection Class | Aspose.Cells Namespace


DynamicFilter Class

Represents the dynamic filter.

For a list of all members of this type, see DynamicFilter Members.

System.Object
Aspose.Cells.DynamicFilter

public class DynamicFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DynamicFilter Members | Aspose.Cells Namespace


DynamicFilter Members

DynamicFilter overview

Public Instance Properties

DynamicFilterType | Gets and sets the dynamic filter type.
MaxValue | Gets and sets the dynamic filter max value.
Value | Gets and sets the dynamic filter value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DynamicFilter Class | Aspose.Cells Namespace


DynamicFilter Properties

The properties of the DynamicFilter class are listed below. For a complete list of DynamicFilter class members, see the DynamicFilter Members topic.

Public Instance Properties

DynamicFilterType | Gets and sets the dynamic filter type.
MaxValue | Gets and sets the dynamic filter max value.
Value | Gets and sets the dynamic filter value.

See Also

DynamicFilter Class | Aspose.Cells Namespace


DynamicFilterType Property

Aspose.Cells for .NET

DynamicFilter.DynamicFilterType Property

Gets and sets the dynamic filter type.

public DynamicFilterType DynamicFilterType {get; set;}

See Also

DynamicFilter Class | Aspose.Cells Namespace


MaxValue Property

Aspose.Cells for .NET

DynamicFilter.MaxValue Property

Gets and sets the dynamic filter max value.

public object MaxValue {get; set;}

See Also

DynamicFilter Class | Aspose.Cells Namespace


Value Property

Aspose.Cells for .NET

DynamicFilter.Value Property

Gets and sets the dynamic filter value.

public object Value {get; set;}

See Also

DynamicFilter Class | Aspose.Cells Namespace


DynamicFilterType Enumeration

Dynamic filter type.

public enum DynamicFilterType

Members

Member Name | Description | Value
AboveAverage | Shows values that are above average. | 0
BelowAverage | Shows values that are below average. | 1
LastMonth | Shows last month's dates. | 2
LastQuarter | Shows last quarter's dates. | 3
LastWeek | Shows last week's dates. | 4
LastYear | Shows last year's dates. | 5
January | Shows the dates that are in January, regardless of year. | 6
October | Shows the dates that are in October, regardless of year. | 7
November | Shows the dates that are in November, regardless of year. | 8
December | Shows the dates that are in December, regardless of year. | 9
Februray | Obsolete. Use DynamicFilterType.February instead. Shows the dates that are in February, regardless of year. | 10
February | Shows the dates that are in February, regardless of year. | 11
March | Shows the dates that are in March, regardless of year. | 12
April | Shows the dates that are in April, regardless of year. | 13
May | Shows the dates that are in May, regardless of year. | 14
June | Shows the dates that are in June, regardless of year. | 15
July | Shows the dates that are in July, regardless of year. | 16
August | Shows the dates that are in August, regardless of year. | 17
September | Shows the dates that are in September, regardless of year. | 18
NextMonth | Shows next month's dates. | 19
NextQuarter | Shows next quarter's dates. | 20
NextWeek | Shows next week's dates. | 21
NextYear | Shows next year's dates. | 22
None |  | 23
Quarter1 | Shows the dates that are in the 1st quarter, regardless of year. | 24
Quarter2 | Shows the dates that are in the 2nd quarter, regardless of year. | 25
Quarter3 | Shows the dates that are in the 3rd quarter, regardless of year. | 26
Quarter4 | Shows the dates that are in the 4th quarter, regardless of year. | 27
ThisMonth | Shows this month's dates. | 28
ThisQuarter | Shows this quarter's dates. | 29
ThisWeek | Shows this week's dates. | 30
ThisYear | Shows this year's dates. | 31
Today | Shows today's dates. | 32
Tomorrow | Shows tomorrow's dates. | 33
YearToDate | Shows the dates between the beginning of the year and today, inclusive. | 34
Yesterday | Shows yesterday's dates. | 35

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


EmfRenderSetting Enumeration

Setting for rendering Emf metafile.

public enum EmfRenderSetting

Members

Member Name | Description | Value
EmfOnly | Only rendering Emf records. | 0
EmfPlusPrefer | Prefer rendering EmfPlus records. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


EncryptionType Enumeration

Encryption Type. Only used by excel2003. We will encrypt 2007/2010 workbook using SHA AES the same as Excel does, and this EncryptionType will be ignored.

public enum EncryptionType

Members

Member Name | Description | Value
XOR |  | 0
Compatible | Office 97/2000 compatible. | 1
EnhancedCryptographicProviderV1 |  | 2
StrongCryptographicProvider |  | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ErrorCheckOption Class

Error check setting applied on certain ranges.

For a list of all members of this type, see ErrorCheckOption Members.

System.Object
Aspose.Cells.ErrorCheckOption

public class ErrorCheckOption

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

  Workbook workbook = new Workbook();
  ErrorCheckOptionCollection opts = workbook.Worksheets[0].ErrorCheckOptions;
  int optionIdx = opts.Add();
  ErrorCheckOption opt = opts[optionIdx];
  opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.InconsistFormula, false);
  opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.InconsistRange, false);
  opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.TextDate, false);
  opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.TextNumber, false);
  opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.Validation, false);
  opt.AddRange(CellArea.CreateCellArea("A1", "B10"));
  workbook.Save(@"D:\Filetemp\Book1.xlsx");

[Visual Basic]

   Dim workbook As Workbook = New Workbook()
   Dim opts As ErrorCheckOptionCollection = workbook.Worksheets(0).ErrorCheckOptions
   Dim optionIdx As Integer = opts.Add()
   Dim opt As ErrorCheckOption = opts(optionIdx)
   opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.InconsistFormula, False)
   opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.InconsistRange, False)
   opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.TextDate, False)
   opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.TextNumber, False)
   opt.SetErrorCheck(Aspose.Cells.ErrorCheckType.Validation, False)
   opt.AddRange(CellArea.CreateCellArea("A1", "B10"))
   workbook.Save("D:\Filetemp\Book1.xlsx")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ErrorCheckOption Members | Aspose.Cells Namespace


ErrorCheckOption Members

ErrorCheckOption overview

Public Instance Methods

AddRange | Adds one influenced range by this setting.
Equals (inherited from Object) |
GetCountOfRange | Gets the count of ranges that influenced by this setting.
GetHashCode (inherited from Object) |
GetRange | Gets the influenced range of this setting by given index.
GetType (inherited from Object) |
IsErrorCheck | Checks whether given error type will be checked.
RemoveRange | Removes one range by given index.
SetErrorCheck | Sets whether given error type will be checked.
ToString (inherited from Object) |

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption Methods

The methods of the ErrorCheckOption class are listed below. For a complete list of ErrorCheckOption class members, see the ErrorCheckOption Members topic.

Public Instance Methods

AddRange | Adds one influenced range by this setting.
Equals (inherited from Object) |
GetCountOfRange | Gets the count of ranges that influenced by this setting.
GetHashCode (inherited from Object) |
GetRange | Gets the influenced range of this setting by given index.
GetType (inherited from Object) |
IsErrorCheck | Checks whether given error type will be checked.
RemoveRange | Removes one range by given index.
SetErrorCheck | Sets whether given error type will be checked.
ToString (inherited from Object) |

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption.AddRange Method

Adds one influenced range by this setting.

public int AddRange(
CellArea ca
);

Parameters

ca
the range to be added.

Return Value

the index of the added range in the range list of this setting.

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption.GetCountOfRange Method

Gets the count of ranges that influenced by this setting.

public int GetCountOfRange();

Return Value

the count of ranges that influenced by this setting.

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption.GetRange Method

Gets the influenced range of this setting by given index.

public CellArea GetRange(
int index
);

Parameters

index
the index of range

Return Value

return influenced range at given index.

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption.IsErrorCheck Method

Checks whether given error type will be checked.

public bool IsErrorCheck(
ErrorCheckType errorCheckType
);

Parameters

errorCheckType
error type can be checked

Return Value

return true if given error type will be checked(green triangle will be shown for cell if the check failed).

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption.RemoveRange Method

Removes one range by given index.

public void RemoveRange(
int index
);

Parameters

index
the index of the range to be removed.

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOption.SetErrorCheck Method

Sets whether given error type will be checked.

public void SetErrorCheck(
ErrorCheckType errorCheckType,
bool isCheck
);

Parameters

errorCheckType
error type can be checked.
isCheck
true if given error type needs to be checked(green triangle will be shown for cell if the check failed).

See Also

ErrorCheckOption Class | Aspose.Cells Namespace


ErrorCheckOptionCollection Class

Represents all error check option.

For a list of all members of this type, see ErrorCheckOptionCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ErrorCheckOptionCollection

public class ErrorCheckOptionCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ErrorCheckOptionCollection Members | Aspose.Cells Namespace


ErrorCheckOptionCollection Members

ErrorCheckOptionCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets ErrorCheckOption object by the given index.

Public Instance Methods

Add | Add an error check option.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ErrorCheckOptionCollection Class | Aspose.Cells Namespace


ErrorCheckOptionCollection Properties

The properties of the ErrorCheckOptionCollection class are listed below. For a complete list of ErrorCheckOptionCollection class members, see the ErrorCheckOptionCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets ErrorCheckOption object by the given index.

See Also

ErrorCheckOptionCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ErrorCheckOptionCollection.Item Property

Gets ErrorCheckOption object by the given index.

public ErrorCheckOption this[
int index
] {get;}

Parameters

index
The index

See Also

ErrorCheckOptionCollection Class | Aspose.Cells Namespace


ErrorCheckOptionCollection Methods

The methods of the ErrorCheckOptionCollection class are listed below. For a complete list of ErrorCheckOptionCollection class members, see the ErrorCheckOptionCollection Members topic.

Public Instance Methods

Add | Add an error check option.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ErrorCheckOptionCollection Class | Aspose.Cells Namespace


ErrorCheckOptionCollection.Add Method

Add an error check option.

public int Add();

Return Value

See Also

ErrorCheckOptionCollection Class | Aspose.Cells Namespace


ErrorCheckType Enumeration

Represents all error check type.

public enum ErrorCheckType

Members

Member Name | Description | Value
Calc | check for calculation errors | 1
EmptyCellRef | check for references to empty cells | 2
TextNumber | check the format of numeric values | 4
InconsistRange | check formulas with references to less than the entirety of a range containing continuous data | 8
InconsistFormula | check formulas that are inconsistent with formulas in neighboring cells. | 16
TextDate | check the format of date/time values | 32
UnproctedFormula | check for unprotected formulas | 64
Validation | whether to perform data validation | 128
CalculatedColumn | Ignore errors when cells contain a value different from a calculated column formula. | 129

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ExceptionType Enumeration

Represents custom exception type code.

public enum ExceptionType

Members

Member Name | Description | Value
Chart | Invalid chart setting. | 0
DataType | Invalid data type setting. | 1
DataValidation | Invalid data validation setting. | 2
ConditionalFormatting | Invalid data validation setting. | 3
FileFormat | Invalid file format. | 4
Formula | Invalid formula. | 5
InvalidData | Invalid data. | 6
InvalidOperator | Invalid operator. | 7
IncorrectPassword | Incorrect password. | 8
License | License related errors. | 9
Limitation | Out of MS Excel limitation error. | 10
PageSetup | Invalid page setup setting. | 11
PivotTable | Invalid pivotTable setting. | 12
Shape | Invalid drawing object setting. | 13
Sparkline | Invalid sparkline object setting. | 14
SheetName | Invalid worksheet name. | 15
SheetType | Invalid worksheet type. | 16
Interrupted | The process is interrupted. | 17
IO | The file is invalid. | 18
Permission | Permission is required to open this file. | 19
UnsupportedFeature | Unsupported feature. | 20
UnsupportedStream | Unsupported stream to be opened. | 21
UndisclosedInformation | Files contains some undisclosed information. | 22

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ExportObjectEvent Class

The event triggered when exporting an object, such as Picture.

For a list of all members of this type, see ExportObjectEvent Members.

System.Object
Aspose.Cells.ExportObjectEvent

public class ExportObjectEvent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExportObjectEvent Members | Aspose.Cells Namespace


ExportObjectEvent Members

ExportObjectEvent overview

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetSource | Gets the object to be exported.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ExportObjectEvent Class | Aspose.Cells Namespace


ExportObjectEvent Methods

The methods of the ExportObjectEvent class are listed below. For a complete list of ExportObjectEvent class members, see the ExportObjectEvent Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetSource | Gets the object to be exported.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ExportObjectEvent Class | Aspose.Cells Namespace


ExportObjectEvent.GetSource Method

Gets the object to be exported.

public object GetSource();

Return Value

the object to be exported.

See Also

ExportObjectEvent Class | Aspose.Cells Namespace


ExportTableOptions Class

Represents all export table options.

For a list of all members of this type, see ExportTableOptions Members.

System.Object
Aspose.Cells.ExportTableOptions

public class ExportTableOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExportTableOptions Members | Aspose.Cells Namespace


ExportTableOptions Members

ExportTableOptions overview

Public Instance Constructors

ExportTableOptions Constructor Initializes a new instance of the ExportTableOptions class.

Public Instance Properties

CheckMixedValueType | False, Aspose.Cells will set the DataColumn's type by the value type of the first row for performance. True, Aspose.Cells will check whether the value type in the column are mixed before set the DataColumn's type And the value type are mixed, the DataColumn's type will be string.
DataTable | Gets and sets the DataTable which columns' data type is assigned.
ExportAsHtmlString | Exports the html string value of the cells to the DataTable.
ExportAsString | Exports the string value of the cells to the DataTable.
ExportColumnName | Indicates whether the data in the first row are exported to the column name of the DataTable. The default value is false.
FormatStrategy | Gets and sets the format strategy when exporting the value as string value.
Indexes | The indexes of columns/rows which should be exported out.
IsVertical | True if a row in Workbook file represents a row in DataTable. False if a column in Workbook file represents a row in DataTable.
PlotVisibleCells | Only exports visible cells.
PlotVisibleColumns | Only exports visible columns.
PlotVisibleRows | Only exports visible rows.
RenameStrategy | Renames strategy when columns contains the duplicate names.
SkipErrorValue | Indicates whether skip invalid value for the column. For example,if the column type is decimal ,the value is greater than decimal.MaxValue and this property is true,we will not throw exception again. The default value is false.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ExportTableOptions Class | Aspose.Cells Namespace


ExportTableOptions Constructor

Initializes a new instance of the ExportTableOptions class.

public ExportTableOptions();

See Also

ExportTableOptions Class | Aspose.Cells Namespace


ExportTableOptions Properties

The properties of the ExportTableOptions class are listed below. For a complete list of ExportTableOptions class members, see the ExportTableOptions Members topic.

Public Instance Properties

CheckMixedValueType | False, Aspose.Cells will set the DataColumn's type by the value type of the first row for performance. True, Aspose.Cells will check whether the value type in the column are mixed before set the DataColumn's type And the value type are mixed, the DataColumn's type will be string.
DataTable | Gets and sets the DataTable which columns' data type is assigned.
ExportAsHtmlString | Exports the html string value of the cells to the DataTable.
ExportAsString | Exports the string value of the cells to the DataTable.
ExportColumnName | Indicates whether the data in the first row are exported to the column name of the DataTable. The default value is false.
FormatStrategy | Gets and sets the format strategy when exporting the value as string value.
Indexes | The indexes of columns/rows which should be exported out.
IsVertical | True if a row in Workbook file represents a row in DataTable. False if a column in Workbook file represents a row in DataTable.
PlotVisibleCells | Only exports visible cells.
PlotVisibleColumns | Only exports visible columns.
PlotVisibleRows | Only exports visible rows.
RenameStrategy | Renames strategy when columns contains the duplicate names.
SkipErrorValue | Indicates whether skip invalid value for the column. For example,if the column type is decimal ,the value is greater than decimal.MaxValue and this property is true,we will not throw exception again. The default value is false.

See Also

ExportTableOptions Class | Aspose.Cells Namespace


CheckMixedValueType Property

Aspose.Cells for .NET

ExportTableOptions.CheckMixedValueType Property

False, Aspose.Cells will set the DataColumn's type by the value type of the first row for performance. True, Aspose.Cells will check whether the value type in the column are mixed before set the DataColumn's type And the value type are mixed, the DataColumn's type will be string.

public bool CheckMixedValueType {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


DataTable Property

Aspose.Cells for .NET

ExportTableOptions.DataTable Property

Gets and sets the DataTable which columns' data type is assigned.

public DataTable DataTable {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


ExportAsHtmlString Property

Aspose.Cells for .NET

ExportTableOptions.ExportAsHtmlString Property

Exports the html string value of the cells to the DataTable.

public bool ExportAsHtmlString {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


ExportAsString Property

Aspose.Cells for .NET

ExportTableOptions.ExportAsString Property

Exports the string value of the cells to the DataTable.

public bool ExportAsString {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


ExportColumnName Property

Aspose.Cells for .NET

ExportTableOptions.ExportColumnName Property

Indicates whether the data in the first row are exported to the column name of the DataTable. The default value is false.

public bool ExportColumnName {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


FormatStrategy Property

Aspose.Cells for .NET

ExportTableOptions.FormatStrategy Property

Gets and sets the format strategy when exporting the value as string value.

public CellValueFormatStrategy FormatStrategy {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


Indexes Property

Aspose.Cells for .NET

ExportTableOptions.Indexes Property

The indexes of columns/rows which should be exported out.

public int[] Indexes {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


IsVertical Property

Aspose.Cells for .NET

ExportTableOptions.IsVertical Property

True if a row in Workbook file represents a row in DataTable. False if a column in Workbook file represents a row in DataTable.

public bool IsVertical {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


PlotVisibleCells Property

Aspose.Cells for .NET

ExportTableOptions.PlotVisibleCells Property

Only exports visible cells.

public bool PlotVisibleCells {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


PlotVisibleColumns Property

Aspose.Cells for .NET

ExportTableOptions.PlotVisibleColumns Property

Only exports visible columns.

public bool PlotVisibleColumns {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


PlotVisibleRows Property

Aspose.Cells for .NET

ExportTableOptions.PlotVisibleRows Property

Only exports visible rows.

public bool PlotVisibleRows {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


RenameStrategy Property

Aspose.Cells for .NET

ExportTableOptions.RenameStrategy Property

Renames strategy when columns contains the duplicate names.

public RenameStrategy RenameStrategy {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


SkipErrorValue Property

Aspose.Cells for .NET

ExportTableOptions.SkipErrorValue Property

Indicates whether skip invalid value for the column. For example,if the column type is decimal ,the value is greater than decimal.MaxValue and this property is true,we will not throw exception again. The default value is false.

public bool SkipErrorValue {get; set;}

See Also

ExportTableOptions Class | Aspose.Cells Namespace


ExternalLink Class

Represents an external link in a workbook.

For a list of all members of this type, see ExternalLink Members.

System.Object
Aspose.Cells.ExternalLink

public class ExternalLink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Open a file with external links
 Workbook workbook = new Workbook("d:\\book1.xls");

 //Get External Link
 ExternalLink externalLink = workbook.Worksheets.ExternalLinks[0];

 //Change External Link's Data Source
 externalLink.DataSource = "d:\\link.xls";

 [VB.NET]

 'Open a file with external links
 Dim workbook As New Workbook("d:\book1.xls")

 'Get External Link
 Dim externalLink As ExternalLink = workbook.Worksheets.ExternalLinks(0)

 'Change External Link's Data Source
 externalLink.DataSource = "d:\link.xls"

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExternalLink Members | Aspose.Cells Namespace


ExternalLink Members

ExternalLink overview

Public Instance Properties

DataSource | Represents data source of the external link.
IsReferred | Indicates whether this external link is referenced by others.
IsVisible | Indicates whether this external link is visible in MS Excel.
OriginalDataSource | Represents stored data source of the external link.
Type | Gets the type of external link.

Public Instance Methods

AddExternalName | Adds an external name.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ExternalLink Class | Aspose.Cells Namespace


ExternalLink Properties

The properties of the ExternalLink class are listed below. For a complete list of ExternalLink class members, see the ExternalLink Members topic.

Public Instance Properties

DataSource | Represents data source of the external link.
IsReferred | Indicates whether this external link is referenced by others.
IsVisible | Indicates whether this external link is visible in MS Excel.
OriginalDataSource | Represents stored data source of the external link.
Type | Gets the type of external link.

See Also

ExternalLink Class | Aspose.Cells Namespace


DataSource Property

Aspose.Cells for .NET

ExternalLink.DataSource Property

Represents data source of the external link.

public string DataSource {get; set;}

See Also

ExternalLink Class | Aspose.Cells Namespace


IsReferred Property

Aspose.Cells for .NET

ExternalLink.IsReferred Property

Indicates whether this external link is referenced by others.

public bool IsReferred {get;}

See Also

ExternalLink Class | Aspose.Cells Namespace


IsVisible Property

Aspose.Cells for .NET

ExternalLink.IsVisible Property

Indicates whether this external link is visible in MS Excel.

public bool IsVisible {get;}

See Also

ExternalLink Class | Aspose.Cells Namespace


OriginalDataSource Property

Aspose.Cells for .NET

ExternalLink.OriginalDataSource Property

Represents stored data source of the external link.

public string OriginalDataSource {get; set;}

See Also

ExternalLink Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

ExternalLink.Type Property

Gets the type of external link.

public ExternalLinkType Type {get;}

See Also

ExternalLink Class | Aspose.Cells Namespace


ExternalLink Methods

The methods of the ExternalLink class are listed below. For a complete list of ExternalLink class members, see the ExternalLink Members topic.

Public Instance Methods

AddExternalName | Adds an external name.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ExternalLink Class | Aspose.Cells Namespace


ExternalLink.AddExternalName Method

Adds an external name.

public void AddExternalName(
string text,
string referTo
);

Parameters

text
The text of the external name. If the external name belongs to a worksheet, the text should be as Sheet1!Text.
referTo
The referTo of the external name. It must be a cell or the range.

See Also

ExternalLink Class | Aspose.Cells Namespace


ExternalLinkCollection Class

Represents external links collection in a workbook.

For a list of all members of this type, see ExternalLinkCollection Members.

System.Object
Aspose.Cells.ExternalLinkCollection

public class ExternalLinkCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Open a file with external links
Workbook workbook = new Workbook("d:\\book1.xls");

//Change external link data source
workbook.Worksheets.ExternalLinks[0].DataSource = "d:\\link.xls";

[Visual Basic]
'Open a file with external links
Dim workbook As Workbook =  New Workbook("d:\\book1.xls")

'Change external link data source
workbook.Worksheets.ExternalLinks(0).DataSource = "d:\\link.xls"

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExternalLinkCollection Members | Aspose.Cells Namespace


ExternalLinkCollection Members

ExternalLinkCollection overview

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
Item | Gets the ExternalLink element at the specified index.

Public Instance Methods

Add | Overloaded. Adds an external link.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace


ExternalLinkCollection Properties

The properties of the ExternalLinkCollection class are listed below. For a complete list of ExternalLinkCollection class members, see the ExternalLinkCollection Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the collection.
Item | Gets the ExternalLink element at the specified index.

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace


Count Property

Aspose.Cells for .NET

ExternalLinkCollection.Count Property

Gets the number of elements actually contained in the collection.

public int Count {get;}

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ExternalLinkCollection.Item Property

Gets the ExternalLink element at the specified index.

public ExternalLink this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace


ExternalLinkCollection Methods

The methods of the ExternalLinkCollection class are listed below. For a complete list of ExternalLinkCollection class members, see the ExternalLinkCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds an external link.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

ExternalLinkCollection.Add Method

Add an external link .

Overload List

Add an external link .

public int Add(DirectoryType,string,string[]);

Adds an external link.

public int Add(string,string[]);

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace


ExternalLinkCollection.Add Method (DirectoryType, String, String[])

Add an external link .

public int Add(
DirectoryType directoryType,
string fileName,
string[] sheetNames
);

Parameters

directoryType
The directory type of the file name.
fileName
the file name.
sheetNames
All sheet names of the external file.

Return Value

The position of the external name in this list.

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace | ExternalLinkCollection.Add Overload List


ExternalLinkCollection.Add Method (String, String[])

Adds an external link.

public int Add(
string fileName,
string[] sheetNames
);

Parameters

fileName
The external file name.
sheetNames
All sheet names of the external file.

Return Value

The position of the external name in this list.

See Also

ExternalLinkCollection Class | Aspose.Cells Namespace | ExternalLinkCollection.Add Overload List


ExternalLinkType Enumeration

Represents the type of external link.

public enum ExternalLinkType

Members

Member Name | Description | Value
DDELink | Represents the DDE link. | 0
External | Represents external link. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FileFontSource Class

Represents the single TrueType font file stored in the file system.

For a list of all members of this type, see FileFontSource Members.

System.Object
Aspose.Cells.FontSourceBase
Aspose.Cells.FileFontSource

public class FileFontSource : FontSourceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FileFontSource Members | Aspose.Cells Namespace


FileFontSource Members

FileFontSource overview

Public Instance Constructors

FileFontSource Constructor Ctor.

Public Instance Properties

FilePath | Path to font file.
Type | Returns the type of the font source.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FileFontSource Class | Aspose.Cells Namespace


FileFontSource Constructor

Ctor.

public FileFontSource(
string filePath
);

Parameters

filePath
path to font file

See Also

FileFontSource Class | Aspose.Cells Namespace


FileFontSource Properties

The properties of the FileFontSource class are listed below. For a complete list of FileFontSource class members, see the FileFontSource Members topic.

Public Instance Properties

FilePath | Path to font file.
Type | Returns the type of the font source.

See Also

FileFontSource Class | Aspose.Cells Namespace


FilePath Property

Aspose.Cells for .NET

FileFontSource.FilePath Property

Path to font file.

public string FilePath {get;}

See Also

FileFontSource Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

FileFontSource.Type Property

Returns the type of the font source.

public override FontSourceType Type {get;}

See Also

FileFontSource Class | Aspose.Cells Namespace


FileFormatInfo Class

Contains data returned by FileFormatUtil file format detection methods.

For a list of all members of this type, see FileFormatInfo Members.

System.Object
Aspose.Cells.FileFormatInfo

public class FileFormatInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FileFormatInfo Members | Aspose.Cells Namespace


FileFormatInfo Members

FileFormatInfo overview

Public Instance Constructors

FileFormatInfo Constructor Initializes a new instance of the FileFormatInfo class.

Public Instance Properties

FileFormatType | Gets the detected file format.
IsEncrypted | Returns true if the document is encrypted and requires a password to open.
IsProtectedByRMS | Gets whether the file is protected by Microsoft Rights Management Server.
LoadFormat | Gets the detected load format.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FileFormatInfo Class | Aspose.Cells Namespace


FileFormatInfo Constructor

Initializes a new instance of the FileFormatInfo class.

public FileFormatInfo();

See Also

FileFormatInfo Class | Aspose.Cells Namespace


FileFormatInfo Properties

The properties of the FileFormatInfo class are listed below. For a complete list of FileFormatInfo class members, see the FileFormatInfo Members topic.

Public Instance Properties

FileFormatType | Gets the detected file format.
IsEncrypted | Returns true if the document is encrypted and requires a password to open.
IsProtectedByRMS | Gets whether the file is protected by Microsoft Rights Management Server.
LoadFormat | Gets the detected load format.

See Also

FileFormatInfo Class | Aspose.Cells Namespace


FileFormatType Property

Aspose.Cells for .NET

FileFormatInfo.FileFormatType Property

Gets the detected file format.

public FileFormatType FileFormatType {get;}

See Also

FileFormatInfo Class | Aspose.Cells Namespace


IsEncrypted Property

Aspose.Cells for .NET

FileFormatInfo.IsEncrypted Property

Returns true if the document is encrypted and requires a password to open.

public bool IsEncrypted {get;}

See Also

FileFormatInfo Class | Aspose.Cells Namespace


IsProtectedByRMS Property

Aspose.Cells for .NET

FileFormatInfo.IsProtectedByRMS Property

Gets whether the file is protected by Microsoft Rights Management Server.

public bool IsProtectedByRMS {get;}

See Also

FileFormatInfo Class | Aspose.Cells Namespace


LoadFormat Property

Aspose.Cells for .NET

FileFormatInfo.LoadFormat Property

Gets the detected load format.

public LoadFormat LoadFormat {get;}

See Also

FileFormatInfo Class | Aspose.Cells Namespace


FileFormatType Enumeration

Enumerates spreadsheet file format types

public enum FileFormatType

Members

Member Name | Description | Value
CSV | Represents a CSV file. | 1
Xlsx | Represents an xlsx file. | 6
Xlsm | Represents an xlsm file which enable macros. | 7
Xltx | Represents a template xltx file. | 8
Xltm | Represents a macro-enabled template xltm file. | 9
Xlam | Represents a addinMacro-enabled template xltm file. | 10
TSV | Represents a TSV(tab-separated values file) file. | 11
TabDelimited | Represents a tab delimited text file, same with TSV. | 11
Html | Represents a html file. | 12
MHtml | Represents a mhtml file. | 17
ODS | Represents a ods file. | 14
Excel97To2003 | Represents an Excel97-2003 xls file. | 5
Excel2003XML | Represents an Excel 2003 xml file. | 15
Xlsb | Represents an xlsb file. | 16
Unknown | Represents unrecognized format, cannot be loaded. | 255
Pdf | Represents a Pdf file. | 13
XPS | Represents an XPS file. | 20
TIFF | Represents a TIFF file. | 21
SVG | Represents a svg file. | 28
Excel95 | Represents an Excel95 xls file. | 22
Excel4 | Represents an Excel4.0 xls file. | 23
Excel3 | Represents an Excel3.0 xls file. | 24
Excel2 | Represents an Excel2.1 xls file. | 25
Pptx | Represents a pptx file. | 26
Docx | Represents a docx file. | 27
Dif | Data Interchange Format. | 30
Doc | Represents a doc file. | 31
Ppt | Represents a ppt file. | 32
MapiMessage | Represents a email file. | 33
MSEquation | Represents the MS Equation 3.0 object. | 34
Ole10Native | Represents the embedded native object. | 35
VSD | Represents MS Visio VSD binary format. | 36
VSDX | MS Visio 2013 VSDX file format. | 37
Docm | Represents a docm file. | 38
Dotx | Represents a dotx file. | 39
Dotm | Represents a dotm file. | 40
Pptm | Represents a pptm file. | 41
Potx | Represents a Potx file. | 42
Potm | Represents a Potm file. | 43
Ppsx | Represents a ppsx file. | 44
Ppsm | Represents a ppsm file. | 45
Ooxml | Represents office open xml file(such as xlsx, docx,pptx, etc). | 46
ODT | Represents a odt file. | 47
ODP | Represents a odp file. | 48
ODF | Represents a odf file. | 49
ODG | Represents a odg file. | 50
XML | Represents an simple xml file. | 51
Xlt | Represents a template xlt file. | 52
OTT | Represents a odt file. | 53
BMP | Represents a bmp file. | 54
OTS | Represents a ods file. | 55
Numbers | Represents Numbers file format by Apple Inc | 56
Markdown | Represents markdown document. | 57
GraphChart | Represents embedded graph chart. | 58
FODS | Represents OpenDocument Flat XML Spreadsheet (.fods) file format. | 59
SXC | Represents StarOffice Calc Spreadsheet (.sxc) file format. | 60
OTP | Represents a otp file. | 61
Numbers35 | Represents Numbers 3.5 file format since 2014 by Apple Inc | 62

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FileFormatUtil Class

Provides utility methods for converting file format enums to strings or file extensions and back.

For a list of all members of this type, see FileFormatUtil Members.

System.Object
Aspose.Cells.FileFormatUtil

public class FileFormatUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FileFormatUtil Members | Aspose.Cells Namespace


FileFormatUtil Members

FileFormatUtil overview

Public Static Methods

DetectFileFormat | Overloaded. Detects and returns the information about a format of an excel stored in a stream.
ExtensionToSaveFormat | Converts a file name extension into a SaveFormat value.
IsTemplateFormat | Returns true if the extension is .xlt, .xltX, .xltm,.ots.
LoadFormatToExtension | Converts a load format enumerated value into a file extension.
LoadFormatToSaveFormat | Converts a LoadFormat value to a SaveFormat value if possible.
SaveFormatToExtension | Converts a save format enumerated value into a file extension.
SaveFormatToLoadFormat | Converts a SaveFormat value to a LoadFormat value if possible.
VerifyPassword | Detects and returns the information about a format of an excel stored in a stream.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil Methods

The methods of the FileFormatUtil class are listed below. For a complete list of FileFormatUtil class members, see the FileFormatUtil Members topic.

Public Static Methods

DetectFileFormat | Overloaded. Detects and returns the information about a format of an excel stored in a stream.
ExtensionToSaveFormat | Converts a file name extension into a SaveFormat value.
IsTemplateFormat | Returns true if the extension is .xlt, .xltX, .xltm,.ots.
LoadFormatToExtension | Converts a load format enumerated value into a file extension.
LoadFormatToSaveFormat | Converts a LoadFormat value to a SaveFormat value if possible.
SaveFormatToExtension | Converts a save format enumerated value into a file extension.
SaveFormatToLoadFormat | Converts a SaveFormat value to a LoadFormat value if possible.
VerifyPassword | Detects and returns the information about a format of an excel stored in a stream.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FileFormatUtil Class | Aspose.Cells Namespace


DetectFileFormat Method

Aspose.Cells for .NET

FileFormatUtil.DetectFileFormat Method

Detects and returns the information about a format of an excel stored in a stream.

Overload List

Detects and returns the information about a format of an excel stored in a stream.

public static FileFormatInfo DetectFileFormat(Stream);

Detects and returns the information about a format of an excel stored in a stream.

public static FileFormatInfo DetectFileFormat(Stream,string);

Detects and returns the information about a format of an excel stored in a file.

public static FileFormatInfo DetectFileFormat(string);

Detects and returns the information about a format of an excel stored in a file.

public static FileFormatInfo DetectFileFormat(string,string);

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.DetectFileFormat Method (Stream)

Detects and returns the information about a format of an excel stored in a stream.

public static FileFormatInfo DetectFileFormat(
Stream stream
);

Parameters

stream

Return Value

A FileFormatInfo object that contains the detected information.

See Also

FileFormatUtil Class | Aspose.Cells Namespace | FileFormatUtil.DetectFileFormat Overload List


FileFormatUtil.DetectFileFormat Method (Stream, String)

Detects and returns the information about a format of an excel stored in a stream.

public static FileFormatInfo DetectFileFormat(
Stream stream,
string password
);

Parameters

stream
password
The password for encrypted ooxml files.

Return Value

A FileFormatInfo object that contains the detected information.

See Also

FileFormatUtil Class | Aspose.Cells Namespace | FileFormatUtil.DetectFileFormat Overload List


FileFormatUtil.DetectFileFormat Method (String)

Detects and returns the information about a format of an excel stored in a file.

public static FileFormatInfo DetectFileFormat(
string filePath
);

Parameters

filePath
The file path.

Return Value

A FileFormatInfo object that contains the detected information.

See Also

FileFormatUtil Class | Aspose.Cells Namespace | FileFormatUtil.DetectFileFormat Overload List


FileFormatUtil.DetectFileFormat Method (String, String)

Detects and returns the information about a format of an excel stored in a file.

public static FileFormatInfo DetectFileFormat(
string filePath,
string password
);

Parameters

filePath
The file path.
password
The password for encrypted ooxml files.

Return Value

A FileFormatInfo object that contains the detected information.

See Also

FileFormatUtil Class | Aspose.Cells Namespace | FileFormatUtil.DetectFileFormat Overload List


FileFormatUtil.ExtensionToSaveFormat Method

Converts a file name extension into a SaveFormat value.

public static SaveFormat ExtensionToSaveFormat(
string extension
);

Parameters

extension
The file extension. Can be with or without a leading dot. Case-insensitive.

Return Value

Remarks

If the extension cannot be recognized, returns Unknown.

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.IsTemplateFormat Method

Returns true if the extension is .xlt, .xltX, .xltm,.ots.

public static bool IsTemplateFormat(
string extension
);

Parameters

extension

Return Value

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.LoadFormatToExtension Method

Converts a load format enumerated value into a file extension.

public static string LoadFormatToExtension(
LoadFormat loadFormat
);

Parameters

loadFormat
The loaded file format.

Return Value

The returned extension is a lower-case string with a leading dot.

Remarks

If it can not be converted, returns null.

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.LoadFormatToSaveFormat Method

Converts a LoadFormat value to a SaveFormat value if possible.

public static SaveFormat LoadFormatToSaveFormat(
LoadFormat loadFormat
);

Parameters

loadFormat
The load format.

Return Value

The save format.

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.SaveFormatToExtension Method

Converts a save format enumerated value into a file extension.

public static string SaveFormatToExtension(
SaveFormat format
);

Parameters

format
The save format.

Return Value

The returned extension is a lower-case string with a leading dot.

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.SaveFormatToLoadFormat Method

Converts a SaveFormat value to a LoadFormat value if possible.

public static LoadFormat SaveFormatToLoadFormat(
SaveFormat saveFormat
);

Parameters

saveFormat
The save format.

Return Value

The load format

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FileFormatUtil.VerifyPassword Method

Detects and returns the information about a format of an excel stored in a stream.

public static bool VerifyPassword(
Stream stream,
string password
);

Parameters

stream
password
The password for encrypted ooxml files.

Return Value

Returns whether the password is corrected.

See Also

FileFormatUtil Class | Aspose.Cells Namespace


FilterColumn Class

Represents a filter for a single column. The Filter object is a member of the Filters collection

For a list of all members of this type, see FilterColumn Members.

System.Object
Aspose.Cells.FilterColumn

public class FilterColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FilterColumn Members | Aspose.Cells Namespace


FilterColumn Members

FilterColumn overview

Public Instance Properties

FieldIndex |
Filter |
FilterType |
IsDropdownVisible | Indicates whether the AutoFilter button for this column is visible.
Visibledropdown | Obsolete. Indicates whether the AutoFilter button for this column is visible.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FilterColumn Class | Aspose.Cells Namespace


FilterColumn Properties

The properties of the FilterColumn class are listed below. For a complete list of FilterColumn class members, see the FilterColumn Members topic.

Public Instance Properties

FieldIndex |
Filter |
FilterType |
IsDropdownVisible | Indicates whether the AutoFilter button for this column is visible.
Visibledropdown | Obsolete. Indicates whether the AutoFilter button for this column is visible.

See Also

FilterColumn Class | Aspose.Cells Namespace


FieldIndex Property

Aspose.Cells for .NET

FilterColumn.FieldIndex Property

public int FieldIndex {get; set;}

See Also

FilterColumn Class | Aspose.Cells Namespace


Filter Property

Aspose.Cells for .NET

FilterColumn.Filter Property

public object Filter {get; set;}

See Also

FilterColumn Class | Aspose.Cells Namespace


FilterType Property

Aspose.Cells for .NET

FilterColumn.FilterType Property

public FilterType FilterType {get; set;}

See Also

FilterColumn Class | Aspose.Cells Namespace


IsDropdownVisible Property

Aspose.Cells for .NET

FilterColumn.IsDropdownVisible Property

Indicates whether the AutoFilter button for this column is visible.

public bool IsDropdownVisible {get; set;}

See Also

FilterColumn Class | Aspose.Cells Namespace


Visibledropdown Property

Aspose.Cells for .NET

FilterColumn.Visibledropdown Property

NOTE: This property is now obsolete.

Use FilterColumn.IsDropdownVisible instead.

Indicates whether the AutoFilter button for this column is visible.

public bool Visibledropdown {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use FilterColumn.IsDropdownVisible to check whether the AutoFilter button for this column is visible. This property will be removed 12 months later since September 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

FilterColumn Class | Aspose.Cells Namespace


FilterColumnCollection Class

A collection of Filter objects that represents all the filters in an autofiltered range.

For a list of all members of this type, see FilterColumnCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.FilterColumnCollection

public class FilterColumnCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FilterColumnCollection Members | Aspose.Cells Namespace


FilterColumnCollection Members

FilterColumnCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets FilterColumn object at the special field.

Public Instance Methods

Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetByIndex | Returns a single Filter object from a collection.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt |
ToString (inherited from Object) |

See Also

FilterColumnCollection Class | Aspose.Cells Namespace


FilterColumnCollection Properties

The properties of the FilterColumnCollection class are listed below. For a complete list of FilterColumnCollection class members, see the FilterColumnCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets FilterColumn object at the special field.

See Also

FilterColumnCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

FilterColumnCollection.Item Property

Gets FilterColumn object at the special field.

public FilterColumn this[
int fieldIndex
] {get;}

Parameters

fieldIndex
The integer offset of the field on which you want to base the filter (from the left of the list; the leftmost field is field 0).

See Also

FilterColumnCollection Class | Aspose.Cells Namespace


FilterColumnCollection Methods

The methods of the FilterColumnCollection class are listed below. For a complete list of FilterColumnCollection class members, see the FilterColumnCollection Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetByIndex | Returns a single Filter object from a collection.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt |
ToString (inherited from Object) |

See Also

FilterColumnCollection Class | Aspose.Cells Namespace


FilterColumnCollection.GetByIndex Method

Returns a single Filter object from a collection.

public FilterColumn GetByIndex(
int index
);

See Also

FilterColumnCollection Class | Aspose.Cells Namespace


FilterColumnCollection.RemoveAt Method

new public void RemoveAt(
int index
);

Parameters

index

Implements

IList.RemoveAt

See Also

FilterColumnCollection Class | Aspose.Cells Namespace


FilterOperatorType Enumeration

Custom Filter operator type.

public enum FilterOperatorType

Members

Member Name | Description | Value
LessOrEqual | Represents LessOrEqual operator. | 0
LessThan | Represents LessThan operator. | 1
Equal | Represents Equal operator. | 2
GreaterThan | Represents GreaterThan operator. | 3
NotEqual | Represents NotEqual operator. | 4
GreaterOrEqual | Represents GreaterOrEqual operator. | 5
None | Represents no comparison. | 6
BeginsWith | Begins with the text. | 7
EndsWith | Ends with the text. | 8
Contains | Contains the text. | 9
NotContains | Not contains the text. | 10

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FilterType Enumeration

The filter type.

public enum FilterType

Members

Member Name | Description | Value
ColorFilter |  | 0
CustomFilters |  | 1
DynamicFilter |  | 2
MultipleFilters | When multiple values are chosen to filter by, or when a group of date values are chosen to filter by, this element groups those criteria together. | 3
IconFilter |  | 4
Top10 |  | 5
None |  | 6

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FindOptions Class

Represents find options.

For a list of all members of this type, see FindOptions Members.

System.Object
Aspose.Cells.FindOptions

public class FindOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate the workbook object
Workbook workbook = new Workbook("C:\\book1.xls");

//Get Cells collection
Cells cells = workbook.Worksheets[0].Cells;

//Instantiate FindOptions Object
FindOptions findOptions = new FindOptions();

//Create a Cells Area
CellArea ca = new CellArea();
ca.StartRow = 8;
ca.StartColumn = 2;
ca.EndRow = 17;
ca.EndColumn = 13;

//Set cells area for find options
findOptions.SetRange(ca);

//Set searching properties
findOptions.SearchBackward = false;

findOptions.SeachOrderByRows = true;

findOptions.LookInType = LookInType.Values;

//Find the cell with 0 value
Cell cell = cells.Find(0, null, findOptions);

[VB.NET]

'Instantiate the workbook object
Dim workbook As New Workbook("C:\book1.xls")

'Get Cells collection
Dim cells As Cells = workbook.Worksheets(0).Cells

'Instantiate FindOptions Object
Dim findOptions As New FindOptions()

'Create a Cells Area
Dim ca As New CellArea()
ca.StartRow = 8
ca.StartColumn = 2
ca.EndRow = 17
ca.EndColumn = 13

'Set cells area for find options
findOptions.SetRange(ca)

'Set searching properties
findOptions.SearchBackward = True

findOptions.SeachOrderByRows = True

findOptions.LookInType = LookInType.Values

'Find the cell with 0 value
Dim cell As Cell = cells.Find(0, Nothing, findOptions)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FindOptions Members | Aspose.Cells Namespace


FindOptions Members

FindOptions overview

Public Instance Constructors

FindOptions Constructor Initializes a new instance of the FindOptions class.

Public Instance Properties

CaseSensitive | Indicates if the searched string is case sensitive.
ConvertNumericData | Gets or sets a value that indicates whether converting the searched string value to numeric data.
IsCaseSensitive | Obsolete. Indicates if the searched string is case sensitive.
IsRangeSet | Indicates whether the searched range is set.
LookAtType | Look at type.
LookInType | Look in type.
RegexKey | Indicates whether the searched key is regex. If true then the searched key will be taken as regex.
SeachOrderByRows | Indicates whether search order by rows or columns.
SearchBackward | Whether search backward for cells.
SearchNext | Obsolete. Search order. True: search next. False: search previous.
Style | The format to search for.
ValueTypeSensitive | Indicates whether searched cell value type should be same with the searched key.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetRange | Gets and sets the searched range.
GetType (inherited from Object) |
SetRange | Sets the searched range.
ToString (inherited from Object) |

See Also

FindOptions Class | Aspose.Cells Namespace


FindOptions Constructor

Initializes a new instance of the FindOptions class.

public FindOptions();

See Also

FindOptions Class | Aspose.Cells Namespace


FindOptions Properties

The properties of the FindOptions class are listed below. For a complete list of FindOptions class members, see the FindOptions Members topic.

Public Instance Properties

CaseSensitive | Indicates if the searched string is case sensitive.
ConvertNumericData | Gets or sets a value that indicates whether converting the searched string value to numeric data.
IsCaseSensitive | Obsolete. Indicates if the searched string is case sensitive.
IsRangeSet | Indicates whether the searched range is set.
LookAtType | Look at type.
LookInType | Look in type.
RegexKey | Indicates whether the searched key is regex. If true then the searched key will be taken as regex.
SeachOrderByRows | Indicates whether search order by rows or columns.
SearchBackward | Whether search backward for cells.
SearchNext | Obsolete. Search order. True: search next. False: search previous.
Style | The format to search for.
ValueTypeSensitive | Indicates whether searched cell value type should be same with the searched key.

See Also

FindOptions Class | Aspose.Cells Namespace


CaseSensitive Property

Aspose.Cells for .NET

FindOptions.CaseSensitive Property

Indicates if the searched string is case sensitive.

public bool CaseSensitive {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


ConvertNumericData Property

Aspose.Cells for .NET

FindOptions.ConvertNumericData Property

Gets or sets a value that indicates whether converting the searched string value to numeric data.

public bool ConvertNumericData {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


IsCaseSensitive Property

Aspose.Cells for .NET

FindOptions.IsCaseSensitive Property

NOTE: This property is now obsolete.

Use FindOptions.CaseSensitive property instead.

Indicates if the searched string is case sensitive.

public bool IsCaseSensitive {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use FindOptions.CaseSensitive property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

FindOptions Class | Aspose.Cells Namespace


IsRangeSet Property

Aspose.Cells for .NET

FindOptions.IsRangeSet Property

Indicates whether the searched range is set.

public bool IsRangeSet {get;}

See Also

FindOptions Class | Aspose.Cells Namespace


LookAtType Property

Aspose.Cells for .NET

FindOptions.LookAtType Property

Look at type.

public LookAtType LookAtType {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


LookInType Property

Aspose.Cells for .NET

FindOptions.LookInType Property

Look in type.

public LookInType LookInType {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


RegexKey Property

Aspose.Cells for .NET

FindOptions.RegexKey Property

Indicates whether the searched key is regex. If true then the searched key will be taken as regex.

public bool RegexKey {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


SeachOrderByRows Property

Aspose.Cells for .NET

FindOptions.SeachOrderByRows Property

Indicates whether search order by rows or columns.

public bool SeachOrderByRows {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


SearchBackward Property

Aspose.Cells for .NET

FindOptions.SearchBackward Property

Whether search backward for cells.

public bool SearchBackward {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


SearchNext Property

Aspose.Cells for .NET

FindOptions.SearchNext Property

NOTE: This property is now obsolete.

Use FindOptions.SearchBackward property instead.

Search order. True: search next. False: search previous.

public bool SearchNext {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use FindOptions.SearchBackward property. This property will be removed 12 months later since November 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

FindOptions Class | Aspose.Cells Namespace


Style Property

Aspose.Cells for .NET

FindOptions.Style Property

The format to search for.

public Style Style {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


ValueTypeSensitive Property

Aspose.Cells for .NET

FindOptions.ValueTypeSensitive Property

Indicates whether searched cell value type should be same with the searched key.

public bool ValueTypeSensitive {get; set;}

See Also

FindOptions Class | Aspose.Cells Namespace


FindOptions Methods

The methods of the FindOptions class are listed below. For a complete list of FindOptions class members, see the FindOptions Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetRange | Gets and sets the searched range.
GetType (inherited from Object) |
SetRange | Sets the searched range.
ToString (inherited from Object) |

See Also

FindOptions Class | Aspose.Cells Namespace


FindOptions.GetRange Method

Gets and sets the searched range.

public CellArea GetRange();

Return Value

Returns the searched range.

See Also

FindOptions Class | Aspose.Cells Namespace


FindOptions.SetRange Method

Sets the searched range.

public void SetRange(
CellArea ca
);

Parameters

ca
the searched range.

See Also

FindOptions Class | Aspose.Cells Namespace


FolderFontSource Class

Represents the folder that contains TrueType font files.

For a list of all members of this type, see FolderFontSource Members.

System.Object
Aspose.Cells.FontSourceBase
Aspose.Cells.FolderFontSource

public class FolderFontSource : FontSourceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FolderFontSource Members | Aspose.Cells Namespace


FolderFontSource Members

FolderFontSource overview

Public Instance Constructors

FolderFontSource Constructor Ctor.

Public Instance Properties

FolderPath | Path to fonts folder.
ScanSubFolders | Determines whether or not to scan the subfolders.
Type | Returns the type of the font source.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FolderFontSource Class | Aspose.Cells Namespace


FolderFontSource Constructor

Ctor.

public FolderFontSource(
string folderPath,
bool scanSubfolders
);

Parameters

folderPath
path to fonts folder
scanSubfolders
Determines whether or not to scan subfolders.

See Also

FolderFontSource Class | Aspose.Cells Namespace


FolderFontSource Properties

The properties of the FolderFontSource class are listed below. For a complete list of FolderFontSource class members, see the FolderFontSource Members topic.

Public Instance Properties

FolderPath | Path to fonts folder.
ScanSubFolders | Determines whether or not to scan the subfolders.
Type | Returns the type of the font source.

See Also

FolderFontSource Class | Aspose.Cells Namespace


FolderPath Property

Aspose.Cells for .NET

FolderFontSource.FolderPath Property

Path to fonts folder.

public string FolderPath {get;}

See Also

FolderFontSource Class | Aspose.Cells Namespace


ScanSubFolders Property

Aspose.Cells for .NET

FolderFontSource.ScanSubFolders Property

Determines whether or not to scan the subfolders.

public bool ScanSubFolders {get;}

See Also

FolderFontSource Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

FolderFontSource.Type Property

Returns the type of the font source.

public override FontSourceType Type {get;}

See Also

FolderFontSource Class | Aspose.Cells Namespace


Font Class

Encapsulates the font object used in a spreadsheet.

For a list of all members of this type, see Font Members.

System.Object
Aspose.Cells.Font
Aspose.Cells.Drawing.Texts.TextOptions

public class Font

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[0];

//Accessing the "A1" cell from the worksheet
Aspose.Cells.Cell cell = worksheet.Cells["A1"];

//Adding some value to the "A1" cell
cell.PutValue("Hello Aspose!");

Aspose.Cells.Font font = cell.Style.Font;

//Setting the font name to "Times New Roman"
font.Name = "Times New Roman";

//Setting font size to 14
font.Size = 14;

//setting font color as Red
font.Color = System.Drawing.Color.Red;

//Saving the Excel file
workbook.Save(@"d:\dest.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Accessing the "A1" cell from the worksheet
Dim cell As Aspose.Cells.Cell = worksheet.Cells("A1")

'Adding some value to the "A1" cell
cell.PutValue("Hello Aspose!")

Dim font As Aspose.Cells.Font = cell.Style.Font

'Setting the font name to "Times New Roman"
font.Name = "Times New Roman"

'Setting font size to 14
font.Size = 14

'setting font color as Red
font.Color = System.Drawing.Color.Red

'Saving the Excel file
workbook.Save("d:\dest.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Font Members | Aspose.Cells Namespace


Font Members

Font overview

Public Instance Properties

ArgbColor | Gets and sets the color with a 32-bit ARGB value.
CapsType | Gets and sets the text caps type.
Charset | Represent the character set.
Color | Gets or sets the Color of the font.
DoubleSize | Gets and sets the double size of the font.
IsBold | Gets or sets a value indicating whether the font is bold.
IsItalic | Gets or sets a value indicating whether the font is italic.
IsNormalizeHeights | Indicates whether the normalization of height that is to be applied to the text run.
IsStrikeout | Gets or sets a value indicating whether the font is single strikeout.
IsSubscript | Gets or sets a value indicating whether the font is subscript.
IsSuperscript | Gets or sets a value indicating whether the font is super script.
Name | Gets or sets the name of the Font.
SchemeType | Gets and sets the scheme type of the font.
ScriptOffset | Gets and sets the script offset,in unit of percentage
Size | Gets or sets the size of the font.
StrikeType | Gets the strike type of the text.
ThemeColor | Gets and sets the theme color.
Underline | Gets or sets the font underline type.

Public Instance Methods

Equals | Overloaded. Checks if two fonts are equals.
Equals (inherited from Object) | Overloaded.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Cell object.

See Also

Font Class | Aspose.Cells Namespace


Font Properties

The properties of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public Instance Properties

ArgbColor | Gets and sets the color with a 32-bit ARGB value.
CapsType | Gets and sets the text caps type.
Charset | Represent the character set.
Color | Gets or sets the Color of the font.
DoubleSize | Gets and sets the double size of the font.
IsBold | Gets or sets a value indicating whether the font is bold.
IsItalic | Gets or sets a value indicating whether the font is italic.
IsNormalizeHeights | Indicates whether the normalization of height that is to be applied to the text run.
IsStrikeout | Gets or sets a value indicating whether the font is single strikeout.
IsSubscript | Gets or sets a value indicating whether the font is subscript.
IsSuperscript | Gets or sets a value indicating whether the font is super script.
Name | Gets or sets the name of the Font.
SchemeType | Gets and sets the scheme type of the font.
ScriptOffset | Gets and sets the script offset,in unit of percentage
Size | Gets or sets the size of the font.
StrikeType | Gets the strike type of the text.
ThemeColor | Gets and sets the theme color.
Underline | Gets or sets the font underline type.

See Also

Font Class | Aspose.Cells Namespace


ArgbColor Property

Aspose.Cells for .NET

Font.ArgbColor Property

Gets and sets the color with a 32-bit ARGB value.

public int ArgbColor {get; set;}

See Also

Font Class | Aspose.Cells Namespace


CapsType Property

Aspose.Cells for .NET

Font.CapsType Property

Gets and sets the text caps type.

public TextCapsType CapsType {get; set;}

See Also

Font Class | Aspose.Cells Namespace


Charset Property

Aspose.Cells for .NET

Font.Charset Property

Represent the character set.

public int Charset {get; set;}

See Also

Font Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

Font.Color Property

Gets or sets the Color of the font.

public Color Color {get; set;}

See Also

Font Class | Aspose.Cells Namespace


DoubleSize Property

Aspose.Cells for .NET

Font.DoubleSize Property

Gets and sets the double size of the font.

public double DoubleSize {get; set;}

See Also

Font Class | Aspose.Cells Namespace


IsBold Property

Aspose.Cells for .NET

Font.IsBold Property

Gets or sets a value indicating whether the font is bold.

public bool IsBold {get; set;}

See Also

Font Class | Aspose.Cells Namespace


IsItalic Property

Aspose.Cells for .NET

Font.IsItalic Property

Gets or sets a value indicating whether the font is italic.

public bool IsItalic {get; set;}

See Also

Font Class | Aspose.Cells Namespace


IsNormalizeHeights Property

Aspose.Cells for .NET

Font.IsNormalizeHeights Property

Indicates whether the normalization of height that is to be applied to the text run.

public bool IsNormalizeHeights {get; set;}

See Also

Font Class | Aspose.Cells Namespace


IsStrikeout Property

Aspose.Cells for .NET

Font.IsStrikeout Property

Gets or sets a value indicating whether the font is single strikeout.

public bool IsStrikeout {get; set;}

See Also

Font Class | Aspose.Cells Namespace


IsSubscript Property

Aspose.Cells for .NET

Font.IsSubscript Property

Gets or sets a value indicating whether the font is subscript.

public bool IsSubscript {get; set;}

See Also

Font Class | Aspose.Cells Namespace


IsSuperscript Property

Aspose.Cells for .NET

Font.IsSuperscript Property

Gets or sets a value indicating whether the font is super script.

public bool IsSuperscript {get; set;}

See Also

Font Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

Font.Name Property

Gets or sets the name of the Font.

public virtual string Name {get; set;}

Example

[C#]

Style style;
..........
Font font = style.Font;
font.Name = "Times New Roman";

[Visual Basic]

Dim style As Style
..........
Dim font As Font =  style.Font
font.Name = "Times New Roman"

See Also

Font Class | Aspose.Cells Namespace


SchemeType Property

Aspose.Cells for .NET

Font.SchemeType Property

Gets and sets the scheme type of the font.

public FontSchemeType SchemeType {get; set;}

See Also

Font Class | Aspose.Cells Namespace


ScriptOffset Property

Aspose.Cells for .NET

Font.ScriptOffset Property

Gets and sets the script offset,in unit of percentage

public double ScriptOffset {get; set;}

See Also

Font Class | Aspose.Cells Namespace


Size Property

Aspose.Cells for .NET

Font.Size Property

Gets or sets the size of the font.

public int Size {get; set;}

See Also

Font Class | Aspose.Cells Namespace


StrikeType Property

Aspose.Cells for .NET

Font.StrikeType Property

Gets the strike type of the text.

public TextStrikeType StrikeType {get; set;}

See Also

Font Class | Aspose.Cells Namespace


ThemeColor Property

Aspose.Cells for .NET

Font.ThemeColor Property

Gets and sets the theme color.

public ThemeColor ThemeColor {get; set;}

Remarks

If the font color is not a theme color, NULL will be returned.

See Also

Font Class | Aspose.Cells Namespace


Underline Property

Aspose.Cells for .NET

Font.Underline Property

Gets or sets the font underline type.

public FontUnderlineType Underline {get; set;}

See Also

Font Class | Aspose.Cells Namespace


Font Methods

The methods of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public Instance Methods

Equals | Overloaded. Checks if two fonts are equals.
Equals (inherited from Object) | Overloaded.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Cell object.

See Also

Font Class | Aspose.Cells Namespace


Equals Method

Aspose.Cells for .NET

Font.Equals Method

Checks if two fonts are equals.

Overload List

Checks if two fonts are equals.

public bool Equals(Font);

Inherited from Object.

public virtual bool Equals(object);

See Also

Font Class | Aspose.Cells Namespace


Font.Equals Method (Font)

Checks if two fonts are equals.

public bool Equals(
Font font
);

Parameters

font
Compared font object.

Return Value

True if equal to the compared font object.

See Also

Font Class | Aspose.Cells Namespace | Font.Equals Overload List


Font.ToString Method

Returns a string represents the current Cell object.

public override string ToString();

Return Value

See Also

Font Class | Aspose.Cells Namespace


FontConfigs Class

Specifies font settings

For a list of all members of this type, see FontConfigs Members.

System.Object
Aspose.Cells.FontConfigs

public class FontConfigs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FontConfigs Members | Aspose.Cells Namespace


FontConfigs Members

FontConfigs overview

Public Static Properties

DefaultFontName | Gets or sets the default font name.
PreferSystemFontSubstitutes | Indicate whether to use system font substitutes first or not when a font is not presented and the substitute of this font is not set. e.g. On Ubuntu, "Arial" font is generally substituted by "Liberation Sans". Default value is false.

Public Static Methods

GetFontSources | Gets a copy of the array that contains the list of sources
GetFontSubstitutes | Returns array containing font substitute names to be used if original font is not presented.
SetFontFolder | Sets the fonts folder
SetFontFolders | Sets the fonts folders
SetFontSources | Sets the fonts sources.
SetFontSubstitutes | Font substitute names for given original font name.

Public Instance Constructors

FontConfigs Constructor Initializes a new instance of the FontConfigs class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs Constructor

Initializes a new instance of the FontConfigs class.

public FontConfigs();

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs Properties

The properties of the FontConfigs class are listed below. For a complete list of FontConfigs class members, see the FontConfigs Members topic.

Public Static Properties

DefaultFontName | Gets or sets the default font name.
PreferSystemFontSubstitutes | Indicate whether to use system font substitutes first or not when a font is not presented and the substitute of this font is not set. e.g. On Ubuntu, "Arial" font is generally substituted by "Liberation Sans". Default value is false.

See Also

FontConfigs Class | Aspose.Cells Namespace


DefaultFontName Property

Aspose.Cells for .NET

FontConfigs.DefaultFontName Property

Gets or sets the default font name.

public static string DefaultFontName {get; set;}

See Also

FontConfigs Class | Aspose.Cells Namespace


PreferSystemFontSubstitutes Property

Aspose.Cells for .NET

FontConfigs.PreferSystemFontSubstitutes Property

Indicate whether to use system font substitutes first or not when a font is not presented and the substitute of this font is not set. e.g. On Ubuntu, "Arial" font is generally substituted by "Liberation Sans". Default value is false.

public static bool PreferSystemFontSubstitutes {get; set;}

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs Methods

The methods of the FontConfigs class are listed below. For a complete list of FontConfigs class members, see the FontConfigs Members topic.

Public Static Methods

GetFontSources | Gets a copy of the array that contains the list of sources
GetFontSubstitutes | Returns array containing font substitute names to be used if original font is not presented.
SetFontFolder | Sets the fonts folder
SetFontFolders | Sets the fonts folders
SetFontSources | Sets the fonts sources.
SetFontSubstitutes | Font substitute names for given original font name.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs.GetFontSources Method

Gets a copy of the array that contains the list of sources

public static FontSourceBase[] GetFontSources();

Return Value

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs.GetFontSubstitutes Method

Returns array containing font substitute names to be used if original font is not presented.

public static string[] GetFontSubstitutes(
string originalFontName
);

Parameters

originalFontName
originalFontName

Return Value

An array containing font substitute names to be used if original font is not presented.

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs.SetFontFolder Method

Sets the fonts folder

public static void SetFontFolder(
string fontFolder,
bool recursive
);

Parameters

fontFolder
The folder that contains TrueType fonts.
recursive
Determines whether or not to scan subfolders.

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs.SetFontFolders Method

Sets the fonts folders

public static void SetFontFolders(
string[] fontFolders,
bool recursive
);

Parameters

fontFolders
The folders that contains TrueType fonts.
recursive
Determines whether or not to scan subfolders.

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs.SetFontSources Method

Sets the fonts sources.

public static void SetFontSources(
FontSourceBase[] sources
);

Parameters

sources
An array of sources that contain TrueType fonts.

See Also

FontConfigs Class | Aspose.Cells Namespace


FontConfigs.SetFontSubstitutes Method

Font substitute names for given original font name.

public static void SetFontSubstitutes(
string originalFontName,
string[] substituteFontNames
);

Parameters

originalFontName
Original font name.
substituteFontNames
List of font substitute names to be used if original font is not presented.

See Also

FontConfigs Class | Aspose.Cells Namespace


FontSchemeType Enumeration

Represents the scheme type of the font.

public enum FontSchemeType

Members

Member Name | Description | Value
None | None | 0
Major | Major scheme. | 1
Minor | Minor scheme. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FontSetting Class

Represents a range of characters within the cell text.

For a list of all members of this type, see FontSetting Members.

System.Object
Aspose.Cells.FontSetting
Aspose.Cells.Drawing.Texts.TextParagraph

public class FontSetting

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Instantiating a Workbook object
 Workbook workbook = new Workbook();

 //Adding a new worksheet to the Excel object
 workbook.Worksheets.Add();

 //Obtaining the reference of the newly added worksheet by passing its sheet index
 Worksheet worksheet = workbook.Worksheets[0];

 //Accessing the "A1" cell from the worksheet
 Aspose.Cells.Cell cell = worksheet.Cells["A1"];

 //Adding some value to the "A1" cell
 cell.PutValue("Visit Aspose!");

 //getting charactor
 FontSetting charactor = cell.Characters(6, 7);

 //Setting the font of selected characters to bold
 charactor.Font.IsBold = true;

 //Setting the font color of selected characters to blue
 charactor.Font.Color = Color.Blue;

 //Saving the Excel file
 workbook.Save("D:\\book1.xls");

 [VB.NET]

 'Instantiating a Workbook object
 Dim workbook As New Workbook()

 'Adding a new worksheet to the Excel object
 workbook.Worksheets.Add()

 'Obtaining the reference of the newly added worksheet by passing its sheet index
 Dim worksheet As Worksheet = workbook.Worksheets(0)

 'Accessing the "A1" cell from the worksheet
 Dim cell As Aspose.Cells.Cell = worksheet.Cells("A1")

 'Adding some value to the "A1" cell
 cell.PutValue("Visit Aspose!")

 'getting charactor
 Dim charactor As FontSetting = cell.Characters(6, 7)

 'Setting the font of selected characters to bold
 charactor.Font.IsBold = True

 'Setting the font color of selected characters to blue
 charactor.Font.Color = Color.Blue

 'Saving the Excel file
 workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FontSetting Members | Aspose.Cells Namespace


FontSetting Members

FontSetting overview

Public Instance Constructors

FontSetting Constructor

Public Instance Properties

Font | Returns the font of this object.
Length | Gets the length of the characters.
StartIndex | Gets the start index of the characters.
TextOptions | Returns the text options.
Type | Gets the type of text node.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetWordArtStyle | Sets the preset WordArt style.
ToString (inherited from Object) |

See Also

FontSetting Class | Aspose.Cells Namespace


FontSetting Constructor

public FontSetting(
int startIndex,
int length,
WorksheetCollection sheets
);

Parameters

startIndex
length
sheets

See Also

FontSetting Class | Aspose.Cells Namespace


FontSetting Properties

The properties of the FontSetting class are listed below. For a complete list of FontSetting class members, see the FontSetting Members topic.

Public Instance Properties

Font | Returns the font of this object.
Length | Gets the length of the characters.
StartIndex | Gets the start index of the characters.
TextOptions | Returns the text options.
Type | Gets the type of text node.

See Also

FontSetting Class | Aspose.Cells Namespace


Font Property

Aspose.Cells for .NET

FontSetting.Font Property

Returns the font of this object.

public Font Font {get;}

See Also

FontSetting Class | Aspose.Cells Namespace


Length Property

Aspose.Cells for .NET

FontSetting.Length Property

Gets the length of the characters.

public int Length {get;}

See Also

FontSetting Class | Aspose.Cells Namespace


StartIndex Property

Aspose.Cells for .NET

FontSetting.StartIndex Property

Gets the start index of the characters.

public int StartIndex {get;}

See Also

FontSetting Class | Aspose.Cells Namespace


TextOptions Property

Aspose.Cells for .NET

FontSetting.TextOptions Property

Returns the text options.

public TextOptions TextOptions {get;}

See Also

FontSetting Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

FontSetting.Type Property

Gets the type of text node.

public virtual TextNodeType Type {get;}

See Also

FontSetting Class | Aspose.Cells Namespace


FontSetting Methods

The methods of the FontSetting class are listed below. For a complete list of FontSetting class members, see the FontSetting Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetWordArtStyle | Sets the preset WordArt style.
ToString (inherited from Object) |

See Also

FontSetting Class | Aspose.Cells Namespace


FontSetting.SetWordArtStyle Method

Sets the preset WordArt style.

public void SetWordArtStyle(
PresetWordArtStyle style
);

Parameters

style
The preset WordArt style.

Remarks

Only for the text of shape/chart.

See Also

FontSetting Class | Aspose.Cells Namespace


FontSourceBase Class

This is an abstract base class for the classes that allow the user to specify various font sources

For a list of all members of this type, see FontSourceBase Members.

System.Object
Aspose.Cells.FontSourceBase
Aspose.Cells.FileFontSource
Aspose.Cells.FolderFontSource
Aspose.Cells.MemoryFontSource

public abstract class FontSourceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FontSourceBase Members | Aspose.Cells Namespace


FontSourceBase Members

FontSourceBase overview

Public Instance Properties

Type Returns the type of the font source.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FontSourceBase Class | Aspose.Cells Namespace


FontSourceBase Properties

The properties of the FontSourceBase class are listed below. For a complete list of FontSourceBase class members, see the FontSourceBase Members topic.

Public Instance Properties

Type Returns the type of the font source.

See Also

FontSourceBase Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

FontSourceBase.Type Property

Returns the type of the font source.

public abstract FontSourceType Type {get;}

See Also

FontSourceBase Class | Aspose.Cells Namespace


FontSourceType Enumeration

Specifies the type of a font source.

public enum FontSourceType

Members

Member Name | Description | Value
FontFile | represents single font file. | 0
FontsFolder | represents folder with font files. | 1
MemoryFont | represents single font in memory. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FontUnderlineType Enumeration

Enumerates the font underline types.

public enum FontUnderlineType

Members

Member Name | Description | Value
None | Represents no underline. | 0
Single | Represents single underline. | 1
Double | Represents double underline. | 2
Accounting | Represents single accounting underline. | 3
DoubleAccounting | Represents double accounting underline. | 4
Dash | Represents Dashed Underline | 5
DashDotDotHeavy | Represents Thick Dash-Dot-Dot Underline | 6
DashDotHeavy | Represents Thick Dash-Dot Underline | 7
DashedHeavy | Represents Thick Dashed Underline | 8
DashLong | Represents Long Dashed Underline | 9
DashLongHeavy | Represents Thick Long Dashed Underline | 10
DotDash | Represents Dash-Dot Underline | 11
DotDotDash | Represents Dash-Dot-Dot Underline | 12
Dotted | Represents Dotted Underline | 13
DottedHeavy | Represents Thick Dotted Underline | 14
Heavy | Represents Thick Underline | 15
Wave | Represents Wave Underline | 16
WavyDouble | Represents Double Wave Underline | 17
WavyHeavy | Represents Heavy Wave Underline | 18
Words | Represents Underline Non-Space Characters Only | 19

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FormatCondition Class

Represents conditional formatting condition.

For a list of all members of this type, see FormatCondition Members.

System.Object
Aspose.Cells.FormatCondition

public class FormatCondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Instantiating a Workbook object
Workbook workbook = new Workbook();
Worksheet sheet = workbook.Worksheets[0];

//Adds an empty conditional formatting
int index = sheet.ConditionalFormattings.Add();
FormatConditionCollection fcs = sheet.ConditionalFormattings[index];

//Sets the conditional format range.
CellArea ca = new CellArea();
ca.StartRow = 0;
ca.EndRow = 0;
ca.StartColumn = 0;
ca.EndColumn = 0;
fcs.AddArea(ca);

ca = new CellArea();
ca.StartRow = 1;
ca.EndRow = 1;
ca.StartColumn = 1;
ca.EndColumn = 1;
fcs.AddArea(ca);

//Adds condition.
int conditionIndex = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "=A2", "100");

//Adds condition.
int conditionIndex2 = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "50", "100");

//Sets the background color.
FormatCondition fc = fcs[conditionIndex];
fc.Style.BackgroundColor = Color.Red;

//Saving the Excel file
workbook.Save("C:\\output.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
Dim sheet As Worksheet = workbook.Worksheets(0)

' Adds an empty conditional formatting
Dim index As Integer = sheet.ConditionalFormattings.Add()
Dim fcs As FormatConditionCollection = sheet.ConditionalFormattings(index)

'Sets the conditional format range.
Dim ca As CellArea = New CellArea()
ca.StartRow = 0
ca.EndRow = 0
ca.StartColumn = 0
ca.EndColumn = 0
fcs.AddArea(ca)
ca = New CellArea()
ca.StartRow = 1
ca.EndRow = 1
ca.StartColumn = 1
ca.EndColumn = 1
fcs.AddArea(ca)

'Adds condition.
Dim conditionIndex As Integer = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "=A2", "100")

'Adds condition.
Dim conditionIndex2 As Integer = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "50", "100")

'Sets the background color.
Dim fc As FormatCondition = fcs(conditionIndex)
fc.Style.BackgroundColor = Color.Red

'Saving the Excel file
workbook.Save("C:\output.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FormatCondition Members | Aspose.Cells Namespace


FormatCondition Members

FormatCondition overview

Public Instance Properties

AboveAverage | Get the conditional formatting's "AboveAverage" instance. The default instance's rule highlights cells that are above the average for all values in the range. Valid only for type = AboveAverage.
ColorScale | Get the conditional formatting's "ColorScale" instance. The default instance is a "green-yellow-red" 3ColorScale . Valid only for type = ColorScale.
DataBar | Get the conditional formatting's "DataBar" instance. The default instance's color is blue. Valid only for type is DataBar.
Formula1 | Gets and sets the value or expression associated with conditional formatting.
Formula2 | Gets and sets the value or expression associated with conditional formatting.
IconSet | Get the conditional formatting's "IconSet" instance. The default instance's IconSetType is TrafficLights31. Valid only for type = IconSet.
Operator | Gets and sets the conditional format operator type.
Priority | The priority of this conditional formatting rule. This value is used to determine which format should be evaluated and rendered. Lower numeric values are higher priority than higher numeric values, where '1' is the highest priority.
StopIfTrue | True, no rules with lower priority may be applied over this rule, when this rule evaluates to true. Only applies for Excel 2007;
Style | Gets or setts style of conditional formatted cell ranges.
Text | The text value in a "text contains" conditional formatting rule. Valid only for type = containsText, notContainsText, beginsWith and endsWith. The default value is null.
TimePeriod | The applicable time period in a "date occurring¡" conditional formatting rule. Valid only for type = timePeriod. The default value is TimePeriodType.Today.
Top10 | Get the conditional formatting's "Top10" instance. The default instance's rule highlights cells whose values fall in the top 10 bracket. Valid only for type is Top10.
Type | Gets and sets whether the conditional format Type.

Public Instance Methods

Equals (inherited from Object) |
GetFormula1 | Overloaded. Gets the value or expression associated with this format condition.
GetFormula2 | Overloaded. Gets the value or expression associated with this format condition.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetFormula1 | Sets the value or expression associated with this format condition.
SetFormula2 | Sets the value or expression associated with this format condition.
SetFormulas | Sets the value or expression associated with this format condition.
ToString (inherited from Object) |

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatCondition Properties

The properties of the FormatCondition class are listed below. For a complete list of FormatCondition class members, see the FormatCondition Members topic.

Public Instance Properties

AboveAverage | Get the conditional formatting's "AboveAverage" instance. The default instance's rule highlights cells that are above the average for all values in the range. Valid only for type = AboveAverage.
ColorScale | Get the conditional formatting's "ColorScale" instance. The default instance is a "green-yellow-red" 3ColorScale . Valid only for type = ColorScale.
DataBar | Get the conditional formatting's "DataBar" instance. The default instance's color is blue. Valid only for type is DataBar.
Formula1 | Gets and sets the value or expression associated with conditional formatting.
Formula2 | Gets and sets the value or expression associated with conditional formatting.
IconSet | Get the conditional formatting's "IconSet" instance. The default instance's IconSetType is TrafficLights31. Valid only for type = IconSet.
Operator | Gets and sets the conditional format operator type.
Priority | The priority of this conditional formatting rule. This value is used to determine which format should be evaluated and rendered. Lower numeric values are higher priority than higher numeric values, where '1' is the highest priority.
StopIfTrue | True, no rules with lower priority may be applied over this rule, when this rule evaluates to true. Only applies for Excel 2007;
Style | Gets or setts style of conditional formatted cell ranges.
Text | The text value in a "text contains" conditional formatting rule. Valid only for type = containsText, notContainsText, beginsWith and endsWith. The default value is null.
TimePeriod | The applicable time period in a "date occurring¡" conditional formatting rule. Valid only for type = timePeriod. The default value is TimePeriodType.Today.
Top10 | Get the conditional formatting's "Top10" instance. The default instance's rule highlights cells whose values fall in the top 10 bracket. Valid only for type is Top10.
Type | Gets and sets whether the conditional format Type.

See Also

FormatCondition Class | Aspose.Cells Namespace


AboveAverage Property

Aspose.Cells for .NET

FormatCondition.AboveAverage Property

Get the conditional formatting's "AboveAverage" instance. The default instance's rule highlights cells that are above the average for all values in the range. Valid only for type = AboveAverage.

public AboveAverage AboveAverage {get;}

See Also

FormatCondition Class | Aspose.Cells Namespace


ColorScale Property

Aspose.Cells for .NET

FormatCondition.ColorScale Property

Get the conditional formatting's "ColorScale" instance. The default instance is a "green-yellow-red" 3ColorScale . Valid only for type = ColorScale.

public ColorScale ColorScale {get;}

See Also

FormatCondition Class | Aspose.Cells Namespace


DataBar Property

Aspose.Cells for .NET

FormatCondition.DataBar Property

Get the conditional formatting's "DataBar" instance. The default instance's color is blue. Valid only for type is DataBar.

public DataBar DataBar {get;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Formula1 Property

Aspose.Cells for .NET

FormatCondition.Formula1 Property

Gets and sets the value or expression associated with conditional formatting.

public string Formula1 {get; set;}

Remarks

Please add all areas before setting formula. For setting formula for this condition, if the input value starts with '=', then it will be taken as formula. Otherwise it will be taken as plain value(text, number, bool). For text value that starts with '=', user may input it as formula in format: "=\"=...\"".

See Also

FormatCondition Class | Aspose.Cells Namespace


Formula2 Property

Aspose.Cells for .NET

FormatCondition.Formula2 Property

Gets and sets the value or expression associated with conditional formatting.

public string Formula2 {get; set;}

Remarks

Please add all areas before setting formula. For setting formula for this condition, if the input value starts with '=', then it will be taken as formula. Otherwise it will be taken as plain value(text, number, bool). For text value that starts with '=', user may input it as formula in format: "=\"=...\"".

See Also

FormatCondition Class | Aspose.Cells Namespace


IconSet Property

Aspose.Cells for .NET

FormatCondition.IconSet Property

Get the conditional formatting's "IconSet" instance. The default instance's IconSetType is TrafficLights31. Valid only for type = IconSet.

public IconSet IconSet {get;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Operator Property

Aspose.Cells for .NET

FormatCondition.Operator Property

Gets and sets the conditional format operator type.

public OperatorType Operator {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Priority Property

Aspose.Cells for .NET

FormatCondition.Priority Property

The priority of this conditional formatting rule. This value is used to determine which format should be evaluated and rendered. Lower numeric values are higher priority than higher numeric values, where '1' is the highest priority.

public int Priority {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


StopIfTrue Property

Aspose.Cells for .NET

FormatCondition.StopIfTrue Property

True, no rules with lower priority may be applied over this rule, when this rule evaluates to true. Only applies for Excel 2007;

public bool StopIfTrue {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Style Property

Aspose.Cells for .NET

FormatCondition.Style Property

Gets or setts style of conditional formatted cell ranges.

public Style Style {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Text Property

Aspose.Cells for .NET

FormatCondition.Text Property

The text value in a "text contains" conditional formatting rule. Valid only for type = containsText, notContainsText, beginsWith and endsWith. The default value is null.

public string Text {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


TimePeriod Property

Aspose.Cells for .NET

FormatCondition.TimePeriod Property

The applicable time period in a "date occurring¡" conditional formatting rule. Valid only for type = timePeriod. The default value is TimePeriodType.Today.

public TimePeriodType TimePeriod {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Top10 Property

Aspose.Cells for .NET

FormatCondition.Top10 Property

Get the conditional formatting's "Top10" instance. The default instance's rule highlights cells whose values fall in the top 10 bracket. Valid only for type is Top10.

public Top10 Top10 {get;}

See Also

FormatCondition Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

FormatCondition.Type Property

Gets and sets whether the conditional format Type.

public FormatConditionType Type {get; set;}

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatCondition Methods

The methods of the FormatCondition class are listed below. For a complete list of FormatCondition class members, see the FormatCondition Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetFormula1 | Overloaded. Gets the value or expression associated with this format condition.
GetFormula2 | Overloaded. Gets the value or expression associated with this format condition.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetFormula1 | Sets the value or expression associated with this format condition.
SetFormula2 | Sets the value or expression associated with this format condition.
SetFormulas | Sets the value or expression associated with this format condition.
ToString (inherited from Object) |

See Also

FormatCondition Class | Aspose.Cells Namespace


GetFormula1 Method

Aspose.Cells for .NET

FormatCondition.GetFormula1 Method

Gets the value or expression associated with this format condition.

Overload List

Gets the value or expression associated with this format condition.

public string GetFormula1(bool,bool);

Gets the value or expression of the conditional formatting of the cell.

public string GetFormula1(bool,bool,int,int);

Gets the formula of the conditional formatting of the cell.

public string GetFormula1(int,int);

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatCondition.GetFormula1 Method (Boolean, Boolean)

Gets the value or expression associated with this format condition.

public string GetFormula1(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The value or expression associated with this format condition.

See Also

FormatCondition Class | Aspose.Cells Namespace | FormatCondition.GetFormula1 Overload List


FormatCondition.GetFormula1 Method (Boolean, Boolean, Int32, Int32)

Gets the value or expression of the conditional formatting of the cell.

public string GetFormula1(
bool isR1C1,
bool isLocal,
int row,
int column
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.
row
The row index.
column
The column index.

Return Value

The value or expression associated with the conditional formatting of the cell.

Remarks

The given cell must be contained by this conditional formatting, otherwise null will be returned.

See Also

FormatCondition Class | Aspose.Cells Namespace | FormatCondition.GetFormula1 Overload List


FormatCondition.GetFormula1 Method (Int32, Int32)

Gets the formula of the conditional formatting of the cell.

public string GetFormula1(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

The formula.

See Also

FormatCondition Class | Aspose.Cells Namespace | FormatCondition.GetFormula1 Overload List


GetFormula2 Method

Aspose.Cells for .NET

FormatCondition.GetFormula2 Method

Gets the value or expression associated with this format condition.

Overload List

Gets the value or expression associated with this format condition.

public string GetFormula2(bool,bool);

Gets the value or expression of the conditional formatting of the cell.

public string GetFormula2(bool,bool,int,int);

Gets the formula of the conditional formatting of the cell.

public string GetFormula2(int,int);

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatCondition.GetFormula2 Method (Boolean, Boolean)

Gets the value or expression associated with this format condition.

public string GetFormula2(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The value or expression associated with this format condition.

See Also

FormatCondition Class | Aspose.Cells Namespace | FormatCondition.GetFormula2 Overload List


FormatCondition.GetFormula2 Method (Boolean, Boolean, Int32, Int32)

Gets the value or expression of the conditional formatting of the cell.

public string GetFormula2(
bool isR1C1,
bool isLocal,
int row,
int column
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.
row
The row index.
column
The column index.

Return Value

The value or expression associated with the conditional formatting of the cell.

Remarks

The given cell must be contained by this conditional formatting, otherwise null will be returned.

See Also

FormatCondition Class | Aspose.Cells Namespace | FormatCondition.GetFormula2 Overload List


FormatCondition.GetFormula2 Method (Int32, Int32)

Gets the formula of the conditional formatting of the cell.

public string GetFormula2(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

The formula.

See Also

FormatCondition Class | Aspose.Cells Namespace | FormatCondition.GetFormula2 Overload List


FormatCondition.SetFormula1 Method

Sets the value or expression associated with this format condition.

public void SetFormula1(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
The value or expression associated with this format condition. If the input value starts with '=', then it will be taken as formula. Otherwise it will be taken as plain value(text, number, bool). For text value that starts with '=', user may input it as formula in format: "=\"=...\"".
isR1C1
Whether the formula is R1C1 formula.
isLocal
Whether the formula is locale formatted.

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatCondition.SetFormula2 Method

Sets the value or expression associated with this format condition.

public void SetFormula2(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
The value or expression associated with this format condition. If the input value starts with '=', then it will be taken as formula. Otherwise it will be taken as plain value(text, number, bool). For text value that starts with '=', user may input it as formula in format: "=\"=...\"".
isR1C1
Whether the formula is R1C1 formula.
isLocal
Whether the formula is locale formatted.

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatCondition.SetFormulas Method

Sets the value or expression associated with this format condition.

public void SetFormulas(
string formula1,
string formula2,
bool isR1C1,
bool isLocal
);

Parameters

formula1
The value or expression associated with this format condition. If the input value starts with '=', then it will be taken as formula. Otherwise it will be taken as plain value(text, number, bool). For text value that starts with '=', user may input it as formula in format: "=\"=...\"".
formula2
The value or expression associated with this format condition. The input format is same with formula1
isR1C1
Whether the formula is R1C1 formula.
isLocal
Whether the formula is locale formatted.

See Also

FormatCondition Class | Aspose.Cells Namespace


FormatConditionCollection Class

Represents conditional formatting. The FormatConditions can contain up to three conditional formats.

For a list of all members of this type, see FormatConditionCollection Members.

System.Object
Aspose.Cells.FormatConditionCollection

public class FormatConditionCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Adds an empty conditional formatting
 int index = sheet.ConditionalFormattings.Add();
 FormatConditionCollection fcs = sheet.ConditionalFormattings[index];
 //Sets the conditional format range.
 CllArea ca = new CellArea();
 ca.StartRow = 0;
 ca.EndRow = 0;
 ca.StartColumn = 0;
 ca.EndColumn = 0;
 fcs.AddArea(ca);
 ca = new CellArea();
 ca.StartRow = 1;
 ca.EndRow = 1;
 ca.StartColumn = 1;
 ca.EndColumn = 1;
 fcs.AddArea(ca);
 //Adds condition.
 int conditionIndex = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "=A2", "100");
 //Adds condition.
 int conditionIndex2 = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "50", "100");
 //Sets the background color.
 FormatCondition fc = fcs[conditionIndex];
 fc.Style.BackgroundColor = Color.Red;
 //Saving the Excel file
 workbook.Save("C:\\output.xls");

 [Visual Basic]

 'Instantiating a Workbook object
 Dim workbook As Workbook = New Workbook()
 Dim sheet As Worksheet = workbook.Worksheets(0)
 ' Adds an empty conditional formatting
 Dim index As Integer = sheet.ConditionalFormattings.Add()
 Dim fcs As FormatConditionCollection = sheet.ConditionalFormattings(index)
 'Sets the conditional format range.
 Dim ca As CellArea = New CellArea()
 ca.StartRow = 0
 ca.EndRow = 0
 ca.StartColumn = 0
 ca.EndColumn = 0
 fcs.AddArea(ca)
 ca = New CellArea()
 ca.StartRow = 1
 ca.EndRow = 1
 ca.StartColumn = 1
 ca.EndColumn = 1
 fcs.AddArea(ca)
 'Adds condition.
 Dim conditionIndex As Integer = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "=A2", "100")
 'Adds condition.
 Dim conditionIndex2 As Integer = fcs.AddCondition(FormatConditionType.CellValue, OperatorType.Between, "50", "100")
 'Sets the background color.
 Dim fc As FormatCondition = fcs(conditionIndex)
 fc.Style.BackgroundColor = Color.Red
 'Saving the Excel file
 workbook.Save("C:\output.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FormatConditionCollection Members | Aspose.Cells Namespace


FormatConditionCollection Members

FormatConditionCollection overview

Public Instance Properties

Count | Gets the count of the conditions.
Item | Gets the formatting condition by index.
RangeCount | Gets count of conditionally formatted ranges.

Public Instance Methods

Add | Adds a formatting condition and effected cell rang to the FormatConditions The FormatConditions can contain up to three conditional formats. References to the other sheets are not allowed in the formulas of conditional formatting.
AddArea | Adds a conditional formatted cell range.
AddCondition | Overloaded. Adds a formatting condition.
Equals (inherited from Object) |
GetCellArea | Gets the conditional formatted cell range by index.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveArea | Overloaded. Removes conditional formatted cell range by index.
RemoveCondition | Removes the formatting condition by index.
ToString (inherited from Object) |

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionCollection Properties

The properties of the FormatConditionCollection class are listed below. For a complete list of FormatConditionCollection class members, see the FormatConditionCollection Members topic.

Public Instance Properties

Count | Gets the count of the conditions.
Item | Gets the formatting condition by index.
RangeCount | Gets count of conditionally formatted ranges.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


Count Property

Aspose.Cells for .NET

FormatConditionCollection.Count Property

Gets the count of the conditions.

public int Count {get;}

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

FormatConditionCollection.Item Property

Gets the formatting condition by index.

public FormatCondition this[
int index
] {get;}

Parameters

index
the index of the formatting condition to return.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


RangeCount Property

Aspose.Cells for .NET

FormatConditionCollection.RangeCount Property

Gets count of conditionally formatted ranges.

public int RangeCount {get;}

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionCollection Methods

The methods of the FormatConditionCollection class are listed below. For a complete list of FormatConditionCollection class members, see the FormatConditionCollection Members topic.

Public Instance Methods

Add | Adds a formatting condition and effected cell rang to the FormatConditions The FormatConditions can contain up to three conditional formats. References to the other sheets are not allowed in the formulas of conditional formatting.
AddArea | Adds a conditional formatted cell range.
AddCondition | Overloaded. Adds a formatting condition.
Equals (inherited from Object) |
GetCellArea | Gets the conditional formatted cell range by index.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveArea | Overloaded. Removes conditional formatted cell range by index.
RemoveCondition | Removes the formatting condition by index.
ToString (inherited from Object) |

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionCollection.Add Method

Adds a formatting condition and effected cell rang to the FormatConditions The FormatConditions can contain up to three conditional formats. References to the other sheets are not allowed in the formulas of conditional formatting.

public int[] Add(
CellArea cellArea,
FormatConditionType type,
OperatorType operatorType,
string formula1,
string formula2
);

Parameters

cellArea
Conditional formatted cell range.
type
Type of conditional formatting.It could be one of the members of FormatConditionType.
operatorType
Comparison operator.It could be one of the members of OperatorType.
formula1
The value or expression associated with conditional formatting.
formula2
The value or expression associated with conditional formatting

Return Value

[0]:Formatting condition object index;[1] Effected cell rang index.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionCollection.AddArea Method

Adds a conditional formatted cell range.

public int AddArea(
CellArea cellArea
);

Parameters

cellArea
Conditional formatted cell range.

Return Value

Conditional formatted cell rang index.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


AddCondition Method

Aspose.Cells for .NET

FormatConditionCollection.AddCondition Method

Add a format condition.

Overload List

Add a format condition.

public int AddCondition(FormatConditionType);

Adds a formatting condition.

public int AddCondition(FormatConditionType,OperatorType,string,string);

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionCollection.AddCondition Method (FormatConditionType)

Add a format condition.

public int AddCondition(
FormatConditionType type
);

Parameters

type
Format condition type.

Return Value

Formatting condition object index;

See Also

FormatConditionCollection Class | Aspose.Cells Namespace | FormatConditionCollection.AddCondition Overload List


FormatConditionCollection.AddCondition Method (FormatConditionType, OperatorType, String, String)

Adds a formatting condition.

public int AddCondition(
FormatConditionType type,
OperatorType operatorType,
string formula1,
string formula2
);

Parameters

type
of conditional formatting.It could be one of the members of FormatConditionType.
operatorType
The comparison OperatorType.It could be one of the members of OperatorType.
formula1
The value or expression associated with conditional formatting. If the input value starts with '=', then it will be taken as formula. Otherwise it will be taken as plain value(text, number, bool). For text value that starts with '=', user may input it as formula in format: "=\"=...\"".
formula2
The value or expression associated with conditional formatting. The input format is same with formula1

Return Value

Formatting condition object index;

See Also

FormatConditionCollection Class | Aspose.Cells Namespace | FormatConditionCollection.AddCondition Overload List


FormatConditionCollection.GetCellArea Method

Gets the conditional formatted cell range by index.

public CellArea GetCellArea(
int index
);

Parameters

index
the index of the conditional formatted cell range.

Return Value

the conditional formatted cell range

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


RemoveArea Method

Aspose.Cells for .NET

FormatConditionCollection.RemoveArea Method

Removes conditional formatted cell range by index.

Overload List

Removes conditional formatted cell range by index.

public void RemoveArea(int);

Remove conditional formatting int the range.

public bool RemoveArea(int,int,int,int);

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionCollection.RemoveArea Method (Int32)

Removes conditional formatted cell range by index.

public void RemoveArea(
int index
);

Parameters

index
The index of the conditional formatted cell range to be removed.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace | FormatConditionCollection.RemoveArea Overload List


FormatConditionCollection.RemoveArea Method (Int32, Int32, Int32, Int32)

Remove conditional formatting int the range.

public bool RemoveArea(
int startRow,
int startColumn,
int totalRows,
int totalColumns
);

Parameters

startRow
The startRow of the range.
startColumn
The startColumn of the range.
totalRows
The number of rows of the range.
totalColumns
The number of columns of the range.

Return Value

Returns TRUE, this FormatCondtionCollection should be removed.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace | FormatConditionCollection.RemoveArea Overload List


FormatConditionCollection.RemoveCondition Method

Removes the formatting condition by index.

public void RemoveCondition(
int index
);

Parameters

index
The index of the formatting condition to be removed.

See Also

FormatConditionCollection Class | Aspose.Cells Namespace


FormatConditionType Enumeration

Conditional format rule type.

public enum FormatConditionType

Members

Member Name | Description | Value
CellValue | This conditional formatting rule compares a cell value to a formula calculated result, using an operator. | 0
Expression | This conditional formatting rule contains a formula to evaluate. When the formula result is true, the cell is highlighted. | 1
ColorScale | This conditional formatting rule creates a gradated color scale on the cells. | 2
DataBar | This conditional formatting rule displays a gradated data bar in the range of cells. | 3
IconSet | This conditional formatting rule applies icons to cells according to their values. | 4
Top10 | This conditional formatting rule highlights cells whose values fall in the top N or bottom N bracket, as specified. | 5
UniqueValues | This conditional formatting rule highlights unique values in the range. | 6
DuplicateValues | This conditional formatting rule highlights duplicated values. | 7
ContainsText | This conditional formatting rule highlights cells containing given text. Equivalent to using the SEARCH() sheet function to determine whether the cell contains the text. | 8
NotContainsText | This conditional formatting rule highlights cells that are not blank. Equivalent of using LEN(TRIM()). This means that if the cell contains only characters that TRIM() would remove, then it is considered blank. An empty cell is also considered blank. | 9
BeginsWith | This conditional formatting rule highlights cells in the range that begin with the given text. Equivalent to using the LEFT() sheet function and comparing values. | 10
EndsWith | This conditional formatting rule highlights cells ending with given text. Equivalent to using the RIGHT() sheet function and comparing values. | 11
ContainsBlanks | This conditional formatting rule highlights cells that are completely blank. Equivalent of using LEN(TRIM()). This means that if the cell contains only characters that TRIM() would remove, then it is considered blank. An empty cell is also considered blank. | 12
NotContainsBlanks | This conditional formatting rule highlights cells that are not blank. Equivalent of using LEN(TRIM()). This means that if the cell contains only characters that TRIM() would remove, then it is considered blank. An empty cell is also considered blank. | 13
ContainsErrors | This conditional formatting rule highlights cells with formula errors. Equivalent to using ISERROR() sheet function to determine if there is a formula error. | 14
NotContainsErrors | This conditional formatting rule highlights cells without formula errors. Equivalent to using ISERROR() sheet function to determine if there is a formula error. | 15
TimePeriod | This conditional formatting rule highlights cells containing dates in the specified time period. The underlying value of the cell is evaluated, therefore the cell does not need to be formatted as a date to be evaluated. For example, with a cell containing the value 38913 the conditional format shall be applied if the rule requires a value of 7/14/2006. | 16
AboveAverage | This conditional formatting rule highlights cells that are above or below the average for all values in the range. | 17

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FormatConditionValueType Enumeration

Condition value type.

public enum FormatConditionValueType

Members

Member Name | Description | Value
Formula | The minimum/ midpoint / maximum value for the gradient is determined by a formula. | 0
Max | Indicates that the maximum value in the range shall be used as the maximum value for the gradient. | 1
Min | Indicates that the minimum value in the range shall be used as the minimum value for the gradient. | 2
Number | Indicates that the minimum / midpoint / maximum value for the gradient is specified by a constant numeric value. | 3
Percent | Value indicates a percentage between the minimum and maximum values in the range shall be used as the minimum / midpoint / maximum value for the gradient. | 4
Percentile | Value indicates a percentile ranking in the range shall be used as the minimum / midpoint / maximum value for the gradient. | 5
AutomaticMax | Indicates that the Automatic maximum value in the range shall be used as the Automatic maximum value for the gradient. | 6
AutomaticMin | Indicates that the Automatic minimum value in the range shall be used as the Automatic minimum value for the gradient. | 7

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


FormulaParseOptions Class

Represents options when parsing formula.

For a list of all members of this type, see FormulaParseOptions Members.

System.Object
Aspose.Cells.FormulaParseOptions

public class FormulaParseOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FormulaParseOptions Members | Aspose.Cells Namespace


FormulaParseOptions Members

FormulaParseOptions overview

Public Instance Constructors

FormulaParseOptions Constructor Initializes a new instance of the FormulaParseOptions class.

Public Instance Properties

CheckAddIn | Whether check addins in existing external links of current workbook for user defined function without external link. Default is true(if user defined function matches one addin in existing external links, then take it as the addin).
LocaleDependent | Whether the formula is locale formatted. Default is false.
Parse | Whether parse given formula. Default is true. If it is false, then given formula string will be kept as it is for the cell until user call other methods to parse them or parsed formula data is required by other operations such as calculating formulas.
R1C1Style | Whether the formula is R1C1 reference style. Default is false.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


FormulaParseOptions Constructor

Initializes a new instance of the FormulaParseOptions class.

public FormulaParseOptions();

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


FormulaParseOptions Properties

The properties of the FormulaParseOptions class are listed below. For a complete list of FormulaParseOptions class members, see the FormulaParseOptions Members topic.

Public Instance Properties

CheckAddIn | Whether check addins in existing external links of current workbook for user defined function without external link. Default is true(if user defined function matches one addin in existing external links, then take it as the addin).
LocaleDependent | Whether the formula is locale formatted. Default is false.
Parse | Whether parse given formula. Default is true. If it is false, then given formula string will be kept as it is for the cell until user call other methods to parse them or parsed formula data is required by other operations such as calculating formulas.
R1C1Style | Whether the formula is R1C1 reference style. Default is false.

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


CheckAddIn Property

Aspose.Cells for .NET

FormulaParseOptions.CheckAddIn Property

Whether check addins in existing external links of current workbook for user defined function without external link. Default is true(if user defined function matches one addin in existing external links, then take it as the addin).

public bool CheckAddIn {get; set;}

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


LocaleDependent Property

Aspose.Cells for .NET

FormulaParseOptions.LocaleDependent Property

Whether the formula is locale formatted. Default is false.

public bool LocaleDependent {get; set;}

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


Parse Property

Aspose.Cells for .NET

FormulaParseOptions.Parse Property

Whether parse given formula. Default is true. If it is false, then given formula string will be kept as it is for the cell until user call other methods to parse them or parsed formula data is required by other operations such as calculating formulas.

public bool Parse {get; set;}

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


R1C1Style Property

Aspose.Cells for .NET

FormulaParseOptions.R1C1Style Property

Whether the formula is R1C1 reference style. Default is false.

public bool R1C1Style {get; set;}

See Also

FormulaParseOptions Class | Aspose.Cells Namespace


GlobalizationSettings Class

Represents the globalization settings.

For a list of all members of this type, see GlobalizationSettings Members.

System.Object
Aspose.Cells.GlobalizationSettings

public class GlobalizationSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GlobalizationSettings Members | Aspose.Cells Namespace


GlobalizationSettings Members

GlobalizationSettings overview

Public Instance Constructors

GlobalizationSettings Constructor Initializes a new instance of the GlobalizationSettings class.

Public Instance Properties

ColumnSeparatorOfFormulaArray | Gets the separator for the items in array's row data in formula.
ListSeparator | Gets the separator for list, parameters of function, ...etc.
RowSeparatorOfFormulaArray | Gets the separator for rows in array data in formula.

Public Instance Methods

Equals (inherited from Object) |
GetAllName | Gets the name of "(All)" label in the PivotTable.
GetBooleanValueString | Gets the display string value for cell's boolean value
GetColumnLabelsOfPivotTable | Gets the name of "Column Labels" label in the PivotTable.
GetColumnLablesName | Obsolete. Gets the name of "Column Labels" label in the PivotTable.
GetEmptyDataName | Gets the name of "(blank)" label in the PivotTable.
GetErrorValueString | Gets the display string value for cell's error value
GetGrandTotalName | Gets the grand total name of the function.
GetHashCode (inherited from Object) |
GetLocalBuiltInName | Gets the locale dependent text for built-in Name according to given standard text.
GetLocalFunctionName | Gets the locale dependent function name according to given standard function name.
GetMultipleItemsName | Gets the name of "(Multiple Items)" label in the PivotTable.
GetOtherName | Gets the name of "Other" labels for Pie charts.
GetPivotGrandTotalName | Gets the name of "Grand Total" label in the PivotTable.
GetPivotTotalName | Gets the name of "Total" label in the PivotTable. You need to override this method when the PivotTable contains two or more PivotFields in the data area.
GetRowLabelsNameOfPivotTable | Gets the name of "Row Labels" label in the PivotTable.
GetRowLablesName | Obsolete. Gets the name of "Row Labels" label in the PivotTable.
GetStandardBuiltInName | Gets the standard text of built-in Name according to given locale dependent text.
GetStandardFunctionName | Gets the standard function name according to given locale dependent function name.
GetStandardHeaderFooterFontStyleName | Gets standard English font style name(Regular, Bold, Italic) for Header/Footer according to given locale font style name.
GetSubTotalName | Gets the name of PivotFieldSubtotalType type in the PivotTable.
GetTableRowTypeOfAll | Gets the type name of table rows that consists of all rows in referenced table. Default is "All": "#All" denotes all rows in referenced table.
GetTableRowTypeOfCurrent | Gets the type name of table rows that consists of the current row in referenced table. Default is "This Row": "#This Row" denotes the current row in referenced table.
GetTableRowTypeOfData | Gets the type name of table rows that consists of data region of referenced table. Default is "Data": "#Data" denotes the data region of the table.
GetTableRowTypeOfHeaders | Gets the type name of table rows that consists of the table header. Default is "Headers": "#Headers" denotes the table header.
GetTableRowTypeOfTotals | Gets the type name of table rows that consists of the total row of referenced table. Default is "Totals": "#Totals" denotes the total row of referenced table.
GetTotalName | Gets the total name of the function.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings Constructor

Initializes a new instance of the GlobalizationSettings class.

public GlobalizationSettings();

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings Properties

The properties of the GlobalizationSettings class are listed below. For a complete list of GlobalizationSettings class members, see the GlobalizationSettings Members topic.

Public Instance Properties

ColumnSeparatorOfFormulaArray | Gets the separator for the items in array's row data in formula.
ListSeparator | Gets the separator for list, parameters of function, ...etc.
RowSeparatorOfFormulaArray | Gets the separator for rows in array data in formula.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


ColumnSeparatorOfFormulaArray Property

Aspose.Cells for .NET

GlobalizationSettings.ColumnSeparatorOfFormulaArray Property

Gets the separator for the items in array's row data in formula.

public virtual char ColumnSeparatorOfFormulaArray {get;}

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


ListSeparator Property

Aspose.Cells for .NET

GlobalizationSettings.ListSeparator Property

Gets the separator for list, parameters of function, ...etc.

public virtual char ListSeparator {get;}

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


RowSeparatorOfFormulaArray Property

Aspose.Cells for .NET

GlobalizationSettings.RowSeparatorOfFormulaArray Property

Gets the separator for rows in array data in formula.

public virtual char RowSeparatorOfFormulaArray {get;}

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings Methods

The methods of the GlobalizationSettings class are listed below. For a complete list of GlobalizationSettings class members, see the GlobalizationSettings Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetAllName | Gets the name of "(All)" label in the PivotTable.
GetBooleanValueString | Gets the display string value for cell's boolean value
GetColumnLabelsOfPivotTable | Gets the name of "Column Labels" label in the PivotTable.
GetColumnLablesName | Obsolete. Gets the name of "Column Labels" label in the PivotTable.
GetEmptyDataName | Gets the name of "(blank)" label in the PivotTable.
GetErrorValueString | Gets the display string value for cell's error value
GetGrandTotalName | Gets the grand total name of the function.
GetHashCode (inherited from Object) |
GetLocalBuiltInName | Gets the locale dependent text for built-in Name according to given standard text.
GetLocalFunctionName | Gets the locale dependent function name according to given standard function name.
GetMultipleItemsName | Gets the name of "(Multiple Items)" label in the PivotTable.
GetOtherName | Gets the name of "Other" labels for Pie charts.
GetPivotGrandTotalName | Gets the name of "Grand Total" label in the PivotTable.
GetPivotTotalName | Gets the name of "Total" label in the PivotTable. You need to override this method when the PivotTable contains two or more PivotFields in the data area.
GetRowLabelsNameOfPivotTable | Gets the name of "Row Labels" label in the PivotTable.
GetRowLablesName | Obsolete. Gets the name of "Row Labels" label in the PivotTable.
GetStandardBuiltInName | Gets the standard text of built-in Name according to given locale dependent text.
GetStandardFunctionName | Gets the standard function name according to given locale dependent function name.
GetStandardHeaderFooterFontStyleName | Gets standard English font style name(Regular, Bold, Italic) for Header/Footer according to given locale font style name.
GetSubTotalName | Gets the name of PivotFieldSubtotalType type in the PivotTable.
GetTableRowTypeOfAll | Gets the type name of table rows that consists of all rows in referenced table. Default is "All": "#All" denotes all rows in referenced table.
GetTableRowTypeOfCurrent | Gets the type name of table rows that consists of the current row in referenced table. Default is "This Row": "#This Row" denotes the current row in referenced table.
GetTableRowTypeOfData | Gets the type name of table rows that consists of data region of referenced table. Default is "Data": "#Data" denotes the data region of the table.
GetTableRowTypeOfHeaders | Gets the type name of table rows that consists of the table header. Default is "Headers": "#Headers" denotes the table header.
GetTableRowTypeOfTotals | Gets the type name of table rows that consists of the total row of referenced table. Default is "Totals": "#Totals" denotes the total row of referenced table.
GetTotalName | Gets the total name of the function.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetAllName Method

Gets the name of "(All)" label in the PivotTable.

public virtual string GetAllName();

Return Value

The name of "(All)" label

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetBooleanValueString Method

Gets the display string value for cell's boolean value

public virtual string GetBooleanValueString(
bool bv
);

Parameters

bv
boolean value

Return Value

Default returns "TRUE" for true value and "FALSE" for false value.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetColumnLabelsOfPivotTable Method

Gets the name of "Column Labels" label in the PivotTable.

public virtual string GetColumnLabelsOfPivotTable();

Return Value

The name of column labels

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetColumnLablesName Method

NOTE: This method is now obsolete.

Use GlobalizationSettings.GetColumnLabelsOfPivotTable() method instead.

Gets the name of "Column Labels" label in the PivotTable.

public virtual string GetColumnLablesName();

Return Value

The name of column labels

Remarks

NOTE: This member is now obsolete. Instead, please use GlobalizationSettings.GetColumnLabelsOfPivotTable() method. This property will be removed 12 months later since September 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetEmptyDataName Method

Gets the name of "(blank)" label in the PivotTable.

public virtual string GetEmptyDataName();

Return Value

The name of empty data

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetErrorValueString Method

Gets the display string value for cell's error value

public virtual string GetErrorValueString(
string err
);

Parameters

err
error values such as #VALUE!,#NAME?

Return Value

Default returns the error value itself

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetGrandTotalName Method

Gets the grand total name of the function.

public virtual string GetGrandTotalName(
ConsolidationFunction functionType
);

Parameters

functionType
The function type.

Return Value

The grand total name of the function.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetLocalBuiltInName Method

Gets the locale dependent text for built-in Name according to given standard text.

public virtual string GetLocalBuiltInName(
string standardName
);

Parameters

standardName
Standard(en-US locale) text of built-in Name.

Return Value

Locale dependent text. The locale was specified by the Workbook for which this settings is used.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetLocalFunctionName Method

Gets the locale dependent function name according to given standard function name.

public virtual string GetLocalFunctionName(
string standardName
);

Parameters

standardName
Standard(en-US locale) function name.

Return Value

Locale dependent function name. The locale was specified by the Workbook for which this settings is used.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetMultipleItemsName Method

Gets the name of "(Multiple Items)" label in the PivotTable.

public virtual string GetMultipleItemsName();

Return Value

The name of "(Multiple Items)" label

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetOtherName Method

Gets the name of "Other" labels for Pie charts.

public virtual string GetOtherName();

Return Value

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetPivotGrandTotalName Method

Gets the name of "Grand Total" label in the PivotTable.

public virtual string GetPivotGrandTotalName();

Return Value

The name of "Grand Total" label

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetPivotTotalName Method

Gets the name of "Total" label in the PivotTable. You need to override this method when the PivotTable contains two or more PivotFields in the data area.

public virtual string GetPivotTotalName();

Return Value

The name of "Total" label

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetRowLabelsNameOfPivotTable Method

Gets the name of "Row Labels" label in the PivotTable.

public virtual string GetRowLabelsNameOfPivotTable();

Return Value

The name of row labels

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetRowLablesName Method

NOTE: This method is now obsolete.

Use GlobalizationSettings.GetRowLabelsOfPivotTable() method instead.

Gets the name of "Row Labels" label in the PivotTable.

public virtual string GetRowLablesName();

Return Value

The name of row labels

Remarks

NOTE: This member is now obsolete. Instead, please use GlobalizationSettings.GetRowLabelsOfPivotTable() method. This property will be removed 12 months later since September 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetStandardBuiltInName Method

Gets the standard text of built-in Name according to given locale dependent text.

public virtual string GetStandardBuiltInName(
string localName
);

Parameters

localName
Locale dependent text of built-in Name. The locale was specified by the Workbook for which this settings is used.

Return Value

Standard(en-US locale) text.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetStandardFunctionName Method

Gets the standard function name according to given locale dependent function name.

public virtual string GetStandardFunctionName(
string localName
);

Parameters

localName
Locale dependent function name. The locale was specified by the Workbook for which this settings is used.

Return Value

Standard(en-US locale) function name.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetStandardHeaderFooterFontStyleName Method

Gets standard English font style name(Regular, Bold, Italic) for Header/Footer according to given locale font style name.

public virtual string GetStandardHeaderFooterFontStyleName(
string localfontStyleName
);

Parameters

localfontStyleName
Locale font style name for Header/Footer.

Return Value

Standard English font style name(Regular, Bold, Italic)

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetSubTotalName Method

Gets the name of PivotFieldSubtotalType type in the PivotTable.

public virtual string GetSubTotalName(
PivotFieldSubtotalType subTotalType
);

Parameters

subTotalType
The PivotFieldSubtotalType type

Return Value

The name of PivotFieldSubtotalType type

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetTableRowTypeOfAll Method

Gets the type name of table rows that consists of all rows in referenced table. Default is "All": "#All" denotes all rows in referenced table.

public virtual string GetTableRowTypeOfAll();

Return Value

the type name of table rows

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetTableRowTypeOfCurrent Method

Gets the type name of table rows that consists of the current row in referenced table. Default is "This Row": "#This Row" denotes the current row in referenced table.

public virtual string GetTableRowTypeOfCurrent();

Return Value

the type name of table rows

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetTableRowTypeOfData Method

Gets the type name of table rows that consists of data region of referenced table. Default is "Data": "#Data" denotes the data region of the table.

public virtual string GetTableRowTypeOfData();

Return Value

the type name of table rows

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetTableRowTypeOfHeaders Method

Gets the type name of table rows that consists of the table header. Default is "Headers": "#Headers" denotes the table header.

public virtual string GetTableRowTypeOfHeaders();

Return Value

the type name of table rows

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetTableRowTypeOfTotals Method

Gets the type name of table rows that consists of the total row of referenced table. Default is "Totals": "#Totals" denotes the total row of referenced table.

public virtual string GetTableRowTypeOfTotals();

Return Value

the type name of table rows

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GlobalizationSettings.GetTotalName Method

Gets the total name of the function.

public virtual string GetTotalName(
ConsolidationFunction functionType
);

Parameters

functionType
The function type.

Return Value

The total name of the function.

See Also

GlobalizationSettings Class | Aspose.Cells Namespace


GridlineType Enumeration

Enumerates grid line Type.

public enum GridlineType

Members

Member Name | Description | Value
Dotted | Represents dotted line. | 0
Hair | Represents hair line. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HeaderFooterCommand Class

Represents the command of header/footer

For a list of all members of this type, see HeaderFooterCommand Members.

System.Object
Aspose.Cells.HeaderFooterCommand

public class HeaderFooterCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

HeaderFooterCommand Members | Aspose.Cells Namespace


HeaderFooterCommand Members

HeaderFooterCommand overview

Public Instance Properties

Font | Gets the font of the command's value.
Text | Gets the text of the command.
Type | Gets the header/footer' command type .

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

HeaderFooterCommand Class | Aspose.Cells Namespace


HeaderFooterCommand Properties

The properties of the HeaderFooterCommand class are listed below. For a complete list of HeaderFooterCommand class members, see the HeaderFooterCommand Members topic.

Public Instance Properties

Font | Gets the font of the command's value.
Text | Gets the text of the command.
Type | Gets the header/footer' command type .

See Also

HeaderFooterCommand Class | Aspose.Cells Namespace


Font Property

Aspose.Cells for .NET

HeaderFooterCommand.Font Property

Gets the font of the command's value.

public Font Font {get;}

Remarks

Useless for HeaderFooterCommandType.Picture.

See Also

HeaderFooterCommand Class | Aspose.Cells Namespace


Text Property

Aspose.Cells for .NET

HeaderFooterCommand.Text Property

Gets the text of the command.

public string Text {get;}

Remarks

Only valid for HeaderFooterCommandType.Text.

See Also

HeaderFooterCommand Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

HeaderFooterCommand.Type Property

Gets the header/footer' command type .

public HeaderFooterCommandType Type {get;}

See Also

HeaderFooterCommand Class | Aspose.Cells Namespace


HeaderFooterCommandType Enumeration

Represents the command type of header and footer.

public enum HeaderFooterCommandType

Members

Member Name | Description | Value
Text | The text. | 0
CurrentPage | Current page number | 1
Pagecount | Page count | 2
CurrentDate | Current date | 3
CurrentTime | Current time | 4
SheetName | Sheet name | 5
FileName | File name without path | 6
FilePath | File path without file name | 7
Picture | Picture | 8

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HorizontalPageBreak Class

Encapsulates the object that represents a horizontal page break.

For a list of all members of this type, see HorizontalPageBreak Members.

System.Object
Aspose.Cells.HorizontalPageBreak

public class HorizontalPageBreak

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[0];

//Add a page break at cell Y30
int Index = worksheet.HorizontalPageBreaks.Add("Y30");

//get the newly added horizontal page break
HorizontalPageBreak hPageBreak = worksheet.HorizontalPageBreaks[Index];

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Add a page break at cell Y30
Dim Index As Integer = worksheet.HorizontalPageBreaks.Add("Y30")

'get the newly added horizontal page break
Dim hPageBreak As HorizontalPageBreak = worksheet.HorizontalPageBreaks(Index)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

HorizontalPageBreak Members | Aspose.Cells Namespace


HorizontalPageBreak Members

HorizontalPageBreak overview

Public Instance Properties

EndColumn | Gets the end column index of this horizontal page break.
Row | Gets the zero based row index.
StartColumn | Gets the start column index of this horizontal page break.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

HorizontalPageBreak Class | Aspose.Cells Namespace


HorizontalPageBreak Properties

The properties of the HorizontalPageBreak class are listed below. For a complete list of HorizontalPageBreak class members, see the HorizontalPageBreak Members topic.

Public Instance Properties

EndColumn | Gets the end column index of this horizontal page break.
Row | Gets the zero based row index.
StartColumn | Gets the start column index of this horizontal page break.

See Also

HorizontalPageBreak Class | Aspose.Cells Namespace


EndColumn Property

Aspose.Cells for .NET

HorizontalPageBreak.EndColumn Property

Gets the end column index of this horizontal page break.

public int EndColumn {get;}

See Also

HorizontalPageBreak Class | Aspose.Cells Namespace


Row Property

Aspose.Cells for .NET

HorizontalPageBreak.Row Property

Gets the zero based row index.

public int Row {get;}

See Also

HorizontalPageBreak Class | Aspose.Cells Namespace


StartColumn Property

Aspose.Cells for .NET

HorizontalPageBreak.StartColumn Property

Gets the start column index of this horizontal page break.

public int StartColumn {get;}

See Also

HorizontalPageBreak Class | Aspose.Cells Namespace


HorizontalPageBreakCollection Class

Encapsulates a collection of HorizontalPageBreak objects.

For a list of all members of this type, see HorizontalPageBreakCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.HorizontalPageBreakCollection

public class HorizontalPageBreakCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Add a pagebreak at G5
excel.Worksheets[0].HorizontalPageBreaks.Add("G5");
excel.Worksheets[0].VerticalPageBreaks.Add("G5");

[VB]
'Add a pagebreak at G5
excel.Worksheets(0).HorizontalPageBreaks.Add("G5")
excel.Worksheets(0).VerticalPageBreaks.Add("G5")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

HorizontalPageBreakCollection Members | Aspose.Cells Namespace


HorizontalPageBreakCollection Members

HorizontalPageBreakCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the HorizontalPageBreak element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a horizontal page break to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes the HPageBreak element at a specified name.
ToString (inherited from Object) |

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace


HorizontalPageBreakCollection Properties

The properties of the HorizontalPageBreakCollection class are listed below. For a complete list of HorizontalPageBreakCollection class members, see the HorizontalPageBreakCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the HorizontalPageBreak element at the specified index.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

HorizontalPageBreakCollection.Item Property

Gets the HorizontalPageBreak element at the specified index.

Overload List

Gets the HorizontalPageBreak element at the specified index.

public HorizontalPageBreak this[int] {get;}

Gets the HorizontalPageBreak element with the specified cell name.

public HorizontalPageBreak this[string] {get;}

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

HorizontalPageBreakCollection.Item Property (Int32)

Gets the HorizontalPageBreak element at the specified index.

public HorizontalPageBreak this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace | HorizontalPageBreakCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

HorizontalPageBreakCollection.Item Property (String)

Gets the HorizontalPageBreak element with the specified cell name.

public HorizontalPageBreak this[
string cellName
] {get;}

Parameters

cellName
Cell name.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace | HorizontalPageBreakCollection.Item Overload List


HorizontalPageBreakCollection Methods

The methods of the HorizontalPageBreakCollection class are listed below. For a complete list of HorizontalPageBreakCollection class members, see the HorizontalPageBreakCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a horizontal page break to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes the HPageBreak element at a specified name.
ToString (inherited from Object) |

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

HorizontalPageBreakCollection.Add Method

Adds a horizontal page break to the collection.

Overload List

Adds a horizontal page break to the collection.

public int Add(int);

Adds a horizontal page break to the collection.

public int Add(int,int);

Adds a horizontal page break to the collection.

public int Add(int,int,int);

Adds a horizontal page break to the collection.

public int Add(string);

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace


HorizontalPageBreakCollection.Add Method (Int32)

Adds a horizontal page break to the collection.

public int Add(
int row
);

Parameters

row
Cell row index, zero based.

Return Value

HorizontalPageBreak object index.

Remarks

Page break is added in the top left of the cell. Please set a horizontal page break and a vertical page break concurrently.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace | HorizontalPageBreakCollection.Add Overload List


HorizontalPageBreakCollection.Add Method (Int32, Int32)

Adds a horizontal page break to the collection.

public int Add(
int row,
int column
);

Parameters

row
Cell row index, zero based.
column
Cell column index, zero based.

Return Value

HorizontalPageBreak object index.

Remarks

Page break is added in the top left of the cell. Please set a horizontal page break and a vertical page break concurrently.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace | HorizontalPageBreakCollection.Add Overload List


HorizontalPageBreakCollection.Add Method (Int32, Int32, Int32)

Adds a horizontal page break to the collection.

public int Add(
int row,
int startColumn,
int endColumn
);

Parameters

row
Row index, zero based.
startColumn
Start column index, zero based.
endColumn
End column index, zero based.

Return Value

HorizontalPageBreak object index.

Remarks

This method is used to add a horizontal pagebreak within a print area.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace | HorizontalPageBreakCollection.Add Overload List


HorizontalPageBreakCollection.Add Method (String)

Adds a horizontal page break to the collection.

public int Add(
string cellName
);

Parameters

cellName
Cell name.

Return Value

HorizontalPageBreak object index.

Remarks

Page break is added in the top left of the cell. Please set a horizontal page break and a vertical page break concurrently.

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace | HorizontalPageBreakCollection.Add Overload List


HorizontalPageBreakCollection.RemoveAt Method

Removes the HPageBreak element at a specified name.

new public void RemoveAt(
int index
);

Parameters

index
Element index, zero based.

Implements

IList.RemoveAt

See Also

HorizontalPageBreakCollection Class | Aspose.Cells Namespace


HtmlCrossType Enumeration

Represents five types of html cross string.

public enum HtmlCrossType

Members

Member Name | Description | Value
Default | Display like MS Excel,depends on the next cell. If the next cell is null,the string will cross,or it will be truncated | 0
MSExport | Display the string like MS Excel exporting html. | 1
Cross | Display HTML cross string, this performance for creating large html files will be more than ten times faster than setting the value to Default or FitToCell. | 2
CrossHideRight | Display HTML cross string and hide the right string when the texts overlap. | 3
FitToCell | Only displaying the string within the width of cell. | 4

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HtmlExportDataOptions Enumeration

Represents the options for exporting html data.

public enum HtmlExportDataOptions

Members

Member Name | Description | Value
Table | Only export table part of html file. | 1
All | Export all the data of html file. | 255

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HtmlHiddenColDisplayType Enumeration

Represents two types of showing the hidden col in html.

public enum HtmlHiddenColDisplayType

Members

Member Name | Description | Value
Hidden | Hidden the column in html page. | 0
Remove | Remove the hidden in html page. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HtmlHiddenRowDisplayType Enumeration

Represents two types of showing the hidden row in html.

public enum HtmlHiddenRowDisplayType

Members

Member Name | Description | Value
Hidden | Hidden the row in html page. | 0
Remove | Remove the row in html page. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HtmlLinkTargetType Enumeration

Represents the type of target attribute in HTML tag.

public enum HtmlLinkTargetType

Members

Member Name | Description | Value
Blank | Opens the linked document in a new window or tab | 0
Parent | Opens the linked document in the parent frame | 1
Self | Opens the linked document in the same frame as it was clicked (this is default) | 2
Top | Opens the linked document in the full body of the window | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


HtmlLoadOptions Class

Represents options when importing a html file.

For a list of all members of this type, see HtmlLoadOptions Members.

System.Object
Aspose.Cells.LoadOptions
Aspose.Cells.AbstractTextLoadOptions
Aspose.Cells.HtmlLoadOptions

public class HtmlLoadOptions : AbstractTextLoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

HtmlLoadOptions Members | Aspose.Cells Namespace


HtmlLoadOptions Members

HtmlLoadOptions overview

Public Instance Constructors

HtmlLoadOptions Overloaded. Initializes a new instance of the HtmlLoadOptions class.

Public Instance Properties

AttachedFilesDirectory | Obsolete. The directory that the attached files will be saved to.
AutoFitColsAndRows | Indicates whether auto-fit columns and rows. The default value is false.
AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
ConvertDateTimeData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to date data.
ConvertFormulasData | if true, convert string to formula when string value starts with character '=',the default value is false.
ConvertNumericData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to numeric data.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
DeleteRedundantSpaces | Indicates whether delete redundant spaces when the text wraps lines using <br>tag.The default value is false.
Encoding (inherited from AbstractTextLoadOptions) | Gets and sets the default encoding. Only applies for csv file.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
KeepPrecision (inherited from AbstractTextLoadOptions) | Indicates whether not parsing a string value if the length is 15.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
LoadFormulas | Indicates whether importing formulas if the original html file contains formulas
LoadStyleStrategy (inherited from AbstractTextLoadOptions) | Indicates the strategy to apply style for parsed values when converting string value to number or datetime.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
ProgId | Gets the program id of creating the file. Only for MHT files.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
StreamProvider | Gets or sets the StreamProviderImportHtmlFile for importing objects.
SupportDivTag | Indicates whether support the layout of <div> tag when the html file contains <div> tags. The default value is false.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPaperSize (inherited from LoadOptions) | Sets the default print paper size from default printer's setting.
ToString (inherited from Object) |

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


HtmlLoadOptions Constructor

Creates an options of loading the file.

Overload List

Creates an options of loading the file.

public HtmlLoadOptions();

Creates an options of loading the file.

public HtmlLoadOptions(LoadFormat);

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


HtmlLoadOptions Constructor ()

Creates an options of loading the file.

public HtmlLoadOptions();

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace | HtmlLoadOptions Constructor Overload List


HtmlLoadOptions Constructor (LoadFormat)

Creates an options of loading the file.

public HtmlLoadOptions(
LoadFormat loadFormat
);

Parameters

loadFormat
The loading format.

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace | HtmlLoadOptions Constructor Overload List


HtmlLoadOptions Properties

The properties of the HtmlLoadOptions class are listed below. For a complete list of HtmlLoadOptions class members, see the HtmlLoadOptions Members topic.

Public Instance Properties

AttachedFilesDirectory | Obsolete. The directory that the attached files will be saved to.
AutoFitColsAndRows | Indicates whether auto-fit columns and rows. The default value is false.
AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
ConvertDateTimeData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to date data.
ConvertFormulasData | if true, convert string to formula when string value starts with character '=',the default value is false.
ConvertNumericData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to numeric data.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
DeleteRedundantSpaces | Indicates whether delete redundant spaces when the text wraps lines using <br>tag.The default value is false.
Encoding (inherited from AbstractTextLoadOptions) | Gets and sets the default encoding. Only applies for csv file.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
KeepPrecision (inherited from AbstractTextLoadOptions) | Indicates whether not parsing a string value if the length is 15.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
LoadFormulas | Indicates whether importing formulas if the original html file contains formulas
LoadStyleStrategy (inherited from AbstractTextLoadOptions) | Indicates the strategy to apply style for parsed values when converting string value to number or datetime.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
ProgId | Gets the program id of creating the file. Only for MHT files.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
StreamProvider | Gets or sets the StreamProviderImportHtmlFile for importing objects.
SupportDivTag | Indicates whether support the layout of <div> tag when the html file contains <div> tags. The default value is false.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


AttachedFilesDirectory Property

Aspose.Cells for .NET

HtmlLoadOptions.AttachedFilesDirectory Property

NOTE: This property is now obsolete.

Use HtmlLoadOptions.StreamProvider property instead.

The directory that the attached files will be saved to.

public string AttachedFilesDirectory {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use HtmlLoadOptions.StreamProvider property. This property will be removed 12 months later since December 2014. Aspose apologizes for any inconvenience you may have experienced.

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


AutoFitColsAndRows Property

Aspose.Cells for .NET

HtmlLoadOptions.AutoFitColsAndRows Property

Indicates whether auto-fit columns and rows. The default value is false.

public bool AutoFitColsAndRows {get; set;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


ConvertFormulasData Property

Aspose.Cells for .NET

HtmlLoadOptions.ConvertFormulasData Property

if true, convert string to formula when string value starts with character '=',the default value is false.

public bool ConvertFormulasData {get; set;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


DeleteRedundantSpaces Property

Aspose.Cells for .NET

HtmlLoadOptions.DeleteRedundantSpaces Property

Indicates whether delete redundant spaces when the text wraps lines using <br>tag.The default value is false.

public bool DeleteRedundantSpaces {get; set;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


LoadFormulas Property

Aspose.Cells for .NET

HtmlLoadOptions.LoadFormulas Property

Indicates whether importing formulas if the original html file contains formulas

public bool LoadFormulas {get; set;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


ProgId Property

Aspose.Cells for .NET

HtmlLoadOptions.ProgId Property

Gets the program id of creating the file. Only for MHT files.

public string ProgId {get;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


StreamProvider Property

Aspose.Cells for .NET

HtmlLoadOptions.StreamProvider Property

Gets or sets the StreamProviderImportHtmlFile for importing objects.

public IStreamProvider StreamProvider {get; set;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


SupportDivTag Property

Aspose.Cells for .NET

HtmlLoadOptions.SupportDivTag Property

Indicates whether support the layout of <div> tag when the html file contains <div> tags. The default value is false.

public bool SupportDivTag {get; set;}

See Also

HtmlLoadOptions Class | Aspose.Cells Namespace


HtmlSaveOptions Class

Represents the options for saving html file.

For a list of all members of this type, see HtmlSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.HtmlSaveOptions

public class HtmlSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

HtmlSaveOptions Members | Aspose.Cells Namespace


HtmlSaveOptions Members

HtmlSaveOptions overview

Public Instance Constructors

HtmlSaveOptions Overloaded. Initializes a new instance of the HtmlSaveOptions class.

Public Instance Properties

AddTooltipText | Indicates whether adding tooltip text when the data can't be fully displayed. The default value is false.
AttachedFilesDirectory | The directory that the attached files will be saved to. Only for saving to html stream.
AttachedFilesUrlPrefix | Specify the Url prefix of attached files such as image in the html file. Only for saving to html stream.
CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
CellCssPrefix | Gets and sets the prefix of the css name,the default value is "".
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
DefaultFontName | Specify the default font name for exporting html, the default font will be used when the font of style is not existing, If this property is null, Aspose.Cells will use universal font which have the same family with the original font, the default value is null.
DisableDownlevelRevealedComments | Indicates if disable Downlevel-revealed conditional comments when exporting file to html, the default value is false.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
Encoding | If not set,use Encoding.UTF8 as default enconding type.
ExcludeUnusedStyles | Indicating whether excluding unused styles.The default value is false.If you want to import the html or mht file to excel, please keep the default value.
ExportActiveWorksheetOnly | Indicates if exporting the whole workbook to html file.
ExportArea | Gets or Sets the exporting CellArea of current active Worksheet. If you set this attribute, the print area of current active Worksheet will be omitted. Only the specified area will be exported when saving the file to html.
ExportBogusRowData | Indicating whether exporting bogus bottom row data. The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportDataOptions | Indicating the rule of exporting html file data.The default value is All.
ExportDocumentProperties | Indicating whether exporting document properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportFrameScriptsAndProperties | Indicating whether exporting frame scripts and document properties. The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportGridLines | Indicating whether exporting the gridlines.The default value is false.
ExportHeadings | Indicates whether exporting headings when saving file to html.The default value is false. If you want to import the html file to excel, please keep the default value.
ExportHiddenWorksheet | Indicating if exporting the hidden worksheet content.The default value is true.
ExportImagesAsBase64 | Specifies whether images are saved in Base64 format to HTML, MHTML or EPUB.
ExportObjectListener | Obsolete. Gets or sets the ExportObjectListener for exporting objects.
ExportPrintAreaOnly | Indicates if only exporting the print area to html file. The default value is false.
ExportSimilarBorderStyle | Indicating whether exporting the similar border style when the border style is not supported by browsers. If you want to import the html or mht file to excel, please keep the default value. The default value is false.
ExportSingleTab | Indicates whether exporting the single tab when the file only has one worksheet. The default value is false.
ExportWorkbookProperties | Indicating whether exporting workbook properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportWorksheetCSSSeparately | Indicating whether export the worksheet css separately.The default value is false.
ExportWorksheetProperties | Indicating whether exporting worksheet properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.
FilePathProvider | Gets or sets the IFilePathProvider for exporting Worksheet to html separately.
HiddenColDisplayType | Hidden column(the width of this column is 0) in excel,before save this into html format, if HtmlHiddenColDisplayType is "Remove",the hidden column would not been output, if the value is "Hidden", the column would been output,but was hidden,the default value is "Hidden"
HiddenRowDisplayType | Hidden row(the height of this row is 0) in excel,before save this into html format, if HtmlHiddenRowDisplayType is "Remove",the hidden row would not been output, if the value is "Hidden", the row would been output,but was hidden,the default value is "Hidden"
HtmlCrossStringType | Indicates if a cross-cell string will be displayed in the same way as MS Excel when saving an Excel file in html format. By default the value is Default, so, for cross-cell strings, there is little difference between the html files created by Aspose.Cells and MS Excel. But the performance for creating large html files,setting the value to Cross would be several times faster than setting it to Default or Fit2Cell.
ImageOptions | Get the ImageOrPrintOptions object before exporting
ImageScalable | Indicates whether using scalable unit to describe the image width when using scalable unit to describe the column width. The default value is true.
IsExpImageToTempDir | Indicates whether exporting image files to temp directory. Only for saving to html stream.
IsExportComments | Indicates if exporting comments when saving file to html, the default value is false.
IsFullPathLink | Indicating whether using full path link in sheet00x.htm,filelist.xml and tabstrip.htm. The default value is false.
LinkTargetType | Indicating the type of target attribute in <a> link,The default value is HtmlLinkTargetType.Parent.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PageTitle | The title of the html page. Only for saving to html stream.
ParseHtmlTagInCell | Parse html tag in cell,like ,as cell value,or as html tag,default is true
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
PresentationPreference | Indicating if html or mht file is presentation preference.The default value is false.if you want to get more beautiful presentation,please set the value to true.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
StreamProvider | Gets or sets the IStreamProvider for exporting objects.
TableCssId | Gets and sets the prefix of the type css name such as tr,col,td and so on, they are contained in the table element which has the specific TableCssId attribute. The default value is "".
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.
WidthScalable | Indicates whether using scalable unit to describe the column width when exporting file to html. The default value is false.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


HtmlSaveOptions Constructor

Creates options for saving html file.

Overload List

Creates options for saving html file.

public HtmlSaveOptions();

Creates options for saving htm file.

public HtmlSaveOptions(SaveFormat);

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


HtmlSaveOptions Constructor ()

Creates options for saving html file.

public HtmlSaveOptions();

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace | HtmlSaveOptions Constructor Overload List


HtmlSaveOptions Constructor (SaveFormat)

Creates options for saving htm file.

public HtmlSaveOptions(
SaveFormat format
);

Parameters

format
The saving file format.

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace | HtmlSaveOptions Constructor Overload List


HtmlSaveOptions Properties

The properties of the HtmlSaveOptions class are listed below. For a complete list of HtmlSaveOptions class members, see the HtmlSaveOptions Members topic.

Public Instance Properties

AddTooltipText | Indicates whether adding tooltip text when the data can't be fully displayed. The default value is false.
AttachedFilesDirectory | The directory that the attached files will be saved to. Only for saving to html stream.
AttachedFilesUrlPrefix | Specify the Url prefix of attached files such as image in the html file. Only for saving to html stream.
CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
CellCssPrefix | Gets and sets the prefix of the css name,the default value is "".
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
DefaultFontName | Specify the default font name for exporting html, the default font will be used when the font of style is not existing, If this property is null, Aspose.Cells will use universal font which have the same family with the original font, the default value is null.
DisableDownlevelRevealedComments | Indicates if disable Downlevel-revealed conditional comments when exporting file to html, the default value is false.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
Encoding | If not set,use Encoding.UTF8 as default enconding type.
ExcludeUnusedStyles | Indicating whether excluding unused styles.The default value is false.If you want to import the html or mht file to excel, please keep the default value.
ExportActiveWorksheetOnly | Indicates if exporting the whole workbook to html file.
ExportArea | Gets or Sets the exporting CellArea of current active Worksheet. If you set this attribute, the print area of current active Worksheet will be omitted. Only the specified area will be exported when saving the file to html.
ExportBogusRowData | Indicating whether exporting bogus bottom row data. The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportDataOptions | Indicating the rule of exporting html file data.The default value is All.
ExportDocumentProperties | Indicating whether exporting document properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportFrameScriptsAndProperties | Indicating whether exporting frame scripts and document properties. The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportGridLines | Indicating whether exporting the gridlines.The default value is false.
ExportHeadings | Indicates whether exporting headings when saving file to html.The default value is false. If you want to import the html file to excel, please keep the default value.
ExportHiddenWorksheet | Indicating if exporting the hidden worksheet content.The default value is true.
ExportImagesAsBase64 | Specifies whether images are saved in Base64 format to HTML, MHTML or EPUB.
ExportObjectListener | Obsolete. Gets or sets the ExportObjectListener for exporting objects.
ExportPrintAreaOnly | Indicates if only exporting the print area to html file. The default value is false.
ExportSimilarBorderStyle | Indicating whether exporting the similar border style when the border style is not supported by browsers. If you want to import the html or mht file to excel, please keep the default value. The default value is false.
ExportSingleTab | Indicates whether exporting the single tab when the file only has one worksheet. The default value is false.
ExportWorkbookProperties | Indicating whether exporting workbook properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.
ExportWorksheetCSSSeparately | Indicating whether export the worksheet css separately.The default value is false.
ExportWorksheetProperties | Indicating whether exporting worksheet properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.
FilePathProvider | Gets or sets the IFilePathProvider for exporting Worksheet to html separately.
HiddenColDisplayType | Hidden column(the width of this column is 0) in excel,before save this into html format, if HtmlHiddenColDisplayType is "Remove",the hidden column would not been output, if the value is "Hidden", the column would been output,but was hidden,the default value is "Hidden"
HiddenRowDisplayType | Hidden row(the height of this row is 0) in excel,before save this into html format, if HtmlHiddenRowDisplayType is "Remove",the hidden row would not been output, if the value is "Hidden", the row would been output,but was hidden,the default value is "Hidden"
HtmlCrossStringType | Indicates if a cross-cell string will be displayed in the same way as MS Excel when saving an Excel file in html format. By default the value is Default, so, for cross-cell strings, there is little difference between the html files created by Aspose.Cells and MS Excel. But the performance for creating large html files,setting the value to Cross would be several times faster than setting it to Default or Fit2Cell.
ImageOptions | Get the ImageOrPrintOptions object before exporting
ImageScalable | Indicates whether using scalable unit to describe the image width when using scalable unit to describe the column width. The default value is true.
IsExpImageToTempDir | Indicates whether exporting image files to temp directory. Only for saving to html stream.
IsExportComments | Indicates if exporting comments when saving file to html, the default value is false.
IsFullPathLink | Indicating whether using full path link in sheet00x.htm,filelist.xml and tabstrip.htm. The default value is false.
LinkTargetType | Indicating the type of target attribute in <a> link,The default value is HtmlLinkTargetType.Parent.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PageTitle | The title of the html page. Only for saving to html stream.
ParseHtmlTagInCell | Parse html tag in cell,like ,as cell value,or as html tag,default is true
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
PresentationPreference | Indicating if html or mht file is presentation preference.The default value is false.if you want to get more beautiful presentation,please set the value to true.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
StreamProvider | Gets or sets the IStreamProvider for exporting objects.
TableCssId | Gets and sets the prefix of the type css name such as tr,col,td and so on, they are contained in the table element which has the specific TableCssId attribute. The default value is "".
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.
WidthScalable | Indicates whether using scalable unit to describe the column width when exporting file to html. The default value is false.

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


AddTooltipText Property

Aspose.Cells for .NET

HtmlSaveOptions.AddTooltipText Property

Indicates whether adding tooltip text when the data can't be fully displayed. The default value is false.

public bool AddTooltipText {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


AttachedFilesDirectory Property

Aspose.Cells for .NET

HtmlSaveOptions.AttachedFilesDirectory Property

The directory that the attached files will be saved to. Only for saving to html stream.

public string AttachedFilesDirectory {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


AttachedFilesUrlPrefix Property

Aspose.Cells for .NET

HtmlSaveOptions.AttachedFilesUrlPrefix Property

Specify the Url prefix of attached files such as image in the html file. Only for saving to html stream.

public string AttachedFilesUrlPrefix {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


CellCssPrefix Property

Aspose.Cells for .NET

HtmlSaveOptions.CellCssPrefix Property

Gets and sets the prefix of the css name,the default value is "".

public string CellCssPrefix {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


DefaultFontName Property

Aspose.Cells for .NET

HtmlSaveOptions.DefaultFontName Property

Specify the default font name for exporting html, the default font will be used when the font of style is not existing, If this property is null, Aspose.Cells will use universal font which have the same family with the original font, the default value is null.

public string DefaultFontName {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


DisableDownlevelRevealedComments Property

Aspose.Cells for .NET

HtmlSaveOptions.DisableDownlevelRevealedComments Property

Indicates if disable Downlevel-revealed conditional comments when exporting file to html, the default value is false.

public bool DisableDownlevelRevealedComments {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


Encoding Property

Aspose.Cells for .NET

HtmlSaveOptions.Encoding Property

If not set,use Encoding.UTF8 as default enconding type.

public Encoding Encoding {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExcludeUnusedStyles Property

Aspose.Cells for .NET

HtmlSaveOptions.ExcludeUnusedStyles Property

Indicating whether excluding unused styles.The default value is false.If you want to import the html or mht file to excel, please keep the default value.

public bool ExcludeUnusedStyles {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportActiveWorksheetOnly Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportActiveWorksheetOnly Property

Indicates if exporting the whole workbook to html file.

public bool ExportActiveWorksheetOnly {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportArea Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportArea Property

Gets or Sets the exporting CellArea of current active Worksheet. If you set this attribute, the print area of current active Worksheet will be omitted. Only the specified area will be exported when saving the file to html.

public CellArea ExportArea {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportBogusRowData Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportBogusRowData Property

Indicating whether exporting bogus bottom row data. The default value is true.If you want to import the html or mht file to excel, please keep the default value.

public bool ExportBogusRowData {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportDataOptions Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportDataOptions Property

Indicating the rule of exporting html file data.The default value is All.

public HtmlExportDataOptions ExportDataOptions {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportDocumentProperties Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportDocumentProperties Property

Indicating whether exporting document properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.

public bool ExportDocumentProperties {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportFrameScriptsAndProperties Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportFrameScriptsAndProperties Property

Indicating whether exporting frame scripts and document properties. The default value is true.If you want to import the html or mht file to excel, please keep the default value.

public bool ExportFrameScriptsAndProperties {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportGridLines Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportGridLines Property

Indicating whether exporting the gridlines.The default value is false.

public bool ExportGridLines {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportHeadings Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportHeadings Property

Indicates whether exporting headings when saving file to html.The default value is false. If you want to import the html file to excel, please keep the default value.

public bool ExportHeadings {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportHiddenWorksheet Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportHiddenWorksheet Property

Indicating if exporting the hidden worksheet content.The default value is true.

public bool ExportHiddenWorksheet {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportImagesAsBase64 Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportImagesAsBase64 Property

Specifies whether images are saved in Base64 format to HTML, MHTML or EPUB.

public bool ExportImagesAsBase64 {get; set;}

Remarks

When this property is set to true image data is exported directly on the img elements and separate files are not created.

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportObjectListener Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportObjectListener Property

NOTE: This property is now obsolete.

Use HtmlSaveOptions.IStreamProvider property instead.

Gets or sets the ExportObjectListener for exporting objects.

public IExportObjectListener ExportObjectListener {get; set;}

Remarks

NOTE: This property is now obsolete. Instead, please use HtmlSaveOptions.IStreamProvider property. This property will be removed 12 months later since August 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportPrintAreaOnly Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportPrintAreaOnly Property

Indicates if only exporting the print area to html file. The default value is false.

public bool ExportPrintAreaOnly {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportSimilarBorderStyle Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportSimilarBorderStyle Property

Indicating whether exporting the similar border style when the border style is not supported by browsers. If you want to import the html or mht file to excel, please keep the default value. The default value is false.

public bool ExportSimilarBorderStyle {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportSingleTab Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportSingleTab Property

Indicates whether exporting the single tab when the file only has one worksheet. The default value is false.

public bool ExportSingleTab {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportWorkbookProperties Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportWorkbookProperties Property

Indicating whether exporting workbook properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.

public bool ExportWorkbookProperties {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportWorksheetCSSSeparately Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportWorksheetCSSSeparately Property

Indicating whether export the worksheet css separately.The default value is false.

public bool ExportWorksheetCSSSeparately {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ExportWorksheetProperties Property

Aspose.Cells for .NET

HtmlSaveOptions.ExportWorksheetProperties Property

Indicating whether exporting worksheet properties.The default value is true.If you want to import the html or mht file to excel, please keep the default value.

public bool ExportWorksheetProperties {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


FilePathProvider Property

Aspose.Cells for .NET

HtmlSaveOptions.FilePathProvider Property

Gets or sets the IFilePathProvider for exporting Worksheet to html separately.

public IFilePathProvider FilePathProvider {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


HiddenColDisplayType Property

Aspose.Cells for .NET

HtmlSaveOptions.HiddenColDisplayType Property

Hidden column(the width of this column is 0) in excel,before save this into html format, if HtmlHiddenColDisplayType is "Remove",the hidden column would not been output, if the value is "Hidden", the column would been output,but was hidden,the default value is "Hidden"

public HtmlHiddenColDisplayType HiddenColDisplayType {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


HiddenRowDisplayType Property

Aspose.Cells for .NET

HtmlSaveOptions.HiddenRowDisplayType Property

Hidden row(the height of this row is 0) in excel,before save this into html format, if HtmlHiddenRowDisplayType is "Remove",the hidden row would not been output, if the value is "Hidden", the row would been output,but was hidden,the default value is "Hidden"

public HtmlHiddenRowDisplayType HiddenRowDisplayType {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


HtmlCrossStringType Property

Aspose.Cells for .NET

HtmlSaveOptions.HtmlCrossStringType Property

Indicates if a cross-cell string will be displayed in the same way as MS Excel when saving an Excel file in html format. By default the value is Default, so, for cross-cell strings, there is little difference between the html files created by Aspose.Cells and MS Excel. But the performance for creating large html files,setting the value to Cross would be several times faster than setting it to Default or Fit2Cell.

public HtmlCrossType HtmlCrossStringType {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ImageOptions Property

Aspose.Cells for .NET

HtmlSaveOptions.ImageOptions Property

Get the ImageOrPrintOptions object before exporting

public ImageOrPrintOptions ImageOptions {get;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ImageScalable Property

Aspose.Cells for .NET

HtmlSaveOptions.ImageScalable Property

Indicates whether using scalable unit to describe the image width when using scalable unit to describe the column width. The default value is true.

public bool ImageScalable {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


IsExpImageToTempDir Property

Aspose.Cells for .NET

HtmlSaveOptions.IsExpImageToTempDir Property

Indicates whether exporting image files to temp directory. Only for saving to html stream.

public bool IsExpImageToTempDir {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


IsExportComments Property

Aspose.Cells for .NET

HtmlSaveOptions.IsExportComments Property

Indicates if exporting comments when saving file to html, the default value is false.

public bool IsExportComments {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


IsFullPathLink Property

Aspose.Cells for .NET

HtmlSaveOptions.IsFullPathLink Property

Indicating whether using full path link in sheet00x.htm,filelist.xml and tabstrip.htm. The default value is false.

public bool IsFullPathLink {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


LinkTargetType Property

Aspose.Cells for .NET

HtmlSaveOptions.LinkTargetType Property

Indicating the type of target attribute in <a> link,The default value is HtmlLinkTargetType.Parent.

public HtmlLinkTargetType LinkTargetType {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


PageTitle Property

Aspose.Cells for .NET

HtmlSaveOptions.PageTitle Property

The title of the html page. Only for saving to html stream.

public string PageTitle {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


ParseHtmlTagInCell Property

Aspose.Cells for .NET

HtmlSaveOptions.ParseHtmlTagInCell Property

Parse html tag in cell,like

,as cell value,or as html tag,default is true

public bool ParseHtmlTagInCell {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


PresentationPreference Property

Aspose.Cells for .NET

HtmlSaveOptions.PresentationPreference Property

Indicating if html or mht file is presentation preference.The default value is false.if you want to get more beautiful presentation,please set the value to true.

public bool PresentationPreference {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


StreamProvider Property

Aspose.Cells for .NET

HtmlSaveOptions.StreamProvider Property

Gets or sets the IStreamProvider for exporting objects.

public IStreamProvider StreamProvider {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


TableCssId Property

Aspose.Cells for .NET

HtmlSaveOptions.TableCssId Property

Gets and sets the prefix of the type css name such as tr,col,td and so on, they are contained in the table element which has the specific TableCssId attribute. The default value is "".

public string TableCssId {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


WidthScalable Property

Aspose.Cells for .NET

HtmlSaveOptions.WidthScalable Property

Indicates whether using scalable unit to describe the column width when exporting file to html. The default value is false.

public bool WidthScalable {get; set;}

See Also

HtmlSaveOptions Class | Aspose.Cells Namespace


Hyperlink Class

Encapsulates the object that represents a hyperlink.

For a list of all members of this type, see Hyperlink Members.

System.Object
Aspose.Cells.Hyperlink

public class Hyperlink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Workbook object
workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[0];
//Adding a hyperlink to a URL at "A1" cell
worksheet.Hyperlinks.Add("A1", 1, 1, "http://www.aspose.com");
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Workbook object
workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(0)
'Adding a hyperlink to a URL at "A1" cell
worksheet.Hyperlinks.Add("A1", 1, 1, "http://www.aspose.com")
'Saving the Excel file
workbook.Save("C:\book1.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Hyperlink Members | Aspose.Cells Namespace


Hyperlink Members

Hyperlink overview

Public Instance Properties

Address | Represents the address of a hyperlink.
Area | Gets the range of hyperlink.
LinkType | Gets the link type.
ScreenTip | Returns or sets the ScreenTip text for the specified hyperlink.
TextToDisplay | Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

Public Instance Methods

Delete | Deletes this hyperlink
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Hyperlink Class | Aspose.Cells Namespace


Hyperlink Properties

The properties of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Instance Properties

Address | Represents the address of a hyperlink.
Area | Gets the range of hyperlink.
LinkType | Gets the link type.
ScreenTip | Returns or sets the ScreenTip text for the specified hyperlink.
TextToDisplay | Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

See Also

Hyperlink Class | Aspose.Cells Namespace


Address Property

Aspose.Cells for .NET

Hyperlink.Address Property

Represents the address of a hyperlink.

public string Address {get; set;}

See Also

Hyperlink Class | Aspose.Cells Namespace


Area Property

Aspose.Cells for .NET

Hyperlink.Area Property

Gets the range of hyperlink.

public CellArea Area {get;}

See Also

Hyperlink Class | Aspose.Cells Namespace


LinkType Property

Aspose.Cells for .NET

Hyperlink.LinkType Property

Gets the link type.

public TargetModeType LinkType {get;}

See Also

Hyperlink Class | Aspose.Cells Namespace


ScreenTip Property

Aspose.Cells for .NET

Hyperlink.ScreenTip Property

Returns or sets the ScreenTip text for the specified hyperlink.

public string ScreenTip {get; set;}

See Also

Hyperlink Class | Aspose.Cells Namespace


TextToDisplay Property

Aspose.Cells for .NET

Hyperlink.TextToDisplay Property

Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

public string TextToDisplay {get; set;}

See Also

Hyperlink Class | Aspose.Cells Namespace


Hyperlink Methods

The methods of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Instance Methods

Delete | Deletes this hyperlink
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Hyperlink Class | Aspose.Cells Namespace


Hyperlink.Delete Method

Deletes this hyperlink

public void Delete();

See Also

Hyperlink Class | Aspose.Cells Namespace


HyperlinkCollection Class

Encapsulates a collection of Hyperlink objects.

For a list of all members of this type, see HyperlinkCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.HyperlinkCollection

public class HyperlinkCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[0];

//Get Hyperlinks Collection
HyperlinkCollection hyperlinks = worksheet.Hyperlinks;

//Adding a hyperlink to a URL at "A1" cell
hyperlinks.Add("A1", 1, 1, "http://www.aspose.com");

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Get Hyperlinks Collection
Dim hyperlinks As HyperlinkCollection = worksheet.Hyperlinks

'Adding a hyperlink to a URL at "A1" cell
hyperlinks.Add("A1", 1, 1, "http://www.aspose.com")

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

HyperlinkCollection Members | Aspose.Cells Namespace


HyperlinkCollection Members

HyperlinkCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Hyperlink element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a hyperlink to a specified cell or a range of cells.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the hyperlink at the specified index.
ToString (inherited from Object) |

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


HyperlinkCollection Properties

The properties of the HyperlinkCollection class are listed below. For a complete list of HyperlinkCollection class members, see the HyperlinkCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Hyperlink element at the specified index.

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

HyperlinkCollection.Item Property

Gets the Hyperlink element at the specified index.

public Hyperlink this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


HyperlinkCollection Methods

The methods of the HyperlinkCollection class are listed below. For a complete list of HyperlinkCollection class members, see the HyperlinkCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a hyperlink to a specified cell or a range of cells.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the hyperlink at the specified index.
ToString (inherited from Object) |

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

HyperlinkCollection.Add Method

Adds a hyperlink to a specified cell or a range of cells.

Overload List

Adds a hyperlink to a specified cell or a range of cells.

public int Add(int,int,int,int,string);

Adds a hyperlink to a specified cell or a range of cells.

public int Add(string,int,int,string);

Adds a hyperlink to a specified cell or a range of cells.

public int Add(string,string,string,string,string);

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


HyperlinkCollection.Add Method (Int32, Int32, Int32, Int32, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
string address
);

Parameters

firstRow
First row of the hyperlink range.
firstColumn
First column of the hyperlink range.
totalRows
Number of rows in this hyperlink range.
totalColumns
Number of columns of this hyperlink range.
address
Address of the hyperlink.

Return Value

Hyperlink object index.

Example

[C#]

Worksheet worksheet = excel.Worksheets[0];
worksheet.Hyperlinks.Add("A4", 1, 1, "http://www.aspose.com");
worksheet.Hyperlinks.Add("A5", 1, 1, "c:\\book1.xls");

[Visual Basic]

Dim worksheet as Worksheet = excel.Worksheets(0)
worksheet.Hyperlinks.Add("A4", 1, 1, "http://www.aspose.com")
worksheet.Hyperlinks.Add("A5", 1, 1, "c:\\book1.xls")

See Also

HyperlinkCollection Class | Aspose.Cells Namespace | HyperlinkCollection.Add Overload List


HyperlinkCollection.Add Method (String, Int32, Int32, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
string cellName,
int totalRows,
int totalColumns,
string address
);

Parameters

cellName
Cell name.
totalRows
Number of rows in this hyperlink range.
totalColumns
Number of columns of this hyperlink range.
address
Address of the hyperlink.

Return Value

Hyperlink object index.

See Also

HyperlinkCollection Class | Aspose.Cells Namespace | HyperlinkCollection.Add Overload List


HyperlinkCollection.Add Method (String, String, String, String, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
string startCellName,
string endCellName,
string address,
string textToDisplay,
string screenTip
);

Parameters

startCellName
The top-left cell of the range.
endCellName
The bottom-right cell of the range.
address
Address of the hyperlink.
textToDisplay
The text to be displayed for the specified hyperlink.
screenTip
The screenTip text for the specified hyperlink.

Return Value

Hyperlink object index.

See Also

HyperlinkCollection Class | Aspose.Cells Namespace | HyperlinkCollection.Add Overload List


HyperlinkCollection.Clear Method

Clears all hyperlinks.

new public void Clear();

Implements

IList.Clear

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


HyperlinkCollection.RemoveAt Method

Remove the hyperlink at the specified index.

new public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

Implements

IList.RemoveAt

See Also

HyperlinkCollection Class | Aspose.Cells Namespace


ICellsDataTable Interface

Represents data table.

For a list of all members of this type, see ICellsDataTable Members.

public interface ICellsDataTable

Remarks

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ICellsDataTable Members | Aspose.Cells Namespace


ICellsDataTable Members

ICellsDataTable overview

Public Instance Properties

Columns | Gets the columns' name.
Count | Gets the count of the records. -1 for unknown records count.
Item | Overloaded. Gets the data stored in the column specified by index.

Public Instance Methods

BeforeFirst | Move the cursor to the front of this object, just before the first row.
Next | Moves the cursor down one row from its current position.

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


ICellsDataTable Properties

The properties of the ICellsDataTable interface are listed below. For a complete list of ICellsDataTable interface members, see the ICellsDataTable Members topic.

Public Instance Properties

Columns | Gets the columns' name.
Count | Gets the count of the records. -1 for unknown records count.
Item | Overloaded. Gets the data stored in the column specified by index.

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


Columns Property

Aspose.Cells for .NET

ICellsDataTable.Columns Property

Gets the columns' name.

string[] Columns {get;}

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


Count Property

Aspose.Cells for .NET

ICellsDataTable.Count Property

Gets the count of the records. -1 for unknown records count.

int Count {get;}

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ICellsDataTable.Item Property

Gets the data stored in the column specified by index.

Overload List

Gets the data stored in the column specified by index.

object this[int] {get;}

Gets the data stored in the column specified by column name.

object this[string] {get;}

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

ICellsDataTable.Item Property (Int32)

Gets the data stored in the column specified by index.

object this[
int columnIndex
] {get;}

Parameters

columnIndex
The zero-based index of the column.

See Also

ICellsDataTable Interface | Aspose.Cells Namespace | ICellsDataTable.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ICellsDataTable.Item Property (String)

Gets the data stored in the column specified by column name.

object this[
string columnName
] {get;}

Parameters

columnName
The column name.

See Also

ICellsDataTable Interface | Aspose.Cells Namespace | ICellsDataTable.Item Overload List


ICellsDataTable Methods

The methods of the ICellsDataTable interface are listed below. For a complete list of ICellsDataTable interface members, see the ICellsDataTable Members topic.

Public Instance Methods

BeforeFirst | Move the cursor to the front of this object, just before the first row.
Next | Moves the cursor down one row from its current position.

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


ICellsDataTable.BeforeFirst Method

Move the cursor to the front of this object, just before the first row.

void BeforeFirst();

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


ICellsDataTable.Next Method

Moves the cursor down one row from its current position.

bool Next();

Return Value

if the new current row is valid; false if there are no more rows

See Also

ICellsDataTable Interface | Aspose.Cells Namespace


IconFilter Class

Represents icon filter.

For a list of all members of this type, see IconFilter Members.

System.Object
Aspose.Cells.IconFilter

public class IconFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IconFilter Members | Aspose.Cells Namespace


IconFilter Members

IconFilter overview

Public Instance Properties

IconId | Gets and sets Zero-based index of an icon in an icon set.
IconSetType | Gets and sets which icon set is used in the filter criteria.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

IconFilter Class | Aspose.Cells Namespace


IconFilter Properties

The properties of the IconFilter class are listed below. For a complete list of IconFilter class members, see the IconFilter Members topic.

Public Instance Properties

IconId | Gets and sets Zero-based index of an icon in an icon set.
IconSetType | Gets and sets which icon set is used in the filter criteria.

See Also

IconFilter Class | Aspose.Cells Namespace


IconId Property

Aspose.Cells for .NET

IconFilter.IconId Property

Gets and sets Zero-based index of an icon in an icon set.

public int IconId {get; set;}

See Also

IconFilter Class | Aspose.Cells Namespace


IconSetType Property

Aspose.Cells for .NET

IconFilter.IconSetType Property

Gets and sets which icon set is used in the filter criteria.

public IconSetType IconSetType {get; set;}

See Also

IconFilter Class | Aspose.Cells Namespace


IconSet Class

Describe the IconSet conditional formatting rule. This conditional formatting rule applies icons to cells according to their values.

For a list of all members of this type, see IconSet Members.

System.Object
Aspose.Cells.IconSet

public class IconSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

Worksheet sheet = workbook.Worksheets[0];

//Adds an empty conditional formatting
int index = sheet.ConditionalFormattings.Add();

FormatConditions fcs = sheet.ConditionalFormattings[index];

//Sets the conditional format range.
CellArea ca = new CellArea();

ca.StartRow = 0;

ca.EndRow = 2;

ca.StartColumn = 0;

ca.EndColumn = 0;

fcs.AddArea(ca);

//Adds condition.
int idx = fcs.AddCondtion(FormatConditionType.IconSet);

fcs.AddArea(ca);

FormatCondition cond = fcs[idx];

//Get Icon Set
IconSet iconSet = cond.IconSet;

//Set Icon Type
iconSet.Type = IconSetType.Arrows3;

//Put Cell Values
Aspose.Cells.Cell cell1 = sheet.Cells["A1"];

cell1.PutValue(10);

Aspose.Cells.Cell cell2 = sheet.Cells["A2"];

cell2.PutValue(120);

Aspose.Cells.Cell cell3 = sheet.Cells["A3"];

cell3.PutValue(260);

//Saving the Excel file
workbook.Save("D:\\book1.xlsx");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

Dim sheet As Worksheet = workbook.Worksheets(0)

'Adds an empty conditional formatting
Dim index As Integer = sheet.ConditionalFormattings.Add()

Dim fcs As FormatConditions = sheet.ConditionalFormattings(index)

'Sets the conditional format range.
Dim ca As New CellArea()

ca.StartRow = 0

ca.EndRow = 2

ca.StartColumn = 0

ca.EndColumn = 0

fcs.AddArea(ca)

'Adds condition.
Dim idx As Integer = fcs.AddCondtion(FormatConditionType.IconSet)

fcs.AddArea(ca)

Dim cond As FormatCondition = fcs(idx)

'Get Icon Set
Dim iconSet As IconSet = cond.IconSet

'Set Icon Type
iconSet.Type = IconSetType.Arrows3

'Put Cell Values
Dim cell1 As Aspose.Cells.Cell = sheet.Cells("A1")

cell1.PutValue(10)

Dim cell2 As Aspose.Cells.Cell = sheet.Cells("A2")

cell2.PutValue(120)

Dim cell3 As Aspose.Cells.Cell = sheet.Cells("A3")

cell3.PutValue(260)

'Saving the Excel file
workbook.Save("D:\book1.xlsx")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IconSet Members | Aspose.Cells Namespace


IconSet Members

IconSet overview

Public Instance Properties

CfIcons | Get theConditionalFormattingIcon from the collection
Cfvos | Get the CFValueObjects instance.
IsCustom | Indicates whether the icon set is custom. Default value is false.
Reverse | Get or set the flag indicating whether to reverses the default order of the icons in this icon set. Default value is false.
ShowValue | Get or set the flag indicating whether to show the values of the cells on which this icon set is applied. Default value is true.
Type | Get or Set the icon set type to display. Setting the type will auto check if the current Cfvos's count is accord with the new type. If not accord, old Cfvos will be cleaned and default Cfvos will be added.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

IconSet Class | Aspose.Cells Namespace


IconSet Properties

The properties of the IconSet class are listed below. For a complete list of IconSet class members, see the IconSet Members topic.

Public Instance Properties

CfIcons | Get theConditionalFormattingIcon from the collection
Cfvos | Get the CFValueObjects instance.
IsCustom | Indicates whether the icon set is custom. Default value is false.
Reverse | Get or set the flag indicating whether to reverses the default order of the icons in this icon set. Default value is false.
ShowValue | Get or set the flag indicating whether to show the values of the cells on which this icon set is applied. Default value is true.
Type | Get or Set the icon set type to display. Setting the type will auto check if the current Cfvos's count is accord with the new type. If not accord, old Cfvos will be cleaned and default Cfvos will be added.

See Also

IconSet Class | Aspose.Cells Namespace


CfIcons Property

Aspose.Cells for .NET

IconSet.CfIcons Property

Get theConditionalFormattingIcon from the collection

public ConditionalFormattingIconCollection CfIcons {get;}

See Also

IconSet Class | Aspose.Cells Namespace


Cfvos Property

Aspose.Cells for .NET

IconSet.Cfvos Property

Get the CFValueObjects instance.

public ConditionalFormattingValueCollection Cfvos {get;}

See Also

IconSet Class | Aspose.Cells Namespace


IsCustom Property

Aspose.Cells for .NET

IconSet.IsCustom Property

Indicates whether the icon set is custom. Default value is false.

public bool IsCustom {get;}

See Also

IconSet Class | Aspose.Cells Namespace


Reverse Property

Aspose.Cells for .NET

IconSet.Reverse Property

Get or set the flag indicating whether to reverses the default order of the icons in this icon set. Default value is false.

public bool Reverse {get; set;}

See Also

IconSet Class | Aspose.Cells Namespace


ShowValue Property

Aspose.Cells for .NET

IconSet.ShowValue Property

Get or set the flag indicating whether to show the values of the cells on which this icon set is applied. Default value is true.

public bool ShowValue {get; set;}

See Also

IconSet Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

IconSet.Type Property

Get or Set the icon set type to display. Setting the type will auto check if the current Cfvos's count is accord with the new type. If not accord, old Cfvos will be cleaned and default Cfvos will be added.

public IconSetType Type {get; set;}

See Also

IconSet Class | Aspose.Cells Namespace


IconSetType Enumeration

Icon set type for conditional formatting. The threshold values for triggering the different icons within a set are configurable, and the icon order is reversible.

public enum IconSetType

Members

Member Name | Description | Value
Arrows3 | 3 arrows icon set. | 0
ArrowsGray3 | 3 gray arrows icon set. | 1
Flags3 | 3 flags icon set. | 2
Signs3 | 3 signs icon set. | 3
Symbols3 | 3 symbols icon set (circled). | 4
Symbols32 | 3 Symbols icon set (uncircled). | 5
TrafficLights31 | 3 traffic lights icon set (unrimmed). | 6
TrafficLights32 | 3 traffic lights icon set with thick black border. | 7
Arrows4 | 4 arrows icon set. | 8
ArrowsGray4 | 4 gray arrows icon set. | 9
Rating4 | 4 ratings icon set. | 10
RedToBlack4 | 4 'red to black' icon set. | 11
TrafficLights4 | 4 traffic lights icon set. | 12
Arrows5 | 5 arrows icon set. | 13
ArrowsGray5 | 5 gray arrows icon set. | 14
Quarters5 | 5 quarters icon set. | 15
Rating5 | 5 rating icon set. | 16
Stars3 | 3 stars set | 17
Boxes5 | 5 boxes set | 18
Triangles3 | 3 triangles set | 19
None | None | 20
CustomSet | CustomSet. This element is read-only. | 21
Smilies3 | 3 smilies. Only for .ods. | 22
ColorSmilies3 | 3 color smilies. Only for .ods. | 23

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ICustomFunction Interface

NOTE: This interface is now obsolete.

Use AbstractCalculationEngine instead.

For a list of all members of this type, see ICustomFunction Members.

public interface ICustomFunction

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ICustomFunction Members | Aspose.Cells Namespace


ICustomFunction Members

ICustomFunction overview

Public Instance Methods

CalculateCustomFunction

See Also

ICustomFunction Interface | Aspose.Cells Namespace


ICustomFunction Methods

The methods of the ICustomFunction interface are listed below. For a complete list of ICustomFunction interface members, see the ICustomFunction Members topic.

Public Instance Methods

CalculateCustomFunction

See Also

ICustomFunction Interface | Aspose.Cells Namespace


ICustomFunction.CalculateCustomFunction Method

object CalculateCustomFunction(
string functionName,
ArrayList paramsList,
ArrayList contextObjects
);

See Also

ICustomFunction Interface | Aspose.Cells Namespace


ICustomParser Interface

Allows users to add their custom value parser for parsing string values to other proper cell value object.

For a list of all members of this type, see ICustomParser Members.

public interface ICustomParser

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ICustomParser Members | Aspose.Cells Namespace


ICustomParser Members

ICustomParser overview

Public Instance Methods

GetFormat | Gets the formatting pattern corresponding to the parsed value by last invocation of ParseObject.
ParseObject | Parses given string to proper value object.

See Also

ICustomParser Interface | Aspose.Cells Namespace


ICustomParser Methods

The methods of the ICustomParser interface are listed below. For a complete list of ICustomParser interface members, see the ICustomParser Members topic.

Public Instance Methods

GetFormat | Gets the formatting pattern corresponding to the parsed value by last invocation of ParseObject.
ParseObject | Parses given string to proper value object.

See Also

ICustomParser Interface | Aspose.Cells Namespace


ICustomParser.GetFormat Method

Gets the formatting pattern corresponding to the parsed value by last invocation of ParseObject.

string GetFormat();

Remarks

The returned formatting pattern may be used to format corresponding cell(set to Style.Custom for the cell).

See Also

ICustomParser Interface | Aspose.Cells Namespace


ICustomParser.ParseObject Method

Parses given string to proper value object.

object ParseObject(
string value
);

Parameters

value
The string value to be parsed

Return Value

Parsed value object from given string. If given string cannot be parsed to proper value object, returns null.

See Also

ICustomParser Interface | Aspose.Cells Namespace


IExportObjectListener Interface

Allows users to manipulate objects while exporting.

For a list of all members of this type, see IExportObjectListener Members.

public interface IExportObjectListener

Example

The following example creates a Workbook, opens a file named designer.xls in it and makes the horizontal and vertical scroll bars invisible for the Workbook. It then replaces two string values with an Integer value and string value respectively within the spreadsheet and finally sends the updated file to the client browser.

[C#]
     //custom implementation of IExportObjectListener
     class CustomExportObjectListener : IExportObjectListener
     {
         private int imgIdx = 0;
         public object ExportObject(ExportObjectEvent e)
         {
             Object source = e.GetSource();
             if (source is Shape)
             {
                 Shape shape = (Shape)source;
                 string url = null;
                 switch (shape.MsoDrawingType)
                 {
                     case MsoDrawingType.Picture:
                     {
                         url = SaveImage(((Picture)shape).Data, imgIdx, ((Picture)shape).ImageFormat);
                         break;
                      }
                 }
                 if (url != null)
                 {
                     imgIdx++;
                 }
                 return url;
             }
             return null;
         }
         private string SaveImage(byte[] data, int imgIdx, ImageFormat format)
         {
             //here save the image to any location, then return the url(relative or absolute) that the generated html can get the image
             return "temp1/temp2.png";
         }
      }

      //Save html file with custom listener
         HtmlSaveOptions saveOptions = new HtmlSaveOptions();
         saveOptions.ExportObjectListener = new CustomExportObjectListener();
         Stream stream = File.Create(outfn);
         book.Save(stream, saveOptions);
         stream.Flush();
         stream.Close();

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IExportObjectListener Members | Aspose.Cells Namespace


IExportObjectListener Members

IExportObjectListener overview

Public Instance Methods

ExportObject Export one object.

See Also

IExportObjectListener Interface | Aspose.Cells Namespace


IExportObjectListener Methods

The methods of the IExportObjectListener interface are listed below. For a complete list of IExportObjectListener interface members, see the IExportObjectListener Members topic.

Public Instance Methods

ExportObject Export one object.

See Also

IExportObjectListener Interface | Aspose.Cells Namespace


IExportObjectListener.ExportObject Method

Export one object.

object ExportObject(
ExportObjectEvent e
);

Parameters

e
The event triggered when one object needs to be exported.

Return Value

The information about the result of exporting object.

  • For exporting objects when export workbook to HTML format, the result is URL string to access the saved Image from the html file which contains this exported object.

See Also

IExportObjectListener Interface | Aspose.Cells Namespace


IFilePathProvider Interface

Represents the exported file path provider.

For a list of all members of this type, see IFilePathProvider Members.

public interface IFilePathProvider

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IFilePathProvider Members | Aspose.Cells Namespace


IFilePathProvider Members

IFilePathProvider overview

Public Instance Methods

GetFullName Gets the full path of the file by Worksheet name when exporting Worksheet to html separately. So the references among the Worksheets can be exported correctly.

See Also

IFilePathProvider Interface | Aspose.Cells Namespace


IFilePathProvider Methods

The methods of the IFilePathProvider interface are listed below. For a complete list of IFilePathProvider interface members, see the IFilePathProvider Members topic.

Public Instance Methods

GetFullName Gets the full path of the file by Worksheet name when exporting Worksheet to html separately. So the references among the Worksheets can be exported correctly.

See Also

IFilePathProvider Interface | Aspose.Cells Namespace


IFilePathProvider.GetFullName Method

Gets the full path of the file by Worksheet name when exporting Worksheet to html separately. So the references among the Worksheets can be exported correctly.

string GetFullName(
string sheetName
);

Parameters

sheetName
Worksheet name

Return Value

the full path of the file

See Also

IFilePathProvider Interface | Aspose.Cells Namespace


ImageSaveOptions Class

Represents image save options

For a list of all members of this type, see ImageSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.ImageSaveOptions
Aspose.Cells.SvgSaveOptions

public class ImageSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ImageSaveOptions Members | Aspose.Cells Namespace


ImageSaveOptions Members

ImageSaveOptions overview

Public Instance Constructors

ImageSaveOptions Overloaded. Initializes a new instance of the ImageSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ImageOrPrintOptions | Additional image creation options
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ImageSaveOptions Class | Aspose.Cells Namespace


ImageSaveOptions Constructor

Creates the options for saving image file.

Overload List

Creates the options for saving image file.

public ImageSaveOptions();

Creates the options for saving image file.

public ImageSaveOptions(SaveFormat);

See Also

ImageSaveOptions Class | Aspose.Cells Namespace


ImageSaveOptions Constructor ()

Creates the options for saving image file.

public ImageSaveOptions();

See Also

ImageSaveOptions Class | Aspose.Cells Namespace | ImageSaveOptions Constructor Overload List


ImageSaveOptions Constructor (SaveFormat)

Creates the options for saving image file.

public ImageSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The file format. It must be tiff or svg.

See Also

ImageSaveOptions Class | Aspose.Cells Namespace | ImageSaveOptions Constructor Overload List


ImageSaveOptions Properties

The properties of the ImageSaveOptions class are listed below. For a complete list of ImageSaveOptions class members, see the ImageSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ImageOrPrintOptions | Additional image creation options
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

ImageSaveOptions Class | Aspose.Cells Namespace


ImageOrPrintOptions Property

Aspose.Cells for .NET

ImageSaveOptions.ImageOrPrintOptions Property

Additional image creation options

public ImageOrPrintOptions ImageOrPrintOptions {get;}

See Also

ImageSaveOptions Class | Aspose.Cells Namespace


ImportTableOptions Class

Represents the options of importing data into cells.

For a list of all members of this type, see ImportTableOptions Members.

System.Object
Aspose.Cells.ImportTableOptions

public class ImportTableOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ImportTableOptions Members | Aspose.Cells Namespace


ImportTableOptions Members

ImportTableOptions overview

Public Instance Constructors

ImportTableOptions Constructor Creates the default importing options.

Public Instance Properties

CheckMergedCells | Indicates whether checking merged cells.
ColumnIndexes | Gets or sets the columns(0-based) to import from data source. null means all columns should be imported.
ConvertGridStyle | Indicates whether apply the style of the grid view to cells.
ConvertNumericData | Gets or sets a value that indicates whether the string value should be converted to numeric or date value.
DateFormat | Gets or sets date format string for cells with imported datetime values.
DefaultValues | Default value for the value in the table is null.
InsertRows | Indicates whether new rows should be added for importing data records.
IsFieldNameShown | Indicates whether field name should be imported.
IsFormulas | Indicates whether the data are formulas.
IsHtmlString | Indicates whether the value contains html tags.
NumberFormats | Gets or sets the number formats
ShiftFirstRowDown | Indicates whether shifting the first row down when inserting rows.
TotalColumns | Gets or sets total column count to import from data source. -1 means all rows of given data source.
TotalRows | Gets or sets total row count to import from data source. -1 means all rows of given data source.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ImportTableOptions Class | Aspose.Cells Namespace


ImportTableOptions Constructor

Creates the default importing options.

public ImportTableOptions();

See Also

ImportTableOptions Class | Aspose.Cells Namespace


ImportTableOptions Properties

The properties of the ImportTableOptions class are listed below. For a complete list of ImportTableOptions class members, see the ImportTableOptions Members topic.

Public Instance Properties

CheckMergedCells | Indicates whether checking merged cells.
ColumnIndexes | Gets or sets the columns(0-based) to import from data source. null means all columns should be imported.
ConvertGridStyle | Indicates whether apply the style of the grid view to cells.
ConvertNumericData | Gets or sets a value that indicates whether the string value should be converted to numeric or date value.
DateFormat | Gets or sets date format string for cells with imported datetime values.
DefaultValues | Default value for the value in the table is null.
InsertRows | Indicates whether new rows should be added for importing data records.
IsFieldNameShown | Indicates whether field name should be imported.
IsFormulas | Indicates whether the data are formulas.
IsHtmlString | Indicates whether the value contains html tags.
NumberFormats | Gets or sets the number formats
ShiftFirstRowDown | Indicates whether shifting the first row down when inserting rows.
TotalColumns | Gets or sets total column count to import from data source. -1 means all rows of given data source.
TotalRows | Gets or sets total row count to import from data source. -1 means all rows of given data source.

See Also

ImportTableOptions Class | Aspose.Cells Namespace


CheckMergedCells Property

Aspose.Cells for .NET

ImportTableOptions.CheckMergedCells Property

Indicates whether checking merged cells.

public bool CheckMergedCells {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


ColumnIndexes Property

Aspose.Cells for .NET

ImportTableOptions.ColumnIndexes Property

Gets or sets the columns(0-based) to import from data source. null means all columns should be imported.

public int[] ColumnIndexes {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


ConvertGridStyle Property

Aspose.Cells for .NET

ImportTableOptions.ConvertGridStyle Property

Indicates whether apply the style of the grid view to cells.

public bool ConvertGridStyle {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


ConvertNumericData Property

Aspose.Cells for .NET

ImportTableOptions.ConvertNumericData Property

Gets or sets a value that indicates whether the string value should be converted to numeric or date value.

public bool ConvertNumericData {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


DateFormat Property

Aspose.Cells for .NET

ImportTableOptions.DateFormat Property

Gets or sets date format string for cells with imported datetime values.

public string DateFormat {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


DefaultValues Property

Aspose.Cells for .NET

ImportTableOptions.DefaultValues Property

Default value for the value in the table is null.

public object[] DefaultValues {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


InsertRows Property

Aspose.Cells for .NET

ImportTableOptions.InsertRows Property

Indicates whether new rows should be added for importing data records.

public bool InsertRows {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


IsFieldNameShown Property

Aspose.Cells for .NET

ImportTableOptions.IsFieldNameShown Property

Indicates whether field name should be imported.

public bool IsFieldNameShown {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


IsFormulas Property

Aspose.Cells for .NET

ImportTableOptions.IsFormulas Property

Indicates whether the data are formulas.

public bool[] IsFormulas {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


IsHtmlString Property

Aspose.Cells for .NET

ImportTableOptions.IsHtmlString Property

Indicates whether the value contains html tags.

public bool IsHtmlString {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


NumberFormats Property

Aspose.Cells for .NET

ImportTableOptions.NumberFormats Property

Gets or sets the number formats

public string[] NumberFormats {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


ShiftFirstRowDown Property

Aspose.Cells for .NET

ImportTableOptions.ShiftFirstRowDown Property

Indicates whether shifting the first row down when inserting rows.

public bool ShiftFirstRowDown {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


TotalColumns Property

Aspose.Cells for .NET

ImportTableOptions.TotalColumns Property

Gets or sets total column count to import from data source. -1 means all rows of given data source.

public int TotalColumns {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


TotalRows Property

Aspose.Cells for .NET

ImportTableOptions.TotalRows Property

Gets or sets total row count to import from data source. -1 means all rows of given data source.

public int TotalRows {get; set;}

See Also

ImportTableOptions Class | Aspose.Cells Namespace


IndividualFontConfigs Class

Font configs for each Workbook object.

For a list of all members of this type, see IndividualFontConfigs Members.

System.Object
Aspose.Cells.IndividualFontConfigs

public class IndividualFontConfigs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IndividualFontConfigs Members | Aspose.Cells Namespace


IndividualFontConfigs Members

IndividualFontConfigs overview

Public Instance Constructors

IndividualFontConfigs Constructor Ctor.

Public Instance Methods

Equals (inherited from Object) |
GetFontSources | Gets a copy of the array that contains the list of sources
GetFontSubstitutes | Returns array containing font substitute names to be used if original font is not presented.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetFontFolder | Sets the fonts folder
SetFontFolders | Sets the fonts folders
SetFontSources | Sets the fonts sources.
SetFontSubstitutes | Font substitute names for given original font name.
ToString (inherited from Object) |

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs Constructor

Ctor.

public IndividualFontConfigs();

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs Methods

The methods of the IndividualFontConfigs class are listed below. For a complete list of IndividualFontConfigs class members, see the IndividualFontConfigs Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetFontSources | Gets a copy of the array that contains the list of sources
GetFontSubstitutes | Returns array containing font substitute names to be used if original font is not presented.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetFontFolder | Sets the fonts folder
SetFontFolders | Sets the fonts folders
SetFontSources | Sets the fonts sources.
SetFontSubstitutes | Font substitute names for given original font name.
ToString (inherited from Object) |

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs.GetFontSources Method

Gets a copy of the array that contains the list of sources

public FontSourceBase[] GetFontSources();

Return Value

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs.GetFontSubstitutes Method

Returns array containing font substitute names to be used if original font is not presented.

public string[] GetFontSubstitutes(
string originalFontName
);

Parameters

originalFontName
originalFontName

Return Value

An array containing font substitute names to be used if original font is not presented.

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs.SetFontFolder Method

Sets the fonts folder

public void SetFontFolder(
string fontFolder,
bool recursive
);

Parameters

fontFolder
The folder that contains TrueType fonts.
recursive
Determines whether or not to scan subfolders.

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs.SetFontFolders Method

Sets the fonts folders

public void SetFontFolders(
string[] fontFolders,
bool recursive
);

Parameters

fontFolders
The folders that contains TrueType fonts.
recursive
Determines whether or not to scan subfolders.

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs.SetFontSources Method

Sets the fonts sources.

public void SetFontSources(
FontSourceBase[] sources
);

Parameters

sources
An array of sources that contain TrueType fonts.

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


IndividualFontConfigs.SetFontSubstitutes Method

Font substitute names for given original font name.

public void SetFontSubstitutes(
string originalFontName,
string[] substituteFontNames
);

Parameters

originalFontName
Original font name.
substituteFontNames
List of font substitute names to be used if original font is not presented.

See Also

IndividualFontConfigs Class | Aspose.Cells Namespace


InsertOptions Class

Represents the options of inserting.

For a list of all members of this type, see InsertOptions Members.

System.Object
Aspose.Cells.InsertOptions

public class InsertOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

InsertOptions Members | Aspose.Cells Namespace


InsertOptions Members

InsertOptions overview

Public Instance Constructors

InsertOptions Constructor Initializes a new instance of the InsertOptions class.

Public Instance Properties

CopyFormatType |
UpdateReference | Indicates if references in other worksheets will be updated.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

InsertOptions Class | Aspose.Cells Namespace


InsertOptions Constructor

Initializes a new instance of the InsertOptions class.

public InsertOptions();

See Also

InsertOptions Class | Aspose.Cells Namespace


InsertOptions Properties

The properties of the InsertOptions class are listed below. For a complete list of InsertOptions class members, see the InsertOptions Members topic.

Public Instance Properties

CopyFormatType |
UpdateReference | Indicates if references in other worksheets will be updated.

See Also

InsertOptions Class | Aspose.Cells Namespace


CopyFormatType Property

Aspose.Cells for .NET

InsertOptions.CopyFormatType Property

public CopyFormatType CopyFormatType {get; set;}

See Also

InsertOptions Class | Aspose.Cells Namespace


UpdateReference Property

Aspose.Cells for .NET

InsertOptions.UpdateReference Property

Indicates if references in other worksheets will be updated.

public bool UpdateReference {get; set;}

See Also

InsertOptions Class | Aspose.Cells Namespace


InterruptMonitor Class

Represents all operator about the interrupt.

For a list of all members of this type, see InterruptMonitor Members.

System.Object
Aspose.Cells.InterruptMonitor

public class InterruptMonitor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

InterruptMonitor Members | Aspose.Cells Namespace


InterruptMonitor Members

InterruptMonitor overview

Public Instance Constructors

InterruptMonitor Constructor Initializes a new instance of the InterruptMonitor class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Interrupt | Interrupt the current operator.
ToString (inherited from Object) |

See Also

InterruptMonitor Class | Aspose.Cells Namespace


InterruptMonitor Constructor

Initializes a new instance of the InterruptMonitor class.

public InterruptMonitor();

See Also

InterruptMonitor Class | Aspose.Cells Namespace


InterruptMonitor Methods

The methods of the InterruptMonitor class are listed below. For a complete list of InterruptMonitor class members, see the InterruptMonitor Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Interrupt | Interrupt the current operator.
ToString (inherited from Object) |

See Also

InterruptMonitor Class | Aspose.Cells Namespace


InterruptMonitor.Interrupt Method

Interrupt the current operator.

public void Interrupt();

See Also

InterruptMonitor Class | Aspose.Cells Namespace


ISmartMarkerCallBack Interface

Represents callback interface of processing smartmarker.

For a list of all members of this type, see ISmartMarkerCallBack Members.

public interface ISmartMarkerCallBack

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ISmartMarkerCallBack Members | Aspose.Cells Namespace


ISmartMarkerCallBack Members

ISmartMarkerCallBack overview

Public Instance Methods

Process Callback for processing a smart marker.

See Also

ISmartMarkerCallBack Interface | Aspose.Cells Namespace


ISmartMarkerCallBack Methods

The methods of the ISmartMarkerCallBack interface are listed below. For a complete list of ISmartMarkerCallBack interface members, see the ISmartMarkerCallBack Members topic.

Public Instance Methods

Process Callback for processing a smart marker.

See Also

ISmartMarkerCallBack Interface | Aspose.Cells Namespace


ISmartMarkerCallBack.Process Method

Callback for processing a smart marker.

void Process(
int sheetIndex,
int rowIndex,
int colIndex,
string tableName,
string columnName
);

Parameters

sheetIndex
The sheet index.
rowIndex
The row index.
colIndex
The column index.
tableName
The table name of smartmarker.
columnName
The table name of smartmarker.

See Also

ISmartMarkerCallBack Interface | Aspose.Cells Namespace


IStreamProvider Interface

Represents the exported stream provider.

For a list of all members of this type, see IStreamProvider Members.

public interface IStreamProvider

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IStreamProvider Members | Aspose.Cells Namespace


IStreamProvider Members

IStreamProvider overview

Public Instance Methods

CloseStream | Closes the stream.
InitStream | Gets the stream.

See Also

IStreamProvider Interface | Aspose.Cells Namespace


IStreamProvider Methods

The methods of the IStreamProvider interface are listed below. For a complete list of IStreamProvider interface members, see the IStreamProvider Members topic.

Public Instance Methods

CloseStream | Closes the stream.
InitStream | Gets the stream.

See Also

IStreamProvider Interface | Aspose.Cells Namespace


IStreamProvider.CloseStream Method

Closes the stream.

void CloseStream(
StreamProviderOptions options
);

Parameters

options

See Also

IStreamProvider Interface | Aspose.Cells Namespace


IStreamProvider.InitStream Method

Gets the stream.

void InitStream(
StreamProviderOptions options
);

Parameters

options

See Also

IStreamProvider Interface | Aspose.Cells Namespace


IWarningCallback Interface

Callback interface of warning.

For a list of all members of this type, see IWarningCallback Members.

public interface IWarningCallback

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IWarningCallback Members | Aspose.Cells Namespace


IWarningCallback Members

IWarningCallback overview

Public Instance Methods

Warning Our callback only needs to implement the "Warning" method.

See Also

IWarningCallback Interface | Aspose.Cells Namespace


IWarningCallback Methods

The methods of the IWarningCallback interface are listed below. For a complete list of IWarningCallback interface members, see the IWarningCallback Members topic.

Public Instance Methods

Warning Our callback only needs to implement the "Warning" method.

See Also

IWarningCallback Interface | Aspose.Cells Namespace


IWarningCallback.Warning Method

Our callback only needs to implement the "Warning" method.

void Warning(
WarningInfo warningInfo
);

Parameters

warningInfo
warning info

See Also

IWarningCallback Interface | Aspose.Cells Namespace


License Class

Provides methods to license the component.

For a list of all members of this type, see License Members.

System.Object
Aspose.Cells.License

public class License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

License Members | Aspose.Cells Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of this class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) |

See Also

License Class | Aspose.Cells Namespace


License Constructor

Initializes a new instance of this class.

public License();

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

See Also

License Class | Aspose.Cells Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) |

See Also

License Class | Aspose.Cells Namespace


SetLicense Method

Aspose.Cells for .NET

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Cells Namespace


License.SetLicense Method (Stream)

Licenses the component.

public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

[C#]

License license = new License();
license.SetLicense(myStream);

[Visual Basic]

Dim license as License = new License
license.SetLicense(myStream)

See Also

License Class | Aspose.Cells Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

public void SetLicense(
string licenseName
);

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder that contains the Aspose component assembly.

3. The folder that contains the client's calling assembly.

4. The folder that contains the entry (startup) assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.

See Also

License Class | Aspose.Cells Namespace | License.SetLicense Overload List


LightCellsDataHandler Interface

Represents cells data handler for reading large spreadsheet files in light weight mode.

For a list of all members of this type, see LightCellsDataHandler Members.

public interface LightCellsDataHandler

Remarks

When reading a workbook by this mode, StartSheet will be checked when reading every worksheet in the workbook. For one sheet, if StartSheet gives true, then all data and properties of rows/cells of this sheet will be checked and processed by the implementation of this interface. For every row, StartRow will be called to check whether it need to be processed. If a row needs to be processed, properties of this row will be read firstly and user can access its properties by ProcessRow. if row's cells need to be processed too, then ProcessRow should returns true and then StartCell will be called for every existing cell in this row to check whether one cell need to be processed. If one cell needs to be processed, then ProcessCell will be called to process the cell by the implementation of this interface.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LightCellsDataHandler Members | Aspose.Cells Namespace


LightCellsDataHandler Members

LightCellsDataHandler overview

Public Instance Methods

ProcessCell | Starts to process one cell.
ProcessRow | Starts to process one row.
StartCell | Prepares to process a cell.
StartRow | Prepares to process a row.
StartSheet | Starts to process a worksheet.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataHandler Methods

The methods of the LightCellsDataHandler interface are listed below. For a complete list of LightCellsDataHandler interface members, see the LightCellsDataHandler Members topic.

Public Instance Methods

ProcessCell | Starts to process one cell.
ProcessRow | Starts to process one row.
StartCell | Prepares to process a cell.
StartRow | Prepares to process a row.
StartSheet | Starts to process a worksheet.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataHandler.ProcessCell Method

Starts to process one cell.

bool ProcessCell(
Cell cell
);

Parameters

cell
Cell object which is being processed currently

Return Value

whether this cell needs to be kept in cells model of current sheet. Commonly it should be false so that all cells will not be kept in memory after being processed and then memory be saved. For some special purpose such as user needs to access some cells later after the whole workbook having been processed, user can make this method return true to keep those special cells in Cells model and access them later by APIs such as Cells[row, column]. However, keeping cells data in Cells model will requires more memory and if all cells are kept then reading template file in LightCells mode will become same with reading it in normal way.

Remarks

It will be called after one cell's data has been read.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataHandler.ProcessRow Method

Starts to process one row.

bool ProcessRow(
Row row
);

Parameters

row
Row object which is being processed currently.

Return Value

whether this row's cells need to be processed. false to ignore all cells in this row.

Remarks

It will be called after row's properties such as height, style, ...etc. have been read. However, cells in this row has not been read yet.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataHandler.StartCell Method

Prepares to process a cell.

bool StartCell(
int columnIndex
);

Parameters

columnIndex
column index of the cell to be processed

Return Value

whether this cell needs to be processed. false to ignore the cell and check the next one until reach the end of cells data of current row

Remarks

It will be called when reaching an existing cell in current row. Current row is the row of last call of ProcessRow.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataHandler.StartRow Method

Prepares to process a row.

bool StartRow(
int rowIndex
);

Parameters

rowIndex
the index of next row to be processed

Return Value

whether this row(properties or cells data) needs to be processed. false to ignore this row and its cells and check the next row.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataHandler.StartSheet Method

Starts to process a worksheet.

bool StartSheet(
Worksheet sheet
);

Parameters

sheet
the worksheet to read cells data.

Return Value

whether this sheet's cells data needs to be processed. false to ignore this sheet.

Remarks

It will be called before reading cells data of a worksheet.

See Also

LightCellsDataHandler Interface | Aspose.Cells Namespace


LightCellsDataProvider Interface

Represents Data provider for saving large spreadsheet files in light weight mode.

For a list of all members of this type, see LightCellsDataProvider Members.

public interface LightCellsDataProvider

Remarks

When saving a workbook by this mode, StartSheet will be checked when saving every worksheet in the workbook. For one sheet, if StartSheet gives true, then all data and properties of rows/cells of this sheet to be saved will be provided by the implementation of this interface. In the first place, NextRow will be called to get the next row index to be saved. If a valid row index is returned(the row index must be in ascending order for the rows to be saved), then a Row object representing this row will be provided for implementation to set its properties by StartRow. For one row, NextCell will be checked firstly. If a valid column index be returned(the column index must be in ascending order for all cells of one row to be saved), then a Cell object representing this cell will be provided for implementation to set its data and properties by StartCell. After data of this cell is set, this cell will be saved directly to the generated spreadsheet file and the next cell will be checked and processed.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LightCellsDataProvider Members | Aspose.Cells Namespace


LightCellsDataProvider Members

LightCellsDataProvider overview

Public Instance Methods

IsGatherString | Checks whether the current string value of cell needs to be gathered into a global pool.
NextCell | Gets next cell to be saved.
NextRow | Gets the next row to be saved.
StartCell | Starts to save data of one cell.
StartRow | Starts to save data of one row.
StartSheet | Starts to save a worksheet.

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider Methods

The methods of the LightCellsDataProvider interface are listed below. For a complete list of LightCellsDataProvider interface members, see the LightCellsDataProvider Members topic.

Public Instance Methods

IsGatherString | Checks whether the current string value of cell needs to be gathered into a global pool.
NextCell | Gets next cell to be saved.
NextRow | Gets the next row to be saved.
StartCell | Starts to save data of one cell.
StartRow | Starts to save data of one row.
StartSheet | Starts to save a worksheet.

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider.IsGatherString Method

Checks whether the current string value of cell needs to be gathered into a global pool.

bool IsGatherString();

Return Value

true if string value need to be gathered into a global pool for the resultant file.

Remarks

Gathering string values will take advantage only when there are many duplicated string values for the cells provided by this implementation. In this situation gathering string will save much memory and generate smaller resultant file. If there are many string values for the cells provided by LightCellsDataProvider but few of them are same, gathering string will cost more memory and time and has no advantage for the resultant file.

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider.NextCell Method

Gets next cell to be saved.

int NextCell();

Return Value

column index of the next cell to be saved. -1 means the end of current row data has been reached and no further cell of current row to be saved.

Remarks

It will be called at the beginning of saving one cell.

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider.NextRow Method

Gets the next row to be saved.

int NextRow();

Return Value

the next row index to be saved. -1 means the end of current sheet data has been reached and no further row of current sheet to be saved.

Remarks

It will be called at the beginning of saving a row and its cells data(before StartRow).

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider.StartCell Method

Starts to save data of one cell.

void StartCell(
Cell cell
);

Parameters

cell
Cell object for implementation to fill data. Its column index is the returned value of latest call of NextCell. If the cell has been initialized in the inner cells model, the existed cell object will be used. Otherwise a temporary Cell object will be used for implementation to fill data.

Remarks

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider.StartRow Method

Starts to save data of one row.

void StartRow(
Row row
);

Parameters

row
Row object for implementation to fill data. Its row index is the returned value of latest call of NextRow. If the row has been initialized in the inner cells model, the existing row object will be used. Otherwise a temporary Row object will be used for implementation to fill data.

Remarks

It will be called at the beginning of saving a row and its cells data. If current row has some custom properties such as height, style, ...etc., implementation should set those properties to given Row object here.

See Also

LightCellsDataProvider Interface | Aspose.Cells Namespace


LightCellsDataProvider.StartSheet Method

Starts to save a worksheet.

bool StartSheet(
int sheetIndex
);

Parameters

sheetIndex
index of current sheet to be saved.

Return Value

true if this provider will provide data for the given sheet; false if given sheet should use its normal data model(Cells).

Remarks

It will be called at the beginning of saving a worksheet during saving a workbook. If the provider needs to refer to

 later in startRow(Row) or startCell(Cell) method, that is, if the process needs to know which worksheet is being processed, the implementation should retain the
 value here.
See Also
LightCellsDataProvider Interface | Aspose.Cells Namespace


LoadDataFilterOptions Enumeration

Represents the options to filter data when loading workbook from template.

public enum LoadDataFilterOptions

Members

Member Name | Description | Value
None | Obsolete. Use Structure instead. Load nothing for sheet data | 0
All | Load all | 2147483647
CellBlank | Load cells whose value is blank | 1
CellString | Load cells whose value is string | 2
CellNumeric | Load cells whose value is numeric(including datetime) | 4
CellError | Load cells whose value is error | 8
CellBool | Load cells whose value is bool | 16
CellValue | Load cells value(all value types) only | 31
Formula | Load cell formulas. | 32
CellData | Load cells data including values, formulas and formatting | 67108927
Chart | Load charts | 256
Shape | Obsolete. Use Drawing instead. Load shapes | 402653696
Drawing | Drawing objects(including Chart, Picture, OleObject and all other drawing objects) | 402653952
MergedArea | Load merged cells | 1024
ConditionalFormatting | Load conditional formatting | 2048
DataValidation | Load data validations | 4096
PivotTable | Load pivot tables | 8192
Table | Load tables | 16384
Hyperlinks | Load hyperlinks | 32768
SheetSettings | Load settings for worksheet | 65536
SheetData | Load all data of worksheet, such as cells data, settings, objects, ...etc. | 403701759
BookSettings | Load settings for workbook | 1048576
Settings | Load settings for workbook and worksheet | 1114112
XmlMap | Load XmlMap | 2097152
Structure | Load structure of the workbook | 4194304
DocumentProperties | Load document properties | 8388608
DefinedNames | Load defined Name objects | 16777216
VBA | Load VBA projects | 33554432
Style | Load styles for cell formatting | 67108864
Picture | Load pictures | 134217728
OleObject | Load OleObjects | 268435456

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


LoadFilter Class

Represents the filter that provides options for loading data when loading workbook from template.

For a list of all members of this type, see LoadFilter Members.

System.Object
Aspose.Cells.LoadFilter

public class LoadFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

User may specify the filter options or implement their own LoadFilter to specify how to load data.

Example

The following example shows how to determine the filter options according to worksheet's properties.

[C#]
Workbook wb = new Workbook(template, new LoadOptions() { LoadFilter = new LoadFilterSheet() });
//Custom LoadFilter implementation
class LoadFilterSheet : LoadFilter
{
    public override void StartSheet(Worksheet sheet)
    {
        if (sheet.Name == "Sheet1")
        {
            LoadDataFilterOptions = Aspose.Cells.LoadDataFilterOptions.All;
        }
        else
        {
            LoadDataFilterOptions = Aspose.Cells.LoadDataFilterOptions.None;
        }
    }
}

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LoadFilter Members | Aspose.Cells Namespace


LoadFilter Members

LoadFilter overview

Public Instance Constructors

LoadFilter Overloaded. Initializes a new instance of the LoadFilter class.

Public Instance Properties

LoadDataFilterOptions | The filter options to denote what data should be loaded.
SheetsInLoadingOrder | Specifies the sheets(indices) and order to be loaded. Default is null, that denotes to load all sheets in the default order in template file. If not null and some sheet's index is not in the returned array, then the sheet will not be loaded.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
StartSheet | Prepares filter options before loading given worksheet. User's implementation of LoadFilter can change the LoadDataFilterOptions here to denote how to load data for this worksheet.
ToString (inherited from Object) |

See Also

LoadFilter Class | Aspose.Cells Namespace


LoadFilter Constructor

Constructs one LoadFilter with default filter options LoadDataFilterOptions.All.

Overload List

Constructs one LoadFilter with default filter options LoadDataFilterOptions.All.

public LoadFilter();

Constructs one LoadFilter with given filter options.

public LoadFilter(LoadDataFilterOptions);

See Also

LoadFilter Class | Aspose.Cells Namespace


LoadFilter Constructor ()

Constructs one LoadFilter with default filter options LoadDataFilterOptions.All.

public LoadFilter();

See Also

LoadFilter Class | Aspose.Cells Namespace | LoadFilter Constructor Overload List


LoadFilter Constructor (LoadDataFilterOptions)

Constructs one LoadFilter with given filter options.

public LoadFilter(
LoadDataFilterOptions opts
);

Parameters

opts
the default filter options

See Also

LoadFilter Class | Aspose.Cells Namespace | LoadFilter Constructor Overload List


LoadFilter Properties

The properties of the LoadFilter class are listed below. For a complete list of LoadFilter class members, see the LoadFilter Members topic.

Public Instance Properties

LoadDataFilterOptions | The filter options to denote what data should be loaded.
SheetsInLoadingOrder | Specifies the sheets(indices) and order to be loaded. Default is null, that denotes to load all sheets in the default order in template file. If not null and some sheet's index is not in the returned array, then the sheet will not be loaded.

See Also

LoadFilter Class | Aspose.Cells Namespace


LoadDataFilterOptions Property

Aspose.Cells for .NET

LoadFilter.LoadDataFilterOptions Property

The filter options to denote what data should be loaded.

public LoadDataFilterOptions LoadDataFilterOptions {get; set;}

See Also

LoadFilter Class | Aspose.Cells Namespace


SheetsInLoadingOrder Property

Aspose.Cells for .NET

LoadFilter.SheetsInLoadingOrder Property

Specifies the sheets(indices) and order to be loaded. Default is null, that denotes to load all sheets in the default order in template file. If not null and some sheet's index is not in the returned array, then the sheet will not be loaded.

public virtual int[] SheetsInLoadingOrder {get;}

See Also

LoadFilter Class | Aspose.Cells Namespace


LoadFilter Methods

The methods of the LoadFilter class are listed below. For a complete list of LoadFilter class members, see the LoadFilter Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
StartSheet | Prepares filter options before loading given worksheet. User's implementation of LoadFilter can change the LoadDataFilterOptions here to denote how to load data for this worksheet.
ToString (inherited from Object) |

See Also

LoadFilter Class | Aspose.Cells Namespace


LoadFilter.StartSheet Method

Prepares filter options before loading given worksheet. User's implementation of LoadFilter can change the LoadDataFilterOptions here to denote how to load data for this worksheet.

public virtual void StartSheet(
Worksheet sheet
);

Parameters

sheet
The worksheet to be loaded. There are only few properties can be used for the given worksheet object here because most data and properties have not been loaded. The available properties are: Name, Index, VisibilityType

See Also

LoadFilter Class | Aspose.Cells Namespace


LoadFormat Enumeration

Represents the load file format.

public enum LoadFormat

Members

Member Name | Description | Value
Auto | Represents recognizing the format automatically. | 0
CSV | Represents a CSV file. | 1
Xlsx | Represents Office Open XML spreadsheetML workbook or template, with or without macros. | 6
TSV | Represents a TSV(tab-separated values file) file. | 11
TabDelimited | Represents a tab delimited text file, same with TSV. | 11
Html | Represents a html file. | 12
MHtml | Represents a mhtml file. | 13
ODS | Represents a ods file. | 14
Excel97To2003 | Represents an Excel97-2003 xls file. | 5
SpreadsheetML | Represents an Excel 2003 xml file. | 15
Xlsb | Represents an xlsb file. | 16
Numbers | Represents a numbers file. | 56
FODS | Represents the flat ods file. | 59
SXC | Represents StarOffice Calc Spreadsheet (.sxc) file format. | 60
Unknown | Represents unrecognized format, cannot be loaded. | 255

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


LoadOptions Class

Represents the options of loading the file.

For a list of all members of this type, see LoadOptions Members.

System.Object
Aspose.Cells.LoadOptions
Aspose.Cells.AbstractTextLoadOptions
Aspose.Cells.OdsLoadOptions

public class LoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LoadOptions Members | Aspose.Cells Namespace


LoadOptions Members

LoadOptions overview

Public Instance Constructors

LoadOptions Overloaded. Initializes a new instance of the LoadOptions class.

Public Instance Properties

AutoFitterOptions | Gets and sets the auto fitter options
CheckDataValid | Check whether data is valid in the template file.
CheckExcelRestriction | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
CultureInfo | Gets or sets the system culture info at the time the file was loaded.
FontConfigs | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted | Ignore the data which are not printed if directly printing the file
InterruptMonitor | Gets and sets the interrupt monitor.
KeepUnparsedData | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler | The data handler for processing cells data when reading template file.
LoadFilter | The filter to denote how to load data.
LoadFormat | Gets the load format.
MemorySetting | Gets or sets the memory usage options.
ParsingFormulaOnOpen | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password | Gets and set the password of the workbook.
Region | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont | Sets the default standard font name
StandardFontSize | Sets the default standard font size.
WarningCallback | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPaperSize | Sets the default print paper size from default printer's setting.
ToString (inherited from Object) |

See Also

LoadOptions Class | Aspose.Cells Namespace


LoadOptions Constructor

Creates an options of loading the file.

Overload List

Creates an options of loading the file.

public LoadOptions();

Creates an options of loading the file.

public LoadOptions(LoadFormat);

See Also

LoadOptions Class | Aspose.Cells Namespace


LoadOptions Constructor ()

Creates an options of loading the file.

public LoadOptions();

See Also

LoadOptions Class | Aspose.Cells Namespace | LoadOptions Constructor Overload List


LoadOptions Constructor (LoadFormat)

Creates an options of loading the file.

public LoadOptions(
LoadFormat loadFormat
);

Parameters

loadFormat
The loading format.

See Also

LoadOptions Class | Aspose.Cells Namespace | LoadOptions Constructor Overload List


LoadOptions Properties

The properties of the LoadOptions class are listed below. For a complete list of LoadOptions class members, see the LoadOptions Members topic.

Public Instance Properties

AutoFitterOptions | Gets and sets the auto fitter options
CheckDataValid | Check whether data is valid in the template file.
CheckExcelRestriction | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
CultureInfo | Gets or sets the system culture info at the time the file was loaded.
FontConfigs | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted | Ignore the data which are not printed if directly printing the file
InterruptMonitor | Gets and sets the interrupt monitor.
KeepUnparsedData | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler | The data handler for processing cells data when reading template file.
LoadFilter | The filter to denote how to load data.
LoadFormat | Gets the load format.
MemorySetting | Gets or sets the memory usage options.
ParsingFormulaOnOpen | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password | Gets and set the password of the workbook.
Region | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont | Sets the default standard font name
StandardFontSize | Sets the default standard font size.
WarningCallback | Gets or sets warning callback.

See Also

LoadOptions Class | Aspose.Cells Namespace


AutoFitterOptions Property

Aspose.Cells for .NET

LoadOptions.AutoFitterOptions Property

Gets and sets the auto fitter options

public AutoFitterOptions AutoFitterOptions {get; set;}

Remarks

Only for xlsx file now.

See Also

LoadOptions Class | Aspose.Cells Namespace


CheckDataValid Property

Aspose.Cells for .NET

LoadOptions.CheckDataValid Property

Check whether data is valid in the template file.

public bool CheckDataValid {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


CheckExcelRestriction Property

Aspose.Cells for .NET

LoadOptions.CheckExcelRestriction Property

Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.

public bool CheckExcelRestriction {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


CultureInfo Property

Aspose.Cells for .NET

LoadOptions.CultureInfo Property

Gets or sets the system culture info at the time the file was loaded.

public CultureInfo CultureInfo {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


FontConfigs Property

Aspose.Cells for .NET

LoadOptions.FontConfigs Property

Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>

public IndividualFontConfigs FontConfigs {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


IgnoreNotPrinted Property

Aspose.Cells for .NET

LoadOptions.IgnoreNotPrinted Property

Ignore the data which are not printed if directly printing the file

public bool IgnoreNotPrinted {get; set;}

Remarks

Only for xlsx file.

See Also

LoadOptions Class | Aspose.Cells Namespace


InterruptMonitor Property

Aspose.Cells for .NET

LoadOptions.InterruptMonitor Property

Gets and sets the interrupt monitor.

public InterruptMonitor InterruptMonitor {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


KeepUnparsedData Property

Aspose.Cells for .NET

LoadOptions.KeepUnparsedData Property

Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.

public bool KeepUnparsedData {get; set;}

Remarks

For scenarios that user only needs to read some contents from template file and does not need to save the workbook back, set this property as false may improve performance, especially when using it together with some kind of LoadFilter,

See Also

LoadOptions Class | Aspose.Cells Namespace


LanguageCode Property

Aspose.Cells for .NET

LoadOptions.LanguageCode Property

Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.

public CountryCode LanguageCode {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


LightCellsDataHandler Property

Aspose.Cells for .NET

LoadOptions.LightCellsDataHandler Property

The data handler for processing cells data when reading template file.

public LightCellsDataHandler LightCellsDataHandler {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


LoadFilter Property

Aspose.Cells for .NET

LoadOptions.LoadFilter Property

The filter to denote how to load data.

public LoadFilter LoadFilter {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


LoadFormat Property

Aspose.Cells for .NET

LoadOptions.LoadFormat Property

Gets the load format.

public LoadFormat LoadFormat {get;}

See Also

LoadOptions Class | Aspose.Cells Namespace


MemorySetting Property

Aspose.Cells for .NET

LoadOptions.MemorySetting Property

Gets or sets the memory usage options.

public MemorySetting MemorySetting {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


ParsingFormulaOnOpen Property

Aspose.Cells for .NET

LoadOptions.ParsingFormulaOnOpen Property

Indicates whether parsing the formula when reading the file.

public bool ParsingFormulaOnOpen {get; set;}

Remarks

Only applies for Excel Xlsx, Xltx, Xltm and Xlsm file because the formulas in the files are stored with a string formula.

See Also

LoadOptions Class | Aspose.Cells Namespace


ParsingPivotCachedRecords Property

Aspose.Cells for .NET

LoadOptions.ParsingPivotCachedRecords Property

Indicates whether parsing pivot cached records when loading the file. The default value is false.

public bool ParsingPivotCachedRecords {get; set;}

Remarks

Only applies for Excel Xlsx, Xltx, Xltm , Xlsm and xlsb file

See Also

LoadOptions Class | Aspose.Cells Namespace


Password Property

Aspose.Cells for .NET

LoadOptions.Password Property

Gets and set the password of the workbook.

public string Password {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


Region Property

Aspose.Cells for .NET

LoadOptions.Region Property

Gets or sets the system regional settings based on CountryCode at the time the file was loaded.

public CountryCode Region {get; set;}

Remarks

If you do not want to use the region saved in the file, please reset it after reading the file.

See Also

LoadOptions Class | Aspose.Cells Namespace


StandardFont Property

Aspose.Cells for .NET

LoadOptions.StandardFont Property

Sets the default standard font name

public string StandardFont {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


StandardFontSize Property

Aspose.Cells for .NET

LoadOptions.StandardFontSize Property

Sets the default standard font size.

public double StandardFontSize {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


WarningCallback Property

Aspose.Cells for .NET

LoadOptions.WarningCallback Property

Gets or sets warning callback.

public IWarningCallback WarningCallback {get; set;}

See Also

LoadOptions Class | Aspose.Cells Namespace


LoadOptions Methods

The methods of the LoadOptions class are listed below. For a complete list of LoadOptions class members, see the LoadOptions Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPaperSize | Sets the default print paper size from default printer's setting.
ToString (inherited from Object) |

See Also

LoadOptions Class | Aspose.Cells Namespace


LoadOptions.SetPaperSize Method

Sets the default print paper size from default printer's setting.

public void SetPaperSize(
PaperSizeType type
);

Parameters

type
The default paper size.

Remarks

If there is no setting about paper size,MS Excel will use default printer's setting.

See Also

LoadOptions Class | Aspose.Cells Namespace


LookAtType Enumeration

Represents look at type.

public enum LookAtType

Members

Member Name | Description | Value
Contains | Cell value Contains the find object. | 0
StartWith | Cell value Starts with the find object. | 1
EndWith | Cell value ends with the find object. | 2
EntireContent | Cell value is same as the find object. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


LookInType Enumeration

Represents look in type.

public enum LookInType

Members

Member Name | Description | Value
Formulas | If the cell contains a formula, find object from formula,else find it from the value. | 0
Values | Only find object from the formatted values. | 1
ValuesExcludeFormulaCell | Only find object from the values of cells which do not contains formula. | 2
Comments | Only find object from the comments. | 3
OnlyFormulas | Only find object from formulas. | 4
OriginalValues | Only find object from the original values. | 5

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


MarkdownSaveOptions Class

Represents the save options for markdown.

For a list of all members of this type, see MarkdownSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.MarkdownSaveOptions

public class MarkdownSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MarkdownSaveOptions Members | Aspose.Cells Namespace


MarkdownSaveOptions Members

MarkdownSaveOptions overview

Public Instance Constructors

MarkdownSaveOptions Constructor Creates options for saving markdown document

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
Encoding | Gets and sets the default encoding.
FormatStrategy | Gets and sets the format strategy when exporting the cell value as string.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
LineSeparator | Gets and sets the line separator.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


MarkdownSaveOptions Constructor

Creates options for saving markdown document

public MarkdownSaveOptions();

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


MarkdownSaveOptions Properties

The properties of the MarkdownSaveOptions class are listed below. For a complete list of MarkdownSaveOptions class members, see the MarkdownSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
Encoding | Gets and sets the default encoding.
FormatStrategy | Gets and sets the format strategy when exporting the cell value as string.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
LineSeparator | Gets and sets the line separator.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


Encoding Property

Aspose.Cells for .NET

MarkdownSaveOptions.Encoding Property

Gets and sets the default encoding.

public Encoding Encoding {get; set;}

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


FormatStrategy Property

Aspose.Cells for .NET

MarkdownSaveOptions.FormatStrategy Property

Gets and sets the format strategy when exporting the cell value as string.

public CellValueFormatStrategy FormatStrategy {get; set;}

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


LightCellsDataProvider Property

Aspose.Cells for .NET

MarkdownSaveOptions.LightCellsDataProvider Property

The Data provider to provide cells data for saving workbook in light mode.

public LightCellsDataProvider LightCellsDataProvider {get; set;}

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


LineSeparator Property

Aspose.Cells for .NET

MarkdownSaveOptions.LineSeparator Property

Gets and sets the line separator.

public string LineSeparator {get; set;}

See Also

MarkdownSaveOptions Class | Aspose.Cells Namespace


MemoryFontSource Class

Represents the single TrueType font file stored in memory.

For a list of all members of this type, see MemoryFontSource Members.

System.Object
Aspose.Cells.FontSourceBase
Aspose.Cells.MemoryFontSource

public class MemoryFontSource : FontSourceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MemoryFontSource Members | Aspose.Cells Namespace


MemoryFontSource Members

MemoryFontSource overview

Public Instance Constructors

MemoryFontSource Constructor Ctor.

Public Instance Properties

FontData | Binary font data.
Type | Returns the type of the font source.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MemoryFontSource Class | Aspose.Cells Namespace


MemoryFontSource Constructor

Ctor.

public MemoryFontSource(
byte[] fontData
);

Parameters

fontData
Binary font data.

See Also

MemoryFontSource Class | Aspose.Cells Namespace


MemoryFontSource Properties

The properties of the MemoryFontSource class are listed below. For a complete list of MemoryFontSource class members, see the MemoryFontSource Members topic.

Public Instance Properties

FontData | Binary font data.
Type | Returns the type of the font source.

See Also

MemoryFontSource Class | Aspose.Cells Namespace


FontData Property

Aspose.Cells for .NET

MemoryFontSource.FontData Property

Binary font data.

public byte[] FontData {get;}

See Also

MemoryFontSource Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

MemoryFontSource.Type Property

Returns the type of the font source.

public override FontSourceType Type {get;}

See Also

MemoryFontSource Class | Aspose.Cells Namespace


MemorySetting Enumeration

Memory usage options.

public enum MemorySetting

Members

Member Name | Description | Value
Normal | Default option for cells model. | 0
MemoryPreference | Memory performance preferrable. With this option the data will be held in compact format so for common scenarios it may give lower memory cost. However, this option also may degrade R/W performance a bit in some special cases. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Metered Class

Provides methods to set metered key.

For a list of all members of this type, see Metered Members.

System.Object
Aspose.Cells.Metered

public class Metered

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

In this example, an attempt will be made to set metered public and private key

[C#]

Metered matered = new Metered();
matered.SetMeteredKey("PublicKey", "PrivateKey");

[Visual Basic]

Dim matered As Metered = New Metered
matered.SetMeteredKey("PublicKey", "PrivateKey")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Metered Members | Aspose.Cells Namespace


Metered Members

Metered overview

Public Static Methods

GetConsumptionCredit | Gets consumption credit
GetConsumptionQuantity | Gets consumption file size

Public Instance Constructors

Metered Constructor Initializes a new instance of this class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetMeteredKey | Sets metered public and private key
ToString (inherited from Object) |

See Also

Metered Class | Aspose.Cells Namespace


Metered Constructor

Initializes a new instance of this class.

public Metered();

See Also

Metered Class | Aspose.Cells Namespace


Metered Methods

The methods of the Metered class are listed below. For a complete list of Metered class members, see the Metered Members topic.

Public Static Methods

GetConsumptionCredit | Gets consumption credit
GetConsumptionQuantity | Gets consumption file size

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetMeteredKey | Sets metered public and private key
ToString (inherited from Object) |

See Also

Metered Class | Aspose.Cells Namespace


Metered.GetConsumptionCredit Method

Gets consumption credit

public static decimal GetConsumptionCredit();

Return Value

consumption quantity

See Also

Metered Class | Aspose.Cells Namespace


Metered.GetConsumptionQuantity Method

Gets consumption file size

public static decimal GetConsumptionQuantity();

Return Value

consumption quantity

See Also

Metered Class | Aspose.Cells Namespace


Metered.SetMeteredKey Method

Sets metered public and private key

public void SetMeteredKey(
string publicKey,
string privateKey
);

Parameters

publicKey
public key
privateKey
private key

See Also

Metered Class | Aspose.Cells Namespace


MultipleFilterCollection Class

Represents the multiple filter collection.

For a list of all members of this type, see MultipleFilterCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.MultipleFilterCollection

public class MultipleFilterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MultipleFilterCollection Members | Aspose.Cells Namespace


MultipleFilterCollection Members

MultipleFilterCollection overview

Public Instance Constructors

MultipleFilterCollection Constructor Initializes a new instance of the MultipleFilterCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | DateTimeGroupItem or a simple object.
MatchBlank | Indicates whether to filter by blank.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

MultipleFilterCollection Class | Aspose.Cells Namespace


MultipleFilterCollection Constructor

Initializes a new instance of the MultipleFilterCollection class.

public MultipleFilterCollection();

See Also

MultipleFilterCollection Class | Aspose.Cells Namespace


MultipleFilterCollection Properties

The properties of the MultipleFilterCollection class are listed below. For a complete list of MultipleFilterCollection class members, see the MultipleFilterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | DateTimeGroupItem or a simple object.
MatchBlank | Indicates whether to filter by blank.

See Also

MultipleFilterCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

MultipleFilterCollection.Item Property

DateTimeGroupItem or a simple object.

public object this[
int index
] {get;}

Parameters

index

See Also

MultipleFilterCollection Class | Aspose.Cells Namespace


MatchBlank Property

Aspose.Cells for .NET

MultipleFilterCollection.MatchBlank Property

Indicates whether to filter by blank.

public bool MatchBlank {get; set;}

See Also

MultipleFilterCollection Class | Aspose.Cells Namespace


Name Class

Represents a defined name for a range of cells.

For a list of all members of this type, see Name Members.

System.Object
Aspose.Cells.Name

public class Name

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Instantiating a Workbook object
 Workbook workbook = new Workbook();
 //Accessing the first worksheet in the Excel file
 Worksheet worksheet = workbook.Worksheets[0];
 //Creating a named range
 Range range = worksheet.Cells.CreateRange("B4", "G14");
 //Setting the name of the named range
 range.Name = "TestRange";
 //Saving the modified Excel file in default (that is Excel 2000) format
 workbook.Save("C:\\output.xls");

 [Visual Basic]

 'Instantiating a Workbook object
 Dim workbook As Workbook = New Workbook()
 'Accessing the first worksheet in the Excel file
 Dim worksheet As Worksheet = workbook.Worksheets(0)
 'Creating a named range
 Dim range As Range = worksheet.Cells.CreateRange("B4", "G14")
 'Setting the name of the named range
 range.Name = "TestRange"
 'Saving the modified Excel file in default (that is Excel 2000) format
 workbook.Save("C:\\output.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Name Members | Aspose.Cells Namespace


Name Members

Name overview

Public Instance Properties

Comment | Gets and sets the comment of the name. Only applies for Excel 2007.
FullText | Gets the name full text of the object with the scope setting.
IsReferred | Indicates whether this name is referred by other formulas.
IsVisible | Indicates whether the name is visible.
R1C1RefersTo | Gets or sets a R1C1 reference of the Name.
RefersTo | Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.
SheetIndex | Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)
Text | Gets the name text of the object.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetRange | Overloaded. Gets the range if this name refers to a range.
GetRanges | Overloaded. Gets all ranges referred by this name.
GetReferredAreas | Gets all references referred by this name.
GetRefersTo | Get the reference of this Name.
GetType (inherited from Object) |
SetRefersTo | Set the reference of this Name.
ToString | Returns a string represents the current Range object.

See Also

Name Class | Aspose.Cells Namespace


Name Properties

The properties of the Name class are listed below. For a complete list of Name class members, see the Name Members topic.

Public Instance Properties

Comment | Gets and sets the comment of the name. Only applies for Excel 2007.
FullText | Gets the name full text of the object with the scope setting.
IsReferred | Indicates whether this name is referred by other formulas.
IsVisible | Indicates whether the name is visible.
R1C1RefersTo | Gets or sets a R1C1 reference of the Name.
RefersTo | Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.
SheetIndex | Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)
Text | Gets the name text of the object.

See Also

Name Class | Aspose.Cells Namespace


Comment Property

Aspose.Cells for .NET

Name.Comment Property

Gets and sets the comment of the name. Only applies for Excel 2007.

public string Comment {get; set;}

See Also

Name Class | Aspose.Cells Namespace


FullText Property

Aspose.Cells for .NET

Name.FullText Property

Gets the name full text of the object with the scope setting.

public string FullText {get;}

See Also

Name Class | Aspose.Cells Namespace


IsReferred Property

Aspose.Cells for .NET

Name.IsReferred Property

Indicates whether this name is referred by other formulas.

public bool IsReferred {get;}

See Also

Name Class | Aspose.Cells Namespace


IsVisible Property

Aspose.Cells for .NET

Name.IsVisible Property

Indicates whether the name is visible.

public bool IsVisible {get; set;}

See Also

Name Class | Aspose.Cells Namespace


R1C1RefersTo Property

Aspose.Cells for .NET

Name.R1C1RefersTo Property

Gets or sets a R1C1 reference of the Name.

public string R1C1RefersTo {get; set;}

See Also

Name Class | Aspose.Cells Namespace


RefersTo Property

Aspose.Cells for .NET

Name.RefersTo Property

Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.

public string RefersTo {get; set;}

See Also

Name Class | Aspose.Cells Namespace


SheetIndex Property

Aspose.Cells for .NET

Name.SheetIndex Property

Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)

public int SheetIndex {get; set;}

See Also

Name Class | Aspose.Cells Namespace


Text Property

Aspose.Cells for .NET

Name.Text Property

Gets the name text of the object.

public string Text {get; set;}

See Also

Name Class | Aspose.Cells Namespace


Name Methods

The methods of the Name class are listed below. For a complete list of Name class members, see the Name Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetRange | Overloaded. Gets the range if this name refers to a range.
GetRanges | Overloaded. Gets all ranges referred by this name.
GetReferredAreas | Gets all references referred by this name.
GetRefersTo | Get the reference of this Name.
GetType (inherited from Object) |
SetRefersTo | Set the reference of this Name.
ToString | Returns a string represents the current Range object.

See Also

Name Class | Aspose.Cells Namespace


GetRange Method

Aspose.Cells for .NET

Name.GetRange Method

Gets the range if this name refers to a range.

Overload List

Gets the range if this name refers to a range.

public Range GetRange();

Gets the range if this name refers to a range

public Range GetRange(bool);

Gets the range if this name refers to a range. If the reference of this name is not absolute, the range may be different for different cell.

public Range GetRange(int,int,int);

See Also

Name Class | Aspose.Cells Namespace


Name.GetRange Method ()

Gets the range if this name refers to a range.

public Range GetRange();

Return Value

The range.

See Also

Name Class | Aspose.Cells Namespace | Name.GetRange Overload List


Name.GetRange Method (Boolean)

Gets the range if this name refers to a range

public Range GetRange(
bool recalculate
);

Parameters

recalculate
whether recalculate it if this name has been calculated before this invocation.

Return Value

The range.

See Also

Name Class | Aspose.Cells Namespace | Name.GetRange Overload List


Name.GetRange Method (Int32, Int32, Int32)

Gets the range if this name refers to a range. If the reference of this name is not absolute, the range may be different for different cell.

public Range GetRange(
int sheetIndex,
int row,
int column
);

Parameters

sheetIndex
The according sheet index.
row
The according row index.
column
The according column index

Return Value

The range.

See Also

Name Class | Aspose.Cells Namespace | Name.GetRange Overload List


GetRanges Method

Aspose.Cells for .NET

Name.GetRanges Method

Gets all ranges referred by this name.

Overload List

Gets all ranges referred by this name.

public Range[] GetRanges();

Gets all ranges referred by this name.

public Range[] GetRanges(bool);

See Also

Name Class | Aspose.Cells Namespace


Name.GetRanges Method ()

Gets all ranges referred by this name.

public Range[] GetRanges();

Return Value

All ranges.

See Also

Name Class | Aspose.Cells Namespace | Name.GetRanges Overload List


Name.GetRanges Method (Boolean)

Gets all ranges referred by this name.

public Range[] GetRanges(
bool recalculate
);

Parameters

recalculate
whether recalculate it if this name has been calculated before this invocation.

Return Value

All ranges.

See Also

Name Class | Aspose.Cells Namespace | Name.GetRanges Overload List


Name.GetReferredAreas Method

Gets all references referred by this name.

public ReferredArea[] GetReferredAreas(
bool recalculate
);

Parameters

recalculate
whether recalculate it if this name has been calculated before this invocation.

Return Value

All ranges.

See Also

Name Class | Aspose.Cells Namespace


Name.GetRefersTo Method

Get the reference of this Name.

public string GetRefersTo(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the reference needs to be formatted as R1C1.
isLocal
Whether the reference needs to be formatted by locale.

See Also

Name Class | Aspose.Cells Namespace


Name.SetRefersTo Method

Set the reference of this Name.

public void SetRefersTo(
string refersTo,
bool isR1C1,
bool isLocal
);

Parameters

refersTo
The reference.
isR1C1
Whether the reference is R1C1 format.
isLocal
Whether the reference is locale formatted.

See Also

Name Class | Aspose.Cells Namespace


Name.ToString Method

Returns a string represents the current Range object.

public override string ToString();

Return Value

See Also

Name Class | Aspose.Cells Namespace


NameCollection Class

Represents a collection of all the Name objects in the spreadsheet.

For a list of all members of this type, see NameCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.NameCollection

public class NameCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

NameCollection Members | Aspose.Cells Namespace


NameCollection Members

NameCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Name element at the specified index.

Public Instance Methods

Add | Defines a new name.
Clear | Remove all defined names which are not referenced by the formulas and data source. If the defined name is referred, we only set Name.ReferTo as null and hide them.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Overloaded. Remove an array of name
RemoveAt | Remove the name at the specific index.
RemoveDuplicateNames | Remove the duplicate defined names
Sort | Sorts defined names.
ToString (inherited from Object) |

See Also

NameCollection Class | Aspose.Cells Namespace


NameCollection Properties

The properties of the NameCollection class are listed below. For a complete list of NameCollection class members, see the NameCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Name element at the specified index.

See Also

NameCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

NameCollection.Item Property

Gets the Name element at the specified index.

Overload List

Gets the Name element at the specified index.

public Name this[int] {get;}

Gets the Name element with the specified name.

public Name this[string] {get;}

See Also

NameCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

NameCollection.Item Property (Int32)

Gets the Name element at the specified index.

public Name this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

NameCollection Class | Aspose.Cells Namespace | NameCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

NameCollection.Item Property (String)

Gets the Name element with the specified name.

public Name this[
string text
] {get;}

Parameters

text
Name text.

See Also

NameCollection Class | Aspose.Cells Namespace | NameCollection.Item Overload List


NameCollection Methods

The methods of the NameCollection class are listed below. For a complete list of NameCollection class members, see the NameCollection Members topic.

Public Instance Methods

Add | Defines a new name.
Clear | Remove all defined names which are not referenced by the formulas and data source. If the defined name is referred, we only set Name.ReferTo as null and hide them.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Overloaded. Remove an array of name
RemoveAt | Remove the name at the specific index.
RemoveDuplicateNames | Remove the duplicate defined names
Sort | Sorts defined names.
ToString (inherited from Object) |

See Also

NameCollection Class | Aspose.Cells Namespace


NameCollection.Add Method

Defines a new name.

public int Add(
string text
);

Parameters

text
The text to use as the name.

Return Value

Name object index.

Remarks

Name cannot include spaces and cannot look like cell references.

See Also

NameCollection Class | Aspose.Cells Namespace


NameCollection.Clear Method

Remove all defined names which are not referenced by the formulas and data source. If the defined name is referred, we only set Name.ReferTo as null and hide them.

new public void Clear();

Implements

IList.Clear

See Also

NameCollection Class | Aspose.Cells Namespace


Remove Method

Aspose.Cells for .NET

NameCollection.Remove Method

Remove the name.

Overload List

Remove the name.

public void Remove(string);

Remove an array of name

public void Remove(string[]);

See Also

NameCollection Class | Aspose.Cells Namespace


NameCollection.Remove Method (String)

Remove the name.

public void Remove(
string text
);

Parameters

text
The name text.

See Also

NameCollection Class | Aspose.Cells Namespace | NameCollection.Remove Overload List


NameCollection.Remove Method (String[])

Remove an array of name

public void Remove(
string[] names
);

Parameters

names
The names' text.

See Also

NameCollection Class | Aspose.Cells Namespace | NameCollection.Remove Overload List


NameCollection.RemoveAt Method

Remove the name at the specific index.

new public void RemoveAt(
int index
);

Parameters

index
index of the Name to be removed.

Implements

IList.RemoveAt

Remarks

Please make sure that the name is not referred by the other formulas before calling the method. And if the name is referred, setting Name.RefersTo as null is better.

See Also

NameCollection Class | Aspose.Cells Namespace


NameCollection.RemoveDuplicateNames Method

Remove the duplicate defined names

public void RemoveDuplicateNames();

See Also

NameCollection Class | Aspose.Cells Namespace


NameCollection.Sort Method

Sorts defined names.

public void Sort();

Remarks

If you create a large amount of named ranges in the Excel file, please call this method after all named ranges are created and before saving

See Also

NameCollection Class | Aspose.Cells Namespace


NegativeBarFormat Class

Represents the color settings of the data bars for negative values that are defined by a data bar conditional formatting rule.

For a list of all members of this type, see NegativeBarFormat Members.

System.Object
Aspose.Cells.NegativeBarFormat

public class NegativeBarFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

NegativeBarFormat Members | Aspose.Cells Namespace


NegativeBarFormat Members

NegativeBarFormat overview

Public Instance Properties

BorderColor | Gets or sets a FormatColor object that you can use to specify the border color for negative data bars.
BorderColorType | Gets whether to use the same border color as positive data bars.
Color | Gets or sets a FormatColor object that you can use to specify the fill color for negative data bars.
ColorType | Gets or sets whether to use the same fill color as positive data bars.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

NegativeBarFormat Class | Aspose.Cells Namespace


NegativeBarFormat Properties

The properties of the NegativeBarFormat class are listed below. For a complete list of NegativeBarFormat class members, see the NegativeBarFormat Members topic.

Public Instance Properties

BorderColor | Gets or sets a FormatColor object that you can use to specify the border color for negative data bars.
BorderColorType | Gets whether to use the same border color as positive data bars.
Color | Gets or sets a FormatColor object that you can use to specify the fill color for negative data bars.
ColorType | Gets or sets whether to use the same fill color as positive data bars.

See Also

NegativeBarFormat Class | Aspose.Cells Namespace


BorderColor Property

Aspose.Cells for .NET

NegativeBarFormat.BorderColor Property

Gets or sets a FormatColor object that you can use to specify the border color for negative data bars.

public Color BorderColor {get; set;}

See Also

NegativeBarFormat Class | Aspose.Cells Namespace


BorderColorType Property

Aspose.Cells for .NET

NegativeBarFormat.BorderColorType Property

Gets whether to use the same border color as positive data bars.

public DataBarNegativeColorType BorderColorType {get; set;}

See Also

NegativeBarFormat Class | Aspose.Cells Namespace


Color Property

Aspose.Cells for .NET

NegativeBarFormat.Color Property

Gets or sets a FormatColor object that you can use to specify the fill color for negative data bars.

public Color Color {get; set;}

See Also

NegativeBarFormat Class | Aspose.Cells Namespace


ColorType Property

Aspose.Cells for .NET

NegativeBarFormat.ColorType Property

Gets or sets whether to use the same fill color as positive data bars.

public DataBarNegativeColorType ColorType {get; set;}

See Also

NegativeBarFormat Class | Aspose.Cells Namespace


NumberCategoryType Enumeration

Represents category type of cell's number formatting.

public enum NumberCategoryType

Members

Member Name | Description | Value
General | General | 0
Text | Text | 1
Number | Number | 2
Date | Date or Date and Time | 3
Time | Time | 4
Fraction | Fraction | 5
Scientific | Scientific | 6

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


OdsLoadOptions Class

Represents the options of loading ods file.

For a list of all members of this type, see OdsLoadOptions Members.

System.Object
Aspose.Cells.LoadOptions
Aspose.Cells.OdsLoadOptions

public class OdsLoadOptions : LoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OdsLoadOptions Members | Aspose.Cells Namespace


OdsLoadOptions Members

OdsLoadOptions overview

Public Instance Constructors

OdsLoadOptions Overloaded. Initializes a new instance of the OdsLoadOptions class.

Public Instance Properties

ApplyExcelDefaultStyleToHyperlink | Indicates whether applying the default style of the Excel to hyperlink.
AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
RefreshPivotTables | Indicates whether refresh pivot tables when loading file.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPaperSize (inherited from LoadOptions) | Sets the default print paper size from default printer's setting.
ToString (inherited from Object) |

See Also

OdsLoadOptions Class | Aspose.Cells Namespace


OdsLoadOptions Constructor

Represents the options of loading ods file.

Overload List

Represents the options of loading ods file.

public OdsLoadOptions();

Represents the options of loading ods file.

public OdsLoadOptions(LoadFormat);

See Also

OdsLoadOptions Class | Aspose.Cells Namespace


OdsLoadOptions Constructor ()

Represents the options of loading ods file.

public OdsLoadOptions();

See Also

OdsLoadOptions Class | Aspose.Cells Namespace | OdsLoadOptions Constructor Overload List


OdsLoadOptions Constructor (LoadFormat)

Represents the options of loading ods file.

public OdsLoadOptions(
LoadFormat type
);

Parameters

type
The load format type.

See Also

OdsLoadOptions Class | Aspose.Cells Namespace | OdsLoadOptions Constructor Overload List


OdsLoadOptions Properties

The properties of the OdsLoadOptions class are listed below. For a complete list of OdsLoadOptions class members, see the OdsLoadOptions Members topic.

Public Instance Properties

ApplyExcelDefaultStyleToHyperlink | Indicates whether applying the default style of the Excel to hyperlink.
AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
RefreshPivotTables | Indicates whether refresh pivot tables when loading file.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

See Also

OdsLoadOptions Class | Aspose.Cells Namespace


ApplyExcelDefaultStyleToHyperlink Property

Aspose.Cells for .NET

OdsLoadOptions.ApplyExcelDefaultStyleToHyperlink Property

Indicates whether applying the default style of the Excel to hyperlink.

public bool ApplyExcelDefaultStyleToHyperlink {get; set;}

See Also

OdsLoadOptions Class | Aspose.Cells Namespace


RefreshPivotTables Property

Aspose.Cells for .NET

OdsLoadOptions.RefreshPivotTables Property

Indicates whether refresh pivot tables when loading file.

public bool RefreshPivotTables {get; set;}

See Also

OdsLoadOptions Class | Aspose.Cells Namespace


OdsSaveOptions Class

Represents the options of saving ods file.

For a list of all members of this type, see OdsSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.OdsSaveOptions

public class OdsSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OdsSaveOptions Members | Aspose.Cells Namespace


OdsSaveOptions Members

OdsSaveOptions overview

Public Instance Constructors

OdsSaveOptions Overloaded. Initializes a new instance of the OdsSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
GeneratorType | Gets and sets the generator of the ods file.
IsStrictSchema11 | Indicates whether the ods file should be saved as ODF format version 1.1. Default is false.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

OdsSaveOptions Class | Aspose.Cells Namespace


OdsSaveOptions Constructor

Creates the options of saving ods file.

Overload List

Creates the options of saving ods file.

public OdsSaveOptions();

Creates the options of saving ods file.

public OdsSaveOptions(SaveFormat);

See Also

OdsSaveOptions Class | Aspose.Cells Namespace


OdsSaveOptions Constructor ()

Creates the options of saving ods file.

public OdsSaveOptions();

See Also

OdsSaveOptions Class | Aspose.Cells Namespace | OdsSaveOptions Constructor Overload List


OdsSaveOptions Constructor (SaveFormat)

Creates the options of saving ods file.

public OdsSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat

See Also

OdsSaveOptions Class | Aspose.Cells Namespace | OdsSaveOptions Constructor Overload List


OdsSaveOptions Properties

The properties of the OdsSaveOptions class are listed below. For a complete list of OdsSaveOptions class members, see the OdsSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
GeneratorType | Gets and sets the generator of the ods file.
IsStrictSchema11 | Indicates whether the ods file should be saved as ODF format version 1.1. Default is false.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

OdsSaveOptions Class | Aspose.Cells Namespace


GeneratorType Property

Aspose.Cells for .NET

OdsSaveOptions.GeneratorType Property

Gets and sets the generator of the ods file.

public OdsGeneratorType GeneratorType {get; set;}

See Also

OdsSaveOptions Class | Aspose.Cells Namespace


IsStrictSchema11 Property

Aspose.Cells for .NET

OdsSaveOptions.IsStrictSchema11 Property

Indicates whether the ods file should be saved as ODF format version 1.1. Default is false.

public bool IsStrictSchema11 {get; set;}

See Also

OdsSaveOptions Class | Aspose.Cells Namespace


OoxmlCompliance Enumeration

Allows to specify which OOXML specification will be used when saving in the Xlsx format.

public enum OoxmlCompliance

Members

Member Name | Description | Value
Ecma376_2006 | ECMA-376 1st Edition, 2006. | 0
Iso29500_2008_Strict | ISO/IEC 29500:2008 Strict compliance level. | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


OoxmlCompressionType Enumeration

The Ooxml compression type

public enum OoxmlCompressionType

Members

Member Name | Description | Value
Level1 | The fastest but least effective compression. | 1
Level2 | A little slower, but better, than level 1. | 2
Level3 | A little slower, but better, than level 2. | 3
Level4 | A little slower, but better, than level 3. | 4
Level5 | A little slower than level 4, but with better compression. | 5
Level6 | A good balance of speed and compression efficiency. | 6
Level7 | Pretty good compression! | 7
Level8 | Better compression than Level7! | 8
Level9 | The "best" compression, where best means greatest reduction in size of the input data stream. This is also the slowest compression. | 9

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


OoxmlSaveOptions Class

Represents the options of saving office open xml file.

For a list of all members of this type, see OoxmlSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.OoxmlSaveOptions

public class OoxmlSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OoxmlSaveOptions Members | Aspose.Cells Namespace


OoxmlSaveOptions Members

OoxmlSaveOptions overview

Public Instance Constructors

OoxmlSaveOptions Overloaded. Initializes a new instance of the OoxmlSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CompressionType | Gets and sets the compression type for ooxml file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EmbedOoxmlAsOleObject | Indicates whether embedding Ooxml files of OleObject as ole object.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
EnableZip64 | Always use ZIP64 extensions when writing zip archives, even when unnecessary.
ExportCellName | Indicates if export cell name to Excel2007 .xlsx (.xlsm, .xltx, .xltm) file. If the output file may be accessed by SQL Server DTS, this value must be true. Setting the value to false will highly increase the performance and reduce the file size when creating large file. Default value is true.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
UpdateZoom | Indicates whether update scaling factor before saving the file if the PageSetup.FitToPagesWide and PageSetup.FitToPagesTall properties control how the worksheet is scaled.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


OoxmlSaveOptions Constructor

Creates the options for saving office open xml file.

Overload List

Creates the options for saving office open xml file.

public OoxmlSaveOptions();

Creates the options for saving office open xml file.

public OoxmlSaveOptions(SaveFormat);

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


OoxmlSaveOptions Constructor ()

Creates the options for saving office open xml file.

public OoxmlSaveOptions();

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace | OoxmlSaveOptions Constructor Overload List


OoxmlSaveOptions Constructor (SaveFormat)

Creates the options for saving office open xml file.

public OoxmlSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The file format. It must be xlsx,xltx,xlsm,xltm.

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace | OoxmlSaveOptions Constructor Overload List


OoxmlSaveOptions Properties

The properties of the OoxmlSaveOptions class are listed below. For a complete list of OoxmlSaveOptions class members, see the OoxmlSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CompressionType | Gets and sets the compression type for ooxml file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EmbedOoxmlAsOleObject | Indicates whether embedding Ooxml files of OleObject as ole object.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
EnableZip64 | Always use ZIP64 extensions when writing zip archives, even when unnecessary.
ExportCellName | Indicates if export cell name to Excel2007 .xlsx (.xlsm, .xltx, .xltm) file. If the output file may be accessed by SQL Server DTS, this value must be true. Setting the value to false will highly increase the performance and reduce the file size when creating large file. Default value is true.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
UpdateZoom | Indicates whether update scaling factor before saving the file if the PageSetup.FitToPagesWide and PageSetup.FitToPagesTall properties control how the worksheet is scaled.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


CompressionType Property

Aspose.Cells for .NET

OoxmlSaveOptions.CompressionType Property

Gets and sets the compression type for ooxml file.

public OoxmlCompressionType CompressionType {get; set;}

Remarks

The default value is OoxmlCompressionType.Level2.

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


EmbedOoxmlAsOleObject Property

Aspose.Cells for .NET

OoxmlSaveOptions.EmbedOoxmlAsOleObject Property

Indicates whether embedding Ooxml files of OleObject as ole object.

public bool EmbedOoxmlAsOleObject {get; set;}

Remarks

Only for OleObject.

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


EnableZip64 Property

Aspose.Cells for .NET

OoxmlSaveOptions.EnableZip64 Property

Always use ZIP64 extensions when writing zip archives, even when unnecessary.

public bool EnableZip64 {get; set;}

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


ExportCellName Property

Aspose.Cells for .NET

OoxmlSaveOptions.ExportCellName Property

Indicates if export cell name to Excel2007 .xlsx (.xlsm, .xltx, .xltm) file. If the output file may be accessed by SQL Server DTS, this value must be true. Setting the value to false will highly increase the performance and reduce the file size when creating large file. Default value is true.

public bool ExportCellName {get; set;}

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


LightCellsDataProvider Property

Aspose.Cells for .NET

OoxmlSaveOptions.LightCellsDataProvider Property

The Data provider to provide cells data for saving workbook in light mode.

public LightCellsDataProvider LightCellsDataProvider {get; set;}

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


UpdateZoom Property

Aspose.Cells for .NET

OoxmlSaveOptions.UpdateZoom Property

Indicates whether update scaling factor before saving the file if the PageSetup.FitToPagesWide and PageSetup.FitToPagesTall properties control how the worksheet is scaled.

public bool UpdateZoom {get; set;}

Remarks

The default value is false for performance.

See Also

OoxmlSaveOptions Class | Aspose.Cells Namespace


OperatorType Enumeration

Represents the operator type of conditional format and data validation.

public enum OperatorType

Members

Member Name | Description | Value
Between | Represents Between operator of conditional format and data validation. | 0
Equal | Represents Equal operator of conditional format and data validation. | 1
GreaterThan | Represents GreaterThan operator of conditional format and data validation. | 2
GreaterOrEqual | Represents GreaterOrEqual operator of conditional format and data validation. | 3
LessThan | Represents LessThan operator of conditional format and data validation. | 4
LessOrEqual | Represents LessOrEqual operator of conditional format and data validation. | 5
None | Represents no comparison. | 6
NotBetween | Represents NotBetween operator of conditional format and data validation. | 7
NotEqual | Represents NotEqual operator of conditional format and data validation. | 8

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Outline Class

Represents an outline on a worksheet.

For a list of all members of this type, see Outline Members.

System.Object
Aspose.Cells.Outline

public class Outline

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Outline Members | Aspose.Cells Namespace


Outline Members

Outline overview

Public Instance Properties

SummaryColumnRight | Indicates if the summary column will be positioned to the right of the detail columns in the outline.
SummaryRowBelow | Indicates if the summary row will be positioned below the detail rows in the outline.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Outline Class | Aspose.Cells Namespace


Outline Properties

The properties of the Outline class are listed below. For a complete list of Outline class members, see the Outline Members topic.

Public Instance Properties

SummaryColumnRight | Indicates if the summary column will be positioned to the right of the detail columns in the outline.
SummaryRowBelow | Indicates if the summary row will be positioned below the detail rows in the outline.

See Also

Outline Class | Aspose.Cells Namespace


SummaryColumnRight Property

Aspose.Cells for .NET

Outline.SummaryColumnRight Property

Indicates if the summary column will be positioned to the right of the detail columns in the outline.

public bool SummaryColumnRight {get; set;}

See Also

Outline Class | Aspose.Cells Namespace


SummaryRowBelow Property

Aspose.Cells for .NET

Outline.SummaryRowBelow Property

Indicates if the summary row will be positioned below the detail rows in the outline.

public bool SummaryRowBelow {get; set;}

See Also

Outline Class | Aspose.Cells Namespace


PageLayoutAlignmentType Enumeration

Enumerates page layout alignment types.

public enum PageLayoutAlignmentType

Members

Member Name | Description | Value
Bottom | Represents bottom page layout alignment. | 0
Center | Represents center page layout alignment. | 1
Left | Represents left page layout alignment. | 2
Right | Represents right page layout alignment. | 3
Top | Represents top page layout alignment. | 4

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PageOrientationType Enumeration

Represents print orientation constants.

public enum PageOrientationType

Members

Member Name | Description | Value
Landscape | Landscape orientation | 0
Portrait | Portrait orientation | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PageSetup Class

Encapsulates the object that represents the page setup description. The PageSetup object contains all page setup options.

For a list of all members of this type, see PageSetup Members.

System.Object
Aspose.Cells.PageSetup

public class PageSetup

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
sheet.PageSetup.PrintArea = "D1:K13";
sheet.PageSetup.PrintTitleRows = "$5:$7";
sheet.PageSetup.PrintTitleColumns = "$A:$B";

[Visual Basic]
sheet.PageSetup.PrintArea = "D1:K13"
sheet.PageSetup.PrintTitleRows = "$5:$7"
sheet.PageSetup.PrintTitleColumns = "$A:$B"

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PageSetup Members | Aspose.Cells Namespace


PageSetup Members

PageSetup overview

Public Instance Properties

BlackAndWhite | Represents if elements of the document will be printed in black and white.
BottomMargin | Represents the size of the bottom margin, in unit of centimeters.
BottomMarginInch | Represents the size of the bottom margin, in unit of inches.
CenterHorizontally | Represent if the sheet is printed centered horizontally.
CenterVertically | Represent if the sheet is printed centered vertically.
FirstPageNumber | Represents the first page number that will be used when this sheet is printed.
FitToPagesTall | Represents the number of pages tall the worksheet will be scaled to when it's printed. The default value is 1.
FitToPagesWide | Represents the number of pages wide the worksheet will be scaled to when it's printed. The default value is 1.
FooterMargin | Represents the distance from the bottom of the page to the footer, in unit of centimeters.
FooterMarginInch | Represents the distance from the bottom of the page to the footer, in unit of inches.
HeaderMargin | Represents the distance from the top of the page to the header, in unit of centimeters.
HeaderMarginInch | Represents the distance from the top of the page to the header, in unit of inches.
IsAutoFirstPageNumber | Indicates whether the first the page number is automatically assigned.
IsAutomaticPaperSize | Indicates whether the paper size is automatic.
IsHFAlignMargins | Indicates whether header and footer margins are aligned with the page margins. If this property is true, the left header and footer will be aligned with the left margin, and the right header and footer will be aligned with the right margin. This option is enabled by default.
IsHFDiffFirst | True means that the header/footer of the first page is different with other pages.
IsHFDiffOddEven | True means that the header/footer of the odd pages is different with odd pages.
IsHFScaleWithDoc | Indicates whether header and footer are scaled with document scaling. Only applies for Excel 2007.
IsPercentScale | If this property is False, the FitToPagesWide and FitToPagesTall properties control how the worksheet is scaled.
LeftMargin | Represents the size of the left margin, in unit of centimeters.
LeftMarginInch | Represents the size of the left margin, in unit of inches.
ODSPageBackground | Gets the background of ODS.
Order | Represents the order that Microsoft Excel uses to number pages when printing a large worksheet.
Orientation | Represents page print orientation.
PaperHeight | Gets the height of the paper in unit of inches , considered page orientation.
PaperSize | Represents the size of the paper.
PaperWidth | Gets the width of the paper in unit of inches, considered page orientation.
PrintArea | Represents the range to be printed.
PrintComments | Represents the way comments are printed with the sheet.
PrintCopies | Get and sets number of copies to print.
PrintDraft | Represents if the sheet will be printed without graphics.
PrintErrors | Specifies the type of print error displayed.
PrinterSettings | Gets and sets the settings of the default printer.
PrintGridlines | Represents if cell gridlines are printed on the page.
PrintHeadings | Represents if row and column headings are printed with this page.
PrintQuality | Represents the print quality.
PrintTitleColumns | Represents the columns that contain the cells to be repeated on the left side of each page.
PrintTitleRows | Represents the rows that contain the cells to be repeated at the top of each page.
RightMargin | Represents the size of the right margin, in unit of centimeters.
RightMarginInch | Represents the size of the right margin, in unit of inches.
TopMargin | Represents the size of the top margin, in unit of centimeters.
TopMarginInch | Represents the size of the top margin, in unit of inches.
Zoom | Represents the scaling factor in percent. It should be between 10 and 400.

Public Instance Methods

ClearHeaderFooter | Clears header and footer setting.
Copy | Copies the setting of the page setup.
CustomPaperSize | Sets the custom paper size, in unit of inches.
Equals (inherited from Object) |
GetCommands | Gets all commands of header or footer.
GetEvenFooter | Gets a script formatting the even footer of an Excel file.
GetEvenHeader | Gets a script formatting the even header of an Excel file.
GetFirstPageFooter | Gets a script formatting the first page footer of an Excel file.
GetFirstPageHeader | Gets a script formatting the first page header of an Excel file.
GetFooter | Gets a script formatting the footer of an Excel file.
GetHashCode (inherited from Object) |
GetHeader | Gets a script formatting the header of an Excel file.
GetPicture | Overloaded. Gets the Picture object of the header / footer.
GetType (inherited from Object) |
SetEvenFooter | Sets a script formatting the even page footer of an Excel file. Only effect in Excel 2007 when IsHFDiffOddEven is true.
SetEvenHeader | Sets a script formatting the even page header of an Excel file. Only effect in Excel 2007 when IsHFDiffOddEven is true.
SetFirstPageFooter | Sets a script formatting the first page footer of an Excel file.
SetFirstPageHeader | Sets a script formatting the first page header of an Excel file. Only effect in Excel 2007 when IsHFDiffFirst is true.
SetFitToPages | Sets the number of pages the worksheet will be scaled to when it's printed.
SetFooter | Sets a script formatting the footer of an Excel file.
SetFooterPicture | Sets an image in the footer of a worksheet.
SetHeader | Sets a script formatting the header of an Excel file.
SetHeaderPicture | Sets an image in the header of a worksheet.
SetPicture | Sets an image in the header/footer of a worksheet.
ToString (inherited from Object) |

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup Properties

The properties of the PageSetup class are listed below. For a complete list of PageSetup class members, see the PageSetup Members topic.

Public Instance Properties

BlackAndWhite | Represents if elements of the document will be printed in black and white.
BottomMargin | Represents the size of the bottom margin, in unit of centimeters.
BottomMarginInch | Represents the size of the bottom margin, in unit of inches.
CenterHorizontally | Represent if the sheet is printed centered horizontally.
CenterVertically | Represent if the sheet is printed centered vertically.
FirstPageNumber | Represents the first page number that will be used when this sheet is printed.
FitToPagesTall | Represents the number of pages tall the worksheet will be scaled to when it's printed. The default value is 1.
FitToPagesWide | Represents the number of pages wide the worksheet will be scaled to when it's printed. The default value is 1.
FooterMargin | Represents the distance from the bottom of the page to the footer, in unit of centimeters.
FooterMarginInch | Represents the distance from the bottom of the page to the footer, in unit of inches.
HeaderMargin | Represents the distance from the top of the page to the header, in unit of centimeters.
HeaderMarginInch | Represents the distance from the top of the page to the header, in unit of inches.
IsAutoFirstPageNumber | Indicates whether the first the page number is automatically assigned.
IsAutomaticPaperSize | Indicates whether the paper size is automatic.
IsHFAlignMargins | Indicates whether header and footer margins are aligned with the page margins. If this property is true, the left header and footer will be aligned with the left margin, and the right header and footer will be aligned with the right margin. This option is enabled by default.
IsHFDiffFirst | True means that the header/footer of the first page is different with other pages.
IsHFDiffOddEven | True means that the header/footer of the odd pages is different with odd pages.
IsHFScaleWithDoc | Indicates whether header and footer are scaled with document scaling. Only applies for Excel 2007.
IsPercentScale | If this property is False, the FitToPagesWide and FitToPagesTall properties control how the worksheet is scaled.
LeftMargin | Represents the size of the left margin, in unit of centimeters.
LeftMarginInch | Represents the size of the left margin, in unit of inches.
ODSPageBackground | Gets the background of ODS.
Order | Represents the order that Microsoft Excel uses to number pages when printing a large worksheet.
Orientation | Represents page print orientation.
PaperHeight | Gets the height of the paper in unit of inches , considered page orientation.
PaperSize | Represents the size of the paper.
PaperWidth | Gets the width of the paper in unit of inches, considered page orientation.
PrintArea | Represents the range to be printed.
PrintComments | Represents the way comments are printed with the sheet.
PrintCopies | Get and sets number of copies to print.
PrintDraft | Represents if the sheet will be printed without graphics.
PrintErrors | Specifies the type of print error displayed.
PrinterSettings | Gets and sets the settings of the default printer.
PrintGridlines | Represents if cell gridlines are printed on the page.
PrintHeadings | Represents if row and column headings are printed with this page.
PrintQuality | Represents the print quality.
PrintTitleColumns | Represents the columns that contain the cells to be repeated on the left side of each page.
PrintTitleRows | Represents the rows that contain the cells to be repeated at the top of each page.
RightMargin | Represents the size of the right margin, in unit of centimeters.
RightMarginInch | Represents the size of the right margin, in unit of inches.
TopMargin | Represents the size of the top margin, in unit of centimeters.
TopMarginInch | Represents the size of the top margin, in unit of inches.
Zoom | Represents the scaling factor in percent. It should be between 10 and 400.

See Also

PageSetup Class | Aspose.Cells Namespace


BlackAndWhite Property

Aspose.Cells for .NET

PageSetup.BlackAndWhite Property

Represents if elements of the document will be printed in black and white.

public bool BlackAndWhite {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


BottomMargin Property

Aspose.Cells for .NET

PageSetup.BottomMargin Property

Represents the size of the bottom margin, in unit of centimeters.

public double BottomMargin {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


BottomMarginInch Property

Aspose.Cells for .NET

PageSetup.BottomMarginInch Property

Represents the size of the bottom margin, in unit of inches.

public double BottomMarginInch {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


CenterHorizontally Property

Aspose.Cells for .NET

PageSetup.CenterHorizontally Property

Represent if the sheet is printed centered horizontally.

public bool CenterHorizontally {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


CenterVertically Property

Aspose.Cells for .NET

PageSetup.CenterVertically Property

Represent if the sheet is printed centered vertically.

public bool CenterVertically {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


FirstPageNumber Property

Aspose.Cells for .NET

PageSetup.FirstPageNumber Property

Represents the first page number that will be used when this sheet is printed.

public int FirstPageNumber {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


FitToPagesTall Property

Aspose.Cells for .NET

PageSetup.FitToPagesTall Property

Represents the number of pages tall the worksheet will be scaled to when it's printed. The default value is 1.

public int FitToPagesTall {get; set;}

Remarks

You have to set FitToPagesWide as zero if you want to fit all rows on one page.

See Also

PageSetup Class | Aspose.Cells Namespace


FitToPagesWide Property

Aspose.Cells for .NET

PageSetup.FitToPagesWide Property

Represents the number of pages wide the worksheet will be scaled to when it's printed. The default value is 1.

public int FitToPagesWide {get; set;}

Remarks

You have to set FitToPagesTall as zero if you want to fit all columns on one page.

See Also

PageSetup Class | Aspose.Cells Namespace


FooterMargin Property

Aspose.Cells for .NET

PageSetup.FooterMargin Property

Represents the distance from the bottom of the page to the footer, in unit of centimeters.

public double FooterMargin {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


FooterMarginInch Property

Aspose.Cells for .NET

PageSetup.FooterMarginInch Property

Represents the distance from the bottom of the page to the footer, in unit of inches.

public double FooterMarginInch {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


HeaderMargin Property

Aspose.Cells for .NET

PageSetup.HeaderMargin Property

Represents the distance from the top of the page to the header, in unit of centimeters.

public double HeaderMargin {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


HeaderMarginInch Property

Aspose.Cells for .NET

PageSetup.HeaderMarginInch Property

Represents the distance from the top of the page to the header, in unit of inches.

public double HeaderMarginInch {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsAutoFirstPageNumber Property

Aspose.Cells for .NET

PageSetup.IsAutoFirstPageNumber Property

Indicates whether the first the page number is automatically assigned.

public bool IsAutoFirstPageNumber {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsAutomaticPaperSize Property

Aspose.Cells for .NET

PageSetup.IsAutomaticPaperSize Property

Indicates whether the paper size is automatic.

public bool IsAutomaticPaperSize {get;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsHFAlignMargins Property

Aspose.Cells for .NET

PageSetup.IsHFAlignMargins Property

Indicates whether header and footer margins are aligned with the page margins. If this property is true, the left header and footer will be aligned with the left margin, and the right header and footer will be aligned with the right margin. This option is enabled by default.

public bool IsHFAlignMargins {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsHFDiffFirst Property

Aspose.Cells for .NET

PageSetup.IsHFDiffFirst Property

True means that the header/footer of the first page is different with other pages.

public bool IsHFDiffFirst {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsHFDiffOddEven Property

Aspose.Cells for .NET

PageSetup.IsHFDiffOddEven Property

True means that the header/footer of the odd pages is different with odd pages.

public bool IsHFDiffOddEven {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsHFScaleWithDoc Property

Aspose.Cells for .NET

PageSetup.IsHFScaleWithDoc Property

Indicates whether header and footer are scaled with document scaling. Only applies for Excel 2007.

public bool IsHFScaleWithDoc {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


IsPercentScale Property

Aspose.Cells for .NET

PageSetup.IsPercentScale Property

If this property is False, the FitToPagesWide and FitToPagesTall properties control how the worksheet is scaled.

public bool IsPercentScale {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


LeftMargin Property

Aspose.Cells for .NET

PageSetup.LeftMargin Property

Represents the size of the left margin, in unit of centimeters.

public double LeftMargin {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


LeftMarginInch Property

Aspose.Cells for .NET

PageSetup.LeftMarginInch Property

Represents the size of the left margin, in unit of inches.

public double LeftMarginInch {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


ODSPageBackground Property

Aspose.Cells for .NET

PageSetup.ODSPageBackground Property

Gets the background of ODS.

public OdsPageBackground ODSPageBackground {get;}

See Also

PageSetup Class | Aspose.Cells Namespace


Order Property

Aspose.Cells for .NET

PageSetup.Order Property

Represents the order that Microsoft Excel uses to number pages when printing a large worksheet.

public PrintOrderType Order {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


Orientation Property

Aspose.Cells for .NET

PageSetup.Orientation Property

Represents page print orientation.

public PageOrientationType Orientation {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PaperHeight Property

Aspose.Cells for .NET

PageSetup.PaperHeight Property

Gets the height of the paper in unit of inches , considered page orientation.

public double PaperHeight {get;}

See Also

PageSetup Class | Aspose.Cells Namespace


PaperSize Property

Aspose.Cells for .NET

PageSetup.PaperSize Property

Represents the size of the paper.

public PaperSizeType PaperSize {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PaperWidth Property

Aspose.Cells for .NET

PageSetup.PaperWidth Property

Gets the width of the paper in unit of inches, considered page orientation.

public double PaperWidth {get;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintArea Property

Aspose.Cells for .NET

PageSetup.PrintArea Property

Represents the range to be printed.

public string PrintArea {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintComments Property

Aspose.Cells for .NET

PageSetup.PrintComments Property

Represents the way comments are printed with the sheet.

public PrintCommentsType PrintComments {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintCopies Property

Aspose.Cells for .NET

PageSetup.PrintCopies Property

Get and sets number of copies to print.

public int PrintCopies {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintDraft Property

Aspose.Cells for .NET

PageSetup.PrintDraft Property

Represents if the sheet will be printed without graphics.

public bool PrintDraft {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintErrors Property

Aspose.Cells for .NET

PageSetup.PrintErrors Property

Specifies the type of print error displayed.

public PrintErrorsType PrintErrors {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrinterSettings Property

Aspose.Cells for .NET

PageSetup.PrinterSettings Property

Gets and sets the settings of the default printer.

public byte[] PrinterSettings {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintGridlines Property

Aspose.Cells for .NET

PageSetup.PrintGridlines Property

Represents if cell gridlines are printed on the page.

public bool PrintGridlines {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintHeadings Property

Aspose.Cells for .NET

PageSetup.PrintHeadings Property

Represents if row and column headings are printed with this page.

public bool PrintHeadings {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintQuality Property

Aspose.Cells for .NET

PageSetup.PrintQuality Property

Represents the print quality.

public int PrintQuality {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PrintTitleColumns Property

Aspose.Cells for .NET

PageSetup.PrintTitleColumns Property

Represents the columns that contain the cells to be repeated on the left side of each page.

public string PrintTitleColumns {get; set;}

Example

[C#]

cells.PageSetup.PrintTitleColumns = "$A:$A";

[Visula Basic]

cells.PageSetup.PrintTitleColumns = "$A:$A"

See Also

PageSetup Class | Aspose.Cells Namespace


PrintTitleRows Property

Aspose.Cells for .NET

PageSetup.PrintTitleRows Property

Represents the rows that contain the cells to be repeated at the top of each page.

public string PrintTitleRows {get; set;}

Example

[C#]

cells.PageSetup.PrintTitleRows = "$1:$1";

[Visula Basic]

cells.PageSetup.PrintTitleRows = "$1:$1"

See Also

PageSetup Class | Aspose.Cells Namespace


RightMargin Property

Aspose.Cells for .NET

PageSetup.RightMargin Property

Represents the size of the right margin, in unit of centimeters.

public double RightMargin {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


RightMarginInch Property

Aspose.Cells for .NET

PageSetup.RightMarginInch Property

Represents the size of the right margin, in unit of inches.

public double RightMarginInch {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


TopMargin Property

Aspose.Cells for .NET

PageSetup.TopMargin Property

Represents the size of the top margin, in unit of centimeters.

public double TopMargin {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


TopMarginInch Property

Aspose.Cells for .NET

PageSetup.TopMarginInch Property

Represents the size of the top margin, in unit of inches.

public double TopMarginInch {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


Zoom Property

Aspose.Cells for .NET

PageSetup.Zoom Property

Represents the scaling factor in percent. It should be between 10 and 400.

public int Zoom {get; set;}

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup Methods

The methods of the PageSetup class are listed below. For a complete list of PageSetup class members, see the PageSetup Members topic.

Public Instance Methods

ClearHeaderFooter | Clears header and footer setting.
Copy | Copies the setting of the page setup.
CustomPaperSize | Sets the custom paper size, in unit of inches.
Equals (inherited from Object) |
GetCommands | Gets all commands of header or footer.
GetEvenFooter | Gets a script formatting the even footer of an Excel file.
GetEvenHeader | Gets a script formatting the even header of an Excel file.
GetFirstPageFooter | Gets a script formatting the first page footer of an Excel file.
GetFirstPageHeader | Gets a script formatting the first page header of an Excel file.
GetFooter | Gets a script formatting the footer of an Excel file.
GetHashCode (inherited from Object) |
GetHeader | Gets a script formatting the header of an Excel file.
GetPicture | Overloaded. Gets the Picture object of the header / footer.
GetType (inherited from Object) |
SetEvenFooter | Sets a script formatting the even page footer of an Excel file. Only effect in Excel 2007 when IsHFDiffOddEven is true.
SetEvenHeader | Sets a script formatting the even page header of an Excel file. Only effect in Excel 2007 when IsHFDiffOddEven is true.
SetFirstPageFooter | Sets a script formatting the first page footer of an Excel file.
SetFirstPageHeader | Sets a script formatting the first page header of an Excel file. Only effect in Excel 2007 when IsHFDiffFirst is true.
SetFitToPages | Sets the number of pages the worksheet will be scaled to when it's printed.
SetFooter | Sets a script formatting the footer of an Excel file.
SetFooterPicture | Sets an image in the footer of a worksheet.
SetHeader | Sets a script formatting the header of an Excel file.
SetHeaderPicture | Sets an image in the header of a worksheet.
SetPicture | Sets an image in the header/footer of a worksheet.
ToString (inherited from Object) |

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.ClearHeaderFooter Method

Clears header and footer setting.

public void ClearHeaderFooter();

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.Copy Method

Copies the setting of the page setup.

public void Copy(
PageSetup source,
CopyOptions copyOptions
);

Parameters

source
The source.
copyOptions
The copy options.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.CustomPaperSize Method

Sets the custom paper size, in unit of inches.

public void CustomPaperSize(
double width,
double height
);

Parameters

width
The width of the paper.
height
The height of the paper.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetCommands Method

Gets all commands of header or footer.

public HeaderFooterCommand[] GetCommands(
string headerFooterScript
);

Parameters

headerFooterScript
The header/footer script

Return Value

Returns all commands of header or footer.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetEvenFooter Method

Gets a script formatting the even footer of an Excel file.

public string GetEvenFooter(
int section
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetEvenHeader Method

Gets a script formatting the even header of an Excel file.

public string GetEvenHeader(
int section
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetFirstPageFooter Method

Gets a script formatting the first page footer of an Excel file.

public string GetFirstPageFooter(
int section
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetFirstPageHeader Method

Gets a script formatting the first page header of an Excel file.

public string GetFirstPageHeader(
int section
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetFooter Method

Gets a script formatting the footer of an Excel file.

public string GetFooter(
int section
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetHeader Method

Gets a script formatting the header of an Excel file.

public string GetHeader(
int section
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

See Also

PageSetup Class | Aspose.Cells Namespace


GetPicture Method

Aspose.Cells for .NET

PageSetup.GetPicture Method

Gets the Picture object of the header / footer.

Overload List

Gets the Picture object of the header / footer.

public Picture GetPicture(bool,bool,bool,int);

Gets the Picture object of the header / footer.

public Picture GetPicture(bool,int);

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.GetPicture Method (Boolean, Boolean, Boolean, Int32)

Gets the Picture object of the header / footer.

public Picture GetPicture(
bool isFirst,
bool isEven,
bool isHeader,
int section
);

Parameters

isFirst
Indicates whether getting the picture of first page header/footer.
isEven
Indicates whether getting the picture of even page header/footer.
isHeader
Indicates whether getting the picture of header/footer.
section

0:Left Section.

1:Center Section

2:Right Section

Return Value

Returns Picture object.

See Also

PageSetup Class | Aspose.Cells Namespace | PageSetup.GetPicture Overload List


PageSetup.GetPicture Method (Boolean, Int32)

Gets the Picture object of the header / footer.

public Picture GetPicture(
bool isHeader,
int section
);

Parameters

isHeader
Indicates whether it is in the header or footer.
section

0:Left Section.

1:Center Section

2:Right Section

Return Value

Returns Picture object. Returns null if there is no picture.

See Also

PageSetup Class | Aspose.Cells Namespace | PageSetup.GetPicture Overload List


PageSetup.SetEvenFooter Method

Sets a script formatting the even page footer of an Excel file. Only effect in Excel 2007 when IsHFDiffOddEven is true.

public void SetEvenFooter(
int section,
string footerScript
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

footerScript
Footer format script.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetEvenHeader Method

Sets a script formatting the even page header of an Excel file. Only effect in Excel 2007 when IsHFDiffOddEven is true.

public void SetEvenHeader(
int section,
string headerScript
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

headerScript
Header format script.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetFirstPageFooter Method

Sets a script formatting the first page footer of an Excel file.

public void SetFirstPageFooter(
int section,
string footerScript
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

footerScript
Footer format script.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetFirstPageHeader Method

Sets a script formatting the first page header of an Excel file. Only effect in Excel 2007 when IsHFDiffFirst is true.

public void SetFirstPageHeader(
int section,
string headerScript
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

headerScript
Header format script.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetFitToPages Method

Sets the number of pages the worksheet will be scaled to when it's printed.

public void SetFitToPages(
int wide,
int tall
);

Parameters

wide
Pages wide.
tall
Pages tall.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetFooter Method

Sets a script formatting the footer of an Excel file.

public void SetFooter(
int section,
string footerScript
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

footerScript
Footer format script.

Remarks

Script commands:

Command¡¡ | Description¡¡
&P | Current page number¡¡
&N | Page count¡¡
&D | Current date¡¡
&T | Current time
&A | Sheet name
&F | File name without path
&"<FontName>" | Font name, for example: &"Arial"
&"<FontName>, <FontStyle>" | Font name and font style, for example: &"Arial,Bold"
&<FontSize> | Font size. If this command is followed by a plain number to be printed in the header, it will be separated from the font height with a space character.
&G | Image script
For example: "&Arial,Bold&8Footer Note"

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetFooterPicture Method

Sets an image in the footer of a worksheet.

public Picture SetFooterPicture(
int section,
byte[] footerPicture
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

footerPicture
Image data.

Return Value

Returns Picture object.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetHeader Method

Sets a script formatting the header of an Excel file.

public void SetHeader(
int section,
string headerScript
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

headerScript
Header format script.

Remarks

Script commands:

Command ¡¡ | Description ¡¡
&P | Current page number¡¡
&N | Page count¡¡
&D | Current date¡¡
&T | Current time
&A | Sheet name
&F | File name without path
&"<FontName>" | Font name, for example: &"Arial"
&"<FontName>, <FontStyle>" | Font name and font style, for example: &"Arial,Bold"
&<FontSize> | Font size. If this command is followed by a plain number to be printed in the header, it will be separated from the font height with a space character.
&"<K" | Font color, for example(RED): &FF0000
&G | Image script
For example: "&Arial,Bold&8Header Note"

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetHeaderPicture Method

Sets an image in the header of a worksheet.

public Picture SetHeaderPicture(
int section,
byte[] headerPicture
);

Parameters

section

0:Left Section.

1:Center Section

2:Right Section

headerPicture
Image data.

Return Value

Returns Picture object.

See Also

PageSetup Class | Aspose.Cells Namespace


PageSetup.SetPicture Method

Sets an image in the header/footer of a worksheet.

public Picture SetPicture(
bool isFirst,
bool isEven,
bool isHeader,
int section,
byte[] imageData
);

Parameters

isFirst
Indicates whether setting the picture of first page header/footer.
isEven
Indicates whether setting the picture of even page header/footer.
isHeader
Indicates whether setting the picture of header/footer.
section

0:Left Section.

1:Center Section

2:Right Section

imageData
Image data.

Return Value

Returns Picture object.

See Also

PageSetup Class | Aspose.Cells Namespace


PaneCollection Class

Represents all Pane objects shown in the specified window.

For a list of all members of this type, see PaneCollection Members.

System.Object
Aspose.Cells.PaneCollection

public class PaneCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PaneCollection Members | Aspose.Cells Namespace


PaneCollection Members

PaneCollection overview

Public Instance Properties

AcitvePaneType | Gets and sets the active pane.
FirstVisibleColumnOfRightPane | Gets and sets the first visible column of the right pane.
FirstVisibleRowOfBottomPane | Gets and sets the first visible row of the bottom pane.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PaneCollection Class | Aspose.Cells Namespace


PaneCollection Properties

The properties of the PaneCollection class are listed below. For a complete list of PaneCollection class members, see the PaneCollection Members topic.

Public Instance Properties

AcitvePaneType | Gets and sets the active pane.
FirstVisibleColumnOfRightPane | Gets and sets the first visible column of the right pane.
FirstVisibleRowOfBottomPane | Gets and sets the first visible row of the bottom pane.

See Also

PaneCollection Class | Aspose.Cells Namespace


AcitvePaneType Property

Aspose.Cells for .NET

PaneCollection.AcitvePaneType Property

Gets and sets the active pane.

public RectangleAlignmentType AcitvePaneType {get; set;}

See Also

PaneCollection Class | Aspose.Cells Namespace


FirstVisibleColumnOfRightPane Property

Aspose.Cells for .NET

PaneCollection.FirstVisibleColumnOfRightPane Property

Gets and sets the first visible column of the right pane.

public int FirstVisibleColumnOfRightPane {get; set;}

See Also

PaneCollection Class | Aspose.Cells Namespace


FirstVisibleRowOfBottomPane Property

Aspose.Cells for .NET

PaneCollection.FirstVisibleRowOfBottomPane Property

Gets and sets the first visible row of the bottom pane.

public int FirstVisibleRowOfBottomPane {get; set;}

See Also

PaneCollection Class | Aspose.Cells Namespace


PaneStateType Enumeration

Represents state of the sheet's pane.

public enum PaneStateType

Members

Member Name | Description | Value
Frozen | Panes are frozen, but were not before being frozen. | 0
FrozenSplit | Panes are frozen and were split before being frozen. | 1
Split | Panes are split, but not frozen. | 2
Normal | Panes are not frozen and not split. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PaperSizeType Enumeration

Represents paper size constants.

public enum PaperSizeType

Members

Member Name | Description | Value
PaperLetter | Letter (8-1/2 in. x 11 in.) | 1
PaperLetterSmall | Letter Small (8-1/2 in. x 11 in.) | 2
PaperTabloid | Tabloid (11 in. x 17 in.) | 3
PaperLedger | Ledger (17 in. x 11 in.) | 4
PaperLegal | Legal (8-1/2 in. x 14 in.) | 5
PaperStatement | Statement (5-1/2 in. x 8-1/2 in.) | 6
PaperExecutive | Executive (7-1/4 in. x 10-1/2 in.) | 7
PaperA3 | A3 (297 mm x 420 mm) | 8
PaperA4 | A4 (210 mm x 297 mm) | 9
PaperA4Small | A4 Small (210 mm x 297 mm) | 10
PaperA5 | A5 (148 mm x 210 mm) | 11
PaperB4 | JIS B4 (257 mm x 364 mm) | 12
PaperB5 | JIS B5 (182 mm x 257 mm) | 13
PaperFolio | Folio (8-1/2 in. x 13 in.) | 14
PaperQuarto | Quarto (215 mm x 275 mm) | 15
Paper10x14 | 10 in. x 14 in. | 16
Paper11x17 | 11 in. x 17 in. | 17
PaperNote | Note (8-1/2 in. x 11 in.) | 18
PaperEnvelope9 | Envelope #9 (3-7/8 in. x 8-7/8 in.) | 19
PaperEnvelope10 | Envelope #10 (4-1/8 in. x 9-1/2 in.) | 20
PaperEnvelope11 | Envelope #11 (4-1/2 in. x 10-3/8 in.) | 21
PaperEnvelope12 | Envelope #12 (4-1/2 in. x 11 in.) | 22
PaperEnvelope14 | Envelope #14 (5 in. x 11-1/2 in.) | 23
PaperCSheet | C size sheet | 24
PaperDSheet | D size sheet | 25
PaperESheet | E size sheet | 26
PaperEnvelopeDL | Envelope DL (110 mm x 220 mm) | 27
PaperEnvelopeC5 | Envelope C5 (162 mm x 229 mm) | 28
PaperEnvelopeC3 | Envelope C3 (324 mm x 458 mm) | 29
PaperEnvelopeC4 | Envelope C4 (229 mm x 324 mm) | 30
PaperEnvelopeC6 | Envelope C6 (114 mm x 162 mm) | 31
PaperEnvelopeC65 | Envelope C65 (114 mm x 229 mm) | 32
PaperEnvelopeB4 | Envelope B4 (250 mm x 353 mm) | 33
PaperEnvelopeB5 | Envelope B5 (176 mm x 250 mm) | 34
PaperEnvelopeB6 | Envelope B6 (176 mm x 125 mm) | 35
PaperEnvelopeItaly | Envelope Italy (110 mm x 230 mm) | 36
PaperEnvelopeMonarch | Envelope Monarch (3-7/8 in. x 7-1/2 in.) | 37
PaperEnvelopePersonal | Envelope (3-5/8 in. x 6-1/2 in.) | 38
PaperFanfoldUS | U.S. Standard Fanfold (14-7/8 in. x 11 in.) | 39
PaperFanfoldStdGerman | German Standard Fanfold (8-1/2 in. x 12 in.) | 40
PaperFanfoldLegalGerman | German Legal Fanfold (8-1/2 in. x 13 in.) | 41
PaperISOB4 | B4 (ISO) 250 x 353 mm | 42
PaperJapanesePostcard | Japanese Postcard (100mm ¡Á 148mm) | 43
Paper9x11 | 9? ¡Á 11? | 44
Paper10x11 | 10? ¡Á 11? | 45
Paper15x11 | 15? ¡Á 11? | 46
PaperEnvelopeInvite | Envelope Invite(220mm ¡Á 220mm) | 47
PaperLetterExtra | US Letter Extra 9 \275 x 12 in | 50
PaperLegalExtra | US Legal Extra 9 \275 x 15 in | 51
PaperTabloidExtra | US Tabloid Extra 11.69 x 18 in | 52
PaperA4Extra | A4 Extra 9.27 x 12.69 in | 53
PaperLetterTransverse | Letter Transverse 8 \275 x 11 in | 54
PaperA4Transverse | A4 Transverse 210 x 297 mm | 55
PaperLetterExtraTransverse | Letter Extra Transverse 9\275 x 12 in | 56
PaperSuperA | SuperA/SuperA/A4 227 x 356 mm | 57
PaperSuperB | SuperB/SuperB/A3 305 x 487 mm | 58
PaperLetterPlus | US Letter Plus 8.5 x 12.69 in | 59
PaperA4Plus | A4 Plus 210 x 330 mm | 60
PaperA5Transverse | A5 Transverse 148 x 210 mm | 61
PaperJISB5Transverse | B5 (JIS) Transverse 182 x 257 mm | 62
PaperA3Extra | A3 Extra 322 x 445 mm | 63
PaperA5Extra | A5 Extra 174 x 235 mm | 64
PaperISOB5Extra | B5 (ISO) Extra 201 x 276 mm | 65
PaperA2 | A2 420 x 594 mm | 66
PaperA3Transverse | A3 Transverse 297 x 420 mm | 67
PaperA3ExtraTransverse | A3 Extra Transverse 322 x 445 mm | 68
PaperJapaneseDoublePostcard | Japanese Double Postcard 200 x 148 mm | 69
PaperA6 | A6 105 x 148 mm | 70
PaperJapaneseEnvelopeKaku2 | Japanese Envelope Kaku #2 | 71
PaperJapaneseEnvelopeKaku3 | Japanese Envelope Kaku #3 | 72
PaperJapaneseEnvelopeChou3 | Japanese Envelope Chou #3 | 73
PaperJapaneseEnvelopeChou4 | Japanese Envelope Chou #4 | 74
PaperLetterRotated | 11in ¡Á 8.5in | 75
PaperA3Rotated | 420mm ¡Á 297mm | 76
PaperA4Rotated | 297mm ¡Á 210mm | 77
PaperA5Rotated | 210mm ¡Á 148mm | 78
PaperJISB4Rotated | B4 (JIS) Rotated 364 x 257 mm | 79
PaperJISB5Rotated | B5 (JIS) Rotated 257 x 182 mm | 80
PaperJapanesePostcardRotated | Japanese Postcard Rotated 148 x 100 mm | 81
PaperJapaneseDoublePostcardRotated | Double Japanese Postcard Rotated 148 x 200 mm | 82
PaperA6Rotated | A6 Rotated 148 x 105 mm | 83
PaperJapaneseEnvelopeKaku2Rotated | Japanese Envelope Kaku #2 Rotated | 84
PaperJapaneseEnvelopeKaku3Rotated | Japanese Envelope Kaku #3 Rotated | 85
PaperJapaneseEnvelopeChou3Rotated | Japanese Envelope Chou #3 Rotated | 86
PaperJapaneseEnvelopeChou4Rotated | Japanese Envelope Chou #4 Rotated | 87
PaperJISB6 | B6 (JIS) 128 x 182 mm | 88
PaperJISB6Rotated | B6 (JIS) Rotated 182 x 128 mm | 89
Paper12x11 | 12 x 11 in | 90
PaperJapaneseEnvelopeYou4 | Japanese Envelope You #4 | 91
PaperJapaneseEnvelopeYou4Rotated | Japanese Envelope You #4 Rotated | 92
PaperPRC16K | PRC 16K 146 x 215 mm | 93
PaperPRC32K | PRC 32K 97 x 151 mm | 94
PaperPRCBig32K | PRC 32K(Big) 97 x 151 mm | 95
PaperPRCEnvelope1 | PRC Envelope #1 102 x 165 mm | 96
PaperPRCEnvelope2 | PRC Envelope #2 102 x 176 mm | 97
PaperPRCEnvelope3 | PRC Envelope #3 125 x 176 mm | 98
PaperPRCEnvelope4 | PRC Envelope #4 110 x 208 mm | 99
PaperPRCEnvelope5 | PRC Envelope #5 110 x 220 mm | 100
PaperPRCEnvelope6 | PRC Envelope #6 120 x 230 mm | 101
PaperPRCEnvelope7 | PRC Envelope #7 160 x 230 mm | 102
PaperPRCEnvelope8 | PRC Envelope #8 120 x 309 mm | 103
PaperPRCEnvelope9 | PRC Envelope #9 229 x 324 mm | 104
PaperPRCEnvelope10 | PRC Envelope #10 324 x 458 mm | 105
PaperPRC16KRotated | PRC 16K Rotated | 106
PaperPRC32KRotated | PRC 32K Rotated | 107
PaperPRCBig32KRotated | PRC 32K(Big) Rotated | 108
PaperPRCEnvelope1Rotated | PRC Envelope #1 Rotated 165 x 102 mm | 109
PaperPRCEnvelope2Rotated | PRC Envelope #2 Rotated 176 x 102 mm | 110
PaperPRCEnvelope3Rotated | PRC Envelope #3 Rotated 176 x 125 mm | 111
PaperPRCEnvelope4Rotated | PRC Envelope #4 Rotated 208 x 110 mm | 112
PaperPRCEnvelope5Rotated | PRC Envelope #5 Rotated 220 x 110 mm | 113
PaperPRCEnvelope6Rotated | PRC Envelope #6 Rotated 230 x 120 mm | 114
PaperPRCEnvelope7Rotated | PRC Envelope #7 Rotated 230 x 160 mm | 115
PaperPRCEnvelope8Rotated | PRC Envelope #8 Rotated 309 x 120 mm | 116
PaperPRCEnvelope9Rotated | PRC Envelope #9 Rotated 324 x 229 mm | 117
PaperPRCEnvelope10Rotated | PRC Envelope #10 Rotated 458 x 324 mm | 118
PaperB3 | usual B3(13.9 x 19.7 in) | 300
PaperBusinessCard | Business Card(90mm x 55 mm) | 301
PaperThermal | Thermal(3 x 11 in) | 302
Custom | Represents the custom paper size. | 0

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ParameterType Enumeration

Represents all parameters' type or return value type of function.

public enum ParameterType

Members

Member Name | Description | Value
Reference |  | 0
Value |  | 1
Array |  | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PasteOptions Class

Represents the paste special options.

For a list of all members of this type, see PasteOptions Members.

System.Object
Aspose.Cells.PasteOptions

public class PasteOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PasteOptions Members | Aspose.Cells Namespace


PasteOptions Members

PasteOptions overview

Public Instance Constructors

PasteOptions Constructor Initializes a new instance of the PasteOptions class.

Public Instance Properties

OnlyVisibleCells | True means only copying visible cells.
PasteType | The paste special type.
SkipBlanks | Indicates whether skips blank cells.
Transpose | True to transpose rows and columns when the range is pasted. The default value is False.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PasteOptions Class | Aspose.Cells Namespace


PasteOptions Constructor

Initializes a new instance of the PasteOptions class.

public PasteOptions();

See Also

PasteOptions Class | Aspose.Cells Namespace


PasteOptions Properties

The properties of the PasteOptions class are listed below. For a complete list of PasteOptions class members, see the PasteOptions Members topic.

Public Instance Properties

OnlyVisibleCells | True means only copying visible cells.
PasteType | The paste special type.
SkipBlanks | Indicates whether skips blank cells.
Transpose | True to transpose rows and columns when the range is pasted. The default value is False.

See Also

PasteOptions Class | Aspose.Cells Namespace


OnlyVisibleCells Property

Aspose.Cells for .NET

PasteOptions.OnlyVisibleCells Property

True means only copying visible cells.

public bool OnlyVisibleCells {get; set;}

See Also

PasteOptions Class | Aspose.Cells Namespace


PasteType Property

Aspose.Cells for .NET

PasteOptions.PasteType Property

The paste special type.

public PasteType PasteType {get; set;}

See Also

PasteOptions Class | Aspose.Cells Namespace


SkipBlanks Property

Aspose.Cells for .NET

PasteOptions.SkipBlanks Property

Indicates whether skips blank cells.

public bool SkipBlanks {get; set;}

See Also

PasteOptions Class | Aspose.Cells Namespace


Transpose Property

Aspose.Cells for .NET

PasteOptions.Transpose Property

True to transpose rows and columns when the range is pasted. The default value is False.

public bool Transpose {get; set;}

See Also

PasteOptions Class | Aspose.Cells Namespace


PasteType Enumeration

Represents the paste special type.

public enum PasteType

Members

Member Name | Description | Value
All | Copies all data of the range. | 0
Default | It works as "All" behavior of MS Excel. | 1
AllExceptBorders | Copies all data of the range without the range. | 2
DefaultExceptBorders | It works as "All except borders" behavior of MS Excel. | 3
ColumnWidths | Only copies the widths of the range. | 4
RowHeights | Only copies the heights of the range. | 5
Comments |  | 6
Formats |  | 7
Formulas |  | 8
FormulasAndNumberFormats |  | 9
Validation |  | 10
Values |  | 11
ValuesAndNumberFormats |  | 12

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PdfSaveOptions Class

Represents the options for saving pdf file.

For a list of all members of this type, see PdfSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.PdfSaveOptions

public class PdfSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PdfSaveOptions Members | Aspose.Cells Namespace


PdfSaveOptions Members

PdfSaveOptions overview

Public Instance Constructors

PdfSaveOptions Overloaded. Initializes a new instance of the PdfSaveOptions class.

Public Instance Properties

AllColumnsInOnePagePerSheet | If AllColumnsInOnePagePerSheet is true , all column content of one sheet will output to only one page in result. The width of paper size of pagesetup will be ignored, and the other settings of pagesetup will still take effect.
Bookmark | Gets and sets the PdfBookmarkEntry object.
CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
CalculateFormula | Indicates whether calculate formulas before saving pdf file.
CheckFontCompatibility | Indicates whether check font compatibility for every character in text.
CheckWorkbookDefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set this to true to try to use workbook's default font to show these characters first.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
Compliance | Workbook converts to pdf will according to PdfCompliance in this property.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
CreatedTime | Gets and sets the time of generating the pdf document.
CustomPropertiesExport | Gets or sets a value determining the way CustomDocumentPropertyCollection are exported to PDF file. Default value is None.
DefaultEditLanguage | Gets or sets default edit language.
DefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set the DefaultFont such as MingLiu or MS Gothic to show these characters. If this property is not set, Aspose.Cells will use system default font to show these unicode characters.
DisplayDocTitle | Indicate whether the window's title bar should display the document title.
DrawObjectEventHandler | Implements this interface to get DrawObject and Bound when rendering.
EmbedStandardWindowsFonts | True to embed true type fonts. Affects only ASCII characters 32-127. Fonts for character codes greater than 127 are always embedded. PDFA1B must embedded font. Default is true.
EmfRenderSetting | Setting for rendering Emf metafile.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ExportDocumentStructure | Gets or sets a value determining whether or not to export document structure.
GridlineType | Gets or sets gridline type.
IgnoreError | Indicates if you need to hide the error while rendering. The error can be error in shape, image, chart rendering, etc.
ImageType | Represents the image type when converting the chart and shape .
IsFontSubstitutionCharGranularity | Indicates whether only substitute the font of character when the cell font is not compatibility for it.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
OnePagePerSheet | If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
OptimizationType | Gets and sets pdf optimization type.
OutputBlankPageWhenNothingToPrint | Indicates whether to output a blank page when there is nothing to print.
PageCount | Gets or sets the number of pages to save.
PageIndex | Gets or sets the 0-based index of the first page to save.
PageSavingCallback | Control/Indicate progress of page saving process.
PdfCompression | Indicate the compression algorithm
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
PrintingPageType | Indicates which pages will not be printed.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SecurityOptions | Set this options, when security is need in xls2pdf result.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
StreamProvider | Obsolete. Gets or sets the IStreamProvider for exporting objects.
TextCrossType | Gets or sets displaying text type when the text width is larger than cell width.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetImageResample | Sets desired PPI(pixels per inch) of resample images and jpeg quality All images will be converted to JPEG with the specified quality setting, and images that are greater than the specified PPI (pixels per inch) will be resampled.
ToString (inherited from Object) |

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PdfSaveOptions Constructor

Creates the options for saving pdf file.

Overload List

Creates the options for saving pdf file.

public PdfSaveOptions();

Creates the options for saving pdf file.

public PdfSaveOptions(SaveFormat);

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PdfSaveOptions Constructor ()

Creates the options for saving pdf file.

public PdfSaveOptions();

See Also

PdfSaveOptions Class | Aspose.Cells Namespace | PdfSaveOptions Constructor Overload List


PdfSaveOptions Constructor (SaveFormat)

Creates the options for saving pdf file.

public PdfSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The save format.It must be pdf.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace | PdfSaveOptions Constructor Overload List


PdfSaveOptions Properties

The properties of the PdfSaveOptions class are listed below. For a complete list of PdfSaveOptions class members, see the PdfSaveOptions Members topic.

Public Instance Properties

AllColumnsInOnePagePerSheet | If AllColumnsInOnePagePerSheet is true , all column content of one sheet will output to only one page in result. The width of paper size of pagesetup will be ignored, and the other settings of pagesetup will still take effect.
Bookmark | Gets and sets the PdfBookmarkEntry object.
CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
CalculateFormula | Indicates whether calculate formulas before saving pdf file.
CheckFontCompatibility | Indicates whether check font compatibility for every character in text.
CheckWorkbookDefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set this to true to try to use workbook's default font to show these characters first.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
Compliance | Workbook converts to pdf will according to PdfCompliance in this property.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
CreatedTime | Gets and sets the time of generating the pdf document.
CustomPropertiesExport | Gets or sets a value determining the way CustomDocumentPropertyCollection are exported to PDF file. Default value is None.
DefaultEditLanguage | Gets or sets default edit language.
DefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set the DefaultFont such as MingLiu or MS Gothic to show these characters. If this property is not set, Aspose.Cells will use system default font to show these unicode characters.
DisplayDocTitle | Indicate whether the window's title bar should display the document title.
DrawObjectEventHandler | Implements this interface to get DrawObject and Bound when rendering.
EmbedStandardWindowsFonts | True to embed true type fonts. Affects only ASCII characters 32-127. Fonts for character codes greater than 127 are always embedded. PDFA1B must embedded font. Default is true.
EmfRenderSetting | Setting for rendering Emf metafile.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ExportDocumentStructure | Gets or sets a value determining whether or not to export document structure.
GridlineType | Gets or sets gridline type.
IgnoreError | Indicates if you need to hide the error while rendering. The error can be error in shape, image, chart rendering, etc.
ImageType | Represents the image type when converting the chart and shape .
IsFontSubstitutionCharGranularity | Indicates whether only substitute the font of character when the cell font is not compatibility for it.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
OnePagePerSheet | If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
OptimizationType | Gets and sets pdf optimization type.
OutputBlankPageWhenNothingToPrint | Indicates whether to output a blank page when there is nothing to print.
PageCount | Gets or sets the number of pages to save.
PageIndex | Gets or sets the 0-based index of the first page to save.
PageSavingCallback | Control/Indicate progress of page saving process.
PdfCompression | Indicate the compression algorithm
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
PrintingPageType | Indicates which pages will not be printed.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SecurityOptions | Set this options, when security is need in xls2pdf result.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
StreamProvider | Obsolete. Gets or sets the IStreamProvider for exporting objects.
TextCrossType | Gets or sets displaying text type when the text width is larger than cell width.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


AllColumnsInOnePagePerSheet Property

Aspose.Cells for .NET

PdfSaveOptions.AllColumnsInOnePagePerSheet Property

If AllColumnsInOnePagePerSheet is true , all column content of one sheet will output to only one page in result. The width of paper size of pagesetup will be ignored, and the other settings of pagesetup will still take effect.

public bool AllColumnsInOnePagePerSheet {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


Bookmark Property

Aspose.Cells for .NET

PdfSaveOptions.Bookmark Property

Gets and sets the PdfBookmarkEntry object.

public PdfBookmarkEntry Bookmark {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


CalculateFormula Property

Aspose.Cells for .NET

PdfSaveOptions.CalculateFormula Property

Indicates whether calculate formulas before saving pdf file.

public bool CalculateFormula {get; set;}

Remarks

The default value is false.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


CheckFontCompatibility Property

Aspose.Cells for .NET

PdfSaveOptions.CheckFontCompatibility Property

Indicates whether check font compatibility for every character in text.

public bool CheckFontCompatibility {get; set;}

Remarks

The default value is true. Disable this property may give better performance. But when the default or specified font of text/character cannot be used to render it, unreadable characters(such as block) maybe occur in the generated pdf. For such situation user should keep this property as true so that alternative font can be searched and used to render the text instead;

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


CheckWorkbookDefaultFont Property

Aspose.Cells for .NET

PdfSaveOptions.CheckWorkbookDefaultFont Property

When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set this to true to try to use workbook's default font to show these characters first.

public bool CheckWorkbookDefaultFont {get; set;}

Remarks

Default is true.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


Compliance Property

Aspose.Cells for .NET

PdfSaveOptions.Compliance Property

Workbook converts to pdf will according to PdfCompliance in this property.

public PdfCompliance Compliance {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


CreatedTime Property

Aspose.Cells for .NET

PdfSaveOptions.CreatedTime Property

Gets and sets the time of generating the pdf document.

public DateTime CreatedTime {get; set;}

Remarks

if it is not be set, it will be the time of generating the pdf.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


CustomPropertiesExport Property

Aspose.Cells for .NET

PdfSaveOptions.CustomPropertiesExport Property

Gets or sets a value determining the way CustomDocumentPropertyCollection are exported to PDF file. Default value is None.

public PdfCustomPropertiesExport CustomPropertiesExport {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


DefaultEditLanguage Property

Aspose.Cells for .NET

PdfSaveOptions.DefaultEditLanguage Property

Gets or sets default edit language.

public DefaultEditLanguage DefaultEditLanguage {get; set;}

Remarks

It may display/render different layouts for text paragraph when different edit languages is set. Default is Auto.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


DefaultFont Property

Aspose.Cells for .NET

PdfSaveOptions.DefaultFont Property

When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set the DefaultFont such as MingLiu or MS Gothic to show these characters. If this property is not set, Aspose.Cells will use system default font to show these unicode characters.

public string DefaultFont {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


DisplayDocTitle Property

Aspose.Cells for .NET

PdfSaveOptions.DisplayDocTitle Property

Indicate whether the window's title bar should display the document title.

public bool DisplayDocTitle {get; set;}

Remarks

If false, the title bar should instead display the name of the PDF file. Default value is false.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


DrawObjectEventHandler Property

Aspose.Cells for .NET

PdfSaveOptions.DrawObjectEventHandler Property

Implements this interface to get DrawObject and Bound when rendering.

public DrawObjectEventHandler DrawObjectEventHandler {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


EmbedStandardWindowsFonts Property

Aspose.Cells for .NET

PdfSaveOptions.EmbedStandardWindowsFonts Property

True to embed true type fonts. Affects only ASCII characters 32-127. Fonts for character codes greater than 127 are always embedded. PDFA1B must embedded font. Default is true.

public bool EmbedStandardWindowsFonts {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


EmfRenderSetting Property

Aspose.Cells for .NET

PdfSaveOptions.EmfRenderSetting Property

Setting for rendering Emf metafile.

public EmfRenderSetting EmfRenderSetting {get; set;}

Remarks

EMF metafiles identified as "EMF+ Dual" can contain both EMF+ records and EMF records. Either type of record can be used to render the image, only EMF+ records, or only EMF records. When EmfPlusPrefer is set, then EMF+ records will be parsed while rendering to pdf, otherwise only EMF records will be parsed. Default value is EmfOnly.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


ExportDocumentStructure Property

Aspose.Cells for .NET

PdfSaveOptions.ExportDocumentStructure Property

Gets or sets a value determining whether or not to export document structure.

public bool ExportDocumentStructure {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


GridlineType Property

Aspose.Cells for .NET

PdfSaveOptions.GridlineType Property

Gets or sets gridline type.

public GridlineType GridlineType {get; set;}

Remarks

Default is Dotted type.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


IgnoreError Property

Aspose.Cells for .NET

PdfSaveOptions.IgnoreError Property

Indicates if you need to hide the error while rendering. The error can be error in shape, image, chart rendering, etc.

public bool IgnoreError {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


ImageType Property

Aspose.Cells for .NET

PdfSaveOptions.ImageType Property

Represents the image type when converting the chart and shape .

public ImageFormat ImageType {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


IsFontSubstitutionCharGranularity Property

Aspose.Cells for .NET

PdfSaveOptions.IsFontSubstitutionCharGranularity Property

Indicates whether only substitute the font of character when the cell font is not compatibility for it.

public bool IsFontSubstitutionCharGranularity {get; set;}

Remarks

Default is false. We will try default font of Workbook and PdfSaveOption/system for cell font first.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


OnePagePerSheet Property

Aspose.Cells for .NET

PdfSaveOptions.OnePagePerSheet Property

If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.

public bool OnePagePerSheet {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


OptimizationType Property

Aspose.Cells for .NET

PdfSaveOptions.OptimizationType Property

Gets and sets pdf optimization type.

public PdfOptimizationType OptimizationType {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


OutputBlankPageWhenNothingToPrint Property

Aspose.Cells for .NET

PdfSaveOptions.OutputBlankPageWhenNothingToPrint Property

Indicates whether to output a blank page when there is nothing to print.

public bool OutputBlankPageWhenNothingToPrint {get; set;}

Remarks

Default is true.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PageCount Property

Aspose.Cells for .NET

PdfSaveOptions.PageCount Property

Gets or sets the number of pages to save.

public int PageCount {get; set;}

Remarks

Default is System.Int32.MaxValue which means all pages will be rendered..

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PageIndex Property

Aspose.Cells for .NET

PdfSaveOptions.PageIndex Property

Gets or sets the 0-based index of the first page to save.

public int PageIndex {get; set;}

Remarks

Default is 0.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PageSavingCallback Property

Aspose.Cells for .NET

PdfSaveOptions.PageSavingCallback Property

Control/Indicate progress of page saving process.

public IPageSavingCallback PageSavingCallback {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PdfCompression Property

Aspose.Cells for .NET

PdfSaveOptions.PdfCompression Property

Indicate the compression algorithm

public PdfCompressionCore PdfCompression {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PrintingPageType Property

Aspose.Cells for .NET

PdfSaveOptions.PrintingPageType Property

Indicates which pages will not be printed.

public PrintingPageType PrintingPageType {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


SecurityOptions Property

Aspose.Cells for .NET

PdfSaveOptions.SecurityOptions Property

Set this options, when security is need in xls2pdf result.

public PdfSecurityOptions SecurityOptions {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


StreamProvider Property

Aspose.Cells for .NET

PdfSaveOptions.StreamProvider Property

NOTE: This property is now obsolete.

Use WorkbookSettings.StreamProvider property instead.

Gets or sets the IStreamProvider for exporting objects.

public IStreamProvider StreamProvider {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Border property. This property will be removed 12 months later since January 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


TextCrossType Property

Aspose.Cells for .NET

PdfSaveOptions.TextCrossType Property

Gets or sets displaying text type when the text width is larger than cell width.

public TextCrossType TextCrossType {get; set;}

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PdfSaveOptions Methods

The methods of the PdfSaveOptions class are listed below. For a complete list of PdfSaveOptions class members, see the PdfSaveOptions Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetImageResample | Sets desired PPI(pixels per inch) of resample images and jpeg quality All images will be converted to JPEG with the specified quality setting, and images that are greater than the specified PPI (pixels per inch) will be resampled.
ToString (inherited from Object) |

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PdfSaveOptions.SetImageResample Method

Sets desired PPI(pixels per inch) of resample images and jpeg quality All images will be converted to JPEG with the specified quality setting, and images that are greater than the specified PPI (pixels per inch) will be resampled.

public void SetImageResample(
int desiredPPI,
int jpegQuality
);

Parameters

desiredPPI
Desired pixels per inch. 220 high quality. 150 screen quality. 96 email quality.
jpegQuality
0 - 100% JPEG quality.

See Also

PdfSaveOptions Class | Aspose.Cells Namespace


PptxSaveOptions Class

Represents the pptx save options.

For a list of all members of this type, see PptxSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.PptxSaveOptions

public class PptxSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PptxSaveOptions Members | Aspose.Cells Namespace


PptxSaveOptions Members

PptxSaveOptions overview

Public Instance Constructors

PptxSaveOptions Constructor Represents the pptx save options.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PptxSaveOptions Class | Aspose.Cells Namespace


PptxSaveOptions Constructor

Represents the pptx save options.

public PptxSaveOptions();

See Also

PptxSaveOptions Class | Aspose.Cells Namespace


PrintCommentsType Enumeration

Represents the way comments are printed with the sheet.

public enum PrintCommentsType

Members

Member Name | Description | Value
PrintInPlace | Represents to print comments as displayed on sheet. | 0
PrintNoComments | Represents not to print comments. | 1
PrintSheetEnd | Represents to print comments at end of sheet. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PrintErrorsType Enumeration

Represents print errors constants.

public enum PrintErrorsType

Members

Member Name | Description | Value
PrintErrorsBlank | Represents not to print errors. | 0
PrintErrorsDash | Represents to print errors as "--". | 1
PrintErrorsDisplayed | Represents to print errors as displayed. | 2
PrintErrorsNA | Represents to print errors as "#N/A". | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PrintingPageType Enumeration

Indicates which pages will not be printed.

public enum PrintingPageType

Members

Member Name | Description | Value
Default | Prints all pages. | 0
IgnoreBlank | Don't print the pages which the cells are blank. | 1
IgnoreStyle | Don't print the pages which cells only contain styles. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PrintOrderType Enumeration

Represent print order constants.

public enum PrintOrderType

Members

Member Name | Description | Value
DownThenOver | Down, then over | 0
OverThenDown | Over, then down | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


PrintSizeType Enumeration

Represents the printed chart size.

public enum PrintSizeType

Members

Member Name | Description | Value
Full | Use full page. | 0
Fit | Scale to fit page. | 1
Custom | Custom. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ProtectedRange Class

A specified range to be allowed to edit when the sheet protection is ON.

For a list of all members of this type, see ProtectedRange Members.

System.Object
Aspose.Cells.ProtectedRange

public class ProtectedRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ProtectedRange Members | Aspose.Cells Namespace


ProtectedRange Members

ProtectedRange overview

Public Instance Properties

CellArea | Gets the CellArea object represents the cell area to be protected.
Name | Gets the Range title. This is used as a descriptor, not as a named range definition.
Password | Represents the password to protect the range.
SecurityDescriptor | The security descriptor defines user accounts who may edit this range without providing a password to access the range.

Public Instance Methods

AddArea | Adds a referred area to this
Equals (inherited from Object) |
GetAreas | Gets all referred areas.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ProtectedRange Class | Aspose.Cells Namespace


ProtectedRange Properties

The properties of the ProtectedRange class are listed below. For a complete list of ProtectedRange class members, see the ProtectedRange Members topic.

Public Instance Properties

CellArea | Gets the CellArea object represents the cell area to be protected.
Name | Gets the Range title. This is used as a descriptor, not as a named range definition.
Password | Represents the password to protect the range.
SecurityDescriptor | The security descriptor defines user accounts who may edit this range without providing a password to access the range.

See Also

ProtectedRange Class | Aspose.Cells Namespace


CellArea Property

Aspose.Cells for .NET

ProtectedRange.CellArea Property

Gets the CellArea object represents the cell area to be protected.

public CellArea CellArea {get;}

See Also

ProtectedRange Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

ProtectedRange.Name Property

Gets the Range title. This is used as a descriptor, not as a named range definition.

public string Name {get; set;}

See Also

ProtectedRange Class | Aspose.Cells Namespace


Password Property

Aspose.Cells for .NET

ProtectedRange.Password Property

Represents the password to protect the range.

public string Password {get; set;}

See Also

ProtectedRange Class | Aspose.Cells Namespace


SecurityDescriptor Property

Aspose.Cells for .NET

ProtectedRange.SecurityDescriptor Property

The security descriptor defines user accounts who may edit this range without providing a password to access the range.

public string SecurityDescriptor {get; set;}

See Also

ProtectedRange Class | Aspose.Cells Namespace


ProtectedRange Methods

The methods of the ProtectedRange class are listed below. For a complete list of ProtectedRange class members, see the ProtectedRange Members topic.

Public Instance Methods

AddArea | Adds a referred area to this
Equals (inherited from Object) |
GetAreas | Gets all referred areas.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ProtectedRange Class | Aspose.Cells Namespace


ProtectedRange.AddArea Method

Adds a referred area to this

public void AddArea(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
The start row.
startColumn
The start column.
endRow
The end row.
endColumn
The end column.

See Also

ProtectedRange Class | Aspose.Cells Namespace


ProtectedRange.GetAreas Method

Gets all referred areas.

public CellArea[] GetAreas();

Return Value

Returns all referred areas.

See Also

ProtectedRange Class | Aspose.Cells Namespace


ProtectedRangeCollection Class

Encapsulates a collection of ProtectedRange objects.

For a list of all members of this type, see ProtectedRangeCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ProtectedRangeCollection

public class ProtectedRangeCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ProtectedRangeCollection Members | Aspose.Cells Namespace


ProtectedRangeCollection Members

ProtectedRangeCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the ProtectedRange element at the specified index.

Public Instance Methods

Add | Adds a ProtectedRange item to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ProtectedRangeCollection Class | Aspose.Cells Namespace


ProtectedRangeCollection Properties

The properties of the ProtectedRangeCollection class are listed below. For a complete list of ProtectedRangeCollection class members, see the ProtectedRangeCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the ProtectedRange element at the specified index.

See Also

ProtectedRangeCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ProtectedRangeCollection.Item Property

Gets the ProtectedRange element at the specified index.

public ProtectedRange this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ProtectedRangeCollection Class | Aspose.Cells Namespace


ProtectedRangeCollection Methods

The methods of the ProtectedRangeCollection class are listed below. For a complete list of ProtectedRangeCollection class members, see the ProtectedRangeCollection Members topic.

Public Instance Methods

Add | Adds a ProtectedRange item to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ProtectedRangeCollection Class | Aspose.Cells Namespace


ProtectedRangeCollection.Add Method

Adds a ProtectedRange item to the collection.

public int Add(
string name,
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

name
Range title. This is used as a descriptor, not as a named range definition.
startRow
Start row index of the range.
startColumn
Start column index of the range.
endRow
End row index of the range.
endColumn
End column index of the range.

Return Value

object index.

See Also

ProtectedRangeCollection Class | Aspose.Cells Namespace


Protection Class

Represents the various types of protection options available for a worksheet. Only used in ExcelXP and above version.

For a list of all members of this type, see Protection Members.

System.Object
Aspose.Cells.Protection

public class Protection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Allowing users to select locked cells of the worksheet
worksheet.Protection.AllowSelectingLockedCell = true;
//Allowing users to select unlocked cells of the worksheet
worksheet.Protection.AllowSelectingUnlockedCell = true;

[Visual Basic]

'Allowing users to select locked cells of the worksheet
worksheet.Protection.AllowSelectingLockedCell = True
'Allowing users to select unlocked cells of the worksheet
worksheet.Protection.AllowSelectingUnlockedCell = True

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Protection Members | Aspose.Cells Namespace


Protection Members

Protection overview

Public Instance Properties

AllowDeletingColumn | Represents if the deletion of columns is allowed on a protected worksheet.
AllowDeletingRow | Represents if the deletion of rows is allowed on a protected worksheet.
AllowEditingContent | Represents if the user is allowed to edit contents of locked cells on a protected worksheet.
AllowEditingObject | Represents if the user is allowed to manipulate drawing objects on a protected worksheet.
AllowEditingScenario | Represents if the user is allowed to edit scenarios on a protected worksheet.
AllowFiltering | Represents if the user is allowed to make use of an AutoFilter that was created before the sheet was protected.
AllowFormattingCell | Represents if the formatting of cells is allowed on a protected worksheet.
AllowFormattingColumn | Represents if the formatting of columns is allowed on a protected worksheet
AllowFormattingRow | Represents if the formatting of rows is allowed on a protected worksheet
AllowInsertingColumn | Represents if the insertion of columns is allowed on a protected worksheet
AllowInsertingHyperlink | Represents if the insertion of hyperlinks is allowed on a protected worksheet
AllowInsertingRow | Represents if the insertion of rows is allowed on a protected worksheet
AllowSelectingLockedCell | Represents if the user is allowed to select locked cells on a protected worksheet.
AllowSelectingUnlockedCell | Represents if the user is allowed to select unlocked cells on a protected worksheet.
AllowSorting | Represents if the sorting option is allowed on a protected worksheet.
AllowUsingPivotTable | Represents if the user is allowed to manipulate pivot tables on a protected worksheet.
IsDeletingColumnsAllowed | Obsolete. Represents if the deletion of columns is allowed on a protected worksheet.
IsDeletingRowsAllowed | Obsolete. Represents if the deletion of rows is allowed on a protected worksheet.
IsEditingContentsAllowed | Obsolete. Represents if the user is allowed to edit contents of locked cells on a protected worksheet.
IsEditingObjectsAllowed | Obsolete. Represents if the user is allowed to manipulate drawing objects on a protected worksheet.
IsEditingScenariosAllowed | Obsolete. Represents if the user is allowed to edit scenarios on a protected worksheet.
IsFilteringAllowed | Obsolete. Represents if the user is allowed to make use of an AutoFilter that was created before the sheet was protected.
IsFormattingCellsAllowed | Obsolete. Represents if the formatting of cells is allowed on a protected worksheet.
IsFormattingColumnsAllowed | Obsolete. Represents if the formatting of columns is allowed on a protected worksheet
IsFormattingRowsAllowed | Obsolete. Represents if the formatting of rows is allowed on a protected worksheet
IsInsertingColumnsAllowed | Obsolete. Represents if the insertion of columns is allowed on a protected worksheet
IsInsertingHyperlinksAllowed | Obsolete. Represents if the insertion of hyperlinks is allowed on a protected worksheet
IsInsertingRowsAllowed | Obsolete. Represents if the insertion of rows is allowed on a protected worksheet
IsProtectedWithPassword | Indicates whether the worksheets is protected with password.
IsSelectingLockedCellsAllowed | Obsolete. Represents if the user is allowed to select locked cells on a protected worksheet.
IsSelectingUnlockedCellsAllowed | Obsolete. Represents if the user is allowed to select unlocked cells on a protected worksheet.
IsSortingAllowed | Obsolete. Represents if the sorting option is allowed on a protected worksheet.
IsUsingPivotTablesAllowed | Obsolete. Represents if the user is allowed to manipulate pivot tables on a protected worksheet.
Password | Represents the password to protect the worksheet.

Public Instance Methods

Copy | Copy protection info.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetPasswordHash | Gets the hash of current password.
GetType (inherited from Object) |
ToString (inherited from Object) |
VerifyPassword | Verifies password.

See Also

Protection Class | Aspose.Cells Namespace


Protection Properties

The properties of the Protection class are listed below. For a complete list of Protection class members, see the Protection Members topic.

Public Instance Properties

AllowDeletingColumn | Represents if the deletion of columns is allowed on a protected worksheet.
AllowDeletingRow | Represents if the deletion of rows is allowed on a protected worksheet.
AllowEditingContent | Represents if the user is allowed to edit contents of locked cells on a protected worksheet.
AllowEditingObject | Represents if the user is allowed to manipulate drawing objects on a protected worksheet.
AllowEditingScenario | Represents if the user is allowed to edit scenarios on a protected worksheet.
AllowFiltering | Represents if the user is allowed to make use of an AutoFilter that was created before the sheet was protected.
AllowFormattingCell | Represents if the formatting of cells is allowed on a protected worksheet.
AllowFormattingColumn | Represents if the formatting of columns is allowed on a protected worksheet
AllowFormattingRow | Represents if the formatting of rows is allowed on a protected worksheet
AllowInsertingColumn | Represents if the insertion of columns is allowed on a protected worksheet
AllowInsertingHyperlink | Represents if the insertion of hyperlinks is allowed on a protected worksheet
AllowInsertingRow | Represents if the insertion of rows is allowed on a protected worksheet
AllowSelectingLockedCell | Represents if the user is allowed to select locked cells on a protected worksheet.
AllowSelectingUnlockedCell | Represents if the user is allowed to select unlocked cells on a protected worksheet.
AllowSorting | Represents if the sorting option is allowed on a protected worksheet.
AllowUsingPivotTable | Represents if the user is allowed to manipulate pivot tables on a protected worksheet.
IsDeletingColumnsAllowed | Obsolete. Represents if the deletion of columns is allowed on a protected worksheet.
IsDeletingRowsAllowed | Obsolete. Represents if the deletion of rows is allowed on a protected worksheet.
IsEditingContentsAllowed | Obsolete. Represents if the user is allowed to edit contents of locked cells on a protected worksheet.
IsEditingObjectsAllowed | Obsolete. Represents if the user is allowed to manipulate drawing objects on a protected worksheet.
IsEditingScenariosAllowed | Obsolete. Represents if the user is allowed to edit scenarios on a protected worksheet.
IsFilteringAllowed | Obsolete. Represents if the user is allowed to make use of an AutoFilter that was created before the sheet was protected.
IsFormattingCellsAllowed | Obsolete. Represents if the formatting of cells is allowed on a protected worksheet.
IsFormattingColumnsAllowed | Obsolete. Represents if the formatting of columns is allowed on a protected worksheet
IsFormattingRowsAllowed | Obsolete. Represents if the formatting of rows is allowed on a protected worksheet
IsInsertingColumnsAllowed | Obsolete. Represents if the insertion of columns is allowed on a protected worksheet
IsInsertingHyperlinksAllowed | Obsolete. Represents if the insertion of hyperlinks is allowed on a protected worksheet
IsInsertingRowsAllowed | Obsolete. Represents if the insertion of rows is allowed on a protected worksheet
IsProtectedWithPassword | Indicates whether the worksheets is protected with password.
IsSelectingLockedCellsAllowed | Obsolete. Represents if the user is allowed to select locked cells on a protected worksheet.
IsSelectingUnlockedCellsAllowed | Obsolete. Represents if the user is allowed to select unlocked cells on a protected worksheet.
IsSortingAllowed | Obsolete. Represents if the sorting option is allowed on a protected worksheet.
IsUsingPivotTablesAllowed | Obsolete. Represents if the user is allowed to manipulate pivot tables on a protected worksheet.
Password | Represents the password to protect the worksheet.

See Also

Protection Class | Aspose.Cells Namespace


AllowDeletingColumn Property

Aspose.Cells for .NET

Protection.AllowDeletingColumn Property

Represents if the deletion of columns is allowed on a protected worksheet.

public bool AllowDeletingColumn {get; set;}

Remarks

The columns containing the cells to be deleted must be unlocked when the sheet is protected, and "Select unlocked cells" option must be enabled.

See Also

Protection Class | Aspose.Cells Namespace


AllowDeletingRow Property

Aspose.Cells for .NET

Protection.AllowDeletingRow Property

Represents if the deletion of rows is allowed on a protected worksheet.

public bool AllowDeletingRow {get; set;}

Remarks

The rows containing the cells to be deleted must be unlocked when the sheet is protected, and "Select unlocked cells" option must be enabled.

See Also

Protection Class | Aspose.Cells Namespace


AllowEditingContent Property

Aspose.Cells for .NET

Protection.AllowEditingContent Property

Represents if the user is allowed to edit contents of locked cells on a protected worksheet.

public bool AllowEditingContent {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowEditingObject Property

Aspose.Cells for .NET

Protection.AllowEditingObject Property

Represents if the user is allowed to manipulate drawing objects on a protected worksheet.

public bool AllowEditingObject {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowEditingScenario Property

Aspose.Cells for .NET

Protection.AllowEditingScenario Property

Represents if the user is allowed to edit scenarios on a protected worksheet.

public bool AllowEditingScenario {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowFiltering Property

Aspose.Cells for .NET

Protection.AllowFiltering Property

Represents if the user is allowed to make use of an AutoFilter that was created before the sheet was protected.

public bool AllowFiltering {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowFormattingCell Property

Aspose.Cells for .NET

Protection.AllowFormattingCell Property

Represents if the formatting of cells is allowed on a protected worksheet.

public bool AllowFormattingCell {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowFormattingColumn Property

Aspose.Cells for .NET

Protection.AllowFormattingColumn Property

Represents if the formatting of columns is allowed on a protected worksheet

public bool AllowFormattingColumn {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowFormattingRow Property

Aspose.Cells for .NET

Protection.AllowFormattingRow Property

Represents if the formatting of rows is allowed on a protected worksheet

public bool AllowFormattingRow {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowInsertingColumn Property

Aspose.Cells for .NET

Protection.AllowInsertingColumn Property

Represents if the insertion of columns is allowed on a protected worksheet

public bool AllowInsertingColumn {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowInsertingHyperlink Property

Aspose.Cells for .NET

Protection.AllowInsertingHyperlink Property

Represents if the insertion of hyperlinks is allowed on a protected worksheet

public bool AllowInsertingHyperlink {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowInsertingRow Property

Aspose.Cells for .NET

Protection.AllowInsertingRow Property

Represents if the insertion of rows is allowed on a protected worksheet

public bool AllowInsertingRow {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowSelectingLockedCell Property

Aspose.Cells for .NET

Protection.AllowSelectingLockedCell Property

Represents if the user is allowed to select locked cells on a protected worksheet.

public bool AllowSelectingLockedCell {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowSelectingUnlockedCell Property

Aspose.Cells for .NET

Protection.AllowSelectingUnlockedCell Property

Represents if the user is allowed to select unlocked cells on a protected worksheet.

public bool AllowSelectingUnlockedCell {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowSorting Property

Aspose.Cells for .NET

Protection.AllowSorting Property

Represents if the sorting option is allowed on a protected worksheet.

public bool AllowSorting {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


AllowUsingPivotTable Property

Aspose.Cells for .NET

Protection.AllowUsingPivotTable Property

Represents if the user is allowed to manipulate pivot tables on a protected worksheet.

public bool AllowUsingPivotTable {get; set;}

See Also

Protection Class | Aspose.Cells Namespace


IsDeletingColumnsAllowed Property

Aspose.Cells for .NET

Protection.IsDeletingColumnsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowDeletingColumn property instead.

Represents if the deletion of columns is allowed on a protected worksheet.

public bool IsDeletingColumnsAllowed {get; set;}

Remarks

The columns containing the cells to be deleted must be unlocked when the sheet is protected, and "Select unlocked cells" option must be enabled. NOTE: This member is now obsolete. Instead, please use Protection.AllowDeletingColumn property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsDeletingRowsAllowed Property

Aspose.Cells for .NET

Protection.IsDeletingRowsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowDeletingRow property instead.

Represents if the deletion of rows is allowed on a protected worksheet.

public bool IsDeletingRowsAllowed {get; set;}

Remarks

The rows containing the cells to be deleted must be unlocked when the sheet is protected, and "Select unlocked cells" option must be enabled. NOTE: This member is now obsolete. Instead, please use Protection.AllowDeletingRow property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsEditingContentsAllowed Property

Aspose.Cells for .NET

Protection.IsEditingContentsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowEditingContent property instead.

Represents if the user is allowed to edit contents of locked cells on a protected worksheet.

public bool IsEditingContentsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowEditingContent property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsEditingObjectsAllowed Property

Aspose.Cells for .NET

Protection.IsEditingObjectsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowEditingObject property instead.

Represents if the user is allowed to manipulate drawing objects on a protected worksheet.

public bool IsEditingObjectsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowEditingObject property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsEditingScenariosAllowed Property

Aspose.Cells for .NET

Protection.IsEditingScenariosAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowEditingScenario property instead.

Represents if the user is allowed to edit scenarios on a protected worksheet.

public bool IsEditingScenariosAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowEditingScenario property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsFilteringAllowed Property

Aspose.Cells for .NET

Protection.IsFilteringAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowFiltering property instead.

Represents if the user is allowed to make use of an AutoFilter that was created before the sheet was protected.

public bool IsFilteringAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowFiltering property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsFormattingCellsAllowed Property

Aspose.Cells for .NET

Protection.IsFormattingCellsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowFormattingCell property instead.

Represents if the formatting of cells is allowed on a protected worksheet.

public bool IsFormattingCellsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowFormattingCell property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsFormattingColumnsAllowed Property

Aspose.Cells for .NET

Protection.IsFormattingColumnsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowFormattingColumn property instead.

Represents if the formatting of columns is allowed on a protected worksheet

public bool IsFormattingColumnsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowFormattingColumn property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsFormattingRowsAllowed Property

Aspose.Cells for .NET

Protection.IsFormattingRowsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowFormattingRow property instead.

Represents if the formatting of rows is allowed on a protected worksheet

public bool IsFormattingRowsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowFormattingRow property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsInsertingColumnsAllowed Property

Aspose.Cells for .NET

Protection.IsInsertingColumnsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowInsertingColumn property instead.

Represents if the insertion of columns is allowed on a protected worksheet

public bool IsInsertingColumnsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowInsertingColumn property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsInsertingHyperlinksAllowed Property

Aspose.Cells for .NET

Protection.IsInsertingHyperlinksAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowInsertingHyperlink property instead.

Represents if the insertion of hyperlinks is allowed on a protected worksheet

public bool IsInsertingHyperlinksAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowInsertingHyperlink property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsInsertingRowsAllowed Property

Aspose.Cells for .NET

Protection.IsInsertingRowsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowInsertingRow property instead.

Represents if the insertion of rows is allowed on a protected worksheet

public bool IsInsertingRowsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowInsertingRow property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsProtectedWithPassword Property

Aspose.Cells for .NET

Protection.IsProtectedWithPassword Property

Indicates whether the worksheets is protected with password.

public bool IsProtectedWithPassword {get;}

See Also

Protection Class | Aspose.Cells Namespace


IsSelectingLockedCellsAllowed Property

Aspose.Cells for .NET

Protection.IsSelectingLockedCellsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowSelectingLockedCell property instead.

Represents if the user is allowed to select locked cells on a protected worksheet.

public bool IsSelectingLockedCellsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowSelectingLockedCell property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsSelectingUnlockedCellsAllowed Property

Aspose.Cells for .NET

Protection.IsSelectingUnlockedCellsAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowSelectingUnlockedCell property instead.

Represents if the user is allowed to select unlocked cells on a protected worksheet.

public bool IsSelectingUnlockedCellsAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowSelectingUnlockedCell property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsSortingAllowed Property

Aspose.Cells for .NET

Protection.IsSortingAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowSorting property instead.

Represents if the sorting option is allowed on a protected worksheet.

public bool IsSortingAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowSorting property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


IsUsingPivotTablesAllowed Property

Aspose.Cells for .NET

Protection.IsUsingPivotTablesAllowed Property

NOTE: This property is now obsolete.

Use Protection.AllowUsingPivotTable property instead.

Represents if the user is allowed to manipulate pivot tables on a protected worksheet.

public bool IsUsingPivotTablesAllowed {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Protection.AllowUsingPivotTable property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Protection Class | Aspose.Cells Namespace


Password Property

Aspose.Cells for .NET

Protection.Password Property

Represents the password to protect the worksheet.

public string Password {get; set;}

Remarks

If password is set to null or blank string, you can unprotect the worksheet or workbook without using a password. Otherwise, you must specify the password to unprotect the worksheet or workbook.

See Also

Protection Class | Aspose.Cells Namespace


Protection Methods

The methods of the Protection class are listed below. For a complete list of Protection class members, see the Protection Members topic.

Public Instance Methods

Copy | Copy protection info.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetPasswordHash | Gets the hash of current password.
GetType (inherited from Object) |
ToString (inherited from Object) |
VerifyPassword | Verifies password.

See Also

Protection Class | Aspose.Cells Namespace


Protection.Copy Method

Copy protection info.

public void Copy(
Protection source
);

Parameters

source

See Also

Protection Class | Aspose.Cells Namespace


Protection.GetPasswordHash Method

Gets the hash of current password.

public int GetPasswordHash();

See Also

Protection Class | Aspose.Cells Namespace


Protection.VerifyPassword Method

Verifies password.

public bool VerifyPassword(
string password
);

Parameters

password
The password.

Return Value

See Also

Protection Class | Aspose.Cells Namespace


ProtectionType Enumeration

Represents workbook/worksheet protection type.

public enum ProtectionType

Members

Member Name | Description | Value
All | Represents to protect all. | 0
Contents | Represents to protect contents, used in Worksheet protection. | 1
Objects | Represents to protect objects, used in Worksheet protection. | 2
Scenarios | Represents to protect scenarios, used in Worksheet protection. | 3
Structure | Represents to protect structure, used in Workbook protection. | 4
Windows | Represents to protect window, used in Workbook protection. | 5
None | Represents no protection. Only for Reading property. | 6

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


QueryTable Class

Represents QueryTable information.

For a list of all members of this type, see QueryTable Members.

System.Object
Aspose.Cells.QueryTable

public class QueryTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

QueryTable Members | Aspose.Cells Namespace


QueryTable Members

QueryTable overview

Public Instance Properties

AdjustColumnWidth | Returns or sets the AdjustColumnWidth of the object.
ConnectionId | Gets the connection id of the query table.
ExternalConnection | Gets the relate external connection.
Name | Gets the name of querytable.
PreserveFormatting | Returns or sets the PreserveFormatting of the object.
ResultRange | Gets the range of the result.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

QueryTable Class | Aspose.Cells Namespace


QueryTable Properties

The properties of the QueryTable class are listed below. For a complete list of QueryTable class members, see the QueryTable Members topic.

Public Instance Properties

AdjustColumnWidth | Returns or sets the AdjustColumnWidth of the object.
ConnectionId | Gets the connection id of the query table.
ExternalConnection | Gets the relate external connection.
Name | Gets the name of querytable.
PreserveFormatting | Returns or sets the PreserveFormatting of the object.
ResultRange | Gets the range of the result.

See Also

QueryTable Class | Aspose.Cells Namespace


AdjustColumnWidth Property

Aspose.Cells for .NET

QueryTable.AdjustColumnWidth Property

Returns or sets the AdjustColumnWidth of the object.

public bool AdjustColumnWidth {get; set;}

See Also

QueryTable Class | Aspose.Cells Namespace


ConnectionId Property

Aspose.Cells for .NET

QueryTable.ConnectionId Property

Gets the connection id of the query table.

public int ConnectionId {get;}

See Also

QueryTable Class | Aspose.Cells Namespace


ExternalConnection Property

Aspose.Cells for .NET

QueryTable.ExternalConnection Property

Gets the relate external connection.

public ExternalConnection ExternalConnection {get;}

See Also

QueryTable Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

QueryTable.Name Property

Gets the name of querytable.

public string Name {get;}

See Also

QueryTable Class | Aspose.Cells Namespace


PreserveFormatting Property

Aspose.Cells for .NET

QueryTable.PreserveFormatting Property

Returns or sets the PreserveFormatting of the object.

public bool PreserveFormatting {get; set;}

See Also

QueryTable Class | Aspose.Cells Namespace


ResultRange Property

Aspose.Cells for .NET

QueryTable.ResultRange Property

Gets the range of the result.

public Range ResultRange {get;}

See Also

QueryTable Class | Aspose.Cells Namespace


QueryTableCollection Class

A collection of QueryTableCollection objects that represent QueryTable collection information.

For a list of all members of this type, see QueryTableCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.QueryTableCollection

public class QueryTableCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

QueryTableCollection Members | Aspose.Cells Namespace


QueryTableCollection Members

QueryTableCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the querytable by the specific index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

QueryTableCollection Class | Aspose.Cells Namespace


QueryTableCollection Properties

The properties of the QueryTableCollection class are listed below. For a complete list of QueryTableCollection class members, see the QueryTableCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the querytable by the specific index.

See Also

QueryTableCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

QueryTableCollection.Item Property

Gets the querytable by the specific index.

public QueryTable this[
int index
] {get;}

Parameters

index
The index.

See Also

QueryTableCollection Class | Aspose.Cells Namespace


Range Class

Encapsulates the object that represents a range of cells within a spreadsheet.

For a list of all members of this type, see Range Members.

System.Object
Aspose.Cells.Range

public class Range

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Range Members | Aspose.Cells Namespace


Range Members

Range overview

Public Instance Properties

Address | Gets address of the range.
CellCount | Gets all cell count in the range.
ColumnCount | Gets the count of columns in the range.
ColumnWidth | Sets or gets the column width of this range
EntireColumn | Gets a Range object that represents the entire column (or columns) that contains the specified range.
EntireRow | Gets a Range object that represents the entire row (or rows) that contains the specified range.
FirstColumn | Gets the index of the first column of the range.
FirstRow | Gets the index of the first row of the range.
Hyperlinks | Gets all hyperlink in the range.
Item | Gets Cell object in this range.
Name | Gets or sets the name of the range.
RefersTo | Gets the range's refers to.
RowCount | Gets the count of rows in the range.
RowHeight | Sets or gets the height of rows in this range
Value | Gets and sets the value of the range.
Worksheet | Gets the Worksheetobject which contains this range.

Public Instance Methods

ApplyStyle | Applies formats for a whole range.
Copy | Overloaded. Copying the range with paste special options.
CopyData | Copies cell data (including formulas) from a source range.
CopyStyle | Copies style settings from a source range.
CopyValue | Copies cell value from a source range.
Equals (inherited from Object) |
ExportDataTable | Overloaded. Exports data in this range to a DataTable object.
ExportDataTableAsString | Exports data in this range to a DataTable object.
GetCellOrNull | Gets Cell object or null in this range.
GetEnumerator | Gets the enumerator for cells in this Range.
GetHashCode (inherited from Object) |
GetOffset | Gets Range range by offset.
GetType (inherited from Object) |
Intersect | Returns a Range object that represents the rectangular intersection of two ranges.
IsIntersect | Indicates whether the range is intersect.
Merge | Combines a range of cells into a single cell.
MoveTo | Move the current range to the dest range.
PutValue | Puts a value into the range, if appropriate the value will be converted to other data type and cell's number format will be reset.
SetOutlineBorder | Sets outline border around a range of cells.
SetOutlineBorders | Overloaded. Sets the outline borders around a range of cells with same border style and color.
SetStyle | Sets the style of the range.
ToString | Returns a string represents the current Range object.
Union | Returns the union of two ranges.
UnMerge | Unmerges merged cells of this range.

See Also

Range Class | Aspose.Cells Namespace


Range Properties

The properties of the Range class are listed below. For a complete list of Range class members, see the Range Members topic.

Public Instance Properties

Address | Gets address of the range.
CellCount | Gets all cell count in the range.
ColumnCount | Gets the count of columns in the range.
ColumnWidth | Sets or gets the column width of this range
EntireColumn | Gets a Range object that represents the entire column (or columns) that contains the specified range.
EntireRow | Gets a Range object that represents the entire row (or rows) that contains the specified range.
FirstColumn | Gets the index of the first column of the range.
FirstRow | Gets the index of the first row of the range.
Hyperlinks | Gets all hyperlink in the range.
Item | Gets Cell object in this range.
Name | Gets or sets the name of the range.
RefersTo | Gets the range's refers to.
RowCount | Gets the count of rows in the range.
RowHeight | Sets or gets the height of rows in this range
Value | Gets and sets the value of the range.
Worksheet | Gets the Worksheetobject which contains this range.

See Also

Range Class | Aspose.Cells Namespace


Address Property

Aspose.Cells for .NET

Range.Address Property

Gets address of the range.

public string Address {get;}

See Also

Range Class | Aspose.Cells Namespace


CellCount Property

Aspose.Cells for .NET

Range.CellCount Property

Gets all cell count in the range.

public int CellCount {get;}

See Also

Range Class | Aspose.Cells Namespace


ColumnCount Property

Aspose.Cells for .NET

Range.ColumnCount Property

Gets the count of columns in the range.

public int ColumnCount {get;}

See Also

Range Class | Aspose.Cells Namespace


ColumnWidth Property

Aspose.Cells for .NET

Range.ColumnWidth Property

Sets or gets the column width of this range

public double ColumnWidth {get; set;}

See Also

Range Class | Aspose.Cells Namespace


EntireColumn Property

Aspose.Cells for .NET

Range.EntireColumn Property

Gets a Range object that represents the entire column (or columns) that contains the specified range.

public Range EntireColumn {get;}

See Also

Range Class | Aspose.Cells Namespace


EntireRow Property

Aspose.Cells for .NET

Range.EntireRow Property

Gets a Range object that represents the entire row (or rows) that contains the specified range.

public Range EntireRow {get;}

See Also

Range Class | Aspose.Cells Namespace


FirstColumn Property

Aspose.Cells for .NET

Range.FirstColumn Property

Gets the index of the first column of the range.

public int FirstColumn {get;}

See Also

Range Class | Aspose.Cells Namespace


FirstRow Property

Aspose.Cells for .NET

Range.FirstRow Property

Gets the index of the first row of the range.

public int FirstRow {get;}

See Also

Range Class | Aspose.Cells Namespace


Hyperlinks Property

Aspose.Cells for .NET

Range.Hyperlinks Property

Gets all hyperlink in the range.

public Hyperlink[] Hyperlinks {get;}

See Also

Range Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

Range.Item Property

Gets Cell object in this range.

public Cell this[
int rowOffset,
int columnOffset
] {get;}

Parameters

rowOffset
Row offset in this range, zero based.
columnOffset
Column offset in this range, zero based.

See Also

Range Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

Range.Name Property

Gets or sets the name of the range.

public string Name {get; set;}

Remarks

Named range is supported. For example,

range.Name = "Sheet1!MyRange";

See Also

Range Class | Aspose.Cells Namespace


RefersTo Property

Aspose.Cells for .NET

Range.RefersTo Property

Gets the range's refers to.

public string RefersTo {get;}

See Also

Range Class | Aspose.Cells Namespace


RowCount Property

Aspose.Cells for .NET

Range.RowCount Property

Gets the count of rows in the range.

public int RowCount {get;}

See Also

Range Class | Aspose.Cells Namespace


RowHeight Property

Aspose.Cells for .NET

Range.RowHeight Property

Sets or gets the height of rows in this range

public double RowHeight {get; set;}

See Also

Range Class | Aspose.Cells Namespace


Value Property

Aspose.Cells for .NET

Range.Value Property

Gets and sets the value of the range.

public object Value {get; set;}

Remarks

If the range contains multiple cells, return a two-dimension Array object. If applies object array to the range, it should be a two-dimension Array object.

See Also

Range Class | Aspose.Cells Namespace


Worksheet Property

Aspose.Cells for .NET

Range.Worksheet Property

Gets the Worksheetobject which contains this range.

public Worksheet Worksheet {get;}

See Also

Range Class | Aspose.Cells Namespace


Range Methods

The methods of the Range class are listed below. For a complete list of Range class members, see the Range Members topic.

Public Instance Methods

ApplyStyle | Applies formats for a whole range.
Copy | Overloaded. Copying the range with paste special options.
CopyData | Copies cell data (including formulas) from a source range.
CopyStyle | Copies style settings from a source range.
CopyValue | Copies cell value from a source range.
Equals (inherited from Object) |
ExportDataTable | Overloaded. Exports data in this range to a DataTable object.
ExportDataTableAsString | Exports data in this range to a DataTable object.
GetCellOrNull | Gets Cell object or null in this range.
GetEnumerator | Gets the enumerator for cells in this Range.
GetHashCode (inherited from Object) |
GetOffset | Gets Range range by offset.
GetType (inherited from Object) |
Intersect | Returns a Range object that represents the rectangular intersection of two ranges.
IsIntersect | Indicates whether the range is intersect.
Merge | Combines a range of cells into a single cell.
MoveTo | Move the current range to the dest range.
PutValue | Puts a value into the range, if appropriate the value will be converted to other data type and cell's number format will be reset.
SetOutlineBorder | Sets outline border around a range of cells.
SetOutlineBorders | Overloaded. Sets the outline borders around a range of cells with same border style and color.
SetStyle | Sets the style of the range.
ToString | Returns a string represents the current Range object.
Union | Returns the union of two ranges.
UnMerge | Unmerges merged cells of this range.

See Also

Range Class | Aspose.Cells Namespace


Range.ApplyStyle Method

Applies formats for a whole range.

public void ApplyStyle(
Style style,
StyleFlag flag
);

Parameters

style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

Remarks

Each cell in this range will contains a Style object. So this is a memory-consuming method. Please use it carefully.

See Also

Range Class | Aspose.Cells Namespace


Copy Method

Aspose.Cells for .NET

Range.Copy Method

Copies data (including formulas), formatting, drawing objects etc. from a source range.

Overload List

Copies data (including formulas), formatting, drawing objects etc. from a source range.

public void Copy(Range);

Copying the range with paste special options.

public void Copy(Range,PasteOptions);

See Also

Range Class | Aspose.Cells Namespace


Range.Copy Method (Range)

Copies data (including formulas), formatting, drawing objects etc. from a source range.

public void Copy(
Range range
);

Parameters

range
Source Range object.

See Also

Range Class | Aspose.Cells Namespace | Range.Copy Overload List


Range.Copy Method (Range, PasteOptions)

Copying the range with paste special options.

public void Copy(
Range range,
PasteOptions options
);

Parameters

range
The source range.
options
The paste special options.

See Also

Range Class | Aspose.Cells Namespace | Range.Copy Overload List


Range.CopyData Method

Copies cell data (including formulas) from a source range.

public void CopyData(
Range range
);

Parameters

range
Source Range object.

See Also

Range Class | Aspose.Cells Namespace


Range.CopyStyle Method

Copies style settings from a source range.

public void CopyStyle(
Range range
);

Parameters

range
Source Range object.

See Also

Range Class | Aspose.Cells Namespace


Range.CopyValue Method

Copies cell value from a source range.

public void CopyValue(
Range range
);

Parameters

range
Source Range object.

See Also

Range Class | Aspose.Cells Namespace


ExportDataTable Method

Aspose.Cells for .NET

Range.ExportDataTable Method

Exports data in this range to a DataTable object.

Overload List

Exports data in this range to a DataTable object.

public DataTable ExportDataTable();

Exports data in this range to a DataTable object.

public DataTable ExportDataTable(ExportTableOptions);

See Also

Range Class | Aspose.Cells Namespace


Range.ExportDataTable Method ()

Exports data in this range to a DataTable object.

public DataTable ExportDataTable();

Return Value

Exported DataTable object.

See Also

Range Class | Aspose.Cells Namespace | Range.ExportDataTable Overload List


Range.ExportDataTable Method (ExportTableOptions)

Exports data in this range to a DataTable object.

public DataTable ExportDataTable(
ExportTableOptions options
);

Parameters

options
The options of exporting range to datatable.

Return Value

Exported DataTable object.

See Also

Range Class | Aspose.Cells Namespace | Range.ExportDataTable Overload List


Range.ExportDataTableAsString Method

Exports data in this range to a DataTable object.

public DataTable ExportDataTableAsString();

Return Value

Exported DataTable object.

Remarks

All data in the Cells collection are converted to strings.

See Also

Range Class | Aspose.Cells Namespace


Range.GetCellOrNull Method

Gets Cell object or null in this range.

public Cell GetCellOrNull(
int rowOffset,
int columnOffset
);

Parameters

rowOffset
Row offset in this range, zero based.
columnOffset
Column offset in this range, zero based.

Return Value

Cell object.

See Also

Range Class | Aspose.Cells Namespace


Range.GetEnumerator Method

Gets the enumerator for cells in this Range.

public IEnumerator GetEnumerator();

Return Value

The cells enumerator

Remarks

When traversing elements by the returned Enumerator, the cells collection should not be modified(such as operations that will cause new Cell/Row be instantiated or existing Cell/Row be deleted). Otherwise the enumerator may not be able to traverse all cells correctly(some elements may be traversed repeatedly or skipped).

See Also

Range Class | Aspose.Cells Namespace


Range.GetOffset Method

Gets Range range by offset.

public Range GetOffset(
int rowOffset,
int columnOffset
);

Parameters

rowOffset
Row offset in this range, zero based.
columnOffset
Column offset in this range, zero based.

Return Value

See Also

Range Class | Aspose.Cells Namespace


Range.Intersect Method

Returns a Range object that represents the rectangular intersection of two ranges.

public Range Intersect(
Range range
);

Parameters

range
The intersecting range.

Return Value

a Range object

Remarks

If the two ranges are not intersected, returns null.

See Also

Range Class | Aspose.Cells Namespace


Range.IsIntersect Method

Indicates whether the range is intersect.

public bool IsIntersect(
Range range
);

Parameters

range
The range.

Return Value

Whether the range is intersect.

Remarks

If the two ranges area not in the same worksheet ,return false.

See Also

Range Class | Aspose.Cells Namespace


Range.Merge Method

Combines a range of cells into a single cell.

public void Merge();

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

Range Class | Aspose.Cells Namespace


Range.MoveTo Method

Move the current range to the dest range.

public void MoveTo(
int destRow,
int destColumn
);

Parameters

destRow
The start row of the dest range.
destColumn
The start column of the dest range.

See Also

Range Class | Aspose.Cells Namespace


Range.PutValue Method

Puts a value into the range, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(
string stringValue,
bool isConverted,
bool setStyle
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.
setStyle
True: set the number format to cell's style when converting to other data type

See Also

Range Class | Aspose.Cells Namespace


Range.SetOutlineBorder Method

Sets outline border around a range of cells.

public void SetOutlineBorder(
BorderType borderEdge,
CellBorderType borderStyle,
Color borderColor
);

Parameters

borderEdge
Border edge.
borderStyle
Border style.
borderColor
Border color.

See Also

Range Class | Aspose.Cells Namespace


SetOutlineBorders Method

Aspose.Cells for .NET

Range.SetOutlineBorders Method

Sets the outline borders around a range of cells with same border style and color.

Overload List

Sets the outline borders around a range of cells with same border style and color.

public void SetOutlineBorders(CellBorderType,Color);

Sets out line borders around a range of cells.

public void SetOutlineBorders(CellBorderType[],Color[]);

See Also

Range Class | Aspose.Cells Namespace


Range.SetOutlineBorders Method (CellBorderType, Color)

Sets the outline borders around a range of cells with same border style and color.

public void SetOutlineBorders(
CellBorderType borderStyle,
Color borderColor
);

Parameters

borderStyle
Border style.
borderColor
Border color.

See Also

Range Class | Aspose.Cells Namespace | Range.SetOutlineBorders Overload List


Range.SetOutlineBorders Method (CellBorderType[], Color[])

Sets out line borders around a range of cells.

public void SetOutlineBorders(
CellBorderType[] borderStyles,
Color[] borderColors
);

Parameters

borderStyles
Border styles.
borderColors
Border colors.

Remarks

Both the length of borderStyles and borderStyles must be 4. The order of borderStyles and borderStyles must be top,bottom,left,right

See Also

Range Class | Aspose.Cells Namespace | Range.SetOutlineBorders Overload List


Range.SetStyle Method

Sets the style of the range.

public void SetStyle(
Style style
);

Parameters

style
The Style object.

See Also

Range Class | Aspose.Cells Namespace


Range.ToString Method

Returns a string represents the current Range object.

public override string ToString();

Return Value

See Also

Range Class | Aspose.Cells Namespace


Range.Union Method

Returns the union of two ranges.

public ArrayList Union(
Range range
);

Parameters

range
The range

Return Value

The union of two ranges.

See Also

Range Class | Aspose.Cells Namespace


Range.UnMerge Method

Unmerges merged cells of this range.

public void UnMerge();

See Also

Range Class | Aspose.Cells Namespace


RangeCollection Class

Encapsulates a collection of Range objects.

For a list of all members of this type, see RangeCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.RangeCollection

public class RangeCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RangeCollection Members | Aspose.Cells Namespace


RangeCollection Members

RangeCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Range element at the specified index.

Public Instance Methods

Add | Adds a Range item to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

RangeCollection Class | Aspose.Cells Namespace


RangeCollection Properties

The properties of the RangeCollection class are listed below. For a complete list of RangeCollection class members, see the RangeCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Range element at the specified index.

See Also

RangeCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

RangeCollection.Item Property

Gets the Range element at the specified index.

public Range this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

RangeCollection Class | Aspose.Cells Namespace


RangeCollection Methods

The methods of the RangeCollection class are listed below. For a complete list of RangeCollection class members, see the RangeCollection Members topic.

Public Instance Methods

Add | Adds a Range item to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

RangeCollection Class | Aspose.Cells Namespace


RangeCollection.Add Method

Adds a Range item to the collection.

public int Add(
Range range
);

Parameters

range
Range object

Return Value

See Also

RangeCollection Class | Aspose.Cells Namespace


ReferredArea Class

Represents a referred area by the formula.

For a list of all members of this type, see ReferredArea Members.

System.Object
Aspose.Cells.ReferredArea

public class ReferredArea

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ReferredArea Members | Aspose.Cells Namespace


ReferredArea Members

ReferredArea overview

Public Instance Properties

EndColumn | The end column of the area.
EndRow | The end row of the area.
ExternalFileName | Get the external file name if this is an external reference.
IsArea | Indicates whether this is an area.
IsExternalLink | Indicates whether this is an external link.
SheetName | Indicates which sheet this reference is in.
StartColumn | The start column of the area.
StartRow | The start row of the area.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValue | Overloaded. Gets cell value with given offset from the top-left of this area.
GetValues | Overloaded. Gets cell values in this area.
ToString | Returns the simple string representation of this area.

See Also

ReferredArea Class | Aspose.Cells Namespace


ReferredArea Properties

The properties of the ReferredArea class are listed below. For a complete list of ReferredArea class members, see the ReferredArea Members topic.

Public Instance Properties

EndColumn | The end column of the area.
EndRow | The end row of the area.
ExternalFileName | Get the external file name if this is an external reference.
IsArea | Indicates whether this is an area.
IsExternalLink | Indicates whether this is an external link.
SheetName | Indicates which sheet this reference is in.
StartColumn | The start column of the area.
StartRow | The start row of the area.

See Also

ReferredArea Class | Aspose.Cells Namespace


EndColumn Property

Aspose.Cells for .NET

ReferredArea.EndColumn Property

The end column of the area.

public int EndColumn {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


EndRow Property

Aspose.Cells for .NET

ReferredArea.EndRow Property

The end row of the area.

public int EndRow {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


ExternalFileName Property

Aspose.Cells for .NET

ReferredArea.ExternalFileName Property

Get the external file name if this is an external reference.

public string ExternalFileName {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


IsArea Property

Aspose.Cells for .NET

ReferredArea.IsArea Property

Indicates whether this is an area.

public bool IsArea {get;}

Remarks

If this is not an area, only StartRow and StartColumn effect.

See Also

ReferredArea Class | Aspose.Cells Namespace


IsExternalLink Property

Aspose.Cells for .NET

ReferredArea.IsExternalLink Property

Indicates whether this is an external link.

public bool IsExternalLink {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


SheetName Property

Aspose.Cells for .NET

ReferredArea.SheetName Property

Indicates which sheet this reference is in.

public string SheetName {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


StartColumn Property

Aspose.Cells for .NET

ReferredArea.StartColumn Property

The start column of the area.

public int StartColumn {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


StartRow Property

Aspose.Cells for .NET

ReferredArea.StartRow Property

The start row of the area.

public int StartRow {get;}

See Also

ReferredArea Class | Aspose.Cells Namespace


ReferredArea Methods

The methods of the ReferredArea class are listed below. For a complete list of ReferredArea class members, see the ReferredArea Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValue | Overloaded. Gets cell value with given offset from the top-left of this area.
GetValues | Overloaded. Gets cell values in this area.
ToString | Returns the simple string representation of this area.

See Also

ReferredArea Class | Aspose.Cells Namespace


GetValue Method

Aspose.Cells for .NET

ReferredArea.GetValue Method

Gets cell value with given offset from the top-left of this area.

Overload List

Gets cell value with given offset from the top-left of this area.

public object GetValue(int,int);

Gets cell value with given offset from the top-left of this area.

public object GetValue(int,int,bool);

See Also

ReferredArea Class | Aspose.Cells Namespace


ReferredArea.GetValue Method (Int32, Int32)

Gets cell value with given offset from the top-left of this area.

public object GetValue(
int rowOffset,
int colOffset
);

Parameters

rowOffset
row offset from the start row of this area
colOffset
column offset from the start row of this area

Return Value

"#REF!" if this area is invalid; "#N/A" if given offset out of this area; Otherwise return the cell value at given position.

See Also

ReferredArea Class | Aspose.Cells Namespace | ReferredArea.GetValue Overload List


ReferredArea.GetValue Method (Int32, Int32, Boolean)

Gets cell value with given offset from the top-left of this area.

public object GetValue(
int rowOffset,
int colOffset,
bool calculateFormulas
);

Parameters

rowOffset
row offset from the start row of this area
colOffset
column offset from the start row of this area
calculateFormulas
Whether calculate it recursively if the specified reference is formula

Return Value

"#REF!" if this area is invalid; "#N/A" if given offset out of this area; Otherwise return the cell value at given position.

See Also

ReferredArea Class | Aspose.Cells Namespace | ReferredArea.GetValue Overload List


GetValues Method

Aspose.Cells for .NET

ReferredArea.GetValues Method

Gets cell values in this area.

Overload List

Gets cell values in this area.

public object GetValues();

Gets cell values in this area.

public object GetValues(bool);

See Also

ReferredArea Class | Aspose.Cells Namespace


ReferredArea.GetValues Method ()

Gets cell values in this area.

public object GetValues();

Return Value

If this area is invalid, "#REF!" will be returned; If this area is one single cell, then return the cell value object; Otherwise return one 2D array for all values in this area.

See Also

ReferredArea Class | Aspose.Cells Namespace | ReferredArea.GetValues Overload List


ReferredArea.GetValues Method (Boolean)

Gets cell values in this area.

public object GetValues(
bool calculateFormulas
);

Parameters

calculateFormulas
In this range, if there are some formulas that have not been calculated, this flag denotes whether those formulas should be calculated recursively

Return Value

If this area is invalid, "#REF!" will be returned; If this area is one single cell, then return the cell value object; Otherwise return one 2D array for all values in this area.

See Also

ReferredArea Class | Aspose.Cells Namespace | ReferredArea.GetValues Overload List


ReferredArea.ToString Method

Returns the simple string representation of this area.

public override string ToString();

Return Value

See Also

ReferredArea Class | Aspose.Cells Namespace


ReferredAreaCollection Class

Represents all referred cells and areas.

For a list of all members of this type, see ReferredAreaCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ReferredAreaCollection

public class ReferredAreaCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ReferredAreaCollection Members | Aspose.Cells Namespace


ReferredAreaCollection Members

ReferredAreaCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase)
Count (inherited from CollectionBase)
Item

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

ReferredAreaCollection Class | Aspose.Cells Namespace


ReferredAreaCollection Properties

The properties of the ReferredAreaCollection class are listed below. For a complete list of ReferredAreaCollection class members, see the ReferredAreaCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase)
Count (inherited from CollectionBase)
Item

See Also

ReferredAreaCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ReferredAreaCollection.Item Property

public ReferredArea this[
int index
] {get;}

Parameters

index

See Also

ReferredAreaCollection Class | Aspose.Cells Namespace


RegexType Enumeration

Represents the regex type for searching string.

public enum RegexType

Members

Member Name | Description | Value
None | Not regex, take the searched value as plain string. | 0
Wildcards | Windows wildcards. Same with wildcards('*','?','~') in ms excel. | 1
Regex | Common regular expression. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


RenameStrategy Enumeration

Renames strategy when columns contains the duplicate names.

public enum RenameStrategy

Members

Member Name | Description | Value
Exception | Throws exception. | 0
Digit | Named with digit. | 1
Letter | Named with letter. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ReplaceOptions Class

Represent the replace options.

For a list of all members of this type, see ReplaceOptions Members.

System.Object
Aspose.Cells.ReplaceOptions

public class ReplaceOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ReplaceOptions Members | Aspose.Cells Namespace


ReplaceOptions Members

ReplaceOptions overview

Public Instance Constructors

ReplaceOptions Constructor Initializes a new instance of the ReplaceOptions class.

Public Instance Properties

CaseSensitive | Indicates if the searched string is case sensitive.
IsCaseSensitive | Obsolete. Indicates if the searched string is case sensitive.
MatchEntireCellContents | Indicates whether to match entire cells contents
RegexKey | Indicates whether the searched key is regex. If true then the searched key will be taken as regex.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ReplaceOptions Class | Aspose.Cells Namespace


ReplaceOptions Constructor

Initializes a new instance of the ReplaceOptions class.

public ReplaceOptions();

See Also

ReplaceOptions Class | Aspose.Cells Namespace


ReplaceOptions Properties

The properties of the ReplaceOptions class are listed below. For a complete list of ReplaceOptions class members, see the ReplaceOptions Members topic.

Public Instance Properties

CaseSensitive | Indicates if the searched string is case sensitive.
IsCaseSensitive | Obsolete. Indicates if the searched string is case sensitive.
MatchEntireCellContents | Indicates whether to match entire cells contents
RegexKey | Indicates whether the searched key is regex. If true then the searched key will be taken as regex.

See Also

ReplaceOptions Class | Aspose.Cells Namespace


CaseSensitive Property

Aspose.Cells for .NET

ReplaceOptions.CaseSensitive Property

Indicates if the searched string is case sensitive.

public bool CaseSensitive {get; set;}

See Also

ReplaceOptions Class | Aspose.Cells Namespace


IsCaseSensitive Property

Aspose.Cells for .NET

ReplaceOptions.IsCaseSensitive Property

NOTE: This property is now obsolete.

Use ReplaceOptions.CaseSensitive property instead.

Indicates if the searched string is case sensitive.

public bool IsCaseSensitive {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use ReplaceOptions.CaseSensitive property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

ReplaceOptions Class | Aspose.Cells Namespace


MatchEntireCellContents Property

Aspose.Cells for .NET

ReplaceOptions.MatchEntireCellContents Property

Indicates whether to match entire cells contents

public bool MatchEntireCellContents {get; set;}

See Also

ReplaceOptions Class | Aspose.Cells Namespace


RegexKey Property

Aspose.Cells for .NET

ReplaceOptions.RegexKey Property

Indicates whether the searched key is regex. If true then the searched key will be taken as regex.

public bool RegexKey {get; set;}

See Also

ReplaceOptions Class | Aspose.Cells Namespace


ResourceLoadingType Enumeration

Represents how to loading the linked resource.

public enum ResourceLoadingType

Members

Member Name | Description | Value
Default | Loads this resource as usual. | 0
Skip | Skips loading of this resource. | 1
UserProvided | Use stream provided by user | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Row Class

Represents a single row in a worksheet.

For a list of all members of this type, see Row Members.

System.Object
Aspose.Cells.Row

public class Row : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Row Members | Aspose.Cells Namespace


Row Members

Row overview

Public Instance Properties

FirstCell | Gets the first cell object in the row.
FirstDataCell | Gets the first non-blank cell in the row.
GroupLevel | Gets the group level of the row.
Height | Gets and sets the row height in unit of Points.
Index | Gets the index of this row.
IsBlank | Indicates whether the row contains any data
IsHeightMatched | Indicates that row height and default font height matches
IsHidden | Indicates whether the row is hidden.
Item | Gets the cell.
LastCell | Gets the last cell object in the row.
LastDataCell | Gets the last non-blank cell in the row.
Style | Represents the style of this row.

Public Instance Methods

ApplyStyle | Applies formats for a whole row.
CopySettings | Copy settings of row, such as style, height, visibility, ...etc.
Equals | Overloaded. Checks whether this object refers to the same row with another.
GetCellByIndex | Obsolete. Get the cell by specific index in the list.
GetCellOrNull | Gets the cell or null in the specific index.
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Row Class | Aspose.Cells Namespace


Row Properties

The properties of the Row class are listed below. For a complete list of Row class members, see the Row Members topic.

Public Instance Properties

FirstCell | Gets the first cell object in the row.
FirstDataCell | Gets the first non-blank cell in the row.
GroupLevel | Gets the group level of the row.
Height | Gets and sets the row height in unit of Points.
Index | Gets the index of this row.
IsBlank | Indicates whether the row contains any data
IsHeightMatched | Indicates that row height and default font height matches
IsHidden | Indicates whether the row is hidden.
Item | Gets the cell.
LastCell | Gets the last cell object in the row.
LastDataCell | Gets the last non-blank cell in the row.
Style | Represents the style of this row.

See Also

Row Class | Aspose.Cells Namespace


FirstCell Property

Aspose.Cells for .NET

Row.FirstCell Property

Gets the first cell object in the row.

public Cell FirstCell {get;}

See Also

Row Class | Aspose.Cells Namespace


FirstDataCell Property

Aspose.Cells for .NET

Row.FirstDataCell Property

Gets the first non-blank cell in the row.

public Cell FirstDataCell {get;}

See Also

Row Class | Aspose.Cells Namespace


GroupLevel Property

Aspose.Cells for .NET

Row.GroupLevel Property

Gets the group level of the row.

public byte GroupLevel {get;}

See Also

Row Class | Aspose.Cells Namespace


Height Property

Aspose.Cells for .NET

Row.Height Property

Gets and sets the row height in unit of Points.

public double Height {get; set;}

See Also

Row Class | Aspose.Cells Namespace


Index Property

Aspose.Cells for .NET

Row.Index Property

Gets the index of this row.

public int Index {get;}

See Also

Row Class | Aspose.Cells Namespace


IsBlank Property

Aspose.Cells for .NET

Row.IsBlank Property

Indicates whether the row contains any data

public bool IsBlank {get;}

See Also

Row Class | Aspose.Cells Namespace


IsHeightMatched Property

Aspose.Cells for .NET

Row.IsHeightMatched Property

Indicates that row height and default font height matches

public bool IsHeightMatched {get; set;}

See Also

Row Class | Aspose.Cells Namespace


IsHidden Property

Aspose.Cells for .NET

Row.IsHidden Property

Indicates whether the row is hidden.

public bool IsHidden {get; set;}

See Also

Row Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

Row.Item Property

Gets the cell.

public Cell this[
int column
] {get;}

Parameters

column
The column index

See Also

Row Class | Aspose.Cells Namespace


LastCell Property

Aspose.Cells for .NET

Row.LastCell Property

Gets the last cell object in the row.

public Cell LastCell {get;}

See Also

Row Class | Aspose.Cells Namespace


LastDataCell Property

Aspose.Cells for .NET

Row.LastDataCell Property

Gets the last non-blank cell in the row.

public Cell LastDataCell {get;}

See Also

Row Class | Aspose.Cells Namespace


Style Property

Aspose.Cells for .NET

Row.Style Property

Represents the style of this row.

public Style Style {get;}

Remarks

You have to call Row.ApplyStyle() method to save your changing with the row style, otherwise it will not effect.

See Also

Row Class | Aspose.Cells Namespace


Row Methods

The methods of the Row class are listed below. For a complete list of Row class members, see the Row Members topic.

Public Instance Methods

ApplyStyle | Applies formats for a whole row.
CopySettings | Copy settings of row, such as style, height, visibility, ...etc.
Equals | Overloaded. Checks whether this object refers to the same row with another.
GetCellByIndex | Obsolete. Get the cell by specific index in the list.
GetCellOrNull | Gets the cell or null in the specific index.
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Row Class | Aspose.Cells Namespace


Row.ApplyStyle Method

Applies formats for a whole row.

public void ApplyStyle(
Style style,
StyleFlag flag
);

Parameters

style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

See Also

Row Class | Aspose.Cells Namespace


Row.CopySettings Method

Copy settings of row, such as style, height, visibility, ...etc.

public void CopySettings(
Row source,
bool checkStyle
);

Parameters

source
the source row whose settings will be copied to this one
checkStyle
whether check and gather style. Only takes effect and be needed when two row objects belong to different workbook and the styles of two workbooks are different.

See Also

Row Class | Aspose.Cells Namespace


Equals Method

Aspose.Cells for .NET

Row.Equals Method

Checks whether this object refers to the same row with another row object.

Overload List

Checks whether this object refers to the same row with another row object.

public bool Equals(Row);

Checks whether this object refers to the same row with another.

new public bool Equals(object);

See Also

Row Class | Aspose.Cells Namespace


Row.Equals Method (Row)

Checks whether this object refers to the same row with another row object.

public bool Equals(
Row row
);

Parameters

row
another row object

Return Value

true if two row objects refers to the same row.

See Also

Row Class | Aspose.Cells Namespace | Row.Equals Overload List


Row.Equals Method (Object)

Checks whether this object refers to the same row with another.

new public bool Equals(
object obj
);

Parameters

obj
another object

Return Value

true if two objects refers to the same row.

See Also

Row Class | Aspose.Cells Namespace | Row.Equals Overload List


Row.GetCellByIndex Method

NOTE: This method is now obsolete.

Use Row.GetEnumerator() method to iterate all cells in this row instead.

Get the cell by specific index in the list.

public Cell GetCellByIndex(
int index
);

Parameters

index
The position.

Return Value

The Cell object.

Remarks

NOTE: This member is now obsolete. Instead, please use Row.GetEnumerator() method to iterate all cells in this row. This property will be removed 12 months later since February 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

Row Class | Aspose.Cells Namespace


Row.GetCellOrNull Method

Gets the cell or null in the specific index.

public Cell GetCellOrNull(
int column
);

Parameters

column
The column index

Return Value

Returns the cell object if the cell exists. Or returns null if the cell object does not exist.

See Also

Row Class | Aspose.Cells Namespace


Row.GetEnumerator Method

Gets the cells enumerator

public IEnumerator GetEnumerator();

Return Value

The cells enumerator

Implements

IEnumerable.GetEnumerator

See Also

Row Class | Aspose.Cells Namespace


RowCollection Class

Collects the objects that represent the individual rows in a worksheet.

For a list of all members of this type, see RowCollection Members.

System.Object
Aspose.Cells.RowCollection

public class RowCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RowCollection Members | Aspose.Cells Namespace | Row


RowCollection Members

RowCollection overview

Public Instance Properties

Count | Gets the number of rows in this collection.
Item | Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

Public Instance Methods

Clear | Clear all rows and cells.
Equals (inherited from Object) |
GetEnumerator | Gets an enumerator that iterates through this collection
GetHashCode (inherited from Object) |
GetRowByIndex | Gets the row object by the position in the list.
GetType (inherited from Object) |
RemoveAt | Remove the row at the specified index
ToString (inherited from Object) |

See Also

RowCollection Class | Aspose.Cells Namespace | Row


RowCollection Properties

The properties of the RowCollection class are listed below. For a complete list of RowCollection class members, see the RowCollection Members topic.

Public Instance Properties

Count | Gets the number of rows in this collection.
Item | Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

See Also

RowCollection Class | Aspose.Cells Namespace | Row


Count Property

Aspose.Cells for .NET

RowCollection.Count Property

Gets the number of rows in this collection.

public int Count {get;}

See Also

RowCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

RowCollection.Item Property

Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

public Row this[
int rowIndex
] {get;}

See Also

RowCollection Class | Aspose.Cells Namespace | Row


RowCollection Methods

The methods of the RowCollection class are listed below. For a complete list of RowCollection class members, see the RowCollection Members topic.

Public Instance Methods

Clear | Clear all rows and cells.
Equals (inherited from Object) |
GetEnumerator | Gets an enumerator that iterates through this collection
GetHashCode (inherited from Object) |
GetRowByIndex | Gets the row object by the position in the list.
GetType (inherited from Object) |
RemoveAt | Remove the row at the specified index
ToString (inherited from Object) |

See Also

RowCollection Class | Aspose.Cells Namespace | Row


RowCollection.Clear Method

Clear all rows and cells.

public void Clear();

See Also

RowCollection Class | Aspose.Cells Namespace


RowCollection.GetEnumerator Method

Gets an enumerator that iterates through this collection

public IEnumerator GetEnumerator();

Return Value

enumerator

Implements

IEnumerable.GetEnumerator

See Also

RowCollection Class | Aspose.Cells Namespace


RowCollection.GetRowByIndex Method

Gets the row object by the position in the list.

public Row GetRowByIndex(
int index
);

Parameters

index
The position.

Return Value

The Row object at given position.

See Also

RowCollection Class | Aspose.Cells Namespace


RowCollection.RemoveAt Method

Remove the row at the specified index

public void RemoveAt(
int index
);

Parameters

index
zero-based row index

See Also

RowCollection Class | Aspose.Cells Namespace


SaveFormat Enumeration

Represents the format in which the workbook is saved.

public enum SaveFormat

Members

Member Name | Description | Value
CSV | Represents a CSV file. | 1
Xlsx | Represents an xlsx file. | 6
Xlsm | Represents an xlsm file which enable macros. | 7
Xltx | Represents an xltx file. | 8
Xltm | Represents an xltm file which enable macros. | 9
Xlam | Represents an xltm file which enable addin macros. | 10
TSV | Represents a TSV(tab-separated values file) file. | 11
TabDelimited | Represents a tab delimited text file, same with TSV. | 11
Html | Represents a html file. | 12
MHtml | Represents a mhtml file. | 17
ODS | Represents a ods file. | 14
Excel97To2003 | Represents an Excel97-2003 xls file. | 5
SpreadsheetML | Represents an Excel 2003 xml file. | 15
Xlsb | Represents an xlsb file. | 16
Auto | If saving the file to the disk,the file format accords to the extension of the file name. If saving the file to the stream, the file format is xlsx. | 0
Unknown | Represents unrecognized format, cannot be saved. | 255
Pdf | Represents a Pdf file. | 13
XPS | Represents an XPS file. | 20
TIFF | Represents an TIFF file. | 21
SVG | Represents an SVG file. | 22
Dif | Data Interchange Format. | 30
Numbers | Represents a numbers file. | 56
Markdown | Represents markdown document. | 57
FODS | Represents the flat ods file. | 59
SXC | Represents StarOffice Calc Spreadsheet (.sxc) file format. | 60
Pptx | Represents .pptx file. | 61
Docx |  | 62

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


SaveOptions Class

Represents all save options

For a list of all members of this type, see SaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Derived types

public class SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SaveOptions Members | Aspose.Cells Namespace


SaveOptions Members

SaveOptions overview

Public Instance Properties

CachedFileFolder | The cached file folder is used to store some large data.
ClearData | Make the workbook empty after saving the file.
CreateDirectory | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache | Indicates whether refreshing chart cache data
SaveFormat | Gets the save file format.
SortNames | Indicates whether sorting defined names before saving file.
UpdateSmartArt | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas | Indicates whether validate merged cells before saving the file.
WarningCallback | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SaveOptions Class | Aspose.Cells Namespace


SaveOptions Properties

The properties of the SaveOptions class are listed below. For a complete list of SaveOptions class members, see the SaveOptions Members topic.

Public Instance Properties

CachedFileFolder | The cached file folder is used to store some large data.
ClearData | Make the workbook empty after saving the file.
CreateDirectory | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache | Indicates whether refreshing chart cache data
SaveFormat | Gets the save file format.
SortNames | Indicates whether sorting defined names before saving file.
UpdateSmartArt | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas | Indicates whether validate merged cells before saving the file.
WarningCallback | Gets or sets warning callback.

See Also

SaveOptions Class | Aspose.Cells Namespace


CachedFileFolder Property

Aspose.Cells for .NET

SaveOptions.CachedFileFolder Property

The cached file folder is used to store some large data.

public string CachedFileFolder {get; set;}

See Also

SaveOptions Class | Aspose.Cells Namespace


ClearData Property

Aspose.Cells for .NET

SaveOptions.ClearData Property

Make the workbook empty after saving the file.

public bool ClearData {get; set;}

See Also

SaveOptions Class | Aspose.Cells Namespace


CreateDirectory Property

Aspose.Cells for .NET

SaveOptions.CreateDirectory Property

If true and the directory does not exist, the directory will be automatically created before saving the file.

public bool CreateDirectory {get; set;}

Remarks

The default value is false.

See Also

SaveOptions Class | Aspose.Cells Namespace


EnableHTTPCompression Property

Aspose.Cells for .NET

SaveOptions.EnableHTTPCompression Property

NOTE: This property is now obsolete.

Use Workbook.Save(System.Web.HttpResponse, string, ContentDisposition, SaveOptions, bool) method instead.

Indicates if http compression is to be used in user's IIS.

public bool EnableHTTPCompression {get; set;}

Remarks

Please specify this property to true if http compression is used.

See Also

SaveOptions Class | Aspose.Cells Namespace


MergeAreas Property

Aspose.Cells for .NET

SaveOptions.MergeAreas Property

Indicates whether merge the areas of conditional formatting and validation before saving the file.

public bool MergeAreas {get; set;}

Remarks

The default value is false.

See Also

SaveOptions Class | Aspose.Cells Namespace


PdfExportImagesFolder Property

Aspose.Cells for .NET

SaveOptions.PdfExportImagesFolder Property

NOTE: This property is now obsolete.

This property is not used.

The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.

public string PdfExportImagesFolder {get; set;}

See Also

SaveOptions Class | Aspose.Cells Namespace


RefreshChartCache Property

Aspose.Cells for .NET

SaveOptions.RefreshChartCache Property

Indicates whether refreshing chart cache data

public bool RefreshChartCache {get; set;}

See Also

SaveOptions Class | Aspose.Cells Namespace


SaveFormat Property

Aspose.Cells for .NET

SaveOptions.SaveFormat Property

Gets the save file format.

public SaveFormat SaveFormat {get;}

See Also

SaveOptions Class | Aspose.Cells Namespace


SortNames Property

Aspose.Cells for .NET

SaveOptions.SortNames Property

Indicates whether sorting defined names before saving file.

public bool SortNames {get; set;}

See Also

SaveOptions Class | Aspose.Cells Namespace


UpdateSmartArt Property

Aspose.Cells for .NET

SaveOptions.UpdateSmartArt Property

Indicates whether updating smart art setting. The default value is false.

public bool UpdateSmartArt {get; set;}

Remarks

Only effects after calling Shape.GetResultOfSmartArt() method and the cached shapes exist in the template file.

See Also

SaveOptions Class | Aspose.Cells Namespace


ValidateMergedAreas Property

Aspose.Cells for .NET

SaveOptions.ValidateMergedAreas Property

Indicates whether validate merged cells before saving the file.

public bool ValidateMergedAreas {get; set;}

Remarks

The default value is false.

See Also

SaveOptions Class | Aspose.Cells Namespace


WarningCallback Property

Aspose.Cells for .NET

SaveOptions.WarningCallback Property

Gets or sets warning callback.

public IWarningCallback WarningCallback {get; set;}

See Also

SaveOptions Class | Aspose.Cells Namespace


Scenario Class

Represents an individual scenario.

For a list of all members of this type, see Scenario Members.

System.Object
Aspose.Cells.Scenario

public class Scenario

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Scenario Members | Aspose.Cells Namespace


Scenario Members

Scenario overview

Public Instance Properties

Comment | Gets and sets the comment of scenario.
InputCells | Gets the input cells of scenario.
IsHidden | Indicates whether scenario is hidden.
IsLocked | Indicates whether scenario is locked for editing when the sheet is protected.
Name | Gets and sets the name of scenario.
User | Gets name of user who last changed the scenario.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Scenario Class | Aspose.Cells Namespace


Scenario Properties

The properties of the Scenario class are listed below. For a complete list of Scenario class members, see the Scenario Members topic.

Public Instance Properties

Comment | Gets and sets the comment of scenario.
InputCells | Gets the input cells of scenario.
IsHidden | Indicates whether scenario is hidden.
IsLocked | Indicates whether scenario is locked for editing when the sheet is protected.
Name | Gets and sets the name of scenario.
User | Gets name of user who last changed the scenario.

See Also

Scenario Class | Aspose.Cells Namespace


Comment Property

Aspose.Cells for .NET

Scenario.Comment Property

Gets and sets the comment of scenario.

public string Comment {get; set;}

See Also

Scenario Class | Aspose.Cells Namespace


InputCells Property

Aspose.Cells for .NET

Scenario.InputCells Property

Gets the input cells of scenario.

public ScenarioInputCellCollection InputCells {get;}

See Also

Scenario Class | Aspose.Cells Namespace


IsHidden Property

Aspose.Cells for .NET

Scenario.IsHidden Property

Indicates whether scenario is hidden.

public bool IsHidden {get; set;}

See Also

Scenario Class | Aspose.Cells Namespace


IsLocked Property

Aspose.Cells for .NET

Scenario.IsLocked Property

Indicates whether scenario is locked for editing when the sheet is protected.

public bool IsLocked {get; set;}

See Also

Scenario Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

Scenario.Name Property

Gets and sets the name of scenario.

public string Name {get; set;}

See Also

Scenario Class | Aspose.Cells Namespace


User Property

Aspose.Cells for .NET

Scenario.User Property

Gets name of user who last changed the scenario.

public string User {get;}

See Also

Scenario Class | Aspose.Cells Namespace


ScenarioCollection Class

Represents the list of scenarios.

For a list of all members of this type, see ScenarioCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ScenarioCollection

public class ScenarioCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ScenarioCollection Members | Aspose.Cells Namespace


ScenarioCollection Members

ScenarioCollection overview

Public Instance Properties

ActiveIndex | Gets and sets which scenario is selected.
Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Scenario object by the index.
LastSelected | Indicates which scenario was last selected by the user to be run/shown.

Public Instance Methods

Add | Adds a scenario.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ScenarioCollection Class | Aspose.Cells Namespace


ScenarioCollection Properties

The properties of the ScenarioCollection class are listed below. For a complete list of ScenarioCollection class members, see the ScenarioCollection Members topic.

Public Instance Properties

ActiveIndex | Gets and sets which scenario is selected.
Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Scenario object by the index.
LastSelected | Indicates which scenario was last selected by the user to be run/shown.

See Also

ScenarioCollection Class | Aspose.Cells Namespace


ActiveIndex Property

Aspose.Cells for .NET

ScenarioCollection.ActiveIndex Property

Gets and sets which scenario is selected.

public int ActiveIndex {get; set;}

See Also

ScenarioCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ScenarioCollection.Item Property

Gets the Scenario object by the index.

public Scenario this[
int index
] {get;}

Parameters

index
The specific index in the list.

See Also

ScenarioCollection Class | Aspose.Cells Namespace


LastSelected Property

Aspose.Cells for .NET

ScenarioCollection.LastSelected Property

Indicates which scenario was last selected by the user to be run/shown.

public int LastSelected {get; set;}

See Also

ScenarioCollection Class | Aspose.Cells Namespace


ScenarioCollection Methods

The methods of the ScenarioCollection class are listed below. For a complete list of ScenarioCollection class members, see the ScenarioCollection Members topic.

Public Instance Methods

Add | Adds a scenario.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ScenarioCollection Class | Aspose.Cells Namespace


ScenarioCollection.Add Method

Adds a scenario.

public int Add(
string name
);

Parameters

name
The name of scenario.

Return Value

The index in the list of scenarios.

See Also

ScenarioCollection Class | Aspose.Cells Namespace


ScenarioInputCell Class

Represents input cell for the scenario.

For a list of all members of this type, see ScenarioInputCell Members.

System.Object
Aspose.Cells.ScenarioInputCell

public class ScenarioInputCell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ScenarioInputCell Members | Aspose.Cells Namespace


ScenarioInputCell Members

ScenarioInputCell overview

Public Instance Properties

Column | Gets and sets the column index of the input cell.
IsDeleted | Indicates whether input cell is deleted.
Name | Gets and sets the input cell address.
Row | Gets and sets the row index of the input cell.
Value | Gets and sets value of the input cell.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


ScenarioInputCell Properties

The properties of the ScenarioInputCell class are listed below. For a complete list of ScenarioInputCell class members, see the ScenarioInputCell Members topic.

Public Instance Properties

Column | Gets and sets the column index of the input cell.
IsDeleted | Indicates whether input cell is deleted.
Name | Gets and sets the input cell address.
Row | Gets and sets the row index of the input cell.
Value | Gets and sets value of the input cell.

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


Column Property

Aspose.Cells for .NET

ScenarioInputCell.Column Property

Gets and sets the column index of the input cell.

public int Column {get;}

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


IsDeleted Property

Aspose.Cells for .NET

ScenarioInputCell.IsDeleted Property

Indicates whether input cell is deleted.

public bool IsDeleted {get; set;}

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

ScenarioInputCell.Name Property

Gets and sets the input cell address.

public string Name {get;}

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


Row Property

Aspose.Cells for .NET

ScenarioInputCell.Row Property

Gets and sets the row index of the input cell.

public int Row {get;}

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


Value Property

Aspose.Cells for .NET

ScenarioInputCell.Value Property

Gets and sets value of the input cell.

public string Value {get; set;}

See Also

ScenarioInputCell Class | Aspose.Cells Namespace


ScenarioInputCellCollection Class

Represents the list of the scenario's input cells.

For a list of all members of this type, see ScenarioInputCellCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ScenarioInputCellCollection

public class ScenarioInputCellCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ScenarioInputCellCollection Members | Aspose.Cells Namespace


ScenarioInputCellCollection Members

ScenarioInputCellCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets ScenarioInputCell by index in the list.

Public Instance Methods

Add | Adds an input cell.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ScenarioInputCellCollection Class | Aspose.Cells Namespace


ScenarioInputCellCollection Properties

The properties of the ScenarioInputCellCollection class are listed below. For a complete list of ScenarioInputCellCollection class members, see the ScenarioInputCellCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets ScenarioInputCell by index in the list.

See Also

ScenarioInputCellCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ScenarioInputCellCollection.Item Property

Gets ScenarioInputCell by index in the list.

public ScenarioInputCell this[
int index
] {get;}

Parameters

index
The specific index in the list

See Also

ScenarioInputCellCollection Class | Aspose.Cells Namespace


ScenarioInputCellCollection Methods

The methods of the ScenarioInputCellCollection class are listed below. For a complete list of ScenarioInputCellCollection class members, see the ScenarioInputCellCollection Members topic.

Public Instance Methods

Add | Adds an input cell.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ScenarioInputCellCollection Class | Aspose.Cells Namespace


ScenarioInputCellCollection.Add Method

Adds an input cell.

public int Add(
int row,
int column,
string value
);

Parameters

row
The row index of input cell.
column
The column index of input cell.
value
The value of input cell.

Return Value

See Also

ScenarioInputCellCollection Class | Aspose.Cells Namespace


SheetType Enumeration

Specifies the worksheet type.

public enum SheetType

Members

Member Name | Description | Value
VB | Visual Basic module | 0
Worksheet |  | 1
Chart | Chart | 2
BIFF4Macro | BIFF4 Macro sheet | 3
InternationalMacro | International Macro sheet | 4
Other |  | 5
Dialog | Dialog worksheet | 6

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ShiftType Enumeration

Represent the shift options when deleting a range of cells.

public enum ShiftType

Members

Member Name | Description | Value
Down | Shift cells down. | 0
Left | Shift cells left. | 1
None | Do not shift cells. | 2
Right | Shift cells right. | 3
Up | Shift cells up. | 4

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


SortOnType Enumeration

Sorted value type.

public enum SortOnType

Members

Member Name | Description | Value
Value | Sorts by cells' value. | 0
CellColor | Sorts by cells' color. | 1
FontColor | Sorts by cells' font color. | 2
Icon | Sorts by conditional icon. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


SortOrder Enumeration

Represents sort order for the data range.

public enum SortOrder

Members

Member Name | Description | Value
Ascending |  | 0
Descending |  | 1

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


SpreadsheetML2003SaveOptions Class

Represents the options for saving Excel 2003 spreadml file.

For a list of all members of this type, see SpreadsheetML2003SaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.SpreadsheetML2003SaveOptions

public class SpreadsheetML2003SaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SpreadsheetML2003SaveOptions Members | Aspose.Cells Namespace


SpreadsheetML2003SaveOptions Members

SpreadsheetML2003SaveOptions overview

Public Instance Constructors

SpreadsheetML2003SaveOptions Overloaded. Initializes a new instance of the SpreadsheetML2003SaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ExportColumnIndexOfCell | The default value is false, it means that column index will be ignored if the cell is contiguous to the previous cell.
IsIndentedFormatting | Causes child elements to be indented.
LimitAsXls | Limit as xls, the max row index is 65535 and the max column index is 255.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace


SpreadsheetML2003SaveOptions Constructor

Creates the options for saving Excel 2003 spreadml file.

Overload List

Creates the options for saving Excel 2003 spreadml file.

public SpreadsheetML2003SaveOptions();

Creates the options for saving Excel 2003 spreadml file.

public SpreadsheetML2003SaveOptions(SaveFormat);

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace


SpreadsheetML2003SaveOptions Constructor ()

Creates the options for saving Excel 2003 spreadml file.

public SpreadsheetML2003SaveOptions();

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace | SpreadsheetML2003SaveOptions Constructor Overload List


SpreadsheetML2003SaveOptions Constructor (SaveFormat)

Creates the options for saving Excel 2003 spreadml file.

public SpreadsheetML2003SaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The save format.

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace | SpreadsheetML2003SaveOptions Constructor Overload List


SpreadsheetML2003SaveOptions Properties

The properties of the SpreadsheetML2003SaveOptions class are listed below. For a complete list of SpreadsheetML2003SaveOptions class members, see the SpreadsheetML2003SaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ExportColumnIndexOfCell | The default value is false, it means that column index will be ignored if the cell is contiguous to the previous cell.
IsIndentedFormatting | Causes child elements to be indented.
LimitAsXls | Limit as xls, the max row index is 65535 and the max column index is 255.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace


ExportColumnIndexOfCell Property

Aspose.Cells for .NET

SpreadsheetML2003SaveOptions.ExportColumnIndexOfCell Property

The default value is false, it means that column index will be ignored if the cell is contiguous to the previous cell.

public bool ExportColumnIndexOfCell {get; set;}

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace


IsIndentedFormatting Property

Aspose.Cells for .NET

SpreadsheetML2003SaveOptions.IsIndentedFormatting Property

Causes child elements to be indented.

public bool IsIndentedFormatting {get; set;}

Remarks

The default value is true. If the value is false, it will reduce the size of the xml file

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace


LimitAsXls Property

Aspose.Cells for .NET

SpreadsheetML2003SaveOptions.LimitAsXls Property

Limit as xls, the max row index is 65535 and the max column index is 255.

public bool LimitAsXls {get; set;}

See Also

SpreadsheetML2003SaveOptions Class | Aspose.Cells Namespace


StreamProviderOptions Class

Represents the stream options.

For a list of all members of this type, see StreamProviderOptions Members.

System.Object
Aspose.Cells.StreamProviderOptions

public class StreamProviderOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

StreamProviderOptions Members | Aspose.Cells Namespace


StreamProviderOptions Members

StreamProviderOptions overview

Public Instance Constructors

StreamProviderOptions Overloaded. Initializes a new instance of the StreamProviderOptions class.

Public Instance Properties

CustomPath | The user custom path(URL) saved in generated html file for the referred source. If not defined by user, DefaultPath will be used. For example, the sheet data will be saved by user to d:/sheet001.htm, the url used in the main html file should be "d:/sheet001.htm" or other valid relative path that can be accessed by the main html file.
DefaultPath | The default path(URL) saved in generated html file for the referred source. For example, the sheet data saved in xxx_files/sheet001.htm, the url used in the main html file should be like "src="xxx_files/sheet001.htm""
ResourceLoadingType | Gets and sets the type of loading resource.
Stream | Gets/Sets the stream

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


StreamProviderOptions Constructor

Initializes a new instance of the StreamProviderOptions class.

Overload List

Initializes a new instance of the StreamProviderOptions class.

public StreamProviderOptions();

Initializes a new instance of the StreamProviderOptions class.

public StreamProviderOptions(ResourceLoadingType,string);

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


StreamProviderOptions Constructor (ResourceLoadingType, String)

Initializes a new instance of the StreamProviderOptions class.

public StreamProviderOptions(
ResourceLoadingType loadingType,
string defaultPath
);

Parameters

loadingType
The type to load the linked resource.
defaultPath
The default path.

See Also

StreamProviderOptions Class | Aspose.Cells Namespace | StreamProviderOptions Constructor Overload List


StreamProviderOptions Constructor ()

Initializes a new instance of the StreamProviderOptions class.

public StreamProviderOptions();

See Also

StreamProviderOptions Class | Aspose.Cells Namespace | StreamProviderOptions Constructor Overload List


StreamProviderOptions Properties

The properties of the StreamProviderOptions class are listed below. For a complete list of StreamProviderOptions class members, see the StreamProviderOptions Members topic.

Public Instance Properties

CustomPath | The user custom path(URL) saved in generated html file for the referred source. If not defined by user, DefaultPath will be used. For example, the sheet data will be saved by user to d:/sheet001.htm, the url used in the main html file should be "d:/sheet001.htm" or other valid relative path that can be accessed by the main html file.
DefaultPath | The default path(URL) saved in generated html file for the referred source. For example, the sheet data saved in xxx_files/sheet001.htm, the url used in the main html file should be like "src="xxx_files/sheet001.htm""
ResourceLoadingType | Gets and sets the type of loading resource.
Stream | Gets/Sets the stream

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


CustomPath Property

Aspose.Cells for .NET

StreamProviderOptions.CustomPath Property

The user custom path(URL) saved in generated html file for the referred source. If not defined by user, DefaultPath will be used. For example, the sheet data will be saved by user to d:/sheet001.htm, the url used in the main html file should be "d:/sheet001.htm" or other valid relative path that can be accessed by the main html file.

public string CustomPath {set;}

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


DefaultPath Property

Aspose.Cells for .NET

StreamProviderOptions.DefaultPath Property

The default path(URL) saved in generated html file for the referred source. For example, the sheet data saved in xxx_files/sheet001.htm, the url used in the main html file should be like "src="xxx_files/sheet001.htm""

public string DefaultPath {get;}

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


ResourceLoadingType Property

Aspose.Cells for .NET

StreamProviderOptions.ResourceLoadingType Property

Gets and sets the type of loading resource.

public ResourceLoadingType ResourceLoadingType {get; set;}

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


Stream Property

Aspose.Cells for .NET

StreamProviderOptions.Stream Property

Gets/Sets the stream

public Stream Stream {get; set;}

See Also

StreamProviderOptions Class | Aspose.Cells Namespace


Style Class

Represents display style of excel document,such as font,color,alignment,border,etc.

For a list of all members of this type, see Style Members.

System.Object
Aspose.Cells.Style

public class Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
        Cell cell = excel.Worksheets[0].Cells["A1"];
        Style style =  cell.GetStyle();
        style.Font.Name = "Times New Roman";
        style.Font.Color = Color.Blue;
        cell.SetStyle(style);

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Style Members | Aspose.Cells Namespace


Style Members

Style overview

Public Instance Constructors

Style Constructor Initializes a new instance of the Style class.

Public Instance Properties

BackgroundArgbColor | Gets and sets the background color with a 32-bit ARGB value.
BackgroundColor | Gets or sets a style's background color.
BackgroundThemeColor | Gets and sets the background theme color.
Borders | Gets the BorderCollection of the style.
CultureCustom | Gets and sets the culture-dependent pattern string for number format. If no number format has been set for this object, null will be returned. If number format is builtin, the pattern string corresponding to the builtin number will be returned.
Custom | Represents the custom number format string of this style object. If the custom number format is not set(For example, the number format is builtin), "" will be returned.
Font | Gets a Font object.
ForegroundArgbColor | Gets and sets the foreground color with a 32-bit ARGB value.
ForegroundColor | Gets or sets a style's foreground color.
ForegroundThemeColor | Gets and sets the foreground theme color.
HorizontalAlignment | Gets or sets the horizontal alignment type of the text in a cell.
IndentLevel | Represents the indent level for the cell or range. Can only be an integer from 0 to 250.
InvariantCustom | Gets the culture-independent pattern string for number format. If no number format has been set for this object, null will be returned. If number format is builtin, the pattern string corresponding to the builtin number will be returned.
IsDateTime | Indicates whether the number format is a date format.
IsFormulaHidden | Represents if the formula will be hidden when the worksheet is protected.
IsGradient | Indicates whether the cell shading is a gradient pattern.
IsJustifyDistributed | Indicates if the cells justified or distributed alignment should be used on the last line of text.
IsLocked | Gets or sets a value indicating whether a cell can be modified or not.
IsPercent | Indicates whether the number format is a percent format.
IsTextWrapped | Gets or sets a value indicating whether the text within a cell is wrapped.
Name | Gets or sets the name of the style.
Number | Gets or sets the display format of numbers and dates. The formatting patterns are different for different regions.
ParentStyle | Gets the parent style of this style.
Pattern | Gets or sets the cell background pattern type.
QuotePrefix | Indicates whether the cell's value starts with single quote mark.
RotationAngle | Represents text rotation angle.
ShrinkToFit | Represents if text automatically shrinks to fit in the available column width.
TextDirection | Represents text reading order.
VerticalAlignment | Gets or sets the vertical alignment type of the text in a cell.

Public Instance Methods

Copy | Copies data from another style object
Equals | Determines whether two Style instances are equal.
GetHashCode | Serves as a hash function for a Style object.
GetTwoColorGradient |
GetType (inherited from Object) |
IsModified | Checks whether the specified properties of the style have been modified. Used for style of ConditionalFormattings to check whether the specified properties of this style should be used when applying the ConditionalFormattings on a cell.
SetBorder | Sets the border of the style.
SetCustom | Sets the Custom number format string of a cell.
SetPatternColor | Sets the background color.
SetTwoColorGradient | Sets the specified fill to a two-color gradient.
ToString (inherited from Object) |
Update | Apply the named style to the styles of the cells which use this named style. It works like clicking the "ok" button after you finished modifying the style. Only applies for named style.

See Also

Style Class | Aspose.Cells Namespace


Style Constructor

NOTE: This constructor is now obsolete.

Use CellsFactory.CreateStyle() method instead.

Initializes a new instance of the Style class.

public Style();

Remarks

NOTE: This constructor is now obsolete. Instead, please use CellsFactory.CreateStyle() method. This property will be removed 6 months later since October 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Style Class | Aspose.Cells Namespace


Style Properties

The properties of the Style class are listed below. For a complete list of Style class members, see the Style Members topic.

Public Instance Properties

BackgroundArgbColor | Gets and sets the background color with a 32-bit ARGB value.
BackgroundColor | Gets or sets a style's background color.
BackgroundThemeColor | Gets and sets the background theme color.
Borders | Gets the BorderCollection of the style.
CultureCustom | Gets and sets the culture-dependent pattern string for number format. If no number format has been set for this object, null will be returned. If number format is builtin, the pattern string corresponding to the builtin number will be returned.
Custom | Represents the custom number format string of this style object. If the custom number format is not set(For example, the number format is builtin), "" will be returned.
Font | Gets a Font object.
ForegroundArgbColor | Gets and sets the foreground color with a 32-bit ARGB value.
ForegroundColor | Gets or sets a style's foreground color.
ForegroundThemeColor | Gets and sets the foreground theme color.
HorizontalAlignment | Gets or sets the horizontal alignment type of the text in a cell.
IndentLevel | Represents the indent level for the cell or range. Can only be an integer from 0 to 250.
InvariantCustom | Gets the culture-independent pattern string for number format. If no number format has been set for this object, null will be returned. If number format is builtin, the pattern string corresponding to the builtin number will be returned.
IsDateTime | Indicates whether the number format is a date format.
IsFormulaHidden | Represents if the formula will be hidden when the worksheet is protected.
IsGradient | Indicates whether the cell shading is a gradient pattern.
IsJustifyDistributed | Indicates if the cells justified or distributed alignment should be used on the last line of text.
IsLocked | Gets or sets a value indicating whether a cell can be modified or not.
IsPercent | Indicates whether the number format is a percent format.
IsTextWrapped | Gets or sets a value indicating whether the text within a cell is wrapped.
Name | Gets or sets the name of the style.
Number | Gets or sets the display format of numbers and dates. The formatting patterns are different for different regions.
ParentStyle | Gets the parent style of this style.
Pattern | Gets or sets the cell background pattern type.
QuotePrefix | Indicates whether the cell's value starts with single quote mark.
RotationAngle | Represents text rotation angle.
ShrinkToFit | Represents if text automatically shrinks to fit in the available column width.
TextDirection | Represents text reading order.
VerticalAlignment | Gets or sets the vertical alignment type of the text in a cell.

See Also

Style Class | Aspose.Cells Namespace


BackgroundArgbColor Property

Aspose.Cells for .NET

Style.BackgroundArgbColor Property

Gets and sets the background color with a 32-bit ARGB value.

public int BackgroundArgbColor {get; set;}

See Also

Style Class | Aspose.Cells Namespace


BackgroundColor Property

Aspose.Cells for .NET

Style.BackgroundColor Property

Gets or sets a style's background color.

public Color BackgroundColor {get; set;}

Remarks

If you want to set a cell's color, please use Style.ForegroundColor property. Only if the cell style pattern is other than none or solid, this property will take effect.

See Also

Style Class | Aspose.Cells Namespace


BackgroundThemeColor Property

Aspose.Cells for .NET

Style.BackgroundThemeColor Property

Gets and sets the background theme color.

public ThemeColor BackgroundThemeColor {get; set;}

Remarks

If the background color is not a theme color, NULL will be returned.

See Also

Style Class | Aspose.Cells Namespace


Borders Property

Aspose.Cells for .NET

Style.Borders Property

Gets the BorderCollection of the style.

public BorderCollection Borders {get;}

See Also

Style Class | Aspose.Cells Namespace


CultureCustom Property

Aspose.Cells for .NET

Style.CultureCustom Property

Gets and sets the culture-dependent pattern string for number format. If no number format has been set for this object, null will be returned. If number format is builtin, the pattern string corresponding to the builtin number will be returned.

public string CultureCustom {get; set;}

Remarks

For builtin number format, both the pattern content(such as, one builtin date format is "m/d/y" for some locales, but for some other locales it becomes "d/m/y") and the format specifier(such as, some locales is using character other than 'y' to represent the year part for date formatting) are culture-dependent; For user specified custom format, only format specifiers are changed according to the culture, other parts of the formatting pattern will not be modified.

See Also

Style Class | Aspose.Cells Namespace


Custom Property

Aspose.Cells for .NET

Style.Custom Property

Represents the custom number format string of this style object. If the custom number format is not set(For example, the number format is builtin), "" will be returned.

public string Custom {get; set;}

Remarks

The returned custom string is culture-independent.

See Also

Style Class | Aspose.Cells Namespace


Font Property

Aspose.Cells for .NET

Style.Font Property

Gets a Font object.

public Font Font {get;}

See Also

Style Class | Aspose.Cells Namespace


ForegroundArgbColor Property

Aspose.Cells for .NET

Style.ForegroundArgbColor Property

Gets and sets the foreground color with a 32-bit ARGB value.

public int ForegroundArgbColor {get; set;}

See Also

Style Class | Aspose.Cells Namespace


ForegroundColor Property

Aspose.Cells for .NET

Style.ForegroundColor Property

Gets or sets a style's foreground color.

public Color ForegroundColor {get; set;}

Remarks

It means no color setting if Color.Empty is returned.

See Also

Style Class | Aspose.Cells Namespace


ForegroundThemeColor Property

Aspose.Cells for .NET

Style.ForegroundThemeColor Property

Gets and sets the foreground theme color.

public ThemeColor ForegroundThemeColor {get; set;}

Remarks

If the foreground color is not a theme color, NULL will be returned.

See Also

Style Class | Aspose.Cells Namespace


HorizontalAlignment Property

Aspose.Cells for .NET

Style.HorizontalAlignment Property

Gets or sets the horizontal alignment type of the text in a cell.

public TextAlignmentType HorizontalAlignment {get; set;}

See Also

Style Class | Aspose.Cells Namespace


IndentLevel Property

Aspose.Cells for .NET

Style.IndentLevel Property

Represents the indent level for the cell or range. Can only be an integer from 0 to 250.

public int IndentLevel {get; set;}

Remarks

If text horizontal alignment type is set to value other than left or right, indent level will be reset to zero.

See Also

Style Class | Aspose.Cells Namespace


InvariantCustom Property

Aspose.Cells for .NET

Style.InvariantCustom Property

Gets the culture-independent pattern string for number format. If no number format has been set for this object, null will be returned. If number format is builtin, the pattern string corresponding to the builtin number will be returned.

public string InvariantCustom {get;}

Remarks

For builtin number formats, the returned pattern content is still culture-dependent, such as, for some locales it returns "m/d/y" and for some other locales it returns "d/m/y". The difference from CultureCustom is(that is also what culture-independent means): the format specifiers and separators are kept as standard, such as '/' will always be used as datetime separator and "y" will always be used as the "year" part no matter what other special character is used for the specific locale.

See Also

Style Class | Aspose.Cells Namespace


IsDateTime Property

Aspose.Cells for .NET

Style.IsDateTime Property

Indicates whether the number format is a date format.

public bool IsDateTime {get;}

See Also

Style Class | Aspose.Cells Namespace


IsFormulaHidden Property

Aspose.Cells for .NET

Style.IsFormulaHidden Property

Represents if the formula will be hidden when the worksheet is protected.

public bool IsFormulaHidden {get; set;}

See Also

Style Class | Aspose.Cells Namespace


IsGradient Property

Aspose.Cells for .NET

Style.IsGradient Property

Indicates whether the cell shading is a gradient pattern.

public bool IsGradient {get; set;}

See Also

Style Class | Aspose.Cells Namespace


IsJustifyDistributed Property

Aspose.Cells for .NET

Style.IsJustifyDistributed Property

Indicates if the cells justified or distributed alignment should be used on the last line of text.

public bool IsJustifyDistributed {get; set;}

Remarks

This is typical for East Asian alignments but not typical in other contexts.

See Also

Style Class | Aspose.Cells Namespace


IsLocked Property

Aspose.Cells for .NET

Style.IsLocked Property

Gets or sets a value indicating whether a cell can be modified or not.

public bool IsLocked {get; set;}

Remarks

Locking cells has no effect unless the worksheet is protected.

See Also

Style Class | Aspose.Cells Namespace


IsPercent Property

Aspose.Cells for .NET

Style.IsPercent Property

Indicates whether the number format is a percent format.

public bool IsPercent {get;}

See Also

Style Class | Aspose.Cells Namespace


IsTextWrapped Property

Aspose.Cells for .NET

Style.IsTextWrapped Property

Gets or sets a value indicating whether the text within a cell is wrapped.

public bool IsTextWrapped {get; set;}

See Also

Style Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

Style.Name Property

Gets or sets the name of the style.

public string Name {get; set;}

See Also

Style Class | Aspose.Cells Namespace


Number Property

Aspose.Cells for .NET

Style.Number Property

Gets or sets the display format of numbers and dates. The formatting patterns are different for different regions.

public int Number {get; set;}

Remarks

For example, the formatting patterns represented by numbers for en_US region:
Value | Type | Format String
0 | General | General
1 | Decimal | 0
2 | Decimal | 0.00
3 | Decimal | #,##0
4 | Decimal | #,##0.00
5 | Currency | $#,##0_);($#,##0)
6 | Currency | $#,##0_);[Red]($#,##0)
7 | Currency | $#,##0.00_);($#,##0.00)
8 | Currency | $#,##0.00_);[Red]($#,##0.00)
9 | Percentage | 0%
10 | Percentage | 0.00%
11 | Scientific | 0.00E+00
12 | Fraction | # ?/?
13 | Fraction | # ??/??
14 | Date | m/d/yyyy
15 | Date | d-mmm-yy
16 | Date | d-mmm
17 | Date | mmm-yy
18 | Time | h:mm AM/PM
19 | Time | h:mm:ss AM/PM
20 | Time | h:mm
21 | Time | h:mm:ss
22 | Time | m/d/yyyy h:mm
37 | Accounting | #,##0_);(#,##0)
38 | Accounting | #,##0_);[Red](#,##0)
39 | Accounting | #,##0.00_);(#,##0.00)
40 | Accounting | #,##0.00_);[Red](#,##0.00)
41 | Accounting | _(* #,##0_);_(* (#,##0);_(* "-"_);_(@_)
42 | Currency | _($* #,##0_);_($* (#,##0);_($* "-"_);_(@_)
43 | Accounting | _(* #,##0.00_);_(* (#,##0.00);_(* "-"??_);_(@_)
44 | Currency | _($* #,##0.00_);_($* (#,##0.00);_($* "-"??_);_(@_)
45 | Time | mm:ss
46 | Time | [h]:mm:ss
47 | Time | mm:ss.0
48 | Scientific | ##0.0E+0
49 | Text | @

See Also

Style Class | Aspose.Cells Namespace


ParentStyle Property

Aspose.Cells for .NET

Style.ParentStyle Property

Gets the parent style of this style.

public Style ParentStyle {get;}

See Also

Style Class | Aspose.Cells Namespace


Pattern Property

Aspose.Cells for .NET

Style.Pattern Property

Gets or sets the cell background pattern type.

public BackgroundType Pattern {get; set;}

See Also

Style Class | Aspose.Cells Namespace


QuotePrefix Property

Aspose.Cells for .NET

Style.QuotePrefix Property

Indicates whether the cell's value starts with single quote mark.

public bool QuotePrefix {get; set;}

See Also

Style Class | Aspose.Cells Namespace


RotationAngle Property

Aspose.Cells for .NET

Style.RotationAngle Property

Represents text rotation angle.

public int RotationAngle {get; set;}

Remarks

0: Not rotated.

255: Top to Bottom.

-90: Downward.

90: Upward.

You can set 255 or value ranged from -90 to 90.

See Also

Style Class | Aspose.Cells Namespace


ShrinkToFit Property

Aspose.Cells for .NET

Style.ShrinkToFit Property

Represents if text automatically shrinks to fit in the available column width.

public bool ShrinkToFit {get; set;}

See Also

Style Class | Aspose.Cells Namespace


TextDirection Property

Aspose.Cells for .NET

Style.TextDirection Property

Represents text reading order.

public TextDirectionType TextDirection {get; set;}

See Also

Style Class | Aspose.Cells Namespace


VerticalAlignment Property

Aspose.Cells for .NET

Style.VerticalAlignment Property

Gets or sets the vertical alignment type of the text in a cell.

public TextAlignmentType VerticalAlignment {get; set;}

See Also

Style Class | Aspose.Cells Namespace


Style Methods

The methods of the Style class are listed below. For a complete list of Style class members, see the Style Members topic.

Public Instance Methods

Copy | Copies data from another style object
Equals | Determines whether two Style instances are equal.
GetHashCode | Serves as a hash function for a Style object.
GetTwoColorGradient |
GetType (inherited from Object) |
IsModified | Checks whether the specified properties of the style have been modified. Used for style of ConditionalFormattings to check whether the specified properties of this style should be used when applying the ConditionalFormattings on a cell.
SetBorder | Sets the border of the style.
SetCustom | Sets the Custom number format string of a cell.
SetPatternColor | Sets the background color.
SetTwoColorGradient | Sets the specified fill to a two-color gradient.
ToString (inherited from Object) |
Update | Apply the named style to the styles of the cells which use this named style. It works like clicking the "ok" button after you finished modifying the style. Only applies for named style.

See Also

Style Class | Aspose.Cells Namespace


Style.Copy Method

Copies data from another style object

public void Copy(
Style style
);

Parameters

style
Source Style object

Remarks

This method does not copy the name of the style. If you want to copy the name, please call the following codes after copying style: destStyle.Name = style.Name.

See Also

Style Class | Aspose.Cells Namespace


Style.Equals Method

Determines whether two Style instances are equal.

public override bool Equals(
object obj
);

Parameters

obj
The Style object to compare with the current Style object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

Style Class | Aspose.Cells Namespace


Style.GetHashCode Method

Serves as a hash function for a Style object.

public override int GetHashCode();

Return Value

A hash code for the current Object.

Remarks

This method is only for internal use.

See Also

Style Class | Aspose.Cells Namespace


Style.GetTwoColorGradient Method

public void GetTwoColorGradient(
out Color color1,
out Color color2,
out GradientStyleType gradientStyleType,
out int variant
);

See Also

Style Class | Aspose.Cells Namespace


Style.IsModified Method

Checks whether the specified properties of the style have been modified. Used for style of ConditionalFormattings to check whether the specified properties of this style should be used when applying the ConditionalFormattings on a cell.

public bool IsModified(
StyleModifyFlag modifyFlag
);

Parameters

modifyFlag
Style modified flags

Return Value

true if the specified properties have been modified

See Also

Style Class | Aspose.Cells Namespace


Style.SetBorder Method

Sets the border of the style.

public bool SetBorder(
BorderType borderEdge,
CellBorderType borderStyle,
Color borderColor
);

Parameters

borderEdge
borderStyle
borderColor

Return Value

See Also

Style Class | Aspose.Cells Namespace


Style.SetCustom Method

Sets the Custom number format string of a cell.

public void SetCustom(
string custom,
bool builtinPreference
);

Parameters

custom
Custom number format string, should be InvariantCulture pattern.
builtinPreference
If given Custom number format string matches one of the built-in number formats corresponding to current regional settings, whether set the number format as built-in instead of Custom.

See Also

Style Class | Aspose.Cells Namespace


Style.SetPatternColor Method

Sets the background color.

public void SetPatternColor(
BackgroundType pattern,
Color color1,
Color color2
);

Parameters

pattern
The pattern.
color1
The foreground color.
color2
The background color. Only works when pattern is not BackgroundType.None and BackgroundType.Solid.

See Also

Style Class | Aspose.Cells Namespace


Style.SetTwoColorGradient Method

Sets the specified fill to a two-color gradient.

public void SetTwoColorGradient(
Color color1,
Color color2,
GradientStyleType gradientStyleType,
int variant
);

Parameters

color1
One gradient color.
color2
Two gradient color.
gradientStyleType
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

Style Class | Aspose.Cells Namespace


Style.Update Method

Apply the named style to the styles of the cells which use this named style. It works like clicking the "ok" button after you finished modifying the style. Only applies for named style.

public void Update();

See Also

Style Class | Aspose.Cells Namespace


StyleCollection Class

NOTE: This class is now obsolete.

Use Workbook.CreateStyle() and Workbook.GetNamedStyle(string) instead

For a list of all members of this type, see StyleCollection Members.

System.Object
Aspose.Cells.StyleCollection

public class StyleCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

StyleCollection Members | Aspose.Cells Namespace


StyleCollection Members

StyleCollection overview

Public Instance Properties

Count |
Item | Overloaded.

Public Instance Methods

Add | Obsolete.
CreateBuiltinStyle |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetThemeStyle |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

StyleCollection Class | Aspose.Cells Namespace


StyleCollection Properties

The properties of the StyleCollection class are listed below. For a complete list of StyleCollection class members, see the StyleCollection Members topic.

Public Instance Properties

Count |
Item | Overloaded.

See Also

StyleCollection Class | Aspose.Cells Namespace


Count Property

Aspose.Cells for .NET

StyleCollection.Count Property

public int Count {get;}

See Also

StyleCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

StyleCollection.Item Property

Overload List

public Style this[int] {get;}

public Style this[string] {get;}

See Also

StyleCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

StyleCollection.Item Property (Int32)

public Style this[
int index
] {get;}

See Also

StyleCollection Class | Aspose.Cells Namespace | StyleCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

StyleCollection.Item Property (String)

public Style this[
string name
] {get;}

See Also

StyleCollection Class | Aspose.Cells Namespace | StyleCollection.Item Overload List


StyleCollection Methods

The methods of the StyleCollection class are listed below. For a complete list of StyleCollection class members, see the StyleCollection Members topic.

Public Instance Methods

Add | Obsolete.
CreateBuiltinStyle |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetThemeStyle |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

StyleCollection Class | Aspose.Cells Namespace


StyleCollection.Add Method

NOTE: This method is now obsolete.

Use Cells.GetEnumerator() method to iterate all cells in this worksheet instead.

public int Add();

See Also

StyleCollection Class | Aspose.Cells Namespace


StyleCollection.CreateBuiltinStyle Method

public Style CreateBuiltinStyle(
BuiltinStyleType type
);

See Also

StyleCollection Class | Aspose.Cells Namespace


StyleCollection.GetThemeStyle Method

public Style GetThemeStyle(
ThemeColorType themeColorType,
double tint
);

See Also

StyleCollection Class | Aspose.Cells Namespace


StyleFlag Class

Represents flags which indicates applied formatting properties.

For a list of all members of this type, see StyleFlag Members.

System.Object
Aspose.Cells.StyleFlag

public class StyleFlag

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

StyleFlag Members | Aspose.Cells Namespace


StyleFlag Members

StyleFlag overview

Public Instance Constructors

StyleFlag Constructor Initializes a new instance of the StyleFlag class.

Public Instance Properties

Alignments | Alignment setting will be applied.
All | All properties will be applied.
Borders | All borders settings will be applied.
BottomBorder | Bottom border settings will be applied.
CellShading | Cell shading setting will be applied.
DiagonalDownBorder | Diagonal down border settings will be applied.
DiagonalUpBorder | Diagonal up border settings will be applied.
Font | Font settings will be applied.
FontBold | Font bold setting will be applied.
FontColor | Font color setting will be applied.
FontItalic | Font italic setting will be applied.
FontName | Font name setting will be applied.
FontScript | Font script setting will be applied.
FontSize | Font size setting will be applied.
FontStrike | Font strikeout setting will be applied.
FontUnderline | Font underline setting will be applied.
HideFormula | Hide formula setting will be applied.
HorizontalAlignment | Horizontal alignment setting will be applied.
Indent | Indent level setting will be applied.
LeftBorder | Left border settings will be applied.
Locked | Locked setting will be applied.
NumberFormat | Number format setting will be applied.
QuotePrefix | Hide formula setting will be applied.
RightBorder | Right border settings will be applied.
Rotation | Rotation setting will be applied.
ShrinkToFit | Shrink to fit setting will be applied.
TextDirection | Text direction setting will be applied.
TopBorder | Top border settings will be applied.
VerticalAlignment | Vertical alignment setting will be applied.
WrapText | Wrap text setting will be applied.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

StyleFlag Class | Aspose.Cells Namespace


StyleFlag Constructor

Initializes a new instance of the StyleFlag class.

public StyleFlag();

See Also

StyleFlag Class | Aspose.Cells Namespace


StyleFlag Properties

The properties of the StyleFlag class are listed below. For a complete list of StyleFlag class members, see the StyleFlag Members topic.

Public Instance Properties

Alignments | Alignment setting will be applied.
All | All properties will be applied.
Borders | All borders settings will be applied.
BottomBorder | Bottom border settings will be applied.
CellShading | Cell shading setting will be applied.
DiagonalDownBorder | Diagonal down border settings will be applied.
DiagonalUpBorder | Diagonal up border settings will be applied.
Font | Font settings will be applied.
FontBold | Font bold setting will be applied.
FontColor | Font color setting will be applied.
FontItalic | Font italic setting will be applied.
FontName | Font name setting will be applied.
FontScript | Font script setting will be applied.
FontSize | Font size setting will be applied.
FontStrike | Font strikeout setting will be applied.
FontUnderline | Font underline setting will be applied.
HideFormula | Hide formula setting will be applied.
HorizontalAlignment | Horizontal alignment setting will be applied.
Indent | Indent level setting will be applied.
LeftBorder | Left border settings will be applied.
Locked | Locked setting will be applied.
NumberFormat | Number format setting will be applied.
QuotePrefix | Hide formula setting will be applied.
RightBorder | Right border settings will be applied.
Rotation | Rotation setting will be applied.
ShrinkToFit | Shrink to fit setting will be applied.
TextDirection | Text direction setting will be applied.
TopBorder | Top border settings will be applied.
VerticalAlignment | Vertical alignment setting will be applied.
WrapText | Wrap text setting will be applied.

See Also

StyleFlag Class | Aspose.Cells Namespace


Alignments Property

Aspose.Cells for .NET

StyleFlag.Alignments Property

Alignment setting will be applied.

public bool Alignments {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


All Property

Aspose.Cells for .NET

StyleFlag.All Property

All properties will be applied.

public bool All {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


Borders Property

Aspose.Cells for .NET

StyleFlag.Borders Property

All borders settings will be applied.

public bool Borders {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


BottomBorder Property

Aspose.Cells for .NET

StyleFlag.BottomBorder Property

Bottom border settings will be applied.

public bool BottomBorder {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


CellShading Property

Aspose.Cells for .NET

StyleFlag.CellShading Property

Cell shading setting will be applied.

public bool CellShading {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


DiagonalDownBorder Property

Aspose.Cells for .NET

StyleFlag.DiagonalDownBorder Property

Diagonal down border settings will be applied.

public bool DiagonalDownBorder {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


DiagonalUpBorder Property

Aspose.Cells for .NET

StyleFlag.DiagonalUpBorder Property

Diagonal up border settings will be applied.

public bool DiagonalUpBorder {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


Font Property

Aspose.Cells for .NET

StyleFlag.Font Property

Font settings will be applied.

public bool Font {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontBold Property

Aspose.Cells for .NET

StyleFlag.FontBold Property

Font bold setting will be applied.

public bool FontBold {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontColor Property

Aspose.Cells for .NET

StyleFlag.FontColor Property

Font color setting will be applied.

public bool FontColor {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontItalic Property

Aspose.Cells for .NET

StyleFlag.FontItalic Property

Font italic setting will be applied.

public bool FontItalic {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontName Property

Aspose.Cells for .NET

StyleFlag.FontName Property

Font name setting will be applied.

public bool FontName {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontScript Property

Aspose.Cells for .NET

StyleFlag.FontScript Property

Font script setting will be applied.

public bool FontScript {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontSize Property

Aspose.Cells for .NET

StyleFlag.FontSize Property

Font size setting will be applied.

public bool FontSize {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontStrike Property

Aspose.Cells for .NET

StyleFlag.FontStrike Property

Font strikeout setting will be applied.

public bool FontStrike {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


FontUnderline Property

Aspose.Cells for .NET

StyleFlag.FontUnderline Property

Font underline setting will be applied.

public bool FontUnderline {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


HideFormula Property

Aspose.Cells for .NET

StyleFlag.HideFormula Property

Hide formula setting will be applied.

public bool HideFormula {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


HorizontalAlignment Property

Aspose.Cells for .NET

StyleFlag.HorizontalAlignment Property

Horizontal alignment setting will be applied.

public bool HorizontalAlignment {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


Indent Property

Aspose.Cells for .NET

StyleFlag.Indent Property

Indent level setting will be applied.

public bool Indent {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


LeftBorder Property

Aspose.Cells for .NET

StyleFlag.LeftBorder Property

Left border settings will be applied.

public bool LeftBorder {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


Locked Property

Aspose.Cells for .NET

StyleFlag.Locked Property

Locked setting will be applied.

public bool Locked {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


NumberFormat Property

Aspose.Cells for .NET

StyleFlag.NumberFormat Property

Number format setting will be applied.

public bool NumberFormat {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


QuotePrefix Property

Aspose.Cells for .NET

StyleFlag.QuotePrefix Property

Hide formula setting will be applied.

public bool QuotePrefix {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


RightBorder Property

Aspose.Cells for .NET

StyleFlag.RightBorder Property

Right border settings will be applied.

public bool RightBorder {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


Rotation Property

Aspose.Cells for .NET

StyleFlag.Rotation Property

Rotation setting will be applied.

public bool Rotation {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


ShrinkToFit Property

Aspose.Cells for .NET

StyleFlag.ShrinkToFit Property

Shrink to fit setting will be applied.

public bool ShrinkToFit {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


TextDirection Property

Aspose.Cells for .NET

StyleFlag.TextDirection Property

Text direction setting will be applied.

public bool TextDirection {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


TopBorder Property

Aspose.Cells for .NET

StyleFlag.TopBorder Property

Top border settings will be applied.

public bool TopBorder {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


VerticalAlignment Property

Aspose.Cells for .NET

StyleFlag.VerticalAlignment Property

Vertical alignment setting will be applied.

public bool VerticalAlignment {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


WrapText Property

Aspose.Cells for .NET

StyleFlag.WrapText Property

Wrap text setting will be applied.

public bool WrapText {get; set;}

See Also

StyleFlag Class | Aspose.Cells Namespace


StyleModifyFlag Enumeration

The style modified flags.

public enum StyleModifyFlag

Members

Member Name | Description | Value
All |  | 0
Borders |  | 1
LeftBorder |  | 2
RightBorder |  | 3
TopBorder |  | 4
BottomBorder |  | 5
HorizontalBorder | Only for dynamic style,such as conditional formatting. | 6
VerticalBorder | Only for dynamic style,such as conditional formatting. | 7
Diagonal |  | 8
DiagonalDownBorder |  | 9
DiagonalUpBorder |  | 10
Font |  | 11
FontSize |  | 12
FontName |  | 13
FontFamily |  | 14
FontCharset |  | 15
FontColor |  | 16
FontWeight |  | 17
FontItalic |  | 18
FontUnderline |  | 19
FontStrike |  | 20
FontSubscript | Obsolete. Use FontScript instead. | 21
FontSuperscript | Obsolete. Use FontScript instead. | 22
FontScript |  | 23
NumberFormat |  | 24
HorizontalAlignment |  | 25
VerticalAlignment |  | 26
Indent |  | 27
Rotation |  | 28
WrapText |  | 29
ShrinkToFit |  | 30
TextDirection |  | 31
CellShading |  | 32
Pattern |  | 33
ForegroundColor |  | 34
BackgroundColor |  | 35
Locked |  | 36
HideFormula |  | 37
AlignmentSettings | Includes horizontal/vertical Alignment, rotation,wrap Text,indent,shrinkToFit,Text Direction | 38
ProtectionSettings | Includes Locked, HideFormula | 39
FontScheme | unused. | 40
FontDirty | unused. | 41
FontSpellingError | unused. | 42
FontUFillTx | unused. | 43
FontSpacing | unused. | 44
FontKerning | unused. | 45
FontEqualize | unused. | 46
FontCap | unused. | 47
RelativeIndent |  | 48
Spacing | Specifies the spacing between characters within a text run. | 49

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


SubtotalSetting Class

Represents the setting of the subtotal .

For a list of all members of this type, see SubtotalSetting Members.

System.Object
Aspose.Cells.SubtotalSetting

public class SubtotalSetting

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SubtotalSetting Members | Aspose.Cells Namespace


SubtotalSetting Members

SubtotalSetting overview

Public Instance Properties

GroupBy | The field to group by, as a zero-based integer offset
SubtotalFunction | The subtotal function.
SummaryBelowData | Indicates whether add summary below data.
TotalList | An array of zero-based field offsets, indicating the fields to which the subtotals are added.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SubtotalSetting Class | Aspose.Cells Namespace


SubtotalSetting Properties

The properties of the SubtotalSetting class are listed below. For a complete list of SubtotalSetting class members, see the SubtotalSetting Members topic.

Public Instance Properties

GroupBy | The field to group by, as a zero-based integer offset
SubtotalFunction | The subtotal function.
SummaryBelowData | Indicates whether add summary below data.
TotalList | An array of zero-based field offsets, indicating the fields to which the subtotals are added.

See Also

SubtotalSetting Class | Aspose.Cells Namespace


GroupBy Property

Aspose.Cells for .NET

SubtotalSetting.GroupBy Property

The field to group by, as a zero-based integer offset

public int GroupBy {get;}

See Also

SubtotalSetting Class | Aspose.Cells Namespace


SubtotalFunction Property

Aspose.Cells for .NET

SubtotalSetting.SubtotalFunction Property

The subtotal function.

public ConsolidationFunction SubtotalFunction {get;}

See Also

SubtotalSetting Class | Aspose.Cells Namespace


SummaryBelowData Property

Aspose.Cells for .NET

SubtotalSetting.SummaryBelowData Property

Indicates whether add summary below data.

public bool SummaryBelowData {get;}

See Also

SubtotalSetting Class | Aspose.Cells Namespace


TotalList Property

Aspose.Cells for .NET

SubtotalSetting.TotalList Property

An array of zero-based field offsets, indicating the fields to which the subtotals are added.

public int[] TotalList {get;}

See Also

SubtotalSetting Class | Aspose.Cells Namespace


SvgSaveOptions Class

Represents Svg save options

For a list of all members of this type, see SvgSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.ImageSaveOptions
Aspose.Cells.SvgSaveOptions

public class SvgSaveOptions : ImageSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SvgSaveOptions Members | Aspose.Cells Namespace


SvgSaveOptions Members

SvgSaveOptions overview

Public Instance Constructors

SvgSaveOptions Overloaded. Initializes a new instance of the SvgSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ImageOrPrintOptions (inherited from ImageSaveOptions) | Additional image creation options
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SheetIndex | Gets and sets which worksheet should be exported. If the value is -1, the active worksheet will be exported.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SvgSaveOptions Class | Aspose.Cells Namespace


SvgSaveOptions Constructor

Creates the options for saving svg file.

Overload List

Creates the options for saving svg file.

public SvgSaveOptions();

Creates the options for saving svg file.

public SvgSaveOptions(SaveFormat);

See Also

SvgSaveOptions Class | Aspose.Cells Namespace


SvgSaveOptions Constructor ()

Creates the options for saving svg file.

public SvgSaveOptions();

See Also

SvgSaveOptions Class | Aspose.Cells Namespace | SvgSaveOptions Constructor Overload List


SvgSaveOptions Constructor (SaveFormat)

Creates the options for saving svg file.

public SvgSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The file format. It must be svg.

See Also

SvgSaveOptions Class | Aspose.Cells Namespace | SvgSaveOptions Constructor Overload List


SvgSaveOptions Properties

The properties of the SvgSaveOptions class are listed below. For a complete list of SvgSaveOptions class members, see the SvgSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ImageOrPrintOptions (inherited from ImageSaveOptions) | Additional image creation options
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SheetIndex | Gets and sets which worksheet should be exported. If the value is -1, the active worksheet will be exported.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

SvgSaveOptions Class | Aspose.Cells Namespace


SheetIndex Property

Aspose.Cells for .NET

SvgSaveOptions.SheetIndex Property

Gets and sets which worksheet should be exported. If the value is -1, the active worksheet will be exported.

public int SheetIndex {get; set;}

See Also

SvgSaveOptions Class | Aspose.Cells Namespace


TargetModeType Enumeration

Represents the type of target mode.

public enum TargetModeType

Members

Member Name | Description | Value
External | External link | 0
FilePath | Local and full paths to files\folders. | 1
Email | Email. | 2
CellReference | Link on cell or named range. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TextAlignmentType Enumeration

Enumerates text alignment types.

public enum TextAlignmentType

Members

Member Name | Description | Value
Bottom | Represents bottom text alignment. | 0
Center | Represents center text alignment. | 1
CenterAcross | Represents center across text alignment. | 2
Distributed | Represents distributed text alignment. | 3
Fill | Represents fill text alignment. | 4
General | Represents general text alignment. | 5
Justify | Represents justify text alignment. | 6
Left | Represents left text alignment. | 7
Right | Represents right text alignment. | 8
Top | Represents top text alignment. | 9
JustifiedLow | Aligns the text with an adjusted kashida length for Arabic text. | 10
ThaiDistributed | Distributes Thai text specially, because each character is treated as a word. | 11

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TextCapsType Enumeration

This type specifies the cap types of the text.

public enum TextCapsType

Members

Member Name | Description | Value
None | None caps | 0
All | Apply all caps on the text. | 1
Small | Apply small caps to the text. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TextCrossType Enumeration

Enumerates displaying text type when the text width is larger than cell width.

public enum TextCrossType

Members

Member Name | Description | Value
Default | Display text like in Microsoft Excel. | 1
CrossKeep | Display all the text by crossing other cells and keep text of crossed cells. | 2
CrossOverride | Display all the text by crossing other cells and override text of crossed cells. | 3
StrictInCell | Only display the text within the width of cell. | 4

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TextDirectionType Enumeration

Represents the direction of the text flow for this paragraph.

public enum TextDirectionType

Members

Member Name | Description | Value
Context |  | 0
LeftToRight |  | 1
RightToLeft |  | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TextOrientationType Enumeration

Enumerates text orientation types.

public enum TextOrientationType

Members

Member Name | Description | Value
ClockWise | text is rotated 90 degrees clockwise | 0
CounterClockWise | text is rotated 90 degrees counterclockwise | 1
NoRotation | Represents the default value. | 2
TopToBottom | Displays text from top to bottom of the cell. Stacked text. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TextStrikeType Enumeration

This type specifies the strike type.

public enum TextStrikeType

Members

Member Name | Description | Value
Single | A single strikethrough applied on the text | 0
Double | A double strikethrough applied on the text | 1
None | No strike is applied to the text | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ThemeColor Class

Represents a theme color.

For a list of all members of this type, see ThemeColor Members.

System.Object
Aspose.Cells.ThemeColor

public class ThemeColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
Cells cells = workbook.Worksheets[0].Cells;
cells["A1"].PutValue("Hello World");
Style style = cells["A1"].GetStyle();
//Set ThemeColorType.Text2 color type with 40% lighten as the font color.
style.Font.ThemeColor = new ThemeColor(ThemeColorType.Text2, 0.4);
style.Pattern = BackgroundType.Solid;
//Set ThemeColorType.Background2 color type with 75% darken as the foreground color
style.ForegroundThemeColor = new ThemeColor(ThemeColorType.Background2, -0.75);
cells["A1"].SetStyle(style);
//Saving the Excel file
workbook.Save("C:\\book1.xlsx");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
Dim cells As Cells = workbook.Worksheets(0).Cells
cells("A1").PutValue("Hello World")
'Get the cell style
Dim style As Style = cells("A1").GetStyle()
'Set ThemeColorType.Text2 color type with 40% lighten as the font color.
Style.Font.ThemeColor = New ThemeColor(ThemeColorType.Text2, 0.4)
Style.Pattern = BackgroundType.Solid
'Set ThemeColorType.Background2 color type with 75% darken as the foreground color
style.ForegroundThemeColor = New ThemeColor(ThemeColorType.Background2, -0.75)
'Set the cell style
cells("A1").SetStyle(style)
'Saving the Excel file
Workbook.Save("C:\\book1.xlsx")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ThemeColor Members | Aspose.Cells Namespace


ThemeColor Members

ThemeColor overview

Public Instance Constructors

ThemeColor Constructor

Public Instance Properties

ColorType | Gets and sets the theme type.
Tint | Gets and sets the tint value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ThemeColor Class | Aspose.Cells Namespace


ThemeColor Constructor

public ThemeColor(
ThemeColorType type,
double tint
);

Parameters

type
The theme type.
tint
The tint value.

See Also

ThemeColor Class | Aspose.Cells Namespace


ThemeColor Properties

The properties of the ThemeColor class are listed below. For a complete list of ThemeColor class members, see the ThemeColor Members topic.

Public Instance Properties

ColorType | Gets and sets the theme type.
Tint | Gets and sets the tint value.

See Also

ThemeColor Class | Aspose.Cells Namespace


ColorType Property

Aspose.Cells for .NET

ThemeColor.ColorType Property

Gets and sets the theme type.

public ThemeColorType ColorType {get; set;}

See Also

ThemeColor Class | Aspose.Cells Namespace


Tint Property

Aspose.Cells for .NET

ThemeColor.Tint Property

Gets and sets the tint value.

public double Tint {get; set;}

Remarks

The tint value is stored as a double from -1.0 .. 1.0, where -1.0 means 100% darken and 1.0 means 100% lighten. Also, 0.0 means no change.

See Also

ThemeColor Class | Aspose.Cells Namespace


ThemeColorType Enumeration

Enumerates the theme color types.

public enum ThemeColorType

Members

Member Name | Description | Value
Background1 |  | 0
Text1 |  | 1
Background2 |  | 2
Text2 |  | 3
Accent1 |  | 4
Accent2 |  | 5
Accent3 |  | 6
Accent4 |  | 7
Accent5 |  | 8
Accent6 |  | 9
Hyperlink |  | 10
FollowedHyperlink |  | 11
StyleColor | Inner used. A color used in theme definitions which means to use the color of the style. | 12

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ThreadedComment Class

Represents the threaded comment.

For a list of all members of this type, see ThreadedComment Members.

System.Object
Aspose.Cells.ThreadedComment

public class ThreadedComment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ThreadedComment Members | Aspose.Cells Namespace


ThreadedComment Members

ThreadedComment overview

Public Instance Properties

Author | Gets the author of the comment.
Column | Gets the column index of the comment.
CreatedTime | Gets and sets the created time of this threaded comment.
Notes | Gets and sets the text of the comment.
Row | Gets the row index of the comment.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ThreadedComment Class | Aspose.Cells Namespace


ThreadedComment Properties

The properties of the ThreadedComment class are listed below. For a complete list of ThreadedComment class members, see the ThreadedComment Members topic.

Public Instance Properties

Author | Gets the author of the comment.
Column | Gets the column index of the comment.
CreatedTime | Gets and sets the created time of this threaded comment.
Notes | Gets and sets the text of the comment.
Row | Gets the row index of the comment.

See Also

ThreadedComment Class | Aspose.Cells Namespace


Author Property

Aspose.Cells for .NET

ThreadedComment.Author Property

Gets the author of the comment.

public ThreadedCommentAuthor Author {get;}

See Also

ThreadedComment Class | Aspose.Cells Namespace


Column Property

Aspose.Cells for .NET

ThreadedComment.Column Property

Gets the column index of the comment.

public int Column {get;}

See Also

ThreadedComment Class | Aspose.Cells Namespace


CreatedTime Property

Aspose.Cells for .NET

ThreadedComment.CreatedTime Property

Gets and sets the created time of this threaded comment.

public DateTime CreatedTime {get; set;}

See Also

ThreadedComment Class | Aspose.Cells Namespace


Notes Property

Aspose.Cells for .NET

ThreadedComment.Notes Property

Gets and sets the text of the comment.

public string Notes {get; set;}

See Also

ThreadedComment Class | Aspose.Cells Namespace


Row Property

Aspose.Cells for .NET

ThreadedComment.Row Property

Gets the row index of the comment.

public int Row {get;}

See Also

ThreadedComment Class | Aspose.Cells Namespace


ThreadedCommentAuthor Class

Represents the person who creates the threaded comments;

For a list of all members of this type, see ThreadedCommentAuthor Members.

System.Object
Aspose.Cells.ThreadedCommentAuthor

public class ThreadedCommentAuthor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ThreadedCommentAuthor Members | Aspose.Cells Namespace


ThreadedCommentAuthor Members

ThreadedCommentAuthor overview

Public Instance Properties

Name | Gets and sets the name.
ProviderId | Gets the id of the provider.
UserId | Gets and sets the id of the user.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ThreadedCommentAuthor Class | Aspose.Cells Namespace


ThreadedCommentAuthor Properties

The properties of the ThreadedCommentAuthor class are listed below. For a complete list of ThreadedCommentAuthor class members, see the ThreadedCommentAuthor Members topic.

Public Instance Properties

Name | Gets and sets the name.
ProviderId | Gets the id of the provider.
UserId | Gets and sets the id of the user.

See Also

ThreadedCommentAuthor Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

ThreadedCommentAuthor.Name Property

Gets and sets the name.

public string Name {get; set;}

See Also

ThreadedCommentAuthor Class | Aspose.Cells Namespace


ProviderId Property

Aspose.Cells for .NET

ThreadedCommentAuthor.ProviderId Property

Gets the id of the provider.

public string ProviderId {get; set;}

See Also

ThreadedCommentAuthor Class | Aspose.Cells Namespace


UserId Property

Aspose.Cells for .NET

ThreadedCommentAuthor.UserId Property

Gets and sets the id of the user.

public string UserId {get; set;}

See Also

ThreadedCommentAuthor Class | Aspose.Cells Namespace


ThreadedCommentAuthorCollection Class

Represents all persons who .

For a list of all members of this type, see ThreadedCommentAuthorCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ThreadedCommentAuthorCollection

public class ThreadedCommentAuthorCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ThreadedCommentAuthorCollection Members | Aspose.Cells Namespace


ThreadedCommentAuthorCollection Members

ThreadedCommentAuthorCollection overview

Public Instance Constructors

ThreadedCommentAuthorCollection Constructor Initializes a new instance of the ThreadedCommentAuthorCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
CurrentPerson | Gets and sets the current user.
Item | Overloaded. Gets the person who create threaded comments.

Public Instance Methods

Add | Adds one thread comment person.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


ThreadedCommentAuthorCollection Constructor

Initializes a new instance of the ThreadedCommentAuthorCollection class.

public ThreadedCommentAuthorCollection();

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


ThreadedCommentAuthorCollection Properties

The properties of the ThreadedCommentAuthorCollection class are listed below. For a complete list of ThreadedCommentAuthorCollection class members, see the ThreadedCommentAuthorCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
CurrentPerson | Gets and sets the current user.
Item | Overloaded. Gets the person who create threaded comments.

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


CurrentPerson Property

Aspose.Cells for .NET

ThreadedCommentAuthorCollection.CurrentPerson Property

Gets and sets the current user.

public ThreadedCommentAuthor CurrentPerson {get; set;}

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ThreadedCommentAuthorCollection.Item Property

Gets the person who create threaded comments.

Overload List

Gets the person who create threaded comments.

public ThreadedCommentAuthor this[int] {get;}

Gets the person who create threaded comments.

public ThreadedCommentAuthor this[string] {get;}

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

ThreadedCommentAuthorCollection.Item Property (Int32)

Gets the person who create threaded comments.

public ThreadedCommentAuthor this[
int index
] {get;}

Parameters

index
The index

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace | ThreadedCommentAuthorCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ThreadedCommentAuthorCollection.Item Property (String)

Gets the person who create threaded comments.

public ThreadedCommentAuthor this[
string name
] {get;}

Parameters

name
The index

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace | ThreadedCommentAuthorCollection.Item Overload List


ThreadedCommentAuthorCollection Methods

The methods of the ThreadedCommentAuthorCollection class are listed below. For a complete list of ThreadedCommentAuthorCollection class members, see the ThreadedCommentAuthorCollection Members topic.

Public Instance Methods

Add | Adds one thread comment person.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


ThreadedCommentAuthorCollection.Add Method

Adds one thread comment person.

public int Add(
string name,
string userId,
string providerId
);

Parameters

name
The name of the person.
userId
providerId
The id of the provider

Return Value

See Also

ThreadedCommentAuthorCollection Class | Aspose.Cells Namespace


ThreadedCommentCollection Class

Represents the list of threaded comments.

For a list of all members of this type, see ThreadedCommentCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ThreadedCommentCollection

public class ThreadedCommentCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ThreadedCommentCollection Members | Aspose.Cells Namespace


ThreadedCommentCollection Members

ThreadedCommentCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the threaded comment by the specific index.

Public Instance Methods

Add | Adds a threaded comment;
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ThreadedCommentCollection Class | Aspose.Cells Namespace


ThreadedCommentCollection Properties

The properties of the ThreadedCommentCollection class are listed below. For a complete list of ThreadedCommentCollection class members, see the ThreadedCommentCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the threaded comment by the specific index.

See Also

ThreadedCommentCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ThreadedCommentCollection.Item Property

Gets the threaded comment by the specific index.

public ThreadedComment this[
int index
] {get;}

Parameters

index
The index

See Also

ThreadedCommentCollection Class | Aspose.Cells Namespace


ThreadedCommentCollection Methods

The methods of the ThreadedCommentCollection class are listed below. For a complete list of ThreadedCommentCollection class members, see the ThreadedCommentCollection Members topic.

Public Instance Methods

Add | Adds a threaded comment;
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ThreadedCommentCollection Class | Aspose.Cells Namespace


ThreadedCommentCollection.Add Method

Adds a threaded comment;

public int Add(
string text,
ThreadedCommentAuthor author
);

Parameters

text
The text of the threaded comment.
author
The author of the threaded comment

Return Value

See Also

ThreadedCommentCollection Class | Aspose.Cells Namespace


TimePeriodType Enumeration

Used in a FormatConditionType.TimePeriod conditional formatting rule. These are dynamic time periods, which change based on the date the conditional formatting is refreshed / applied.

public enum TimePeriodType

Members

Member Name | Description | Value
Today | Today's date. | 0
Yesterday | Yesterday's date. | 1
Tomorrow | Tomorrow's date. | 2
Last7Days | A date in the last seven days. | 3
ThisMonth | A date occurring in this calendar month. | 4
LastMonth | A date occurring in the last calendar month. | 5
NextMonth | A date occurring in the next calendar month. | 6
ThisWeek | A date occurring this week. | 7
LastWeek | A date occurring last week. | 8
NextWeek | A date occurring next week. | 9
ThisYear | A date occurring this year. Only for .ods. | 10
LastYear | A date occurring last year. Only for .ods. | 11
NextYear | A date occurring next year. Only for .ods. | 12

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Top10 Class

Describe the Top10 conditional formatting rule. This conditional formatting rule highlights cells whose values fall in the top N or bottom N bracket, as specified.

For a list of all members of this type, see Top10 Members.

System.Object
Aspose.Cells.Top10

public class Top10

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Top10 Members | Aspose.Cells Namespace


Top10 Members

Top10 overview

Public Instance Constructors

Top10 Constructor Initializes a new instance of the Top10 class.

Public Instance Properties

IsBottom | Get or set the flag indicating whether a "top/bottom n" rule is a "bottom n" rule. '1' indicates 'bottom'. Default value is false.
IsPercent | Get or set the flag indicating whether a "top/bottom n" rule is a "top/bottom n percent" rule. Default value is false.
Rank | Get or set the value of "n" in a "top/bottom n" conditional formatting rule. If IsPercent is true, the value must between 0 and 100. Otherwise it must between 0 and 1000. Default value is 10.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Top10 Class | Aspose.Cells Namespace


Top10 Constructor

Initializes a new instance of the Top10 class.

public Top10();

See Also

Top10 Class | Aspose.Cells Namespace


Top10 Properties

The properties of the Top10 class are listed below. For a complete list of Top10 class members, see the Top10 Members topic.

Public Instance Properties

IsBottom | Get or set the flag indicating whether a "top/bottom n" rule is a "bottom n" rule. '1' indicates 'bottom'. Default value is false.
IsPercent | Get or set the flag indicating whether a "top/bottom n" rule is a "top/bottom n percent" rule. Default value is false.
Rank | Get or set the value of "n" in a "top/bottom n" conditional formatting rule. If IsPercent is true, the value must between 0 and 100. Otherwise it must between 0 and 1000. Default value is 10.

See Also

Top10 Class | Aspose.Cells Namespace


IsBottom Property

Aspose.Cells for .NET

Top10.IsBottom Property

Get or set the flag indicating whether a "top/bottom n" rule is a "bottom n" rule. '1' indicates 'bottom'. Default value is false.

public bool IsBottom {get; set;}

See Also

Top10 Class | Aspose.Cells Namespace


IsPercent Property

Aspose.Cells for .NET

Top10.IsPercent Property

Get or set the flag indicating whether a "top/bottom n" rule is a "top/bottom n percent" rule. Default value is false.

public bool IsPercent {get; set;}

See Also

Top10 Class | Aspose.Cells Namespace


Rank Property

Aspose.Cells for .NET

Top10.Rank Property

Get or set the value of "n" in a "top/bottom n" conditional formatting rule. If IsPercent is true, the value must between 0 and 100. Otherwise it must between 0 and 1000. Default value is 10.

public int Rank {get; set;}

See Also

Top10 Class | Aspose.Cells Namespace


Top10Filter Class

Represents the top 10 filter.

For a list of all members of this type, see Top10Filter Members.

System.Object
Aspose.Cells.Top10Filter

public class Top10Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Top10Filter Members | Aspose.Cells Namespace


Top10Filter Members

Top10Filter overview

Public Instance Properties

Criteria |
IsPercent | Indicates whether the items is percent.
IsTop | Indicates whether it's top filter.
Items | Gets and sets the items of the filter.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Top10Filter Class | Aspose.Cells Namespace


Top10Filter Properties

The properties of the Top10Filter class are listed below. For a complete list of Top10Filter class members, see the Top10Filter Members topic.

Public Instance Properties

Criteria |
IsPercent | Indicates whether the items is percent.
IsTop | Indicates whether it's top filter.
Items | Gets and sets the items of the filter.

See Also

Top10Filter Class | Aspose.Cells Namespace


Criteria Property

Aspose.Cells for .NET

Top10Filter.Criteria Property

public object Criteria {get; set;}

See Also

Top10Filter Class | Aspose.Cells Namespace


IsPercent Property

Aspose.Cells for .NET

Top10Filter.IsPercent Property

Indicates whether the items is percent.

public bool IsPercent {get; set;}

See Also

Top10Filter Class | Aspose.Cells Namespace


IsTop Property

Aspose.Cells for .NET

Top10Filter.IsTop Property

Indicates whether it's top filter.

public bool IsTop {get; set;}

See Also

Top10Filter Class | Aspose.Cells Namespace


Items Property

Aspose.Cells for .NET

Top10Filter.Items Property

Gets and sets the items of the filter.

public int Items {get; set;}

See Also

Top10Filter Class | Aspose.Cells Namespace


TxtLoadOptions Class

Represents the options for loading text file.

For a list of all members of this type, see TxtLoadOptions Members.

System.Object
Aspose.Cells.LoadOptions
Aspose.Cells.AbstractTextLoadOptions
Aspose.Cells.TxtLoadOptions

public class TxtLoadOptions : AbstractTextLoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TxtLoadOptions Members | Aspose.Cells Namespace


TxtLoadOptions Members

TxtLoadOptions overview

Public Instance Constructors

TxtLoadOptions Overloaded. Initializes a new instance of the TxtLoadOptions class.

Public Instance Properties

AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
ConvertDateTimeData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to date data.
ConvertNumericData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to numeric data.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
Encoding (inherited from AbstractTextLoadOptions) | Gets and sets the default encoding. Only applies for csv file.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
HasFormula | Indicates whether the text is formula if it starts with "=".
HasTextQualifier | Whether there is text qualifier for cell value. Default is true.
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
IsMultiEncoded | True means that the file contains several encoding.
KeepPrecision (inherited from AbstractTextLoadOptions) | Indicates whether not parsing a string value if the length is 15.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
LoadStyleStrategy (inherited from AbstractTextLoadOptions) | Indicates the strategy to apply style for parsed values when converting string value to number or datetime.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
PreferredParsers | Gets and sets preferred value parsers for loading text file.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
Separator | Gets and sets character separator of text file.
SeparatorString | Gets and sets the a string value as separator.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
TextQualifier | Specifies the text qualifier for cell values. Default qualifier is '"'.
TreatConsecutiveDelimitersAsOne | Whether consecutive delimiters should be treated as one.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPaperSize (inherited from LoadOptions) | Sets the default print paper size from default printer's setting.
ToString (inherited from Object) |

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


TxtLoadOptions Constructor

Creates the options for loading text file.

Overload List

Creates the options for loading text file.

public TxtLoadOptions();

Creates the options for loading text file.

public TxtLoadOptions(LoadFormat);

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


TxtLoadOptions Constructor ()

Creates the options for loading text file.

public TxtLoadOptions();

Remarks

The default load file type is CSV .

See Also

TxtLoadOptions Class | Aspose.Cells Namespace | TxtLoadOptions Constructor Overload List


TxtLoadOptions Constructor (LoadFormat)

Creates the options for loading text file.

public TxtLoadOptions(
LoadFormat loadFormat
);

Parameters

loadFormat
The loading format

See Also

TxtLoadOptions Class | Aspose.Cells Namespace | TxtLoadOptions Constructor Overload List


TxtLoadOptions Properties

The properties of the TxtLoadOptions class are listed below. For a complete list of TxtLoadOptions class members, see the TxtLoadOptions Members topic.

Public Instance Properties

AutoFitterOptions (inherited from LoadOptions) | Gets and sets the auto fitter options
CheckDataValid (inherited from LoadOptions) | Check whether data is valid in the template file.
CheckExcelRestriction (inherited from LoadOptions) | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
ConvertDateTimeData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to date data.
ConvertNumericData (inherited from AbstractTextLoadOptions) | Gets or sets a value that indicates whether the string in text file is converted to numeric data.
CultureInfo (inherited from LoadOptions) | Gets or sets the system culture info at the time the file was loaded.
Encoding (inherited from AbstractTextLoadOptions) | Gets and sets the default encoding. Only applies for csv file.
FontConfigs (inherited from LoadOptions) | Gets and sets individual font configs. Only works for the Workbook which uses this LoadOptions to load.>
HasFormula | Indicates whether the text is formula if it starts with "=".
HasTextQualifier | Whether there is text qualifier for cell value. Default is true.
IgnoreNotPrinted (inherited from LoadOptions) | Ignore the data which are not printed if directly printing the file
InterruptMonitor (inherited from LoadOptions) | Gets and sets the interrupt monitor.
IsMultiEncoded | True means that the file contains several encoding.
KeepPrecision (inherited from AbstractTextLoadOptions) | Indicates whether not parsing a string value if the length is 15.
KeepUnparsedData (inherited from LoadOptions) | Whether keep the unparsed data in memory for the Workbook when it is loaded from template file. Default is true.
LanguageCode (inherited from LoadOptions) | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
LightCellsDataHandler (inherited from LoadOptions) | The data handler for processing cells data when reading template file.
LoadFilter (inherited from LoadOptions) | The filter to denote how to load data.
LoadFormat (inherited from LoadOptions) | Gets the load format.
LoadStyleStrategy (inherited from AbstractTextLoadOptions) | Indicates the strategy to apply style for parsed values when converting string value to number or datetime.
MemorySetting (inherited from LoadOptions) | Gets or sets the memory usage options.
ParsingFormulaOnOpen (inherited from LoadOptions) | Indicates whether parsing the formula when reading the file.
ParsingPivotCachedRecords (inherited from LoadOptions) | Indicates whether parsing pivot cached records when loading the file. The default value is false.
Password (inherited from LoadOptions) | Gets and set the password of the workbook.
PreferredParsers | Gets and sets preferred value parsers for loading text file.
Region (inherited from LoadOptions) | Gets or sets the system regional settings based on CountryCode at the time the file was loaded.
Separator | Gets and sets character separator of text file.
SeparatorString | Gets and sets the a string value as separator.
StandardFont (inherited from LoadOptions) | Sets the default standard font name
StandardFontSize (inherited from LoadOptions) | Sets the default standard font size.
TextQualifier | Specifies the text qualifier for cell values. Default qualifier is '"'.
TreatConsecutiveDelimitersAsOne | Whether consecutive delimiters should be treated as one.
WarningCallback (inherited from LoadOptions) | Gets or sets warning callback.

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


HasFormula Property

Aspose.Cells for .NET

TxtLoadOptions.HasFormula Property

Indicates whether the text is formula if it starts with "=".

public bool HasFormula {get; set;}

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


HasTextQualifier Property

Aspose.Cells for .NET

TxtLoadOptions.HasTextQualifier Property

Whether there is text qualifier for cell value. Default is true.

public bool HasTextQualifier {get; set;}

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


IsMultiEncoded Property

Aspose.Cells for .NET

TxtLoadOptions.IsMultiEncoded Property

True means that the file contains several encoding.

public bool IsMultiEncoded {get; set;}

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


PreferredParsers Property

Aspose.Cells for .NET

TxtLoadOptions.PreferredParsers Property

Gets and sets preferred value parsers for loading text file.

public ICustomParser[] PreferredParsers {get; set;}

Remarks

parsers[0] is the parser will be used for the first column in text template file, parsers[1] is the parser will be used for the second column, ...etc. The last one(parsers[parsers.length-1]) will be used for all other columns start from parsers.length-1. If one item is null, the corresponding column will be parsed by the default parser of Aspose.Cells.

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


Separator Property

Aspose.Cells for .NET

TxtLoadOptions.Separator Property

Gets and sets character separator of text file.

public char Separator {get; set;}

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


SeparatorString Property

Aspose.Cells for .NET

TxtLoadOptions.SeparatorString Property

Gets and sets the a string value as separator.

public string SeparatorString {get; set;}

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


TextQualifier Property

Aspose.Cells for .NET

TxtLoadOptions.TextQualifier Property

Specifies the text qualifier for cell values. Default qualifier is '"'.

public char TextQualifier {get; set;}

Remarks

When setting this property, HasTextQualifier will become true automatically.

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


TreatConsecutiveDelimitersAsOne Property

Aspose.Cells for .NET

TxtLoadOptions.TreatConsecutiveDelimitersAsOne Property

Whether consecutive delimiters should be treated as one.

public bool TreatConsecutiveDelimitersAsOne {get; set;}

See Also

TxtLoadOptions Class | Aspose.Cells Namespace


TxtLoadStyleStrategy Enumeration

Specifies how to apply style for parsed values when converting string value to number or datetime.

public enum TxtLoadStyleStrategy

Members

Member Name | Description | Value
None | Does not set style for the parsed value. | 0
BuiltIn | Set the style as built-in number/datetime when the parsed value are plain numeric/datetime values. | 1
ExactFormat | Set the exact custom format for the parsed value to make the formatted value be same with the original input one. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


TxtSaveOptions Class

Represents the save options for csv/tab delimited/other text format.

For a list of all members of this type, see TxtSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.TxtSaveOptions

public class TxtSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TxtSaveOptions Members | Aspose.Cells Namespace


TxtSaveOptions Members

TxtSaveOptions overview

Public Instance Constructors

TxtSaveOptions Overloaded. Initializes a new instance of the TxtSaveOptions class.

Public Instance Properties

AlwaysQuoted | Obsolete. Indicates whether always adding '"' for each field. If true then all values will be quoted; If false then only quote values when needed(when values contain special characters such as '"' , '\n' or separator character). Default is false.
CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
Encoding | Gets and sets the default encoding.
ExportArea | The range of cells to be exported.
FormatStrategy | Gets and sets the format strategy when exporting the cell value as string.
KeepSeparatorsForBlankRow | Indicates whether separators should be output for blank row. Default value is false which means the content for blank row will be empty.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
QuoteType | Gets or sets how to quote values in the exported text file.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
Separator | Gets and sets char Delimiter of text file.
SeparatorString | Gets and sets the a string value as separator.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
TrimLeadingBlankRowAndColumn | Indicates whether leading blank rows and columns should be trimmed like what ms excel does. Default is true.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


TxtSaveOptions Constructor

Creates text file save options.

Overload List

Creates text file save options.

public TxtSaveOptions();

Creates text file save options.

public TxtSaveOptions(SaveFormat);

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


TxtSaveOptions Constructor ()

Creates text file save options.

public TxtSaveOptions();

See Also

TxtSaveOptions Class | Aspose.Cells Namespace | TxtSaveOptions Constructor Overload List


TxtSaveOptions Constructor (SaveFormat)

Creates text file save options.

public TxtSaveOptions(
SaveFormat format
);

Parameters

format
The save format of the text file.

See Also

TxtSaveOptions Class | Aspose.Cells Namespace | TxtSaveOptions Constructor Overload List


TxtSaveOptions Properties

The properties of the TxtSaveOptions class are listed below. For a complete list of TxtSaveOptions class members, see the TxtSaveOptions Members topic.

Public Instance Properties

AlwaysQuoted | Obsolete. Indicates whether always adding '"' for each field. If true then all values will be quoted; If false then only quote values when needed(when values contain special characters such as '"' , '\n' or separator character). Default is false.
CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
Encoding | Gets and sets the default encoding.
ExportArea | The range of cells to be exported.
FormatStrategy | Gets and sets the format strategy when exporting the cell value as string.
KeepSeparatorsForBlankRow | Indicates whether separators should be output for blank row. Default value is false which means the content for blank row will be empty.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
QuoteType | Gets or sets how to quote values in the exported text file.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
Separator | Gets and sets char Delimiter of text file.
SeparatorString | Gets and sets the a string value as separator.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
TrimLeadingBlankRowAndColumn | Indicates whether leading blank rows and columns should be trimmed like what ms excel does. Default is true.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


AlwaysQuoted Property

Aspose.Cells for .NET

TxtSaveOptions.AlwaysQuoted Property

NOTE: This property is now obsolete.

Use QuoteType property instead.

Indicates whether always adding '"' for each field. If true then all values will be quoted; If false then only quote values when needed(when values contain special characters such as '"' , '\n' or separator character). Default is false.

public bool AlwaysQuoted {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use QuoteType property instead. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


Encoding Property

Aspose.Cells for .NET

TxtSaveOptions.Encoding Property

Gets and sets the default encoding.

public Encoding Encoding {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


ExportArea Property

Aspose.Cells for .NET

TxtSaveOptions.ExportArea Property

The range of cells to be exported.

public CellArea ExportArea {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


FormatStrategy Property

Aspose.Cells for .NET

TxtSaveOptions.FormatStrategy Property

Gets and sets the format strategy when exporting the cell value as string.

public CellValueFormatStrategy FormatStrategy {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


KeepSeparatorsForBlankRow Property

Aspose.Cells for .NET

TxtSaveOptions.KeepSeparatorsForBlankRow Property

Indicates whether separators should be output for blank row. Default value is false which means the content for blank row will be empty.

public bool KeepSeparatorsForBlankRow {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


LightCellsDataProvider Property

Aspose.Cells for .NET

TxtSaveOptions.LightCellsDataProvider Property

The Data provider to provide cells data for saving workbook in light mode.

public LightCellsDataProvider LightCellsDataProvider {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


QuoteType Property

Aspose.Cells for .NET

TxtSaveOptions.QuoteType Property

Gets or sets how to quote values in the exported text file.

public TxtValueQuoteType QuoteType {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


Separator Property

Aspose.Cells for .NET

TxtSaveOptions.Separator Property

Gets and sets char Delimiter of text file.

public char Separator {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


SeparatorString Property

Aspose.Cells for .NET

TxtSaveOptions.SeparatorString Property

Gets and sets the a string value as separator.

public string SeparatorString {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


TrimLeadingBlankRowAndColumn Property

Aspose.Cells for .NET

TxtSaveOptions.TrimLeadingBlankRowAndColumn Property

Indicates whether leading blank rows and columns should be trimmed like what ms excel does. Default is true.

public bool TrimLeadingBlankRowAndColumn {get; set;}

See Also

TxtSaveOptions Class | Aspose.Cells Namespace


TxtValueQuoteType Enumeration

Specifies the type of using quotation marks for values in text format files.

public enum TxtValueQuoteType

Members

Member Name | Description | Value
Normal | All values that contain special characters such as quotation mark, separator character will be quoted. Same with the behavior of ms excel for exporting text file. | 0
Always | All values will be quoted always. | 1
Minimum | Only quote values when needed. Such as, if one value contains quotation mark but the quotation mark is not at the begin of this value, this value will not be quoted. | 2
Never | All values will not be quoted. The exported text file with this type may not be read back correctly because the needed quotation marks being absent. | 3

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


UnionRange Class

Represents union range.

For a list of all members of this type, see UnionRange Members.

System.Object
Aspose.Cells.UnionRange

public class UnionRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

UnionRange Members | Aspose.Cells Namespace


UnionRange Members

UnionRange overview

Public Instance Properties

CellCount | Gets all cell count in the range.
ColumnCount | Gets the count of rows in the range.
FirstColumn | Gets the index of the first column of the range.
FirstRow | Gets the index of the first row of the range.
HasRange | Indicates whether this has range.
Hyperlinks | Gets all hyperlink in the range.
Name | Gets or sets the name of the range.
RangeCount | Gets the count of the ranges.
Ranges | Gets all union ranges.
RefersTo | Gets the range's refers to.
RowCount | Gets the count of rows in the range.
Value | Gets and sets the values of the range.

Public Instance Methods

ApplyStyle | Applies formats for a whole range.
Copy | Copying the range with paste special options.
Equals (inherited from Object) |
GetEnumerator | Gets the enumerator for cells in this Range.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Intersect | Overloaded. Intersects another range.
Merge | Combines a range of cells into a single cell.
PutValue | Puts a value into the range, if appropriate the value will be converted to other data type and cell's number format will be reset.
SetOutlineBorders | Overloaded. Sets out line borders around a range of cells.
SetStyle | Sets the style of the range.
ToString (inherited from Object) |
Union | Overloaded. Union another range.
UnMerge | Unmerges merged cells of this range.

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange Properties

The properties of the UnionRange class are listed below. For a complete list of UnionRange class members, see the UnionRange Members topic.

Public Instance Properties

CellCount | Gets all cell count in the range.
ColumnCount | Gets the count of rows in the range.
FirstColumn | Gets the index of the first column of the range.
FirstRow | Gets the index of the first row of the range.
HasRange | Indicates whether this has range.
Hyperlinks | Gets all hyperlink in the range.
Name | Gets or sets the name of the range.
RangeCount | Gets the count of the ranges.
Ranges | Gets all union ranges.
RefersTo | Gets the range's refers to.
RowCount | Gets the count of rows in the range.
Value | Gets and sets the values of the range.

See Also

UnionRange Class | Aspose.Cells Namespace


CellCount Property

Aspose.Cells for .NET

UnionRange.CellCount Property

Gets all cell count in the range.

public int CellCount {get;}

See Also

UnionRange Class | Aspose.Cells Namespace


ColumnCount Property

Aspose.Cells for .NET

UnionRange.ColumnCount Property

Gets the count of rows in the range.

public int ColumnCount {get;}

Remarks

Only effects when it only contains one range.

See Also

UnionRange Class | Aspose.Cells Namespace


FirstColumn Property

Aspose.Cells for .NET

UnionRange.FirstColumn Property

Gets the index of the first column of the range.

public int FirstColumn {get;}

Remarks

Only effects when it only contains one range.

See Also

UnionRange Class | Aspose.Cells Namespace


FirstRow Property

Aspose.Cells for .NET

UnionRange.FirstRow Property

Gets the index of the first row of the range.

public int FirstRow {get;}

Remarks

Only effects when it only contains one range.

See Also

UnionRange Class | Aspose.Cells Namespace


HasRange Property

Aspose.Cells for .NET

UnionRange.HasRange Property

Indicates whether this has range.

public bool HasRange {get;}

See Also

UnionRange Class | Aspose.Cells Namespace


Hyperlinks Property

Aspose.Cells for .NET

UnionRange.Hyperlinks Property

Gets all hyperlink in the range.

public Hyperlink[] Hyperlinks {get;}

See Also

UnionRange Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

UnionRange.Name Property

Gets or sets the name of the range.

public string Name {get; set;}

Remarks

Named range is supported. For example,

range.Name = "Sheet1!MyRange";

See Also

UnionRange Class | Aspose.Cells Namespace


RangeCount Property

Aspose.Cells for .NET

UnionRange.RangeCount Property

Gets the count of the ranges.

public int RangeCount {get;}

See Also

UnionRange Class | Aspose.Cells Namespace


Ranges Property

Aspose.Cells for .NET

UnionRange.Ranges Property

Gets all union ranges.

public Range[] Ranges {get;}

See Also

UnionRange Class | Aspose.Cells Namespace


RefersTo Property

Aspose.Cells for .NET

UnionRange.RefersTo Property

Gets the range's refers to.

public string RefersTo {get;}

See Also

UnionRange Class | Aspose.Cells Namespace


RowCount Property

Aspose.Cells for .NET

UnionRange.RowCount Property

Gets the count of rows in the range.

public int RowCount {get;}

Remarks

Only effects when it only contains one range.

See Also

UnionRange Class | Aspose.Cells Namespace


Value Property

Aspose.Cells for .NET

UnionRange.Value Property

Gets and sets the values of the range.

public object Value {get; set;}

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange Methods

The methods of the UnionRange class are listed below. For a complete list of UnionRange class members, see the UnionRange Members topic.

Public Instance Methods

ApplyStyle | Applies formats for a whole range.
Copy | Copying the range with paste special options.
Equals (inherited from Object) |
GetEnumerator | Gets the enumerator for cells in this Range.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Intersect | Overloaded. Intersects another range.
Merge | Combines a range of cells into a single cell.
PutValue | Puts a value into the range, if appropriate the value will be converted to other data type and cell's number format will be reset.
SetOutlineBorders | Overloaded. Sets out line borders around a range of cells.
SetStyle | Sets the style of the range.
ToString (inherited from Object) |
Union | Overloaded. Union another range.
UnMerge | Unmerges merged cells of this range.

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.ApplyStyle Method

Applies formats for a whole range.

public void ApplyStyle(
Style style,
StyleFlag flag
);

Parameters

style
The style object which will be applied.
flag
Flags which indicates applied formatting properties.

Remarks

Each cell in this range will contains a Style object. So this is a memory-consuming method. Please use it carefully.

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.Copy Method

Copying the range with paste special options.

public void Copy(
UnionRange range,
PasteOptions options
);

Parameters

range
The source range.
options
The paste special options.

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.GetEnumerator Method

Gets the enumerator for cells in this Range.

public IEnumerator GetEnumerator();

Return Value

The cells enumerator

Remarks

When traversing elements by the returned Enumerator, the cells collection should not be modified(such as operations that will cause new Cell/Row be instantiated or existing Cell/Row be deleted). Otherwise the enumerator may not be able to traverse all cells correctly(some elements may be traversed repeatedly or skipped).

See Also

UnionRange Class | Aspose.Cells Namespace


Intersect Method

Aspose.Cells for .NET

UnionRange.Intersect Method

Intersects another range.

Overload List

Intersects another range.

public UnionRange Intersect(Range[]);

Intersects another range.

public UnionRange Intersect(UnionRange);

Intersects another range.

public UnionRange Intersect(string);

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.Intersect Method (Range[])

Intersects another range.

public UnionRange Intersect(
Range[] ranges
);

Parameters

ranges
The range.

Remarks

If the two union ranges are not intersected, returns null.

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.Intersect Overload List


UnionRange.Intersect Method (UnionRange)

Intersects another range.

public UnionRange Intersect(
UnionRange unionRange
);

Parameters

unionRange
The range.

Remarks

If the two union ranges are not intersected, returns null.

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.Intersect Overload List


UnionRange.Intersect Method (String)

Intersects another range.

public UnionRange Intersect(
string range
);

Parameters

range
The range.

Remarks

If the two union ranges are not intersected, returns null.

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.Intersect Overload List


UnionRange.Merge Method

Combines a range of cells into a single cell.

public void Merge();

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.PutValue Method

Puts a value into the range, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(
string stringValue,
bool isConverted,
bool setStyle
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.
setStyle
True: set the number format to cell's style when converting to other data type

See Also

UnionRange Class | Aspose.Cells Namespace


SetOutlineBorders Method

Aspose.Cells for .NET

UnionRange.SetOutlineBorders Method

Sets the outline borders around a range of cells with same border style and color.

Overload List

Sets the outline borders around a range of cells with same border style and color.

public void SetOutlineBorders(CellBorderType,Color);

Sets out line borders around a range of cells.

public void SetOutlineBorders(CellBorderType[],Color[]);

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.SetOutlineBorders Method (CellBorderType, Color)

Sets the outline borders around a range of cells with same border style and color.

public void SetOutlineBorders(
CellBorderType borderStyle,
Color borderColor
);

Parameters

borderStyle
Border style.
borderColor
Border color.

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.SetOutlineBorders Overload List


UnionRange.SetOutlineBorders Method (CellBorderType[], Color[])

Sets out line borders around a range of cells.

public void SetOutlineBorders(
CellBorderType[] borderStyles,
Color[] borderColors
);

Parameters

borderStyles
Border styles.
borderColors
Border colors.

Remarks

Both the length of borderStyles and borderStyles must be 4. The order of borderStyles and borderStyles must be top,bottom,left,right

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.SetOutlineBorders Overload List


UnionRange.SetStyle Method

Sets the style of the range.

public void SetStyle(
Style style
);

Parameters

style
The Style object.

See Also

UnionRange Class | Aspose.Cells Namespace


Union Method

Aspose.Cells for .NET

UnionRange.Union Method

Union the ranges.

Overload List

Union the ranges.

public UnionRange Union(Range[]);

Union another range.

public UnionRange Union(UnionRange);

Union another range.

public UnionRange Union(string);

See Also

UnionRange Class | Aspose.Cells Namespace


UnionRange.Union Method (Range[])

Union the ranges.

public UnionRange Union(
Range[] ranges
);

Parameters

ranges
The ranges.

Return Value

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.Union Overload List


UnionRange.Union Method (UnionRange)

Union another range.

public UnionRange Union(
UnionRange unionRange
);

Parameters

unionRange
The range.

Return Value

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.Union Overload List


UnionRange.Union Method (String)

Union another range.

public UnionRange Union(
string range
);

Parameters

range
The range.

Return Value

See Also

UnionRange Class | Aspose.Cells Namespace | UnionRange.Union Overload List


UnionRange.UnMerge Method

Unmerges merged cells of this range.

public void UnMerge();

See Also

UnionRange Class | Aspose.Cells Namespace


UpdateLinksType Enumeration

Represents how to update links to other workbooks when the workbook is opened.

public enum UpdateLinksType

Members

Member Name | Description | Value
UserSet | Prompt user to update. | 0
Never | Do not update, and do not prompt user. | 1
Always | Always update. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Validation Class

Represents data validation.settings.

For a list of all members of this type, see Validation Members.

System.Object
Aspose.Cells.Validation

public class Validation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
 Workbook workbook = new Workbook();
    ValidationCollection validations = workbook.Worksheets[0].Validations;
    Validation validation = validations[validations.Add()];
    validation.Type = Aspose.Cells.ValidationType.WholeNumber;
    validation.Operator = OperatorType.Between;
    validation.Formula1 = "3";
    validation.Formula2 = "1234";

    CellArea area;
    area.StartRow = 0;
    area.EndRow = 1;
    area.StartColumn = 0;
    area.EndColumn = 1;

    validation.AddArea(area);

    [Visual Basic]
    Dim workbook as Workbook = new Workbook()
    Dim validations as ValidationCollection  = workbook.Worksheets(0).Validations
    Dim validation as Validation = validations(validations.Add())
    validation.Type = ValidationType.WholeNumber
    validation.Operator = OperatorType.Between
    validation.Formula1 = "3"
    validation.Formula2 = "1234"

    Dim area as CellArea
    area.StartRow = 0
    area.EndRow = 1
    area.StartColumn = 0
    area.EndColumn = 1

    validation.AddArea(area)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Validation Members | Aspose.Cells Namespace


Validation Members

Validation overview

Public Instance Properties

AlertStyle | Represents the validation alert style.
Areas | Gets all CellArea which contain the data validation settings.
ErrorMessage | Represents the data validation error message.
ErrorTitle | Represents the title of the data-validation error dialog box.
Formula1 | Represents the value or expression associated with the data validation.
Formula2 | Represents the value or expression associated with the data validation.
IgnoreBlank | Indicates whether blank values are permitted by the range data validation.
InCellDropDown | Indicates whether data validation displays a drop-down list that contains acceptable values.
InputMessage | Represents the data validation input message.
InputTitle | Represents the title of the data-validation input dialog box.
Operator | Represents the operator for the data validation.
ShowError | Indicates whether the data validation error message will be displayed whenever the user enters invalid data.
ShowInput | Indicates whether the data validation input message will be displayed whenever the user selects a cell in the data validation range.
Type | Represents the data validation type.
Value1 | Represents the first value associated with the data validation.
Value2 | Represents the second value associated with the data validation.

Public Instance Methods

AddArea | Overloaded. Applies the validation to the area.
AddAreas | Applies the validation to given areas.
Copy | Copy validation.
Equals (inherited from Object) |
GetFormula1 | Overloaded. Gets the value or expression associated with this validation.
GetFormula2 | Overloaded. Gets the value or expression associated with this validation.
GetHashCode (inherited from Object) |
GetListValue | Get the value for list of the validation for the specified cell.
GetType (inherited from Object) |
RemoveACell | Remove the validation settings in the cell.
RemoveArea | Remove the validation settings in the range.
RemoveAreas | Removes this validation from given areas.
SetFormula1 | Sets the value or expression associated with this validation.
SetFormula2 | Sets the value or expression associated with this validation.
ToString (inherited from Object) |

See Also

Validation Class | Aspose.Cells Namespace


Validation Properties

The properties of the Validation class are listed below. For a complete list of Validation class members, see the Validation Members topic.

Public Instance Properties

AlertStyle | Represents the validation alert style.
Areas | Gets all CellArea which contain the data validation settings.
ErrorMessage | Represents the data validation error message.
ErrorTitle | Represents the title of the data-validation error dialog box.
Formula1 | Represents the value or expression associated with the data validation.
Formula2 | Represents the value or expression associated with the data validation.
IgnoreBlank | Indicates whether blank values are permitted by the range data validation.
InCellDropDown | Indicates whether data validation displays a drop-down list that contains acceptable values.
InputMessage | Represents the data validation input message.
InputTitle | Represents the title of the data-validation input dialog box.
Operator | Represents the operator for the data validation.
ShowError | Indicates whether the data validation error message will be displayed whenever the user enters invalid data.
ShowInput | Indicates whether the data validation input message will be displayed whenever the user selects a cell in the data validation range.
Type | Represents the data validation type.
Value1 | Represents the first value associated with the data validation.
Value2 | Represents the second value associated with the data validation.

See Also

Validation Class | Aspose.Cells Namespace


AlertStyle Property

Aspose.Cells for .NET

Validation.AlertStyle Property

Represents the validation alert style.

public ValidationAlertType AlertStyle {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Areas Property

Aspose.Cells for .NET

Validation.Areas Property

Gets all CellArea which contain the data validation settings.

public CellArea[] Areas {get;}

See Also

Validation Class | Aspose.Cells Namespace


ErrorMessage Property

Aspose.Cells for .NET

Validation.ErrorMessage Property

Represents the data validation error message.

public string ErrorMessage {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


ErrorTitle Property

Aspose.Cells for .NET

Validation.ErrorTitle Property

Represents the title of the data-validation error dialog box.

public string ErrorTitle {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Formula1 Property

Aspose.Cells for .NET

Validation.Formula1 Property

Represents the value or expression associated with the data validation.

public string Formula1 {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Formula2 Property

Aspose.Cells for .NET

Validation.Formula2 Property

Represents the value or expression associated with the data validation.

public string Formula2 {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


IgnoreBlank Property

Aspose.Cells for .NET

Validation.IgnoreBlank Property

Indicates whether blank values are permitted by the range data validation.

public bool IgnoreBlank {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


InCellDropDown Property

Aspose.Cells for .NET

Validation.InCellDropDown Property

Indicates whether data validation displays a drop-down list that contains acceptable values.

public bool InCellDropDown {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


InputMessage Property

Aspose.Cells for .NET

Validation.InputMessage Property

Represents the data validation input message.

public string InputMessage {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


InputTitle Property

Aspose.Cells for .NET

Validation.InputTitle Property

Represents the title of the data-validation input dialog box.

public string InputTitle {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Operator Property

Aspose.Cells for .NET

Validation.Operator Property

Represents the operator for the data validation.

public OperatorType Operator {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


ShowError Property

Aspose.Cells for .NET

Validation.ShowError Property

Indicates whether the data validation error message will be displayed whenever the user enters invalid data.

public bool ShowError {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


ShowInput Property

Aspose.Cells for .NET

Validation.ShowInput Property

Indicates whether the data validation input message will be displayed whenever the user selects a cell in the data validation range.

public bool ShowInput {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

Validation.Type Property

Represents the data validation type.

public ValidationType Type {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Value1 Property

Aspose.Cells for .NET

Validation.Value1 Property

Represents the first value associated with the data validation.

public object Value1 {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Value2 Property

Aspose.Cells for .NET

Validation.Value2 Property

Represents the second value associated with the data validation.

public object Value2 {get; set;}

See Also

Validation Class | Aspose.Cells Namespace


Validation Methods

The methods of the Validation class are listed below. For a complete list of Validation class members, see the Validation Members topic.

Public Instance Methods

AddArea | Overloaded. Applies the validation to the area.
AddAreas | Applies the validation to given areas.
Copy | Copy validation.
Equals (inherited from Object) |
GetFormula1 | Overloaded. Gets the value or expression associated with this validation.
GetFormula2 | Overloaded. Gets the value or expression associated with this validation.
GetHashCode (inherited from Object) |
GetListValue | Get the value for list of the validation for the specified cell.
GetType (inherited from Object) |
RemoveACell | Remove the validation settings in the cell.
RemoveArea | Remove the validation settings in the range.
RemoveAreas | Removes this validation from given areas.
SetFormula1 | Sets the value or expression associated with this validation.
SetFormula2 | Sets the value or expression associated with this validation.
ToString (inherited from Object) |

See Also

Validation Class | Aspose.Cells Namespace


AddArea Method

Aspose.Cells for .NET

Validation.AddArea Method

Applies the validation to the area.

Overload List

Applies the validation to the area.

public void AddArea(CellArea);

Applies the validation to the area.

public void AddArea(CellArea,bool,bool);

See Also

Validation Class | Aspose.Cells Namespace


Validation.AddArea Method (CellArea)

Applies the validation to the area.

public void AddArea(
CellArea cellArea
);

Parameters

cellArea
The area.

Remarks

It is equivalent to use AddArea with checking intersection and edge.

See Also

Validation Class | Aspose.Cells Namespace | Validation.AddArea Overload List


Validation.AddArea Method (CellArea, Boolean, Boolean)

Applies the validation to the area.

public void AddArea(
CellArea cellArea,
bool checkIntersection,
bool checkEdge
);

Parameters

cellArea
The area.
checkIntersection
Whether check the intersection of given area with existing validations' areas. If one validation has been applied in given area(or part of it), then the existing validation should be removed at first from given area. Otherwise corruption may be caused for the generated Validations. If user is sure that the added area does not intersect with any existing area, this parameter can be set as false for performance consideration.
checkEdge
Whether check the edge of this validation's applied areas. Validation's internal settings depend on the top-left one of its applied ranges, so if given area will become the new top-left one of the applied ranges, the internal settings should be changed and rebuilt, otherwise unexpected result may be caused. If user is sure that the added area is not the top-left one, this parameter can be set as false for performance consideration.

Remarks

In this method, we will remove all old validations in given area. For the top-left one of Validation's applied ranges, firstly its StartRow is smallest, secondly its StartColumn is the smallest one of those areas who have the same smallest StartRow.

See Also

Validation Class | Aspose.Cells Namespace | Validation.AddArea Overload List


Validation.AddAreas Method

Applies the validation to given areas.

public void AddAreas(
CellArea[] areas,
bool checkIntersection,
bool checkEdge
);

Parameters

areas
The areas.
checkIntersection
Whether check the intersection of given area with existing validations' areas. If one validation has been applied in given area(or part of it), then the existing validation should be removed at first from given area. Otherwise corruption may be caused for the generated Validations. If user is sure that all the added areas do not intersect with any existing area, this parameter can be set as false for performance consideration.
checkEdge
Whether check the edge of this validation's applied areas. Validation's internal settings depend on the top-left one of its applied ranges, so if one of given areas will become the new top-left one of the applied ranges, the internal settings should be changed and rebuilt, otherwise unexpected result may be caused. If user is sure that no one of those added areas is the top-left, this parameter can be set as false for performance consideration.

Remarks

In this method, we will remove all old validations in given area. For the top-left one of Validation's applied ranges, firstly its StartRow is smallest, secondly its StartColumn is the smallest one of those areas who have the same smallest StartRow.

See Also

Validation Class | Aspose.Cells Namespace


Validation.Copy Method

Copy validation.

public void Copy(
Validation source,
CopyOptions copyOption
);

Parameters

source
The source validation.
copyOption
The copy option.

See Also

Validation Class | Aspose.Cells Namespace


GetFormula1 Method

Aspose.Cells for .NET

Validation.GetFormula1 Method

Gets the value or expression associated with this validation.

Overload List

Gets the value or expression associated with this validation.

public string GetFormula1(bool,bool);

Gets the value or expression associated with this validation for specific cell.

public string GetFormula1(bool,bool,int,int);

See Also

Validation Class | Aspose.Cells Namespace


Validation.GetFormula1 Method (Boolean, Boolean)

Gets the value or expression associated with this validation.

public string GetFormula1(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The value or expression associated with this validation.

See Also

Validation Class | Aspose.Cells Namespace | Validation.GetFormula1 Overload List


Validation.GetFormula1 Method (Boolean, Boolean, Int32, Int32)

Gets the value or expression associated with this validation for specific cell.

public string GetFormula1(
bool isR1C1,
bool isLocal,
int row,
int column
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.
row
The row index.
column
The column index.

Return Value

The value or expression associated with this validation.

See Also

Validation Class | Aspose.Cells Namespace | Validation.GetFormula1 Overload List


GetFormula2 Method

Aspose.Cells for .NET

Validation.GetFormula2 Method

Gets the value or expression associated with this validation.

Overload List

Gets the value or expression associated with this validation.

public string GetFormula2(bool,bool);

Gets the value or expression associated with this validation for specific cell.

public string GetFormula2(bool,bool,int,int);

See Also

Validation Class | Aspose.Cells Namespace


Validation.GetFormula2 Method (Boolean, Boolean)

Gets the value or expression associated with this validation.

public string GetFormula2(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The value or expression associated with this validation.

See Also

Validation Class | Aspose.Cells Namespace | Validation.GetFormula2 Overload List


Validation.GetFormula2 Method (Boolean, Boolean, Int32, Int32)

Gets the value or expression associated with this validation for specific cell.

public string GetFormula2(
bool isR1C1,
bool isLocal,
int row,
int column
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.
row
The row index.
column
The column index.

Return Value

The value or expression associated with this validation.

See Also

Validation Class | Aspose.Cells Namespace | Validation.GetFormula2 Overload List


Validation.GetListValue Method

Get the value for list of the validation for the specified cell.

public object GetListValue(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

The value to produce the list of this validation for the specified cell. If the list references to a range, then the returned value will be a ReferredArea object; Otherwise the returned value may be null, object[], or simple object.

Remarks

Only for validation whose type is List and has been applied to given cell, otherwise null will be returned.

See Also

Validation Class | Aspose.Cells Namespace


Validation.RemoveACell Method

Remove the validation settings in the cell.

public void RemoveACell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

See Also

Validation Class | Aspose.Cells Namespace


Validation.RemoveArea Method

Remove the validation settings in the range.

public void RemoveArea(
CellArea cellArea
);

Parameters

cellArea
the areas where this validation settings should be removed.

See Also

Validation Class | Aspose.Cells Namespace


Validation.RemoveAreas Method

Removes this validation from given areas.

public void RemoveAreas(
CellArea[] areas
);

Parameters

areas
the areas where this validation settings should be removed.

See Also

Validation Class | Aspose.Cells Namespace


Validation.SetFormula1 Method

Sets the value or expression associated with this validation.

public void SetFormula1(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
The value or expression associated with this format condition.
isR1C1
Whether the formula is R1C1 formula.
isLocal
Whether the formula is locale formatted.

See Also

Validation Class | Aspose.Cells Namespace


Validation.SetFormula2 Method

Sets the value or expression associated with this validation.

public void SetFormula2(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
The value or expression associated with this format condition.
isR1C1
Whether the formula is R1C1 formula.
isLocal
Whether the formula is locale formatted.

See Also

Validation Class | Aspose.Cells Namespace


ValidationAlertType Enumeration

Represents the data validation alert style.

public enum ValidationAlertType

Members

Member Name | Description | Value
Information | Information alert style. | 0
Stop | Stop alert style. | 1
Warning | Warning alert style. | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


ValidationCollection Class

Represents data validation collection.

For a list of all members of this type, see ValidationCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ValidationCollection

public class ValidationCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ValidationCollection Members | Aspose.Cells Namespace


ValidationCollection Members

ValidationCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Validation element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a data validation to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValidationInCell | Gets the validation applied to given cell.
RemoveACell | Removes all validation setting on the cell.
RemoveArea | Removes all validation setting on the range..
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ValidationCollection Class | Aspose.Cells Namespace


ValidationCollection Properties

The properties of the ValidationCollection class are listed below. For a complete list of ValidationCollection class members, see the ValidationCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Validation element at the specified index.

See Also

ValidationCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

ValidationCollection.Item Property

Gets the Validation element at the specified index.

public Validation this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ValidationCollection Class | Aspose.Cells Namespace


ValidationCollection Methods

The methods of the ValidationCollection class are listed below. For a complete list of ValidationCollection class members, see the ValidationCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a data validation to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValidationInCell | Gets the validation applied to given cell.
RemoveACell | Removes all validation setting on the cell.
RemoveArea | Removes all validation setting on the range..
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ValidationCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

ValidationCollection.Add Method

NOTE: This method is now obsolete.

Use ValidationCollection.Add(CellArea) method instead.

Adds a data validation to the collection.

Overload List

Obsolete. Adds a data validation to the collection.

public int Add();

Adds a data validation to the collection.

public int Add(CellArea);

See Also

ValidationCollection Class | Aspose.Cells Namespace


ValidationCollection.Add Method ()

NOTE: This method is now obsolete.

Use ValidationCollection.Add(CellArea) method instead.

Adds a data validation to the collection.

public int Add();

Return Value

Validation object index.

Remarks

NOTE: This member is now obsolete. Instead, please use ValidationCollection.Add(CellArea) method. This property will be removed 12 months later since JANUARY 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

ValidationCollection Class | Aspose.Cells Namespace | ValidationCollection.Add Overload List


ValidationCollection.Add Method (CellArea)

Adds a data validation to the collection.

public int Add(
CellArea ca
);

Parameters

ca
The area contains this validation.

Return Value

Validation object index.

See Also

ValidationCollection Class | Aspose.Cells Namespace | ValidationCollection.Add Overload List


ValidationCollection.GetValidationInCell Method

Gets the validation applied to given cell.

public Validation GetValidationInCell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

Returns a Validation object or null if there is no validation for given cell

See Also

ValidationCollection Class | Aspose.Cells Namespace


ValidationCollection.RemoveACell Method

Removes all validation setting on the cell.

public void RemoveACell(
int row,
int column
);

Parameters

row
The row index of the cell.
column
The column index of the cell.

See Also

ValidationCollection Class | Aspose.Cells Namespace


ValidationCollection.RemoveArea Method

Removes all validation setting on the range..

public void RemoveArea(
CellArea ca
);

Parameters

ca
The range which contains the validations setting.

See Also

ValidationCollection Class | Aspose.Cells Namespace


ValidationType Enumeration

Represents data validation type.

public enum ValidationType

Members

Member Name | Description | Value
AnyValue | Any value validation type. | 0
WholeNumber | Whole number validation type. | 1
Decimal | Decimal validation type. | 2
List | List validation type. | 3
Date | Date validation type. | 4
Time | Time validation type. | 5
TextLength | Text length validation type. | 6
Custom | Custom validation type. | 7

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


VerticalPageBreak Class

Encapsulates the object that represents a vertical page break.

For a list of all members of this type, see VerticalPageBreak Members.

System.Object
Aspose.Cells.VerticalPageBreak

public class VerticalPageBreak

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Add a pagebreak at G5
excel.Worksheets[0].HorizontalPageBreaks.Add("G5");
excel.Worksheets[0].VerticalPageBreaks.Add("G5");

[VB]
'Add a pagebreak at G5
excel.Worksheets(0).HorizontalPageBreaks.Add("G5")
excel.Worksheets(0).VerticalPageBreaks.Add("G5")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VerticalPageBreak Members | Aspose.Cells Namespace


VerticalPageBreak Members

VerticalPageBreak overview

Public Instance Properties

Column | Gets the column index of the vertical page break.
EndRow | Gets the end row index of the vertical page break.
StartRow | Gets the start row index of the vertical page break.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

VerticalPageBreak Class | Aspose.Cells Namespace


VerticalPageBreak Properties

The properties of the VerticalPageBreak class are listed below. For a complete list of VerticalPageBreak class members, see the VerticalPageBreak Members topic.

Public Instance Properties

Column | Gets the column index of the vertical page break.
EndRow | Gets the end row index of the vertical page break.
StartRow | Gets the start row index of the vertical page break.

See Also

VerticalPageBreak Class | Aspose.Cells Namespace


Column Property

Aspose.Cells for .NET

VerticalPageBreak.Column Property

Gets the column index of the vertical page break.

public int Column {get;}

See Also

VerticalPageBreak Class | Aspose.Cells Namespace


EndRow Property

Aspose.Cells for .NET

VerticalPageBreak.EndRow Property

Gets the end row index of the vertical page break.

public int EndRow {get;}

See Also

VerticalPageBreak Class | Aspose.Cells Namespace


StartRow Property

Aspose.Cells for .NET

VerticalPageBreak.StartRow Property

Gets the start row index of the vertical page break.

public int StartRow {get;}

See Also

VerticalPageBreak Class | Aspose.Cells Namespace


VerticalPageBreakCollection Class

Encapsulates a collection of VerticalPageBreak objects.

For a list of all members of this type, see VerticalPageBreakCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.VerticalPageBreakCollection

public class VerticalPageBreakCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VerticalPageBreakCollection Members | Aspose.Cells Namespace


VerticalPageBreakCollection Members

VerticalPageBreakCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the VerticalPageBreak element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a vertical page break to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes the VPageBreak element at a specified name.
ToString (inherited from Object) |

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace


VerticalPageBreakCollection Properties

The properties of the VerticalPageBreakCollection class are listed below. For a complete list of VerticalPageBreakCollection class members, see the VerticalPageBreakCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the VerticalPageBreak element at the specified index.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

VerticalPageBreakCollection.Item Property

Gets the VerticalPageBreak element at the specified index.

Overload List

Gets the VerticalPageBreak element at the specified index.

public VerticalPageBreak this[int] {get;}

Gets the VerticalPageBreak element with the specified cell name.

public VerticalPageBreak this[string] {get;}

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

VerticalPageBreakCollection.Item Property (Int32)

Gets the VerticalPageBreak element at the specified index.

public VerticalPageBreak this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace | VerticalPageBreakCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

VerticalPageBreakCollection.Item Property (String)

Gets the VerticalPageBreak element with the specified cell name.

public VerticalPageBreak this[
string cellName
] {get;}

Parameters

cellName
Cell name.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace | VerticalPageBreakCollection.Item Overload List


VerticalPageBreakCollection Methods

The methods of the VerticalPageBreakCollection class are listed below. For a complete list of VerticalPageBreakCollection class members, see the VerticalPageBreakCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a vertical page break to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes the VPageBreak element at a specified name.
ToString (inherited from Object) |

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

VerticalPageBreakCollection.Add Method

Adds a vertical page break to the collection.

Overload List

Adds a vertical page break to the collection.

public int Add(int);

Adds a vertical page break to the collection.

public int Add(int,int);

Adds a vertical page break to the collection.

public int Add(int,int,int);

Adds a vertical page break to the collection.

public int Add(string);

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace


VerticalPageBreakCollection.Add Method (Int32)

Adds a vertical page break to the collection.

public int Add(
int column
);

Parameters

column
Cell column index, zero based.

Return Value

VerticalPageBreak object index.

Remarks

Page break is added in the top left of the cell. Please set a horizontal page break and a vertical page break concurrently.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace | VerticalPageBreakCollection.Add Overload List


VerticalPageBreakCollection.Add Method (Int32, Int32)

Adds a vertical page break to the collection.

public int Add(
int row,
int column
);

Parameters

row
Cell row index, zero based.
column
Cell column index, zero based.

Return Value

VerticalPageBreak object index.

Remarks

Page break is added in the top left of the cell. Please set a horizontal page break and a vertical page break concurrently.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace | VerticalPageBreakCollection.Add Overload List


VerticalPageBreakCollection.Add Method (Int32, Int32, Int32)

Adds a vertical page break to the collection.

public int Add(
int startRow,
int endRow,
int column
);

Parameters

startRow
Start row index, zero based.
endRow
End row index, zero based.
column
Column index, zero based.

Return Value

VerticalPageBreak object index.

Remarks

This method is used to add a vertical pagebreak within a print area.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace | VerticalPageBreakCollection.Add Overload List


VerticalPageBreakCollection.Add Method (String)

Adds a vertical page break to the collection.

public int Add(
string cellName
);

Parameters

cellName
Cell name.

Return Value

VerticalPageBreak object index.

Remarks

Page break is added in the top left of the cell. Please set a horizontal page break and a vertical page break concurrently.

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace | VerticalPageBreakCollection.Add Overload List


VerticalPageBreakCollection.RemoveAt Method

Removes the VPageBreak element at a specified name.

new public void RemoveAt(
int index
);

Parameters

index
Element index, zero based.

Implements

IList.RemoveAt

See Also

VerticalPageBreakCollection Class | Aspose.Cells Namespace


ViewType Enumeration

Represents the view type of the worksheet.

public enum ViewType

Members

Member Name | Description | Value
NormalView |  | 0
PageBreakPreview |  | 1
PageLayoutView |  | 2

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


VisibilityType Enumeration

Represents the states for sheet visibility.

public enum VisibilityType

Members

Member Name | Description | Value
Hidden | Indicates the sheet is hidden, but can be shown by the user via the user interface. | 1
VeryHidden | Indicates the sheet is hidden and cannot be shown in the user interface (UI). This state is only available programmatically. | 2
Visible | Indicates the sheet is visible. | 0

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


WarningInfo Class

Warning info

For a list of all members of this type, see WarningInfo Members.

System.Object
Aspose.Cells.WarningInfo

public class WarningInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WarningInfo Members | Aspose.Cells Namespace


WarningInfo Members

WarningInfo overview

Public Instance Properties

CorrectedObject | Gets and sets the corrected object.
Description | Get description of warning info.
ErrorObject | The error object.
WarningType | Get warning type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WarningInfo Class | Aspose.Cells Namespace


WarningInfo Properties

The properties of the WarningInfo class are listed below. For a complete list of WarningInfo class members, see the WarningInfo Members topic.

Public Instance Properties

CorrectedObject | Gets and sets the corrected object.
Description | Get description of warning info.
ErrorObject | The error object.
WarningType | Get warning type.

See Also

WarningInfo Class | Aspose.Cells Namespace


CorrectedObject Property

Aspose.Cells for .NET

WarningInfo.CorrectedObject Property

Gets and sets the corrected object.

public object CorrectedObject {get; set;}

See Also

WarningInfo Class | Aspose.Cells Namespace


Description Property

Aspose.Cells for .NET

WarningInfo.Description Property

Get description of warning info.

public string Description {get;}

See Also

WarningInfo Class | Aspose.Cells Namespace


ErrorObject Property

Aspose.Cells for .NET

WarningInfo.ErrorObject Property

The error object.

public object ErrorObject {get;}

See Also

WarningInfo Class | Aspose.Cells Namespace


WarningType Property

Aspose.Cells for .NET

WarningInfo.WarningType Property

Get warning type.

public WarningType WarningType {get;}

See Also

WarningInfo Class | Aspose.Cells Namespace


WarningType Enumeration

WaringType

public enum WarningType

Members

Member Name | Description | Value
FontSubstitution | Font substitution warning type when a font has not been found, this warning type can be get. | 0
DuplicateDefinedName | Duplicate defined name is found in the file. | 1
UnsupportedFileFormat | Unsupported file format. | 2
InvalidTextOfDefinedName | Invalid text of the defined name. | 3
InvalidFontName | Invalid the font name. | 4
InvalidAutoFilterRange | Invalid autofilter range. | 5

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells Namespace


Workbook Class

Represents a root object to create an Excel spreadsheet.

For a list of all members of this type, see Workbook Members.

System.Object
Aspose.Cells.Workbook

public class Workbook : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The Workbook class denotes an Excel spreadsheet. Each spreadsheet can contain multiple worksheets. The basic feature of the class is to open and save native excel files. The class has some advanced features like copying data from other Workbooks, combining two Workbooks and protecting the Excel spreadsheet.

Example

The following example creates a Workbook, opens a file named designer.xls in it and makes the horizontal and vertical scroll bars invisible for the Workbook. It then replaces two string values with an Integer value and string value respectively within the spreadsheet and finally sends the updated file to the client browser.

[C#]

 //Open a designer file
 string designerFile = MapPath("Designer") + "\\designer.xls";
 Workbook workbook = new Workbook(designerFile);

 //Set scroll bars
 workbook.Settings.IsHScrollBarVisible = false;
 workbook.Settings.IsVScrollBarVisible = false;

 //Replace the placeholder string with new values
 int newInt = 100;
 workbook.Replace("OldInt", newInt);

 string newString = "Hello!";
 workbook.Replace("OldString", newString);
 XlsSaveOptions saveOptions = new XlsSaveOptions();
 workbook.Save(Response, "result.xls", ContentDisposition.Inline, saveOptions);

 [Visual Basic]

 'Open a designer file
 Dim designerFile as String = MapPath("Designer") + "\designer.xls"
 Dim workbook as Workbook = new Workbook(designerFile)

 'Set scroll bars
 workbook.IsHScrollBarVisible = False
 workbook.IsVScrollBarVisible = False

 'Replace the placeholder string with new values
 Dim newInt as Integer = 100
 workbook.Replace("OldInt", newInt)

 Dim newString as String = "Hello!"
 workbook.Replace("OldString", newString)
 Dim saveOptions as XlsSaveOptions  = new XlsSaveOptions()
 workbook.Save(Response, "result.xls", ContentDisposition.Inline, saveOptions)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Workbook Members | Aspose.Cells Namespace


Workbook Members

Workbook overview

Public Instance Constructors

Workbook Overloaded. Initializes a new instance of the Workbook class.

Public Instance Properties

AbsolutePath | Gets and sets the absolute path of the file.
BuiltInDocumentProperties | Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.
Colors | Returns colors in the palette for the spreadsheet.
ContentTypeProperties | Gets the list of ContentTypeProperty objects in the workbook.
CountOfStylesInPool | Gets number of the styles in the style pool.
CustomDocumentProperties | Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.
CustomXmlParts | Represents a Custom XML Data Storage Part (custom XML data within a package).
DataConnections | Gets the ExternalConnection collection.
DataMashup | Gets mashup data.
DataSorter | Gets a DataSorter object to sort data.
DefaultStyle | Gets or sets the default Style object of the workbook.
FileFormat | Gets and sets the file format.
FileName | Gets and sets the current file name.
HasMacro | Indicates if this spreadsheet contains macro/VBA.
HasRevisions | Gets if the workbook has any tracked changes
InterruptMonitor | Gets and sets the interrupt monitor.
IsDigitallySigned | Indicates if this spreadsheet is digitally signed.
IsLicensed | Indicates whether license is set.
IsWorkbookProtectedWithPassword | Indicates whether structure or window is protected with password.
RibbonXml | Gets and sets the XML file that defines the Ribbon UI.
Settings | Represents the workbook settings.
Theme | Gets the theme name.
VbaProject | Gets the VbaProject in a spreadsheet.
Worksheets | Gets the WorksheetCollection collection in the spreadsheet.

Public Instance Methods

AcceptAllRevisions | Accepts all tracked changes in the workbook.
AddDigitalSignature | Adds digital signature to an OOXML spreadsheet file (Excel2007 and later).
CalculateFormula | Overloaded. Calculates the result of formulas.
ChangePalette | Changes the palette for the spreadsheet in the specified index.
Combine | Combines another Workbook object.
Copy | Overloaded. Copies data from a source Workbook object.
CopyTheme | Copies the theme from another workbook.
CreateBuiltinStyle | Creates built-in style by given type.
CreateCellsColor | Creates a CellsColor object.
CreateStyle | Creates a new style.
CustomTheme | Customs the theme.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
ExportXml | Overloaded. Export XML data.
GetDigitalSignature | Gets digital signature from file.
GetFonts | Gets all fonts in the style pool.
GetHashCode (inherited from Object) |
GetMatchingColor | Find best matching Color in current palette.
GetNamedStyle | Gets the named style in the style pool.
GetStyleInPool | Gets the style in the style pool. All styles in the workbook will be gathered into a pool. There is only a simple reference index in the cells.
GetThemeColor | Gets theme color.
GetType (inherited from Object) |
HasExernalLinks | Indicates whether this workbook contains external links to other data sources.
ImportXml | Overloaded. Imports an xml file into the workbook.
IsColorInPalette | Checks if a color is in the palette for the spreadsheet.
ParseFormulas | Parses all formulas which have not been parsed when they were loaded from template file or set to a cell.
Protect | Protects a workbook.
ProtectSharedWorkbook | Protects a shared workbook.
RemoveDigitalSignature | Removes digital signature from this spreadsheet.
RemoveExternalLinks | Removes all external links in the workbook.
RemoveMacro | Removes VBA/macro from this spreadsheet.
RemoveUnusedStyles | Remove all unused styles.
Replace | Overloaded. Replaces a cell's value with a new string.
Save | Overloaded. Saves the workbook to the disk.
SaveToStream | Saves Excel file to a MemoryStream object and returns it.
SetDigitalSignature | Sets digital signature to an spreadsheet file (Excel2007 and later).
SetEncryptionOptions | Set Encryption Options.
SetThemeColor | Sets the theme color
ToString (inherited from Object) |
Unprotect | Unprotects a workbook.
UnprotectSharedWorkbook | Unprotects a shared workbook.
UpdateLinkedDataSource | If this workbook contains external links to other data source, Aspose.Cells will attempt to retrieve the latest data.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook Constructor

Initializes a new instance of the Workbook class.

Overload List

Initializes a new instance of the Workbook class.

public Workbook();

Initializes a new instance of the Workbook class.

public Workbook(FileFormatType);

Initializes a new instance of the Workbook class and open a stream.

public Workbook(Stream);

Initializes a new instance of the Workbook class and open stream.

public Workbook(Stream,LoadOptions);

Initializes a new instance of the Workbook class and open a file.

public Workbook(string);

Initializes a new instance of the Workbook class and open a file.

public Workbook(string,LoadOptions);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook Constructor ()

Initializes a new instance of the Workbook class.

public Workbook();

Remarks

The default file format type is Excel97To2003.If want create other format file type, please call Workbook(FileFormatType fileFormatType).

Example

The following code shows how to use the Workbook constructor to create and initialize a new instance of the class.

[C#]

Workbook workbook = new Workbook();

[Visual Basic]

Dim workbook as Workbook = new Workbook()

See Also

Workbook Class | Aspose.Cells Namespace | Workbook Constructor Overload List


Workbook Constructor (FileFormatType)

Initializes a new instance of the Workbook class.

public Workbook(
FileFormatType fileFormatType
);

Parameters

fileFormatType
The new file format.

Remarks

The default file format type is Excel97To2003.

Example

The following code shows how to use the Workbook constructor to create and initialize a new instance of the class.

[C#]

Workbook workbook = new Workbook(FileFormatType.Excel2007Xlsx);

[Visual Basic]

Dim workbook as Workbook = new Workbook(FileFormatType.Excel2007Xlsx)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook Constructor Overload List


Workbook Constructor (String)

Initializes a new instance of the Workbook class and open a file.

public Workbook(
string file
);

Parameters

file
The file name.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook Constructor Overload List


Workbook Constructor (Stream)

Initializes a new instance of the Workbook class and open a stream.

public Workbook(
Stream stream
);

Parameters

stream
The stream.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook Constructor Overload List


Workbook Constructor (String, LoadOptions)

Initializes a new instance of the Workbook class and open a file.

public Workbook(
string file,
LoadOptions loadOptions
);

Parameters

file
The file name.
loadOptions
The load options

See Also

Workbook Class | Aspose.Cells Namespace | Workbook Constructor Overload List


Workbook Constructor (Stream, LoadOptions)

Initializes a new instance of the Workbook class and open stream.

public Workbook(
Stream stream,
LoadOptions loadOptions
);

Parameters

stream
The stream.
loadOptions
The load options

See Also

Workbook Class | Aspose.Cells Namespace | Workbook Constructor Overload List


Workbook Properties

The properties of the Workbook class are listed below. For a complete list of Workbook class members, see the Workbook Members topic.

Public Instance Properties

AbsolutePath | Gets and sets the absolute path of the file.
BuiltInDocumentProperties | Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.
Colors | Returns colors in the palette for the spreadsheet.
ContentTypeProperties | Gets the list of ContentTypeProperty objects in the workbook.
CountOfStylesInPool | Gets number of the styles in the style pool.
CustomDocumentProperties | Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.
CustomXmlParts | Represents a Custom XML Data Storage Part (custom XML data within a package).
DataConnections | Gets the ExternalConnection collection.
DataMashup | Gets mashup data.
DataSorter | Gets a DataSorter object to sort data.
DefaultStyle | Gets or sets the default Style object of the workbook.
FileFormat | Gets and sets the file format.
FileName | Gets and sets the current file name.
HasMacro | Indicates if this spreadsheet contains macro/VBA.
HasRevisions | Gets if the workbook has any tracked changes
InterruptMonitor | Gets and sets the interrupt monitor.
IsDigitallySigned | Indicates if this spreadsheet is digitally signed.
IsLicensed | Indicates whether license is set.
IsWorkbookProtectedWithPassword | Indicates whether structure or window is protected with password.
RibbonXml | Gets and sets the XML file that defines the Ribbon UI.
Settings | Represents the workbook settings.
Theme | Gets the theme name.
VbaProject | Gets the VbaProject in a spreadsheet.
Worksheets | Gets the WorksheetCollection collection in the spreadsheet.

See Also

Workbook Class | Aspose.Cells Namespace


AbsolutePath Property

Aspose.Cells for .NET

Workbook.AbsolutePath Property

Gets and sets the absolute path of the file.

public string AbsolutePath {get; set;}

Remarks

Only used for external links.

See Also

Workbook Class | Aspose.Cells Namespace


BuiltInDocumentProperties Property

Aspose.Cells for .NET

Workbook.BuiltInDocumentProperties Property

Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.

public BuiltInDocumentPropertyCollection BuiltInDocumentProperties {get;}

Remarks

A new property cannot be added to built-in document properties list. You can only get a built-in property and change its value. The following is the built-in properties name list:

Title

Subject

Author

Keywords

Comments

Template

Last Author

Revision Number

Application Name

Last Print Date

Creation Date

Last Save Time

Total Editing Time

Number of Pages

Number of Words

Number of Characters

Security

Category

Format

Manager

Company

Number of Bytes

Number of Lines

Number of Paragraphs

Number of Slides

Number of Notes

Number of Hidden Slides

Number of Multimedia Clips

Example

[C#]
DocumentProperty doc = workbook.BuiltInDocumentProperties["Author"];
doc.Value = "John Smith";

[Visual Basic]
Dim doc as DocumentProperty = workbook.BuiltInDocumentProperties("Author")
doc.Value = "John Smith"

See Also

Workbook Class | Aspose.Cells Namespace


Colors Property

Aspose.Cells for .NET

Workbook.Colors Property

Returns colors in the palette for the spreadsheet.

public Color[] Colors {get;}

Remarks

The palette has 56 entries, each represented by an RGB value.

See Also

Workbook Class | Aspose.Cells Namespace


ContentTypeProperties Property

Aspose.Cells for .NET

Workbook.ContentTypeProperties Property

Gets the list of ContentTypeProperty objects in the workbook.

public ContentTypePropertyCollection ContentTypeProperties {get;}

See Also

Workbook Class | Aspose.Cells Namespace


CountOfStylesInPool Property

Aspose.Cells for .NET

Workbook.CountOfStylesInPool Property

Gets number of the styles in the style pool.

public int CountOfStylesInPool {get;}

See Also

Workbook Class | Aspose.Cells Namespace


CustomDocumentProperties Property

Aspose.Cells for .NET

Workbook.CustomDocumentProperties Property

Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.

public CustomDocumentPropertyCollection CustomDocumentProperties {get;}

Example

[C#]
excel.CustomDocumentProperties.Add("Checked by", "Jane");

[Visual Basic]
excel.CustomDocumentProperties.Add("Checked by", "Jane")

See Also

Workbook Class | Aspose.Cells Namespace


CustomXmlParts Property

Aspose.Cells for .NET

Workbook.CustomXmlParts Property

Represents a Custom XML Data Storage Part (custom XML data within a package).

public CustomXmlPartCollection CustomXmlParts {get;}

See Also

Workbook Class | Aspose.Cells Namespace


DataConnections Property

Aspose.Cells for .NET

Workbook.DataConnections Property

Gets the ExternalConnection collection.

public ExternalConnectionCollection DataConnections {get;}

See Also

Workbook Class | Aspose.Cells Namespace


DataMashup Property

Aspose.Cells for .NET

Workbook.DataMashup Property

Gets mashup data.

public DataMashup DataMashup {get;}

See Also

Workbook Class | Aspose.Cells Namespace


DataSorter Property

Aspose.Cells for .NET

Workbook.DataSorter Property

Gets a DataSorter object to sort data.

public DataSorter DataSorter {get;}

See Also

Workbook Class | Aspose.Cells Namespace


DefaultStyle Property

Aspose.Cells for .NET

Workbook.DefaultStyle Property

Gets or sets the default Style object of the workbook.

public Style DefaultStyle {get; set;}

Remarks

The DefaultStyle property is useful to implement a Style for the whole Workbook.

Example

The following code creates and instantiates a new Workbook and sets a default Style to it.

[C#]
 Workbook workbook = new Workbook();
 Style defaultStyle = workbook.DefaultStyle;
 defaultStyle.Font.Name = "Tahoma";
 workbook.DefaultStyle = defaultStyle;

 [Visual Basic]
 Dim workbook as Workbook = new Workbook()
 Dim defaultStyle as Style = workbook.DefaultStyle
 defaultStyle.Font.Name = "Tahoma"
 workbook.DefaultStyle = defaultStyle

See Also

Workbook Class | Aspose.Cells Namespace


FileFormat Property

Aspose.Cells for .NET

Workbook.FileFormat Property

Gets and sets the file format.

public FileFormatType FileFormat {get; set;}

See Also

Workbook Class | Aspose.Cells Namespace


FileName Property

Aspose.Cells for .NET

Workbook.FileName Property

Gets and sets the current file name.

public string FileName {get; set;}

Remarks

If the file is opened by stream and there are some external formula references, please set the file name.

See Also

Workbook Class | Aspose.Cells Namespace


HasMacro Property

Aspose.Cells for .NET

Workbook.HasMacro Property

Indicates if this spreadsheet contains macro/VBA.

public bool HasMacro {get;}

See Also

Workbook Class | Aspose.Cells Namespace


HasRevisions Property

Aspose.Cells for .NET

Workbook.HasRevisions Property

Gets if the workbook has any tracked changes

public bool HasRevisions {get;}

See Also

Workbook Class | Aspose.Cells Namespace


InterruptMonitor Property

Aspose.Cells for .NET

Workbook.InterruptMonitor Property

Gets and sets the interrupt monitor.

public InterruptMonitor InterruptMonitor {get; set;}

See Also

Workbook Class | Aspose.Cells Namespace


IsDigitallySigned Property

Aspose.Cells for .NET

Workbook.IsDigitallySigned Property

Indicates if this spreadsheet is digitally signed.

public bool IsDigitallySigned {get;}

See Also

Workbook Class | Aspose.Cells Namespace


IsLicensed Property

Aspose.Cells for .NET

Workbook.IsLicensed Property

Indicates whether license is set.

public bool IsLicensed {get;}

See Also

Workbook Class | Aspose.Cells Namespace


IsWorkbookProtectedWithPassword Property

Aspose.Cells for .NET

Workbook.IsWorkbookProtectedWithPassword Property

Indicates whether structure or window is protected with password.

public bool IsWorkbookProtectedWithPassword {get;}

See Also

Workbook Class | Aspose.Cells Namespace


RibbonXml Property

Aspose.Cells for .NET

Workbook.RibbonXml Property

Gets and sets the XML file that defines the Ribbon UI.

public string RibbonXml {get; set;}

See Also

Workbook Class | Aspose.Cells Namespace


Settings Property

Aspose.Cells for .NET

Workbook.Settings Property

Represents the workbook settings.

public WorkbookSettings Settings {get;}

See Also

Workbook Class | Aspose.Cells Namespace


Theme Property

Aspose.Cells for .NET

Workbook.Theme Property

Gets the theme name.

public string Theme {get;}

See Also

Workbook Class | Aspose.Cells Namespace


VbaProject Property

Aspose.Cells for .NET

Workbook.VbaProject Property

Gets the VbaProject in a spreadsheet.

public VbaProject VbaProject {get;}

See Also

Workbook Class | Aspose.Cells Namespace


Worksheets Property

Aspose.Cells for .NET

Workbook.Worksheets Property

Gets the WorksheetCollection collection in the spreadsheet.

public WorksheetCollection Worksheets {get;}

See Also

Workbook Class | Aspose.Cells Namespace


Workbook Methods

The methods of the Workbook class are listed below. For a complete list of Workbook class members, see the Workbook Members topic.

Public Instance Methods

AcceptAllRevisions | Accepts all tracked changes in the workbook.
AddDigitalSignature | Adds digital signature to an OOXML spreadsheet file (Excel2007 and later).
CalculateFormula | Overloaded. Calculates the result of formulas.
ChangePalette | Changes the palette for the spreadsheet in the specified index.
Combine | Combines another Workbook object.
Copy | Overloaded. Copies data from a source Workbook object.
CopyTheme | Copies the theme from another workbook.
CreateBuiltinStyle | Creates built-in style by given type.
CreateCellsColor | Creates a CellsColor object.
CreateStyle | Creates a new style.
CustomTheme | Customs the theme.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
ExportXml | Overloaded. Export XML data.
GetDigitalSignature | Gets digital signature from file.
GetFonts | Gets all fonts in the style pool.
GetHashCode (inherited from Object) |
GetMatchingColor | Find best matching Color in current palette.
GetNamedStyle | Gets the named style in the style pool.
GetStyleInPool | Gets the style in the style pool. All styles in the workbook will be gathered into a pool. There is only a simple reference index in the cells.
GetThemeColor | Gets theme color.
GetType (inherited from Object) |
HasExernalLinks | Indicates whether this workbook contains external links to other data sources.
ImportXml | Overloaded. Imports an xml file into the workbook.
IsColorInPalette | Checks if a color is in the palette for the spreadsheet.
ParseFormulas | Parses all formulas which have not been parsed when they were loaded from template file or set to a cell.
Protect | Protects a workbook.
ProtectSharedWorkbook | Protects a shared workbook.
RemoveDigitalSignature | Removes digital signature from this spreadsheet.
RemoveExternalLinks | Removes all external links in the workbook.
RemoveMacro | Removes VBA/macro from this spreadsheet.
RemoveUnusedStyles | Remove all unused styles.
Replace | Overloaded. Replaces a cell's value with a new string.
Save | Overloaded. Saves the workbook to the disk.
SaveToStream | Saves Excel file to a MemoryStream object and returns it.
SetDigitalSignature | Sets digital signature to an spreadsheet file (Excel2007 and later).
SetEncryptionOptions | Set Encryption Options.
SetThemeColor | Sets the theme color
ToString (inherited from Object) |
Unprotect | Unprotects a workbook.
UnprotectSharedWorkbook | Unprotects a shared workbook.
UpdateLinkedDataSource | If this workbook contains external links to other data source, Aspose.Cells will attempt to retrieve the latest data.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.AcceptAllRevisions Method

Accepts all tracked changes in the workbook.

public void AcceptAllRevisions();

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.AddDigitalSignature Method

Adds digital signature to an OOXML spreadsheet file (Excel2007 and later).

public void AddDigitalSignature(
DigitalSignatureCollection digitalSignatureCollection
);

Parameters

digitalSignatureCollection

Remarks

Only support adding Xmldsig Digital Signature to an OOXML spreadsheet file

See Also

Workbook Class | Aspose.Cells Namespace


CalculateFormula Method

Aspose.Cells for .NET

Workbook.CalculateFormula Method

Calculates the result of formulas.

Overload List

Calculates the result of formulas.

public void CalculateFormula();

Calculating formulas in this workbook.

public void CalculateFormula(CalculationOptions);

Calculates the result of formulas.

public void CalculateFormula(bool);

Obsolete. Calculates the result of formulas.

public void CalculateFormula(bool,ICustomFunction);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.CalculateFormula Method ()

Calculates the result of formulas.

public void CalculateFormula();

Remarks

For all supported formulas, please see the list at https://docs.aspose.com/display/cellsnet/Supported+Formula+Functions

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.CalculateFormula Overload List


Workbook.CalculateFormula Method (CalculationOptions)

Calculating formulas in this workbook.

public void CalculateFormula(
CalculationOptions options
);

Parameters

options
Options for calculation

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.CalculateFormula Overload List


Workbook.CalculateFormula Method (Boolean)

Calculates the result of formulas.

public void CalculateFormula(
bool ignoreError
);

Parameters

ignoreError
Indicates if hide the error in calculating formulas. The error may be unsupported function, external links, etc.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.CalculateFormula Overload List


Workbook.CalculateFormula Method (Boolean, ICustomFunction)

NOTE: This method is now obsolete.

Use CalculateFormula(CalculationOptions) method instead.

Calculates the result of formulas.

public void CalculateFormula(
bool ignoreError,
ICustomFunction customFunction
);

Parameters

ignoreError
Indicates if hide the error in calculating formulas. The error may be unsupported function, external links, etc.
customFunction
The custom formula calculation functions to extend the calculation engine.

Remarks

NOTE: This member is now obsolete. Instead, please use CalculateFormula(CalculationOptions) method. This method will be removed 12 months later since August 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.CalculateFormula Overload List


Workbook.ChangePalette Method

Changes the palette for the spreadsheet in the specified index.

public void ChangePalette(
Color color,
int index
);

Parameters

color
Color structure.
index
Palette index, 0 - 55.

Remarks

The palette has 56 entries, each represented by an RGB value. If you set a color which is not in the palette, it will not take effect. So if you want to set a custom color, please change the palette at first.

The following is the standard color palette.

Color¡¡ | Red¡¡ | Green¡¡ | Blue¡¡
Black¡¡ | 0¡¡ | 0¡¡ | 0¡¡
White¡¡ | 255¡¡ | 255¡¡ | 255¡¡
Red¡¡ | 255¡¡ | 0¡¡ | 0¡¡
Lime¡¡ | 0¡¡ | 255¡¡ | 0¡¡
Blue¡¡ | 0¡¡ | 0¡¡ | 255¡¡
Yellow¡¡ | 255¡¡ | 255¡¡ | 0¡¡
Magenta¡¡ | 255¡¡ | 0¡¡ | 255¡¡
Cyan¡¡ | 0¡¡ | 255¡¡ | 255¡¡
Maroon¡¡ | 128¡¡ | 0¡¡ | 0¡¡
Green¡¡ | 0¡¡ | 128¡¡ | 0¡¡
Navy¡¡ | 0¡¡ | 0¡¡ | 128¡¡
Olive¡¡ | 128¡¡ | 128¡¡ | 0¡¡
Purple¡¡ | 128¡¡ | 0¡¡ | 128¡¡
Teal¡¡ | 0¡¡ | 128¡¡ | 128¡¡
Silver¡¡ | 192¡¡ | 192¡¡ | 192¡¡
Gray¡¡ | 128¡¡ | 128¡¡ | 128¡¡
Color17¡¡ | 153¡¡ | 153¡¡ | 255¡¡
Color18¡¡ | 153¡¡ | 51¡¡ | 102¡¡
Color19¡¡ | 255¡¡ | 255¡¡ | 204¡¡
Color20¡¡ | 204¡¡ | 255¡¡ | 255¡¡
Color21¡¡ | 102¡¡ | 0¡¡ | 102¡¡
Color22¡¡ | 255¡¡ | 128¡¡ | 128¡¡
Color23¡¡ | 0¡¡ | 102¡¡ | 204¡¡
Color24¡¡ | 204¡¡ | 204¡¡ | 255¡¡
Color25¡¡ | 0¡¡ | 0¡¡ | 128¡¡
Color26¡¡ | 255¡¡ | 0¡¡ | 255¡¡
Color27¡¡ | 255¡¡ | 255¡¡ | 0¡¡
Color28¡¡ | 0¡¡ | 255¡¡ | 255¡¡
Color29¡¡ | 128¡¡ | 0¡¡ | 128¡¡
Color30¡¡ | 128¡¡ | 0¡¡ | 0¡¡
Color31¡¡ | 0¡¡ | 128¡¡ | 128¡¡
Color32¡¡ | 0¡¡ | 0¡¡ | 255¡¡
Color33¡¡ | 0¡¡ | 204¡¡ | 255¡¡
Color34¡¡ | 204¡¡ | 255¡¡ | 255¡¡
Color35¡¡ | 204¡¡ | 255¡¡ | 204¡¡
Color36¡¡ | 255¡¡ | 255¡¡ | 153¡¡
Color37¡¡ | 153¡¡ | 204¡¡ | 255¡¡
Color38¡¡ | 255¡¡ | 153¡¡ | 204¡¡
Color39¡¡ | 204¡¡ | 153¡¡ | 255¡¡
Color40¡¡ | 255¡¡ | 204¡¡ | 153¡¡
Color41¡¡ | 51¡¡ | 102¡¡ | 255¡¡
Color42¡¡ | 51¡¡ | 204¡¡ | 204¡¡
Color43¡¡ | 153¡¡ | 204¡¡ | 0¡¡
Color44¡¡ | 255¡¡ | 204¡¡ | 0¡¡
Color45¡¡ | 255¡¡ | 153¡¡ | 0¡¡
Color46¡¡ | 255¡¡ | 102¡¡ | 0¡¡
Color47¡¡ | 102¡¡ | 102¡¡ | 153¡¡
Color48¡¡ | 150¡¡ | 150¡¡ | 150¡¡
Color49¡¡ | 0¡¡ | 51¡¡ | 102¡¡
Color50¡¡ | 51¡¡ | 153¡¡ | 102¡¡
Color51¡¡ | 0¡¡ | 51¡¡ | 0¡¡
Color52¡¡ | 51¡¡ | 51¡¡ | 0¡¡
Color53¡¡ | 153¡¡ | 51¡¡ | 0¡¡
Color54¡¡ | 153¡¡ | 51¡¡ | 102¡¡
Color55¡¡ | 51¡¡ | 51¡¡ | 153¡¡
Color56¡¡ | 51¡¡ | 51¡¡ | 51¡¡

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Combine Method

Combines another Workbook object.

public void Combine(
Workbook secondWorkbook
);

Parameters

secondWorkbook
Another Workbook object.

Remarks

Currently, only cell data and cell style of the second Workbook object can be combined. Images, charts and other drawing objects are not supported.

See Also

Workbook Class | Aspose.Cells Namespace


Copy Method

Aspose.Cells for .NET

Workbook.Copy Method

Copies data from a source Workbook object.

Overload List

Copies data from a source Workbook object.

public void Copy(Workbook);

Copies data from a source Workbook object.

public void Copy(Workbook,CopyOptions);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Copy Method (Workbook)

Copies data from a source Workbook object.

public void Copy(
Workbook source
);

Parameters

source
Source Workbook object.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Copy Overload List


Workbook.Copy Method (Workbook, CopyOptions)

Copies data from a source Workbook object.

public void Copy(
Workbook source,
CopyOptions copyOptions
);

Parameters

source
Source Workbook object.
copyOptions

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Copy Overload List


Workbook.CopyTheme Method

Copies the theme from another workbook.

public void CopyTheme(
Workbook source
);

Parameters

source
Source workbook.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.CreateBuiltinStyle Method

Creates built-in style by given type.

public Style CreateBuiltinStyle(
BuiltinStyleType type
);

Parameters

type

Return Value

style object

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.CreateCellsColor Method

Creates a CellsColor object.

public CellsColor CreateCellsColor();

Return Value

Returns a CellsColor object.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.CreateStyle Method

Creates a new style.

public Style CreateStyle();

Return Value

Returns a style object.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.CustomTheme Method

Customs the theme.

public void CustomTheme(
string themeName,
Color[] colors
);

Parameters

themeName
The theme name
colors
The theme colors

Remarks

The length of colors should be 12.
Array index¡¡ | Theme type¡¡
0¡¡ | Backgournd1¡¡
1¡¡ | Text1¡¡
2¡¡ | Backgournd2¡¡
3¡¡ | Text2¡¡
4¡¡ | Accent1¡¡
5¡¡ | Accent2¡¡
6¡¡ | Accent3¡¡
7¡¡ | Accent4¡¡
8¡¡ | Accent5¡¡
9¡¡ | Accent6¡¡
10¡¡ | Hyperlink¡¡
11¡¡ | Followed Hyperlink¡¡

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

Workbook Class | Aspose.Cells Namespace


ExportXml Method

Aspose.Cells for .NET

Workbook.ExportXml Method

Export XML data.

Overload List

Export XML data.

public void ExportXml(string,Stream);

Export XML data.

public void ExportXml(string,string);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.ExportXml Method (String, Stream)

Export XML data.

public void ExportXml(
string mapName,
Stream stream
);

Parameters

mapName
name of the XML map that need to be exported
stream
the export stream

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.ExportXml Overload List


Workbook.ExportXml Method (String, String)

Export XML data.

public void ExportXml(
string mapName,
string path
);

Parameters

mapName
name of the XML map that need to be exported
path
the export path

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.ExportXml Overload List


Workbook.GetDigitalSignature Method

Gets digital signature from file.

public DigitalSignatureCollection GetDigitalSignature();

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.GetFonts Method

Gets all fonts in the style pool.

public Font[] GetFonts();

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.GetMatchingColor Method

Find best matching Color in current palette.

public Color GetMatchingColor(
Color rawColor
);

Parameters

rawColor
Raw color.

Return Value

Best matching color.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.GetNamedStyle Method

Gets the named style in the style pool.

public Style GetNamedStyle(
string name
);

Parameters

name
name of the style

Return Value

named style, maybe null.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.GetStyleInPool Method

Gets the style in the style pool. All styles in the workbook will be gathered into a pool. There is only a simple reference index in the cells.

public Style GetStyleInPool(
int index
);

Parameters

index
The index.

Return Value

The style in the pool corresponds to given index, may be null.

Remarks

If the returned style is changed, the style of all cells(which refers to this style) will be changed.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.GetThemeColor Method

Gets theme color.

public Color GetThemeColor(
ThemeColorType type
);

Parameters

type
The theme color type.

Return Value

The theme color.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.HasExernalLinks Method

Indicates whether this workbook contains external links to other data sources.

public bool HasExernalLinks();

Return Value

Whether this workbook contains external links to other data sources.

See Also

Workbook Class | Aspose.Cells Namespace


ImportXml Method

Aspose.Cells for .NET

Workbook.ImportXml Method

Imports an xml file into the workbook.

Overload List

Imports an xml file into the workbook.

public void ImportXml(Stream,string,int,int);

Imports an xml file into the workbook.

public void ImportXml(string,string,int,int);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.ImportXml Method (Stream, String, Int32, Int32)

Imports an xml file into the workbook.

public void ImportXml(
Stream stream,
string sheetName,
int row,
int col
);

Parameters

stream
the xml file stream.
sheetName
the destination sheet name .
row
the destination row of the xml.
col
the destination column of the xml.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.ImportXml Overload List


Workbook.ImportXml Method (String, String, Int32, Int32)

Imports an xml file into the workbook.

public void ImportXml(
string url,
string sheetName,
int row,
int col
);

Parameters

url
the path of the xml file.
sheetName
the destination sheet name .
row
the destination row of the xml.
col
the destination column of the xml.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.ImportXml Overload List


Workbook.IsColorInPalette Method

Checks if a color is in the palette for the spreadsheet.

public bool IsColorInPalette(
Color color
);

Parameters

color
Color structure.

Return Value

Returns true if this color is in the palette. Otherwise, returns false

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.ParseFormulas Method

Parses all formulas which have not been parsed when they were loaded from template file or set to a cell.

public void ParseFormulas(
bool ignoreError
);

Parameters

ignoreError
whether ignore error for invalid formula. For one invalid formula, if ignore error then this formula will be ignored and the process will continue to parse other formulas, otherwise exception will be thrown.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Protect Method

Protects a workbook.

public void Protect(
ProtectionType protectionType,
string password
);

Parameters

protectionType
Protection type.
password
Password to protect the workbook.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.ProtectSharedWorkbook Method

Protects a shared workbook.

public void ProtectSharedWorkbook(
string password
);

Parameters

password
Password to protect the workbook.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.RemoveDigitalSignature Method

Removes digital signature from this spreadsheet.

public void RemoveDigitalSignature();

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.RemoveExternalLinks Method

Removes all external links in the workbook.

public void RemoveExternalLinks();

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.RemoveMacro Method

Removes VBA/macro from this spreadsheet.

public void RemoveMacro();

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.RemoveUnusedStyles Method

Remove all unused styles.

public void RemoveUnusedStyles();

See Also

Workbook Class | Aspose.Cells Namespace


Replace Method

Aspose.Cells for .NET

Workbook.Replace Method

Replaces cells' values with new data.

Overload List

Replaces cells' values with new data.

public int Replace(bool,object);

Replaces cells' values with new data.

public int Replace(int,object);

Replaces cells' values with data from a DataTable.

public int Replace(string,DataTable);

Replaces a cell's value with a new double.

public int Replace(string,double);

Replaces cells' values with a double array.

public int Replace(string,double[],bool);

Replaces a cell's value with a new integer.

public int Replace(string,int);

Replaces cells' values with an integer array.

public int Replace(string,int[],bool);

Replaces a cell's value with a new string.

public int Replace(string,string);

Replaces a cell's value with a new string.

public int Replace(string,string,ReplaceOptions);

Replaces a cell's value with a new string array.

public int Replace(string,string[],bool);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Replace Method (Boolean, Object)

Replaces cells' values with new data.

public int Replace(
bool boolValue,
object newValue
);

Parameters

boolValue
The boolean value to be replaced.
newValue
New value. Can be string, integer, double or DateTime value.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (Int32, Object)

Replaces cells' values with new data.

public int Replace(
int intValue,
object newValue
);

Parameters

intValue
The integer value to be replaced.
newValue
New value. Can be string, integer, double or DateTime value.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, DataTable)

Replaces cells' values with data from a DataTable.

public int Replace(
string placeHolder,
DataTable insertTable
);

Parameters

placeHolder
Cell placeholder
insertTable
DataTable to replace

Example

[C#]

 Workbook workbook = new Workbook();
 DataTable myDataTable = new DataTable("Customers");
 // Adds data to myDataTable
 ........
 workbook.Replace("AnOldValue", myDataTable);

 [Visual Basic]

 Dim workbook As Workbook =  New Workbook()
 Dim myDataTable As DataTable =  New DataTable("Customers")
 ' Adds data to myDataTable
.............
 workbook.Replace("AnOldValue", myDataTable)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, Double)

Replaces a cell's value with a new double.

public int Replace(
string placeHolder,
double newValue
);

Parameters

placeHolder
Cell placeholder
newValue
Double value to replace

Example

[C#]

 Workbook workbook = new Workbook();
 ......
 double newValue = 100.0;
 workbook.Replace("AnOldValue", newValue);

 [Visual Basic]

 Dim workbook As Workbook =  New Workbook()
.........
Dim NewValue As Double =  100.0
workbook.Replace("AnOldValue", NewValue)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, Double[], Boolean)

Replaces cells' values with a double array.

public int Replace(
string placeHolder,
double[] newValues,
bool isVertical
);

Parameters

placeHolder
Cell placeholder
newValues
Double array to replace
isVertical
True - Vertical, False - Horizontal

Example

[C#]

Workbook workbook = new Workbook();
......
double[] newValues = new double[]{1.23, 2.56, 3.14159};
workbook.Replace("AnOldValue", newValues, true);

[Visual Basic]

Dim workbook As Workbook =  New Workbook()
...........
Dim NewValues() As Double =  New Double() {1.23, 2.56, 3.14159}
workbook.Replace("AnOldValue", NewValues, True)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, Int32)

Replaces a cell's value with a new integer.

public int Replace(
string placeHolder,
int newValue
);

Parameters

placeHolder
Cell placeholder
newValue
Integer value to replace

Example

[C#]

 Workbook workbook = new Workbook();
 ......
 int newValue = 100;
 workbook.Replace("AnOldValue", newValue);

 [Visual Basic]

 Dim workbook As Workbook =  New Workbook()
.........
Dim NewValue As Integer =  100
workbook.Replace("AnOldValue", NewValue)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, Int32[], Boolean)

Replaces cells' values with an integer array.

public int Replace(
string placeHolder,
int[] newValues,
bool isVertical
);

Parameters

placeHolder
Cell placeholder
newValues
Integer array to replace
isVertical
True - Vertical, False - Horizontal

Example

[C#]

 Workbook workbook = new Workbook();
 ......
 int[] newValues = new int[]{1, 2, 3};
 workbook.Replace("AnOldValue", newValues, true);

 [Visual Basic]

 Dim workbook As Workbook =  New Workbook()
...........
Dim NewValues() As Integer =  New Integer() {1, 2, 3}
workbook.Replace("AnOldValue", NewValues, True)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, String)

Replaces a cell's value with a new string.

public int Replace(
string placeHolder,
string newValue
);

Parameters

placeHolder
Cell placeholder
newValue
String value to replace

Example

[C#]

 Workbook workbook = new Workbook();
 ......
 workbook.Replace("AnOldValue", "NewValue");

 [Visual Basic]

 Dim workbook As Workbook =  New Workbook()
  ........
workbook.Replace("AnOldValue", "NewValue")

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, String, ReplaceOptions)

Replaces a cell's value with a new string.

public int Replace(
string placeHolder,
string newValue,
ReplaceOptions options
);

Parameters

placeHolder
Cell placeholder
newValue
String value to replace
options
The replace options

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Workbook.Replace Method (String, String[], Boolean)

Replaces a cell's value with a new string array.

public int Replace(
string placeHolder,
string[] newValues,
bool isVertical
);

Parameters

placeHolder
Cell placeholder
newValues
String array to replace
isVertical
True - Vertical, False - Horizontal

Example

[C#]

 Workbook workbook = new Workbook();
 ......
 string[] newValues = new string[]{"Tom", "Alice", "Jerry"};
 workbook.Replace("AnOldValue", newValues, true);

 [Visual Basic]

 Dim workbook As Workbook =  New Workbook()
 .............
Dim NewValues() As String =  New String() {"Tom", "Alice", "Jerry"}
workbook.Replace("AnOldValue", NewValues, True)

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Replace Overload List


Save Method

Aspose.Cells for .NET

Workbook.Save Method

Saves the workbook to the stream.

Overload List

Saves the workbook to the stream.

public void Save(Stream,SaveFormat);

Saves the workbook to the stream.

public void Save(Stream,SaveOptions);

Save the workbook to the disk.

public void Save(string);

Saves the workbook to the disk.

public void Save(string,SaveFormat);

Saves the workbook to the disk.

public void Save(string,SaveOptions);

Creates the result spreadsheet and transfer it to the client then open it in the browser or MS Workbook.

public void Save(HttpResponse,string,ContentDisposition,SaveOptions);

Creates the result spreadsheet and transfer it to the client then open it in the browser or MS Workbook.

public void Save(HttpResponse,string,ContentDisposition,SaveOptions,bool);

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Save Method (Stream, SaveFormat)

Saves the workbook to the stream.

public void Save(
Stream stream,
SaveFormat saveFormat
);

Parameters

stream
The file stream.
saveFormat
The save file format type.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.Save Method (Stream, SaveOptions)

Saves the workbook to the stream.

public void Save(
Stream stream,
SaveOptions saveOptions
);

Parameters

stream
The file stream.
saveOptions
The save options.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.Save Method (String)

Save the workbook to the disk.

public void Save(
string fileName
);

Parameters

fileName

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.Save Method (String, SaveFormat)

Saves the workbook to the disk.

public void Save(
string fileName,
SaveFormat saveFormat
);

Parameters

fileName
The file name.
saveFormat
The save format type.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.Save Method (String, SaveOptions)

Saves the workbook to the disk.

public void Save(
string fileName,
SaveOptions saveOptions
);

Parameters

fileName
The file name.
saveOptions
The save options.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.Save Method (HttpResponse, String, ContentDisposition, SaveOptions)

Creates the result spreadsheet and transfer it to the client then open it in the browser or MS Workbook.

public void Save(
HttpResponse response,
string fileName,
ContentDisposition contentDisposition,
SaveOptions saveOptions
);

Parameters

response
Response object to return the spreadsheet to client.
fileName
The name of created file.
contentDisposition
The content disposition type.
saveOptions
The save options.

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.Save Method (HttpResponse, String, ContentDisposition, SaveOptions, Boolean)

Creates the result spreadsheet and transfer it to the client then open it in the browser or MS Workbook.

public void Save(
HttpResponse response,
string fileName,
ContentDisposition contentDisposition,
SaveOptions saveOptions,
bool enableHttpCompression
);

Parameters

response
Response object to return the spreadsheet to client.
fileName
The name of created file.
contentDisposition
The content disposition type.
saveOptions
The save options.
enableHttpCompression
whether http compression is to be used

See Also

Workbook Class | Aspose.Cells Namespace | Workbook.Save Overload List


Workbook.SaveToStream Method

Saves Excel file to a MemoryStream object and returns it.

public MemoryStream SaveToStream();

Return Value

MemoryStream object which contains an Excel file.

Remarks

This method provides same function as Save method and only save the workbook as Excel97-2003 xls file. It's mainly for calling from COM clients.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.SetDigitalSignature Method

Sets digital signature to an spreadsheet file (Excel2007 and later).

public void SetDigitalSignature(
DigitalSignatureCollection digitalSignatureCollection
);

Parameters

digitalSignatureCollection

Remarks

Only support adding Xmldsig Digital Signature

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.SetEncryptionOptions Method

Set Encryption Options.

public void SetEncryptionOptions(
EncryptionType encryptionType,
int keyLength
);

Parameters

encryptionType
The encryption type.
keyLength
The key length.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.SetThemeColor Method

Sets the theme color

public void SetThemeColor(
ThemeColorType type,
Color color
);

Parameters

type
The theme color type.
color
the theme color

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.Unprotect Method

Unprotects a workbook.

public void Unprotect(
string password
);

Parameters

password
Password to unprotect the workbook.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.UnprotectSharedWorkbook Method

Unprotects a shared workbook.

public void UnprotectSharedWorkbook(
string password
);

Parameters

password
Password to unprotect the workbook.

See Also

Workbook Class | Aspose.Cells Namespace


Workbook.UpdateLinkedDataSource Method

If this workbook contains external links to other data source, Aspose.Cells will attempt to retrieve the latest data.

public void UpdateLinkedDataSource(
Workbook[] exteralWorkbooks
);

Parameters

exteralWorkbooks
External workbooks are referenced by this workbook. If it's null, we will directly open the external linked files.. If it's not null, we will check whether the external link in the array first; if not, we will open the external linked files again.

Remarks

If the method is not called before calculating formulas, Aspose.Cells will use the previous information(cached in the file); Please set CellsHelper.StartupPath,CellsHelper.AltStartPath,CellsHelper.LibraryPath. And please set Workbook.FilePath if this workbook is from a stream, otherwise Aspose.Cells could not get the external link full path sometimes.

See Also

Workbook Class | Aspose.Cells Namespace


WorkbookDesigner Class

Encapsulates the object that represents a designer spreadsheet.

For a list of all members of this type, see WorkbookDesigner Members.

System.Object
Aspose.Cells.WorkbookDesigner

public class WorkbookDesigner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Create a connection object, specify the provider info and set the data source.
OleDbConnection con = new OleDbConnection("provider=microsoft.jet.oledb.4.0;data source=d:\\test\\Northwind.mdb");
//Open the connection object.
con.Open();
//Create a command object and specify the SQL query.
OleDbCommand cmd = new OleDbCommand("Select * from [Order Details]", con);
//Create a data adapter object.
OleDbDataAdapter da = new OleDbDataAdapter();
//Specify the command.
da.SelectCommand = cmd;
//Create a dataset object.
DataSet ds = new DataSet();
//Fill the dataset with the table records.
da.Fill(ds, "Order Details");
//Create a datatable with respect to dataset table.
DataTable dt = ds.Tables["Order Details"];
//Create WorkbookDesigner object.
WorkbookDesigner wd = new WorkbookDesigner();
//Open the template file (which contains smart markers).
wd.Open("D:\\test\\SmartMarker_Designer.xls");
//Set the datatable as the data source.
wd.SetDataSource(dt);
//Process the smart markers to fill the data into the worksheets.
wd.Process(true);
//Save the excel file.
wd.Workbook.Save("D:\\test\\outSmartMarker_Designer.xls");

[Visual Basic]

'Create a connection object, specify the provider info and set the data source.
Dim con As OleDbConnection = New OleDbConnection("provider=microsoft.jet.oledb.4.0;data source=d:\test\Northwind.mdb")
'Open the connection object.
con.Open()
'Create a command object and specify the SQL query.
Dim cmd As OleDbCommand = New OleDbCommand("Select * from [Order Details]", con)
'Create a data adapter object.
Dim da As OleDbDataAdapter = New OleDbDataAdapter()
'Specify the command.
da.SelectCommand = cmd
'Create a dataset object.
Dim ds As DataSet = New DataSet()
'Fill the dataset with the table records.
da.Fill(ds, "Order Details")
'Create a datatable with respect to dataset table.
Dim dt As DataTable = ds.Tables("Order Details")
'Create WorkbookDesigner object.
Dim wd As WorkbookDesigner = New WorkbookDesigner()
'Open the template file (which contains smart markers).
wd.Open("D:\test\SmartMarker_Designer.xls")
'Set the datatable as the data source.
wd.SetDataSource(dt)
'Process the smart markers to fill the data into the worksheets.
wd.Process(True)
'Save the excel file.
wd.Workbook.Save("D:\test\outSmartMarker_Designer.xls")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WorkbookDesigner Members | Aspose.Cells Namespace


WorkbookDesigner Members

WorkbookDesigner overview

Public Instance Constructors

WorkbookDesigner Overloaded. Initializes a new instance of the WorkbookDesigner class.

Public Instance Properties

CalculateFormula | Indicates whether formulas should be calculated.
CallBack | Gets and sets callback interface of processing smartmarker.
RepeatFormulasWithSubtotal | Indicates whether repeating formulas with subtotal row.
UpdateEmptyStringAsNull | If TRUE, Null will be inserted if the value is "";
UpdateReference | Indicates if references in other worksheets will be updated.
Workbook | Gets and sets the Workbook object.

Public Instance Methods

ClearDataSource | Clears all data sources.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetSmartMarkers | Returns a collection of smart markers in a spreadsheet.
GetType (inherited from Object) |
Process | Overloaded. Processes the smart markers and populates the data source values.
SetDataSource | Overloaded. Sets data source of a DataSet object.
ToString (inherited from Object) |

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner Constructor

Initializes a new instance of the WorkbookDesigner class.

Overload List

Initializes a new instance of the WorkbookDesigner class.

public WorkbookDesigner();

Initializes a new instance of the WorkbookDesigner class.

public WorkbookDesigner(Workbook);

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner Constructor ()

Initializes a new instance of the WorkbookDesigner class.

public WorkbookDesigner();

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner Constructor Overload List


WorkbookDesigner Constructor (Workbook)

Initializes a new instance of the WorkbookDesigner class.

public WorkbookDesigner(
Workbook workbook
);

Parameters

workbook
The template workbook file.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner Constructor Overload List


WorkbookDesigner Properties

The properties of the WorkbookDesigner class are listed below. For a complete list of WorkbookDesigner class members, see the WorkbookDesigner Members topic.

Public Instance Properties

CalculateFormula | Indicates whether formulas should be calculated.
CallBack | Gets and sets callback interface of processing smartmarker.
RepeatFormulasWithSubtotal | Indicates whether repeating formulas with subtotal row.
UpdateEmptyStringAsNull | If TRUE, Null will be inserted if the value is "";
UpdateReference | Indicates if references in other worksheets will be updated.
Workbook | Gets and sets the Workbook object.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


CalculateFormula Property

Aspose.Cells for .NET

WorkbookDesigner.CalculateFormula Property

Indicates whether formulas should be calculated.

public bool CalculateFormula {get; set;}

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


CallBack Property

Aspose.Cells for .NET

WorkbookDesigner.CallBack Property

Gets and sets callback interface of processing smartmarker.

public ISmartMarkerCallBack CallBack {get; set;}

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


RepeatFormulasWithSubtotal Property

Aspose.Cells for .NET

WorkbookDesigner.RepeatFormulasWithSubtotal Property

Indicates whether repeating formulas with subtotal row.

public bool RepeatFormulasWithSubtotal {get; set;}

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


UpdateEmptyStringAsNull Property

Aspose.Cells for .NET

WorkbookDesigner.UpdateEmptyStringAsNull Property

If TRUE, Null will be inserted if the value is "";

public bool UpdateEmptyStringAsNull {get; set;}

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


UpdateReference Property

Aspose.Cells for .NET

WorkbookDesigner.UpdateReference Property

Indicates if references in other worksheets will be updated.

public bool UpdateReference {get; set;}

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


Workbook Property

Aspose.Cells for .NET

WorkbookDesigner.Workbook Property

Gets and sets the Workbook object.

public Workbook Workbook {get; set;}

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner Methods

The methods of the WorkbookDesigner class are listed below. For a complete list of WorkbookDesigner class members, see the WorkbookDesigner Members topic.

Public Instance Methods

ClearDataSource | Clears all data sources.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetSmartMarkers | Returns a collection of smart markers in a spreadsheet.
GetType (inherited from Object) |
Process | Overloaded. Processes the smart markers and populates the data source values.
SetDataSource | Overloaded. Sets data source of a DataSet object.
ToString (inherited from Object) |

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner.ClearDataSource Method

Clears all data sources.

public void ClearDataSource();

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner.GetSmartMarkers Method

Returns a collection of smart markers in a spreadsheet.

public string[] GetSmartMarkers();

Return Value

A collection of smart markers

Remarks

A string array is created on every call. The array is sorted and duplicated values are removed.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


Process Method

Aspose.Cells for .NET

WorkbookDesigner.Process Method

Processes the smart markers and populates the data source values.

Overload List

Processes the smart markers and populates the data source values.

public void Process();

Processes the smart markers and populates the data source values.

public void Process(bool);

Processes the smart markers and populates the data source values.

public void Process(int,bool);

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner.Process Method ()

Processes the smart markers and populates the data source values.

public void Process();

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.Process Overload List


WorkbookDesigner.Process Method (Boolean)

Processes the smart markers and populates the data source values.

public void Process(
bool isPreserved
);

Parameters

isPreserved
True if the unrecognized smart marker is preserved.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.Process Overload List


WorkbookDesigner.Process Method (Int32, Boolean)

Processes the smart markers and populates the data source values.

public void Process(
int sheetIndex,
bool isPreserved
);

Parameters

sheetIndex
Worksheet index.
isPreserved
True if the unrecognized smart marker is preserved.

Remarks

This method works on worksheet level.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.Process Overload List


SetDataSource Method

Aspose.Cells for .NET

WorkbookDesigner.SetDataSource Method

Sets data source of a DataSet object.

Overload List

Sets data source of a DataSet object.

public void SetDataSource(DataSet);

Sets data source of a DataTable object.

public void SetDataSource(DataTable);

Sets data source of a DataView object.

public void SetDataSource(DataView);

Sets data source of a OleDbConnection object.

public void SetDataSource(OleDbConnection);

Sets data source of a SqlConnection object.

public void SetDataSource(SqlConnection);

Sets data source of a ICellsDataTable object.

public void SetDataSource(string,ICellsDataTable);

Sets data source of a DataView object and binds it to a data source name.

public void SetDataSource(string,DataView);

Sets data source of a IDataReader object.

public void SetDataSource(string,IDataReader,int);

Sets data binding to a variable.

public void SetDataSource(string,object);

Sets data array binding to a variable.

public void SetDataSource(string,object[]);

See Also

WorkbookDesigner Class | Aspose.Cells Namespace


WorkbookDesigner.SetDataSource Method (DataSet)

Sets data source of a DataSet object.

public void SetDataSource(
DataSet dataSet
);

Parameters

dataSet
DataSet object

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (DataTable)

Sets data source of a DataTable object.

public void SetDataSource(
DataTable dataTable
);

Parameters

dataTable
DataTable object

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (DataView)

Sets data source of a DataView object.

public void SetDataSource(
DataView dataView
);

Parameters

dataView
DataView object

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (OleDbConnection)

Sets data source of a OleDbConnection object.

public void SetDataSource(
OleDbConnection connection
);

Parameters

connection
OleDbConnection object

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (SqlConnection)

Sets data source of a SqlConnection object.

public void SetDataSource(
SqlConnection connection
);

Parameters

connection
SqlConnection object

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (String, ICellsDataTable)

Sets data source of a ICellsDataTable object.

public void SetDataSource(
string name,
ICellsDataTable dataTable
);

Parameters

name
The name of the table.
dataTable
DataTable object

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (String, DataView)

Sets data source of a DataView object and binds it to a data source name.

public void SetDataSource(
string dataSourceName,
DataView dataView
);

Parameters

dataSourceName
Data source name.
dataView
DataView object.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (String, IDataReader, Int32)

Sets data source of a IDataReader object.

public void SetDataSource(
string name,
IDataReader dataReader,
int rowCount
);

Parameters

name
The data source map name.
dataReader
IDataReader object
rowCount
The number of the data rows. If the smart marker does not contains "noadd", we have to insert rows by the row count for performance issue and dynamic repeated formulas. -1 means the param is useless.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (String, Object)

Sets data binding to a variable.

public void SetDataSource(
string variable,
object data
);

Parameters

variable
Variable name created using smart marker.
data
Source data.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookDesigner.SetDataSource Method (String, Object[])

Sets data array binding to a variable.

public void SetDataSource(
string variable,
object[] dataArray
);

Parameters

variable
Variable name created using smart marker.
dataArray
Source data array.

See Also

WorkbookDesigner Class | Aspose.Cells Namespace | WorkbookDesigner.SetDataSource Overload List


WorkbookSettings Class

Represents all settings of the workbook.

For a list of all members of this type, see WorkbookSettings Members.

System.Object
Aspose.Cells.WorkbookSettings

public class WorkbookSettings : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WorkbookSettings Members | Aspose.Cells Namespace


WorkbookSettings Members

WorkbookSettings overview

Public Instance Properties

AutoCompressPictures | Specifies a boolean value that indicates the application automatically compressed pictures in the workbook.
AutoRecover | Indicates whether the file is mark for auto-recovery.
BuildVersion | Specifies the incremental public release of the application.
CalcMode | It specifies whether to calculate formulas manually, automatically or automatically except for multiple table operations.
CalcStackSize | Specifies the stack size for calculating cells recursively. The large value for this size will give better performance when there are lots of cells need to be calculated recursively. On the other hand, larger value will raise the risk of StackOverflowException. If user gets StackOverflowException when calculating formulas, this value should be decreased.
CalculationId | Specifies the version of the calculation engine used to calculate values in the workbook.
CheckCompatibility | Indicates whether check compatibility when saving workbook.
CheckCustomNumberFormat | Indicates whether checking custom number format when setting Style.Custom.
CheckExcelRestriction | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
Compliance | Specifies the OOXML version for the output document. The default value is Ecma376_2006.
CrashSave | indicates whether the application last saved the workbook file after a crash.
CreateCalcChain | Indicates whether create calculated formulas chain. Default is false.
CultureInfo | Gets or sets the system culture info.
DataExtractLoad | indicates whether the application last opened the workbook for data recovery.
Date1904 | Gets or sets a value which represents if the workbook uses the 1904 date system.
DisplayDrawingObjects | Indicates whether and how to show objects in the workbook.
EnableMacros | Enable macros;
FirstVisibleTab | Gets or sets the first visible worksheet tab.
GlobalizationSettings | Gets and sets the globalization settings.
HidePivotFieldList | Gets and sets whether hide the field list for the PivotTable.
IsDefaultEncrypted | Indicates whether encrypting the workbook with default password if Structure and Windows of the workbook are locked.
IsEncrypted | Gets a value that indicates whether a password is required to open this workbook.
IsHidden | Indicates whether this workbook is hidden.
IsHScrollBarVisible | Gets or sets a value indicating whether the generated spreadsheet will contain a horizontal scroll bar.
IsMinimized | Represents whether the generated spreadsheet will be opened Minimized.
IsProtected | Gets a value that indicates whether the structure or window of the Workbook is protected.
IsVScrollBarVisible | Gets or sets a value indicating whether the generated spreadsheet will contain a vertical scroll bar.
IsWriteProtected | Obsolete. Indicates whether this workbook is write protected.
Iteration | Indicates if Aspose.Cells will use iteration to resolve circular references.
LanguageCode | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
MaxChange | Returns or sets the maximum number of change that Microsoft Excel can use to resolve a circular reference.
MaxColumn | Gets the max column index, zero-based.
MaxIteration | Returns or sets the maximum number of iterations that Aspose.Cells can use to resolve a circular reference.
MaxRow | Gets the max row index, zero-based.
MaxRowsOfSharedFormula | Gets and sets the max row number of shared formula.
MemorySetting | Gets or sets the memory usage options. The new option will be taken as the default option for newly created worksheets but does not take effect for existing worksheets.
NumberDecimalSeparator | Gets or sets the decimal separator for formatting/parsing numeric values. Default is the decimal separator of current Region.
NumberGroupSeparator | Gets or sets the character that separates groups of digits to the left of the decimal in numeric values. Default is the group separator of current Region.
PaperSize | Gets and sets the default print paper size.
ParsingFormulaOnOpen | Obsolete. Indicates whether parsing the formula when reading the file.
Password | Represents Workbook file encryption password.
PrecisionAsDisplayed | True if calculations in this workbook will be done using only the precision of the numbers as they're displayed
ProtectionType | Gets the protection type of the workbook.
QuotePrefixToStyle | Indicates whether setting QuotePrefix property when entering the string value(which starts with single quote mark ) to the cell
RecalculateBeforeSave | Indicates whether to recalculate before saving the document.
ReCalculateOnOpen | Indicates whether re-calculate all formulas on opening file.
RecommendReadOnly | Obsolete. Indicates if the Read Only Recommended option is selected.
Region | Gets or sets the regional settings for workbook.
RemovePersonalInformation | True if personal information can be removed from the specified workbook.
RepairLoad | Indicates whether the application last opened the workbook in safe or repair mode.
Shared | Gets or sets a value that indicates whether the Workbook is shared.
SheetTabBarWidth | Width of worksheet tab bar (in 1/1000 of window width).
ShowTabs | Get or sets a value whether the Workbook tabs are displayed.
SignificantDigits | Gets and sets the number of significant digits. The default value is SignificantDigits.
StreamProvider | Gets and sets the stream provider for external resource.
UpdateAdjacentCellsBorder | Indicates whether update adjacent cells' border.
UpdateLinksType | Gets and sets how updates external links when the workbook is opened.
WarningCallback | Gets or sets warning callback.
WindowHeight | The height of the window, in unit of point.
WindowHeightCM | The height of the window, in unit of centimeter.
WindowHeightInch | The height of the window, in unit of inch.
WindowLeft | The distance from the left edge of the client area to the left edge of the window, in unit of point.
WindowLeftCM | The distance from the left edge of the client area to the left edge of the window. In unit of centimeter.
WindowLeftInch | The distance from the left edge of the client area to the left edge of the window. In unit of inch.
WindowTop | The distance from the top edge of the client area to the top edge of the window, in unit of point.
WindowTopCM | The distance from the top edge of the client area to the top edge of the window, in unit of centimeter.
WindowTopInch | The distance from the top edge of the client area to the top edge of the window, in unit of inch.
WindowWidth | The width of the window, in unit of point.
WindowWidthCM | The width of the window, in unit of centimeter.
WindowWidthInch | The width of the window, in unit of inch.
WriteProtectedPassword | Obsolete. Sets the protected password to modify the file.
WriteProtection | Provides access to the workbook write protection options.

Public Instance Methods

Dispose | Releases resources.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetThemeFont | Gets the default theme font name.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WorkbookSettings Properties

The properties of the WorkbookSettings class are listed below. For a complete list of WorkbookSettings class members, see the WorkbookSettings Members topic.

Public Instance Properties

AutoCompressPictures | Specifies a boolean value that indicates the application automatically compressed pictures in the workbook.
AutoRecover | Indicates whether the file is mark for auto-recovery.
BuildVersion | Specifies the incremental public release of the application.
CalcMode | It specifies whether to calculate formulas manually, automatically or automatically except for multiple table operations.
CalcStackSize | Specifies the stack size for calculating cells recursively. The large value for this size will give better performance when there are lots of cells need to be calculated recursively. On the other hand, larger value will raise the risk of StackOverflowException. If user gets StackOverflowException when calculating formulas, this value should be decreased.
CalculationId | Specifies the version of the calculation engine used to calculate values in the workbook.
CheckCompatibility | Indicates whether check compatibility when saving workbook.
CheckCustomNumberFormat | Indicates whether checking custom number format when setting Style.Custom.
CheckExcelRestriction | Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.
Compliance | Specifies the OOXML version for the output document. The default value is Ecma376_2006.
CrashSave | indicates whether the application last saved the workbook file after a crash.
CreateCalcChain | Indicates whether create calculated formulas chain. Default is false.
CultureInfo | Gets or sets the system culture info.
DataExtractLoad | indicates whether the application last opened the workbook for data recovery.
Date1904 | Gets or sets a value which represents if the workbook uses the 1904 date system.
DisplayDrawingObjects | Indicates whether and how to show objects in the workbook.
EnableMacros | Enable macros;
FirstVisibleTab | Gets or sets the first visible worksheet tab.
GlobalizationSettings | Gets and sets the globalization settings.
HidePivotFieldList | Gets and sets whether hide the field list for the PivotTable.
IsDefaultEncrypted | Indicates whether encrypting the workbook with default password if Structure and Windows of the workbook are locked.
IsEncrypted | Gets a value that indicates whether a password is required to open this workbook.
IsHidden | Indicates whether this workbook is hidden.
IsHScrollBarVisible | Gets or sets a value indicating whether the generated spreadsheet will contain a horizontal scroll bar.
IsMinimized | Represents whether the generated spreadsheet will be opened Minimized.
IsProtected | Gets a value that indicates whether the structure or window of the Workbook is protected.
IsVScrollBarVisible | Gets or sets a value indicating whether the generated spreadsheet will contain a vertical scroll bar.
IsWriteProtected | Obsolete. Indicates whether this workbook is write protected.
Iteration | Indicates if Aspose.Cells will use iteration to resolve circular references.
LanguageCode | Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.
MaxChange | Returns or sets the maximum number of change that Microsoft Excel can use to resolve a circular reference.
MaxColumn | Gets the max column index, zero-based.
MaxIteration | Returns or sets the maximum number of iterations that Aspose.Cells can use to resolve a circular reference.
MaxRow | Gets the max row index, zero-based.
MaxRowsOfSharedFormula | Gets and sets the max row number of shared formula.
MemorySetting | Gets or sets the memory usage options. The new option will be taken as the default option for newly created worksheets but does not take effect for existing worksheets.
NumberDecimalSeparator | Gets or sets the decimal separator for formatting/parsing numeric values. Default is the decimal separator of current Region.
NumberGroupSeparator | Gets or sets the character that separates groups of digits to the left of the decimal in numeric values. Default is the group separator of current Region.
PaperSize | Gets and sets the default print paper size.
ParsingFormulaOnOpen | Obsolete. Indicates whether parsing the formula when reading the file.
Password | Represents Workbook file encryption password.
PrecisionAsDisplayed | True if calculations in this workbook will be done using only the precision of the numbers as they're displayed
ProtectionType | Gets the protection type of the workbook.
QuotePrefixToStyle | Indicates whether setting QuotePrefix property when entering the string value(which starts with single quote mark ) to the cell
RecalculateBeforeSave | Indicates whether to recalculate before saving the document.
ReCalculateOnOpen | Indicates whether re-calculate all formulas on opening file.
RecommendReadOnly | Obsolete. Indicates if the Read Only Recommended option is selected.
Region | Gets or sets the regional settings for workbook.
RemovePersonalInformation | True if personal information can be removed from the specified workbook.
RepairLoad | Indicates whether the application last opened the workbook in safe or repair mode.
Shared | Gets or sets a value that indicates whether the Workbook is shared.
SheetTabBarWidth | Width of worksheet tab bar (in 1/1000 of window width).
ShowTabs | Get or sets a value whether the Workbook tabs are displayed.
SignificantDigits | Gets and sets the number of significant digits. The default value is SignificantDigits.
StreamProvider | Gets and sets the stream provider for external resource.
UpdateAdjacentCellsBorder | Indicates whether update adjacent cells' border.
UpdateLinksType | Gets and sets how updates external links when the workbook is opened.
WarningCallback | Gets or sets warning callback.
WindowHeight | The height of the window, in unit of point.
WindowHeightCM | The height of the window, in unit of centimeter.
WindowHeightInch | The height of the window, in unit of inch.
WindowLeft | The distance from the left edge of the client area to the left edge of the window, in unit of point.
WindowLeftCM | The distance from the left edge of the client area to the left edge of the window. In unit of centimeter.
WindowLeftInch | The distance from the left edge of the client area to the left edge of the window. In unit of inch.
WindowTop | The distance from the top edge of the client area to the top edge of the window, in unit of point.
WindowTopCM | The distance from the top edge of the client area to the top edge of the window, in unit of centimeter.
WindowTopInch | The distance from the top edge of the client area to the top edge of the window, in unit of inch.
WindowWidth | The width of the window, in unit of point.
WindowWidthCM | The width of the window, in unit of centimeter.
WindowWidthInch | The width of the window, in unit of inch.
WriteProtectedPassword | Obsolete. Sets the protected password to modify the file.
WriteProtection | Provides access to the workbook write protection options.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


AutoCompressPictures Property

Aspose.Cells for .NET

WorkbookSettings.AutoCompressPictures Property

Specifies a boolean value that indicates the application automatically compressed pictures in the workbook.

public bool AutoCompressPictures {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


AutoRecover Property

Aspose.Cells for .NET

WorkbookSettings.AutoRecover Property

Indicates whether the file is mark for auto-recovery.

public bool AutoRecover {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


BuildVersion Property

Aspose.Cells for .NET

WorkbookSettings.BuildVersion Property

Specifies the incremental public release of the application.

public string BuildVersion {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CalcMode Property

Aspose.Cells for .NET

WorkbookSettings.CalcMode Property

It specifies whether to calculate formulas manually, automatically or automatically except for multiple table operations.

public CalcModeType CalcMode {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CalcStackSize Property

Aspose.Cells for .NET

WorkbookSettings.CalcStackSize Property

Specifies the stack size for calculating cells recursively. The large value for this size will give better performance when there are lots of cells need to be calculated recursively. On the other hand, larger value will raise the risk of StackOverflowException. If user gets StackOverflowException when calculating formulas, this value should be decreased.

public int CalcStackSize {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CalculationId Property

Aspose.Cells for .NET

WorkbookSettings.CalculationId Property

Specifies the version of the calculation engine used to calculate values in the workbook.

public string CalculationId {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CheckCompatibility Property

Aspose.Cells for .NET

WorkbookSettings.CheckCompatibility Property

Indicates whether check compatibility when saving workbook.

public bool CheckCompatibility {get; set;}

Remarks

The default value is true.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CheckCustomNumberFormat Property

Aspose.Cells for .NET

WorkbookSettings.CheckCustomNumberFormat Property

Indicates whether checking custom number format when setting Style.Custom.

public bool CheckCustomNumberFormat {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CheckExcelRestriction Property

Aspose.Cells for .NET

WorkbookSettings.CheckExcelRestriction Property

Whether check restriction of excel file when user modify cells related objects. For example, excel does not allow inputting string value longer than 32K. When you input a value longer than 32K such as by Cell.PutValue(string), if this property is true, you will get an Exception. If this property is false, we will accept your input string value as the cell's value so that later you can output the complete string value for other file formats such as CSV. However, if you have set such kind of value that is invalid for excel file format, you should not save the workbook as excel file format later. Otherwise there may be unexpected error for the generated excel file.

public bool CheckExcelRestriction {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Compliance Property

Aspose.Cells for .NET

WorkbookSettings.Compliance Property

Specifies the OOXML version for the output document. The default value is Ecma376_2006.

public OoxmlCompliance Compliance {get; set;}

Remarks

Only for .xlsx files.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CrashSave Property

Aspose.Cells for .NET

WorkbookSettings.CrashSave Property

indicates whether the application last saved the workbook file after a crash.

public bool CrashSave {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CreateCalcChain Property

Aspose.Cells for .NET

WorkbookSettings.CreateCalcChain Property

Indicates whether create calculated formulas chain. Default is false.

public bool CreateCalcChain {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


CultureInfo Property

Aspose.Cells for .NET

WorkbookSettings.CultureInfo Property

Gets or sets the system culture info.

public CultureInfo CultureInfo {get; set;}

Remarks

Returns null if culture info is not set and Region is not set.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


DataExtractLoad Property

Aspose.Cells for .NET

WorkbookSettings.DataExtractLoad Property

indicates whether the application last opened the workbook for data recovery.

public bool DataExtractLoad {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Date1904 Property

Aspose.Cells for .NET

WorkbookSettings.Date1904 Property

Gets or sets a value which represents if the workbook uses the 1904 date system.

public bool Date1904 {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


DisplayDrawingObjects Property

Aspose.Cells for .NET

WorkbookSettings.DisplayDrawingObjects Property

Indicates whether and how to show objects in the workbook.

public DisplayDrawingObjects DisplayDrawingObjects {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


EnableMacros Property

Aspose.Cells for .NET

WorkbookSettings.EnableMacros Property

Enable macros;

public bool EnableMacros {get; set;}

Remarks

Now it only works when copying a worksheet to other worksheet in a workbook.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


FirstVisibleTab Property

Aspose.Cells for .NET

WorkbookSettings.FirstVisibleTab Property

Gets or sets the first visible worksheet tab.

public int FirstVisibleTab {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


GlobalizationSettings Property

Aspose.Cells for .NET

WorkbookSettings.GlobalizationSettings Property

Gets and sets the globalization settings.

public GlobalizationSettings GlobalizationSettings {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


HidePivotFieldList Property

Aspose.Cells for .NET

WorkbookSettings.HidePivotFieldList Property

Gets and sets whether hide the field list for the PivotTable.

public bool HidePivotFieldList {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsDefaultEncrypted Property

Aspose.Cells for .NET

WorkbookSettings.IsDefaultEncrypted Property

Indicates whether encrypting the workbook with default password if Structure and Windows of the workbook are locked.

public bool IsDefaultEncrypted {get; set;}

Remarks

The default value is false now. It's same as MS Excel 2013.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsEncrypted Property

Aspose.Cells for .NET

WorkbookSettings.IsEncrypted Property

Gets a value that indicates whether a password is required to open this workbook.

public bool IsEncrypted {get;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsHidden Property

Aspose.Cells for .NET

WorkbookSettings.IsHidden Property

Indicates whether this workbook is hidden.

public bool IsHidden {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsHScrollBarVisible Property

Aspose.Cells for .NET

WorkbookSettings.IsHScrollBarVisible Property

Gets or sets a value indicating whether the generated spreadsheet will contain a horizontal scroll bar.

public bool IsHScrollBarVisible {get; set;}

Remarks

The default value is true.

Example

The following code makes the horizontal scroll bar invisible for the spreadsheet.

[C#]
// Hide the horizontal scroll bar of the Excel file.
workbook.IsHScrollBarVisible = false;

[Visual Basic]
' Hide the horizontal scroll bar of the Excel file.
workbook.IsHScrollBarVisible = False

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsMinimized Property

Aspose.Cells for .NET

WorkbookSettings.IsMinimized Property

Represents whether the generated spreadsheet will be opened Minimized.

public bool IsMinimized {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsProtected Property

Aspose.Cells for .NET

WorkbookSettings.IsProtected Property

Gets a value that indicates whether the structure or window of the Workbook is protected.

public bool IsProtected {get;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsVScrollBarVisible Property

Aspose.Cells for .NET

WorkbookSettings.IsVScrollBarVisible Property

Gets or sets a value indicating whether the generated spreadsheet will contain a vertical scroll bar.

public bool IsVScrollBarVisible {get; set;}

Remarks

The default value is true.

Example

The following code makes the vertical scroll bar invisible for the spreadsheet.

[C#]
    // Hide the vertical scroll bar of the Excel file.
 workbook.IsVScrollBarVisible = false;

 [Visual Basic]
 ' Hide the vertical scroll bar of the Excel file.
 workbook.IsVScrollBarVisible = False

See Also

WorkbookSettings Class | Aspose.Cells Namespace


IsWriteProtected Property

Aspose.Cells for .NET

WorkbookSettings.IsWriteProtected Property

NOTE: This property is now obsolete.

Use WorkbookSettings.WriteProtection.IsWriteProtected property instead.

Indicates whether this workbook is write protected.

public bool IsWriteProtected {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use WorkbookSettings.WriteProtection.IsWriteProtected property. This property will be removed 12 months later since October 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Iteration Property

Aspose.Cells for .NET

WorkbookSettings.Iteration Property

Indicates if Aspose.Cells will use iteration to resolve circular references.

public bool Iteration {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


LanguageCode Property

Aspose.Cells for .NET

WorkbookSettings.LanguageCode Property

Gets or sets the user interface language of the Workbook version based on CountryCode that has saved the file.

public CountryCode LanguageCode {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


MaxChange Property

Aspose.Cells for .NET

WorkbookSettings.MaxChange Property

Returns or sets the maximum number of change that Microsoft Excel can use to resolve a circular reference.

public double MaxChange {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


MaxColumn Property

Aspose.Cells for .NET

WorkbookSettings.MaxColumn Property

Gets the max column index, zero-based.

public int MaxColumn {get;}

Remarks

Returns 255 if the file format is Excel97-2003;

See Also

WorkbookSettings Class | Aspose.Cells Namespace


MaxIteration Property

Aspose.Cells for .NET

WorkbookSettings.MaxIteration Property

Returns or sets the maximum number of iterations that Aspose.Cells can use to resolve a circular reference.

public int MaxIteration {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


MaxRow Property

Aspose.Cells for .NET

WorkbookSettings.MaxRow Property

Gets the max row index, zero-based.

public int MaxRow {get;}

Remarks

Returns 65535 if the file format is Excel97-2003;

See Also

WorkbookSettings Class | Aspose.Cells Namespace


MaxRowsOfSharedFormula Property

Aspose.Cells for .NET

WorkbookSettings.MaxRowsOfSharedFormula Property

Gets and sets the max row number of shared formula.

public int MaxRowsOfSharedFormula {get; set;}

Remarks

If the number is too large, the autofilter works very slow in MS Excel 2013.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


MemorySetting Property

Aspose.Cells for .NET

WorkbookSettings.MemorySetting Property

Gets or sets the memory usage options. The new option will be taken as the default option for newly created worksheets but does not take effect for existing worksheets.

public MemorySetting MemorySetting {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


NumberDecimalSeparator Property

Aspose.Cells for .NET

WorkbookSettings.NumberDecimalSeparator Property

Gets or sets the decimal separator for formatting/parsing numeric values. Default is the decimal separator of current Region.

public char NumberDecimalSeparator {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


NumberGroupSeparator Property

Aspose.Cells for .NET

WorkbookSettings.NumberGroupSeparator Property

Gets or sets the character that separates groups of digits to the left of the decimal in numeric values. Default is the group separator of current Region.

public char NumberGroupSeparator {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


PaperSize Property

Aspose.Cells for .NET

WorkbookSettings.PaperSize Property

Gets and sets the default print paper size.

public PaperSizeType PaperSize {get; set;}

Remarks

If there is no setting about paper size,MS Excel will use default printer's setting.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


ParsingFormulaOnOpen Property

Aspose.Cells for .NET

WorkbookSettings.ParsingFormulaOnOpen Property

NOTE: This property is now obsolete.

Use LoadOptions.ParsingFormulaOnOpen instead.

Indicates whether parsing the formula when reading the file.

public bool ParsingFormulaOnOpen {get; set;}

Remarks

Only applies for Excel Xlsx, Xltx, Xltm and Xlsm file because the formulas in the files are stored with a string formula. NOTE: This member is now obsolete. Instead, please use LoadOptions.ParsingFormulaOnOpen. This property will be removed 12 months later since January 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Password Property

Aspose.Cells for .NET

WorkbookSettings.Password Property

Represents Workbook file encryption password.

public string Password {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


PrecisionAsDisplayed Property

Aspose.Cells for .NET

WorkbookSettings.PrecisionAsDisplayed Property

True if calculations in this workbook will be done using only the precision of the numbers as they're displayed

public bool PrecisionAsDisplayed {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


ProtectionType Property

Aspose.Cells for .NET

WorkbookSettings.ProtectionType Property

Gets the protection type of the workbook.

public ProtectionType ProtectionType {get;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


QuotePrefixToStyle Property

Aspose.Cells for .NET

WorkbookSettings.QuotePrefixToStyle Property

Indicates whether setting QuotePrefix property when entering the string value(which starts with single quote mark ) to the cell

public bool QuotePrefixToStyle {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


RecalculateBeforeSave Property

Aspose.Cells for .NET

WorkbookSettings.RecalculateBeforeSave Property

Indicates whether to recalculate before saving the document.

public bool RecalculateBeforeSave {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


ReCalculateOnOpen Property

Aspose.Cells for .NET

WorkbookSettings.ReCalculateOnOpen Property

Indicates whether re-calculate all formulas on opening file.

public bool ReCalculateOnOpen {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


RecommendReadOnly Property

Aspose.Cells for .NET

WorkbookSettings.RecommendReadOnly Property

NOTE: This property is now obsolete.

Use WorkbookSettings.WriteProtection.RecommendReadOnly property instead.

Indicates if the Read Only Recommended option is selected.

public bool RecommendReadOnly {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use WorkbookSettings.WriteProtection.RecommendReadOnly property. This property will be removed 12 months later since October 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Region Property

Aspose.Cells for .NET

WorkbookSettings.Region Property

Gets or sets the regional settings for workbook.

public CountryCode Region {get; set;}

Remarks

1. Regional settings used by Aspose.Cells component for a workbook loaded from template file: i). For an XLS file, there are fields defined for regional settings and MS Excel does save regional settings data into the file when saving the XLS file. So, we use the saved region in the template file for the workbook. If you do not want to use the region saved in the XLS file, please reset it to the expected one (such as, CountryCode.Default) after loading the template file. And, we save the user specified value (by this method) into the file too when saving an XLS file. ii). For other file formats, such as, XLSX, XLSB...etc., there is no field defined for regional settings in the file format specification. So, we use the regional settings of application's environment for the workbook. And, the user specified value (by this method) cannot be kept for the generated files with those file formats. 2. For the view effect in MS Excel: The applied regional settings here can take effect only at runtime with Aspose.Cells component and not when viewing the generated file with MS Excel. Even for the generated XLS file in which the specified regional settings data has been saved, when viewing/editing it with MS Excel, the used region to perform formatting by MS Excel is always the default regional settings of the environment where MS Excel is running, not the one saved in the file. It is MS Excel's behavior and cannot be changed by code.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


RemovePersonalInformation Property

Aspose.Cells for .NET

WorkbookSettings.RemovePersonalInformation Property

True if personal information can be removed from the specified workbook.

public bool RemovePersonalInformation {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


RepairLoad Property

Aspose.Cells for .NET

WorkbookSettings.RepairLoad Property

Indicates whether the application last opened the workbook in safe or repair mode.

public bool RepairLoad {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Shared Property

Aspose.Cells for .NET

WorkbookSettings.Shared Property

Gets or sets a value that indicates whether the Workbook is shared.

public bool Shared {get; set;}

Remarks

The default value is false.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


SheetTabBarWidth Property

Aspose.Cells for .NET

WorkbookSettings.SheetTabBarWidth Property

Width of worksheet tab bar (in 1/1000 of window width).

public int SheetTabBarWidth {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


ShowTabs Property

Aspose.Cells for .NET

WorkbookSettings.ShowTabs Property

Get or sets a value whether the Workbook tabs are displayed.

public bool ShowTabs {get; set;}

Remarks

The default value is true.

Example

The following code hides the Sheet Tabs and Tab Scrolling Buttons for the spreadsheet.

[C#]
// Hide the spreadsheet tabs.
workbook.ShowTabs = false;

[Visual Basic]
' Hide the spreadsheet tabs.
workbook.ShowTabs = False

See Also

WorkbookSettings Class | Aspose.Cells Namespace


SignificantDigits Property

Aspose.Cells for .NET

WorkbookSettings.SignificantDigits Property

Gets and sets the number of significant digits. The default value is SignificantDigits.

public int SignificantDigits {get; set;}

Remarks

Only could be 15 or 17 now.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


StreamProvider Property

Aspose.Cells for .NET

WorkbookSettings.StreamProvider Property

Gets and sets the stream provider for external resource.

public IStreamProvider StreamProvider {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


UpdateAdjacentCellsBorder Property

Aspose.Cells for .NET

WorkbookSettings.UpdateAdjacentCellsBorder Property

Indicates whether update adjacent cells' border.

public bool UpdateAdjacentCellsBorder {get; set;}

Remarks

The default value is false. For example: the bottom border of the cell A1 is update, the top border of the cell A2 should be changed too.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


UpdateLinksType Property

Aspose.Cells for .NET

WorkbookSettings.UpdateLinksType Property

Gets and sets how updates external links when the workbook is opened.

public UpdateLinksType UpdateLinksType {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WarningCallback Property

Aspose.Cells for .NET

WorkbookSettings.WarningCallback Property

Gets or sets warning callback.

public IWarningCallback WarningCallback {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowHeight Property

Aspose.Cells for .NET

WorkbookSettings.WindowHeight Property

The height of the window, in unit of point.

public double WindowHeight {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowHeightCM Property

Aspose.Cells for .NET

WorkbookSettings.WindowHeightCM Property

The height of the window, in unit of centimeter.

public double WindowHeightCM {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowHeightInch Property

Aspose.Cells for .NET

WorkbookSettings.WindowHeightInch Property

The height of the window, in unit of inch.

public double WindowHeightInch {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowLeft Property

Aspose.Cells for .NET

WorkbookSettings.WindowLeft Property

The distance from the left edge of the client area to the left edge of the window, in unit of point.

public double WindowLeft {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowLeftCM Property

Aspose.Cells for .NET

WorkbookSettings.WindowLeftCM Property

The distance from the left edge of the client area to the left edge of the window. In unit of centimeter.

public double WindowLeftCM {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowLeftInch Property

Aspose.Cells for .NET

WorkbookSettings.WindowLeftInch Property

The distance from the left edge of the client area to the left edge of the window. In unit of inch.

public double WindowLeftInch {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowTop Property

Aspose.Cells for .NET

WorkbookSettings.WindowTop Property

The distance from the top edge of the client area to the top edge of the window, in unit of point.

public double WindowTop {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowTopCM Property

Aspose.Cells for .NET

WorkbookSettings.WindowTopCM Property

The distance from the top edge of the client area to the top edge of the window, in unit of centimeter.

public double WindowTopCM {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowTopInch Property

Aspose.Cells for .NET

WorkbookSettings.WindowTopInch Property

The distance from the top edge of the client area to the top edge of the window, in unit of inch.

public double WindowTopInch {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowWidth Property

Aspose.Cells for .NET

WorkbookSettings.WindowWidth Property

The width of the window, in unit of point.

public double WindowWidth {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowWidthCM Property

Aspose.Cells for .NET

WorkbookSettings.WindowWidthCM Property

The width of the window, in unit of centimeter.

public double WindowWidthCM {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WindowWidthInch Property

Aspose.Cells for .NET

WorkbookSettings.WindowWidthInch Property

The width of the window, in unit of inch.

public double WindowWidthInch {get; set;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WriteProtectedPassword Property

Aspose.Cells for .NET

WorkbookSettings.WriteProtectedPassword Property

NOTE: This property is now obsolete.

Use WorkbookSettings.WriteProtection.Password property instead.

Sets the protected password to modify the file.

public string WriteProtectedPassword {set;}

Remarks

NOTE: This member is now obsolete. Instead, please use WorkbookSettings.WriteProtection.Password property. This property will be removed 12 months later since October 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WriteProtection Property

Aspose.Cells for .NET

WorkbookSettings.WriteProtection Property

Provides access to the workbook write protection options.

public WriteProtection WriteProtection {get;}

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WorkbookSettings Methods

The methods of the WorkbookSettings class are listed below. For a complete list of WorkbookSettings class members, see the WorkbookSettings Members topic.

Public Instance Methods

Dispose | Releases resources.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetThemeFont | Gets the default theme font name.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WorkbookSettings.Dispose Method

Releases resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

WorkbookSettings Class | Aspose.Cells Namespace


WorkbookSettings.GetThemeFont Method

Gets the default theme font name.

public string GetThemeFont(
FontSchemeType type
);

Parameters

type
The scheme type of the font.

Return Value

See Also

WorkbookSettings Class | Aspose.Cells Namespace


Worksheet Class

Encapsulates the object that represents a single worksheet.

For a list of all members of this type, see Worksheet Members.

System.Object
Aspose.Cells.Worksheet

public class Worksheet : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 Workbook workbook = new Workbook();

 Worksheet sheet = workbook.Worksheets[0];

 //Freeze panes at "AS40" with 10 rows and 10 columns
 sheet.FreezePanes("AS40", 10, 10);

 //Add a hyperlink in Cell A1
 sheet.Hyperlinks.Add("A1", 1, 1, "http://www.aspose.com");

 [Visual Basic]

 Dim workbook as Workbook = new Workbook()

 Dim sheet as Worksheet = workbook.Worksheets(0)

 'Freeze panes at "AS40" with 10 rows and 10 columns
 sheet.FreezePanes("AS40", 10, 10)

 'Add a hyperlink in Cell A1
 sheet.Hyperlinks.Add("A1", 1, 1, "http://www.aspose.com")

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Worksheet Members | Aspose.Cells Namespace


Worksheet Members

Worksheet overview

Public Instance Properties

ActiveCell | Gets or sets the active cell in the worksheet.
AllowEditRanges | Gets the allow edit range collection in the worksheet.
AutoFilter | Represents auto filter for the specified worksheet.
BackgroundImage | Gets and sets worksheet background image.
Cells | Gets the Cells collection.
CellWatches | Gets collection of cells on this worksheet being watched in the 'watch window'.
Charts | Gets a Chart collection
CheckBoxes | Gets a CheckBox collection.
CodeName | Gets worksheet code name.
Comments | Gets the Comment collection.
ConditionalFormattings | Gets the ConditionalFormattings in the worksheet.
CustomProperties | Gets an object representing the identifier information associated with a worksheet.
DisplayRightToLeft | Indicates if the specified worksheet is displayed from right to left instead of from left to right. Default is false.
DisplayZeros | True if zero values are displayed.
ErrorCheckOptions | Gets error check setting applied on certain ranges.
FirstVisibleColumn | Represents first visible column index.
FirstVisibleRow | Represents first visible row index.
HasAutofilter | Indicates whether this worksheet has auto filter.
HorizontalPageBreaks | Gets the HorizontalPageBreakCollection collection.
Hyperlinks | Gets the HyperlinkCollection collection.
Index | Gets the index of sheet in the worksheet collection.
IsGridlinesVisible | Gets or sets a value indicating whether the gridlines are visible.Default is true.
IsOutlineShown | Indicates whether to show outline.
IsPageBreakPreview | Indicates whether the specified worksheet is shown in normal view or page break preview.
IsProtected | Indicates if the worksheet is protected.
IsRowColumnHeadersVisible | Gets or sets a value indicating whether the worksheet will display row and column headers. Default is true.
IsRulerVisible | Indicates whether the ruler is visible. This property is only applied for page break preview.
IsSelected | Indicates whether this worksheet is selected when the workbook is opened.
IsVisible | Represents if the worksheet is visible.
ListObjects | Gets all ListObjects in this worksheet.
Name | Gets or sets the name of the worksheet.
OleObjects | Represents a collection of OleObject in a worksheet.
Outline | Gets the outline on this worksheet.
PageSetup | Represents the page setup description in this sheet.
PaneState | Indicates whether the pane has horizontal or vertical splits, and whether those splits are frozen.
Pictures | Gets a Picture collection.
PivotTables | Gets all pivot tables in this worksheet.
Protection | Represents the various types of protection options available for a worksheet. Supports advanced protection options in ExcelXP and above version.
QueryTables | Gets the queryTables in the worksheet.
Scenarios | Gets the collection of Scenario.
Shapes | Returns all drawing shapes in this worksheet.
ShowFormulas | Indicates whether to show formulas or their results.
Slicers | Get the Slicer collection in the worksheet
SmartTagSetting | Gets all SmartTagCollection objects of the worksheet.
SparklineGroupCollection | Gets the sparkline group collection in the worksheet.
TabColor | Represents worksheet tab color.
TabId | Specifies the internal identifier for the sheet.
TextBoxes | Gets a TextBox collection.
TransitionEntry | Indicates whether the Transition Formula Entry (Lotus compatibility) option is enabled.
TransitionEvaluation | Indicates whether the Transition Formula Evaluation (Lotus compatibility) option is enabled.
Type | Represents worksheet type.
UniqueId | Gets and sets the unique id, it is same as {15DB5C3C-A5A1-48AF-8F25-3D86AC232D4F}.
Validations | Gets the data validation setting collection in the worksheet.
VerticalPageBreaks | Gets the VerticalPageBreakCollection collection.
ViewType | Gets and sets the view type.
VisibilityType | Indicates the visible state for this sheet.
Workbook | Gets the workbook object which contains this sheet.
Zoom | Represents the scaling factor in percentage. It should be between 10 and 400.

Public Instance Methods

AddPageBreaks | Adds page break.
AdvancedFilter | Filters data using complex criteria.
AutoFitColumn | Overloaded. Autofits the column width.
AutoFitColumns | Overloaded. Autofits all columns in this worksheet.
AutoFitRow | Overloaded. Autofits the row height.
AutoFitRows | Overloaded. Autofits all rows in this worksheet.
CalculateFormula | Overloaded. Calculates a formula.
ClearComments | Clears all comments in designer spreadsheet.
Copy | Overloaded. Copies contents and formats from another worksheet.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
FreezePanes | Overloaded. Freezes panes at the specified cell in the worksheet.
GetFreezedPanes |
GetHashCode (inherited from Object) |
GetPanes | Gets the window panes.
GetPrintingPageBreaks | Gets automatic page breaks.
GetSelectedRanges | Gets selected ranges of cells in the designer spreadsheet.
GetType (inherited from Object) |
MoveTo | Moves the sheet to another location in the spreadsheet.
Protect | Overloaded. Protects worksheet.
RefreshPivotTables | Refreshes all the PivotTables in this Worksheet.
RemoveAllDrawingObjects | Removes all drawing objects in this worksheet.
RemoveAutoFilter | Removes the auto filter of the worksheet.
RemoveSplit | Removes split window.
Replace | Replaces all cells' text with a new string.
SelectRange | Selects a range.
SetBackground | Obsolete. Sets worksheet background image.
SetVisible | Sets the visible options.
Split | Splits window.
ToString | Returns a string represents the current Worksheet object.
UnFreezePanes | Unfreezes panes in the worksheet.
Unprotect | Overloaded. Unprotects worksheet.
XmlMapQuery | Query cell areas that mapped/linked to the specific path of xml map.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet Properties

The properties of the Worksheet class are listed below. For a complete list of Worksheet class members, see the Worksheet Members topic.

Public Instance Properties

ActiveCell | Gets or sets the active cell in the worksheet.
AllowEditRanges | Gets the allow edit range collection in the worksheet.
AutoFilter | Represents auto filter for the specified worksheet.
BackgroundImage | Gets and sets worksheet background image.
Cells | Gets the Cells collection.
CellWatches | Gets collection of cells on this worksheet being watched in the 'watch window'.
Charts | Gets a Chart collection
CheckBoxes | Gets a CheckBox collection.
CodeName | Gets worksheet code name.
Comments | Gets the Comment collection.
ConditionalFormattings | Gets the ConditionalFormattings in the worksheet.
CustomProperties | Gets an object representing the identifier information associated with a worksheet.
DisplayRightToLeft | Indicates if the specified worksheet is displayed from right to left instead of from left to right. Default is false.
DisplayZeros | True if zero values are displayed.
ErrorCheckOptions | Gets error check setting applied on certain ranges.
FirstVisibleColumn | Represents first visible column index.
FirstVisibleRow | Represents first visible row index.
HasAutofilter | Indicates whether this worksheet has auto filter.
HorizontalPageBreaks | Gets the HorizontalPageBreakCollection collection.
Hyperlinks | Gets the HyperlinkCollection collection.
Index | Gets the index of sheet in the worksheet collection.
IsGridlinesVisible | Gets or sets a value indicating whether the gridlines are visible.Default is true.
IsOutlineShown | Indicates whether to show outline.
IsPageBreakPreview | Indicates whether the specified worksheet is shown in normal view or page break preview.
IsProtected | Indicates if the worksheet is protected.
IsRowColumnHeadersVisible | Gets or sets a value indicating whether the worksheet will display row and column headers. Default is true.
IsRulerVisible | Indicates whether the ruler is visible. This property is only applied for page break preview.
IsSelected | Indicates whether this worksheet is selected when the workbook is opened.
IsVisible | Represents if the worksheet is visible.
ListObjects | Gets all ListObjects in this worksheet.
Name | Gets or sets the name of the worksheet.
OleObjects | Represents a collection of OleObject in a worksheet.
Outline | Gets the outline on this worksheet.
PageSetup | Represents the page setup description in this sheet.
PaneState | Indicates whether the pane has horizontal or vertical splits, and whether those splits are frozen.
Pictures | Gets a Picture collection.
PivotTables | Gets all pivot tables in this worksheet.
Protection | Represents the various types of protection options available for a worksheet. Supports advanced protection options in ExcelXP and above version.
QueryTables | Gets the queryTables in the worksheet.
Scenarios | Gets the collection of Scenario.
Shapes | Returns all drawing shapes in this worksheet.
ShowFormulas | Indicates whether to show formulas or their results.
Slicers | Get the Slicer collection in the worksheet
SmartTagSetting | Gets all SmartTagCollection objects of the worksheet.
SparklineGroupCollection | Gets the sparkline group collection in the worksheet.
TabColor | Represents worksheet tab color.
TabId | Specifies the internal identifier for the sheet.
TextBoxes | Gets a TextBox collection.
TransitionEntry | Indicates whether the Transition Formula Entry (Lotus compatibility) option is enabled.
TransitionEvaluation | Indicates whether the Transition Formula Evaluation (Lotus compatibility) option is enabled.
Type | Represents worksheet type.
UniqueId | Gets and sets the unique id, it is same as {15DB5C3C-A5A1-48AF-8F25-3D86AC232D4F}.
Validations | Gets the data validation setting collection in the worksheet.
VerticalPageBreaks | Gets the VerticalPageBreakCollection collection.
ViewType | Gets and sets the view type.
VisibilityType | Indicates the visible state for this sheet.
Workbook | Gets the workbook object which contains this sheet.
Zoom | Represents the scaling factor in percentage. It should be between 10 and 400.

See Also

Worksheet Class | Aspose.Cells Namespace


ActiveCell Property

Aspose.Cells for .NET

Worksheet.ActiveCell Property

Gets or sets the active cell in the worksheet.

public string ActiveCell {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


AllowEditRanges Property

Aspose.Cells for .NET

Worksheet.AllowEditRanges Property

Gets the allow edit range collection in the worksheet.

public ProtectedRangeCollection AllowEditRanges {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


AutoFilter Property

Aspose.Cells for .NET

Worksheet.AutoFilter Property

Represents auto filter for the specified worksheet.

public AutoFilter AutoFilter {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


BackgroundImage Property

Aspose.Cells for .NET

Worksheet.BackgroundImage Property

Gets and sets worksheet background image.

public byte[] BackgroundImage {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


Cells Property

Aspose.Cells for .NET

Worksheet.Cells Property

Gets the Cells collection.

public Cells Cells {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


CellWatches Property

Aspose.Cells for .NET

Worksheet.CellWatches Property

Gets collection of cells on this worksheet being watched in the 'watch window'.

public CellWatchCollection CellWatches {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Charts Property

Aspose.Cells for .NET

Worksheet.Charts Property

Gets a Chart collection

public ChartCollection Charts {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


CheckBoxes Property

Aspose.Cells for .NET

Worksheet.CheckBoxes Property

Gets a CheckBox collection.

public CheckBoxCollection CheckBoxes {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


CodeName Property

Aspose.Cells for .NET

Worksheet.CodeName Property

Gets worksheet code name.

public string CodeName {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


Comments Property

Aspose.Cells for .NET

Worksheet.Comments Property

Gets the Comment collection.

public CommentCollection Comments {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


ConditionalFormattings Property

Aspose.Cells for .NET

Worksheet.ConditionalFormattings Property

Gets the ConditionalFormattings in the worksheet.

public ConditionalFormattingCollection ConditionalFormattings {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


CustomProperties Property

Aspose.Cells for .NET

Worksheet.CustomProperties Property

Gets an object representing the identifier information associated with a worksheet.

public CustomPropertyCollection CustomProperties {get;}

Remarks

Worksheet.CustomProperties provide a preferred mechanism for storing arbitrary data. It supports legacy third-party document components, as well as those situations that have a stringent need for binary parts.

See Also

Worksheet Class | Aspose.Cells Namespace


DisplayRightToLeft Property

Aspose.Cells for .NET

Worksheet.DisplayRightToLeft Property

Indicates if the specified worksheet is displayed from right to left instead of from left to right. Default is false.

public bool DisplayRightToLeft {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


DisplayZeros Property

Aspose.Cells for .NET

Worksheet.DisplayZeros Property

True if zero values are displayed.

public bool DisplayZeros {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


ErrorCheckOptions Property

Aspose.Cells for .NET

Worksheet.ErrorCheckOptions Property

Gets error check setting applied on certain ranges.

public ErrorCheckOptionCollection ErrorCheckOptions {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


FirstVisibleColumn Property

Aspose.Cells for .NET

Worksheet.FirstVisibleColumn Property

Represents first visible column index.

public int FirstVisibleColumn {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


FirstVisibleRow Property

Aspose.Cells for .NET

Worksheet.FirstVisibleRow Property

Represents first visible row index.

public int FirstVisibleRow {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


HasAutofilter Property

Aspose.Cells for .NET

Worksheet.HasAutofilter Property

Indicates whether this worksheet has auto filter.

public bool HasAutofilter {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


HorizontalPageBreaks Property

Aspose.Cells for .NET

Worksheet.HorizontalPageBreaks Property

Gets the HorizontalPageBreakCollection collection.

public HorizontalPageBreakCollection HorizontalPageBreaks {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Hyperlinks Property

Aspose.Cells for .NET

Worksheet.Hyperlinks Property

Gets the HyperlinkCollection collection.

public HyperlinkCollection Hyperlinks {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Index Property

Aspose.Cells for .NET

Worksheet.Index Property

Gets the index of sheet in the worksheet collection.

public int Index {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsGridlinesVisible Property

Aspose.Cells for .NET

Worksheet.IsGridlinesVisible Property

Gets or sets a value indicating whether the gridlines are visible.Default is true.

public bool IsGridlinesVisible {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsOutlineShown Property

Aspose.Cells for .NET

Worksheet.IsOutlineShown Property

Indicates whether to show outline.

public bool IsOutlineShown {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsPageBreakPreview Property

Aspose.Cells for .NET

Worksheet.IsPageBreakPreview Property

Indicates whether the specified worksheet is shown in normal view or page break preview.

public bool IsPageBreakPreview {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsProtected Property

Aspose.Cells for .NET

Worksheet.IsProtected Property

Indicates if the worksheet is protected.

public bool IsProtected {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsRowColumnHeadersVisible Property

Aspose.Cells for .NET

Worksheet.IsRowColumnHeadersVisible Property

Gets or sets a value indicating whether the worksheet will display row and column headers. Default is true.

public bool IsRowColumnHeadersVisible {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsRulerVisible Property

Aspose.Cells for .NET

Worksheet.IsRulerVisible Property

Indicates whether the ruler is visible. This property is only applied for page break preview.

public bool IsRulerVisible {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsSelected Property

Aspose.Cells for .NET

Worksheet.IsSelected Property

Indicates whether this worksheet is selected when the workbook is opened.

public bool IsSelected {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


IsVisible Property

Aspose.Cells for .NET

Worksheet.IsVisible Property

Represents if the worksheet is visible.

public bool IsVisible {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


ListObjects Property

Aspose.Cells for .NET

Worksheet.ListObjects Property

Gets all ListObjects in this worksheet.

public ListObjectCollection ListObjects {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

Worksheet.Name Property

Gets or sets the name of the worksheet.

public string Name {get; set;}

Remarks

The max length of sheet name is 31. And you cannot assign same name(case insensitive) to two worksheets. For example, you cannot set "SheetName1" to the first worksheet and set "SHEETNAME1" to the second worksheet.

See Also

Worksheet Class | Aspose.Cells Namespace


OleObjects Property

Aspose.Cells for .NET

Worksheet.OleObjects Property

Represents a collection of OleObject in a worksheet.

public OleObjectCollection OleObjects {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Outline Property

Aspose.Cells for .NET

Worksheet.Outline Property

Gets the outline on this worksheet.

public Outline Outline {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


PageSetup Property

Aspose.Cells for .NET

Worksheet.PageSetup Property

Represents the page setup description in this sheet.

public PageSetup PageSetup {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


PaneState Property

Aspose.Cells for .NET

Worksheet.PaneState Property

Indicates whether the pane has horizontal or vertical splits, and whether those splits are frozen.

public PaneStateType PaneState {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Pictures Property

Aspose.Cells for .NET

Worksheet.Pictures Property

Gets a Picture collection.

public PictureCollection Pictures {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


PivotTables Property

Aspose.Cells for .NET

Worksheet.PivotTables Property

Gets all pivot tables in this worksheet.

public PivotTableCollection PivotTables {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Protection Property

Aspose.Cells for .NET

Worksheet.Protection Property

Represents the various types of protection options available for a worksheet. Supports advanced protection options in ExcelXP and above version.

public Protection Protection {get;}

Remarks

This property can protect worksheet in all versions of Excel file and support advanced protection options in ExcelXP and above version.

See Also

Worksheet Class | Aspose.Cells Namespace


QueryTables Property

Aspose.Cells for .NET

Worksheet.QueryTables Property

Gets the queryTables in the worksheet.

public QueryTableCollection QueryTables {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Scenarios Property

Aspose.Cells for .NET

Worksheet.Scenarios Property

Gets the collection of Scenario.

public ScenarioCollection Scenarios {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Shapes Property

Aspose.Cells for .NET

Worksheet.Shapes Property

Returns all drawing shapes in this worksheet.

public ShapeCollection Shapes {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


ShowFormulas Property

Aspose.Cells for .NET

Worksheet.ShowFormulas Property

Indicates whether to show formulas or their results.

public bool ShowFormulas {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


Slicers Property

Aspose.Cells for .NET

Worksheet.Slicers Property

Get the Slicer collection in the worksheet

public SlicerCollection Slicers {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


SmartTagSetting Property

Aspose.Cells for .NET

Worksheet.SmartTagSetting Property

Gets all SmartTagCollection objects of the worksheet.

public SmartTagSetting SmartTagSetting {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


SparklineGroupCollection Property

Aspose.Cells for .NET

Worksheet.SparklineGroupCollection Property

Gets the sparkline group collection in the worksheet.

public SparklineGroupCollection SparklineGroupCollection {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


TabColor Property

Aspose.Cells for .NET

Worksheet.TabColor Property

Represents worksheet tab color.

public Color TabColor {get; set;}

Remarks

This feature is only supported in ExcelXP(Excel2002) and later versions. If you save file as Excel97 or Excel2000 format, it will be omitted.

See Also

Worksheet Class | Aspose.Cells Namespace


TabId Property

Aspose.Cells for .NET

Worksheet.TabId Property

Specifies the internal identifier for the sheet.

public int TabId {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


TextBoxes Property

Aspose.Cells for .NET

Worksheet.TextBoxes Property

Gets a TextBox collection.

public TextBoxCollection TextBoxes {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


TransitionEntry Property

Aspose.Cells for .NET

Worksheet.TransitionEntry Property

Indicates whether the Transition Formula Entry (Lotus compatibility) option is enabled.

public bool TransitionEntry {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


TransitionEvaluation Property

Aspose.Cells for .NET

Worksheet.TransitionEvaluation Property

Indicates whether the Transition Formula Evaluation (Lotus compatibility) option is enabled.

public bool TransitionEvaluation {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


Type Property

Aspose.Cells for .NET

Worksheet.Type Property

Represents worksheet type.

public SheetType Type {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


UniqueId Property

Aspose.Cells for .NET

Worksheet.UniqueId Property

Gets and sets the unique id, it is same as {15DB5C3C-A5A1-48AF-8F25-3D86AC232D4F}.

public string UniqueId {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


Validations Property

Aspose.Cells for .NET

Worksheet.Validations Property

Gets the data validation setting collection in the worksheet.

public ValidationCollection Validations {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


VerticalPageBreaks Property

Aspose.Cells for .NET

Worksheet.VerticalPageBreaks Property

Gets the VerticalPageBreakCollection collection.

public VerticalPageBreakCollection VerticalPageBreaks {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


ViewType Property

Aspose.Cells for .NET

Worksheet.ViewType Property

Gets and sets the view type.

public ViewType ViewType {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


VisibilityType Property

Aspose.Cells for .NET

Worksheet.VisibilityType Property

Indicates the visible state for this sheet.

public VisibilityType VisibilityType {get; set;}

See Also

Worksheet Class | Aspose.Cells Namespace


Workbook Property

Aspose.Cells for .NET

Worksheet.Workbook Property

Gets the workbook object which contains this sheet.

public Workbook Workbook {get;}

See Also

Worksheet Class | Aspose.Cells Namespace


Zoom Property

Aspose.Cells for .NET

Worksheet.Zoom Property

Represents the scaling factor in percentage. It should be between 10 and 400.

public int Zoom {get; set;}

Remarks

Please set the view type first.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet Methods

The methods of the Worksheet class are listed below. For a complete list of Worksheet class members, see the Worksheet Members topic.

Public Instance Methods

AddPageBreaks | Adds page break.
AdvancedFilter | Filters data using complex criteria.
AutoFitColumn | Overloaded. Autofits the column width.
AutoFitColumns | Overloaded. Autofits all columns in this worksheet.
AutoFitRow | Overloaded. Autofits the row height.
AutoFitRows | Overloaded. Autofits all rows in this worksheet.
CalculateFormula | Overloaded. Calculates a formula.
ClearComments | Clears all comments in designer spreadsheet.
Copy | Overloaded. Copies contents and formats from another worksheet.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
FreezePanes | Overloaded. Freezes panes at the specified cell in the worksheet.
GetFreezedPanes |
GetHashCode (inherited from Object) |
GetPanes | Gets the window panes.
GetPrintingPageBreaks | Gets automatic page breaks.
GetSelectedRanges | Gets selected ranges of cells in the designer spreadsheet.
GetType (inherited from Object) |
MoveTo | Moves the sheet to another location in the spreadsheet.
Protect | Overloaded. Protects worksheet.
RefreshPivotTables | Refreshes all the PivotTables in this Worksheet.
RemoveAllDrawingObjects | Removes all drawing objects in this worksheet.
RemoveAutoFilter | Removes the auto filter of the worksheet.
RemoveSplit | Removes split window.
Replace | Replaces all cells' text with a new string.
SelectRange | Selects a range.
SetBackground | Obsolete. Sets worksheet background image.
SetVisible | Sets the visible options.
Split | Splits window.
ToString | Returns a string represents the current Worksheet object.
UnFreezePanes | Unfreezes panes in the worksheet.
Unprotect | Overloaded. Unprotects worksheet.
XmlMapQuery | Query cell areas that mapped/linked to the specific path of xml map.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.AddPageBreaks Method

Adds page break.

public void AddPageBreaks(
string cellName
);

Parameters

cellName

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.AdvancedFilter Method

Filters data using complex criteria.

public void AdvancedFilter(
bool isFilter,
string listRange,
string criteriaRange,
string copyTo,
bool uniqueRecordOnly
);

Parameters

isFilter
Indicates whether filtering the list in place.
listRange
The list range.
criteriaRange
The criteria range.
copyTo
The range where copying data to.
uniqueRecordOnly
Only displaying or copying unique rows.

See Also

Worksheet Class | Aspose.Cells Namespace


AutoFitColumn Method

Aspose.Cells for .NET

Worksheet.AutoFitColumn Method

Autofits the column width.

Overload List

Autofits the column width.

public void AutoFitColumn(int);

Autofits the column width.

public void AutoFitColumn(int,int,int);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.AutoFitColumn Method (Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumn Overload List


Worksheet.AutoFitColumn Method (Int32, Int32, Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex,
int firstRow,
int lastRow
);

Parameters

columnIndex
Column index.
firstRow
First row index.
lastRow
Last row index.

Remarks

This method autofits a row based on content in a range of cells within the row.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumn Overload List


AutoFitColumns Method

Aspose.Cells for .NET

Worksheet.AutoFitColumns Method

Autofits all columns in this worksheet.

Overload List

Autofits all columns in this worksheet.

public void AutoFitColumns();

Autofits all columns in this worksheet.

public void AutoFitColumns(AutoFitterOptions);

Autofits the columns width.

public void AutoFitColumns(int,int);

Autofits the columns width.

public void AutoFitColumns(int,int,AutoFitterOptions);

Autofits the columns width.

public void AutoFitColumns(int,int,int,int);

Autofits the columns width.

public void AutoFitColumns(int,int,int,int,AutoFitterOptions);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.AutoFitColumns Method ()

Autofits all columns in this worksheet.

public void AutoFitColumns();

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (AutoFitterOptions)

Autofits all columns in this worksheet.

public void AutoFitColumns(
AutoFitterOptions options
);

Parameters

options
The auto fitting options

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (Int32, Int32)

Autofits the columns width.

public void AutoFitColumns(
int firstColumn,
int lastColumn
);

Parameters

firstColumn
First column index.
lastColumn
Last column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (Int32, Int32, AutoFitterOptions)

Autofits the columns width.

public void AutoFitColumns(
int firstColumn,
int lastColumn,
AutoFitterOptions options
);

Parameters

firstColumn
First column index.
lastColumn
Last column index.
options
The auto fitting options

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (Int32, Int32, Int32, Int32)

Autofits the columns width.

public void AutoFitColumns(
int firstRow,
int firstColumn,
int lastRow,
int lastColumn
);

Parameters

firstRow
First row index.
firstColumn
First column index.
lastRow
Last row index.
lastColumn
Last column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (Int32, Int32, Int32, Int32, AutoFitterOptions)

Autofits the columns width.

public void AutoFitColumns(
int firstRow,
int firstColumn,
int lastRow,
int lastColumn,
AutoFitterOptions options
);

Parameters

firstRow
First row index.
firstColumn
First column index.
lastRow
Last row index.
lastColumn
Last column index.
options
The auto fitting options

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitColumns Overload List


AutoFitRow Method

Aspose.Cells for .NET

Worksheet.AutoFitRow Method

Autofits the row height.

Overload List

Autofits the row height.

public void AutoFitRow(int);

Autofits the row height.

public void AutoFitRow(int,int,int);

Autofits the row height.

public void AutoFitRow(int,int,int,AutoFitterOptions);

Autofits row height in a rectangle range.

public void AutoFitRow(int,int,int,int);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.AutoFitRow Method (Int32)

Autofits the row height.

public void AutoFitRow(
int rowIndex
);

Parameters

rowIndex
Row index.

Remarks

AutoFitRow is an imprecise function.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRow Overload List


Worksheet.AutoFitRow Method (Int32, Int32, Int32)

Autofits the row height.

public void AutoFitRow(
int rowIndex,
int firstColumn,
int lastColumn
);

Parameters

rowIndex
Row index.
firstColumn
First column index.
lastColumn
Last column index.

Remarks

This method autofits a row based on content in a range of cells within the row.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRow Overload List


Worksheet.AutoFitRow Method (Int32, Int32, Int32, AutoFitterOptions)

Autofits the row height.

public void AutoFitRow(
int rowIndex,
int firstColumn,
int lastColumn,
AutoFitterOptions options
);

Parameters

rowIndex
Row index.
firstColumn
First column index.
lastColumn
Last column index.
options
The auto fitter options

Remarks

This method autofits a row based on content in a range of cells within the row.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRow Overload List


Worksheet.AutoFitRow Method (Int32, Int32, Int32, Int32)

Autofits row height in a rectangle range.

public void AutoFitRow(
int startRow,
int endRow,
int startColumn,
int endColumn
);

Parameters

startRow
Start row index.
endRow
End row index.
startColumn
Start column index.
endColumn
End column index.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRow Overload List


AutoFitRows Method

Aspose.Cells for .NET

Worksheet.AutoFitRows Method

Autofits all rows in this worksheet.

Overload List

Autofits all rows in this worksheet.

public void AutoFitRows();

Autofits all rows in this worksheet.

public void AutoFitRows(AutoFitterOptions);

Autofits all rows in this worksheet.

public void AutoFitRows(bool);

Autofits row height in a range.

public void AutoFitRows(int,int);

Autofits row height in a range.

public void AutoFitRows(int,int,AutoFitterOptions);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.AutoFitRows Method ()

Autofits all rows in this worksheet.

public void AutoFitRows();

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRows Overload List


Worksheet.AutoFitRows Method (AutoFitterOptions)

Autofits all rows in this worksheet.

public void AutoFitRows(
AutoFitterOptions options
);

Parameters

options
The auto fitter options

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRows Overload List


Worksheet.AutoFitRows Method (Boolean)

Autofits all rows in this worksheet.

public void AutoFitRows(
bool onlyAuto
);

Parameters

onlyAuto
True,only autofits the row height when row height is not customed.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRows Overload List


Worksheet.AutoFitRows Method (Int32, Int32)

Autofits row height in a range.

public void AutoFitRows(
int startRow,
int endRow
);

Parameters

startRow
Start row index.
endRow
End row index.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRows Overload List


Worksheet.AutoFitRows Method (Int32, Int32, AutoFitterOptions)

Autofits row height in a range.

public void AutoFitRows(
int startRow,
int endRow,
AutoFitterOptions options
);

Parameters

startRow
Start row index.
endRow
End row index.
options
The options of auto fitter.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.AutoFitRows Overload List


CalculateFormula Method

Aspose.Cells for .NET

Worksheet.CalculateFormula Method

Calculates all formulas in this worksheet.

Overload List

Calculates all formulas in this worksheet.

public void CalculateFormula(CalculationOptions,bool);

Obsolete. Calculates all formulas in this worksheet.

public void CalculateFormula(bool,bool,ICustomFunction);

Calculates a formula.

public object CalculateFormula(string);

Calculates a formula.

public object CalculateFormula(string,CalculationOptions);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.CalculateFormula Method (CalculationOptions, Boolean)

Calculates all formulas in this worksheet.

public void CalculateFormula(
CalculationOptions options,
bool recursive
);

Parameters

options
Options for calculation
recursive
True means if the worksheet' cells depend on the cells of other worksheets, the dependent cells in other worksheets will be calculated too. False means all the formulas in the worksheet have been calculated and the values are right.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.CalculateFormula Overload List


Worksheet.CalculateFormula Method (Boolean, Boolean, ICustomFunction)

NOTE: This method is now obsolete.

Use CalculateFormula(CalculationOptions, bool) method instead.

Calculates all formulas in this worksheet.

public void CalculateFormula(
bool recursive,
bool ignoreError,
ICustomFunction customFunction
);

Parameters

recursive
True means if the worksheet' cells depend on the cells of other worksheets, the dependent cells in other worksheets will be calculated too. False means all the formulas in the worksheet have been calculated and the values are right.
ignoreError
Indicates if hide the error in calculating formulas. The error may be unsupported function, external links, etc.
customFunction
The custom formula calculation functions to extend the calculation engine.

Remarks

NOTE: This member is now obsolete. Instead, please use CalculateFormula(CalculationOptions, bool) method. This method will be removed 12 months later since August 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.CalculateFormula Overload List


Worksheet.CalculateFormula Method (String)

Calculates a formula.

public object CalculateFormula(
string formula
);

Parameters

formula
Formula to be calculated.

Return Value

Calculated formula result.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.CalculateFormula Overload List


Worksheet.CalculateFormula Method (String, CalculationOptions)

Calculates a formula.

public object CalculateFormula(
string formula,
CalculationOptions opts
);

Parameters

formula
Formula to be calculated.
opts
Options for calculating formula

Return Value

Calculated formula result.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.CalculateFormula Overload List


Worksheet.ClearComments Method

Clears all comments in designer spreadsheet.

public void ClearComments();

See Also

Worksheet Class | Aspose.Cells Namespace


Copy Method

Aspose.Cells for .NET

Worksheet.Copy Method

Copies contents and formats from another worksheet.

Overload List

Copies contents and formats from another worksheet.

public void Copy(Worksheet);

Copies contents and formats from another worksheet.

public void Copy(Worksheet,CopyOptions);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.Copy Method (Worksheet)

Copies contents and formats from another worksheet.

public void Copy(
Worksheet sourceSheet
);

Parameters

sourceSheet
Source worksheet.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.Copy Overload List


Worksheet.Copy Method (Worksheet, CopyOptions)

Copies contents and formats from another worksheet.

public void Copy(
Worksheet sourceSheet,
CopyOptions copyOptions
);

Parameters

sourceSheet
Source worksheet.
copyOptions

Remarks

You can copy data from another worksheet in the same file or another file. However, this method does not support to copy drawing objects, such as comments, images and charts.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.Copy Overload List


Worksheet.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

Worksheet Class | Aspose.Cells Namespace


FreezePanes Method

Aspose.Cells for .NET

Worksheet.FreezePanes Method

Freezes panes at the specified cell in the worksheet.

Overload List

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(int,int,int,int);

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(string,int,int);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.FreezePanes Method (Int32, Int32, Int32, Int32)

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(
int row,
int column,
int freezedRows,
int freezedColumns
);

Parameters

row
Row index.
column
Column index.
freezedRows
Number of visible rows in top pane, no more than row index.
freezedColumns
Number of visible columns in left pane, no more than column index.

Remarks

Row index and column index cannot all be zero. Number of rows and number of columns also cannot all be zero.

The first two parameters specify the froze position and the last two parameters specify the area frozen on the left top pane.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.FreezePanes Overload List


Worksheet.FreezePanes Method (String, Int32, Int32)

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(
string cellName,
int freezedRows,
int freezedColumns
);

Parameters

cellName
Cell name.
freezedRows
Number of visible rows in top pane, no more than row index.
freezedColumns
Number of visible columns in left pane, no more than column index.

Remarks

Row index and column index cannot all be zero. Number of rows and number of columns also cannot all be zero.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.FreezePanes Overload List


Worksheet.GetFreezedPanes Method

public bool GetFreezedPanes(
out int row,
out int column,
out int freezedRows,
out int freezedColumns
);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.GetPanes Method

Gets the window panes.

public PaneCollection GetPanes();

Remarks

If the window is not split or frozen.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.GetPrintingPageBreaks Method

Gets automatic page breaks.

public CellArea[] GetPrintingPageBreaks(
ImageOrPrintOptions options
);

Parameters

options
The print options

Return Value

The automatic page breaks areas.

Remarks

Each cell area represents a paper.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.GetSelectedRanges Method

Gets selected ranges of cells in the designer spreadsheet.

public ArrayList GetSelectedRanges();

Return Value

An ArrayList which contains selected ranges.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.MoveTo Method

Moves the sheet to another location in the spreadsheet.

public void MoveTo(
int index
);

Parameters

index
Destination sheet index.

See Also

Worksheet Class | Aspose.Cells Namespace


Protect Method

Aspose.Cells for .NET

Worksheet.Protect Method

Protects worksheet.

Overload List

Protects worksheet.

public void Protect(ProtectionType);

Protects worksheet.

public void Protect(ProtectionType,string,string);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.Protect Method (ProtectionType)

Protects worksheet.

public void Protect(
ProtectionType type
);

Parameters

type
Protection type.

Remarks

This method protects worksheet without password. It can protect worksheet in all versions of Excel file.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.Protect Overload List


Worksheet.Protect Method (ProtectionType, String, String)

Protects worksheet.

public void Protect(
ProtectionType type,
string password,
string oldPassword
);

Parameters

type
Protection type.
password
Password.
oldPassword
If the worksheet is already protected by a password, please supply the old password. Otherwise, you can set a null value or blank string to this parameter.

Remarks

This method can protect worksheet in all versions of Excel file.

Example

[C#]

//Creating a file stream containing the Excel file to be opened
FileStream fstream = new FileStream("C:\\book1.xls", FileMode.Open);
//Instantiating a Workbook object and Opening the Excel file through the file stream
Workbook excel = new Workbook(fstream);
//Accessing the first worksheet in the Excel file
Worksheet worksheet = excel.Worksheets[0];
//Protecting the worksheet with a password
worksheet.Protect(ProtectionType.All, "aspose", null);
//Saving the modified Excel file in default (that is Excel 20003) format
excel.Save("C:\\output.xls");
//Closing the file stream to free all resources
fstream.Close();

[Visual Basic]

'Creating a file stream containing the Excel file to be opened
Dim fstream As FileStream = New FileStream("C:\\book1.xls", FileMode.Open)
'Instantiating a Workbook object and Opening the Excel file through the file stream
Dim excel As Workbook = New Workbook(fstream)
'Accessing the first worksheet in the Excel file
Dim worksheet As Worksheet = excel.Worksheets(0)
'Protecting the worksheet with a password
worksheet.Protect(ProtectionType.All, "aspose", DBNull.Value.ToString())
'Saving the modified Excel file in default (that is Excel 20003) format
excel.Save("C:\\output.xls")
'Closing the file stream to free all resources
fstream.Close()

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.Protect Overload List


Worksheet.RefreshPivotTables Method

Refreshes all the PivotTables in this Worksheet.

public void RefreshPivotTables();

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.RemoveAllDrawingObjects Method

Removes all drawing objects in this worksheet.

public void RemoveAllDrawingObjects();

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.RemoveAutoFilter Method

Removes the auto filter of the worksheet.

public void RemoveAutoFilter();

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.RemoveSplit Method

Removes split window.

public void RemoveSplit();

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.Replace Method

Replaces all cells' text with a new string.

public int Replace(
string oldString,
string newString
);

Parameters

oldString
Old string value.
newString
New string value.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.SelectRange Method

Selects a range.

public void SelectRange(
int startRow,
int startColumn,
int totalRows,
int totalColumns,
bool removeOthers
);

Parameters

startRow
The start row.
startColumn
The start column
totalRows
The number of rows.
totalColumns
The number of columns
removeOthers
True means removing other selected range and only select this range.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.SetBackground Method

NOTE: This method is now obsolete.

Use Worksheet.BackgroundImage property instead.

Sets worksheet background image.

public void SetBackground(
byte[] pictureData
);

Parameters

pictureData
Picture data.

Remarks

NOTE: This member is now obsolete. Instead, please use Worksheet.BackgroundImage property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.SetVisible Method

Sets the visible options.

public void SetVisible(
bool isVisible,
bool ignoreError
);

Parameters

isVisible
Whether the worksheet is visible
ignoreError
Whether to ignore error if this option is not valid.

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.Split Method

Splits window.

public void Split();

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.ToString Method

Returns a string represents the current Worksheet object.

new public string ToString();

Return Value

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.UnFreezePanes Method

Unfreezes panes in the worksheet.

public void UnFreezePanes();

See Also

Worksheet Class | Aspose.Cells Namespace


Unprotect Method

Aspose.Cells for .NET

Worksheet.Unprotect Method

Unprotects worksheet.

Overload List

Unprotects worksheet.

public void Unprotect();

Unprotects worksheet.

public void Unprotect(string);

See Also

Worksheet Class | Aspose.Cells Namespace


Worksheet.Unprotect Method ()

Unprotects worksheet.

public void Unprotect();

Remarks

This method unprotects worksheet which is protected without password.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.Unprotect Overload List


Worksheet.Unprotect Method (String)

Unprotects worksheet.

public void Unprotect(
string password
);

Parameters

password
Password

Remarks

If the worksheet is protected without a password, you can set a null value or blank string to password parameter.

See Also

Worksheet Class | Aspose.Cells Namespace | Worksheet.Unprotect Overload List


Worksheet.XmlMapQuery Method

Query cell areas that mapped/linked to the specific path of xml map.

public ArrayList XmlMapQuery(
string path,
XmlMap xmlMap
);

Parameters

path
xml element path
xmlMap
Specify an xml map if you want to query for the specific path within a specific map

Return Value

CellArea list that mapped/linked to the specific path of xml map, an empty list is returned if nothing is mapped/linked.

See Also

Worksheet Class | Aspose.Cells Namespace


WorksheetCollection Class

Encapsulates a collection of Worksheet objects.

For a list of all members of this type, see WorksheetCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.WorksheetCollection

public class WorksheetCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Workbook workbook = new Workbook();

WorksheetCollection sheets = workbook.Worksheets;

//Add a worksheet
sheets.Add();

//Change the name of a worksheet
sheets[0].Name = "First Sheet";

//Set the active sheet to the second worksheet
sheets.SetActiveSheet(1);

[Visual Basic]

Dim excel as Workbook = new Workbook()

Dim sheets as WorksheetCollection = excel.Worksheets

'Add a worksheet
sheets.Add()

'Change the name of a worksheet
sheets(0).Name = "First Sheet"

'Set the active sheet to the second worksheet
sheets.SetActiveSheet(1)

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WorksheetCollection Members | Aspose.Cells Namespace


WorksheetCollection Members

WorksheetCollection overview

Public Instance Properties

ActiveSheetIndex | Represents the index of active worksheet when the spreadsheet is opened.
BuiltInDocumentProperties | Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.
Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
CustomDocumentProperties | Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.
Dxfs | Gets the master differential formatting records.
ExternalLinks | Represents external links in a workbook.
IsRefreshAllConnections | Indicates whether refresh all connections on opening file in MS Excel.
Item | Overloaded. Gets the Worksheet element at the specified index.
Names | Gets the collection of all the Name objects in the spreadsheet.
OleSize | Gets and Sets displayed size when Workbook file is used as an Ole object.
RevisionLogs | Represents revision logs.
TableStyles | Gets TableStyles object.
ThreadedCommentAuthors | Gets the list of threaded comment authors.
WebExtensions | Gets the list of task panes.
WebExtensionTaskPanes | Gets the list of task panes.
XmlMaps | Gets and sets the XML maps in the workbook.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
Clear | Clear all worksheets.
ClearPivottables | Clears pivot tables from the spreadsheet.
CreateRange | Creates a Range object from an address of the range.
CreateUnionRange | Creates a Range object from an address of the range.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetNamedRanges | Gets all pre-defined named ranges in the spreadsheet.
GetNamedRangesAndTables | Gets all pre-defined named ranges in the spreadsheet.
GetRangeByName | Gets Range object by pre-defined name.
GetSheetByCodeName | Gets the worksheet by the code name.
GetType (inherited from Object) |
Insert | Overloaded. Insert a worksheet.
RefreshPivotTables | Refreshes all the PivotTables in the WorksheetCollection.
RegisterAddInFunction | Overloaded. Adds addin function into the workbook
RemoveAt | Overloaded. Removes the element at a specified name.
SetOleSize | Sets displayed size when Workbook file is used as an Ole object.
SortNames | Sorts the defined names.
SwapSheet | Swaps the two sheets.
ToString (inherited from Object) |

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection Properties

The properties of the WorksheetCollection class are listed below. For a complete list of WorksheetCollection class members, see the WorksheetCollection Members topic.

Public Instance Properties

ActiveSheetIndex | Represents the index of active worksheet when the spreadsheet is opened.
BuiltInDocumentProperties | Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.
Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
CustomDocumentProperties | Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.
Dxfs | Gets the master differential formatting records.
ExternalLinks | Represents external links in a workbook.
IsRefreshAllConnections | Indicates whether refresh all connections on opening file in MS Excel.
Item | Overloaded. Gets the Worksheet element at the specified index.
Names | Gets the collection of all the Name objects in the spreadsheet.
OleSize | Gets and Sets displayed size when Workbook file is used as an Ole object.
RevisionLogs | Represents revision logs.
TableStyles | Gets TableStyles object.
ThreadedCommentAuthors | Gets the list of threaded comment authors.
WebExtensions | Gets the list of task panes.
WebExtensionTaskPanes | Gets the list of task panes.
XmlMaps | Gets and sets the XML maps in the workbook.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


ActiveSheetIndex Property

Aspose.Cells for .NET

WorksheetCollection.ActiveSheetIndex Property

Represents the index of active worksheet when the spreadsheet is opened.

public int ActiveSheetIndex {get; set;}

Remarks

Sheet index is zero based.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


BuiltInDocumentProperties Property

Aspose.Cells for .NET

WorksheetCollection.BuiltInDocumentProperties Property

Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.

public BuiltInDocumentPropertyCollection BuiltInDocumentProperties {get;}

Remarks

A new property cannot be added to built-in document properties list. You can only get a built-in property and change its value. The following is the built-in properties name list:

Title

Subject

Author

Keywords

Comments

Template

Last Author

Revision Number

Application Name

Last Print Date

Creation Date

Last Save Time

Total Editing Time

Number of Pages

Number of Words

Number of Characters

Security

Category

Format

Manager

Company

Number of Bytes

Number of Lines

Number of Paragraphs

Number of Slides

Number of Notes

Number of Hidden Slides

Number of Multimedia Clips

Example

[C#]
DocumentProperty doc = workbook.Worksheets.BuiltInDocumentProperties["Author"];
doc.Value = "John Smith";

[Visual Basic]
Dim doc as DocumentProperty = workbook.Worksheets.BuiltInDocumentProperties("Author")
doc.Value = "John Smith"

See Also

WorksheetCollection Class | Aspose.Cells Namespace


CustomDocumentProperties Property

Aspose.Cells for .NET

WorksheetCollection.CustomDocumentProperties Property

Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.

public CustomDocumentPropertyCollection CustomDocumentProperties {get;}

Example

[C#]
excel.Worksheets.CustomDocumentProperties.Add("Checked by", "Jane");

[Visual Basic]
excel.Worksheets.CustomDocumentProperties.Add("Checked by", "Jane")

See Also

WorksheetCollection Class | Aspose.Cells Namespace


Dxfs Property

Aspose.Cells for .NET

WorksheetCollection.Dxfs Property

Gets the master differential formatting records.

public DxfCollection Dxfs {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


ExternalLinks Property

Aspose.Cells for .NET

WorksheetCollection.ExternalLinks Property

Represents external links in a workbook.

public ExternalLinkCollection ExternalLinks {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


IsRefreshAllConnections Property

Aspose.Cells for .NET

WorksheetCollection.IsRefreshAllConnections Property

Indicates whether refresh all connections on opening file in MS Excel.

public bool IsRefreshAllConnections {get; set;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

WorksheetCollection.Item Property

Gets the Worksheet element at the specified index.

Overload List

Gets the Worksheet element at the specified index.

public Worksheet this[int] {get;}

Gets the Worksheet element with the specified name.

public Worksheet this[string] {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


Item Property (Int32)

Aspose.Cells for .NET

WorksheetCollection.Item Property (Int32)

Gets the Worksheet element at the specified index.

public Worksheet this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

WorksheetCollection.Item Property (String)

Gets the Worksheet element with the specified name.

public Worksheet this[
string sheetName
] {get;}

Parameters

sheetName
Worksheet name

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Item Overload List


Names Property

Aspose.Cells for .NET

WorksheetCollection.Names Property

Gets the collection of all the Name objects in the spreadsheet.

public NameCollection Names {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


OleSize Property

Aspose.Cells for .NET

WorksheetCollection.OleSize Property

Gets and Sets displayed size when Workbook file is used as an Ole object.

public object OleSize {get; set;}

Remarks

Null means no ole size setting.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


RevisionLogs Property

Aspose.Cells for .NET

WorksheetCollection.RevisionLogs Property

Represents revision logs.

public RevisionLogCollection RevisionLogs {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


TableStyles Property

Aspose.Cells for .NET

WorksheetCollection.TableStyles Property

Gets TableStyles object.

public TableStyleCollection TableStyles {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


ThreadedCommentAuthors Property

Aspose.Cells for .NET

WorksheetCollection.ThreadedCommentAuthors Property

Gets the list of threaded comment authors.

public ThreadedCommentAuthorCollection ThreadedCommentAuthors {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WebExtensions Property

Aspose.Cells for .NET

WorksheetCollection.WebExtensions Property

Gets the list of task panes.

public WebExtensionCollection WebExtensions {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WebExtensionTaskPanes Property

Aspose.Cells for .NET

WorksheetCollection.WebExtensionTaskPanes Property

Gets the list of task panes.

public WebExtensionTaskPaneCollection WebExtensionTaskPanes {get;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


XmlMaps Property

Aspose.Cells for .NET

WorksheetCollection.XmlMaps Property

Gets and sets the XML maps in the workbook.

public XmlMapCollection XmlMaps {get; set;}

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection Methods

The methods of the WorksheetCollection class are listed below. For a complete list of WorksheetCollection class members, see the WorksheetCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
Clear | Clear all worksheets.
ClearPivottables | Clears pivot tables from the spreadsheet.
CreateRange | Creates a Range object from an address of the range.
CreateUnionRange | Creates a Range object from an address of the range.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetNamedRanges | Gets all pre-defined named ranges in the spreadsheet.
GetNamedRangesAndTables | Gets all pre-defined named ranges in the spreadsheet.
GetRangeByName | Gets Range object by pre-defined name.
GetSheetByCodeName | Gets the worksheet by the code name.
GetType (inherited from Object) |
Insert | Overloaded. Insert a worksheet.
RefreshPivotTables | Refreshes all the PivotTables in the WorksheetCollection.
RegisterAddInFunction | Overloaded. Adds addin function into the workbook
RemoveAt | Overloaded. Removes the element at a specified name.
SetOleSize | Sets displayed size when Workbook file is used as an Ole object.
SortNames | Sorts the defined names.
SwapSheet | Swaps the two sheets.
ToString (inherited from Object) |

See Also

WorksheetCollection Class | Aspose.Cells Namespace


Add Method

Aspose.Cells for .NET

WorksheetCollection.Add Method

Adds a worksheet to the collection.

Overload List

Adds a worksheet to the collection.

public int Add();

Adds a worksheet to the collection.

public int Add(SheetType);

Adds a worksheet to the collection.

public Worksheet Add(string);

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.Add Method ()

Adds a worksheet to the collection.

public int Add();

Return Value

Worksheet object index.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Add Overload List


WorksheetCollection.Add Method (SheetType)

Adds a worksheet to the collection.

public int Add(
SheetType type
);

Parameters

type
Worksheet type.

Return Value

Worksheet object index.

Example

[C#]
Workbook workbook = new Workbook();
workbook.Worksheets.Add(SheetType.Chart);
Cells cells = workbook.Worksheets[0].Cells;
cells["c2"].PutValue(5000);
cells["c3"].PutValue(3000);
cells["c4"].PutValue(4000);
cells["c5"].PutValue(5000);
cells["c6"].PutValue(6000);
Charts charts = workbook.Worksheets[1].Charts;
int chartIndex = charts.Add(ChartType.Column, 10,10,20,20);
Chart chart = charts[chartIndex];
chart.NSeries.Add("Sheet1!C2:C6", true);

[Visual Basic]
Dim workbook As Workbook =  New Workbook()
workbook.Worksheets.Add(SheetType.Chart)
Dim cells As Cells = workbook.Worksheets(0).Cells
cells("c2").PutValue(5000)
cells("c3").PutValue(3000)
cells("c4").PutValue(4000)
cells("c5").PutValue(5000)
cells("c6").PutValue(6000)
Dim charts As Charts = workbook.Worksheets(1).Charts
Dim chartIndex As Integer = charts.Add(ChartType.Column,10,10,20,20)
Dim chart As Chart = charts(chartIndex)
chart.NSeries.Add("Sheet1!C2:C6", True)

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Add Overload List


WorksheetCollection.Add Method (String)

Adds a worksheet to the collection.

public Worksheet Add(
string sheetName
);

Parameters

sheetName
Worksheet name

Return Value

Worksheet object.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Add Overload List


AddCopy Method

Aspose.Cells for .NET

WorksheetCollection.AddCopy Method

Adds a worksheet to the collection and copies data from an existed worksheet.

Overload List

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(int);

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(string);

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.AddCopy Method (Int32)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
int sheetIndex
);

Parameters

sheetIndex
Index of source worksheet.

Return Value

Worksheet object index.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.AddCopy Overload List


WorksheetCollection.AddCopy Method (String)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
string sheetName
);

Parameters

sheetName
Name of source worksheet.

Return Value

Worksheet object index.

Exceptions

Exception Type | Condition
CellsException | Specifies an invalid worksheet name.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.AddCopy Overload List


WorksheetCollection.Clear Method

Clear all worksheets.

new public void Clear();

Implements

IList.Clear

Remarks

A workbook must contains a worksheet.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.ClearPivottables Method

Clears pivot tables from the spreadsheet.

public void ClearPivottables();

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.CreateRange Method

Creates a Range object from an address of the range.

public Range CreateRange(
string address,
int sheetIndex
);

Parameters

address
The address of the range.
sheetIndex
The sheet index.

Return Value

A Range object

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.CreateUnionRange Method

Creates a Range object from an address of the range.

public UnionRange CreateUnionRange(
string address,
int sheetIndex
);

Parameters

address
The address of the range.
sheetIndex
The sheet index.

Return Value

A Range object

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.GetNamedRanges Method

Gets all pre-defined named ranges in the spreadsheet.

public Range[] GetNamedRanges();

Return Value

An array of Range objects. If the defined Name's reference is external or has multiple ranges, no Range object will be returned for this Name.

Returns null if the named range does not exist.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.GetNamedRangesAndTables Method

Gets all pre-defined named ranges in the spreadsheet.

public Range[] GetNamedRangesAndTables();

Return Value

An array of Range objects.

Returns null if the named range does not exist.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.GetRangeByName Method

Gets Range object by pre-defined name.

public Range GetRangeByName(
string rangeName
);

Parameters

rangeName
Name of range.

Return Value

Range object.

Returns null if the named range does not exist.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.GetSheetByCodeName Method

Gets the worksheet by the code name.

public Worksheet GetSheetByCodeName(
string codeName
);

Parameters

codeName
Worksheet code name.

Return Value

The element with the specified code name.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


Insert Method

Aspose.Cells for .NET

WorksheetCollection.Insert Method

Insert a worksheet.

Overload List

Insert a worksheet.

public Worksheet Insert(int,SheetType);

Insert a worksheet.

public Worksheet Insert(int,SheetType,string);

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.Insert Method (Int32, SheetType)

Insert a worksheet.

public Worksheet Insert(
int index,
SheetType sheetType
);

Parameters

index
The sheet index
sheetType
The sheet type.

Return Value

Returns an inserted worksheet.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Insert Overload List


WorksheetCollection.Insert Method (Int32, SheetType, String)

Insert a worksheet.

public Worksheet Insert(
int index,
SheetType sheetType,
string sheetName
);

Parameters

index
The sheet index
sheetType
The sheet type.
sheetName
The sheet name.

Return Value

Returns an inserted worksheet.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.Insert Overload List


WorksheetCollection.RefreshPivotTables Method

Refreshes all the PivotTables in the WorksheetCollection.

public void RefreshPivotTables();

See Also

WorksheetCollection Class | Aspose.Cells Namespace


RegisterAddInFunction Method

Aspose.Cells for .NET

WorksheetCollection.RegisterAddInFunction Method

Adds addin function into the workbook

Overload List

Adds addin function into the workbook

public string RegisterAddInFunction(int,string);

Adds addin function into the workbook

public int RegisterAddInFunction(string,string,bool);

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.RegisterAddInFunction Method (Int32, String)

Adds addin function into the workbook

public string RegisterAddInFunction(
int id,
string functionName
);

Parameters

id
ID of the data which contains addin functions, can be got by the first call of RegisterAddInFunction for the same addin file.
functionName
the addin function name

Return Value

URL of the addin file which contains addin functions

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.RegisterAddInFunction Overload List


WorksheetCollection.RegisterAddInFunction Method (String, String, Boolean)

Adds addin function into the workbook

public int RegisterAddInFunction(
string addInFile,
string functionName,
bool lib
);

Parameters

addInFile
the file contains the addin functions
functionName
the addin function name
lib
whether the given addin file is in the directory or sub-directory of Workbook Add-In library. This flag takes effect and makes difference when given addInFile is of relative path: true denotes the path is relative to Add-In library and false denotes the path is relative to this Workbook.

Return Value

ID of the data which contains given addin function

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.RegisterAddInFunction Overload List


RemoveAt Method

Aspose.Cells for .NET

WorksheetCollection.RemoveAt Method

Removes the element at a specified index.

Overload List

Removes the element at a specified index.

new public void RemoveAt(int);

Removes the element at a specified name.

public void RemoveAt(string);

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.RemoveAt Method (Int32)

Removes the element at a specified index.

new public void RemoveAt(
int index
);

Parameters

index
The index value of the element to remove.

Implements

IList.RemoveAt

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.RemoveAt Overload List


WorksheetCollection.RemoveAt Method (String)

Removes the element at a specified name.

public void RemoveAt(
string name
);

Parameters

name
The name of the element to remove.

See Also

WorksheetCollection Class | Aspose.Cells Namespace | WorksheetCollection.RemoveAt Overload List


WorksheetCollection.SetOleSize Method

Sets displayed size when Workbook file is used as an Ole object.

public void SetOleSize(
int startRow,
int endRow,
int startColumn,
int endColumn
);

Parameters

startRow
Start row index.
endRow
End row index.
startColumn
Start column index.
endColumn
End column index.

Remarks

This method is generally used to adjust display size in ppt file or doc file.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.SortNames Method

Sorts the defined names.

public void SortNames();

Remarks

If you create a large amount of named ranges in the Excel file, please call this method after all named ranges are created and before saving

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WorksheetCollection.SwapSheet Method

Swaps the two sheets.

public void SwapSheet(
int sheetIndex1,
int sheetIndex2
);

Parameters

sheetIndex1
The first worksheet.
sheetIndex2
The second worksheet.

See Also

WorksheetCollection Class | Aspose.Cells Namespace


WriteProtection Class

Specifies write protection settings for a workbook.

For a list of all members of this type, see WriteProtection Members.

System.Object
Aspose.Cells.WriteProtection

public class WriteProtection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WriteProtection Members | Aspose.Cells Namespace


WriteProtection Members

WriteProtection overview

Public Instance Constructors

WriteProtection Constructor Initializes a new instance of the WriteProtection class.

Public Instance Properties

Author | Gets and sets the author.
IsWriteProtected | Indicates whether this workbook is write protected.
Password | Sets the protected password to modify the file.
RecommendReadOnly | Indicates if the Read Only Recommended option is selected.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |
ValidatePassword | Returns true if the specified password is the same as the write-protection password the file was protected with.

See Also

WriteProtection Class | Aspose.Cells Namespace


WriteProtection Constructor

Initializes a new instance of the WriteProtection class.

public WriteProtection();

See Also

WriteProtection Class | Aspose.Cells Namespace


WriteProtection Properties

The properties of the WriteProtection class are listed below. For a complete list of WriteProtection class members, see the WriteProtection Members topic.

Public Instance Properties

Author | Gets and sets the author.
IsWriteProtected | Indicates whether this workbook is write protected.
Password | Sets the protected password to modify the file.
RecommendReadOnly | Indicates if the Read Only Recommended option is selected.

See Also

WriteProtection Class | Aspose.Cells Namespace


Author Property

Aspose.Cells for .NET

WriteProtection.Author Property

Gets and sets the author.

public string Author {get; set;}

See Also

WriteProtection Class | Aspose.Cells Namespace


IsWriteProtected Property

Aspose.Cells for .NET

WriteProtection.IsWriteProtected Property

Indicates whether this workbook is write protected.

public bool IsWriteProtected {get;}

See Also

WriteProtection Class | Aspose.Cells Namespace


Password Property

Aspose.Cells for .NET

WriteProtection.Password Property

Sets the protected password to modify the file.

public string Password {set;}

See Also

WriteProtection Class | Aspose.Cells Namespace


RecommendReadOnly Property

Aspose.Cells for .NET

WriteProtection.RecommendReadOnly Property

Indicates if the Read Only Recommended option is selected.

public bool RecommendReadOnly {get; set;}

See Also

WriteProtection Class | Aspose.Cells Namespace


WriteProtection Methods

The methods of the WriteProtection class are listed below. For a complete list of WriteProtection class members, see the WriteProtection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |
ValidatePassword | Returns true if the specified password is the same as the write-protection password the file was protected with.

See Also

WriteProtection Class | Aspose.Cells Namespace


WriteProtection.ValidatePassword Method

Returns true if the specified password is the same as the write-protection password the file was protected with.

public bool ValidatePassword(
string password
);

Parameters

password
The specified password.

Return Value

See Also

WriteProtection Class | Aspose.Cells Namespace


XlsbSaveOptions Class

Represents the options for saving xlsb file.

For a list of all members of this type, see XlsbSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.XlsbSaveOptions

public class XlsbSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XlsbSaveOptions Members | Aspose.Cells Namespace


XlsbSaveOptions Members

XlsbSaveOptions overview

Public Instance Constructors

XlsbSaveOptions Overloaded. Initializes a new instance of the XlsbSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CompressionType | Gets and sets the compression type for ooxml file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ExportAllColumnIndexes | Indicates whether exporting all column indexes for cells.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace


XlsbSaveOptions Constructor

Creates xlsb file save options.

Overload List

Creates xlsb file save options.

public XlsbSaveOptions();

Creates xlsb file save options.

public XlsbSaveOptions(SaveFormat);

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace


XlsbSaveOptions Constructor ()

Creates xlsb file save options.

public XlsbSaveOptions();

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace | XlsbSaveOptions Constructor Overload List


XlsbSaveOptions Constructor (SaveFormat)

Creates xlsb file save options.

public XlsbSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The save format . It must be xlsb.

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace | XlsbSaveOptions Constructor Overload List


XlsbSaveOptions Properties

The properties of the XlsbSaveOptions class are listed below. For a complete list of XlsbSaveOptions class members, see the XlsbSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CompressionType | Gets and sets the compression type for ooxml file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
ExportAllColumnIndexes | Indicates whether exporting all column indexes for cells.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace


CompressionType Property

Aspose.Cells for .NET

XlsbSaveOptions.CompressionType Property

Gets and sets the compression type for ooxml file.

public OoxmlCompressionType CompressionType {get; set;}

Remarks

The default value is OoxmlCompressionType.Level6.

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace


ExportAllColumnIndexes Property

Aspose.Cells for .NET

XlsbSaveOptions.ExportAllColumnIndexes Property

Indicates whether exporting all column indexes for cells.

public bool ExportAllColumnIndexes {get; set;}

Remarks

The default value is true.

See Also

XlsbSaveOptions Class | Aspose.Cells Namespace


XlsSaveOptions Class

Represents the save options for the Excel 97-2003 file format: xls and xlt.

For a list of all members of this type, see XlsSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.XlsSaveOptions

public class XlsSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XlsSaveOptions Members | Aspose.Cells Namespace


XlsSaveOptions Members

XlsSaveOptions overview

Public Instance Constructors

XlsSaveOptions Overloaded. Initializes a new instance of the XlsSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
IsTemplate | Indicates whether saving a template file.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
MatchColor | Indicates whether matching font color because there are 56 colors in the standard color palette.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

XlsSaveOptions Class | Aspose.Cells Namespace


XlsSaveOptions Constructor

Creates options for saving Excel 97-2003 xls/xlt file.

Overload List

Creates options for saving Excel 97-2003 xls/xlt file.

public XlsSaveOptions();

Creates options for saving Excel 97-2003 xls/xlt file.

public XlsSaveOptions(SaveFormat);

See Also

XlsSaveOptions Class | Aspose.Cells Namespace


XlsSaveOptions Constructor ()

Creates options for saving Excel 97-2003 xls/xlt file.

public XlsSaveOptions();

See Also

XlsSaveOptions Class | Aspose.Cells Namespace | XlsSaveOptions Constructor Overload List


XlsSaveOptions Constructor (SaveFormat)

Creates options for saving Excel 97-2003 xls/xlt file.

public XlsSaveOptions(
SaveFormat format
);

Parameters

format
The file format. It must be xls/xlt.

See Also

XlsSaveOptions Class | Aspose.Cells Namespace | XlsSaveOptions Constructor Overload List


XlsSaveOptions Properties

The properties of the XlsSaveOptions class are listed below. For a complete list of XlsSaveOptions class members, see the XlsSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
IsTemplate | Indicates whether saving a template file.
LightCellsDataProvider | The Data provider to provide cells data for saving workbook in light mode.
MatchColor | Indicates whether matching font color because there are 56 colors in the standard color palette.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

XlsSaveOptions Class | Aspose.Cells Namespace


IsTemplate Property

Aspose.Cells for .NET

XlsSaveOptions.IsTemplate Property

Indicates whether saving a template file.

public bool IsTemplate {get; set;}

See Also

XlsSaveOptions Class | Aspose.Cells Namespace


LightCellsDataProvider Property

Aspose.Cells for .NET

XlsSaveOptions.LightCellsDataProvider Property

The Data provider to provide cells data for saving workbook in light mode.

public LightCellsDataProvider LightCellsDataProvider {get; set;}

See Also

XlsSaveOptions Class | Aspose.Cells Namespace


MatchColor Property

Aspose.Cells for .NET

XlsSaveOptions.MatchColor Property

Indicates whether matching font color because there are 56 colors in the standard color palette.

public bool MatchColor {get; set;}

See Also

XlsSaveOptions Class | Aspose.Cells Namespace


XmlColumnProperty Class

Represents Xml Data Binding information.

For a list of all members of this type, see XmlColumnProperty Members.

System.Object
Aspose.Cells.XmlColumnProperty

public class XmlColumnProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XmlColumnProperty Members | Aspose.Cells Namespace


XmlColumnProperty Members

XmlColumnProperty overview

Public Instance Constructors

XmlColumnProperty Constructor Initializes a new instance of the XmlColumnProperty class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

XmlColumnProperty Class | Aspose.Cells Namespace


XmlColumnProperty Constructor

Initializes a new instance of the XmlColumnProperty class.

public XmlColumnProperty();

See Also

XmlColumnProperty Class | Aspose.Cells Namespace


XmlDataBinding Class

Represents Xml Data Binding information.

For a list of all members of this type, see XmlDataBinding Members.

System.Object
Aspose.Cells.XmlDataBinding

public class XmlDataBinding

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XmlDataBinding Members | Aspose.Cells Namespace


XmlDataBinding Members

XmlDataBinding overview

Public Instance Properties

Url Gets source url of this data binding.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

XmlDataBinding Class | Aspose.Cells Namespace


XmlDataBinding Properties

The properties of the XmlDataBinding class are listed below. For a complete list of XmlDataBinding class members, see the XmlDataBinding Members topic.

Public Instance Properties

Url Gets source url of this data binding.

See Also

XmlDataBinding Class | Aspose.Cells Namespace


Url Property

Aspose.Cells for .NET

XmlDataBinding.Url Property

Gets source url of this data binding.

public string Url {get;}

See Also

XmlDataBinding Class | Aspose.Cells Namespace


XmlMap Class

Represents Xml map information.

For a list of all members of this type, see XmlMap Members.

System.Object
Aspose.Cells.XmlMap

public class XmlMap

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XmlMap Members | Aspose.Cells Namespace


XmlMap Members

XmlMap overview

Public Instance Properties

DataBinding | Gets an XmlDataBinding of this map.
Name | Returns or sets the name of the object.
RootElementName | Gets root element name.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

XmlMap Class | Aspose.Cells Namespace


XmlMap Properties

The properties of the XmlMap class are listed below. For a complete list of XmlMap class members, see the XmlMap Members topic.

Public Instance Properties

DataBinding | Gets an XmlDataBinding of this map.
Name | Returns or sets the name of the object.
RootElementName | Gets root element name.

See Also

XmlMap Class | Aspose.Cells Namespace


DataBinding Property

Aspose.Cells for .NET

XmlMap.DataBinding Property

Gets an XmlDataBinding of this map.

public XmlDataBinding DataBinding {get;}

See Also

XmlMap Class | Aspose.Cells Namespace


Name Property

Aspose.Cells for .NET

XmlMap.Name Property

Returns or sets the name of the object.

public string Name {get; set;}

See Also

XmlMap Class | Aspose.Cells Namespace


RootElementName Property

Aspose.Cells for .NET

XmlMap.RootElementName Property

Gets root element name.

public string RootElementName {get;}

See Also

XmlMap Class | Aspose.Cells Namespace


XmlMapCollection Class

A collection of XmlMap objects that represent XmlMap information.

For a list of all members of this type, see XmlMapCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.XmlMapCollection

public class XmlMapCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XmlMapCollection Members | Aspose.Cells Namespace


XmlMapCollection Members

XmlMapCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the xml map by the specific index.

Public Instance Methods

Add | Add a XmlMap by the url/path of a xml file.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

XmlMapCollection Class | Aspose.Cells Namespace


XmlMapCollection Properties

The properties of the XmlMapCollection class are listed below. For a complete list of XmlMapCollection class members, see the XmlMapCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the xml map by the specific index.

See Also

XmlMapCollection Class | Aspose.Cells Namespace


Item Property

Aspose.Cells for .NET

XmlMapCollection.Item Property

Gets the xml map by the specific index.

public XmlMap this[
int index
] {get;}

Parameters

index
The index.

See Also

XmlMapCollection Class | Aspose.Cells Namespace


XmlMapCollection Methods

The methods of the XmlMapCollection class are listed below. For a complete list of XmlMapCollection class members, see the XmlMapCollection Members topic.

Public Instance Methods

Add | Add a XmlMap by the url/path of a xml file.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

XmlMapCollection Class | Aspose.Cells Namespace


XmlMapCollection.Add Method

Add a XmlMap by the url/path of a xml file.

public int Add(
string url
);

Parameters

url
url/path of a xml file.

Return Value

XmlMap object index.

See Also

XmlMapCollection Class | Aspose.Cells Namespace


XpsSaveOptions Class

Represents the additional options when saving the file as the Xps.

For a list of all members of this type, see XpsSaveOptions Members.

System.Object
Aspose.Cells.SaveOptions
Aspose.Cells.XpsSaveOptions

public class XpsSaveOptions : SaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

XpsSaveOptions Members | Aspose.Cells Namespace


XpsSaveOptions Members

XpsSaveOptions overview

Public Instance Constructors

XpsSaveOptions Overloaded. Initializes a new instance of the XpsSaveOptions class.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
OnePagePerSheet | If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
PageCount | Gets or sets the number of pages to save.
PageIndex | Gets or sets the 0-based index of the first page to save.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

XpsSaveOptions Class | Aspose.Cells Namespace


XpsSaveOptions Constructor

Creates options for saving xps file.

Overload List

Creates options for saving xps file.

public XpsSaveOptions();

Creates options for saving xps file.

public XpsSaveOptions(SaveFormat);

See Also

XpsSaveOptions Class | Aspose.Cells Namespace


XpsSaveOptions Constructor ()

Creates options for saving xps file.

public XpsSaveOptions();

See Also

XpsSaveOptions Class | Aspose.Cells Namespace | XpsSaveOptions Constructor Overload List


XpsSaveOptions Constructor (SaveFormat)

Creates options for saving xps file.

public XpsSaveOptions(
SaveFormat saveFormat
);

Parameters

saveFormat
The save format, it must be xps format.

See Also

XpsSaveOptions Class | Aspose.Cells Namespace | XpsSaveOptions Constructor Overload List


XpsSaveOptions Properties

The properties of the XpsSaveOptions class are listed below. For a complete list of XpsSaveOptions class members, see the XpsSaveOptions Members topic.

Public Instance Properties

CachedFileFolder (inherited from SaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from SaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from SaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
EnableHTTPCompression (inherited from SaveOptions) | Obsolete. Indicates if http compression is to be used in user's IIS.
MergeAreas (inherited from SaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
OnePagePerSheet | If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
PageCount | Gets or sets the number of pages to save.
PageIndex | Gets or sets the 0-based index of the first page to save.
PdfExportImagesFolder (inherited from SaveOptions) | Obsolete. The physical folder where images will be saved when exporting a workbook to Aspose.Pdf XML format. Default is an empty string.
RefreshChartCache (inherited from SaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from SaveOptions) | Gets the save file format.
SortNames (inherited from SaveOptions) | Indicates whether sorting defined names before saving file.
UpdateSmartArt (inherited from SaveOptions) | Indicates whether updating smart art setting. The default value is false.
ValidateMergedAreas (inherited from SaveOptions) | Indicates whether validate merged cells before saving the file.
WarningCallback (inherited from SaveOptions) | Gets or sets warning callback.

See Also

XpsSaveOptions Class | Aspose.Cells Namespace


OnePagePerSheet Property

Aspose.Cells for .NET

XpsSaveOptions.OnePagePerSheet Property

If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.

public bool OnePagePerSheet {get; set;}

See Also

XpsSaveOptions Class | Aspose.Cells Namespace


PageCount Property

Aspose.Cells for .NET

XpsSaveOptions.PageCount Property

Gets or sets the number of pages to save.

public int PageCount {get; set;}

Remarks

Default is System.Int32.MaxValue which means all pages will be rendered..

See Also

XpsSaveOptions Class | Aspose.Cells Namespace


PageIndex Property

Aspose.Cells for .NET

XpsSaveOptions.PageIndex Property

Gets or sets the 0-based index of the first page to save.

public int PageIndex {get; set;}

Remarks

Default is 0.

See Also

XpsSaveOptions Class | Aspose.Cells Namespace


Aspose.Cells.Charts

Aspose.Cells for .NET

Aspose.Cells.Charts Namespace

Namespace hierarchy

Classes

Class | Description
Axis | Encapsulates the object that represents a chart's axis.
Chart | Encapsulates the object that represents a single Excel chart.
ChartArea | Encapsulates the object that represents the chart area in the worksheet.
ChartCollection | Encapsulates a collection of Chart objects.
ChartDataTable | Represents a chart data table.
ChartFrame | Encapsulates the object that represents the frame object in a chart.
ChartPoint | Represents a single point in a series in a chart.
ChartPointCollection | Represents a collection that contains all the points in one series.
ChartTextFrame | Encapsulates the object that represents the frame object which contains text.
DataLabels | Encapsulates a collection of all the DataLabel objects for the specified Series.
DisplayUnitLabel | Represents the display unit label.
DropBars | Represents the up/down bars in a chart.
ErrorBar | Represents error bar of data series.
Floor | Encapsulates the object that represents the floor of a 3-D chart.
Legend | Encapsulates the object that represents the chart legend.
LegendEntry | Represents a legend entry in a chart legend.
LegendEntryCollection | Represents a collection of all the LegendEntry objects in the specified chart legend.
Marker | Represents the marker in a line chart, scatter chart, or radar chart.
PivotOptions | Represents a complex type that specifies the pivot controls that appear on the chart
PlotArea | Encapsulates the object that represents the plot area in a chart.
Series | Encapsulates the object that represents a single data series in a chart.
SeriesCollection | Encapsulates a collection of Series objects.
SeriesLayoutProperties |
Sparkline | A sparkline represents a tiny chart or graphic in a worksheet cell that provides a visual representation of data.
SparklineCollection | Encapsulates a collection of Sparkline objects.
SparklineGroup | Sparkline is organized into sparkline group. A SparklineGroup contains a variable number of sparkline items. A sparkline group specifies the type, display settings and axis settings for the sparklines.
SparklineGroupCollection | Encapsulates a collection of SparklineGroup objects.
TickLabels | Represents the tick-mark labels associated with tick marks on a chart axis.
Title | Encapsulates the object that represents the title of chart or axis.
Trendline | Represents a trendline in a chart.
TrendlineCollection | Represents a collection of all the Trendline objects for the specified data series.
Walls | Encapsulates the object that represents the walls of a 3-D chart.

Enumerations

Enumeration | Description
AxisType | Represents the axis type.
BackgroundMode | Represents the display mode of the background.
Bar3DShapeType | Represents the shape used with the 3-D bar or column chart.
BubbleSizeRepresents | Represents what the bubble size represents on a bubble chart.
CategoryType | Represents the category axis type.
ChartLineFormattingType | Represents line format type of chart line.
ChartMarkerType | Represents the marker style in a line chart, scatter chart, or radar chart.
ChartSplitType | Represents the way the two sections of either a pie of pie chart or a bar of pie chart are split.
ChartTextDirectionType | Represents the text direction type of the chart.
ChartType | Enumerates all chart types used in Excel.
CrossType | Represents the axis cross type.
DataLabelsSeparatorType | Represents the separator type of DataLabels.
DataLablesSeparatorType | Obsolete. Represents the separator type of DataLabels.
DisplayUnitType | Represents the type of display unit.
ErrorBarDisplayType | Represents error bar display type.
ErrorBarType | Represents error bar amount type.
FormattingType | Represents the type of formatting applied to an Area object or a Line object.
LabelPositionType | Represents data label position type.
LegendPositionType | Enumerates the legend position types.
MapChartLabelLayout | Represents the layout of map chart's labels.
MapChartProjectionType | Represents projection type of the map chart.
MapChartRegionType | Represents the region type of the map chart.
PlotDataByType | Represents the type of data plot by row or column.
PlotEmptyCellsType | Represents all plot empty cells type of a chart.
QuartileCalculationType | Represents quartile calculation methods.
SparklineAxisMinMaxType | Represents the minimum and maximum value types for the sparkline vertical axis.
SparklinePresetStyleType | Represents the preset style types for sparkline.
SparklineType | Represents the sparkline types.
TickLabelPositionType | Represents the position type of tick-mark labels on the specified axis.
TickMarkType | Represents the tick mark type for the specified axis.
TimeUnit | Represents the base unit for the category axis.
TrendlineType | Represents the trendline type.


Axis Class

Encapsulates the object that represents a chart's axis.

For a list of all members of this type, see Axis Members.

System.Object
Aspose.Cells.Charts.Axis

public class Axis

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Excel object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(4);
//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(20);
//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 25, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", true);
//Set the max value of value axis
chart.ValueAxis.MaxValue = 200;
//Set the min value of value axis
chart.ValueAxis.MinValue = 0;
//Set the major unit
chart.ValueAxis.MajorUnit = 25;
//Category(X) axis crosses at the maxinum value.
chart.ValueAxis.Crosses = CrossType.Maximum;
//Set he number of categories or series between tick-mark labels.
chart.CategoryAxis.TickLabelSpacing = 2;
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Excel object
Dim sheetIndex As Int32 = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(4)
'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(20)
'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)
'Adding a chart to the worksheet
Dim chartIndex As Int32 = worksheet.Charts.Add(ChartType.Column, 5, 0, 25, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", True)
'Set the max value of value axis
chart.ValueAxis.MaxValue = 200
'Set the min value of value axis
chart.ValueAxis.MinValue = 0
'Set the major unit
chart.ValueAxis.MajorUnit = 25
'Category(X) axis crosses at the maxinum value.
chart.ValueAxis.Crosses = CrossType.Maximum
'Set he number of categories or series between tick-mark labels.
chart.CategoryAxis.TickLabelSpacing = 2
'Saving the Excel file
workbook.Save("C:\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Axis Members | Aspose.Cells.Charts Namespace


Axis Members

Axis overview

Public Instance Properties

Area | Gets the Area.
AxisBetweenCategories | Represents if the value axis crosses the category axis between categories.
AxisLabels | Gets the labels of the axis after call Chart.Calculate() method.
AxisLine | Gets the appearance of an Axis.
BaseUnitScale | Represents the base unit scale for the category axis.
CategoryType | Represents the category axis type.
CrossAt | Represents the point on the value axis where the category axis crosses it.
CrossType | Represents the CrossType on the specified axis where the other axis crosses.
CustUnit | Specifies a custom value for the display unit.
DisplayUnit | Represents the unit label for the specified axis.
DisplayUnitLabel | Represents a unit label on an axis in the specified chart. Unit labels are useful for charting large values¡ª for example, in the millions or billions.
HasMultiLevelLabels | Indicates whether the labels shall be shown as multi level.
IsAutomaticMajorUnit | Indicates whether the major unit of the axis is automatically assigned.
IsAutomaticMaxValue | Indicates whether the max value is automatically assigned.
IsAutomaticMinorUnit | Indicates whether the minor unit of the axis is automatically assigned.
IsAutomaticMinValue | Indicates whether the min value is automatically assigned.
IsAutoTickLabelSpacing | Indicates whether ticklabel spacing is automatic
IsDisplayUnitLabelShown | Represents if the display unit label is shown on the specified axis.
IsLogarithmic | Represents if the value axis scale type is logarithmic or not.
IsPlotOrderReversed | Represents if Microsoft Excel plots data points from last to first.
IsVisible | Represents if the axis is visible.
LogBase | Represents the logarithmic base. Default value is 10.Only applies for Excel2007.
MajorGridLines | Represents major gridlines on a chart axis.
MajorTickMark | Represents the type of major tick mark for the specified axis.
MajorUnit | Represents the major units for the axis.
MajorUnitScale | Represents the major unit scale for the category axis.
MaxValue | Represents the maximum value on the value axis.
MinorGridLines | Represents minor gridlines on a chart axis.
MinorTickMark | Represents the type of minor tick mark for the specified axis.
MinorUnit | Represents the minor units for the axis.
MinorUnitScale | Represents the major unit scale for the category axis.
MinValue | Represents the minimum value on the value axis.
TickLabelPosition | Represents the position of tick-mark labels on the specified axis.
TickLabels | Returns a TickLabels object that represents the tick-mark labels for the specified axis.
TickLabelSpacing | Represents the number of categories or series between tick-mark labels. Applies only to category and series axes.
TickMarkSpacing | Returns or sets the number of categories or series between tick marks. Applies only to category and series axes.
Title | Gets the axis' title.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Axis Class | Aspose.Cells.Charts Namespace


Axis Properties

The properties of the Axis class are listed below. For a complete list of Axis class members, see the Axis Members topic.

Public Instance Properties

Area | Gets the Area.
AxisBetweenCategories | Represents if the value axis crosses the category axis between categories.
AxisLabels | Gets the labels of the axis after call Chart.Calculate() method.
AxisLine | Gets the appearance of an Axis.
BaseUnitScale | Represents the base unit scale for the category axis.
CategoryType | Represents the category axis type.
CrossAt | Represents the point on the value axis where the category axis crosses it.
CrossType | Represents the CrossType on the specified axis where the other axis crosses.
CustUnit | Specifies a custom value for the display unit.
DisplayUnit | Represents the unit label for the specified axis.
DisplayUnitLabel | Represents a unit label on an axis in the specified chart. Unit labels are useful for charting large values¡ª for example, in the millions or billions.
HasMultiLevelLabels | Indicates whether the labels shall be shown as multi level.
IsAutomaticMajorUnit | Indicates whether the major unit of the axis is automatically assigned.
IsAutomaticMaxValue | Indicates whether the max value is automatically assigned.
IsAutomaticMinorUnit | Indicates whether the minor unit of the axis is automatically assigned.
IsAutomaticMinValue | Indicates whether the min value is automatically assigned.
IsAutoTickLabelSpacing | Indicates whether ticklabel spacing is automatic
IsDisplayUnitLabelShown | Represents if the display unit label is shown on the specified axis.
IsLogarithmic | Represents if the value axis scale type is logarithmic or not.
IsPlotOrderReversed | Represents if Microsoft Excel plots data points from last to first.
IsVisible | Represents if the axis is visible.
LogBase | Represents the logarithmic base. Default value is 10.Only applies for Excel2007.
MajorGridLines | Represents major gridlines on a chart axis.
MajorTickMark | Represents the type of major tick mark for the specified axis.
MajorUnit | Represents the major units for the axis.
MajorUnitScale | Represents the major unit scale for the category axis.
MaxValue | Represents the maximum value on the value axis.
MinorGridLines | Represents minor gridlines on a chart axis.
MinorTickMark | Represents the type of minor tick mark for the specified axis.
MinorUnit | Represents the minor units for the axis.
MinorUnitScale | Represents the major unit scale for the category axis.
MinValue | Represents the minimum value on the value axis.
TickLabelPosition | Represents the position of tick-mark labels on the specified axis.
TickLabels | Returns a TickLabels object that represents the tick-mark labels for the specified axis.
TickLabelSpacing | Represents the number of categories or series between tick-mark labels. Applies only to category and series axes.
TickMarkSpacing | Returns or sets the number of categories or series between tick marks. Applies only to category and series axes.
Title | Gets the axis' title.

See Also

Axis Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

Axis.Area Property

Gets the Area.

public Area Area {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


AxisBetweenCategories Property

Aspose.Cells for .NET

Axis.AxisBetweenCategories Property

Represents if the value axis crosses the category axis between categories.

public bool AxisBetweenCategories {get; set;}

Remarks

This property applies only to category axes, and it doesn't apply to 3-D charts.

See Also

Axis Class | Aspose.Cells.Charts Namespace


AxisLabels Property

Aspose.Cells for .NET

Axis.AxisLabels Property

Gets the labels of the axis after call Chart.Calculate() method.

public ArrayList AxisLabels {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


AxisLine Property

Aspose.Cells for .NET

Axis.AxisLine Property

Gets the appearance of an Axis.

public Line AxisLine {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


BaseUnitScale Property

Aspose.Cells for .NET

Axis.BaseUnitScale Property

Represents the base unit scale for the category axis.

public TimeUnit BaseUnitScale {get; set;}

Remarks

Setting this property only takes effect when the CategoryType property is set to TimeScale.

See Also

Axis Class | Aspose.Cells.Charts Namespace


CategoryType Property

Aspose.Cells for .NET

Axis.CategoryType Property

Represents the category axis type.

public CategoryType CategoryType {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


CrossAt Property

Aspose.Cells for .NET

Axis.CrossAt Property

Represents the point on the value axis where the category axis crosses it.

public double CrossAt {get; set;}

Remarks

The number should be a integer when it applies to category axis. And the value must be between 1 and 31999.

See Also

Axis Class | Aspose.Cells.Charts Namespace


CrossType Property

Aspose.Cells for .NET

Axis.CrossType Property

Represents the CrossType on the specified axis where the other axis crosses.

public CrossType CrossType {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


CustUnit Property

Aspose.Cells for .NET

Axis.CustUnit Property

Specifies a custom value for the display unit.

public int CustUnit {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


DisplayUnit Property

Aspose.Cells for .NET

Axis.DisplayUnit Property

Represents the unit label for the specified axis.

public DisplayUnitType DisplayUnit {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


DisplayUnitLabel Property

Aspose.Cells for .NET

Axis.DisplayUnitLabel Property

Represents a unit label on an axis in the specified chart. Unit labels are useful for charting large values¡ª for example, in the millions or billions.

public DisplayUnitLabel DisplayUnitLabel {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


HasMultiLevelLabels Property

Aspose.Cells for .NET

Axis.HasMultiLevelLabels Property

Indicates whether the labels shall be shown as multi level.

public bool HasMultiLevelLabels {get; set;}

Remarks

Only valid for category axis.

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsAutomaticMajorUnit Property

Aspose.Cells for .NET

Axis.IsAutomaticMajorUnit Property

Indicates whether the major unit of the axis is automatically assigned.

public bool IsAutomaticMajorUnit {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsAutomaticMaxValue Property

Aspose.Cells for .NET

Axis.IsAutomaticMaxValue Property

Indicates whether the max value is automatically assigned.

public bool IsAutomaticMaxValue {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsAutomaticMinorUnit Property

Aspose.Cells for .NET

Axis.IsAutomaticMinorUnit Property

Indicates whether the minor unit of the axis is automatically assigned.

public bool IsAutomaticMinorUnit {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsAutomaticMinValue Property

Aspose.Cells for .NET

Axis.IsAutomaticMinValue Property

Indicates whether the min value is automatically assigned.

public bool IsAutomaticMinValue {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsAutoTickLabelSpacing Property

Aspose.Cells for .NET

Axis.IsAutoTickLabelSpacing Property

Indicates whether ticklabel spacing is automatic

public bool IsAutoTickLabelSpacing {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsDisplayUnitLabelShown Property

Aspose.Cells for .NET

Axis.IsDisplayUnitLabelShown Property

Represents if the display unit label is shown on the specified axis.

public bool IsDisplayUnitLabelShown {get; set;}

Remarks

The default value is True.

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsLogarithmic Property

Aspose.Cells for .NET

Axis.IsLogarithmic Property

Represents if the value axis scale type is logarithmic or not.

public bool IsLogarithmic {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsPlotOrderReversed Property

Aspose.Cells for .NET

Axis.IsPlotOrderReversed Property

Represents if Microsoft Excel plots data points from last to first.

public bool IsPlotOrderReversed {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


IsVisible Property

Aspose.Cells for .NET

Axis.IsVisible Property

Represents if the axis is visible.

public bool IsVisible {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


LogBase Property

Aspose.Cells for .NET

Axis.LogBase Property

Represents the logarithmic base. Default value is 10.Only applies for Excel2007.

public double LogBase {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


MajorGridLines Property

Aspose.Cells for .NET

Axis.MajorGridLines Property

Represents major gridlines on a chart axis.

public Line MajorGridLines {get;}

Example

[C#]

chart.ValueAxis.MajorGridLines.IsVisible = false;
chart.CategoryAxis.MajorGridLines.IsVisible = true;

[Visual Basic]
chart.ValueAxis.MajorGridLines.IsVisible = false
chart.CategoryAxis.MajorGridLines.IsVisible = true

See Also

Axis Class | Aspose.Cells.Charts Namespace


MajorTickMark Property

Aspose.Cells for .NET

Axis.MajorTickMark Property

Represents the type of major tick mark for the specified axis.

public TickMarkType MajorTickMark {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


MajorUnit Property

Aspose.Cells for .NET

Axis.MajorUnit Property

Represents the major units for the axis.

public double MajorUnit {get; set;}

Remarks

The major units must be greater than zero.

See Also

Axis Class | Aspose.Cells.Charts Namespace


MajorUnitScale Property

Aspose.Cells for .NET

Axis.MajorUnitScale Property

Represents the major unit scale for the category axis.

public TimeUnit MajorUnitScale {get; set;}

Example

[C#]

chart.CategoryAxis.CategoryType = CategoryType.TimeScale;
chart.CategoryAxis.MajorUnitScale = TimeUnit.Months;
chart.CategoryAxis.MajorUnit = 2;

[Visual Basic]
chart.CategoryAxis.CategoryType = CategoryType.TimeScale
chart.CategoryAxis.MajorUnitScale = TimeUnit.Months
chart.CategoryAxis.MajorUnit = 2

See Also

Axis Class | Aspose.Cells.Charts Namespace


MaxValue Property

Aspose.Cells for .NET

Axis.MaxValue Property

Represents the maximum value on the value axis.

public object MaxValue {get; set;}

Remarks

The maxValue type only can be double or DateTime

See Also

Axis Class | Aspose.Cells.Charts Namespace


MinorGridLines Property

Aspose.Cells for .NET

Axis.MinorGridLines Property

Represents minor gridlines on a chart axis.

public Line MinorGridLines {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


MinorTickMark Property

Aspose.Cells for .NET

Axis.MinorTickMark Property

Represents the type of minor tick mark for the specified axis.

public TickMarkType MinorTickMark {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


MinorUnit Property

Aspose.Cells for .NET

Axis.MinorUnit Property

Represents the minor units for the axis.

public double MinorUnit {get; set;}

Remarks

The minor units must be greater than zero.

See Also

Axis Class | Aspose.Cells.Charts Namespace


MinorUnitScale Property

Aspose.Cells for .NET

Axis.MinorUnitScale Property

Represents the major unit scale for the category axis.

public TimeUnit MinorUnitScale {get; set;}

Example

[C#]

chart.CategoryAxis.CategoryType = CategoryType.TimeScale;
chart.CategoryAxis.MinorUnitScale = TimeUnit.Months;
chart.CategoryAxis.MinorUnit = 2;

[Visual Basic]
chart.CategoryAxis.CategoryType = CategoryType.TimeScale
chart.CategoryAxis.MinorUnitScale = TimeUnit.Months
chart.CategoryAxis.MinorUnit = 2

See Also

Axis Class | Aspose.Cells.Charts Namespace


MinValue Property

Aspose.Cells for .NET

Axis.MinValue Property

Represents the minimum value on the value axis.

public object MinValue {get; set;}

Remarks

The minValue type only can be double or DateTime

See Also

Axis Class | Aspose.Cells.Charts Namespace


TickLabelPosition Property

Aspose.Cells for .NET

Axis.TickLabelPosition Property

Represents the position of tick-mark labels on the specified axis.

public TickLabelPositionType TickLabelPosition {get; set;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


TickLabels Property

Aspose.Cells for .NET

Axis.TickLabels Property

Returns a TickLabels object that represents the tick-mark labels for the specified axis.

public TickLabels TickLabels {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


TickLabelSpacing Property

Aspose.Cells for .NET

Axis.TickLabelSpacing Property

Represents the number of categories or series between tick-mark labels. Applies only to category and series axes.

public int TickLabelSpacing {get; set;}

Remarks

The number must be between 1 and 31999.

See Also

Axis Class | Aspose.Cells.Charts Namespace


TickMarkSpacing Property

Aspose.Cells for .NET

Axis.TickMarkSpacing Property

Returns or sets the number of categories or series between tick marks. Applies only to category and series axes.

public int TickMarkSpacing {get; set;}

Remarks

The number must be between 1 and 31999.

See Also

Axis Class | Aspose.Cells.Charts Namespace


Title Property

Aspose.Cells for .NET

Axis.Title Property

Gets the axis' title.

public Title Title {get;}

See Also

Axis Class | Aspose.Cells.Charts Namespace


AxisType Enumeration

Represents the axis type.

public enum AxisType

Members

Member Name | Description | Value
Category | Category axis | 0
Value | Value axis | 1
Series | Series axis | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


BackgroundMode Enumeration

Represents the display mode of the background.

public enum BackgroundMode

Members

Member Name | Description | Value
Automatic | Automatic | 0
Opaque | Opaque | 1
Transparent | Transparent | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Bar3DShapeType Enumeration

Represents the shape used with the 3-D bar or column chart.

public enum Bar3DShapeType

Members

Member Name | Description | Value
Box | Box | 0
PyramidToPoint | PyramidToPoint | 1
PyramidToMax | PyramidToMax | 2
Cylinder | Cylinder | 3
ConeToPoint | ConeToPoint | 4
ConeToMax | ConeToMax | 5

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


BubbleSizeRepresents Enumeration

Represents what the bubble size represents on a bubble chart.

public enum BubbleSizeRepresents

Members

Member Name | Description | Value
SizeIsArea | Represents the value of BubbleSizes is area of the bubble. | 0
SizeIsWidth | Represents the value of BubbleSizes is width of the bubble. | 1

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


CategoryType Enumeration

Represents the category axis type.

public enum CategoryType

Members

Member Name | Description | Value
AutomaticScale | AutomaticScale | 0
CategoryScale | CategoryScale | 1
TimeScale | TimeScale | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Chart Class

Encapsulates the object that represents a single Excel chart.

For a list of all members of this type, see Chart Members.

System.Object
Aspose.Cells.Charts.Chart

public class Chart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 Workbook workbook = new Workbook();
    Worksheet sheet = workbook.Worksheets[0];

    Cells cells = sheet.Cells;
    cells[0,1].PutValue("Income");
    cells[1,0].PutValue("Company A");
    cells[2,0].PutValue("Company B");
    cells[3,0].PutValue("Company C");
    cells[1,1].PutValue(10000);
    cells[2,1].PutValue(20000);
    cells[3,1].PutValue(30000);

    int chartIndex = sheet.Charts.Add(ChartType.Column, 9, 9, 21, 15);

    Chart chart = sheet.Charts[chartIndex];
    chart.NSeries.Add("B2:B4", true);
    chart.NSeries.CategoryData = "A2:A4";

    ASeries aSeries = chart.NSeries[0];
    aSeries.Name = "=B1";
    chart.IsLegendShown = true;
    chart.Title.Text = "Income Analysis";

 [Visual Basic]

 Dim workbook as Workbook = new Workbook()
 Dim sheet as Worksheet = workbook.Worksheets(0)

 Dim cells as Cells = sheet.Cells
 cells(0,1).PutValue("Income")
    cells(1,0).PutValue("Company A")
    cells(2,0).PutValue("Company B")
    cells(3,0).PutValue("Company C")
    cells(1,1).PutValue(10000)
    cells(2,1).PutValue(20000)
    cells(3,1).PutValue(30000)

    Dim chartIndex as Integer = sheet.Charts.Add(ChartType.Column, 9, 9, 21, 15)

    Dim chart as Chart = sheet.Charts(chartIndex)
    chart.NSeries.Add("B2:B4", true)
    chart.NSeries.CategoryData = "A2:A4"

    Dim aSeries as ASeries = chart.NSeries(0)
    aSeries.Name = "=B1"
    chart.IsLegendShown = true
    chart.Title.Text = "Income Analysis"

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Chart Members | Aspose.Cells.Charts Namespace


Chart Members

Chart overview

Public Instance Properties

ActualChartSize | Gets actual size of chart
AutoScaling | True if Microsoft Excel scales a 3-D chart so that it's closer in size to the equivalent 2-D chart. The RightAngleAxes property must be True.
BackWall | Returns a Walls object that represents the back wall of a 3-D chart.
CategoryAxis | Gets the chart's X axis.
ChartArea | Gets the chart area in the worksheet
ChartDataTable | Represents the chart data table.
ChartObject | Represents the chartShape;
DepthPercent | Represents the depth of a 3-D chart as a percentage of the chart width (between 20 and 2000 percent).
DisplayNaAsBlank | Indicates whether displaying #N/A as blank value.
Elevation | Represents the elevation of the 3-D chart view, in degrees.
FirstSliceAngle | Gets or sets the angle of the first pie-chart or doughnut-chart slice, in degrees (clockwise from vertical). Applies only to pie, 3-D pie, and doughnut charts, 0 to 360.
Floor | Returns a Floor object that represents the walls of a 3-D chart.
GapDepth | Gets or sets the distance between the data series in a 3-D chart, as a percentage of the marker width. The value of this property must be between 0 and 500.
GapWidth | Returns or sets the space between bar or column clusters, as a percentage of the bar or column width. The value of this property must be between 0 and 500.
HeightPercent | Returns or sets the height of a 3-D chart as a percentage of the chart width (between 5 and 500 percent).
HidePivotFieldButtons | Indicates whether hide the pivot chart field buttons only when the chart is PivotChart
Is3D | Indicates whether the chart is a 3d chart.
IsRectangularCornered | Gets or sets a value indicating whether the chart area is rectangular cornered. Default is true.
Legend | Gets the chart legend.
Line | Gets the line.
Name | Gets and sets the name of the chart.
NSeries | Gets a SeriesCollection collection representing the data series in the chart.
PageSetup | Represents the page setup description in this chart.
Perspective | Returns or sets the perspective for the 3-D chart view. Must be between 0 and 100. This property is ignored if the RightAngleAxes property is True.
PivotOptions | Specifies the pivot controls that appear on the chart
PivotSource | The source is the data of the pivotTable. If PivotSource is not empty ,the chart is PivotChart.
Placement | Represents the way the chart is attached to the cells below it.
PlotArea | Gets the chart's plot area which includes axis tick labels.
PlotBy | Gets and sets whether plot by row or column.
PlotEmptyCellsType | Gets and sets how to plot the empty cells.
PlotVisibleCells | Indicates whether only plot visible cells.
PrintSize | Gets and sets the printed chart size.
RightAngleAxes | True if the chart axes are at right angles.Applies only for 3-D charts(except Column3D and 3-D Pie Charts).
RotationAngle | Represents the rotation of the 3-D chart view (the rotation of the plot area around the z-axis, in degrees).
SecondCategoryAxis | Gets the chart's second X axis.
SecondValueAxis | Gets the chart's second Y axis.
SeriesAxis | Gets the chart's series axis.
Shapes | Returns all drawing shapes in this chart.
ShowDataTable | Gets or sets a value indicating whether the chart displays a data table.
ShowLegend | Gets or sets a value indicating whether the chart legend will be displayed. Default is true.
SideWall | Returns a Walls object that represents the side wall of a 3-D chart.
SizeWithWindow | True if Microsoft Excel resizes the chart to match the size of the chart sheet window.
Style | Gets and sets the builtin style.
SubTitle | Gets the chart's sub-title. Only for ODS format file.
Title | Gets the chart's title.
Type | Gets or sets a chart's type.
ValueAxis | Gets the chart's Y axis.
Walls | Returns a Walls object that represents the walls of a 3-D chart.
WallsAndGridlines2D | True if gridlines are drawn two-dimensionally on a 3-D chart.
Worksheet | Gets the worksheet which contains this chart.

Public Instance Methods

Calculate | Calculates the custom position of plot area, axes if the position of them are auto assigned.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasAxis | Returns which axes exist on the chart.
IsChartDataChanged | Detects if a chart's data source has changed.
Move | Moves the chart to a specified location.
RefreshPivotData | Refreshes pivot chart's data from it's pivot data source.
SetChartDataRange | Specifies data range for a chart.
ToImage | Overloaded. Gets a 32-bit Bitmap object of the chart.
ToPdf | Overloaded. Saves the chart to a pdf file.
ToString (inherited from Object) |

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart Properties

The properties of the Chart class are listed below. For a complete list of Chart class members, see the Chart Members topic.

Public Instance Properties

ActualChartSize | Gets actual size of chart
AutoScaling | True if Microsoft Excel scales a 3-D chart so that it's closer in size to the equivalent 2-D chart. The RightAngleAxes property must be True.
BackWall | Returns a Walls object that represents the back wall of a 3-D chart.
CategoryAxis | Gets the chart's X axis.
ChartArea | Gets the chart area in the worksheet
ChartDataTable | Represents the chart data table.
ChartObject | Represents the chartShape;
DepthPercent | Represents the depth of a 3-D chart as a percentage of the chart width (between 20 and 2000 percent).
DisplayNaAsBlank | Indicates whether displaying #N/A as blank value.
Elevation | Represents the elevation of the 3-D chart view, in degrees.
FirstSliceAngle | Gets or sets the angle of the first pie-chart or doughnut-chart slice, in degrees (clockwise from vertical). Applies only to pie, 3-D pie, and doughnut charts, 0 to 360.
Floor | Returns a Floor object that represents the walls of a 3-D chart.
GapDepth | Gets or sets the distance between the data series in a 3-D chart, as a percentage of the marker width. The value of this property must be between 0 and 500.
GapWidth | Returns or sets the space between bar or column clusters, as a percentage of the bar or column width. The value of this property must be between 0 and 500.
HeightPercent | Returns or sets the height of a 3-D chart as a percentage of the chart width (between 5 and 500 percent).
HidePivotFieldButtons | Indicates whether hide the pivot chart field buttons only when the chart is PivotChart
Is3D | Indicates whether the chart is a 3d chart.
IsRectangularCornered | Gets or sets a value indicating whether the chart area is rectangular cornered. Default is true.
Legend | Gets the chart legend.
Line | Gets the line.
Name | Gets and sets the name of the chart.
NSeries | Gets a SeriesCollection collection representing the data series in the chart.
PageSetup | Represents the page setup description in this chart.
Perspective | Returns or sets the perspective for the 3-D chart view. Must be between 0 and 100. This property is ignored if the RightAngleAxes property is True.
PivotOptions | Specifies the pivot controls that appear on the chart
PivotSource | The source is the data of the pivotTable. If PivotSource is not empty ,the chart is PivotChart.
Placement | Represents the way the chart is attached to the cells below it.
PlotArea | Gets the chart's plot area which includes axis tick labels.
PlotBy | Gets and sets whether plot by row or column.
PlotEmptyCellsType | Gets and sets how to plot the empty cells.
PlotVisibleCells | Indicates whether only plot visible cells.
PrintSize | Gets and sets the printed chart size.
RightAngleAxes | True if the chart axes are at right angles.Applies only for 3-D charts(except Column3D and 3-D Pie Charts).
RotationAngle | Represents the rotation of the 3-D chart view (the rotation of the plot area around the z-axis, in degrees).
SecondCategoryAxis | Gets the chart's second X axis.
SecondValueAxis | Gets the chart's second Y axis.
SeriesAxis | Gets the chart's series axis.
Shapes | Returns all drawing shapes in this chart.
ShowDataTable | Gets or sets a value indicating whether the chart displays a data table.
ShowLegend | Gets or sets a value indicating whether the chart legend will be displayed. Default is true.
SideWall | Returns a Walls object that represents the side wall of a 3-D chart.
SizeWithWindow | True if Microsoft Excel resizes the chart to match the size of the chart sheet window.
Style | Gets and sets the builtin style.
SubTitle | Gets the chart's sub-title. Only for ODS format file.
Title | Gets the chart's title.
Type | Gets or sets a chart's type.
ValueAxis | Gets the chart's Y axis.
Walls | Returns a Walls object that represents the walls of a 3-D chart.
WallsAndGridlines2D | True if gridlines are drawn two-dimensionally on a 3-D chart.
Worksheet | Gets the worksheet which contains this chart.

See Also

Chart Class | Aspose.Cells.Charts Namespace


ActualChartSize Property

Aspose.Cells for .NET

Chart.ActualChartSize Property

Gets actual size of chart

public Size ActualChartSize {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


AutoScaling Property

Aspose.Cells for .NET

Chart.AutoScaling Property

True if Microsoft Excel scales a 3-D chart so that it's closer in size to the equivalent 2-D chart. The RightAngleAxes property must be True.

public bool AutoScaling {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


BackWall Property

Aspose.Cells for .NET

Chart.BackWall Property

Returns a Walls object that represents the back wall of a 3-D chart.

public Walls BackWall {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


CategoryAxis Property

Aspose.Cells for .NET

Chart.CategoryAxis Property

Gets the chart's X axis.

public Axis CategoryAxis {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


ChartArea Property

Aspose.Cells for .NET

Chart.ChartArea Property

Gets the chart area in the worksheet

public ChartArea ChartArea {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


ChartDataTable Property

Aspose.Cells for .NET

Chart.ChartDataTable Property

Represents the chart data table.

public ChartDataTable ChartDataTable {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


ChartObject Property

Aspose.Cells for .NET

Chart.ChartObject Property

Represents the chartShape;

public ChartShape ChartObject {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


DepthPercent Property

Aspose.Cells for .NET

Chart.DepthPercent Property

Represents the depth of a 3-D chart as a percentage of the chart width (between 20 and 2000 percent).

public int DepthPercent {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


DisplayNaAsBlank Property

Aspose.Cells for .NET

Chart.DisplayNaAsBlank Property

Indicates whether displaying #N/A as blank value.

public bool DisplayNaAsBlank {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Elevation Property

Aspose.Cells for .NET

Chart.Elevation Property

Represents the elevation of the 3-D chart view, in degrees.

public int Elevation {get; set;}

Remarks

The chart elevation is the height at which you view the chart, in degrees. The default is 15 for most chart types. The value of this property must be between -90 and 90, except for 3-D bar charts, where it must be between 0 and 44.

See Also

Chart Class | Aspose.Cells.Charts Namespace


FirstSliceAngle Property

Aspose.Cells for .NET

Chart.FirstSliceAngle Property

Gets or sets the angle of the first pie-chart or doughnut-chart slice, in degrees (clockwise from vertical). Applies only to pie, 3-D pie, and doughnut charts, 0 to 360.

public int FirstSliceAngle {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Floor Property

Aspose.Cells for .NET

Chart.Floor Property

Returns a Floor object that represents the walls of a 3-D chart.

public Floor Floor {get;}

Remarks

This property doesn't apply to 3-D pie charts.

See Also

Chart Class | Aspose.Cells.Charts Namespace


GapDepth Property

Aspose.Cells for .NET

Chart.GapDepth Property

Gets or sets the distance between the data series in a 3-D chart, as a percentage of the marker width. The value of this property must be between 0 and 500.

public int GapDepth {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


GapWidth Property

Aspose.Cells for .NET

Chart.GapWidth Property

Returns or sets the space between bar or column clusters, as a percentage of the bar or column width. The value of this property must be between 0 and 500.

public int GapWidth {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


HeightPercent Property

Aspose.Cells for .NET

Chart.HeightPercent Property

Returns or sets the height of a 3-D chart as a percentage of the chart width (between 5 and 500 percent).

public int HeightPercent {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


HidePivotFieldButtons Property

Aspose.Cells for .NET

Chart.HidePivotFieldButtons Property

Indicates whether hide the pivot chart field buttons only when the chart is PivotChart

public bool HidePivotFieldButtons {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Is3D Property

Aspose.Cells for .NET

Chart.Is3D Property

Indicates whether the chart is a 3d chart.

public bool Is3D {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


IsRectangularCornered Property

Aspose.Cells for .NET

Chart.IsRectangularCornered Property

Gets or sets a value indicating whether the chart area is rectangular cornered. Default is true.

public bool IsRectangularCornered {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Legend Property

Aspose.Cells for .NET

Chart.Legend Property

Gets the chart legend.

public Legend Legend {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Line Property

Aspose.Cells for .NET

Chart.Line Property

Gets the line.

public Line Line {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Name Property

Aspose.Cells for .NET

Chart.Name Property

Gets and sets the name of the chart.

public string Name {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


NSeries Property

Aspose.Cells for .NET

Chart.NSeries Property

Gets a SeriesCollection collection representing the data series in the chart.

public SeriesCollection NSeries {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PageSetup Property

Aspose.Cells for .NET

Chart.PageSetup Property

Represents the page setup description in this chart.

public PageSetup PageSetup {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Perspective Property

Aspose.Cells for .NET

Chart.Perspective Property

Returns or sets the perspective for the 3-D chart view. Must be between 0 and 100. This property is ignored if the RightAngleAxes property is True.

public short Perspective {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PivotOptions Property

Aspose.Cells for .NET

Chart.PivotOptions Property

Specifies the pivot controls that appear on the chart

public PivotOptions PivotOptions {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PivotSource Property

Aspose.Cells for .NET

Chart.PivotSource Property

The source is the data of the pivotTable. If PivotSource is not empty ,the chart is PivotChart.

public string PivotSource {get; set;}

Remarks

If the pivot table "PivotTable1" in the Worksheet "Sheet1" in the file "Book1.xls". The pivotSource could be "[Book1.xls]Sheet1!PivotTable1" if the chart and the PivotTable is not in the same workbook. If you set this property ,the previous data source setting will be lost.

See Also

Chart Class | Aspose.Cells.Charts Namespace


Placement Property

Aspose.Cells for .NET

Chart.Placement Property

Represents the way the chart is attached to the cells below it.

public PlacementType Placement {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PlotArea Property

Aspose.Cells for .NET

Chart.PlotArea Property

Gets the chart's plot area which includes axis tick labels.

public PlotArea PlotArea {get;}

Remarks

See Also

Chart Class | Aspose.Cells.Charts Namespace


PlotBy Property

Aspose.Cells for .NET

Chart.PlotBy Property

Gets and sets whether plot by row or column.

public PlotDataByType PlotBy {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PlotEmptyCellsType Property

Aspose.Cells for .NET

Chart.PlotEmptyCellsType Property

Gets and sets how to plot the empty cells.

public PlotEmptyCellsType PlotEmptyCellsType {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PlotVisibleCells Property

Aspose.Cells for .NET

Chart.PlotVisibleCells Property

Indicates whether only plot visible cells.

public bool PlotVisibleCells {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


PrintSize Property

Aspose.Cells for .NET

Chart.PrintSize Property

Gets and sets the printed chart size.

public PrintSizeType PrintSize {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


RightAngleAxes Property

Aspose.Cells for .NET

Chart.RightAngleAxes Property

True if the chart axes are at right angles.Applies only for 3-D charts(except Column3D and 3-D Pie Charts).

public bool RightAngleAxes {get; set;}

Remarks

If this property is True, the Perspective property is ignored.

See Also

Chart Class | Aspose.Cells.Charts Namespace


RotationAngle Property

Aspose.Cells for .NET

Chart.RotationAngle Property

Represents the rotation of the 3-D chart view (the rotation of the plot area around the z-axis, in degrees).

public int RotationAngle {get; set;}

Remarks

The value of this property must be from 0 to 360, except for 3-D bar charts, where the value must be from 0 to 44. The default value is 20. Applies only to 3-D charts.

See Also

Chart Class | Aspose.Cells.Charts Namespace


SecondCategoryAxis Property

Aspose.Cells for .NET

Chart.SecondCategoryAxis Property

Gets the chart's second X axis.

public Axis SecondCategoryAxis {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


SecondValueAxis Property

Aspose.Cells for .NET

Chart.SecondValueAxis Property

Gets the chart's second Y axis.

public Axis SecondValueAxis {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


SeriesAxis Property

Aspose.Cells for .NET

Chart.SeriesAxis Property

Gets the chart's series axis.

public Axis SeriesAxis {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Shapes Property

Aspose.Cells for .NET

Chart.Shapes Property

Returns all drawing shapes in this chart.

public ShapeCollection Shapes {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


ShowDataTable Property

Aspose.Cells for .NET

Chart.ShowDataTable Property

Gets or sets a value indicating whether the chart displays a data table.

public bool ShowDataTable {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


ShowLegend Property

Aspose.Cells for .NET

Chart.ShowLegend Property

Gets or sets a value indicating whether the chart legend will be displayed. Default is true.

public bool ShowLegend {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


SideWall Property

Aspose.Cells for .NET

Chart.SideWall Property

Returns a Walls object that represents the side wall of a 3-D chart.

public Walls SideWall {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


SizeWithWindow Property

Aspose.Cells for .NET

Chart.SizeWithWindow Property

True if Microsoft Excel resizes the chart to match the size of the chart sheet window.

public bool SizeWithWindow {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Style Property

Aspose.Cells for .NET

Chart.Style Property

Gets and sets the builtin style.

public int Style {get; set;}

Remarks

It should be between 1 and 48. Return -1 if it's not be set.

See Also

Chart Class | Aspose.Cells.Charts Namespace


SubTitle Property

Aspose.Cells for .NET

Chart.SubTitle Property

Gets the chart's sub-title. Only for ODS format file.

public Title SubTitle {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Title Property

Aspose.Cells for .NET

Chart.Title Property

Gets the chart's title.

public Title Title {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Type Property

Aspose.Cells for .NET

Chart.Type Property

Gets or sets a chart's type.

public ChartType Type {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


ValueAxis Property

Aspose.Cells for .NET

Chart.ValueAxis Property

Gets the chart's Y axis.

public Axis ValueAxis {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Walls Property

Aspose.Cells for .NET

Chart.Walls Property

Returns a Walls object that represents the walls of a 3-D chart.

public Walls Walls {get;}

Remarks

This property doesn't apply to 3-D pie charts.

See Also

Chart Class | Aspose.Cells.Charts Namespace


WallsAndGridlines2D Property

Aspose.Cells for .NET

Chart.WallsAndGridlines2D Property

True if gridlines are drawn two-dimensionally on a 3-D chart.

public bool WallsAndGridlines2D {get; set;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Worksheet Property

Aspose.Cells for .NET

Chart.Worksheet Property

Gets the worksheet which contains this chart.

public Worksheet Worksheet {get;}

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart Methods

The methods of the Chart class are listed below. For a complete list of Chart class members, see the Chart Members topic.

Public Instance Methods

Calculate | Calculates the custom position of plot area, axes if the position of them are auto assigned.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasAxis | Returns which axes exist on the chart.
IsChartDataChanged | Detects if a chart's data source has changed.
Move | Moves the chart to a specified location.
RefreshPivotData | Refreshes pivot chart's data from it's pivot data source.
SetChartDataRange | Specifies data range for a chart.
ToImage | Overloaded. Gets a 32-bit Bitmap object of the chart.
ToPdf | Overloaded. Saves the chart to a pdf file.
ToString (inherited from Object) |

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.Calculate Method

Calculates the custom position of plot area, axes if the position of them are auto assigned.

public void Calculate();

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.HasAxis Method

Returns which axes exist on the chart.

public bool HasAxis(
AxisType aixsType,
bool isPrimary
);

Remarks

Normally, Pie, PieExploded, PiePie,PieBar, Pie3D, Pie3DExploded,Doughnut, DoughnutExploded is no axis.

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.IsChartDataChanged Method

Detects if a chart's data source has changed.

public bool IsChartDataChanged();

Return Value

Returns true if the chart has changed otherwise returns false

Remarks

The method detects the changes in the chart's data source before rendering the chart to image format. At first Chart.toImage call, the chart source data (e.g. XValuesParseData, ValuesParseData) will be recorded. Before calling the Chart.toImage method again, call IsChartDataChanged method to check if Chart needs re-rendering.

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.Move Method

Moves the chart to a specified location.

public void Move(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.RefreshPivotData Method

Refreshes pivot chart's data from it's pivot data source.

public void RefreshPivotData();

Remarks

We will gather data from pivot data source to the pivot chart cache. This method is only used to gather all data to a pivot chart.

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.SetChartDataRange Method

Specifies data range for a chart.

public void SetChartDataRange(
string area,
bool isVertical
);

Parameters

area
Specifies values from which to plot the data series
isVertical
Specifies whether to plot the series from a range of cell values by row or by column.

See Also

Chart Class | Aspose.Cells.Charts Namespace


ToImage Method

Aspose.Cells for .NET

Chart.ToImage Method

Gets a 32-bit Bitmap object of the chart.

Overload List

Gets a 32-bit Bitmap object of the chart.

public Bitmap ToImage();

Gets a 32-bit Bitmap object of the chart. ImageOrPrintOptions.ImageFormat, ImageOrPrintOptions.TiffCompression and ImageOrPrintOptions.Quality attributes are ignored.

public Bitmap ToImage(ImageOrPrintOptions);

Creates the chart image and saves it to a stream in the specified format.

public void ToImage(Stream,ImageOrPrintOptions);

Creates the chart image and saves it to a stream in the specified format.

public void ToImage(Stream,ImageFormat);

Creates the chart image and saves it to a stream in the Jpeg format.

public void ToImage(Stream,long);

Creates the chart image and saves it to a file. The extension of the file name determines the format of the image.

public void ToImage(string);

Creates the chart image and saves it to a file. The extension of the file name determines the format of the image.

public void ToImage(string,ImageOrPrintOptions);

Creates the chart image and saves it to a file in the specified format.

public void ToImage(string,ImageFormat);

Creates the chart image and saves it to a file in the Jpeg format.

public void ToImage(string,long);

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.ToImage Method ()

Gets a 32-bit Bitmap object of the chart.

public Bitmap ToImage();

Return Value

the picture of the chart.

Remarks

If the width or height is zero or the chart is not supported according to Supported Charts List, it will return null. Please refer to Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (ImageOrPrintOptions)

Gets a 32-bit Bitmap object of the chart. ImageOrPrintOptions.ImageFormat, ImageOrPrintOptions.TiffCompression and ImageOrPrintOptions.Quality attributes are ignored.

public Bitmap ToImage(
ImageOrPrintOptions options
);

Parameters

options
Additional image creation options

Return Value

the picture of the chart.

Remarks

Returns a 32-bit bitmap object, so ImageOrPrintOptions.ImageFormat, ImageOrPrintOptions.TiffCompression and ImageOrPrintOptions.Quality attributes do not affect the method. If the width or height is zero or the chart is not supported according to Supported Charts List, it will return null. Please refer to Supported Charts List for more details.

Example

Gets a bitmap object with 200 x dpi and 300 y dpi.

[C#]
 ImageOrPrintOptions options = new ImageOrPrintOptions();
 options.HorizontalResolution = 200;
 options.VerticalResolution = 300;

 Workbook book = new Workbook(@"c:\test.xls");
 Bitmap chartObject = book.Worksheets[0].Charts[0].ToImage(options);

 [VB]
 Dim options As ImageOrPrintOptions =  New ImageOrPrintOptions()
 options.HorizontalResolution = 200
 options.VerticalResolution = 300

 Dim book As Workbook =  New Workbook("c:\test.xls")
 Dim chartObject As Bitmap = book.Worksheets(0).Charts(0).ToImage(options)

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (Stream, ImageOrPrintOptions)

Creates the chart image and saves it to a stream in the specified format.

public void ToImage(
Stream stream,
ImageOrPrintOptions options
);

Parameters

stream
The output stream.
options
Additional image creation options

Remarks

The format of the image is specified by using options.ImageFormat. The following formats are supported: ImageFormat.Bmp, ImageFormat.Gif, ImageFormat.Png, ImageFormat.Jpeg, ImageFormat.Tiff, ImageFormat.Emf.

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer to Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (Stream, ImageFormat)

Creates the chart image and saves it to a stream in the specified format.

public void ToImage(
Stream stream,
ImageFormat imageFormat
);

Parameters

stream
The output stream.
imageFormat
The format in which to save the image.

Remarks

The format of the image is specified by using imageFormat. The following formats are supported: ImageFormat.Bmp, ImageFormat.Gif, ImageFormat.Png, ImageFormat.Jpeg, ImageFormat.Tiff, ImageFormat.Emf.

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (Stream, Int64)

Creates the chart image and saves it to a stream in the Jpeg format.

public void ToImage(
Stream stream,
long jpegQuality
);

Parameters

stream
The output stream.
jpegQuality
Jpeg quality.

Remarks

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer to Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (String)

Creates the chart image and saves it to a file. The extension of the file name determines the format of the image.

public void ToImage(
string imageFile
);

Parameters

imageFile
The image file name with full path.

Remarks

The format of the image is specified by using the extension of the file name. For example, if you specify "myfile.png", then the image will be saved in the PNG format. The following file extensions are recognized: .bmp, .gif, .png, .jpg, .jpeg, .tiff, .tif, .emf.

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer to Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (String, ImageOrPrintOptions)

Creates the chart image and saves it to a file. The extension of the file name determines the format of the image.

public void ToImage(
string imageFile,
ImageOrPrintOptions options
);

Parameters

imageFile
The image file name with full path.
options
Additional image creation options

Remarks

The format of the image is specified by using the extension of the file name. For example, if you specify "myfile.png", then the image will be saved in the PNG format. The following file extensions are recognized: .bmp, .gif, .png, .jpg, .jpeg, .tiff, .tif, .emf.

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer to Supported Charts List for more details.

Example

Saves to Tiff with 300 dpi and CCITT4 compression.

[C#]
 ImageOrPrintOptions options = new ImageOrPrintOptions();
 options.HorizontalResolution = 300;
 options.VerticalResolution = 300;
 options.TiffCompression = TiffCompression.CompressionCCITT4;

 Workbook book = new Workbook(@"c:\test.xls");
 book.Worksheets[0].Charts[0].ToImage(@"c:\chart.Tiff", options);

 [VB]
 Dim options As ImageOrPrintOptions =  New ImageOrPrintOptions()
 options.HorizontalResolution = 300
 options.VerticalResolution = 300
 options.TiffCompression = TiffCompression.CompressionCCITT4

 Dim book As Workbook =  New Workbook("c:\test.xls")
 book.Worksheets(0).Charts(0).ToImage("c:\chart.Tiff", options)
Saves to Jpeg with 300 dpi and 80 image quality.
[C#]
 ImageOrPrintOptions options = new ImageOrPrintOptions();
 options.HorizontalResolution = 300;
 options.VerticalResolution = 300;
 options.Quality = 80;

 Workbook book = new Workbook(@"c:\test.xls");
 book.Worksheets[0].Charts[0].ToImage(@"c:\chart.Jpeg", options);

 [VB]
 Dim options As ImageOrPrintOptions =  New ImageOrPrintOptions()
 options.HorizontalResolution = 300
 options.VerticalResolution = 300
 options.Quality = 80

 Dim book As Workbook =  New Workbook("c:\test.xls")
 book.Worksheets(0).Charts(0).ToImage("c:\chart.Jpeg", options)

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (String, ImageFormat)

Creates the chart image and saves it to a file in the specified format.

public void ToImage(
string imageFile,
ImageFormat imageFormat
);

Parameters

imageFile
The image file name with full path.
imageFormat
The format in which to save the image.

Remarks

The format of the image is specified by using imageFormat. The following formats are supported: ImageFormat.Bmp, ImageFormat.Gif, ImageFormat.Png, ImageFormat.Jpeg, ImageFormat.Tiff, ImageFormat.Emf.

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer to Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


Chart.ToImage Method (String, Int64)

Creates the chart image and saves it to a file in the Jpeg format.

public void ToImage(
string imageFile,
long jpegQuality
);

Parameters

imageFile
The image file name with full path.
jpegQuality
Jpeg quality.

Remarks

If the width or height is zero or the chart is not supported according to Supported Charts List, this method will do nothing. Please refer to Supported Charts List for more details.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToImage Overload List


ToPdf Method

Aspose.Cells for .NET

Chart.ToPdf Method

Creates the chart pdf and saves it to a stream.

Overload List

Creates the chart pdf and saves it to a stream.

public void ToPdf(Stream);

Creates the chart pdf and saves it to a stream.

public void ToPdf(Stream,float,float,PageLayoutAlignmentType,PageLayoutAlignmentType);

Saves the chart to a pdf file.

public void ToPdf(string);

Saves the chart to a pdf file.

public void ToPdf(string,float,float,PageLayoutAlignmentType,PageLayoutAlignmentType);

See Also

Chart Class | Aspose.Cells.Charts Namespace


Chart.ToPdf Method (Stream)

Creates the chart pdf and saves it to a stream.

public void ToPdf(
Stream stream
);

Parameters

stream
The output stream.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToPdf Overload List


Chart.ToPdf Method (Stream, Single, Single, PageLayoutAlignmentType, PageLayoutAlignmentType)

Creates the chart pdf and saves it to a stream.

public void ToPdf(
Stream stream,
float desiredPageWidth,
float desiredPageHeight,
PageLayoutAlignmentType hAlignmentType,
PageLayoutAlignmentType vAlignmentType
);

Parameters

stream
The output stream.
desiredPageWidth
The desired page width in inches.
desiredPageHeight
The desired page height in inches.
hAlignmentType
The chart horizontal alignment type in the output page.
vAlignmentType
The chart vertical alignment type in the output page.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToPdf Overload List


Chart.ToPdf Method (String)

Saves the chart to a pdf file.

public void ToPdf(
string fileName
);

Parameters

fileName
the pdf file name with full path

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToPdf Overload List


Chart.ToPdf Method (String, Single, Single, PageLayoutAlignmentType, PageLayoutAlignmentType)

Saves the chart to a pdf file.

public void ToPdf(
string fileName,
float desiredPageWidth,
float desiredPageHeight,
PageLayoutAlignmentType hAlignmentType,
PageLayoutAlignmentType vAlignmentType
);

Parameters

fileName
the pdf file name with full path
desiredPageWidth
The desired page width in inches.
desiredPageHeight
The desired page height in inches.
hAlignmentType
The chart horizontal alignment type in the output page.
vAlignmentType
The chart vertical alignment type in the output page.

See Also

Chart Class | Aspose.Cells.Charts Namespace | Chart.ToPdf Overload List


ChartArea Class

Encapsulates the object that represents the chart area in the worksheet.

For a list of all members of this type, see ChartArea Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartArea

public class ChartArea : ChartFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the first worksheet
Worksheet worksheet = workbook.Worksheets[0];

//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);

//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);

//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);

//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);

//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);

//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);

//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);

//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];

//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", true);

//Getting Chart Area
ChartArea chartArea = chart.ChartArea;

//Setting the foreground color of the chart area
chartArea.Area.ForegroundColor = Color.Yellow;

//Setting Chart Area Shadow
chartArea.Shadow = true;

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the first worksheet
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)

'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)

'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)

'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)

'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)

'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)

'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)

'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)

'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", True)

'Getting Chart Area
Dim chartArea As ChartArea = chart.ChartArea

'Setting the foreground color of the chart area
chartArea.Area.ForegroundColor = Color.Yellow

'Setting Chart Area Shadow
chartArea.Shadow = True

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartArea Members | Aspose.Cells.Charts Namespace


ChartArea Members

ChartArea overview

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
Font | Gets a Font object of the specified chartarea object.
Height | Gets or sets the vertical offset from its lower right corner row.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
Width | Gets or sets the horizontal offset from its lower right corner column.
X | Gets or gets the horizontal offset from its upper left corner column.
Y | Gets or gets the vertical offset from its upper left corner row.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


ChartArea Properties

The properties of the ChartArea class are listed below. For a complete list of ChartArea class members, see the ChartArea Members topic.

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
Font | Gets a Font object of the specified chartarea object.
Height | Gets or sets the vertical offset from its lower right corner row.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
Width | Gets or sets the horizontal offset from its lower right corner column.
X | Gets or gets the horizontal offset from its upper left corner column.
Y | Gets or gets the vertical offset from its upper left corner row.

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

ChartArea.Font Property

Gets a Font object of the specified chartarea object.

public override Font Font {get;}

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


Height Property

Aspose.Cells for .NET

ChartArea.Height Property

Gets or sets the vertical offset from its lower right corner row.

public override int Height {get; set;}

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


Width Property

Aspose.Cells for .NET

ChartArea.Width Property

Gets or sets the horizontal offset from its lower right corner column.

public override int Width {get; set;}

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


X Property

Aspose.Cells for .NET

ChartArea.X Property

Gets or gets the horizontal offset from its upper left corner column.

public override int X {get; set;}

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


Y Property

Aspose.Cells for .NET

ChartArea.Y Property

Gets or gets the vertical offset from its upper left corner row.

public override int Y {get; set;}

See Also

ChartArea Class | Aspose.Cells.Charts Namespace


ChartCollection Class

Encapsulates a collection of Chart objects.

For a list of all members of this type, see ChartCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Charts.ChartCollection

public class ChartCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Workbook workbook = new Workbook();

ChartCollection charts = workbook.Worksheets[0].Charts;

[Visual Basic]

Dim workbook as Workbook = new Workbook()

Dim ChartCollection as Charts = workbook.Worksheets(0).Charts

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartCollection Members | Aspose.Cells.Charts Namespace


ChartCollection Members

ChartCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Chart element at the specified index.

Public Instance Methods

Add | Adds a chart to the collection.
AddFloatingChart | Adds a chart to the collection.
Clear | Clear all charts.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove a chart at the specific index.
ToString (inherited from Object) |

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


ChartCollection Properties

The properties of the ChartCollection class are listed below. For a complete list of ChartCollection class members, see the ChartCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Chart element at the specified index.

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

ChartCollection.Item Property

Gets the Chart element at the specified index.

Overload List

Gets the Chart element at the specified index.

public Chart this[int] {get;}

Gets the chart by the name.

public Chart this[string] {get;}

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


Item Property (Int32)

Aspose.Cells for .NET

ChartCollection.Item Property (Int32)

Gets the Chart element at the specified index.

public Chart this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace | ChartCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ChartCollection.Item Property (String)

Gets the chart by the name.

public Chart this[
string name
] {get;}

Parameters

name
The chart name.

Remarks

The default chart name is null. So you have to explicitly set the name of the chart.

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace | ChartCollection.Item Overload List


ChartCollection Methods

The methods of the ChartCollection class are listed below. For a complete list of ChartCollection class members, see the ChartCollection Members topic.

Public Instance Methods

Add | Adds a chart to the collection.
AddFloatingChart | Adds a chart to the collection.
Clear | Clear all charts.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove a chart at the specific index.
ToString (inherited from Object) |

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


ChartCollection.Add Method

Adds a chart to the collection.

public int Add(
ChartType type,
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn
);

Parameters

type
Chart type
upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index

Return Value

Chart object index.

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


ChartCollection.AddFloatingChart Method

Adds a chart to the collection.

public int AddFloatingChart(
ChartType type,
int left,
int top,
int width,
int height
);

Parameters

type
Chart type
left
The x offset to corner
top
The y offset to corner
width
The chart width
height
The chart height

Return Value

Chart object index.

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


ChartCollection.Clear Method

Clear all charts.

new public void Clear();

Implements

IList.Clear

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


ChartCollection.RemoveAt Method

Remove a chart at the specific index.

new public void RemoveAt(
int index
);

Parameters

index
The chart index.

Implements

IList.RemoveAt

See Also

ChartCollection Class | Aspose.Cells.Charts Namespace


ChartDataTable Class

Represents a chart data table.

For a list of all members of this type, see ChartDataTable Members.

System.Object
Aspose.Cells.Charts.ChartDataTable

public class ChartDataTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the first worksheet
Worksheet worksheet = workbook.Worksheets[0];

//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);

//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);

//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);

//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);

//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);

//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);

//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 25, 10);

//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];

//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", true);

chart.IsDataTableShown = true;

//Getting Chart Table
ChartDataTable chartTable = chart.ChartDataTable;

//Setting Chart Table Font Color
chartTable.Font.Color = System.Drawing.Color.Red;

//Setting Legend Key VisibilityOptions
chartTable.ShowLegendKey = false;

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the first worksheet
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)

'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)

'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)

'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)

'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)

'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)

'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.Column, 5, 0, 25, 10)

'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)

'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", True)

chart.IsDataTableShown = True

'Getting Chart Table
Dim chartTable As ChartDataTable = chart.ChartDataTable

'Setting Chart Table Font Color
chartTable.Font.Color = System.Drawing.Color.Red

'Setting Legend Key VisibilityOptions
chartTable.ShowLegendKey = False

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartDataTable Members | Aspose.Cells.Charts Namespace


ChartDataTable Members

ChartDataTable overview

Public Instance Properties

AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Border | Returns a Border object that represents the border of the object
Font | Gets a Font object which represents the font setting of the specified chart data table.
HasBorderHorizontal | True if the chart data table has horizontal cell borders
HasBorderOutline | True if the chart data table has outline borders
HasBorderVertical | True if the chart data table has vertical cell borders
ShowLegendKey | True if the data label legend key is visible.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


ChartDataTable Properties

The properties of the ChartDataTable class are listed below. For a complete list of ChartDataTable class members, see the ChartDataTable Members topic.

Public Instance Properties

AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Border | Returns a Border object that represents the border of the object
Font | Gets a Font object which represents the font setting of the specified chart data table.
HasBorderHorizontal | True if the chart data table has horizontal cell borders
HasBorderOutline | True if the chart data table has outline borders
HasBorderVertical | True if the chart data table has vertical cell borders
ShowLegendKey | True if the data label legend key is visible.

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


AutoScaleFont Property

Aspose.Cells for .NET

ChartDataTable.AutoScaleFont Property

True if the text in the object changes font size when the object size changes. The default value is True.

public bool AutoScaleFont {get; set;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


Background Property

Aspose.Cells for .NET

ChartDataTable.Background Property

NOTE: This property is now obsolete.

Use ChartDataTable.BackgroundMode property instead.

Gets and sets the display mode of the background

public BackgroundMode Background {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use ChartDataTable.BackgroundMode property. This property will be removed 12 months later since JANUARY 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


BackgroundMode Property

Aspose.Cells for .NET

ChartDataTable.BackgroundMode Property

Gets and sets the display mode of the background

public BackgroundMode BackgroundMode {get; set;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

ChartDataTable.Border Property

Returns a Border object that represents the border of the object

public Line Border {get;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

ChartDataTable.Font Property

Gets a Font object which represents the font setting of the specified chart data table.

public Font Font {get;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


HasBorderHorizontal Property

Aspose.Cells for .NET

ChartDataTable.HasBorderHorizontal Property

True if the chart data table has horizontal cell borders

public bool HasBorderHorizontal {get; set;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


HasBorderOutline Property

Aspose.Cells for .NET

ChartDataTable.HasBorderOutline Property

True if the chart data table has outline borders

public bool HasBorderOutline {get; set;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


HasBorderVertical Property

Aspose.Cells for .NET

ChartDataTable.HasBorderVertical Property

True if the chart data table has vertical cell borders

public bool HasBorderVertical {get; set;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


ShowLegendKey Property

Aspose.Cells for .NET

ChartDataTable.ShowLegendKey Property

True if the data label legend key is visible.

public bool ShowLegendKey {get; set;}

See Also

ChartDataTable Class | Aspose.Cells.Charts Namespace


ChartFrame Class

Encapsulates the object that represents the frame object in a chart.

For a list of all members of this type, see ChartFrame Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartArea
Aspose.Cells.Charts.ChartTextFrame
Aspose.Cells.Charts.Legend
Aspose.Cells.Charts.PlotArea

public class ChartFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartFrame Members | Aspose.Cells.Charts Namespace


ChartFrame Members

ChartFrame overview

Public Instance Properties

Area | Gets the area.
AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Border | Gets the border.
DefaultHeight | Represents height of default position
DefaultWidth | Represents width of default position
DefaultX | Represents x of default position
DefaultY | Represents y of default position
Font | Gets a Font object of the specified ChartFrame object.
Height | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize | Indicates whether the chart frame is automatic sized.
IsDefaultPosBeSet | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
Shadow | True if the frame has a shadow.
ShapeProperties | Gets the ShapeProperties object.
TextFont | Obsolete. Gets a Font object of the specified ChartFrame object.
Width | Gets or sets the width of frame in units of 1/4000 of the chart area.
X | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


ChartFrame Properties

The properties of the ChartFrame class are listed below. For a complete list of ChartFrame class members, see the ChartFrame Members topic.

Public Instance Properties

Area | Gets the area.
AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Border | Gets the border.
DefaultHeight | Represents height of default position
DefaultWidth | Represents width of default position
DefaultX | Represents x of default position
DefaultY | Represents y of default position
Font | Gets a Font object of the specified ChartFrame object.
Height | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize | Indicates whether the chart frame is automatic sized.
IsDefaultPosBeSet | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
Shadow | True if the frame has a shadow.
ShapeProperties | Gets the ShapeProperties object.
TextFont | Obsolete. Gets a Font object of the specified ChartFrame object.
Width | Gets or sets the width of frame in units of 1/4000 of the chart area.
X | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

ChartFrame.Area Property

Gets the area.

public virtual Area Area {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


AutoScaleFont Property

Aspose.Cells for .NET

ChartFrame.AutoScaleFont Property

True if the text in the object changes font size when the object size changes. The default value is True.

public virtual bool AutoScaleFont {get; set;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Background Property

Aspose.Cells for .NET

ChartFrame.Background Property

NOTE: This property is now obsolete.

Use ChartFrame.BackgroundMode property instead.

Gets and sets the display mode of the background

public BackgroundMode Background {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use ChartFrame.BackgroundMode property. This property will be removed 12 months later since JANUARY 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


BackgroundMode Property

Aspose.Cells for .NET

ChartFrame.BackgroundMode Property

Gets and sets the display mode of the background

public BackgroundMode BackgroundMode {get; set;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

ChartFrame.Border Property

Gets the border.

public virtual Line Border {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


DefaultHeight Property

Aspose.Cells for .NET

ChartFrame.DefaultHeight Property

Represents height of default position

public int DefaultHeight {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


DefaultWidth Property

Aspose.Cells for .NET

ChartFrame.DefaultWidth Property

Represents width of default position

public int DefaultWidth {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


DefaultX Property

Aspose.Cells for .NET

ChartFrame.DefaultX Property

Represents x of default position

public int DefaultX {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


DefaultY Property

Aspose.Cells for .NET

ChartFrame.DefaultY Property

Represents y of default position

public int DefaultY {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

ChartFrame.Font Property

Gets a Font object of the specified ChartFrame object.

public virtual Font Font {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Height Property

Aspose.Cells for .NET

ChartFrame.Height Property

Gets or sets the height of frame in units of 1/4000 of the chart area.

public virtual int Height {get; set;}

Remarks

How to convert units of 1/4000 to pixels? Height In Pixels = Y * Chart.ChartObject.Height / 4000;

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


IsAutomaticSize Property

Aspose.Cells for .NET

ChartFrame.IsAutomaticSize Property

Indicates whether the chart frame is automatic sized.

public virtual bool IsAutomaticSize {get; set;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


IsDefaultPosBeSet Property

Aspose.Cells for .NET

ChartFrame.IsDefaultPosBeSet Property

Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.

public bool IsDefaultPosBeSet {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


IsInnerMode Property

Aspose.Cells for .NET

ChartFrame.IsInnerMode Property

Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.

public bool IsInnerMode {get; set;}

Remarks

Only for Xlsx file.

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Shadow Property

Aspose.Cells for .NET

ChartFrame.Shadow Property

True if the frame has a shadow.

public bool Shadow {get; set;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


ShapeProperties Property

Aspose.Cells for .NET

ChartFrame.ShapeProperties Property

Gets the ShapeProperties object.

public ShapePropertyCollection ShapeProperties {get;}

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


TextFont Property

Aspose.Cells for .NET

ChartFrame.TextFont Property

NOTE: This property is now obsolete.

Use ChartFrame.Font property instead.

Gets a Font object of the specified ChartFrame object.

public virtual Font TextFont {get;}

Remarks

NOTE: This member is now obsolete. Instead, please use ChartFrame.Font property. This property will be removed 12 months later since JANUARY 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Width Property

Aspose.Cells for .NET

ChartFrame.Width Property

Gets or sets the width of frame in units of 1/4000 of the chart area.

public virtual int Width {get; set;}

Remarks

How to convert units of 1/4000 to pixels? Width In Pixels = Width * Chart.ChartObject.Height / 4000;

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


X Property

Aspose.Cells for .NET

ChartFrame.X Property

Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.

public virtual int X {get; set;}

Remarks

How to convert units of 1/4000 to pixels? X In Pixels = X * Chart.ChartObject.Width / 4000;

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


Y Property

Aspose.Cells for .NET

ChartFrame.Y Property

Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

public virtual int Y {get; set;}

Remarks

How to convert units of 1/4000 to pixels? Y In Pixels = Y * Chart.ChartObject.Height / 4000;

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


ChartFrame Methods

The methods of the ChartFrame class are listed below. For a complete list of ChartFrame class members, see the ChartFrame Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


ChartFrame.SetPositionAuto Method

Set position of the frame to automatic

public virtual void SetPositionAuto();

See Also

ChartFrame Class | Aspose.Cells.Charts Namespace


ChartLineFormattingType Enumeration

Represents line format type of chart line.

public enum ChartLineFormattingType

Members

Member Name | Description | Value
Automatic | Represents automatic formatting type. | 0
Solid | Represents solid formatting type. | 1
None | Represents none formatting type. | 2
Gradient | Gradient | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


ChartMarkerType Enumeration

Represents the marker style in a line chart, scatter chart, or radar chart.

public enum ChartMarkerType

Members

Member Name | Description | Value
Automatic | Automatic markers. | 0
Circle | Circular markers. | 1
Dash | Long bar markers | 2
Diamond | Diamond-shaped markers. | 3
Dot | Short bar markers. | 4
None | No markers. | 5
SquarePlus | Square markers with a plus sign. | 6
Square | Square markers. | 7
SquareStar | Square markers with an asterisk. | 8
Triangle | Triangular markers. | 9
SquareX | Square markers with an X. | 10
Picture | Picture | 11

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


ChartPoint Class

Represents a single point in a series in a chart.

For a list of all members of this type, see ChartPoint Members.

System.Object
Aspose.Cells.Charts.ChartPoint

public class ChartPoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the first worksheet
Worksheet worksheet = workbook.Worksheets[0];

//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);

//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);

//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);

//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);

//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);

//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);

//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.PieExploded, 5, 0, 25, 10);

//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];

//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", true);

//Show Data Labels
chart.NSeries[0].DataLabels.IsValueShown = true;

for (int i = 0; i  < chart.NSeries[0].Points.Count; i++)
{
    //Get Data Point
    ChartPoint point = chart.NSeries[0].Points[i];
    //Set Pir Explosion
    point.Explosion = 15;
    //Set Border Color
    point.Border.Color = System.Drawing.Color.Red;
}

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the first worksheet
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)

'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)

'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)

'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)

'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)

'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)

'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.PieExploded, 5, 0, 25, 10)

'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)

'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", True)

'Show Data Labels
chart.NSeries(0).DataLabels.IsValueShown = True

For i As Integer = 0 To chart.NSeries(0).Points.Count - 1
    'Get Data Point
    Dim point As ChartPoint = chart.NSeries(0).Points(i)
    'Set Pir Explosion
    point.Explosion = 15
    'Set Border Color
    point.Border.Color = System.Drawing.Color.Red
Next i

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartPoint Members | Aspose.Cells.Charts Namespace


ChartPoint Members

ChartPoint overview

Public Instance Properties

ArcEndPointXPx | Gets the x coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
ArcEndPointYPx | Gets the y coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
ArcStartPointXPx | Gets the x coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
ArcStartPointYPx | Gets the y coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
Area | Gets the area.
Border | Gets the border.
BorderWidthPx | Gets the width of border in units of pixels after calls Chart.Calculate() method.
DataLabels | Returns a DataLabels object that represents the data label associated with the point.
EndAngle | Gets the ending angle for the pie section, measured in degrees clockwise from the x-axis after calls Chart.Calculate() method. Applies to Pie chart.
Explosion | The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.
InnerArcEndPointXPx | Gets the x coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerArcEndPointYPx | Gets the y coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerArcStartPointXPx | Gets the x coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerArcStartPointYPx | Gets the y coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerRadiusPx | Gets the inner radius of doughnut slice in units of pixels after calls Chart.Calculate() method. Applies to Doughnut chart.
IsInSecondaryPlot | Gets or sets a value indicates whether this data points is in the second pie or bar on a pie of pie or bar of pie chart
Marker | Gets the marker.
MarkerBackgroundColor | Obsolete. Represents the marker background color in a line chart, scatter chart, or radar chart.
MarkerBackgroundColorSetType | Obsolete. Gets or sets the marker background color set type.
MarkerForegroundColor | Obsolete. Represents the marker foreground color in a line chart, scatter chart, or radar chart.
MarkerForegroundColorSetType | Obsolete. Gets or sets the marker foreground color set type.
MarkerSize | Obsolete. Represents the marker size in a line chart, scatter chart, or radar chart.
MarkerStyle | Obsolete. Represents the marker style in a line chart, scatter chart, or radar chart.
RadiusPx | Gets the radius of bubble, pie or doughnut in units of pixels after calls Chart.Calculate() method.
Shadow | True if the chartpoint has a shadow.
ShapeHeight | Gets the height in units of 1/4000 of chart's height after calls Chart.Calculate() method.
ShapeHeightPx | Gets the height in units of pixels after calls Chart.Calculate() method.
ShapeProperties | Gets the object that holds the visual shape properties of the ChartPoint.
ShapeWidth | Gets the width in units of 1/4000 of chart's width after calls Chart.Calculate() method.
ShapeWidthPx | Gets the width in units of pixels after calls Chart.Calculate() method.
ShapeX | Gets the x coordinate of the upper left corner in units of 1/4000 of chart's width after calls Chart.Calculate() method.
ShapeXPx | Gets the x coordinate of the upper left corner in units of pixels after calls Chart.Calculate() method.
ShapeY | Gets the y coordinate of the upper left corner in units of 1/4000 of chart's height after calls Chart.Calculate() method.
ShapeYPx | Gets the y coordinate of the upper left corner in units of pixels after calls Chart.Calculate() method.
StartAngle | Gets the starting angle for the pie section, measured in degrees clockwise from the x-axis after calls Chart.Calculate() method. Applies to Pie chart.
XValue | Gets or sets the X value of the chart point.
XValueType | Gets X value type of the chart point.
YValue | Gets or sets the Y value of the chart point.
YValueType | Gets Y value type of the chart point.

Public Instance Methods

Equals (inherited from Object) |
GetBottomPointCount | Gets the number of bottom points after calls Chart.Calculate() method.
GetBottomPointXPx | Gets x-coordinate of the bottom point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid
GetBottomPointYPx | Gets y-coordinate of the bottom point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid
GetHashCode (inherited from Object) |
GetOnCategoryAxisPointCount | Gets the number of the points on category axis after calls Chart.Calculate() method. Only applies to area chart.
GetOnCategoryAxisPointXPx | Gets x-coordinate of the point on category axis after calls Chart.Calculate() method. Only applies to Area chart.
GetOnCategoryAxisPointYPx | Gets y-coordinate of the point on category axis after calls Chart.Calculate() method. Only applies to Area chart.
GetTopPointCount | Gets the number of top points after calls Chart.Calculate() method.
GetTopPointXPx | Gets x-coordinate of the top point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid and Area3D
GetTopPointYPx | Gets y-coordinate of the top point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid and Area3D
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint Properties

The properties of the ChartPoint class are listed below. For a complete list of ChartPoint class members, see the ChartPoint Members topic.

Public Instance Properties

ArcEndPointXPx | Gets the x coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
ArcEndPointYPx | Gets the y coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
ArcStartPointXPx | Gets the x coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
ArcStartPointYPx | Gets the y coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.
Area | Gets the area.
Border | Gets the border.
BorderWidthPx | Gets the width of border in units of pixels after calls Chart.Calculate() method.
DataLabels | Returns a DataLabels object that represents the data label associated with the point.
EndAngle | Gets the ending angle for the pie section, measured in degrees clockwise from the x-axis after calls Chart.Calculate() method. Applies to Pie chart.
Explosion | The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.
InnerArcEndPointXPx | Gets the x coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerArcEndPointYPx | Gets the y coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerArcStartPointXPx | Gets the x coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerArcStartPointYPx | Gets the y coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.
InnerRadiusPx | Gets the inner radius of doughnut slice in units of pixels after calls Chart.Calculate() method. Applies to Doughnut chart.
IsInSecondaryPlot | Gets or sets a value indicates whether this data points is in the second pie or bar on a pie of pie or bar of pie chart
Marker | Gets the marker.
MarkerBackgroundColor | Obsolete. Represents the marker background color in a line chart, scatter chart, or radar chart.
MarkerBackgroundColorSetType | Obsolete. Gets or sets the marker background color set type.
MarkerForegroundColor | Obsolete. Represents the marker foreground color in a line chart, scatter chart, or radar chart.
MarkerForegroundColorSetType | Obsolete. Gets or sets the marker foreground color set type.
MarkerSize | Obsolete. Represents the marker size in a line chart, scatter chart, or radar chart.
MarkerStyle | Obsolete. Represents the marker style in a line chart, scatter chart, or radar chart.
RadiusPx | Gets the radius of bubble, pie or doughnut in units of pixels after calls Chart.Calculate() method.
Shadow | True if the chartpoint has a shadow.
ShapeHeight | Gets the height in units of 1/4000 of chart's height after calls Chart.Calculate() method.
ShapeHeightPx | Gets the height in units of pixels after calls Chart.Calculate() method.
ShapeProperties | Gets the object that holds the visual shape properties of the ChartPoint.
ShapeWidth | Gets the width in units of 1/4000 of chart's width after calls Chart.Calculate() method.
ShapeWidthPx | Gets the width in units of pixels after calls Chart.Calculate() method.
ShapeX | Gets the x coordinate of the upper left corner in units of 1/4000 of chart's width after calls Chart.Calculate() method.
ShapeXPx | Gets the x coordinate of the upper left corner in units of pixels after calls Chart.Calculate() method.
ShapeY | Gets the y coordinate of the upper left corner in units of 1/4000 of chart's height after calls Chart.Calculate() method.
ShapeYPx | Gets the y coordinate of the upper left corner in units of pixels after calls Chart.Calculate() method.
StartAngle | Gets the starting angle for the pie section, measured in degrees clockwise from the x-axis after calls Chart.Calculate() method. Applies to Pie chart.
XValue | Gets or sets the X value of the chart point.
XValueType | Gets X value type of the chart point.
YValue | Gets or sets the Y value of the chart point.
YValueType | Gets Y value type of the chart point.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ArcEndPointXPx Property

Aspose.Cells for .NET

ChartPoint.ArcEndPointXPx Property

Gets the x coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.

public float ArcEndPointXPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ArcEndPointYPx Property

Aspose.Cells for .NET

ChartPoint.ArcEndPointYPx Property

Gets the y coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.

public float ArcEndPointYPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ArcStartPointXPx Property

Aspose.Cells for .NET

ChartPoint.ArcStartPointXPx Property

Gets the x coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.

public float ArcStartPointXPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ArcStartPointYPx Property

Aspose.Cells for .NET

ChartPoint.ArcStartPointYPx Property

Gets the y coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Pie and Doughnut chart.

public float ArcStartPointYPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

ChartPoint.Area Property

Gets the area.

public Area Area {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

ChartPoint.Border Property

Gets the border.

public Line Border {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


BorderWidthPx Property

Aspose.Cells for .NET

ChartPoint.BorderWidthPx Property

Gets the width of border in units of pixels after calls Chart.Calculate() method.

public int BorderWidthPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


DataLabels Property

Aspose.Cells for .NET

ChartPoint.DataLabels Property

Returns a DataLabels object that represents the data label associated with the point.

public DataLabels DataLabels {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


EndAngle Property

Aspose.Cells for .NET

ChartPoint.EndAngle Property

Gets the ending angle for the pie section, measured in degrees clockwise from the x-axis after calls Chart.Calculate() method. Applies to Pie chart.

public float EndAngle {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


Explosion Property

Aspose.Cells for .NET

ChartPoint.Explosion Property

The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.

public int Explosion {get; set;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


InnerArcEndPointXPx Property

Aspose.Cells for .NET

ChartPoint.InnerArcEndPointXPx Property

Gets the x coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.

public float InnerArcEndPointXPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


InnerArcEndPointYPx Property

Aspose.Cells for .NET

ChartPoint.InnerArcEndPointYPx Property

Gets the y coordinate of ending point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.

public float InnerArcEndPointYPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


InnerArcStartPointXPx Property

Aspose.Cells for .NET

ChartPoint.InnerArcStartPointXPx Property

Gets the x coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.

public float InnerArcStartPointXPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


InnerArcStartPointYPx Property

Aspose.Cells for .NET

ChartPoint.InnerArcStartPointYPx Property

Gets the y coordinate of starting point for the pie section after calls Chart.Calculate() method. Applies to Doughnut chart.

public float InnerArcStartPointYPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


InnerRadiusPx Property

Aspose.Cells for .NET

ChartPoint.InnerRadiusPx Property

Gets the inner radius of doughnut slice in units of pixels after calls Chart.Calculate() method. Applies to Doughnut chart.

public int InnerRadiusPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


IsInSecondaryPlot Property

Aspose.Cells for .NET

ChartPoint.IsInSecondaryPlot Property

Gets or sets a value indicates whether this data points is in the second pie or bar on a pie of pie or bar of pie chart

public bool IsInSecondaryPlot {get; set;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


Marker Property

Aspose.Cells for .NET

ChartPoint.Marker Property

Gets the marker.

public Marker Marker {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


MarkerBackgroundColor Property

Aspose.Cells for .NET

ChartPoint.MarkerBackgroundColor Property

NOTE: This property is now obsolete.

Use Marker.Area.ForegroundColor property instead.

Represents the marker background color in a line chart, scatter chart, or radar chart.

public Color MarkerBackgroundColor {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerBackgroundColor property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


MarkerBackgroundColorSetType Property

Aspose.Cells for .NET

ChartPoint.MarkerBackgroundColorSetType Property

NOTE: This property is now obsolete.

Use Marker.Area.Formatting property instead.

Gets or sets the marker background color set type.

public FormattingType MarkerBackgroundColorSetType {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerBackgroundColorSetType property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced. FormattingType.Automatic is same as ChartLineFormattingType.Automatic. FormattingType.None is same as ChartLineFormattingType.None. FormattingType.InnerCustom is same as ChartLineFormattingType.Solid.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


MarkerForegroundColor Property

Aspose.Cells for .NET

ChartPoint.MarkerForegroundColor Property

NOTE: This property is now obsolete.

Use Marker.Border.Color property instead.

Represents the marker foreground color in a line chart, scatter chart, or radar chart.

public Color MarkerForegroundColor {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerForegroundColor property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


MarkerForegroundColorSetType Property

Aspose.Cells for .NET

ChartPoint.MarkerForegroundColorSetType Property

NOTE: This property is now obsolete.

Use Marker.Border.Formatting property instead.

Gets or sets the marker foreground color set type.

public FormattingType MarkerForegroundColorSetType {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerForegroundColorSetType property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced. FormattingType.Automatic is same as ChartLineFormattingType.Automatic. FormattingType.None is same as ChartLineFormattingType.None. FormattingType.InnerCustom is same as ChartLineFormattingType.Solid.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


MarkerSize Property

Aspose.Cells for .NET

ChartPoint.MarkerSize Property

NOTE: This property is now obsolete.

Use Marker.MarkerSize property instead.

Represents the marker size in a line chart, scatter chart, or radar chart.

public int MarkerSize {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerSize property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


MarkerStyle Property

Aspose.Cells for .NET

ChartPoint.MarkerStyle Property

NOTE: This property is now obsolete.

Use Marker.MarkerStyle property instead.

Represents the marker style in a line chart, scatter chart, or radar chart.

public ChartMarkerType MarkerStyle {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerStyle property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


RadiusPx Property

Aspose.Cells for .NET

ChartPoint.RadiusPx Property

Gets the radius of bubble, pie or doughnut in units of pixels after calls Chart.Calculate() method.

public int RadiusPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


Shadow Property

Aspose.Cells for .NET

ChartPoint.Shadow Property

True if the chartpoint has a shadow.

public bool Shadow {get; set;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeHeight Property

Aspose.Cells for .NET

ChartPoint.ShapeHeight Property

Gets the height in units of 1/4000 of chart's height after calls Chart.Calculate() method.

public int ShapeHeight {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeHeightPx Property

Aspose.Cells for .NET

ChartPoint.ShapeHeightPx Property

Gets the height in units of pixels after calls Chart.Calculate() method.

public int ShapeHeightPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeProperties Property

Aspose.Cells for .NET

ChartPoint.ShapeProperties Property

Gets the object that holds the visual shape properties of the ChartPoint.

public ShapePropertyCollection ShapeProperties {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace | ShapePropertyCollection


ShapeWidth Property

Aspose.Cells for .NET

ChartPoint.ShapeWidth Property

Gets the width in units of 1/4000 of chart's width after calls Chart.Calculate() method.

public int ShapeWidth {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeWidthPx Property

Aspose.Cells for .NET

ChartPoint.ShapeWidthPx Property

Gets the width in units of pixels after calls Chart.Calculate() method.

public int ShapeWidthPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeX Property

Aspose.Cells for .NET

ChartPoint.ShapeX Property

Gets the x coordinate of the upper left corner in units of 1/4000 of chart's width after calls Chart.Calculate() method.

public int ShapeX {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeXPx Property

Aspose.Cells for .NET

ChartPoint.ShapeXPx Property

Gets the x coordinate of the upper left corner in units of pixels after calls Chart.Calculate() method.

public int ShapeXPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeY Property

Aspose.Cells for .NET

ChartPoint.ShapeY Property

Gets the y coordinate of the upper left corner in units of 1/4000 of chart's height after calls Chart.Calculate() method.

public int ShapeY {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ShapeYPx Property

Aspose.Cells for .NET

ChartPoint.ShapeYPx Property

Gets the y coordinate of the upper left corner in units of pixels after calls Chart.Calculate() method.

public int ShapeYPx {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


StartAngle Property

Aspose.Cells for .NET

ChartPoint.StartAngle Property

Gets the starting angle for the pie section, measured in degrees clockwise from the x-axis after calls Chart.Calculate() method. Applies to Pie chart.

public float StartAngle {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


XValue Property

Aspose.Cells for .NET

ChartPoint.XValue Property

Gets or sets the X value of the chart point.

public object XValue {get; set;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


XValueType Property

Aspose.Cells for .NET

ChartPoint.XValueType Property

Gets X value type of the chart point.

public CellValueType XValueType {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


YValue Property

Aspose.Cells for .NET

ChartPoint.YValue Property

Gets or sets the Y value of the chart point.

public object YValue {get; set;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


YValueType Property

Aspose.Cells for .NET

ChartPoint.YValueType Property

Gets Y value type of the chart point.

public CellValueType YValueType {get;}

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint Methods

The methods of the ChartPoint class are listed below. For a complete list of ChartPoint class members, see the ChartPoint Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetBottomPointCount | Gets the number of bottom points after calls Chart.Calculate() method.
GetBottomPointXPx | Gets x-coordinate of the bottom point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid
GetBottomPointYPx | Gets y-coordinate of the bottom point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid
GetHashCode (inherited from Object) |
GetOnCategoryAxisPointCount | Gets the number of the points on category axis after calls Chart.Calculate() method. Only applies to area chart.
GetOnCategoryAxisPointXPx | Gets x-coordinate of the point on category axis after calls Chart.Calculate() method. Only applies to Area chart.
GetOnCategoryAxisPointYPx | Gets y-coordinate of the point on category axis after calls Chart.Calculate() method. Only applies to Area chart.
GetTopPointCount | Gets the number of top points after calls Chart.Calculate() method.
GetTopPointXPx | Gets x-coordinate of the top point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid and Area3D
GetTopPointYPx | Gets y-coordinate of the top point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid and Area3D
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetBottomPointCount Method

Gets the number of bottom points after calls Chart.Calculate() method.

public int GetBottomPointCount();

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetBottomPointXPx Method

Gets x-coordinate of the bottom point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid

public float GetBottomPointXPx(
int index
);

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetBottomPointYPx Method

Gets y-coordinate of the bottom point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid

public float GetBottomPointYPx(
int index
);

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetOnCategoryAxisPointCount Method

Gets the number of the points on category axis after calls Chart.Calculate() method. Only applies to area chart.

public int GetOnCategoryAxisPointCount();

Remarks

Area 2D chart return 1 Area 3D chart return 2.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetOnCategoryAxisPointXPx Method

Gets x-coordinate of the point on category axis after calls Chart.Calculate() method. Only applies to Area chart.

public float GetOnCategoryAxisPointXPx(
int index
);

Remarks

Area 2D chart: index is 0. Area 3D chart: index is 0 or 1.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetOnCategoryAxisPointYPx Method

Gets y-coordinate of the point on category axis after calls Chart.Calculate() method. Only applies to Area chart.

public float GetOnCategoryAxisPointYPx(
int index
);

Remarks

Area 2D chart: index is 0. Area 3D chart: index is 0 or 1.

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetTopPointCount Method

Gets the number of top points after calls Chart.Calculate() method.

public int GetTopPointCount();

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetTopPointXPx Method

Gets x-coordinate of the top point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid and Area3D

public float GetTopPointXPx(
int index
);

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPoint.GetTopPointYPx Method

Gets y-coordinate of the top point of shape after calls Chart.Calculate() method. Applies 3D charts: Column3D, Bar3D, Cone, Cylinder, Pyramid and Area3D

public float GetTopPointYPx(
int index
);

See Also

ChartPoint Class | Aspose.Cells.Charts Namespace


ChartPointCollection Class

Represents a collection that contains all the points in one series.

For a list of all members of this type, see ChartPointCollection Members.

System.Object
Aspose.Cells.Charts.ChartPointCollection

public class ChartPointCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Requirements
Namespace:  Aspose.Cells.Charts
Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also
ChartPointCollection Members | Aspose.Cells.Charts Namespace


ChartPointCollection Members

ChartPointCollection overview

Public Instance Properties

Count | Gets the count of the chart point.
Item | Gets the ChartPoint element at the specified index in the series.

Public Instance Methods

Clear | Remove all setting of the chart points.
Equals (inherited from Object) |
GetEnumerator | Returns an enumerator for the entire ChartPointCollection.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes point at the index of the series..
ToString (inherited from Object) |

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


ChartPointCollection Properties

The properties of the ChartPointCollection class are listed below. For a complete list of ChartPointCollection class members, see the ChartPointCollection Members topic.

Public Instance Properties

Count | Gets the count of the chart point.
Item | Gets the ChartPoint element at the specified index in the series.

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


Count Property

Aspose.Cells for .NET

ChartPointCollection.Count Property

Gets the count of the chart point.

public int Count {get;}

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

ChartPointCollection.Item Property

Gets the ChartPoint element at the specified index in the series.

public ChartPoint this[
int index
] {get;}

Parameters

index
The index of chart point in the series.

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


ChartPointCollection Methods

The methods of the ChartPointCollection class are listed below. For a complete list of ChartPointCollection class members, see the ChartPointCollection Members topic.

Public Instance Methods

Clear | Remove all setting of the chart points.
Equals (inherited from Object) |
GetEnumerator | Returns an enumerator for the entire ChartPointCollection.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes point at the index of the series..
ToString (inherited from Object) |

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


ChartPointCollection.Clear Method

Remove all setting of the chart points.

public void Clear();

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


ChartPointCollection.GetEnumerator Method

Returns an enumerator for the entire ChartPointCollection.

public IEnumerator GetEnumerator();

Return Value

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


ChartPointCollection.RemoveAt Method

Removes point at the index of the series..

public void RemoveAt(
int index
);

Parameters

index
The index of the point.

See Also

ChartPointCollection Class | Aspose.Cells.Charts Namespace


ChartSplitType Enumeration

Represents the way the two sections of either a pie of pie chart or a bar of pie chart are split.

public enum ChartSplitType

Members

Member Name | Description | Value
Position | Represents the data points shall be split between the pie and the second chart by putting the last Split Position of the data points in the second chart | 0
Value | Represents the data points shall be split between the pie and the second chart by putting the data points with value less than Split Position in the second chart. | 1
PercentValue | Represents the data points shall be split between the pie and the second chart by putting the points with percentage less than Split Position percent in the second chart. | 2
Custom | Represents the data points shall be split between the pie and the second chart according to the Custom Split values. | 3
Auto | Represents the data points shall be split using the default mechanism for this chart type. | 4

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


ChartTextDirectionType Enumeration

Represents the text direction type of the chart.

public enum ChartTextDirectionType

Members

Member Name | Description | Value
Horizontal | Horizontal direction type. | 0
Vertical | Vertical direction type. | 1
Rotate90 | Rotate 90 angle. | 2
Rotate270 | Rotate 270 angle. | 3
Stacked | Stacked text. | 4

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


ChartTextFrame Class

Encapsulates the object that represents the frame object which contains text.

For a list of all members of this type, see ChartTextFrame Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartTextFrame
Aspose.Cells.Charts.DataLabels
Aspose.Cells.Charts.DisplayUnitLabel
Aspose.Cells.Charts.Title

public class ChartTextFrame : ChartFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartTextFrame Members | Aspose.Cells.Charts Namespace


ChartTextFrame Members

ChartTextFrame overview

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType | Gets and sets the direction of text.
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped | Gets or sets a value indicating whether the text is wrapped.
LinkedSource | Gets and sets a reference to the worksheet.
ReadingOrder | Represents text reading order.
RotationAngle | Represents text rotation angle.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
Text | Gets or sets the text of a frame's title.
TextDirection | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment | Gets and sets the text horizontal alignment.
TextVerticalAlignment | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

Public Instance Methods

Characters | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


ChartTextFrame Properties

The properties of the ChartTextFrame class are listed below. For a complete list of ChartTextFrame class members, see the ChartTextFrame Members topic.

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType | Gets and sets the direction of text.
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped | Gets or sets a value indicating whether the text is wrapped.
LinkedSource | Gets and sets a reference to the worksheet.
ReadingOrder | Represents text reading order.
RotationAngle | Represents text rotation angle.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
Text | Gets or sets the text of a frame's title.
TextDirection | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment | Gets and sets the text horizontal alignment.
TextVerticalAlignment | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


DirectionType Property

Aspose.Cells for .NET

ChartTextFrame.DirectionType Property

Gets and sets the direction of text.

public virtual ChartTextDirectionType DirectionType {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


IsAutoText Property

Aspose.Cells for .NET

ChartTextFrame.IsAutoText Property

Indicates the text is auto generated.

public virtual bool IsAutoText {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


IsDeleted Property

Aspose.Cells for .NET

ChartTextFrame.IsDeleted Property

Indicates whether this data labels is deleted.

public bool IsDeleted {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


IsResizeShapeToFitText Property

Aspose.Cells for .NET

ChartTextFrame.IsResizeShapeToFitText Property

Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.

public bool IsResizeShapeToFitText {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


IsTextWrapped Property

Aspose.Cells for .NET

ChartTextFrame.IsTextWrapped Property

Gets or sets a value indicating whether the text is wrapped.

public virtual bool IsTextWrapped {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


LinkedSource Property

Aspose.Cells for .NET

ChartTextFrame.LinkedSource Property

Gets and sets a reference to the worksheet.

public virtual string LinkedSource {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


ReadingOrder Property

Aspose.Cells for .NET

ChartTextFrame.ReadingOrder Property

Represents text reading order.

public TextDirectionType ReadingOrder {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


RotationAngle Property

Aspose.Cells for .NET

ChartTextFrame.RotationAngle Property

Represents text rotation angle.

public int RotationAngle {get; set;}

Remarks

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


Text Property

Aspose.Cells for .NET

ChartTextFrame.Text Property

Gets or sets the text of a frame's title.

public virtual string Text {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


TextDirection Property

Aspose.Cells for .NET

ChartTextFrame.TextDirection Property

NOTE: This property is now obsolete.

Use ChartTextFrame.ReadingOrder property instead.

Represents text reading order.

public TextDirectionType TextDirection {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use ChartTextFrame.ReadingOrder property. This property will be removed 12 months later since March 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


TextHorizontalAlignment Property

Aspose.Cells for .NET

ChartTextFrame.TextHorizontalAlignment Property

Gets and sets the text horizontal alignment.

public TextAlignmentType TextHorizontalAlignment {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


TextVerticalAlignment Property

Aspose.Cells for .NET

ChartTextFrame.TextVerticalAlignment Property

Gets or sets the text vertical alignment of text.

public TextAlignmentType TextVerticalAlignment {get; set;}

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


ChartTextFrame Methods

The methods of the ChartTextFrame class are listed below. For a complete list of ChartTextFrame class members, see the ChartTextFrame Members topic.

Public Instance Methods

Characters | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


ChartTextFrame.Characters Method

Returns a Characters object that represents a range of characters within the text.

public FontSetting Characters(
int startIndex,
int length
);

Parameters

startIndex
The index of the start of the character.
length
The number of characters.

Return Value

Characters object.

See Also

ChartTextFrame Class | Aspose.Cells.Charts Namespace


ChartType Enumeration

Enumerates all chart types used in Excel.

public enum ChartType

Members

Member Name | Description | Value
Area | Represents Area Chart. | 0
AreaStacked | Represents Stacked Area Chart. | 1
Area100PercentStacked | Represents 100% Stacked Area Chart. | 2
Area3D | Represents 3D Area Chart. | 3
Area3DStacked | Represents 3D Stacked Area Chart. | 4
Area3D100PercentStacked | Represents 3D 100% Stacked Area Chart. | 5
Bar | Represents Bar Chart: Clustered Bar Chart. | 6
BarStacked | Represents Stacked Bar Chart. | 7
Bar100PercentStacked | Represents 100% Stacked Bar Chart. | 8
Bar3DClustered | Represents 3D Colustered Bar Chart. | 9
Bar3DStacked | Represents 3D Stacked Bar Chart. | 10
Bar3D100PercentStacked | Represents 3D 100% Stacked Bar Chart. | 11
Bubble | Represents Bubble Chart. | 12
Bubble3D | Represents 3D Bubble Chart. | 13
Column | Represents Column Chart: Clustered Column Chart. | 14
ColumnStacked | Represents Stacked Column Chart. | 15
Column100PercentStacked | Represents 100% Stacked Column Chart. | 16
Column3D | Represents 3D Column Chart. | 17
Column3DClustered | Represents 3D Clustered Column Chart. | 18
Column3DStacked | Represents 3D Stacked Column Chart. | 19
Column3D100PercentStacked | Represents 3D 100% Stacked Column Chart. | 20
Cone | Represents Cone Chart. | 21
ConeStacked | Represents Stacked Cone Chart. | 22
Cone100PercentStacked | Represents 100% Stacked Cone Chart. | 23
ConicalBar | Represents Conical Bar Chart. | 24
ConicalBarStacked | Represents Stacked Conical Bar Chart. | 25
ConicalBar100PercentStacked | Represents 100% Stacked Conical Bar Chart. | 26
ConicalColumn3D | Represents 3D Conical Column Chart. | 27
Cylinder | Represents Cylinder Chart. | 28
CylinderStacked | Represents Stacked Cylinder Chart. | 29
Cylinder100PercentStacked | Represents 100% Stacked Cylinder Chart. | 30
CylindricalBar | Represents Cylindrical Bar Chart. | 31
CylindricalBarStacked | Represents Stacked Cylindrical Bar Chart. | 32
CylindricalBar100PercentStacked | Represents 100% Stacked Cylindrical Bar Chart. | 33
CylindricalColumn3D | Represents 3D Cylindrical Column Chart. | 34
Doughnut | Represents Doughnut Chart. | 35
DoughnutExploded | Represents Exploded Doughnut Chart. | 36
Line | Represents Line Chart. | 37
LineStacked | Represents Stacked Line Chart. | 38
Line100PercentStacked | Represents 100% Stacked Line Chart. | 39
LineWithDataMarkers | Represents Line Chart with data markers. | 40
LineStackedWithDataMarkers | Represents Stacked Line Chart with data markers. | 41
Line100PercentStackedWithDataMarkers | Represents 100% Stacked Line Chart with data markers. | 42
Line3D | Represents 3D Line Chart. | 43
Pie | Represents Pie Chart. | 44
Pie3D | Represents 3D Pie Chart. | 45
PiePie | Represents Pie of Pie Chart. | 46
PieExploded | Represents Exploded Pie Chart. | 47
Pie3DExploded | Represents 3D Exploded Pie Chart. | 48
PieBar | Represents Bar of Pie Chart. | 49
Pyramid | Represents Pyramid Chart. | 50
PyramidStacked | Represents Stacked Pyramid Chart. | 51
Pyramid100PercentStacked | Represents 100% Stacked Pyramid Chart. | 52
PyramidBar | Represents Pyramid Bar Chart. | 53
PyramidBarStacked | Represents Stacked Pyramid Bar Chart. | 54
PyramidBar100PercentStacked | Represents 100% Stacked Pyramid Bar Chart. | 55
PyramidColumn3D | Represents 3D Pyramid Column Chart. | 56
Radar | Represents Radar Chart. | 57
RadarWithDataMarkers | Represents Radar Chart with data markers. | 58
RadarFilled | Represents Filled Radar Chart. | 59
Scatter | Represents Scatter Chart. | 60
ScatterConnectedByCurvesWithDataMarker | Represents Scatter Chart connected by curves, with data markers. | 61
ScatterConnectedByCurvesWithoutDataMarker | Represents Scatter Chart connected by curves, without data markers. | 62
ScatterConnectedByLinesWithDataMarker | Represents Scatter Chart connected by lines, with data markers. | 63
ScatterConnectedByLinesWithoutDataMarker | Represents Scatter Chart connected by lines, without data markers. | 64
StockHighLowClose | Represents High-Low-Close Stock Chart. | 65
StockOpenHighLowClose | Represents Open-High-Low-Close Stock Chart. | 66
StockVolumeHighLowClose | Represents Volume-High-Low-Close Stock Chart. | 67
StockVolumeOpenHighLowClose | Represents Volume-Open-High-Low-Close Stock Chart. | 68
Surface3D | Represents Surface Chart: 3D Surface Chart. | 69
SurfaceWireframe3D | Represents Wireframe 3D Surface Chart. | 70
SurfaceContour | Represents Contour Chart. | 71
SurfaceContourWireframe | Represents Wireframe Contour Chart. | 72
BoxWhisker | The series is laid out as box and whisker. | 73
Funnel | The series is laid out as a funnel. | 74
ParetoLine | The series is laid out as pareto lines. | 75
Sunburst | The series is laid out as a sunburst. | 76
Treemap | The series is laid out as a treemap. | 77
Waterfall | The series is laid out as a waterfall. | 78
Histogram | The series is laid out as a histogram. | 79
Map | The series is laid out as a region map. | 80

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


CrossType Enumeration

Represents the axis cross type.

public enum CrossType

Members

Member Name | Description | Value
Automatic | Microsoft Excel sets the axis crossing point. | 0
Maximum | The axis crosses at the maximum value. | 1
Minimum | The axis crosses at the minimum value. | 2
Custom | The axis crosses at the custom value. | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


DataLabels Class

Encapsulates a collection of all the DataLabel objects for the specified Series.

For a list of all members of this type, see DataLabels Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartTextFrame
Aspose.Cells.Charts.DataLabels

public class DataLabels : ChartTextFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Set the DataLabels in the chart
 DataLabels datalabels;
 for (int i = 0; i  <chart.NSeries.Count; i++)
 {
     datalabels = chart.NSeries[i].DataLabels;
     //Set the position of DataLabels
     datalabels.Position = LabelPositionType.InsideBase;
     //Show the category name in the DataLabels
     datalabels.ShowCategoryName = true;
     //Show the value in the DataLabels
     datalabels.ShowValue = true;
     //Not show the percentage in the DataLabels
     datalabels.ShowPercentage = false;
     //Not show the legend key.
     datalabels.ShowLegendKey = false;
 }

 [Visual Basic]

 'Set the DataLabels in the chart
 Dim datalabels As DataLabels
 Dim i As Integer
 For i = 0 To chart.NSeries.Count - 1 Step 1
     datalabels = chart.NSeries(i).DataLabels
     'Set the position of DataLabels
     datalabels.Position = LabelPositionType.InsideBase
     'Show the category name in the DataLabels
     datalabels.ShowCategoryName= True
     'Show the value in the DataLabels
     datalabels.ShowValue = True
     'Not show the percentage in the DataLabels
     datalabels.ShowPercentage = False
     'Not show the legend key.
     datalabels.ShowLegendKey = False
 Next

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataLabels Members | Aspose.Cells.Charts Namespace


DataLabels Members

DataLabels overview

Public Instance Properties

Area | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Border | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType | Gets and sets the direction of text.
Font | Gets the font of the DataLabels;
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted (inherited from ChartTextFrame) | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText (inherited from ChartTextFrame) | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped | Gets or sets a value indicating whether the text is wrapped.
LinkedSource | Gets and sets the linked source.
Number | Gets and sets the built-in number format.
NumberFormat | Represents the format string for the DataLabels object.
NumberFormatLinked | True if the number format is linked to the cells (so that the number format changes in the labels when it changes in the cells).
Position | Represents the position of the data label.
ReadingOrder (inherited from ChartTextFrame) | Represents text reading order.
RotationAngle (inherited from ChartTextFrame) | Represents text rotation angle.
Separator | Obsolete. Gets or sets the separator type used for the data labels on a chart.
SeparatorType | Gets or sets the separator type used for the data labels on a chart.
SeparatorValue | Gets or sets the separator value used for the data labels on a chart.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
ShapeType | Gets or sets shape type of data label.
ShowBubbleSize | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide.
ShowCategoryName | Represents a specified chart's data label category name display behavior.True to display the category name for the data labels on a chart. False to hide.
ShowCellRange | Indicates whether showing cell range as the data labels.
ShowLegendKey | Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible.
ShowPercentage | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide.
ShowSeriesName | Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide.
ShowValue | Represents a specified chart's data label values display behavior. True displays the values. False to hide.
Text | Gets or sets the text of data label.
TextDirection (inherited from ChartTextFrame) | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment (inherited from ChartTextFrame) | Gets and sets the text horizontal alignment.
TextVerticalAlignment (inherited from ChartTextFrame) | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

Public Instance Methods

Characters (inherited from ChartTextFrame) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


DataLabels Properties

The properties of the DataLabels class are listed below. For a complete list of DataLabels class members, see the DataLabels Members topic.

Public Instance Properties

Area | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Border | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType | Gets and sets the direction of text.
Font | Gets the font of the DataLabels;
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted (inherited from ChartTextFrame) | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText (inherited from ChartTextFrame) | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped | Gets or sets a value indicating whether the text is wrapped.
LinkedSource | Gets and sets the linked source.
Number | Gets and sets the built-in number format.
NumberFormat | Represents the format string for the DataLabels object.
NumberFormatLinked | True if the number format is linked to the cells (so that the number format changes in the labels when it changes in the cells).
Position | Represents the position of the data label.
ReadingOrder (inherited from ChartTextFrame) | Represents text reading order.
RotationAngle (inherited from ChartTextFrame) | Represents text rotation angle.
Separator | Obsolete. Gets or sets the separator type used for the data labels on a chart.
SeparatorType | Gets or sets the separator type used for the data labels on a chart.
SeparatorValue | Gets or sets the separator value used for the data labels on a chart.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
ShapeType | Gets or sets shape type of data label.
ShowBubbleSize | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide.
ShowCategoryName | Represents a specified chart's data label category name display behavior.True to display the category name for the data labels on a chart. False to hide.
ShowCellRange | Indicates whether showing cell range as the data labels.
ShowLegendKey | Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible.
ShowPercentage | Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide.
ShowSeriesName | Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide.
ShowValue | Represents a specified chart's data label values display behavior. True displays the values. False to hide.
Text | Gets or sets the text of data label.
TextDirection (inherited from ChartTextFrame) | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment (inherited from ChartTextFrame) | Gets and sets the text horizontal alignment.
TextVerticalAlignment (inherited from ChartTextFrame) | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

DataLabels.Area Property

Gets the area.

public override Area Area {get;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


BackgroundMode Property

Aspose.Cells for .NET

DataLabels.BackgroundMode Property

Gets and sets the display mode of the background

new public BackgroundMode BackgroundMode {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

DataLabels.Border Property

Gets the border.

public override Line Border {get;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


DirectionType Property

Aspose.Cells for .NET

DataLabels.DirectionType Property

Gets and sets the direction of text.

public override ChartTextDirectionType DirectionType {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

DataLabels.Font Property

Gets the font of the DataLabels;

public override Font Font {get;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


IsAutoText Property

Aspose.Cells for .NET

DataLabels.IsAutoText Property

Indicates the text is auto generated.

public override bool IsAutoText {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


IsTextWrapped Property

Aspose.Cells for .NET

DataLabels.IsTextWrapped Property

Gets or sets a value indicating whether the text is wrapped.

public override bool IsTextWrapped {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


LinkedSource Property

Aspose.Cells for .NET

DataLabels.LinkedSource Property

Gets and sets the linked source.

public override string LinkedSource {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Number Property

Aspose.Cells for .NET

DataLabels.Number Property

Gets and sets the built-in number format.

public int Number {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


NumberFormat Property

Aspose.Cells for .NET

DataLabels.NumberFormat Property

Represents the format string for the DataLabels object.

public string NumberFormat {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


NumberFormatLinked Property

Aspose.Cells for .NET

DataLabels.NumberFormatLinked Property

True if the number format is linked to the cells (so that the number format changes in the labels when it changes in the cells).

public bool NumberFormatLinked {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Position Property

Aspose.Cells for .NET

DataLabels.Position Property

Represents the position of the data label.

public LabelPositionType Position {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Separator Property

Aspose.Cells for .NET

DataLabels.Separator Property

NOTE: This property is now obsolete.

Use DataLabels.SeparatorType instead.

Gets or sets the separator type used for the data labels on a chart.

public DataLablesSeparatorType Separator {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use DataLabels.SeparatorType property. This property will be removed 12 months later since September 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


SeparatorType Property

Aspose.Cells for .NET

DataLabels.SeparatorType Property

Gets or sets the separator type used for the data labels on a chart.

public DataLabelsSeparatorType SeparatorType {get; set;}

Remarks

To set custom separator, please set the property SeparatorType as Custom and then specify the expected value for SeparatorValue.

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


SeparatorValue Property

Aspose.Cells for .NET

DataLabels.SeparatorValue Property

Gets or sets the separator value used for the data labels on a chart.

public string SeparatorValue {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShapeType Property

Aspose.Cells for .NET

DataLabels.ShapeType Property

Gets or sets shape type of data label.

public DataLabelShapeType ShapeType {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowBubbleSize Property

Aspose.Cells for .NET

DataLabels.ShowBubbleSize Property

Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide.

public bool ShowBubbleSize {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowCategoryName Property

Aspose.Cells for .NET

DataLabels.ShowCategoryName Property

Represents a specified chart's data label category name display behavior.True to display the category name for the data labels on a chart. False to hide.

public bool ShowCategoryName {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowCellRange Property

Aspose.Cells for .NET

DataLabels.ShowCellRange Property

Indicates whether showing cell range as the data labels.

public bool ShowCellRange {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowLegendKey Property

Aspose.Cells for .NET

DataLabels.ShowLegendKey Property

Represents a specified chart's data label legend key display behavior. True if the data label legend key is visible.

public bool ShowLegendKey {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowPercentage Property

Aspose.Cells for .NET

DataLabels.ShowPercentage Property

Represents a specified chart's data label percentage value display behavior. True displays the percentage value. False to hide.

public bool ShowPercentage {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowSeriesName Property

Aspose.Cells for .NET

DataLabels.ShowSeriesName Property

Returns or sets a Boolean to indicate the series name display behavior for the data labels on a chart. True to show the series name. False to hide.

public bool ShowSeriesName {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


ShowValue Property

Aspose.Cells for .NET

DataLabels.ShowValue Property

Represents a specified chart's data label values display behavior. True displays the values. False to hide.

public bool ShowValue {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


Text Property

Aspose.Cells for .NET

DataLabels.Text Property

Gets or sets the text of data label.

public override string Text {get; set;}

See Also

DataLabels Class | Aspose.Cells.Charts Namespace


DataLabelsSeparatorType Enumeration

Represents the separator type of DataLabels.

public enum DataLabelsSeparatorType

Members

Member Name | Description | Value
Auto | Represents automatic separator | 0
Space | Represents space(" ") | 1
Comma | Represents comma(",") | 2
Semicolon | Represents semicolon(";") | 3
Period | Represents period(".") | 4
NewLine | Represents newline("\n") | 5
Custom | Represents custom separator | 6

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


DataLablesSeparatorType Enumeration

NOTE: This enumeration is now obsolete.

Use DataLabelsSeparatorType enum instead.

Represents the separator type of DataLabels.

public enum DataLablesSeparatorType

Remarks

NOTE: This member is now obsolete. Instead, please use DataLabelsSeparatorType enum. This property will be removed 12 months later since September 2020. Aspose apologizes for any inconvenience you may have experienced.

Members

Member Name | Description | Value
Auto | Represents automatic separator | 0
Space | Represents space(" ") | 1
Comma | Represents comma(",") | 2
Semicolon | Represents semicolon(";") | 3
Period | Represents period(".") | 4
NewLine | Represents newline("\n") | 5
Custom | Represents custom separator | 6

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


DisplayUnitLabel Class

Represents the display unit label.

For a list of all members of this type, see DisplayUnitLabel Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartTextFrame
Aspose.Cells.Charts.DisplayUnitLabel

public class DisplayUnitLabel : ChartTextFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Excel object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a sample value to "A4" cell
worksheet.Cells["A4"].PutValue(200);
//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);
//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);
//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);
//Adding a sample value to "B4" cell
worksheet.Cells["B4"].PutValue(40);
//Adding a sample value to "C1" cell as category data
worksheet.Cells["C1"].PutValue("Q1");
//Adding a sample value to "C2" cell as category data
worksheet.Cells["C2"].PutValue("Q2");
//Adding a sample value to "C3" cell as category data
worksheet.Cells["C3"].PutValue("Y1");
//Adding a sample value to "C4" cell as category data
worksheet.Cells["C4"].PutValue("Y2");
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", true);
//Setting the data source for the category data of NSeries
chart.NSeries.CategoryData = "C1:C4";
//Setting the display unit of value(Y) axis.
chart.ValueAxis.DisplayUnit = DisplayUnitType.Hundreds;
DisplayUnitLabel displayUnitLabel = chart.ValueAxis.DisplayUnitLabel;
//Setting the custom display unit label
displayUnitLabel.Text = "100";
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Excel object
Dim sheetIndex As Int32 = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a sample value to "A4" cell
worksheet.Cells("A4").PutValue(200)
'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)
'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)
'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)
'Adding a sample value to "B4" cell
worksheet.Cells("B4").PutValue(40)
'Adding a sample value to "C1" cell as category data
worksheet.Cells("C1").PutValue("Q1")
'Adding a sample value to "C2" cell as category data
worksheet.Cells("C2").PutValue("Q2")
'Adding a sample value to "C3" cell as category data
worksheet.Cells("C3").PutValue("Y1")
'Adding a sample value to "C4" cell as category data
worksheet.Cells("C4").PutValue("Y2")
'Adding a chart to the worksheet
Dim chartIndex As Int32 = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", True)
'Setting the data source for the category data of NSeries
Chart.NSeries.CategoryData = "C1:C4"
'Setting the display unit of value(Y) axis.
chart.ValueAxis.DisplayUnit = DisplayUnitType.Hundreds
Dim displayUnitLabel As DisplayUnitLabel = chart.ValueAxis.DisplayUnitLabel
'Setting the custom display unit label
displayUnitLabel.Text = "100"
'Saving the Excel file
workbook.Save("C:\\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DisplayUnitLabel Members | Aspose.Cells.Charts Namespace


DisplayUnitLabel Members

DisplayUnitLabel overview

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType (inherited from ChartTextFrame) | Gets and sets the direction of text.
Font | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText (inherited from ChartTextFrame) | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted (inherited from ChartTextFrame) | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText (inherited from ChartTextFrame) | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped (inherited from ChartTextFrame) | Gets or sets a value indicating whether the text is wrapped.
LinkedSource (inherited from ChartTextFrame) | Gets and sets a reference to the worksheet.
ReadingOrder (inherited from ChartTextFrame) | Represents text reading order.
RotationAngle (inherited from ChartTextFrame) | Represents text rotation angle.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
Text | Gets or sets the text of display unit label.
TextDirection (inherited from ChartTextFrame) | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment (inherited from ChartTextFrame) | Gets and sets the text horizontal alignment.
TextVerticalAlignment (inherited from ChartTextFrame) | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

Public Instance Methods

Characters (inherited from ChartTextFrame) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

DisplayUnitLabel Class | Aspose.Cells.Charts Namespace


DisplayUnitLabel Properties

The properties of the DisplayUnitLabel class are listed below. For a complete list of DisplayUnitLabel class members, see the DisplayUnitLabel Members topic.

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType (inherited from ChartTextFrame) | Gets and sets the direction of text.
Font | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText (inherited from ChartTextFrame) | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted (inherited from ChartTextFrame) | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText (inherited from ChartTextFrame) | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped (inherited from ChartTextFrame) | Gets or sets a value indicating whether the text is wrapped.
LinkedSource (inherited from ChartTextFrame) | Gets and sets a reference to the worksheet.
ReadingOrder (inherited from ChartTextFrame) | Represents text reading order.
RotationAngle (inherited from ChartTextFrame) | Represents text rotation angle.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
Text | Gets or sets the text of display unit label.
TextDirection (inherited from ChartTextFrame) | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment (inherited from ChartTextFrame) | Gets and sets the text horizontal alignment.
TextVerticalAlignment (inherited from ChartTextFrame) | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

See Also

DisplayUnitLabel Class | Aspose.Cells.Charts Namespace


AutoScaleFont Property

Aspose.Cells for .NET

DisplayUnitLabel.AutoScaleFont Property

True if the text in the object changes font size when the object size changes. The default value is True.

public override bool AutoScaleFont {get; set;}

See Also

DisplayUnitLabel Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

DisplayUnitLabel.Font Property

Gets a Font object of the specified ChartFrame object.

public override Font Font {get;}

See Also

DisplayUnitLabel Class | Aspose.Cells.Charts Namespace


Text Property

Aspose.Cells for .NET

DisplayUnitLabel.Text Property

Gets or sets the text of display unit label.

public override string Text {get; set;}

See Also

DisplayUnitLabel Class | Aspose.Cells.Charts Namespace


DisplayUnitType Enumeration

Represents the type of display unit.

public enum DisplayUnitType

Members

Member Name | Description | Value
None | Display unit is None. | 0
Hundreds | Specifies the values on the chart shall be divided by 100. | 1
Thousands | Specifies the values on the chart shall be divided by 1,000. | 2
TenThousands | Specifies the values on the chart shall be divided by 10,000. | 3
HundredThousands | Specifies the values on the chart shall be divided by 100,000. | 4
Millions | Specifies the values on the chart shall be divided by 1,000,000. | 5
TenMillions | Specifies the values on the chart shall be divided by 10,000,000. | 6
HundredMillions | Specifies the values on the chart shall be divided by 100,000,000. | 7
Billions | Specifies the values on the chart shall be divided by 1,000,000,000. | 8
Trillions | Specifies the values on the chart shall be divided by 1,000,000,000,000. | 9
Percentage | The values on the chart shall be divided by 0.01. | 10
Cust | specifies a custom value for the display unit. | 11

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


DropBars Class

Represents the up/down bars in a chart.

For a list of all members of this type, see DropBars Members.

System.Object
Aspose.Cells.Charts.DropBars

public class DropBars

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DropBars Members | Aspose.Cells.Charts Namespace


DropBars Members

DropBars overview

Public Instance Properties

Area | Gets the Area.
Border | Gets the border Line.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DropBars Class | Aspose.Cells.Charts Namespace


DropBars Properties

The properties of the DropBars class are listed below. For a complete list of DropBars class members, see the DropBars Members topic.

Public Instance Properties

Area | Gets the Area.
Border | Gets the border Line.

See Also

DropBars Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

DropBars.Area Property

Gets the Area.

public Area Area {get;}

See Also

DropBars Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

DropBars.Border Property

Gets the border Line.

public Line Border {get;}

See Also

DropBars Class | Aspose.Cells.Charts Namespace


ErrorBar Class

Represents error bar of data series.

For a list of all members of this type, see ErrorBar Members.

System.Object
Aspose.Cells.Drawing.Line
Aspose.Cells.Charts.ErrorBar

public class ErrorBar : Line

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
 Workbook workbook = new Workbook();
 Cells cells = workbook.Worksheets[0].Cells;
 cells["a1"].PutValue(2);
 cells["a2"].PutValue(5);
 cells["a3"].PutValue(3);
 cells["a4"].PutValue(6);
 cells["b1"].PutValue(4);
 cells["b2"].PutValue(3);
 cells["b3"].PutValue(6);
 cells["b4"].PutValue(7);

 cells["C1"].PutValue("Q1");
 cells["C2"].PutValue("Q2");
 cells["C3"].PutValue("Y1");
 cells["C4"].PutValue("Y2");

 int chartIndex = excel.Worksheets[0].Charts.Add(ChartType.Column, 11, 0, 27, 10);

 Chart chart = excel.Worksheets[0].Charts[chartIndex];
 chart.NSeries.Add("A1:B4", true);

 chart.NSeries.CategoryData = "C1:C4";

 for(int i = 0; i < chart.NSeries.Count; i ++)
 {
        ASeries aseries = chart.NSeries[i];
        aseries.YErrorBar.DisplayType = ErrorBarDisplayType.Minus;
        aseries.YErrorBar.Type = ErrorBarType.FixedValue;
        aseries.YErrorBar.Amount = 5;
 }

 [Visual Basic]
 Dim workbook As Workbook =  New Workbook()
 Dim cells As Cells =  workbook.Worksheets(0).Cells
 cells("a1").PutValue(2)
 cells("a2").PutValue(5)
 cells("a3").PutValue(3)
 cells("a4").PutValue(6)
 cells("b1").PutValue(4)
 cells("b2").PutValue(3)
 cells("b3").PutValue(6)
 cells("b4").PutValue(7)

 cells("C1").PutValue("Q1")
 cells("C2").PutValue("Q2")
 cells("C3").PutValue("Y1")
 cells("C4").PutValue("Y2")

 Dim chartIndex As Integer =  excel.Worksheets(0).Charts.Add(ChartType.Column,11,0,27,10)

 Dim chart As Chart =  excel.Worksheets(0).Charts(chartIndex)
 chart.NSeries.Add("A1:B4", True)

 chart.NSeries.CategoryData = "C1:C4"

 Dim i As Integer
 For  i = 0 To chart.NSeries.Count - 1
 Dim aseries As ASeries =  chart.NSeries(i)
 aseries.YErrorBar.DisplayType = ErrorBarDisplayType.Minus
 aseries.YErrorBar.Type = ErrorBarType.FixedValue
 aseries.YErrorBar.Amount = 5
 Next

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ErrorBar Members | Aspose.Cells.Charts Namespace


ErrorBar Members

ErrorBar overview

Public Instance Properties

Amount | Represents amount of error bar. The amount must be greater than and equal to zero.
BeginArrowLength (inherited from Line) | Specifies the length of the arrowhead for the begin of a line.
BeginArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the begin of a line.
BeginType (inherited from Line) | Specifies an arrowhead for the begin of a line.
CapType (inherited from Line) | Specifies the ending caps.
Color (inherited from Line) | Represents the Color of the line.
CompoundType (inherited from Line) | Specifies the compound line type
DashType (inherited from Line) | Specifies the dash line type
DisplayType | Represents error bar display type.
EndArrowLength (inherited from Line) | Specifies the length of the arrowhead for the end of a line.
EndArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the end of a line.
EndType (inherited from Line) | Specifies an arrowhead for the end of a line.
FormattingType (inherited from Line) | Gets or sets format type.
GradientFill (inherited from Line) | Represents gradient fill.
IsAuto (inherited from Line) | Indicates whether this line style is auto assigned.
IsAutomaticColor (inherited from Line) | Indicates whether the color of line is auotmatic assigned.
IsVisible (inherited from Line) | Represents whether the line is visible.
JoinType (inherited from Line) | Specifies the joining caps.
MinusValue | Represents negative error amount when error bar type is Custom.
PlusValue | Represents positive error amount when error bar type is Custom.
ShowMarkerTTop | Indicates if formatting error bars with a T-top.
Style (inherited from Line) | Represents the style of the line.
ThemeColor (inherited from Line) | Gets and sets the theme color.
Transparency (inherited from Line) | Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).
Type | Represents error bar amount type.
Weight (inherited from Line) | Gets or sets the WeightType of the line.
WeightPt (inherited from Line) | Gets or sets the weight of the line in unit of points.
WeightPx (inherited from Line) | Gets or sets the weight of the line in unit of pixels.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


ErrorBar Properties

The properties of the ErrorBar class are listed below. For a complete list of ErrorBar class members, see the ErrorBar Members topic.

Public Instance Properties

Amount | Represents amount of error bar. The amount must be greater than and equal to zero.
BeginArrowLength (inherited from Line) | Specifies the length of the arrowhead for the begin of a line.
BeginArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the begin of a line.
BeginType (inherited from Line) | Specifies an arrowhead for the begin of a line.
CapType (inherited from Line) | Specifies the ending caps.
Color (inherited from Line) | Represents the Color of the line.
CompoundType (inherited from Line) | Specifies the compound line type
DashType (inherited from Line) | Specifies the dash line type
DisplayType | Represents error bar display type.
EndArrowLength (inherited from Line) | Specifies the length of the arrowhead for the end of a line.
EndArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the end of a line.
EndType (inherited from Line) | Specifies an arrowhead for the end of a line.
FormattingType (inherited from Line) | Gets or sets format type.
GradientFill (inherited from Line) | Represents gradient fill.
IsAuto (inherited from Line) | Indicates whether this line style is auto assigned.
IsAutomaticColor (inherited from Line) | Indicates whether the color of line is auotmatic assigned.
IsVisible (inherited from Line) | Represents whether the line is visible.
JoinType (inherited from Line) | Specifies the joining caps.
MinusValue | Represents negative error amount when error bar type is Custom.
PlusValue | Represents positive error amount when error bar type is Custom.
ShowMarkerTTop | Indicates if formatting error bars with a T-top.
Style (inherited from Line) | Represents the style of the line.
ThemeColor (inherited from Line) | Gets and sets the theme color.
Transparency (inherited from Line) | Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).
Type | Represents error bar amount type.
Weight (inherited from Line) | Gets or sets the WeightType of the line.
WeightPt (inherited from Line) | Gets or sets the weight of the line in unit of points.
WeightPx (inherited from Line) | Gets or sets the weight of the line in unit of pixels.

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


Amount Property

Aspose.Cells for .NET

ErrorBar.Amount Property

Represents amount of error bar. The amount must be greater than and equal to zero.

public double Amount {get; set;}

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


DisplayType Property

Aspose.Cells for .NET

ErrorBar.DisplayType Property

Represents error bar display type.

public ErrorBarDisplayType DisplayType {get; set;}

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


MinusValue Property

Aspose.Cells for .NET

ErrorBar.MinusValue Property

Represents negative error amount when error bar type is Custom.

public string MinusValue {get; set;}

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


PlusValue Property

Aspose.Cells for .NET

ErrorBar.PlusValue Property

Represents positive error amount when error bar type is Custom.

public string PlusValue {get; set;}

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


ShowMarkerTTop Property

Aspose.Cells for .NET

ErrorBar.ShowMarkerTTop Property

Indicates if formatting error bars with a T-top.

public bool ShowMarkerTTop {get; set;}

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


Type Property

Aspose.Cells for .NET

ErrorBar.Type Property

Represents error bar amount type.

public ErrorBarType Type {get; set;}

Example

[C#]
//Sets custom error bar type
aseries.YErrorBar.Type = ErrorBarType.InnerCustom;
aseries.YErrorBar.PlusValue = "=Sheet1!A1";
aseries.YErrorBar.MinusValue = "=Sheet1!A2";

[Visual Basic]
'Sets custom error bar type
aseries.YErrorBar.Type = ErrorBarType.InnerCustom
aseries.YErrorBar.PlusValue = "=Sheet1!A1"
aseries.YErrorBar.MinusValue = "=Sheet1!A2"

See Also

ErrorBar Class | Aspose.Cells.Charts Namespace


ErrorBarDisplayType Enumeration

Represents error bar display type.

public enum ErrorBarDisplayType

Members

Member Name | Description | Value
Both | Both | 0
Minus | Minus | 1
None | None | 2
Plus | Plus | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


ErrorBarType Enumeration

Represents error bar amount type.

public enum ErrorBarType

Members

Member Name | Description | Value
Custom | InnerCustom value type. | 0
FixedValue | Fixed value type. | 1
Percent | Percentage type | 2
StDev | Standard deviation type. | 3
StError | Standard error type. | 4

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Floor Class

Encapsulates the object that represents the floor of a 3-D chart.

For a list of all members of this type, see Floor Members.

System.Object
Aspose.Cells.Drawing.Area
Aspose.Cells.Charts.Floor
Aspose.Cells.Charts.Walls

public class Floor : Area

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate the License class
Aspose.Cells.License license = new Aspose.Cells.License();

//Pass only the name of the license file embedded in the assembly
license.SetLicense("Aspose.Cells.lic");

//Instantiate the workbook object
Workbook workbook = new Workbook();

//Get cells collection
Cells cells = workbook.Worksheets[0].Cells;

//Put values in cells
cells["A1"].PutValue(1);

cells["A2"].PutValue(2);

cells["A3"].PutValue(3);

//get charts colletion
Charts charts = workbook.Worksheets[0].Charts;

//add a new chart
int index = charts.Add(ChartType.Column3DStacked, 5, 0, 15, 5);

//get the newly added chart
Chart chart = charts[index];

//set charts nseries
chart.NSeries.Add("A1:A3", true);

//Show data labels
chart.NSeries[0].DataLabels.IsValueShown = true;

//Get chart's floor
Floor floor = chart.Floor;

//set floor's border as red
floor.Border.Color = System.Drawing.Color.Red;

//set fill format
floor.FillFormat.SetPresetColorGradient(GradientPresetType.CalmWater, GradientStyleType.DiagonalDown, 2);

//save the file
workbook.Save(@"d:\dest.xls");

[VB.NET]

'Instantiate the License class
Dim license As New Aspose.Cells.License()

'Pass only the name of the license file embedded in the assembly
license.SetLicense("Aspose.Cells.lic")

'Instantiate the workbook object
Dim workbook As New Workbook()

'Get cells collection
Dim cells As Cells = workbook.Worksheets(0).Cells

'Put values in cells
cells("A1").PutValue(1)

cells("A2").PutValue(2)

cells("A3").PutValue(3)

'get charts colletion
Dim charts As Charts = workbook.Worksheets(0).Charts

'add a new chart
Dim index As Integer = charts.Add(ChartType.Column3DStacked, 5, 0, 15, 5)

'get the newly added chart
Dim chart As Chart = charts(index)

'set charts nseries
chart.NSeries.Add("A1:A3", True)

'Show data labels
chart.NSeries(0).DataLabels.IsValueShown = True

'Get chart's floor
Dim floor As Floor = chart.Floor

'set floor's border as red
floor.Border.Color = System.Drawing.Color.Red

'set fill format
floor.FillFormat.SetPresetColorGradient(GradientPresetType.CalmWater, GradientStyleType.DiagonalDown, 2)

'save the file
workbook.Save("d:\dest.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Floor Members | Aspose.Cells.Charts Namespace


Floor Members

Floor overview

Public Instance Properties

BackgroundColor (inherited from Area) | Gets or sets the background Color of the Area.
Border | Gets or sets the border Line.
FillFormat (inherited from Area) | Represents a object that contains fill formatting properties for the specified chart or shape.
ForegroundColor (inherited from Area) | Gets or sets the foreground Color.
Formatting (inherited from Area) | Represents the formatting of the area.
InvertIfNegative (inherited from Area) | If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.
Transparency (inherited from Area) | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Floor Class | Aspose.Cells.Charts Namespace


Floor Properties

The properties of the Floor class are listed below. For a complete list of Floor class members, see the Floor Members topic.

Public Instance Properties

BackgroundColor (inherited from Area) | Gets or sets the background Color of the Area.
Border | Gets or sets the border Line.
FillFormat (inherited from Area) | Represents a object that contains fill formatting properties for the specified chart or shape.
ForegroundColor (inherited from Area) | Gets or sets the foreground Color.
Formatting (inherited from Area) | Represents the formatting of the area.
InvertIfNegative (inherited from Area) | If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.
Transparency (inherited from Area) | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

See Also

Floor Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

Floor.Border Property

Gets or sets the border Line.

public Line Border {get; set;}

See Also

Floor Class | Aspose.Cells.Charts Namespace


FormattingType Enumeration

Represents the type of formatting applied to an Area object or a Line object.

public enum FormattingType

Members

Member Name | Description | Value
Automatic | Represents automatic formatting type. | 0
Custom | Represents custom formatting type. | 2
None | Represents none formatting type. | 1

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


LabelPositionType Enumeration

Represents data label position type.

public enum LabelPositionType

Members

Member Name | Description | Value
Center | Applies only to bar, 2d/3d pie charts | 0
InsideBase | Applies only to bar, 2d/3d pie charts | 1
InsideEnd | Applies only to bar charts | 2
OutsideEnd | Applies only to bar, 2d/3d pie charts | 3
Above | Applies only to line charts | 4
Below | Applies only to line charts | 5
Left | Applies only to line charts | 6
Right | Applies only to line charts | 7
BestFit | Applies only to 2d/3d pie charts | 8
Moved | User moved the data labels, Only for reading chart from template file. | 9

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Legend Class

Encapsulates the object that represents the chart legend.

For a list of all members of this type, see Legend Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.Legend

public class Legend : ChartFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Set Legend's width and height
Legend legend = chart.Legend;

//Legend is at right side of chart by default.
//If the legend is at left or right side of the chart, setting Legend.X property will not take effect.
//If the legend is at top or bottom side of the chart, setting Legend.Y property will not take effect.
legend.Y = 1500;
legend.Width = 50;
legend.Height = 50;
//Set legend's position
legend.Position = LegendPositionType.Left;

[Visual Basic]

'Set Legend's width and height
Dim legend as Legend = chart.Legend

'Legend is at right side of chart by default.
'If the legend is at left or right side of the chart, setting Legend.X property will not take effect.
'If the legend is at top or bottom side of the chart, setting Legend.Y property will not take effect.
legend.Y = 1500
legend.Width = 50
legend.Height = 50
'Set legend's position
legend.Position = LegendPositionType.Left

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Legend Members | Aspose.Cells.Charts Namespace


Legend Members

Legend overview

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsOverLay | Gets or sets whether other chart elements shall be allowed to overlap this chart element.
LegendEntries | Gets a collection of all the LegendEntry objects in the specified chart legend. Setting the legend entries of the surface chart is not supported. So it will return null if the chart type is surface chart type.
LegendEntriesLabels | Gets the labels of the legend entries after call Chart.Calculate() method.
Position | Gets or sets the legend position type.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

Legend Class | Aspose.Cells.Charts Namespace


Legend Properties

The properties of the Legend class are listed below. For a complete list of Legend class members, see the Legend Members topic.

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsOverLay | Gets or sets whether other chart elements shall be allowed to overlap this chart element.
LegendEntries | Gets a collection of all the LegendEntry objects in the specified chart legend. Setting the legend entries of the surface chart is not supported. So it will return null if the chart type is surface chart type.
LegendEntriesLabels | Gets the labels of the legend entries after call Chart.Calculate() method.
Position | Gets or sets the legend position type.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X (inherited from ChartFrame) | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y (inherited from ChartFrame) | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

See Also

Legend Class | Aspose.Cells.Charts Namespace


IsOverLay Property

Aspose.Cells for .NET

Legend.IsOverLay Property

Gets or sets whether other chart elements shall be allowed to overlap this chart element.

public bool IsOverLay {get; set;}

See Also

Legend Class | Aspose.Cells.Charts Namespace


LegendEntries Property

Aspose.Cells for .NET

Legend.LegendEntries Property

Gets a collection of all the LegendEntry objects in the specified chart legend. Setting the legend entries of the surface chart is not supported. So it will return null if the chart type is surface chart type.

public LegendEntryCollection LegendEntries {get;}

See Also

Legend Class | Aspose.Cells.Charts Namespace


LegendEntriesLabels Property

Aspose.Cells for .NET

Legend.LegendEntriesLabels Property

Gets the labels of the legend entries after call Chart.Calculate() method.

public ArrayList LegendEntriesLabels {get;}

See Also

Legend Class | Aspose.Cells.Charts Namespace


Position Property

Aspose.Cells for .NET

Legend.Position Property

Gets or sets the legend position type.

public LegendPositionType Position {get; set;}

Remarks

See Also

Legend Class | Aspose.Cells.Charts Namespace


LegendEntry Class

Represents a legend entry in a chart legend.

For a list of all members of this type, see LegendEntry Members.

System.Object
Aspose.Cells.Charts.LegendEntry

public class LegendEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LegendEntry Members | Aspose.Cells.Charts Namespace


LegendEntry Members

LegendEntry overview

Public Instance Properties

AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Font | Gets a Font object of the specified ChartFrame object.
IsDeleted | Gets and sets whether the legend entry is deleted.
IsTextNoFill | Gets or sets no fill of the text.
TextFont | Obsolete. Gets a Font object of the specified LegendEntry object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


LegendEntry Properties

The properties of the LegendEntry class are listed below. For a complete list of LegendEntry class members, see the LegendEntry Members topic.

Public Instance Properties

AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
Background | Obsolete. Gets and sets the display mode of the background
BackgroundMode | Gets and sets the display mode of the background
Font | Gets a Font object of the specified ChartFrame object.
IsDeleted | Gets and sets whether the legend entry is deleted.
IsTextNoFill | Gets or sets no fill of the text.
TextFont | Obsolete. Gets a Font object of the specified LegendEntry object.

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


AutoScaleFont Property

Aspose.Cells for .NET

LegendEntry.AutoScaleFont Property

True if the text in the object changes font size when the object size changes. The default value is True.

public bool AutoScaleFont {get; set;}

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


Background Property

Aspose.Cells for .NET

LegendEntry.Background Property

NOTE: This property is now obsolete.

Use LegendEntry.BackgroundMode property instead.

Gets and sets the display mode of the background

public BackgroundMode Background {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use LegendEntry.BackgroundMode property. This property will be removed 12 months later since JANUARY 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


BackgroundMode Property

Aspose.Cells for .NET

LegendEntry.BackgroundMode Property

Gets and sets the display mode of the background

public BackgroundMode BackgroundMode {get; set;}

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

LegendEntry.Font Property

Gets a Font object of the specified ChartFrame object.

public Font Font {get;}

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


IsDeleted Property

Aspose.Cells for .NET

LegendEntry.IsDeleted Property

Gets and sets whether the legend entry is deleted.

public bool IsDeleted {get; set;}

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


IsTextNoFill Property

Aspose.Cells for .NET

LegendEntry.IsTextNoFill Property

Gets or sets no fill of the text.

public bool IsTextNoFill {get; set;}

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


TextFont Property

Aspose.Cells for .NET

LegendEntry.TextFont Property

NOTE: This property is now obsolete.

Use LegendEntry.Font property instead.

Gets a Font object of the specified LegendEntry object.

public virtual Font TextFont {get;}

Remarks

NOTE: This member is now obsolete. Instead, please use LegendEntry.Font property. This property will be removed 12 months later since JANUARY 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

LegendEntry Class | Aspose.Cells.Charts Namespace


LegendEntryCollection Class

Represents a collection of all the LegendEntry objects in the specified chart legend.

For a list of all members of this type, see LegendEntryCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Charts.LegendEntryCollection

public class LegendEntryCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LegendEntryCollection Members | Aspose.Cells.Charts Namespace


LegendEntryCollection Members

LegendEntryCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the LegendEntry element at the specified index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

LegendEntryCollection Class | Aspose.Cells.Charts Namespace


LegendEntryCollection Properties

The properties of the LegendEntryCollection class are listed below. For a complete list of LegendEntryCollection class members, see the LegendEntryCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the LegendEntry element at the specified index.

See Also

LegendEntryCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

LegendEntryCollection.Item Property

Gets the LegendEntry element at the specified index.

public LegendEntry this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

LegendEntryCollection Class | Aspose.Cells.Charts Namespace


LegendPositionType Enumeration

Enumerates the legend position types.

public enum LegendPositionType

Members

Member Name | Description | Value
Bottom | Displays the legend to the bottom of the chart's plot area. | 0
Corner | Displays the legend to the corner of the chart's plot area. | 1
Left | Displays the legend to the left of the chart's plot area. | 4
NotDocked | Represents that the legend is not docked. | 7
Right | Displays the legend to the right of the chart's plot area. | 3
Top | Displays the legend to the top of the chart's plot area. | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


MapChartLabelLayout Enumeration

Represents the layout of map chart's labels.

public enum MapChartLabelLayout

Members

Member Name | Description | Value
BestFitOnly | Only best fit. | 0
ShowAll | Shows all labels. | 1
None | No labels. | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


MapChartProjectionType Enumeration

Represents projection type of the map chart.

public enum MapChartProjectionType

Members

Member Name | Description | Value
Automatic | Automatic | 0
Mercator | Mercator | 1
Miller | Miller | 2
Albers | Albers | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


MapChartRegionType Enumeration

Represents the region type of the map chart.

public enum MapChartRegionType

Members

Member Name | Description | Value
Automatic | Automatic | 0
DataOnly | Only Data. | 1
CountryRegionList | Country region list. | 2
World | World. | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Marker Class

Represents the marker in a line chart, scatter chart, or radar chart.

For a list of all members of this type, see Marker Members.

System.Object
Aspose.Cells.Charts.Marker

public class Marker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Marker Members | Aspose.Cells.Charts Namespace


Marker Members

Marker overview

Public Instance Properties

Area | Gets the area.
Border | Gets the border.
MarkerSize | Represents the marker size in unit of points. Applies to line chart, scatter chart, or radar chart.
MarkerSizePx | Represents the marker size in unit of pixels. Applies to line chart, scatter chart, or radar chart.
MarkerStyle | Represents the marker style. Applies to line chart, scatter chart, or radar chart.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Marker Class | Aspose.Cells.Charts Namespace


Marker Properties

The properties of the Marker class are listed below. For a complete list of Marker class members, see the Marker Members topic.

Public Instance Properties

Area | Gets the area.
Border | Gets the border.
MarkerSize | Represents the marker size in unit of points. Applies to line chart, scatter chart, or radar chart.
MarkerSizePx | Represents the marker size in unit of pixels. Applies to line chart, scatter chart, or radar chart.
MarkerStyle | Represents the marker style. Applies to line chart, scatter chart, or radar chart.

See Also

Marker Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

Marker.Area Property

Gets the area.

public Area Area {get;}

See Also

Marker Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

Marker.Border Property

Gets the border.

public Line Border {get;}

See Also

Marker Class | Aspose.Cells.Charts Namespace


MarkerSize Property

Aspose.Cells for .NET

Marker.MarkerSize Property

Represents the marker size in unit of points. Applies to line chart, scatter chart, or radar chart.

public int MarkerSize {get; set;}

See Also

Marker Class | Aspose.Cells.Charts Namespace


MarkerSizePx Property

Aspose.Cells for .NET

Marker.MarkerSizePx Property

Represents the marker size in unit of pixels. Applies to line chart, scatter chart, or radar chart.

public int MarkerSizePx {get; set;}

See Also

Marker Class | Aspose.Cells.Charts Namespace


MarkerStyle Property

Aspose.Cells for .NET

Marker.MarkerStyle Property

Represents the marker style. Applies to line chart, scatter chart, or radar chart.

public ChartMarkerType MarkerStyle {get; set;}

See Also

Marker Class | Aspose.Cells.Charts Namespace


PivotOptions Class

Represents a complex type that specifies the pivot controls that appear on the chart

For a list of all members of this type, see PivotOptions Members.

System.Object
Aspose.Cells.Charts.PivotOptions

public class PivotOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotOptions Members | Aspose.Cells.Charts Namespace


PivotOptions Members

PivotOptions overview

Public Instance Properties

DropZoneCategories | Specifies whether a control for each PivotTable field on the PivotTable row axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZoneData | Specifies whether a control for each PivotTable field on the PivotTable data axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZoneFilter | Specifies whether a control for each PivotTable field on the PivotTable page axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZoneSeries | Specifies whether a control for each PivotTable field on the PivotTable column axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZonesVisible | Specifies whether any pivot controls can appear on the pivot chart.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


PivotOptions Properties

The properties of the PivotOptions class are listed below. For a complete list of PivotOptions class members, see the PivotOptions Members topic.

Public Instance Properties

DropZoneCategories | Specifies whether a control for each PivotTable field on the PivotTable row axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZoneData | Specifies whether a control for each PivotTable field on the PivotTable data axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZoneFilter | Specifies whether a control for each PivotTable field on the PivotTable page axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZoneSeries | Specifies whether a control for each PivotTable field on the PivotTable column axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.
DropZonesVisible | Specifies whether any pivot controls can appear on the pivot chart.

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


DropZoneCategories Property

Aspose.Cells for .NET

PivotOptions.DropZoneCategories Property

Specifies whether a control for each PivotTable field on the PivotTable row axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.

public bool DropZoneCategories {get; set;}

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


DropZoneData Property

Aspose.Cells for .NET

PivotOptions.DropZoneData Property

Specifies whether a control for each PivotTable field on the PivotTable data axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.

public bool DropZoneData {get; set;}

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


DropZoneFilter Property

Aspose.Cells for .NET

PivotOptions.DropZoneFilter Property

Specifies whether a control for each PivotTable field on the PivotTable page axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.

public bool DropZoneFilter {get; set;}

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


DropZoneSeries Property

Aspose.Cells for .NET

PivotOptions.DropZoneSeries Property

Specifies whether a control for each PivotTable field on the PivotTable column axis of the source PivotTable appears on the chart when dropZonesVisible is set to true.

public bool DropZoneSeries {get; set;}

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


DropZonesVisible Property

Aspose.Cells for .NET

PivotOptions.DropZonesVisible Property

Specifies whether any pivot controls can appear on the pivot chart.

public bool DropZonesVisible {get; set;}

See Also

PivotOptions Class | Aspose.Cells.Charts Namespace


PlotArea Class

Encapsulates the object that represents the plot area in a chart.

For a list of all members of this type, see PlotArea Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.PlotArea

public class PlotArea : ChartFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PlotArea Members | Aspose.Cells.Charts Namespace


PlotArea Members

PlotArea overview

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height | Gets or sets the height of plot-area bounding box in units of 1/4000 of the chart area.
InnerHeight | Gets or sets the height of plot area in units of 1/4000 of the chart area.
InnerWidth | Gets or sets the width of plot area in units of 1/4000 of the chart area.
InnerX | Gets or gets the x coordinate of the upper top corner of plot area in units of 1/4000 of the chart area.
InnerY | Gets or gets the x coordinate of the upper top corner of plot area in units of 1/4000 of the chart area.
IsAutomaticSize | Indicates whether the plot area is automatic sized.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
Width | Gets or sets the width of plot-area bounding box in units of 1/4000 of the chart area.
X | Gets or gets the x coordinate of the upper left corner of plot-area bounding box in units of 1/4000 of the chart area.
Y | Gets or gets the y coordinate of the upper top corner of plot-area bounding box in units of 1/4000 of the chart area.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto | Set position of the plot area to automatic
ToString (inherited from Object) |

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


PlotArea Properties

The properties of the PlotArea class are listed below. For a complete list of PlotArea class members, see the PlotArea Members topic.

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height | Gets or sets the height of plot-area bounding box in units of 1/4000 of the chart area.
InnerHeight | Gets or sets the height of plot area in units of 1/4000 of the chart area.
InnerWidth | Gets or sets the width of plot area in units of 1/4000 of the chart area.
InnerX | Gets or gets the x coordinate of the upper top corner of plot area in units of 1/4000 of the chart area.
InnerY | Gets or gets the x coordinate of the upper top corner of plot area in units of 1/4000 of the chart area.
IsAutomaticSize | Indicates whether the plot area is automatic sized.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
Width | Gets or sets the width of plot-area bounding box in units of 1/4000 of the chart area.
X | Gets or gets the x coordinate of the upper left corner of plot-area bounding box in units of 1/4000 of the chart area.
Y | Gets or gets the y coordinate of the upper top corner of plot-area bounding box in units of 1/4000 of the chart area.

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


Height Property

Aspose.Cells for .NET

PlotArea.Height Property

Gets or sets the height of plot-area bounding box in units of 1/4000 of the chart area.

public override int Height {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


InnerHeight Property

Aspose.Cells for .NET

PlotArea.InnerHeight Property

Gets or sets the height of plot area in units of 1/4000 of the chart area.

public int InnerHeight {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


InnerWidth Property

Aspose.Cells for .NET

PlotArea.InnerWidth Property

Gets or sets the width of plot area in units of 1/4000 of the chart area.

public int InnerWidth {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


InnerX Property

Aspose.Cells for .NET

PlotArea.InnerX Property

Gets or gets the x coordinate of the upper top corner of plot area in units of 1/4000 of the chart area.

public int InnerX {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


InnerY Property

Aspose.Cells for .NET

PlotArea.InnerY Property

Gets or gets the x coordinate of the upper top corner of plot area in units of 1/4000 of the chart area.

public int InnerY {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


IsAutomaticSize Property

Aspose.Cells for .NET

PlotArea.IsAutomaticSize Property

Indicates whether the plot area is automatic sized.

public override bool IsAutomaticSize {get; set;}

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


Width Property

Aspose.Cells for .NET

PlotArea.Width Property

Gets or sets the width of plot-area bounding box in units of 1/4000 of the chart area.

public override int Width {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


X Property

Aspose.Cells for .NET

PlotArea.X Property

Gets or gets the x coordinate of the upper left corner of plot-area bounding box in units of 1/4000 of the chart area.

public override int X {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


Y Property

Aspose.Cells for .NET

PlotArea.Y Property

Gets or gets the y coordinate of the upper top corner of plot-area bounding box in units of 1/4000 of the chart area.

public override int Y {get; set;}

Remarks

The plot-area bounding box includes the plot area, tick marks(tick labels), and a small border around the tick marks. If the value is not created by MS Excel, please call Chart.Calculate() method before calling this method.

The X, Y, Width and Height of PlotArea represents the plot-area bounding box that includes the plot area, tick marks(tick labels), and a small border around the tick marks. If you want to get actual size of plot area, you should call InnerX, InnerY, InnerWidth and InnerHeight properties.

For excel 2007 or latter, the default value is zero. you should call get the value after calling Chart.Calculate().

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


PlotArea Methods

The methods of the PlotArea class are listed below. For a complete list of PlotArea class members, see the PlotArea Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto | Set position of the plot area to automatic
ToString (inherited from Object) |

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


PlotArea.SetPositionAuto Method

Set position of the plot area to automatic

public override void SetPositionAuto();

See Also

PlotArea Class | Aspose.Cells.Charts Namespace


PlotDataByType Enumeration

Represents the type of data plot by row or column.

public enum PlotDataByType

Members

Member Name | Description | Value
Row | By row. | 0
Column | By column. | 1

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


PlotEmptyCellsType Enumeration

Represents all plot empty cells type of a chart.

public enum PlotEmptyCellsType

Members

Member Name | Description | Value
NotPlotted | Not plotted(leave gap) | 0
Zero | Zero | 1
Interpolated | Interpolated | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


QuartileCalculationType Enumeration

Represents quartile calculation methods.

public enum QuartileCalculationType

Members

Member Name | Description | Value
Exclusive | The quartile calculation includes the median when splitting the dataset into quartiles. | 0
Inclusive | The quartile calculation excludes the median when splitting the dataset into quartiles. | 1

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Series Class

Encapsulates the object that represents a single data series in a chart.

For a list of all members of this type, see Series Members.

System.Object
Aspose.Cells.Charts.Series

public class Series

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Excel object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a sample value to "A4" cell
worksheet.Cells["A4"].PutValue(200);
//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);
//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);
//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);
//Adding a sample value to "B4" cell
worksheet.Cells["B4"].PutValue(40);
//Adding a sample value to "C1" cell as category data
worksheet.Cells["C1"].PutValue("Q1");
//Adding a sample value to "C2" cell as category data
worksheet.Cells["C2"].PutValue("Q2");
//Adding a sample value to "C3" cell as category data
worksheet.Cells["C3"].PutValue("Y1");
//Adding a sample value to "C4" cell as category data
worksheet.Cells["C4"].PutValue("Y2");
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", true);
//Setting the data source for the category data of NSeries
chart.NSeries.CategoryData = "C1:C4";
Series series = chart.NSeries[1];
//Setting the values of the series.
series.Values = "=B1:B4";
//Changing the chart type of the series.
series.Type = ChartType.Line;
//Setting marker properties.
series.MarkerStyle = ChartMarkerType.Circle;
series.MarkerForegroundColorSetType = FormattingType.Automatic;
series.MarkerForegroundColor = System.Drawing.Color.Black;
series.MarkerBackgroundColorSetType = FormattingType.Automatic;
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Excel object
Dim sheetIndex As Int32 = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a sample value to "A4" cell
worksheet.Cells("A4").PutValue(200)
'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)
'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)
'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)
'Adding a sample value to "B4" cell
worksheet.Cells("B4").PutValue(40)
'Adding a sample value to "C1" cell as category data
worksheet.Cells("C1").PutValue("Q1")
'Adding a sample value to "C2" cell as category data
worksheet.Cells("C2").PutValue("Q2")
'Adding a sample value to "C3" cell as category data
worksheet.Cells("C3").PutValue("Y1")
'Adding a sample value to "C4" cell as category data
worksheet.Cells("C4").PutValue("Y2")
'Adding a chart to the worksheet
Dim chartIndex As Int32 = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", True)
'Setting the data source for the category data of NSeries
chart.NSeries.CategoryData = "C1:C4"
Dim series As Series = chart.NSeries(1)
'Setting the values of the series.
series.Values = "=B1:B4"
'Changing the chart type of the series.
series.Type = ChartType.Line
'Setting marker properties.
series.MarkerStyle = ChartMarkerType.Circle
series.MarkerForegroundColorSetType = FormattingType.Automatic
series.MarkerForegroundColor = System.Drawing.Color.Black
series.MarkerBackgroundColorSetType = FormattingType.Automatic
'Saving the Excel file
workbook.Save("C:\\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Series Members | Aspose.Cells.Charts Namespace


Series Members

Series overview

Public Instance Properties

Area | Represents the background area of Series object.
Bar3DShapeType | Gets or sets the 3D shape type used with the 3-D bar or column chart.
BarShape | Obsolete. Gets or sets the 3D shape type used with the 3-D bar or column chart.
Border | Represents border of Series object.
BubbleScale | Gets or sets the scale factor for bubbles in the specified chart group. It can be an integer value from 0 (zero) to 300, corresponding to a percentage of the default size. Applies only to bubble charts.
BubbleSizes | Gets or sets the bubble sizes values of the chart series.
CountOfDataValues | Gets the number of the data values.
DataLabels | Represents the DataLabels object for the specified ASeries.
DisplayName | Gets the series's name that displays on the chart graph.
DoughnutHoleSize | Returns or sets the size of the hole in a doughnut chart group. The hole size is expressed as a percentage of the chart size, between 10 and 90 percent.
DownBars | Returns a DropBars object that represents the down bars on a line chart. Applies only to line charts.
DropLines | Returns a Line object that represents the drop lines for a series on the line chart or area chart. Applies only to line chart or area charts.
Explosion | The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.
FirstSliceAngle | Gets or sets the angle of the first pie-chart or doughnut-chart slice, in degrees (clockwise from vertical). Applies only to pie, 3-D pie, and doughnut charts, 0 to 360.
GapWidth | Returns or sets the space between bar or column clusters, as a percentage of the bar or column width. The value of this property must be between 0 and 500.
Has3DEffect | True if the series has a three-dimensional appearance. Applies only to bubble charts.
HasDropLines | True if the chart has drop lines. Applies only to line chart or area charts.
HasHiLoLines | True if the line chart has high-low lines. Applies only to line charts.
HasLeaderLines | True if the series has leader lines.
HasRadarAxisLabels | True if a radar chart has category axis labels. Applies only to radar charts.
HasSeriesLines | True if a stacked column chart or bar chart has series lines or if a Pie of Pie chart or Bar of Pie chart has connector lines between the two sections. Applies only to stacked column charts, bar charts, Pie of Pie charts, or Bar of Pie charts.
HasUpDownBars | True if a line chart has up and down bars. Applies only to line charts.
HiLoLines | Returns a HiLoLines object that represents the high-low lines for a series on a line chart. Applies only to line charts.
IsAutoSplit | Indicates whether the threshold value is automatic.
IsColorVaried | Represents if the color of points is varied. The chart must contain only one series.
IsVerticalValues | Indicates whether the data source is vertical.
LayoutProperties | Represents the properties of layout.
LeaderLines | Represents leader lines on a chart. Leader lines connect data labels to data points. This object isn¡¯t a collection; there¡¯s no object that represents a single leader line.
LegendEntry | Gets the legend entry according to this series.
Marker | Gets the marker.
MarkerBackgroundColor | Obsolete. Represents the marker background color in a line chart, scatter chart, or radar chart.
MarkerBackgroundColorSetType | Obsolete. Gets or sets the marker background color set type.
MarkerForegroundColor | Obsolete. Represents the marker foreground color in a line chart, scatter chart, or radar chart.
MarkerForegroundColorSetType | Obsolete. Gets or sets the marker foreground color set type.
MarkerSize | Obsolete. Represents the marker size in a line chart, scatter chart, or radar chart.
MarkerStyle | Obsolete. Represents the marker style in a line chart, scatter chart, or radar chart.
Name | Gets or sets the name of the data series.
Overlap | Specifies how bars and columns are positioned. Can be a value between ¨C 100 and 100. Applies only to 2-D bar and 2-D column charts.
PlotOnSecondAxis | Indicates if this series is plotted on second value axis.
Points | Gets the collection of points in a series in a chart.
SecondPlotSize | Returns or sets the size of the secondary section of either a pie of pie chart or a bar of pie chart, as a percentage of the size of the primary pie. Can be a value from 5 to 200.
SeriesLines | Returns a SeriesLines object that represents the series lines for a stacked bar chart or a stacked column chart. Applies only to stacked bar and stacked column charts.
Shadow | True if the series has a shadow.
ShapeProperties | Gets the object that holds the visual shape properties of the Series.
ShowNegativeBubbles | True if negative bubbles are shown for the chart group. Valid only for bubble charts.
SizeRepresents | Gets or sets what the bubble size represents on a bubble chart.
Smooth | Represents curve smoothing. True if curve smoothing is turned on for the line chart or scatter chart. Applies only to line and scatter connected by lines charts.
SplitType | Returns or sets a value that how to determine which data points are in the second pie or bar on a pie of pie or bar of pie chart.
SplitValue | Returns or sets a value that shall be used to determine which data points are in the second pie or bar on a pie of pie or bar of pie chart.
TrendLines | Returns an object that represents a collection of all the trendlines for the series.
Type | Gets or sets a data series' type.
UpBars | Returns an DropBars object that represents the up bars on a line chart. Applies only to line charts.
Values | Represents the data of the chart series.
ValuesFormatCode | Represents format code of Values¡®s NumberList.
XErrorBar | Represents X direction error bar of the series.
XValues | Represents the x values of the chart series.
YErrorBar | Represents Y direction error bar of the series.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Move | Moves the series up or down.
ToString (inherited from Object) |

See Also

Series Class | Aspose.Cells.Charts Namespace


Series Properties

The properties of the Series class are listed below. For a complete list of Series class members, see the Series Members topic.

Public Instance Properties

Area | Represents the background area of Series object.
Bar3DShapeType | Gets or sets the 3D shape type used with the 3-D bar or column chart.
BarShape | Obsolete. Gets or sets the 3D shape type used with the 3-D bar or column chart.
Border | Represents border of Series object.
BubbleScale | Gets or sets the scale factor for bubbles in the specified chart group. It can be an integer value from 0 (zero) to 300, corresponding to a percentage of the default size. Applies only to bubble charts.
BubbleSizes | Gets or sets the bubble sizes values of the chart series.
CountOfDataValues | Gets the number of the data values.
DataLabels | Represents the DataLabels object for the specified ASeries.
DisplayName | Gets the series's name that displays on the chart graph.
DoughnutHoleSize | Returns or sets the size of the hole in a doughnut chart group. The hole size is expressed as a percentage of the chart size, between 10 and 90 percent.
DownBars | Returns a DropBars object that represents the down bars on a line chart. Applies only to line charts.
DropLines | Returns a Line object that represents the drop lines for a series on the line chart or area chart. Applies only to line chart or area charts.
Explosion | The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.
FirstSliceAngle | Gets or sets the angle of the first pie-chart or doughnut-chart slice, in degrees (clockwise from vertical). Applies only to pie, 3-D pie, and doughnut charts, 0 to 360.
GapWidth | Returns or sets the space between bar or column clusters, as a percentage of the bar or column width. The value of this property must be between 0 and 500.
Has3DEffect | True if the series has a three-dimensional appearance. Applies only to bubble charts.
HasDropLines | True if the chart has drop lines. Applies only to line chart or area charts.
HasHiLoLines | True if the line chart has high-low lines. Applies only to line charts.
HasLeaderLines | True if the series has leader lines.
HasRadarAxisLabels | True if a radar chart has category axis labels. Applies only to radar charts.
HasSeriesLines | True if a stacked column chart or bar chart has series lines or if a Pie of Pie chart or Bar of Pie chart has connector lines between the two sections. Applies only to stacked column charts, bar charts, Pie of Pie charts, or Bar of Pie charts.
HasUpDownBars | True if a line chart has up and down bars. Applies only to line charts.
HiLoLines | Returns a HiLoLines object that represents the high-low lines for a series on a line chart. Applies only to line charts.
IsAutoSplit | Indicates whether the threshold value is automatic.
IsColorVaried | Represents if the color of points is varied. The chart must contain only one series.
IsVerticalValues | Indicates whether the data source is vertical.
LayoutProperties | Represents the properties of layout.
LeaderLines | Represents leader lines on a chart. Leader lines connect data labels to data points. This object isn¡¯t a collection; there¡¯s no object that represents a single leader line.
LegendEntry | Gets the legend entry according to this series.
Marker | Gets the marker.
MarkerBackgroundColor | Obsolete. Represents the marker background color in a line chart, scatter chart, or radar chart.
MarkerBackgroundColorSetType | Obsolete. Gets or sets the marker background color set type.
MarkerForegroundColor | Obsolete. Represents the marker foreground color in a line chart, scatter chart, or radar chart.
MarkerForegroundColorSetType | Obsolete. Gets or sets the marker foreground color set type.
MarkerSize | Obsolete. Represents the marker size in a line chart, scatter chart, or radar chart.
MarkerStyle | Obsolete. Represents the marker style in a line chart, scatter chart, or radar chart.
Name | Gets or sets the name of the data series.
Overlap | Specifies how bars and columns are positioned. Can be a value between ¨C 100 and 100. Applies only to 2-D bar and 2-D column charts.
PlotOnSecondAxis | Indicates if this series is plotted on second value axis.
Points | Gets the collection of points in a series in a chart.
SecondPlotSize | Returns or sets the size of the secondary section of either a pie of pie chart or a bar of pie chart, as a percentage of the size of the primary pie. Can be a value from 5 to 200.
SeriesLines | Returns a SeriesLines object that represents the series lines for a stacked bar chart or a stacked column chart. Applies only to stacked bar and stacked column charts.
Shadow | True if the series has a shadow.
ShapeProperties | Gets the object that holds the visual shape properties of the Series.
ShowNegativeBubbles | True if negative bubbles are shown for the chart group. Valid only for bubble charts.
SizeRepresents | Gets or sets what the bubble size represents on a bubble chart.
Smooth | Represents curve smoothing. True if curve smoothing is turned on for the line chart or scatter chart. Applies only to line and scatter connected by lines charts.
SplitType | Returns or sets a value that how to determine which data points are in the second pie or bar on a pie of pie or bar of pie chart.
SplitValue | Returns or sets a value that shall be used to determine which data points are in the second pie or bar on a pie of pie or bar of pie chart.
TrendLines | Returns an object that represents a collection of all the trendlines for the series.
Type | Gets or sets a data series' type.
UpBars | Returns an DropBars object that represents the up bars on a line chart. Applies only to line charts.
Values | Represents the data of the chart series.
ValuesFormatCode | Represents format code of Values¡®s NumberList.
XErrorBar | Represents X direction error bar of the series.
XValues | Represents the x values of the chart series.
YErrorBar | Represents Y direction error bar of the series.

See Also

Series Class | Aspose.Cells.Charts Namespace


Area Property

Aspose.Cells for .NET

Series.Area Property

Represents the background area of Series object.

public Area Area {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Bar3DShapeType Property

Aspose.Cells for .NET

Series.Bar3DShapeType Property

Gets or sets the 3D shape type used with the 3-D bar or column chart.

public Bar3DShapeType Bar3DShapeType {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


BarShape Property

Aspose.Cells for .NET

Series.BarShape Property

NOTE: This property is now obsolete.

Use Series.Bar3DShapeType property instead.

Gets or sets the 3D shape type used with the 3-D bar or column chart.

public Bar3DShapeType BarShape {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use ASeries.Bar3DShapeType property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

Series Class | Aspose.Cells.Charts Namespace


Border Property

Aspose.Cells for .NET

Series.Border Property

Represents border of Series object.

public Line Border {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


BubbleScale Property

Aspose.Cells for .NET

Series.BubbleScale Property

Gets or sets the scale factor for bubbles in the specified chart group. It can be an integer value from 0 (zero) to 300, corresponding to a percentage of the default size. Applies only to bubble charts.

public int BubbleScale {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


BubbleSizes Property

Aspose.Cells for .NET

Series.BubbleSizes Property

Gets or sets the bubble sizes values of the chart series.

public string BubbleSizes {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


CountOfDataValues Property

Aspose.Cells for .NET

Series.CountOfDataValues Property

Gets the number of the data values.

public int CountOfDataValues {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


DataLabels Property

Aspose.Cells for .NET

Series.DataLabels Property

Represents the DataLabels object for the specified ASeries.

public DataLabels DataLabels {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


DisplayName Property

Aspose.Cells for .NET

Series.DisplayName Property

Gets the series's name that displays on the chart graph.

public string DisplayName {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


DoughnutHoleSize Property

Aspose.Cells for .NET

Series.DoughnutHoleSize Property

Returns or sets the size of the hole in a doughnut chart group. The hole size is expressed as a percentage of the chart size, between 10 and 90 percent.

public int DoughnutHoleSize {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


DownBars Property

Aspose.Cells for .NET

Series.DownBars Property

Returns a DropBars object that represents the down bars on a line chart. Applies only to line charts.

public DropBars DownBars {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


DropLines Property

Aspose.Cells for .NET

Series.DropLines Property

Returns a Line object that represents the drop lines for a series on the line chart or area chart. Applies only to line chart or area charts.

public Line DropLines {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Explosion Property

Aspose.Cells for .NET

Series.Explosion Property

The distance of an open pie slice from the center of the pie chart is expressed as a percentage of the pie diameter.

public int Explosion {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


FirstSliceAngle Property

Aspose.Cells for .NET

Series.FirstSliceAngle Property

Gets or sets the angle of the first pie-chart or doughnut-chart slice, in degrees (clockwise from vertical). Applies only to pie, 3-D pie, and doughnut charts, 0 to 360.

public short FirstSliceAngle {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


GapWidth Property

Aspose.Cells for .NET

Series.GapWidth Property

Returns or sets the space between bar or column clusters, as a percentage of the bar or column width. The value of this property must be between 0 and 500.

public short GapWidth {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Has3DEffect Property

Aspose.Cells for .NET

Series.Has3DEffect Property

True if the series has a three-dimensional appearance. Applies only to bubble charts.

public bool Has3DEffect {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HasDropLines Property

Aspose.Cells for .NET

Series.HasDropLines Property

True if the chart has drop lines. Applies only to line chart or area charts.

public bool HasDropLines {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HasHiLoLines Property

Aspose.Cells for .NET

Series.HasHiLoLines Property

True if the line chart has high-low lines. Applies only to line charts.

public bool HasHiLoLines {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HasLeaderLines Property

Aspose.Cells for .NET

Series.HasLeaderLines Property

True if the series has leader lines.

public bool HasLeaderLines {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HasRadarAxisLabels Property

Aspose.Cells for .NET

Series.HasRadarAxisLabels Property

True if a radar chart has category axis labels. Applies only to radar charts.

public bool HasRadarAxisLabels {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HasSeriesLines Property

Aspose.Cells for .NET

Series.HasSeriesLines Property

True if a stacked column chart or bar chart has series lines or if a Pie of Pie chart or Bar of Pie chart has connector lines between the two sections. Applies only to stacked column charts, bar charts, Pie of Pie charts, or Bar of Pie charts.

public bool HasSeriesLines {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HasUpDownBars Property

Aspose.Cells for .NET

Series.HasUpDownBars Property

True if a line chart has up and down bars. Applies only to line charts.

public bool HasUpDownBars {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


HiLoLines Property

Aspose.Cells for .NET

Series.HiLoLines Property

Returns a HiLoLines object that represents the high-low lines for a series on a line chart. Applies only to line charts.

public Line HiLoLines {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


IsAutoSplit Property

Aspose.Cells for .NET

Series.IsAutoSplit Property

Indicates whether the threshold value is automatic.

public bool IsAutoSplit {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


IsColorVaried Property

Aspose.Cells for .NET

Series.IsColorVaried Property

Represents if the color of points is varied. The chart must contain only one series.

public bool IsColorVaried {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


IsVerticalValues Property

Aspose.Cells for .NET

Series.IsVerticalValues Property

Indicates whether the data source is vertical.

public bool IsVerticalValues {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


LayoutProperties Property

Aspose.Cells for .NET

Series.LayoutProperties Property

Represents the properties of layout.

public SeriesLayoutProperties LayoutProperties {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


LeaderLines Property

Aspose.Cells for .NET

Series.LeaderLines Property

Represents leader lines on a chart. Leader lines connect data labels to data points. This object isn¡¯t a collection; there¡¯s no object that represents a single leader line.

public Line LeaderLines {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


LegendEntry Property

Aspose.Cells for .NET

Series.LegendEntry Property

Gets the legend entry according to this series.

public LegendEntry LegendEntry {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Marker Property

Aspose.Cells for .NET

Series.Marker Property

Gets the marker.

public Marker Marker {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


MarkerBackgroundColor Property

Aspose.Cells for .NET

Series.MarkerBackgroundColor Property

NOTE: This property is now obsolete.

Use Marker.Area.ForegroundColor property instead.

Represents the marker background color in a line chart, scatter chart, or radar chart.

public Color MarkerBackgroundColor {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerBackgroundColor property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

Series Class | Aspose.Cells.Charts Namespace


MarkerBackgroundColorSetType Property

Aspose.Cells for .NET

Series.MarkerBackgroundColorSetType Property

NOTE: This property is now obsolete.

Use Marker.Area.Formatting property instead.

Gets or sets the marker background color set type.

public FormattingType MarkerBackgroundColorSetType {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerBackgroundColorSetType property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced. FormattingType.Automatic is same as ChartLineFormattingType.Automatic. FormattingType.None is same as ChartLineFormattingType.None. FormattingType.InnerCustom is same as ChartLineFormattingType.Solid.

See Also

Series Class | Aspose.Cells.Charts Namespace


MarkerForegroundColor Property

Aspose.Cells for .NET

Series.MarkerForegroundColor Property

NOTE: This property is now obsolete.

Use Marker.Border.Color property instead.

Represents the marker foreground color in a line chart, scatter chart, or radar chart.

public Color MarkerForegroundColor {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerForegroundColor property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

Series Class | Aspose.Cells.Charts Namespace


MarkerForegroundColorSetType Property

Aspose.Cells for .NET

Series.MarkerForegroundColorSetType Property

NOTE: This property is now obsolete.

Use Marker.Border.Formatting property instead.

Gets or sets the marker foreground color set type.

public FormattingType MarkerForegroundColorSetType {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerForegroundColorSetType property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced. FormattingType.Automatic is same as ChartLineFormattingType.Automatic. FormattingType.None is same as ChartLineFormattingType.None. FormattingType.InnerCustom is same as ChartLineFormattingType.Solid.

See Also

Series Class | Aspose.Cells.Charts Namespace


MarkerSize Property

Aspose.Cells for .NET

Series.MarkerSize Property

NOTE: This property is now obsolete.

Use Marker.MarkerSize property instead.

Represents the marker size in a line chart, scatter chart, or radar chart.

public int MarkerSize {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerSize property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

Series Class | Aspose.Cells.Charts Namespace


MarkerStyle Property

Aspose.Cells for .NET

Series.MarkerStyle Property

NOTE: This property is now obsolete.

Use Marker.MarkerStyle property instead.

Represents the marker style in a line chart, scatter chart, or radar chart.

public ChartMarkerType MarkerStyle {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Marker.MarkerStyle property. This property will be removed 12 months later since August 2012. Aspose apologizes for any inconvenience you may have experienced.

See Also

Series Class | Aspose.Cells.Charts Namespace


Name Property

Aspose.Cells for .NET

Series.Name Property

Gets or sets the name of the data series.

public string Name {get; set;}

Example

[C#]

//Reference name to a cell
chart.NSeries[0].Name = "=A1";

//Set a string to name
chart.NSeries[0].Name = "First Series";
[Visual Basic]

'Reference name to a cell
chart.NSeries[0].Name = "=A1"

'Set a string to name
chart.NSeries[0].Name = "First Series"

See Also

Series Class | Aspose.Cells.Charts Namespace


Overlap Property

Aspose.Cells for .NET

Series.Overlap Property

Specifies how bars and columns are positioned. Can be a value between ¨C 100 and 100. Applies only to 2-D bar and 2-D column charts.

public short Overlap {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


PlotOnSecondAxis Property

Aspose.Cells for .NET

Series.PlotOnSecondAxis Property

Indicates if this series is plotted on second value axis.

public bool PlotOnSecondAxis {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Points Property

Aspose.Cells for .NET

Series.Points Property

Gets the collection of points in a series in a chart.

public ChartPointCollection Points {get;}

Remarks

When the chart is Pie of Pie or Bar of Pie, the last point is other point in first pie plot.

See Also

Series Class | Aspose.Cells.Charts Namespace


SecondPlotSize Property

Aspose.Cells for .NET

Series.SecondPlotSize Property

Returns or sets the size of the secondary section of either a pie of pie chart or a bar of pie chart, as a percentage of the size of the primary pie. Can be a value from 5 to 200.

public short SecondPlotSize {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


SeriesLines Property

Aspose.Cells for .NET

Series.SeriesLines Property

Returns a SeriesLines object that represents the series lines for a stacked bar chart or a stacked column chart. Applies only to stacked bar and stacked column charts.

public Line SeriesLines {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Shadow Property

Aspose.Cells for .NET

Series.Shadow Property

True if the series has a shadow.

public bool Shadow {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


ShapeProperties Property

Aspose.Cells for .NET

Series.ShapeProperties Property

Gets the object that holds the visual shape properties of the Series.

public ShapePropertyCollection ShapeProperties {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace | ShapePropertyCollection


ShowNegativeBubbles Property

Aspose.Cells for .NET

Series.ShowNegativeBubbles Property

True if negative bubbles are shown for the chart group. Valid only for bubble charts.

public bool ShowNegativeBubbles {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


SizeRepresents Property

Aspose.Cells for .NET

Series.SizeRepresents Property

Gets or sets what the bubble size represents on a bubble chart.

public BubbleSizeRepresents SizeRepresents {get; set;}

Remarks

BubbleSizeRepresents.SizeIsArea means the value BubbleSizes is the area of the bubble. BubbleSizeRepresents.SizeIsWidth means the value BubbleSizes is the width of the bubble.

See Also

Series Class | Aspose.Cells.Charts Namespace


Smooth Property

Aspose.Cells for .NET

Series.Smooth Property

Represents curve smoothing. True if curve smoothing is turned on for the line chart or scatter chart. Applies only to line and scatter connected by lines charts.

public bool Smooth {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


SplitType Property

Aspose.Cells for .NET

Series.SplitType Property

Returns or sets a value that how to determine which data points are in the second pie or bar on a pie of pie or bar of pie chart.

public ChartSplitType SplitType {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


SplitValue Property

Aspose.Cells for .NET

Series.SplitValue Property

Returns or sets a value that shall be used to determine which data points are in the second pie or bar on a pie of pie or bar of pie chart.

public double SplitValue {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


TrendLines Property

Aspose.Cells for .NET

Series.TrendLines Property

Returns an object that represents a collection of all the trendlines for the series.

public TrendlineCollection TrendLines {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Type Property

Aspose.Cells for .NET

Series.Type Property

Gets or sets a data series' type.

public ChartType Type {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


UpBars Property

Aspose.Cells for .NET

Series.UpBars Property

Returns an DropBars object that represents the up bars on a line chart. Applies only to line charts.

public DropBars UpBars {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Values Property

Aspose.Cells for .NET

Series.Values Property

Represents the data of the chart series.

public string Values {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


ValuesFormatCode Property

Aspose.Cells for .NET

Series.ValuesFormatCode Property

Represents format code of Values¡®s NumberList.

public string ValuesFormatCode {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


XErrorBar Property

Aspose.Cells for .NET

Series.XErrorBar Property

Represents X direction error bar of the series.

public ErrorBar XErrorBar {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


XValues Property

Aspose.Cells for .NET

Series.XValues Property

Represents the x values of the chart series.

public string XValues {get; set;}

See Also

Series Class | Aspose.Cells.Charts Namespace


YErrorBar Property

Aspose.Cells for .NET

Series.YErrorBar Property

Represents Y direction error bar of the series.

public ErrorBar YErrorBar {get;}

See Also

Series Class | Aspose.Cells.Charts Namespace


Series Methods

The methods of the Series class are listed below. For a complete list of Series class members, see the Series Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Move | Moves the series up or down.
ToString (inherited from Object) |

See Also

Series Class | Aspose.Cells.Charts Namespace


Series.Move Method

Moves the series up or down.

public void Move(
int count
);

Parameters

count
The number of moving up or down. Move the series up if this is less than zero; Move the series down if this is greater than zero.

See Also

Series Class | Aspose.Cells.Charts Namespace


SeriesCollection Class

Encapsulates a collection of Series objects.

For a list of all members of this type, see SeriesCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Charts.SeriesCollection

public class SeriesCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Excel object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a sample value to "A4" cell
worksheet.Cells["A4"].PutValue(200);
//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);
//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);
//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);
//Adding a sample value to "B4" cell
worksheet.Cells["B4"].PutValue(40);
//Adding a sample value to "C1" cell as category data
worksheet.Cells["C1"].PutValue("Q1");
//Adding a sample value to "C2" cell as category data
worksheet.Cells["C2"].PutValue("Q2");
//Adding a sample value to "C3" cell as category data
worksheet.Cells["C3"].PutValue("Y1");
//Adding a sample value to "C4" cell as category data
worksheet.Cells["C4"].PutValue("Y2");
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", true);
//Setting the data source for the category data of NSeries
chart.NSeries.CategoryData = "C1:C4";
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Excel object
Dim sheetIndex As Integer = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a sample value to "A4" cell
worksheet.Cells("A4").PutValue(200)
'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)
'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)
'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)
'Adding a sample value to "B4" cell
worksheet.Cells("B4").PutValue(40)
'Adding a sample value to "C1" cell as category data
worksheet.Cells("C1").PutValue("Q1")
'Adding a sample value to "C2" cell as category data
worksheet.Cells("C2").PutValue("Q2")
'Adding a sample value to "C3" cell as category data
worksheet.Cells("C3").PutValue("Y1")
'Adding a sample value to "C4" cell as category data
worksheet.Cells("C4").PutValue("Y2")
'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", True)
'Setting the data source for the category data of NSeries
chart.NSeries.CategoryData = "C1:C4"
'Saving the Excel file
workbook.Save("C:\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SeriesCollection Members | Aspose.Cells.Charts Namespace


SeriesCollection Members

SeriesCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
CategoryData | Gets or sets the range of category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}").
Count (inherited from CollectionBase) |
IsColorVaried | Represents if the color of points is varied.
Item | Gets the Series element at the specified index.
SecondCategoryData | Gets or sets the range of second category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}"). Only effects when some ASerieses plot on the second axis.
SecondCatergoryData | Obsolete. Gets or sets the range of second category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}"). Only effects when some ASerieses plot on the second axis.

Public Instance Methods

Add | Adds the SeriesCollection collection to a chart.
AddR1C1 | Adds the SeriesCollection collection to a chart.
ChangeSeriesOrder | Directly changes the orders of the two series.
Clear | Clears the collection
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetSeriesByOrder | Gets the Series element by order.
GetType (inherited from Object) |
RemoveAt | Remove at a series at the specific index.
ToString (inherited from Object) |

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection Properties

The properties of the SeriesCollection class are listed below. For a complete list of SeriesCollection class members, see the SeriesCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
CategoryData | Gets or sets the range of category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}").
Count (inherited from CollectionBase) |
IsColorVaried | Represents if the color of points is varied.
Item | Gets the Series element at the specified index.
SecondCategoryData | Gets or sets the range of second category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}"). Only effects when some ASerieses plot on the second axis.
SecondCatergoryData | Obsolete. Gets or sets the range of second category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}"). Only effects when some ASerieses plot on the second axis.

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


CategoryData Property

Aspose.Cells for .NET

SeriesCollection.CategoryData Property

Gets or sets the range of category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}").

public string CategoryData {get; set;}

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


IsColorVaried Property

Aspose.Cells for .NET

SeriesCollection.IsColorVaried Property

Represents if the color of points is varied.

public bool IsColorVaried {get; set;}

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

SeriesCollection.Item Property

Gets the Series element at the specified index.

public Series this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SecondCategoryData Property

Aspose.Cells for .NET

SeriesCollection.SecondCategoryData Property

Gets or sets the range of second category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}"). Only effects when some ASerieses plot on the second axis.

public string SecondCategoryData {get; set;}

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SecondCatergoryData Property

Aspose.Cells for .NET

SeriesCollection.SecondCatergoryData Property

NOTE: This property is now obsolete.

Use SeriesCollection.SecondCategoryData property instead.

Gets or sets the range of second category Axis values. It can be a range of cells (such as, "d1:e10"), or a sequence of values (such as,"{2,6,8,10}"). Only effects when some ASerieses plot on the second axis.

public string SecondCatergoryData {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use SeriesCollection.SecondCategoryData property. This property will be removed 12 months later since February 2014. Aspose apologizes for any inconvenience you may have experienced.

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection Methods

The methods of the SeriesCollection class are listed below. For a complete list of SeriesCollection class members, see the SeriesCollection Members topic.

Public Instance Methods

Add | Adds the SeriesCollection collection to a chart.
AddR1C1 | Adds the SeriesCollection collection to a chart.
ChangeSeriesOrder | Directly changes the orders of the two series.
Clear | Clears the collection
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetSeriesByOrder | Gets the Series element by order.
GetType (inherited from Object) |
RemoveAt | Remove at a series at the specific index.
ToString (inherited from Object) |

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection.Add Method

Adds the SeriesCollection collection to a chart.

public int Add(
string area,
bool isVertical
);

Parameters

area
Specifies values from which to plot the data series
isVertical
Specifies whether to plot the series from a range of cell values by row or by column.

Return Value

Return the first index of the added ASeries in the NSeries.

Remarks

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection.AddR1C1 Method

Adds the SeriesCollection collection to a chart.

public int AddR1C1(
string area,
bool isVertical
);

Parameters

area
Specifies values from which to plot the data series
isVertical
Specifies whether to plot the series from a range of cell values by row or by column.

Return Value

Return the first index of the added ASeries in the NSeries.

Remarks

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection.ChangeSeriesOrder Method

Directly changes the orders of the two series.

public void ChangeSeriesOrder(
int sourceIndex,
int destIndex
);

Parameters

sourceIndex
The current index
destIndex
The dest index

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection.Clear Method

Clears the collection

new public void Clear();

Implements

IList.Clear

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection.GetSeriesByOrder Method

Gets the Series element by order.

public Series GetSeriesByOrder(
int order
);

Parameters

order
The order of series

Return Value

The element series

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesCollection.RemoveAt Method

Remove at a series at the specific index.

new public void RemoveAt(
int index
);

Parameters

index
The index.

Implements

IList.RemoveAt

See Also

SeriesCollection Class | Aspose.Cells.Charts Namespace


SeriesLayoutProperties Class

For a list of all members of this type, see SeriesLayoutProperties Members.

System.Object
Aspose.Cells.Charts.SeriesLayoutProperties

public class SeriesLayoutProperties

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SeriesLayoutProperties Members | Aspose.Cells.Charts Namespace


SeriesLayoutProperties Members

SeriesLayoutProperties overview

Public Instance Constructors

SeriesLayoutProperties Constructor Initializes a new instance of the SeriesLayoutProperties class.

Public Instance Properties

MapChartProjectionType | Gets and sets the projection type of the map.
MapChartRegionType | Gets and sets the region type of the map.
MapLabelLayout | Gets and sets the layout of map labels.
QuartileCalculation | Represents the statistical properties for the series.
ShowConnectorLines | Indicates whether showing connector lines between data points.
ShowInnerPoints | Indicates whether showing non-outlier data points.
ShowMeanLine | Indicates whether showing the line connecting all mean points.
ShowMeanMarker | Indicates whether showing markers denoting the mean.
ShowOutlierPoints | Indicates whether showing outlier data points.
Subtotals | Represents the index of a subtotal data point.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


SeriesLayoutProperties Constructor

Initializes a new instance of the SeriesLayoutProperties class.

public SeriesLayoutProperties();

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


SeriesLayoutProperties Properties

The properties of the SeriesLayoutProperties class are listed below. For a complete list of SeriesLayoutProperties class members, see the SeriesLayoutProperties Members topic.

Public Instance Properties

MapChartProjectionType | Gets and sets the projection type of the map.
MapChartRegionType | Gets and sets the region type of the map.
MapLabelLayout | Gets and sets the layout of map labels.
QuartileCalculation | Represents the statistical properties for the series.
ShowConnectorLines | Indicates whether showing connector lines between data points.
ShowInnerPoints | Indicates whether showing non-outlier data points.
ShowMeanLine | Indicates whether showing the line connecting all mean points.
ShowMeanMarker | Indicates whether showing markers denoting the mean.
ShowOutlierPoints | Indicates whether showing outlier data points.
Subtotals | Represents the index of a subtotal data point.

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


MapChartProjectionType Property

Aspose.Cells for .NET

SeriesLayoutProperties.MapChartProjectionType Property

Gets and sets the projection type of the map.

public MapChartProjectionType MapChartProjectionType {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


MapChartRegionType Property

Aspose.Cells for .NET

SeriesLayoutProperties.MapChartRegionType Property

Gets and sets the region type of the map.

public MapChartRegionType MapChartRegionType {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


MapLabelLayout Property

Aspose.Cells for .NET

SeriesLayoutProperties.MapLabelLayout Property

Gets and sets the layout of map labels.

public MapChartLabelLayout MapLabelLayout {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


QuartileCalculation Property

Aspose.Cells for .NET

SeriesLayoutProperties.QuartileCalculation Property

Represents the statistical properties for the series.

public QuartileCalculationType QuartileCalculation {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


ShowConnectorLines Property

Aspose.Cells for .NET

SeriesLayoutProperties.ShowConnectorLines Property

Indicates whether showing connector lines between data points.

public bool ShowConnectorLines {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


ShowInnerPoints Property

Aspose.Cells for .NET

SeriesLayoutProperties.ShowInnerPoints Property

Indicates whether showing non-outlier data points.

public bool ShowInnerPoints {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


ShowMeanLine Property

Aspose.Cells for .NET

SeriesLayoutProperties.ShowMeanLine Property

Indicates whether showing the line connecting all mean points.

public bool ShowMeanLine {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


ShowMeanMarker Property

Aspose.Cells for .NET

SeriesLayoutProperties.ShowMeanMarker Property

Indicates whether showing markers denoting the mean.

public bool ShowMeanMarker {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


ShowOutlierPoints Property

Aspose.Cells for .NET

SeriesLayoutProperties.ShowOutlierPoints Property

Indicates whether showing outlier data points.

public bool ShowOutlierPoints {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


Subtotals Property

Aspose.Cells for .NET

SeriesLayoutProperties.Subtotals Property

Represents the index of a subtotal data point.

public int[] Subtotals {get; set;}

See Also

SeriesLayoutProperties Class | Aspose.Cells.Charts Namespace


Sparkline Class

A sparkline represents a tiny chart or graphic in a worksheet cell that provides a visual representation of data.

For a list of all members of this type, see Sparkline Members.

System.Object
Aspose.Cells.Charts.Sparkline

public class Sparkline

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Sparkline Members | Aspose.Cells.Charts Namespace


Sparkline Members

Sparkline overview

Public Instance Properties

Column | Gets the column index of the sparkline.
DataRange | Represents the data range of the sparkline.
Row | Gets the row index of the sparkline.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToImage | Overloaded. Converts a sparkline to an image.
ToString (inherited from Object) |

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


Sparkline Properties

The properties of the Sparkline class are listed below. For a complete list of Sparkline class members, see the Sparkline Members topic.

Public Instance Properties

Column | Gets the column index of the sparkline.
DataRange | Represents the data range of the sparkline.
Row | Gets the row index of the sparkline.

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


Column Property

Aspose.Cells for .NET

Sparkline.Column Property

Gets the column index of the sparkline.

public int Column {get;}

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


DataRange Property

Aspose.Cells for .NET

Sparkline.DataRange Property

Represents the data range of the sparkline.

public string DataRange {get; set;}

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


Row Property

Aspose.Cells for .NET

Sparkline.Row Property

Gets the row index of the sparkline.

public int Row {get;}

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


Sparkline Methods

The methods of the Sparkline class are listed below. For a complete list of Sparkline class members, see the Sparkline Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToImage | Overloaded. Converts a sparkline to an image.
ToString (inherited from Object) |

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


ToImage Method

Aspose.Cells for .NET

Sparkline.ToImage Method

Converts a sparkline to an image.

Overload List

Converts a sparkline to an image.

public Bitmap ToImage(ImageOrPrintOptions);

Converts a sparkline to an image.

public void ToImage(Stream,ImageOrPrintOptions);

Converts a sparkline to an image.

public void ToImage(string,ImageOrPrintOptions);

See Also

Sparkline Class | Aspose.Cells.Charts Namespace


Sparkline.ToImage Method (ImageOrPrintOptions)

Converts a sparkline to an image.

public Bitmap ToImage(
ImageOrPrintOptions options
);

Parameters

options
The image options

Return Value

Returns a Bitmap object.

See Also

Sparkline Class | Aspose.Cells.Charts Namespace | Sparkline.ToImage Overload List


Sparkline.ToImage Method (Stream, ImageOrPrintOptions)

Converts a sparkline to an image.

public void ToImage(
Stream stream,
ImageOrPrintOptions options
);

Parameters

stream
The image stream.
options
The image options.

See Also

Sparkline Class | Aspose.Cells.Charts Namespace | Sparkline.ToImage Overload List


Sparkline.ToImage Method (String, ImageOrPrintOptions)

Converts a sparkline to an image.

public void ToImage(
string fileName,
ImageOrPrintOptions options
);

Parameters

fileName
The image file name.
options
The image options

See Also

Sparkline Class | Aspose.Cells.Charts Namespace | Sparkline.ToImage Overload List


SparklineAxisMinMaxType Enumeration

Represents the minimum and maximum value types for the sparkline vertical axis.

public enum SparklineAxisMinMaxType

Members

Member Name | Description | Value
AutoIndividual | Automatic for each sparkline. | 0
Group | Same for all sparklines in the group. | 1
Custom | Custom value for sparkline. | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


SparklineCollection Class

Encapsulates a collection of Sparkline objects.

For a list of all members of this type, see SparklineCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Charts.SparklineCollection

public class SparklineCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SparklineCollection Members | Aspose.Cells.Charts Namespace


SparklineCollection Members

SparklineCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Sparkline element at the specified index.

Public Instance Methods

Add | Add a sparkline.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Removes the sparkline
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SparklineCollection Class | Aspose.Cells.Charts Namespace


SparklineCollection Properties

The properties of the SparklineCollection class are listed below. For a complete list of SparklineCollection class members, see the SparklineCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Sparkline element at the specified index.

See Also

SparklineCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

SparklineCollection.Item Property

Gets the Sparkline element at the specified index.

public Sparkline this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

SparklineCollection Class | Aspose.Cells.Charts Namespace


SparklineCollection Methods

The methods of the SparklineCollection class are listed below. For a complete list of SparklineCollection class members, see the SparklineCollection Members topic.

Public Instance Methods

Add | Add a sparkline.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Removes the sparkline
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SparklineCollection Class | Aspose.Cells.Charts Namespace


SparklineCollection.Add Method

Add a sparkline.

public int Add(
string dataRange,
int row,
int column
);

Parameters

dataRange
Specifies the new data range of the sparkline.
row
The row index of the location.
column
The column index of the location.

See Also

SparklineCollection Class | Aspose.Cells.Charts Namespace


SparklineCollection.Remove Method

Removes the sparkline

public void Remove(
object o
);

Parameters

o

See Also

SparklineCollection Class | Aspose.Cells.Charts Namespace


SparklineGroup Class

Sparkline is organized into sparkline group. A SparklineGroup contains a variable number of sparkline items. A sparkline group specifies the type, display settings and axis settings for the sparklines.

For a list of all members of this type, see SparklineGroup Members.

System.Object
Aspose.Cells.Charts.SparklineGroup

public class SparklineGroup

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SparklineGroup Members | Aspose.Cells.Charts Namespace


SparklineGroup Members

SparklineGroup overview

Public Instance Properties

DisplayHidden | Indicates whether to show data in hidden rows and columns.
FirstPointColor | Gets and sets the color of the first point of data in the sparkline group.
HighPointColor | Gets and sets the color of the highest points of data in the sparkline group.
HorizontalAxisColor | Gets and sets the color of the horizontal axis in the sparkline group.
HorizontalAxisDateRange | Represents the range that contains the date values for the sparkline data.
LastPointColor | Gets and sets the color of the last point of data in the sparkline group.
LineWeight | Gets and sets the line weight in each line sparkline in the sparkline group, in the unit of points.
LowPointColor | Gets and sets the color of the lowest points of data in the sparkline group.
MarkersColor | Gets and sets the color of points in each line sparkline in the sparkline group.
NegativePointsColor | Gets and sets the color of the negative values on the sparkline group.
PlotEmptyCellsType | Indicates how to plot empty cells.
PlotRightToLeft | Indicates whether the plot data is right to left.
PresetStyle | Gets and sets the preset style type of the sparkline group.
SeriesColor | Gets and sets the color of the sparklines in the sparkline group.
ShowFirstPoint | Indicates whether to highlight the first point of data in the sparkline group.
ShowHighPoint | Indicates whether to highlight the highest points of data in the sparkline group.
ShowHorizontalAxis | Indicates whether to show the sparkline horizontal axis. The horizontal axis appears if the sparkline has data that crosses the zero axis.
ShowLastPoint | Indicates whether to highlight the last point of data in the sparkline group.
ShowLowPoint | Indicates whether to highlight the lowest points of data in the sparkline group.
ShowMarkers | Indicates whether to highlight each point in each line sparkline in the sparkline group.
ShowNegativePoints | Indicates whether to highlight the negative values on the sparkline group with a different color or marker.
SparklineCollection | Gets the SparklineCollection object of the sparkline group.
Type | Indicates the sparkline type of the sparkline group.
VerticalAxisMaxValue | Gets and sets the custom maximum value for the vertical axis.
VerticalAxisMaxValueType | Represents the vertical axis maximum value type.
VerticalAxisMinValue | Gets and sets the custom minimum value for the vertical axis.
VerticalAxisMinValueType | Represents the vertical axis minimum value type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ResetRanges | Resets the data range and location range of the sparkline group. This method will clear original sparkline items in the group and creates new sparkline items for the new ranges.
ToString (inherited from Object) |

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


SparklineGroup Properties

The properties of the SparklineGroup class are listed below. For a complete list of SparklineGroup class members, see the SparklineGroup Members topic.

Public Instance Properties

DisplayHidden | Indicates whether to show data in hidden rows and columns.
FirstPointColor | Gets and sets the color of the first point of data in the sparkline group.
HighPointColor | Gets and sets the color of the highest points of data in the sparkline group.
HorizontalAxisColor | Gets and sets the color of the horizontal axis in the sparkline group.
HorizontalAxisDateRange | Represents the range that contains the date values for the sparkline data.
LastPointColor | Gets and sets the color of the last point of data in the sparkline group.
LineWeight | Gets and sets the line weight in each line sparkline in the sparkline group, in the unit of points.
LowPointColor | Gets and sets the color of the lowest points of data in the sparkline group.
MarkersColor | Gets and sets the color of points in each line sparkline in the sparkline group.
NegativePointsColor | Gets and sets the color of the negative values on the sparkline group.
PlotEmptyCellsType | Indicates how to plot empty cells.
PlotRightToLeft | Indicates whether the plot data is right to left.
PresetStyle | Gets and sets the preset style type of the sparkline group.
SeriesColor | Gets and sets the color of the sparklines in the sparkline group.
ShowFirstPoint | Indicates whether to highlight the first point of data in the sparkline group.
ShowHighPoint | Indicates whether to highlight the highest points of data in the sparkline group.
ShowHorizontalAxis | Indicates whether to show the sparkline horizontal axis. The horizontal axis appears if the sparkline has data that crosses the zero axis.
ShowLastPoint | Indicates whether to highlight the last point of data in the sparkline group.
ShowLowPoint | Indicates whether to highlight the lowest points of data in the sparkline group.
ShowMarkers | Indicates whether to highlight each point in each line sparkline in the sparkline group.
ShowNegativePoints | Indicates whether to highlight the negative values on the sparkline group with a different color or marker.
SparklineCollection | Gets the SparklineCollection object of the sparkline group.
Type | Indicates the sparkline type of the sparkline group.
VerticalAxisMaxValue | Gets and sets the custom maximum value for the vertical axis.
VerticalAxisMaxValueType | Represents the vertical axis maximum value type.
VerticalAxisMinValue | Gets and sets the custom minimum value for the vertical axis.
VerticalAxisMinValueType | Represents the vertical axis minimum value type.

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


DisplayHidden Property

Aspose.Cells for .NET

SparklineGroup.DisplayHidden Property

Indicates whether to show data in hidden rows and columns.

public bool DisplayHidden {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


FirstPointColor Property

Aspose.Cells for .NET

SparklineGroup.FirstPointColor Property

Gets and sets the color of the first point of data in the sparkline group.

public CellsColor FirstPointColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


HighPointColor Property

Aspose.Cells for .NET

SparklineGroup.HighPointColor Property

Gets and sets the color of the highest points of data in the sparkline group.

public CellsColor HighPointColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


HorizontalAxisColor Property

Aspose.Cells for .NET

SparklineGroup.HorizontalAxisColor Property

Gets and sets the color of the horizontal axis in the sparkline group.

public CellsColor HorizontalAxisColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


HorizontalAxisDateRange Property

Aspose.Cells for .NET

SparklineGroup.HorizontalAxisDateRange Property

Represents the range that contains the date values for the sparkline data.

public string HorizontalAxisDateRange {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


LastPointColor Property

Aspose.Cells for .NET

SparklineGroup.LastPointColor Property

Gets and sets the color of the last point of data in the sparkline group.

public CellsColor LastPointColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


LineWeight Property

Aspose.Cells for .NET

SparklineGroup.LineWeight Property

Gets and sets the line weight in each line sparkline in the sparkline group, in the unit of points.

public double LineWeight {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


LowPointColor Property

Aspose.Cells for .NET

SparklineGroup.LowPointColor Property

Gets and sets the color of the lowest points of data in the sparkline group.

public CellsColor LowPointColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


MarkersColor Property

Aspose.Cells for .NET

SparklineGroup.MarkersColor Property

Gets and sets the color of points in each line sparkline in the sparkline group.

public CellsColor MarkersColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


NegativePointsColor Property

Aspose.Cells for .NET

SparklineGroup.NegativePointsColor Property

Gets and sets the color of the negative values on the sparkline group.

public CellsColor NegativePointsColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


PlotEmptyCellsType Property

Aspose.Cells for .NET

SparklineGroup.PlotEmptyCellsType Property

Indicates how to plot empty cells.

public PlotEmptyCellsType PlotEmptyCellsType {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


PlotRightToLeft Property

Aspose.Cells for .NET

SparklineGroup.PlotRightToLeft Property

Indicates whether the plot data is right to left.

public bool PlotRightToLeft {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


PresetStyle Property

Aspose.Cells for .NET

SparklineGroup.PresetStyle Property

Gets and sets the preset style type of the sparkline group.

public SparklinePresetStyleType PresetStyle {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


SeriesColor Property

Aspose.Cells for .NET

SparklineGroup.SeriesColor Property

Gets and sets the color of the sparklines in the sparkline group.

public CellsColor SeriesColor {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowFirstPoint Property

Aspose.Cells for .NET

SparklineGroup.ShowFirstPoint Property

Indicates whether to highlight the first point of data in the sparkline group.

public bool ShowFirstPoint {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowHighPoint Property

Aspose.Cells for .NET

SparklineGroup.ShowHighPoint Property

Indicates whether to highlight the highest points of data in the sparkline group.

public bool ShowHighPoint {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowHorizontalAxis Property

Aspose.Cells for .NET

SparklineGroup.ShowHorizontalAxis Property

Indicates whether to show the sparkline horizontal axis. The horizontal axis appears if the sparkline has data that crosses the zero axis.

public bool ShowHorizontalAxis {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowLastPoint Property

Aspose.Cells for .NET

SparklineGroup.ShowLastPoint Property

Indicates whether to highlight the last point of data in the sparkline group.

public bool ShowLastPoint {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowLowPoint Property

Aspose.Cells for .NET

SparklineGroup.ShowLowPoint Property

Indicates whether to highlight the lowest points of data in the sparkline group.

public bool ShowLowPoint {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowMarkers Property

Aspose.Cells for .NET

SparklineGroup.ShowMarkers Property

Indicates whether to highlight each point in each line sparkline in the sparkline group.

public bool ShowMarkers {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


ShowNegativePoints Property

Aspose.Cells for .NET

SparklineGroup.ShowNegativePoints Property

Indicates whether to highlight the negative values on the sparkline group with a different color or marker.

public bool ShowNegativePoints {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


SparklineCollection Property

Aspose.Cells for .NET

SparklineGroup.SparklineCollection Property

Gets the SparklineCollection object of the sparkline group.

public SparklineCollection SparklineCollection {get;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


Type Property

Aspose.Cells for .NET

SparklineGroup.Type Property

Indicates the sparkline type of the sparkline group.

public SparklineType Type {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


VerticalAxisMaxValue Property

Aspose.Cells for .NET

SparklineGroup.VerticalAxisMaxValue Property

Gets and sets the custom maximum value for the vertical axis.

public double VerticalAxisMaxValue {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


VerticalAxisMaxValueType Property

Aspose.Cells for .NET

SparklineGroup.VerticalAxisMaxValueType Property

Represents the vertical axis maximum value type.

public SparklineAxisMinMaxType VerticalAxisMaxValueType {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


VerticalAxisMinValue Property

Aspose.Cells for .NET

SparklineGroup.VerticalAxisMinValue Property

Gets and sets the custom minimum value for the vertical axis.

public double VerticalAxisMinValue {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


VerticalAxisMinValueType Property

Aspose.Cells for .NET

SparklineGroup.VerticalAxisMinValueType Property

Represents the vertical axis minimum value type.

public SparklineAxisMinMaxType VerticalAxisMinValueType {get; set;}

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


SparklineGroup Methods

The methods of the SparklineGroup class are listed below. For a complete list of SparklineGroup class members, see the SparklineGroup Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ResetRanges | Resets the data range and location range of the sparkline group. This method will clear original sparkline items in the group and creates new sparkline items for the new ranges.
ToString (inherited from Object) |

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


SparklineGroup.ResetRanges Method

Resets the data range and location range of the sparkline group. This method will clear original sparkline items in the group and creates new sparkline items for the new ranges.

public void ResetRanges(
string dataRange,
bool isVertical,
CellArea locationRange
);

Parameters

dataRange
Specifies the new data range of the sparkline group.
isVertical
Specifies whether to plot the sparklines from the new data range by row or by column.
locationRange
Specifies where the sparklines to be placed.

See Also

SparklineGroup Class | Aspose.Cells.Charts Namespace


SparklineGroupCollection Class

Encapsulates a collection of SparklineGroup objects.

For a list of all members of this type, see SparklineGroupCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Charts.SparklineGroupCollection

public class SparklineGroupCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SparklineGroupCollection Members | Aspose.Cells.Charts Namespace


SparklineGroupCollection Members

SparklineGroupCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the SparklineGroup element at the specified index.

Public Instance Methods

Add | Adds an SparklineGroup item to the collection.
Clear (inherited from CollectionBase) |
ClearSparklineGroups | Clears the sparkline groups that overlaps an area of cells.
ClearSparklines | Clears the sparklines that is inside an area of cells.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


SparklineGroupCollection Properties

The properties of the SparklineGroupCollection class are listed below. For a complete list of SparklineGroupCollection class members, see the SparklineGroupCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the SparklineGroup element at the specified index.

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

SparklineGroupCollection.Item Property

Gets the SparklineGroup element at the specified index.

public SparklineGroup this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


SparklineGroupCollection Methods

The methods of the SparklineGroupCollection class are listed below. For a complete list of SparklineGroupCollection class members, see the SparklineGroupCollection Members topic.

Public Instance Methods

Add | Adds an SparklineGroup item to the collection.
Clear (inherited from CollectionBase) |
ClearSparklineGroups | Clears the sparkline groups that overlaps an area of cells.
ClearSparklines | Clears the sparklines that is inside an area of cells.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


SparklineGroupCollection.Add Method

Adds an SparklineGroup item to the collection.

public int Add(
SparklineType type,
string dataRange,
bool isVertical,
CellArea locationRange
);

Parameters

type
Specifies the type of the Sparkline group.
dataRange
Specifies the data range of the sparkline group.
isVertical
Specifies whether to plot the sparklines from the data range by row or by column.
locationRange
Specifies where the sparklines to be placed.

Return Value

SparklineGroup object index.

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


SparklineGroupCollection.ClearSparklineGroups Method

Clears the sparkline groups that overlaps an area of cells.

public void ClearSparklineGroups(
CellArea cellArea
);

Parameters

cellArea
Specifies the area of cells

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


SparklineGroupCollection.ClearSparklines Method

Clears the sparklines that is inside an area of cells.

public void ClearSparklines(
CellArea cellArea
);

Parameters

cellArea
Specifies the area of cells

See Also

SparklineGroupCollection Class | Aspose.Cells.Charts Namespace


SparklinePresetStyleType Enumeration

Represents the preset style types for sparkline.

public enum SparklinePresetStyleType

Members

Member Name | Description | Value
Style1 | Style 1 | 0
Style2 | Style 2 | 1
Style3 | Style 3 | 2
Style4 | Style 4 | 3
Style5 | Style 5 | 4
Style6 | Style 6 | 5
Style7 | Style 7 | 6
Style8 | Style 8 | 7
Style9 | Style 9 | 8
Style10 | Style 10 | 9
Style11 | Style 11 | 10
Style12 | Style 12 | 11
Style13 | Style 13 | 12
Style14 | Style 14 | 13
Style15 | Style 15 | 14
Style16 | Style 16 | 15
Style17 | Style 17 | 16
Style18 | Style 18 | 17
Style19 | Style 19 | 18
Style20 | Style 20 | 19
Style21 | Style 21 | 20
Style22 | Style 22 | 21
Style23 | Style 23 | 22
Style24 | Style 24 | 23
Style25 | Style 25 | 24
Style26 | Style 26 | 25
Style27 | Style 27 | 26
Style28 | Style 28 | 27
Style29 | Style 29 | 28
Style30 | Style 30 | 29
Style31 | Style 31 | 30
Style32 | Style 32 | 31
Style33 | Style 33 | 32
Style34 | Style 34 | 33
Style35 | Style 35 | 34
Style36 | Style 36 | 35
Custom | No preset style. | 36

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


SparklineType Enumeration

Represents the sparkline types.

public enum SparklineType

Members

Member Name | Description | Value
Line | Line sparkline. | 0
Column | Column sparkline. | 1
Stacked | Win/Loss sparkline. | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


TickLabelPositionType Enumeration

Represents the position type of tick-mark labels on the specified axis.

public enum TickLabelPositionType

Members

Member Name | Description | Value
High | Position type is high. | 0
Low | Position type is low. | 1
NextToAxis | Position type is next to axis. | 2
None | Position type is none. | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


TickLabels Class

Represents the tick-mark labels associated with tick marks on a chart axis.

For a list of all members of this type, see TickLabels Members.

System.Object
Aspose.Cells.Charts.TickLabels

public class TickLabels

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TickLabels Members | Aspose.Cells.Charts Namespace


TickLabels Members

TickLabels overview

Public Instance Properties

AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
BackgroundMode | Gets and sets the display mode of the background
DirectionType | Gets and sets the direction of text.
DisplayNumberFormat | Gets and sets the display number format of tick labels.
Font | Returns a Font object that represents the font of the specified TickLabels object.
IsAutomaticRotation | Indicates whether the rotation angle is automatic
Number | Represents the format number for the TickLabels object.
NumberFormat | Represents the format string for the TickLabels object.
NumberFormatLinked | True if the number format is linked to the cells (so that the number format changes in the labels when it changes in the cells).
Offset | Represents the distance between the levels of labels, and the distance between the first level and the axis line.
ReadingOrder | Represents text reading order.
RotationAngle | Represents text rotation angle in clockwise.
TextDirection | Obsolete. Represents text reading order.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


TickLabels Properties

The properties of the TickLabels class are listed below. For a complete list of TickLabels class members, see the TickLabels Members topic.

Public Instance Properties

AutoScaleFont | True if the text in the object changes font size when the object size changes. The default value is True.
BackgroundMode | Gets and sets the display mode of the background
DirectionType | Gets and sets the direction of text.
DisplayNumberFormat | Gets and sets the display number format of tick labels.
Font | Returns a Font object that represents the font of the specified TickLabels object.
IsAutomaticRotation | Indicates whether the rotation angle is automatic
Number | Represents the format number for the TickLabels object.
NumberFormat | Represents the format string for the TickLabels object.
NumberFormatLinked | True if the number format is linked to the cells (so that the number format changes in the labels when it changes in the cells).
Offset | Represents the distance between the levels of labels, and the distance between the first level and the axis line.
ReadingOrder | Represents text reading order.
RotationAngle | Represents text rotation angle in clockwise.
TextDirection | Obsolete. Represents text reading order.

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


AutoScaleFont Property

Aspose.Cells for .NET

TickLabels.AutoScaleFont Property

True if the text in the object changes font size when the object size changes. The default value is True.

public bool AutoScaleFont {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


BackgroundMode Property

Aspose.Cells for .NET

TickLabels.BackgroundMode Property

Gets and sets the display mode of the background

public BackgroundMode BackgroundMode {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


DirectionType Property

Aspose.Cells for .NET

TickLabels.DirectionType Property

Gets and sets the direction of text.

public ChartTextDirectionType DirectionType {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


DisplayNumberFormat Property

Aspose.Cells for .NET

TickLabels.DisplayNumberFormat Property

Gets and sets the display number format of tick labels.

public string DisplayNumberFormat {get;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


Font Property

Aspose.Cells for .NET

TickLabels.Font Property

Returns a Font object that represents the font of the specified TickLabels object.

public Font Font {get;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


IsAutomaticRotation Property

Aspose.Cells for .NET

TickLabels.IsAutomaticRotation Property

Indicates whether the rotation angle is automatic

public bool IsAutomaticRotation {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


Number Property

Aspose.Cells for .NET

TickLabels.Number Property

Represents the format number for the TickLabels object.

public int Number {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


NumberFormat Property

Aspose.Cells for .NET

TickLabels.NumberFormat Property

Represents the format string for the TickLabels object.

public string NumberFormat {get; set;}

Remarks

The formatting string is same as a custom format string setting to a cell. For example, "$0".

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


NumberFormatLinked Property

Aspose.Cells for .NET

TickLabels.NumberFormatLinked Property

True if the number format is linked to the cells (so that the number format changes in the labels when it changes in the cells).

public bool NumberFormatLinked {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


Offset Property

Aspose.Cells for .NET

TickLabels.Offset Property

Represents the distance between the levels of labels, and the distance between the first level and the axis line.

public int Offset {get; set;}

Remarks

The default distance is 100 percent, which represents the default spacing between the axis labels and the axis line. The value can be an integer percentage from 0 through 1000, relative to the axis label¡¯s font size.

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


ReadingOrder Property

Aspose.Cells for .NET

TickLabels.ReadingOrder Property

Represents text reading order.

public TextDirectionType ReadingOrder {get; set;}

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


RotationAngle Property

Aspose.Cells for .NET

TickLabels.RotationAngle Property

Represents text rotation angle in clockwise.

public int RotationAngle {get; set;}

Remarks

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


TextDirection Property

Aspose.Cells for .NET

TickLabels.TextDirection Property

NOTE: This property is now obsolete.

Use TickLabels.ReadingOrder property instead.

Represents text reading order.

public TextDirectionType TextDirection {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use TickLabels.ReadingOrder property. This property will be removed 12 months later since March 2020. Aspose apologizes for any inconvenience you may have experienced.

See Also

TickLabels Class | Aspose.Cells.Charts Namespace


TickMarkType Enumeration

Represents the tick mark type for the specified axis.

public enum TickMarkType

Members

Member Name | Description | Value
Cross | Tick mark type is Cross. | 0
Inside | Tick mark type is Inside. | 1
None | Tick mark type is None. | 2
Outside | Tick mark type is Outside | 3

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


TimeUnit Enumeration

Represents the base unit for the category axis.

public enum TimeUnit

Members

Member Name | Description | Value
Days | Days | 0
Months | Months | 1
Years | Years | 2

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Title Class

Encapsulates the object that represents the title of chart or axis.

For a list of all members of this type, see Title Members.

System.Object
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartTextFrame
Aspose.Cells.Charts.Title

public class Title : ChartTextFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Setting the title of a chart
chart.Title.Text = "Title";
//Setting the font color of the chart title to blue
chart.Title.Font.Color = Color.Blue;
//Setting the title of category axis of the chart
chart.CategoryAxis.Title.Text = "Category";
//Setting the title of value axis of the chart
chart.ValueAxis.Title.Text = "Value";

[Visual Basic]

'Setting the title of a chart
chart.Title.Text = "Title"
'Setting the font color of the chart title to blue
chart.Title.Font.Color = Color.Blue
'Setting the title of category axis of the chart
chart.CategoryAxis.Title.Text = "Category"
'Setting the title of value axis of the chart
chart.ValueAxis.Title.Text = "Value"

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Title Members | Aspose.Cells.Charts Namespace


Title Members

Title overview

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType (inherited from ChartTextFrame) | Gets and sets the direction of text.
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText (inherited from ChartTextFrame) | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted (inherited from ChartTextFrame) | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText (inherited from ChartTextFrame) | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped (inherited from ChartTextFrame) | Gets or sets a value indicating whether the text is wrapped.
IsVisible | Represents whether the title is visible.
LinkedSource (inherited from ChartTextFrame) | Gets and sets a reference to the worksheet.
OverLay | Represents overlay centered title on chart without resizing chart.
ReadingOrder (inherited from ChartTextFrame) | Represents text reading order.
RotationAngle (inherited from ChartTextFrame) | Represents text rotation angle.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
Text | Gets or sets the text of display unit label.
TextDirection (inherited from ChartTextFrame) | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment (inherited from ChartTextFrame) | Gets and sets the text horizontal alignment.
TextVerticalAlignment (inherited from ChartTextFrame) | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

Public Instance Methods

Characters | Overloaded. Gets rich text formatting of this Title.
Characters (inherited from ChartTextFrame) | Overloaded. Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

Title Class | Aspose.Cells.Charts Namespace


Title Properties

The properties of the Title class are listed below. For a complete list of Title class members, see the Title Members topic.

Public Instance Properties

Area (inherited from ChartFrame) | Gets the area.
AutoScaleFont (inherited from ChartFrame) | True if the text in the object changes font size when the object size changes. The default value is True.
Background (inherited from ChartFrame) | Obsolete. Gets and sets the display mode of the background
BackgroundMode (inherited from ChartFrame) | Gets and sets the display mode of the background
Border (inherited from ChartFrame) | Gets the border.
DefaultHeight (inherited from ChartFrame) | Represents height of default position
DefaultWidth (inherited from ChartFrame) | Represents width of default position
DefaultX (inherited from ChartFrame) | Represents x of default position
DefaultY (inherited from ChartFrame) | Represents y of default position
DirectionType (inherited from ChartTextFrame) | Gets and sets the direction of text.
Font (inherited from ChartFrame) | Gets a Font object of the specified ChartFrame object.
Height (inherited from ChartFrame) | Gets or sets the height of frame in units of 1/4000 of the chart area.
IsAutomaticSize (inherited from ChartFrame) | Indicates whether the chart frame is automatic sized.
IsAutoText (inherited from ChartTextFrame) | Indicates the text is auto generated.
IsDefaultPosBeSet (inherited from ChartFrame) | Indicates whether default position(DefaultX, DefaultY, DefaultWidth and DefaultHeight) are set.
IsDeleted (inherited from ChartTextFrame) | Indicates whether this data labels is deleted.
IsInnerMode (inherited from ChartFrame) | Indicates whether the size of the plot area size includes the tick marks, and the axis labels. False specifies that the size shall determine the size of the plot area, the tick marks, and the axis labels.
IsResizeShapeToFitText (inherited from ChartTextFrame) | Gets or sets whether a shape should be auto-fit to fully contain the text described within it. Auto-fitting is when text within a shape is scaled in order to contain all the text inside.
IsTextWrapped (inherited from ChartTextFrame) | Gets or sets a value indicating whether the text is wrapped.
IsVisible | Represents whether the title is visible.
LinkedSource (inherited from ChartTextFrame) | Gets and sets a reference to the worksheet.
OverLay | Represents overlay centered title on chart without resizing chart.
ReadingOrder (inherited from ChartTextFrame) | Represents text reading order.
RotationAngle (inherited from ChartTextFrame) | Represents text rotation angle.
Shadow (inherited from ChartFrame) | True if the frame has a shadow.
ShapeProperties (inherited from ChartFrame) | Gets the ShapeProperties object.
Text | Gets or sets the text of display unit label.
TextDirection (inherited from ChartTextFrame) | Obsolete. Represents text reading order.
TextFont (inherited from ChartFrame) | Obsolete. Gets a Font object of the specified ChartFrame object.
TextHorizontalAlignment (inherited from ChartTextFrame) | Gets and sets the text horizontal alignment.
TextVerticalAlignment (inherited from ChartTextFrame) | Gets or sets the text vertical alignment of text.
Width (inherited from ChartFrame) | Gets or sets the width of frame in units of 1/4000 of the chart area.
X | Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.
Y | Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

See Also

Title Class | Aspose.Cells.Charts Namespace


IsVisible Property

Aspose.Cells for .NET

Title.IsVisible Property

Represents whether the title is visible.

public bool IsVisible {get; set;}

See Also

Title Class | Aspose.Cells.Charts Namespace


OverLay Property

Aspose.Cells for .NET

Title.OverLay Property

Represents overlay centered title on chart without resizing chart.

public bool OverLay {get; set;}

See Also

Title Class | Aspose.Cells.Charts Namespace


Text Property

Aspose.Cells for .NET

Title.Text Property

Gets or sets the text of display unit label.

public override string Text {get; set;}

See Also

Title Class | Aspose.Cells.Charts Namespace


X Property

Aspose.Cells for .NET

Title.X Property

Gets or sets the x coordinate of the upper left corner in units of 1/4000 of the chart area.

public override int X {get; set;}

See Also

Title Class | Aspose.Cells.Charts Namespace


Y Property

Aspose.Cells for .NET

Title.Y Property

Gets or sets the y coordinate of the upper left corner in units of 1/4000 of the chart area.

public override int Y {get; set;}

See Also

Title Class | Aspose.Cells.Charts Namespace


Title Methods

The methods of the Title class are listed below. For a complete list of Title class members, see the Title Members topic.

Public Instance Methods

Characters | Overloaded. Gets rich text formatting of this Title.
Characters (inherited from ChartTextFrame) | Overloaded. Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetPositionAuto (inherited from ChartFrame) | Set position of the frame to automatic
ToString (inherited from Object) |

See Also

Title Class | Aspose.Cells.Charts Namespace


Characters Method

Aspose.Cells for .NET

Title.Characters Method

Gets rich text formatting of this Title.

Overload List

Gets rich text formatting of this Title.

public FontSetting[] Characters();

Inherited from ChartTextFrame.

public FontSetting Characters(int,int);

See Also

Title Class | Aspose.Cells.Charts Namespace


Title.Characters Method ()

Gets rich text formatting of this Title.

public FontSetting[] Characters();

Return Value

returns FontSetting array

See Also

Title Class | Aspose.Cells.Charts Namespace | Title.Characters Overload List


Trendline Class

Represents a trendline in a chart.

For a list of all members of this type, see Trendline Members.

System.Object
Aspose.Cells.Drawing.Line
Aspose.Cells.Charts.Trendline

public class Trendline : Line

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Excel object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a sample value to "A4" cell
worksheet.Cells["A4"].PutValue(200);
//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);
//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);
//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);
//Adding a sample value to "B4" cell
worksheet.Cells["B4"].PutValue(40);
//Adding a sample value to "C1" cell as category data
worksheet.Cells["C1"].PutValue("Q1");
//Adding a sample value to "C2" cell as category data
worksheet.Cells["C2"].PutValue("Q2");
//Adding a sample value to "C3" cell as category data
worksheet.Cells["C3"].PutValue("Y1");
//Adding a sample value to "C4" cell as category data
worksheet.Cells["C4"].PutValue("Y2");
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", true);
//Setting the data source for the category data of NSeries
chart.NSeries.CategoryData = "C1:C4";
//adding a linear trendline
int index = chart.NSeries[0].TrendLines.Add(TrendlineType.Linear);
Trendline trendline = chart.NSeries[0].TrendLines[index];
//Setting the custom name of the trendline.
trendline.Name = "Linear";
//Displaying the equation on chart
trendline.DisplayEquation = true;
//Displaying the R-Squared value on chart
trendline.DisplayRSquared = true;
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Excel object
Dim sheetIndex As Int32 = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a sample value to "A4" cell
worksheet.Cells("A4").PutValue(200)
'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)
'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)
'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)
'Adding a sample value to "B4" cell
worksheet.Cells("B4").PutValue(40)
'Adding a sample value to "C1" cell as category data
worksheet.Cells("C1").PutValue("Q1")
'Adding a sample value to "C2" cell as category data
worksheet.Cells("C2").PutValue("Q2")
'Adding a sample value to "C3" cell as category data
worksheet.Cells("C3").PutValue("Y1")
'Adding a sample value to "C4" cell as category data
worksheet.Cells("C4").PutValue("Y2")
'Adding a chart to the worksheet
Dim chartIndex As Int32 = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B4"
chart.NSeries.Add("A1:B4", True)
'Setting the data source for the category data of NSeries
Chart.NSeries.CategoryData = "C1:C4"
'adding a linear trendline
Dim index As Int32 = chart.NSeries(0).TrendLines.Add(TrendlineType.Linear)
Dim trendline As Trendline = chart.NSeries(0).TrendLines(index)
'Setting the custom name of the trendline.
trendline.Name = "Linear"
'Displaying the equation on chart
trendline.DisplayEquation = True
'Displaying the R-Squared value on chart
trendline.DisplayRSquared = True
'Saving the Excel file
workbook.Save("C:\\book1.xls")

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Trendline Members | Aspose.Cells.Charts Namespace


Trendline Members

Trendline overview

Public Instance Properties

Backward | Returns or sets the number of periods (or units on a scatter chart) that the trendline extends backward. The number of periods must be greater than and equal to zero. If the chart type is column ,the number of periods must be between 0 and 0.5
BeginArrowLength (inherited from Line) | Specifies the length of the arrowhead for the begin of a line.
BeginArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the begin of a line.
BeginType (inherited from Line) | Specifies an arrowhead for the begin of a line.
CapType (inherited from Line) | Specifies the ending caps.
Color (inherited from Line) | Represents the Color of the line.
CompoundType (inherited from Line) | Specifies the compound line type
DashType (inherited from Line) | Specifies the dash line type
DataLabels | Represents the DataLabels object for the specified ASeries.
DisplayEquation | Represents if the equation for the trendline is displayed on the chart (in the same data label as the R-squared value). Setting this property to True automatically turns on data labels.
DisplayRSquared | Represents if the R-squared value of the trendline is displayed on the chart (in the same data label as the equation). Setting this property to True automatically turns on data labels.
EndArrowLength (inherited from Line) | Specifies the length of the arrowhead for the end of a line.
EndArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the end of a line.
EndType (inherited from Line) | Specifies an arrowhead for the end of a line.
FormattingType (inherited from Line) | Gets or sets format type.
Forward | Returns or sets the number of periods (or units on a scatter chart) that the trendline extends forward. The number of periods must be greater than and equal to zero.
GradientFill (inherited from Line) | Represents gradient fill.
Intercept | Returns or sets the point where the trendline crosses the value axis.
IsAuto (inherited from Line) | Indicates whether this line style is auto assigned.
IsAutomaticColor (inherited from Line) | Indicates whether the color of line is auotmatic assigned.
IsNameAuto | Returns if Microsoft Excel automatically determines the name of the trendline.
IsVisible (inherited from Line) | Represents whether the line is visible.
JoinType (inherited from Line) | Specifies the joining caps.
LegendEntry | Gets the legend entry according to this trendline
Name | Returns the name of the trendline.
Order | Returns or sets the trendline order (an integer greater than 1) when the trendline type is Polynomial. The order must be between 2 and 6.
Period | Returns or sets the period for the moving-average trendline.
Style (inherited from Line) | Represents the style of the line.
ThemeColor (inherited from Line) | Gets and sets the theme color.
Transparency (inherited from Line) | Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).
Type | Returns the trendline type.
Weight (inherited from Line) | Gets or sets the WeightType of the line.
WeightPt (inherited from Line) | Gets or sets the weight of the line in unit of points.
WeightPx (inherited from Line) | Gets or sets the weight of the line in unit of pixels.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Trendline Properties

The properties of the Trendline class are listed below. For a complete list of Trendline class members, see the Trendline Members topic.

Public Instance Properties

Backward | Returns or sets the number of periods (or units on a scatter chart) that the trendline extends backward. The number of periods must be greater than and equal to zero. If the chart type is column ,the number of periods must be between 0 and 0.5
BeginArrowLength (inherited from Line) | Specifies the length of the arrowhead for the begin of a line.
BeginArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the begin of a line.
BeginType (inherited from Line) | Specifies an arrowhead for the begin of a line.
CapType (inherited from Line) | Specifies the ending caps.
Color (inherited from Line) | Represents the Color of the line.
CompoundType (inherited from Line) | Specifies the compound line type
DashType (inherited from Line) | Specifies the dash line type
DataLabels | Represents the DataLabels object for the specified ASeries.
DisplayEquation | Represents if the equation for the trendline is displayed on the chart (in the same data label as the R-squared value). Setting this property to True automatically turns on data labels.
DisplayRSquared | Represents if the R-squared value of the trendline is displayed on the chart (in the same data label as the equation). Setting this property to True automatically turns on data labels.
EndArrowLength (inherited from Line) | Specifies the length of the arrowhead for the end of a line.
EndArrowWidth (inherited from Line) | Specifies the width of the arrowhead for the end of a line.
EndType (inherited from Line) | Specifies an arrowhead for the end of a line.
FormattingType (inherited from Line) | Gets or sets format type.
Forward | Returns or sets the number of periods (or units on a scatter chart) that the trendline extends forward. The number of periods must be greater than and equal to zero.
GradientFill (inherited from Line) | Represents gradient fill.
Intercept | Returns or sets the point where the trendline crosses the value axis.
IsAuto (inherited from Line) | Indicates whether this line style is auto assigned.
IsAutomaticColor (inherited from Line) | Indicates whether the color of line is auotmatic assigned.
IsNameAuto | Returns if Microsoft Excel automatically determines the name of the trendline.
IsVisible (inherited from Line) | Represents whether the line is visible.
JoinType (inherited from Line) | Specifies the joining caps.
LegendEntry | Gets the legend entry according to this trendline
Name | Returns the name of the trendline.
Order | Returns or sets the trendline order (an integer greater than 1) when the trendline type is Polynomial. The order must be between 2 and 6.
Period | Returns or sets the period for the moving-average trendline.
Style (inherited from Line) | Represents the style of the line.
ThemeColor (inherited from Line) | Gets and sets the theme color.
Transparency (inherited from Line) | Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).
Type | Returns the trendline type.
Weight (inherited from Line) | Gets or sets the WeightType of the line.
WeightPt (inherited from Line) | Gets or sets the weight of the line in unit of points.
WeightPx (inherited from Line) | Gets or sets the weight of the line in unit of pixels.

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Backward Property

Aspose.Cells for .NET

Trendline.Backward Property

Returns or sets the number of periods (or units on a scatter chart) that the trendline extends backward. The number of periods must be greater than and equal to zero. If the chart type is column ,the number of periods must be between 0 and 0.5

public double Backward {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


DataLabels Property

Aspose.Cells for .NET

Trendline.DataLabels Property

Represents the DataLabels object for the specified ASeries.

public DataLabels DataLabels {get;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


DisplayEquation Property

Aspose.Cells for .NET

Trendline.DisplayEquation Property

Represents if the equation for the trendline is displayed on the chart (in the same data label as the R-squared value). Setting this property to True automatically turns on data labels.

public bool DisplayEquation {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


DisplayRSquared Property

Aspose.Cells for .NET

Trendline.DisplayRSquared Property

Represents if the R-squared value of the trendline is displayed on the chart (in the same data label as the equation). Setting this property to True automatically turns on data labels.

public bool DisplayRSquared {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Forward Property

Aspose.Cells for .NET

Trendline.Forward Property

Returns or sets the number of periods (or units on a scatter chart) that the trendline extends forward. The number of periods must be greater than and equal to zero.

public double Forward {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Intercept Property

Aspose.Cells for .NET

Trendline.Intercept Property

Returns or sets the point where the trendline crosses the value axis.

public double Intercept {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


IsNameAuto Property

Aspose.Cells for .NET

Trendline.IsNameAuto Property

Returns if Microsoft Excel automatically determines the name of the trendline.

public bool IsNameAuto {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


LegendEntry Property

Aspose.Cells for .NET

Trendline.LegendEntry Property

Gets the legend entry according to this trendline

public LegendEntry LegendEntry {get;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Name Property

Aspose.Cells for .NET

Trendline.Name Property

Returns the name of the trendline.

public string Name {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Order Property

Aspose.Cells for .NET

Trendline.Order Property

Returns or sets the trendline order (an integer greater than 1) when the trendline type is Polynomial. The order must be between 2 and 6.

public int Order {get; set;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Period Property

Aspose.Cells for .NET

Trendline.Period Property

Returns or sets the period for the moving-average trendline.

public int Period {get; set;}

Remarks

This value should be between 2 and 255. And it must be less than the number of the chart points in the series

See Also

Trendline Class | Aspose.Cells.Charts Namespace


Type Property

Aspose.Cells for .NET

Trendline.Type Property

Returns the trendline type.

public TrendlineType Type {get;}

See Also

Trendline Class | Aspose.Cells.Charts Namespace


TrendlineCollection Class

Represents a collection of all the Trendline objects for the specified data series.

For a list of all members of this type, see TrendlineCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Charts.TrendlineCollection

public class TrendlineCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
int chartIndex = excel.Worksheets[0].Charts.Add(ChartType.Column, 3, 3, 15, 10);
Chart chart = excel.Worksheets[0].Charts[chartIndex];
chart.NSeries.Add("A1:a3", true);
chart.NSeries[0].TrendLines.Add(TrendlineType.Linear, "MyTrendLine");
Trendline line = chart.NSeries[0].TrendLines[0];
line.DisplayEquation = true;
line.DisplayRSquared = true;
line.Color = Color.Red;

[Visual Basic]
Dim chartIndex As Integer =  excel.Worksheets(0).Charts.Add(ChartType.Column,3,3,15,10)
Dim chart As Chart =  excel.Worksheets(0).Charts(chartIndex)
chart.NSeries.Add("A1:a3", True)
chart.NSeries(0).TrendLines.Add(TrendlineType.Linear, "MyTrendLine")
Dim line As Trendline =  chart.NSeries(0).TrendLines(0)
line.DisplayEquation = True
line.DisplayRSquared = True
line.Color = Color.Red

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TrendlineCollection Members | Aspose.Cells.Charts Namespace


TrendlineCollection Members

TrendlineCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets a object by its index.

Public Instance Methods

Add | Overloaded. Adds a object to this collection with specified type.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace


TrendlineCollection Properties

The properties of the TrendlineCollection class are listed below. For a complete list of TrendlineCollection class members, see the TrendlineCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets a object by its index.

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace


Item Property

Aspose.Cells for .NET

TrendlineCollection.Item Property

Gets a object by its index.

public Trendline this[
int index
] {get;}

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace | Trendline


TrendlineCollection Methods

The methods of the TrendlineCollection class are listed below. For a complete list of TrendlineCollection class members, see the TrendlineCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a object to this collection with specified type.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace


Add Method

Aspose.Cells for .NET

TrendlineCollection.Add Method

Adds a object to this collection with specified type.

Overload List

Adds a object to this collection with specified type.

public int Add(TrendlineType);

Adds a object to this collection with specified type and name.

public int Add(TrendlineType,string);

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace | Trendline


TrendlineCollection.Add Method (TrendlineType)

Adds a object to this collection with specified type.

public int Add(
TrendlineType type
);

Parameters

type
Trendline type.

Return Value

Trendline object index.

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace | TrendlineCollection.Add Overload List | Trendline


TrendlineCollection.Add Method (TrendlineType, String)

Adds a object to this collection with specified type and name.

public int Add(
TrendlineType type,
string name
);

Parameters

type
Trendline type.
name
Trendline name.

Return Value

Trendline object index.

See Also

TrendlineCollection Class | Aspose.Cells.Charts Namespace | TrendlineCollection.Add Overload List | Trendline


TrendlineType Enumeration

Represents the trendline type.

public enum TrendlineType

Members

Member Name | Description | Value
Exponential | Exponential | 0
Linear | Linear | 1
Logarithmic | Logarithmic | 2
MovingAverage | MovingAverage | 3
Polynomial | Polynomial | 4
Power | Power | 5

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Charts Namespace


Walls Class

Encapsulates the object that represents the walls of a 3-D chart.

For a list of all members of this type, see Walls Members.

System.Object
Aspose.Cells.Drawing.Area
Aspose.Cells.Charts.Floor
Aspose.Cells.Charts.Walls

public class Walls : Floor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Charts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Walls Members | Aspose.Cells.Charts Namespace


Walls Members

Walls overview

Public Instance Properties

BackgroundColor (inherited from Area) | Gets or sets the background Color of the Area.
Border (inherited from Floor) | Gets or sets the border Line.
CenterX | Gets the x coordinate of the left-bottom corner of Wall center in units of 1/4000 of chart's width after calls Chart.Calculate() method.
CenterXPx | Gets the x coordinate of the left-bottom corner of Wall center in units of pixels after calls Chart.Calculate() method.
CenterY | Gets the y coordinate of the left-bottom corner of Wall center in units of 1/4000 of chart's height after calls Chart.Calculate() method.
CenterYPx | Gets the y coordinate of the left-bottom corner of Wall center in units of pixels after calls Chart.Calculate() method.
Depth | Gets the depth front to back in units of 1/4000 of chart's width after calls Chart.Calculate() method.
DepthPx | Gets the depth front to back in units of pixels after calls Chart.Calculate() method.
FillFormat (inherited from Area) | Represents a object that contains fill formatting properties for the specified chart or shape.
ForegroundColor (inherited from Area) | Gets or sets the foreground Color.
Formatting (inherited from Area) | Represents the formatting of the area.
Height | Gets the height of top to bottom in units of 1/4000 of chart's height after calls Chart.Calculate() method.
HeightPx | Gets the height of top to bottom in units of pixels after calls Chart.Calculate() method.
InvertIfNegative (inherited from Area) | If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.
Transparency (inherited from Area) | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Width | Gets the width of left to right in units of 1/4000 of chart's width after calls Chart.Calculate() method.
WidthPx | Gets the width of left to right in units of pixels after calls Chart.Calculate() method.

Public Instance Methods

Equals (inherited from Object) |
GetCubePointCount | Gets the number of cube points after calls Chart.Calculate() method.
GetCubePointXPx | Gets x-coordinate of the apex point of walls cube after calls Chart.Calculate() method. The number of apex points of walls cube is eight
GetCubePointYPx | Gets y-coordinate of the apex point of walls cube after calls Chart.Calculate() method. The number of apex points of walls cube is eight.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Walls Class | Aspose.Cells.Charts Namespace


Walls Properties

The properties of the Walls class are listed below. For a complete list of Walls class members, see the Walls Members topic.

Public Instance Properties

BackgroundColor (inherited from Area) | Gets or sets the background Color of the Area.
Border (inherited from Floor) | Gets or sets the border Line.
CenterX | Gets the x coordinate of the left-bottom corner of Wall center in units of 1/4000 of chart's width after calls Chart.Calculate() method.
CenterXPx | Gets the x coordinate of the left-bottom corner of Wall center in units of pixels after calls Chart.Calculate() method.
CenterY | Gets the y coordinate of the left-bottom corner of Wall center in units of 1/4000 of chart's height after calls Chart.Calculate() method.
CenterYPx | Gets the y coordinate of the left-bottom corner of Wall center in units of pixels after calls Chart.Calculate() method.
Depth | Gets the depth front to back in units of 1/4000 of chart's width after calls Chart.Calculate() method.
DepthPx | Gets the depth front to back in units of pixels after calls Chart.Calculate() method.
FillFormat (inherited from Area) | Represents a object that contains fill formatting properties for the specified chart or shape.
ForegroundColor (inherited from Area) | Gets or sets the foreground Color.
Formatting (inherited from Area) | Represents the formatting of the area.
Height | Gets the height of top to bottom in units of 1/4000 of chart's height after calls Chart.Calculate() method.
HeightPx | Gets the height of top to bottom in units of pixels after calls Chart.Calculate() method.
InvertIfNegative (inherited from Area) | If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.
Transparency (inherited from Area) | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Width | Gets the width of left to right in units of 1/4000 of chart's width after calls Chart.Calculate() method.
WidthPx | Gets the width of left to right in units of pixels after calls Chart.Calculate() method.

See Also

Walls Class | Aspose.Cells.Charts Namespace


CenterX Property

Aspose.Cells for .NET

Walls.CenterX Property

Gets the x coordinate of the left-bottom corner of Wall center in units of 1/4000 of chart's width after calls Chart.Calculate() method.

public int CenterX {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


CenterXPx Property

Aspose.Cells for .NET

Walls.CenterXPx Property

Gets the x coordinate of the left-bottom corner of Wall center in units of pixels after calls Chart.Calculate() method.

public int CenterXPx {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


CenterY Property

Aspose.Cells for .NET

Walls.CenterY Property

Gets the y coordinate of the left-bottom corner of Wall center in units of 1/4000 of chart's height after calls Chart.Calculate() method.

public int CenterY {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


CenterYPx Property

Aspose.Cells for .NET

Walls.CenterYPx Property

Gets the y coordinate of the left-bottom corner of Wall center in units of pixels after calls Chart.Calculate() method.

public int CenterYPx {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


Depth Property

Aspose.Cells for .NET

Walls.Depth Property

Gets the depth front to back in units of 1/4000 of chart's width after calls Chart.Calculate() method.

public int Depth {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


DepthPx Property

Aspose.Cells for .NET

Walls.DepthPx Property

Gets the depth front to back in units of pixels after calls Chart.Calculate() method.

public int DepthPx {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


Height Property

Aspose.Cells for .NET

Walls.Height Property

Gets the height of top to bottom in units of 1/4000 of chart's height after calls Chart.Calculate() method.

public int Height {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


HeightPx Property

Aspose.Cells for .NET

Walls.HeightPx Property

Gets the height of top to bottom in units of pixels after calls Chart.Calculate() method.

public int HeightPx {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


Width Property

Aspose.Cells for .NET

Walls.Width Property

Gets the width of left to right in units of 1/4000 of chart's width after calls Chart.Calculate() method.

public int Width {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


WidthPx Property

Aspose.Cells for .NET

Walls.WidthPx Property

Gets the width of left to right in units of pixels after calls Chart.Calculate() method.

public int WidthPx {get;}

See Also

Walls Class | Aspose.Cells.Charts Namespace


Walls Methods

The methods of the Walls class are listed below. For a complete list of Walls class members, see the Walls Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetCubePointCount | Gets the number of cube points after calls Chart.Calculate() method.
GetCubePointXPx | Gets x-coordinate of the apex point of walls cube after calls Chart.Calculate() method. The number of apex points of walls cube is eight
GetCubePointYPx | Gets y-coordinate of the apex point of walls cube after calls Chart.Calculate() method. The number of apex points of walls cube is eight.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

Walls Class | Aspose.Cells.Charts Namespace


Walls.GetCubePointCount Method

Gets the number of cube points after calls Chart.Calculate() method.

public int GetCubePointCount();

See Also

Walls Class | Aspose.Cells.Charts Namespace


Walls.GetCubePointXPx Method

Gets x-coordinate of the apex point of walls cube after calls Chart.Calculate() method. The number of apex points of walls cube is eight

public float GetCubePointXPx(
int index
);

See Also

Walls Class | Aspose.Cells.Charts Namespace


Walls.GetCubePointYPx Method

Gets y-coordinate of the apex point of walls cube after calls Chart.Calculate() method. The number of apex points of walls cube is eight.

public float GetCubePointYPx(
int index
);

See Also

Walls Class | Aspose.Cells.Charts Namespace


Aspose.Cells.DigitalSignatures

Aspose.Cells for .NET

Aspose.Cells.DigitalSignatures Namespace

Namespace hierarchy

Classes

Class | Description
DigitalSignature | Signature in file.
DigitalSignatureCollection | Provides a collection of digital signatures attached to a document.

Enumerations

Enumeration | Description
XAdESType | Type of XML Advanced Electronic Signature (XAdES).


DigitalSignature Class

Signature in file.

For a list of all members of this type, see DigitalSignature Members.

System.Object
Aspose.Cells.DigitalSignatures.DigitalSignature

public class DigitalSignature

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.DigitalSignatures

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DigitalSignature Members | Aspose.Cells.DigitalSignatures Namespace


DigitalSignature Members

DigitalSignature overview

Public Instance Constructors

DigitalSignature Overloaded. Initializes a new instance of the DigitalSignature class.

Public Instance Properties

Certificate | Certificate object that was used to sign the document.
Comments | The purpose to signature.
IsValid | If this digital signature is valid and the document has not been tampered with, this value will be true.
SignTime | The time when the document was signed.
XAdESType | XAdES type. Default value is None(XAdES is off).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignature Constructor

Constructor of digitalSignature. Uses .Net implementation.

Overload List

Constructor of digitalSignature. Uses Bouncy Castle implementation.

public DigitalSignature(byte[],string,string,DateTime);

Constructor of digitalSignature. Uses .Net implementation.

public DigitalSignature(X509Certificate2,string,DateTime);

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignature Constructor (X509Certificate2, String, DateTime)

Constructor of digitalSignature. Uses .Net implementation.

public DigitalSignature(
X509Certificate2 certificate,
string comments,
DateTime signTime
);

Parameters

certificate
Certificate object that was used to sign the document.
comments
The purpose to signature.
signTime
The time when the document was signed.

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace | DigitalSignature Constructor Overload List


DigitalSignature Constructor (Byte[], String, String, DateTime)

Constructor of digitalSignature. Uses Bouncy Castle implementation.

public DigitalSignature(
byte[] rawData,
string password,
string comments,
DateTime signTime
);

Parameters

rawData
A byte array containing data from an X.509 certificate.
password
The password required to access the X.509 certificate data.
comments
The purpose to signature.
signTime
The time when the document was signed.

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace | DigitalSignature Constructor Overload List


DigitalSignature Properties

The properties of the DigitalSignature class are listed below. For a complete list of DigitalSignature class members, see the DigitalSignature Members topic.

Public Instance Properties

Certificate | Certificate object that was used to sign the document.
Comments | The purpose to signature.
IsValid | If this digital signature is valid and the document has not been tampered with, this value will be true.
SignTime | The time when the document was signed.
XAdESType | XAdES type. Default value is None(XAdES is off).

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


Certificate Property

Aspose.Cells for .NET

DigitalSignature.Certificate Property

Certificate object that was used to sign the document.

public X509Certificate2 Certificate {get; set;}

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


Comments Property

Aspose.Cells for .NET

DigitalSignature.Comments Property

The purpose to signature.

public string Comments {get; set;}

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


IsValid Property

Aspose.Cells for .NET

DigitalSignature.IsValid Property

If this digital signature is valid and the document has not been tampered with, this value will be true.

public bool IsValid {get;}

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


SignTime Property

Aspose.Cells for .NET

DigitalSignature.SignTime Property

The time when the document was signed.

public DateTime SignTime {get; set;}

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


XAdESType Property

Aspose.Cells for .NET

DigitalSignature.XAdESType Property

XAdES type. Default value is None(XAdES is off).

public XAdESType XAdESType {get; set;}

See Also

DigitalSignature Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignatureCollection Class

Provides a collection of digital signatures attached to a document.

For a list of all members of this type, see DigitalSignatureCollection Members.

System.Object
Aspose.Cells.DigitalSignatures.DigitalSignatureCollection

public class DigitalSignatureCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example shows how to create digital signature

[C#]
 internal void ValidateSignature()
 {
    Workbook wb = new Workbook(@"c:\newfile.xlsx");
    //wb.IsDigitallySigned is true when the workbook is signed already.
    System.Console.WriteLine(wb.IsDigitallySigned);
    //get digitalSignature collection from workbook
    DigitalSignatureCollection dsc = wb.GetDigitalSignature();
    foreach (DigitalSignature ds in dsc)
    {
        System.Console.WriteLine(ds.Comments);
        System.Console.WriteLine(ds.SignTime);
        System.Console.WriteLine(ds.IsValid);
    }
 }
 internal void SignSignature()
 {
    //dsc is signature collection contains one or more signature needed to sign
    DigitalSignatureCollection dsc = new DigitalSignatureCollection();
    //cert must contain private key, it can be contructed from cert file or windows certificate collection.
    //123456 is password of cert
    X509Certificate2 cert = new X509Certificate2("c:\\mykey2.pfx", "123456");
    DigitalSignature ds = new DigitalSignature(cert, "test for sign", DateTime.Now);
    dsc.Add(ds);
    Workbook wb = new Workbook();
    //wb.SetDigitalSignature sign all signatures in dsc
    wb.SetDigitalSignature(dsc);
    wb.Save(@"c:\newfile.xlsx");
 }

 [Visual Basic]
    Sub ValidateSignature()
    Dim workbook As Workbook = New Workbook("c:\newfile.xlsx")
    'Workbook.IsDigitallySigned is true when the workbook is signed already.
    System.Console.WriteLine(workbook.IsDigitallySigned)
    'get digitalSignature collection from workbook
    Dim dsc As DigitalSignatureCollection = workbook.GetDigitalSignature()
    Dim ds As DigitalSignature
    For Each ds In dsc
        System.Console.WriteLine(ds.Comments)
        System.Console.WriteLine(ds.SignTime)
        System.Console.WriteLine(ds.IsValid)
    Next
 End Sub

 Sub SignSignature()
    'dsc is signature collection contains one or more signature needed to sign
    Dim dsc As DigitalSignatureCollection = New DigitalSignatureCollection()
    'cert must contain private key, it can be contructed from cert file or windows certificate collection.
    Dim cert As X509Certificate2 = New X509Certificate2("c:\mykey2.pfx", "123456")
    'create a signature with certificate, sign purpose and sign time
    Dim ds As DigitalSignature = New DigitalSignature(cert, "test for sign", DateTime.Now)
    dsc.Add(ds)
    Dim workbook As Workbook = New Workbook()
    'workbook.SetDigitalSignature sign all signatures in dsc
    workbook.SetDigitalSignature(dsc)
    workbook.Save("c:\newfile.xlsx")
 End Sub

Requirements

Namespace: Aspose.Cells.DigitalSignatures

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DigitalSignatureCollection Members | Aspose.Cells.DigitalSignatures Namespace


DigitalSignatureCollection Members

DigitalSignatureCollection overview

Public Instance Constructors

DigitalSignatureCollection Constructor The constructor of DigitalSignatureCollection.

Public Instance Methods

Add | Add one signature to DigitalSignatureCollection.
Equals (inherited from Object) |
GetEnumerator | Get the enumerator for DigitalSignatureCollection, this enumerator allows iteration over the collection
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

DigitalSignatureCollection Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignatureCollection Constructor

The constructor of DigitalSignatureCollection.

public DigitalSignatureCollection();

See Also

DigitalSignatureCollection Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignatureCollection Methods

The methods of the DigitalSignatureCollection class are listed below. For a complete list of DigitalSignatureCollection class members, see the DigitalSignatureCollection Members topic.

Public Instance Methods

Add | Add one signature to DigitalSignatureCollection.
Equals (inherited from Object) |
GetEnumerator | Get the enumerator for DigitalSignatureCollection, this enumerator allows iteration over the collection
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

DigitalSignatureCollection Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignatureCollection.Add Method

Add one signature to DigitalSignatureCollection.

public void Add(
DigitalSignature digitalSignature
);

Parameters

digitalSignature
Digital signature in collection.

See Also

DigitalSignatureCollection Class | Aspose.Cells.DigitalSignatures Namespace


DigitalSignatureCollection.GetEnumerator Method

Get the enumerator for DigitalSignatureCollection, this enumerator allows iteration over the collection

public IEnumerator GetEnumerator();

Return Value

The enumerator to iteration.

Implements

IEnumerable.GetEnumerator

See Also

DigitalSignatureCollection Class | Aspose.Cells.DigitalSignatures Namespace


XAdESType Enumeration

Type of XML Advanced Electronic Signature (XAdES).

public enum XAdESType

Members

Member Name | Description | Value
None | XAdES is off. | 0
XAdES | Basic XAdES. | 1

Requirements

Namespace: Aspose.Cells.DigitalSignatures

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.DigitalSignatures Namespace


Aspose.Cells.Drawing

Aspose.Cells for .NET

Aspose.Cells.Drawing Namespace

Namespace hierarchy

Classes

Class | Description
ArcShape | Represents the arc shape.
Area | Encapsulates the object that represents an area format.
AutomaticFill | represents automatic fill.
Bevel | Represents a bevel of a shape
Button | Represents the Forms control: Button
CellsDrawing | Represents the auto shape and drawing object.
ChartShape | Represents the shape of the chart. Properties and methods for the ChartObject object control the appearance and size of the embedded chart on the worksheet.
CheckBox | Represents a check box object in a worksheet.
CheckBoxCollection | Represents a collection of CheckBox objects in a worksheet.
ColorHelper | Provides helper functions about color.
ComboBox | Represents the control form ComboBox.
CommentShape | Represents the shape of the comment.
CustomGeometry | Represents a custom geometric shape.
CustomXmlShape | Represents Custom xml shape ,such as Ink.
DialogBox | Represents the dialog box.
Fill | Represents the fill format of the shape.
FillFormat | Encapsulates the object that represents fill formatting for a shape.
Format3D | This class specifies the 3D shape properties for a chart element or shape.
Geometry | Represents a geometric shape.
GlowEffect | This class specifies a glow effect, in which a color blurred outline is added outside the edges of the object.
GradientFill | Represents the gradient fill.
GradientStop | Represents the gradient stop.
GradientStopCollection | Represents the gradient stop collection.
GroupBox | Encapsulates the object that represents a groupbox in a spreadsheet.
GroupFill | Represents this fill format should inherit the fill properties of the group.
GroupShape | Represents the group shape which contains the individual shapes.
Label | Encapsulates the object that represents a label in a spreadsheet.
Line | Encapsulates the object that represents the line format.
LineFormat | Represents all setting of the line.
LineShape | Represents the line shape.
ListBox | Represents a list box object.
MsoFillFormat | Represents fill formatting for a shape.
MsoFillFormatHelper | Represents fill formatting for a shape.
MsoFormatPicture | Represents the picture format.
MsoLineFormat | Represents line and arrowhead formatting.
MsoLineFormatHelper | Represents line and arrowhead formatting.
MsoTextFrame | Represents the text frame in a Shape object.
NoneFill | Represents no fill.
OleObject | Represents an OleObject in a worksheet.
OleObjectCollection | Represents embedded OLE objects.
Oval | Represents the oval shape.
PatternFill | Encapsulates the object that represents pattern fill format
PicFormatOption | Represents picture format option
Picture | Encapsulates the object that represents a single picture in a spreadsheet.
PictureCollection | Encapsulates a collection of Picture objects.
RadioButton | Represents a radio button.
RectangleShape | Represents the rectangle shape.
ReflectionEffect | This class specifies a reflection effect.
ScrollBar | Represents a scroll bar object.
ShadowEffect | This class specifies the shadow effect of the chart element or shape.
Shape | Represents the msodrawing object.
ShapeCollection | Represents all the shape in a worksheet/chart.
ShapeFormat | Obsolete.
ShapeGuide | Encapsulates a shape guide specifies the presence of a shape guide that will be used to govern the geometry of the specified shape
ShapeGuideCollection | Encapsulates a collection of shape guide
ShapePath | Represents a creation path consisting of a series of moves, lines and curves that when combined will form a geometric shape.
ShapePathCollection | Represents path collection information in NotPrimitive autoshape
ShapePathPoint | Represents an x-y coordinate within the path coordinate space.
ShapePathPointCollection | Represents all shape path points.
ShapePropertyCollection | This class specifies the visual shape properties for a chart element or shape.
ShapeSegmentPath | Represents a segment path in a path of the freeform.
ShapeSegmentPathCollection | Represents a creation path consisting of a series of moves, lines and curves that when combined will form a geometric shape.
SignatureLine | Represent the signature line.
SmartArtShape | Represents the smart art.
SolidFill | Encapsulates the object that represents solid fill format
Spinner | Represents the Forms control: Spinner.
TextBox | Encapsulates the object that represents a textbox in a spreadsheet.
TextBoxCollection | Encapsulates a collection of TextBox objects.
TextEffectFormat | Contains properties and methods that apply to WordArt objects.
TextureFill | Encapsulates the object that represents texture fill format
ThreeDFormat | Represents a shape's three-dimensional formatting.
TilePicOption | Represents tile picture as texture.
WebExtensionShape | Represents the shape of web extension.

Enumerations

Enumeration | Description
AutoShapeType | Represents all built-in auto shape type.
BevelPresetType | Represents a preset for a type of bevel which can be applied to a shape in 3D.
BevelType | Represents a preset for a type of bevel which can be applied to a shape in 3D.
CheckValueType | Represents the check value type of the check box.
DataLabelShapeType | Specifies the preset shape geometry that is to be used for a chart.
FillPattern | Enumerates shape fill pattern types.
FillPictureType | Represents the picture fill type.
FillType | Fill format type.
FormatSetType | Fill format set type.
GradientColorType | Represents the gradient color type for the specified fill.
GradientDirectionType | Represents all direction type of gradient.
GradientFillType | Represents all Gradient fill type.
GradientPresetType | Represents gradient preset color type.
GradientStyleType | Represents gradient shading style.
ImageType | Specifies the type (format) of an image.
LightRigDirectionType | Represents the light rig direction type.
LightRigType | Represents a preset light right that can be applied to a shape
LineCapType | Represents the caps of a line
LineJoinType | Represents the join styles of a line.
LineType | Enumerates the type of Picture border or Chart line.
MirrorType | Represents mirror type of texture fill
MsoArrowheadLength | Enumerates the line end width of the shape border line.
MsoArrowheadStyle | Enumerates the line end type of the shape border line.
MsoArrowheadWidth | Enumerates the line end width of the shape border line.
MsoDrawingType | Represents office drawing objects type.
MsoLineDashStyle | Represents style of dash drawing lines.
MsoLineStyle | Represents style of drawing lines.
MsoPresetTextEffect | Represents preset text effect type of WordArt.
MsoPresetTextEffectShape | Represents preset text effect shape type of WordArt.
OleFileType | Obsolete.
PlacementType | Represents the way the drawing object is attached to the cells below it.
PresetCameraType | Represent different algorithmic methods for setting all camera properties, including position.
PresetMaterialType | Describes surface appearance of a shape.
PresetShadowType | Represents preset shadow type.
PresetWordArtStyle | Represents the preset WordArt styles.
RectangleAlignmentType | Represents how to position two rectangles relative to each other.
ReflectionEffectType |
SelectionType | The selection type of list box.
ShapeLockType | Represents type of the property to be locked.
ShapePathType | Represents path segment type.
TextOverflowType | Represents the way the text vertical or horizontal overflow.
TextureType | Represents the preset texture type.
WeightType | Enumerates the weight types for a picture border or a chart line.


ArcShape Class

Represents the arc shape.

For a list of all members of this type, see ArcShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.ArcShape

public class ArcShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
 //Instantiate a new Workbook.
Workbook excelbook = new Workbook();

 //Add an arc shape.
Aspose.Cells.ArcShape arc1 = excelbook.Worksheets[0].Shapes.AddArc(2, 0, 2, 0, 130, 130);

 //Set the placement of the arc.
arc1.Placement = PlacementType.FreeFloating;

 //Set the fill format.
arc1.FillFormat.ForeColor = Color.Blue;

 //Set the line style.
arc1.LineFormat.Style = MsoLineStyle.Single;

 //Set the line weight.
arc1.LineFormat.Weight = 1;

 //Set the color of the arc line.
arc1.LineFormat.ForeColor = Color.Blue;

 //Set the dash style of the arc.
arc1.LineFormat.DashStyle = MsoLineDashStyle.Solid;

 //Add another arc shape.
Aspose.Cells.ArcShape arc2 = excelbook.Worksheets[0].Shapes.AddArc(9, 0, 2, 0, 130, 130);

 //Set the placement of the arc.
arc2.Placement = PlacementType.FreeFloating;

 //Set the line style.
arc2.LineFormat.Style = MsoLineStyle.Single;

 //Set the line weight.
arc2.LineFormat.Weight = 1;

 //Set the color of the arc line.
arc2.LineFormat.ForeColor = Color.Blue;

 //Set the dash style of the arc.
arc2.LineFormat.DashStyle = MsoLineDashStyle.Solid;

 //Save the excel file.
excelbook.Save("d:\\test\\tstarcs.xls");

 [VB..NET]

'Instantiate a new Workbook.
Dim excelbook As Workbook = New Workbook()

'Add an arc shape.
Dim arc1 As Aspose.Cells.ArcShape = excelbook.Worksheets(0).Shapes.AddArc(2, 0, 2, 0, 130, 130)

'Set the placement of the arc.
arc1.Placement = PlacementType.FreeFloating

'Set the fill format.
arc1.FillFormat.ForeColor = Color.Blue

'Set the line style.
arc1.LineFormat.Style = MsoLineStyle.Single

'Set the line weight.
arc1.LineFormat.Weight = 1

'Set the color of the arc line.
arc1.LineFormat.ForeColor = Color.Blue

'Set the dash style of the arc.
arc1.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Add another arc shape.
Dim arc2 As Aspose.Cells.ArcShape = excelbook.Worksheets(0).Shapes.AddArc(9, 0, 2, 0, 130, 130)

'Set the placement of the arc.
arc2.Placement = PlacementType.FreeFloating

'Set the line style.
arc2.LineFormat.Style = MsoLineStyle.Single

'Set the line weight.
arc2.LineFormat.Weight = 1

'Set the color of the arc line.
arc2.LineFormat.ForeColor = Color.Blue

'Set the dash style of the arc.
arc2.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Save the excel file.
excelbook.Save("d:\test\tstarcs.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ArcShape Members | Aspose.Cells.Drawing Namespace


ArcShape Members

ArcShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
BeginArrowheadLength | Obsolete. Gets and sets the begin arrow head length of the line.
BeginArrowheadStyle | Obsolete. Gets and sets the begin arrow head style of the line.
BeginArrowheadWidth | Obsolete. Gets and sets the begin arrow head width of the line.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
EndArrowheadLength | Obsolete. Gets and sets the end arrow head length of the line.
EndArrowheadStyle | Obsolete. Gets and sets the end arrow head style of the line.
EndArrowheadWidth | Obsolete. Gets and sets the end arrow head width of the line.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


ArcShape Properties

The properties of the ArcShape class are listed below. For a complete list of ArcShape class members, see the ArcShape Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
BeginArrowheadLength | Obsolete. Gets and sets the begin arrow head length of the line.
BeginArrowheadStyle | Obsolete. Gets and sets the begin arrow head style of the line.
BeginArrowheadWidth | Obsolete. Gets and sets the begin arrow head width of the line.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
EndArrowheadLength | Obsolete. Gets and sets the end arrow head length of the line.
EndArrowheadStyle | Obsolete. Gets and sets the end arrow head style of the line.
EndArrowheadWidth | Obsolete. Gets and sets the end arrow head width of the line.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


BeginArrowheadLength Property

Aspose.Cells for .NET

ArcShape.BeginArrowheadLength Property

NOTE: This property is now obsolete.

Use Shape.Line.BeginArrowheadLength property instead.

Gets and sets the begin arrow head length of the line.

public MsoArrowheadLength BeginArrowheadLength {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.BeginArrowheadLength property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


BeginArrowheadStyle Property

Aspose.Cells for .NET

ArcShape.BeginArrowheadStyle Property

NOTE: This property is now obsolete.

Use Shape.Line.BeginArrowheadStyle property instead.

Gets and sets the begin arrow head style of the line.

public MsoArrowheadStyle BeginArrowheadStyle {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.BeginArrowheadStyle property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


BeginArrowheadWidth Property

Aspose.Cells for .NET

ArcShape.BeginArrowheadWidth Property

NOTE: This property is now obsolete.

Use Shape.Line.BeginArrowheadWidth property instead.

Gets and sets the begin arrow head width of the line.

public MsoArrowheadWidth BeginArrowheadWidth {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.BeginArrowheadWidth property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


EndArrowheadLength Property

Aspose.Cells for .NET

ArcShape.EndArrowheadLength Property

NOTE: This property is now obsolete.

Use Shape.Line.EndArrowheadLength property instead.

Gets and sets the end arrow head length of the line.

public MsoArrowheadLength EndArrowheadLength {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.EndArrowheadLength property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


EndArrowheadStyle Property

Aspose.Cells for .NET

ArcShape.EndArrowheadStyle Property

NOTE: This property is now obsolete.

Use Shape.Line.EndArrowheadStyle property instead.

Gets and sets the end arrow head style of the line.

public MsoArrowheadStyle EndArrowheadStyle {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.EndArrowheadStyle property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


EndArrowheadWidth Property

Aspose.Cells for .NET

ArcShape.EndArrowheadWidth Property

NOTE: This property is now obsolete.

Use Shape.Line.EndArrowheadWidth property instead.

Gets and sets the end arrow head width of the line.

public MsoArrowheadWidth EndArrowheadWidth {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.EndArrowheadWidth property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

ArcShape Class | Aspose.Cells.Drawing Namespace


Area Class

Encapsulates the object that represents an area format.

For a list of all members of this type, see Area Members.

System.Object
Aspose.Cells.Drawing.Area
Aspose.Cells.Charts.Floor

public class Area

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Workbook object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);
//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);
//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", true);
//Setting the foreground color of the plot area
chart.PlotArea.Area.ForegroundColor = Color.Blue;
//Setting the foreground color of the chart area
chart.ChartArea.Area.ForegroundColor = Color.Yellow;
//Setting the foreground color of the 1st NSeries area
chart.NSeries[0].Area.ForegroundColor = Color.Red;
//Setting the foreground color of the area of the 1st NSeries point
chart.NSeries[0].Points[0].Area.ForegroundColor = Color.Cyan;
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Workbook object
Dim sheetIndex As Integer = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)
'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)
'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)
'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", True)
'Setting the foreground color of the plot area
chart.PlotArea.Area.ForegroundColor = Color.Blue
'Setting the foreground color of the chart area
chart.ChartArea.Area.ForegroundColor = Color.Yellow
'Setting the foreground color of the 1st NSeries area
chart.NSeries(0).Area.ForegroundColor = Color.Red
'Setting the foreground color of the area of the 1st NSeries point
chart.NSeries(0).Points(0).Area.ForegroundColor = Color.Cyan
'Saving the Excel file
workbook.Save("C:\book1.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Area Members | Aspose.Cells.Drawing Namespace


Area Members

Area overview

Public Instance Properties

BackgroundColor | Gets or sets the background Color of the Area.
FillFormat | Represents a object that contains fill formatting properties for the specified chart or shape.
ForegroundColor | Gets or sets the foreground Color.
Formatting | Represents the formatting of the area.
InvertIfNegative | If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Area Class | Aspose.Cells.Drawing Namespace


Area Properties

The properties of the Area class are listed below. For a complete list of Area class members, see the Area Members topic.

Public Instance Properties

BackgroundColor | Gets or sets the background Color of the Area.
FillFormat | Represents a object that contains fill formatting properties for the specified chart or shape.
ForegroundColor | Gets or sets the foreground Color.
Formatting | Represents the formatting of the area.
InvertIfNegative | If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

See Also

Area Class | Aspose.Cells.Drawing Namespace


BackgroundColor Property

Aspose.Cells for .NET

Area.BackgroundColor Property

Gets or sets the background Color of the Area.

public Color BackgroundColor {get; set;}

See Also

Area Class | Aspose.Cells.Drawing Namespace


FillFormat Property

Aspose.Cells for .NET

Area.FillFormat Property

Represents a object that contains fill formatting properties for the specified chart or shape.

public FillFormat FillFormat {get;}

See Also

Area Class | Aspose.Cells.Drawing Namespace | FillFormat


ForegroundColor Property

Aspose.Cells for .NET

Area.ForegroundColor Property

Gets or sets the foreground Color.

public Color ForegroundColor {get; set;}

See Also

Area Class | Aspose.Cells.Drawing Namespace


Formatting Property

Aspose.Cells for .NET

Area.Formatting Property

Represents the formatting of the area.

public FormattingType Formatting {get; set;}

See Also

Area Class | Aspose.Cells.Drawing Namespace


InvertIfNegative Property

Aspose.Cells for .NET

Area.InvertIfNegative Property

If the property is true and the value of chart point is a negative number, the foreground color and background color will be exchanged.

public bool InvertIfNegative {get; set;}

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Workbook object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);
//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(-100);
//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);
//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5);
//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];
//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "A3"
chart.NSeries.Add("A1:A3", true);
chart.NSeries[0].Area.InvertIfNegative = true;
//Setting the foreground color of the 1st NSeries area
chart.NSeries[0].Area.ForegroundColor = Color.Red;
//Setting the background color of the 1st NSeries area.
//The displayed area color of second chart point will be the background color.
chart.NSeries[0].Area.BackgroundColor = Color.Yellow;
//Saving the Excel file
workbook.Save("C:\\book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Workbook object
Dim sheetIndex As Integer = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)
'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(-100)
'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)
'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.Column, 5, 0, 15, 5)
'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)
'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "A3"
chart.NSeries.Add("A1:A3", True)
chart.NSeries(0).Area.InvertIfNegative = True
'Setting the foreground color of the 1st NSeries area
chart.NSeries(0).Area.ForegroundColor = Color.Red
'Setting the background color of the 1st NSeries area.
'The displayed area color of second chart point will be the background color.
chart.NSeries(0).Area.BackgroundColor = Color.Yellow
'Saving the Excel file
workbook.Save("C:\book1.xls")

See Also

Area Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

Area.Transparency Property

Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

Area Class | Aspose.Cells.Drawing Namespace


AutomaticFill Class

represents automatic fill.

For a list of all members of this type, see AutomaticFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.AutomaticFill

public class AutomaticFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AutomaticFill Members | Aspose.Cells.Drawing Namespace


AutomaticFill Members

AutomaticFill overview

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

AutomaticFill Class | Aspose.Cells.Drawing Namespace


AutoShapeType Enumeration

Represents all built-in auto shape type.

public enum AutoShapeType

Members

Member Name | Description | Value
NotPrimitive |  | 0
Rectangle |  | 1
RoundedRectangle |  | 2
Oval |  | 3
Diamond |  | 4
IsoscelesTriangle |  | 5
RightTriangle |  | 6
Parallelogram |  | 7
Trapezoid |  | 8
Hexagon |  | 9
Octagon |  | 10
Cross |  | 11
Star5 |  | 12
RightArrow |  | 13
HomePlate |  | 15
Cube |  | 16
Balloon |  | 17
Seal |  | 18
Arc |  | 19
Line |  | 20
Plaque |  | 21
Can |  | 22
Donut |  | 23
TextSimple |  | 24
TextOctagon |  | 25
TextHexagon |  | 26
TextCurve |  | 27
TextWave |  | 28
TextRing |  | 29
TextOnCurve |  | 30
msosptTextOnRing |  | 31
StraightConnector |  | 32
BentConnector2 |  | 33
ElbowConnector |  | 34
BentConnector4 |  | 35
BentConnector5 |  | 36
CurvedConnector2 |  | 37
CurvedConnector |  | 38
CurvedConnector4 |  | 39
CurvedConnector5 |  | 40
LineCalloutNoBorder2 |  | 41
LineCalloutNoBorder3 |  | 42
LineCalloutNoBorder4 |  | 43
LineCalloutWithAccentBar2 |  | 44
LineCalloutWithAccentBar3 |  | 45
LineCalloutWithAccentBar4 |  | 46
LineCalloutWithBorder2 |  | 47
LineCalloutWithBorder3 |  | 48
LineCalloutWithBorder4 |  | 49
LineCalloutWithBorderAndAccentBar2 |  | 50
LineCalloutWithBorderAndAccentBar3 |  | 51
LineCalloutWithBorderAndAccentBar4 |  | 52
DownRibbon |  | 53
UpRibbon |  | 54
Chevron |  | 55
RegularPentagon |  | 56
NoSymbol |  | 57
Star8 |  | 58
Star16 |  | 59
Star32 |  | 60
RectangularCallout |  | 61
RoundedRectangularCallout |  | 62
OvalCallout |  | 63
Wave |  | 64
FoldedCorner |  | 65
LeftArrow |  | 66
DownArrow |  | 67
UpArrow |  | 68
LeftRightArrow |  | 69
UpDownArrow |  | 70
Explosion1 |  | 71
Explosion2 |  | 72
LightningBolt |  | 73
Heart |  | 74
PictureFrame |  | 75
QuadArrow |  | 76
LeftArrowCallout |  | 77
RightArrowCallout |  | 78
UpArrowCallout |  | 79
DownArrowCallout |  | 80
LeftRightArrowCallout |  | 81
UpDownArrowCallout |  | 82
QuadArrowCallout |  | 83
Bevel |  | 84
LeftBracket |  | 85
RightBracket |  | 86
LeftBrace |  | 87
RightBrace |  | 88
LeftUpArrow |  | 89
BentUpArrow |  | 90
BentArrow |  | 91
Star24 |  | 92
StripedRightArrow |  | 93
NotchedRightArrow |  | 94
BlockArc |  | 95
SmileyFace |  | 96
VerticalScroll |  | 97
HorizontalScroll |  | 98
CircularArrow |  | 99
NotchedCircularArrow | A value that SHOULD NOT be used. | 100
UTurnArrow |  | 101
CurvedRightArrow |  | 102
CurvedLeftArrow |  | 103
CurvedUpArrow |  | 104
CurvedDownArrow |  | 105
CloudCallout |  | 106
CurvedDownRibbon |  | 107
CurvedUpRibbon |  | 108
FlowChartProcess |  | 109
FlowChartDecision |  | 110
FlowChartData |  | 111
FlowChartPredefinedProcess |  | 112
FlowChartInternalStorage |  | 113
FlowChartDocument |  | 114
FlowChartMultidocument |  | 115
FlowChartTerminator |  | 116
FlowChartPreparation |  | 117
FlowChartManualInput |  | 118
FlowChartManualOperation |  | 119
FlowChartConnector |  | 120
FlowChartCard |  | 121
FlowChartPunchedTape |  | 122
FlowChartSummingJunction |  | 123
FlowChartOr |  | 124
FlowChartCollate |  | 125
FlowChartSort |  | 126
FlowChartExtract |  | 127
FlowChartMerge |  | 128
FlowChartOfflineStorage |  | 129
FlowChartStoredData |  | 130
FlowChartSequentialAccessStorage |  | 131
FlowChartMagneticDisk |  | 132
FlowChartDirectAccessStorage |  | 133
FlowChartDisplay |  | 134
FlowChartDelay |  | 135
TextPlainText | A plain text shape. | 136
TextStop | An octagonal text shape. | 137
TextTriangle | A triangular text shape pointing upwards. | 138
TextTriangleInverted | A triangular text shape pointing downwards. | 139
TextChevron | A chevron text shape pointing upwards. | 140
TextChevronInverted | A chevron text shape pointing downwards. | 141
TextRingInside | A circular text shape, as if reading an inscription on the inside of a ring. | 142
TextRingOutside | A circular text shape, as if reading an inscription on the outside of a ring. | 143
TextArchUpCurve | An upward arching curved text shape. | 144
TextArchDownCurve | A downward arching curved text shape. | 145
TextCircleCurve | A circular text shape. | 146
TextButtonCurve | A text shape that resembles a button. | 147
TextArchUpPour | An upward arching text shape. | 148
TextArchDownPour | A downward arching text shape. | 149
TextCirclePour | A circular text shape. | 150
TextButtonPour | A text shape that resembles a button. | 151
TextCurveUp | An upward curving text shape. | 152
TextCurveDown | A downward curving text shape. | 153
TextCascadeUp | A cascading text shape pointed upwards. | 154
TextCascadeDown | A cascading text shape pointed downwards. | 155
TextWave1 | A wavy text shape. | 156
TextWave2 | A wavy text shape. | 157
TextWave3 | Obsolete. UseAutoShape.TextDoubleWave1. A wavy text shape. | 158
TextWave4 | Obsolete. UseAutoShape.TextDoubleWave2. A wavy text shape. | 159
TextDoubleWave1 | A wavy text shape. | 158
TextDoubleWave2 | A wavy text shape. | 159
TextInflate | A text shape that expands vertically in the middle. | 160
TextDeflate | A text shape that shrinks vertically in the middle. | 161
TextInflateBottom | A text shape that expands downward in the middle. | 162
TextDeflateBottom | A text shape that shrinks upwards in the middle. | 163
TextInflateTop | A text shape that expands upward in the middle. | 164
TextDeflateTop | A text shape that shrinks downward in the middle. | 165
TextDeflateInflate | A text shape where lower lines expand upward. Upper lines shrink to compensate. | 166
TextDeflateInflateDeflate | A text shape where lines in the center expand vertically. Upper and lower lines shrink to compensate. | 167
TextFadeRight | A text shape that shrinks vertically on the right side. | 168
TextFadeLeft | A text shape that shrinks vertically on the left side. | 169
TextFadeUp | A text shape that shrinks horizontally on top. | 170
TextFadeDown | A text shape that shrinks horizontally on bottom. | 171
TextSlantUp | An upward slanted text shape. | 172
TextSlantDown | A downward slanted text shape. | 173
TextCanUp | A text shape that is curved upwards as if being read on the side of a can. | 174
TextCanDown | A text shape that is curved downwards as if being read on the side of a can. | 175
FlowChartAlternateProcess |  | 176
FlowChartOffpageConnector |  | 177
LineCalloutNoBorder1 |  | 178
LineCalloutWithAccentBar1 |  | 179
LineCalloutWithBorder1 |  | 180
LineCalloutWithBorderAndAccentBar1 |  | 181
LeftRightUpArrow |  | 182
Sun |  | 183
Moon |  | 184
DoubleBracket | A shape enclosed in brackets. | 185
DoubleBrace | A shape enclosed in braces. | 186
Star4 |  | 187
DoubleWave |  | 188
BlankActionButton |  | 189
HomeActionButton |  | 190
HelpActionButton |  | 191
InformationActionButton |  | 192
ForwardNextActionButton |  | 193
BackPreviousActionButton |  | 194
EndActionButton |  | 195
BeginningActionButton |  | 196
ReturnActionButton |  | 197
DocumentActionButton |  | 198
SoundActionButton |  | 199
MovieActionButton |  | 200
HostControl | This value SHOULD NOT be used. | 201
TextBox |  | 202
Heptagon |  | 2049
Decagon |  | 2050
Dodecagon |  | 2051
Star6 |  | 2052
Star7 |  | 2053
Star10 |  | 2054
Star12 |  | 2055
RoundSingleCornerRectangle |  | 2056
RoundSameSideCornerRectangle |  | 2057
RoundDiagonalCornerRectangle |  | 2058
SnipRoundSingleCornerRectangle |  | 2059
SnipSingleCornerRectangle |  | 2060
SnipSameSideCornerRectangle |  | 2061
SnipDiagonalCornerRectangle |  | 2062
Teardrop |  | 2063
Pie |  | 2064
HalfFrame |  | 2066
L_Shape |  | 2067
DiagonalStripe |  | 2068
Chord |  | 2069
Cloud |  | 2070
MathPlus |  | 2071
MathMinus |  | 2072
MathMultiply |  | 2073
MathDivide |  | 2074
MathEqual |  | 2075
MathNotEqual |  | 2076
LineInv |  | 2077
NonIsoscelesTrapezoid |  | 2078
PieWedge |  | 2079
LeftCircularArrow |  | 2080
LeftRightCircularArrow |  | 2081
SwooshArrow |  | 2082
LeftRightRibbon |  | 2083
TextNoShape |  | 2084
Gear6 |  | 2097
Gear9 |  | 2098
Funnel |  | 2099
CornerTabs |  | 2100
SquareTabs |  | 2101
PlaqueTabs |  | 2102
ChartX |  | 2103
ChartStar |  | 2104
ChartPlus |  | 2105
Frame |  | 2106
Model3D |  | 2107
RoundCallout | There is no such type in Excel | 2108
TextArchLeftPour | There is no such type in Excel | 2109
TextArchRightPour | There is no such type in Excel | 2110
TextArchLeftCurve | There is no such type in Excel | 2111
TextArchRightCurve | There is no such type in Excel | 2112
Unknown |  | 4095

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Bevel Class

Represents a bevel of a shape

For a list of all members of this type, see Bevel Members.

System.Object
Aspose.Cells.Drawing.Bevel

public class Bevel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Bevel Members | Aspose.Cells.Drawing Namespace


Bevel Members

Bevel overview

Public Instance Properties

Height | Gets and sets the height of the bevel, or how far above the shape it is applied. In unit of Points.
Type | Gets and sets the preset bevel type.
Width | Gets and sets the width of the bevel, or how far into the shape it is applied. In unit of Points.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Bevel Class | Aspose.Cells.Drawing Namespace


Bevel Properties

The properties of the Bevel class are listed below. For a complete list of Bevel class members, see the Bevel Members topic.

Public Instance Properties

Height | Gets and sets the height of the bevel, or how far above the shape it is applied. In unit of Points.
Type | Gets and sets the preset bevel type.
Width | Gets and sets the width of the bevel, or how far into the shape it is applied. In unit of Points.

See Also

Bevel Class | Aspose.Cells.Drawing Namespace


Height Property

Aspose.Cells for .NET

Bevel.Height Property

Gets and sets the height of the bevel, or how far above the shape it is applied. In unit of Points.

public double Height {get; set;}

See Also

Bevel Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

Bevel.Type Property

Gets and sets the preset bevel type.

public BevelPresetType Type {get; set;}

See Also

Bevel Class | Aspose.Cells.Drawing Namespace


Width Property

Aspose.Cells for .NET

Bevel.Width Property

Gets and sets the width of the bevel, or how far into the shape it is applied. In unit of Points.

public double Width {get; set;}

See Also

Bevel Class | Aspose.Cells.Drawing Namespace


BevelPresetType Enumeration

Represents a preset for a type of bevel which can be applied to a shape in 3D.

public enum BevelPresetType

Members

Member Name | Description | Value
None | No bevel | 0
Angle | Angle | 1
ArtDeco | Art deco | 2
Circle | Circle | 3
Convex | Convex | 4
CoolSlant | Cool slant | 5
Cross | Cross | 6
Divot | Divot | 7
HardEdge | Hard edge | 8
RelaxedInset | Relaxed inset | 9
Riblet | Riblet | 10
Slope | Slope | 11
SoftRound | Soft round | 12

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


BevelType Enumeration

Represents a preset for a type of bevel which can be applied to a shape in 3D.

public enum BevelType

Members

Member Name | Description | Value
None | No bevel | 0
Angle | Angle | 1
ArtDeco | Art deco | 2
Circle | Circle | 3
Convex | Convex | 4
CoolSlant | Cool slant | 5
Cross | Cross | 6
Divot | Divot | 7
HardEdge | Hard edge | 8
RelaxedInset | Relaxed inset | 9
Riblet | Riblet | 10
Slope | Slope | 11
SoftRound | Soft round | 12

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Button Class

Represents the Forms control: Button

For a list of all members of this type, see Button Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.Button

public class Button : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Create a new Workbook.
 Workbook workbook = new Workbook();

 //Get the first worksheet in the workbook.
 Worksheet sheet = workbook.Worksheets[0];

 //Add a new button to the worksheet.
 Aspose.Cells.Button button = sheet.Shapes.AddButton(2, 0, 2, 0, 28, 80);

 //Set the caption of the button.
 button.Text = "Aspose";

 //Set the Placement Type, the way the
 //button is attached to the cells.
 button.Placement = PlacementType.FreeFloating;

 //Set the font name.
 button.Font.Name = "Tahoma";

 //Set the caption string bold.
 button.Font.IsBold = true;

 //Set the color to blue.
 button.Font.Color = Color.Blue;

 //Set the hyperlink for the button.
 button.AddHyperlink("http://www.aspose.com/");

 //Saves the file.
 workbook.Save(@"d:\test\tstbutton.xls");

 [VB.NET]

 'Create a new Workbook.
 Dim workbook As Workbook = New Workbook()

 'Get the first worksheet in the workbook.
 Dim sheet As Worksheet = workbook.Worksheets(0)

 'Add a new button to the worksheet.
 Dim button As Aspose.Cells.Button = sheet.Shapes.AddButton(2, 0, 2, 0, 28, 80)

 'Set the caption of the button.
 button.Text = "Aspose"

 'Set the Placement Type, the way the
 'button is attached to the cells.
 button.Placement = PlacementType.FreeFloating

 'Set the font name.
 button.Font.Name = "Tahoma"

 'Set the caption string bold.
 button.Font.IsBold = True

 'Set the color to blue.
 button.Font.Color = Color.Blue

 'Set the hyperlink for the button.
 button.AddHyperlink("http://www.aspose.com/")

 'Saves the file.
 workbook.Save("d:\test\tstbutton.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Button Members | Aspose.Cells.Drawing Namespace


Button Members

Button overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

Button Class | Aspose.Cells.Drawing Namespace


CellsDrawing Class

Represents the auto shape and drawing object.

For a list of all members of this type, see CellsDrawing Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.CellsDrawing

public class CellsDrawing : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CellsDrawing Members | Aspose.Cells.Drawing Namespace


CellsDrawing Members

CellsDrawing overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

CellsDrawing Class | Aspose.Cells.Drawing Namespace


ChartShape Class

Represents the shape of the chart. Properties and methods for the ChartObject object control the appearance and size of the embedded chart on the worksheet.

For a list of all members of this type, see ChartShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.ChartShape

public class ChartShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();

//Obtaining the reference of the first worksheet
Worksheet worksheet = workbook.Worksheets[0];

//Adding a sample value to "A1" cell
worksheet.Cells["A1"].PutValue(50);

//Adding a sample value to "A2" cell
worksheet.Cells["A2"].PutValue(100);

//Adding a sample value to "A3" cell
worksheet.Cells["A3"].PutValue(150);

//Adding a sample value to "B1" cell
worksheet.Cells["B1"].PutValue(60);

//Adding a sample value to "B2" cell
worksheet.Cells["B2"].PutValue(32);

//Adding a sample value to "B3" cell
worksheet.Cells["B3"].PutValue(50);

//Adding a chart to the worksheet
int chartIndex = worksheet.Charts.Add(ChartType.PieExploded, 5, 0, 25, 10);

//Accessing the instance of the newly added chart
Chart chart = worksheet.Charts[chartIndex];

//Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", true);

//Show Data Labels
chart.NSeries[0].DataLabels.IsValueShown = true;

//Getting Chart Shape
ChartShape chartShape = chart.ChartObject;

//Set Lower Right Column
chartShape.LowerRightColumn = 10;

//Set LowerDeltaX
chartShape.LowerDeltaX = 1024;

//Saving the Excel file
workbook.Save("D:\\book1.xls");

[VB.NET]

'Instantiating a Workbook object
Dim workbook As New Workbook()

'Obtaining the reference of the first worksheet
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Adding a sample value to "A1" cell
worksheet.Cells("A1").PutValue(50)

'Adding a sample value to "A2" cell
worksheet.Cells("A2").PutValue(100)

'Adding a sample value to "A3" cell
worksheet.Cells("A3").PutValue(150)

'Adding a sample value to "B1" cell
worksheet.Cells("B1").PutValue(60)

'Adding a sample value to "B2" cell
worksheet.Cells("B2").PutValue(32)

'Adding a sample value to "B3" cell
worksheet.Cells("B3").PutValue(50)

'Adding a chart to the worksheet
Dim chartIndex As Integer = worksheet.Charts.Add(ChartType.PieExploded, 5, 0, 25, 10)

'Accessing the instance of the newly added chart
Dim chart As Chart = worksheet.Charts(chartIndex)

'Adding NSeries (chart data source) to the chart ranging from "A1" cell to "B3"
chart.NSeries.Add("A1:B3", True)

'Show Data Labels
chart.NSeries(0).DataLabels.IsValueShown = True

'Getting Chart Shape
Dim chartShape As ChartShape = chart.ChartObject

'Set Lower Right Column
chartShape.LowerRightColumn = 10

'Set LowerDeltaX
chartShape.LowerDeltaX = 1024

'Saving the Excel file
workbook.Save("D:\book1.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ChartShape Members | Aspose.Cells.Drawing Namespace


ChartShape Members

ChartShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
Chart | Returns a Chart object that represents the chart contained in the object.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

ChartShape Class | Aspose.Cells.Drawing Namespace


ChartShape Properties

The properties of the ChartShape class are listed below. For a complete list of ChartShape class members, see the ChartShape Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
Chart | Returns a Chart object that represents the chart contained in the object.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

ChartShape Class | Aspose.Cells.Drawing Namespace


Chart Property

Aspose.Cells for .NET

ChartShape.Chart Property

Returns a Chart object that represents the chart contained in the object.

public Chart Chart {get;}

See Also

ChartShape Class | Aspose.Cells.Drawing Namespace


CheckBox Class

Represents a check box object in a worksheet.

For a list of all members of this type, see CheckBox Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.CheckBox

public class CheckBox : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

int index = excel.Worksheets[0].CheckBoxes.Add(15, 15, 20, 100);
CheckBox checkBox = excel.Worksheets[0].CheckBoxes[index];
checkBox.Text = "Check Box 1";

[Visual Basic]

Dim index as integer = excel.Worksheets(0).CheckBoxes.Add(15, 15, 20, 100)
Dim checkBox as CheckBox = excel.Worksheets(0).CheckBoxes[index];
checkBox.Text = "Check Box 1"

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CheckBox Members | Aspose.Cells.Drawing Namespace


CheckBox Members

CheckBox overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
CheckedValue | Gets or set checkbox' value.
CheckValue | Obsolete. Gets or set checkbox' value.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Value | Indicates if the checkbox is checked or not.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

CheckBox Class | Aspose.Cells.Drawing Namespace


CheckBox Properties

The properties of the CheckBox class are listed below. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
CheckedValue | Gets or set checkbox' value.
CheckValue | Obsolete. Gets or set checkbox' value.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Value | Indicates if the checkbox is checked or not.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

CheckBox Class | Aspose.Cells.Drawing Namespace


CheckedValue Property

Aspose.Cells for .NET

CheckBox.CheckedValue Property

Gets or set checkbox' value.

public CheckValueType CheckedValue {get; set;}

See Also

CheckBox Class | Aspose.Cells.Drawing Namespace


CheckValue Property

Aspose.Cells for .NET

CheckBox.CheckValue Property

NOTE: This property is now obsolete.

Use CheckBox.CheckValueType property instead.

Gets or set checkbox' value.

public CheckValueType CheckValue {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use CheckBox.CheckValueType property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

CheckBox Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

CheckBox.Shadow Property

Indicates whether the combobox has 3-D shading.

public bool Shadow {get; set;}

See Also

CheckBox Class | Aspose.Cells.Drawing Namespace


Value Property

Aspose.Cells for .NET

CheckBox.Value Property

Indicates if the checkbox is checked or not.

public bool Value {get; set;}

See Also

CheckBox Class | Aspose.Cells.Drawing Namespace


CheckBoxCollection Class

Represents a collection of CheckBox objects in a worksheet.

For a list of all members of this type, see CheckBoxCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.CheckBoxCollection

public class CheckBoxCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

int index = excel.Worksheets[0].CheckBoxes.Add(15, 15, 20, 100);
CheckBox checkBox = excel.Worksheets[0].CheckBoxes[index];
checkBox.Text = "Check Box 1";

[Visual Basic]

Dim index as integer = excel.Worksheets(0).CheckBoxes.Add(15, 15, 20, 100)
Dim checkBox as CheckBox = excel.Worksheets(0).CheckBoxes[index];
checkBox.Text = "Check Box 1"

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CheckBoxCollection Members | Aspose.Cells.Drawing Namespace


CheckBoxCollection Members

CheckBoxCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the CheckBox element at the specified index.

Public Instance Methods

Add | Adds a checkBox to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CheckBoxCollection Class | Aspose.Cells.Drawing Namespace


CheckBoxCollection Properties

The properties of the CheckBoxCollection class are listed below. For a complete list of CheckBoxCollection class members, see the CheckBoxCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the CheckBox element at the specified index.

See Also

CheckBoxCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

CheckBoxCollection.Item Property

Gets the CheckBox element at the specified index.

public CheckBox this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

CheckBoxCollection Class | Aspose.Cells.Drawing Namespace


CheckBoxCollection Methods

The methods of the CheckBoxCollection class are listed below. For a complete list of CheckBoxCollection class members, see the CheckBoxCollection Members topic.

Public Instance Methods

Add | Adds a checkBox to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CheckBoxCollection Class | Aspose.Cells.Drawing Namespace


CheckBoxCollection.Add Method

Adds a checkBox to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
height
Height of checkBox, in unit of pixel.
width
Width of checkBox, in unit of pixel.

Return Value

CheckBox object index.

See Also

CheckBoxCollection Class | Aspose.Cells.Drawing Namespace


CheckValueType Enumeration

Represents the check value type of the check box.

public enum CheckValueType

Members

Member Name | Description | Value
UnChecked | UnChecked | 0
Checked | Checked | 1
Mixed | Mixed | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ColorHelper Class

Provides helper functions about color.

For a list of all members of this type, see ColorHelper Members.

System.Object
Aspose.Cells.Drawing.ColorHelper

public class ColorHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ColorHelper Members | Aspose.Cells.Drawing Namespace


ColorHelper Members

ColorHelper overview

Public Static Methods

FromOleColor | Convert OLE_COLOR.
ToOleColor | Convert color to OLE_COLOR

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ColorHelper Class | Aspose.Cells.Drawing Namespace


ColorHelper Methods

The methods of the ColorHelper class are listed below. For a complete list of ColorHelper class members, see the ColorHelper Members topic.

Public Static Methods

FromOleColor | Convert OLE_COLOR.
ToOleColor | Convert color to OLE_COLOR

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ColorHelper Class | Aspose.Cells.Drawing Namespace


ColorHelper.FromOleColor Method

Convert OLE_COLOR.

public static Color FromOleColor(
int oleColor
);

Parameters

oleColor
The value of OLE_COLOR.

Return Value

The Color object.

See Also

ColorHelper Class | Aspose.Cells.Drawing Namespace


ColorHelper.ToOleColor Method

Convert color to OLE_COLOR

public static int ToOleColor(
Color color,
Workbook workbook
);

Parameters

color
The Color object.
workbook

Return Value

The value of OLE_COLOR

See Also

ColorHelper Class | Aspose.Cells.Drawing Namespace


ComboBox Class

Represents the control form ComboBox.

For a list of all members of this type, see ComboBox Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.ComboBox

public class ComboBox : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Create a new Workbook.
Workbook workbook = new Workbook();

//Get the first worksheet.
Worksheet sheet = workbook.Worksheets[0];

//Get the worksheet cells collection.
Cells cells = sheet.Cells;

//Input a value.
cells["B3"].PutValue("Employee:");

//Set it bold.
cells["B3"].Style.Font.IsBold = true;

//Input some values that denote the input range
//for the combo box.
cells["A2"].PutValue("Emp001");
cells["A3"].PutValue("Emp002");
cells["A4"].PutValue("Emp003");
cells["A5"].PutValue("Emp004");
cells["A6"].PutValue("Emp005");
cells["A7"].PutValue("Emp006");

//Add a new combo box.
Aspose.Cells.ComboBox comboBox = sheet.Shapes.AddComboBox(2, 0, 2, 0, 22, 100);

//Set the linked cell;
comboBox.LinkedCell = "A1";

//Set the input range.
comboBox.InputRange = "A2:A7";

//Set no. of list lines displayed in the combo
//box's list portion.
comboBox.DropDownLines = 5;

//Set the combo box with 3-D shading.
comboBox.Shadow = true;

//AutoFit Columns
sheet.AutoFitColumns();

//Saves the file.
workbook.Save(@"d:\test\tstcombobox.xls");

[VB.NET]

'Create a new Workbook.
Dim workbook As Workbook = New Workbook()

'Get the first worksheet.
Dim sheet As Worksheet = workbook.Worksheets(0)

'Get the worksheet cells collection.
Dim cells As Cells = sheet.Cells

'Input a value.
cells("B3").PutValue("Employee:")

'Set it bold.
cells("B3").Style.Font.IsBold = True

'Input some values that denote the input range
'for the combo box.
cells("A2").PutValue("Emp001")
cells("A3").PutValue("Emp002")
cells("A4").PutValue("Emp003")
cells("A5").PutValue("Emp004")
cells("A6").PutValue("Emp005")
cells("A7").PutValue("Emp006")

'Add a new combo box.
Dim comboBox As Aspose.Cells.ComboBox = sheet.Shapes.AddComboBox(2, 0, 2, 0, 22, 100)

'Set the linked cell;
comboBox.LinkedCell = "A1"

'Set the input range.
comboBox.InputRange = "A2:A7"

'Set no. of list lines displayed in the combo
'box's list portion.
comboBox.DropDownLines = 5

'Set the combo box with 3-D shading.
comboBox.Shadow = True

'AutoFit Columns
sheet.AutoFitColumns()

'Saves the file.
workbook.Save("d:\test\tstcombobox.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ComboBox Members | Aspose.Cells.Drawing Namespace


ComboBox Members

ComboBox overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
DropDownLines | Gets or sets the number of list lines displayed in the drop-down portion of a combo box.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
SelectedCell | Gets the selected cell in the input range of the combo box.
SelectedIndex | Gets or sets the index number of the currently selected item in a list box or combo box. Zero-based.
SelectedValue | Gets the selected value of the combox box.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


ComboBox Properties

The properties of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
DropDownLines | Gets or sets the number of list lines displayed in the drop-down portion of a combo box.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
SelectedCell | Gets the selected cell in the input range of the combo box.
SelectedIndex | Gets or sets the index number of the currently selected item in a list box or combo box. Zero-based.
SelectedValue | Gets the selected value of the combox box.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


DropDownLines Property

Aspose.Cells for .NET

ComboBox.DropDownLines Property

Gets or sets the number of list lines displayed in the drop-down portion of a combo box.

public int DropDownLines {get; set;}

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


SelectedCell Property

Aspose.Cells for .NET

ComboBox.SelectedCell Property

Gets the selected cell in the input range of the combo box.

public Cell SelectedCell {get;}

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


SelectedIndex Property

Aspose.Cells for .NET

ComboBox.SelectedIndex Property

Gets or sets the index number of the currently selected item in a list box or combo box. Zero-based.

public int SelectedIndex {get; set;}

Remarks

-1 presents no item is selected.

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


SelectedValue Property

Aspose.Cells for .NET

ComboBox.SelectedValue Property

Gets the selected value of the combox box.

public string SelectedValue {get;}

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

ComboBox.Shadow Property

Indicates whether the combobox has 3-D shading.

public bool Shadow {get; set;}

See Also

ComboBox Class | Aspose.Cells.Drawing Namespace


CommentShape Class

Represents the shape of the comment.

For a list of all members of this type, see CommentShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.CommentShape

public class CommentShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CommentShape Members | Aspose.Cells.Drawing Namespace


CommentShape Members

CommentShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
Comment | Gets the comment object.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

CommentShape Class | Aspose.Cells.Drawing Namespace


CommentShape Properties

The properties of the CommentShape class are listed below. For a complete list of CommentShape class members, see the CommentShape Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
Comment | Gets the comment object.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

CommentShape Class | Aspose.Cells.Drawing Namespace


Comment Property

Aspose.Cells for .NET

CommentShape.Comment Property

Gets the comment object.

public Comment Comment {get;}

See Also

CommentShape Class | Aspose.Cells.Drawing Namespace


CustomGeometry Class

Represents a custom geometric shape.

For a list of all members of this type, see CustomGeometry Members.

System.Object
Aspose.Cells.Drawing.Geometry
Aspose.Cells.Drawing.CustomGeometry

public class CustomGeometry : Geometry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomGeometry Members | Aspose.Cells.Drawing Namespace


CustomGeometry Members

CustomGeometry overview

Public Instance Properties

Paths | Gets path collection information when shape is a NotPrimitive autoshape
ShapeAdjustValues (inherited from Geometry) | Gets a collection of shape adjust value

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CustomGeometry Class | Aspose.Cells.Drawing Namespace


CustomGeometry Properties

The properties of the CustomGeometry class are listed below. For a complete list of CustomGeometry class members, see the CustomGeometry Members topic.

Public Instance Properties

Paths | Gets path collection information when shape is a NotPrimitive autoshape
ShapeAdjustValues (inherited from Geometry) | Gets a collection of shape adjust value

See Also

CustomGeometry Class | Aspose.Cells.Drawing Namespace


Paths Property

Aspose.Cells for .NET

CustomGeometry.Paths Property

Gets path collection information when shape is a NotPrimitive autoshape

public ShapePathCollection Paths {get;}

See Also

CustomGeometry Class | Aspose.Cells.Drawing Namespace


CustomXmlShape Class

Represents Custom xml shape ,such as Ink.

For a list of all members of this type, see CustomXmlShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.CustomXmlShape

public class CustomXmlShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomXmlShape Members | Aspose.Cells.Drawing Namespace


CustomXmlShape Members

CustomXmlShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

CustomXmlShape Class | Aspose.Cells.Drawing Namespace


DataLabelShapeType Enumeration

Specifies the preset shape geometry that is to be used for a chart.

public enum DataLabelShapeType

Members

Member Name | Description | Value
Rect | Represents the rectangle shape. | 0
RoundRect | Represents the round rectangle shape. | 1
Ellipse | Represents the ellipse shape. | 2
RightArrowCallout | Represents the right arrow callout shape. | 3
DownArrowCallout | Represents the down arrow callout shape. | 4
LeftArrowCallout | Represents the left arrow callout shape. | 5
UpArrowCallout | Represents the up arrow callout shape. | 6
WedgeRectCallout | Represents the wedge rectangle callout shape. | 7
WedgeRoundRectCallout | Represents the wedge round rectangle callout shape. | 8
WedgeEllipseCallout | Represents the wedge ellipse callout shape. | 9
LineCallout | Represents the line callout shape. | 10
BentLineCallout | Represents the bent line callout shape. | 11
LineWithAccentBarCallout | Represents the line with accent bar callout shape. | 12
BentLineWithAccentBarCallout | Represents the bent line with accent bar callout shape. | 13

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


DialogBox Class

Represents the dialog box.

For a list of all members of this type, see DialogBox Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.DialogBox

public class DialogBox : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DialogBox Members | Aspose.Cells.Drawing Namespace


DialogBox Members

DialogBox overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

DialogBox Class | Aspose.Cells.Drawing Namespace


Fill Class

Represents the fill format of the shape.

For a list of all members of this type, see Fill Members.

System.Object
Aspose.Cells.Drawing.Fill
Derived types

public abstract class Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Fill Members | Aspose.Cells.Drawing Namespace


Fill Members

Fill overview

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Fill Class | Aspose.Cells.Drawing Namespace


FillFormat Class

Encapsulates the object that represents fill formatting for a shape.

For a list of all members of this type, see FillFormat Members.

System.Object
Aspose.Cells.Drawing.FillFormat
Aspose.Cells.Drawing.LineFormat

public class FillFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Filling the area of the 2nd NSeries with a gradient
chart.NSeries[1].Area.FillFormat.SetOneColorGradient(Color.Lime, 1, GradientStyleType.Horizontal, 1);

[Visual Basic]

'Filling the area of the 2nd NSeries with a gradient
chart.NSeries(1).Area.FillFormat.SetOneColorGradient(Color.Lime, 1, GradientStyleType.Horizontal, 1)

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FillFormat Members | Aspose.Cells.Drawing Namespace


FillFormat Members

FillFormat overview

Public Instance Properties

FillType | Gets and sets fill type
GradientColor1 | Returns the gradient color 1 for the specified fill.
GradientColor2 | Returns the gradient color 2 for the specified fill.
GradientColorType | Returns the gradient color type for the specified fill.
GradientDegree | Returns the gradient degree for the specified fill. Only applies for Excel 2007.
GradientFill | Gets GradientFill object.
GradientStyle | Returns the gradient style for the specified fill.
GradientVariant | Returns the gradient variant for the specified fill. Only applies for Excel 2007.
ImageData | Gets and sets the picture image data.
Pattern | Represents an area's display pattern.
PatternFill | Gets PatternFill object.
PictureFormatType | Gets and sets the picture format type.
PresetColor | Returns the gradient preset color for the specified fill.
Scale | Gets and sets the picture format scale.
SetType | Obsolete. Gets the fill format set type.
SolidFill | Gets SolidFill object.
Texture | Represents the texture type for the specified fill.
TextureFill | Gets TextureFill object.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Type | Obsolete. Gets and sets the fill type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient | Sets the specified fill to a one-color gradient. Only applies for Excel 2007.
SetPresetColorGradient | Sets the specified fill to a preset-color gradient. Only applies for Excel 2007.
SetTwoColorGradient | Overloaded. Sets the specified fill to a two-color gradient. Only applies for Excel 2007.
ToString (inherited from Object) |

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


FillFormat Properties

The properties of the FillFormat class are listed below. For a complete list of FillFormat class members, see the FillFormat Members topic.

Public Instance Properties

FillType | Gets and sets fill type
GradientColor1 | Returns the gradient color 1 for the specified fill.
GradientColor2 | Returns the gradient color 2 for the specified fill.
GradientColorType | Returns the gradient color type for the specified fill.
GradientDegree | Returns the gradient degree for the specified fill. Only applies for Excel 2007.
GradientFill | Gets GradientFill object.
GradientStyle | Returns the gradient style for the specified fill.
GradientVariant | Returns the gradient variant for the specified fill. Only applies for Excel 2007.
ImageData | Gets and sets the picture image data.
Pattern | Represents an area's display pattern.
PatternFill | Gets PatternFill object.
PictureFormatType | Gets and sets the picture format type.
PresetColor | Returns the gradient preset color for the specified fill.
Scale | Gets and sets the picture format scale.
SetType | Obsolete. Gets the fill format set type.
SolidFill | Gets SolidFill object.
Texture | Represents the texture type for the specified fill.
TextureFill | Gets TextureFill object.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Type | Obsolete. Gets and sets the fill type.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


FillType Property

Aspose.Cells for .NET

FillFormat.FillType Property

Gets and sets fill type

public FillType FillType {get; set;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientColor1 Property

Aspose.Cells for .NET

FillFormat.GradientColor1 Property

Returns the gradient color 1 for the specified fill.

public Color GradientColor1 {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientColor2 Property

Aspose.Cells for .NET

FillFormat.GradientColor2 Property

Returns the gradient color 2 for the specified fill.

public Color GradientColor2 {get;}

Remarks

Only when the gradient color type is GradientColorType.TwoColors, this property is meaningful.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientColorType Property

Aspose.Cells for .NET

FillFormat.GradientColorType Property

Returns the gradient color type for the specified fill.

public GradientColorType GradientColorType {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientDegree Property

Aspose.Cells for .NET

FillFormat.GradientDegree Property

Returns the gradient degree for the specified fill. Only applies for Excel 2007.

public double GradientDegree {get;}

Remarks

Can only be a value from 0.0 (dark) through 1.0 (light).

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientFill Property

Aspose.Cells for .NET

FillFormat.GradientFill Property

Gets GradientFill object.

public GradientFill GradientFill {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientStyle Property

Aspose.Cells for .NET

FillFormat.GradientStyle Property

Returns the gradient style for the specified fill.

public GradientStyleType GradientStyle {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


GradientVariant Property

Aspose.Cells for .NET

FillFormat.GradientVariant Property

Returns the gradient variant for the specified fill. Only applies for Excel 2007.

public int GradientVariant {get;}

Remarks

Can only be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


ImageData Property

Aspose.Cells for .NET

FillFormat.ImageData Property

Gets and sets the picture image data.

public byte[] ImageData {get; set;}

Remarks

If the fill format is not custom texture format, returns null.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


Pattern Property

Aspose.Cells for .NET

FillFormat.Pattern Property

Represents an area's display pattern.

public FillPattern Pattern {get; set;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


PatternFill Property

Aspose.Cells for .NET

FillFormat.PatternFill Property

Gets PatternFill object.

public PatternFill PatternFill {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


PictureFormatType Property

Aspose.Cells for .NET

FillFormat.PictureFormatType Property

Gets and sets the picture format type.

public FillPictureType PictureFormatType {get; set;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


PresetColor Property

Aspose.Cells for .NET

FillFormat.PresetColor Property

Returns the gradient preset color for the specified fill.

public GradientPresetType PresetColor {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


Scale Property

Aspose.Cells for .NET

FillFormat.Scale Property

Gets and sets the picture format scale.

public double Scale {get; set;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


SetType Property

Aspose.Cells for .NET

FillFormat.SetType Property

NOTE: This property is now obsolete.

Use FillFormat.FillType instead.

Gets the fill format set type.

public FormatSetType SetType {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use FillFormat.FillType property instead. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


SolidFill Property

Aspose.Cells for .NET

FillFormat.SolidFill Property

Gets SolidFill object.

public SolidFill SolidFill {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


Texture Property

Aspose.Cells for .NET

FillFormat.Texture Property

Represents the texture type for the specified fill.

public TextureType Texture {get; set;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


TextureFill Property

Aspose.Cells for .NET

FillFormat.TextureFill Property

Gets TextureFill object.

public TextureFill TextureFill {get;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

FillFormat.Transparency Property

Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

FillFormat.Type Property

NOTE: This property is now obsolete.

Use FillFormat.FillType instead.

Gets and sets the fill type.

public FillType Type {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use FillFormat.FillType property instead. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


FillFormat Methods

The methods of the FillFormat class are listed below. For a complete list of FillFormat class members, see the FillFormat Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient | Sets the specified fill to a one-color gradient. Only applies for Excel 2007.
SetPresetColorGradient | Sets the specified fill to a preset-color gradient. Only applies for Excel 2007.
SetTwoColorGradient | Overloaded. Sets the specified fill to a two-color gradient. Only applies for Excel 2007.
ToString (inherited from Object) |

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


FillFormat.SetOneColorGradient Method

Sets the specified fill to a one-color gradient. Only applies for Excel 2007.

public void SetOneColorGradient(
Color color,
double degree,
GradientStyleType style,
int variant
);

Parameters

color
One gradient color.
degree
The gradient degree. Can be a value from 0.0 (dark) through 1.0 (light).
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


FillFormat.SetPresetColorGradient Method

Sets the specified fill to a preset-color gradient. Only applies for Excel 2007.

public void SetPresetColorGradient(
GradientPresetType presetColor,
GradientStyleType style,
int variant
);

Parameters

presetColor
Preset color type
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


SetTwoColorGradient Method

Aspose.Cells for .NET

FillFormat.SetTwoColorGradient Method

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

Overload List

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(Color,double,Color,double,GradientStyleType,int);

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(Color,Color,GradientStyleType,int);

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace


FillFormat.SetTwoColorGradient Method (Color, Double, Color, Double, GradientStyleType, Int32)

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(
Color color1,
double transparency1,
Color color2,
double transparency2,
GradientStyleType style,
int variant
);

Parameters

color1
One gradient color.
transparency1
The degree of transparency of the color1 as a value from 0.0 (opaque) through 1.0 (clear).
color2
Two gradient color.
transparency2
The degree of transparency of the color2 as a value from 0.0 (opaque) through 1.0 (clear).
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace | FillFormat.SetTwoColorGradient Overload List


FillFormat.SetTwoColorGradient Method (Color, Color, GradientStyleType, Int32)

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(
Color color1,
Color color2,
GradientStyleType style,
int variant
);

Parameters

color1
One gradient color.
color2
Two gradient color.
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

FillFormat Class | Aspose.Cells.Drawing Namespace | FillFormat.SetTwoColorGradient Overload List


FillPattern Enumeration

Enumerates shape fill pattern types.

public enum FillPattern

Members

Member Name | Description | Value
None | Represents no background. | 0
Solid | Represents solid pattern. | 1
Gray5 | Represents 5% gray pattern. | 2
Gray10 | Represents 10% gray pattern. | 3
Gray20 | Represents 20% gray pattern. | 4
Gray30 | Represents 30% gray pattern. | 5
Gray40 | Represents 40% gray pattern. | 6
Gray50 | Represents 50% gray pattern. | 7
Gray60 | Represents 60% gray pattern. | 8
Gray70 | Represents 70% gray pattern. | 9
Gray75 | Represents 75% gray pattern. | 10
Gray80 | Represents 80% gray pattern. | 11
Gray90 | Represents 90% gray pattern. | 12
Gray25 | Represents 25% gray pattern. | 13
LightDownwardDiagonal | Represents light downward diagonal pattern. | 14
LightUpwardDiagonal | Represents light upward diagonal pattern. | 15
DarkDownwardDiagonal | Represents dark downward diagonal pattern. | 16
DarkUpwardDiagonal | Represents dark upward diagonal pattern. | 17
WideDownwardDiagonal | Represents wide downward diagonal pattern. | 18
WideUpwardDiagonal | Represents wide upward diagonal pattern. | 19
LightVertical | Represents light vertical pattern. | 20
LightHorizontal | Represents light horizontal pattern. | 21
NarrowVertical | Represents narrow vertical pattern. | 22
NarrowHorizontal | Represents narrow horizontal pattern. | 23
DarkVertical | Represents dark vertical pattern. | 24
DarkHorizontal | Represents dark horizontal pattern. | 25
DashedDownwardDiagonal | Represents dashed downward diagonal pattern. | 26
DashedUpwardDiagonal | Represents dashed upward diagonal pattern. | 27
DashedVertical | Represents dashed vertical pattern. | 28
DashedHorizontal | Represents dashed horizontal pattern. | 29
SmallConfetti | Represents small confetti pattern. | 30
LargeConfetti | Represents large confetti pattern. | 31
ZigZag | Represents zig zag pattern. | 32
Wave | Represents wave pattern. | 33
DiagonalBrick | Represents diagonal brick pattern. | 34
HorizontalBrick | Represents horizontal brick pattern. | 35
Weave | Represents weave pattern. | 36
Plaid | Represents plaid pattern. | 37
Divot | Represents divot pattern. | 38
DottedGrid | Represents dotted grid pattern. | 39
DottedDiamond | Represents dotted diamond pattern. | 40
Shingle | Represents shingle pattern. | 41
Trellis | Represents trellis pattern. | 42
Sphere | Represents sphere pattern. | 43
SmallGrid | Represents small grid pattern. | 44
LargeGrid | Represents large grid pattern. | 45
SmallCheckerBoard | Represents small checker board pattern. | 46
LargeCheckerBoard | Represents large checker board pattern. | 47
OutlinedDiamond | Represents outlined diamond pattern. | 48
SolidDiamond | Represents solid diamond pattern. | 49
Unknown | Represents unknown pattern. | 50

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


FillPictureType Enumeration

Represents the picture fill type.

public enum FillPictureType

Members

Member Name | Description | Value
Stretch | Stretch | 0
Stack | Stack | 1
StackAndScale | StackAndScale | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


FillType Enumeration

Fill format type.

public enum FillType

Members

Member Name | Description | Value
Automatic | Represents automatic formatting type. | 0
None | Represents none formatting type. | 1
Solid | Solid fill format. | 2
Gradient | Gradient fill format. | 3
Texture | Texture fill format(includes picture fill). | 4
Pattern | Pattern fill format. | 5
Group | Inherit the fill properties of the group. | 6

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Format3D Class

This class specifies the 3D shape properties for a chart element or shape.

For a list of all members of this type, see Format3D Members.

System.Object
Aspose.Cells.Drawing.Format3D

public class Format3D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Format3D Members | Aspose.Cells.Drawing Namespace


Format3D Members

Format3D overview

Public Instance Properties

LightingAngle | Gets and sets the lighting angle. Range from 0 to 359.9 degrees.
SurfaceLightingType | Gets and sets the lighting type which is to be applied to the scene of the shape. Default value is LightRigType.ThreePoint.
SurfaceMaterialType | Gets and sets the material type which is combined with the lighting properties to give the final look and feel of a shape. Default value is PresetMaterialType.WarmMatte.
TopBevel | Gets the object that holds the properties associated with defining a bevel on the top or front face of a shape.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasTopBevelData | Indicates if the shape has top bevel data.
ToString (inherited from Object) |

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


Format3D Properties

The properties of the Format3D class are listed below. For a complete list of Format3D class members, see the Format3D Members topic.

Public Instance Properties

LightingAngle | Gets and sets the lighting angle. Range from 0 to 359.9 degrees.
SurfaceLightingType | Gets and sets the lighting type which is to be applied to the scene of the shape. Default value is LightRigType.ThreePoint.
SurfaceMaterialType | Gets and sets the material type which is combined with the lighting properties to give the final look and feel of a shape. Default value is PresetMaterialType.WarmMatte.
TopBevel | Gets the object that holds the properties associated with defining a bevel on the top or front face of a shape.

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


LightingAngle Property

Aspose.Cells for .NET

Format3D.LightingAngle Property

Gets and sets the lighting angle. Range from 0 to 359.9 degrees.

public double LightingAngle {get; set;}

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


SurfaceLightingType Property

Aspose.Cells for .NET

Format3D.SurfaceLightingType Property

Gets and sets the lighting type which is to be applied to the scene of the shape. Default value is LightRigType.ThreePoint.

public LightRigType SurfaceLightingType {get; set;}

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


SurfaceMaterialType Property

Aspose.Cells for .NET

Format3D.SurfaceMaterialType Property

Gets and sets the material type which is combined with the lighting properties to give the final look and feel of a shape. Default value is PresetMaterialType.WarmMatte.

public PresetMaterialType SurfaceMaterialType {get; set;}

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


TopBevel Property

Aspose.Cells for .NET

Format3D.TopBevel Property

Gets the object that holds the properties associated with defining a bevel on the top or front face of a shape.

public Bevel TopBevel {get;}

See Also

Format3D Class | Aspose.Cells.Drawing Namespace | Bevel


Format3D Methods

The methods of the Format3D class are listed below. For a complete list of Format3D class members, see the Format3D Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasTopBevelData | Indicates if the shape has top bevel data.
ToString (inherited from Object) |

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


Format3D.HasTopBevelData Method

Indicates if the shape has top bevel data.

public bool HasTopBevelData();

Return Value

See Also

Format3D Class | Aspose.Cells.Drawing Namespace


FormatSetType Enumeration

Fill format set type.

public enum FormatSetType

Members

Member Name | Description | Value
None | No Fill format. | 0
IsGradientSet | Gradient fill format. | 1
IsTextureSet | Texture fill format. | 2
IsPatternSet | Pattern fill format. | 3

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Geometry Class

Represents a geometric shape.

For a list of all members of this type, see Geometry Members.

System.Object
Aspose.Cells.Drawing.Geometry
Aspose.Cells.Drawing.CustomGeometry

public abstract class Geometry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Geometry Members | Aspose.Cells.Drawing Namespace


Geometry Members

Geometry overview

Public Instance Properties

ShapeAdjustValues Gets a collection of shape adjust value

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Geometry Class | Aspose.Cells.Drawing Namespace


Geometry Properties

The properties of the Geometry class are listed below. For a complete list of Geometry class members, see the Geometry Members topic.

Public Instance Properties

ShapeAdjustValues Gets a collection of shape adjust value

See Also

Geometry Class | Aspose.Cells.Drawing Namespace


ShapeAdjustValues Property

Aspose.Cells for .NET

Geometry.ShapeAdjustValues Property

Gets a collection of shape adjust value

public ShapeGuideCollection ShapeAdjustValues {get;}

See Also

Geometry Class | Aspose.Cells.Drawing Namespace


GlowEffect Class

This class specifies a glow effect, in which a color blurred outline is added outside the edges of the object.

For a list of all members of this type, see GlowEffect Members.

System.Object
Aspose.Cells.Drawing.GlowEffect

public class GlowEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GlowEffect Members | Aspose.Cells.Drawing Namespace


GlowEffect Members

GlowEffect overview

Public Instance Properties

Color | Gets the color of the glow effect.
Radius | Obsolete. Gets and sets the radius of the glow, in unit of points.
Size | Gets and sets the radius of the glow, in unit of points.
Transparency | Gets and sets the degree of transparency of the glow effect. Range from 0.0 (opaque) to 1.0 (clear).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GlowEffect Class | Aspose.Cells.Drawing Namespace


GlowEffect Properties

The properties of the GlowEffect class are listed below. For a complete list of GlowEffect class members, see the GlowEffect Members topic.

Public Instance Properties

Color | Gets the color of the glow effect.
Radius | Obsolete. Gets and sets the radius of the glow, in unit of points.
Size | Gets and sets the radius of the glow, in unit of points.
Transparency | Gets and sets the degree of transparency of the glow effect. Range from 0.0 (opaque) to 1.0 (clear).

See Also

GlowEffect Class | Aspose.Cells.Drawing Namespace


Color Property

Aspose.Cells for .NET

GlowEffect.Color Property

Gets the color of the glow effect.

public CellsColor Color {get; set;}

See Also

GlowEffect Class | Aspose.Cells.Drawing Namespace


Radius Property

Aspose.Cells for .NET

GlowEffect.Radius Property

NOTE: This property is now obsolete.

Use GlowEffect.Size property instead.

Gets and sets the radius of the glow, in unit of points.

public double Radius {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use GlowEffect.Size property. This property will be removed 6 months later since September 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

GlowEffect Class | Aspose.Cells.Drawing Namespace


Size Property

Aspose.Cells for .NET

GlowEffect.Size Property

Gets and sets the radius of the glow, in unit of points.

public double Size {get; set;}

See Also

GlowEffect Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

GlowEffect.Transparency Property

Gets and sets the degree of transparency of the glow effect. Range from 0.0 (opaque) to 1.0 (clear).

public double Transparency {get; set;}

See Also

GlowEffect Class | Aspose.Cells.Drawing Namespace


GradientColorType Enumeration

Represents the gradient color type for the specified fill.

public enum GradientColorType

Members

Member Name | Description | Value
None | No gradient color | 0
OneColor | One gradient color | 1
PresetColors | Preset gradient colors | 2
TwoColors | Two gradient colors | 3

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


GradientDirectionType Enumeration

Represents all direction type of gradient.

public enum GradientDirectionType

Members

Member Name | Description | Value
FromUpperLeftCorner | FromUpperLeftCorner | 0
FromUpperRightCorner | FromUpperRightCorner | 1
FromLowerLeftCorner | FromLowerLeftCorner | 2
FromLowerRightCorner | FromLowerRightCorner | 3
FromCenter | FromCenter | 4
Unknown | Unknown | 5

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


GradientFill Class

Represents the gradient fill.

For a list of all members of this type, see GradientFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.GradientFill

public class GradientFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GradientFill Members | Aspose.Cells.Drawing Namespace


GradientFill Members

GradientFill overview

Public Instance Properties

Angle | The angle of linear fill.
DirectionType | Gets the gradient direction type.
FillType | Gets the gradient fill type.
GradientStops | Represents the gradient stop collection.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetGradient | Set the gradient fill type and direction.
SetOneColorGradient | Sets the specified fill to a one-color gradient. Only applies for Excel 2007.
SetTwoColorGradient | Overloaded. Sets the specified fill to a two-color gradient. Only applies for Excel 2007.
ToString (inherited from Object) |

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


GradientFill Properties

The properties of the GradientFill class are listed below. For a complete list of GradientFill class members, see the GradientFill Members topic.

Public Instance Properties

Angle | The angle of linear fill.
DirectionType | Gets the gradient direction type.
FillType | Gets the gradient fill type.
GradientStops | Represents the gradient stop collection.

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


Angle Property

Aspose.Cells for .NET

GradientFill.Angle Property

The angle of linear fill.

public float Angle {get; set;}

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


DirectionType Property

Aspose.Cells for .NET

GradientFill.DirectionType Property

Gets the gradient direction type.

public GradientDirectionType DirectionType {get;}

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


FillType Property

Aspose.Cells for .NET

GradientFill.FillType Property

Gets the gradient fill type.

public GradientFillType FillType {get;}

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


GradientStops Property

Aspose.Cells for .NET

GradientFill.GradientStops Property

Represents the gradient stop collection.

public GradientStopCollection GradientStops {get;}

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


GradientFill Methods

The methods of the GradientFill class are listed below. For a complete list of GradientFill class members, see the GradientFill Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetGradient | Set the gradient fill type and direction.
SetOneColorGradient | Sets the specified fill to a one-color gradient. Only applies for Excel 2007.
SetTwoColorGradient | Overloaded. Sets the specified fill to a two-color gradient. Only applies for Excel 2007.
ToString (inherited from Object) |

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


GradientFill.SetGradient Method

Set the gradient fill type and direction.

public void SetGradient(
GradientFillType type,
double angle,
GradientDirectionType direction
);

Parameters

type
Gradient fill type.
angle
The angle. Only applies for GradientFillType.Linear.
direction
The direction type. Only applies for GradientFillType.Radial and GradientFillType.Rectangle.

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


GradientFill.SetOneColorGradient Method

Sets the specified fill to a one-color gradient. Only applies for Excel 2007.

public void SetOneColorGradient(
Color color,
double degree,
GradientStyleType style,
int variant
);

Parameters

color
One gradient color.
degree
The gradient degree. Can be a value from 0.0 (dark) through 1.0 (light).
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


SetTwoColorGradient Method

Aspose.Cells for .NET

GradientFill.SetTwoColorGradient Method

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

Overload List

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(Color,double,Color,double,GradientStyleType,int);

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(Color,Color,GradientStyleType,int);

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace


GradientFill.SetTwoColorGradient Method (Color, Double, Color, Double, GradientStyleType, Int32)

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(
Color color1,
double transparency1,
Color color2,
double transparency2,
GradientStyleType style,
int variant
);

Parameters

color1
One gradient color.
transparency1
The degree of transparency of the color1 as a value from 0.0 (opaque) through 1.0 (clear).
color2
Two gradient color.
transparency2
The degree of transparency of the color2 as a value from 0.0 (opaque) through 1.0 (clear).
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace | GradientFill.SetTwoColorGradient Overload List


GradientFill.SetTwoColorGradient Method (Color, Color, GradientStyleType, Int32)

Sets the specified fill to a two-color gradient. Only applies for Excel 2007.

public void SetTwoColorGradient(
Color color1,
Color color2,
GradientStyleType style,
int variant
);

Parameters

color1
One gradient color.
color2
Two gradient color.
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

GradientFill Class | Aspose.Cells.Drawing Namespace | GradientFill.SetTwoColorGradient Overload List


GradientFillType Enumeration

Represents all Gradient fill type.

public enum GradientFillType

Members

Member Name | Description | Value
Linear | Linear | 0
Radial | Radial | 1
Rectangle | Rectangle | 2
Path | Path | 3

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


GradientPresetType Enumeration

Represents gradient preset color type.

public enum GradientPresetType

Members

Member Name | Description | Value
Brass | Brass preset color | 0
CalmWater | Calm Water preset color | 1
Chrome | Chrome preset color | 2
ChromeII | Chrome II preset color | 3
Daybreak | Daybreak preset color | 4
Desert | Desert preset color | 5
EarlySunset | Early Sunset preset color | 6
Fire | Fire preset color | 7
Fog | Fog preset color | 8
Gold | Gold preset color | 9
GoldII | Gold II preset color | 10
Horizon | Horizon preset color | 11
LateSunset | Late Sunset preset color | 12
Mahogany | Mahogany preset color | 13
Moss | Moss preset color | 14
Nightfall | Nightfall preset color | 15
Ocean | Ocean preset color | 16
Parchment | Parchment preset color | 17
Peacock | Peacock preset color | 18
Rainbow | Rainbow preset color | 19
RainbowII | Rainbow II preset color | 20
Sapphire | Sapphire preset color | 21
Silver | Silver preset color | 22
Wheat | Wheat preset color | 23
Unknown | Unknown preset color. Only for the preset color (which is not same as any known preset color) in the template workbook. | 24

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


GradientStop Class

Represents the gradient stop.

For a list of all members of this type, see GradientStop Members.

System.Object
Aspose.Cells.Drawing.GradientStop

public class GradientStop

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GradientStop Members | Aspose.Cells.Drawing Namespace


GradientStop Members

GradientStop overview

Public Instance Properties

CellsColor | Gets the color of this gradient stop.
Position | The position of the stop.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GradientStop Class | Aspose.Cells.Drawing Namespace


GradientStop Properties

The properties of the GradientStop class are listed below. For a complete list of GradientStop class members, see the GradientStop Members topic.

Public Instance Properties

CellsColor | Gets the color of this gradient stop.
Position | The position of the stop.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

See Also

GradientStop Class | Aspose.Cells.Drawing Namespace


CellsColor Property

Aspose.Cells for .NET

GradientStop.CellsColor Property

Gets the color of this gradient stop.

public CellsColor CellsColor {get;}

See Also

GradientStop Class | Aspose.Cells.Drawing Namespace


Position Property

Aspose.Cells for .NET

GradientStop.Position Property

The position of the stop.

public double Position {get; set;}

See Also

GradientStop Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

GradientStop.Transparency Property

Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

GradientStop Class | Aspose.Cells.Drawing Namespace


GradientStopCollection Class

Represents the gradient stop collection.

For a list of all members of this type, see GradientStopCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.GradientStopCollection

public class GradientStopCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GradientStopCollection Members | Aspose.Cells.Drawing Namespace


GradientStopCollection Members

GradientStopCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the gradient stop by the index.

Public Instance Methods

Add | Overloaded. Add a gradient stop.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace


GradientStopCollection Properties

The properties of the GradientStopCollection class are listed below. For a complete list of GradientStopCollection class members, see the GradientStopCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the gradient stop by the index.

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

GradientStopCollection.Item Property

Gets the gradient stop by the index.

public GradientStop this[
int index
] {get; set;}

Parameters

index
The index.

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace


GradientStopCollection Methods

The methods of the GradientStopCollection class are listed below. For a complete list of GradientStopCollection class members, see the GradientStopCollection Members topic.

Public Instance Methods

Add | Overloaded. Add a gradient stop.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace


Add Method

Aspose.Cells for .NET

GradientStopCollection.Add Method

Add a gradient stop.

Overload List

Add a gradient stop.

public void Add(double,CellsColor,int);

Add a gradient stop.

public void Add(double,Color,int);

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace


GradientStopCollection.Add Method (Double, CellsColor, Int32)

Add a gradient stop.

public void Add(
double position,
CellsColor color,
int alpha
);

Parameters

position
The position of the stop,in unit of percentage.
color
The color of the stop.
alpha
The alpha of the color.

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace | GradientStopCollection.Add Overload List


GradientStopCollection.Add Method (Double, Color, Int32)

Add a gradient stop.

public void Add(
double position,
Color color,
int alpha
);

Parameters

position
The position of the stop,in unit of percentage.
color
The color of the stop.
alpha
The alpha of the color.

See Also

GradientStopCollection Class | Aspose.Cells.Drawing Namespace | GradientStopCollection.Add Overload List


GradientStyleType Enumeration

Represents gradient shading style.

public enum GradientStyleType

Members

Member Name | Description | Value
DiagonalDown | Diagonal down shading style | 0
DiagonalUp | Diagonal up shading style | 1
FromCenter | From center shading style | 2
FromCorner | From corner shading style | 3
Horizontal | Horizontal shading style | 4
Vertical | Vertical shading style | 5
Unknown | Unknown shading style.Only for the shading style(which is not for any member of the GradientStyleType) in the template file. | 6

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


GroupBox Class

Encapsulates the object that represents a groupbox in a spreadsheet.

For a list of all members of this type, see GroupBox Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.GroupBox

public class GroupBox : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate a new Workbook.
Workbook excelbook = new Workbook();

//Add a group box to the first worksheet.
Aspose.Cells.GroupBox box = excelbook.Worksheets[0].Shapes.AddGroupBox(1, 0, 1, 0, 300, 250);

//Set the caption of the group box.
box.Text = "Age Groups";
box.Placement = PlacementType.FreeFloating;

//Make it 2-D box.
box.Shadow = false;

//Add a radio button.
Aspose.Cells.RadioButton radio1 = excelbook.Worksheets[0].Shapes.AddRadioButton(3, 0, 2, 0, 30, 110);

//Set its text string.
radio1.Text = "20-29";

//Set A1 cell as a linked cell for the radio button.
radio1.LinkedCell = "A1";

//Make the radio button 3-D.
radio1.Shadow = true;

//Set the foreground color of the radio button.
radio1.FillFormat.ForeColor = Color.LightGreen;

//Set the line style of the radio button.
radio1.LineFormat.Style = MsoLineStyle.ThickThin;

//Set the weight of the radio button.
radio1.LineFormat.Weight = 4;

//Set the line color of the radio button.
radio1.LineFormat.ForeColor = Color.Blue;

//Set the dash style of the radio button.
radio1.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Make the line format visible.
radio1.LineFormat.IsVisible = true;

//Make the fill format visible.
radio1.FillFormat.IsVisible = true;

//Add another radio button.
Aspose.Cells.RadioButton radio2 = excelbook.Worksheets[0].Shapes.AddRadioButton(6, 0, 2, 0, 30, 110);

//Set its text string.
radio2.Text = "30-39";

//Set A1 cell as a linked cell for the radio button.
radio2.LinkedCell = "A1";

//Make the radio button 3-D.
radio2.Shadow = true;

//Set the foreground color of the radio button.
radio2.FillFormat.ForeColor = Color.LightGreen;

//Set the line style of the radio button.
radio2.LineFormat.Style = MsoLineStyle.ThickThin;

//Set the weight of the radio button.
radio2.LineFormat.Weight = 4;

//Set the line color of the radio button.
radio2.LineFormat.ForeColor = Color.Blue;

//Set the dash style of the radio button.
radio2.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Make the line format visible.
radio2.LineFormat.IsVisible = true;

//Make the fill format visible.
radio2.FillFormat.IsVisible = true;

//Add another radio button.
Aspose.Cells.RadioButton radio3 = excelbook.Worksheets[0].Shapes.AddRadioButton(9, 0, 2, 0, 30, 110);

//Set its text string.
radio3.Text = "40-49";

//Set A1 cell as a linked cell for the radio button.
radio3.LinkedCell = "A1";

//Make the radio button 3-D.
radio3.Shadow = true;

//Set the foreground color of the radio button.
radio3.FillFormat.ForeColor = Color.LightGreen;

//Set the line style of the radio button.
radio3.LineFormat.Style = MsoLineStyle.ThickThin;

//Set the weight of the radio button.
radio3.LineFormat.Weight = 4;

//Set the line color of the radio button.
radio3.LineFormat.ForeColor = Color.Blue;

//Set the dash style of the radio button.
radio3.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Make the line format visible.
radio3.LineFormat.IsVisible = true;

//Make the fill format visible.
radio3.FillFormat.IsVisible = true;

//Get the shapes.
Aspose.Cells.Shape[] shapeobjects = new Aspose.Cells.Shape[] { box, radio1, radio2, radio3 };

//Group the shapes.
Aspose.Cells.GroupShape group = excelbook.Worksheets[0].Shapes.Group(shapeobjects);

//Save the excel file.
excelbook.Save("d:\\test\\groupshapes.xls");

[VB.NET]

'Instantiate a new Workbook.
Dim excelbook As Workbook = New Workbook()

'Add a group box to the first worksheet.
Dim box As Aspose.Cells.GroupBox = excelbook.Worksheets(0).Shapes.AddGroupBox(1, 0, 1, 0, 300, 250)

'Set the caption of the group box.
box.Text = "Age Groups"
box.Placement = PlacementType.FreeFloating

'Make it 2-D box.
box.Shadow = False

'Add a radio button.
Dim radio1 As Aspose.Cells.RadioButton = excelbook.Worksheets(0).Shapes.AddRadioButton(3, 0, 2, 0, 30, 110)

'Set its text string.
radio1.Text = "20-29"

'Set A1 cell as a linked cell for the radio button.
radio1.LinkedCell = "A1"

'Make the radio button 3-D.
radio1.Shadow = True

'Set the foreground color of the radio button.
radio1.FillFormat.ForeColor = Color.LightGreen

'Set the line style of the radio button.
radio1.LineFormat.Style = MsoLineStyle.ThickThin

'Set the weight of the radio button.
radio1.LineFormat.Weight = 4

'Set the line color of the radio button.
radio1.LineFormat.ForeColor = Color.Blue

'Set the dash style of the radio button.
radio1.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Make the line format visible.
radio1.LineFormat.IsVisible = True

'Make the fill format visible.
radio1.FillFormat.IsVisible = True

'Add another radio button.
Dim radio2 As Aspose.Cells.RadioButton = excelbook.Worksheets(0).Shapes.AddRadioButton(6, 0, 2, 0, 30, 110)

'Set its text string.
radio2.Text = "30-39"

'Set A1 cell as a linked cell for the radio button.
radio2.LinkedCell = "A1"

'Make the radio button 3-D.
radio2.Shadow = True

'Set the foreground color of the radio button.
radio2.FillFormat.ForeColor = Color.LightGreen

'Set the line style of the radio button.
radio2.LineFormat.Style = MsoLineStyle.ThickThin

'Set the weight of the radio button.
radio2.LineFormat.Weight = 4

'Set the line color of the radio button.
radio2.LineFormat.ForeColor = Color.Blue

'Set the dash style of the radio button.
radio2.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Make the line format visible.
radio2.LineFormat.IsVisible = True

'Make the fill format visible.
radio2.FillFormat.IsVisible = True

'Add another radio button.
Dim radio3 As Aspose.Cells.RadioButton = excelbook.Worksheets(0).Shapes.AddRadioButton(9, 0, 2, 0, 30, 110)

'Set its text string.
radio3.Text = "40-49"

'Set A1 cell as a linked cell for the radio button.
radio3.LinkedCell = "A1"

'Make the radio button 3-D.
radio3.Shadow = True

'Set the foreground color of the radio button.
radio3.FillFormat.ForeColor = Color.LightGreen

'Set the line style of the radio button.
radio3.LineFormat.Style = MsoLineStyle.ThickThin

'Set the weight of the radio button.
radio3.LineFormat.Weight = 4

'Set the line color of the radio button.
radio3.LineFormat.ForeColor = Color.Blue

'Set the dash style of the radio button.
radio3.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Make the line format visible.
radio3.LineFormat.IsVisible = True

'Make the fill format visible.
radio3.FillFormat.IsVisible = True

'Get the shapes.
Dim shapeobjects() As Aspose.Cells.Shape = New Aspose.Cells.Shape() {box, radio1, radio2, radio3}

'Group the shapes.
Dim group As Aspose.Cells.GroupShape = excelbook.Worksheets(0).Shapes.Group(shapeobjects)

'Save the excel file.
excelbook.Save("d:\test\groupshapes.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GroupBox Members | Aspose.Cells.Drawing Namespace


GroupBox Members

GroupBox overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the groupbox has shadow.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

GroupBox Class | Aspose.Cells.Drawing Namespace


GroupBox Properties

The properties of the GroupBox class are listed below. For a complete list of GroupBox class members, see the GroupBox Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the groupbox has shadow.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

GroupBox Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

GroupBox.Shadow Property

Indicates whether the groupbox has shadow.

public bool Shadow {get; set;}

See Also

GroupBox Class | Aspose.Cells.Drawing Namespace


GroupFill Class

Represents this fill format should inherit the fill properties of the group.

For a list of all members of this type, see GroupFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.GroupFill

public class GroupFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GroupFill Members | Aspose.Cells.Drawing Namespace


GroupFill Members

GroupFill overview

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GroupFill Class | Aspose.Cells.Drawing Namespace


GroupShape Class

Represents the group shape which contains the individual shapes.

For a list of all members of this type, see GroupShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.GroupShape

public class GroupShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate a new Workbook.
Workbook excelbook = new Workbook();

//Add a group box to the first worksheet.
Aspose.Cells.GroupBox box = excelbook.Worksheets[0].Shapes.AddGroupBox(1, 0, 1, 0, 300, 250);

//Set the caption of the group box.
box.Text = "Age Groups";
box.Placement = PlacementType.FreeFloating;

//Make it 2-D box.
box.Shadow = false;

//Add a radio button.
Aspose.Cells.RadioButton radio1 = excelbook.Worksheets[0].Shapes.AddRadioButton(3, 0, 2, 0, 30, 110);

//Set its text string.
radio1.Text = "20-29";

//Set A1 cell as a linked cell for the radio button.
radio1.LinkedCell = "A1";

//Make the radio button 3-D.
radio1.Shadow = true;

//Set the foreground color of the radio button.
radio1.FillFormat.ForeColor = Color.LightGreen;

//Set the line style of the radio button.
radio1.LineFormat.Style = MsoLineStyle.ThickThin;

//Set the weight of the radio button.
radio1.LineFormat.Weight = 4;

//Set the line color of the radio button.
radio1.LineFormat.ForeColor = Color.Blue;

//Set the dash style of the radio button.
radio1.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Make the line format visible.
radio1.LineFormat.IsVisible = true;

//Make the fill format visible.
radio1.FillFormat.IsVisible = true;

//Add another radio button.
Aspose.Cells.RadioButton radio2 = excelbook.Worksheets[0].Shapes.AddRadioButton(6, 0, 2, 0, 30, 110);

//Set its text string.
radio2.Text = "30-39";

//Set A1 cell as a linked cell for the radio button.
radio2.LinkedCell = "A1";

//Make the radio button 3-D.
radio2.Shadow = true;

//Set the foreground color of the radio button.
radio2.FillFormat.ForeColor = Color.LightGreen;

//Set the line style of the radio button.
radio2.LineFormat.Style = MsoLineStyle.ThickThin;

//Set the weight of the radio button.
radio2.LineFormat.Weight = 4;

//Set the line color of the radio button.
radio2.LineFormat.ForeColor = Color.Blue;

//Set the dash style of the radio button.
radio2.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Make the line format visible.
radio2.LineFormat.IsVisible = true;

//Make the fill format visible.
radio2.FillFormat.IsVisible = true;

//Add another radio button.
Aspose.Cells.RadioButton radio3 = excelbook.Worksheets[0].Shapes.AddRadioButton(9, 0, 2, 0, 30, 110);

//Set its text string.
radio3.Text = "40-49";

//Set A1 cell as a linked cell for the radio button.
radio3.LinkedCell = "A1";

//Make the radio button 3-D.
radio3.Shadow = true;

//Set the foreground color of the radio button.
radio3.FillFormat.ForeColor = Color.LightGreen;

//Set the line style of the radio button.
radio3.LineFormat.Style = MsoLineStyle.ThickThin;

//Set the weight of the radio button.
radio3.LineFormat.Weight = 4;

//Set the line color of the radio button.
radio3.LineFormat.ForeColor = Color.Blue;

//Set the dash style of the radio button.
radio3.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Make the line format visible.
radio3.LineFormat.IsVisible = true;

//Make the fill format visible.
radio3.FillFormat.IsVisible = true;

//Get the shapes.
Aspose.Cells.Shape[] shapeobjects = new Aspose.Cells.Shape[] { box, radio1, radio2, radio3 };

//Group the shapes.
Aspose.Cells.GroupShape group = excelbook.Worksheets[0].Shapes.Group(shapeobjects);

//Save the excel file.
excelbook.Save("d:\\test\\groupshapes.xls");

[VB.NET]

'Instantiate a new Workbook.
Dim excelbook As Workbook = New Workbook()

'Add a group box to the first worksheet.
Dim box As Aspose.Cells.GroupBox = excelbook.Worksheets(0).Shapes.AddGroupBox(1, 0, 1, 0, 300, 250)

'Set the caption of the group box.
box.Text = "Age Groups"
box.Placement = PlacementType.FreeFloating

'Make it 2-D box.
box.Shadow = False

'Add a radio button.
Dim radio1 As Aspose.Cells.RadioButton = excelbook.Worksheets(0).Shapes.AddRadioButton(3, 0, 2, 0, 30, 110)

'Set its text string.
radio1.Text = "20-29"

'Set A1 cell as a linked cell for the radio button.
radio1.LinkedCell = "A1"

'Make the radio button 3-D.
radio1.Shadow = True

'Set the foreground color of the radio button.
radio1.FillFormat.ForeColor = Color.LightGreen

'Set the line style of the radio button.
radio1.LineFormat.Style = MsoLineStyle.ThickThin

'Set the weight of the radio button.
radio1.LineFormat.Weight = 4

'Set the line color of the radio button.
radio1.LineFormat.ForeColor = Color.Blue

'Set the dash style of the radio button.
radio1.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Make the line format visible.
radio1.LineFormat.IsVisible = True

'Make the fill format visible.
radio1.FillFormat.IsVisible = True

'Add another radio button.
Dim radio2 As Aspose.Cells.RadioButton = excelbook.Worksheets(0).Shapes.AddRadioButton(6, 0, 2, 0, 30, 110)

'Set its text string.
radio2.Text = "30-39"

'Set A1 cell as a linked cell for the radio button.
radio2.LinkedCell = "A1"

'Make the radio button 3-D.
radio2.Shadow = True

'Set the foreground color of the radio button.
radio2.FillFormat.ForeColor = Color.LightGreen

'Set the line style of the radio button.
radio2.LineFormat.Style = MsoLineStyle.ThickThin

'Set the weight of the radio button.
radio2.LineFormat.Weight = 4

'Set the line color of the radio button.
radio2.LineFormat.ForeColor = Color.Blue

'Set the dash style of the radio button.
radio2.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Make the line format visible.
radio2.LineFormat.IsVisible = True

'Make the fill format visible.
radio2.FillFormat.IsVisible = True

'Add another radio button.
Dim radio3 As Aspose.Cells.RadioButton = excelbook.Worksheets(0).Shapes.AddRadioButton(9, 0, 2, 0, 30, 110)

'Set its text string.
radio3.Text = "40-49"

'Set A1 cell as a linked cell for the radio button.
radio3.LinkedCell = "A1"

'Make the radio button 3-D.
radio3.Shadow = True

'Set the foreground color of the radio button.
radio3.FillFormat.ForeColor = Color.LightGreen

'Set the line style of the radio button.
radio3.LineFormat.Style = MsoLineStyle.ThickThin

'Set the weight of the radio button.
radio3.LineFormat.Weight = 4

'Set the line color of the radio button.
radio3.LineFormat.ForeColor = Color.Blue

'Set the dash style of the radio button.
radio3.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Make the line format visible.
radio3.LineFormat.IsVisible = True

'Make the fill format visible.
radio3.FillFormat.IsVisible = True

'Get the shapes.
Dim shapeobjects() As Aspose.Cells.Shape = New Aspose.Cells.Shape() {box, radio1, radio2, radio3}

'Group the shapes.
Dim group As Aspose.Cells.GroupShape = excelbook.Worksheets(0).Shapes.Group(shapeobjects)

'Save the excel file.
excelbook.Save("d:\test\groupshapes.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

GroupShape Members | Aspose.Cells.Drawing Namespace


GroupShape Members

GroupShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Item | Gets the child shape by index.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetGroupedShapes | Gets the shapes grouped by this shape.
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
Ungroup | Ungroups the shape items.
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

GroupShape Class | Aspose.Cells.Drawing Namespace


GroupShape Properties

The properties of the GroupShape class are listed below. For a complete list of GroupShape class members, see the GroupShape Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Item | Gets the child shape by index.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

GroupShape Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

GroupShape.Item Property

Gets the child shape by index.

public Shape this[
int index
] {get;}

Parameters

index
the child shape index.

See Also

GroupShape Class | Aspose.Cells.Drawing Namespace


GroupShape Methods

The methods of the GroupShape class are listed below. For a complete list of GroupShape class members, see the GroupShape Members topic.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetGroupedShapes | Gets the shapes grouped by this shape.
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
Ungroup | Ungroups the shape items.
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

GroupShape Class | Aspose.Cells.Drawing Namespace


GroupShape.GetGroupedShapes Method

Gets the shapes grouped by this shape.

public Shape[] GetGroupedShapes();

See Also

GroupShape Class | Aspose.Cells.Drawing Namespace


GroupShape.Ungroup Method

Ungroups the shape items.

public void Ungroup();

Remarks

If the group shape is grouped by another group shape,nothing will be done.

See Also

GroupShape Class | Aspose.Cells.Drawing Namespace


ImageType Enumeration

Specifies the type (format) of an image.

public enum ImageType

Members

Member Name | Description | Value
Unknown | An unknown image type. | 0
Emf | Windows Enhanced Metafile. | 2
Wmf | Windows Metafile. | 3
Pict | Macintosh PICT. | 4
Jpeg | JPEG JFIF. | 5
Png | Portable Network Graphics. | 6
Bmp | Windows Bitmap | 7
Gif | Gif | 66
Tiff | Tiff | 67
Svg | Svg | 68
Svm | Svm | 69
Gltf | glTF | 70

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Label Class

Encapsulates the object that represents a label in a spreadsheet.

For a list of all members of this type, see Label Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.Label

public class Label : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Requirements
Namespace:  Aspose.Cells.Drawing
Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also
Label Members | Aspose.Cells.Drawing Namespace


Label Members

Label overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

Label Class | Aspose.Cells.Drawing Namespace


LightRigDirectionType Enumeration

Represents the light rig direction type.

public enum LightRigDirectionType

Members

Member Name | Description | Value
Bottom | Bottom | 0
BottomLeft | Bottom left. | 1
BottomRight | Bottom Right. | 2
Left | Left. | 3
Right | Right. | 4
Top | Top. | 5
TopLeft | Top left. | 6
TopRight | Top Right. | 7

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


LightRigType Enumeration

Represents a preset light right that can be applied to a shape

public enum LightRigType

Members

Member Name | Description | Value
Balanced | Balanced | 0
BrightRoom | Bright room | 1
Chilly | Chilly | 2
Contrasting | Contrasting | 3
Flat | Flat | 4
Flood | Flood | 5
Freezing | Freezing | 6
Glow | Glow | 7
Harsh | Harsh | 8
LegacyFlat1 | LegacyFlat1 | 9
LegacyFlat2 | LegacyFlat2 | 10
LegacyFlat3 | LegacyFlat3 | 11
LegacyFlat4 | LegacyFlat4 | 12
LegacyHarsh1 | LegacyHarsh1 | 13
LegacyHarsh2 | LegacyHarsh2 | 14
LegacyHarsh3 | LegacyHarsh3 | 15
LegacyHarsh4 | LegacyHarsh4 | 16
LegacyNormal1 | LegacyNormal1 | 17
LegacyNormal2 | LegacyNormal2 | 18
LegacyNormal3 | LegacyNormal3 | 19
LegacyNormal4 | LegacyNormal4 | 20
Morning | Morning | 21
Soft | Soft | 22
Sunrise | Sunrise | 23
Sunset | Sunset | 24
ThreePoint | Three point | 25
TwoPoint | Two point | 26
None | No light rig. | 27

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Line Class

Encapsulates the object that represents the line format.

For a list of all members of this type, see Line Members.

System.Object
Aspose.Cells.Drawing.Line
Aspose.Cells.Charts.ErrorBar
Aspose.Cells.Charts.Trendline

public class Line

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Applying a dotted line style on the lines of an NSeries
chart.NSeries[0].Border.Style = LineType.Dot;
chart.NSeries[0].Border.Color = Color.Red;
//Applying a triangular marker style on the data markers of an NSeries
chart.NSeries[0].MarkerStyle = ChartMarkerType.Triangle;
//Setting the weight of all lines in an NSeries to medium
chart.NSeries[1].Border.Weight = WeightType.MediumLine;
chart.NSeries[1].Border.Color = Color.Green;

[Visual Basic]

'Applying a dotted line style on the lines of an NSeries
chart.NSeries(0).Border.Style = LineType.Dot
chart.NSeries(0).Border.Color = Color.Red
'Applying a triangular marker style on the data markers of an NSeries
chart.NSeries(0).MarkerStyle = ChartMarkerType.Triangle
'Setting the weight of all lines in an NSeries to medium
chart.NSeries(1).Border.Weight = WeightType.MediumLine

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Line Members | Aspose.Cells.Drawing Namespace


Line Members

Line overview

Public Instance Properties

BeginArrowLength | Specifies the length of the arrowhead for the begin of a line.
BeginArrowWidth | Specifies the width of the arrowhead for the begin of a line.
BeginType | Specifies an arrowhead for the begin of a line.
CapType | Specifies the ending caps.
Color | Represents the Color of the line.
CompoundType | Specifies the compound line type
DashType | Specifies the dash line type
EndArrowLength | Specifies the length of the arrowhead for the end of a line.
EndArrowWidth | Specifies the width of the arrowhead for the end of a line.
EndType | Specifies an arrowhead for the end of a line.
FormattingType | Gets or sets format type.
GradientFill | Represents gradient fill.
IsAuto | Indicates whether this line style is auto assigned.
IsAutomaticColor | Indicates whether the color of line is auotmatic assigned.
IsVisible | Represents whether the line is visible.
JoinType | Specifies the joining caps.
Style | Represents the style of the line.
ThemeColor | Gets and sets the theme color.
Transparency | Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).
Weight | Gets or sets the WeightType of the line.
WeightPt | Gets or sets the weight of the line in unit of points.
WeightPx | Gets or sets the weight of the line in unit of pixels.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Line Class | Aspose.Cells.Drawing Namespace


Line Properties

The properties of the Line class are listed below. For a complete list of Line class members, see the Line Members topic.

Public Instance Properties

BeginArrowLength | Specifies the length of the arrowhead for the begin of a line.
BeginArrowWidth | Specifies the width of the arrowhead for the begin of a line.
BeginType | Specifies an arrowhead for the begin of a line.
CapType | Specifies the ending caps.
Color | Represents the Color of the line.
CompoundType | Specifies the compound line type
DashType | Specifies the dash line type
EndArrowLength | Specifies the length of the arrowhead for the end of a line.
EndArrowWidth | Specifies the width of the arrowhead for the end of a line.
EndType | Specifies an arrowhead for the end of a line.
FormattingType | Gets or sets format type.
GradientFill | Represents gradient fill.
IsAuto | Indicates whether this line style is auto assigned.
IsAutomaticColor | Indicates whether the color of line is auotmatic assigned.
IsVisible | Represents whether the line is visible.
JoinType | Specifies the joining caps.
Style | Represents the style of the line.
ThemeColor | Gets and sets the theme color.
Transparency | Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).
Weight | Gets or sets the WeightType of the line.
WeightPt | Gets or sets the weight of the line in unit of points.
WeightPx | Gets or sets the weight of the line in unit of pixels.

See Also

Line Class | Aspose.Cells.Drawing Namespace


BeginArrowLength Property

Aspose.Cells for .NET

Line.BeginArrowLength Property

Specifies the length of the arrowhead for the begin of a line.

public MsoArrowheadLength BeginArrowLength {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


BeginArrowWidth Property

Aspose.Cells for .NET

Line.BeginArrowWidth Property

Specifies the width of the arrowhead for the begin of a line.

public MsoArrowheadWidth BeginArrowWidth {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


BeginType Property

Aspose.Cells for .NET

Line.BeginType Property

Specifies an arrowhead for the begin of a line.

public MsoArrowheadStyle BeginType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


CapType Property

Aspose.Cells for .NET

Line.CapType Property

Specifies the ending caps.

public LineCapType CapType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


Color Property

Aspose.Cells for .NET

Line.Color Property

Represents the Color of the line.

public Color Color {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


CompoundType Property

Aspose.Cells for .NET

Line.CompoundType Property

Specifies the compound line type

public MsoLineStyle CompoundType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


DashType Property

Aspose.Cells for .NET

Line.DashType Property

Specifies the dash line type

public MsoLineDashStyle DashType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


EndArrowLength Property

Aspose.Cells for .NET

Line.EndArrowLength Property

Specifies the length of the arrowhead for the end of a line.

public MsoArrowheadLength EndArrowLength {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


EndArrowWidth Property

Aspose.Cells for .NET

Line.EndArrowWidth Property

Specifies the width of the arrowhead for the end of a line.

public MsoArrowheadWidth EndArrowWidth {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


EndType Property

Aspose.Cells for .NET

Line.EndType Property

Specifies an arrowhead for the end of a line.

public MsoArrowheadStyle EndType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


FormattingType Property

Aspose.Cells for .NET

Line.FormattingType Property

Gets or sets format type.

public ChartLineFormattingType FormattingType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


GradientFill Property

Aspose.Cells for .NET

Line.GradientFill Property

Represents gradient fill.

public GradientFill GradientFill {get;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


IsAuto Property

Aspose.Cells for .NET

Line.IsAuto Property

Indicates whether this line style is auto assigned.

public bool IsAuto {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


IsAutomaticColor Property

Aspose.Cells for .NET

Line.IsAutomaticColor Property

Indicates whether the color of line is auotmatic assigned.

public bool IsAutomaticColor {get;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


IsVisible Property

Aspose.Cells for .NET

Line.IsVisible Property

Represents whether the line is visible.

public bool IsVisible {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


JoinType Property

Aspose.Cells for .NET

Line.JoinType Property

Specifies the joining caps.

public LineJoinType JoinType {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


Style Property

Aspose.Cells for .NET

Line.Style Property

Represents the style of the line.

public LineType Style {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


ThemeColor Property

Aspose.Cells for .NET

Line.ThemeColor Property

Gets and sets the theme color.

public ThemeColor ThemeColor {get; set;}

Remarks

If the foreground color is not a theme color, NULL will be returned.

See Also

Line Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

Line.Transparency Property

Returns or sets the degree of transparency of the line as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


Weight Property

Aspose.Cells for .NET

Line.Weight Property

Gets or sets the WeightType of the line.

public WeightType Weight {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


WeightPt Property

Aspose.Cells for .NET

Line.WeightPt Property

Gets or sets the weight of the line in unit of points.

public double WeightPt {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


WeightPx Property

Aspose.Cells for .NET

Line.WeightPx Property

Gets or sets the weight of the line in unit of pixels.

public double WeightPx {get; set;}

See Also

Line Class | Aspose.Cells.Drawing Namespace


LineCapType Enumeration

Represents the caps of a line

public enum LineCapType

Members

Member Name | Description | Value
Square | Square protrudes by half line width. | 0
Round | Rounded ends. | 1
Flat | Line ends at end point. | 2
None | None cap | 3

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


LineFormat Class

Represents all setting of the line.

For a list of all members of this type, see LineFormat Members.

System.Object
Aspose.Cells.Drawing.FillFormat
Aspose.Cells.Drawing.LineFormat

public class LineFormat : FillFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LineFormat Members | Aspose.Cells.Drawing Namespace


LineFormat Members

LineFormat overview

Public Instance Properties

BeginArrowheadLength | Gets and sets the begin arrow length type of the line.
BeginArrowheadStyle | Gets and sets the begin arrow type of the line.
BeginArrowheadWidth | Gets and sets the begin arrow width type of the line.
CapType | Specifies the ending caps.
CompoundType | Specifies the line compound type.
DashStyle | Specifies the line dash type.
EndArrowheadLength | Gets and sets the end arrow length type of the line.
EndArrowheadStyle | Gets and sets the end arrow type of the line.
EndArrowheadWidth | Gets and sets the end arrow width type of the line.
FillType (inherited from FillFormat) | Gets and sets fill type
GradientColor1 (inherited from FillFormat) | Returns the gradient color 1 for the specified fill.
GradientColor2 (inherited from FillFormat) | Returns the gradient color 2 for the specified fill.
GradientColorType (inherited from FillFormat) | Returns the gradient color type for the specified fill.
GradientDegree (inherited from FillFormat) | Returns the gradient degree for the specified fill. Only applies for Excel 2007.
GradientFill (inherited from FillFormat) | Gets GradientFill object.
GradientStyle (inherited from FillFormat) | Returns the gradient style for the specified fill.
GradientVariant (inherited from FillFormat) | Returns the gradient variant for the specified fill. Only applies for Excel 2007.
ImageData (inherited from FillFormat) | Gets and sets the picture image data.
JoinType | Specifies the line join type.
Pattern (inherited from FillFormat) | Represents an area's display pattern.
PatternFill (inherited from FillFormat) | Gets PatternFill object.
PictureFormatType (inherited from FillFormat) | Gets and sets the picture format type.
PresetColor (inherited from FillFormat) | Returns the gradient preset color for the specified fill.
Scale (inherited from FillFormat) | Gets and sets the picture format scale.
SetType (inherited from FillFormat) | Obsolete. Gets the fill format set type.
SolidFill (inherited from FillFormat) | Gets SolidFill object.
Texture (inherited from FillFormat) | Represents the texture type for the specified fill.
TextureFill (inherited from FillFormat) | Gets TextureFill object.
Transparency (inherited from FillFormat) | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Type (inherited from FillFormat) | Obsolete. Gets and sets the fill type.
Weight | Gets or sets the weight of the line in unit of points.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient (inherited from FillFormat) | Sets the specified fill to a one-color gradient. Only applies for Excel 2007.
SetPresetColorGradient (inherited from FillFormat) | Sets the specified fill to a preset-color gradient. Only applies for Excel 2007.
SetTwoColorGradient (inherited from FillFormat) | Overloaded. Sets the specified fill to a two-color gradient. Only applies for Excel 2007.
ToString (inherited from Object) |

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


LineFormat Properties

The properties of the LineFormat class are listed below. For a complete list of LineFormat class members, see the LineFormat Members topic.

Public Instance Properties

BeginArrowheadLength | Gets and sets the begin arrow length type of the line.
BeginArrowheadStyle | Gets and sets the begin arrow type of the line.
BeginArrowheadWidth | Gets and sets the begin arrow width type of the line.
CapType | Specifies the ending caps.
CompoundType | Specifies the line compound type.
DashStyle | Specifies the line dash type.
EndArrowheadLength | Gets and sets the end arrow length type of the line.
EndArrowheadStyle | Gets and sets the end arrow type of the line.
EndArrowheadWidth | Gets and sets the end arrow width type of the line.
FillType (inherited from FillFormat) | Gets and sets fill type
GradientColor1 (inherited from FillFormat) | Returns the gradient color 1 for the specified fill.
GradientColor2 (inherited from FillFormat) | Returns the gradient color 2 for the specified fill.
GradientColorType (inherited from FillFormat) | Returns the gradient color type for the specified fill.
GradientDegree (inherited from FillFormat) | Returns the gradient degree for the specified fill. Only applies for Excel 2007.
GradientFill (inherited from FillFormat) | Gets GradientFill object.
GradientStyle (inherited from FillFormat) | Returns the gradient style for the specified fill.
GradientVariant (inherited from FillFormat) | Returns the gradient variant for the specified fill. Only applies for Excel 2007.
ImageData (inherited from FillFormat) | Gets and sets the picture image data.
JoinType | Specifies the line join type.
Pattern (inherited from FillFormat) | Represents an area's display pattern.
PatternFill (inherited from FillFormat) | Gets PatternFill object.
PictureFormatType (inherited from FillFormat) | Gets and sets the picture format type.
PresetColor (inherited from FillFormat) | Returns the gradient preset color for the specified fill.
Scale (inherited from FillFormat) | Gets and sets the picture format scale.
SetType (inherited from FillFormat) | Obsolete. Gets the fill format set type.
SolidFill (inherited from FillFormat) | Gets SolidFill object.
Texture (inherited from FillFormat) | Represents the texture type for the specified fill.
TextureFill (inherited from FillFormat) | Gets TextureFill object.
Transparency (inherited from FillFormat) | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Type (inherited from FillFormat) | Obsolete. Gets and sets the fill type.
Weight | Gets or sets the weight of the line in unit of points.

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


BeginArrowheadLength Property

Aspose.Cells for .NET

LineFormat.BeginArrowheadLength Property

Gets and sets the begin arrow length type of the line.

public MsoArrowheadLength BeginArrowheadLength {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


BeginArrowheadStyle Property

Aspose.Cells for .NET

LineFormat.BeginArrowheadStyle Property

Gets and sets the begin arrow type of the line.

public MsoArrowheadStyle BeginArrowheadStyle {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


BeginArrowheadWidth Property

Aspose.Cells for .NET

LineFormat.BeginArrowheadWidth Property

Gets and sets the begin arrow width type of the line.

public MsoArrowheadWidth BeginArrowheadWidth {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


CapType Property

Aspose.Cells for .NET

LineFormat.CapType Property

Specifies the ending caps.

public LineCapType CapType {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


CompoundType Property

Aspose.Cells for .NET

LineFormat.CompoundType Property

Specifies the line compound type.

public MsoLineStyle CompoundType {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


DashStyle Property

Aspose.Cells for .NET

LineFormat.DashStyle Property

Specifies the line dash type.

public MsoLineDashStyle DashStyle {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


EndArrowheadLength Property

Aspose.Cells for .NET

LineFormat.EndArrowheadLength Property

Gets and sets the end arrow length type of the line.

public MsoArrowheadLength EndArrowheadLength {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


EndArrowheadStyle Property

Aspose.Cells for .NET

LineFormat.EndArrowheadStyle Property

Gets and sets the end arrow type of the line.

public MsoArrowheadStyle EndArrowheadStyle {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


EndArrowheadWidth Property

Aspose.Cells for .NET

LineFormat.EndArrowheadWidth Property

Gets and sets the end arrow width type of the line.

public MsoArrowheadWidth EndArrowheadWidth {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


JoinType Property

Aspose.Cells for .NET

LineFormat.JoinType Property

Specifies the line join type.

public LineJoinType JoinType {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


Weight Property

Aspose.Cells for .NET

LineFormat.Weight Property

Gets or sets the weight of the line in unit of points.

public double Weight {get; set;}

See Also

LineFormat Class | Aspose.Cells.Drawing Namespace


LineJoinType Enumeration

Represents the join styles of a line.

public enum LineJoinType

Members

Member Name | Description | Value
Round | Round joint | 0
Bevel | Bevel joint | 1
Miter | Miter joint | 2
None | None joint | 3

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


LineShape Class

Represents the line shape.

For a list of all members of this type, see LineShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.LineShape

public class LineShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate a new Workbook.
Workbook workbook = new Workbook();

//Get the first worksheet in the book.
Worksheet worksheet = workbook.Worksheets[0];

//Add a new line to the worksheet.
Aspose.Cells.LineShape line1 = worksheet.Shapes.AddLine(5, 0, 1, 0, 0, 250);

//Set the line dash style
line1.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Set the placement.
line1.Placement = PlacementType.FreeFloating;

//Add another line to the worksheet.
Aspose.Cells.LineShape line2 = worksheet.Shapes.AddLine(7, 0, 1, 0, 85, 250);

//Set the line dash style.
line2.LineFormat.DashStyle = MsoLineDashStyle.DashLongDash;

//Set the weight of the line.
line2.LineFormat.Weight = 4;

//Set the placement.
line2.Placement = PlacementType.FreeFloating;

//Add the third line to the worksheet.
Aspose.Cells.LineShape line3 = worksheet.Shapes.AddLine(13, 0, 1, 0, 0, 250);

//Set the line dash style
line3.LineFormat.DashStyle = MsoLineDashStyle.Solid;

//Set the placement.
line3.Placement = PlacementType.FreeFloating;

//Make the gridlines invisible in the first worksheet.
workbook.Worksheets[0].IsGridlinesVisible = false;

//Save the excel file.
workbook.Save("d:\\test\\tstlines.xls");

[VB.NET]

'Instantiate a new Workbook.
Dim workbook As Workbook = New Workbook()

'Get the first worksheet in the book.
Dim worksheet As Worksheet = workbook.Worksheets(0)

'Add a new line to the worksheet.
Dim line1 As Aspose.Cells.LineShape = worksheet.Shapes.AddLine(5, 0, 1, 0, 0, 250)

'Set the line dash style
line1.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Set the placement.
line1.Placement = PlacementType.FreeFloating

'Add another line to the worksheet.
Dim line2 As Aspose.Cells.LineShape = worksheet.Shapes.AddLine(7, 0, 1, 0, 85, 250)

'Set the line dash style.
line2.LineFormat.DashStyle = MsoLineDashStyle.DashLongDash

'Set the weight of the line.
line2.LineFormat.Weight = 4

'Set the placement.
line2.Placement = PlacementType.FreeFloating

'Add the third line to the worksheet.
Dim line3 As Aspose.Cells.LineShape = worksheet.Shapes.AddLine(13, 0, 1, 0, 0, 250)

'Set the line dash style
line3.LineFormat.DashStyle = MsoLineDashStyle.Solid

'Set the placement.
line3.Placement = PlacementType.FreeFloating

'Make the gridlines invisible in the first worksheet.
workbook.Worksheets(0).IsGridlinesVisible = False

'Save the excel file.
workbook.Save("d:\test\tstlines.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LineShape Members | Aspose.Cells.Drawing Namespace


LineShape Members

LineShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
BeginArrowheadLength | Obsolete. Gets and sets the begin arrow head length of the line.
BeginArrowheadStyle | Obsolete. Gets and sets the begin arrow head style of the line.
BeginArrowheadWidth | Obsolete. Gets and sets the begin arrow head width of the line.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
EndArrowheadLength | Obsolete. Gets and sets the end arrow head length of the line.
EndArrowheadStyle | Obsolete. Gets and sets the end arrow head style of the line.
EndArrowheadWidth | Obsolete. Gets and sets the end arrow head width of the line.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


LineShape Properties

The properties of the LineShape class are listed below. For a complete list of LineShape class members, see the LineShape Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
BeginArrowheadLength | Obsolete. Gets and sets the begin arrow head length of the line.
BeginArrowheadStyle | Obsolete. Gets and sets the begin arrow head style of the line.
BeginArrowheadWidth | Obsolete. Gets and sets the begin arrow head width of the line.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
EndArrowheadLength | Obsolete. Gets and sets the end arrow head length of the line.
EndArrowheadStyle | Obsolete. Gets and sets the end arrow head style of the line.
EndArrowheadWidth | Obsolete. Gets and sets the end arrow head width of the line.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


BeginArrowheadLength Property

Aspose.Cells for .NET

LineShape.BeginArrowheadLength Property

NOTE: This property is now obsolete.

Use Shape.Line.BeginArrowheadLength property instead.

Gets and sets the begin arrow head length of the line.

public MsoArrowheadLength BeginArrowheadLength {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.BeginArrowheadLength property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


BeginArrowheadStyle Property

Aspose.Cells for .NET

LineShape.BeginArrowheadStyle Property

NOTE: This property is now obsolete.

Use Shape.Line.BeginArrowheadStyle property instead.

Gets and sets the begin arrow head style of the line.

public MsoArrowheadStyle BeginArrowheadStyle {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.BeginArrowheadStyle property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


BeginArrowheadWidth Property

Aspose.Cells for .NET

LineShape.BeginArrowheadWidth Property

NOTE: This property is now obsolete.

Use Shape.Line.BeginArrowheadWidth property instead.

Gets and sets the begin arrow head width of the line.

public MsoArrowheadWidth BeginArrowheadWidth {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.BeginArrowheadWidth property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


EndArrowheadLength Property

Aspose.Cells for .NET

LineShape.EndArrowheadLength Property

NOTE: This property is now obsolete.

Use Shape.Line.EndArrowheadLength property instead.

Gets and sets the end arrow head length of the line.

public MsoArrowheadLength EndArrowheadLength {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.EndArrowheadLength property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


EndArrowheadStyle Property

Aspose.Cells for .NET

LineShape.EndArrowheadStyle Property

NOTE: This property is now obsolete.

Use Shape.Line.EndArrowheadStyle property instead.

Gets and sets the end arrow head style of the line.

public MsoArrowheadStyle EndArrowheadStyle {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.EndArrowheadStyle property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


EndArrowheadWidth Property

Aspose.Cells for .NET

LineShape.EndArrowheadWidth Property

NOTE: This property is now obsolete.

Use Shape.Line.EndArrowheadWidth property instead.

Gets and sets the end arrow head width of the line.

public MsoArrowheadWidth EndArrowheadWidth {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line.EndArrowheadWidth property. This property will be removed 12 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

LineShape Class | Aspose.Cells.Drawing Namespace


LineType Enumeration

Enumerates the type of Picture border or Chart line.

public enum LineType

Members

Member Name | Description | Value
DarkGray | Represents a dark gray line. | 6
Dash | Represent a dash line. | 1
DashDot | Represents a dash-dot line | 3
DashDotDot | Represents a dash-dot-dot line. | 4
Dot | Represents a dotted line. | 2
LightGray | Represents a light gray line. | 8
MediumGray | Represents a medium gray line. | 7
Solid | Represent a solid line. | 0

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ListBox Class

Represents a list box object.

For a list of all members of this type, see ListBox Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.ListBox

public class ListBox : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Create a new Workbook.
Workbook workbook = new Workbook();

//Get the first worksheet.
Worksheet sheet = workbook.Worksheets[0];

//Get the worksheet cells collection.
Cells cells = sheet.Cells;

//Input a value.
cells["B3"].PutValue("Choose Dept:");

//Set it bold.
cells["B3"].Style.Font.IsBold = true;

//Input some values that denote the input range
//for the list box.
cells["A2"].PutValue("Sales");
cells["A3"].PutValue("Finance");
cells["A4"].PutValue("MIS");
cells["A5"].PutValue("R&D");
cells["A6"].PutValue("Marketing");
cells["A7"].PutValue("HRA");

//Add a new list box.
ListBox listBox = sheet.Shapes.AddListBox(2, 0, 3, 0, 122, 100);

//Set the placement type.
listBox.Placement = PlacementType.FreeFloating;

//Set the linked cell.
listBox.LinkedCell = "A1";

//Set the input range.
listBox.InputRange = "A2:A7";

//Set the selection tyle.
listBox.SelectionType = SelectionType.Single;

//Set the list box with 3-D shading.
listBox.Shadow = true;

//Saves the file.
workbook.Save(@"d:\test\tstlistbox.xls");

[VB.NET]

'Create a new Workbook.
Dim workbook As Aspose.Cells.Workbook = New Aspose.Cells.Workbook()

'Get the first worksheet.
Dim sheet As Worksheet = workbook.Worksheets(0)

'Get the worksheet cells collection.
Dim cells As Cells = sheet.Cells

'Input a value.
cells("B3").PutValue("Choose Dept:")

'Set it bold.
cells("B3").Style.Font.IsBold = True

'Input some values that denote the input range
'for the list box.
cells("A2").PutValue("Sales")
cells("A3").PutValue("Finance")
cells("A4").PutValue("MIS")
cells("A5").PutValue("R&D")
cells("A6").PutValue("Marketing")
cells("A7").PutValue("HRA")

'Add a new list box.
Dim listBox As Aspose.Cells.ListBox = sheet.Shapes.AddListBox(2, 0, 3, 0, 122, 100)

'Set the placement type.
listBox.Placement = PlacementType.FreeFloating

'Set the linked cell.
listBox.LinkedCell = "A1"

'Set the input range.
listBox.InputRange = "A2:A7"

'Set the selection tyle.
listBox.SelectionType = SelectionType.Single

'Set the list box with 3-D shading.
listBox.Shadow = True

'Saves the file.
workbook.Save("d:\test\tstlistbox.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ListBox Members | Aspose.Cells.Drawing Namespace


ListBox Members

ListBox overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
ItemCount | Gets the number of items in the list box.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
PageChange | Specifies the amount by which the control's value is changed when the user clicks on the scrollbar's page up or page down region.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
SelectedCells | Gets the selected cells. Returns null if the input range is not set or no item is selected
SelectedIndex | Gets or sets the index number of the currently selected item in a list box or combo box. Zero-based.
SelectionType | Gets or sets the selection mode of the specified list box.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
IsSelected | Indicates whether the item is selected.
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SelectedItem | Sets whether the item is selected
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


ListBox Properties

The properties of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
ItemCount | Gets the number of items in the list box.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
PageChange | Specifies the amount by which the control's value is changed when the user clicks on the scrollbar's page up or page down region.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
SelectedCells | Gets the selected cells. Returns null if the input range is not set or no item is selected
SelectedIndex | Gets or sets the index number of the currently selected item in a list box or combo box. Zero-based.
SelectionType | Gets or sets the selection mode of the specified list box.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


ItemCount Property

Aspose.Cells for .NET

ListBox.ItemCount Property

Gets the number of items in the list box.

public int ItemCount {get;}

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


PageChange Property

Aspose.Cells for .NET

ListBox.PageChange Property

Specifies the amount by which the control's value is changed when the user clicks on the scrollbar's page up or page down region.

public int PageChange {get; set;}

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


SelectedCells Property

Aspose.Cells for .NET

ListBox.SelectedCells Property

Gets the selected cells. Returns null if the input range is not set or no item is selected

public Cell[] SelectedCells {get;}

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


SelectedIndex Property

Aspose.Cells for .NET

ListBox.SelectedIndex Property

Gets or sets the index number of the currently selected item in a list box or combo box. Zero-based.

public int SelectedIndex {get; set;}

Remarks

-1 presents no item is selected.

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


SelectionType Property

Aspose.Cells for .NET

ListBox.SelectionType Property

Gets or sets the selection mode of the specified list box.

public SelectionType SelectionType {get; set;}

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

ListBox.Shadow Property

Indicates whether the combobox has 3-D shading.

public bool Shadow {get; set;}

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


ListBox Methods

The methods of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
IsSelected | Indicates whether the item is selected.
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SelectedItem | Sets whether the item is selected
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


ListBox.IsSelected Method

Indicates whether the item is selected.

public bool IsSelected(
int itemIndex
);

Parameters

itemIndex
The item index.

Return Value

whether the item is selected.

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


ListBox.SelectedItem Method

Sets whether the item is selected

public void SelectedItem(
int itemIndex,
bool isSelected
);

Parameters

itemIndex
The item index
isSelected
Whether the item is selected. True means that this item should be selected. False means that this item should be unselected.

See Also

ListBox Class | Aspose.Cells.Drawing Namespace


MirrorType Enumeration

Represents mirror type of texture fill

public enum MirrorType

Members

Member Name | Description | Value
None | None | 0
Horizonal | Horizonal | 1
Vertical | Vertical | 2
Both | Both | 3

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoArrowheadLength Enumeration

Enumerates the line end width of the shape border line.

public enum MsoArrowheadLength

Members

Member Name | Description | Value
Short | Short line end length | 0
Medium | Medium line end length | 1
Long | Long line end length | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoArrowheadStyle Enumeration

Enumerates the line end type of the shape border line.

public enum MsoArrowheadStyle

Members

Member Name | Description | Value
None | No line end type. | 0
Arrow | Arrow line end type. | 1
ArrowStealth | Arrow Stealth line end type. | 2
ArrowDiamond | Arrow Diamond Line end type. | 3
ArrowOval | Arrow Oval line end type. | 4
ArrowOpen | Arrow Open line end type. | 5

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoArrowheadWidth Enumeration

Enumerates the line end width of the shape border line.

public enum MsoArrowheadWidth

Members

Member Name | Description | Value
Narrow | Short line end width. | 0
Medium | Medium line end width. | 1
Wide | Wide line end width. | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoDrawingType Enumeration

Represents office drawing objects type.

public enum MsoDrawingType

Members

Member Name | Description | Value
Group | Group | 0
Line | Line | 1
Rectangle | Rectangle | 2
Oval | Oval | 3
Arc | Arc | 4
Chart | Chart | 5
TextBox | TextBox | 6
Button | Button | 7
Picture | Picture | 8
Polygon | Polygon | 9
CheckBox | CheckBox | 11
RadioButton | RadioButton | 12
Label | Label | 14
DialogBox | DialogBox | 15
Spinner | Spinner | 16
ScrollBar | ScrollBar | 17
ListBox | ListBox | 18
GroupBox | GroupBox | 19
ComboBox | ComboBox | 20
Comment | Comment | 25
OleObject | OleObject | 24
CellsDrawing | Only for preserving the drawing object in the template file. | 30
Unknown | Only for preserving the drawing object in the xlsx file. | 29
Slicer | Slicer | 31
WebExtension | Web extension | 32
SmartArt | Smart Art | 33
CustomXml | Custom xml shape ,such as Ink. | 34
Model3D | 3D Model | 35

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoFillFormat Class

Represents fill formatting for a shape.

For a list of all members of this type, see MsoFillFormat Members.

System.Object
Aspose.Cells.Drawing.MsoFillFormat

public class MsoFillFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MsoFillFormat Members | Aspose.Cells.Drawing Namespace


MsoFillFormat Members

MsoFillFormat overview

Public Instance Properties

BackColor | Gets and sets the file back color.
ForeColor | Gets and sets the fill fore color.
ImageData | Gets and sets the Texture and Picture fill data.
IsVisible | Indicates whether there is fill.
Texture | Gets the texture fill type.
Transparency | Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient | Sets the specified fill to a one-color gradient.
ToString (inherited from Object) |

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


MsoFillFormat Properties

The properties of the MsoFillFormat class are listed below. For a complete list of MsoFillFormat class members, see the MsoFillFormat Members topic.

Public Instance Properties

BackColor | Gets and sets the file back color.
ForeColor | Gets and sets the fill fore color.
ImageData | Gets and sets the Texture and Picture fill data.
IsVisible | Indicates whether there is fill.
Texture | Gets the texture fill type.
Transparency | Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


BackColor Property

Aspose.Cells for .NET

MsoFillFormat.BackColor Property

Gets and sets the file back color.

public Color BackColor {get; set;}

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


ForeColor Property

Aspose.Cells for .NET

MsoFillFormat.ForeColor Property

Gets and sets the fill fore color.

public Color ForeColor {get; set;}

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


ImageData Property

Aspose.Cells for .NET

MsoFillFormat.ImageData Property

Gets and sets the Texture and Picture fill data.

public byte[] ImageData {get; set;}

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


IsVisible Property

Aspose.Cells for .NET

MsoFillFormat.IsVisible Property

Indicates whether there is fill.

public bool IsVisible {get; set;}

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


Texture Property

Aspose.Cells for .NET

MsoFillFormat.Texture Property

Gets the texture fill type.

public TextureType Texture {get;}

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

MsoFillFormat.Transparency Property

Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


MsoFillFormat Methods

The methods of the MsoFillFormat class are listed below. For a complete list of MsoFillFormat class members, see the MsoFillFormat Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient | Sets the specified fill to a one-color gradient.
ToString (inherited from Object) |

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


MsoFillFormat.SetOneColorGradient Method

Sets the specified fill to a one-color gradient.

public void SetOneColorGradient(
Color color,
double degree,
GradientStyleType style,
int variant
);

Parameters

color
One gradient color.
degree
The gradient degree. Can be a value from 0.0 (dark) through 1.0 (light).
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

MsoFillFormat Class | Aspose.Cells.Drawing Namespace


MsoFillFormatHelper Class

Represents fill formatting for a shape.

For a list of all members of this type, see MsoFillFormatHelper Members.

System.Object
Aspose.Cells.Drawing.MsoFillFormatHelper

public class MsoFillFormatHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MsoFillFormatHelper Members | Aspose.Cells.Drawing Namespace


MsoFillFormatHelper Members

MsoFillFormatHelper overview

Public Instance Properties

BackColor | Gets and sets the file back color.
ForeColor | Gets and sets the fill fore color.
ForeColorTransparency | Returns or sets the degree of fore color of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).
ImageData | Gets and sets the Texture and Picture fill data.
IsVisible | Indicates whether there is fill.
Texture | Gets the texture fill type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient | Sets the specified fill to a one-color gradient.
ToString (inherited from Object) |

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


MsoFillFormatHelper Properties

The properties of the MsoFillFormatHelper class are listed below. For a complete list of MsoFillFormatHelper class members, see the MsoFillFormatHelper Members topic.

Public Instance Properties

BackColor | Gets and sets the file back color.
ForeColor | Gets and sets the fill fore color.
ForeColorTransparency | Returns or sets the degree of fore color of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).
ImageData | Gets and sets the Texture and Picture fill data.
IsVisible | Indicates whether there is fill.
Texture | Gets the texture fill type.

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


BackColor Property

Aspose.Cells for .NET

MsoFillFormatHelper.BackColor Property

Gets and sets the file back color.

public Color BackColor {get; set;}

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


ForeColor Property

Aspose.Cells for .NET

MsoFillFormatHelper.ForeColor Property

Gets and sets the fill fore color.

public Color ForeColor {get; set;}

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


ForeColorTransparency Property

Aspose.Cells for .NET

MsoFillFormatHelper.ForeColorTransparency Property

Returns or sets the degree of fore color of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).

public double ForeColorTransparency {get; set;}

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


ImageData Property

Aspose.Cells for .NET

MsoFillFormatHelper.ImageData Property

Gets and sets the Texture and Picture fill data.

public byte[] ImageData {get; set;}

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


IsVisible Property

Aspose.Cells for .NET

MsoFillFormatHelper.IsVisible Property

Indicates whether there is fill.

public bool IsVisible {get; set;}

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


Texture Property

Aspose.Cells for .NET

MsoFillFormatHelper.Texture Property

Gets the texture fill type.

public TextureType Texture {get;}

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


MsoFillFormatHelper Methods

The methods of the MsoFillFormatHelper class are listed below. For a complete list of MsoFillFormatHelper class members, see the MsoFillFormatHelper Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetOneColorGradient | Sets the specified fill to a one-color gradient.
ToString (inherited from Object) |

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


MsoFillFormatHelper.SetOneColorGradient Method

Sets the specified fill to a one-color gradient.

public void SetOneColorGradient(
Color color,
double degree,
GradientStyleType style,
int variant
);

Parameters

color
One gradient color.
degree
The gradient degree. Can be a value from 0.0 (dark) through 1.0 (light).
style
Gradient shading style.
variant
The gradient variant. Can be a value from 1 through 4, corresponding to one of the four variants on the Gradient tab in the Fill Effects dialog box. If style is GradientStyle.FromCenter, the Variant argument can only be 1 or 2.

See Also

MsoFillFormatHelper Class | Aspose.Cells.Drawing Namespace


MsoFormatPicture Class

Represents the picture format.

For a list of all members of this type, see MsoFormatPicture Members.

System.Object
Aspose.Cells.Drawing.MsoFormatPicture

public class MsoFormatPicture

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MsoFormatPicture Members | Aspose.Cells.Drawing Namespace


MsoFormatPicture Members

MsoFormatPicture overview

Public Instance Properties

BottomCrop | Represents the location of the bottom of the crop rectangle expressed, expressed as a ratio of the image's height.
Brightness | Represents the brightness modification for the picture in unit of percentage.
Contrast | Represents the contrast modification for the picture.in unit of percentage.
Gamma | Represents gamma of the picture.
IsBiLevel | Indicates whether this picture should be displayed in two-color black and white.
IsGray | Indicates whether this picture SHOULD be displayed in grayscale.
LeftCrop | Represents the location of the left of the crop rectangle expressed, expressed as a ratio of the image's width.
RightCrop | Represents the location of the right of the crop rectangle expressed, expressed as a ratio of the image's width.
TopCrop | Represents the location of the top of the crop rectangle expressed, expressed as a ratio of the image's height.
TransparentColor | Gets and sets the transparent color of the picture.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


MsoFormatPicture Properties

The properties of the MsoFormatPicture class are listed below. For a complete list of MsoFormatPicture class members, see the MsoFormatPicture Members topic.

Public Instance Properties

BottomCrop | Represents the location of the bottom of the crop rectangle expressed, expressed as a ratio of the image's height.
Brightness | Represents the brightness modification for the picture in unit of percentage.
Contrast | Represents the contrast modification for the picture.in unit of percentage.
Gamma | Represents gamma of the picture.
IsBiLevel | Indicates whether this picture should be displayed in two-color black and white.
IsGray | Indicates whether this picture SHOULD be displayed in grayscale.
LeftCrop | Represents the location of the left of the crop rectangle expressed, expressed as a ratio of the image's width.
RightCrop | Represents the location of the right of the crop rectangle expressed, expressed as a ratio of the image's width.
TopCrop | Represents the location of the top of the crop rectangle expressed, expressed as a ratio of the image's height.
TransparentColor | Gets and sets the transparent color of the picture.

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


BottomCrop Property

Aspose.Cells for .NET

MsoFormatPicture.BottomCrop Property

Represents the location of the bottom of the crop rectangle expressed, expressed as a ratio of the image's height.

public double BottomCrop {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


Brightness Property

Aspose.Cells for .NET

MsoFormatPicture.Brightness Property

Represents the brightness modification for the picture in unit of percentage.

public double Brightness {get; set;}

Remarks

It is between -100% and 100%. It works same as Excel 2007 or above version.

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


Contrast Property

Aspose.Cells for .NET

MsoFormatPicture.Contrast Property

Represents the contrast modification for the picture.in unit of percentage.

public double Contrast {get; set;}

Remarks

It is between -100% and 100%. It works same as Excel 2007 or above version.

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


Gamma Property

Aspose.Cells for .NET

MsoFormatPicture.Gamma Property

Represents gamma of the picture.

public double Gamma {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


IsBiLevel Property

Aspose.Cells for .NET

MsoFormatPicture.IsBiLevel Property

Indicates whether this picture should be displayed in two-color black and white.

public bool IsBiLevel {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


IsGray Property

Aspose.Cells for .NET

MsoFormatPicture.IsGray Property

Indicates whether this picture SHOULD be displayed in grayscale.

public bool IsGray {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


LeftCrop Property

Aspose.Cells for .NET

MsoFormatPicture.LeftCrop Property

Represents the location of the left of the crop rectangle expressed, expressed as a ratio of the image's width.

public double LeftCrop {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


RightCrop Property

Aspose.Cells for .NET

MsoFormatPicture.RightCrop Property

Represents the location of the right of the crop rectangle expressed, expressed as a ratio of the image's width.

public double RightCrop {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


TopCrop Property

Aspose.Cells for .NET

MsoFormatPicture.TopCrop Property

Represents the location of the top of the crop rectangle expressed, expressed as a ratio of the image's height.

public double TopCrop {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


TransparentColor Property

Aspose.Cells for .NET

MsoFormatPicture.TransparentColor Property

Gets and sets the transparent color of the picture.

public CellsColor TransparentColor {get; set;}

See Also

MsoFormatPicture Class | Aspose.Cells.Drawing Namespace


MsoLineDashStyle Enumeration

Represents style of dash drawing lines.

public enum MsoLineDashStyle

Members

Member Name | Description | Value
Dash | Represent a dash line. | 0
DashDot | Represents a dash-dot line. | 1
DashDotDot | Represents a dash-dot-dot line. | 2
DashLongDash | Represents a long dash-short dash line. | 3
DashLongDashDot | Represents a long dash-short dash-dot line. | 4
RoundDot | Represents a round-dot line. | 5
Solid | Represent a solid line. | 6
SquareDot | Represents a square-dot line. | 7
Custom | Custom dash style. | 8

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoLineFormat Class

Represents line and arrowhead formatting.

For a list of all members of this type, see MsoLineFormat Members.

System.Object
Aspose.Cells.Drawing.MsoLineFormat

public class MsoLineFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MsoLineFormat Members | Aspose.Cells.Drawing Namespace


MsoLineFormat Members

MsoLineFormat overview

Public Instance Properties

BackColor | Gets and sets the border line back color.
DashStyle | Gets or sets the dash style for the specified line.
ForeColor | Gets and sets the border line fore color.
IsVisible | Indicates whether the object is visible.
Style | Returns a Style object that represents the style of the specified range.
Transparency | Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).
Weight | Returns or sets the weight of the line ,in units of pt.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


MsoLineFormat Properties

The properties of the MsoLineFormat class are listed below. For a complete list of MsoLineFormat class members, see the MsoLineFormat Members topic.

Public Instance Properties

BackColor | Gets and sets the border line back color.
DashStyle | Gets or sets the dash style for the specified line.
ForeColor | Gets and sets the border line fore color.
IsVisible | Indicates whether the object is visible.
Style | Returns a Style object that represents the style of the specified range.
Transparency | Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).
Weight | Returns or sets the weight of the line ,in units of pt.

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


BackColor Property

Aspose.Cells for .NET

MsoLineFormat.BackColor Property

Gets and sets the border line back color.

public Color BackColor {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


DashStyle Property

Aspose.Cells for .NET

MsoLineFormat.DashStyle Property

Gets or sets the dash style for the specified line.

public MsoLineDashStyle DashStyle {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


ForeColor Property

Aspose.Cells for .NET

MsoLineFormat.ForeColor Property

Gets and sets the border line fore color.

public Color ForeColor {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


IsVisible Property

Aspose.Cells for .NET

MsoLineFormat.IsVisible Property

Indicates whether the object is visible.

public bool IsVisible {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


Style Property

Aspose.Cells for .NET

MsoLineFormat.Style Property

Returns a Style object that represents the style of the specified range.

public MsoLineStyle Style {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

MsoLineFormat.Transparency Property

Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


Weight Property

Aspose.Cells for .NET

MsoLineFormat.Weight Property

Returns or sets the weight of the line ,in units of pt.

public double Weight {get; set;}

See Also

MsoLineFormat Class | Aspose.Cells.Drawing Namespace


MsoLineFormatHelper Class

Represents line and arrowhead formatting.

For a list of all members of this type, see MsoLineFormatHelper Members.

System.Object
Aspose.Cells.Drawing.MsoLineFormatHelper

public class MsoLineFormatHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MsoLineFormatHelper Members | Aspose.Cells.Drawing Namespace


MsoLineFormatHelper Members

MsoLineFormatHelper overview

Public Instance Properties

BackColor | Gets and sets the border line back color.
DashStyle | Gets or sets the dash style for the specified line.
ForeColor | Gets and sets the border line fore color.
IsVisible | Indicates whether the object is visible.
Style | Returns a Style object that represents the style of the specified range.
Transparency | Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).
Weight | Returns or sets the weight of the line ,in units of pt.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


MsoLineFormatHelper Properties

The properties of the MsoLineFormatHelper class are listed below. For a complete list of MsoLineFormatHelper class members, see the MsoLineFormatHelper Members topic.

Public Instance Properties

BackColor | Gets and sets the border line back color.
DashStyle | Gets or sets the dash style for the specified line.
ForeColor | Gets and sets the border line fore color.
IsVisible | Indicates whether the object is visible.
Style | Returns a Style object that represents the style of the specified range.
Transparency | Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).
Weight | Returns or sets the weight of the line ,in units of pt.

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


BackColor Property

Aspose.Cells for .NET

MsoLineFormatHelper.BackColor Property

Gets and sets the border line back color.

public Color BackColor {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


DashStyle Property

Aspose.Cells for .NET

MsoLineFormatHelper.DashStyle Property

Gets or sets the dash style for the specified line.

public MsoLineDashStyle DashStyle {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


ForeColor Property

Aspose.Cells for .NET

MsoLineFormatHelper.ForeColor Property

Gets and sets the border line fore color.

public Color ForeColor {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


IsVisible Property

Aspose.Cells for .NET

MsoLineFormatHelper.IsVisible Property

Indicates whether the object is visible.

public bool IsVisible {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


Style Property

Aspose.Cells for .NET

MsoLineFormatHelper.Style Property

Returns a Style object that represents the style of the specified range.

public MsoLineStyle Style {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

MsoLineFormatHelper.Transparency Property

Returns or sets the degree of transparency of the specified fill as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


Weight Property

Aspose.Cells for .NET

MsoLineFormatHelper.Weight Property

Returns or sets the weight of the line ,in units of pt.

public double Weight {get; set;}

See Also

MsoLineFormatHelper Class | Aspose.Cells.Drawing Namespace


MsoLineStyle Enumeration

Represents style of drawing lines.

public enum MsoLineStyle

Members

Member Name | Description | Value
Single | Single line (of width lineWidth) | 0
ThickBetweenThin | Three lines, thin, thick, thin | 1
ThinThick | Double lines, one thin, one thick | 2
ThickThin | Double lines, one thick, one thin | 3
ThinThin | Double lines of equal width | 4

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoPresetTextEffect Enumeration

Represents preset text effect type of WordArt.

public enum MsoPresetTextEffect

Members

Member Name | Description | Value
TextEffect1 | TextEffect1 | 0
TextEffect2 | TextEffect2 | 1
TextEffect3 | TextEffect3 | 2
TextEffect4 | TextEffect4 | 3
TextEffect5 | TextEffect5 | 4
TextEffect6 | TextEffect6 | 5
TextEffect7 | TextEffect7 | 6
TextEffect8 | TextEffect8 | 7
TextEffect9 | TextEffect9 | 8
TextEffect10 | TextEffect10 | 9
TextEffect11 | TextEffect11 | 10
TextEffect12 | TextEffect12 | 11
TextEffect13 | TextEffect13 | 12
TextEffect14 | TextEffect14 | 13
TextEffect15 | TextEffect15 | 14
TextEffect16 | TextEffect16 | 15
TextEffect17 | TextEffect17 | 16
TextEffect18 | TextEffect18 | 17
TextEffect19 | TextEffect19 | 18
TextEffect20 | TextEffect20 | 19
TextEffect21 | TextEffect21 | 20
TextEffect22 | TextEffect22 | 21
TextEffect23 | TextEffect23 | 22
TextEffect24 | TextEffect24 | 23
TextEffect25 | TextEffect25 | 24
TextEffect26 | TextEffect26 | 25
TextEffect27 | TextEffect27 | 26
TextEffect28 | TextEffect28 | 27
TextEffect29 | TextEffect29 | 28
TextEffect30 | TextEffect30 | 29

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoPresetTextEffectShape Enumeration

Represents preset text effect shape type of WordArt.

public enum MsoPresetTextEffectShape

Members

Member Name | Description | Value
PlainText | PlainText | 136
Stop | Stop | 137
TriangleUp | TriangleUp | 138
TriangleDown | TriangleDown | 139
ChevronUp | ChevronUp | 140
ChevronDown | ChevronDown | 141
RingInside | RingInside | 142
RingOutside | RingOutside | 143
ArchUpCurve | ArchUpCurve | 144
ArchDownCurve | ArchDownCurve | 145
CircleCurve | CircleCurve | 146
ButtonCurve | ButtonCurve | 147
ArchUpPour | ArchUpPour | 148
ArchDownPour | ArchDownPour | 149
CirclePour | CirclePour | 150
ButtonPour | ButtonPour | 151
CurveUp | CurveUp | 152
CurveDown | CurveDown | 153
CanUp | CanUp | 174
CanDown | CanDown | 175
Wave1 | Wave1 | 156
Wave2 | Wave2 | 157
DoubleWave1 | DoubleWave1 | 158
DoubleWave2 | DoubleWave2 | 159
Inflate | Inflate | 160
Deflate | Deflate | 161
InflateBottom | InflateBottom | 162
DeflateBottom | DeflateBottom | 163
InflateTop | InflateTop | 164
DeflateTop | DeflateTop | 165
DeflateInflate | DeflateInflate | 166
DeflateInflateDeflate | DeflateInflateDeflate | 167
FadeRight | FadeRight | 168
FadeLeft | FadeLeft | 169
FadeUp | FadeUp | 170
FadeDown | FadeDown | 171
SlantUp | SlantUp | 172
SlantDown | SlantDown | 173
CascadeUp | CascadeUp | 154
CascadeDown | CascadeDown | 155
Mixed | Mixed | 255

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


MsoTextFrame Class

Represents the text frame in a Shape object.

For a list of all members of this type, see MsoTextFrame Members.

System.Object
Aspose.Cells.Drawing.MsoTextFrame

public class MsoTextFrame

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MsoTextFrame Members | Aspose.Cells.Drawing Namespace


MsoTextFrame Members

MsoTextFrame overview

Public Instance Properties

AutoSize | Indicates if size of shape is adjusted automatically according to its content.
BottomMarginPt | Returns the bottom margin in unit of Points
IsAutoMargin | Indicates whether the margin is auto calculated.
LeftMarginPt | Returns the left margin in unit of Points
RightMarginPt | Returns the right margin in unit of Points
RotateTextWithShape | Indicates whether rotating text with shape.
TopMarginPt | Returns the top margin in unit of Points

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


MsoTextFrame Properties

The properties of the MsoTextFrame class are listed below. For a complete list of MsoTextFrame class members, see the MsoTextFrame Members topic.

Public Instance Properties

AutoSize | Indicates if size of shape is adjusted automatically according to its content.
BottomMarginPt | Returns the bottom margin in unit of Points
IsAutoMargin | Indicates whether the margin is auto calculated.
LeftMarginPt | Returns the left margin in unit of Points
RightMarginPt | Returns the right margin in unit of Points
RotateTextWithShape | Indicates whether rotating text with shape.
TopMarginPt | Returns the top margin in unit of Points

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


AutoSize Property

Aspose.Cells for .NET

MsoTextFrame.AutoSize Property

Indicates if size of shape is adjusted automatically according to its content.

public bool AutoSize {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


BottomMarginPt Property

Aspose.Cells for .NET

MsoTextFrame.BottomMarginPt Property

Returns the bottom margin in unit of Points

public double BottomMarginPt {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


IsAutoMargin Property

Aspose.Cells for .NET

MsoTextFrame.IsAutoMargin Property

Indicates whether the margin is auto calculated.

public bool IsAutoMargin {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


LeftMarginPt Property

Aspose.Cells for .NET

MsoTextFrame.LeftMarginPt Property

Returns the left margin in unit of Points

public double LeftMarginPt {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


RightMarginPt Property

Aspose.Cells for .NET

MsoTextFrame.RightMarginPt Property

Returns the right margin in unit of Points

public double RightMarginPt {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


RotateTextWithShape Property

Aspose.Cells for .NET

MsoTextFrame.RotateTextWithShape Property

Indicates whether rotating text with shape.

public bool RotateTextWithShape {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


TopMarginPt Property

Aspose.Cells for .NET

MsoTextFrame.TopMarginPt Property

Returns the top margin in unit of Points

public double TopMarginPt {get; set;}

See Also

MsoTextFrame Class | Aspose.Cells.Drawing Namespace


NoneFill Class

Represents no fill.

For a list of all members of this type, see NoneFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.NoneFill

public class NoneFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

NoneFill Members | Aspose.Cells.Drawing Namespace


NoneFill Members

NoneFill overview

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

NoneFill Class | Aspose.Cells.Drawing Namespace


OleFileType Enumeration

NOTE: This enumeration is now obsolete.

Use FileFormatType enum instead.

public enum OleFileType

Members

Member Name | Description | Value
Xls |  | 0
Doc |  | 1
Ppt |  | 2
Pdf |  | 3
MSEquation |  | 4
MapiMessage |  | 5
Xlsx |  | 6
Xlsb |  | 7
Docx |  | 8
Pptx |  | 9
Unknown |  | 10

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


OleObject Class

Represents an OleObject in a worksheet.

For a list of all members of this type, see OleObject Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.OleObject

public class OleObject : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Instantiate a new Workbook.
Workbook workbook = new Workbook();
//Get the first worksheet.
Worksheet sheet = workbook.Worksheets[0];
//Define a string variable to store the image path.
string ImageUrl = @"C:\school.jpg";
//Get the picture into the streams.
FileStream fs = File.OpenRead(ImageUrl);
//Define a byte array.
byte[] imageData = new Byte[fs.Length];
//Obtain the picture into the array of bytes from streams.
fs.Read(imageData, 0, imageData.Length);
//Close the stream.
fs.Close();
//Get an excel file path in a variable.
string path = @"C:\Book1.xls";
//Get the file into the streams.
fs = File.OpenRead(path);
//Define an array of bytes.
byte[] objectData = new Byte[fs.Length];
//Store the file from streams.
fs.Read(objectData, 0, objectData.Length);
//Close the stream.
fs.Close();
//Add an Ole object into the worksheet with the image
//shown in MS Excel.
sheet.OleObjects.Add(14, 3, 200, 220, imageData);
//Set embedded ole object data.
sheet.OleObjects[0].ObjectData = objectData;
//Save the excel file
workbook.Save(@"C:\oleobjects.xls");

[Visual Basic]

'Instantiate a new Workbook.
Dim workbook As Workbook = New Workbook()
'Get the first worksheet.
Dim sheet As Worksheet = workbook.Worksheets(0)
'Define a string variable to store the image path.
Dim ImageUrl As String = @"C:\school.jpg"
'Get the picture into the streams.
Dim fs As FileStream = File.OpenRead(ImageUrl)
'Define a byte array.
Dim imageData(fs.Length) As Byte
'Obtain the picture into the array of bytes from streams.
fs.Read(imageData, 0, imageData.Length)
'Close the stream.
fs.Close()
'Get an excel file path in a variable.
Dim path As String = @"C:\Book1.xls"
'Get the file into the streams.
fs = File.OpenRead(path)
'Define an array of bytes.
Dim objectData(fs.Length) As Byte
'Store the file from streams.
fs.Read(objectData, 0, objectData.Length)
'Close the stream.
fs.Close()
'Add an Ole object into the worksheet with the image
'shown in MS Excel.
sheet.OleObjects.Add(14, 3, 200, 220, imageData)
'Set embedded ole object data.
sheet.OleObjects(0).ObjectData = objectData
'Save the excel file
workbook.Save("C:\oleobjects.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OleObject Members | Aspose.Cells.Drawing Namespace


OleObject Members

OleObject overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoLoad | Specifies whether the host application for the embedded object shall be called to load the object data automatically when the parent workbook is opened.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
AutoUpdate | Specifies whether the link to the OleObject is automatically updated or not.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ClassIdentifier | Gets and sets the class identifier of the embedded object. It means which application opens the embedded file.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
DisplayAsIcon | True if the specified object is displayed as an icon and the image will not be auto changed.
FileFormatType | Gets and sets the file type of the embedded ole object data
FileType | Obsolete. Gets and sets the file type of the embedded ole object data
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
FullObjectBin | Gets the full embedded ole object binary data in the template file.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
ImageData | Represents image of ole object as byte array.
ImageSourceFullName | Gets or sets the path and name of the source file for the linked image.
ImageType | Gets the image format of the ole object.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsAutoSize | True indicates that the size of the ole object will be auto changed as the size of snapshop of the embedded content when the ole object is activated.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLink | Returns true if the OleObject is linked
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Label | Gets and sets the display label of the linked ole object.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
ObjectData | Represents embedded ole object data as byte array.
ObjectSourceFullName | Returns the source full name of the source file for the linked OLE object.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
ProgID | Gets or sets the ProgID of the OLE object.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
SourceFullName | Obsolete. Returns the source full name of the source file for the linked OLE object.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
SetNativeSourceFullName | Sets the ole native source full file name with path.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


OleObject Properties

The properties of the OleObject class are listed below. For a complete list of OleObject class members, see the OleObject Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoLoad | Specifies whether the host application for the embedded object shall be called to load the object data automatically when the parent workbook is opened.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
AutoUpdate | Specifies whether the link to the OleObject is automatically updated or not.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ClassIdentifier | Gets and sets the class identifier of the embedded object. It means which application opens the embedded file.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
DisplayAsIcon | True if the specified object is displayed as an icon and the image will not be auto changed.
FileFormatType | Gets and sets the file type of the embedded ole object data
FileType | Obsolete. Gets and sets the file type of the embedded ole object data
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
FullObjectBin | Gets the full embedded ole object binary data in the template file.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
ImageData | Represents image of ole object as byte array.
ImageSourceFullName | Gets or sets the path and name of the source file for the linked image.
ImageType | Gets the image format of the ole object.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsAutoSize | True indicates that the size of the ole object will be auto changed as the size of snapshop of the embedded content when the ole object is activated.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLink | Returns true if the OleObject is linked
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Label | Gets and sets the display label of the linked ole object.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
ObjectData | Represents embedded ole object data as byte array.
ObjectSourceFullName | Returns the source full name of the source file for the linked OLE object.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
ProgID | Gets or sets the ProgID of the OLE object.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
SourceFullName | Obsolete. Returns the source full name of the source file for the linked OLE object.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


AutoLoad Property

Aspose.Cells for .NET

OleObject.AutoLoad Property

Specifies whether the host application for the embedded object shall be called to load the object data automatically when the parent workbook is opened.

public bool AutoLoad {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


AutoUpdate Property

Aspose.Cells for .NET

OleObject.AutoUpdate Property

Specifies whether the link to the OleObject is automatically updated or not.

public bool AutoUpdate {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ClassIdentifier Property

Aspose.Cells for .NET

OleObject.ClassIdentifier Property

Gets and sets the class identifier of the embedded object. It means which application opens the embedded file.

public byte[] ClassIdentifier {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


DisplayAsIcon Property

Aspose.Cells for .NET

OleObject.DisplayAsIcon Property

True if the specified object is displayed as an icon and the image will not be auto changed.

public bool DisplayAsIcon {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


FileFormatType Property

Aspose.Cells for .NET

OleObject.FileFormatType Property

Gets and sets the file type of the embedded ole object data

public FileFormatType FileFormatType {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


FileType Property

Aspose.Cells for .NET

OleObject.FileType Property

NOTE: This property is now obsolete.

Use OleObject.FileFormatType property instead.

Gets and sets the file type of the embedded ole object data

public OleFileType FileType {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use OleObject.FileFormatType property. This property will be removed 12 months later since December 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


FullObjectBin Property

Aspose.Cells for .NET

OleObject.FullObjectBin Property

Gets the full embedded ole object binary data in the template file.

public byte[] FullObjectBin {get;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ImageData Property

Aspose.Cells for .NET

OleObject.ImageData Property

Represents image of ole object as byte array.

public byte[] ImageData {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ImageSourceFullName Property

Aspose.Cells for .NET

OleObject.ImageSourceFullName Property

Gets or sets the path and name of the source file for the linked image.

public string ImageSourceFullName {get; set;}

Remarks

The default value is an empty string. If SourceFullName is not an empty string, the image is linked. If SourceFullName is not an empty string, but Data is null, then the image is linked and not stored in the file.

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ImageType Property

Aspose.Cells for .NET

OleObject.ImageType Property

Gets the image format of the ole object.

public ImageType ImageType {get;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


IsAutoSize Property

Aspose.Cells for .NET

OleObject.IsAutoSize Property

True indicates that the size of the ole object will be auto changed as the size of snapshop of the embedded content when the ole object is activated.

public bool IsAutoSize {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


IsLink Property

Aspose.Cells for .NET

OleObject.IsLink Property

Returns true if the OleObject is linked

public bool IsLink {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


Label Property

Aspose.Cells for .NET

OleObject.Label Property

Gets and sets the display label of the linked ole object.

public string Label {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ObjectData Property

Aspose.Cells for .NET

OleObject.ObjectData Property

Represents embedded ole object data as byte array.

public byte[] ObjectData {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ObjectSourceFullName Property

Aspose.Cells for .NET

OleObject.ObjectSourceFullName Property

Returns the source full name of the source file for the linked OLE object.

public string ObjectSourceFullName {get; set;}

Remarks

Only supports setting the source full name when the file type is OleFileType.Unknown. Such as wav file ,avi file..etc..

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


ProgID Property

Aspose.Cells for .NET

OleObject.ProgID Property

Gets or sets the ProgID of the OLE object.

public string ProgID {get; set;}

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


SourceFullName Property

Aspose.Cells for .NET

OleObject.SourceFullName Property

NOTE: This property is now obsolete.

Use OleObject.ObjectSourceFullName property instead.

Returns the source full name of the source file for the linked OLE object.

public string SourceFullName {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use OleObject.ObjectSourceFullName property. This property will be removed 12 months later since November 2013. Aspose apologizes for any inconvenience you may have experienced.

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


OleObject Methods

The methods of the OleObject class are listed below. For a complete list of OleObject class members, see the OleObject Members topic.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
SetNativeSourceFullName | Sets the ole native source full file name with path.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


OleObject.SetNativeSourceFullName Method

Sets the ole native source full file name with path.

public void SetNativeSourceFullName(
string sourceFullName
);

Parameters

sourceFullName
the ole native source full file name

See Also

OleObject Class | Aspose.Cells.Drawing Namespace


OleObjectCollection Class

Represents embedded OLE objects.

For a list of all members of this type, see OleObjectCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.OleObjectCollection

public class OleObjectCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OleObjectCollection Members | Aspose.Cells.Drawing Namespace


OleObjectCollection Members

OleObjectCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the OleObject element at the specified index.

Public Instance Methods

Add | Overloaded. Adds an OleObject to the collection.
Clear | Remove all embedded OLE objects.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes the element at the specified index.
ToString (inherited from Object) |

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


OleObjectCollection Properties

The properties of the OleObjectCollection class are listed below. For a complete list of OleObjectCollection class members, see the OleObjectCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the OleObject element at the specified index.

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

OleObjectCollection.Item Property

Gets the OleObject element at the specified index.

public OleObject this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


OleObjectCollection Methods

The methods of the OleObjectCollection class are listed below. For a complete list of OleObjectCollection class members, see the OleObjectCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds an OleObject to the collection.
Clear | Remove all embedded OLE objects.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Removes the element at the specified index.
ToString (inherited from Object) |

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


Add Method

Aspose.Cells for .NET

OleObjectCollection.Add Method

Adds an OleObject to the collection.

Overload List

Adds an OleObject to the collection.

public int Add(int,int,int,int,byte[]);

Adds an linked OleObject to the collection.

public int Add(int,int,int,int,byte[],string);

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


OleObjectCollection.Add Method (Int32, Int32, Int32, Int32, Byte[])

Adds an OleObject to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int height,
int width,
byte[] imageData
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
height
Height of oleObject, in unit of pixel.
width
Width of oleObject, in unit of pixel.
imageData
Image of ole object as byte array.

Return Value

OleObject object index.

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace | OleObjectCollection.Add Overload List


OleObjectCollection.Add Method (Int32, Int32, Int32, Int32, Byte[], String)

Adds an linked OleObject to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int height,
int width,
byte[] imageData,
string linkedFile
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
height
Height of oleObject, in unit of pixel.
width
Width of oleObject, in unit of pixel.
imageData
Image of ole object as byte array.
linkedFile

Return Value

OleObject object index.

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace | OleObjectCollection.Add Overload List


OleObjectCollection.Clear Method

Remove all embedded OLE objects.

new public void Clear();

Implements

IList.Clear

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


OleObjectCollection.RemoveAt Method

Removes the element at the specified index.

new public void RemoveAt(
int index
);

Parameters

index
The specified index.

Implements

IList.RemoveAt

See Also

OleObjectCollection Class | Aspose.Cells.Drawing Namespace


Oval Class

Represents the oval shape.

For a list of all members of this type, see Oval Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.Oval

public class Oval : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Oval Members | Aspose.Cells.Drawing Namespace


Oval Members

Oval overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

Oval Class | Aspose.Cells.Drawing Namespace


PatternFill Class

Encapsulates the object that represents pattern fill format

For a list of all members of this type, see PatternFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.PatternFill

public class PatternFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PatternFill Members | Aspose.Cells.Drawing Namespace


PatternFill Members

PatternFill overview

Public Instance Properties

BackgroundCellsColor | Gets and sets the foreground CellsColor object.
BackgroundColor | Gets or sets the background Color of the Area.
BackTransparency | Gets or sets the transparency of background color.
ForegroundCellsColor | Gets and sets the foreground CellsColor object.
ForegroundColor | Gets or sets the foreground Color.
ForeTransparency | Gets or sets the transparency of foreground color.
Pattern | Gets or sets the fill pattern type

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


PatternFill Properties

The properties of the PatternFill class are listed below. For a complete list of PatternFill class members, see the PatternFill Members topic.

Public Instance Properties

BackgroundCellsColor | Gets and sets the foreground CellsColor object.
BackgroundColor | Gets or sets the background Color of the Area.
BackTransparency | Gets or sets the transparency of background color.
ForegroundCellsColor | Gets and sets the foreground CellsColor object.
ForegroundColor | Gets or sets the foreground Color.
ForeTransparency | Gets or sets the transparency of foreground color.
Pattern | Gets or sets the fill pattern type

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


BackgroundCellsColor Property

Aspose.Cells for .NET

PatternFill.BackgroundCellsColor Property

Gets and sets the foreground CellsColor object.

public CellsColor BackgroundCellsColor {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


BackgroundColor Property

Aspose.Cells for .NET

PatternFill.BackgroundColor Property

Gets or sets the background Color of the Area.

public Color BackgroundColor {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


BackTransparency Property

Aspose.Cells for .NET

PatternFill.BackTransparency Property

Gets or sets the transparency of background color.

public double BackTransparency {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


ForegroundCellsColor Property

Aspose.Cells for .NET

PatternFill.ForegroundCellsColor Property

Gets and sets the foreground CellsColor object.

public CellsColor ForegroundCellsColor {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


ForegroundColor Property

Aspose.Cells for .NET

PatternFill.ForegroundColor Property

Gets or sets the foreground Color.

public Color ForegroundColor {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


ForeTransparency Property

Aspose.Cells for .NET

PatternFill.ForeTransparency Property

Gets or sets the transparency of foreground color.

public double ForeTransparency {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


Pattern Property

Aspose.Cells for .NET

PatternFill.Pattern Property

Gets or sets the fill pattern type

public FillPattern Pattern {get; set;}

See Also

PatternFill Class | Aspose.Cells.Drawing Namespace


PicFormatOption Class

Represents picture format option

For a list of all members of this type, see PicFormatOption Members.

System.Object
Aspose.Cells.Drawing.PicFormatOption

public class PicFormatOption

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PicFormatOption Members | Aspose.Cells.Drawing Namespace


PicFormatOption Members

PicFormatOption overview

Public Instance Constructors

PicFormatOption Constructor Initializes a new instance of the PicFormatOption class.

Public Instance Properties

Bottom | Gets or sets the bottom offset for stretching picture.
Left | Gets or sets the left offset for stretching picture.
Right | Gets or sets the right offset for stretching picture.
Scale | Gets or sets how many the picture stack and scale with.
Top | Gets or sets the top offset for stretching picture.
Type | Gets or sets the picture fill type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


PicFormatOption Constructor

Initializes a new instance of the PicFormatOption class.

public PicFormatOption();

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


PicFormatOption Properties

The properties of the PicFormatOption class are listed below. For a complete list of PicFormatOption class members, see the PicFormatOption Members topic.

Public Instance Properties

Bottom | Gets or sets the bottom offset for stretching picture.
Left | Gets or sets the left offset for stretching picture.
Right | Gets or sets the right offset for stretching picture.
Scale | Gets or sets how many the picture stack and scale with.
Top | Gets or sets the top offset for stretching picture.
Type | Gets or sets the picture fill type.

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Bottom Property

Aspose.Cells for .NET

PicFormatOption.Bottom Property

Gets or sets the bottom offset for stretching picture.

public double Bottom {get; set;}

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Left Property

Aspose.Cells for .NET

PicFormatOption.Left Property

Gets or sets the left offset for stretching picture.

public double Left {get; set;}

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Right Property

Aspose.Cells for .NET

PicFormatOption.Right Property

Gets or sets the right offset for stretching picture.

public double Right {get; set;}

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Scale Property

Aspose.Cells for .NET

PicFormatOption.Scale Property

Gets or sets how many the picture stack and scale with.

public double Scale {get; set;}

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Top Property

Aspose.Cells for .NET

PicFormatOption.Top Property

Gets or sets the top offset for stretching picture.

public double Top {get; set;}

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

PicFormatOption.Type Property

Gets or sets the picture fill type.

public FillPictureType Type {get; set;}

See Also

PicFormatOption Class | Aspose.Cells.Drawing Namespace


Picture Class

Encapsulates the object that represents a single picture in a spreadsheet.

For a list of all members of this type, see Picture Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.Picture

public class Picture : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
//Instantiating a Workbook object
Workbook workbook = new Workbook();
//Adding a new worksheet to the Workbook object
int sheetIndex = workbook.Worksheets.Add();
//Obtaining the reference of the newly added worksheet by passing its sheet index
Worksheet worksheet = workbook.Worksheets[sheetIndex];
//Adding a picture at the location of a cell whose row and column indices
//are 5 in the worksheet. It is "F6" cell
worksheet.Pictures.Add(5, 5, "C:\\image.gif");
//Saving the Excel file
workbook.Save(saveFileDialog1.FileName, SaveFormat.Excel97To2003);

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
'Adding a new worksheet to the Workbook object
Dim sheetIndex As Integer = workbook.Worksheets.Add()
'Obtaining the reference of the newly added worksheet by passing its sheet index
Dim worksheet As Worksheet = workbook.Worksheets(sheetIndex)
'Adding a picture at the location of a cell whose row and column indices
'are 5 in the worksheet. It is "F6" cell
worksheet.Pictures.Add(5, 5, "C:\image.gif")
'Saving the Excel file
workbook.Save("C:\book1.xls", SaveFormat.Excel97To2003)

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Picture Members | Aspose.Cells.Drawing Namespace


Picture Members

Picture overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
BorderLineColor | Represents the Color of the border line of a picture.
BorderWeight | Gets or sets the weight of the border line of a picture in units of pt.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Data | Gets the data of the picture.
DisplayAsIcon | True if the specified object is displayed as an icon and the image will not be auto changed.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Formula | Gets and sets the data of the formula.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
ImageType | Gets the image format of the picture.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsAutoSize | True indicates that the size of the ole object will be auto changed as the size of snapshop of the embedded content when the ole object is activated.
IsDynamicDataExchange | Gets or sets whether dynamic data exchange
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLink | Returns true if the picture is linked to a file.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
OriginalHeight | Gets the original height of the picture.
OriginalHeightCM | Gets the original height of picture, in unit of centimeters.
OriginalHeightInch | Gets the original height of picture, in unit of inches.
OriginalWidth | Gets the original width of the picture.
OriginalWidthCM | Gets the original width of picture, in unit of centimeters.
OriginalWidthInch | Gets the original width of picture, in unit of inches.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SignatureLine | Gets and sets the signature line
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
SourceFullName | Gets or sets the path and name of the source file for the linked image.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Copy | Copy the picture.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
Move | Moves the picture to a specified location.
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

Picture Class | Aspose.Cells.Drawing Namespace


Picture Properties

The properties of the Picture class are listed below. For a complete list of Picture class members, see the Picture Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
BorderLineColor | Represents the Color of the border line of a picture.
BorderWeight | Gets or sets the weight of the border line of a picture in units of pt.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Data | Gets the data of the picture.
DisplayAsIcon | True if the specified object is displayed as an icon and the image will not be auto changed.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Formula | Gets and sets the data of the formula.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
ImageType | Gets the image format of the picture.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsAutoSize | True indicates that the size of the ole object will be auto changed as the size of snapshop of the embedded content when the ole object is activated.
IsDynamicDataExchange | Gets or sets whether dynamic data exchange
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLink | Returns true if the picture is linked to a file.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
OriginalHeight | Gets the original height of the picture.
OriginalHeightCM | Gets the original height of picture, in unit of centimeters.
OriginalHeightInch | Gets the original height of picture, in unit of inches.
OriginalWidth | Gets the original width of the picture.
OriginalWidthCM | Gets the original width of picture, in unit of centimeters.
OriginalWidthInch | Gets the original width of picture, in unit of inches.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SignatureLine | Gets and sets the signature line
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
SourceFullName | Gets or sets the path and name of the source file for the linked image.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

Picture Class | Aspose.Cells.Drawing Namespace


BorderLineColor Property

Aspose.Cells for .NET

Picture.BorderLineColor Property

Represents the Color of the border line of a picture.

public Color BorderLineColor {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


BorderWeight Property

Aspose.Cells for .NET

Picture.BorderWeight Property

Gets or sets the weight of the border line of a picture in units of pt.

public double BorderWeight {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


Data Property

Aspose.Cells for .NET

Picture.Data Property

Gets the data of the picture.

public byte[] Data {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


DisplayAsIcon Property

Aspose.Cells for .NET

Picture.DisplayAsIcon Property

True if the specified object is displayed as an icon and the image will not be auto changed.

public bool DisplayAsIcon {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


Formula Property

Aspose.Cells for .NET

Picture.Formula Property

Gets and sets the data of the formula.

public string Formula {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


ImageType Property

Aspose.Cells for .NET

Picture.ImageType Property

Gets the image format of the picture.

public ImageType ImageType {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


IsAutoSize Property

Aspose.Cells for .NET

Picture.IsAutoSize Property

True indicates that the size of the ole object will be auto changed as the size of snapshop of the embedded content when the ole object is activated.

public bool IsAutoSize {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


IsDynamicDataExchange Property

Aspose.Cells for .NET

Picture.IsDynamicDataExchange Property

Gets or sets whether dynamic data exchange

public bool IsDynamicDataExchange {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


IsLink Property

Aspose.Cells for .NET

Picture.IsLink Property

Returns true if the picture is linked to a file.

public bool IsLink {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


OriginalHeight Property

Aspose.Cells for .NET

Picture.OriginalHeight Property

Gets the original height of the picture.

public int OriginalHeight {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


OriginalHeightCM Property

Aspose.Cells for .NET

Picture.OriginalHeightCM Property

Gets the original height of picture, in unit of centimeters.

public double OriginalHeightCM {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


OriginalHeightInch Property

Aspose.Cells for .NET

Picture.OriginalHeightInch Property

Gets the original height of picture, in unit of inches.

public double OriginalHeightInch {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


OriginalWidth Property

Aspose.Cells for .NET

Picture.OriginalWidth Property

Gets the original width of the picture.

public int OriginalWidth {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


OriginalWidthCM Property

Aspose.Cells for .NET

Picture.OriginalWidthCM Property

Gets the original width of picture, in unit of centimeters.

public double OriginalWidthCM {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


OriginalWidthInch Property

Aspose.Cells for .NET

Picture.OriginalWidthInch Property

Gets the original width of picture, in unit of inches.

public double OriginalWidthInch {get;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


SignatureLine Property

Aspose.Cells for .NET

Picture.SignatureLine Property

Gets and sets the signature line

public SignatureLine SignatureLine {get; set;}

See Also

Picture Class | Aspose.Cells.Drawing Namespace


SourceFullName Property

Aspose.Cells for .NET

Picture.SourceFullName Property

Gets or sets the path and name of the source file for the linked image.

public string SourceFullName {get; set;}

Remarks

The default value is an empty string. If SourceFullName is not an empty string, the image is linked. If SourceFullName is not an empty string, but Data is null, then the image is linked and not stored in the file.

See Also

Picture Class | Aspose.Cells.Drawing Namespace


Picture Methods

The methods of the Picture class are listed below. For a complete list of Picture class members, see the Picture Members topic.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Copy | Copy the picture.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
Move | Moves the picture to a specified location.
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

Picture Class | Aspose.Cells.Drawing Namespace


Picture.Copy Method

Copy the picture.

public void Copy(
Picture source,
CopyOptions options
);

Parameters

source
The source picture.
options
The copy options.

See Also

Picture Class | Aspose.Cells.Drawing Namespace


Picture.Move Method

Moves the picture to a specified location.

public void Move(
int upperLeftRow,
int upperLeftColumn
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.

See Also

Picture Class | Aspose.Cells.Drawing Namespace


PictureCollection Class

Encapsulates a collection of Picture objects.

For a list of all members of this type, see PictureCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.PictureCollection

public class PictureCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PictureCollection Members | Aspose.Cells.Drawing Namespace


PictureCollection Members

PictureCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Picture element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a picture to the collection.
Clear | Clear all pictures.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove shapes at the specific index
ToString (inherited from Object) |

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


PictureCollection Properties

The properties of the PictureCollection class are listed below. For a complete list of PictureCollection class members, see the PictureCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the Picture element at the specified index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

PictureCollection.Item Property

Gets the Picture element at the specified index.

public Picture this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


PictureCollection Methods

The methods of the PictureCollection class are listed below. For a complete list of PictureCollection class members, see the PictureCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a picture to the collection.
Clear | Clear all pictures.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove shapes at the specific index
ToString (inherited from Object) |

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


Add Method

Aspose.Cells for .NET

PictureCollection.Add Method

Adds a picture to the collection.

Overload List

Adds a picture to the collection.

public int Add(int,int,int,int,Stream);

Adds a picture to the collection.

public int Add(int,int,int,int,string);

Adds a picture to the collection.

public int Add(int,int,Stream);

Adds a picture to the collection.

public int Add(int,int,Stream,int,int);

Adds a picture to the collection.

public int Add(int,int,string);

Adds a picture to the collection.

public int Add(int,int,string,int,int);

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


PictureCollection.Add Method (Int32, Int32, Int32, Int32, Stream)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
stream
Stream object which contains the image data.

Return Value

Picture object index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace | PictureCollection.Add Overload List


PictureCollection.Add Method (Int32, Int32, Int32, Int32, String)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
string fileName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
fileName
Image filename.

Return Value

Picture object index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace | PictureCollection.Add Overload List


PictureCollection.Add Method (Int32, Int32, Stream)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
stream
Stream object which contains the image data.

Return Value

Picture object index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace | PictureCollection.Add Overload List


PictureCollection.Add Method (Int32, Int32, Stream, Int32, Int32)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
Stream stream,
int widthScale,
int heightScale
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
stream
Stream object which contains the image data.
widthScale
Scale of image width, a percentage.
heightScale
Scale of image height, a percentage.

Return Value

Picture object index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace | PictureCollection.Add Overload List


PictureCollection.Add Method (Int32, Int32, String)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
string fileName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
fileName
Image filename.

Return Value

Picture object index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace | PictureCollection.Add Overload List


PictureCollection.Add Method (Int32, Int32, String, Int32, Int32)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
string fileName,
int widthScale,
int heightScale
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
fileName
Image filename.
widthScale
Scale of image width, a percentage.
heightScale
Scale of image height, a percentage.

Return Value

Picture object index.

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace | PictureCollection.Add Overload List


PictureCollection.Clear Method

Clear all pictures.

new public void Clear();

Implements

IList.Clear

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


PictureCollection.RemoveAt Method

Remove shapes at the specific index

new public void RemoveAt(
int index
);

Implements

IList.RemoveAt

See Also

PictureCollection Class | Aspose.Cells.Drawing Namespace


PlacementType Enumeration

Represents the way the drawing object is attached to the cells below it.

public enum PlacementType

Members

Member Name | Description | Value
FreeFloating | Don't move or size with cells. | 0
Move | Move but don't size with cells. | 1
MoveAndSize | Move and size with cells. | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


PresetCameraType Enumeration

Represent different algorithmic methods for setting all camera properties, including position.

public enum PresetCameraType

Members

Member Name | Description | Value
IsometricBottomDown |  | 0
IsometricBottomUp |  | 1
IsometricLeftDown |  | 2
IsometricLeftUp |  | 3
IsometricOffAxis1Left |  | 4
IsometricOffAxis1Right |  | 5
IsometricOffAxis1Top |  | 6
IsometricOffAxis2Left |  | 7
IsometricOffAxis2Right |  | 8
IsometricOffAxis2Top |  | 9
IsometricOffAxis3Bottom |  | 10
IsometricOffAxis3Left |  | 11
IsometricOffAxis3Right |  | 12
IsometricOffAxis4Bottom |  | 13
IsometricOffAxis4Left |  | 14
IsometricOffAxis4Right |  | 15
IsometricRightDown |  | 16
IsometricRightUp |  | 17
IsometricTopDown |  | 18
IsometricTopUp |  | 19
LegacyObliqueBottom |  | 20
LegacyObliqueBottomLeft |  | 21
LegacyObliqueBottomRight |  | 22
LegacyObliqueFront |  | 23
LegacyObliqueLeft |  | 24
LegacyObliqueRight |  | 25
LegacyObliqueTop |  | 26
LegacyObliqueTopLeft |  | 27
LegacyObliqueTopRight |  | 28
LegacyPerspectiveBottom |  | 29
LegacyPerspectiveBottomLeft |  | 30
LegacyPerspectiveBottomRight |  | 31
LegacyPerspectiveFront |  | 32
LegacyPerspectiveLeft |  | 33
LegacyPerspectiveRight |  | 34
LegacyPerspectiveTop |  | 35
LegacyPerspectiveTopLeft |  | 36
LegacyPerspectiveTopRight |  | 37
ObliqueBottom |  | 38
ObliqueBottomLeft |  | 39
ObliqueBottomRight |  | 40
ObliqueLeft |  | 41
ObliqueRight |  | 42
ObliqueTop |  | 43
ObliqueTopLeft |  | 44
ObliqueTopRight |  | 45
OrthographicFront |  | 46
PerspectiveAbove |  | 47
PerspectiveAboveLeftFacing |  | 48
PerspectiveAboveRightFacing |  | 49
PerspectiveBelow |  | 50
PerspectiveContrastingLeftFacing |  | 51
PerspectiveContrastingRightFacing |  | 52
PerspectiveFront |  | 53
PerspectiveHeroicExtremeLeftFacing |  | 54
PerspectiveHeroicExtremeRightFacing |  | 55
PerspectiveHeroicLeftFacing |  | 56
PerspectiveHeroicRightFacing |  | 57
PerspectiveLeft |  | 58
PerspectiveRelaxed |  | 59
PerspectiveRelaxedModerately |  | 60
PerspectiveRight |  | 61

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


PresetMaterialType Enumeration

Describes surface appearance of a shape.

public enum PresetMaterialType

Members

Member Name | Description | Value
Clear | Clear | 0
DarkEdge | Dark edge | 1
Flat | Flat | 2
LegacyMatte | Legacy matte | 3
LegacyMetal | Legacy metal | 4
LegacyPlastic | Legacy plastic | 5
LegacyWireframe | Legacy wireframe | 6
Matte | Matte | 7
Metal | Metal | 8
Plastic | Plastic | 9
Powder | Powder | 10
SoftEdge | Soft edge | 11
SoftMetal | Soft metal | 12
TranslucentPowder | Translucent powder | 13
WarmMatte | Warm matte | 14

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


PresetShadowType Enumeration

Represents preset shadow type.

public enum PresetShadowType

Members

Member Name | Description | Value
NoShadow | No shadow. | 0
Custom | Custom shadow. | 1
OffsetDiagonalBottomRight | Outer shadow offset diagonal bottom right. | 2
OffsetBottom | Outer shadow offset bottom. | 3
OffsetDiagonalBottomLeft | Outer shadow offset diagonal bottom left. | 4
OffsetRight | Outer shadow offset right. | 5
OffsetCenter | Outer shadow offset center. | 6
OffsetLeft | Outer shadow offset left. | 7
OffsetDiagonalTopRight | Outer shadow offset diagonal top right. | 8
OffsetTop | Outer shadow offset top. | 9
OffsetDiagonalTopLeft | Outer shadow offset diagonal top left. | 10
InsideDiagonalTopLeft | Inner shadow inside diagonal top Left. | 11
InsideTop | Inner shadow inside top. | 12
InsideDiagonalTopRight | Inner shadow inside diagonal top right. | 13
InsideLeft | Inner shadow inside left. | 14
InsideCenter | Inner shadow inside center. | 15
InsideRight | Inner shadow inside right. | 16
InsideDiagonalBottomLeft | Inner shadow inside diagonal bottom left. | 17
InsideBottom | Inner shadow inside bottom. | 18
InsideDiagonalBottomRight | Inner shadow inside diagonal bottom right. | 19
PerspectiveDiagonalUpperLeft | Outer shadow perspective diagonal upper left. | 20
PerspectiveDiagonalUpperRight | Outer shadow perspective diagonal upper right. | 21
Below | Outer shadow below. | 22
PerspectiveDiagonalLowerLeft | Outer shadow perspective diagonal lower left. | 23
PerspectiveDiagonalLowerRight | Outer shadow perspective diagonal lower right. | 24

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


PresetWordArtStyle Enumeration

Represents the preset WordArt styles.

public enum PresetWordArtStyle

Members

Member Name | Description | Value
WordArtStyle1 | Fill - Black, Text 1, Shadow | 1
WordArtStyle2 | Fill - Blue, Accent 1, Shadow | 2
WordArtStyle3 | Fill - Orange, Accent 2, Outline - Accent 2 | 3
WordArtStyle4 | Fill - White, Outline - Accent 1, Shadow | 4
WordArtStyle5 | Fill - Gold, Accent 4, Soft Bevel | 5
WordArtStyle6 | Gradient Fill - Gray | 6
WordArtStyle7 | Gradient Fill - Blue, Accent 1, Reflection | 7
WordArtStyle8 | Gradient Fill - Gold, Accent 4, Outline - Accent 4 | 8
WordArtStyle9 | Fill - White, Outline - Accent 1, Glow - Accent 1 | 9
WordArtStyle10 | Fill - Gray-50%, Accent 3, Sharp Bevel | 10
WordArtStyle11 | Fill - Black, Text 1, Outline - Background 1, Hard Shadow - Background 1 | 11
WordArtStyle12 | Fill - Black, Text 1, Outline - Background 1, Hard Shadow - Accent 1 | 12
WordArtStyle13 | Fill - Blue, Accent 1, Outline - Background 1, Hard Shadow - Accent 1 | 13
WordArtStyle14 | Fill - White, Outline - Accent 2, Hard Shadow - Accent 2 | 14
WordArtStyle15 | Fill - Gray-25%, Background 2, Inner Shadow | 15
WordArtStyle16 | Pattern Fill - White, Text 2, Dark Upward Diagonal, Shadow | 16
WordArtStyle17 | Pattern Fill - Gray-50%, Accent 3, Narrow Horizontal, Inner Shadow | 17
WordArtStyle18 | Fill - Blue, Accent 1, 50%, Hard Shadow - Accent 1 | 18
WordArtStyle19 | Pattern Fill - Blue, Accent 1, Light Downward Diagonal, Outline - Accent 1 | 19
WordArtStyle20 | Pattern Fill - Blue-Gray, Text 2, Dark Upward Diagonal, Hard Shadow - Text 2 | 20

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


RadioButton Class

Represents a radio button.

For a list of all members of this type, see RadioButton Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.RadioButton

public class RadioButton : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RadioButton Members | Aspose.Cells.Drawing Namespace


RadioButton Members

RadioButton overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
GroupBox | Gets the GroupBox that contains this RadioButton.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsChecked | Indicates if the radiobutton is checked or not.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

RadioButton Class | Aspose.Cells.Drawing Namespace


RadioButton Properties

The properties of the RadioButton class are listed below. For a complete list of RadioButton class members, see the RadioButton Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
GroupBox | Gets the GroupBox that contains this RadioButton.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsChecked | Indicates if the radiobutton is checked or not.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the combobox has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

RadioButton Class | Aspose.Cells.Drawing Namespace


GroupBox Property

Aspose.Cells for .NET

RadioButton.GroupBox Property

Gets the GroupBox that contains this RadioButton.

public GroupBox GroupBox {get;}

See Also

RadioButton Class | Aspose.Cells.Drawing Namespace


IsChecked Property

Aspose.Cells for .NET

RadioButton.IsChecked Property

Indicates if the radiobutton is checked or not.

public bool IsChecked {get; set;}

See Also

RadioButton Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

RadioButton.Shadow Property

Indicates whether the combobox has 3-D shading.

public bool Shadow {get; set;}

See Also

RadioButton Class | Aspose.Cells.Drawing Namespace


RectangleAlignmentType Enumeration

Represents how to position two rectangles relative to each other.

public enum RectangleAlignmentType

Members

Member Name | Description | Value
Bottom | Bottom | 0
BottomLeft | BottomLeft | 1
BottomRight | BottomRight | 2
Center | Center | 3
Left | Left | 4
Right | Right | 5
Top | Top | 6
TopLeft | TopLeft | 7
TopRight | TopRight | 8

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


RectangleShape Class

Represents the rectangle shape.

For a list of all members of this type, see RectangleShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.RectangleShape

public class RectangleShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RectangleShape Members | Aspose.Cells.Drawing Namespace


RectangleShape Members

RectangleShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

RectangleShape Class | Aspose.Cells.Drawing Namespace


ReflectionEffect Class

This class specifies a reflection effect.

For a list of all members of this type, see ReflectionEffect Members.

System.Object
Aspose.Cells.Drawing.ReflectionEffect

public class ReflectionEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ReflectionEffect Members | Aspose.Cells.Drawing Namespace


ReflectionEffect Members

ReflectionEffect overview

Public Instance Properties

Blur | Gets and sets the blur radius,in unit of points.
Direction | Gets and sets the direction of the alpha gradient ramp relative to the shape itself.
Distance | Gets and sets how far to distance the shadow,in unit of points.
FadeDirection | Gets and sets the direction to offset the reflection.
RotWithShape | Gets and sets if the reflection should rotate with the shape.
Size | Gets and sets the end position (along the alpha gradient ramp) of the end alpha value,in unit of percentage
Transparency | Gets and sets the degree of the starting reflection transparency as a value from 0.0 (opaque) through 1.0 (clear).
Type | Gets and sets the preset reflection effect.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


ReflectionEffect Properties

The properties of the ReflectionEffect class are listed below. For a complete list of ReflectionEffect class members, see the ReflectionEffect Members topic.

Public Instance Properties

Blur | Gets and sets the blur radius,in unit of points.
Direction | Gets and sets the direction of the alpha gradient ramp relative to the shape itself.
Distance | Gets and sets how far to distance the shadow,in unit of points.
FadeDirection | Gets and sets the direction to offset the reflection.
RotWithShape | Gets and sets if the reflection should rotate with the shape.
Size | Gets and sets the end position (along the alpha gradient ramp) of the end alpha value,in unit of percentage
Transparency | Gets and sets the degree of the starting reflection transparency as a value from 0.0 (opaque) through 1.0 (clear).
Type | Gets and sets the preset reflection effect.

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


Blur Property

Aspose.Cells for .NET

ReflectionEffect.Blur Property

Gets and sets the blur radius,in unit of points.

public double Blur {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


Direction Property

Aspose.Cells for .NET

ReflectionEffect.Direction Property

Gets and sets the direction of the alpha gradient ramp relative to the shape itself.

public double Direction {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


Distance Property

Aspose.Cells for .NET

ReflectionEffect.Distance Property

Gets and sets how far to distance the shadow,in unit of points.

public double Distance {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


FadeDirection Property

Aspose.Cells for .NET

ReflectionEffect.FadeDirection Property

Gets and sets the direction to offset the reflection.

public double FadeDirection {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


RotWithShape Property

Aspose.Cells for .NET

ReflectionEffect.RotWithShape Property

Gets and sets if the reflection should rotate with the shape.

public bool RotWithShape {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


Size Property

Aspose.Cells for .NET

ReflectionEffect.Size Property

Gets and sets the end position (along the alpha gradient ramp) of the end alpha value,in unit of percentage

public double Size {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

ReflectionEffect.Transparency Property

Gets and sets the degree of the starting reflection transparency as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

ReflectionEffect.Type Property

Gets and sets the preset reflection effect.

public ReflectionEffectType Type {get; set;}

See Also

ReflectionEffect Class | Aspose.Cells.Drawing Namespace


ReflectionEffectType Enumeration

public enum ReflectionEffectType

Members

Member Name | Description | Value
None | No reflection effect. | 0
Custom | Custom reflection effect. | 1
TightReflectionTouching | Tight reflection, touching. | 2
HalfReflectionTouching | Half reflection, touching. | 3
FullReflectionTouching | Full reflection, touching. | 4
TightReflection4PtOffset | Tight reflection, 4 pt offset. | 5
HalfReflection4PtOffset | Half reflection, 4 pt offset. | 6
FullReflection4PtOffset | Full reflection, 4 pt offset. | 7
TightReflection8PtOffset | Tight reflection, 8 pt offset. | 8
HalfReflection8PtOffset | Half reflection, 8 pt offset. | 9
FullReflection8PtOffset | Full reflection, 8 pt offset. | 10

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ScrollBar Class

Represents a scroll bar object.

For a list of all members of this type, see ScrollBar Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.ScrollBar

public class ScrollBar : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Scroll value must be between 0 and 30000.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ScrollBar Members | Aspose.Cells.Drawing Namespace


ScrollBar Members

ScrollBar overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
CurrentValue | Gets or sets the current value.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
IncrementalChange | Gets or sets the amount that the scroll bar or spinner is incremented a line scroll.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsHorizontal | Indicates whether this is a horizontal scroll bar.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
Max | Gets or sets the maximum value of a scroll bar or spinner range.
Min | Gets or sets the minimum value of a scroll bar or spinner range.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
PageChange | Gets or sets page change
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the shape has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


ScrollBar Properties

The properties of the ScrollBar class are listed below. For a complete list of ScrollBar class members, see the ScrollBar Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
CurrentValue | Gets or sets the current value.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
IncrementalChange | Gets or sets the amount that the scroll bar or spinner is incremented a line scroll.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsHorizontal | Indicates whether this is a horizontal scroll bar.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
Max | Gets or sets the maximum value of a scroll bar or spinner range.
Min | Gets or sets the minimum value of a scroll bar or spinner range.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
PageChange | Gets or sets page change
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the shape has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


CurrentValue Property

Aspose.Cells for .NET

ScrollBar.CurrentValue Property

Gets or sets the current value.

public int CurrentValue {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


IncrementalChange Property

Aspose.Cells for .NET

ScrollBar.IncrementalChange Property

Gets or sets the amount that the scroll bar or spinner is incremented a line scroll.

public int IncrementalChange {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


IsHorizontal Property

Aspose.Cells for .NET

ScrollBar.IsHorizontal Property

Indicates whether this is a horizontal scroll bar.

public bool IsHorizontal {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


Max Property

Aspose.Cells for .NET

ScrollBar.Max Property

Gets or sets the maximum value of a scroll bar or spinner range.

public int Max {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


Min Property

Aspose.Cells for .NET

ScrollBar.Min Property

Gets or sets the minimum value of a scroll bar or spinner range.

public int Min {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


PageChange Property

Aspose.Cells for .NET

ScrollBar.PageChange Property

Gets or sets page change

public int PageChange {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

ScrollBar.Shadow Property

Indicates whether the shape has 3-D shading.

public bool Shadow {get; set;}

See Also

ScrollBar Class | Aspose.Cells.Drawing Namespace


SelectionType Enumeration

The selection type of list box.

public enum SelectionType

Members

Member Name | Description | Value
Single | Sigle selection type. | 0
Multi | Multiple selection type. | 1
Extend | Extend selection type. | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ShadowEffect Class

This class specifies the shadow effect of the chart element or shape.

For a list of all members of this type, see ShadowEffect Members.

System.Object
Aspose.Cells.Drawing.ShadowEffect

public class ShadowEffect

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShadowEffect Members | Aspose.Cells.Drawing Namespace


ShadowEffect Members

ShadowEffect overview

Public Instance Properties

Angle | Gets and sets the lighting angle. Range from 0 to 359.9 degrees.
Blur | Gets and sets the blur of the shadow. Range from 0 to 100 points.
Color | Gets and sets the color of the shadow.
Distance | Gets and sets the distance of the shadow. Range from 0 to 200 points.
PresetType | Gets and sets the preset shadow type of the shadow.
Size | Gets and sets the size of the shadow. Range from 0 to 2.0. Meaningless in inner shadow.
Transparency | Gets and sets the degree of transparency of the shadow. Range from 0.0 (opaque) to 1.0 (clear).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


ShadowEffect Properties

The properties of the ShadowEffect class are listed below. For a complete list of ShadowEffect class members, see the ShadowEffect Members topic.

Public Instance Properties

Angle | Gets and sets the lighting angle. Range from 0 to 359.9 degrees.
Blur | Gets and sets the blur of the shadow. Range from 0 to 100 points.
Color | Gets and sets the color of the shadow.
Distance | Gets and sets the distance of the shadow. Range from 0 to 200 points.
PresetType | Gets and sets the preset shadow type of the shadow.
Size | Gets and sets the size of the shadow. Range from 0 to 2.0. Meaningless in inner shadow.
Transparency | Gets and sets the degree of transparency of the shadow. Range from 0.0 (opaque) to 1.0 (clear).

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Angle Property

Aspose.Cells for .NET

ShadowEffect.Angle Property

Gets and sets the lighting angle. Range from 0 to 359.9 degrees.

public double Angle {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Blur Property

Aspose.Cells for .NET

ShadowEffect.Blur Property

Gets and sets the blur of the shadow. Range from 0 to 100 points.

public double Blur {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Color Property

Aspose.Cells for .NET

ShadowEffect.Color Property

Gets and sets the color of the shadow.

public CellsColor Color {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Distance Property

Aspose.Cells for .NET

ShadowEffect.Distance Property

Gets and sets the distance of the shadow. Range from 0 to 200 points.

public double Distance {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


PresetType Property

Aspose.Cells for .NET

ShadowEffect.PresetType Property

Gets and sets the preset shadow type of the shadow.

public PresetShadowType PresetType {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Size Property

Aspose.Cells for .NET

ShadowEffect.Size Property

Gets and sets the size of the shadow. Range from 0 to 2.0. Meaningless in inner shadow.

public double Size {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

ShadowEffect.Transparency Property

Gets and sets the degree of transparency of the shadow. Range from 0.0 (opaque) to 1.0 (clear).

public double Transparency {get; set;}

See Also

ShadowEffect Class | Aspose.Cells.Drawing Namespace


Shape Class

Represents the msodrawing object.

For a list of all members of this type, see Shape Members.

System.Object
Aspose.Cells.Drawing.Shape
Derived types

public class Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Shape Members | Aspose.Cells.Drawing Namespace


Shape Members

Shape overview

Public Instance Properties

ActiveXControl | Gets the ActiveX control.
ActualLowerRightRow | Get the actual bottom row.
AlternativeText | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType | Gets the auto shape type.
Bottom | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints | Get the connection points
ControlData | Gets the data of control.
Fill | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font | Represents the font of shape.
Format | Obsolete. Represents the setting of the shape's formatting.
FormatPicture | Gets and sets the options of the picture format.
Geometry | Gets the geometry
Glow | Represents a object that specifies glow effect for the chart element or shape.
Group | Gets the group shape which contains this shape.
HasLine | Gets and sets the line border of the shape is visible.
Height | Represents the height of shape, in unit of pixel.
HeightCM | Represents the height of the shape, in unit of inches.
HeightInch | Represents the height of the shape, in unit of inches.
HeightInShape | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt | Represents the height of the shape, in unit of points.
HeightScale | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink | Gets the hyperlink of the shape.
Id | Gets the identifier of this shape.
InputRange | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation | Indicates whether the shape only contains an equation.
IsFilled | Indicates whether the fill format is visible.
IsFlippedHorizontally | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically | Gets and sets whether shape is vertically flipped .
IsGroup | Indicates whether the shape is a group.
IsHidden | Indicates whether the object is visible.
IsLockAspectRatio | True means that don't allow changes in aspect ratio.
IsLocked | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable | True if the object is printable
IsRichText | Whether or not the text is rich text.
IsSmartArt | Indicates whether the shape is smart art.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt | Indicates whether this shape is a word art.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner | Gets and sets the horizonal offset of shape from worksheet left border.
Line | Gets line style
LineFormat | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn | Represents lower right corner column index.
LowerRightRow | Represents lower right corner row index.
MacroName | Gets and sets the name of macro.
MsoDrawingType | Gets and sets mso drawing type.
Name | Gets and sets the name of the shape.
Paths | Gets the paths of a custom geometric shape.
Placement | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize | Indicates whether shape is relative to original picture size.
Right | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle | Gets and sets the rotation of the shape.
ShadowEffect | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid | Specifies an optional string that an application can use to Identify the particular shape.
Spt | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text | Represents the string in this TextBox object.
TextBody | Gets and sets the setting of the shape's text.
TextDirection | Gets/Sets the direction of the text flow for this object.
TextEffect | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions | Represents the text options of the shape.
TextOrientationType | Gets and sets the text orientation type of the shape.
TextShapeType | Gets and sets the preset text shape type.
TextVerticalAlignment | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat | Gets and sets 3d format of the shape.
Title | Specifies the title (caption) of the current shape object.
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type | Gets the auto shape type.
UpperDeltaX | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
Width | Represents the width of shape, in unit of pixels.
WidthCM | Represents the width of the shape, in unit of centimeters.
WidthInch | Represents the width of the shape, in unit of inch.
WidthInShape | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt | Represents the width of the shape, in unit of point.
WidthScale | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink | Adds a hyperlink to the shape.
AlignTopRightCorner | Moves the picture to the top-right corner.
CalculateTextSize | Recalculate the text area
Characters | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters | Overloaded. Formats some characters with the font setting.
GetCharacters | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange | Gets the range used to fill the control.
GetLinkedCell | Gets the range linked to the control's value.
GetLockedProperty | Gets the value of locked property.
GetResultOfSmartArt | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange | Moves the shape to a specified range.
RemoveActiveXControl | Remove activeX control.
RemoveHyperlink | Remove the hyperlink of the shape.
SetInputRange | Sets the range used to fill the control.
SetLinkedCell | Sets the range linked to the control's value.
SetLockedProperty | Set the locked property.
ToFrontOrBack | Brings the shape to the front or sends the shape to back.
ToImage | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue | Update the selected value by the value of the linked cell.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape Properties

The properties of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Properties

ActiveXControl | Gets the ActiveX control.
ActualLowerRightRow | Get the actual bottom row.
AlternativeText | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType | Gets the auto shape type.
Bottom | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints | Get the connection points
ControlData | Gets the data of control.
Fill | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font | Represents the font of shape.
Format | Obsolete. Represents the setting of the shape's formatting.
FormatPicture | Gets and sets the options of the picture format.
Geometry | Gets the geometry
Glow | Represents a object that specifies glow effect for the chart element or shape.
Group | Gets the group shape which contains this shape.
HasLine | Gets and sets the line border of the shape is visible.
Height | Represents the height of shape, in unit of pixel.
HeightCM | Represents the height of the shape, in unit of inches.
HeightInch | Represents the height of the shape, in unit of inches.
HeightInShape | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt | Represents the height of the shape, in unit of points.
HeightScale | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink | Gets the hyperlink of the shape.
Id | Gets the identifier of this shape.
InputRange | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation | Indicates whether the shape only contains an equation.
IsFilled | Indicates whether the fill format is visible.
IsFlippedHorizontally | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically | Gets and sets whether shape is vertically flipped .
IsGroup | Indicates whether the shape is a group.
IsHidden | Indicates whether the object is visible.
IsLockAspectRatio | True means that don't allow changes in aspect ratio.
IsLocked | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable | True if the object is printable
IsRichText | Whether or not the text is rich text.
IsSmartArt | Indicates whether the shape is smart art.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt | Indicates whether this shape is a word art.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner | Gets and sets the horizonal offset of shape from worksheet left border.
Line | Gets line style
LineFormat | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn | Represents lower right corner column index.
LowerRightRow | Represents lower right corner row index.
MacroName | Gets and sets the name of macro.
MsoDrawingType | Gets and sets mso drawing type.
Name | Gets and sets the name of the shape.
Paths | Gets the paths of a custom geometric shape.
Placement | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize | Indicates whether shape is relative to original picture size.
Right | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle | Gets and sets the rotation of the shape.
ShadowEffect | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid | Specifies an optional string that an application can use to Identify the particular shape.
Spt | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text | Represents the string in this TextBox object.
TextBody | Gets and sets the setting of the shape's text.
TextDirection | Gets/Sets the direction of the text flow for this object.
TextEffect | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions | Represents the text options of the shape.
TextOrientationType | Gets and sets the text orientation type of the shape.
TextShapeType | Gets and sets the preset text shape type.
TextVerticalAlignment | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat | Gets and sets 3d format of the shape.
Title | Specifies the title (caption) of the current shape object.
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type | Gets the auto shape type.
UpperDeltaX | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
Width | Represents the width of shape, in unit of pixels.
WidthCM | Represents the width of the shape, in unit of centimeters.
WidthInch | Represents the width of the shape, in unit of inch.
WidthInShape | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt | Represents the width of the shape, in unit of point.
WidthScale | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition | Returns the position of a shape in the z-order.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ActiveXControl Property

Aspose.Cells for .NET

Shape.ActiveXControl Property

Gets the ActiveX control.

public ActiveXControl ActiveXControl {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ActualLowerRightRow Property

Aspose.Cells for .NET

Shape.ActualLowerRightRow Property

Get the actual bottom row.

public int ActualLowerRightRow {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


AlternativeText Property

Aspose.Cells for .NET

Shape.AlternativeText Property

Returns or sets the descriptive (alternative) text string of the Shape object.

public string AlternativeText {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


AutoShapeType Property

Aspose.Cells for .NET

Shape.AutoShapeType Property

Gets the auto shape type.

public AutoShapeType AutoShapeType {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Bottom Property

Aspose.Cells for .NET

Shape.Bottom Property

Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.

public int Bottom {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ConnectionPoints Property

Aspose.Cells for .NET

Shape.ConnectionPoints Property

Get the connection points

public PointF[] ConnectionPoints {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ControlData Property

Aspose.Cells for .NET

Shape.ControlData Property

Gets the data of control.

public byte[] ControlData {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Fill Property

Aspose.Cells for .NET

Shape.Fill Property

Returns a FillFormat object that contains fill formatting properties for the specified shape.

public FillFormat Fill {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


FillFormat Property

Aspose.Cells for .NET

Shape.FillFormat Property

NOTE: This property is now obsolete.

Use Shape.Fill property instead.

Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.

public MsoFillFormat FillFormat {get;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Fill property. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Font Property

Aspose.Cells for .NET

Shape.Font Property

Represents the font of shape.

public Font Font {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Format Property

Aspose.Cells for .NET

Shape.Format Property

NOTE: This property is now obsolete.

Use Shape.Fill and Shape.Line properties instead.

Represents the setting of the shape's formatting.

public ShapeFormat Format {get;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Fill and Shape.Line properties. This property will be removed 6 months later since August 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


FormatPicture Property

Aspose.Cells for .NET

Shape.FormatPicture Property

Gets and sets the options of the picture format.

public MsoFormatPicture FormatPicture {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Geometry Property

Aspose.Cells for .NET

Shape.Geometry Property

Gets the geometry

public Geometry Geometry {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Glow Property

Aspose.Cells for .NET

Shape.Glow Property

Represents a object that specifies glow effect for the chart element or shape.

public GlowEffect Glow {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace | GlowEffect


Group Property

Aspose.Cells for .NET

Shape.Group Property

Gets the group shape which contains this shape.

public GroupShape Group {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HasLine Property

Aspose.Cells for .NET

Shape.HasLine Property

Gets and sets the line border of the shape is visible.

public bool HasLine {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Height Property

Aspose.Cells for .NET

Shape.Height Property

Represents the height of shape, in unit of pixel.

public int Height {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HeightCM Property

Aspose.Cells for .NET

Shape.HeightCM Property

Represents the height of the shape, in unit of inches.

public double HeightCM {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HeightInch Property

Aspose.Cells for .NET

Shape.HeightInch Property

Represents the height of the shape, in unit of inches.

public double HeightInch {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HeightInShape Property

Aspose.Cells for .NET

Shape.HeightInShape Property

Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..

public int HeightInShape {get; set;}

Remarks

Only Applies when this shape in the group or chart.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HeightPt Property

Aspose.Cells for .NET

Shape.HeightPt Property

Represents the height of the shape, in unit of points.

public double HeightPt {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HeightScale Property

Aspose.Cells for .NET

Shape.HeightScale Property

Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;

public int HeightScale {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


HtmlText Property

Aspose.Cells for .NET

Shape.HtmlText Property

Gets and sets the html string which contains data and some formats in this textbox.

public string HtmlText {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Hyperlink Property

Aspose.Cells for .NET

Shape.Hyperlink Property

Gets the hyperlink of the shape.

public Hyperlink Hyperlink {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Id Property

Aspose.Cells for .NET

Shape.Id Property

Gets the identifier of this shape.

public int Id {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


InputRange Property

Aspose.Cells for .NET

Shape.InputRange Property

Gets or sets the worksheet range used to fill the specified combo box.

public string InputRange {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsEquation Property

Aspose.Cells for .NET

Shape.IsEquation Property

Indicates whether the shape only contains an equation.

public bool IsEquation {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsFilled Property

Aspose.Cells for .NET

Shape.IsFilled Property

Indicates whether the fill format is visible.

public bool IsFilled {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsFlippedHorizontally Property

Aspose.Cells for .NET

Shape.IsFlippedHorizontally Property

Gets and sets whether shape is horizontally flipped .

public bool IsFlippedHorizontally {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsFlippedVertically Property

Aspose.Cells for .NET

Shape.IsFlippedVertically Property

Gets and sets whether shape is vertically flipped .

public bool IsFlippedVertically {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsGroup Property

Aspose.Cells for .NET

Shape.IsGroup Property

Indicates whether the shape is a group.

public bool IsGroup {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsHidden Property

Aspose.Cells for .NET

Shape.IsHidden Property

Indicates whether the object is visible.

public bool IsHidden {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsLockAspectRatio Property

Aspose.Cells for .NET

Shape.IsLockAspectRatio Property

True means that don't allow changes in aspect ratio.

public bool IsLockAspectRatio {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsLocked Property

Aspose.Cells for .NET

Shape.IsLocked Property

True if the object is locked, False if the object can be modified when the sheet is protected.

public bool IsLocked {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsPrintable Property

Aspose.Cells for .NET

Shape.IsPrintable Property

True if the object is printable

public bool IsPrintable {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsRichText Property

Aspose.Cells for .NET

Shape.IsRichText Property

Whether or not the text is rich text.

public bool IsRichText {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsSmartArt Property

Aspose.Cells for .NET

Shape.IsSmartArt Property

Indicates whether the shape is smart art.

public bool IsSmartArt {get;}

Remarks

Only for ooxml file.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsTextWrapped Property

Aspose.Cells for .NET

Shape.IsTextWrapped Property

Gets and sets the text wrapped type of the shape which contains text.

public bool IsTextWrapped {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


IsWordArt Property

Aspose.Cells for .NET

Shape.IsWordArt Property

Indicates whether this shape is a word art.

public bool IsWordArt {get;}

Remarks

Only for the Legacy Shape of xls file.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Left Property

Aspose.Cells for .NET

Shape.Left Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int Left {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LeftCM Property

Aspose.Cells for .NET

Shape.LeftCM Property

Represents the horizontal offset of shape from its left column, in unit of centimeters.

public double LeftCM {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LeftInch Property

Aspose.Cells for .NET

Shape.LeftInch Property

Represents the horizontal offset of shape from its left column, in unit of inches.

public double LeftInch {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LeftInShape Property

Aspose.Cells for .NET

Shape.LeftInShape Property

Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.

public int LeftInShape {get; set;}

Remarks

Only Applies when this shape in the group or chart.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LeftToCorner Property

Aspose.Cells for .NET

Shape.LeftToCorner Property

Gets and sets the horizonal offset of shape from worksheet left border.

public int LeftToCorner {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Line Property

Aspose.Cells for .NET

Shape.Line Property

Gets line style

public LineFormat Line {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LineFormat Property

Aspose.Cells for .NET

Shape.LineFormat Property

NOTE: This property is now obsolete.

Use Shape.Line property instead.

Returns a MsoLineFormat object that contains line formatting properties for the specified shape.

public MsoLineFormat LineFormat {get;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.Line property. This property will be removed 12 months later since July 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LinkedCell Property

Aspose.Cells for .NET

Shape.LinkedCell Property

Gets or sets the worksheet range linked to the control's value.

public string LinkedCell {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LowerDeltaX Property

Aspose.Cells for .NET

Shape.LowerDeltaX Property

Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.

public int LowerDeltaX {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LowerDeltaY Property

Aspose.Cells for .NET

Shape.LowerDeltaY Property

Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.

public int LowerDeltaY {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LowerRightColumn Property

Aspose.Cells for .NET

Shape.LowerRightColumn Property

Represents lower right corner column index.

public int LowerRightColumn {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


LowerRightRow Property

Aspose.Cells for .NET

Shape.LowerRightRow Property

Represents lower right corner row index.

public int LowerRightRow {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


MacroName Property

Aspose.Cells for .NET

Shape.MacroName Property

Gets and sets the name of macro.

public string MacroName {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


MsoDrawingType Property

Aspose.Cells for .NET

Shape.MsoDrawingType Property

Gets and sets mso drawing type.

public MsoDrawingType MsoDrawingType {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Name Property

Aspose.Cells for .NET

Shape.Name Property

Gets and sets the name of the shape.

public string Name {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Paths Property

Aspose.Cells for .NET

Shape.Paths Property

Gets the paths of a custom geometric shape.

public ShapePathCollection Paths {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Placement Property

Aspose.Cells for .NET

Shape.Placement Property

Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.

public PlacementType Placement {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Reflection Property

Aspose.Cells for .NET

Shape.Reflection Property

Represents a object that specifies reflection effect for the chart element or shape.

public ReflectionEffect Reflection {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace | ReflectionEffect


RelativeToOriginalPictureSize Property

Aspose.Cells for .NET

Shape.RelativeToOriginalPictureSize Property

Indicates whether shape is relative to original picture size.

public bool RelativeToOriginalPictureSize {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Right Property

Aspose.Cells for .NET

Shape.Right Property

Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.

public int Right {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


RotationAngle Property

Aspose.Cells for .NET

Shape.RotationAngle Property

Gets and sets the rotation of the shape.

public double RotationAngle {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ShadowEffect Property

Aspose.Cells for .NET

Shape.ShadowEffect Property

Represents a object that specifies shadow effect for the chart element or shape.

public ShadowEffect ShadowEffect {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace | ShadowEffect


SoftEdges Property

Aspose.Cells for .NET

Shape.SoftEdges Property

Gets and sets the radius of blur to apply to the edges, in unit of points.

public double SoftEdges {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Spid Property

Aspose.Cells for .NET

Shape.Spid Property

Specifies an optional string that an application can use to Identify the particular shape.

public string Spid {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Spt Property

Aspose.Cells for .NET

Shape.Spt Property

Specifies an optional number that an application can use to associate the particular shape with a defined shape type.

public int Spt {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Text Property

Aspose.Cells for .NET

Shape.Text Property

Represents the string in this TextBox object.

public string Text {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextBody Property

Aspose.Cells for .NET

Shape.TextBody Property

Gets and sets the setting of the shape's text.

public FontSettingCollection TextBody {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextDirection Property

Aspose.Cells for .NET

Shape.TextDirection Property

Gets/Sets the direction of the text flow for this object.

public TextDirectionType TextDirection {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextEffect Property

Aspose.Cells for .NET

Shape.TextEffect Property

Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.

public TextEffectFormat TextEffect {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextFrame Property

Aspose.Cells for .NET

Shape.TextFrame Property

NOTE: This property is now obsolete.

Use Shape.TextBody.TextAlignment property instead.

Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.

public MsoTextFrame TextFrame {get;}

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.TextBody.TextAlignment property. This property will be removed 12 months later since May 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextHorizontalAlignment Property

Aspose.Cells for .NET

Shape.TextHorizontalAlignment Property

Gets and sets the text horizontal alignment type of the shape.

public TextAlignmentType TextHorizontalAlignment {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextHorizontalOverflow Property

Aspose.Cells for .NET

Shape.TextHorizontalOverflow Property

Gets and sets the text horizontal overflow type of the shape which contains text.

public TextOverflowType TextHorizontalOverflow {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextOptions Property

Aspose.Cells for .NET

Shape.TextOptions Property

Represents the text options of the shape.

public TextOptions TextOptions {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextOrientationType Property

Aspose.Cells for .NET

Shape.TextOrientationType Property

Gets and sets the text orientation type of the shape.

public TextOrientationType TextOrientationType {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextShapeType Property

Aspose.Cells for .NET

Shape.TextShapeType Property

Gets and sets the preset text shape type.

public AutoShapeType TextShapeType {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextVerticalAlignment Property

Aspose.Cells for .NET

Shape.TextVerticalAlignment Property

Gets and sets the text vertical alignment type of the shape.

public TextAlignmentType TextVerticalAlignment {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TextVerticalOverflow Property

Aspose.Cells for .NET

Shape.TextVerticalOverflow Property

Gets and sets the text vertical overflow type of the shape which contains text.

public TextOverflowType TextVerticalOverflow {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ThreeDFormat Property

Aspose.Cells for .NET

Shape.ThreeDFormat Property

Gets and sets 3d format of the shape.

public ThreeDFormat ThreeDFormat {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Title Property

Aspose.Cells for .NET

Shape.Title Property

Specifies the title (caption) of the current shape object.

public string Title {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Top Property

Aspose.Cells for .NET

Shape.Top Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int Top {get; set;}

Remarks

If the shape is in the chart, represents the vertical offset of shape from its top border.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TopCM Property

Aspose.Cells for .NET

Shape.TopCM Property

Represents the vertical offset of shape from its top row, in unit of centimeters.

public double TopCM {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TopInch Property

Aspose.Cells for .NET

Shape.TopInch Property

Represents the vertical offset of shape from its top row, in unit of inches.

public double TopInch {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TopInShape Property

Aspose.Cells for .NET

Shape.TopInShape Property

Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.

public int TopInShape {get; set;}

Remarks

Only Applies when this shape in the group or chart.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


TopToCorner Property

Aspose.Cells for .NET

Shape.TopToCorner Property

Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.

public int TopToCorner {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

Shape.Type Property

Gets the auto shape type.

public AutoShapeType Type {get;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


UpperDeltaX Property

Aspose.Cells for .NET

Shape.UpperDeltaX Property

Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.

public int UpperDeltaX {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


UpperDeltaY Property

Aspose.Cells for .NET

Shape.UpperDeltaY Property

Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.

public int UpperDeltaY {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


UpperLeftColumn Property

Aspose.Cells for .NET

Shape.UpperLeftColumn Property

Represents upper left corner column index.

public int UpperLeftColumn {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


UpperLeftRow Property

Aspose.Cells for .NET

Shape.UpperLeftRow Property

Represents upper left corner row index.

public int UpperLeftRow {get; set;}

Remarks

If the shape is in the shape or in the group , UpperLeftRow will be ignored.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Width Property

Aspose.Cells for .NET

Shape.Width Property

Represents the width of shape, in unit of pixels.

public int Width {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


WidthCM Property

Aspose.Cells for .NET

Shape.WidthCM Property

Represents the width of the shape, in unit of centimeters.

public double WidthCM {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


WidthInch Property

Aspose.Cells for .NET

Shape.WidthInch Property

Represents the width of the shape, in unit of inch.

public double WidthInch {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


WidthInShape Property

Aspose.Cells for .NET

Shape.WidthInShape Property

Represents the width of the shape, in unit of 1/4000 of the parent shape.

public int WidthInShape {get; set;}

Remarks

Only Applies when this shape in the group or chart.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


WidthPt Property

Aspose.Cells for .NET

Shape.WidthPt Property

Represents the width of the shape, in unit of point.

public double WidthPt {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


WidthScale Property

Aspose.Cells for .NET

Shape.WidthScale Property

Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;

public int WidthScale {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


X Property

Aspose.Cells for .NET

Shape.X Property

Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.

public int X {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Y Property

Aspose.Cells for .NET

Shape.Y Property

Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.

public int Y {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ZOrderPosition Property

Aspose.Cells for .NET

Shape.ZOrderPosition Property

Returns the position of a shape in the z-order.

public int ZOrderPosition {get; set;}

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape Methods

The methods of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Methods

AddHyperlink | Adds a hyperlink to the shape.
AlignTopRightCorner | Moves the picture to the top-right corner.
CalculateTextSize | Recalculate the text area
Characters | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters | Overloaded. Formats some characters with the font setting.
GetCharacters | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange | Gets the range used to fill the control.
GetLinkedCell | Gets the range linked to the control's value.
GetLockedProperty | Gets the value of locked property.
GetResultOfSmartArt | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange | Moves the shape to a specified range.
RemoveActiveXControl | Remove activeX control.
RemoveHyperlink | Remove the hyperlink of the shape.
SetInputRange | Sets the range used to fill the control.
SetLinkedCell | Sets the range linked to the control's value.
SetLockedProperty | Set the locked property.
ToFrontOrBack | Brings the shape to the front or sends the shape to back.
ToImage | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue | Update the selected value by the value of the linked cell.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.AddHyperlink Method

Adds a hyperlink to the shape.

public Hyperlink AddHyperlink(
string address
);

Parameters

address
Address of the hyperlink.

Return Value

Return the new hyperlink object.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.AlignTopRightCorner Method

Moves the picture to the top-right corner.

public void AlignTopRightCorner(
int topRow,
int rightColumn
);

Parameters

topRow
the row index.
rightColumn
the column index.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.CalculateTextSize Method

Recalculate the text area

public int[] CalculateTextSize();

Return Value

Text's Size in an array(width and height).

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.Characters Method

Returns a Characters object that represents a range of characters within the text.

public FontSetting Characters(
int startIndex,
int length
);

Parameters

startIndex
The index of the start of the character.
length
The number of characters.

Return Value

Characters object.

Remarks

This method only works on shape with title.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


FormatCharacters Method

Aspose.Cells for .NET

Shape.FormatCharacters Method

NOTE: This method is now obsolete.

Shape.FormatCharacters(int startIndex, int length, Font font,StyleFlag flag) method instead.

Formats some characters with the font setting.

Overload List

Obsolete. Formats some characters with the font setting.

public void FormatCharacters(int,int,Font);

Formats some characters with the font setting.

public void FormatCharacters(int,int,Font,StyleFlag);

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.FormatCharacters Method (Int32, Int32, Font)

NOTE: This method is now obsolete.

Shape.FormatCharacters(int startIndex, int length, Font font,StyleFlag flag) method instead.

Formats some characters with the font setting.

public void FormatCharacters(
int startIndex,
int length,
Font font
);

Parameters

startIndex
The start index.
length
The length.
font
The font setting.

Remarks

NOTE: This member is now obsolete. Instead, please use Shape.FormatCharacters(int startIndex, int length, Font font, StyleFlag flag) method. This property will be removed 12 months later since March 2016. Aspose apologizes for any inconvenience you may have experienced.

See Also

Shape Class | Aspose.Cells.Drawing Namespace | Shape.FormatCharacters Overload List


Shape.FormatCharacters Method (Int32, Int32, Font, StyleFlag)

Formats some characters with the font setting.

public void FormatCharacters(
int startIndex,
int length,
Font font,
StyleFlag flag
);

Parameters

startIndex
The start index.
length
The length.
font
The font setting.
flag
The flag of the font setting.

See Also

Shape Class | Aspose.Cells.Drawing Namespace | Shape.FormatCharacters Overload List


Shape.GetCharacters Method

Returns all Characters objects that represents a range of characters within the text .

public ArrayList GetCharacters();

Return Value

All Characters objects

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.GetInputRange Method

Gets the range used to fill the control.

public string GetInputRange(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The range used to fill the control.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.GetLinkedCell Method

Gets the range linked to the control's value.

public string GetLinkedCell(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The range linked to the control's value.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.GetLockedProperty Method

Gets the value of locked property.

public bool GetLockedProperty(
ShapeLockType type
);

Parameters

type
The type of the shape locked property.

Return Value

Returns the value of locked property.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.GetResultOfSmartArt Method

Converting smart art to grouped shapes.

public virtual GroupShape GetResultOfSmartArt();

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.MoveToRange Method

Moves the shape to a specified range.

public void MoveToRange(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.RemoveActiveXControl Method

Remove activeX control.

public void RemoveActiveXControl();

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.RemoveHyperlink Method

Remove the hyperlink of the shape.

public void RemoveHyperlink();

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.SetInputRange Method

Sets the range used to fill the control.

public void SetInputRange(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
The range used to fill the control.
isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.SetLinkedCell Method

Sets the range linked to the control's value.

public void SetLinkedCell(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
The range linked to the control's value.
isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.SetLockedProperty Method

Set the locked property.

public void SetLockedProperty(
ShapeLockType type,
bool value
);

Parameters

type
The locked type.
value
The value of the property.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.ToFrontOrBack Method

Brings the shape to the front or sends the shape to back.

public void ToFrontOrBack(
int orders
);

Parameters

orders
If it's less than zero, sets the shape to back. If it's greater than zero, brings the shape to front.

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ToImage Method

Aspose.Cells for .NET

Shape.ToImage Method

Returns the bitmap object of the shape .

Overload List

Returns the bitmap object of the shape .

public Bitmap ToImage(ImageOrPrintOptions);

Saves the shape to a stream.

public void ToImage(Stream,ImageOrPrintOptions);

Creates the shape image and saves it to a stream in the specified format.

public void ToImage(Stream,ImageFormat);

Saves the shape to a file.

public void ToImage(string,ImageOrPrintOptions);

See Also

Shape Class | Aspose.Cells.Drawing Namespace


Shape.ToImage Method (ImageOrPrintOptions)

Returns the bitmap object of the shape .

public Bitmap ToImage(
ImageOrPrintOptions options
);

See Also

Shape Class | Aspose.Cells.Drawing Namespace | Shape.ToImage Overload List


Shape.ToImage Method (Stream, ImageOrPrintOptions)

Saves the shape to a stream.

public void ToImage(
Stream stream,
ImageOrPrintOptions options
);

See Also

Shape Class | Aspose.Cells.Drawing Namespace | Shape.ToImage Overload List


Shape.ToImage Method (Stream, ImageFormat)

Creates the shape image and saves it to a stream in the specified format.

public void ToImage(
Stream stream,
ImageFormat imageFormat
);

Parameters

stream
The output stream.
imageFormat
The format in which to save the image.

Remarks

The following formats are supported: .bmp, .gif, .jpg, .jpeg, .tiff, .emf.

See Also

Shape Class | Aspose.Cells.Drawing Namespace | Shape.ToImage Overload List


Shape.ToImage Method (String, ImageOrPrintOptions)

Saves the shape to a file.

public void ToImage(
string imageFile,
ImageOrPrintOptions options
);

See Also

Shape Class | Aspose.Cells.Drawing Namespace | Shape.ToImage Overload List


Shape.UpdateSelectedValue Method

Update the selected value by the value of the linked cell.

public void UpdateSelectedValue();

See Also

Shape Class | Aspose.Cells.Drawing Namespace


ShapeCollection Class

Represents all the shape in a worksheet/chart.

For a list of all members of this type, see ShapeCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.ShapeCollection

public class ShapeCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeCollection Members | Aspose.Cells.Drawing Namespace


ShapeCollection Members

ShapeCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the shape object at the specific index.

Public Instance Methods

AddActiveXControl | Creates an Activex Control.
AddArc | Adds a ArcShape to the worksheet.
AddAutoShape | Adds a AutoShape to the worksheet.
AddAutoShapeInChart | Adds a AutoShape to the chart.
AddButton | Adds a Button to the worksheet.
AddCheckBox | Adds a checkbox to the worksheet.
AddComboBox | Adds a ComboBox to the worksheet.
AddCopy | Adds and copy a shape to the worksheet..
AddFreeFloatingShape | Adds a free floating shape to the worksheet.Only applies for line/image shape.
AddGroupBox | Adds a GroupBox to the worksheet.
AddLabel | Adds a Label to the worksheet.
AddLabelInChart | Adds a label to the chart.
AddLine | Adds a LineShape to the worksheet.
AddLinkedPicture | Add a linked picture.
AddListBox | Adds a ListBox to the worksheet.
AddOleObject |
AddOleObjectWithLinkedImage | Add a linked picture.
AddOval | Adds a Oval to the worksheet.
AddPicture | Overloaded. Adds a picture to the collection.
AddPictureInChart | Adds a picture to the chart.
AddRadioButton | Adds a RadioButton to the worksheet.
AddRectangle | Adds a RectangleShape to the worksheet.
AddScrollBar | Adds a ScrollBar to the worksheet.
AddShape | Adds a Shape to the worksheet.
AddShapeInChart | Overloaded. Add a shape to chart .All unit is 1/4000 of chart area.
AddSpinner | Adds a Spinner to the worksheet.
AddSvg | Adds svg image.
AddTextBox | Adds a text box to the worksheet.
AddTextBoxInChart | Adds a textbox to the chart.
AddTextEffect | Inserts a WordArt object.
AddTextEffectInChart | Inserts a WordArt object to the chart
AddWordArt | Adds preset WordArt since Excel 2007.s
Clear | Clear all shapes.
CopyCommentsInRange | Copy all comments in the range.
CopyInRange | Copy shapes in the range to destination range.
DeleteInRange | Delete shapes in the range.Comment shapes will not be deleted.
DeleteShape | Delete a shape. If the shape is in the group or is a comment shape, it will not be deleted.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Group | Group the shapes.
Remove | Remove the shape.
RemoveAt | Remove the shape.
ToString (inherited from Object) |
Ungroup | Ungroups the shape items.
UpdateSelectedValue | Update the selected value by the value of the linked cell of the shapes.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection Properties

The properties of the ShapeCollection class are listed below. For a complete list of ShapeCollection class members, see the ShapeCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the shape object at the specific index.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

ShapeCollection.Item Property

Gets the shape object at the specific index.

Overload List

Gets the shape object at the specific index.

public Shape this[int] {get;}

Gets the shape object by the shape image

public Shape this[string] {get;}

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


Item Property (Int32)

Aspose.Cells for .NET

ShapeCollection.Item Property (Int32)

Gets the shape object at the specific index.

public Shape this[
int index
] {get;}

Parameters

index

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace | ShapeCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ShapeCollection.Item Property (String)

Gets the shape object by the shape image

public Shape this[
string name
] {get;}

Parameters

name

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace | ShapeCollection.Item Overload List


ShapeCollection Methods

The methods of the ShapeCollection class are listed below. For a complete list of ShapeCollection class members, see the ShapeCollection Members topic.

Public Instance Methods

AddActiveXControl | Creates an Activex Control.
AddArc | Adds a ArcShape to the worksheet.
AddAutoShape | Adds a AutoShape to the worksheet.
AddAutoShapeInChart | Adds a AutoShape to the chart.
AddButton | Adds a Button to the worksheet.
AddCheckBox | Adds a checkbox to the worksheet.
AddComboBox | Adds a ComboBox to the worksheet.
AddCopy | Adds and copy a shape to the worksheet..
AddFreeFloatingShape | Adds a free floating shape to the worksheet.Only applies for line/image shape.
AddGroupBox | Adds a GroupBox to the worksheet.
AddLabel | Adds a Label to the worksheet.
AddLabelInChart | Adds a label to the chart.
AddLine | Adds a LineShape to the worksheet.
AddLinkedPicture | Add a linked picture.
AddListBox | Adds a ListBox to the worksheet.
AddOleObject |
AddOleObjectWithLinkedImage | Add a linked picture.
AddOval | Adds a Oval to the worksheet.
AddPicture | Overloaded. Adds a picture to the collection.
AddPictureInChart | Adds a picture to the chart.
AddRadioButton | Adds a RadioButton to the worksheet.
AddRectangle | Adds a RectangleShape to the worksheet.
AddScrollBar | Adds a ScrollBar to the worksheet.
AddShape | Adds a Shape to the worksheet.
AddShapeInChart | Overloaded. Add a shape to chart .All unit is 1/4000 of chart area.
AddSpinner | Adds a Spinner to the worksheet.
AddSvg | Adds svg image.
AddTextBox | Adds a text box to the worksheet.
AddTextBoxInChart | Adds a textbox to the chart.
AddTextEffect | Inserts a WordArt object.
AddTextEffectInChart | Inserts a WordArt object to the chart
AddWordArt | Adds preset WordArt since Excel 2007.s
Clear | Clear all shapes.
CopyCommentsInRange | Copy all comments in the range.
CopyInRange | Copy shapes in the range to destination range.
DeleteInRange | Delete shapes in the range.Comment shapes will not be deleted.
DeleteShape | Delete a shape. If the shape is in the group or is a comment shape, it will not be deleted.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Group | Group the shapes.
Remove | Remove the shape.
RemoveAt | Remove the shape.
ToString (inherited from Object) |
Ungroup | Ungroups the shape items.
UpdateSelectedValue | Update the selected value by the value of the linked cell of the shapes.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddActiveXControl Method

Creates an Activex Control.

public Shape AddActiveXControl(
ControlType type,
int topRow,
int top,
int leftColumn,
int left,
int width,
int height
);

Parameters

type
The type of the control.
topRow
Upper left row index.
top
Represents the vertical offset of Shape from its left row, in unit of pixel.
leftColumn
Upper left column index.
left
Represents the horizontal offset of Shape from its left column, in unit of pixel.
width
Represents the width of Shape, in unit of pixel.
height
Represents the height of Shape, in unit of pixel.

Return Value

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddArc Method

Adds a ArcShape to the worksheet.

public ArcShape AddArc(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of ArcShape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of ArcShape from its left column, in unit of pixel.
height
Represents the height of ArcShape, in unit of pixel.
width
Represents the width of ArcShape, in unit of pixel.

Return Value

A ArcShape object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddAutoShape Method

Adds a AutoShape to the worksheet.

public Shape AddAutoShape(
AutoShapeType type,
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

type
Auto shape type.
upperLeftRow
Upper left row index.
top
Represents the vertical offset of Shape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of Shape from its left column, in unit of pixel.
height
Represents the height of Shape, in unit of pixel.
width
Represents the width of Shape, in unit of pixel.

Return Value

A Shape object.

Remarks

The type could not be Chart/Comment/Picture/OleObject/Polygon/DialogBox

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddAutoShapeInChart Method

Adds a AutoShape to the chart.

public Shape AddAutoShapeInChart(
AutoShapeType type,
int top,
int left,
int height,
int width
);

Parameters

type
Auto shape type.
top
Represents the vertical offset of textbox from the upper left corner in units of 1/4000 of the chart area.
left
Represents the vertical offset of textbox from the upper left corner in units of 1/4000 of the chart area.
height
Represents the height of textbox, in units of 1/4000 of the chart area.
width
Represents the width of textbox, in units of 1/4000 of the chart area.

Return Value

Returns a shape object.

Remarks

The type could not be Chart/Comment/Picture/OleObject/Polygon/DialogBox

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddButton Method

Adds a Button to the worksheet.

public Button AddButton(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of Button from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of Button from its left column, in unit of pixel.
height
Represents the height of Button, in unit of pixel.
width
Represents the width of Button, in unit of pixel.

Return Value

A Button object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddCheckBox Method

Adds a checkbox to the worksheet.

public CheckBox AddCheckBox(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of checkbox from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of textbox from its left column, in unit of pixel.
height
Height of textbox, in unit of pixel.
width
Width of textbox, in unit of pixel.

Return Value

The new CheckBox object index.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddComboBox Method

Adds a ComboBox to the worksheet.

public ComboBox AddComboBox(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of ComboBox from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of ComboBox from its left column, in unit of pixel.
height
Represents the height of ComboBox, in unit of pixel.
width
Represents the width of ComboBox, in unit of pixel.

Return Value

A ComboBox object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddCopy Method

Adds and copy a shape to the worksheet..

public Shape AddCopy(
Shape sourceShape,
int upperLeftRow,
int top,
int upperLeftColumn,
int left
);

Parameters

sourceShape
Source shape.
upperLeftRow
Upper left row index.
top
Represents the vertical offset of checkbox from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of textbox from its left column, in unit of pixel.

Return Value

The new shape object index.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddFreeFloatingShape Method

Adds a free floating shape to the worksheet.Only applies for line/image shape.

public Shape AddFreeFloatingShape(
MsoDrawingType type,
int top,
int left,
int height,
int width,
byte[] imageData,
bool isOriginalSize
);

Parameters

type
The shape type.
top
Represents the vertical offset of shape from the worksheet's top row, in unit of pixel.
left
Represents the horizontal offset of shape from the worksheet's left column, in unit of pixel.
height
Represents the height of LineShape, in unit of pixel.
width
Represents the width of LineShape, in unit of pixel.
imageData
The image data,only applies for the picture.
isOriginalSize
Whether the shape use original size if the shape is image.

Return Value

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddGroupBox Method

Adds a GroupBox to the worksheet.

public GroupBox AddGroupBox(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of GroupBox from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of GroupBox from its left column, in unit of pixel.
height
Represents the height of GroupBox, in unit of pixel.
width
Represents the width of GroupBox, in unit of pixel.

Return Value

A GroupBox object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddLabel Method

Adds a Label to the worksheet.

public Label AddLabel(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of Label from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of Label from its left column, in unit of pixel.
height
Represents the height of Label, in unit of pixel.
width
Represents the width of Label, in unit of pixel.

Return Value

A Label object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddLabelInChart Method

Adds a label to the chart.

public Label AddLabelInChart(
int top,
int left,
int height,
int width
);

Parameters

top
Represents the vertical offset of label from the upper left corner in units of 1/4000 of the chart area.
left
Represents the vertical offset of label from the upper left corner in units of 1/4000 of the chart area.
height
Represents the height of label, in units of 1/4000 of the chart area.
width
Represents the width of label, in units of 1/4000 of the chart area.

Return Value

A new Label object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddLine Method

Adds a LineShape to the worksheet.

public LineShape AddLine(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of LineShape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of LineShape from its left column, in unit of pixel.
height
Represents the height of LineShape, in unit of pixel.
width
Represents the width of LineShape, in unit of pixel.

Return Value

A LineShape object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddLinkedPicture Method

Add a linked picture.

public Picture AddLinkedPicture(
int upperLeftRow,
int upperLeftColumn,
int height,
int width,
string sourceFullName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
height
The height of the shape. In unit of pixels
width
The width of the shape. In unit of pixels
sourceFullName
The path and name of the source file for the linked image

Return Value

Picture Picture object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddListBox Method

Adds a ListBox to the worksheet.

public ListBox AddListBox(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of ListBox from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of ListBox from its left column, in unit of pixel.
height
Represents the height of ListBox, in unit of pixel.
width
Represents the width of ListBox, in unit of pixel.

Return Value

A ListBox object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddOleObject Method

public OleObject AddOleObject(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width,
byte[] imageData
);

Parameters

upperLeftRow
top
upperLeftColumn
left
height
width
imageData

Return Value

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddOleObjectWithLinkedImage Method

Add a linked picture.

public OleObject AddOleObjectWithLinkedImage(
int upperLeftRow,
int upperLeftColumn,
int height,
int width,
string sourceFullName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
height
The height of the shape. In unit of pixels
width
The width of the shape. In unit of pixels
sourceFullName
The path and name of the source file for the linked image

Return Value

Picture Picture object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddOval Method

Adds a Oval to the worksheet.

public Oval AddOval(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of Oval from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of Oval from its left column, in unit of pixel.
height
Represents the height of Oval, in unit of pixel.
width
Represents the width of Oval, in unit of pixel.

Return Value

A Oval object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


AddPicture Method

Aspose.Cells for .NET

ShapeCollection.AddPicture Method

Adds a picture to the collection.

Overload List

Adds a picture to the collection.

public Picture AddPicture(int,int,int,int,Stream);

Adds a picture to the collection.

public Picture AddPicture(int,int,Stream,int,int);

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddPicture Method (Int32, Int32, Int32, Int32, Stream)

Adds a picture to the collection.

public Picture AddPicture(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
stream
Stream object which contains the image data.

Return Value

Picture Picture object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace | ShapeCollection.AddPicture Overload List


ShapeCollection.AddPicture Method (Int32, Int32, Stream, Int32, Int32)

Adds a picture to the collection.

public Picture AddPicture(
int upperLeftRow,
int upperLeftColumn,
Stream stream,
int widthScale,
int heightScale
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
stream
Stream object which contains the image data.
widthScale
Scale of image width, a percentage.
heightScale
Scale of image height, a percentage.

Return Value

Picture Picture object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace | ShapeCollection.AddPicture Overload List


ShapeCollection.AddPictureInChart Method

Adds a picture to the chart.

public Picture AddPictureInChart(
int top,
int left,
Stream stream,
int widthScale,
int heightScale
);

Parameters

top
Represents the vertical offset of shape from the upper left corner in units of 1/4000 of the chart area.
left
Represents the horizontal offset of shape from the upper left corner in units of 1/4000 of the chart area.
stream
Stream object which contains the image data.
widthScale
Scale of image width, a percentage.
heightScale
Scale of image height, a percentage.

Return Value

Returns a Picture object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddRadioButton Method

Adds a RadioButton to the worksheet.

public RadioButton AddRadioButton(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of RadioButton from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of RadioButton from its left column, in unit of pixel.
height
Represents the height of RadioButton, in unit of pixel.
width
Represents the width of RadioButton, in unit of pixel.

Return Value

A RadioButton object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddRectangle Method

Adds a RectangleShape to the worksheet.

public RectangleShape AddRectangle(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of RectangleShape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of RectangleShape from its left column, in unit of pixel.
height
Represents the height of RectangleShape, in unit of pixel.
width
Represents the width of RectangleShape, in unit of pixel.

Return Value

A RectangleShape object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddScrollBar Method

Adds a ScrollBar to the worksheet.

public ScrollBar AddScrollBar(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of ScrollBar from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of ScrollBar from its left column, in unit of pixel.
height
Represents the height of ScrollBar, in unit of pixel.
width
Represents the width of ScrollBar, in unit of pixel.

Return Value

A ScrollBar object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddShape Method

Adds a Shape to the worksheet.

public Shape AddShape(
MsoDrawingType type,
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

type
Mso drawing type.
upperLeftRow
Upper left row index.
top
Represents the vertical offset of Shape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of Shape from its left column, in unit of pixel.
height
Represents the height of Shape, in unit of pixel.
width
Represents the width of Shape, in unit of pixel.

Return Value

A Shape object.

Remarks

The type could not be Chart/Comment/Picture/OleObject/Polygon/DialogBox

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


AddShapeInChart Method

Aspose.Cells for .NET

ShapeCollection.AddShapeInChart Method

Add a shape to chart .All unit is 1/4000 of chart area.

Overload List

Add a shape to chart .All unit is 1/4000 of chart area.

public Shape AddShapeInChart(MsoDrawingType,PlacementType,int,int,int,int);

Add a shape to chart .All unit is 1/4000 of chart area.

public Shape AddShapeInChart(MsoDrawingType,PlacementType,int,int,int,int,byte[]);

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddShapeInChart Method (MsoDrawingType, PlacementType, Int32, Int32, Int32, Int32)

Add a shape to chart .All unit is 1/4000 of chart area.

public Shape AddShapeInChart(
MsoDrawingType type,
PlacementType placement,
int left,
int top,
int right,
int bottom
);

Parameters

type
The drawing type.
placement
the placement type.
left
In unit of 1/4000 chart area width.
top
In unit of 1/4000 chart area height.
right
In unit of 1/4000 chart area width.
bottom
In unit of 1/4000 chart area height.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace | ShapeCollection.AddShapeInChart Overload List


ShapeCollection.AddShapeInChart Method (MsoDrawingType, PlacementType, Int32, Int32, Int32, Int32, Byte[])

Add a shape to chart .All unit is 1/4000 of chart area.

public Shape AddShapeInChart(
MsoDrawingType type,
PlacementType placement,
int left,
int top,
int right,
int bottom,
byte[] imageData
);

Parameters

type
The drawing type.
placement
the placement type.
left
In unit of 1/4000 chart area width.
top
In unit of 1/4000 chart area height.
right
In unit of 1/4000 chart area width.
bottom
In unit of 1/4000 chart area height.
imageData
If the shape is not a picture or ole object,imageData should be null.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace | ShapeCollection.AddShapeInChart Overload List


ShapeCollection.AddSpinner Method

Adds a Spinner to the worksheet.

public Spinner AddSpinner(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of Spinner from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of Spinner from its left column, in unit of pixel.
height
Represents the height of Spinner, in unit of pixel.
width
Represents the width of Spinner, in unit of pixel.

Return Value

A Spinner object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddSvg Method

Adds svg image.

public Picture AddSvg(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width,
byte[] svgData,
byte[] compatibleImageData
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of shape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
The horizontal offset of shape from its left column, in unit of pixel.
height
The height of shape, in unit of pixel.
width
The width of shape, in unit of pixel.
svgData
The svg image data.
compatibleImageData
Converted image data from svg in order to be compatible with Excel 2016 or lower versions.

Return Value

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddTextBox Method

Adds a text box to the worksheet.

public TextBox AddTextBox(
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
top
Represents the vertical offset of textbox from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of textbox from its left column, in unit of pixel.
height
Represents the height of textbox, in unit of pixel.
width
Represents the width of textbox, in unit of pixel.

Return Value

A TextBox object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddTextBoxInChart Method

Adds a textbox to the chart.

public TextBox AddTextBoxInChart(
int top,
int left,
int height,
int width
);

Parameters

top
Represents the vertical offset of textbox from the upper left corner in units of 1/4000 of the chart area.
left
Represents the vertical offset of textbox from the upper left corner in units of 1/4000 of the chart area.
height
Represents the height of textbox, in units of 1/4000 of the chart area.
width
Represents the width of textbox, in units of 1/4000 of the chart area.

Return Value

A TextBox object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddTextEffect Method

Inserts a WordArt object.

public Shape AddTextEffect(
MsoPresetTextEffect effect,
string text,
string fontName,
int size,
bool fontBold,
bool fontItalic,
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

effect
The mso preset text effect type.
text
The WordArt text.
fontName
The font name.
size
The font size
fontBold
Indicates whether font is bold.
fontItalic
Indicates whether font is italic.
upperLeftRow
Upper left row index.
top
Represents the vertical offset of shape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of shape from its left column, in unit of pixel.
height
Represents the height of shape, in unit of pixel.
width
Represents the width of shape, in unit of pixel.

Return Value

Returns a Shape object that represents the new WordArt object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddTextEffectInChart Method

Inserts a WordArt object to the chart

public Shape AddTextEffectInChart(
MsoPresetTextEffect effect,
string text,
string fontName,
int size,
bool fontBold,
bool fontItalic,
int top,
int left,
int height,
int width
);

Parameters

effect
The mso preset text effect type.
text
The WordArt text.
fontName
The font name.
size
The font size
fontBold
Indicates whether font is bold.
fontItalic
Indicates whether font is italic.
top
Represents the vertical offset of shape from the upper left corner in units of 1/4000 of the chart area.
left
Represents the vertical offset of shape from the upper left corner in units of 1/4000 of the chart area.
height
Represents the height of shape, in units of 1/4000 of the chart area.
width
Represents the width of shape, in units of 1/4000 of the chart area.

Return Value

Returns a Shape object that represents the new WordArt object.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.AddWordArt Method

Adds preset WordArt since Excel 2007.s

public Shape AddWordArt(
PresetWordArtStyle style,
string text,
int upperLeftRow,
int top,
int upperLeftColumn,
int left,
int height,
int width
);

Parameters

style
The preset WordArt Style.
text
The text.
upperLeftRow
Upper left row index.
top
Represents the vertical offset of shape from its left row, in unit of pixel.
upperLeftColumn
Upper left column index.
left
Represents the horizontal offset of shape from its left column, in unit of pixel.
height
Represents the height of shape, in unit of pixel.
width
Represents the width of shape, in unit of pixel.

Return Value

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.Clear Method

Clear all shapes.

new public void Clear();

Implements

IList.Clear

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.CopyCommentsInRange Method

Copy all comments in the range.

public void CopyCommentsInRange(
ShapeCollection shapes,
CellArea ca,
int destRow,
int destColumn
);

Parameters

shapes
The source shapes.
ca
The source range.
destRow
The dest range start row.
destColumn
The dest range start column.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.CopyInRange Method

Copy shapes in the range to destination range.

public void CopyInRange(
ShapeCollection sourceShapes,
CellArea ca,
int destRow,
int destColumn,
bool isContained
);

Parameters

sourceShapes
Source shapes.
ca
The source range.
destRow
The dest row index of the dest range.
destColumn
The dest column of the dest range.
isContained
Whether only copy the shapes which are contained in the range. If true,only copies the shapes in the range. Otherwise,it works as MS Office.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.DeleteInRange Method

Delete shapes in the range.Comment shapes will not be deleted.

public void DeleteInRange(
CellArea ca
);

Parameters

ca
The range.If the shapes are contained in the range, they will be removed.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.DeleteShape Method

Delete a shape. If the shape is in the group or is a comment shape, it will not be deleted.

public void DeleteShape(
Shape shape
);

Parameters

shape

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.Group Method

Group the shapes.

public GroupShape Group(
Shape[] groupItems
);

Parameters

groupItems
the group items.

Return Value

Return the group shape.

Remarks

The shape in the groupItems should not be grouped. The shape must be in this Shapes collection.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.Remove Method

Remove the shape.

public void Remove(
Shape shape
);

Parameters

shape

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.RemoveAt Method

Remove the shape.

new public void RemoveAt(
int index
);

Parameters

index
The index of the shape.

Implements

IList.RemoveAt

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.Ungroup Method

Ungroups the shape items.

public void Ungroup(
GroupShape group
);

Parameters

group
The group shape.

Remarks

If the group shape is grouped by another group shape,nothing will be done.

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeCollection.UpdateSelectedValue Method

Update the selected value by the value of the linked cell of the shapes.

public void UpdateSelectedValue();

See Also

ShapeCollection Class | Aspose.Cells.Drawing Namespace


ShapeFormat Class

NOTE: This class is now obsolete.

Use Shape.Fill and Shape.Line properties instead.

For a list of all members of this type, see ShapeFormat Members.

System.Object
Aspose.Cells.Drawing.ShapeFormat

public class ShapeFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeFormat Members | Aspose.Cells.Drawing Namespace


ShapeFormat Members

ShapeFormat overview

Public Instance Properties

Fill |
FillFormat | Obsolete.
GlowEffect |
Line |
Outline | Obsolete.
ShadowEffect |
SoftEdgeRadius |

Public Instance Methods

ClearFormat3D
ClearGlowEffect
ClearShadowEffect
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasFormat3D
HasGlowEffect
HasShadowEffect
ToString (inherited from Object)

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat Properties

The properties of the ShapeFormat class are listed below. For a complete list of ShapeFormat class members, see the ShapeFormat Members topic.

Public Instance Properties

Fill |
FillFormat | Obsolete.
GlowEffect |
Line |
Outline | Obsolete.
ShadowEffect |
SoftEdgeRadius |

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


Fill Property

Aspose.Cells for .NET

ShapeFormat.Fill Property

public FillFormat Fill {get;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


FillFormat Property

Aspose.Cells for .NET

ShapeFormat.FillFormat Property

NOTE: This property is now obsolete.

Use ShapeFormat.Fill property instead.

public FillFormat FillFormat {get;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


GlowEffect Property

Aspose.Cells for .NET

ShapeFormat.GlowEffect Property

public GlowEffect GlowEffect {get;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


Line Property

Aspose.Cells for .NET

ShapeFormat.Line Property

public LineFormat Line {get;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


Outline Property

Aspose.Cells for .NET

ShapeFormat.Outline Property

NOTE: This property is now obsolete.

Use ShapeFormat.Line property instead.

public LineFormat Outline {get;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShadowEffect Property

Aspose.Cells for .NET

ShapeFormat.ShadowEffect Property

public ShadowEffect ShadowEffect {get;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


SoftEdgeRadius Property

Aspose.Cells for .NET

ShapeFormat.SoftEdgeRadius Property

public double SoftEdgeRadius {get; set;}

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat Methods

The methods of the ShapeFormat class are listed below. For a complete list of ShapeFormat class members, see the ShapeFormat Members topic.

Public Instance Methods

ClearFormat3D
ClearGlowEffect
ClearShadowEffect
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasFormat3D
HasGlowEffect
HasShadowEffect
ToString (inherited from Object)

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat.ClearFormat3D Method

public void ClearFormat3D();

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat.ClearGlowEffect Method

public void ClearGlowEffect();

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat.ClearShadowEffect Method

public void ClearShadowEffect();

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat.HasFormat3D Method

public bool HasFormat3D();

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat.HasGlowEffect Method

public bool HasGlowEffect();

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeFormat.HasShadowEffect Method

public bool HasShadowEffect();

See Also

ShapeFormat Class | Aspose.Cells.Drawing Namespace


ShapeGuide Class

Encapsulates a shape guide specifies the presence of a shape guide that will be used to govern the geometry of the specified shape

For a list of all members of this type, see ShapeGuide Members.

System.Object
Aspose.Cells.Drawing.ShapeGuide

public class ShapeGuide

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeGuide Members | Aspose.Cells.Drawing Namespace


ShapeGuide Members

ShapeGuide overview

Public Instance Properties

Value Gets or sets value of this guide

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ShapeGuide Class | Aspose.Cells.Drawing Namespace


ShapeGuide Properties

The properties of the ShapeGuide class are listed below. For a complete list of ShapeGuide class members, see the ShapeGuide Members topic.

Public Instance Properties

Value Gets or sets value of this guide

See Also

ShapeGuide Class | Aspose.Cells.Drawing Namespace


Value Property

Aspose.Cells for .NET

ShapeGuide.Value Property

Gets or sets value of this guide

public double Value {get; set;}

See Also

ShapeGuide Class | Aspose.Cells.Drawing Namespace


ShapeGuideCollection Class

Encapsulates a collection of shape guide

For a list of all members of this type, see ShapeGuideCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.ShapeGuideCollection

public class ShapeGuideCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeGuideCollection Members | Aspose.Cells.Drawing Namespace


ShapeGuideCollection Members

ShapeGuideCollection overview

Public Instance Constructors

ShapeGuideCollection Constructor Initializes a new instance of the ShapeGuideCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets a shape guide by index

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

ShapeGuideCollection Class | Aspose.Cells.Drawing Namespace


ShapeGuideCollection Constructor

Initializes a new instance of the ShapeGuideCollection class.

public ShapeGuideCollection();

See Also

ShapeGuideCollection Class | Aspose.Cells.Drawing Namespace


ShapeGuideCollection Properties

The properties of the ShapeGuideCollection class are listed below. For a complete list of ShapeGuideCollection class members, see the ShapeGuideCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets a shape guide by index

See Also

ShapeGuideCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

ShapeGuideCollection.Item Property

Gets a shape guide by index

public ShapeGuide this[
int index
] {get;}

Parameters

index

See Also

ShapeGuideCollection Class | Aspose.Cells.Drawing Namespace


ShapeLockType Enumeration

Represents type of the property to be locked.

public enum ShapeLockType

Members

Member Name | Description | Value
Group | Group | 0
AdjustHandles | AdjustHandles | 1
Text | Text | 2
Points | Points | 3
Crop | Crop | 4
Selection | Selection | 5
Move | Move | 6
AspectRatio | AspectRatio | 7
Rotation | Rotation | 8
Ungroup | Ungroup | 9
Resize | Resize | 10
ShapeType | ShapeType | 11
Arrowhead | Arrowhead | 12

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ShapePath Class

Represents a creation path consisting of a series of moves, lines and curves that when combined will form a geometric shape.

For a list of all members of this type, see ShapePath Members.

System.Object
Aspose.Cells.Drawing.ShapePath

public class ShapePath

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapePath Members | Aspose.Cells.Drawing Namespace


ShapePath Members

ShapePath overview

Public Instance Constructors

ShapePath Constructor Initializes a new instance of the ShapePath class.

Public Instance Properties

PathSegementList Gets ShapeSegmentPathCollection list

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ShapePath Class | Aspose.Cells.Drawing Namespace


ShapePath Constructor

Initializes a new instance of the ShapePath class.

public ShapePath();

See Also

ShapePath Class | Aspose.Cells.Drawing Namespace


ShapePath Properties

The properties of the ShapePath class are listed below. For a complete list of ShapePath class members, see the ShapePath Members topic.

Public Instance Properties

PathSegementList Gets ShapeSegmentPathCollection list

See Also

ShapePath Class | Aspose.Cells.Drawing Namespace


PathSegementList Property

Aspose.Cells for .NET

ShapePath.PathSegementList Property

Gets ShapeSegmentPathCollection list

public ShapeSegmentPathCollection PathSegementList {get;}

See Also

ShapePath Class | Aspose.Cells.Drawing Namespace


ShapePathCollection Class

Represents path collection information in NotPrimitive autoshape

For a list of all members of this type, see ShapePathCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.ShapePathCollection

public class ShapePathCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapePathCollection Members | Aspose.Cells.Drawing Namespace


ShapePathCollection Members

ShapePathCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count | Gets the count of paths
Item | Gets a creation path.

Public Instance Methods

Add | Add a creation path.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ShapePathCollection Class | Aspose.Cells.Drawing Namespace


ShapePathCollection Properties

The properties of the ShapePathCollection class are listed below. For a complete list of ShapePathCollection class members, see the ShapePathCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count | Gets the count of paths
Item | Gets a creation path.

See Also

ShapePathCollection Class | Aspose.Cells.Drawing Namespace


Count Property

Aspose.Cells for .NET

ShapePathCollection.Count Property

Gets the count of paths

new public int Count {get;}

Implements

ICollection.Count

See Also

ShapePathCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

ShapePathCollection.Item Property

Gets a creation path.

public ShapePath this[
int index
] {get;}

Parameters

index
The index.

See Also

ShapePathCollection Class | Aspose.Cells.Drawing Namespace


ShapePathCollection Methods

The methods of the ShapePathCollection class are listed below. For a complete list of ShapePathCollection class members, see the ShapePathCollection Members topic.

Public Instance Methods

Add | Add a creation path.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ShapePathCollection Class | Aspose.Cells.Drawing Namespace


ShapePathCollection.Add Method

Add a creation path.

public int Add();

Return Value

Returns ShapePath object.

See Also

ShapePathCollection Class | Aspose.Cells.Drawing Namespace


ShapePathPoint Class

Represents an x-y coordinate within the path coordinate space.

For a list of all members of this type, see ShapePathPoint Members.

System.Object
Aspose.Cells.Drawing.ShapePathPoint

public class ShapePathPoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapePathPoint Members | Aspose.Cells.Drawing Namespace


ShapePathPoint Members

ShapePathPoint overview

Public Instance Properties

X | Gets and sets x coordinate for this position coordinate.
Y | Gets y coordinate for this position coordinate.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ShapePathPoint Class | Aspose.Cells.Drawing Namespace


ShapePathPoint Properties

The properties of the ShapePathPoint class are listed below. For a complete list of ShapePathPoint class members, see the ShapePathPoint Members topic.

Public Instance Properties

X | Gets and sets x coordinate for this position coordinate.
Y | Gets y coordinate for this position coordinate.

See Also

ShapePathPoint Class | Aspose.Cells.Drawing Namespace


X Property

Aspose.Cells for .NET

ShapePathPoint.X Property

Gets and sets x coordinate for this position coordinate.

public int X {get; set;}

See Also

ShapePathPoint Class | Aspose.Cells.Drawing Namespace


Y Property

Aspose.Cells for .NET

ShapePathPoint.Y Property

Gets y coordinate for this position coordinate.

public int Y {get; set;}

See Also

ShapePathPoint Class | Aspose.Cells.Drawing Namespace


ShapePathPointCollection Class

Represents all shape path points.

For a list of all members of this type, see ShapePathPointCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.ShapePathPointCollection

public class ShapePathPointCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapePathPointCollection Members | Aspose.Cells.Drawing Namespace


ShapePathPointCollection Members

ShapePathPointCollection overview

Public Instance Constructors

ShapePathPointCollection Constructor Initializes a new instance of the ShapePathPointCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets shape path point by index.

Public Instance Methods

Add | Adds a path point.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ShapePathPointCollection Class | Aspose.Cells.Drawing Namespace


ShapePathPointCollection Constructor

Initializes a new instance of the ShapePathPointCollection class.

public ShapePathPointCollection();

See Also

ShapePathPointCollection Class | Aspose.Cells.Drawing Namespace


ShapePathPointCollection Properties

The properties of the ShapePathPointCollection class are listed below. For a complete list of ShapePathPointCollection class members, see the ShapePathPointCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets shape path point by index.

See Also

ShapePathPointCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

ShapePathPointCollection.Item Property

Gets shape path point by index.

public ShapePathPoint this[
int index
] {get;}

Parameters

index
The index

See Also

ShapePathPointCollection Class | Aspose.Cells.Drawing Namespace


ShapePathPointCollection Methods

The methods of the ShapePathPointCollection class are listed below. For a complete list of ShapePathPointCollection class members, see the ShapePathPointCollection Members topic.

Public Instance Methods

Add | Adds a path point.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ShapePathPointCollection Class | Aspose.Cells.Drawing Namespace


ShapePathPointCollection.Add Method

Adds a path point.

public int Add(
int x,
int y
);

Parameters

x
The x coordinate.
y
The y coordinate.

See Also

ShapePathPointCollection Class | Aspose.Cells.Drawing Namespace


ShapePathType Enumeration

Represents path segment type.

public enum ShapePathType

Members

Member Name | Description | Value
LineTo | Straight line segment | 0
CubicBezierCurveTo | Cubic Bezier curve | 1
MoveTo | Start a new path | 2
Close | If the starting POINT and the end POINT are not the same, a single straight line is drawn to connect the starting POINT and ending POINT of the path. | 3
End | The end of the current path | 4
Escape | Escape | 5
ArcTo | An arc | 6
Unknown | Unknown | 7

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ShapePropertyCollection Class

This class specifies the visual shape properties for a chart element or shape.

For a list of all members of this type, see ShapePropertyCollection Members.

System.Object
Aspose.Cells.Drawing.ShapePropertyCollection

public class ShapePropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapePropertyCollection Members | Aspose.Cells.Drawing Namespace


ShapePropertyCollection Members

ShapePropertyCollection overview

Public Instance Properties

Format3D | Represents a object that specifies 3D shape properties for the chart element or shape.
GlowEffect | Represents a object that specifies glow effect for the chart element or shape.
ShadowEffect | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdgeRadius | Gets and sets the radius of blur to apply to the edges, in unit of points.

Public Instance Methods

ClearFormat3D | Clears the 3D shape properties of the shape.
ClearGlowEffect | Clears the glow effect of the shape.
ClearShadowEffect | Clears the shadow effect of the chart element or shape.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasFormat3D | Indicates if the shape has 3d format data.
HasGlowEffect | Indicates if the shape has glow effect data.
HasShadowEffect | Indicates if the shape has shadow effect data.
ToString (inherited from Object) |

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection Properties

The properties of the ShapePropertyCollection class are listed below. For a complete list of ShapePropertyCollection class members, see the ShapePropertyCollection Members topic.

Public Instance Properties

Format3D | Represents a object that specifies 3D shape properties for the chart element or shape.
GlowEffect | Represents a object that specifies glow effect for the chart element or shape.
ShadowEffect | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdgeRadius | Gets and sets the radius of blur to apply to the edges, in unit of points.

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


Format3D Property

Aspose.Cells for .NET

ShapePropertyCollection.Format3D Property

Represents a object that specifies 3D shape properties for the chart element or shape.

public Format3D Format3D {get;}

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace | Format3D


GlowEffect Property

Aspose.Cells for .NET

ShapePropertyCollection.GlowEffect Property

Represents a object that specifies glow effect for the chart element or shape.

public GlowEffect GlowEffect {get;}

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace | GlowEffect


ShadowEffect Property

Aspose.Cells for .NET

ShapePropertyCollection.ShadowEffect Property

Represents a object that specifies shadow effect for the chart element or shape.

public ShadowEffect ShadowEffect {get;}

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace | ShadowEffect


SoftEdgeRadius Property

Aspose.Cells for .NET

ShapePropertyCollection.SoftEdgeRadius Property

Gets and sets the radius of blur to apply to the edges, in unit of points.

public double SoftEdgeRadius {get; set;}

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection Methods

The methods of the ShapePropertyCollection class are listed below. For a complete list of ShapePropertyCollection class members, see the ShapePropertyCollection Members topic.

Public Instance Methods

ClearFormat3D | Clears the 3D shape properties of the shape.
ClearGlowEffect | Clears the glow effect of the shape.
ClearShadowEffect | Clears the shadow effect of the chart element or shape.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasFormat3D | Indicates if the shape has 3d format data.
HasGlowEffect | Indicates if the shape has glow effect data.
HasShadowEffect | Indicates if the shape has shadow effect data.
ToString (inherited from Object) |

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection.ClearFormat3D Method

Clears the 3D shape properties of the shape.

public void ClearFormat3D();

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection.ClearGlowEffect Method

Clears the glow effect of the shape.

public void ClearGlowEffect();

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection.ClearShadowEffect Method

Clears the shadow effect of the chart element or shape.

public void ClearShadowEffect();

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection.HasFormat3D Method

Indicates if the shape has 3d format data.

public bool HasFormat3D();

Return Value

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection.HasGlowEffect Method

Indicates if the shape has glow effect data.

public bool HasGlowEffect();

Return Value

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapePropertyCollection.HasShadowEffect Method

Indicates if the shape has shadow effect data.

public bool HasShadowEffect();

Return Value

See Also

ShapePropertyCollection Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPath Class

Represents a segment path in a path of the freeform.

For a list of all members of this type, see ShapeSegmentPath Members.

System.Object
Aspose.Cells.Drawing.ShapeSegmentPath

public class ShapeSegmentPath

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeSegmentPath Members | Aspose.Cells.Drawing Namespace


ShapeSegmentPath Members

ShapeSegmentPath overview

Public Instance Properties

Points | Gets the points in path segment
Type | Gets the path segment type

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ShapeSegmentPath Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPath Properties

The properties of the ShapeSegmentPath class are listed below. For a complete list of ShapeSegmentPath class members, see the ShapeSegmentPath Members topic.

Public Instance Properties

Points | Gets the points in path segment
Type | Gets the path segment type

See Also

ShapeSegmentPath Class | Aspose.Cells.Drawing Namespace


Points Property

Aspose.Cells for .NET

ShapeSegmentPath.Points Property

Gets the points in path segment

public ShapePathPointCollection Points {get;}

See Also

ShapeSegmentPath Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

ShapeSegmentPath.Type Property

Gets the path segment type

public ShapePathType Type {get;}

See Also

ShapeSegmentPath Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPathCollection Class

Represents a creation path consisting of a series of moves, lines and curves that when combined will form a geometric shape.

For a list of all members of this type, see ShapeSegmentPathCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.ShapeSegmentPathCollection

public class ShapeSegmentPathCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeSegmentPathCollection Members | Aspose.Cells.Drawing Namespace


ShapeSegmentPathCollection Members

ShapeSegmentPathCollection overview

Public Instance Constructors

ShapeSegmentPathCollection Constructor Initializes a new instance of the ShapeSegmentPathCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets ShapeSegmentPath object.

Public Instance Methods

Add | Add a segment path in creation path.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ShapeSegmentPathCollection Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPathCollection Constructor

Initializes a new instance of the ShapeSegmentPathCollection class.

public ShapeSegmentPathCollection();

See Also

ShapeSegmentPathCollection Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPathCollection Properties

The properties of the ShapeSegmentPathCollection class are listed below. For a complete list of ShapeSegmentPathCollection class members, see the ShapeSegmentPathCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets ShapeSegmentPath object.

See Also

ShapeSegmentPathCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

ShapeSegmentPathCollection.Item Property

Gets ShapeSegmentPath object.

public ShapeSegmentPath this[
int index
] {get;}

Parameters

index
The index.

See Also

ShapeSegmentPathCollection Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPathCollection Methods

The methods of the ShapeSegmentPathCollection class are listed below. For a complete list of ShapeSegmentPathCollection class members, see the ShapeSegmentPathCollection Members topic.

Public Instance Methods

Add | Add a segment path in creation path.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ShapeSegmentPathCollection Class | Aspose.Cells.Drawing Namespace


ShapeSegmentPathCollection.Add Method

Add a segment path in creation path.

public int Add(
ShapePathType type
);

Parameters

type
The path type.

Return Value

Returns the position of ShapeSegmentPath object in the list.

See Also

ShapeSegmentPathCollection Class | Aspose.Cells.Drawing Namespace


SignatureLine Class

Represent the signature line.

For a list of all members of this type, see SignatureLine Members.

System.Object
Aspose.Cells.Drawing.SignatureLine

public class SignatureLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SignatureLine Members | Aspose.Cells.Drawing Namespace


SignatureLine Members

SignatureLine overview

Public Instance Constructors

SignatureLine Constructor Initializes a new instance of the SignatureLine class.

Public Instance Properties

AllowComments | Indicates whether comments could be attached.
Email | Gets and sets the email of singer.
Instructions | Gets and sets the text shown to user at signing time.
IsLine | Indicates whether it is a signature line.
ProviderId | Gets and sets the id of signature provider.
ShowSignedDate | Indicates whether show signed date.
Signer | Gets and sets the singer.
Title | Gets and sets the title of singer.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


SignatureLine Constructor

Initializes a new instance of the SignatureLine class.

public SignatureLine();

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


SignatureLine Properties

The properties of the SignatureLine class are listed below. For a complete list of SignatureLine class members, see the SignatureLine Members topic.

Public Instance Properties

AllowComments | Indicates whether comments could be attached.
Email | Gets and sets the email of singer.
Instructions | Gets and sets the text shown to user at signing time.
IsLine | Indicates whether it is a signature line.
ProviderId | Gets and sets the id of signature provider.
ShowSignedDate | Indicates whether show signed date.
Signer | Gets and sets the singer.
Title | Gets and sets the title of singer.

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


AllowComments Property

Aspose.Cells for .NET

SignatureLine.AllowComments Property

Indicates whether comments could be attached.

public bool AllowComments {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


Email Property

Aspose.Cells for .NET

SignatureLine.Email Property

Gets and sets the email of singer.

public string Email {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


Instructions Property

Aspose.Cells for .NET

SignatureLine.Instructions Property

Gets and sets the text shown to user at signing time.

public string Instructions {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


IsLine Property

Aspose.Cells for .NET

SignatureLine.IsLine Property

Indicates whether it is a signature line.

public bool IsLine {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


ProviderId Property

Aspose.Cells for .NET

SignatureLine.ProviderId Property

Gets and sets the id of signature provider.

public Guid ProviderId {get; set;}

Remarks

It's typically the CLSID of the provider com add-in.

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


ShowSignedDate Property

Aspose.Cells for .NET

SignatureLine.ShowSignedDate Property

Indicates whether show signed date.

public bool ShowSignedDate {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


Signer Property

Aspose.Cells for .NET

SignatureLine.Signer Property

Gets and sets the singer.

public string Signer {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


Title Property

Aspose.Cells for .NET

SignatureLine.Title Property

Gets and sets the title of singer.

public string Title {get; set;}

See Also

SignatureLine Class | Aspose.Cells.Drawing Namespace


SmartArtShape Class

Represents the smart art.

For a list of all members of this type, see SmartArtShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.SmartArtShape

public class SmartArtShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartArtShape Members | Aspose.Cells.Drawing Namespace


SmartArtShape Members

SmartArtShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

SmartArtShape Class | Aspose.Cells.Drawing Namespace


SmartArtShape Methods

The methods of the SmartArtShape class are listed below. For a complete list of SmartArtShape class members, see the SmartArtShape Members topic.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

SmartArtShape Class | Aspose.Cells.Drawing Namespace


SmartArtShape.GetResultOfSmartArt Method

Converting smart art to grouped shapes.

public override GroupShape GetResultOfSmartArt();

See Also

SmartArtShape Class | Aspose.Cells.Drawing Namespace


SolidFill Class

Encapsulates the object that represents solid fill format

For a list of all members of this type, see SolidFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.SolidFill

public class SolidFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SolidFill Members | Aspose.Cells.Drawing Namespace


SolidFill Members

SolidFill overview

Public Instance Properties

CellsColor | Gets and sets the CellsColor object.
Color | Gets or sets the Color.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SolidFill Class | Aspose.Cells.Drawing Namespace


SolidFill Properties

The properties of the SolidFill class are listed below. For a complete list of SolidFill class members, see the SolidFill Members topic.

Public Instance Properties

CellsColor | Gets and sets the CellsColor object.
Color | Gets or sets the Color.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

See Also

SolidFill Class | Aspose.Cells.Drawing Namespace


CellsColor Property

Aspose.Cells for .NET

SolidFill.CellsColor Property

Gets and sets the CellsColor object.

public CellsColor CellsColor {get; set;}

See Also

SolidFill Class | Aspose.Cells.Drawing Namespace


Color Property

Aspose.Cells for .NET

SolidFill.Color Property

Gets or sets the Color.

public Color Color {get; set;}

See Also

SolidFill Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

SolidFill.Transparency Property

Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

SolidFill Class | Aspose.Cells.Drawing Namespace


Spinner Class

Represents the Forms control: Spinner.

For a list of all members of this type, see Spinner Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.Spinner

public class Spinner : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Scroll value must be between 0 and 30000.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Spinner Members | Aspose.Cells.Drawing Namespace


Spinner Members

Spinner overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
CurrentValue | Gets or sets the current value.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
IncrementalChange | Gets or sets the amount that the scroll bar or spinner is incremented a line scroll.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsHorizontal | Indicates whether this is a horizontal scroll bar.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
Max | Gets or sets the maximum value of a scroll bar or spinner range.
Min | Gets or sets the minimum value of a scroll bar or spinner range.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the shape has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


Spinner Properties

The properties of the Spinner class are listed below. For a complete list of Spinner class members, see the Spinner Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
CurrentValue | Gets or sets the current value.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
IncrementalChange | Gets or sets the amount that the scroll bar or spinner is incremented a line scroll.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsHorizontal | Indicates whether this is a horizontal scroll bar.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
Max | Gets or sets the maximum value of a scroll bar or spinner range.
Min | Gets or sets the minimum value of a scroll bar or spinner range.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
Shadow | Indicates whether the shape has 3-D shading.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


CurrentValue Property

Aspose.Cells for .NET

Spinner.CurrentValue Property

Gets or sets the current value.

public int CurrentValue {get; set;}

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


IncrementalChange Property

Aspose.Cells for .NET

Spinner.IncrementalChange Property

Gets or sets the amount that the scroll bar or spinner is incremented a line scroll.

public int IncrementalChange {get; set;}

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


IsHorizontal Property

Aspose.Cells for .NET

Spinner.IsHorizontal Property

Indicates whether this is a horizontal scroll bar.

public bool IsHorizontal {get; set;}

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


Max Property

Aspose.Cells for .NET

Spinner.Max Property

Gets or sets the maximum value of a scroll bar or spinner range.

public int Max {get; set;}

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


Min Property

Aspose.Cells for .NET

Spinner.Min Property

Gets or sets the minimum value of a scroll bar or spinner range.

public int Min {get; set;}

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


Shadow Property

Aspose.Cells for .NET

Spinner.Shadow Property

Indicates whether the shape has 3-D shading.

public bool Shadow {get; set;}

See Also

Spinner Class | Aspose.Cells.Drawing Namespace


TextBox Class

Encapsulates the object that represents a textbox in a spreadsheet.

For a list of all members of this type, see TextBox Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.TextBox

public class TextBox : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate a new Workbook.
Workbook workbook = new Workbook();
//Get the first worksheet in the book.
Worksheet worksheet = workbook.Worksheets[0];
//Add a new textbox to the collection.
int textboxIndex = worksheet.TextBoxes.Add(2, 1, 160, 200);
//Get the textbox object.
Aspose.Cells.TextBox textbox0 = worksheet.TextBoxes[textboxIndex];
//Fill the text.
textbox0.Text = "ASPOSE______The .NET and JAVA Component Publisher!";
//Get the textbox text frame.
MsoTextFrame textframe0 = textbox0.TextFrame;
//Set the textbox to adjust it according to its contents.
textframe0.AutoSize = true;
//Set the placement.
textbox0.Placement = PlacementType.FreeFloating;
//Set the font color.
textbox0.Font.Color = Color.Blue;
//Set the font to bold.
textbox0.Font.IsBold = true;
//Set the font size.
textbox0.Font.Size = 14;
//Set font attribute to italic.
textbox0.Font.IsItalic = true;
//Add a hyperlink to the textbox.
textbox0.AddHyperlink("http://www.aspose.com/");
//Get the filformat of the textbox.
MsoFillFormat fillformat = textbox0.FillFormat;
//Set the fillcolor.
fillformat.ForeColor = Color.Silver;
//Get the lineformat type of the textbox.
MsoLineFormat lineformat = textbox0.LineFormat;
//Set the line style.
lineformat.Style = MsoLineStyle.ThinThick;
//Set the line weight.
lineformat.Weight = 6;
//Set the dash style to squaredot.
lineformat.DashStyle = MsoLineDashStyle.SquareDot;
//Add another textbox.
textboxIndex = worksheet.TextBoxes.Add(15, 4, 85, 120);
//Get the second textbox.
Aspose.Cells.TextBox textbox1 = worksheet.TextBoxes[textboxIndex];
//Input some text to it.
textbox1.Text = "This is another simple text box";
//Set the placement type as the textbox will move and
//resize with cells.
textbox1.Placement = PlacementType.MoveAndSize;
//Save the excel file.
workbook.Save("C:\\tsttextboxes.xls");

[Visual Basic]

'Instantiate a new Workbook.
Dim workbook As Workbook = New Workbook()
'Get the first worksheet in the book.
Dim worksheet As Worksheet = workbook.Worksheets(0)
'Add a new textbox to the collection.
Dim textboxIndex As Integer = worksheet.TextBoxes.Add(2, 1, 160, 200)
'Get the textbox object.
Dim textbox0 As Aspose.Cells.TextBox = worksheet.TextBoxes(textboxIndex)
'Fill the text.
textbox0.Text = "ASPOSE______The .NET and JAVA Component Publisher!"
'Get the textbox text frame.
Dim textframe0 As MsoTextFrame = textbox0.TextFrame
'Set the textbox to adjust it according to its contents.
textframe0.AutoSize = True
'Set the placement.
textbox0.Placement = PlacementType.FreeFloating
'Set the font color.
textbox0.Font.Color = Color.Blue
'Set the font to bold.
textbox0.Font.IsBold = True
'Set the font size.
textbox0.Font.Size = 14
'Set font attribute to italic.
textbox0.Font.IsItalic = True
'Add a hyperlink to the textbox.
textbox0.AddHyperlink("http://www.aspose.com/")
'Get the filformat of the textbox.
Dim fillformat As MsoFillFormat = textbox0.FillFormat
'Set the fillcolor.
fillformat.ForeColor = Color.Silver
'Get the lineformat type of the textbox.
Dim lineformat As MsoLineFormat = textbox0.LineFormat
'Set the line style.
lineformat.Style = MsoLineStyle.ThinThick
'Set the line weight.
lineformat.Weight = 6
'Set the dash style to squaredot.
lineformat.DashStyle = MsoLineDashStyle.SquareDot
'Add another textbox.
textboxIndex = worksheet.TextBoxes.Add(15, 4, 85, 120)
'Get the second textbox.
Dim textbox1 As Aspose.Cells.TextBox = worksheet.TextBoxes(textboxIndex)
'Input some text to it.
textbox1.Text = "This is another simple text box"
'Set the placement type as the textbox will move and
'resize with cells.
textbox1.Placement = PlacementType.MoveAndSize
'Save the excel file.
workbook.Save("C:\tsttextboxes.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextBox Members | Aspose.Cells.Drawing Namespace


TextBox Members

TextBox overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

TextBox Class | Aspose.Cells.Drawing Namespace


TextBoxCollection Class

Encapsulates a collection of TextBox objects.

For a list of all members of this type, see TextBoxCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.TextBoxCollection

public class TextBoxCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextBoxCollection Members | Aspose.Cells.Drawing Namespace


TextBoxCollection Members

TextBoxCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the TextBox element at the specified index.

Public Instance Methods

Add | Adds a textbox to the collection.
Clear | Clear all text boxes.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove a text box from the file.
ToString (inherited from Object) |

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


TextBoxCollection Properties

The properties of the TextBoxCollection class are listed below. For a complete list of TextBoxCollection class members, see the TextBoxCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the TextBox element at the specified index.

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


Item Property

Aspose.Cells for .NET

TextBoxCollection.Item Property

Gets the TextBox element at the specified index.

Overload List

Gets the TextBox element at the specified index.

public TextBox this[int] {get;}

Gets the TextBox element by the name.

public TextBox this[string] {get;}

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


Item Property (Int32)

Aspose.Cells for .NET

TextBoxCollection.Item Property (Int32)

Gets the TextBox element at the specified index.

public TextBox this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace | TextBoxCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

TextBoxCollection.Item Property (String)

Gets the TextBox element by the name.

public TextBox this[
string name
] {get;}

Parameters

name
The name of the text box.

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace | TextBoxCollection.Item Overload List


TextBoxCollection Methods

The methods of the TextBoxCollection class are listed below. For a complete list of TextBoxCollection class members, see the TextBoxCollection Members topic.

Public Instance Methods

Add | Adds a textbox to the collection.
Clear | Clear all text boxes.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove a text box from the file.
ToString (inherited from Object) |

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


TextBoxCollection.Add Method

Adds a textbox to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int height,
int width
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
height
Height of textbox, in unit of pixel.
width
Width of textbox, in unit of pixel.

Return Value

TextBox object index.

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


TextBoxCollection.Clear Method

Clear all text boxes.

new public void Clear();

Implements

IList.Clear

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


TextBoxCollection.RemoveAt Method

Remove a text box from the file.

new public void RemoveAt(
int index
);

Parameters

index
The text box index.

Implements

IList.RemoveAt

See Also

TextBoxCollection Class | Aspose.Cells.Drawing Namespace


TextEffectFormat Class

Contains properties and methods that apply to WordArt objects.

For a list of all members of this type, see TextEffectFormat Members.

System.Object
Aspose.Cells.Drawing.TextEffectFormat

public class TextEffectFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiating a Workbook object
Workbook workbook = new Workbook();
Shapes shapes = workbook.Worksheets[0].Shapes;
shapes.AddTextEffect(MsoPresetTextEffect.TextEffect1, "Aspose", "Arial", 30, false, false, 0, 0, 0, 0, 100, 200);
TextEffectFormat textEffectFormat = shapes[0].TextEffect;
textEffectFormat.SetTextEffect(MsoPresetTextEffect.TextEffect10);
workbook.Save("C:\\Book1.xls");

[Visual Basic]

'Instantiating a Workbook object
Dim workbook As Workbook = New Workbook()
Dim shapes As Shapes = workbook.Worksheets(0).Shapes
shapes.AddTextEffect(MsoPresetTextEffect.TextEffect1, "Aspose", "Arial", 30, false, false, 0, 0, 0, 0, 100, 200)
Dim textEffectFormat As TextEffectFormat = shapes(0).TextEffect
TextEffectFormat.SetTextEffect(MsoPresetTextEffect.TextEffect10)
workbook.Save("C:\\Book1.xls")

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextEffectFormat Members | Aspose.Cells.Drawing Namespace


TextEffectFormat Members

TextEffectFormat overview

Public Instance Properties

FontBold | Indicates whether font is bold.
FontItalic | Indicates whether font is italic.
FontName | The name of the font used in the WordArt.
FontSize | The size (in points) of the font used in the WordArt.
PresetShape | Gets and sets the preset shape type.
RotatedChars | If true,characters in the specified WordArt are rotated 90 degrees relative to the WordArt's bounding shape.
Text | The text in the WordArt.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetTextEffect | Sets the preset text effect.
ToString (inherited from Object) |

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


TextEffectFormat Properties

The properties of the TextEffectFormat class are listed below. For a complete list of TextEffectFormat class members, see the TextEffectFormat Members topic.

Public Instance Properties

FontBold | Indicates whether font is bold.
FontItalic | Indicates whether font is italic.
FontName | The name of the font used in the WordArt.
FontSize | The size (in points) of the font used in the WordArt.
PresetShape | Gets and sets the preset shape type.
RotatedChars | If true,characters in the specified WordArt are rotated 90 degrees relative to the WordArt's bounding shape.
Text | The text in the WordArt.

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


FontBold Property

Aspose.Cells for .NET

TextEffectFormat.FontBold Property

Indicates whether font is bold.

public bool FontBold {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


FontItalic Property

Aspose.Cells for .NET

TextEffectFormat.FontItalic Property

Indicates whether font is italic.

public bool FontItalic {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


FontName Property

Aspose.Cells for .NET

TextEffectFormat.FontName Property

The name of the font used in the WordArt.

public string FontName {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


FontSize Property

Aspose.Cells for .NET

TextEffectFormat.FontSize Property

The size (in points) of the font used in the WordArt.

public int FontSize {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


PresetShape Property

Aspose.Cells for .NET

TextEffectFormat.PresetShape Property

Gets and sets the preset shape type.

public MsoPresetTextEffectShape PresetShape {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


RotatedChars Property

Aspose.Cells for .NET

TextEffectFormat.RotatedChars Property

If true,characters in the specified WordArt are rotated 90 degrees relative to the WordArt's bounding shape.

public bool RotatedChars {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


Text Property

Aspose.Cells for .NET

TextEffectFormat.Text Property

The text in the WordArt.

public string Text {get; set;}

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


TextEffectFormat Methods

The methods of the TextEffectFormat class are listed below. For a complete list of TextEffectFormat class members, see the TextEffectFormat Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetTextEffect | Sets the preset text effect.
ToString (inherited from Object) |

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


TextEffectFormat.SetTextEffect Method

Sets the preset text effect.

public void SetTextEffect(
MsoPresetTextEffect effect
);

Parameters

effect
The preset text effect.

See Also

TextEffectFormat Class | Aspose.Cells.Drawing Namespace


TextOverflowType Enumeration

Represents the way the text vertical or horizontal overflow.

public enum TextOverflowType

Members

Member Name | Description | Value
Clip | Pay attention to top and bottom barriers. Provide no indication that there is text which is not visible. | 0
Ellipsis | Pay attention to top and bottom barriers. Use an ellipsis to denote that there is text which is not visible. Only for vertical overflow. | 1
Overflow | Overflow the text and pay no attention to top and bottom barriers. | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


TextureFill Class

Encapsulates the object that represents texture fill format

For a list of all members of this type, see TextureFill Members.

System.Object
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.TextureFill

public class TextureFill : Fill

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextureFill Members | Aspose.Cells.Drawing Namespace


TextureFill Members

TextureFill overview

Public Instance Properties

ImageData | Gets and sets the image data of the fill.
IsTiling | Indicates whether tile picture as texture.
PicFormatOption | Gets or sets picture format option.
PictureFormatType | Gets and sets the picture format type.
Scale | Gets and sets the picture format scale.
TilePicOption | Gets or sets tile picture option.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Type | Gets and sets the texture type

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


TextureFill Properties

The properties of the TextureFill class are listed below. For a complete list of TextureFill class members, see the TextureFill Members topic.

Public Instance Properties

ImageData | Gets and sets the image data of the fill.
IsTiling | Indicates whether tile picture as texture.
PicFormatOption | Gets or sets picture format option.
PictureFormatType | Gets and sets the picture format type.
Scale | Gets and sets the picture format scale.
TilePicOption | Gets or sets tile picture option.
Transparency | Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).
Type | Gets and sets the texture type

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


ImageData Property

Aspose.Cells for .NET

TextureFill.ImageData Property

Gets and sets the image data of the fill.

public byte[] ImageData {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


IsTiling Property

Aspose.Cells for .NET

TextureFill.IsTiling Property

Indicates whether tile picture as texture.

public bool IsTiling {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


PicFormatOption Property

Aspose.Cells for .NET

TextureFill.PicFormatOption Property

Gets or sets picture format option.

public PicFormatOption PicFormatOption {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


PictureFormatType Property

Aspose.Cells for .NET

TextureFill.PictureFormatType Property

Gets and sets the picture format type.

public FillPictureType PictureFormatType {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


Scale Property

Aspose.Cells for .NET

TextureFill.Scale Property

Gets and sets the picture format scale.

public double Scale {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


TilePicOption Property

Aspose.Cells for .NET

TextureFill.TilePicOption Property

Gets or sets tile picture option.

public TilePicOption TilePicOption {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


Transparency Property

Aspose.Cells for .NET

TextureFill.Transparency Property

Returns or sets the degree of transparency of the area as a value from 0.0 (opaque) through 1.0 (clear).

public double Transparency {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


Type Property

Aspose.Cells for .NET

TextureFill.Type Property

Gets and sets the texture type

public TextureType Type {get; set;}

See Also

TextureFill Class | Aspose.Cells.Drawing Namespace


TextureType Enumeration

Represents the preset texture type.

public enum TextureType

Members

Member Name | Description | Value
BlueTissuePaper | Represents Blue Tissue Paper texture type. | 0
Bouquet | Represents Bouquet texture type. | 1
BrownMarble | Represents Brown Marble texture type. | 2
Canvas | Represents Canvas texture type. | 3
Cork | Represents Cork texture type. | 4
Denim | Represents Denim texture type. | 5
FishFossil | Represents Fish Fossil texture type. | 6
Granite | Represents Granite texture type. | 7
GreenMarble | Represents Green Marble texture type. | 8
MediumWood | Represents Medium Wood texture type. | 9
Newsprint | Represents Newsprint texture type. | 10
Oak | Represents Oak texture type. | 11
PaperBag | Represents Paper Bag texture type. | 12
Papyrus | Represents Papyrus texture type. | 13
Parchment | Represents Parchment texture type. | 14
PinkTissuePaper | Represents Pink Tissue Paper texture type. | 15
PurpleMesh | Represents Purple Mesh texture type. | 16
RecycledPaper | Represents Recycled Paper texture type. | 17
Sand | Represents Sand texture type. | 18
Stationery | Represents Stationery texture type. | 19
Walnut | Represents Walnut Droplets texture type. | 20
WaterDroplets | Represents Water Droplets texture type. | 21
WhiteMarble | Represents White Marble texture type. | 22
WovenMat | Represents Woven Mat texture type. | 23
Unknown | Represents Unknown texture type. | 24

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


ThreeDFormat Class

Represents a shape's three-dimensional formatting.

For a list of all members of this type, see ThreeDFormat Members.

System.Object
Aspose.Cells.Drawing.ThreeDFormat

public class ThreeDFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ThreeDFormat Members | Aspose.Cells.Drawing Namespace


ThreeDFormat Members

ThreeDFormat overview

Public Instance Properties

BottomBevelHeight | Gets and sets the height of the bottom bevel, or how far into the shape it is applied. In unit of Points.
BottomBevelType | Gets and sets the type of the bottom bevel, or how far into the shape it is applied. In unit of Points.
BottomBevelWidth | Gets and sets the width of the bottom bevel, or how far into the shape it is applied. In unit of Points.
ContourColor | Gets and sets the contour color on a shape.
ContourWidth | Gets and sets the contour width on the shape, in unit of points.
ExtrusionColor | Gets the extrusion color on a shape.
ExtrusionHeight | Gets and sets the extrusion height of the applied to the shape, in unit of points.
LightAngle | Gets and sets the angle of the extrusion lights.
Lighting | Gets and sets type of light rig.
LightingDirection | Gets and sets the direction from which the light rig is oriented in relation to the scene.
Material | Represents the preset material which is combined with the lighting properties to give the final look and feel of a shape.
Perspective | Gets and sets the angle at which a ThreeDFormat object can be viewed.
PresetCameraType | Gets and sets the extrusion preset camera type.
RotationX | Gets and sets the rotation of the extruded shape around the x-axis in degrees.
RotationY | Gets and sets the rotation of the extruded shape around the y-axis in degrees.
RotationZ | Gets and sets the rotation of the extruded shape around the z-axis in degrees.
TopBevelHeight | Gets and sets the height of the top bevel, or how far into the shape it is applied. In unit of Points.
TopBevelType | Gets and sets the type of the top bevel, or how far into the shape it is applied. In unit of Points.
TopBevelWidth | Gets and sets the width of the top bevel, or how far into the shape it is applied. In unit of Points.
Z | Defines the distance from ground for the 3D shape.

Public Instance Methods

Equals |
GetHashCode | Gets hashcode.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ThreeDFormat Properties

The properties of the ThreeDFormat class are listed below. For a complete list of ThreeDFormat class members, see the ThreeDFormat Members topic.

Public Instance Properties

BottomBevelHeight | Gets and sets the height of the bottom bevel, or how far into the shape it is applied. In unit of Points.
BottomBevelType | Gets and sets the type of the bottom bevel, or how far into the shape it is applied. In unit of Points.
BottomBevelWidth | Gets and sets the width of the bottom bevel, or how far into the shape it is applied. In unit of Points.
ContourColor | Gets and sets the contour color on a shape.
ContourWidth | Gets and sets the contour width on the shape, in unit of points.
ExtrusionColor | Gets the extrusion color on a shape.
ExtrusionHeight | Gets and sets the extrusion height of the applied to the shape, in unit of points.
LightAngle | Gets and sets the angle of the extrusion lights.
Lighting | Gets and sets type of light rig.
LightingDirection | Gets and sets the direction from which the light rig is oriented in relation to the scene.
Material | Represents the preset material which is combined with the lighting properties to give the final look and feel of a shape.
Perspective | Gets and sets the angle at which a ThreeDFormat object can be viewed.
PresetCameraType | Gets and sets the extrusion preset camera type.
RotationX | Gets and sets the rotation of the extruded shape around the x-axis in degrees.
RotationY | Gets and sets the rotation of the extruded shape around the y-axis in degrees.
RotationZ | Gets and sets the rotation of the extruded shape around the z-axis in degrees.
TopBevelHeight | Gets and sets the height of the top bevel, or how far into the shape it is applied. In unit of Points.
TopBevelType | Gets and sets the type of the top bevel, or how far into the shape it is applied. In unit of Points.
TopBevelWidth | Gets and sets the width of the top bevel, or how far into the shape it is applied. In unit of Points.
Z | Defines the distance from ground for the 3D shape.

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


BottomBevelHeight Property

Aspose.Cells for .NET

ThreeDFormat.BottomBevelHeight Property

Gets and sets the height of the bottom bevel, or how far into the shape it is applied. In unit of Points.

public double BottomBevelHeight {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


BottomBevelType Property

Aspose.Cells for .NET

ThreeDFormat.BottomBevelType Property

Gets and sets the type of the bottom bevel, or how far into the shape it is applied. In unit of Points.

public BevelType BottomBevelType {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


BottomBevelWidth Property

Aspose.Cells for .NET

ThreeDFormat.BottomBevelWidth Property

Gets and sets the width of the bottom bevel, or how far into the shape it is applied. In unit of Points.

public double BottomBevelWidth {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ContourColor Property

Aspose.Cells for .NET

ThreeDFormat.ContourColor Property

Gets and sets the contour color on a shape.

public CellsColor ContourColor {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ContourWidth Property

Aspose.Cells for .NET

ThreeDFormat.ContourWidth Property

Gets and sets the contour width on the shape, in unit of points.

public double ContourWidth {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ExtrusionColor Property

Aspose.Cells for .NET

ThreeDFormat.ExtrusionColor Property

Gets the extrusion color on a shape.

public CellsColor ExtrusionColor {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ExtrusionHeight Property

Aspose.Cells for .NET

ThreeDFormat.ExtrusionHeight Property

Gets and sets the extrusion height of the applied to the shape, in unit of points.

public double ExtrusionHeight {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


LightAngle Property

Aspose.Cells for .NET

ThreeDFormat.LightAngle Property

Gets and sets the angle of the extrusion lights.

public double LightAngle {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


Lighting Property

Aspose.Cells for .NET

ThreeDFormat.Lighting Property

Gets and sets type of light rig.

public LightRigType Lighting {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


LightingDirection Property

Aspose.Cells for .NET

ThreeDFormat.LightingDirection Property

Gets and sets the direction from which the light rig is oriented in relation to the scene.

public LightRigDirectionType LightingDirection {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


Material Property

Aspose.Cells for .NET

ThreeDFormat.Material Property

Represents the preset material which is combined with the lighting properties to give the final look and feel of a shape.

public PresetMaterialType Material {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


Perspective Property

Aspose.Cells for .NET

ThreeDFormat.Perspective Property

Gets and sets the angle at which a ThreeDFormat object can be viewed.

public double Perspective {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


PresetCameraType Property

Aspose.Cells for .NET

ThreeDFormat.PresetCameraType Property

Gets and sets the extrusion preset camera type.

public PresetCameraType PresetCameraType {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


RotationX Property

Aspose.Cells for .NET

ThreeDFormat.RotationX Property

Gets and sets the rotation of the extruded shape around the x-axis in degrees.

public double RotationX {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


RotationY Property

Aspose.Cells for .NET

ThreeDFormat.RotationY Property

Gets and sets the rotation of the extruded shape around the y-axis in degrees.

public double RotationY {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


RotationZ Property

Aspose.Cells for .NET

ThreeDFormat.RotationZ Property

Gets and sets the rotation of the extruded shape around the z-axis in degrees.

public double RotationZ {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


TopBevelHeight Property

Aspose.Cells for .NET

ThreeDFormat.TopBevelHeight Property

Gets and sets the height of the top bevel, or how far into the shape it is applied. In unit of Points.

public double TopBevelHeight {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


TopBevelType Property

Aspose.Cells for .NET

ThreeDFormat.TopBevelType Property

Gets and sets the type of the top bevel, or how far into the shape it is applied. In unit of Points.

public BevelType TopBevelType {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


TopBevelWidth Property

Aspose.Cells for .NET

ThreeDFormat.TopBevelWidth Property

Gets and sets the width of the top bevel, or how far into the shape it is applied. In unit of Points.

public double TopBevelWidth {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


Z Property

Aspose.Cells for .NET

ThreeDFormat.Z Property

Defines the distance from ground for the 3D shape.

public double Z {get; set;}

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ThreeDFormat Methods

The methods of the ThreeDFormat class are listed below. For a complete list of ThreeDFormat class members, see the ThreeDFormat Members topic.

Public Instance Methods

Equals |
GetHashCode | Gets hashcode.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ThreeDFormat.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


ThreeDFormat.GetHashCode Method

Gets hashcode.

public override int GetHashCode();

Return Value

See Also

ThreeDFormat Class | Aspose.Cells.Drawing Namespace


TilePicOption Class

Represents tile picture as texture.

For a list of all members of this type, see TilePicOption Members.

System.Object
Aspose.Cells.Drawing.TilePicOption

public class TilePicOption

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TilePicOption Members | Aspose.Cells.Drawing Namespace


TilePicOption Members

TilePicOption overview

Public Instance Constructors

TilePicOption Constructor Initializes a new instance of the TilePicOption class.

Public Instance Properties

AlignmentType | Gets or sets the alignment for tiling.
MirrorType | Gets or sets the mirror type for tiling.
OffsetX | Gets or sets the X offset for tiling picture.
OffsetY | Gets or sets the Y offset for tiling picture.
ScaleX | Gets or sets the X scale for tiling picture.
ScaleY | Gets or sets the Y scale for tiling picture.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


TilePicOption Constructor

Initializes a new instance of the TilePicOption class.

public TilePicOption();

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


TilePicOption Properties

The properties of the TilePicOption class are listed below. For a complete list of TilePicOption class members, see the TilePicOption Members topic.

Public Instance Properties

AlignmentType | Gets or sets the alignment for tiling.
MirrorType | Gets or sets the mirror type for tiling.
OffsetX | Gets or sets the X offset for tiling picture.
OffsetY | Gets or sets the Y offset for tiling picture.
ScaleX | Gets or sets the X scale for tiling picture.
ScaleY | Gets or sets the Y scale for tiling picture.

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


AlignmentType Property

Aspose.Cells for .NET

TilePicOption.AlignmentType Property

Gets or sets the alignment for tiling.

public RectangleAlignmentType AlignmentType {get; set;}

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


MirrorType Property

Aspose.Cells for .NET

TilePicOption.MirrorType Property

Gets or sets the mirror type for tiling.

public MirrorType MirrorType {get; set;}

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


OffsetX Property

Aspose.Cells for .NET

TilePicOption.OffsetX Property

Gets or sets the X offset for tiling picture.

public double OffsetX {get; set;}

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


OffsetY Property

Aspose.Cells for .NET

TilePicOption.OffsetY Property

Gets or sets the Y offset for tiling picture.

public double OffsetY {get; set;}

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


ScaleX Property

Aspose.Cells for .NET

TilePicOption.ScaleX Property

Gets or sets the X scale for tiling picture.

public double ScaleX {get; set;}

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


ScaleY Property

Aspose.Cells for .NET

TilePicOption.ScaleY Property

Gets or sets the Y scale for tiling picture.

public double ScaleY {get; set;}

See Also

TilePicOption Class | Aspose.Cells.Drawing Namespace


WebExtensionShape Class

Represents the shape of web extension.

For a list of all members of this type, see WebExtensionShape Members.

System.Object
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.WebExtensionShape

public class WebExtensionShape : Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionShape Members | Aspose.Cells.Drawing Namespace


WebExtensionShape Members

WebExtensionShape overview

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
WebExtension | Gets and set the web extension.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink (inherited from Shape) | Adds a hyperlink to the shape.
AlignTopRightCorner (inherited from Shape) | Moves the picture to the top-right corner.
CalculateTextSize (inherited from Shape) | Recalculate the text area
Characters (inherited from Shape) | Returns a Characters object that represents a range of characters within the text.
Equals (inherited from Object) |
FormatCharacters (inherited from Shape) | Overloaded. Formats some characters with the font setting.
GetCharacters (inherited from Shape) | Returns all Characters objects that represents a range of characters within the text .
GetHashCode (inherited from Object) |
GetInputRange (inherited from Shape) | Gets the range used to fill the control.
GetLinkedCell (inherited from Shape) | Gets the range linked to the control's value.
GetLockedProperty (inherited from Shape) | Gets the value of locked property.
GetResultOfSmartArt (inherited from Shape) | Converting smart art to grouped shapes.
GetType (inherited from Object) |
MoveToRange (inherited from Shape) | Moves the shape to a specified range.
RemoveActiveXControl (inherited from Shape) | Remove activeX control.
RemoveHyperlink (inherited from Shape) | Remove the hyperlink of the shape.
SetInputRange (inherited from Shape) | Sets the range used to fill the control.
SetLinkedCell (inherited from Shape) | Sets the range linked to the control's value.
SetLockedProperty (inherited from Shape) | Set the locked property.
ToFrontOrBack (inherited from Shape) | Brings the shape to the front or sends the shape to back.
ToImage (inherited from Shape) | Overloaded. Creates the shape image and saves it to a stream in the specified format.
ToString (inherited from Object) |
UpdateSelectedValue (inherited from Shape) | Update the selected value by the value of the linked cell.

See Also

WebExtensionShape Class | Aspose.Cells.Drawing Namespace


WebExtensionShape Properties

The properties of the WebExtensionShape class are listed below. For a complete list of WebExtensionShape class members, see the WebExtensionShape Members topic.

Public Instance Properties

ActiveXControl (inherited from Shape) | Gets the ActiveX control.
ActualLowerRightRow (inherited from Shape) | Get the actual bottom row.
AlternativeText (inherited from Shape) | Returns or sets the descriptive (alternative) text string of the Shape object.
AutoShapeType (inherited from Shape) | Gets the auto shape type.
Bottom (inherited from Shape) | Represents the width of the shape's vertical offset from its lower bottom corner row, in unit of pixels.
ConnectionPoints (inherited from Shape) | Get the connection points
ControlData (inherited from Shape) | Gets the data of control.
Fill (inherited from Shape) | Returns a FillFormat object that contains fill formatting properties for the specified shape.
FillFormat (inherited from Shape) | Obsolete. Returns a MsoFillFormat object that contains fill formatting properties for the specified shape.
Font (inherited from Shape) | Represents the font of shape.
Format (inherited from Shape) | Obsolete. Represents the setting of the shape's formatting.
FormatPicture (inherited from Shape) | Gets and sets the options of the picture format.
Geometry (inherited from Shape) | Gets the geometry
Glow (inherited from Shape) | Represents a object that specifies glow effect for the chart element or shape.
Group (inherited from Shape) | Gets the group shape which contains this shape.
HasLine (inherited from Shape) | Gets and sets the line border of the shape is visible.
Height (inherited from Shape) | Represents the height of shape, in unit of pixel.
HeightCM (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInch (inherited from Shape) | Represents the height of the shape, in unit of inches.
HeightInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape..
HeightPt (inherited from Shape) | Represents the height of the shape, in unit of points.
HeightScale (inherited from Shape) | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText (inherited from Shape) | Gets and sets the html string which contains data and some formats in this textbox.
Hyperlink (inherited from Shape) | Gets the hyperlink of the shape.
Id (inherited from Shape) | Gets the identifier of this shape.
InputRange (inherited from Shape) | Gets or sets the worksheet range used to fill the specified combo box.
IsEquation (inherited from Shape) | Indicates whether the shape only contains an equation.
IsFilled (inherited from Shape) | Indicates whether the fill format is visible.
IsFlippedHorizontally (inherited from Shape) | Gets and sets whether shape is horizontally flipped .
IsFlippedVertically (inherited from Shape) | Gets and sets whether shape is vertically flipped .
IsGroup (inherited from Shape) | Indicates whether the shape is a group.
IsHidden (inherited from Shape) | Indicates whether the object is visible.
IsLockAspectRatio (inherited from Shape) | True means that don't allow changes in aspect ratio.
IsLocked (inherited from Shape) | True if the object is locked, False if the object can be modified when the sheet is protected.
IsPrintable (inherited from Shape) | True if the object is printable
IsRichText (inherited from Shape) | Whether or not the text is rich text.
IsSmartArt (inherited from Shape) | Indicates whether the shape is smart art.
IsTextWrapped (inherited from Shape) | Gets and sets the text wrapped type of the shape which contains text.
IsWordArt (inherited from Shape) | Indicates whether this shape is a word art.
Left (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch (inherited from Shape) | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftInShape (inherited from Shape) | Represents the horizontal offset of shape from the left border of the parent shape, in unit of 1/4000 of width of the parent shape.
LeftToCorner (inherited from Shape) | Gets and sets the horizonal offset of shape from worksheet left border.
Line (inherited from Shape) | Gets line style
LineFormat (inherited from Shape) | Obsolete. Returns a MsoLineFormat object that contains line formatting properties for the specified shape.
LinkedCell (inherited from Shape) | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn (inherited from Shape) | Represents lower right corner column index.
LowerRightRow (inherited from Shape) | Represents lower right corner row index.
MacroName (inherited from Shape) | Gets and sets the name of macro.
MsoDrawingType (inherited from Shape) | Gets and sets mso drawing type.
Name (inherited from Shape) | Gets and sets the name of the shape.
Paths (inherited from Shape) | Gets the paths of a custom geometric shape.
Placement (inherited from Shape) | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
Reflection (inherited from Shape) | Represents a object that specifies reflection effect for the chart element or shape.
RelativeToOriginalPictureSize (inherited from Shape) | Indicates whether shape is relative to original picture size.
Right (inherited from Shape) | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle (inherited from Shape) | Gets and sets the rotation of the shape.
ShadowEffect (inherited from Shape) | Represents a object that specifies shadow effect for the chart element or shape.
SoftEdges (inherited from Shape) | Gets and sets the radius of blur to apply to the edges, in unit of points.
Spid (inherited from Shape) | Specifies an optional string that an application can use to Identify the particular shape.
Spt (inherited from Shape) | Specifies an optional number that an application can use to associate the particular shape with a defined shape type.
Text (inherited from Shape) | Represents the string in this TextBox object.
TextBody (inherited from Shape) | Gets and sets the setting of the shape's text.
TextDirection (inherited from Shape) | Gets/Sets the direction of the text flow for this object.
TextEffect (inherited from Shape) | Returns a TextEffectFormat object that contains text-effect formatting properties for the specified shape. Applies to Shape objects that represent WordArt.
TextFrame (inherited from Shape) | Obsolete. Returns a TextFrame object that contains the alignment and anchoring properties for the specified shape.
TextHorizontalAlignment (inherited from Shape) | Gets and sets the text horizontal alignment type of the shape.
TextHorizontalOverflow (inherited from Shape) | Gets and sets the text horizontal overflow type of the shape which contains text.
TextOptions (inherited from Shape) | Represents the text options of the shape.
TextOrientationType (inherited from Shape) | Gets and sets the text orientation type of the shape.
TextShapeType (inherited from Shape) | Gets and sets the preset text shape type.
TextVerticalAlignment (inherited from Shape) | Gets and sets the text vertical alignment type of the shape.
TextVerticalOverflow (inherited from Shape) | Gets and sets the text vertical overflow type of the shape which contains text.
ThreeDFormat (inherited from Shape) | Gets and sets 3d format of the shape.
Title (inherited from Shape) | Specifies the title (caption) of the current shape object.
Top (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch (inherited from Shape) | Represents the vertical offset of shape from its top row, in unit of inches.
TopInShape (inherited from Shape) | Represents the vertical offset of shape from the top border of the parent shape, in unit of 1/4000 of height of the parent shape.
TopToCorner (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border, in unit of pixels.
Type (inherited from Shape) | Gets the auto shape type.
UpperDeltaX (inherited from Shape) | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY (inherited from Shape) | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn (inherited from Shape) | Represents upper left corner column index.
UpperLeftRow (inherited from Shape) | Represents upper left corner row index.
WebExtension | Gets and set the web extension.
Width (inherited from Shape) | Represents the width of shape, in unit of pixels.
WidthCM (inherited from Shape) | Represents the width of the shape, in unit of centimeters.
WidthInch (inherited from Shape) | Represents the width of the shape, in unit of inch.
WidthInShape (inherited from Shape) | Represents the width of the shape, in unit of 1/4000 of the parent shape.
WidthPt (inherited from Shape) | Represents the width of the shape, in unit of point.
WidthScale (inherited from Shape) | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X (inherited from Shape) | Gets and sets the horizontal offset of shape from worksheet left border,in unit of pixels.
Y (inherited from Shape) | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition (inherited from Shape) | Returns the position of a shape in the z-order.

See Also

WebExtensionShape Class | Aspose.Cells.Drawing Namespace


WebExtension Property

Aspose.Cells for .NET

WebExtensionShape.WebExtension Property

Gets and set the web extension.

public WebExtension WebExtension {get; set;}

See Also

WebExtensionShape Class | Aspose.Cells.Drawing Namespace


WeightType Enumeration

Enumerates the weight types for a picture border or a chart line.

public enum WeightType

Members

Member Name | Description | Value
HairLine | Represents the weight of hair line. | -1
MediumLine | Represents the weight of medium line. | 1
SingleLine | Represents the weight of single line. | 0
WideLine | Represents the weight of wide line. | 2

Requirements

Namespace: Aspose.Cells.Drawing

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing Namespace


Aspose.Cells.Drawing.ActiveXControls

Aspose.Cells for .NET

Aspose.Cells.Drawing.ActiveXControls Namespace

Namespace hierarchy

Classes

Class | Description
ActiveXControl | Represents the ActiveX control.
ActiveXControlBase | Represents the ActiveX control.
CheckBoxActiveXControl | Represents a CheckBox ActiveX control.
ComboBoxActiveXControl | Represents a ComboBox ActiveX control.
CommandButtonActiveXControl | Represents a command button.
ImageActiveXControl | Represents the image control.
LabelActiveXControl | Represents the label ActiveX control.
ListBoxActiveXControl | Represents a ListBox ActiveX control.
RadioButtonActiveXControl | Represents a RadioButton ActiveX control.
ScrollBarActiveXControl | Represents the ScrollBar control.
SpinButtonActiveXControl | Represents the SpinButton control.
TextBoxActiveXControl | Represents a text box ActiveX control.
ToggleButtonActiveXControl | Represents a ToggleButton ActiveX control.
UnknownControl | Unknow control.

Enumerations

Enumeration | Description
ActiveXPersistenceType | Represents the persistence method to persist an ActiveX control.
ControlBorderType | Represents the border type of the ActiveX control.
ControlCaptionAlignmentType | Represents the position of the Caption relative to the control.
ControlListStyle | Represents the visual appearance of the list in a ListBox or ComboBox.
ControlMatchEntryType | Represents how a ListBox or ComboBox searches its list as the user types.
ControlMousePointerType | Represents the type of icon displayed as the mouse pointer for the control.
ControlPictureAlignmentType | Represents the alignment of the picture inside the Form or Image.
ControlPicturePositionType | Represents the location of the control's picture relative to its caption.
ControlPictureSizeMode | Represents how to display the picture.
ControlScrollBarType | Represents the type of scroll bar.
ControlScrollOrientation | Represents type of scroll orientation
ControlSpecialEffectType | Represents the type of special effect.
ControlType | Represents all type of ActiveX control.
DropButtonStyle | Represents the symbol displayed on the drop button.
InputMethodEditorMode | Represents the default run-time mode of the Input Method Editor.
ShowDropButtonType | Specifies when to show the drop button


ActiveXControl Class

Represents the ActiveX control.

For a list of all members of this type, see ActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Derived types

public abstract class ActiveXControl : ActiveXControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ActiveXControl Members

ActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data | Gets and sets the binary data of the control.
Font | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked | Indicates whether data in the control is locked for editing.
IsTransparent | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
TextAlign | Represents how to align the text used by the control.
Type (inherited from ActiveXControlBase) | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ActiveXControl Properties

The properties of the ActiveXControl class are listed below. For a complete list of ActiveXControl class members, see the ActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data | Gets and sets the binary data of the control.
Font | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked | Indicates whether data in the control is locked for editing.
IsTransparent | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
TextAlign | Represents how to align the text used by the control.
Type (inherited from ActiveXControlBase) | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Data Property

Aspose.Cells for .NET

ActiveXControl.Data Property

Gets and sets the binary data of the control.

public override byte[] Data {get;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Font Property

Aspose.Cells for .NET

ActiveXControl.Font Property

Represents the font of the control.

public Font Font {get;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IMEMode Property

Aspose.Cells for .NET

ActiveXControl.IMEMode Property

Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.

public InputMethodEditorMode IMEMode {get; set;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsAutoSize Property

Aspose.Cells for .NET

ActiveXControl.IsAutoSize Property

Indicates whether the control will automatically resize to display its entire contents.

public virtual bool IsAutoSize {get; set;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsEnabled Property

Aspose.Cells for .NET

ActiveXControl.IsEnabled Property

Indicates whether the control can receive the focus and respond to user-generated events.

public bool IsEnabled {get; set;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsLocked Property

Aspose.Cells for .NET

ActiveXControl.IsLocked Property

Indicates whether data in the control is locked for editing.

public bool IsLocked {get; set;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsTransparent Property

Aspose.Cells for .NET

ActiveXControl.IsTransparent Property

Indicates whether the control is transparent.

public bool IsTransparent {get; set;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TextAlign Property

Aspose.Cells for .NET

ActiveXControl.TextAlign Property

Represents how to align the text used by the control.

public TextAlignmentType TextAlign {get; set;}

See Also

ActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ActiveXControlBase Class

Represents the ActiveX control.

For a list of all members of this type, see ActiveXControlBase Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl

public abstract class ActiveXControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ActiveXControlBase Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ActiveXControlBase Members

ActiveXControlBase overview

Public Instance Properties

BackOleColor | Gets and sets the ole color of the background.
Data | Gets and sets the binary data of the control.
ForeOleColor | Gets and sets the ole color of the foreground.
Height | Gets and sets the height of the control in unit of points.
IsVisible | Indicates whether this control is visible.
LinkedCell | Gets and sets the linked cell.
ListFillRange | Gets and sets the list fill range.
MouseIcon | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer | Gets and sets the type of icon displayed as the mouse pointer for the control.
Shadow | Indicates whether to show a shadow.
Type | Gets the type of the ActiveX control.
Width | Gets and sets the width of the control in unit of points.
Workbook | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ActiveXControlBase Properties

The properties of the ActiveXControlBase class are listed below. For a complete list of ActiveXControlBase class members, see the ActiveXControlBase Members topic.

Public Instance Properties

BackOleColor | Gets and sets the ole color of the background.
Data | Gets and sets the binary data of the control.
ForeOleColor | Gets and sets the ole color of the foreground.
Height | Gets and sets the height of the control in unit of points.
IsVisible | Indicates whether this control is visible.
LinkedCell | Gets and sets the linked cell.
ListFillRange | Gets and sets the list fill range.
MouseIcon | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer | Gets and sets the type of icon displayed as the mouse pointer for the control.
Shadow | Indicates whether to show a shadow.
Type | Gets the type of the ActiveX control.
Width | Gets and sets the width of the control in unit of points.
Workbook | Gets the Workbook object.

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BackOleColor Property

Aspose.Cells for .NET

ActiveXControlBase.BackOleColor Property

Gets and sets the ole color of the background.

public int BackOleColor {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Data Property

Aspose.Cells for .NET

ActiveXControlBase.Data Property

Gets and sets the binary data of the control.

public virtual byte[] Data {get;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ForeOleColor Property

Aspose.Cells for .NET

ActiveXControlBase.ForeOleColor Property

Gets and sets the ole color of the foreground.

public virtual int ForeOleColor {get; set;}

Remarks

Not applies to Image control.

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Height Property

Aspose.Cells for .NET

ActiveXControlBase.Height Property

Gets and sets the height of the control in unit of points.

public virtual double Height {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsVisible Property

Aspose.Cells for .NET

ActiveXControlBase.IsVisible Property

Indicates whether this control is visible.

public virtual bool IsVisible {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


LinkedCell Property

Aspose.Cells for .NET

ActiveXControlBase.LinkedCell Property

Gets and sets the linked cell.

public string LinkedCell {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListFillRange Property

Aspose.Cells for .NET

ActiveXControlBase.ListFillRange Property

Gets and sets the list fill range.

public string ListFillRange {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


MouseIcon Property

Aspose.Cells for .NET

ActiveXControlBase.MouseIcon Property

Gets and sets a custom icon to display as the mouse pointer for the control.

public byte[] MouseIcon {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


MousePointer Property

Aspose.Cells for .NET

ActiveXControlBase.MousePointer Property

Gets and sets the type of icon displayed as the mouse pointer for the control.

public ControlMousePointerType MousePointer {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Shadow Property

Aspose.Cells for .NET

ActiveXControlBase.Shadow Property

Indicates whether to show a shadow.

public virtual bool Shadow {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

ActiveXControlBase.Type Property

Gets the type of the ActiveX control.

public abstract ControlType Type {get;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Width Property

Aspose.Cells for .NET

ActiveXControlBase.Width Property

Gets and sets the width of the control in unit of points.

public virtual double Width {get; set;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Workbook Property

Aspose.Cells for .NET

ActiveXControlBase.Workbook Property

Gets the Workbook object.

public Workbook Workbook {get;}

See Also

ActiveXControlBase Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ActiveXPersistenceType Enumeration

Represents the persistence method to persist an ActiveX control.

public enum ActiveXPersistenceType

Members

Member Name | Description | Value
PropertyBag | The data is stored as xml data. | 0
Storage | The data is stored as a storage binary data. | 1
Stream | The data is stored as a stream binary data. | 2
StreamInit | The data is stored as a streaminit binary data. | 3

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


CheckBoxActiveXControl Class

Represents a CheckBox ActiveX control.

For a list of all members of this type, see CheckBoxActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.CheckBoxActiveXControl

public class CheckBoxActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CheckBoxActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


CheckBoxActiveXControl Members

CheckBoxActiveXControl overview

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
Alignment | Gets and set the position of the Caption relative to the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
GroupName | Gets and sets the group's name.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsTripleState | Indicates how the specified control will display Null values.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Value | Indicates if the control is checked or not.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


CheckBoxActiveXControl Properties

The properties of the CheckBoxActiveXControl class are listed below. For a complete list of CheckBoxActiveXControl class members, see the CheckBoxActiveXControl Members topic.

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
Alignment | Gets and set the position of the Caption relative to the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
GroupName | Gets and sets the group's name.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsTripleState | Indicates how the specified control will display Null values.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Value | Indicates if the control is checked or not.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Accelerator Property

Aspose.Cells for .NET

CheckBoxActiveXControl.Accelerator Property

Gets and sets the accelerator key for the control.

public char Accelerator {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Alignment Property

Aspose.Cells for .NET

CheckBoxActiveXControl.Alignment Property

Gets and set the position of the Caption relative to the control.

public ControlCaptionAlignmentType Alignment {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Caption Property

Aspose.Cells for .NET

CheckBoxActiveXControl.Caption Property

Gets and set the descriptive text that appears on a control.

public string Caption {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


GroupName Property

Aspose.Cells for .NET

CheckBoxActiveXControl.GroupName Property

Gets and sets the group's name.

public string GroupName {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsTripleState Property

Aspose.Cells for .NET

CheckBoxActiveXControl.IsTripleState Property

Indicates how the specified control will display Null values.

public bool IsTripleState {get; set;}

Remarks

///
Setting | Description
True | The control will cycle through states for Yes, No, and Null values. The control appears dimmed (grayed) when its Value property is set to Null.
False | (Default) The control will cycle through states for Yes and No values. Null values display as if they were No values.

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsWordWrapped Property

Aspose.Cells for .NET

CheckBoxActiveXControl.IsWordWrapped Property

Indicates whether the contents of the control automatically wrap at the end of a line.

public bool IsWordWrapped {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Picture Property

Aspose.Cells for .NET

CheckBoxActiveXControl.Picture Property

Gets and sets the data of the picture.

public byte[] Picture {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PicturePosition Property

Aspose.Cells for .NET

CheckBoxActiveXControl.PicturePosition Property

Gets and set the location of the control's picture relative to its caption.

public ControlPicturePositionType PicturePosition {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

CheckBoxActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

CheckBoxActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Value Property

Aspose.Cells for .NET

CheckBoxActiveXControl.Value Property

Indicates if the control is checked or not.

public CheckValueType Value {get; set;}

See Also

CheckBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ComboBoxActiveXControl Class

Represents a ComboBox ActiveX control.

For a list of all members of this type, see ComboBoxActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ComboBoxActiveXControl

public class ComboBoxActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ComboBoxActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ComboBoxActiveXControl Members

ComboBoxActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
BoundColumn | Represents how the Value property is determined for a ComboBox or ListBox when the MultiSelect properties value (fmMultiSelectSingle).
ColumnCount | Represents the number of columns to display in a ComboBox or ListBox.
ColumnWidths | Gets and sets the width of the column.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
DropButtonStyle | Specifies the symbol displayed on the drop button
EnterFieldBehavior | Specifies selection behavior when entering the control. True specifies that the selection remains unchanged from last time the control was active. False specifies that all the text in the control will be selected when entering the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
HideSelection | Indicates whether selected text in the control appears highlighted when the control does not have focus.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsAutoWordSelected | Specifies the basic unit used to extend a selection. True specifies that the basic unit is a single character. false specifies that the basic unit is a whole word.
IsDragBehaviorEnabled | Indicates whether dragging and dropping is enabled for the control.
IsEditable | Indicates whether the user can type into the control.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
ListRows | Represents the maximum number of rows to display in the list.
ListStyle | Gets and sets the visual appearance.
ListWidth | Gets and set the width in unit of points.
MatchEntry | Indicates how a ListBox or ComboBox searches its list as the user types.
MaxLength | Gets and sets the maximum number of characters
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
SelectionMargin | Indicates whether the user can select a line of text by clicking in the region to the left of the text.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
ShowColumnHeads | Indicates whether column headings are displayed.
ShowDropButtonTypeWhen | Specifies the symbol displayed on the drop button
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
TextColumn | Represents the column in a ComboBox or ListBox to display to the user.
Type | Gets the type of the ActiveX control.
Value | Gets and sets the value of the control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ComboBoxActiveXControl Properties

The properties of the ComboBoxActiveXControl class are listed below. For a complete list of ComboBoxActiveXControl class members, see the ComboBoxActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
BoundColumn | Represents how the Value property is determined for a ComboBox or ListBox when the MultiSelect properties value (fmMultiSelectSingle).
ColumnCount | Represents the number of columns to display in a ComboBox or ListBox.
ColumnWidths | Gets and sets the width of the column.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
DropButtonStyle | Specifies the symbol displayed on the drop button
EnterFieldBehavior | Specifies selection behavior when entering the control. True specifies that the selection remains unchanged from last time the control was active. False specifies that all the text in the control will be selected when entering the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
HideSelection | Indicates whether selected text in the control appears highlighted when the control does not have focus.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsAutoWordSelected | Specifies the basic unit used to extend a selection. True specifies that the basic unit is a single character. false specifies that the basic unit is a whole word.
IsDragBehaviorEnabled | Indicates whether dragging and dropping is enabled for the control.
IsEditable | Indicates whether the user can type into the control.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
ListRows | Represents the maximum number of rows to display in the list.
ListStyle | Gets and sets the visual appearance.
ListWidth | Gets and set the width in unit of points.
MatchEntry | Indicates how a ListBox or ComboBox searches its list as the user types.
MaxLength | Gets and sets the maximum number of characters
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
SelectionMargin | Indicates whether the user can select a line of text by clicking in the region to the left of the text.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
ShowColumnHeads | Indicates whether column headings are displayed.
ShowDropButtonTypeWhen | Specifies the symbol displayed on the drop button
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
TextColumn | Represents the column in a ComboBox or ListBox to display to the user.
Type | Gets the type of the ActiveX control.
Value | Gets and sets the value of the control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderOleColor Property

Aspose.Cells for .NET

ComboBoxActiveXControl.BorderOleColor Property

Gets and sets the ole color of the background.

public int BorderOleColor {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderStyle Property

Aspose.Cells for .NET

ComboBoxActiveXControl.BorderStyle Property

Gets and set the type of border used by the control.

public ControlBorderType BorderStyle {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BoundColumn Property

Aspose.Cells for .NET

ComboBoxActiveXControl.BoundColumn Property

Represents how the Value property is determined for a ComboBox or ListBox when the MultiSelect properties value (fmMultiSelectSingle).

public int BoundColumn {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ColumnCount Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ColumnCount Property

Represents the number of columns to display in a ComboBox or ListBox.

public int ColumnCount {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ColumnWidths Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ColumnWidths Property

Gets and sets the width of the column.

public double ColumnWidths {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


DropButtonStyle Property

Aspose.Cells for .NET

ComboBoxActiveXControl.DropButtonStyle Property

Specifies the symbol displayed on the drop button

public DropButtonStyle DropButtonStyle {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


EnterFieldBehavior Property

Aspose.Cells for .NET

ComboBoxActiveXControl.EnterFieldBehavior Property

Specifies selection behavior when entering the control. True specifies that the selection remains unchanged from last time the control was active. False specifies that all the text in the control will be selected when entering the control.

public bool EnterFieldBehavior {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


HideSelection Property

Aspose.Cells for .NET

ComboBoxActiveXControl.HideSelection Property

Indicates whether selected text in the control appears highlighted when the control does not have focus.

public bool HideSelection {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsAutoWordSelected Property

Aspose.Cells for .NET

ComboBoxActiveXControl.IsAutoWordSelected Property

Specifies the basic unit used to extend a selection. True specifies that the basic unit is a single character. false specifies that the basic unit is a whole word.

public virtual bool IsAutoWordSelected {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsDragBehaviorEnabled Property

Aspose.Cells for .NET

ComboBoxActiveXControl.IsDragBehaviorEnabled Property

Indicates whether dragging and dropping is enabled for the control.

public bool IsDragBehaviorEnabled {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsEditable Property

Aspose.Cells for .NET

ComboBoxActiveXControl.IsEditable Property

Indicates whether the user can type into the control.

public bool IsEditable {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListRows Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ListRows Property

Represents the maximum number of rows to display in the list.

public int ListRows {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListStyle Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ListStyle Property

Gets and sets the visual appearance.

public ControlListStyle ListStyle {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListWidth Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ListWidth Property

Gets and set the width in unit of points.

public double ListWidth {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


MatchEntry Property

Aspose.Cells for .NET

ComboBoxActiveXControl.MatchEntry Property

Indicates how a ListBox or ComboBox searches its list as the user types.

public ControlMatchEntryType MatchEntry {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


MaxLength Property

Aspose.Cells for .NET

ComboBoxActiveXControl.MaxLength Property

Gets and sets the maximum number of characters

public int MaxLength {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SelectionMargin Property

Aspose.Cells for .NET

ComboBoxActiveXControl.SelectionMargin Property

Indicates whether the user can select a line of text by clicking in the region to the left of the text.

public bool SelectionMargin {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ShowColumnHeads Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ShowColumnHeads Property

Indicates whether column headings are displayed.

public bool ShowColumnHeads {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ShowDropButtonTypeWhen Property

Aspose.Cells for .NET

ComboBoxActiveXControl.ShowDropButtonTypeWhen Property

Specifies the symbol displayed on the drop button

public ShowDropButtonType ShowDropButtonTypeWhen {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

ComboBoxActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TextColumn Property

Aspose.Cells for .NET

ComboBoxActiveXControl.TextColumn Property

Represents the column in a ComboBox or ListBox to display to the user.

public int TextColumn {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

ComboBoxActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Value Property

Aspose.Cells for .NET

ComboBoxActiveXControl.Value Property

Gets and sets the value of the control.

public string Value {get; set;}

See Also

ComboBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


CommandButtonActiveXControl Class

Represents a command button.

For a list of all members of this type, see CommandButtonActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.CommandButtonActiveXControl

public class CommandButtonActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CommandButtonActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


CommandButtonActiveXControl Members

CommandButtonActiveXControl overview

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
TakeFocusOnClick | Indicates whether the control takes the focus when clicked.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


CommandButtonActiveXControl Properties

The properties of the CommandButtonActiveXControl class are listed below. For a complete list of CommandButtonActiveXControl class members, see the CommandButtonActiveXControl Members topic.

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
TakeFocusOnClick | Indicates whether the control takes the focus when clicked.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Accelerator Property

Aspose.Cells for .NET

CommandButtonActiveXControl.Accelerator Property

Gets and sets the accelerator key for the control.

public char Accelerator {get; set;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Caption Property

Aspose.Cells for .NET

CommandButtonActiveXControl.Caption Property

Gets and set the descriptive text that appears on a control.

public string Caption {get; set;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsWordWrapped Property

Aspose.Cells for .NET

CommandButtonActiveXControl.IsWordWrapped Property

Indicates whether the contents of the control automatically wrap at the end of a line.

public bool IsWordWrapped {get; set;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Picture Property

Aspose.Cells for .NET

CommandButtonActiveXControl.Picture Property

Gets and sets the data of the picture.

public byte[] Picture {get; set;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PicturePosition Property

Aspose.Cells for .NET

CommandButtonActiveXControl.PicturePosition Property

Gets and set the location of the control's picture relative to its caption.

public ControlPicturePositionType PicturePosition {get; set;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TakeFocusOnClick Property

Aspose.Cells for .NET

CommandButtonActiveXControl.TakeFocusOnClick Property

Indicates whether the control takes the focus when clicked.

public bool TakeFocusOnClick {get; set;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

CommandButtonActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

CommandButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ControlBorderType Enumeration

Represents the border type of the ActiveX control.

public enum ControlBorderType

Members

Member Name | Description | Value
None | No border. | 0
Single | The single line. | 1

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlCaptionAlignmentType Enumeration

Represents the position of the Caption relative to the control.

public enum ControlCaptionAlignmentType

Members

Member Name | Description | Value
Left | The left of the control. | 0
Right | The right of the control. | 1

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlListStyle Enumeration

Represents the visual appearance of the list in a ListBox or ComboBox.

public enum ControlListStyle

Members

Member Name | Description | Value
Plain | Displays a list in which the background of an item is highlighted when it is selected. | 0
Option | Displays a list in which an option button or a checkbox next to each entry displays the selection state of that item. | 1

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlMatchEntryType Enumeration

Represents how a ListBox or ComboBox searches its list as the user types.

public enum ControlMatchEntryType

Members

Member Name | Description | Value
FirstLetter | The control searches for the next entry that starts with the character entered. Repeatedly typing the same letter cycles through all entries beginning with that letter. | 0
Complete | As each character is typed, the control searches for an entry matching all characters entered. | 1
None | The list will not be searched when characters are typed. | 2

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlMousePointerType Enumeration

Represents the type of icon displayed as the mouse pointer for the control.

public enum ControlMousePointerType

Members

Member Name | Description | Value
Default | Standard pointer. | 0
Arrow | Arrow. | 1
Cross | Cross-hair pointer. | 2
IBeam | I-beam. | 3
SizeNESW | Double arrow pointing northeast and southwest. | 6
SizeNS | Double arrow pointing north and south. | 7
SizeNWSE | Double arrow pointing northwest and southeast. | 8
SizeWE | Double arrow pointing west and east. | 9
UpArrow | Up arrow. | 10
HourGlass | Hourglass. | 11
NoDrop | "Not” symbol (circle with a diagonal line) on top of the object being dragged. | 12
AppStarting | Arrow with an hourglass. | 13
Help | Arrow with a question mark. | 14
SizeAll | "Size-all” cursor (arrows pointing north, south, east, and west). | 15
Custom | Uses the icon specified by the MouseIcon property. | 99

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlPictureAlignmentType Enumeration

Represents the alignment of the picture inside the Form or Image.

public enum ControlPictureAlignmentType

Members

Member Name | Description | Value
TopLeft | The top left corner. | 0
TopRight | The top right corner. | 1
Center | The center. | 2
BottomLeft | The bottom left corner. | 3
BottomRight | The bottom right corner. | 4

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlPicturePositionType Enumeration

Represents the location of the control's picture relative to its caption.

public enum ControlPicturePositionType

Members

Member Name | Description | Value
LeftTop | The picture appears to the left of the caption. The caption is aligned with the top of the picture. | 131072
LeftCenter | The picture appears to the left of the caption. The caption is centered relative to the picture. | 327683
LeftBottom | The picture appears to the left of the caption. The caption is aligned with the bottom of the picture. | 524294
RightTop | The picture appears to the right of the caption. The caption is aligned with the top of the picture. | 2
RightCenter | The picture appears to the right of the caption. The caption is centered relative to the picture. | 196613
RightBottom | The picture appears to the right of the caption. The caption is aligned with the bottom of the picture. | 393224
AboveLeft | The picture appears above the caption. The caption is aligned with the left edge of the picture. | 393216
AboveCenter | The picture appears above the caption. The caption is centered below the picture. | 458753
AboveRight | The picture appears above the caption. The caption is aligned with the right edge of the picture. | 524290
BelowLeft | The picture appears below the caption. The caption is aligned with the left edge of the picture. | 6
BelowCenter | The picture appears below the caption. The caption is centered above the picture. | 65543
BelowRight | The picture appears below the caption. The caption is aligned with the right edge of the picture. | 131080
Center | The picture appears in the center of the control. The caption is centered horizontally and vertically on top of the picture. | 262148

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlPictureSizeMode Enumeration

Represents how to display the picture.

public enum ControlPictureSizeMode

Members

Member Name | Description | Value
Clip | Crops any part of the picture that is larger than the control's boundaries. | 0
Stretch | Stretches the picture to fill the control's area. This setting distorts the picture in either the horizontal or vertical direction. | 1
Zoom | Enlarges the picture, but does not distort the picture in either the horizontal or vertical direction. | 3

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlScrollBarType Enumeration

Represents the type of scroll bar.

public enum ControlScrollBarType

Members

Member Name | Description | Value
None | Displays no scroll bars. | 0
Horizontal | Displays a horizontal scroll bar. | 1
BarsVertical | Displays a vertical scroll bar. | 2
BarsBoth | Displays both a horizontal and a vertical scroll bar. | 3

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlScrollOrientation Enumeration

Represents type of scroll orientation

public enum ControlScrollOrientation

Members

Member Name | Description | Value
Auto | Control is rendered horizontally when the control's width is greater than its height. Control is rendered vertically otherwise. | 3
Vertical | Control is rendered vertically. | 0
Horizontal | Control is rendered horizontally. | 1

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlSpecialEffectType Enumeration

Represents the type of special effect.

public enum ControlSpecialEffectType

Members

Member Name | Description | Value
Flat | Flat | 0
Raised | Raised | 1
Sunken | Sunken | 2
Etched | Etched | 3
Bump | Bump | 6

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ControlType Enumeration

Represents all type of ActiveX control.

public enum ControlType

Members

Member Name | Description | Value
CommandButton | Button | 0
ComboBox | ComboBox | 1
CheckBox | CheckBox | 2
ListBox | ListBox | 3
TextBox | TextBox | 4
SpinButton | Spinner | 5
RadioButton | RadioButton | 6
Label | Label | 7
Image | Image | 8
ToggleButton | ToggleButton | 9
ScrollBar | ScrollBar | 10
Unknown | Unknown | 11

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


DropButtonStyle Enumeration

Represents the symbol displayed on the drop button.

public enum DropButtonStyle

Members

Member Name | Description | Value
Plain | Displays a button with no symbol. | 0
Arrow | Displays a button with a down arrow. | 1
Ellipsis | Displays a button with an ellipsis (...). | 2
Reduce | Displays a button with a horizontal line like an underscore character. | 3

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


ImageActiveXControl Class

Represents the image control.

For a list of all members of this type, see ImageActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ImageActiveXControl

public class ImageActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ImageActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ImageActiveXControl Members

ImageActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTiled | Indicates whether the picture is tiled across the background.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PictureAlignment | Gets and sets the alignment of the picture inside the Form or Image.
PictureSizeMode | Gets and sets how to display the picture.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ImageActiveXControl Properties

The properties of the ImageActiveXControl class are listed below. For a complete list of ImageActiveXControl class members, see the ImageActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTiled | Indicates whether the picture is tiled across the background.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PictureAlignment | Gets and sets the alignment of the picture inside the Form or Image.
PictureSizeMode | Gets and sets how to display the picture.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderOleColor Property

Aspose.Cells for .NET

ImageActiveXControl.BorderOleColor Property

Gets and sets the ole color of the background.

public int BorderOleColor {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderStyle Property

Aspose.Cells for .NET

ImageActiveXControl.BorderStyle Property

Gets and set the type of border used by the control.

public ControlBorderType BorderStyle {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsAutoSize Property

Aspose.Cells for .NET

ImageActiveXControl.IsAutoSize Property

Indicates whether the control will automatically resize to display its entire contents.

public override bool IsAutoSize {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsTiled Property

Aspose.Cells for .NET

ImageActiveXControl.IsTiled Property

Indicates whether the picture is tiled across the background.

public bool IsTiled {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Picture Property

Aspose.Cells for .NET

ImageActiveXControl.Picture Property

Gets and sets the data of the picture.

public byte[] Picture {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PictureAlignment Property

Aspose.Cells for .NET

ImageActiveXControl.PictureAlignment Property

Gets and sets the alignment of the picture inside the Form or Image.

public ControlPictureAlignmentType PictureAlignment {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PictureSizeMode Property

Aspose.Cells for .NET

ImageActiveXControl.PictureSizeMode Property

Gets and sets how to display the picture.

public ControlPictureSizeMode PictureSizeMode {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

ImageActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

ImageActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

ImageActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


InputMethodEditorMode Enumeration

Represents the default run-time mode of the Input Method Editor.

public enum InputMethodEditorMode

Members

Member Name | Description | Value
NoControl | Does not control IME. | 0
On | IME on. | 1
Off | IME off. English mode. | 2
Disable | IME off.User can't turn on IME by keyboard. | 3
Hiragana | IME on with Full-width hiragana mode. | 4
Katakana | IME on with Full-width katakana mode. | 5
KatakanaHalf | IME on with Half-width katakana mode. | 6
AlphaFull | IME on with Full-width Alphanumeric mode. | 7
Alpha | IME on with Half-width Alphanumeric mode. | 8
HangulFull | IME on with Full-width hangul mode. | 9
Hangul | IME on with Half-width hangul mode. | 10
HanziFull | IME on with Full-width hanzi mode. | 11
Hanzi | IME on with Half-width hanzi mode. | 12

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


LabelActiveXControl Class

Represents the label ActiveX control.

For a list of all members of this type, see LabelActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.LabelActiveXControl

public class LabelActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

LabelActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


LabelActiveXControl Members

LabelActiveXControl overview

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


LabelActiveXControl Properties

The properties of the LabelActiveXControl class are listed below. For a complete list of LabelActiveXControl class members, see the LabelActiveXControl Members topic.

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Accelerator Property

Aspose.Cells for .NET

LabelActiveXControl.Accelerator Property

Gets and sets the accelerator key for the control.

public char Accelerator {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderOleColor Property

Aspose.Cells for .NET

LabelActiveXControl.BorderOleColor Property

Gets and sets the ole color of the background.

public int BorderOleColor {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderStyle Property

Aspose.Cells for .NET

LabelActiveXControl.BorderStyle Property

Gets and set the type of border used by the control.

public ControlBorderType BorderStyle {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Caption Property

Aspose.Cells for .NET

LabelActiveXControl.Caption Property

Gets and set the descriptive text that appears on a control.

public string Caption {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsWordWrapped Property

Aspose.Cells for .NET

LabelActiveXControl.IsWordWrapped Property

Indicates whether the contents of the control automatically wrap at the end of a line.

public bool IsWordWrapped {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Picture Property

Aspose.Cells for .NET

LabelActiveXControl.Picture Property

Gets and sets the data of the picture.

public byte[] Picture {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PicturePosition Property

Aspose.Cells for .NET

LabelActiveXControl.PicturePosition Property

Gets and set the location of the control's picture relative to its caption.

public ControlPicturePositionType PicturePosition {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

LabelActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

LabelActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

LabelActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListBoxActiveXControl Class

Represents a ListBox ActiveX control.

For a list of all members of this type, see ListBoxActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ListBoxActiveXControl

public class ListBoxActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ListBoxActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ListBoxActiveXControl Members

ListBoxActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
BoundColumn | Represents how the Value property is determined for a ComboBox or ListBox when the MultiSelect properties value (fmMultiSelectSingle).
ColumnCount | Represents the number of columns to display in a ComboBox or ListBox.
ColumnWidths | Gets and sets the width of the column.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IntegralHeight | Indicates whether the control will only show complete lines of text without showing any partial lines.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
ListStyle | Gets and sets the visual appearance.
ListWidth | Gets and set the width in unit of points.
MatchEntry | Indicates how a ListBox or ComboBox searches its list as the user types.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
ScrollBars | Indicates specifies whether the control has vertical scroll bars, horizontal scroll bars, both, or neither.
SelectionType | Indicates whether the control permits multiple selections.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
ShowColumnHeads | Indicates whether column headings are displayed.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
TextColumn | Represents the column in a ComboBox or ListBox to display to the user.
Type | Gets the type of the ActiveX control.
Value | Gets and sets the value of the control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListBoxActiveXControl Properties

The properties of the ListBoxActiveXControl class are listed below. For a complete list of ListBoxActiveXControl class members, see the ListBoxActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
BoundColumn | Represents how the Value property is determined for a ComboBox or ListBox when the MultiSelect properties value (fmMultiSelectSingle).
ColumnCount | Represents the number of columns to display in a ComboBox or ListBox.
ColumnWidths | Gets and sets the width of the column.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IntegralHeight | Indicates whether the control will only show complete lines of text without showing any partial lines.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
ListStyle | Gets and sets the visual appearance.
ListWidth | Gets and set the width in unit of points.
MatchEntry | Indicates how a ListBox or ComboBox searches its list as the user types.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
ScrollBars | Indicates specifies whether the control has vertical scroll bars, horizontal scroll bars, both, or neither.
SelectionType | Indicates whether the control permits multiple selections.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
ShowColumnHeads | Indicates whether column headings are displayed.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
TextColumn | Represents the column in a ComboBox or ListBox to display to the user.
Type | Gets the type of the ActiveX control.
Value | Gets and sets the value of the control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderOleColor Property

Aspose.Cells for .NET

ListBoxActiveXControl.BorderOleColor Property

Gets and sets the ole color of the background.

public int BorderOleColor {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderStyle Property

Aspose.Cells for .NET

ListBoxActiveXControl.BorderStyle Property

Gets and set the type of border used by the control.

public ControlBorderType BorderStyle {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BoundColumn Property

Aspose.Cells for .NET

ListBoxActiveXControl.BoundColumn Property

Represents how the Value property is determined for a ComboBox or ListBox when the MultiSelect properties value (fmMultiSelectSingle).

public int BoundColumn {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ColumnCount Property

Aspose.Cells for .NET

ListBoxActiveXControl.ColumnCount Property

Represents the number of columns to display in a ComboBox or ListBox.

public int ColumnCount {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ColumnWidths Property

Aspose.Cells for .NET

ListBoxActiveXControl.ColumnWidths Property

Gets and sets the width of the column.

public double ColumnWidths {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IntegralHeight Property

Aspose.Cells for .NET

ListBoxActiveXControl.IntegralHeight Property

Indicates whether the control will only show complete lines of text without showing any partial lines.

public bool IntegralHeight {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListStyle Property

Aspose.Cells for .NET

ListBoxActiveXControl.ListStyle Property

Gets and sets the visual appearance.

public ControlListStyle ListStyle {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ListWidth Property

Aspose.Cells for .NET

ListBoxActiveXControl.ListWidth Property

Gets and set the width in unit of points.

public double ListWidth {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


MatchEntry Property

Aspose.Cells for .NET

ListBoxActiveXControl.MatchEntry Property

Indicates how a ListBox or ComboBox searches its list as the user types.

public ControlMatchEntryType MatchEntry {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ScrollBars Property

Aspose.Cells for .NET

ListBoxActiveXControl.ScrollBars Property

Indicates specifies whether the control has vertical scroll bars, horizontal scroll bars, both, or neither.

public ControlScrollBarType ScrollBars {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SelectionType Property

Aspose.Cells for .NET

ListBoxActiveXControl.SelectionType Property

Indicates whether the control permits multiple selections.

public SelectionType SelectionType {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ShowColumnHeads Property

Aspose.Cells for .NET

ListBoxActiveXControl.ShowColumnHeads Property

Indicates whether column headings are displayed.

public bool ShowColumnHeads {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

ListBoxActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TextColumn Property

Aspose.Cells for .NET

ListBoxActiveXControl.TextColumn Property

Represents the column in a ComboBox or ListBox to display to the user.

public int TextColumn {get; set;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

ListBoxActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Value Property

Aspose.Cells for .NET

ListBoxActiveXControl.Value Property

Gets and sets the value of the control.

public string Value {get; set;}

Remarks

Only effects when SelectionType is SelectionType.Single;

See Also

ListBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


RadioButtonActiveXControl Class

Represents a RadioButton ActiveX control.

For a list of all members of this type, see RadioButtonActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ToggleButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.RadioButtonActiveXControl

public class RadioButtonActiveXControl : ToggleButtonActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RadioButtonActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


RadioButtonActiveXControl Members

RadioButtonActiveXControl overview

Public Instance Properties

Accelerator (inherited from ToggleButtonActiveXControl) | Gets and sets the accelerator key for the control.
Alignment | Gets and set the position of the Caption relative to the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption (inherited from ToggleButtonActiveXControl) | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
GroupName | Gets and sets the group's name.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsTripleState (inherited from ToggleButtonActiveXControl) | Indicates how the specified control will display Null values.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture (inherited from ToggleButtonActiveXControl) | Gets and sets the data of the picture.
PicturePosition (inherited from ToggleButtonActiveXControl) | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect (inherited from ToggleButtonActiveXControl) | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Value (inherited from ToggleButtonActiveXControl) | Indicates if the control is checked or not.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RadioButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


RadioButtonActiveXControl Properties

The properties of the RadioButtonActiveXControl class are listed below. For a complete list of RadioButtonActiveXControl class members, see the RadioButtonActiveXControl Members topic.

Public Instance Properties

Accelerator (inherited from ToggleButtonActiveXControl) | Gets and sets the accelerator key for the control.
Alignment | Gets and set the position of the Caption relative to the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption (inherited from ToggleButtonActiveXControl) | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
GroupName | Gets and sets the group's name.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsTripleState (inherited from ToggleButtonActiveXControl) | Indicates how the specified control will display Null values.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture (inherited from ToggleButtonActiveXControl) | Gets and sets the data of the picture.
PicturePosition (inherited from ToggleButtonActiveXControl) | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect (inherited from ToggleButtonActiveXControl) | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Value (inherited from ToggleButtonActiveXControl) | Indicates if the control is checked or not.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

RadioButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Alignment Property

Aspose.Cells for .NET

RadioButtonActiveXControl.Alignment Property

Gets and set the position of the Caption relative to the control.

public ControlCaptionAlignmentType Alignment {get; set;}

See Also

RadioButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


GroupName Property

Aspose.Cells for .NET

RadioButtonActiveXControl.GroupName Property

Gets and sets the group's name.

public string GroupName {get; set;}

See Also

RadioButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsWordWrapped Property

Aspose.Cells for .NET

RadioButtonActiveXControl.IsWordWrapped Property

Indicates whether the contents of the control automatically wrap at the end of a line.

public bool IsWordWrapped {get; set;}

See Also

RadioButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

RadioButtonActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

RadioButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ScrollBarActiveXControl Class

Represents the ScrollBar control.

For a list of all members of this type, see ScrollBarActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.SpinButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ScrollBarActiveXControl

public class ScrollBarActiveXControl : SpinButtonActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ScrollBarActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ScrollBarActiveXControl Members

ScrollBarActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LargeChange | Gets and sets the amount by which the Position property changes
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
Max (inherited from SpinButtonActiveXControl) | Gets and sets the maximum acceptable value.
Min (inherited from SpinButtonActiveXControl) | Gets and sets the minimum acceptable value.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Orientation (inherited from SpinButtonActiveXControl) | Gets and sets whether the SpinButton or ScrollBar is oriented vertically or horizontally.
Position (inherited from SpinButtonActiveXControl) | Gets and sets the value.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SmallChange (inherited from SpinButtonActiveXControl) | Gets and sets the amount by which the Position property changes
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ScrollBarActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ScrollBarActiveXControl Properties

The properties of the ScrollBarActiveXControl class are listed below. For a complete list of ScrollBarActiveXControl class members, see the ScrollBarActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LargeChange | Gets and sets the amount by which the Position property changes
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
Max (inherited from SpinButtonActiveXControl) | Gets and sets the maximum acceptable value.
Min (inherited from SpinButtonActiveXControl) | Gets and sets the minimum acceptable value.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Orientation (inherited from SpinButtonActiveXControl) | Gets and sets whether the SpinButton or ScrollBar is oriented vertically or horizontally.
Position (inherited from SpinButtonActiveXControl) | Gets and sets the value.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SmallChange (inherited from SpinButtonActiveXControl) | Gets and sets the amount by which the Position property changes
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

ScrollBarActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


LargeChange Property

Aspose.Cells for .NET

ScrollBarActiveXControl.LargeChange Property

Gets and sets the amount by which the Position property changes

public int LargeChange {get; set;}

See Also

ScrollBarActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

ScrollBarActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

ScrollBarActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ShowDropButtonType Enumeration

Specifies when to show the drop button

public enum ShowDropButtonType

Members

Member Name | Description | Value
Never | Never show the drop button. | 0
Focus | Show the drop button when the control has the focus. | 1
Always | Always show the drop button. | 2

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


SpinButtonActiveXControl Class

Represents the SpinButton control.

For a list of all members of this type, see SpinButtonActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.SpinButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ScrollBarActiveXControl

public class SpinButtonActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SpinButtonActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


SpinButtonActiveXControl Members

SpinButtonActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
Max | Gets and sets the maximum acceptable value.
Min | Gets and sets the minimum acceptable value.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Orientation | Gets and sets whether the SpinButton or ScrollBar is oriented vertically or horizontally.
Position | Gets and sets the value.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SmallChange | Gets and sets the amount by which the Position property changes
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpinButtonActiveXControl Properties

The properties of the SpinButtonActiveXControl class are listed below. For a complete list of SpinButtonActiveXControl class members, see the SpinButtonActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
Max | Gets and sets the maximum acceptable value.
Min | Gets and sets the minimum acceptable value.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Orientation | Gets and sets whether the SpinButton or ScrollBar is oriented vertically or horizontally.
Position | Gets and sets the value.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SmallChange | Gets and sets the amount by which the Position property changes
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Max Property

Aspose.Cells for .NET

SpinButtonActiveXControl.Max Property

Gets and sets the maximum acceptable value.

public int Max {get; set;}

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Min Property

Aspose.Cells for .NET

SpinButtonActiveXControl.Min Property

Gets and sets the minimum acceptable value.

public int Min {get; set;}

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Orientation Property

Aspose.Cells for .NET

SpinButtonActiveXControl.Orientation Property

Gets and sets whether the SpinButton or ScrollBar is oriented vertically or horizontally.

public ControlScrollOrientation Orientation {get; set;}

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Position Property

Aspose.Cells for .NET

SpinButtonActiveXControl.Position Property

Gets and sets the value.

public int Position {get; set;}

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SmallChange Property

Aspose.Cells for .NET

SpinButtonActiveXControl.SmallChange Property

Gets and sets the amount by which the Position property changes

public int SmallChange {get; set;}

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

SpinButtonActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

SpinButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TextBoxActiveXControl Class

Represents a text box ActiveX control.

For a list of all members of this type, see TextBoxActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.TextBoxActiveXControl

public class TextBoxActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextBoxActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


TextBoxActiveXControl Members

TextBoxActiveXControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
DropButtonStyle | Specifies the symbol displayed on the drop button
EnterFieldBehavior | Specifies selection behavior when entering the control. True specifies that the selection remains unchanged from last time the control was active. False specifies that all the text in the control will be selected when entering the control.
EnterKeyBehavior | Specifies the behavior of the ENTER key. True specifies that pressing ENTER will create a new line. False specifies that pressing ENTER will move the focus to the next object in the tab order.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
HideSelection | Indicates whether selected text in the control appears highlighted when the control does not have focus.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IntegralHeight | Indicates whether the control will only show complete lines of text without showing any partial lines.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsAutoTab | Indicates whether the focus will automatically move to the next control when the user enters the maximum number of characters.
IsAutoWordSelected | Specifies the basic unit used to extend a selection. True specifies that the basic unit is a single character. false specifies that the basic unit is a whole word.
IsDragBehaviorEnabled | Indicates whether dragging and dropping is enabled for the control.
IsEditable | Indicates whether the user can type into the control.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsMultiLine | Indicates whether the control can display more than one line of text.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MaxLength | Gets and sets the maximum number of characters
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
PasswordChar | Gets and sets a character to be displayed in place of the characters entered.
ScrollBars | Indicates specifies whether the control has vertical scroll bars, horizontal scroll bars, both, or neither.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
ShowDropButtonTypeWhen | Specifies the symbol displayed on the drop button
SpecialEffect | Gets and sets the special effect of the control.
TabKeyBehavior | Indicates whether tab characters are allowed in the text of the control.
Text | Gets and set text of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TextBoxActiveXControl Properties

The properties of the TextBoxActiveXControl class are listed below. For a complete list of TextBoxActiveXControl class members, see the TextBoxActiveXControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
BorderOleColor | Gets and sets the ole color of the background.
BorderStyle | Gets and set the type of border used by the control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
DropButtonStyle | Specifies the symbol displayed on the drop button
EnterFieldBehavior | Specifies selection behavior when entering the control. True specifies that the selection remains unchanged from last time the control was active. False specifies that all the text in the control will be selected when entering the control.
EnterKeyBehavior | Specifies the behavior of the ENTER key. True specifies that pressing ENTER will create a new line. False specifies that pressing ENTER will move the focus to the next object in the tab order.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
HideSelection | Indicates whether selected text in the control appears highlighted when the control does not have focus.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IntegralHeight | Indicates whether the control will only show complete lines of text without showing any partial lines.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsAutoTab | Indicates whether the focus will automatically move to the next control when the user enters the maximum number of characters.
IsAutoWordSelected | Specifies the basic unit used to extend a selection. True specifies that the basic unit is a single character. false specifies that the basic unit is a whole word.
IsDragBehaviorEnabled | Indicates whether dragging and dropping is enabled for the control.
IsEditable | Indicates whether the user can type into the control.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsMultiLine | Indicates whether the control can display more than one line of text.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
IsWordWrapped | Indicates whether the contents of the control automatically wrap at the end of a line.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MaxLength | Gets and sets the maximum number of characters
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
PasswordChar | Gets and sets a character to be displayed in place of the characters entered.
ScrollBars | Indicates specifies whether the control has vertical scroll bars, horizontal scroll bars, both, or neither.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
ShowDropButtonTypeWhen | Specifies the symbol displayed on the drop button
SpecialEffect | Gets and sets the special effect of the control.
TabKeyBehavior | Indicates whether tab characters are allowed in the text of the control.
Text | Gets and set text of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderOleColor Property

Aspose.Cells for .NET

TextBoxActiveXControl.BorderOleColor Property

Gets and sets the ole color of the background.

public int BorderOleColor {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


BorderStyle Property

Aspose.Cells for .NET

TextBoxActiveXControl.BorderStyle Property

Gets and set the type of border used by the control.

public ControlBorderType BorderStyle {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


DropButtonStyle Property

Aspose.Cells for .NET

TextBoxActiveXControl.DropButtonStyle Property

Specifies the symbol displayed on the drop button

public DropButtonStyle DropButtonStyle {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


EnterFieldBehavior Property

Aspose.Cells for .NET

TextBoxActiveXControl.EnterFieldBehavior Property

Specifies selection behavior when entering the control. True specifies that the selection remains unchanged from last time the control was active. False specifies that all the text in the control will be selected when entering the control.

public bool EnterFieldBehavior {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


EnterKeyBehavior Property

Aspose.Cells for .NET

TextBoxActiveXControl.EnterKeyBehavior Property

Specifies the behavior of the ENTER key. True specifies that pressing ENTER will create a new line. False specifies that pressing ENTER will move the focus to the next object in the tab order.

public bool EnterKeyBehavior {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


HideSelection Property

Aspose.Cells for .NET

TextBoxActiveXControl.HideSelection Property

Indicates whether selected text in the control appears highlighted when the control does not have focus.

public bool HideSelection {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IntegralHeight Property

Aspose.Cells for .NET

TextBoxActiveXControl.IntegralHeight Property

Indicates whether the control will only show complete lines of text without showing any partial lines.

public bool IntegralHeight {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsAutoTab Property

Aspose.Cells for .NET

TextBoxActiveXControl.IsAutoTab Property

Indicates whether the focus will automatically move to the next control when the user enters the maximum number of characters.

public bool IsAutoTab {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsAutoWordSelected Property

Aspose.Cells for .NET

TextBoxActiveXControl.IsAutoWordSelected Property

Specifies the basic unit used to extend a selection. True specifies that the basic unit is a single character. false specifies that the basic unit is a whole word.

public virtual bool IsAutoWordSelected {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsDragBehaviorEnabled Property

Aspose.Cells for .NET

TextBoxActiveXControl.IsDragBehaviorEnabled Property

Indicates whether dragging and dropping is enabled for the control.

public bool IsDragBehaviorEnabled {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsEditable Property

Aspose.Cells for .NET

TextBoxActiveXControl.IsEditable Property

Indicates whether the user can type into the control.

public bool IsEditable {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsMultiLine Property

Aspose.Cells for .NET

TextBoxActiveXControl.IsMultiLine Property

Indicates whether the control can display more than one line of text.

public bool IsMultiLine {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsWordWrapped Property

Aspose.Cells for .NET

TextBoxActiveXControl.IsWordWrapped Property

Indicates whether the contents of the control automatically wrap at the end of a line.

public bool IsWordWrapped {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


MaxLength Property

Aspose.Cells for .NET

TextBoxActiveXControl.MaxLength Property

Gets and sets the maximum number of characters

public int MaxLength {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PasswordChar Property

Aspose.Cells for .NET

TextBoxActiveXControl.PasswordChar Property

Gets and sets a character to be displayed in place of the characters entered.

public char PasswordChar {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ScrollBars Property

Aspose.Cells for .NET

TextBoxActiveXControl.ScrollBars Property

Indicates specifies whether the control has vertical scroll bars, horizontal scroll bars, both, or neither.

public ControlScrollBarType ScrollBars {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ShowDropButtonTypeWhen Property

Aspose.Cells for .NET

TextBoxActiveXControl.ShowDropButtonTypeWhen Property

Specifies the symbol displayed on the drop button

public ShowDropButtonType ShowDropButtonTypeWhen {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

TextBoxActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


TabKeyBehavior Property

Aspose.Cells for .NET

TextBoxActiveXControl.TabKeyBehavior Property

Indicates whether tab characters are allowed in the text of the control.

public bool TabKeyBehavior {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Text Property

Aspose.Cells for .NET

TextBoxActiveXControl.Text Property

Gets and set text of the control.

public string Text {get; set;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

TextBoxActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

TextBoxActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ToggleButtonActiveXControl Class

Represents a ToggleButton ActiveX control.

For a list of all members of this type, see ToggleButtonActiveXControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ToggleButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.RadioButtonActiveXControl

public class ToggleButtonActiveXControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ToggleButtonActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


ToggleButtonActiveXControl Members

ToggleButtonActiveXControl overview

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsTripleState | Indicates how the specified control will display Null values.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Value | Indicates if the control is checked or not.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


ToggleButtonActiveXControl Properties

The properties of the ToggleButtonActiveXControl class are listed below. For a complete list of ToggleButtonActiveXControl class members, see the ToggleButtonActiveXControl Members topic.

Public Instance Properties

Accelerator | Gets and sets the accelerator key for the control.
BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Caption | Gets and set the descriptive text that appears on a control.
Data (inherited from ActiveXControl) | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsTripleState | Indicates how the specified control will display Null values.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
Picture | Gets and sets the data of the picture.
PicturePosition | Gets and set the location of the control's picture relative to its caption.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
SpecialEffect | Gets and sets the special effect of the control.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Value | Indicates if the control is checked or not.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Accelerator Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.Accelerator Property

Gets and sets the accelerator key for the control.

public char Accelerator {get; set;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Caption Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.Caption Property

Gets and set the descriptive text that appears on a control.

public string Caption {get; set;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


IsTripleState Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.IsTripleState Property

Indicates how the specified control will display Null values.

public bool IsTripleState {get; set;}

Remarks

///
Setting | Description
True | The control will cycle through states for Yes, No, and Null values. The control appears dimmed (grayed) when its Value property is set to Null.
False | (Default) The control will cycle through states for Yes and No values. Null values display as if they were No values.

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Picture Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.Picture Property

Gets and sets the data of the picture.

public byte[] Picture {get; set;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PicturePosition Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.PicturePosition Property

Gets and set the location of the control's picture relative to its caption.

public ControlPicturePositionType PicturePosition {get; set;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


SpecialEffect Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.SpecialEffect Property

Gets and sets the special effect of the control.

public ControlSpecialEffectType SpecialEffect {get; set;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Value Property

Aspose.Cells for .NET

ToggleButtonActiveXControl.Value Property

Indicates if the control is checked or not.

public CheckValueType Value {get; set;}

See Also

ToggleButtonActiveXControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


UnknownControl Class

Unknow control.

For a list of all members of this type, see UnknownControl Members.

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.UnknownControl

public class UnknownControl : ActiveXControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.ActiveXControls

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

UnknownControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


UnknownControl Members

UnknownControl overview

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
PersistenceType | Gets the persistence method to persist an ActiveX control.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetRelationshipData | Gets the related data.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


UnknownControl Properties

The properties of the UnknownControl class are listed below. For a complete list of UnknownControl class members, see the UnknownControl Members topic.

Public Instance Properties

BackOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the background.
Data | Gets and sets the binary data of the control.
Font (inherited from ActiveXControl) | Represents the font of the control.
ForeOleColor (inherited from ActiveXControlBase) | Gets and sets the ole color of the foreground.
Height (inherited from ActiveXControlBase) | Gets and sets the height of the control in unit of points.
IMEMode (inherited from ActiveXControl) | Gets and sets the default run-time mode of the Input Method Editor for the control as it receives focus.
IsAutoSize (inherited from ActiveXControl) | Indicates whether the control will automatically resize to display its entire contents.
IsEnabled (inherited from ActiveXControl) | Indicates whether the control can receive the focus and respond to user-generated events.
IsLocked (inherited from ActiveXControl) | Indicates whether data in the control is locked for editing.
IsTransparent (inherited from ActiveXControl) | Indicates whether the control is transparent.
IsVisible (inherited from ActiveXControlBase) | Indicates whether this control is visible.
LinkedCell (inherited from ActiveXControlBase) | Gets and sets the linked cell.
ListFillRange (inherited from ActiveXControlBase) | Gets and sets the list fill range.
MouseIcon (inherited from ActiveXControlBase) | Gets and sets a custom icon to display as the mouse pointer for the control.
MousePointer (inherited from ActiveXControlBase) | Gets and sets the type of icon displayed as the mouse pointer for the control.
PersistenceType | Gets the persistence method to persist an ActiveX control.
Shadow (inherited from ActiveXControlBase) | Indicates whether to show a shadow.
TextAlign (inherited from ActiveXControl) | Represents how to align the text used by the control.
Type | Gets the type of the ActiveX control.
Width (inherited from ActiveXControlBase) | Gets and sets the width of the control in unit of points.
Workbook (inherited from ActiveXControlBase) | Gets the Workbook object.

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Data Property

Aspose.Cells for .NET

UnknownControl.Data Property

Gets and sets the binary data of the control.

public override byte[] Data {get;}

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


PersistenceType Property

Aspose.Cells for .NET

UnknownControl.PersistenceType Property

Gets the persistence method to persist an ActiveX control.

public ActiveXPersistenceType PersistenceType {get;}

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Type Property

Aspose.Cells for .NET

UnknownControl.Type Property

Gets the type of the ActiveX control.

public override ControlType Type {get;}

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


UnknownControl Methods

The methods of the UnknownControl class are listed below. For a complete list of UnknownControl class members, see the UnknownControl Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetRelationshipData | Gets the related data.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


UnknownControl.GetRelationshipData Method

Gets the related data.

public byte[] GetRelationshipData(
string relId
);

Parameters

relId
The relationship id.

Return Value

Returns the related data.

See Also

UnknownControl Class | Aspose.Cells.Drawing.ActiveXControls Namespace


Aspose.Cells.Drawing.Texts

Aspose.Cells for .NET

Aspose.Cells.Drawing.Texts Namespace

Namespace hierarchy

Classes

Class | Description
AutoNumberedBulletValue | Represents automatic numbered bullet.
Bullet | Represents the bullet.
BulletValue | Represents the value of the bullet.
CharacterBulletValue | Represents the character bullet.
FontSettingCollection | Represents the list of FontSetting.
NoneBulletValue | Represents no bullet.
PictureBulletValue | Represents the value of the image bullet.
ShapeTextAlignment | Represents the setting of shape's text alignment;
TextOptions | Represents the text options.
TextParagraph | Represents the text paragraph setting.
TextParagraphCollection | Represents all text paragraph.
TextTabStop | Represents tab stop.
TextTabStopCollection | Represents the list of all tab stops.

Enumerations

Enumeration | Description
BulletType | Represents the type of the bullet.
LineSpaceSizeType | Represents the unit type of line space size.
TextAutonumberScheme | Represents all automatic number scheme.
TextFontAlignType | Represents the different types of font alignment.
TextNodeType | Represents the node type.
TextTabAlignmentType | Represents the text tab alignment types.
TextVerticalType | Represents the text direct type.


AutoNumberedBulletValue Class

Represents automatic numbered bullet.

For a list of all members of this type, see AutoNumberedBulletValue Members.

System.Object
Aspose.Cells.Drawing.Texts.BulletValue
Aspose.Cells.Drawing.Texts.AutoNumberedBulletValue

public class AutoNumberedBulletValue : BulletValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

AutoNumberedBulletValue Members | Aspose.Cells.Drawing.Texts Namespace


AutoNumberedBulletValue Members

AutoNumberedBulletValue overview

Public Instance Constructors

AutoNumberedBulletValue Constructor Initializes a new instance of the AutoNumberedBulletValue class.

Public Instance Properties

AutonumberScheme | Represents the scheme of automatic number.
StartAt | Gets and sets the starting number of the bullet.
Type | Gets the type of the bullet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

AutoNumberedBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


AutoNumberedBulletValue Constructor

Initializes a new instance of the AutoNumberedBulletValue class.

public AutoNumberedBulletValue();

See Also

AutoNumberedBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


AutoNumberedBulletValue Properties

The properties of the AutoNumberedBulletValue class are listed below. For a complete list of AutoNumberedBulletValue class members, see the AutoNumberedBulletValue Members topic.

Public Instance Properties

AutonumberScheme | Represents the scheme of automatic number.
StartAt | Gets and sets the starting number of the bullet.
Type | Gets the type of the bullet.

See Also

AutoNumberedBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


AutonumberScheme Property

Aspose.Cells for .NET

AutoNumberedBulletValue.AutonumberScheme Property

Represents the scheme of automatic number.

public TextAutonumberScheme AutonumberScheme {get; set;}

See Also

AutoNumberedBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


StartAt Property

Aspose.Cells for .NET

AutoNumberedBulletValue.StartAt Property

Gets and sets the starting number of the bullet.

public int StartAt {get; set;}

See Also

AutoNumberedBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

AutoNumberedBulletValue.Type Property

Gets the type of the bullet.

public override BulletType Type {get;}

See Also

AutoNumberedBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Bullet Class

Represents the bullet.

For a list of all members of this type, see Bullet Members.

System.Object
Aspose.Cells.Drawing.Texts.Bullet

public class Bullet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Bullet Members | Aspose.Cells.Drawing.Texts Namespace


Bullet Members

Bullet overview

Public Instance Properties

BulletValue | Gets bullet value
FontName | Get and sets the name of the font.
Type | Gets and sets the bullet type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Bullet Class | Aspose.Cells.Drawing.Texts Namespace


Bullet Properties

The properties of the Bullet class are listed below. For a complete list of Bullet class members, see the Bullet Members topic.

Public Instance Properties

BulletValue | Gets bullet value
FontName | Get and sets the name of the font.
Type | Gets and sets the bullet type.

See Also

Bullet Class | Aspose.Cells.Drawing.Texts Namespace


BulletValue Property

Aspose.Cells for .NET

Bullet.BulletValue Property

Gets bullet value

public BulletValue BulletValue {get;}

See Also

Bullet Class | Aspose.Cells.Drawing.Texts Namespace


FontName Property

Aspose.Cells for .NET

Bullet.FontName Property

Get and sets the name of the font.

public string FontName {get; set;}

See Also

Bullet Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

Bullet.Type Property

Gets and sets the bullet type.

public BulletType Type {get; set;}

See Also

Bullet Class | Aspose.Cells.Drawing.Texts Namespace


BulletType Enumeration

Represents the type of the bullet.

public enum BulletType

Members

Member Name | Description | Value
None | No bullet. | 0
Character | Character bullet. | 1
Picture | Image bullet. | 2
AutoNumbered | Automatic numbered bullet. | 3

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


BulletValue Class

Represents the value of the bullet.

For a list of all members of this type, see BulletValue Members.

System.Object
Aspose.Cells.Drawing.Texts.BulletValue
Aspose.Cells.Drawing.Texts.AutoNumberedBulletValue
Aspose.Cells.Drawing.Texts.CharacterBulletValue
Aspose.Cells.Drawing.Texts.NoneBulletValue
Aspose.Cells.Drawing.Texts.PictureBulletValue

public abstract class BulletValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

BulletValue Members | Aspose.Cells.Drawing.Texts Namespace


BulletValue Members

BulletValue overview

Public Instance Properties

Type Gets the type of the bullet's value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

BulletValue Class | Aspose.Cells.Drawing.Texts Namespace


BulletValue Properties

The properties of the BulletValue class are listed below. For a complete list of BulletValue class members, see the BulletValue Members topic.

Public Instance Properties

Type Gets the type of the bullet's value.

See Also

BulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

BulletValue.Type Property

Gets the type of the bullet's value.

public abstract BulletType Type {get;}

See Also

BulletValue Class | Aspose.Cells.Drawing.Texts Namespace


CharacterBulletValue Class

Represents the character bullet.

For a list of all members of this type, see CharacterBulletValue Members.

System.Object
Aspose.Cells.Drawing.Texts.BulletValue
Aspose.Cells.Drawing.Texts.CharacterBulletValue

public class CharacterBulletValue : BulletValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CharacterBulletValue Members | Aspose.Cells.Drawing.Texts Namespace


CharacterBulletValue Members

CharacterBulletValue overview

Public Instance Constructors

CharacterBulletValue Constructor Initializes a new instance of the CharacterBulletValue class.

Public Instance Properties

Character | Gets and sets character of the bullet.
Type | Gets the type of the bullet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CharacterBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


CharacterBulletValue Constructor

Initializes a new instance of the CharacterBulletValue class.

public CharacterBulletValue();

See Also

CharacterBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


CharacterBulletValue Properties

The properties of the CharacterBulletValue class are listed below. For a complete list of CharacterBulletValue class members, see the CharacterBulletValue Members topic.

Public Instance Properties

Character | Gets and sets character of the bullet.
Type | Gets the type of the bullet.

See Also

CharacterBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Character Property

Aspose.Cells for .NET

CharacterBulletValue.Character Property

Gets and sets character of the bullet.

public char Character {get; set;}

See Also

CharacterBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

CharacterBulletValue.Type Property

Gets the type of the bullet.

public override BulletType Type {get;}

See Also

CharacterBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection Class

Represents the list of FontSetting.

For a list of all members of this type, see FontSettingCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.Texts.FontSettingCollection

public class FontSettingCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

FontSettingCollection Members | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection Members

FontSettingCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
HtmlString | Gets and sets the html string which contains data and some formats in this shape.
Item | Gets the FontSetting by the index.
Text | Gets and sets the text of the shape.
TextAlignment | Represents the alignment setting of the text body.
TextParagraphs | Gets all paragraphs.

Public Instance Methods

AppendText | Appends the text.
Clear | Clear all setting.
DeleteText | Delete some characters.
Equals (inherited from Object) |
Format | Format the text with font setting.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetParagraphEnumerator | Gets the enumerator of the paragraphs.
GetType (inherited from Object) |
InsertText | Insert index at the position.
RemoveAt (inherited from CollectionBase) |
Replace | Replace the text.
SetWordArtStyle | Sets the preset WordArt style.
ToString (inherited from Object) |

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection Properties

The properties of the FontSettingCollection class are listed below. For a complete list of FontSettingCollection class members, see the FontSettingCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
HtmlString | Gets and sets the html string which contains data and some formats in this shape.
Item | Gets the FontSetting by the index.
Text | Gets and sets the text of the shape.
TextAlignment | Represents the alignment setting of the text body.
TextParagraphs | Gets all paragraphs.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


HtmlString Property

Aspose.Cells for .NET

FontSettingCollection.HtmlString Property

Gets and sets the html string which contains data and some formats in this shape.

public string HtmlString {get; set;}

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


Item Property

Aspose.Cells for .NET

FontSettingCollection.Item Property

Gets the FontSetting by the index.

public FontSetting this[
int index
] {get;}

Parameters

index
The index.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


Text Property

Aspose.Cells for .NET

FontSettingCollection.Text Property

Gets and sets the text of the shape.

public string Text {get; set;}

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextAlignment Property

Aspose.Cells for .NET

FontSettingCollection.TextAlignment Property

Represents the alignment setting of the text body.

public ShapeTextAlignment TextAlignment {get;}

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraphs Property

Aspose.Cells for .NET

FontSettingCollection.TextParagraphs Property

Gets all paragraphs.

public TextParagraphCollection TextParagraphs {get;}

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection Methods

The methods of the FontSettingCollection class are listed below. For a complete list of FontSettingCollection class members, see the FontSettingCollection Members topic.

Public Instance Methods

AppendText | Appends the text.
Clear | Clear all setting.
DeleteText | Delete some characters.
Equals (inherited from Object) |
Format | Format the text with font setting.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetParagraphEnumerator | Gets the enumerator of the paragraphs.
GetType (inherited from Object) |
InsertText | Insert index at the position.
RemoveAt (inherited from CollectionBase) |
Replace | Replace the text.
SetWordArtStyle | Sets the preset WordArt style.
ToString (inherited from Object) |

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.AppendText Method

Appends the text.

public void AppendText(
string text
);

Parameters

text
The text.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.Clear Method

Clear all setting.

new public void Clear();

Implements

IList.Clear

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.DeleteText Method

Delete some characters.

public void DeleteText(
int index,
int count
);

Parameters

index
The start index.
count
The count of characters.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.Format Method

Format the text with font setting.

public void Format(
int startIndex,
int length,
Font font,
StyleFlag flag
);

Parameters

startIndex
The start index.
length
The length.
font
The font.
flag
The flags of the font.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.GetParagraphEnumerator Method

Gets the enumerator of the paragraphs.

public IEnumerator GetParagraphEnumerator();

Return Value

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.InsertText Method

Insert index at the position.

public void InsertText(
int index,
string text
);

Parameters

index
The start index.
text
The text.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.Replace Method

Replace the text.

public void Replace(
int index,
int count,
string text
);

Parameters

index
The start index.
count
The count of characters.
text
The text.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


FontSettingCollection.SetWordArtStyle Method

Sets the preset WordArt style.

public void SetWordArtStyle(
PresetWordArtStyle style
);

Parameters

style
The preset WordArt style.

See Also

FontSettingCollection Class | Aspose.Cells.Drawing.Texts Namespace


LineSpaceSizeType Enumeration

Represents the unit type of line space size.

public enum LineSpaceSizeType

Members

Member Name | Description | Value
Percentage | Represents in unit of a percentage of the text size. | 0
Points | Represents in unit of points. | 1

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


NoneBulletValue Class

Represents no bullet.

For a list of all members of this type, see NoneBulletValue Members.

System.Object
Aspose.Cells.Drawing.Texts.BulletValue
Aspose.Cells.Drawing.Texts.NoneBulletValue

public class NoneBulletValue : BulletValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

NoneBulletValue Members | Aspose.Cells.Drawing.Texts Namespace


NoneBulletValue Members

NoneBulletValue overview

Public Instance Constructors

NoneBulletValue Constructor Initializes a new instance of the NoneBulletValue class.

Public Instance Properties

Type Gets the type of the bullet's value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

NoneBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


NoneBulletValue Constructor

Initializes a new instance of the NoneBulletValue class.

public NoneBulletValue();

See Also

NoneBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


NoneBulletValue Properties

The properties of the NoneBulletValue class are listed below. For a complete list of NoneBulletValue class members, see the NoneBulletValue Members topic.

Public Instance Properties

Type Gets the type of the bullet's value.

See Also

NoneBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

NoneBulletValue.Type Property

Gets the type of the bullet's value.

public override BulletType Type {get;}

See Also

NoneBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


PictureBulletValue Class

Represents the value of the image bullet.

For a list of all members of this type, see PictureBulletValue Members.

System.Object
Aspose.Cells.Drawing.Texts.BulletValue
Aspose.Cells.Drawing.Texts.PictureBulletValue

public class PictureBulletValue : BulletValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PictureBulletValue Members | Aspose.Cells.Drawing.Texts Namespace


PictureBulletValue Members

PictureBulletValue overview

Public Instance Constructors

PictureBulletValue Constructor Initializes a new instance of the PictureBulletValue class.

Public Instance Properties

ImageData | Gets and sets image data of the bullet.
Type | Gets the type of the bullet's value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PictureBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


PictureBulletValue Constructor

Initializes a new instance of the PictureBulletValue class.

public PictureBulletValue();

See Also

PictureBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


PictureBulletValue Properties

The properties of the PictureBulletValue class are listed below. For a complete list of PictureBulletValue class members, see the PictureBulletValue Members topic.

Public Instance Properties

ImageData | Gets and sets image data of the bullet.
Type | Gets the type of the bullet's value.

See Also

PictureBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


ImageData Property

Aspose.Cells for .NET

PictureBulletValue.ImageData Property

Gets and sets image data of the bullet.

public byte[] ImageData {get; set;}

See Also

PictureBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

PictureBulletValue.Type Property

Gets the type of the bullet's value.

public override BulletType Type {get;}

See Also

PictureBulletValue Class | Aspose.Cells.Drawing.Texts Namespace


ShapeTextAlignment Class

Represents the setting of shape's text alignment;

For a list of all members of this type, see ShapeTextAlignment Members.

System.Object
Aspose.Cells.Drawing.Texts.ShapeTextAlignment

public class ShapeTextAlignment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ShapeTextAlignment Members | Aspose.Cells.Drawing.Texts Namespace


ShapeTextAlignment Members

ShapeTextAlignment overview

Public Instance Properties

AutoSize | Indicates if size of shape is adjusted automatically according to its content.
BottomMarginPt | Returns the bottom margin in unit of Points
IsAutoMargin | Indicates whether the margin of the text frame is automatic.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
LeftMarginPt | Returns the left margin in unit of Points
RightMarginPt | Returns the right margin in unit of Points
RotateTextWithShape | Indicates whether rotating text with shape.
RotationAngle | Gets and sets the rotation of the shape.
TextHorizontalOverflow | Gets and sets the text horizontal overflow type of the text box.
TextShapeType | Gets and set the transform type of text.
TextVerticalOverflow | Gets and sets the text vertical overflow type of the text box.
TextVerticalType | Gets and sets the text direction.
TopMarginPt | Returns the top margin in unit of Points

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


ShapeTextAlignment Properties

The properties of the ShapeTextAlignment class are listed below. For a complete list of ShapeTextAlignment class members, see the ShapeTextAlignment Members topic.

Public Instance Properties

AutoSize | Indicates if size of shape is adjusted automatically according to its content.
BottomMarginPt | Returns the bottom margin in unit of Points
IsAutoMargin | Indicates whether the margin of the text frame is automatic.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
LeftMarginPt | Returns the left margin in unit of Points
RightMarginPt | Returns the right margin in unit of Points
RotateTextWithShape | Indicates whether rotating text with shape.
RotationAngle | Gets and sets the rotation of the shape.
TextHorizontalOverflow | Gets and sets the text horizontal overflow type of the text box.
TextShapeType | Gets and set the transform type of text.
TextVerticalOverflow | Gets and sets the text vertical overflow type of the text box.
TextVerticalType | Gets and sets the text direction.
TopMarginPt | Returns the top margin in unit of Points

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


AutoSize Property

Aspose.Cells for .NET

ShapeTextAlignment.AutoSize Property

Indicates if size of shape is adjusted automatically according to its content.

public bool AutoSize {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


BottomMarginPt Property

Aspose.Cells for .NET

ShapeTextAlignment.BottomMarginPt Property

Returns the bottom margin in unit of Points

public double BottomMarginPt {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


IsAutoMargin Property

Aspose.Cells for .NET

ShapeTextAlignment.IsAutoMargin Property

Indicates whether the margin of the text frame is automatic.

public bool IsAutoMargin {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


IsTextWrapped Property

Aspose.Cells for .NET

ShapeTextAlignment.IsTextWrapped Property

Gets and sets the text wrapped type of the shape which contains text.

public bool IsTextWrapped {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


LeftMarginPt Property

Aspose.Cells for .NET

ShapeTextAlignment.LeftMarginPt Property

Returns the left margin in unit of Points

public double LeftMarginPt {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


RightMarginPt Property

Aspose.Cells for .NET

ShapeTextAlignment.RightMarginPt Property

Returns the right margin in unit of Points

public double RightMarginPt {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


RotateTextWithShape Property

Aspose.Cells for .NET

ShapeTextAlignment.RotateTextWithShape Property

Indicates whether rotating text with shape.

public bool RotateTextWithShape {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


RotationAngle Property

Aspose.Cells for .NET

ShapeTextAlignment.RotationAngle Property

Gets and sets the rotation of the shape.

public double RotationAngle {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


TextHorizontalOverflow Property

Aspose.Cells for .NET

ShapeTextAlignment.TextHorizontalOverflow Property

Gets and sets the text horizontal overflow type of the text box.

public TextOverflowType TextHorizontalOverflow {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


TextShapeType Property

Aspose.Cells for .NET

ShapeTextAlignment.TextShapeType Property

Gets and set the transform type of text.

public AutoShapeType TextShapeType {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


TextVerticalOverflow Property

Aspose.Cells for .NET

ShapeTextAlignment.TextVerticalOverflow Property

Gets and sets the text vertical overflow type of the text box.

public TextOverflowType TextVerticalOverflow {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


TextVerticalType Property

Aspose.Cells for .NET

ShapeTextAlignment.TextVerticalType Property

Gets and sets the text direction.

public TextVerticalType TextVerticalType {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


TopMarginPt Property

Aspose.Cells for .NET

ShapeTextAlignment.TopMarginPt Property

Returns the top margin in unit of Points

public double TopMarginPt {get; set;}

See Also

ShapeTextAlignment Class | Aspose.Cells.Drawing.Texts Namespace


TextAutonumberScheme Enumeration

Represents all automatic number scheme.

public enum TextAutonumberScheme

Members

Member Name | Description | Value
None |  | 0
AlphaLcParenBoth | (a), (b), (c), … | 1
AlphaLcParenR | a), b), c), … | 2
AlphaLcPeriod | a., b., c., … | 3
AlphaUcParenBoth | (A), (B), (C), … | 4
AlphaUcParenR | A), B), C), … | 5
AlphaUcPeriod | A., B., C., … | 6
Arabic1Minus | Bidi Arabic 1 (AraAlpha) with ANSI minus symbol | 7
Arabic2Minus | Bidi Arabic 2 (AraAbjad) with ANSI minus symbol | 8
ArabicDbPeriod | Dbl-byte Arabic numbers w/ double-byte period | 9
ArabicDbPlain | Dbl-byte Arabic numbers | 10
ArabicParenBoth | (1), (2), (3), … | 11
ArabicParenR | 1), 2), 3), … | 12
ArabicPeriod | 1., 2., 3., … | 13
ArabicPlain | 1, 2, 3, … | 14
CircleNumDbPlain | Dbl-byte circle numbers (1-10 circle[0x2460-], 11-arabic numbers) | 15
CircleNumWdBlackPlain | Wingdings black circle numbers | 16
CircleNumWdWhitePlain | Wingdings white circle numbers (0-10 circle[0x0080-],11- arabic numbers) | 17
Ea1ChsPeriod | EA: Simplified Chinese w/ single-byte period | 18
Ea1ChsPlain | EA: Simplified Chinese (TypeA 1-99, TypeC 100-) | 19
Ea1ChtPeriod | EA: Traditional Chinese w/ single-byte period | 20
Ea1ChtPlain | EA: Traditional Chinese (TypeA 1-19, TypeC 20-) | 21
Ea1JpnChsDbPeriod | EA: Japanese w/ double-byte period | 22
Ea1JpnKorPeriod | EA: Japanese/Korean w/ single-byte period | 23
Ea1JpnKorPlain | EA: Japanese/Korean (TypeC 1-) | 24
Hebrew2Minus | Bidi Hebrew 2 with ANSI minus symbol | 25
HindiAlpha1Period | Hindi alphabet period - consonants | 26
HindiAlphaPeriod | Hindi alphabet period - vowels | 27
HindiNumParenR | Hindi numerical parentheses - right | 28
HindiNumPeriod | Hindi numerical period | 29
RomanLcParenBoth | (i), (ii), (iii), … | 30
RomanLcParenR | i), ii), iii), … | 31
RomanLcPeriod | i., ii., iii., … | 32
RomanUcParenBoth | (I), (II), (III), … | 33
RomanUcParenR | I), II), III), … | 34
RomanUcPeriod | I., II., III., … | 35
ThaiAlphaParenBoth | Thai alphabet parentheses - both | 36
ThaiAlphaParenR | Thai alphabet parentheses - right | 37
ThaiAlphaPeriod | Thai alphabet period | 38
ThaiNumParenBoth | Thai numerical parentheses - both | 39
ThaiNumParenR | Thai numerical parentheses - right | 40
ThaiNumPeriod | Thai numerical period | 41

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


TextFontAlignType Enumeration

Represents the different types of font alignment.

public enum TextFontAlignType

Members

Member Name | Description | Value
Automatic | When the text flow is horizontal or simple vertical same as fontBaseline but for other vertical modes same as fontCenter. | 0
Bottom | The letters are anchored to the very bottom of a single line. | 1
Baseline | The letters are anchored to the bottom baseline of a single line. | 2
Center | The letters are anchored between the two baselines of a single line. | 3
Top | The letters are anchored to the top baseline of a single dline. | 4

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


TextNodeType Enumeration

Represents the node type.

public enum TextNodeType

Members

Member Name | Description | Value
TextRun | Represents the text node. | 0
TextParagraph | Represents the text paragraph. | 1
Equation | Represents the equation text. | 2

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


TextOptions Class

Represents the text options.

For a list of all members of this type, see TextOptions Members.

System.Object
Aspose.Cells.Font
Aspose.Cells.Drawing.Texts.TextOptions

public class TextOptions : Font

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextOptions Members | Aspose.Cells.Drawing.Texts Namespace


TextOptions Members

TextOptions overview

Public Instance Properties

ArgbColor (inherited from Font) | Gets and sets the color with a 32-bit ARGB value.
CapsType (inherited from Font) | Gets and sets the text caps type.
Charset (inherited from Font) | Represent the character set.
Color (inherited from Font) | Gets or sets the Color of the font.
DoubleSize (inherited from Font) | Gets and sets the double size of the font.
FarEastName | Gets and sets the FarEast name.
Fill | Represents the fill format of the text.
IsBold (inherited from Font) | Gets or sets a value indicating whether the font is bold.
IsItalic (inherited from Font) | Gets or sets a value indicating whether the font is italic.
IsNormalizeHeights (inherited from Font) | Indicates whether the normalization of height that is to be applied to the text run.
IsStrikeout (inherited from Font) | Gets or sets a value indicating whether the font is single strikeout.
IsSubscript (inherited from Font) | Gets or sets a value indicating whether the font is subscript.
IsSuperscript (inherited from Font) | Gets or sets a value indicating whether the font is super script.
Kerning | Specifies the minimum font size at which character kerning will occur for this text run.
LatinName | Gets and sets the latin name.
Name | Gets and sets the name of the shape.
Outline | Represents the outline format of the text.
SchemeType (inherited from Font) | Gets and sets the scheme type of the font.
ScriptOffset (inherited from Font) | Gets and sets the script offset,in unit of percentage
Shadow | Represents a object that specifies shadow effect for the chart element or shape.
Size (inherited from Font) | Gets or sets the size of the font.
Spacing | Specifies the spacing between characters within a text run.
StrikeType (inherited from Font) | Gets the strike type of the text.
ThemeColor (inherited from Font) | Gets and sets the theme color.
Underline (inherited from Font) | Gets or sets the font underline type.
UnderlineColor | Gets or sets the color of underline.

Public Instance Methods

Equals (inherited from Font) | Overloaded. Checks if two fonts are equals.
Equals (inherited from Object) | Overloaded.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Font) | Returns a string represents the current Cell object.

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


TextOptions Properties

The properties of the TextOptions class are listed below. For a complete list of TextOptions class members, see the TextOptions Members topic.

Public Instance Properties

ArgbColor (inherited from Font) | Gets and sets the color with a 32-bit ARGB value.
CapsType (inherited from Font) | Gets and sets the text caps type.
Charset (inherited from Font) | Represent the character set.
Color (inherited from Font) | Gets or sets the Color of the font.
DoubleSize (inherited from Font) | Gets and sets the double size of the font.
FarEastName | Gets and sets the FarEast name.
Fill | Represents the fill format of the text.
IsBold (inherited from Font) | Gets or sets a value indicating whether the font is bold.
IsItalic (inherited from Font) | Gets or sets a value indicating whether the font is italic.
IsNormalizeHeights (inherited from Font) | Indicates whether the normalization of height that is to be applied to the text run.
IsStrikeout (inherited from Font) | Gets or sets a value indicating whether the font is single strikeout.
IsSubscript (inherited from Font) | Gets or sets a value indicating whether the font is subscript.
IsSuperscript (inherited from Font) | Gets or sets a value indicating whether the font is super script.
Kerning | Specifies the minimum font size at which character kerning will occur for this text run.
LatinName | Gets and sets the latin name.
Name | Gets and sets the name of the shape.
Outline | Represents the outline format of the text.
SchemeType (inherited from Font) | Gets and sets the scheme type of the font.
ScriptOffset (inherited from Font) | Gets and sets the script offset,in unit of percentage
Shadow | Represents a object that specifies shadow effect for the chart element or shape.
Size (inherited from Font) | Gets or sets the size of the font.
Spacing | Specifies the spacing between characters within a text run.
StrikeType (inherited from Font) | Gets the strike type of the text.
ThemeColor (inherited from Font) | Gets and sets the theme color.
Underline (inherited from Font) | Gets or sets the font underline type.
UnderlineColor | Gets or sets the color of underline.

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


FarEastName Property

Aspose.Cells for .NET

TextOptions.FarEastName Property

Gets and sets the FarEast name.

public string FarEastName {get; set;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


Fill Property

Aspose.Cells for .NET

TextOptions.Fill Property

Represents the fill format of the text.

public FillFormat Fill {get;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


Kerning Property

Aspose.Cells for .NET

TextOptions.Kerning Property

Specifies the minimum font size at which character kerning will occur for this text run.

public double Kerning {get; set;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


LatinName Property

Aspose.Cells for .NET

TextOptions.LatinName Property

Gets and sets the latin name.

public string LatinName {get; set;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


Name Property

Aspose.Cells for .NET

TextOptions.Name Property

Gets and sets the name of the shape.

public override string Name {get; set;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


Outline Property

Aspose.Cells for .NET

TextOptions.Outline Property

Represents the outline format of the text.

public LineFormat Outline {get;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


Shadow Property

Aspose.Cells for .NET

TextOptions.Shadow Property

Represents a object that specifies shadow effect for the chart element or shape.

public ShadowEffect Shadow {get;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace | ShadowEffect


Spacing Property

Aspose.Cells for .NET

TextOptions.Spacing Property

Specifies the spacing between characters within a text run.

public double Spacing {get; set;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


UnderlineColor Property

Aspose.Cells for .NET

TextOptions.UnderlineColor Property

Gets or sets the color of underline.

public CellsColor UnderlineColor {get; set;}

See Also

TextOptions Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraph Class

Represents the text paragraph setting.

For a list of all members of this type, see TextParagraph Members.

System.Object
Aspose.Cells.FontSetting
Aspose.Cells.Drawing.Texts.TextParagraph

public class TextParagraph : FontSetting

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextParagraph Members | Aspose.Cells.Drawing.Texts Namespace


TextParagraph Members

TextParagraph overview

Public Instance Properties

AlignmentType | Gets and sets the text horizontal alignment type of the paragraph.
Bullet | Gets the bullet.
Children | Gets all text runs in this paragraph. If this paragraph is empty, return paragraph itself.
DefaultTabSize | Gets and sets the default size for a tab character within this paragraph.
FirstLineIndent | Specifies the indent size that will be applied to the first line of text in the paragraph.
Font (inherited from FontSetting) | Returns the font of this object.
FontAlignType | Determines where vertically on a line of text the actual words are positioned. This deals with vertical placement of the characters with respect to the baselines.
IsEastAsianLineBreak | Specifies whether an East Asian word can be broken in half and wrapped onto the next line without a hyphen being added.
IsHangingPunctuation | Specifies whether punctuation is to be forcefully laid out on a line of text or put on a different line of text.
IsLatinLineBreak | Specifies whether a Latin word can be broken in half and wrapped onto the next line without a hyphen being added.
LeftMargin | Specifies the left margin of the paragraph.
Length (inherited from FontSetting) | Gets the length of the characters.
LineSpace | Gets and sets the amount of vertical white space that will be used within a paragraph.
LineSpaceSizeType | Gets and sets the amount of vertical white space that will be used within a paragraph.
RightMargin | Specifies the right margin of the paragraph.
SpaceAfter | Gets and sets the amount of vertical white space that will be present after a paragraph.
SpaceAfterSizeType | Gets and sets the amount of vertical white space that will be present after a paragraph.
SpaceBefore | Gets and sets the amount of vertical white space that will be present before a paragraph.
SpaceBeforeSizeType | Gets and sets the amount of vertical white space that will be present before a paragraph.
StartIndex (inherited from FontSetting) | Gets the start index of the characters.
Stops | Gets tab stop list.
TextOptions (inherited from FontSetting) | Returns the text options.
Type | Gets the type of text node.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetWordArtStyle (inherited from FontSetting) | Sets the preset WordArt style.
ToString (inherited from Object) |

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraph Properties

The properties of the TextParagraph class are listed below. For a complete list of TextParagraph class members, see the TextParagraph Members topic.

Public Instance Properties

AlignmentType | Gets and sets the text horizontal alignment type of the paragraph.
Bullet | Gets the bullet.
Children | Gets all text runs in this paragraph. If this paragraph is empty, return paragraph itself.
DefaultTabSize | Gets and sets the default size for a tab character within this paragraph.
FirstLineIndent | Specifies the indent size that will be applied to the first line of text in the paragraph.
Font (inherited from FontSetting) | Returns the font of this object.
FontAlignType | Determines where vertically on a line of text the actual words are positioned. This deals with vertical placement of the characters with respect to the baselines.
IsEastAsianLineBreak | Specifies whether an East Asian word can be broken in half and wrapped onto the next line without a hyphen being added.
IsHangingPunctuation | Specifies whether punctuation is to be forcefully laid out on a line of text or put on a different line of text.
IsLatinLineBreak | Specifies whether a Latin word can be broken in half and wrapped onto the next line without a hyphen being added.
LeftMargin | Specifies the left margin of the paragraph.
Length (inherited from FontSetting) | Gets the length of the characters.
LineSpace | Gets and sets the amount of vertical white space that will be used within a paragraph.
LineSpaceSizeType | Gets and sets the amount of vertical white space that will be used within a paragraph.
RightMargin | Specifies the right margin of the paragraph.
SpaceAfter | Gets and sets the amount of vertical white space that will be present after a paragraph.
SpaceAfterSizeType | Gets and sets the amount of vertical white space that will be present after a paragraph.
SpaceBefore | Gets and sets the amount of vertical white space that will be present before a paragraph.
SpaceBeforeSizeType | Gets and sets the amount of vertical white space that will be present before a paragraph.
StartIndex (inherited from FontSetting) | Gets the start index of the characters.
Stops | Gets tab stop list.
TextOptions (inherited from FontSetting) | Returns the text options.
Type | Gets the type of text node.

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


AlignmentType Property

Aspose.Cells for .NET

TextParagraph.AlignmentType Property

Gets and sets the text horizontal alignment type of the paragraph.

public TextAlignmentType AlignmentType {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


Bullet Property

Aspose.Cells for .NET

TextParagraph.Bullet Property

Gets the bullet.

public Bullet Bullet {get;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


Children Property

Aspose.Cells for .NET

TextParagraph.Children Property

Gets all text runs in this paragraph. If this paragraph is empty, return paragraph itself.

public FontSetting[] Children {get;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


DefaultTabSize Property

Aspose.Cells for .NET

TextParagraph.DefaultTabSize Property

Gets and sets the default size for a tab character within this paragraph.

public double DefaultTabSize {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


FirstLineIndent Property

Aspose.Cells for .NET

TextParagraph.FirstLineIndent Property

Specifies the indent size that will be applied to the first line of text in the paragraph.

public double FirstLineIndent {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


FontAlignType Property

Aspose.Cells for .NET

TextParagraph.FontAlignType Property

Determines where vertically on a line of text the actual words are positioned. This deals with vertical placement of the characters with respect to the baselines.

public TextFontAlignType FontAlignType {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


IsEastAsianLineBreak Property

Aspose.Cells for .NET

TextParagraph.IsEastAsianLineBreak Property

Specifies whether an East Asian word can be broken in half and wrapped onto the next line without a hyphen being added.

public bool IsEastAsianLineBreak {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


IsHangingPunctuation Property

Aspose.Cells for .NET

TextParagraph.IsHangingPunctuation Property

Specifies whether punctuation is to be forcefully laid out on a line of text or put on a different line of text.

public bool IsHangingPunctuation {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


IsLatinLineBreak Property

Aspose.Cells for .NET

TextParagraph.IsLatinLineBreak Property

Specifies whether a Latin word can be broken in half and wrapped onto the next line without a hyphen being added.

public bool IsLatinLineBreak {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


LeftMargin Property

Aspose.Cells for .NET

TextParagraph.LeftMargin Property

Specifies the left margin of the paragraph.

public double LeftMargin {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


LineSpace Property

Aspose.Cells for .NET

TextParagraph.LineSpace Property

Gets and sets the amount of vertical white space that will be used within a paragraph.

public double LineSpace {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


LineSpaceSizeType Property

Aspose.Cells for .NET

TextParagraph.LineSpaceSizeType Property

Gets and sets the amount of vertical white space that will be used within a paragraph.

public LineSpaceSizeType LineSpaceSizeType {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


RightMargin Property

Aspose.Cells for .NET

TextParagraph.RightMargin Property

Specifies the right margin of the paragraph.

public double RightMargin {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


SpaceAfter Property

Aspose.Cells for .NET

TextParagraph.SpaceAfter Property

Gets and sets the amount of vertical white space that will be present after a paragraph.

public double SpaceAfter {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


SpaceAfterSizeType Property

Aspose.Cells for .NET

TextParagraph.SpaceAfterSizeType Property

Gets and sets the amount of vertical white space that will be present after a paragraph.

public LineSpaceSizeType SpaceAfterSizeType {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


SpaceBefore Property

Aspose.Cells for .NET

TextParagraph.SpaceBefore Property

Gets and sets the amount of vertical white space that will be present before a paragraph.

public double SpaceBefore {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


SpaceBeforeSizeType Property

Aspose.Cells for .NET

TextParagraph.SpaceBeforeSizeType Property

Gets and sets the amount of vertical white space that will be present before a paragraph.

public LineSpaceSizeType SpaceBeforeSizeType {get; set;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


Stops Property

Aspose.Cells for .NET

TextParagraph.Stops Property

Gets tab stop list.

public TextTabStopCollection Stops {get;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


Type Property

Aspose.Cells for .NET

TextParagraph.Type Property

Gets the type of text node.

public override TextNodeType Type {get;}

See Also

TextParagraph Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraphCollection Class

Represents all text paragraph.

For a list of all members of this type, see TextParagraphCollection Members.

System.Object
Aspose.Cells.Drawing.Texts.TextParagraphCollection

public class TextParagraphCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextParagraphCollection Members | Aspose.Cells.Drawing.Texts Namespace


TextParagraphCollection Members

TextParagraphCollection overview

Public Instance Properties

Count | Gets the count of text paragraphs.
Item | Gets the TextParagraph object at specific index.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the enumerator of the paragraphs.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

TextParagraphCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraphCollection Properties

The properties of the TextParagraphCollection class are listed below. For a complete list of TextParagraphCollection class members, see the TextParagraphCollection Members topic.

Public Instance Properties

Count | Gets the count of text paragraphs.
Item | Gets the TextParagraph object at specific index.

See Also

TextParagraphCollection Class | Aspose.Cells.Drawing.Texts Namespace


Count Property

Aspose.Cells for .NET

TextParagraphCollection.Count Property

Gets the count of text paragraphs.

public int Count {get;}

See Also

TextParagraphCollection Class | Aspose.Cells.Drawing.Texts Namespace


Item Property

Aspose.Cells for .NET

TextParagraphCollection.Item Property

Gets the TextParagraph object at specific index.

public TextParagraph this[
int index
] {get;}

Parameters

index
The index.

See Also

TextParagraphCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraphCollection Methods

The methods of the TextParagraphCollection class are listed below. For a complete list of TextParagraphCollection class members, see the TextParagraphCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the enumerator of the paragraphs.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

TextParagraphCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextParagraphCollection.GetEnumerator Method

Gets the enumerator of the paragraphs.

public IEnumerator GetEnumerator();

Return Value

See Also

TextParagraphCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextTabAlignmentType Enumeration

Represents the text tab alignment types.

public enum TextTabAlignmentType

Members

Member Name | Description | Value
Center | The text at this tab stop is center aligned. | 0
Decimal | At this tab stop, the decimals are lined up. | 1
Left | The text at this tab stop is left aligned. | 2
Right | The text at this tab stop is right aligned. | 3

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


TextTabStop Class

Represents tab stop.

For a list of all members of this type, see TextTabStop Members.

System.Object
Aspose.Cells.Drawing.Texts.TextTabStop

public class TextTabStop

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextTabStop Members | Aspose.Cells.Drawing.Texts Namespace


TextTabStop Members

TextTabStop overview

Public Instance Properties

TabAlignment | Specifies the alignment that is to be applied to text using this tab stop.
TabPosition | Specifies the position of the tab stop relative to the left margin.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TextTabStop Class | Aspose.Cells.Drawing.Texts Namespace


TextTabStop Properties

The properties of the TextTabStop class are listed below. For a complete list of TextTabStop class members, see the TextTabStop Members topic.

Public Instance Properties

TabAlignment | Specifies the alignment that is to be applied to text using this tab stop.
TabPosition | Specifies the position of the tab stop relative to the left margin.

See Also

TextTabStop Class | Aspose.Cells.Drawing.Texts Namespace


TabAlignment Property

Aspose.Cells for .NET

TextTabStop.TabAlignment Property

Specifies the alignment that is to be applied to text using this tab stop.

public TextTabAlignmentType TabAlignment {get; set;}

See Also

TextTabStop Class | Aspose.Cells.Drawing.Texts Namespace


TabPosition Property

Aspose.Cells for .NET

TextTabStop.TabPosition Property

Specifies the position of the tab stop relative to the left margin.

public double TabPosition {get; set;}

See Also

TextTabStop Class | Aspose.Cells.Drawing.Texts Namespace


TextTabStopCollection Class

Represents the list of all tab stops.

For a list of all members of this type, see TextTabStopCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Drawing.Texts.TextTabStopCollection

public class TextTabStopCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TextTabStopCollection Members | Aspose.Cells.Drawing.Texts Namespace


TextTabStopCollection Members

TextTabStopCollection overview

Public Instance Constructors

TextTabStopCollection Constructor Initializes a new instance of the TextTabStopCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets TextTabStop by the index.

Public Instance Methods

Add | Adds a tab stop.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TextTabStopCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextTabStopCollection Constructor

Initializes a new instance of the TextTabStopCollection class.

public TextTabStopCollection();

See Also

TextTabStopCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextTabStopCollection Properties

The properties of the TextTabStopCollection class are listed below. For a complete list of TextTabStopCollection class members, see the TextTabStopCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets TextTabStop by the index.

See Also

TextTabStopCollection Class | Aspose.Cells.Drawing.Texts Namespace


Item Property

Aspose.Cells for .NET

TextTabStopCollection.Item Property

Gets TextTabStop by the index.

public TextTabStop this[
int index
] {get;}

Parameters

index
The index.

See Also

TextTabStopCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextTabStopCollection Methods

The methods of the TextTabStopCollection class are listed below. For a complete list of TextTabStopCollection class members, see the TextTabStopCollection Members topic.

Public Instance Methods

Add | Adds a tab stop.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TextTabStopCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextTabStopCollection.Add Method

Adds a tab stop.

public int Add(
TextTabAlignmentType tabAlignment,
double tabPosition
);

Parameters

tabAlignment
tabPosition

Return Value

See Also

TextTabStopCollection Class | Aspose.Cells.Drawing.Texts Namespace


TextVerticalType Enumeration

Represents the text direct type.

public enum TextVerticalType

Members

Member Name | Description | Value
Vertical | East Asian Vertical display. | 0
Horizontal | Horizontal text. | 1
VerticalLeftToRight | Displayed vertical and the text flows top down then LEFT to RIGHT | 2
Vertical90 | Each line is 90 degrees rotated clockwise | 3
Vertical270 | Each line is 270 degrees rotated clockwise | 4
Stacked | Determines if all of the text is vertical | 5
StackedRightToLeft | Specifies that vertical WordArt should be shown from right to left rather than left to right. | 6

Requirements

Namespace: Aspose.Cells.Drawing.Texts

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Drawing.Texts Namespace


Aspose.Cells.ExternalConnections

Aspose.Cells for .NET

Aspose.Cells.ExternalConnections Namespace

Namespace hierarchy

Classes

Class | Description
ConnectionParameter | Specifies properties about any parameters used with external data connections Parameters are valid for ODBC and web queries.
ConnectionParameterCollection | Specifies the ConnectionParameter collection
DBConnection | Specifies all properties associated with an ODBC or OLE DB external data connection.
ExternalConnection | Specifies an external data connection
ExternalConnectionCollection | Specifies the ExternalConnection collection
WebQueryConnection | Specifies the properties for a web query source. A web query will retrieve data from HTML tables, and can also supply HTTP "Get" parameters to be processed by the web server in generating the HTML by including the parameters and parameter elements.

Enumerations

Enumeration | Description
ConnectionDataSourceType | Specifies external database source type
ConnectionParameterType | Specifies the parameter type of external connection
CredentialsMethodType | Specifies Credentials method used for server access.
HtmlFormatHandlingType | Specifies how to handle formatting from the HTML source
OLEDBCommandType | Specifies the OLE DB command type.
ReConnectionMethodType | Specifies what the spreadsheet application should do when a connection fails.
SqlDataType | Specifies SQL data type of the parameter. Only valid for ODBC sources.


ConnectionDataSourceType Enumeration

Specifies external database source type

public enum ConnectionDataSourceType

Members

Member Name | Description | Value
ODBCBasedSource | ODBC-based source | 1
DAOBasedSource | DAO-based source | 2
FileBasedDataBaseSource | File based database source | 3
WebQuery | Web query | 4
OLEDBBasedSource | OLE DB-based source | 5
TextBasedSource | Text-based source | 6
ADORecordSet | ADO record set | 7
DSP | DSP | 8
OLEDBDataModel | OLE DB data source created by the Spreadsheet Data Model. | 100
DataFeedDataModel | Data feed data source created by the Spreadsheet Data Model. | 101
WorksheetDataModel | Worksheet data source created by the Spreadsheet Data Model. | 102
Table | Obsolete. Use WorksheetDataModel enum instead. Worksheet data source created by the Spreadsheet Data Model. | 102
TextDataModel | Text data source created by the Spreadsheet Data Model. | 103
Unknown | Text data source created by the Spreadsheet Data Model. | 255

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


ConnectionParameter Class

Specifies properties about any parameters used with external data connections Parameters are valid for ODBC and web queries.

For a list of all members of this type, see ConnectionParameter Members.

System.Object
Aspose.Cells.ExternalConnections.ConnectionParameter

public class ConnectionParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConnectionParameter Members | Aspose.Cells.ExternalConnections Namespace


ConnectionParameter Members

ConnectionParameter overview

Public Instance Properties

CellReference | Cell reference indicating which cell's value to use for the query parameter. Used only when parameterType is cell.
Name | The name of the parameter.
Prompt | Prompt string for the parameter. Presented to the spreadsheet user along with input UI to collect the parameter value before refreshing the external data. Used only when parameterType = prompt.
RefreshOnChange | Flag indicating whether the query should automatically refresh when the contents of a cell that provides the parameter value changes. If true, then external data is refreshed using the new parameter value every time there's a change. If false, then external data is only refreshed when requested by the user, or some other event triggers refresh (e.g., workbook opened).
SqlType | SQL data type of the parameter. Only valid for ODBC sources.
Type | Type of parameter used. If the parameterType=value, then the value from boolean, double, integer, or string will be used. In this case, it is expected that only one of {boolean, double, integer, or string} will be specified.
Value | Non-integer numeric value,Integer value,String value or Boolean value to use as the query parameter. Used only when parameterType is value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


ConnectionParameter Properties

The properties of the ConnectionParameter class are listed below. For a complete list of ConnectionParameter class members, see the ConnectionParameter Members topic.

Public Instance Properties

CellReference | Cell reference indicating which cell's value to use for the query parameter. Used only when parameterType is cell.
Name | The name of the parameter.
Prompt | Prompt string for the parameter. Presented to the spreadsheet user along with input UI to collect the parameter value before refreshing the external data. Used only when parameterType = prompt.
RefreshOnChange | Flag indicating whether the query should automatically refresh when the contents of a cell that provides the parameter value changes. If true, then external data is refreshed using the new parameter value every time there's a change. If false, then external data is only refreshed when requested by the user, or some other event triggers refresh (e.g., workbook opened).
SqlType | SQL data type of the parameter. Only valid for ODBC sources.
Type | Type of parameter used. If the parameterType=value, then the value from boolean, double, integer, or string will be used. In this case, it is expected that only one of {boolean, double, integer, or string} will be specified.
Value | Non-integer numeric value,Integer value,String value or Boolean value to use as the query parameter. Used only when parameterType is value.

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


CellReference Property

Aspose.Cells for .NET

ConnectionParameter.CellReference Property

Cell reference indicating which cell's value to use for the query parameter. Used only when parameterType is cell.

public string CellReference {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


Name Property

Aspose.Cells for .NET

ConnectionParameter.Name Property

The name of the parameter.

public string Name {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


Prompt Property

Aspose.Cells for .NET

ConnectionParameter.Prompt Property

Prompt string for the parameter. Presented to the spreadsheet user along with input UI to collect the parameter value before refreshing the external data. Used only when parameterType = prompt.

public string Prompt {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


RefreshOnChange Property

Aspose.Cells for .NET

ConnectionParameter.RefreshOnChange Property

Flag indicating whether the query should automatically refresh when the contents of a cell that provides the parameter value changes. If true, then external data is refreshed using the new parameter value every time there's a change. If false, then external data is only refreshed when requested by the user, or some other event triggers refresh (e.g., workbook opened).

public bool RefreshOnChange {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


SqlType Property

Aspose.Cells for .NET

ConnectionParameter.SqlType Property

SQL data type of the parameter. Only valid for ODBC sources.

public SqlDataType SqlType {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


Type Property

Aspose.Cells for .NET

ConnectionParameter.Type Property

Type of parameter used. If the parameterType=value, then the value from boolean, double, integer, or string will be used. In this case, it is expected that only one of {boolean, double, integer, or string} will be specified.

public ConnectionParameterType Type {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


Value Property

Aspose.Cells for .NET

ConnectionParameter.Value Property

Non-integer numeric value,Integer value,String value or Boolean value to use as the query parameter. Used only when parameterType is value.

public object Value {get; set;}

See Also

ConnectionParameter Class | Aspose.Cells.ExternalConnections Namespace


ConnectionParameterCollection Class

Specifies the ConnectionParameter collection

For a list of all members of this type, see ConnectionParameterCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ExternalConnections.ConnectionParameterCollection

public class ConnectionParameterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ConnectionParameterCollection Members | Aspose.Cells.ExternalConnections Namespace


ConnectionParameterCollection Members

ConnectionParameterCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ConnectionParameter element at the specified index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

ConnectionParameterCollection Class | Aspose.Cells.ExternalConnections Namespace


ConnectionParameterCollection Properties

The properties of the ConnectionParameterCollection class are listed below. For a complete list of ConnectionParameterCollection class members, see the ConnectionParameterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ConnectionParameter element at the specified index.

See Also

ConnectionParameterCollection Class | Aspose.Cells.ExternalConnections Namespace


Item Property

Aspose.Cells for .NET

ConnectionParameterCollection.Item Property

Gets the ConnectionParameter element at the specified index.

Overload List

Gets the ConnectionParameter element at the specified index.

public ConnectionParameter this[int] {get; set;}

Gets the ConnectionParameter element with the specified name.

public ConnectionParameter this[string] {get;}

See Also

ConnectionParameterCollection Class | Aspose.Cells.ExternalConnections Namespace


Item Property (Int32)

Aspose.Cells for .NET

ConnectionParameterCollection.Item Property (Int32)

Gets the ConnectionParameter element at the specified index.

public ConnectionParameter this[
int index
] {get; set;}

Parameters

index
The zero based index of the element.

See Also

ConnectionParameterCollection Class | Aspose.Cells.ExternalConnections Namespace | ConnectionParameterCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ConnectionParameterCollection.Item Property (String)

Gets the ConnectionParameter element with the specified name.

public ConnectionParameter this[
string connParamName
] {get;}

Parameters

connParamName
connection parameter name

See Also

ConnectionParameterCollection Class | Aspose.Cells.ExternalConnections Namespace | ConnectionParameterCollection.Item Overload List


ConnectionParameterType Enumeration

Specifies the parameter type of external connection

public enum ConnectionParameterType

Members

Member Name | Description | Value
Cell | Get the parameter value from a cell on each refresh. | 0
Prompt | Prompt the user on each refresh for a parameter value. | 1
Value | Use a constant value on each refresh for the parameter value. | 2

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


CredentialsMethodType Enumeration

Specifies Credentials method used for server access.

public enum CredentialsMethodType

Members

Member Name | Description | Value
Integrated | Integrated Authentication | 0
None | No Credentials | 1
Prompt | Prompt Credentials | 2
Stored | Stored Credentials | 3

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


DBConnection Class

Specifies all properties associated with an ODBC or OLE DB external data connection.

For a list of all members of this type, see DBConnection Members.

System.Object
Aspose.Cells.ExternalConnections.ExternalConnection
Aspose.Cells.ExternalConnections.DBConnection

public class DBConnection : ExternalConnection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DBConnection Members | Aspose.Cells.ExternalConnections Namespace


DBConnection Members

DBConnection overview

Public Instance Properties

BackgroundRefresh (inherited from ExternalConnection) | Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.
Command | The string containing the database command to pass to the data provider API that will interact with the external source in order to retrieve data
CommandType | Specifies the OLE DB command type. 1. Query specifies a cube name 2. Query specifies a SQL statement 3. Query specifies a table name 4. Query specifies that default information has been given, and it is up to the provider how to interpret. 5. Query is against a web based List Data Provider.
ConnectionDescription (inherited from ExternalConnection) | Specifies the user description for this connection
ConnectionId (inherited from ExternalConnection) | Specifies The unique identifier of this connection.
ConnectionInfo | The connection information string is used to make contact with an OLE DB or ODBC data source.
Credentials (inherited from ExternalConnection) | Obsolete. Specifies the authentication method to be used when establishing (or re-establishing) the connection.
CredentialsMethodType (inherited from ExternalConnection) | Specifies the authentication method to be used when establishing (or re-establishing) the connection.
Id (inherited from ExternalConnection) | Gets the id of the connection.
IsDeleted (inherited from ExternalConnection) | Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.
IsNew (inherited from ExternalConnection) | True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.
KeepAlive (inherited from ExternalConnection) | True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.
Name (inherited from ExternalConnection) | Specifies the name of the connection. Each connection must have a unique name.
OdcFile (inherited from ExternalConnection) | Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.
OnlyUseConnectionFile (inherited from ExternalConnection) | Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute
Parameters (inherited from ExternalConnection) | Gets ConnectionParameterCollection for an ODBC or web query.
PowerQueryFormula | Gets the definition of power query formula.
ReconnectionMethod (inherited from ExternalConnection) | Obsolete. Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
ReconnectionMethodType (inherited from ExternalConnection) | Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
RefreshInternal (inherited from ExternalConnection) | Specifies the number of minutes between automatic refreshes of the connection.
RefreshOnLoad (inherited from ExternalConnection) | True if this connection should be refreshed when opening the file; otherwise, false.
SaveData (inherited from ExternalConnection) | True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.
SavePassword (inherited from ExternalConnection) | True if the password is to be saved as part of the connection string; otherwise, False.
SeverCommand | Specifies a second command text string that is persisted when PivotTable server-based page fields are in use. For ODBC connections, serverCommand is usually a broader query than command (no WHERE clause is present in the former). Based on these 2 commands(Command and ServerCommand), parameter UI can be populated and parameterized queries can be constructed
SourceFile (inherited from ExternalConnection) | Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.
SSOId (inherited from ExternalConnection) | Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.
Type (inherited from ExternalConnection) | Gets or Sets the external connection DataSource type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


DBConnection Properties

The properties of the DBConnection class are listed below. For a complete list of DBConnection class members, see the DBConnection Members topic.

Public Instance Properties

BackgroundRefresh (inherited from ExternalConnection) | Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.
Command | The string containing the database command to pass to the data provider API that will interact with the external source in order to retrieve data
CommandType | Specifies the OLE DB command type. 1. Query specifies a cube name 2. Query specifies a SQL statement 3. Query specifies a table name 4. Query specifies that default information has been given, and it is up to the provider how to interpret. 5. Query is against a web based List Data Provider.
ConnectionDescription (inherited from ExternalConnection) | Specifies the user description for this connection
ConnectionId (inherited from ExternalConnection) | Specifies The unique identifier of this connection.
ConnectionInfo | The connection information string is used to make contact with an OLE DB or ODBC data source.
Credentials (inherited from ExternalConnection) | Obsolete. Specifies the authentication method to be used when establishing (or re-establishing) the connection.
CredentialsMethodType (inherited from ExternalConnection) | Specifies the authentication method to be used when establishing (or re-establishing) the connection.
Id (inherited from ExternalConnection) | Gets the id of the connection.
IsDeleted (inherited from ExternalConnection) | Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.
IsNew (inherited from ExternalConnection) | True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.
KeepAlive (inherited from ExternalConnection) | True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.
Name (inherited from ExternalConnection) | Specifies the name of the connection. Each connection must have a unique name.
OdcFile (inherited from ExternalConnection) | Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.
OnlyUseConnectionFile (inherited from ExternalConnection) | Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute
Parameters (inherited from ExternalConnection) | Gets ConnectionParameterCollection for an ODBC or web query.
PowerQueryFormula | Gets the definition of power query formula.
ReconnectionMethod (inherited from ExternalConnection) | Obsolete. Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
ReconnectionMethodType (inherited from ExternalConnection) | Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
RefreshInternal (inherited from ExternalConnection) | Specifies the number of minutes between automatic refreshes of the connection.
RefreshOnLoad (inherited from ExternalConnection) | True if this connection should be refreshed when opening the file; otherwise, false.
SaveData (inherited from ExternalConnection) | True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.
SavePassword (inherited from ExternalConnection) | True if the password is to be saved as part of the connection string; otherwise, False.
SeverCommand | Specifies a second command text string that is persisted when PivotTable server-based page fields are in use. For ODBC connections, serverCommand is usually a broader query than command (no WHERE clause is present in the former). Based on these 2 commands(Command and ServerCommand), parameter UI can be populated and parameterized queries can be constructed
SourceFile (inherited from ExternalConnection) | Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.
SSOId (inherited from ExternalConnection) | Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.
Type (inherited from ExternalConnection) | Gets or Sets the external connection DataSource type.

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


Command Property

Aspose.Cells for .NET

DBConnection.Command Property

The string containing the database command to pass to the data provider API that will interact with the external source in order to retrieve data

public string Command {get; set;}

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


CommandType Property

Aspose.Cells for .NET

DBConnection.CommandType Property

Specifies the OLE DB command type. 1. Query specifies a cube name 2. Query specifies a SQL statement 3. Query specifies a table name 4. Query specifies that default information has been given, and it is up to the provider how to interpret. 5. Query is against a web based List Data Provider.

public OLEDBCommandType CommandType {get; set;}

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


ConnectionInfo Property

Aspose.Cells for .NET

DBConnection.ConnectionInfo Property

The connection information string is used to make contact with an OLE DB or ODBC data source.

public string ConnectionInfo {get; set;}

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


PowerQueryFormula Property

Aspose.Cells for .NET

DBConnection.PowerQueryFormula Property

Gets the definition of power query formula.

public override PowerQueryFormula PowerQueryFormula {get;}

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


SeverCommand Property

Aspose.Cells for .NET

DBConnection.SeverCommand Property

Specifies a second command text string that is persisted when PivotTable server-based page fields are in use. For ODBC connections, serverCommand is usually a broader query than command (no WHERE clause is present in the former). Based on these 2 commands(Command and ServerCommand), parameter UI can be populated and parameterized queries can be constructed

public string SeverCommand {get; set;}

See Also

DBConnection Class | Aspose.Cells.ExternalConnections Namespace


ExternalConnection Class

Specifies an external data connection

For a list of all members of this type, see ExternalConnection Members.

System.Object
Aspose.Cells.ExternalConnections.ExternalConnection
Aspose.Cells.ExternalConnections.DBConnection
Aspose.Cells.ExternalConnections.WebQueryConnection

public abstract class ExternalConnection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExternalConnection Members | Aspose.Cells.ExternalConnections Namespace


ExternalConnection Members

ExternalConnection overview

Public Instance Properties

BackgroundRefresh | Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.
ConnectionDescription | Specifies the user description for this connection
ConnectionId | Specifies The unique identifier of this connection.
Credentials | Obsolete. Specifies the authentication method to be used when establishing (or re-establishing) the connection.
CredentialsMethodType | Specifies the authentication method to be used when establishing (or re-establishing) the connection.
Id | Gets the id of the connection.
IsDeleted | Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.
IsNew | True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.
KeepAlive | True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.
Name | Specifies the name of the connection. Each connection must have a unique name.
OdcFile | Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.
OnlyUseConnectionFile | Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute
Parameters | Gets ConnectionParameterCollection for an ODBC or web query.
PowerQueryFormula | Gets the definition of power query formula.
ReconnectionMethod | Obsolete. Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
ReconnectionMethodType | Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
RefreshInternal | Specifies the number of minutes between automatic refreshes of the connection.
RefreshOnLoad | True if this connection should be refreshed when opening the file; otherwise, false.
SaveData | True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.
SavePassword | True if the password is to be saved as part of the connection string; otherwise, False.
SourceFile | Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.
SSOId | Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.
Type | Gets or Sets the external connection DataSource type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


ExternalConnection Properties

The properties of the ExternalConnection class are listed below. For a complete list of ExternalConnection class members, see the ExternalConnection Members topic.

Public Instance Properties

BackgroundRefresh | Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.
ConnectionDescription | Specifies the user description for this connection
ConnectionId | Specifies The unique identifier of this connection.
Credentials | Obsolete. Specifies the authentication method to be used when establishing (or re-establishing) the connection.
CredentialsMethodType | Specifies the authentication method to be used when establishing (or re-establishing) the connection.
Id | Gets the id of the connection.
IsDeleted | Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.
IsNew | True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.
KeepAlive | True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.
Name | Specifies the name of the connection. Each connection must have a unique name.
OdcFile | Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.
OnlyUseConnectionFile | Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute
Parameters | Gets ConnectionParameterCollection for an ODBC or web query.
PowerQueryFormula | Gets the definition of power query formula.
ReconnectionMethod | Obsolete. Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
ReconnectionMethodType | Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
RefreshInternal | Specifies the number of minutes between automatic refreshes of the connection.
RefreshOnLoad | True if this connection should be refreshed when opening the file; otherwise, false.
SaveData | True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.
SavePassword | True if the password is to be saved as part of the connection string; otherwise, False.
SourceFile | Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.
SSOId | Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.
Type | Gets or Sets the external connection DataSource type.

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


BackgroundRefresh Property

Aspose.Cells for .NET

ExternalConnection.BackgroundRefresh Property

Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.

public bool BackgroundRefresh {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


ConnectionDescription Property

Aspose.Cells for .NET

ExternalConnection.ConnectionDescription Property

Specifies the user description for this connection

public string ConnectionDescription {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


ConnectionId Property

Aspose.Cells for .NET

ExternalConnection.ConnectionId Property

Specifies The unique identifier of this connection.

public int ConnectionId {get;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


Credentials Property

Aspose.Cells for .NET

ExternalConnection.Credentials Property

NOTE: This property is now obsolete.

Use ExternalConnection.CredentialsMethodType property instead.

Specifies the authentication method to be used when establishing (or re-establishing) the connection.

public CredentialsMethodType Credentials {get; set;}

Remarks

NOTE: This property is now obsolete. Instead, please use ExternalConnection.CredentialsMethodType property. This property will be removed 12 months later since October 2017. Aspose apologizes for any inconvenience you may have experienced.

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


CredentialsMethodType Property

Aspose.Cells for .NET

ExternalConnection.CredentialsMethodType Property

Specifies the authentication method to be used when establishing (or re-establishing) the connection.

public CredentialsMethodType CredentialsMethodType {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


Id Property

Aspose.Cells for .NET

ExternalConnection.Id Property

Gets the id of the connection.

public int Id {get;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


IsDeleted Property

Aspose.Cells for .NET

ExternalConnection.IsDeleted Property

Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.

public bool IsDeleted {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


IsNew Property

Aspose.Cells for .NET

ExternalConnection.IsNew Property

True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.

public bool IsNew {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


KeepAlive Property

Aspose.Cells for .NET

ExternalConnection.KeepAlive Property

True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.

public bool KeepAlive {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


Name Property

Aspose.Cells for .NET

ExternalConnection.Name Property

Specifies the name of the connection. Each connection must have a unique name.

public string Name {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


OdcFile Property

Aspose.Cells for .NET

ExternalConnection.OdcFile Property

Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.

public string OdcFile {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


OnlyUseConnectionFile Property

Aspose.Cells for .NET

ExternalConnection.OnlyUseConnectionFile Property

Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute

public bool OnlyUseConnectionFile {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


Parameters Property

Aspose.Cells for .NET

ExternalConnection.Parameters Property

Gets ConnectionParameterCollection for an ODBC or web query.

public ConnectionParameterCollection Parameters {get;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


PowerQueryFormula Property

Aspose.Cells for .NET

ExternalConnection.PowerQueryFormula Property

Gets the definition of power query formula.

public virtual PowerQueryFormula PowerQueryFormula {get;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


ReconnectionMethod Property

Aspose.Cells for .NET

ExternalConnection.ReconnectionMethod Property

NOTE: This property is now obsolete.

Use ExternalConnection.ReconnectionMethodType property instead.

Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.

public ReConnectionMethodType ReconnectionMethod {get; set;}

Remarks

NOTE: This property is now obsolete. Instead, please use ExternalConnection.ReconnectionMethodType property. This property will be removed 12 months later since October 2017. Aspose apologizes for any inconvenience you may have experienced.

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


ReconnectionMethodType Property

Aspose.Cells for .NET

ExternalConnection.ReconnectionMethodType Property

Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.

public ReConnectionMethodType ReconnectionMethodType {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


RefreshInternal Property

Aspose.Cells for .NET

ExternalConnection.RefreshInternal Property

Specifies the number of minutes between automatic refreshes of the connection.

public int RefreshInternal {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


RefreshOnLoad Property

Aspose.Cells for .NET

ExternalConnection.RefreshOnLoad Property

True if this connection should be refreshed when opening the file; otherwise, false.

public bool RefreshOnLoad {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


SaveData Property

Aspose.Cells for .NET

ExternalConnection.SaveData Property

True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.

public bool SaveData {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


SavePassword Property

Aspose.Cells for .NET

ExternalConnection.SavePassword Property

True if the password is to be saved as part of the connection string; otherwise, False.

public bool SavePassword {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


SourceFile Property

Aspose.Cells for .NET

ExternalConnection.SourceFile Property

Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.

public string SourceFile {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


SSOId Property

Aspose.Cells for .NET

ExternalConnection.SSOId Property

Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.

public string SSOId {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


Type Property

Aspose.Cells for .NET

ExternalConnection.Type Property

Gets or Sets the external connection DataSource type.

public ConnectionDataSourceType Type {get; set;}

See Also

ExternalConnection Class | Aspose.Cells.ExternalConnections Namespace


ExternalConnectionCollection Class

Specifies the ExternalConnection collection

For a list of all members of this type, see ExternalConnectionCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.ExternalConnections.ExternalConnectionCollection

public class ExternalConnectionCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
Workbook wb = new Workbook("connection.xlsx");
ExternalConnectionCollection dataConns = wb.DataConnections;
ExternalConnection dataConn = null;
for (int i = 0; i < dataConns.Count; i++)
{
    dataConn = dataConns[i];
    //get external connection id
    Console.WriteLine(dataConn.ConnectionId);
}

[Visual Basic]
Dim wb As Workbook = New Workbook("connection.xlsx")
Dim dataConns As ExternalConnectionCollection = wb.DataConnections
Dim dataConn As ExternalConnection
Dim count As Integer = dataConns.Count - 1
Dim i As Integer
For i = 0 To count Step 1
    dataConn = dataConns(i)
    'get external connection id
    Console.WriteLine(dataConn.ConnectionId)
Next

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExternalConnectionCollection Members | Aspose.Cells.ExternalConnections Namespace


ExternalConnectionCollection Members

ExternalConnectionCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ExternalConnection element at the specified index.

Public Instance Methods

Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetExternalConnectionById | Gets the ExternalConnection element with the specified id.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace


ExternalConnectionCollection Properties

The properties of the ExternalConnectionCollection class are listed below. For a complete list of ExternalConnectionCollection class members, see the ExternalConnectionCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ExternalConnection element at the specified index.

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace


Item Property

Aspose.Cells for .NET

ExternalConnectionCollection.Item Property

Gets the ExternalConnection element at the specified index.

Overload List

Gets the ExternalConnection element at the specified index.

public ExternalConnection this[int] {get; set;}

Gets the ExternalConnection element with the specified name.

public ExternalConnection this[string] {get;}

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace


Item Property (Int32)

Aspose.Cells for .NET

ExternalConnectionCollection.Item Property (Int32)

Gets the ExternalConnection element at the specified index.

public ExternalConnection this[
int index
] {get; set;}

Parameters

index
The zero based index of the element.

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace | ExternalConnectionCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ExternalConnectionCollection.Item Property (String)

Gets the ExternalConnection element with the specified name.

public ExternalConnection this[
string connectionName
] {get;}

Parameters

connectionName
data connection name

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace | ExternalConnectionCollection.Item Overload List


ExternalConnectionCollection Methods

The methods of the ExternalConnectionCollection class are listed below. For a complete list of ExternalConnectionCollection class members, see the ExternalConnectionCollection Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetExternalConnectionById | Gets the ExternalConnection element with the specified id.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace


ExternalConnectionCollection.GetExternalConnectionById Method

Gets the ExternalConnection element with the specified id.

public ExternalConnection GetExternalConnectionById(
int connId
);

Parameters

connId
external connection id

Return Value

The element with the specified id.

See Also

ExternalConnectionCollection Class | Aspose.Cells.ExternalConnections Namespace


HtmlFormatHandlingType Enumeration

Specifies how to handle formatting from the HTML source

public enum HtmlFormatHandlingType

Members

Member Name | Description | Value
All | Transfer all HTML formatting into the worksheet along with data. | 0
None | Bring data in as unformatted text (setting data types still occurs). | 1
Rtf | Translate HTML formatting to rich text formatting on the data brought into the worksheet. | 2

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


OLEDBCommandType Enumeration

Specifies the OLE DB command type.

public enum OLEDBCommandType

Members

Member Name | Description | Value
None | The command type is not specified. | 0
CubeName | Specifies a cube name | 1
SqlStatement | Specifies a SQL statement | 2
TableName | Specifies a table name | 3
DefaultInformation | Specifies that default information has been given, and it is up to the provider how to interpret. | 4
WebBasedList | Specifies a query which is against a web based List Data Provider. | 5

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


ReConnectionMethodType Enumeration

Specifies what the spreadsheet application should do when a connection fails.

public enum ReConnectionMethodType

Members

Member Name | Description | Value
Required | On refresh use the existing connection information and if it ends up being invalid then get updated connection information, if available from the external connection file. | 1
Always | On every refresh get updated connection information from the external connection file, if available, and use that instead of the existing connection information. In this case the data refresh will fail if the external connection file is unavailable. | 2
Never | Never get updated connection information from the external connection file even if it is available and even if the existing connection information is invalid | 3

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


SqlDataType Enumeration

Specifies SQL data type of the parameter. Only valid for ODBC sources.

public enum SqlDataType

Members

Member Name | Description | Value
SqlUnsignedOffset | sql unsigned offset | -22
SqlSignedOffset | sql signed offset | -20
SqlGUID | sql guid | -11
SqlWLongVarchar | sql wide long variable char | -10
SqlWVarchar | sql wide variable char | -9
SqlWChar | sql wide char | -8
SqlBit | sql bit | -7
SqlTinyInt | sql tiny int | -6
SqlBigInt | sql big int | -5
SqlLongVarBinary | sql long variable binary | -4
SqlVarBinary | sql variable binary | -3
SqlBinary | sql binary | -2
SqlLongVarChar | sql long variable char | -1
SqlUnknownType | sql unknown type | 0
SqlChar | sql char | 1
SqlNumeric | sql numeric | 2
SqlDecimal | sql decimal | 3
SqlInteger | sql integer | 4
SqlSmallInt | sql small int | 5
SqlFloat | sql float | 6
SqlReal | sql real | 7
SqlDouble | sql double | 8
SqlTypeDate | sql date type | 9
SqlTypeTime | sql time type | 10
SqlTypeTimestamp | sql timestamp type | 11
SqlVarChar | sql variable char | 12
SqlIntervalYear | sql interval year | 101
SqlIntervalMonth | sql interval month | 102
SqlIntervalDay | sql interval day | 103
SqlIntervalHour | sql interval hour | 104
SqlIntervalMinute | sql interval minute | 105
SqlIntervalSecond | sql interval second | 106
SqlIntervalYearToMonth | sql interval year to month | 107
SqlIntervalDayToHour | sql interval day to hour | 108
SqlIntervalDayToMinute | sql interval day to minute | 109
SqlIntervalDayToSecond | sql interval day to second | 110
SqlIntervalHourToMinute | sql interval hour to minute | 111
SqlIntervalHourToSecond | sql interval hour to second | 112
SqlIntervalMinuteToSecond | sql interval minute to second | 113

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.ExternalConnections Namespace


WebQueryConnection Class

Specifies the properties for a web query source. A web query will retrieve data from HTML tables, and can also supply HTTP "Get" parameters to be processed by the web server in generating the HTML by including the parameters and parameter elements.

For a list of all members of this type, see WebQueryConnection Members.

System.Object
Aspose.Cells.ExternalConnections.ExternalConnection
Aspose.Cells.ExternalConnections.WebQueryConnection

public class WebQueryConnection : ExternalConnection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.ExternalConnections

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebQueryConnection Members | Aspose.Cells.ExternalConnections Namespace


WebQueryConnection Members

WebQueryConnection overview

Public Instance Properties

BackgroundRefresh (inherited from ExternalConnection) | Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.
ConnectionDescription (inherited from ExternalConnection) | Specifies the user description for this connection
ConnectionId (inherited from ExternalConnection) | Specifies The unique identifier of this connection.
Credentials (inherited from ExternalConnection) | Obsolete. Specifies the authentication method to be used when establishing (or re-establishing) the connection.
CredentialsMethodType (inherited from ExternalConnection) | Specifies the authentication method to be used when establishing (or re-establishing) the connection.
EditPage | Obsolete. The URL of the user-facing web page showing the web query data. This URL is persisted in the case that sourceData="true" and url has been redirected to reference an XML file. Then the user-facing page can be shown in the UI, and the XML data can be retrieved behind the scenes.
EditWebPage | The URL of the user-facing web page showing the web query data. This URL is persisted in the case that sourceData="true" and url has been redirected to reference an XML file. Then the user-facing page can be shown in the UI, and the XML data can be retrieved behind the scenes.
HtmlFormat | How to handle formatting from the HTML source when bringing web query data into the worksheet. Relevant when sourceData is True.
Id (inherited from ExternalConnection) | Gets the id of the connection.
IsConsecutive | Flag indicating whether consecutive delimiters should be treated as just one delimiter.
IsDeleted (inherited from ExternalConnection) | Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.
IsHtmlTables | Flag indicating whether web queries should only work on HTML tables.
IsNew (inherited from ExternalConnection) | True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.
IsParsePre | Flag indicating whether data contained within HTML PRE tags in the web page is parsed into columns when you import the page into a query table.
IsSameSettings | Flag indicating whether to parse all tables inside a PRE block with the same width settings as the first row.
IsTextDates | Flag indicating whether dates should be imported into cells in the worksheet as text rather than dates.
IsXl2000 | This flag exists for backward compatibility with older existing spreadsheet files, and is set to true if this web query was refreshed in a spreadsheet application newer than or equal to Microsoft Excel 2000. This is an optional attribute that can be ignored.
IsXl97 | This flag exists for backward compatibility with older existing spreadsheet files, and is set to true if this web query was created in Microsoft Excel 97. This is an optional attribute that can be ignored.
IsXml | true if the web query source is XML (versus HTML), otherwise false.
IsXmlSourceData | Flag indicating that XML source data should be imported instead of the HTML table itself.
KeepAlive (inherited from ExternalConnection) | True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.
Name (inherited from ExternalConnection) | Specifies the name of the connection. Each connection must have a unique name.
OdcFile (inherited from ExternalConnection) | Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.
OnlyUseConnectionFile (inherited from ExternalConnection) | Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute
Parameters (inherited from ExternalConnection) | Gets ConnectionParameterCollection for an ODBC or web query.
Post | Returns or sets the string used with the post method of inputting data into a web server to return data from a web query.
PowerQueryFormula (inherited from ExternalConnection) | Gets the definition of power query formula.
ReconnectionMethod (inherited from ExternalConnection) | Obsolete. Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
ReconnectionMethodType (inherited from ExternalConnection) | Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
RefreshInternal (inherited from ExternalConnection) | Specifies the number of minutes between automatic refreshes of the connection.
RefreshOnLoad (inherited from ExternalConnection) | True if this connection should be refreshed when opening the file; otherwise, false.
SaveData (inherited from ExternalConnection) | True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.
SavePassword (inherited from ExternalConnection) | True if the password is to be saved as part of the connection string; otherwise, False.
SourceFile (inherited from ExternalConnection) | Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.
SSOId (inherited from ExternalConnection) | Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.
Type (inherited from ExternalConnection) | Gets or Sets the external connection DataSource type.
Url | URL to use to refresh external data.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


WebQueryConnection Properties

The properties of the WebQueryConnection class are listed below. For a complete list of WebQueryConnection class members, see the WebQueryConnection Members topic.

Public Instance Properties

BackgroundRefresh (inherited from ExternalConnection) | Indicates whether the connection can be refreshed in the background (asynchronously). true if preferred usage of the connection is to refresh asynchronously in the background; false if preferred usage of the connection is to refresh synchronously in the foreground.
ConnectionDescription (inherited from ExternalConnection) | Specifies the user description for this connection
ConnectionId (inherited from ExternalConnection) | Specifies The unique identifier of this connection.
Credentials (inherited from ExternalConnection) | Obsolete. Specifies the authentication method to be used when establishing (or re-establishing) the connection.
CredentialsMethodType (inherited from ExternalConnection) | Specifies the authentication method to be used when establishing (or re-establishing) the connection.
EditPage | Obsolete. The URL of the user-facing web page showing the web query data. This URL is persisted in the case that sourceData="true" and url has been redirected to reference an XML file. Then the user-facing page can be shown in the UI, and the XML data can be retrieved behind the scenes.
EditWebPage | The URL of the user-facing web page showing the web query data. This URL is persisted in the case that sourceData="true" and url has been redirected to reference an XML file. Then the user-facing page can be shown in the UI, and the XML data can be retrieved behind the scenes.
HtmlFormat | How to handle formatting from the HTML source when bringing web query data into the worksheet. Relevant when sourceData is True.
Id (inherited from ExternalConnection) | Gets the id of the connection.
IsConsecutive | Flag indicating whether consecutive delimiters should be treated as just one delimiter.
IsDeleted (inherited from ExternalConnection) | Indicates whether the associated workbook connection has been deleted. true if the connection has been deleted; otherwise, false.
IsHtmlTables | Flag indicating whether web queries should only work on HTML tables.
IsNew (inherited from ExternalConnection) | True if the connection has not been refreshed for the first time; otherwise, false. This state can happen when the user saves the file before a query has finished returning.
IsParsePre | Flag indicating whether data contained within HTML PRE tags in the web page is parsed into columns when you import the page into a query table.
IsSameSettings | Flag indicating whether to parse all tables inside a PRE block with the same width settings as the first row.
IsTextDates | Flag indicating whether dates should be imported into cells in the worksheet as text rather than dates.
IsXl2000 | This flag exists for backward compatibility with older existing spreadsheet files, and is set to true if this web query was refreshed in a spreadsheet application newer than or equal to Microsoft Excel 2000. This is an optional attribute that can be ignored.
IsXl97 | This flag exists for backward compatibility with older existing spreadsheet files, and is set to true if this web query was created in Microsoft Excel 97. This is an optional attribute that can be ignored.
IsXml | true if the web query source is XML (versus HTML), otherwise false.
IsXmlSourceData | Flag indicating that XML source data should be imported instead of the HTML table itself.
KeepAlive (inherited from ExternalConnection) | True when the spreadsheet application should make efforts to keep the connection open. When false, the application should close the connection after retrieving the information.
Name (inherited from ExternalConnection) | Specifies the name of the connection. Each connection must have a unique name.
OdcFile (inherited from ExternalConnection) | Specifies the full path to external connection file from which this connection was created. If a connection fails during an attempt to refresh data, and reconnectionMethod=1, then the spreadsheet application will try again using information from the external connection file instead of the connection object embedded within the workbook.
OnlyUseConnectionFile (inherited from ExternalConnection) | Indicates whether the spreadsheet application should always and only use the connection information in the external connection file indicated by the odcFile attribute when the connection is refreshed. If false, then the spreadsheet application should follow the procedure indicated by the reconnectionMethod attribute
Parameters (inherited from ExternalConnection) | Gets ConnectionParameterCollection for an ODBC or web query.
Post | Returns or sets the string used with the post method of inputting data into a web server to return data from a web query.
PowerQueryFormula (inherited from ExternalConnection) | Gets the definition of power query formula.
ReconnectionMethod (inherited from ExternalConnection) | Obsolete. Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
ReconnectionMethodType (inherited from ExternalConnection) | Specifies what the spreadsheet application should do when a connection fails. The default value is ReConnectionMethodType.Required.
RefreshInternal (inherited from ExternalConnection) | Specifies the number of minutes between automatic refreshes of the connection.
RefreshOnLoad (inherited from ExternalConnection) | True if this connection should be refreshed when opening the file; otherwise, false.
SaveData (inherited from ExternalConnection) | True if the external data fetched over the connection to populate a table is to be saved with the workbook; otherwise, false.
SavePassword (inherited from ExternalConnection) | True if the password is to be saved as part of the connection string; otherwise, False.
SourceFile (inherited from ExternalConnection) | Used when the external data source is file-based. When a connection to such a data source fails, the spreadsheet application attempts to connect directly to this file. May be expressed in URI or system-specific file path notation.
SSOId (inherited from ExternalConnection) | Identifier for Single Sign On (SSO) used for authentication between an intermediate spreadsheetML server and the external data source.
Type (inherited from ExternalConnection) | Gets or Sets the external connection DataSource type.
Url | URL to use to refresh external data.

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


EditPage Property

Aspose.Cells for .NET

WebQueryConnection.EditPage Property

NOTE: This property is now obsolete.

Use WebQueryConnection.EditWebPage property instead.

The URL of the user-facing web page showing the web query data. This URL is persisted in the case that sourceData="true" and url has been redirected to reference an XML file. Then the user-facing page can be shown in the UI, and the XML data can be retrieved behind the scenes.

public string EditPage {get; set;}

Remarks

NOTE: This property is now obsolete. Instead, please use WebQueryConnection.EditWebPage property. This property will be removed 12 months later since October 2017. Aspose apologizes for any inconvenience you may have experienced.

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


EditWebPage Property

Aspose.Cells for .NET

WebQueryConnection.EditWebPage Property

The URL of the user-facing web page showing the web query data. This URL is persisted in the case that sourceData="true" and url has been redirected to reference an XML file. Then the user-facing page can be shown in the UI, and the XML data can be retrieved behind the scenes.

public string EditWebPage {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


HtmlFormat Property

Aspose.Cells for .NET

WebQueryConnection.HtmlFormat Property

How to handle formatting from the HTML source when bringing web query data into the worksheet. Relevant when sourceData is True.

public HtmlFormatHandlingType HtmlFormat {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsConsecutive Property

Aspose.Cells for .NET

WebQueryConnection.IsConsecutive Property

Flag indicating whether consecutive delimiters should be treated as just one delimiter.

public bool IsConsecutive {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsHtmlTables Property

Aspose.Cells for .NET

WebQueryConnection.IsHtmlTables Property

Flag indicating whether web queries should only work on HTML tables.

public bool IsHtmlTables {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsParsePre Property

Aspose.Cells for .NET

WebQueryConnection.IsParsePre Property

Flag indicating whether data contained within HTML PRE tags in the web page is parsed into columns when you import the page into a query table.

public bool IsParsePre {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsSameSettings Property

Aspose.Cells for .NET

WebQueryConnection.IsSameSettings Property

Flag indicating whether to parse all tables inside a PRE block with the same width settings as the first row.

public bool IsSameSettings {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsTextDates Property

Aspose.Cells for .NET

WebQueryConnection.IsTextDates Property

Flag indicating whether dates should be imported into cells in the worksheet as text rather than dates.

public bool IsTextDates {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsXl2000 Property

Aspose.Cells for .NET

WebQueryConnection.IsXl2000 Property

This flag exists for backward compatibility with older existing spreadsheet files, and is set to true if this web query was refreshed in a spreadsheet application newer than or equal to Microsoft Excel 2000. This is an optional attribute that can be ignored.

public bool IsXl2000 {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsXl97 Property

Aspose.Cells for .NET

WebQueryConnection.IsXl97 Property

This flag exists for backward compatibility with older existing spreadsheet files, and is set to true if this web query was created in Microsoft Excel 97. This is an optional attribute that can be ignored.

public bool IsXl97 {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsXml Property

Aspose.Cells for .NET

WebQueryConnection.IsXml Property

true if the web query source is XML (versus HTML), otherwise false.

public bool IsXml {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


IsXmlSourceData Property

Aspose.Cells for .NET

WebQueryConnection.IsXmlSourceData Property

Flag indicating that XML source data should be imported instead of the HTML table itself.

public bool IsXmlSourceData {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


Post Property

Aspose.Cells for .NET

WebQueryConnection.Post Property

Returns or sets the string used with the post method of inputting data into a web server to return data from a web query.

public string Post {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


Url Property

Aspose.Cells for .NET

WebQueryConnection.Url Property

URL to use to refresh external data.

public string Url {get; set;}

See Also

WebQueryConnection Class | Aspose.Cells.ExternalConnections Namespace


Aspose.Cells.GridDesktop

Aspose.Cells for .NET

Aspose.Cells.GridDesktop Namespace

Namespace hierarchy

Classes

Class | Description
Button | Represents a cell button control.
CellComboBoxEventArgs | Provides data for cell ComboBox events.
CellControl | Represents a cell control.
CellControlCollection | Encapsulates a collection of cell control.
CellControlEventArgs | Provides data for cell control events.
CellCopyComboBoxEventArgs | Provides data for cell copy ComboBox events.
CellEventArgs | Provides data for grid cell events.
CellFormatEventArgs | Provides data for grid cell format event.
CellKeyEventArgs | Provides data for grid cell key events.
CellLocation | Indicates the cell location.
CellRange | Encapsulates the object that represents a range of cells within a spreadsheet.
CellRangeEventArgs | Provides data for grid cellrange events.
CellRelative | Internal use only.
CellRelativeCollection | Internal use only.
CellValidationEventArgs | Provides data for grid cell validation events.
CheckBox | Represents a cell checkbox control.
ComboBox | Represents a cell combobox control.
CommentEventArgs | Provides data for comment events.
ContextMenuManager | Represents context menu item's available status.
CustomProperty | Represents identifier information.
CustomPropertyCollection | A collection of CustomProperty objects that represent additional information.
GridCell | Represents a cell object.
GridDesktop | Aspose GridDesktop class Represents a root object to create an GridDesktop control. To use this control, simply drag it from your toolbox to a form or usercontrol.
License |
RowColumnEventArgs | Provides data for row/column events.
RowFilterSettings | Summary description for RowFilter.
Shape | Represents a shape object.
SortRange | Indicates a range of a Worksheet and provide method to sort the range datas by row or column.
Style |
ThemeColor | Represents a theme color.
UndoManager | Encapsulates the object that manages the undo/redo operations.
Worksheet |
WorksheetCollection | Collects the objects that represent the individual rows in a worksheet.
WorksheetEventArgs | Provides data for worksheet events.

Interfaces

Interface | Description
ICustomColumnCaption | Interface for custom row caption.
ICustomRowCaption | Interface for custom row caption.
ICustomValidation | Interface of a gridcell's custom validation.

Delegates

Delegate | Description
CellComboBoxEventHandler | Represents the method that intend to handle cell ComboBox events.
CellControlEventHandler | Represents the method that intend to handle cell control events.
CellCopyComboBoxEventHandler | Represents the method that intend to handle cell copy events.
CellEventHandler | Represents the method that intend to handle cell events.
CellFormatEventHandler | Represents the method that intend to handle cell format events.
CellKeyEventHandler | Represents the method that intend to handle cell key events.
CellRangeEventHandler | Represents the method that intend to handle cellrange events.
CellValidationEventHandler | Represents the method that intend to handle cell validation events.
CommentEventHandler | Represents the method that intend to handle comment events.
WorkbookEventHandler | Represents the method that intend to handle workbook events.
WorksheetEventHandler | Represents the method that intend to handle worksheet events.

Enumerations

Enumeration | Description
BorderLineType | Specifies the border line type for a gridCell.
BorderType | Specifies the border type for a gridCell.
FileFormatType | Enumerates spreadsheet file format types
FormatConditionType | Conditional format rule type.
GridBackgroundType | Enumerates cell background pattern types.
GridMemorySetting | Aspose GridMemorySetting class Represents Memory Setting Preference For GridDesktop.
HorizontalAlignmentType | Specifies how a gridcell is horizontally aligned.
RowColumnType | Represents the row/column type of the row/column events.
SortOrder | Represents what order the data sort by.
SortOrientation | Represents sorting orientation
TextDirectionType |
ThemeColorType | Enumerates the theme color types.
VerticalAlignmentType | Specifies how a gridcell is vertically aligned.
WorkBookEvents | WorkBook Events category.
WorksheetEvents | Worksheet Events category.


BorderLineType Enumeration

Specifies the border line type for a gridCell.

public enum BorderLineType

Members

Member Name | Description | Value
None | No border. | 0
Thin | A solid line border. | 1
Medium | A solid line border.Line width is 2f. | 2
Dashed | A dashed line border. | 3
Dotted | A dotted line border. | 4
Thick | A solid line border.Line width is 3f. | 5
MediumDashed | A dashed line border.Line width is 2f. | 8
ThinDashDotted | A dashDotted line border. | 9
MediumDashDotted | A dashDotted line border.Line width is 2f. | 10
ThinDashDotDotted | A dashDotDotted line border. | 11
MediumDashDotDotted | A dashDotDotted line border.Line width is 2f. | 12

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


BorderType Enumeration

Specifies the border type for a gridCell.

public enum BorderType

Members

Member Name | Description | Value
Left | GridCell has Left border. | 0
Right | GridCell has Right border. | 1
Top | GridCell has Top border. | 2
Bottom | GridCell has Bottom border. | 3
DiagonalDown | GridCell has DiagonalDown border. | 4
DiagonalUp | GridCell has DiagonalUp border. | 5

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


Button Class

Represents a cell button control.

For a list of all members of this type, see Button Members.

System.Object
Aspose.Cells.GridDesktop.CellRelative
Aspose.Cells.GridDesktop.CellControl
Aspose.Cells.GridDesktop.Button

public class Button : CellControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Button Members | Aspose.Cells.GridDesktop Namespace


Button Members

Button overview

Public Instance Properties

AlwaysVisible | Gets or sets if the Button should always visible, only work for Cell Control Button.
Height | Gets or sets the height of the control.
Image | Gets or sets the background image.
Text (inherited from CellControl) | Gets or sets the text associated with this control.
Width | Gets or sets the width of the control.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Button Class | Aspose.Cells.GridDesktop Namespace


Button Properties

The properties of the Button class are listed below. For a complete list of Button class members, see the Button Members topic.

Public Instance Properties

AlwaysVisible | Gets or sets if the Button should always visible, only work for Cell Control Button.
Height | Gets or sets the height of the control.
Image | Gets or sets the background image.
Text (inherited from CellControl) | Gets or sets the text associated with this control.
Width | Gets or sets the width of the control.

See Also

Button Class | Aspose.Cells.GridDesktop Namespace


AlwaysVisible Property

Aspose.Cells for .NET

Button.AlwaysVisible Property

Gets or sets if the Button should always visible, only work for Cell Control Button.

public bool AlwaysVisible {get; set;}

See Also

Button Class | Aspose.Cells.GridDesktop Namespace


Height Property

Aspose.Cells for .NET

Button.Height Property

Gets or sets the height of the control.

public int Height {get; set;}

See Also

Button Class | Aspose.Cells.GridDesktop Namespace


Image Property

Aspose.Cells for .NET

Button.Image Property

Gets or sets the background image.

public Image Image {get; set;}

See Also

Button Class | Aspose.Cells.GridDesktop Namespace


Width Property

Aspose.Cells for .NET

Button.Width Property

Gets or sets the width of the control.

public int Width {get; set;}

See Also

Button Class | Aspose.Cells.GridDesktop Namespace


CellComboBoxEventArgs Class

Provides data for cell ComboBox events.

For a list of all members of this type, see CellComboBoxEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellControlEventArgs
Aspose.Cells.GridDesktop.CellComboBoxEventArgs

public class CellComboBoxEventArgs : CellControlEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellComboBoxEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellComboBoxEventArgs Members

CellComboBoxEventArgs overview

Public Instance Properties

Column (inherited from CellControlEventArgs) | Gets column index of worksheet.
Handled | Gets or sets the value indicating whether the event should be handled.
NewValue | Gets the new value to be set.
Row (inherited from CellControlEventArgs) | Gets row index of worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellComboBoxEventArgs Properties

The properties of the CellComboBoxEventArgs class are listed below. For a complete list of CellComboBoxEventArgs class members, see the CellComboBoxEventArgs Members topic.

Public Instance Properties

Column (inherited from CellControlEventArgs) | Gets column index of worksheet.
Handled | Gets or sets the value indicating whether the event should be handled.
NewValue | Gets the new value to be set.
Row (inherited from CellControlEventArgs) | Gets row index of worksheet.

See Also

CellComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


Handled Property

Aspose.Cells for .NET

CellComboBoxEventArgs.Handled Property

Gets or sets the value indicating whether the event should be handled.

public bool Handled {get; set;}

See Also

CellComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


NewValue Property

Aspose.Cells for .NET

CellComboBoxEventArgs.NewValue Property

Gets the new value to be set.

public object NewValue {get;}

See Also

CellComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellComboBoxEventHandler Delegate

Represents the method that intend to handle cell ComboBox events.

public delegate void CellComboBoxEventHandler(
object sender,
CellComboBoxEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellControl Class

Represents a cell control.

For a list of all members of this type, see CellControl Members.

System.Object
Aspose.Cells.GridDesktop.CellRelative
Aspose.Cells.GridDesktop.CellControl
Aspose.Cells.GridDesktop.Button
Aspose.Cells.GridDesktop.CheckBox
Aspose.Cells.GridDesktop.ComboBox

public abstract class CellControl : CellRelative

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellControl Members | Aspose.Cells.GridDesktop Namespace


CellControl Members

CellControl overview

Public Instance Properties

Text Gets or sets the text associated with this control.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellControl Class | Aspose.Cells.GridDesktop Namespace


CellControl Properties

The properties of the CellControl class are listed below. For a complete list of CellControl class members, see the CellControl Members topic.

Public Instance Properties

Text Gets or sets the text associated with this control.

See Also

CellControl Class | Aspose.Cells.GridDesktop Namespace


Text Property

Aspose.Cells for .NET

CellControl.Text Property

Gets or sets the text associated with this control.

public string Text {get; set;}

See Also

CellControl Class | Aspose.Cells.GridDesktop Namespace


CellControlCollection Class

Encapsulates a collection of cell control.

For a list of all members of this type, see CellControlCollection Members.

System.Object
Aspose.Cells.GridDesktop.CellRelativeCollection
Aspose.Cells.GridDesktop.CellControlCollection

public class CellControlCollection : CellRelativeCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellControlCollection Members | Aspose.Cells.GridDesktop Namespace


CellControlCollection Members

CellControlCollection overview

Public Instance Properties

Item Overloaded. Gets the cell control at specified row and column index.

Public Instance Methods

AddButton | Overloaded. Adds a button to a specified cell at row column index.
AddCheckBox | Overloaded. Adds a checkbox to a specified cell at row column index.
AddComboBox | Overloaded. Adds a combobox to a specified cell at row column index.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove (inherited from CellRelativeCollection) | Overloaded. Removes the item at the specified row column index of the cell.
ToString (inherited from Object) |

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


CellControlCollection Properties

The properties of the CellControlCollection class are listed below. For a complete list of CellControlCollection class members, see the CellControlCollection Members topic.

Public Instance Properties

Item Overloaded. Gets the cell control at specified row and column index.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


Item Property

Aspose.Cells for .NET

CellControlCollection.Item Property

Gets the cell control at specified row and column index.

Overload List

Gets the cell control at specified row and column index.

public CellControl this[int, int] {get;}

Gets the cell control by specified cell name.

public CellControl this[string] {get;}

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


Item Property (Int32, Int32)

Aspose.Cells for .NET

CellControlCollection.Item Property (Int32, Int32)

Gets the cell control at specified row and column index.

public CellControl this[
int row,
int col
] {get;}

Parameters

row
row index.
col
column index.

Remarks

If there is not a CellControl object at specified row column index, this will check the column CellControl object.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

CellControlCollection.Item Property (String)

Gets the cell control by specified cell name.

public CellControl this[
string cellName
] {get;}

Parameters

cellName
cell name(in excel name format, like 'A1', 'F22')

Remarks

If there is not a CellControl object at specified row column index, this will check the column CellControl object.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.Item Overload List


CellControlCollection Methods

The methods of the CellControlCollection class are listed below. For a complete list of CellControlCollection class members, see the CellControlCollection Members topic.

Public Instance Methods

AddButton | Overloaded. Adds a button to a specified cell at row column index.
AddCheckBox | Overloaded. Adds a checkbox to a specified cell at row column index.
AddComboBox | Overloaded. Adds a combobox to a specified cell at row column index.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove (inherited from CellRelativeCollection) | Overloaded. Removes the item at the specified row column index of the cell.
ToString (inherited from Object) |

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


AddButton Method

Aspose.Cells for .NET

CellControlCollection.AddButton Method

Adds a button to a specified cell at row column index.

Overload List

Adds a button to a specified cell at row column index.

public Button AddButton(int,int,int,int,string);

Adds a button to a specified cell at row column index.

public Button AddButton(int,int,int,int,string,bool);

Adds a button to a specified cell by cell name.

public Button AddButton(string,int,int,string);

Adds a button to a specified cell by cell name.

public Button AddButton(string,int,int,string,bool);

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


CellControlCollection.AddButton Method (Int32, Int32, Int32, Int32, String)

Adds a button to a specified cell at row column index.

public Button AddButton(
int row,
int col,
int width,
int height,
string text
);

Parameters

row
Row index of cell.
col
Column index of cell.
width
Width of button.
height
Height of button.
text
Button text.

Return Value

The added button.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddButton Overload List


CellControlCollection.AddButton Method (Int32, Int32, Int32, Int32, String, Boolean)

Adds a button to a specified cell at row column index.

public Button AddButton(
int row,
int col,
int width,
int height,
string text,
bool alwaysVisible
);

Parameters

row
Row index of cell.
col
Column index of cell.
width
Width of button.
height
Height of button.
text
Button text.
alwaysVisible
If the Button should always visible, only work for Cell Control Button.

Return Value

The added button.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddButton Overload List


CellControlCollection.AddButton Method (String, Int32, Int32, String)

Adds a button to a specified cell by cell name.

public Button AddButton(
string cellName,
int width,
int height,
string text
);

Parameters

cellName
Name of grid cell.
width
Width of button.
height
Height of button.
text
Button text.

Return Value

The added button.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddButton Overload List


CellControlCollection.AddButton Method (String, Int32, Int32, String, Boolean)

Adds a button to a specified cell by cell name.

public Button AddButton(
string cellName,
int width,
int height,
string text,
bool alwaysVisible
);

Parameters

cellName
Name of grid cell.
width
Width of button.
height
Height of button.
text
Button text.
alwaysVisible
If the Button should always visible, only work for Cell Control Button.

Return Value

The added button.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddButton Overload List


AddCheckBox Method

Aspose.Cells for .NET

CellControlCollection.AddCheckBox Method

Adds a checkbox to a specified cell at row column index.

Overload List

Adds a checkbox to a specified cell at row column index.

public CheckBox AddCheckBox(int,int,bool);

Adds a checkbox to a specified cell by cell name.

public CheckBox AddCheckBox(string,bool);

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


CellControlCollection.AddCheckBox Method (Int32, Int32, Boolean)

Adds a checkbox to a specified cell at row column index.

public CheckBox AddCheckBox(
int row,
int col,
bool check
);

Parameters

row
Row index of cell.
col
Column index of cell.
check
Checkbox checked property state.

Return Value

The added checkbox.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddCheckBox Overload List


CellControlCollection.AddCheckBox Method (String, Boolean)

Adds a checkbox to a specified cell by cell name.

public CheckBox AddCheckBox(
string cellName,
bool check
);

Parameters

cellName
Name of grid cell.
check
Checkbox checked property state.

Return Value

The added checkbox.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddCheckBox Overload List


AddComboBox Method

Aspose.Cells for .NET

CellControlCollection.AddComboBox Method

Adds a combobox to a specified cell at row column index.

Overload List

Adds a combobox to a specified cell at row column index.

public ComboBox AddComboBox(int,int,ICollection);

Adds a combobox to a specified cell at row column index.

public ComboBox AddComboBox(int,int,ICollection,ICollection);

Adds a combobox to a specified cell by cell name.

public ComboBox AddComboBox(string,ICollection);

Adds a combobox to a specified cell by cell name.

public ComboBox AddComboBox(string,ICollection,ICollection);

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace


CellControlCollection.AddComboBox Method (Int32, Int32, ICollection)

Adds a combobox to a specified cell at row column index.

public ComboBox AddComboBox(
int row,
int col,
ICollection items
);

Parameters

row
Row index of cell.
col
Column index of cell.
items
The collection of the items contained in ComboBox.

Return Value

The added combobox.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddComboBox Overload List


CellControlCollection.AddComboBox Method (Int32, Int32, ICollection, ICollection)

Adds a combobox to a specified cell at row column index.

public ComboBox AddComboBox(
int row,
int col,
ICollection items,
ICollection values
);

Parameters

row
Row index of cell.
col
Column index of cell.
items
The collection of the items contained in ComboBox.
values
The collection of the values contained in ComboBox.

Return Value

The added combobox.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddComboBox Overload List


CellControlCollection.AddComboBox Method (String, ICollection)

Adds a combobox to a specified cell by cell name.

public ComboBox AddComboBox(
string cellName,
ICollection items
);

Parameters

cellName
Name of grid cell.
items
The collection of the items contained in ComboBox.

Return Value

The added combobox.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddComboBox Overload List


CellControlCollection.AddComboBox Method (String, ICollection, ICollection)

Adds a combobox to a specified cell by cell name.

public ComboBox AddComboBox(
string cellName,
ICollection items,
ICollection values
);

Parameters

cellName
Name of grid cell.
items
The collection of the items contained in ComboBox.
values
The collection of the values contained in ComboBox.

Return Value

The added combobox.

See Also

CellControlCollection Class | Aspose.Cells.GridDesktop Namespace | CellControlCollection.AddComboBox Overload List


CellControlEventArgs Class

Provides data for cell control events.

For a list of all members of this type, see CellControlEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellControlEventArgs
Aspose.Cells.GridDesktop.CellComboBoxEventArgs

public class CellControlEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellControlEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellControlEventArgs Members

CellControlEventArgs overview

Public Instance Properties

Column | Gets column index of worksheet.
Row | Gets row index of worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellControlEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellControlEventArgs Properties

The properties of the CellControlEventArgs class are listed below. For a complete list of CellControlEventArgs class members, see the CellControlEventArgs Members topic.

Public Instance Properties

Column | Gets column index of worksheet.
Row | Gets row index of worksheet.

See Also

CellControlEventArgs Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

CellControlEventArgs.Column Property

Gets column index of worksheet.

public int Column {get;}

See Also

CellControlEventArgs Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

CellControlEventArgs.Row Property

Gets row index of worksheet.

public int Row {get;}

See Also

CellControlEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellControlEventHandler Delegate

Represents the method that intend to handle cell control events.

public delegate void CellControlEventHandler(
object sender,
CellControlEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellCopyComboBoxEventArgs Class

Provides data for cell copy ComboBox events.

For a list of all members of this type, see CellCopyComboBoxEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellCopyComboBoxEventArgs

public class CellCopyComboBoxEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellCopyComboBoxEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellCopyComboBoxEventArgs Members

CellCopyComboBoxEventArgs overview

Public Instance Properties

Column | Gets column index of worksheet.
ComboBoxItems | Gets an object representing the collection of the items contained in this ComboBox.
comboBoxValues | Gets an object representing the collection of the values contained in this ComboBox.
Handled | Gets or sets the value indicating whether the event should be handled.
Row | Gets row index of worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellCopyComboBoxEventArgs Properties

The properties of the CellCopyComboBoxEventArgs class are listed below. For a complete list of CellCopyComboBoxEventArgs class members, see the CellCopyComboBoxEventArgs Members topic.

Public Instance Properties

Column | Gets column index of worksheet.
ComboBoxItems | Gets an object representing the collection of the items contained in this ComboBox.
comboBoxValues | Gets an object representing the collection of the values contained in this ComboBox.
Handled | Gets or sets the value indicating whether the event should be handled.
Row | Gets row index of worksheet.

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

CellCopyComboBoxEventArgs.Column Property

Gets column index of worksheet.

public int Column {get;}

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


ComboBoxItems Property

Aspose.Cells for .NET

CellCopyComboBoxEventArgs.ComboBoxItems Property

Gets an object representing the collection of the items contained in this ComboBox.

public ArrayList ComboBoxItems {get;}

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


comboBoxValues Property

Aspose.Cells for .NET

CellCopyComboBoxEventArgs.comboBoxValues Property

Gets an object representing the collection of the values contained in this ComboBox.

public ArrayList comboBoxValues {get;}

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


Handled Property

Aspose.Cells for .NET

CellCopyComboBoxEventArgs.Handled Property

Gets or sets the value indicating whether the event should be handled.

public bool Handled {get; set;}

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

CellCopyComboBoxEventArgs.Row Property

Gets row index of worksheet.

public int Row {get;}

See Also

CellCopyComboBoxEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellCopyComboBoxEventHandler Delegate

Represents the method that intend to handle cell copy events.

public delegate void CellCopyComboBoxEventHandler(
object sender,
CellCopyComboBoxEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellEventArgs Class

Provides data for grid cell events.

For a list of all members of this type, see CellEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellEventArgs

public class CellEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellEventArgs Members

CellEventArgs overview

Public Instance Properties

Argument | The argument of the event.
Cell | Represents a grid cell.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellEventArgs Properties

The properties of the CellEventArgs class are listed below. For a complete list of CellEventArgs class members, see the CellEventArgs Members topic.

Public Instance Properties

Argument | The argument of the event.
Cell | Represents a grid cell.

See Also

CellEventArgs Class | Aspose.Cells.GridDesktop Namespace


Argument Property

Aspose.Cells for .NET

CellEventArgs.Argument Property

The argument of the event.

public object Argument {get;}

See Also

CellEventArgs Class | Aspose.Cells.GridDesktop Namespace


Cell Property

Aspose.Cells for .NET

CellEventArgs.Cell Property

Represents a grid cell.

public GridCell Cell {get;}

See Also

CellEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellEventHandler Delegate

Represents the method that intend to handle cell events.

public delegate void CellEventHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellFormatEventArgs Class

Provides data for grid cell format event.

For a list of all members of this type, see CellFormatEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellFormatEventArgs

public class CellFormatEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellFormatEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellFormatEventArgs Members

CellFormatEventArgs overview

Public Instance Properties

Font | Gets the new font.
FontColor | Gets the new font color.
Sources | Gets the format sources, list of CellRange.
Style | Gets the new style.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellFormatEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellFormatEventArgs Properties

The properties of the CellFormatEventArgs class are listed below. For a complete list of CellFormatEventArgs class members, see the CellFormatEventArgs Members topic.

Public Instance Properties

Font | Gets the new font.
FontColor | Gets the new font color.
Sources | Gets the format sources, list of CellRange.
Style | Gets the new style.

See Also

CellFormatEventArgs Class | Aspose.Cells.GridDesktop Namespace


Font Property

Aspose.Cells for .NET

CellFormatEventArgs.Font Property

Gets the new font.

public ArrayList Font {get;}

See Also

CellFormatEventArgs Class | Aspose.Cells.GridDesktop Namespace


FontColor Property

Aspose.Cells for .NET

CellFormatEventArgs.FontColor Property

Gets the new font color.

public ArrayList FontColor {get;}

See Also

CellFormatEventArgs Class | Aspose.Cells.GridDesktop Namespace


Sources Property

Aspose.Cells for .NET

CellFormatEventArgs.Sources Property

Gets the format sources, list of CellRange.

public ArrayList Sources {get;}

See Also

CellFormatEventArgs Class | Aspose.Cells.GridDesktop Namespace


Style Property

Aspose.Cells for .NET

CellFormatEventArgs.Style Property

Gets the new style.

public ArrayList Style {get;}

See Also

CellFormatEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellFormatEventHandler Delegate

Represents the method that intend to handle cell format events.

public delegate void CellFormatEventHandler(
object sender,
CellFormatEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellKeyEventArgs Class

Provides data for grid cell key events.

For a list of all members of this type, see CellKeyEventArgs Members.

System.Object
System.EventArgs
System.Windows.Forms.KeyEventArgs
Aspose.Cells.GridDesktop.CellKeyEventArgs

public class CellKeyEventArgs : KeyEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellKeyEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellKeyEventArgs Members

CellKeyEventArgs overview

Public Instance Properties

Alt (inherited from KeyEventArgs) |
Column | Gets column index of worksheet.
Control (inherited from KeyEventArgs) |
Handled (inherited from KeyEventArgs) |
KeyCode (inherited from KeyEventArgs) |
KeyData (inherited from KeyEventArgs) |
KeyValue (inherited from KeyEventArgs) |
Modifiers (inherited from KeyEventArgs) |
Row | Gets row index of worksheet.
Shift (inherited from KeyEventArgs) |
SuppressKeyPress (inherited from KeyEventArgs) |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellKeyEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellKeyEventArgs Properties

The properties of the CellKeyEventArgs class are listed below. For a complete list of CellKeyEventArgs class members, see the CellKeyEventArgs Members topic.

Public Instance Properties

Alt (inherited from KeyEventArgs) |
Column | Gets column index of worksheet.
Control (inherited from KeyEventArgs) |
Handled (inherited from KeyEventArgs) |
KeyCode (inherited from KeyEventArgs) |
KeyData (inherited from KeyEventArgs) |
KeyValue (inherited from KeyEventArgs) |
Modifiers (inherited from KeyEventArgs) |
Row | Gets row index of worksheet.
Shift (inherited from KeyEventArgs) |
SuppressKeyPress (inherited from KeyEventArgs) |

See Also

CellKeyEventArgs Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

CellKeyEventArgs.Column Property

Gets column index of worksheet.

public int Column {get;}

See Also

CellKeyEventArgs Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

CellKeyEventArgs.Row Property

Gets row index of worksheet.

public int Row {get;}

See Also

CellKeyEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellKeyEventHandler Delegate

Represents the method that intend to handle cell key events.

public delegate void CellKeyEventHandler(
object sender,
CellKeyEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellLocation Class

Indicates the cell location.

For a list of all members of this type, see CellLocation Members.

System.Object
Aspose.Cells.GridDesktop.CellLocation

public class CellLocation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellLocation Members | Aspose.Cells.GridDesktop Namespace


CellLocation Members

CellLocation overview

Public Static Operators

Equality Operator | Overload operator ==
Inequality Operator | Overload opertor !=

Public Instance Constructors

CellLocation Overloaded. Initializes a new instance of the CellLocation class.

Public Instance Properties

Column | Gets or sets the column of the cell location.
Row | Gets or sets the row of the cell location.

Public Instance Methods

Equals | Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) |
ToString | Override the ToString() of the object.

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation Constructor

Overload List

public CellLocation();

public CellLocation(int,int);

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation Constructor ()

public CellLocation();

Example

See Also
CellLocation Class | Aspose.Cells.GridDesktop Namespace | CellLocation Constructor Overload List


CellLocation Constructor (Int32, Int32)

public CellLocation(
int cRow,
int cCol
);

Example

See Also
CellLocation Class | Aspose.Cells.GridDesktop Namespace | CellLocation Constructor Overload List


CellLocation Properties

The properties of the CellLocation class are listed below. For a complete list of CellLocation class members, see the CellLocation Members topic.

Public Instance Properties

Column | Gets or sets the column of the cell location.
Row | Gets or sets the row of the cell location.

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

CellLocation.Column Property

Gets or sets the column of the cell location.

public int Column {get; set;}

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

CellLocation.Row Property

Gets or sets the row of the cell location.

public int Row {get; set;}

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation Methods

The methods of the CellLocation class are listed below. For a complete list of CellLocation class members, see the CellLocation Members topic.

Public Instance Methods

Equals | Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) |
ToString | Override the ToString() of the object.

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation.Equals Method

Determines whether the specified Object is equal to the current Object.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

Return Value

A hash code for the current Object.

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation.ToString Method

Override the ToString() of the object.

public override string ToString();

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation Operators

The operators of the CellLocation class are listed below. For a complete list of CellLocation class members, see the CellLocation Members topic.

Public Static Operators

Equality Operator | Overload operator ==
Inequality Operator | Overload opertor !=

See Also

CellLocation Class | CellLocation Members | Aspose.Cells.GridDesktop Namespace


CellLocation Equality Operator

Overload operator ==

public static bool operator ==(
CellLocation a,
CellLocation b
);

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellLocation Inequality Operator

Overload opertor !=

public static bool operator !=(
CellLocation a,
CellLocation b
);

See Also

CellLocation Class | Aspose.Cells.GridDesktop Namespace


CellRange Class

Encapsulates the object that represents a range of cells within a spreadsheet.

For a list of all members of this type, see CellRange Members.

System.Object
Aspose.Cells.GridDesktop.CellRange

public class CellRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellRange Members | Aspose.Cells.GridDesktop Namespace


CellRange Members

CellRange overview

Public Instance Constructors

CellRange Overloaded. Initializes a new instance of the CellRange class.

Public Instance Properties

Address | Gets the address of CellRange object.
Columns |
EndColumn | Gets or sets the index of the end column of the range.
EndRow | Gets or sets the index of the end row of the range.
Rows |
StartColumn | Gets or sets the index of the start column of the range.
StartRow | Gets or sets the index of the start row of the range.
Worksheet | Gets worksheet object.

Public Instance Methods

Copy | Copies from another CellRange object.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getName | get the name defined for the cellrange.if no name defined for this cellrange ,just return null
GetType (inherited from Object) |
Inside | check whether current CellRange is inside in the target CellRange
ToString | Returns a String that represents the current CellRange.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange Constructor

Default Constructor.

Overload List

Default Constructor.

public CellRange();

CellRange Constructor.

public CellRange(int,int,int,int);

CellRange Constructor.

public CellRange(string,string);

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange Constructor ()

Default Constructor.

public CellRange();

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace | CellRange Constructor Overload List


CellRange Constructor (Int32, Int32, Int32, Int32)

CellRange Constructor.

public CellRange(
int cStartRow,
int cStartCol,
int cEndRow,
int cEndCol
);

Parameters

cStartRow
Start Row index.
cStartCol
Start Column index.
cEndRow
End Row index.
cEndCol
End Column index.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace | CellRange Constructor Overload List


CellRange Constructor (String, String)

CellRange Constructor.

public CellRange(
string startCellName,
string endCellName
);

Parameters

startCellName
Start cell name.
endCellName
End cell name.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace | CellRange Constructor Overload List


CellRange Properties

The properties of the CellRange class are listed below. For a complete list of CellRange class members, see the CellRange Members topic.

Public Instance Properties

Address | Gets the address of CellRange object.
Columns |
EndColumn | Gets or sets the index of the end column of the range.
EndRow | Gets or sets the index of the end row of the range.
Rows |
StartColumn | Gets or sets the index of the start column of the range.
StartRow | Gets or sets the index of the start row of the range.
Worksheet | Gets worksheet object.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


Address Property

Aspose.Cells for .NET

CellRange.Address Property

Gets the address of CellRange object.

public string Address {get;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


Columns Property

Aspose.Cells for .NET

CellRange.Columns Property

public int Columns {get;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


EndColumn Property

Aspose.Cells for .NET

CellRange.EndColumn Property

Gets or sets the index of the end column of the range.

public int EndColumn {get; set;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


EndRow Property

Aspose.Cells for .NET

CellRange.EndRow Property

Gets or sets the index of the end row of the range.

public int EndRow {get; set;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


Rows Property

Aspose.Cells for .NET

CellRange.Rows Property

public int Rows {get;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


StartColumn Property

Aspose.Cells for .NET

CellRange.StartColumn Property

Gets or sets the index of the start column of the range.

public int StartColumn {get; set;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


StartRow Property

Aspose.Cells for .NET

CellRange.StartRow Property

Gets or sets the index of the start row of the range.

public int StartRow {get; set;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


Worksheet Property

Aspose.Cells for .NET

CellRange.Worksheet Property

Gets worksheet object.

public Worksheet Worksheet {get;}

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange Methods

The methods of the CellRange class are listed below. For a complete list of CellRange class members, see the CellRange Members topic.

Public Instance Methods

Copy | Copies from another CellRange object.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getName | get the name defined for the cellrange.if no name defined for this cellrange ,just return null
GetType (inherited from Object) |
Inside | check whether current CellRange is inside in the target CellRange
ToString | Returns a String that represents the current CellRange.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange.Copy Method

Copies from another CellRange object.

public void Copy(
CellRange cellRange
);

Parameters

cellRange
The CellRange object to copy from.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange.getName Method

get the name defined for the cellrange.if no name defined for this cellrange ,just return null

public GridName getName();

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange.Inside Method

check whether current CellRange is inside in the target CellRange

public bool Inside(
CellRange r
);

Parameters

r
target CellRange.

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRange.ToString Method

Returns a String that represents the current CellRange.

public override string ToString();

See Also

CellRange Class | Aspose.Cells.GridDesktop Namespace


CellRangeEventArgs Class

Provides data for grid cellrange events.

For a list of all members of this type, see CellRangeEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellRangeEventArgs

public class CellRangeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellRangeEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellRangeEventArgs Members

CellRangeEventArgs overview

Public Instance Properties

CellRange Represents a cellrange object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellRangeEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellRangeEventArgs Properties

The properties of the CellRangeEventArgs class are listed below. For a complete list of CellRangeEventArgs class members, see the CellRangeEventArgs Members topic.

Public Instance Properties

CellRange Represents a cellrange object.

See Also

CellRangeEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellRange Property

Aspose.Cells for .NET

CellRangeEventArgs.CellRange Property

Represents a cellrange object.

public CellRange CellRange {get;}

See Also

CellRangeEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellRangeEventHandler Delegate

Represents the method that intend to handle cellrange events.

public delegate void CellRangeEventHandler(
object sender,
CellRangeEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CellRelative Class

Internal use only.

For a list of all members of this type, see CellRelative Members.

System.Object
Aspose.Cells.GridDesktop.CellRelative
Aspose.Cells.GridDesktop.CellControl

public class CellRelative

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellRelative Members | Aspose.Cells.GridDesktop Namespace


CellRelative Members

CellRelative overview

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellRelative Class | Aspose.Cells.GridDesktop Namespace


CellRelativeCollection Class

Internal use only.

For a list of all members of this type, see CellRelativeCollection Members.

System.Object
Aspose.Cells.GridDesktop.CellRelativeCollection
Aspose.Cells.GridDesktop.CellControlCollection

public class CellRelativeCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellRelativeCollection Members | Aspose.Cells.GridDesktop Namespace


CellRelativeCollection Members

CellRelativeCollection overview

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Overloaded. Removes the item at the specified row column index of the cell.
ToString (inherited from Object) |

See Also

CellRelativeCollection Class | Aspose.Cells.GridDesktop Namespace


CellRelativeCollection Methods

The methods of the CellRelativeCollection class are listed below. For a complete list of CellRelativeCollection class members, see the CellRelativeCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Overloaded. Removes the item at the specified row column index of the cell.
ToString (inherited from Object) |

See Also

CellRelativeCollection Class | Aspose.Cells.GridDesktop Namespace


Remove Method

Aspose.Cells for .NET

CellRelativeCollection.Remove Method

Removes the item at the specified row column index of the cell.

Overload List

Removes the item at the specified row column index of the cell.

public virtual void Remove(int,int);

Removes the item by cell name.

public void Remove(string);

See Also

CellRelativeCollection Class | Aspose.Cells.GridDesktop Namespace


CellRelativeCollection.Remove Method (Int32, Int32)

Removes the item at the specified row column index of the cell.

public virtual void Remove(
int row,
int col
);

Parameters

row
Row index of cell.
col
Column index of cell.

See Also

CellRelativeCollection Class | Aspose.Cells.GridDesktop Namespace | CellRelativeCollection.Remove Overload List


CellRelativeCollection.Remove Method (String)

Removes the item by cell name.

public void Remove(
string cellName
);

Parameters

cellName
cell name(in excel name format, like 'A1', 'F22')

See Also

CellRelativeCollection Class | Aspose.Cells.GridDesktop Namespace | CellRelativeCollection.Remove Overload List


CellValidationEventArgs Class

Provides data for grid cell validation events.

For a list of all members of this type, see CellValidationEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CellValidationEventArgs

public class CellValidationEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CellValidationEventArgs Members | Aspose.Cells.GridDesktop Namespace


CellValidationEventArgs Members

CellValidationEventArgs overview

Public Instance Properties

Cell | Represents a grid cell.
Handled | Gets or sets the value indicating whether the event should be handled.
NewValue | Gets the new value set to cell.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellValidationEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellValidationEventArgs Properties

The properties of the CellValidationEventArgs class are listed below. For a complete list of CellValidationEventArgs class members, see the CellValidationEventArgs Members topic.

Public Instance Properties

Cell | Represents a grid cell.
Handled | Gets or sets the value indicating whether the event should be handled.
NewValue | Gets the new value set to cell.

See Also

CellValidationEventArgs Class | Aspose.Cells.GridDesktop Namespace


Cell Property

Aspose.Cells for .NET

CellValidationEventArgs.Cell Property

Represents a grid cell.

public GridCell Cell {get;}

See Also

CellValidationEventArgs Class | Aspose.Cells.GridDesktop Namespace


Handled Property

Aspose.Cells for .NET

CellValidationEventArgs.Handled Property

Gets or sets the value indicating whether the event should be handled.

public bool Handled {get; set;}

See Also

CellValidationEventArgs Class | Aspose.Cells.GridDesktop Namespace


NewValue Property

Aspose.Cells for .NET

CellValidationEventArgs.NewValue Property

Gets the new value set to cell.

public object NewValue {get;}

See Also

CellValidationEventArgs Class | Aspose.Cells.GridDesktop Namespace


CellValidationEventHandler Delegate

Represents the method that intend to handle cell validation events.

public delegate void CellValidationEventHandler(
object sender,
CellValidationEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


CheckBox Class

Represents a cell checkbox control.

For a list of all members of this type, see CheckBox Members.

System.Object
Aspose.Cells.GridDesktop.CellRelative
Aspose.Cells.GridDesktop.CellControl
Aspose.Cells.GridDesktop.CheckBox

public class CheckBox : CellControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CheckBox Members | Aspose.Cells.GridDesktop Namespace


CheckBox Members

CheckBox overview

Public Instance Properties

Checked | Gets or set a value indicating whether the check box is in the checked state.
Text (inherited from CellControl) | Gets or sets the text associated with this control.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CheckBox Class | Aspose.Cells.GridDesktop Namespace


CheckBox Properties

The properties of the CheckBox class are listed below. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Instance Properties

Checked | Gets or set a value indicating whether the check box is in the checked state.
Text (inherited from CellControl) | Gets or sets the text associated with this control.

See Also

CheckBox Class | Aspose.Cells.GridDesktop Namespace


Checked Property

Aspose.Cells for .NET

CheckBox.Checked Property

Gets or set a value indicating whether the check box is in the checked state.

public bool Checked {get; set;}

See Also

CheckBox Class | Aspose.Cells.GridDesktop Namespace


ComboBox Class

Represents a cell combobox control.

For a list of all members of this type, see ComboBox Members.

System.Object
Aspose.Cells.GridDesktop.CellRelative
Aspose.Cells.GridDesktop.CellControl
Aspose.Cells.GridDesktop.ComboBox

public class ComboBox : CellControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

ComboBox Members | Aspose.Cells.GridDesktop Namespace


ComboBox Members

ComboBox overview

Public Instance Properties

Height | Gets or sets the height of the list control.
IsInputable | Indicates if the user can input text to the combobox. The inputted text will be saved as the cell's value. The default value is "false".
Items | Gets an object representing the collection of the items contained in this ComboBox.
SelectedIndex | Gets or sets the index specifying the currently selected item. Setting the index will call GridDesktop.RunAllFormulas method automatic if GridDesktop.RecalculateFormulas property is true.
Text (inherited from CellControl) | Gets or sets the text associated with this control.
Values | Gets an object representing the collection of the values contained in this ComboBox.
Width | Gets or sets the width of the list control.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetSelectedIndex | Sets the Selected index of the ComboBox. This will not calculate formula. To calculate formula,need to call GridDesktop.RunAllFormulas manually. It will not auto calculate formulas in any case even GridDesktop.RecalculateFormulas is true.
ToString (inherited from Object) |

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


ComboBox Properties

The properties of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Properties

Height | Gets or sets the height of the list control.
IsInputable | Indicates if the user can input text to the combobox. The inputted text will be saved as the cell's value. The default value is "false".
Items | Gets an object representing the collection of the items contained in this ComboBox.
SelectedIndex | Gets or sets the index specifying the currently selected item. Setting the index will call GridDesktop.RunAllFormulas method automatic if GridDesktop.RecalculateFormulas property is true.
Text (inherited from CellControl) | Gets or sets the text associated with this control.
Values | Gets an object representing the collection of the values contained in this ComboBox.
Width | Gets or sets the width of the list control.

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


Height Property

Aspose.Cells for .NET

ComboBox.Height Property

Gets or sets the height of the list control.

public int Height {get; set;}

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


IsInputable Property

Aspose.Cells for .NET

ComboBox.IsInputable Property

Indicates if the user can input text to the combobox. The inputted text will be saved as the cell's value. The default value is "false".

public bool IsInputable {get; set;}

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


Items Property

Aspose.Cells for .NET

ComboBox.Items Property

Gets an object representing the collection of the items contained in this ComboBox.

public ArrayList Items {get;}

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


SelectedIndex Property

Aspose.Cells for .NET

ComboBox.SelectedIndex Property

Gets or sets the index specifying the currently selected item. Setting the index will call GridDesktop.RunAllFormulas method automatic if GridDesktop.RecalculateFormulas property is true.

public int SelectedIndex {get; set;}

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


Values Property

Aspose.Cells for .NET

ComboBox.Values Property

Gets an object representing the collection of the values contained in this ComboBox.

public ArrayList Values {get;}

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


Width Property

Aspose.Cells for .NET

ComboBox.Width Property

Gets or sets the width of the list control.

public int Width {get; set;}

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


ComboBox Methods

The methods of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetSelectedIndex | Sets the Selected index of the ComboBox. This will not calculate formula. To calculate formula,need to call GridDesktop.RunAllFormulas manually. It will not auto calculate formulas in any case even GridDesktop.RecalculateFormulas is true.
ToString (inherited from Object) |

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


ComboBox.SetSelectedIndex Method

Sets the Selected index of the ComboBox. This will not calculate formula. To calculate formula,need to call GridDesktop.RunAllFormulas manually. It will not auto calculate formulas in any case even GridDesktop.RecalculateFormulas is true.

public void SetSelectedIndex(
int selIdx
);

See Also

ComboBox Class | Aspose.Cells.GridDesktop Namespace


CommentEventArgs Class

Provides data for comment events.

For a list of all members of this type, see CommentEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.CommentEventArgs

public class CommentEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CommentEventArgs Members | Aspose.Cells.GridDesktop Namespace


CommentEventArgs Members

CommentEventArgs overview

Public Instance Properties

Column | Gets column index.
NewText | Gets new text data of comment
OldText | Gets old text data of comment
Row | Gets row index.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CommentEventArgs Class | Aspose.Cells.GridDesktop Namespace


CommentEventArgs Properties

The properties of the CommentEventArgs class are listed below. For a complete list of CommentEventArgs class members, see the CommentEventArgs Members topic.

Public Instance Properties

Column | Gets column index.
NewText | Gets new text data of comment
OldText | Gets old text data of comment
Row | Gets row index.

See Also

CommentEventArgs Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

CommentEventArgs.Column Property

Gets column index.

public int Column {get;}

See Also

CommentEventArgs Class | Aspose.Cells.GridDesktop Namespace


NewText Property

Aspose.Cells for .NET

CommentEventArgs.NewText Property

Gets new text data of comment

public string NewText {get;}

See Also

CommentEventArgs Class | Aspose.Cells.GridDesktop Namespace


OldText Property

Aspose.Cells for .NET

CommentEventArgs.OldText Property

Gets old text data of comment

public string OldText {get;}

See Also

CommentEventArgs Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

CommentEventArgs.Row Property

Gets row index.

public int Row {get;}

See Also

CommentEventArgs Class | Aspose.Cells.GridDesktop Namespace


CommentEventHandler Delegate

Represents the method that intend to handle comment events.

public delegate void CommentEventHandler(
object sender,
CommentEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


ContextMenuManager Class

Represents context menu item's available status.

For a list of all members of this type, see ContextMenuManager Members.

System.Object
Aspose.Cells.GridDesktop.ContextMenuManager

public class ContextMenuManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

ContextMenuManager Members | Aspose.Cells.GridDesktop Namespace


ContextMenuManager Members

ContextMenuManager overview

Public Instance Properties

ContextMenu | Gets the shortcut menu associated with the control.
MenuItemAvailable_AddRow | Gets or sets a value indicating whether the context menu item "AddRow" is available.
MenuItemAvailable_All | Sets a value indicating whether all the context menu items are available.
MenuItemAvailable_ClearContents | Gets or sets a value indicating whether the context menu item "ClearContents" is available.
MenuItemAvailable_Copy | Gets or sets a value indicating whether the context menu item "Copy" is available.
MenuItemAvailable_Cut | Gets or sets a value indicating whether the context menu item "Cut" is available.
MenuItemAvailable_Delete | Gets or sets a value indicating whether the context menu item "Delete" is available.
MenuItemAvailable_DeleteColumn | Gets or sets a value indicating whether the context menu item "DeleteColumn" is available.
MenuItemAvailable_DeleteComment | Gets or sets a value indicating whether the context menu item "DeleteComment" is available.
MenuItemAvailable_DeleteRow | Gets or sets a value indicating whether the context menu item "DeleteRow" is available.
MenuItemAvailable_EditHyperlink | Gets or sets a value indicating whether the context menu item "EditHyperlink" is available.
MenuItemAvailable_FormatCells | Gets or sets a value indicating whether the context menu item "FormatCells" is available.
MenuItemAvailable_Hide | Gets or sets a value indicating whether the context menu item "Hide" is available.
MenuItemAvailable_Hyperlink | Gets or sets a value indicating whether the context menu item "Hyperlink" is available.
MenuItemAvailable_Insert | Gets or sets a value indicating whether the context menu item "Insert" is available.
MenuItemAvailable_InsertColumn | Gets or sets a value indicating whether the context menu item "InsertColumn" is available.
MenuItemAvailable_InsertComment | Gets or sets a value indicating whether the context menu item "InsertComment" is available.
MenuItemAvailable_InsertRow | Gets or sets a value indicating whether the context menu item "InsertRow" is available.
MenuItemAvailable_OpenHyperlink | Gets or sets a value indicating whether the context menu item "OpenHyperlink" is available.
MenuItemAvailable_Paste | Gets or sets a value indicating whether the context menu item "Paste" is available.
MenuItemAvailable_RemoveHyperlink | Gets or sets a value indicating whether the context menu item "RemoveHyperlink" is available.
MenuItemAvailable_Separator1 | Gets or sets a value indicating whether the context menu item separator "Separator1" is available.
MenuItemAvailable_Separator2 | Gets or sets a value indicating whether the context menu item separator "Separator2" is available.
MenuItemAvailable_Separator3 | Gets or sets a value indicating whether the context menu item separator "Separator3" is available.
MenuItemAvailable_UnHide | Gets or sets a value indicating whether the context menu item "UnHide" is available.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


ContextMenuManager Properties

The properties of the ContextMenuManager class are listed below. For a complete list of ContextMenuManager class members, see the ContextMenuManager Members topic.

Public Instance Properties

ContextMenu | Gets the shortcut menu associated with the control.
MenuItemAvailable_AddRow | Gets or sets a value indicating whether the context menu item "AddRow" is available.
MenuItemAvailable_All | Sets a value indicating whether all the context menu items are available.
MenuItemAvailable_ClearContents | Gets or sets a value indicating whether the context menu item "ClearContents" is available.
MenuItemAvailable_Copy | Gets or sets a value indicating whether the context menu item "Copy" is available.
MenuItemAvailable_Cut | Gets or sets a value indicating whether the context menu item "Cut" is available.
MenuItemAvailable_Delete | Gets or sets a value indicating whether the context menu item "Delete" is available.
MenuItemAvailable_DeleteColumn | Gets or sets a value indicating whether the context menu item "DeleteColumn" is available.
MenuItemAvailable_DeleteComment | Gets or sets a value indicating whether the context menu item "DeleteComment" is available.
MenuItemAvailable_DeleteRow | Gets or sets a value indicating whether the context menu item "DeleteRow" is available.
MenuItemAvailable_EditHyperlink | Gets or sets a value indicating whether the context menu item "EditHyperlink" is available.
MenuItemAvailable_FormatCells | Gets or sets a value indicating whether the context menu item "FormatCells" is available.
MenuItemAvailable_Hide | Gets or sets a value indicating whether the context menu item "Hide" is available.
MenuItemAvailable_Hyperlink | Gets or sets a value indicating whether the context menu item "Hyperlink" is available.
MenuItemAvailable_Insert | Gets or sets a value indicating whether the context menu item "Insert" is available.
MenuItemAvailable_InsertColumn | Gets or sets a value indicating whether the context menu item "InsertColumn" is available.
MenuItemAvailable_InsertComment | Gets or sets a value indicating whether the context menu item "InsertComment" is available.
MenuItemAvailable_InsertRow | Gets or sets a value indicating whether the context menu item "InsertRow" is available.
MenuItemAvailable_OpenHyperlink | Gets or sets a value indicating whether the context menu item "OpenHyperlink" is available.
MenuItemAvailable_Paste | Gets or sets a value indicating whether the context menu item "Paste" is available.
MenuItemAvailable_RemoveHyperlink | Gets or sets a value indicating whether the context menu item "RemoveHyperlink" is available.
MenuItemAvailable_Separator1 | Gets or sets a value indicating whether the context menu item separator "Separator1" is available.
MenuItemAvailable_Separator2 | Gets or sets a value indicating whether the context menu item separator "Separator2" is available.
MenuItemAvailable_Separator3 | Gets or sets a value indicating whether the context menu item separator "Separator3" is available.
MenuItemAvailable_UnHide | Gets or sets a value indicating whether the context menu item "UnHide" is available.

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


ContextMenu Property

Aspose.Cells for .NET

ContextMenuManager.ContextMenu Property

Gets the shortcut menu associated with the control.

public ContextMenu ContextMenu {get;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_AddRow Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_AddRow Property

Gets or sets a value indicating whether the context menu item "AddRow" is available.

public bool MenuItemAvailable_AddRow {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_All Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_All Property

Sets a value indicating whether all the context menu items are available.

public bool MenuItemAvailable_All {set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_ClearContents Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_ClearContents Property

Gets or sets a value indicating whether the context menu item "ClearContents" is available.

public bool MenuItemAvailable_ClearContents {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Copy Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Copy Property

Gets or sets a value indicating whether the context menu item "Copy" is available.

public bool MenuItemAvailable_Copy {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Cut Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Cut Property

Gets or sets a value indicating whether the context menu item "Cut" is available.

public bool MenuItemAvailable_Cut {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Delete Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Delete Property

Gets or sets a value indicating whether the context menu item "Delete" is available.

public bool MenuItemAvailable_Delete {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_DeleteColumn Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_DeleteColumn Property

Gets or sets a value indicating whether the context menu item "DeleteColumn" is available.

public bool MenuItemAvailable_DeleteColumn {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_DeleteComment Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_DeleteComment Property

Gets or sets a value indicating whether the context menu item "DeleteComment" is available.

public bool MenuItemAvailable_DeleteComment {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_DeleteRow Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_DeleteRow Property

Gets or sets a value indicating whether the context menu item "DeleteRow" is available.

public bool MenuItemAvailable_DeleteRow {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_EditHyperlink Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_EditHyperlink Property

Gets or sets a value indicating whether the context menu item "EditHyperlink" is available.

public bool MenuItemAvailable_EditHyperlink {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_FormatCells Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_FormatCells Property

Gets or sets a value indicating whether the context menu item "FormatCells" is available.

public bool MenuItemAvailable_FormatCells {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Hide Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Hide Property

Gets or sets a value indicating whether the context menu item "Hide" is available.

public bool MenuItemAvailable_Hide {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Hyperlink Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Hyperlink Property

Gets or sets a value indicating whether the context menu item "Hyperlink" is available.

public bool MenuItemAvailable_Hyperlink {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Insert Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Insert Property

Gets or sets a value indicating whether the context menu item "Insert" is available.

public bool MenuItemAvailable_Insert {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_InsertColumn Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_InsertColumn Property

Gets or sets a value indicating whether the context menu item "InsertColumn" is available.

public bool MenuItemAvailable_InsertColumn {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_InsertComment Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_InsertComment Property

Gets or sets a value indicating whether the context menu item "InsertComment" is available.

public bool MenuItemAvailable_InsertComment {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_InsertRow Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_InsertRow Property

Gets or sets a value indicating whether the context menu item "InsertRow" is available.

public bool MenuItemAvailable_InsertRow {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_OpenHyperlink Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_OpenHyperlink Property

Gets or sets a value indicating whether the context menu item "OpenHyperlink" is available.

public bool MenuItemAvailable_OpenHyperlink {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Paste Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Paste Property

Gets or sets a value indicating whether the context menu item "Paste" is available.

public bool MenuItemAvailable_Paste {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_RemoveHyperlink Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_RemoveHyperlink Property

Gets or sets a value indicating whether the context menu item "RemoveHyperlink" is available.

public bool MenuItemAvailable_RemoveHyperlink {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Separator1 Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Separator1 Property

Gets or sets a value indicating whether the context menu item separator "Separator1" is available.

public bool MenuItemAvailable_Separator1 {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Separator2 Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Separator2 Property

Gets or sets a value indicating whether the context menu item separator "Separator2" is available.

public bool MenuItemAvailable_Separator2 {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_Separator3 Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_Separator3 Property

Gets or sets a value indicating whether the context menu item separator "Separator3" is available.

public bool MenuItemAvailable_Separator3 {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


MenuItemAvailable_UnHide Property

Aspose.Cells for .NET

ContextMenuManager.MenuItemAvailable_UnHide Property

Gets or sets a value indicating whether the context menu item "UnHide" is available.

public bool MenuItemAvailable_UnHide {get; set;}

See Also

ContextMenuManager Class | Aspose.Cells.GridDesktop Namespace


CustomProperty Class

Represents identifier information.

For a list of all members of this type, see CustomProperty Members.

System.Object
Aspose.Cells.GridDesktop.CustomProperty

public class CustomProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CustomProperty Members | Aspose.Cells.GridDesktop Namespace


CustomProperty Members

CustomProperty overview

Public Instance Constructors

CustomProperty Constructor Initializes a new instance of the CustomProperty class.

Public Instance Properties

Name | Returns or sets the name of the object.
StringValue | Returns or sets the value of the custom property.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CustomProperty Class | Aspose.Cells.GridDesktop Namespace


CustomProperty Constructor

Initializes a new instance of the CustomProperty class.

public CustomProperty();

See Also

CustomProperty Class | Aspose.Cells.GridDesktop Namespace


CustomProperty Properties

The properties of the CustomProperty class are listed below. For a complete list of CustomProperty class members, see the CustomProperty Members topic.

Public Instance Properties

Name | Returns or sets the name of the object.
StringValue | Returns or sets the value of the custom property.

See Also

CustomProperty Class | Aspose.Cells.GridDesktop Namespace


Name Property

Aspose.Cells for .NET

CustomProperty.Name Property

Returns or sets the name of the object.

public string Name {get; set;}

See Also

CustomProperty Class | Aspose.Cells.GridDesktop Namespace


StringValue Property

Aspose.Cells for .NET

CustomProperty.StringValue Property

Returns or sets the value of the custom property.

public string StringValue {get; set;}

See Also

CustomProperty Class | Aspose.Cells.GridDesktop Namespace


CustomPropertyCollection Class

A collection of CustomProperty objects that represent additional information.

For a list of all members of this type, see CustomPropertyCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.GridDesktop.CustomPropertyCollection

public class CustomPropertyCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

CustomPropertyCollection Members | Aspose.Cells.GridDesktop Namespace


CustomPropertyCollection Members

CustomPropertyCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the custom property by the specific index.

Public Instance Methods

Add | Adds custom property information.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace


CustomPropertyCollection Properties

The properties of the CustomPropertyCollection class are listed below. For a complete list of CustomPropertyCollection class members, see the CustomPropertyCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the custom property by the specific index.

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace


Item Property

Aspose.Cells for .NET

CustomPropertyCollection.Item Property

Gets the custom property by the specific index.

Overload List

Gets the custom property by the specific index.

public CustomProperty this[int] {get;}

Gets the custom property by the property name.

public CustomProperty this[string] {get;}

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace


Item Property (Int32)

Aspose.Cells for .NET

CustomPropertyCollection.Item Property (Int32)

Gets the custom property by the specific index.

public CustomProperty this[
int index
] {get;}

Parameters

index
The index.

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace | CustomPropertyCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

CustomPropertyCollection.Item Property (String)

Gets the custom property by the property name.

public CustomProperty this[
string name
] {get;}

Parameters

name
The property name.

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace | CustomPropertyCollection.Item Overload List


CustomPropertyCollection Methods

The methods of the CustomPropertyCollection class are listed below. For a complete list of CustomPropertyCollection class members, see the CustomPropertyCollection Members topic.

Public Instance Methods

Add | Adds custom property information.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace


CustomPropertyCollection.Add Method

Adds custom property information.

public int Add(
string name,
string value
);

Parameters

name
The name of the custom property.
value
The value of the custom property.

See Also

CustomPropertyCollection Class | Aspose.Cells.GridDesktop Namespace


FileFormatType Enumeration

Enumerates spreadsheet file format types

public enum FileFormatType

Members

Member Name | Description | Value
Default | Represents an Excel2003 file. | 5
Excel2007Xlsx | Represents an Excel2007 xlsx file. | 6
SpreadsheetML | Represents a SpreadSheetML file. | 7

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


FormatConditionType Enumeration

Conditional format rule type.

public enum FormatConditionType

Members

Member Name | Description | Value
CellValue | This conditional formatting rule compares a cell value to a formula calculated result, using an operator. | 0
Expression | This conditional formatting rule contains a formula to evaluate. When the formula result is true, the cell is highlighted. | 1
ColorScale | This conditional formatting rule creates a gradated color scale on the cells. | 2
DataBar | This conditional formatting rule displays a gradated data bar in the range of cells. | 3
IconSet | This conditional formatting rule applies icons to cells according to their values. | 4
Top10 | This conditional formatting rule highlights cells whose values fall in the top N or bottom N bracket, as specified. | 5
UniqueValues | This conditional formatting rule highlights unique values in the range. | 6
DuplicateValues | This conditional formatting rule highlights duplicated values. | 7
ContainsText | This conditional formatting rule highlights cells containing given text. Equivalent to using the SEARCH() sheet function to determine whether the cell contains the text. | 8
NotContainsText | This conditional formatting rule highlights cells that are not blank. Equivalent of using LEN(TRIM()). This means that if the cell contains only characters that TRIM() would remove, then it is considered blank. An empty cell is also considered blank. | 9
BeginsWith | This conditional formatting rule highlights cells in the range that begin with the given text. Equivalent to using the LEFT() sheet function and comparing values. | 10
EndsWith | This conditional formatting rule highlights cells ending with given text. Equivalent to using the RIGHT() sheet function and comparing values. | 11
ContainsBlanks | This conditional formatting rule highlights cells that are completely blank. Equivalent of using LEN(TRIM()). This means that if the cell contains only characters that TRIM() would remove, then it is considered blank. An empty cell is also considered blank. | 12
NotContainsBlanks | This conditional formatting rule highlights cells that are not blank. Equivalent of using LEN(TRIM()). This means that if the cell contains only characters that TRIM() would remove, then it is considered blank. An empty cell is also considered blank. | 13
ContainsErrors | This conditional formatting rule highlights cells with formula errors. Equivalent to using ISERROR() sheet function to determine if there is a formula error. | 14
NotContainsErrors | This conditional formatting rule highlights cells without formula errors. Equivalent to using ISERROR() sheet function to determine if there is a formula error. | 15
TimePeriod | This conditional formatting rule highlights cells containing dates in the specified time period. The underlying value of the cell is evaluated, therefore the cell does not need to be formatted as a date to be evaluated. For example, with a cell containing the value 38913 the conditional format shall be applied if the rule requires a value of 7/14/2006. | 16
AboveAverage | This conditional formatting rule highlights cells that are above or below the average for all values in the range. | 17

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


GridBackgroundType Enumeration

Enumerates cell background pattern types.

public enum GridBackgroundType

Members

Member Name | Description | Value
DiagonalCrosshatch | Represents diagonal crosshatch pattern. | 9
DiagonalStripe | Represents diagonal stripe pattern. | 8
Gray6 | Represents 6.25% gray pattern | 18
Gray12 | Represents 12.5% gray pattern | 17
Gray25 | Represents 25% gray pattern. | 4
Gray50 | Represents 50% gray pattern. | 2
Gray75 | Represents 75% gray pattern. | 3
HorizontalStripe | Represents horizontal stripe pattern. | 5
None | Represents no background. | 0
ReverseDiagonalStripe | Represents reverse diagonal stripe pattern. | 7
Solid | Represents solid pattern. | 1
ThickDiagonalCrosshatch | Represents thick diagonal crosshatch pattern. | 10
ThinDiagonalCrosshatch | Represents thin diagonal crosshatch pattern. | 16
ThinDiagonalStripe | Represents thin diagonal stripe pattern. | 14
ThinHorizontalCrosshatch | Represents thin horizontal crosshatch pattern. | 15
ThinHorizontalStripe | Represents thin horizontal stripe pattern. | 11
ThinReverseDiagonalStripe | Represents thin reverse diagonal stripe pattern. | 13
ThinVerticalStripe | Represents thin vertical stripe pattern. | 12
VerticalStripe | Represents vertical stripe pattern. | 6

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


GridCell Class

Represents a cell object.

For a list of all members of this type, see GridCell Members.

System.Object
Aspose.Cells.GridDesktop.GridCell

public class GridCell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridCell Members | Aspose.Cells.GridDesktop Namespace


GridCell Members

GridCell overview

Public Static Operators

Equality Operator
Inequality Operator

Public Instance Properties

BoolValue | Gets the boolean value contained in the cell.
Column | Gets column number (zero based) of the cell.
DateValue | Gets the DateTime value contained in the cell.
DisplayStringValue | Gets the formatted string value of this cell.
DoubleValue | Gets the double value contained in the cell.
FloatValue | Gets the float value contained in the cell.
Formula | Gets or sets a formula of the Cell.
HtmlString | Gets and sets the html string which contains data and some formattings in this cell.
IntValue | Gets the integer value contained in the cell.
IsStyleSet | Indicates if the cell's style is set. If return false, it means this cell has a default cell format.
Location |
Name | Gets the name of the cell. For example: A1, F102.
Protected | Indicates if the cell is protected. If the value is "true", user can not modify the cell through the user interface. This attribute has nothing to do with the Style.CellLocked property and will not be saved to file when grid data exported. The default value is "false".
Row | Gets row number (zero based) of the cell.
StringValue | Gets the string value contained in the cell.
Style | Gets the copy of cell style. set the style for the cell.
Type | return the cell value type ,the meaning can see GridCellValueType.java
Value | Gets the value contained in this cell.
Worksheet | Gets worksheet object.

Public Instance Methods

ContainsExternalLink | Indicates wether this cell contains an external link. Only applies when the cell is a formula cell.
Copy | Copies data from a source cell.
CopyStyle | copy the style and set the style for the cell
Equals |
GetCellArea |
GetFont | Gets cell font. When change the font, you should invoke "SetFont" method, to set font to cell.
GetFontColor | Gets cell font color. When change the color,you should invoke "SetFontColor" method, to set font color to cell.
GetHashCode |
GetStyle | Gets cell style. When change the style,you should invoke "SetStyle" method, to set style to cell.
GetType (inherited from Object) |
GetWidthOfValue | Gets the width of the value in unit of pixels.
GetWorksheet | Gets the parent worksheet.
IsErrorValue | Checks if a formula can properly evaluate a result.
IsFormula | Represents if the specified cell contains formula.
PutValue | Overloaded. Puts a DateTime value into the cell.
PutValueAndSetFormatByValue | Sets the cell's value with a string value and set cell format by this value.
SetCellValue | If the value is a formula,this method set cell's value as FormulaType,
SetCustom | sets the custom format, null or empty string means no custom format.
SetFont | Sets font to cell. To improve performance,implement "SetFont" method, not implement "Font" property.
SetFontColor | Sets font color to cell. To improve performance,implement "SetFontColor" method, not implement "FontColor" property.
SetFormula | Set the formula and the value of the formula.
SetNumberType | set the display format of numbers and dates
SetStyle | Sets style to cell. To improve performance,implement "SetStyle" method, not implement "Style" property.
ToString | Returns a string represents the current Cell object.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell Properties

The properties of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Instance Properties

BoolValue | Gets the boolean value contained in the cell.
Column | Gets column number (zero based) of the cell.
DateValue | Gets the DateTime value contained in the cell.
DisplayStringValue | Gets the formatted string value of this cell.
DoubleValue | Gets the double value contained in the cell.
FloatValue | Gets the float value contained in the cell.
Formula | Gets or sets a formula of the Cell.
HtmlString | Gets and sets the html string which contains data and some formattings in this cell.
IntValue | Gets the integer value contained in the cell.
IsStyleSet | Indicates if the cell's style is set. If return false, it means this cell has a default cell format.
Location |
Name | Gets the name of the cell. For example: A1, F102.
Protected | Indicates if the cell is protected. If the value is "true", user can not modify the cell through the user interface. This attribute has nothing to do with the Style.CellLocked property and will not be saved to file when grid data exported. The default value is "false".
Row | Gets row number (zero based) of the cell.
StringValue | Gets the string value contained in the cell.
Style | Gets the copy of cell style. set the style for the cell.
Type | return the cell value type ,the meaning can see GridCellValueType.java
Value | Gets the value contained in this cell.
Worksheet | Gets worksheet object.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


BoolValue Property

Aspose.Cells for .NET

GridCell.BoolValue Property

Gets the boolean value contained in the cell.

public bool BoolValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

GridCell.Column Property

Gets column number (zero based) of the cell.

public int Column {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


DateValue Property

Aspose.Cells for .NET

GridCell.DateValue Property

Gets the DateTime value contained in the cell.

public DateTime DateValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


DisplayStringValue Property

Aspose.Cells for .NET

GridCell.DisplayStringValue Property

Gets the formatted string value of this cell.

public string DisplayStringValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


DoubleValue Property

Aspose.Cells for .NET

GridCell.DoubleValue Property

Gets the double value contained in the cell.

public double DoubleValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


FloatValue Property

Aspose.Cells for .NET

GridCell.FloatValue Property

Gets the float value contained in the cell.

public float FloatValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Formula Property

Aspose.Cells for .NET

GridCell.Formula Property

Gets or sets a formula of the Cell.

public string Formula {get; set;}

Remarks

A formula string always begins with an equal sign (=). And please always use comma(,) as parameters delimeter, such as "=SUM(A1, E1, H2)".

User can set any formula in Workbook designer file. Aspose.Cells will keep all the formulas. If user use this property to set a formula to a cell, major part of Workbook built-in functions is supported. And more is coming. If you have any special need for Workbook built-in functions, please let us know.

Example

[C#]
        cell.Formula = "=SUM(A1:C3) + E6*2";
    [Visual Basic]
        cell.Formula = "=SUM(A1:C3) + E6*2"

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


HtmlString Property

Aspose.Cells for .NET

GridCell.HtmlString Property

Gets and sets the html string which contains data and some formattings in this cell.

public string HtmlString {get; set;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


IntValue Property

Aspose.Cells for .NET

GridCell.IntValue Property

Gets the integer value contained in the cell.

public int IntValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


IsStyleSet Property

Aspose.Cells for .NET

GridCell.IsStyleSet Property

Indicates if the cell's style is set. If return false, it means this cell has a default cell format.

public bool IsStyleSet {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Location Property

Aspose.Cells for .NET

GridCell.Location Property

public CellLocation Location {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Name Property

Aspose.Cells for .NET

GridCell.Name Property

Gets the name of the cell. For example: A1, F102.

public string Name {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Protected Property

Aspose.Cells for .NET

GridCell.Protected Property

Indicates if the cell is protected. If the value is "true", user can not modify the cell through the user interface. This attribute has nothing to do with the Style.CellLocked property and will not be saved to file when grid data exported. The default value is "false".

public bool Protected {get; set;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

GridCell.Row Property

Gets row number (zero based) of the cell.

public int Row {get;}

Property Value

Cell row number

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


StringValue Property

Aspose.Cells for .NET

GridCell.StringValue Property

Gets the string value contained in the cell.

public string StringValue {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Style Property

Aspose.Cells for .NET

GridCell.Style Property

Gets the copy of cell style. set the style for the cell.

public Style Style {get; set;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Type Property

Aspose.Cells for .NET

GridCell.Type Property

return the cell value type ,the meaning can see GridCellValueType.java

public int Type {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Value Property

Aspose.Cells for .NET

GridCell.Value Property

Gets the value contained in this cell.

public object Value {get; set;}

Remarks

Possible type:

null,

Boolean,

DateTime,

Double,

Integer

String.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


Worksheet Property

Aspose.Cells for .NET

GridCell.Worksheet Property

Gets worksheet object.

public Worksheet Worksheet {get;}

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell Methods

The methods of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Instance Methods

ContainsExternalLink | Indicates wether this cell contains an external link. Only applies when the cell is a formula cell.
Copy | Copies data from a source cell.
CopyStyle | copy the style and set the style for the cell
Equals |
GetCellArea |
GetFont | Gets cell font. When change the font, you should invoke "SetFont" method, to set font to cell.
GetFontColor | Gets cell font color. When change the color,you should invoke "SetFontColor" method, to set font color to cell.
GetHashCode |
GetStyle | Gets cell style. When change the style,you should invoke "SetStyle" method, to set style to cell.
GetType (inherited from Object) |
GetWidthOfValue | Gets the width of the value in unit of pixels.
GetWorksheet | Gets the parent worksheet.
IsErrorValue | Checks if a formula can properly evaluate a result.
IsFormula | Represents if the specified cell contains formula.
PutValue | Overloaded. Puts a DateTime value into the cell.
PutValueAndSetFormatByValue | Sets the cell's value with a string value and set cell format by this value.
SetCellValue | If the value is a formula,this method set cell's value as FormulaType,
SetCustom | sets the custom format, null or empty string means no custom format.
SetFont | Sets font to cell. To improve performance,implement "SetFont" method, not implement "Font" property.
SetFontColor | Sets font color to cell. To improve performance,implement "SetFontColor" method, not implement "FontColor" property.
SetFormula | Set the formula and the value of the formula.
SetNumberType | set the display format of numbers and dates
SetStyle | Sets style to cell. To improve performance,implement "SetStyle" method, not implement "Style" property.
ToString | Returns a string represents the current Cell object.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.ContainsExternalLink Method

Indicates wether this cell contains an external link. Only applies when the cell is a formula cell.

public bool ContainsExternalLink();

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.Copy Method

Copies data from a source cell.

public void Copy(
GridCell source
);

Parameters

source
Source GridCell object.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.CopyStyle Method

copy the style and set the style for the cell

public void CopyStyle(
Style style
);

Parameters

style
The source style.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.Equals Method

public override bool Equals(
object obj
);

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetCellArea Method

public GridCellArea GetCellArea();

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetFont Method

Gets cell font. When change the font, you should invoke "SetFont" method, to set font to cell.

public Font GetFont();

Return Value

return copy of cell font.

Example

[C#]
GridCell cell = gridDesktop1.GetActiveWorksheet().Cells[0, 0];
Font font = new Font("Courier New", 8, FontStyle.Italic);
cell.SetFont(font);
Color color = cell.GetFontColor();
color = Color.Black;
cell.SetFontColor(color);

[Visual Basic]
Dim cell As GridCell =  gridDesktop1.GetActiveWorksheet().Cells(0, 0)
Dim font As Font =  New Font("Courier New",8,FontStyle.Italic)
cell.SetFont(font)
Dim color As Color =  cell.GetFontColor()
color = Color.Black
cell.SetFontColor(color)

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetFontColor Method

Gets cell font color. When change the color,you should invoke "SetFontColor" method, to set font color to cell.

public Color GetFontColor();

Return Value

return cell font color.

Example

[C#]
GridCell cell = gridDesktop1.GetActiveWorksheet().Cells[0, 0];
Font font = new Font("Courier New", 8, FontStyle.Italic);
cell.SetFont(font);
Color color = cell.GetFontColor();
color = Color.Black;
cell.SetFontColor(color);

[Visual Basic]
Dim cell As GridCell =  gridDesktop1.GetActiveWorksheet().Cells(0, 0)
Dim font As Font =  New Font("Courier New",8,FontStyle.Italic)
cell.SetFont(font)
Dim color As Color =  cell.GetFontColor()
color = Color.Black
cell.SetFontColor(color)

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetHashCode Method

public override int GetHashCode();

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetStyle Method

Gets cell style. When change the style,you should invoke "SetStyle" method, to set style to cell.

public Style GetStyle();

Return Value

return copy of cell style.

Example

[C#]
Style style = sheet.GetCell(0, 0).GetStyle();
style.CellLocked = true;
style.VAlignment = VerticalAlignmentType.Top;
...
sheet.GetCell(0, 0).SetStyle(style);

[Visual Basic]
Dim style As Style =  sheet.GetCell(0,0).GetStyle()
style.CellLocked = True
style.VAlignment = VerticalAlignmentType.Top
...
sheet.GetCell(0, 0).SetStyle(style)

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetWidthOfValue Method

Gets the width of the value in unit of pixels.

public int GetWidthOfValue();

Return Value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.GetWorksheet Method

Gets the parent worksheet.

public Worksheet GetWorksheet();

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.IsErrorValue Method

Checks if a formula can properly evaluate a result.

public bool IsErrorValue();

Remarks

Only applies to formula cell.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.IsFormula Method

Represents if the specified cell contains formula.

public bool IsFormula();

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


PutValue Method

Aspose.Cells for .NET

GridCell.PutValue Method

Puts a boolean value into the cell.

Overload List

Puts a boolean value into the cell.

public void PutValue(bool);

Puts a DateTime value into the cell.

public void PutValue(DateTime);

Puts a double value into the cell.

public void PutValue(double);

Puts a int value into the cell.

public void PutValue(int);

Puts an object value into the cell.same as setValue(Object param_object)

public void PutValue(object);

Puts a String value into the cell.

public void PutValue(string);

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(string,bool);

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(string,bool,bool);

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.PutValue Method (Boolean)

Puts a boolean value into the cell.

public void PutValue(
bool param_boolean
);

Parameters

param_boolean
Input value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (DateTime)

Puts a DateTime value into the cell.

public void PutValue(
DateTime param_date
);

Parameters

param_date
Input value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (Double)

Puts a double value into the cell.

public void PutValue(
double param_double
);

Parameters

param_double
Input value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (Int32)

Puts a int value into the cell.

public void PutValue(
int param_int
);

Parameters

param_int
Input value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (Object)

Puts an object value into the cell.same as setValue(Object param_object)

public void PutValue(
object param_object
);

Parameters

param_object

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (String)

Puts a String value into the cell.

public void PutValue(
string param_string
);

Parameters

param_string
Input value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (String, Boolean)

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(
string stringValue,
bool isConverted
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (String, Boolean, Boolean)

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(
string stringValue,
bool isConverted,
bool setStyle
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.
setStyle
True: set the number format to cell's style when converting to other data type

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace | GridCell.PutValue Overload List


GridCell.PutValueAndSetFormatByValue Method

Sets the cell's value with a string value and set cell format by this value.

public void PutValueAndSetFormatByValue(
string stringValue
);

Parameters

stringValue
Input value.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetCellValue Method

If the value is a formula,this method set cell's value as FormulaType,

public void SetCellValue(
object itemValue
);

Parameters

itemValue

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetCustom Method

sets the custom format, null or empty string means no custom format.

public void SetCustom(
string custom
);

Parameters

custom
the custom string presentation

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetFont Method

Sets font to cell. To improve performance,implement "SetFont" method, not implement "Font" property.

public void SetFont(
Font font
);

Parameters

font
font to be set.

Example

[C#]
GridCell cell = gridDesktop1.GetActiveWorksheet().Cells[0, 0];
Font font = new Font("Courier New", 8, FontStyle.Italic);
cell.SetFont(font);
Color color = cell.GetFontColor();
color = Color.Black;
cell.SetFontColor(color);

[Visual Basic]
Dim cell As GridCell =  gridDesktop1.GetActiveWorksheet().Cells(0, 0)
Dim font As Font =  New Font("Courier New",8,FontStyle.Italic)
cell.SetFont(font)
Dim color As Color =  cell.GetFontColor()
color = Color.Black
cell.SetFontColor(color)

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetFontColor Method

Sets font color to cell. To improve performance,implement "SetFontColor" method, not implement "FontColor" property.

public void SetFontColor(
Color color
);

Parameters

color
font color to be set.

Example

[C#]
GridCell cell = gridDesktop1.GetActiveWorksheet().Cells[0, 0];
Font font = new Font("Courier New", 8, FontStyle.Italic);
cell.SetFont(font);
Color color = cell.GetFontColor();
color = Color.Black;
cell.SetFontColor(color);

[Visual Basic]
Dim cell As GridCell =  gridDesktop1.GetActiveWorksheet().Cells(0, 0)
Dim font As Font =  New Font("Courier New",8,FontStyle.Italic)
cell.SetFont(font)
Dim color As Color =  cell.GetFontColor()
color = Color.Black
cell.SetFontColor(color)

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetFormula Method

Set the formula and the value of the formula.

public void SetFormula(
string formula,
object value
);

Parameters

formula
The formula.
value
The value of the formula.

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetNumberType Method

set the display format of numbers and dates

public void SetNumberType(
int numbertype
);

Parameters

numbertype
the value of ther numbertype,see GridTableItemStyle.NumberType

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.SetStyle Method

Sets style to cell. To improve performance,implement "SetStyle" method, not implement "Style" property.

public void SetStyle(
Style value
);

Parameters

value

Example

[C#]
Style style = sheet.GetCell(0, 0).GetStyle();
style.CellLocked = true;
style.VAlignment = VerticalAlignmentType.Top;
...
sheet.GetCell(0, 0).SetStyle(style);

[Visual Basic]
Dim style As Style =  sheet.GetCell(0,0).GetStyle()
style.CellLocked = True
style.VAlignment = VerticalAlignmentType.Top
...
sheet.GetCell(0, 0).SetStyle(style)

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell.ToString Method

Returns a string represents the current Cell object.

new public string ToString();

Return Value

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell Operators

The operators of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Static Operators

Equality Operator
Inequality Operator

See Also

GridCell Class | GridCell Members | Aspose.Cells.GridDesktop Namespace


GridCell Equality Operator

public static bool operator ==(
GridCell a,
GridCell b
);

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridCell Inequality Operator

public static bool operator !=(
GridCell a,
GridCell b
);

See Also

GridCell Class | Aspose.Cells.GridDesktop Namespace


GridDesktop Class

Aspose GridDesktop class Represents a root object to create an GridDesktop control. To use this control, simply drag it from your toolbox to a form or usercontrol.

For a list of all members of this type, see GridDesktop Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Aspose.Cells.GridDesktop.GridDesktop

public class GridDesktop : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Please refer to .NET SDK document about further information about System.Windows.Forms.UserControl.

Example

[C#]
gridDesktop1.Worksheets[0].Cells[0, 0].Value = "2";
gridDesktop1.Worksheets[0].Cells[1, 0].Value = "3";
gridDesktop1.Worksheets[0].Cells[2, 1].Value = "=a1*a2";
gridDesktop1.RunAllFormulas();
gridDesktop1.Invalidate();

[Visual Basic]
gridDesktop1.Worksheets(0).Cells(0, 0).Value = "2"
gridDesktop1.Worksheets(0).Cells(1, 0).Value = "3"
gridDesktop1.Worksheets(0).Cells(2, 1).Value = "=a1*a2"
gridDesktop1.RunAllFormulas()
gridDesktop1.Invalidate()

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridDesktop Members | Aspose.Cells.GridDesktop Namespace


GridDesktop Members

GridDesktop overview

Public Static Methods

GetVersion Get the release version.

Public Instance Constructors

GridDesktop Constructor Aspose GridDesktop class

Public Instance Properties

AccessibilityObject (inherited from Control) |
AccessibleDefaultActionDescription (inherited from Control) |
AccessibleDescription (inherited from Control) |
AccessibleName (inherited from Control) |
AccessibleRole (inherited from Control) |
ActiveControl (inherited from ContainerControl) |
ActiveSheetIndex | Gets or sets the selected sheet index.
ActiveSheetNameFont | Gets or sets the active sheet displaying font of sheet bar.
AllowDrop (inherited from Control) |
AlwasysRecalculateAllFormulas | Gets or sets a value indicating whether we need to run all formulas,as when we run all formulas, when update one cell value,and it affect others ,and others affect others ,more and more, cause the whole cells need recalculate ,just like the Butterfly Effect,it needs lots of stack opertation , it will get very low performance, like in CELLSNET-41921,this issue contains the very file that can show this scenario we'd better just run all formulas, ,as when run all formulas we may have some optimization.
Anchor (inherited from Control) |
AutoScaleDimensions (inherited from ContainerControl) |
AutoScaleMode (inherited from ContainerControl) |
AutoScroll (inherited from ScrollableControl) |
AutoScrollMargin (inherited from ScrollableControl) |
AutoScrollMinSize (inherited from ScrollableControl) |
AutoScrollOffset (inherited from Control) |
AutoScrollPosition (inherited from ScrollableControl) |
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) |
AutoValidate (inherited from UserControl) |
BackColor (inherited from Control) |
BackgroundImage (inherited from Control) |
BackgroundImageLayout (inherited from Control) |
BindingContext (inherited from ContainerControl) |
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) |
Bounds (inherited from Control) |
CanFocus (inherited from Control) |
CanSelect (inherited from Control) |
Capture (inherited from Control) |
CausesValidation (inherited from Control) |
ClientRectangle (inherited from Control) |
ClientSize (inherited from Control) |
ColumnHeaderVisible | Gets or sets a value indicating whether column header is visible.
CommentDisplayingFont | Gets or sets the default displaying font of comment text.
CompanyName (inherited from Control) |
Container (inherited from Component) |
ContainsFocus (inherited from Control) |
ContextMenu (inherited from Control) |
ContextMenuManager | Gets the ContextMenuManager instance.
ContextMenuStrip (inherited from Control) |
Controls (inherited from Control) |
Created (inherited from Control) |
CurrentAutoScaleDimensions (inherited from ContainerControl) |
Cursor (inherited from Control) |
DataBindings (inherited from Control) |
DefaultCellFont | Gets or sets the default font of the cell
DefaultCellFontColor | Gets or sets the default font color of the cell.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) |
Dock (inherited from Control) |
DockPadding (inherited from ScrollableControl) |
EnableClipboardCopyPaste | Indicates whether to copy/paste based on clipboard,so that it can copy/paste with MS-EXCEL. It only copys/pastes cell value ,It does not copy any other setting of the cell like format,border style and so on The default value is false.
EnableCopyWithExtension | Gets or sets a value indicating whether the copy operation will extend the number of rows or columns.
EnableCopyWithLockedOption | Gets or sets a value indicating whether the copy operation will copy the style's CellLocked attribute value of a cell.
Enabled (inherited from Control) |
EnableUndo | Gets or sets a value indicating whether the Undo function is enabled. The default value is false.
Focused (inherited from Control) |
Font (inherited from Control) |
ForeColor (inherited from Control) |
GridMemorySetting | Gets or sets memory option.
Handle (inherited from Control) |
HasChildren (inherited from Control) |
Height (inherited from Control) |
HorizontalScroll (inherited from ScrollableControl) |
ImeMode (inherited from Control) |
InvokeRequired (inherited from Control) |
IsAccessible (inherited from Control) |
IsDisposed (inherited from Control) |
IsHandleCreated (inherited from Control) |
IsHorizontalScrollBarVisible | Sets visible statue for Horizontal ScrollBar.
IsMirrored (inherited from Control) |
IsVerticalScrollBarVisible | Sets visible statue for Vertical ScrollBar.
LayoutEngine (inherited from Control) |
Left (inherited from Control) |
Location (inherited from Control) |
Margin (inherited from Control) |
MaximumSize (inherited from Control) |
MinimumSize (inherited from Control) |
Name (inherited from Control) |
Names | Gets the collection of all the Name objects in the spreadsheet.
Padding (inherited from Control) |
PageRows | Sets or Gets row size for Pagination.the maximum of PageRows supported is 100000,the maximum of page number supported is 5000.
Parent (inherited from Control) |
ParentForm (inherited from ContainerControl) |
PasteType | Indicates which paste type when do paste action，only available when EnableClipboardCopyPaste is false .
PreferredSize (inherited from Control) |
ProductName (inherited from Control) |
ProductVersion (inherited from Control) |
R1C1 | Gets or sets a value indicating whether the control using R1C1 reference style.
RecalculateFormulas | Gets or sets a value indicating whether to recalculate all the cells' formula when a cell's value changed. The default value is true.
RecreatingHandle (inherited from Control) |
Region (inherited from Control) |
Right (inherited from Control) |
RightToLeft (inherited from Control) |
RowHeaderVisible | Gets or sets a value indicating whether row header is visible.
SheetNameFont | Gets or sets the default displaying font of sheet bar.
SheetsBarVisible | Gets or sets a value indicating whether sheet bar is visible.
SheetTabWidth | Sets /Gets width of Sheet Tab.
ShowContextMenu | Gets or sets a value indicating whether the control can show context menu.
ShowStatus | Gets or sets a value indicating whether to show the calculate status The default value is true.
Site (inherited from Control) |
Size (inherited from Control) |
TabIndex (inherited from Control) |
TabStop (inherited from Control) |
Tag (inherited from Control) |
Text (inherited from UserControl) |
Top (inherited from Control) |
TopLevelControl (inherited from Control) |
UndoManager | Gets the UndoManager instance.
UseWaitCursor (inherited from Control) |
VerticalScroll (inherited from ScrollableControl) |
Visible (inherited from Control) |
Width (inherited from Control) |
WindowTarget (inherited from Control) |
Worksheets | Gets the Worksheets.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded.
BringToFront (inherited from Control) |
Clear | Clears GridDesktop control.
Contains (inherited from Control) |
Copy | Copies focused cell content to clipboard.
CreateControl (inherited from Control) |
CreateGraphics (inherited from Control) |
CreateObjRef (inherited from MarshalByRefObject) |
Cut | Cuts focused cell content to clipboard.
Dispose (inherited from Component) |
DoDragDrop (inherited from Control) |
DoSplit | Sets Split view.
DrawToBitmap (inherited from Control) |
EndFormatPainter | Notifies GridDesktop to end FormatPainter.
EndInvoke (inherited from Control) |
Equals (inherited from Object) |
ExportExcelFile | Overloaded. Exports to a excel file stream, including disk IO stream or memory stream.
FindForm (inherited from Control) |
Focus (inherited from Control) |
GetActiveWorksheet | Gets current active worksheet.
GetChildAtPoint (inherited from Control) | Overloaded.
GetContainerControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetNextControl (inherited from Control) |
GetPreferredSize (inherited from Control) |
GetType (inherited from Object) |
Hide (inherited from Control) |
ImportExcelFile | Overloaded. Imports from an excel file stream, including disk file stream or memory stream.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Invalidate (inherited from Control) | Overloaded.
Invoke (inherited from Control) | Overloaded.
OpenFindReplaceDialog | Opens the FindReplace dialog to find or replace cells.
Paste | Pastes clipboard content to focused cell.
PerformAutoScale (inherited from ContainerControl) |
PerformLayout (inherited from Control) | Overloaded.
PointToClient (inherited from Control) |
PointToScreen (inherited from Control) |
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) |
RectangleToScreen (inherited from Control) |
Refresh (inherited from Control) |
RefreshControl | Refresh the GridDesktop control.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) |
ResumeLayout (inherited from Control) | Overloaded.
RunAllFormulas | Runs all the cells's formula.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) |
SelectNextControl (inherited from Control) |
SendToBack (inherited from Control) |
SetAllScrollBarsVisible | Sets all scrollbars visible.
SetAutoScrollMargin (inherited from ScrollableControl) |
SetBounds (inherited from Control) | Overloaded.
Show (inherited from Control) |
ShowStyleDialog | Opens a style dialog,to set cells style,font,colors etc.
StartFormatPainter | Notifies GridDesktop to start FormatPainter.
SuspendLayout (inherited from Control) |
ToString (inherited from Component) |
UnDoSplit | Unset Split view.
Update (inherited from Control) |
Validate (inherited from ContainerControl) | Overloaded.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDeleteColumns | Occurs after column is deleted.
AfterDeleteRows | Occurs after row is deleted.
AfterInsertColumns | Occurs after new column is inserted.
AfterInsertRows | Occurs after new row is inserted.
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) |
BackColorChanged (inherited from Control) |
BackgroundImageChanged (inherited from Control) |
BackgroundImageLayoutChanged (inherited from Control) |
BeforeCalculate | Occurs when the grid workbook state is changed.
BeforeLoadFile | Occurs when the grid workbook state is changed.
BindingContextChanged (inherited from Control) |
CausesValidationChanged (inherited from Control) |
CellButtonClick | Occurs when the cell button clicked.
CellCheckedChanged | Occurs when the cell checkbox Checked property is changed.
CellClick | Occurs when the gridcell is clicked.
CellComboBoxCopy | Occurs when a grid cell ComboBox is being copied.
CellDataChanged | Occurs when the grid cell data property is changed.
CellDoubleClick | Occurs when the gridcell is double clicked.
CellFormatChanged | Occurs when the cell format is changed via Format Cells dialog box.
CellKeyPressed | Occurs when a key is pressed while a cell has focus.
CellSelectedIndexChanged | Occurs when the cell combobox SelectedIndex property has changed.
CellTextBoxChanging | Occurs when typing characters in a grid cell.
CellValidationFailed | Occurs when a grid cell validates failed.
ChangeUICues (inherited from Control) |
Click (inherited from Control) |
ClientSizeChanged (inherited from Control) |
ColumnHeaderClick | Occurs when the column header clicked.
ColumnHeaderDoubleClick | Occurs when the column header double clicked.
CommentDataChanged | Occurs when the comment data has changed.
ContextMenuChanged (inherited from Control) |
ContextMenuStripChanged (inherited from Control) |
ControlAdded (inherited from Control) |
ControlRemoved (inherited from Control) |
CursorChanged (inherited from Control) |
Disposed (inherited from Component) |
DockChanged (inherited from Control) |
DoubleClick (inherited from Control) |
DragDrop (inherited from Control) |
DragEnter (inherited from Control) |
DragLeave (inherited from Control) |
DragOver (inherited from Control) |
EnabledChanged (inherited from Control) |
Enter (inherited from Control) |
FinishCalculate | Occurs when the grid workbook state is changed.
FinishLoadFile | Occurs when the grid workbook state is changed.
FocusedCellChanged | Occurs when the focused cell is changed.
FontChanged (inherited from Control) |
ForeColorChanged (inherited from Control) |
GiveFeedback (inherited from Control) |
GotFocus (inherited from Control) |
HandleCreated (inherited from Control) |
HandleDestroyed (inherited from Control) |
HelpRequested (inherited from Control) |
ImeModeChanged (inherited from Control) |
Invalidated (inherited from Control) |
KeyDown (inherited from Control) |
KeyPress (inherited from Control) |
KeyUp (inherited from Control) |
Layout (inherited from Control) |
Leave (inherited from Control) |
Load (inherited from UserControl) |
LocationChanged (inherited from Control) |
LostFocus (inherited from Control) |
MarginChanged (inherited from Control) |
MouseCaptureChanged (inherited from Control) |
MouseClick (inherited from Control) |
MouseDoubleClick (inherited from Control) |
MouseDown (inherited from Control) |
MouseEnter (inherited from Control) |
MouseHover (inherited from Control) |
MouseLeave (inherited from Control) |
MouseMove (inherited from Control) |
MouseUp (inherited from Control) |
MouseWheel (inherited from Control) |
Move (inherited from Control) |
PaddingChanged (inherited from Control) |
Paint (inherited from Control) |
ParentChanged (inherited from Control) |
PreviewKeyDown (inherited from Control) |
QueryAccessibilityHelp (inherited from Control) |
QueryContinueDrag (inherited from Control) |
RegionChanged (inherited from Control) |
Resize (inherited from Control) |
RightToLeftChanged (inherited from Control) |
RowColumnHiddenChanged | Occurs when the row/column hide status changed.
RowFilteredEvent | Occurs after row filter item selected.
RowHeaderClick | Occurs when the row header clicked.
RowHeaderDoubleClick | Occurs when the row header double clicked.
Scroll (inherited from ScrollableControl) |
SelectedCellRangeChanged | Occurs when the selected cellrange is changed.
SelectedSheetIndexChanged | Occurs when the SelectedSheetIndex property is changed.
ShapeClick | Occurs when the shape is clicked.
SizeChanged (inherited from Control) |
StyleChanged (inherited from Control) |
SystemColorsChanged (inherited from Control) |
TabIndexChanged (inherited from Control) |
TabStopChanged (inherited from Control) |
TextChanged (inherited from UserControl) |
Validated (inherited from Control) |
Validating (inherited from Control) |
VisibleChanged (inherited from Control) |

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop Constructor

Aspose GridDesktop class

public GridDesktop();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop Properties

The properties of the GridDesktop class are listed below. For a complete list of GridDesktop class members, see the GridDesktop Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) |
AccessibleDefaultActionDescription (inherited from Control) |
AccessibleDescription (inherited from Control) |
AccessibleName (inherited from Control) |
AccessibleRole (inherited from Control) |
ActiveControl (inherited from ContainerControl) |
ActiveSheetIndex | Gets or sets the selected sheet index.
ActiveSheetNameFont | Gets or sets the active sheet displaying font of sheet bar.
AllowDrop (inherited from Control) |
AlwasysRecalculateAllFormulas | Gets or sets a value indicating whether we need to run all formulas,as when we run all formulas, when update one cell value,and it affect others ,and others affect others ,more and more, cause the whole cells need recalculate ,just like the Butterfly Effect,it needs lots of stack opertation , it will get very low performance, like in CELLSNET-41921,this issue contains the very file that can show this scenario we'd better just run all formulas, ,as when run all formulas we may have some optimization.
Anchor (inherited from Control) |
AutoScaleDimensions (inherited from ContainerControl) |
AutoScaleMode (inherited from ContainerControl) |
AutoScroll (inherited from ScrollableControl) |
AutoScrollMargin (inherited from ScrollableControl) |
AutoScrollMinSize (inherited from ScrollableControl) |
AutoScrollOffset (inherited from Control) |
AutoScrollPosition (inherited from ScrollableControl) |
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) |
AutoValidate (inherited from UserControl) |
BackColor (inherited from Control) |
BackgroundImage (inherited from Control) |
BackgroundImageLayout (inherited from Control) |
BindingContext (inherited from ContainerControl) |
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) |
Bounds (inherited from Control) |
CanFocus (inherited from Control) |
CanSelect (inherited from Control) |
Capture (inherited from Control) |
CausesValidation (inherited from Control) |
ClientRectangle (inherited from Control) |
ClientSize (inherited from Control) |
ColumnHeaderVisible | Gets or sets a value indicating whether column header is visible.
CommentDisplayingFont | Gets or sets the default displaying font of comment text.
CompanyName (inherited from Control) |
Container (inherited from Component) |
ContainsFocus (inherited from Control) |
ContextMenu (inherited from Control) |
ContextMenuManager | Gets the ContextMenuManager instance.
ContextMenuStrip (inherited from Control) |
Controls (inherited from Control) |
Created (inherited from Control) |
CurrentAutoScaleDimensions (inherited from ContainerControl) |
Cursor (inherited from Control) |
DataBindings (inherited from Control) |
DefaultCellFont | Gets or sets the default font of the cell
DefaultCellFontColor | Gets or sets the default font color of the cell.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) |
Dock (inherited from Control) |
DockPadding (inherited from ScrollableControl) |
EnableClipboardCopyPaste | Indicates whether to copy/paste based on clipboard,so that it can copy/paste with MS-EXCEL. It only copys/pastes cell value ,It does not copy any other setting of the cell like format,border style and so on The default value is false.
EnableCopyWithExtension | Gets or sets a value indicating whether the copy operation will extend the number of rows or columns.
EnableCopyWithLockedOption | Gets or sets a value indicating whether the copy operation will copy the style's CellLocked attribute value of a cell.
Enabled (inherited from Control) |
EnableUndo | Gets or sets a value indicating whether the Undo function is enabled. The default value is false.
Focused (inherited from Control) |
Font (inherited from Control) |
ForeColor (inherited from Control) |
GridMemorySetting | Gets or sets memory option.
Handle (inherited from Control) |
HasChildren (inherited from Control) |
Height (inherited from Control) |
HorizontalScroll (inherited from ScrollableControl) |
ImeMode (inherited from Control) |
InvokeRequired (inherited from Control) |
IsAccessible (inherited from Control) |
IsDisposed (inherited from Control) |
IsHandleCreated (inherited from Control) |
IsHorizontalScrollBarVisible | Sets visible statue for Horizontal ScrollBar.
IsMirrored (inherited from Control) |
IsVerticalScrollBarVisible | Sets visible statue for Vertical ScrollBar.
LayoutEngine (inherited from Control) |
Left (inherited from Control) |
Location (inherited from Control) |
Margin (inherited from Control) |
MaximumSize (inherited from Control) |
MinimumSize (inherited from Control) |
Name (inherited from Control) |
Names | Gets the collection of all the Name objects in the spreadsheet.
Padding (inherited from Control) |
PageRows | Sets or Gets row size for Pagination.the maximum of PageRows supported is 100000,the maximum of page number supported is 5000.
Parent (inherited from Control) |
ParentForm (inherited from ContainerControl) |
PasteType | Indicates which paste type when do paste action，only available when EnableClipboardCopyPaste is false .
PreferredSize (inherited from Control) |
ProductName (inherited from Control) |
ProductVersion (inherited from Control) |
R1C1 | Gets or sets a value indicating whether the control using R1C1 reference style.
RecalculateFormulas | Gets or sets a value indicating whether to recalculate all the cells' formula when a cell's value changed. The default value is true.
RecreatingHandle (inherited from Control) |
Region (inherited from Control) |
Right (inherited from Control) |
RightToLeft (inherited from Control) |
RowHeaderVisible | Gets or sets a value indicating whether row header is visible.
SheetNameFont | Gets or sets the default displaying font of sheet bar.
SheetsBarVisible | Gets or sets a value indicating whether sheet bar is visible.
SheetTabWidth | Sets /Gets width of Sheet Tab.
ShowContextMenu | Gets or sets a value indicating whether the control can show context menu.
ShowStatus | Gets or sets a value indicating whether to show the calculate status The default value is true.
Site (inherited from Control) |
Size (inherited from Control) |
TabIndex (inherited from Control) |
TabStop (inherited from Control) |
Tag (inherited from Control) |
Text (inherited from UserControl) |
Top (inherited from Control) |
TopLevelControl (inherited from Control) |
UndoManager | Gets the UndoManager instance.
UseWaitCursor (inherited from Control) |
VerticalScroll (inherited from ScrollableControl) |
Visible (inherited from Control) |
Width (inherited from Control) |
WindowTarget (inherited from Control) |
Worksheets | Gets the Worksheets.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ActiveSheetIndex Property

Aspose.Cells for .NET

GridDesktop.ActiveSheetIndex Property

Gets or sets the selected sheet index.

public int ActiveSheetIndex {get; set;}

Example

[C#]
gridDesktop1.ActiveSheetIndex = 0;

[Visual Basic]
gridDesktop1.ActiveSheetIndex = 0

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ActiveSheetNameFont Property

Aspose.Cells for .NET

GridDesktop.ActiveSheetNameFont Property

Gets or sets the active sheet displaying font of sheet bar.

public Font ActiveSheetNameFont {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


AlwasysRecalculateAllFormulas Property

Aspose.Cells for .NET

GridDesktop.AlwasysRecalculateAllFormulas Property

Gets or sets a value indicating whether we need to run all formulas,as when we run all formulas, when update one cell value,and it affect others ,and others affect others ,more and more, cause the whole cells need recalculate ,just like the Butterfly Effect,it needs lots of stack opertation , it will get very low performance, like in CELLSNET-41921,this issue contains the very file that can show this scenario we'd better just run all formulas, ,as when run all formulas we may have some optimization.

public bool AlwasysRecalculateAllFormulas {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


BorderStyle Property

Aspose.Cells for .NET

GridDesktop.BorderStyle Property

Indicates the border style for the control.

new public BorderStyle BorderStyle {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ColumnHeaderVisible Property

Aspose.Cells for .NET

GridDesktop.ColumnHeaderVisible Property

Gets or sets a value indicating whether column header is visible.

public bool ColumnHeaderVisible {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


CommentDisplayingFont Property

Aspose.Cells for .NET

GridDesktop.CommentDisplayingFont Property

Gets or sets the default displaying font of comment text.

public Font CommentDisplayingFont {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ContextMenuManager Property

Aspose.Cells for .NET

GridDesktop.ContextMenuManager Property

Gets the ContextMenuManager instance.

public ContextMenuManager ContextMenuManager {get;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


DefaultCellFont Property

Aspose.Cells for .NET

GridDesktop.DefaultCellFont Property

Gets or sets the default font of the cell

public Font DefaultCellFont {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


DefaultCellFontColor Property

Aspose.Cells for .NET

GridDesktop.DefaultCellFontColor Property

Gets or sets the default font color of the cell.

public Color DefaultCellFontColor {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


EnableClipboardCopyPaste Property

Aspose.Cells for .NET

GridDesktop.EnableClipboardCopyPaste Property

Indicates whether to copy/paste based on clipboard,so that it can copy/paste with MS-EXCEL. It only copys/pastes cell value ,It does not copy any other setting of the cell like format,border style and so on The default value is false.

public bool EnableClipboardCopyPaste {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


EnableCopyWithExtension Property

Aspose.Cells for .NET

GridDesktop.EnableCopyWithExtension Property

Gets or sets a value indicating whether the copy operation will extend the number of rows or columns.

public bool EnableCopyWithExtension {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


EnableCopyWithLockedOption Property

Aspose.Cells for .NET

GridDesktop.EnableCopyWithLockedOption Property

Gets or sets a value indicating whether the copy operation will copy the style's CellLocked attribute value of a cell.

public bool EnableCopyWithLockedOption {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


EnableUndo Property

Aspose.Cells for .NET

GridDesktop.EnableUndo Property

Gets or sets a value indicating whether the Undo function is enabled. The default value is false.

public bool EnableUndo {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridMemorySetting Property

Aspose.Cells for .NET

GridDesktop.GridMemorySetting Property

Gets or sets memory option.

public GridMemorySetting GridMemorySetting {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


IsHorizontalScrollBarVisible Property

Aspose.Cells for .NET

GridDesktop.IsHorizontalScrollBarVisible Property

Sets visible statue for Horizontal ScrollBar.

public bool IsHorizontalScrollBarVisible {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


IsVerticalScrollBarVisible Property

Aspose.Cells for .NET

GridDesktop.IsVerticalScrollBarVisible Property

Sets visible statue for Vertical ScrollBar.

public bool IsVerticalScrollBarVisible {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


Names Property

Aspose.Cells for .NET

GridDesktop.Names Property

Gets the collection of all the Name objects in the spreadsheet.

public GridNameCollection Names {get;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


PageRows Property

Aspose.Cells for .NET

GridDesktop.PageRows Property

Sets or Gets row size for Pagination.the maximum of PageRows supported is 100000,the maximum of page number supported is 5000.

public int PageRows {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


PasteType Property

Aspose.Cells for .NET

GridDesktop.PasteType Property

Indicates which paste type when do paste action，only available when EnableClipboardCopyPaste is false .

public GridPasteType PasteType {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


R1C1 Property

Aspose.Cells for .NET

GridDesktop.R1C1 Property

Gets or sets a value indicating whether the control using R1C1 reference style.

public bool R1C1 {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


RecalculateFormulas Property

Aspose.Cells for .NET

GridDesktop.RecalculateFormulas Property

Gets or sets a value indicating whether to recalculate all the cells' formula when a cell's value changed. The default value is true.

public bool RecalculateFormulas {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


RowHeaderVisible Property

Aspose.Cells for .NET

GridDesktop.RowHeaderVisible Property

Gets or sets a value indicating whether row header is visible.

public bool RowHeaderVisible {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


SheetNameFont Property

Aspose.Cells for .NET

GridDesktop.SheetNameFont Property

Gets or sets the default displaying font of sheet bar.

public Font SheetNameFont {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


SheetsBarVisible Property

Aspose.Cells for .NET

GridDesktop.SheetsBarVisible Property

Gets or sets a value indicating whether sheet bar is visible.

public bool SheetsBarVisible {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


SheetTabWidth Property

Aspose.Cells for .NET

GridDesktop.SheetTabWidth Property

Sets /Gets width of Sheet Tab.

public int SheetTabWidth {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ShowContextMenu Property

Aspose.Cells for .NET

GridDesktop.ShowContextMenu Property

Gets or sets a value indicating whether the control can show context menu.

public bool ShowContextMenu {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ShowStatus Property

Aspose.Cells for .NET

GridDesktop.ShowStatus Property

Gets or sets a value indicating whether to show the calculate status The default value is true.

public bool ShowStatus {get; set;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


UndoManager Property

Aspose.Cells for .NET

GridDesktop.UndoManager Property

Gets the UndoManager instance.

public UndoManager UndoManager {get;}

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


Worksheets Property

Aspose.Cells for .NET

GridDesktop.Worksheets Property

Gets the Worksheets.

public WorksheetCollection Worksheets {get;}

Example

[C#]
gridDesktop1.Worksheets.Add();
gridDesktop1.Worksheets.Insert(0);

[Visual Basic]
gridDesktop1.Worksheets.Add()
gridDesktop1.Worksheets.Insert(0)

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop Methods

The methods of the GridDesktop class are listed below. For a complete list of GridDesktop class members, see the GridDesktop Members topic.

Public Static Methods

GetVersion Get the release version.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded.
BringToFront (inherited from Control) |
Clear | Clears GridDesktop control.
Contains (inherited from Control) |
Copy | Copies focused cell content to clipboard.
CreateControl (inherited from Control) |
CreateGraphics (inherited from Control) |
CreateObjRef (inherited from MarshalByRefObject) |
Cut | Cuts focused cell content to clipboard.
Dispose (inherited from Component) |
DoDragDrop (inherited from Control) |
DoSplit | Sets Split view.
DrawToBitmap (inherited from Control) |
EndFormatPainter | Notifies GridDesktop to end FormatPainter.
EndInvoke (inherited from Control) |
Equals (inherited from Object) |
ExportExcelFile | Overloaded. Exports to a excel file stream, including disk IO stream or memory stream.
FindForm (inherited from Control) |
Focus (inherited from Control) |
GetActiveWorksheet | Gets current active worksheet.
GetChildAtPoint (inherited from Control) | Overloaded.
GetContainerControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetNextControl (inherited from Control) |
GetPreferredSize (inherited from Control) |
GetType (inherited from Object) |
Hide (inherited from Control) |
ImportExcelFile | Overloaded. Imports from an excel file stream, including disk file stream or memory stream.
InitializeLifetimeService (inherited from MarshalByRefObject) |
Invalidate (inherited from Control) | Overloaded.
Invoke (inherited from Control) | Overloaded.
OpenFindReplaceDialog | Opens the FindReplace dialog to find or replace cells.
Paste | Pastes clipboard content to focused cell.
PerformAutoScale (inherited from ContainerControl) |
PerformLayout (inherited from Control) | Overloaded.
PointToClient (inherited from Control) |
PointToScreen (inherited from Control) |
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) |
RectangleToScreen (inherited from Control) |
Refresh (inherited from Control) |
RefreshControl | Refresh the GridDesktop control.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) |
ResumeLayout (inherited from Control) | Overloaded.
RunAllFormulas | Runs all the cells's formula.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) |
SelectNextControl (inherited from Control) |
SendToBack (inherited from Control) |
SetAllScrollBarsVisible | Sets all scrollbars visible.
SetAutoScrollMargin (inherited from ScrollableControl) |
SetBounds (inherited from Control) | Overloaded.
Show (inherited from Control) |
ShowStyleDialog | Opens a style dialog,to set cells style,font,colors etc.
StartFormatPainter | Notifies GridDesktop to start FormatPainter.
SuspendLayout (inherited from Control) |
ToString (inherited from Component) |
UnDoSplit | Unset Split view.
Update (inherited from Control) |
Validate (inherited from ContainerControl) | Overloaded.
ValidateChildren (inherited from UserControl) | Overloaded.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.Clear Method

Clears GridDesktop control.

public void Clear();

Example

[C#]
gridDesktop1.Clear();
gridDesktop1.Worksheets.Add();
gridDesktop1.Worksheets.Insert(0);

[Visual Basic]
gridDesktop1.Clear()
gridDesktop1.Worksheets.Add()
gridDesktop1.Worksheets.Insert(0)

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.Copy Method

Copies focused cell content to clipboard.

public void Copy();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.Cut Method

Cuts focused cell content to clipboard.

public void Cut();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.DoSplit Method

Sets Split view.

public void DoSplit();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.EndFormatPainter Method

Notifies GridDesktop to end FormatPainter.

public void EndFormatPainter();

Example

[C#]
gridDesktop1.StartFormatPainter(false);
...
//User Interface Operation
...
gridDesktop1.EndFormatPainter();

[Visual Basic]
gridDesktop1.StartFormatPainter(False)
...
'User Interface Operation
...
gridDesktop1.EndFormatPainter()

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ExportExcelFile Method

Aspose.Cells for .NET

GridDesktop.ExportExcelFile Method

Exports to a excel file stream, including disk IO stream or memory stream.

Overload List

Exports to a excel file stream, including disk IO stream or memory stream.

public void ExportExcelFile(Stream);

Exports to a excel file stream, including disk IO stream or memory stream.

public void ExportExcelFile(Stream,FileFormatType);

Exports to an excel file.

public void ExportExcelFile(string);

Exports to a excel file.

public void ExportExcelFile(string,FileFormatType);

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.ExportExcelFile Method (Stream)

Exports to a excel file stream, including disk IO stream or memory stream.

public void ExportExcelFile(
Stream stream
);

Example

[C#]
private void button1_Click(object sender, System.EventArgs e)
{
    FileStream fs = new FileStream("d:\\bookx.xls", FileMode.OpenOrCreate);
    try
    {
        gridDesktop1.Worksheets.ExportExcelFile(fs);
    }
    catch(Exception ex)
    {
    }
    finally
    {
        fs.Close();
    }
}

[Visual Basic]
Private Sub menuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles menuItem6.Click
    Dim fs As FileStream =  New FileStream("d:\bookx.xls", FileMode.OpenOrCreate)
    Try
        gridDesktop1.Worksheets.ExportExcelFile(fs)
    Catch ex As Exception
        Throw ex
    Finally
        fs.Close()
    End Try
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ExportExcelFile Overload List


GridDesktop.ExportExcelFile Method (Stream, FileFormatType)

Exports to a excel file stream, including disk IO stream or memory stream.

public void ExportExcelFile(
Stream stream,
FileFormatType fileFormatType
);

Parameters

stream
Stream where to save the spreadsheet.
fileFormatType
Excel file format type.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ExportExcelFile Overload List


GridDesktop.ExportExcelFile Method (String)

Exports to an excel file.

public void ExportExcelFile(
string fileName
);

Example

[C#]
private void button1_Click(object sender, System.EventArgs e)
{
    gridDesktop1.Worksheets.ExportExcelFile("savedemo.xls");
}

[Visual Basic]
Private Sub menuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles menuItem7.Click
    gridDesktop1.Worksheets.ExportExcelFile("savedemo.xls")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ExportExcelFile Overload List


GridDesktop.ExportExcelFile Method (String, FileFormatType)

Exports to a excel file.

public void ExportExcelFile(
string fileName,
FileFormatType fileFormatType
);

Parameters

fileName
The name of created file.
fileFormatType
Excel file format type.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ExportExcelFile Overload List


GridDesktop.GetActiveWorksheet Method

Gets current active worksheet.

public Worksheet GetActiveWorksheet();

Return Value

Worksheet object.

Example

[C#]
Worksheet worksheet = gridDesktop1.GetActiveWorksheet();

[Visual Basic]
Dim worksheet As Worksheet =  gridDesktop1.GetActiveWorksheet()

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.GetVersion Method

Get the release version.

public static string GetVersion();

Return Value

The release version.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


ImportExcelFile Method

Aspose.Cells for .NET

GridDesktop.ImportExcelFile Method

Imports from an excel file stream, including disk file stream or memory stream.

Overload List

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(Stream);

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(Stream,bool);

Imports from an excel file.

public void ImportExcelFile(Stream,string,string,bool,bool);

Imports from an excel file.

public void ImportExcelFile(string);

Imports from an excel file.

public void ImportExcelFile(string,bool);

Imports a worksheet from an excel file.

public void ImportExcelFile(string,int);

Imports from an excel file.

public void ImportExcelFile(string,string,string,bool,bool);

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.ImportExcelFile Method (Stream)

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(
Stream stream
);

Example

[C#]
private void button1_Click(object sender, System.EventArgs e)
{
    FileStream fs = new FileStream("d:\\bookx.xls", FileMode.Open);
    try
    {
        gridDesktop1.ImportExcelFile(fs);
    }
    catch(Exception ex)
    {
    }
    finally
    {
        fs.Close();
    }
}

[Visual Basic]
Private Sub menuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles menuItem6.Click
    Dim fs As FileStream =  New FileStream("d:\bookx.xls",FileMode.Open)
    Try
        gridDesktop1.ImportExcelFile(fs)
    Catch ex As Exception
        Throw ex
    Finally
        fs.Close()
    End Try
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.ImportExcelFile Method (Stream, Boolean)

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(
Stream stream,
bool runFormulas
);

Parameters

stream
stream object.
runFormulas
if true, this method will invoke RunAllFormulas method.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.ImportExcelFile Method (Stream, String, String, Boolean, Boolean)

Imports from an excel file.

public void ImportExcelFile(
Stream stream,
string passwordtoOpen,
string passwordtoModify,
bool openasReadOnly,
bool runFormulas
);

Parameters

stream
stream of excel file .
passwordtoOpen
the open password for the file which is encrypted . the modify password for the file which is protected .
passwordtoModify
openasReadOnly
whether to open the file as ReadOnly .
runFormulas
if true, this method will invoke RunAllFormulas method.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.ImportExcelFile Method (String)

Imports from an excel file.

public void ImportExcelFile(
string fileName
);

Example

[C#]
private void button1_Click(object sender, System.EventArgs e)
{
    gridDesktop1.ImportExcelFile("FinancialPlan.xls");
}

[Visual Basic]
Private Sub menuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles menuItem6.Click
    gridDesktop1.ImportExcelFile("FinancialPlan.xls")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.ImportExcelFile Method (String, Boolean)

Imports from an excel file.

public void ImportExcelFile(
string fileName,
bool runFormulas
);

Parameters

fileName
excel file name.
runFormulas
if true, this method will invoke RunAllFormulas method.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.ImportExcelFile Method (String, Int32)

Imports a worksheet from an excel file.

public void ImportExcelFile(
string fileName,
int sheetIndex
);

Parameters

fileName
excel file name.
sheetIndex
index of sheet to be imported.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.ImportExcelFile Method (String, String, String, Boolean, Boolean)

Imports from an excel file.

public void ImportExcelFile(
string fileName,
string passwordtoOpen,
string passwordtoModify,
bool openasReadOnly,
bool runFormulas
);

Parameters

fileName
excel file name.
passwordtoOpen
the open password for the file which is encrypted . the modify password for the file which is protected .
passwordtoModify
openasReadOnly
whether to open the file as ReadOnly .
runFormulas
if true, this method will invoke RunAllFormulas method.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace | GridDesktop.ImportExcelFile Overload List


GridDesktop.OpenFindReplaceDialog Method

Opens the FindReplace dialog to find or replace cells.

public void OpenFindReplaceDialog(
bool findMode
);

Parameters

findMode
If true, open the Find dialog; else open the Replace dialog.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.Paste Method

Pastes clipboard content to focused cell.

public void Paste();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.RefreshControl Method

Refresh the GridDesktop control.

public void RefreshControl();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.RunAllFormulas Method

Runs all the cells's formula.

public void RunAllFormulas();

Example

[C#]
gridDesktop1.Worksheets[0].Cells[0, 0].Value = "2";
gridDesktop1.Worksheets[0].Cells[1, 0].Value = "3";
gridDesktop1.Worksheets[0].Cells[2, 1].Value = "=a1*a2";
gridDesktop1.RunAllFormulas();
gridDesktop1.Invalidate();

[Visual Basic]
gridDesktop1.Worksheets(0).Cells(0, 0).Value = "2"
gridDesktop1.Worksheets(0).Cells(1, 0).Value = "3"
gridDesktop1.Worksheets(0).Cells(2, 1).Value = "=a1*a2"
gridDesktop1.RunAllFormulas()
gridDesktop1.Invalidate()

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.SetAllScrollBarsVisible Method

Sets all scrollbars visible.

public void SetAllScrollBarsVisible();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.ShowStyleDialog Method

Opens a style dialog,to set cells style,font,colors etc.

public void ShowStyleDialog();

Example

[C#]
gridDesktop1.ShowStyleDialog();

[Visual Basic]
gridDesktop1.ShowStyleDialog()

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.StartFormatPainter Method

Notifies GridDesktop to start FormatPainter.

public void StartFormatPainter(
bool formatOnce
);

Parameters

formatOnce
if formatOnce is true,FormatPainter can use once, if formatOnce is false,FormatPainter can use multi-times,until invokes EndFormatPainter().

Example

[C#]
gridDesktop1.StartFormatPainter(true);

[Visual Basic]
gridDesktop1.StartFormatPainter(True)

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.UnDoSplit Method

Unset Split view.

public void UnDoSplit();

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop Events

The events of the GridDesktop class are listed below. For a complete list of GridDesktop class members, see the GridDesktop Members topic.

Public Instance Events

AfterDeleteColumns | Occurs after column is deleted.
AfterDeleteRows | Occurs after row is deleted.
AfterInsertColumns | Occurs after new column is inserted.
AfterInsertRows | Occurs after new row is inserted.
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) |
BackColorChanged (inherited from Control) |
BackgroundImageChanged (inherited from Control) |
BackgroundImageLayoutChanged (inherited from Control) |
BeforeCalculate | Occurs when the grid workbook state is changed.
BeforeLoadFile | Occurs when the grid workbook state is changed.
BindingContextChanged (inherited from Control) |
CausesValidationChanged (inherited from Control) |
CellButtonClick | Occurs when the cell button clicked.
CellCheckedChanged | Occurs when the cell checkbox Checked property is changed.
CellClick | Occurs when the gridcell is clicked.
CellComboBoxCopy | Occurs when a grid cell ComboBox is being copied.
CellDataChanged | Occurs when the grid cell data property is changed.
CellDoubleClick | Occurs when the gridcell is double clicked.
CellFormatChanged | Occurs when the cell format is changed via Format Cells dialog box.
CellKeyPressed | Occurs when a key is pressed while a cell has focus.
CellSelectedIndexChanged | Occurs when the cell combobox SelectedIndex property has changed.
CellTextBoxChanging | Occurs when typing characters in a grid cell.
CellValidationFailed | Occurs when a grid cell validates failed.
ChangeUICues (inherited from Control) |
Click (inherited from Control) |
ClientSizeChanged (inherited from Control) |
ColumnHeaderClick | Occurs when the column header clicked.
ColumnHeaderDoubleClick | Occurs when the column header double clicked.
CommentDataChanged | Occurs when the comment data has changed.
ContextMenuChanged (inherited from Control) |
ContextMenuStripChanged (inherited from Control) |
ControlAdded (inherited from Control) |
ControlRemoved (inherited from Control) |
CursorChanged (inherited from Control) |
Disposed (inherited from Component) |
DockChanged (inherited from Control) |
DoubleClick (inherited from Control) |
DragDrop (inherited from Control) |
DragEnter (inherited from Control) |
DragLeave (inherited from Control) |
DragOver (inherited from Control) |
EnabledChanged (inherited from Control) |
Enter (inherited from Control) |
FinishCalculate | Occurs when the grid workbook state is changed.
FinishLoadFile | Occurs when the grid workbook state is changed.
FocusedCellChanged | Occurs when the focused cell is changed.
FontChanged (inherited from Control) |
ForeColorChanged (inherited from Control) |
GiveFeedback (inherited from Control) |
GotFocus (inherited from Control) |
HandleCreated (inherited from Control) |
HandleDestroyed (inherited from Control) |
HelpRequested (inherited from Control) |
ImeModeChanged (inherited from Control) |
Invalidated (inherited from Control) |
KeyDown (inherited from Control) |
KeyPress (inherited from Control) |
KeyUp (inherited from Control) |
Layout (inherited from Control) |
Leave (inherited from Control) |
Load (inherited from UserControl) |
LocationChanged (inherited from Control) |
LostFocus (inherited from Control) |
MarginChanged (inherited from Control) |
MouseCaptureChanged (inherited from Control) |
MouseClick (inherited from Control) |
MouseDoubleClick (inherited from Control) |
MouseDown (inherited from Control) |
MouseEnter (inherited from Control) |
MouseHover (inherited from Control) |
MouseLeave (inherited from Control) |
MouseMove (inherited from Control) |
MouseUp (inherited from Control) |
MouseWheel (inherited from Control) |
Move (inherited from Control) |
PaddingChanged (inherited from Control) |
Paint (inherited from Control) |
ParentChanged (inherited from Control) |
PreviewKeyDown (inherited from Control) |
QueryAccessibilityHelp (inherited from Control) |
QueryContinueDrag (inherited from Control) |
RegionChanged (inherited from Control) |
Resize (inherited from Control) |
RightToLeftChanged (inherited from Control) |
RowColumnHiddenChanged | Occurs when the row/column hide status changed.
RowFilteredEvent | Occurs after row filter item selected.
RowHeaderClick | Occurs when the row header clicked.
RowHeaderDoubleClick | Occurs when the row header double clicked.
Scroll (inherited from ScrollableControl) |
SelectedCellRangeChanged | Occurs when the selected cellrange is changed.
SelectedSheetIndexChanged | Occurs when the SelectedSheetIndex property is changed.
ShapeClick | Occurs when the shape is clicked.
SizeChanged (inherited from Control) |
StyleChanged (inherited from Control) |
SystemColorsChanged (inherited from Control) |
TabIndexChanged (inherited from Control) |
TabStopChanged (inherited from Control) |
TextChanged (inherited from UserControl) |
Validated (inherited from Control) |
Validating (inherited from Control) |
VisibleChanged (inherited from Control) |

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.AfterDeleteColumns Event

Occurs after column is deleted.

public event WorksheetEventHandler AfterDeleteColumns;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.AfterDeleteRows Event

Occurs after row is deleted.

public event WorksheetEventHandler AfterDeleteRows;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.AfterInsertColumns Event

Occurs after new column is inserted.

public event WorksheetEventHandler AfterInsertColumns;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.AfterInsertRows Event

Occurs after new row is inserted.

public event WorksheetEventHandler AfterInsertRows;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.BeforeCalculate Event

Occurs when the grid workbook state is changed.

public event WorkbookEventHandler BeforeCalculate;

Example

[C#]
private void gridDesktop1_BeforeCalculate(object sender, Aspose.Cells.GridDesktop.Event.WorkBookEvents e)
{
    MessageBox.Show("before calculate formula!");
}

[Visual Basic]
Private  Sub gridDesktop1_BeforeCalculate(ByVal sender As Object, ByVal e As Aspose.Cells.GridDesktop.Event.WorkBookEvents) Handles gridDesktop1.CellDataChanged
    MessageBox.Show("before calculate formula!")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.BeforeLoadFile Event

Occurs when the grid workbook state is changed.

public event WorkbookEventHandler BeforeLoadFile;

Example

[C#]
private void gridDesktop1_BeforeLoadFile(object sender, Aspose.Cells.GridDesktop.Event.WorkBookEvents e)
{
    MessageBox.Show("before load file!");
}

[Visual Basic]
Private  Sub gridDesktop1_BeforeLoadFile(ByVal sender As Object, ByVal e As Aspose.Cells.GridDesktop.Event.WorkBookEvents) Handles gridDesktop1.CellDataChanged
    MessageBox.Show("before load file!")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellButtonClick Event

Occurs when the cell button clicked.

public event CellControlEventHandler CellButtonClick;

Event Data

The event handler receives an argument of type CellControlEventArgs containing data related to this event. The following CellControlEventArgs properties provide information specific to this event.

Property | Description
Column | Gets column index of worksheet.
Row | Gets row index of worksheet.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellCheckedChanged Event

Occurs when the cell checkbox Checked property is changed.

public event CellControlEventHandler CellCheckedChanged;

Event Data

The event handler receives an argument of type CellControlEventArgs containing data related to this event. The following CellControlEventArgs properties provide information specific to this event.

Property | Description
Column | Gets column index of worksheet.
Row | Gets row index of worksheet.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellClick Event

Occurs when the gridcell is clicked.

public event CellEventHandler CellClick;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | Represents a grid cell.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellComboBoxCopy Event

Occurs when a grid cell ComboBox is being copied.

public event CellCopyComboBoxEventHandler CellComboBoxCopy;

Event Data

The event handler receives an argument of type CellCopyComboBoxEventArgs containing data related to this event. The following CellCopyComboBoxEventArgs properties provide information specific to this event.

Property | Description
Column | Gets column index of worksheet.
ComboBoxItems | Gets an object representing the collection of the items contained in this ComboBox.
comboBoxValues | Gets an object representing the collection of the values contained in this ComboBox.
Handled | Gets or sets the value indicating whether the event should be handled.
Row | Gets row index of worksheet.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellDataChanged Event

Occurs when the grid cell data property is changed.

public event CellEventHandler CellDataChanged;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | Represents a grid cell.

Example

[C#]
private void gridDesktop1_CellDataChanged(object sender, Aspose.Cells.GridDesktop.Event.CellEventArgs e)
{
    MessageBox.Show("Cell Data changed!");
}

[Visual Basic]
Private  Sub gridDesktop1_CellDataChanged(ByVal sender As Object, ByVal e As Aspose.Cells.GridDesktop.Event.CellEventArgs) Handles gridDesktop1.CellDataChanged
    MessageBox.Show("Cell Data changed!")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellDoubleClick Event

Occurs when the gridcell is double clicked.

public event CellEventHandler CellDoubleClick;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | Represents a grid cell.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellFormatChanged Event

Occurs when the cell format is changed via Format Cells dialog box.

public event CellFormatEventHandler CellFormatChanged;

Event Data

The event handler receives an argument of type CellFormatEventArgs containing data related to this event. The following CellFormatEventArgs properties provide information specific to this event.

Property | Description
Font | Gets the new font.
FontColor | Gets the new font color.
Sources | Gets the format sources, list of CellRange.
Style | Gets the new style.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellKeyPressed Event

Occurs when a key is pressed while a cell has focus.

public event CellKeyEventHandler CellKeyPressed;

Event Data

The event handler receives an argument of type CellKeyEventArgs containing data related to this event. The following CellKeyEventArgs properties provide information specific to this event.

Property | Description
Alt |
Column | Gets column index of worksheet.
Control |
Handled |
KeyCode |
KeyData |
KeyValue |
Modifiers |
Row | Gets row index of worksheet.
Shift |
SuppressKeyPress |

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellSelectedIndexChanged Event

Occurs when the cell combobox SelectedIndex property has changed.

public event CellComboBoxEventHandler CellSelectedIndexChanged;

Event Data

The event handler receives an argument of type CellComboBoxEventArgs containing data related to this event. The following CellComboBoxEventArgs properties provide information specific to this event.

Property | Description
Column | Gets column index of worksheet.
Handled | Gets or sets the value indicating whether the event should be handled.
NewValue | Gets the new value to be set.
Row | Gets row index of worksheet.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellTextBoxChanging Event

Occurs when typing characters in a grid cell.

public event EventHandler CellTextBoxChanging;

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CellValidationFailed Event

Occurs when a grid cell validates failed.

public event CellValidationEventHandler CellValidationFailed;

Event Data

The event handler receives an argument of type CellValidationEventArgs containing data related to this event. The following CellValidationEventArgs properties provide information specific to this event.

Property | Description
Cell | Represents a grid cell.
Handled | Gets or sets the value indicating whether the event should be handled.
NewValue | Gets the new value set to cell.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.ColumnHeaderClick Event

Occurs when the column header clicked.

public event WorksheetEventHandler ColumnHeaderClick;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.ColumnHeaderDoubleClick Event

Occurs when the column header double clicked.

public event WorksheetEventHandler ColumnHeaderDoubleClick;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.CommentDataChanged Event

Occurs when the comment data has changed.

public event CommentEventHandler CommentDataChanged;

Event Data

The event handler receives an argument of type CommentEventArgs containing data related to this event. The following CommentEventArgs properties provide information specific to this event.

Property | Description
Column | Gets column index.
NewText | Gets new text data of comment
OldText | Gets old text data of comment
Row | Gets row index.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.FinishCalculate Event

Occurs when the grid workbook state is changed.

public event WorkbookEventHandler FinishCalculate;

Example

[C#]
private void gridDesktop1_FinishCalculate(object sender, Aspose.Cells.GridDesktop.Event.WorkBookEvents e)
{
    MessageBox.Show("finish calculate formula!");
}

[Visual Basic]
Private  Sub gridDesktop1_FinishCalculate(ByVal sender As Object, ByVal e As Aspose.Cells.GridDesktop.Event.WorkBookEvents) Handles gridDesktop1.CellDataChanged
    MessageBox.Show("finish calculate formula!")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.FinishLoadFile Event

Occurs when the grid workbook state is changed.

public event WorkbookEventHandler FinishLoadFile;

Example

[C#]
private void gridDesktop1_FinishLoadFile(object sender, Aspose.Cells.GridDesktop.WorkBookEvents e)
{
    MessageBox.Show("finish load file!");
}

[Visual Basic]
Private  Sub gridDesktop1_FinishLoadFile(ByVal sender As Object, ByVal e As Aspose.Cells.GridDesktop.WorkBookEvents) Handles gridDesktop1.CellDataChanged
    MessageBox.Show("finish load file!")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.FocusedCellChanged Event

Occurs when the focused cell is changed.

public event CellEventHandler FocusedCellChanged;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | Represents a grid cell.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.RowColumnHiddenChanged Event

Occurs when the row/column hide status changed.

public event WorksheetEventHandler RowColumnHiddenChanged;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.RowFilteredEvent Event

Occurs after row filter item selected.

public event WorksheetEventHandler RowFilteredEvent;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.RowHeaderClick Event

Occurs when the row header clicked.

public event WorksheetEventHandler RowHeaderClick;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.RowHeaderDoubleClick Event

Occurs when the row header double clicked.

public event WorksheetEventHandler RowHeaderDoubleClick;

Event Data

The event handler receives an argument of type WorksheetEventArgs containing data related to this event. The following WorksheetEventArgs properties provide information specific to this event.

Property | Description
Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.SelectedCellRangeChanged Event

Occurs when the selected cellrange is changed.

public event CellRangeEventHandler SelectedCellRangeChanged;

Event Data

The event handler receives an argument of type CellRangeEventArgs containing data related to this event. The following CellRangeEventArgs property provides information specific to this event.

Property | Description
CellRange | Represents a cellrange object.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.SelectedSheetIndexChanged Event

Occurs when the SelectedSheetIndex property is changed.

public event EventHandler SelectedSheetIndexChanged;

Example

[C#]
private void gridDesktop1_SelectedSheetIndexChanged(object sender, System.EventArgs e)
{
    MessageBox.Show("selected index changed!");
}

[Visual Basic]
Private  Sub gridDesktop1_SelectedSheetIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles gridDesktop1.SelectedSheetIndexChanged
    MessageBox.Show("selected index changed!")
End Sub

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridDesktop.ShapeClick Event

Occurs when the shape is clicked.

public event CellEventHandler ShapeClick;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | Represents a grid cell.

See Also

GridDesktop Class | Aspose.Cells.GridDesktop Namespace


GridMemorySetting Enumeration

Aspose GridMemorySetting class Represents Memory Setting Preference For GridDesktop.

public enum GridMemorySetting

Members

Member Name | Description | Value
Normal | Default option. This option is applied for all versions. | 0
MemoryPreference | Optimized for memory usage. This option may degrade performance in some special cases and is applied since v 8.0.0. | 1

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


HorizontalAlignmentType Enumeration

Specifies how a gridcell is horizontally aligned.

public enum HorizontalAlignmentType

Members

Member Name | Description | Value
General | If object type is number,object is aligned on the right of the girdcell. If object type is string,object is aligned on the left of the girdcell. | 0
Left | The object or text is aligned on the left of the gridcell. | 1
Centred | The object or text is aligned in the center of the gridcell. | 2
Right | The object or text is aligned on the right of the gridcell. | 3
Filled | The object or text is Filled in the gridcell. | 4
Justified |  | 5
CentredAcross |  | 6
Distributed |  | 7

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


ICustomColumnCaption Interface

Interface for custom row caption.

For a list of all members of this type, see ICustomColumnCaption Members.

public interface ICustomColumnCaption

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

ICustomColumnCaption Members | Aspose.Cells.GridDesktop Namespace


ICustomColumnCaption Members

ICustomColumnCaption overview

Public Instance Methods

GetCaption get the custom column caption.

See Also

ICustomColumnCaption Interface | Aspose.Cells.GridDesktop Namespace


ICustomColumnCaption Methods

The methods of the ICustomColumnCaption interface are listed below. For a complete list of ICustomColumnCaption interface members, see the ICustomColumnCaption Members topic.

Public Instance Methods

GetCaption get the custom column caption.

See Also

ICustomColumnCaption Interface | Aspose.Cells.GridDesktop Namespace


ICustomColumnCaption.GetCaption Method

get the custom column caption.

string GetCaption(
int column
);

Parameters

column
column index.

Return Value

return the column caption.

See Also

ICustomColumnCaption Interface | Aspose.Cells.GridDesktop Namespace


ICustomRowCaption Interface

Interface for custom row caption.

For a list of all members of this type, see ICustomRowCaption Members.

public interface ICustomRowCaption

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

ICustomRowCaption Members | Aspose.Cells.GridDesktop Namespace


ICustomRowCaption Members

ICustomRowCaption overview

Public Instance Methods

GetCaption get the custom row caption.

See Also

ICustomRowCaption Interface | Aspose.Cells.GridDesktop Namespace


ICustomRowCaption Methods

The methods of the ICustomRowCaption interface are listed below. For a complete list of ICustomRowCaption interface members, see the ICustomRowCaption Members topic.

Public Instance Methods

GetCaption get the custom row caption.

See Also

ICustomRowCaption Interface | Aspose.Cells.GridDesktop Namespace


ICustomRowCaption.GetCaption Method

get the custom row caption.

string GetCaption(
int row
);

Parameters

row
Row index.

Return Value

return the row caption.

See Also

ICustomRowCaption Interface | Aspose.Cells.GridDesktop Namespace


ICustomValidation Interface

Interface of a gridcell's custom validation.

For a list of all members of this type, see ICustomValidation Members.

public interface ICustomValidation

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

ICustomValidation Members | Aspose.Cells.GridDesktop Namespace


ICustomValidation Members

ICustomValidation overview

Public Instance Methods

Validate Validate a gridcell's data is valid or not.

See Also

ICustomValidation Interface | Aspose.Cells.GridDesktop Namespace


ICustomValidation Methods

The methods of the ICustomValidation interface are listed below. For a complete list of ICustomValidation interface members, see the ICustomValidation Members topic.

Public Instance Methods

Validate Validate a gridcell's data is valid or not.

See Also

ICustomValidation Interface | Aspose.Cells.GridDesktop Namespace


ICustomValidation.Validate Method

Validate a gridcell's data is valid or not.

bool Validate(
Worksheet worksheet,
int row,
int col,
object value
);

Parameters

worksheet
Worksheet object.
row
Row index.
col
Column index.
value
Value to be validated.

Return Value

True is valid, false is invalid.

See Also

ICustomValidation Interface | Aspose.Cells.GridDesktop Namespace


License Class

For a list of all members of this type, see License Members.

System.Object
Aspose.Cells.GridDesktop.License

public class License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

License Members | Aspose.Cells.GridDesktop Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of the License class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) |

See Also

License Class | Aspose.Cells.GridDesktop Namespace


License Constructor

Initializes a new instance of the License class.

public License();

See Also

License Class | Aspose.Cells.GridDesktop Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) |

See Also

License Class | Aspose.Cells.GridDesktop Namespace


SetLicense Method

Aspose.Cells for .NET

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Cells.GridDesktop Namespace


License.SetLicense Method (Stream)

Licenses the component.

public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

[C#]

License license = new License();
license.SetLicense(myStream);

[Visual Basic]

Dim license as License = new License
license.SetLicense(myStream)

See Also

License Class | Aspose.Cells.GridDesktop Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

public void SetLicense(
string licenseName
);

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder that contains the Aspose component assembly.

3. The folder that contains the client's calling assembly.

4. The folder that contains the entry (startup) assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.

See Also

License Class | Aspose.Cells.GridDesktop Namespace | License.SetLicense Overload List


RowColumnEventArgs Class

Provides data for row/column events.

For a list of all members of this type, see RowColumnEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.RowColumnEventArgs

public class RowColumnEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

RowColumnEventArgs Members | Aspose.Cells.GridDesktop Namespace


RowColumnEventArgs Members

RowColumnEventArgs overview

Public Instance Properties

Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RejectOperation | Call this method in RowDeleting/ColumnDeleting event handlers to cancel the deleting operations.
ToString (inherited from Object) |

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


RowColumnEventArgs Properties

The properties of the RowColumnEventArgs class are listed below. For a complete list of RowColumnEventArgs class members, see the RowColumnEventArgs Members topic.

Public Instance Properties

Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


Argument Property

Aspose.Cells for .NET

RowColumnEventArgs.Argument Property

The argument of the event.

public object Argument {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


IsCancel Property

Aspose.Cells for .NET

RowColumnEventArgs.IsCancel Property

shall we cancel the operation.

public bool IsCancel {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


Num Property

Aspose.Cells for .NET

RowColumnEventArgs.Num Property

The row or column number, starts from zero.

public int Num {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


Type Property

Aspose.Cells for .NET

RowColumnEventArgs.Type Property

The row or column type.

public RowColumnType Type {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


RowColumnEventArgs Methods

The methods of the RowColumnEventArgs class are listed below. For a complete list of RowColumnEventArgs class members, see the RowColumnEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RejectOperation | Call this method in RowDeleting/ColumnDeleting event handlers to cancel the deleting operations.
ToString (inherited from Object) |

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


RowColumnEventArgs.RejectOperation Method

Call this method in RowDeleting/ColumnDeleting event handlers to cancel the deleting operations.

public void RejectOperation();

See Also

RowColumnEventArgs Class | Aspose.Cells.GridDesktop Namespace


RowColumnType Enumeration

Represents the row/column type of the row/column events.

public enum RowColumnType

Members

Member Name | Description | Value
Row | Row type. | 0
Column | Column type. | 1

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


RowFilterSettings Class

Summary description for RowFilter.

For a list of all members of this type, see RowFilterSettings Members.

System.Object
Aspose.Cells.GridDesktop.RowFilterSettings

public class RowFilterSettings : IComparer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

RowFilterSettings Members | Aspose.Cells.GridDesktop Namespace


RowFilterSettings Members

RowFilterSettings overview

Public Instance Properties

Criteria | The filter criteria string.
EnableAutoFilter | Enables auto filtering. The HeaderRow will display dropdown buttons to let user select the column's value to be filtered.
EndCol | The end col number of the filter range.
HeaderRow | The header row number which will display filter dropdown buttons.
StartCol | The start col number of the filter range.

Public Instance Methods

Compare | internal uses only.
CustomRows | Overloaded. Filters a list with a custom criteria.
Equals (inherited from Object) |
FilterRows | Filters rows using criteria string.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ShowAll | Unhide all rows.
ToString (inherited from Object) |

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


RowFilterSettings Properties

The properties of the RowFilterSettings class are listed below. For a complete list of RowFilterSettings class members, see the RowFilterSettings Members topic.

Public Instance Properties

Criteria | The filter criteria string.
EnableAutoFilter | Enables auto filtering. The HeaderRow will display dropdown buttons to let user select the column's value to be filtered.
EndCol | The end col number of the filter range.
HeaderRow | The header row number which will display filter dropdown buttons.
StartCol | The start col number of the filter range.

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


Criteria Property

Aspose.Cells for .NET

RowFilterSettings.Criteria Property

The filter criteria string.

public string Criteria {get; set;}

Remarks

The filter criteria string. below are the criteria string examples: CELL0 = 12.3 CELL1 = "ABC" AND(CELL0 = 123, CELL1 = "ABC") OR(CELL0 = 123, CELL1 = "ABC") CELL0 = B1 + 4

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


EnableAutoFilter Property

Aspose.Cells for .NET

RowFilterSettings.EnableAutoFilter Property

Enables auto filtering. The HeaderRow will display dropdown buttons to let user select the column's value to be filtered.

public bool EnableAutoFilter {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


EndCol Property

Aspose.Cells for .NET

RowFilterSettings.EndCol Property

The end col number of the filter range.

public int EndCol {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


HeaderRow Property

Aspose.Cells for .NET

RowFilterSettings.HeaderRow Property

The header row number which will display filter dropdown buttons.

public int HeaderRow {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


StartCol Property

Aspose.Cells for .NET

RowFilterSettings.StartCol Property

The start col number of the filter range.

public int StartCol {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


RowFilterSettings Methods

The methods of the RowFilterSettings class are listed below. For a complete list of RowFilterSettings class members, see the RowFilterSettings Members topic.

Public Instance Methods

Compare | internal uses only.
CustomRows | Overloaded. Filters a list with a custom criteria.
Equals (inherited from Object) |
FilterRows | Filters rows using criteria string.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ShowAll | Unhide all rows.
ToString (inherited from Object) |

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


RowFilterSettings.Compare Method

internal uses only.

public int Compare(
object a,
object b
);

Parameters

a
b

Return Value

Implements

IComparer.Compare

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


CustomRows Method

Aspose.Cells for .NET

RowFilterSettings.CustomRows Method

Filters a list with a custom criteria.

Overload List

Filters a list with a custom criteria.

public void CustomRows(int,GridFilterOperatorType,object);

Filters a list with a custom criteria.

public void CustomRows(int,GridFilterOperatorType,object,bool,GridFilterOperatorType,object);

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


RowFilterSettings.CustomRows Method (Int32, GridFilterOperatorType, Object)

Filters a list with a custom criteria.

public void CustomRows(
int column,
GridFilterOperatorType operatorType1,
object criteria1
);

Parameters

column
The column of the worksheet
operatorType1
The filter operator type
criteria1
The custom criteria

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace | RowFilterSettings.CustomRows Overload List


RowFilterSettings.CustomRows Method (Int32, GridFilterOperatorType, Object, Boolean, GridFilterOperatorType, Object)

Filters a list with a custom criteria.

public void CustomRows(
int column,
GridFilterOperatorType operatorType1,
object criteria1,
bool isAnd,
GridFilterOperatorType operatorType2,
object criteria2
);

Parameters

column
The column of the worksheet
operatorType1
The filter operator type
criteria1
The custom criteria
isAnd
operatorType2
The filter operator type
criteria2
The custom criteria

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace | RowFilterSettings.CustomRows Overload List


RowFilterSettings.FilterRows Method

Filters rows using criteria string.

public void FilterRows(
int column,
string criteria
);

Parameters

column
The column of the worksheet
criteria
The specified criteria (a string; for example, "101").

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


RowFilterSettings.ShowAll Method

Unhide all rows.

public void ShowAll();

See Also

RowFilterSettings Class | Aspose.Cells.GridDesktop Namespace


Shape Class

Represents a shape object.

For a list of all members of this type, see Shape Members.

System.Object
Aspose.Cells.GridDesktop.Shape

public class Shape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Shape Members | Aspose.Cells.GridDesktop Namespace


Shape Members

Shape overview

Public Instance Fields

_withinCell

Public Instance Properties

ActualHeight |
ActualWidth |
Column |
Image |
ImageFormat | Gets the image format of the picture.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftOffset | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftToCorner |
MsoDrawingType | Gets and sets mso drawing type.
Name | Gets and sets the name of the shape.
Row |
Text | Represents the string in this TextBox object.
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopOffset | Represents the vertical offset of shape from its top row, in unit of pixels.
TopToCorner |
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
ZOrderPosition | Returns the position of a shape in the z-order.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Shape Fields

The fields of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Fields

_withinCell

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Shape._withinCell Field

public bool _withinCell;

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Shape Properties

The properties of the Shape class are listed below. For a complete list of Shape class members, see the Shape Members topic.

Public Instance Properties

ActualHeight |
ActualWidth |
Column |
Image |
ImageFormat | Gets the image format of the picture.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftOffset | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftToCorner |
MsoDrawingType | Gets and sets mso drawing type.
Name | Gets and sets the name of the shape.
Row |
Text | Represents the string in this TextBox object.
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopOffset | Represents the vertical offset of shape from its top row, in unit of pixels.
TopToCorner |
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
ZOrderPosition | Returns the position of a shape in the z-order.

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


ActualHeight Property

Aspose.Cells for .NET

Shape.ActualHeight Property

public int ActualHeight {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


ActualWidth Property

Aspose.Cells for .NET

Shape.ActualWidth Property

public int ActualWidth {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Column Property

Aspose.Cells for .NET

Shape.Column Property

public int Column {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Image Property

Aspose.Cells for .NET

Shape.Image Property

public Image Image {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


ImageFormat Property

Aspose.Cells for .NET

Shape.ImageFormat Property

Gets the image format of the picture.

public ImageFormat ImageFormat {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Left Property

Aspose.Cells for .NET

Shape.Left Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int Left {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


LeftOffset Property

Aspose.Cells for .NET

Shape.LeftOffset Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int LeftOffset {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


LeftToCorner Property

Aspose.Cells for .NET

Shape.LeftToCorner Property

public int LeftToCorner {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


MsoDrawingType Property

Aspose.Cells for .NET

Shape.MsoDrawingType Property

Gets and sets mso drawing type.

public GridMsoDrawingType MsoDrawingType {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Name Property

Aspose.Cells for .NET

Shape.Name Property

Gets and sets the name of the shape.

public string Name {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Row Property

Aspose.Cells for .NET

Shape.Row Property

public int Row {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Text Property

Aspose.Cells for .NET

Shape.Text Property

Represents the string in this TextBox object.

public string Text {get; set;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


Top Property

Aspose.Cells for .NET

Shape.Top Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int Top {get;}

Remarks

If the shape is in the chart, represents the vertical offset of shape from its top border.

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


TopOffset Property

Aspose.Cells for .NET

Shape.TopOffset Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int TopOffset {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


TopToCorner Property

Aspose.Cells for .NET

Shape.TopToCorner Property

public int TopToCorner {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


UpperLeftColumn Property

Aspose.Cells for .NET

Shape.UpperLeftColumn Property

Represents upper left corner column index.

public int UpperLeftColumn {get;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


UpperLeftRow Property

Aspose.Cells for .NET

Shape.UpperLeftRow Property

Represents upper left corner row index.

public int UpperLeftRow {get;}

Remarks

If the shape is in the shape or in the group , UpperLeftRow will be ignored.

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


ZOrderPosition Property

Aspose.Cells for .NET

Shape.ZOrderPosition Property

Returns the position of a shape in the z-order.

public int ZOrderPosition {get; set;}

See Also

Shape Class | Aspose.Cells.GridDesktop Namespace


SortOrder Enumeration

Represents what order the data sort by.

public enum SortOrder

Members

Member Name | Description | Value
Ascending | Sorts by ascending | 1
Descending | Sorts by descending | 2

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


SortOrientation Enumeration

Represents sorting orientation

public enum SortOrientation

Remarks

SortOrientation.SortTopToBottom represents sorting datas from top to bottom and exchanging data row by row. SortOrientation.SortLeftToRight represents sorting datas from left to right and exchanging data column by column.

Members

Member Name | Description | Value
SortTopToBottom | Represents sorting datas from top to bottom and exchanging data row by row. | 1
SortLeftToRight | Represents sorting datas from left to right and exchanging data column by column. | 2

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


SortRange Class

Indicates a range of a Worksheet and provide method to sort the range datas by row or column.

For a list of all members of this type, see SortRange Members.

System.Object
Aspose.Cells.GridDesktop.SortRange

public class SortRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

SortRange Members | Aspose.Cells.GridDesktop Namespace


SortRange Members

SortRange overview

Public Instance Constructors

SortRange Constructor Intializes a new instance of the SortRange class by specifing a worksheet range and sort orientation.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Sort | Overloaded. Sorts the datas ascend in the range by index.
ToString (inherited from Object) |

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace


SortRange Constructor

Intializes a new instance of the SortRange class by specifing a worksheet range and sort orientation.

public SortRange(
Worksheet worksheet,
int startRow,
int startColumn,
int rows,
int columns,
SortOrientation orientation,
bool isCaseSensitive
);

Parameters

worksheet
The Worksheet that contains the range.
startRow
The start row of the range.
startColumn
The start column of the range.
rows
The number of the rows.
columns
The number of the columns
orientation
The sort orientation: top to bottom or left to right.
isCaseSensitive
Determines whether the sort datas is case sensitive if datas are string

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace


SortRange Methods

The methods of the SortRange class are listed below. For a complete list of SortRange class members, see the SortRange Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Sort | Overloaded. Sorts the datas ascend in the range by index.
ToString (inherited from Object) |

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace


Sort Method

Aspose.Cells for .NET

SortRange.Sort Method

Sorts the datas ascend in the range by index.

Overload List

Sorts the datas ascend in the range by index.

public void Sort(int);

Sorts the datas in the range by index.

public void Sort(int,SortOrder);

Sorts the datas ascend in the range by some field that are specifed by array indexes.

public void Sort(int[]);

Sorts the datas in the range by some field that are specifed by array indexes.

public void Sort(int[],SortOrder[]);

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace


SortRange.Sort Method (Int32)

Sorts the datas ascend in the range by index.

public void Sort(
int index
);

Parameters

index
The column(or row) index that specifis the sort column(or row). If sort orientation is top to bottom, the index represents column index. If sort orientation is left to right, the index represents row index.

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace | SortRange.Sort Overload List


SortRange.Sort Method (Int32, SortOrder)

Sorts the datas in the range by index.

public void Sort(
int index,
SortOrder order
);

Parameters

index
The column(or row) index that specifis the sort column(or row). If sort orientation is top to bottom, the index represents column index. If sort orientation is left to right, the index represents row index.
order
The sort order

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace | SortRange.Sort Overload List


SortRange.Sort Method (Int32[])

Sorts the datas ascend in the range by some field that are specifed by array indexes.

public void Sort(
int[] indexes
);

Parameters

indexes
The index array that specifies the data sorted by.

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace | SortRange.Sort Overload List


SortRange.Sort Method (Int32[], SortOrder[])

Sorts the datas in the range by some field that are specifed by array indexes.

public void Sort(
int[] indexes,
SortOrder[] orders
);

Parameters

indexes
The index array that specifies the data sorted by.
orders
The sort order array

See Also

SortRange Class | Aspose.Cells.GridDesktop Namespace | SortRange.Sort Overload List


Style Class

For a list of all members of this type, see Style Members.

System.Object
Aspose.Cells.GridDesktop.Style

public class Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Style Members | Aspose.Cells.GridDesktop Namespace


Style Members

Style overview

Public Instance Constructors

Style Constructor

Public Instance Properties

BackgroundColor | Gets or sets the cell background color,if style pattern is not set to solid,then it will take affect
CellLocked |
Color | Gets or sets the cell shading color. when pattern is none ,it return Color.Empty; when pattern is BackgroundType.Solid,it return ForegroundColor; others it return BackgroundColor
Custom |
ForegroundColor | Gets or sets a style's foreground color.
HAlignment | Gets or sets horizontal alignment attribute.
Indent | Represents the m_IndentLevel level for the cell or range. Can only be an integer from 0 to 15.
NumberFormat | Gets or sets the display format of numbers and dates.
NumberType | same as NumberFormat
Pattern | Gets or sets the cell background pattern type.
Rotation | Represents text rotation angle.
Shrink |
TextDirection | Gets or sets text direction attribute.
TextWrapped | Gets or sets a value indicating whether the text within a cell is wrapped.
VAlignment | Gets or sets vertical alignment attribute.

Public Instance Methods

Clone | Creates and returns a copy of this object. NOTE:If you clone a named style, name is not cloned becaule style name must be unique. Therefore, the cloned style will not "equals to" the original style.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetBorderColor | Sets the color of the specified border.
SetBorderLine | Sets the border line type of the specified border.
ToString (inherited from Object) |

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Style Constructor

public Style(
GridDesktop gridDesktop
);

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Style Properties

The properties of the Style class are listed below. For a complete list of Style class members, see the Style Members topic.

Public Instance Properties

BackgroundColor | Gets or sets the cell background color,if style pattern is not set to solid,then it will take affect
CellLocked |
Color | Gets or sets the cell shading color. when pattern is none ,it return Color.Empty; when pattern is BackgroundType.Solid,it return ForegroundColor; others it return BackgroundColor
Custom |
ForegroundColor | Gets or sets a style's foreground color.
HAlignment | Gets or sets horizontal alignment attribute.
Indent | Represents the m_IndentLevel level for the cell or range. Can only be an integer from 0 to 15.
NumberFormat | Gets or sets the display format of numbers and dates.
NumberType | same as NumberFormat
Pattern | Gets or sets the cell background pattern type.
Rotation | Represents text rotation angle.
Shrink |
TextDirection | Gets or sets text direction attribute.
TextWrapped | Gets or sets a value indicating whether the text within a cell is wrapped.
VAlignment | Gets or sets vertical alignment attribute.

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


BackgroundColor Property

Aspose.Cells for .NET

Style.BackgroundColor Property

Gets or sets the cell background color,if style pattern is not set to solid,then it will take affect

public Color BackgroundColor {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


CellLocked Property

Aspose.Cells for .NET

Style.CellLocked Property

public bool CellLocked {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Color Property

Aspose.Cells for .NET

Style.Color Property

Gets or sets the cell shading color. when pattern is none ,it return Color.Empty; when pattern is BackgroundType.Solid,it return ForegroundColor; others it return BackgroundColor

public Color Color {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Custom Property

Aspose.Cells for .NET

Style.Custom Property

public string Custom {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


ForegroundColor Property

Aspose.Cells for .NET

Style.ForegroundColor Property

Gets or sets a style's foreground color.

public Color ForegroundColor {get; set;}

Remarks

It means no color setting if Color.Empty is returned.

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


HAlignment Property

Aspose.Cells for .NET

Style.HAlignment Property

Gets or sets horizontal alignment attribute.

public HorizontalAlignmentType HAlignment {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Indent Property

Aspose.Cells for .NET

Style.Indent Property

Represents the m_IndentLevel level for the cell or range. Can only be an integer from 0 to 15.

public int Indent {get; set;}

Remarks

If text horizontal alignment type is set to value other than left or right, m_IndentLevel level will be reset to zero.

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


NumberFormat Property

Aspose.Cells for .NET

Style.NumberFormat Property

Gets or sets the display format of numbers and dates.

public int NumberFormat {get; set;}

Remarks

Value | Type | Format String
0 | General | General
1 | Decimal | 0
2 | Decimal | 0.00
3 | Decimal | #,##0
4 | Decimal | #,##0.00
5 | Currency | $#,##0;($#,##0)
6 | Currency | $#,##0;[Red]($#,##0)
7 | Currency | $#,##0.00;($#,##0.00)
8 | Currency | $#,##0.00;[Red]($#,##0.00)
9 | Percentage | 0%
10 | Percentage | 0.00%
11 | Scientific | 0.00E+00
12 | Fraction | # ?/?
13 | Fraction | # ??/??
14 | Date | m/d/yyyy
15 | Date | d-mmm-yy
16 | Date | d-mmm
17 | Date | mmm-yy
18 | Time | h:mm AM/PM
19 | Time | h:mm:ss AM/PM
20 | Time | h:mm
21 | Time | h:mm:ss
22 | Time | m/d/yyyy h:mm
37 | Accounting | #,##0;(#,##0)
38 | Accounting | #,##0;[Red](#,##0)
39 | Accounting | #,##0.00;(#,##0.00)
40 | Accounting | #,##0.00;[Red](#,##0.00)
41 | Accounting | _ * #,##0_ ;_ * (#,##0)_ ;_ * "-"_ ;_ @_
42 | Currency | _ $* #,##0_ ;_ $* (#,##0)_ ;_ $* "-"_ ;_ @_
43 | Accounting | _ * #,##0.00_ ;_ * (#,##0.00)_ ;_ * "-"??_ ;_ @_
44 | Currency | _ $* #,##0.00_ ;_ $* (#,##0.00)_ ;_ $* "-"??_ ;_ @_
45 | Time | mm:ss
46 | Time | [h]:mm:ss
47 | Time | mm:ss.0
48 | Scientific | ##0.0E+00
49 | Text | @

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


NumberType Property

Aspose.Cells for .NET

Style.NumberType Property

same as NumberFormat

public int NumberType {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Pattern Property

Aspose.Cells for .NET

Style.Pattern Property

Gets or sets the cell background pattern type.

public GridBackgroundType Pattern {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Rotation Property

Aspose.Cells for .NET

Style.Rotation Property

Represents text rotation angle.

public int Rotation {get; set;}

Remarks

0: Not rotated.

255: Top to Bottom.

-90: Downward.

90: Upward.

You can set 255 or value ranged from -90 to 90.

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Shrink Property

Aspose.Cells for .NET

Style.Shrink Property

public bool Shrink {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


TextDirection Property

Aspose.Cells for .NET

Style.TextDirection Property

Gets or sets text direction attribute.

public TextDirectionType TextDirection {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


TextWrapped Property

Aspose.Cells for .NET

Style.TextWrapped Property

Gets or sets a value indicating whether the text within a cell is wrapped.

public bool TextWrapped {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


VAlignment Property

Aspose.Cells for .NET

Style.VAlignment Property

Gets or sets vertical alignment attribute.

public VerticalAlignmentType VAlignment {get; set;}

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Style Methods

The methods of the Style class are listed below. For a complete list of Style class members, see the Style Members topic.

Public Instance Methods

Clone | Creates and returns a copy of this object. NOTE:If you clone a named style, name is not cloned becaule style name must be unique. Therefore, the cloned style will not "equals to" the original style.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetBorderColor | Sets the color of the specified border.
SetBorderLine | Sets the border line type of the specified border.
ToString (inherited from Object) |

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Style.Clone Method

Creates and returns a copy of this object. NOTE:If you clone a named style, name is not cloned becaule style name must be unique. Therefore, the cloned style will not "equals to" the original style.

public Style Clone();

Return Value

Return a new Style object.

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Style.SetBorderColor Method

Sets the color of the specified border.

public void SetBorderColor(
BorderType borderType,
Color colorvalue
);

Parameters

borderType
borderType which border to set.
colorvalue

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


Style.SetBorderLine Method

Sets the border line type of the specified border.

public void SetBorderLine(
BorderType borderType,
BorderLineType borderLineType
);

Parameters

borderType
borderType which border to set.
borderLineType
borderLineType border line type of the specified border.

See Also

Style Class | Aspose.Cells.GridDesktop Namespace


TextDirectionType Enumeration

public enum TextDirectionType

Members

Member Name | Description | Value
Context |  | 0
LeftToRight |  | 1
RightToLeft |  | 2

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


ThemeColor Class

Represents a theme color.

For a list of all members of this type, see ThemeColor Members.

System.Object
Aspose.Cells.GridDesktop.ThemeColor

public class ThemeColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

ThemeColor Members | Aspose.Cells.GridDesktop Namespace


ThemeColor Members

ThemeColor overview

Public Instance Constructors

ThemeColor Constructor

Public Instance Properties

ColorType | Gets and sets the theme type.
Tint | Gets and sets the tint value. The tint value is stored as a double from -1.0 .. 1.0, where -1.0 means 100% darken and 1.0 means 100% lighten. Also, 0.0 means no change.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ThemeColor Class | Aspose.Cells.GridDesktop Namespace


ThemeColor Constructor

public ThemeColor(
ThemeColorType type,
double tint
);

Parameters

type
The theme type.
tint
The tint value.

See Also

ThemeColor Class | Aspose.Cells.GridDesktop Namespace


ThemeColor Properties

The properties of the ThemeColor class are listed below. For a complete list of ThemeColor class members, see the ThemeColor Members topic.

Public Instance Properties

ColorType | Gets and sets the theme type.
Tint | Gets and sets the tint value. The tint value is stored as a double from -1.0 .. 1.0, where -1.0 means 100% darken and 1.0 means 100% lighten. Also, 0.0 means no change.

See Also

ThemeColor Class | Aspose.Cells.GridDesktop Namespace


ColorType Property

Aspose.Cells for .NET

ThemeColor.ColorType Property

Gets and sets the theme type.

public ThemeColorType ColorType {get; set;}

See Also

ThemeColor Class | Aspose.Cells.GridDesktop Namespace


Tint Property

Aspose.Cells for .NET

ThemeColor.Tint Property

Gets and sets the tint value. The tint value is stored as a double from -1.0 .. 1.0, where -1.0 means 100% darken and 1.0 means 100% lighten. Also, 0.0 means no change.

public double Tint {get; set;}

See Also

ThemeColor Class | Aspose.Cells.GridDesktop Namespace


ThemeColorType Enumeration

Enumerates the theme color types.

public enum ThemeColorType

Members

Member Name | Description | Value
Background1 |  | 0
Text1 |  | 1
Background2 |  | 2
Text2 |  | 3
Accent1 |  | 4
Accent2 |  | 5
Accent3 |  | 6
Accent4 |  | 7
Accent5 |  | 8
Accent6 |  | 9
Hyperlink |  | 10
FollowedHyperlink |  | 11

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


UndoManager Class

Encapsulates the object that manages the undo/redo operations.

For a list of all members of this type, see UndoManager Members.

System.Object
Aspose.Cells.GridDesktop.UndoManager

public class UndoManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

UndoManager Members | Aspose.Cells.GridDesktop Namespace


UndoManager Members

UndoManager overview

Public Instance Properties

Enabled | Gets or sets a value indicating whether the Undo function is enabled. The default value is false.
RedoStepsCount | Gets the current available redo steps count.
UndoStackSize | Gets or sets the undo/redo stack size. The default value is 300.
UndoStepsCount | Gets the current available undo steps count.

Public Instance Methods

BeginChanges | Begins to record changes.
BeginMark | Begins to mark changes.
ClearStack | Clears the Undo and Redo stacks.
EndChanges | Ends to record changes.
EndMark | Ends to mark changes.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Redo | Performs a redo operation.
RedoMark | Performs a redo operation with mark.
ToString (inherited from Object) |
Undo | Performs an undo operation.
UndoMark | Performs an undo operation with mark.

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager Properties

The properties of the UndoManager class are listed below. For a complete list of UndoManager class members, see the UndoManager Members topic.

Public Instance Properties

Enabled | Gets or sets a value indicating whether the Undo function is enabled. The default value is false.
RedoStepsCount | Gets the current available redo steps count.
UndoStackSize | Gets or sets the undo/redo stack size. The default value is 300.
UndoStepsCount | Gets the current available undo steps count.

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


Enabled Property

Aspose.Cells for .NET

UndoManager.Enabled Property

Gets or sets a value indicating whether the Undo function is enabled. The default value is false.

public bool Enabled {get; set;}

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


RedoStepsCount Property

Aspose.Cells for .NET

UndoManager.RedoStepsCount Property

Gets the current available redo steps count.

public int RedoStepsCount {get;}

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoStackSize Property

Aspose.Cells for .NET

UndoManager.UndoStackSize Property

Gets or sets the undo/redo stack size. The default value is 300.

public int UndoStackSize {get; set;}

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoStepsCount Property

Aspose.Cells for .NET

UndoManager.UndoStepsCount Property

Gets the current available undo steps count.

public int UndoStepsCount {get;}

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager Methods

The methods of the UndoManager class are listed below. For a complete list of UndoManager class members, see the UndoManager Members topic.

Public Instance Methods

BeginChanges | Begins to record changes.
BeginMark | Begins to mark changes.
ClearStack | Clears the Undo and Redo stacks.
EndChanges | Ends to record changes.
EndMark | Ends to mark changes.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Redo | Performs a redo operation.
RedoMark | Performs a redo operation with mark.
ToString (inherited from Object) |
Undo | Performs an undo operation.
UndoMark | Performs an undo operation with mark.

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.BeginChanges Method

Begins to record changes.

public void BeginChanges();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.BeginMark Method

Begins to mark changes.

public void BeginMark();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.ClearStack Method

Clears the Undo and Redo stacks.

public void ClearStack();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.EndChanges Method

Ends to record changes.

public void EndChanges();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.EndMark Method

Ends to mark changes.

public void EndMark();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.Redo Method

Performs a redo operation.

public void Redo();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.RedoMark Method

Performs a redo operation with mark.

public void RedoMark();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.Undo Method

Performs an undo operation.

public void Undo();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


UndoManager.UndoMark Method

Performs an undo operation with mark.

public void UndoMark();

See Also

UndoManager Class | Aspose.Cells.GridDesktop Namespace


VerticalAlignmentType Enumeration

Specifies how a gridcell is vertically aligned.

public enum VerticalAlignmentType

Members

Member Name | Description | Value
Top | The object or text is aligned on the top of the gridcell. | 0
Centred | The object or text is aligned in the center of the gridcell. | 1
Bottom | The object or text is aligned on the bottom of the gridcell. | 2
Justified |  | 3
Distributed |  | 4

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


WorkbookEventHandler Delegate

Represents the method that intend to handle workbook events.

public delegate void WorkbookEventHandler(
object sender,
WorkBookEvents args
);

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


WorkBookEvents Enumeration

WorkBook Events category.

public enum WorkBookEvents

Members

Member Name | Description | Value
BeforeLoad | before load workbook. | 0
LoadFinish | finish load workbook. | 1
BeforeCalculate | before calculate formula. | 2
CalculateFinish | finish calculate formula. | 3
CalculatePivotStyleFinish | finish calculate style for pivot table . | 4

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


Worksheet Class

For a list of all members of this type, see Worksheet Members.

System.Object
Aspose.Cells.GridDesktop.Worksheet

public class Worksheet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Worksheet Members | Aspose.Cells.GridDesktop Namespace


Worksheet Members

Worksheet overview

Public Static Fields

DEFAULT_COLUMNSCOUNT | Default columns count of worksheet.
DEFAULT_ROWSCOUNT | Default rows count of worksheet.

Public Static Methods

CellIndexToR1C1 Gets cell r1c1 style name according to its row and column indexes.

Public Instance Properties

ActiveCell |
AllowSelectingLockedCell | Represents if the user is allowed to select locked cells on a protected worksheet.
BackgroundImage | Gets and sets worksheet background image.
Cells |
CodeName | Represents worksheet code name.
Columns |
ColumnsCount |
Comments |
Controls | Gets the cell control collection.
CustomColumnCaption | Gets or sets the custom column caption for the worksheet.
CustomRowCaption | Gets or sets the custom row caption for the worksheet.
DataMember | Gets the data source that the Worksheet object is displaying data for.
DataSource | Gets the specific list in a DataSource for Worksheet object.
DisplayRightToLeft |
DisplayZeros | True if zero values are displayed.
FirstVisibleColumn |
FirstVisibleRow | Represents first visible row index.
FrozenCols | Gets or sets Worksheet's frozen column count. Frozen will start at first column.
FrozenRows | Gets or sets Worksheet's frozen row count. Frozen will start at first row.
GridDesktop | Gets Sheet's GridDesktop object.
GridlinesVisible | Gets or sets a value indicating whether the gridelines are visible.Default is true.
Hyperlinks | Gets the HyperlinkCollection collection.
Index | Gets the index of sheet in the worksheets collection.
IsVeryHidden | Indicates wether the sheet is hidden and cannot be shown in the user interface (UI).
IsVisible |
MergesCount | Gets the count of the merges
Name | Gets or sets the name of the worksheet.
OutlineShown | Indicates whether show outline.
Pictures | Gets a Pictures collection.
PivotTables | Gets the pivotTables in the worksheet.
Protected |
RowFilter | Gets the RowFilterSettings object of the sheet.
Rows |
RowsCount |
Selected | Indicates whether this worksheet is selected when the workbook is opened.
Shapes | Gets a Pictures collection.
ShowGridlines |
TabColor | Represents worksheet tab color.
Validations | Gets the data validation setting collection in the worksheet.
Visible | Represents if the worksheet is visible.
Workbook |
Zoom | Represents the scaling factor in percent. It should be between 10 and 400.

Public Instance Methods

AddAutoFilter | Sets the range to which the specified AutoFilter applies.
AddColumn | Adds a new column.
AddCustomFilter | Overloaded. Add custom filter for the specified row range from start row to end row.
AddRow | Adds a new row.
AddSelectedRange | Add a new selected range to the worksheet.
AutoFitColumn | Overloaded. Autofits the column width.
AutoFitColumns | Overloaded. Autofits all columns in this worksheet.
AutoFitRow | Overloaded. Autofits the row height.
AutoFitRows | Overloaded. Autofits all rows in this worksheet.
AutoFitRowsMerged | Autofits all rows in this worksheet.It will also auto fit row height when the cells is merged in a row.
CalculateFormula | Calculates a formula.
CellInMerged | Gets a value whether the specified cell location is in merges.
CellRangeInMerge | Gets a value that indicates whether the specified cell range in merges.
ClearComments | Clears all comments in designer spreadsheet.
ClearMerges | Clear all merges.
ClearSelection | Clear the selection in Worksheet.
ColInMerged | Gets a value that indicates whether the specified column in merges.
ColInSelection | Determines whether the specified column at index is in selected.
Copy | Copies contents and formats from another worksheet.
CreateRange | Overloaded.
DataBind | Binds data from data source object with Worksheet object.
DataUnbind | Unbind data from data source object with Worksheet object.
Equals (inherited from Object) |
ExportDataTable | Overloaded. Exports data in the Cells collection of a Worksheet to a specifed DataTable object.
FilterString | Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc
FreezePanes | Overloaded. Freezes panes at the specified cell in the worksheet.
GetAllSelectedRanges | Gets all selected ranges of this worksheet.
GetCellLocationByClientPoint | Gets the cell location by client coordinates point.
GetColumnCaption | Gets the column caption. If the caption is not set, returns empty string.
GetFirstVisibleColumn | Get the first visible column index of sheet view.
GetFirstVisibleRow | Get the first visible row index of sheet view.
GetFocusedCell | Gets the focused cell.
GetFocusedCellLocation | Gets a cell location which is focused.
GetFreezedPanes |
GetHashCode (inherited from Object) |
GetIsReadonly | Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
GetLastSelection | Gets the cell range of last selected.
GetMerge | Gets the cell range of the merge at the specified index.
GetType (inherited from Object) |
GroupColumns | Overloaded. Groups columns.
GroupRows | Overloaded. Groups rows.
ImportDataTable | Imports a DataTable object into a worksheet.
InSelection | Determines whether the specified cell location is in selected.
InsertColumn | Inserts a new column.
InsertRow | Inserts a new row.
IsCellFocused | Determines whether the cell is focused.
IsProtected | Indicates if the worksheet is protected.
Merge | Merges a specified range of cells into a single cell.
MergeFocused | Gets the index of the focused merge.
MoveTo | Moves the sheet to another location in the spreadsheet.
RefreshFilter | Refresh auto filters to hide or unhide the rows.
RemoveAutoFilter | Remove the auto filter of the worksheet.
RemoveColumn | Removes a column at the specified index.
RemoveRow | Removes a row at the specified index.
ResetFilter | reset filter type to none
ResetFilters | reset filter type to none
RowInMerged | Gets a value that indicates whether the specified row in merges.
RowInSelection | Determines whether the specified row at index is in selected.
SetAllCellsEditable | Makes all cells editable.this is extended attribute
SetAllCellsReadonly | Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect
SetColumnCaption | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetFirstVisibleColumn | Set the first visible column index of sheet view.
SetFirstVisibleRow | Set the first visible row index of sheet view.
SetFocusedCell | Overloaded. Sets the cell focus at the specified location.
SetFont | Sets font object to cellRange.
SetFontColor | Sets font color to cellRange.
SetIsReadonly | Sets whether the cell is readonly.this is an extended attribute ,it will not keep in actual excel file
SetProtect | Protects worksheet.
SetProtected | Sets cellRange whether it is protected.this is an extended method used only in Grid. This method has nothing to do with the cell.Style.CellLocked property It will not take affect after save to excel file.
SetStyle | Overloaded. Sets style object to cellRange.
ToString (inherited from Object) |
UnFreezePanes | Unfreezes panes in the worksheet.
UngroupColumns | Overloaded. Ungroups columns.
UngroupRows | Overloaded. Ungroups rows.
Unmerge | Overloaded. Unmerges a specified range of cells into a single cell.
UnProtect | unProtects worksheet.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet Fields

The fields of the Worksheet class are listed below. For a complete list of Worksheet class members, see the Worksheet Members topic.

Public Static Fields

DEFAULT_COLUMNSCOUNT | Default columns count of worksheet.
DEFAULT_ROWSCOUNT | Default rows count of worksheet.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.DEFAULT_COLUMNSCOUNT Field

Default columns count of worksheet.

public static int DEFAULT_COLUMNSCOUNT;

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.DEFAULT_ROWSCOUNT Field

Default rows count of worksheet.

public static int DEFAULT_ROWSCOUNT;

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet Properties

The properties of the Worksheet class are listed below. For a complete list of Worksheet class members, see the Worksheet Members topic.

Public Instance Properties

ActiveCell |
AllowSelectingLockedCell | Represents if the user is allowed to select locked cells on a protected worksheet.
BackgroundImage | Gets and sets worksheet background image.
Cells |
CodeName | Represents worksheet code name.
Columns |
ColumnsCount |
Comments |
Controls | Gets the cell control collection.
CustomColumnCaption | Gets or sets the custom column caption for the worksheet.
CustomRowCaption | Gets or sets the custom row caption for the worksheet.
DataMember | Gets the data source that the Worksheet object is displaying data for.
DataSource | Gets the specific list in a DataSource for Worksheet object.
DisplayRightToLeft |
DisplayZeros | True if zero values are displayed.
FirstVisibleColumn |
FirstVisibleRow | Represents first visible row index.
FrozenCols | Gets or sets Worksheet's frozen column count. Frozen will start at first column.
FrozenRows | Gets or sets Worksheet's frozen row count. Frozen will start at first row.
GridDesktop | Gets Sheet's GridDesktop object.
GridlinesVisible | Gets or sets a value indicating whether the gridelines are visible.Default is true.
Hyperlinks | Gets the HyperlinkCollection collection.
Index | Gets the index of sheet in the worksheets collection.
IsVeryHidden | Indicates wether the sheet is hidden and cannot be shown in the user interface (UI).
IsVisible |
MergesCount | Gets the count of the merges
Name | Gets or sets the name of the worksheet.
OutlineShown | Indicates whether show outline.
Pictures | Gets a Pictures collection.
PivotTables | Gets the pivotTables in the worksheet.
Protected |
RowFilter | Gets the RowFilterSettings object of the sheet.
Rows |
RowsCount |
Selected | Indicates whether this worksheet is selected when the workbook is opened.
Shapes | Gets a Pictures collection.
ShowGridlines |
TabColor | Represents worksheet tab color.
Validations | Gets the data validation setting collection in the worksheet.
Visible | Represents if the worksheet is visible.
Workbook |
Zoom | Represents the scaling factor in percent. It should be between 10 and 400.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


ActiveCell Property

Aspose.Cells for .NET

Worksheet.ActiveCell Property

public string ActiveCell {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


AllowSelectingLockedCell Property

Aspose.Cells for .NET

Worksheet.AllowSelectingLockedCell Property

Represents if the user is allowed to select locked cells on a protected worksheet.

public bool AllowSelectingLockedCell {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


BackgroundImage Property

Aspose.Cells for .NET

Worksheet.BackgroundImage Property

Gets and sets worksheet background image.

public byte[] BackgroundImage {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Cells Property

Aspose.Cells for .NET

Worksheet.Cells Property

public GridCells Cells {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


CodeName Property

Aspose.Cells for .NET

Worksheet.CodeName Property

Represents worksheet code name.

public string CodeName {get;}

Remarks

You cannot change the code name while the template file contains VBA/macro.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Columns Property

Aspose.Cells for .NET

Worksheet.Columns Property

public GridColumnCollection Columns {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


ColumnsCount Property

Aspose.Cells for .NET

Worksheet.ColumnsCount Property

public int ColumnsCount {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Comments Property

Aspose.Cells for .NET

Worksheet.Comments Property

public GridCommentCollection Comments {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Controls Property

Aspose.Cells for .NET

Worksheet.Controls Property

Gets the cell control collection.

public CellControlCollection Controls {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


CustomColumnCaption Property

Aspose.Cells for .NET

Worksheet.CustomColumnCaption Property

Gets or sets the custom column caption for the worksheet.

public ICustomColumnCaption CustomColumnCaption {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


CustomRowCaption Property

Aspose.Cells for .NET

Worksheet.CustomRowCaption Property

Gets or sets the custom row caption for the worksheet.

public ICustomRowCaption CustomRowCaption {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


DataMember Property

Aspose.Cells for .NET

Worksheet.DataMember Property

Gets the data source that the Worksheet object is displaying data for.

public string DataMember {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


DataSource Property

Aspose.Cells for .NET

Worksheet.DataSource Property

Gets the specific list in a DataSource for Worksheet object.

public object DataSource {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


DisplayRightToLeft Property

Aspose.Cells for .NET

Worksheet.DisplayRightToLeft Property

public bool DisplayRightToLeft {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


DisplayZeros Property

Aspose.Cells for .NET

Worksheet.DisplayZeros Property

True if zero values are displayed.

public bool DisplayZeros {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


FirstVisibleColumn Property

Aspose.Cells for .NET

Worksheet.FirstVisibleColumn Property

public int FirstVisibleColumn {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


FirstVisibleRow Property

Aspose.Cells for .NET

Worksheet.FirstVisibleRow Property

Represents first visible row index.

public int FirstVisibleRow {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


FrozenCols Property

Aspose.Cells for .NET

Worksheet.FrozenCols Property

Gets or sets Worksheet's frozen column count. Frozen will start at first column.

public int FrozenCols {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


FrozenRows Property

Aspose.Cells for .NET

Worksheet.FrozenRows Property

Gets or sets Worksheet's frozen row count. Frozen will start at first row.

public int FrozenRows {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


GridDesktop Property

Aspose.Cells for .NET

Worksheet.GridDesktop Property

Gets Sheet's GridDesktop object.

public GridDesktop GridDesktop {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


GridlinesVisible Property

Aspose.Cells for .NET

Worksheet.GridlinesVisible Property

Gets or sets a value indicating whether the gridelines are visible.Default is true.

public bool GridlinesVisible {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Hyperlinks Property

Aspose.Cells for .NET

Worksheet.Hyperlinks Property

Gets the HyperlinkCollection collection.

public GridHyperlinkCollection Hyperlinks {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Index Property

Aspose.Cells for .NET

Worksheet.Index Property

Gets the index of sheet in the worksheets collection.

public int Index {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


IsVeryHidden Property

Aspose.Cells for .NET

Worksheet.IsVeryHidden Property

Indicates wether the sheet is hidden and cannot be shown in the user interface (UI).

public bool IsVeryHidden {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


IsVisible Property

Aspose.Cells for .NET

Worksheet.IsVisible Property

public bool IsVisible {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


MergesCount Property

Aspose.Cells for .NET

Worksheet.MergesCount Property

Gets the count of the merges

public int MergesCount {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Name Property

Aspose.Cells for .NET

Worksheet.Name Property

Gets or sets the name of the worksheet.

public string Name {get; set;}

Remarks

The max length of sheet name is 31. And you cannot assign same name(case insensitive) to two worksheets. For example, you cannot set "SheetName1" to the first worksheet and set "SHEETNAME1" to the second worksheet.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


OutlineShown Property

Aspose.Cells for .NET

Worksheet.OutlineShown Property

Indicates whether show outline.

public bool OutlineShown {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Pictures Property

Aspose.Cells for .NET

Worksheet.Pictures Property

Gets a Pictures collection.

public GridPictureCollection Pictures {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


PivotTables Property

Aspose.Cells for .NET

Worksheet.PivotTables Property

Gets the pivotTables in the worksheet.

public GridPivotTableCollection PivotTables {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Protected Property

Aspose.Cells for .NET

Worksheet.Protected Property

public bool Protected {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


RowFilter Property

Aspose.Cells for .NET

Worksheet.RowFilter Property

Gets the RowFilterSettings object of the sheet.

public RowFilterSettings RowFilter {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Rows Property

Aspose.Cells for .NET

Worksheet.Rows Property

public GridRowCollection Rows {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


RowsCount Property

Aspose.Cells for .NET

Worksheet.RowsCount Property

public int RowsCount {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Selected Property

Aspose.Cells for .NET

Worksheet.Selected Property

Indicates whether this worksheet is selected when the workbook is opened.

public bool Selected {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Shapes Property

Aspose.Cells for .NET

Worksheet.Shapes Property

Gets a Pictures collection.

public GridShapeCollection Shapes {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


ShowGridlines Property

Aspose.Cells for .NET

Worksheet.ShowGridlines Property

public bool ShowGridlines {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


TabColor Property

Aspose.Cells for .NET

Worksheet.TabColor Property

Represents worksheet tab color.

public Color TabColor {get; set;}

Remarks

This feature is only supported in ExcelXP(Excel2002) and above version. If you save file as Excel97 or Excel2000 format, it will be omitted.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Validations Property

Aspose.Cells for .NET

Worksheet.Validations Property

Gets the data validation setting collection in the worksheet.

public GridValidationCollection Validations {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Visible Property

Aspose.Cells for .NET

Worksheet.Visible Property

Represents if the worksheet is visible.

public bool Visible {get; set;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Workbook Property

Aspose.Cells for .NET

Worksheet.Workbook Property

public GridWorkbook Workbook {get;}

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Zoom Property

Aspose.Cells for .NET

Worksheet.Zoom Property

Represents the scaling factor in percent. It should be between 10 and 400.

public int Zoom {get; set;}

Remarks

Please set the view type first.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet Methods

The methods of the Worksheet class are listed below. For a complete list of Worksheet class members, see the Worksheet Members topic.

Public Static Methods

CellIndexToR1C1 Gets cell r1c1 style name according to its row and column indexes.

Public Instance Methods

AddAutoFilter | Sets the range to which the specified AutoFilter applies.
AddColumn | Adds a new column.
AddCustomFilter | Overloaded. Add custom filter for the specified row range from start row to end row.
AddRow | Adds a new row.
AddSelectedRange | Add a new selected range to the worksheet.
AutoFitColumn | Overloaded. Autofits the column width.
AutoFitColumns | Overloaded. Autofits all columns in this worksheet.
AutoFitRow | Overloaded. Autofits the row height.
AutoFitRows | Overloaded. Autofits all rows in this worksheet.
AutoFitRowsMerged | Autofits all rows in this worksheet.It will also auto fit row height when the cells is merged in a row.
CalculateFormula | Calculates a formula.
CellInMerged | Gets a value whether the specified cell location is in merges.
CellRangeInMerge | Gets a value that indicates whether the specified cell range in merges.
ClearComments | Clears all comments in designer spreadsheet.
ClearMerges | Clear all merges.
ClearSelection | Clear the selection in Worksheet.
ColInMerged | Gets a value that indicates whether the specified column in merges.
ColInSelection | Determines whether the specified column at index is in selected.
Copy | Copies contents and formats from another worksheet.
CreateRange | Overloaded.
DataBind | Binds data from data source object with Worksheet object.
DataUnbind | Unbind data from data source object with Worksheet object.
Equals (inherited from Object) |
ExportDataTable | Overloaded. Exports data in the Cells collection of a Worksheet to a specifed DataTable object.
FilterString | Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc
FreezePanes | Overloaded. Freezes panes at the specified cell in the worksheet.
GetAllSelectedRanges | Gets all selected ranges of this worksheet.
GetCellLocationByClientPoint | Gets the cell location by client coordinates point.
GetColumnCaption | Gets the column caption. If the caption is not set, returns empty string.
GetFirstVisibleColumn | Get the first visible column index of sheet view.
GetFirstVisibleRow | Get the first visible row index of sheet view.
GetFocusedCell | Gets the focused cell.
GetFocusedCellLocation | Gets a cell location which is focused.
GetFreezedPanes |
GetHashCode (inherited from Object) |
GetIsReadonly | Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
GetLastSelection | Gets the cell range of last selected.
GetMerge | Gets the cell range of the merge at the specified index.
GetType (inherited from Object) |
GroupColumns | Overloaded. Groups columns.
GroupRows | Overloaded. Groups rows.
ImportDataTable | Imports a DataTable object into a worksheet.
InSelection | Determines whether the specified cell location is in selected.
InsertColumn | Inserts a new column.
InsertRow | Inserts a new row.
IsCellFocused | Determines whether the cell is focused.
IsProtected | Indicates if the worksheet is protected.
Merge | Merges a specified range of cells into a single cell.
MergeFocused | Gets the index of the focused merge.
MoveTo | Moves the sheet to another location in the spreadsheet.
RefreshFilter | Refresh auto filters to hide or unhide the rows.
RemoveAutoFilter | Remove the auto filter of the worksheet.
RemoveColumn | Removes a column at the specified index.
RemoveRow | Removes a row at the specified index.
ResetFilter | reset filter type to none
ResetFilters | reset filter type to none
RowInMerged | Gets a value that indicates whether the specified row in merges.
RowInSelection | Determines whether the specified row at index is in selected.
SetAllCellsEditable | Makes all cells editable.this is extended attribute
SetAllCellsReadonly | Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect
SetColumnCaption | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetFirstVisibleColumn | Set the first visible column index of sheet view.
SetFirstVisibleRow | Set the first visible row index of sheet view.
SetFocusedCell | Overloaded. Sets the cell focus at the specified location.
SetFont | Sets font object to cellRange.
SetFontColor | Sets font color to cellRange.
SetIsReadonly | Sets whether the cell is readonly.this is an extended attribute ,it will not keep in actual excel file
SetProtect | Protects worksheet.
SetProtected | Sets cellRange whether it is protected.this is an extended method used only in Grid. This method has nothing to do with the cell.Style.CellLocked property It will not take affect after save to excel file.
SetStyle | Overloaded. Sets style object to cellRange.
ToString (inherited from Object) |
UnFreezePanes | Unfreezes panes in the worksheet.
UngroupColumns | Overloaded. Ungroups columns.
UngroupRows | Overloaded. Ungroups rows.
Unmerge | Overloaded. Unmerges a specified range of cells into a single cell.
UnProtect | unProtects worksheet.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AddAutoFilter Method

Sets the range to which the specified AutoFilter applies.

public void AddAutoFilter(
int row,
int startColumn,
int endColumn
);

Parameters

row
header Row index.
startColumn
Start column index.
endColumn
End column Index.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AddColumn Method

Adds a new column.

public void AddColumn();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


AddCustomFilter Method

Aspose.Cells for .NET

Worksheet.AddCustomFilter Method

Add custom filter for the specified row range from start row to end row.

Overload List

Add custom filter for the specified row range from start row to end row.

public void AddCustomFilter(int,int,object[],GridFilterOperatorType[]);

Add custom filter for the specified row.

public void AddCustomFilter(int,string);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AddCustomFilter Method (Int32, Int32, Object[], GridFilterOperatorType[])

Add custom filter for the specified row range from start row to end row.

public void AddCustomFilter(
int startrow,
int startcolumn,
object[] critiras,
GridFilterOperatorType[] filterOperatorTypes
);

Parameters

startrow
The startrow of the filter range
startcolumn
The startcolumn of the filter range
critiras
The critira array for the columns,each one apply to each column
filterOperatorTypes
The filter operate type array for the columns,each one apply to each column

Remarks

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AddCustomFilter Overload List


Worksheet.AddCustomFilter Method (Int32, String)

Add custom filter for the specified row.

public void AddCustomFilter(
int row,
string critira
);

Remarks

The filter criteria string. notice we use , and ; as split char,so the cell value shall not contains with those split char below are the criteria string examples: //column 0 with value 12.3 CELL0 = 12.3 //column 1 with value ABC CELL1 = ABC //column 0 with value 123 or 456 or ABC and column 1 with value ABC CELL0 = 123,456,ABC; CELL1 = ABC

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AddCustomFilter Overload List


Worksheet.AddRow Method

Adds a new row.

public void AddRow();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AddSelectedRange Method

Add a new selected range to the worksheet.

public void AddSelectedRange(
CellRange cCellRange
);

Parameters

cCellRange
The added selected range

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


AutoFitColumn Method

Aspose.Cells for .NET

Worksheet.AutoFitColumn Method

Autofits the column width.

Overload List

Autofits the column width.

public void AutoFitColumn(int);

Autofits the column width.

public void AutoFitColumn(int,int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AutoFitColumn Method (Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitColumn Overload List


Worksheet.AutoFitColumn Method (Int32, Int32, Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex,
int firstRow,
int lastRow
);

Parameters

columnIndex
Column index.
firstRow
First row index.
lastRow
Last row index.

Remarks

This method autofits a row based on content in a range of cells within the row.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitColumn Overload List


AutoFitColumns Method

Aspose.Cells for .NET

Worksheet.AutoFitColumns Method

Autofits all columns in this worksheet.

Overload List

Autofits all columns in this worksheet.

public void AutoFitColumns();

Autofits the columns width.

public void AutoFitColumns(int,int);

Autofits the columns width.

public void AutoFitColumns(int,int,int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AutoFitColumns Method ()

Autofits all columns in this worksheet.

public void AutoFitColumns();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (Int32, Int32)

Autofits the columns width.

public void AutoFitColumns(
int firstColumn,
int lastColumn
);

Parameters

firstColumn
First column index.
lastColumn
Last column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitColumns Overload List


Worksheet.AutoFitColumns Method (Int32, Int32, Int32, Int32)

Autofits the columns width.

public void AutoFitColumns(
int firstRow,
int firstColumn,
int lastRow,
int lastColumn
);

Parameters

firstRow
First row index.
firstColumn
First column index.
lastRow
Last row index.
lastColumn
Last column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitColumns Overload List


AutoFitRow Method

Aspose.Cells for .NET

Worksheet.AutoFitRow Method

Autofits the row height.

Overload List

Autofits the row height.

public void AutoFitRow(int);

Autofits the row height.

public void AutoFitRow(int,int,int);

Autofits row height in a rectangle range.

public void AutoFitRow(int,int,int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AutoFitRow Method (Int32)

Autofits the row height.

public void AutoFitRow(
int rowIndex
);

Parameters

rowIndex
Row index.

Remarks

AutoFitRow is an imprecise function.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitRow Overload List


Worksheet.AutoFitRow Method (Int32, Int32, Int32)

Autofits the row height.

public void AutoFitRow(
int rowIndex,
int firstColumn,
int lastColumn
);

Parameters

rowIndex
Row index.
firstColumn
First column index.
lastColumn
Last column index.

Remarks

This method autofits a row based on content in a range of cells within the row.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitRow Overload List


Worksheet.AutoFitRow Method (Int32, Int32, Int32, Int32)

Autofits row height in a rectangle range.

public void AutoFitRow(
int startRow,
int endRow,
int startColumn,
int endColumn
);

Parameters

startRow
Start row index.
endRow
End row index.
startColumn
Start column index.
endColumn
End column index.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitRow Overload List


AutoFitRows Method

Aspose.Cells for .NET

Worksheet.AutoFitRows Method

Autofits all rows in this worksheet.

Overload List

Autofits all rows in this worksheet.

public void AutoFitRows();

Autofits row height in a range.

public void AutoFitRows(int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.AutoFitRows Method ()

Autofits all rows in this worksheet.

public void AutoFitRows();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitRows Overload List


Worksheet.AutoFitRows Method (Int32, Int32)

Autofits row height in a range.

public void AutoFitRows(
int startRow,
int endRow
);

Parameters

startRow
Start row index.
endRow
End row index.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.AutoFitRows Overload List


Worksheet.AutoFitRowsMerged Method

Autofits all rows in this worksheet.It will also auto fit row height when the cells is merged in a row.

public void AutoFitRowsMerged();

Remarks

If the cells in merged in a row and auto fit the rows in MS Excel, MS Excel do not expand the row height. Aspose.Cells will expand the row height to fit the cells' data.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.CalculateFormula Method

Calculates a formula.

public object CalculateFormula(
string formula
);

Parameters

formula

Return Value

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.CellIndexToR1C1 Method

Gets cell r1c1 style name according to its row and column indexes.

public static string CellIndexToR1C1(
int row,
int column
);

Parameters

row
Row index.
column
Column index.

Return Value

R1C1 style name of cell.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.CellInMerged Method

Gets a value whether the specified cell location is in merges.

public bool CellInMerged(
CellLocation cl
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.CellRangeInMerge Method

Gets a value that indicates whether the specified cell range in merges.

public bool CellRangeInMerge(
CellRange cr
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ClearComments Method

Clears all comments in designer spreadsheet.

public void ClearComments();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ClearMerges Method

Clear all merges.

public void ClearMerges();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ClearSelection Method

Clear the selection in Worksheet.

public void ClearSelection();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ColInMerged Method

Gets a value that indicates whether the specified column in merges.

public bool ColInMerged(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ColInSelection Method

Determines whether the specified column at index is in selected.

public bool ColInSelection(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.Copy Method

Copies contents and formats from another worksheet.

public void Copy(
Worksheet sourceSheet
);

Parameters

sourceSheet
Source worksheet.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


CreateRange Method

Aspose.Cells for .NET

Worksheet.CreateRange Method

Overload List

public CellRange CreateRange(int,int,int,int);

public CellRange CreateRange(string,string);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.CreateRange Method (Int32, Int32, Int32, Int32)

public CellRange CreateRange(
int cStartRow,
int cStartCol,
int cEndRow,
int cEndCol
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.CreateRange Overload List


Worksheet.CreateRange Method (String, String)

public CellRange CreateRange(
string upperLeftCell,
string lowerRightCell
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.CreateRange Overload List


Worksheet.DataBind Method

Binds data from data source object with Worksheet object.

public void DataBind(
object dataSource,
string dataMember
);

Parameters

dataSource
The data source for GridDesktop control.
dataMember
The data member string that specifies the table to bind to within the data source object.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.DataUnbind Method

Unbind data from data source object with Worksheet object.

public void DataUnbind();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


ExportDataTable Method

Aspose.Cells for .NET

Worksheet.ExportDataTable Method

Exports data in the Cells collection of a Worksheet to a specifed DataTable object.

Overload List

Exports data in the Cells collection of a Worksheet to a specifed DataTable object.

public DataTable ExportDataTable(DataTable,int,int,int,int,bool);

Exports data in the Cells collection of a Worksheet to a new DataTable object.

public DataTable ExportDataTable(int,int,int,int,bool,bool);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ExportDataTable Method (DataTable, Int32, Int32, Int32, Int32, Boolean)

Exports data in the Cells collection of a Worksheet to a specifed DataTable object.

public DataTable ExportDataTable(
DataTable dataTable,
int startRow,
int startColumn,
int rows,
int columns,
bool isVertical
);

Parameters

dataTable
The DataTable object that exports data to.
startRow
The row number of the first cell to export out.
startColumn
The column number of the first cell to export out.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
isVertical
True if a row in the control represents a row in DataTable. False if a column in the control represents a row in DataTable.

Return Value

Exported DataTable object.

Remarks

The method permits first create a DataTable object. Then exports data to the DataTable object. If dataTable don't be set valid, the method will return a new DataTable object by calling overload method 'Export(bool exportColumnName, bool isVertical)'.

Example

[C#]

DataTable dataTable = new DataTable();
dataTable.Columns.Add("Column a",System.Type.GetType("System.String"));
dataTable.Columns.Add("Column b");
dataTable.Columns.Add("Column c");
dataTable.Columns.Add("Column d",System.Type.GetType("System.Double"));
dataTable.Columns.Add("Column e",System.Type.GetType("System.Int32"));
dataTable.Columns.Add("Column f",System.Type.GetType("System.Int32"));
DataTable exportTable = gridDesktop.Worksheets[0].Export(dataTable,1,0,10,6,true);
DataGrid1.SetDataBinding(exportTable, null);

[VB]

Dim dataTable As DataTable =  New DataTable()
dataTable.Columns.Add("Column a",System.Type.GetType("System.String"))
dataTable.Columns.Add("Column b")
dataTable.Columns.Add("Column c")
dataTable.Columns.Add("Column d",System.Type.GetType("System.Double"))
dataTable.Columns.Add("Column e",System.Type.GetType("System.Int32"))
dataTable.Columns.Add("Column f",System.Type.GetType("System.Int32"))
Dim exportTable As DataTable =  GridDesktop.Worksheets(0).Export(dataTable,1,0,10,6,True)
DataGrid1.SetDataBinding(exportTable)

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.ExportDataTable Overload List


Worksheet.ExportDataTable Method (Int32, Int32, Int32, Int32, Boolean, Boolean)

Exports data in the Cells collection of a Worksheet to a new DataTable object.

public DataTable ExportDataTable(
int startRow,
int startColumn,
int rows,
int columns,
bool exportColumnName,
bool isVertical
);

Parameters

startRow
The row number of the first cell to export out.
startColumn
The column number of the first cell to export out.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
exportColumnName
Indicates whether the data in the first row are exported to the column name of the DataTable.
isVertical
True if a row in the control represents a row in DataTable. False if a column in the control represents a row in DataTable.

Return Value

Exported DataTable object.

Example

[C#]

DataTable exportTable = gridDesktop.Worksheets[0].Export(0,0,10,2,true,false);
DataGrid1.SetDataBinding(exportTable, null);

[VB]

Dim exportTable As DataTable =  GridDesktop.Worksheets(0).Export(0,0,10,2,True,False)
DataGrid1.SetDataBinding(exportTable)

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.ExportDataTable Overload List


Worksheet.FilterString Method

Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc

public void FilterString(
int column,
string criteria
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


FreezePanes Method

Aspose.Cells for .NET

Worksheet.FreezePanes Method

Freezes panes at the specified cell in the worksheet.

Overload List

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(int,int,int,int);

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(string,int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.FreezePanes Method (Int32, Int32, Int32, Int32)

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(
int row,
int column,
int freezedRows,
int freezedColumns
);

Parameters

row
Row index.
column
Column index.
freezedRows
Number of visible rows in top pane, no more than row index.
freezedColumns
Number of visible columns in left pane, no more than column index.

Remarks

Row index and column index cannot all be zero. Number of rows and number of columns also cannot all be zero.

The first two parameters specify the freezed position and the last two parameters specify the area freezed on the left top pane.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.FreezePanes Overload List


Worksheet.FreezePanes Method (String, Int32, Int32)

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(
string cellName,
int freezedRows,
int freezedColumns
);

Parameters

cellName
Cell name.
freezedRows
Number of visible rows in top pane, no more than row index.
freezedColumns
Number of visible columns in left pane, no more than column index.

Remarks

Row index and column index cannot all be zero. Number of rows and number of columns also cannot all be zero.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.FreezePanes Overload List


Worksheet.GetAllSelectedRanges Method

Gets all selected ranges of this worksheet.

public ArrayList GetAllSelectedRanges();

Return Value

an ArrayList contains all selected CellRange objects.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetCellLocationByClientPoint Method

Gets the cell location by client coordinates point.

public CellLocation GetCellLocationByClientPoint(
Point clientPoint
);

Parameters

clientPoint
Client coordinates point

Return Value

CellLocation object.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetColumnCaption Method

Gets the column caption. If the caption is not set, returns empty string.

public string GetColumnCaption(
int column
);

Parameters

column
Column index.

Return Value

The column caption. If the caption is not set, returns empty string.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetFirstVisibleColumn Method

Get the first visible column index of sheet view.

public int GetFirstVisibleColumn();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetFirstVisibleRow Method

Get the first visible row index of sheet view.

public int GetFirstVisibleRow();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetFocusedCell Method

Gets the focused cell.

public GridCell GetFocusedCell();

Return Value

Cell object.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetFocusedCellLocation Method

Gets a cell location which is focused.

public CellLocation GetFocusedCellLocation();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetFreezedPanes Method

public bool GetFreezedPanes(
out int row,
out int column,
out int freezedRows,
out int freezedColumns
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetIsReadonly Method

Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file

public bool GetIsReadonly(
GridCell cell
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetLastSelection Method

Gets the cell range of last selected.

public CellRange GetLastSelection();

Return Value

CellRange object.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GetMerge Method

Gets the cell range of the merge at the specified index.

public CellRange GetMerge(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


GroupColumns Method

Aspose.Cells for .NET

Worksheet.GroupColumns Method

Groups columns.

Overload List

Groups columns.

public void GroupColumns(int,int);

Groups columns.

public void GroupColumns(int,int,bool,bool);

Groups columns.

public void GroupColumns(int,int,int,bool);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GroupColumns Method (Int32, Int32)

Groups columns.

public void GroupColumns(
int firstColumn,
int lastColumn
);

Parameters

firstColumn
The first column index to be grouped.
lastColumn
The last column index to be grouped.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupColumns Overload List


Worksheet.GroupColumns Method (Int32, Int32, Boolean, Boolean)

Groups columns.

public void GroupColumns(
int firstColumn,
int lastColumn,
bool isHidden,
bool addToUndo
);

Parameters

firstColumn
The first column index to be grouped.
lastColumn
The last column index to be grouped.
isHidden
Specifies if the grouped columns are hidden
addToUndo
Specifies if this operation will be added into undo manager. And the GridDesktop's EnableUndo property must be set to true.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupColumns Overload List


Worksheet.GroupColumns Method (Int32, Int32, Int32, Boolean)

Groups columns.

public void GroupColumns(
int firstColumn,
int lastColumn,
int outlineLevel,
bool isHidden
);

Parameters

firstColumn
The first column index to be grouped.
lastColumn
The last column index to be grouped.
outlineLevel
outlineLevel
isHidden
Specifies if the grouped columns are hidden

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupColumns Overload List


GroupRows Method

Aspose.Cells for .NET

Worksheet.GroupRows Method

Groups rows.

Overload List

Groups rows.

public void GroupRows(int,int);

Groups rows.

public void GroupRows(int,int,bool);

Groups rows.

public void GroupRows(int,int,bool,bool);

Groups rows.

public void GroupRows(int,int,int,bool);

Groups rows.

public void GroupRows(int,int,int,bool,bool);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.GroupRows Method (Int32, Int32)

Groups rows.

public void GroupRows(
int firstRow,
int lastRow
);

Parameters

firstRow
The first row index to be grouped.
lastRow
The last row index to be grouped.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupRows Overload List


Worksheet.GroupRows Method (Int32, Int32, Boolean)

Groups rows.

public void GroupRows(
int firstRow,
int lastRow,
bool isHidden
);

Parameters

firstRow
The first row index to be grouped.
lastRow
The last row index to be grouped.
isHidden
Specifies if the grouped rows are shown.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupRows Overload List


Worksheet.GroupRows Method (Int32, Int32, Boolean, Boolean)

Groups rows.

public void GroupRows(
int firstRow,
int lastRow,
bool isHidden,
bool addToUndo
);

Parameters

firstRow
The first row index to be grouped.
lastRow
The last row index to be grouped.
isHidden
Specifies if the grouped rows are shown.
addToUndo
Specifies if this operation will be added into undo manager. And the GridDesktop's EnableUndo property must be set to true.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupRows Overload List


Worksheet.GroupRows Method (Int32, Int32, Int32, Boolean)

Groups rows.

public void GroupRows(
int firstRow,
int lastRow,
int outlineLevel,
bool isHidden
);

Parameters

firstRow
The first row index to be grouped.
lastRow
The last row index to be grouped.
outlineLevel
outlineLevel
isHidden
Specifies if the grouped rows are shown.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupRows Overload List


Worksheet.GroupRows Method (Int32, Int32, Int32, Boolean, Boolean)

Groups rows.

public void GroupRows(
int firstRow,
int lastRow,
int outlineLevel,
bool isHidden,
bool addToUndo
);

Parameters

firstRow
The first row index to be grouped.
lastRow
The last row index to be grouped.
outlineLevel
outlineLevel
isHidden
Specifies if the grouped rows are shown.
addToUndo
Specifies if this operation will be added into undo manager. And the GridDesktop's EnableUndo property must be set to true.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.GroupRows Overload List


Worksheet.ImportDataTable Method

Imports a DataTable object into a worksheet.

public int ImportDataTable(
DataTable dataTable,
bool isFieldNameShown,
int firstRow,
int firstColumn
);

Parameters

dataTable
The DataTable object to be imported.
isFieldNameShown
Indicates whether the field name of the datatable will be imported to the first row.
firstRow
The row number of the first cell to import.
firstColumn
The column number of the first cell to import.

Return Value

Total number of rows imported.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.InSelection Method

Determines whether the specified cell location is in selected.

public bool InSelection(
CellLocation cellLocation
);

Parameters

cellLocation
Cell location.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.InsertColumn Method

Inserts a new column.

public void InsertColumn(
int index
);

Parameters

index
Index of column is inserted.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.InsertRow Method

Inserts a new row.

public void InsertRow(
int index
);

Parameters

index
row index is inserted.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.IsCellFocused Method

Determines whether the cell is focused.

public bool IsCellFocused();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.IsProtected Method

Indicates if the worksheet is protected.

public bool IsProtected();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.Merge Method

Merges a specified range of cells into a single cell.

public void Merge(
CellRange r
);

Parameters

r
CellRange of this range(zero based)

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.MergeFocused Method

Gets the index of the focused merge.

public int MergeFocused(
CellLocation cl
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.MoveTo Method

Moves the sheet to another location in the spreadsheet.

public void MoveTo(
int index
);

Parameters

index
Destination sheet index.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.RefreshFilter Method

Refresh auto filters to hide or unhide the rows.

public void RefreshFilter();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.RemoveAutoFilter Method

Remove the auto filter of the worksheet.

public void RemoveAutoFilter();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.RemoveColumn Method

Removes a column at the specified index.

public void RemoveColumn(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.RemoveRow Method

Removes a row at the specified index.

public void RemoveRow(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ResetFilter Method

reset filter type to none

public void ResetFilter(
int fieldIndex
);

Parameters

fieldIndex
The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.ResetFilters Method

reset filter type to none

public void ResetFilters(
int startFieldIndex,
int endFildIndex
);

Parameters

startFieldIndex
tht first field index, The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).
endFildIndex
tht last field index,The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.RowInMerged Method

Gets a value that indicates whether the specified row in merges.

public bool RowInMerged(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.RowInSelection Method

Determines whether the specified row at index is in selected.

public bool RowInSelection(
int index
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetAllCellsEditable Method

Makes all cells editable.this is extended attribute

public void SetAllCellsEditable();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetAllCellsReadonly Method

Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect

public void SetAllCellsReadonly();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetColumnCaption Method

Sets the caption for the column.please note this is an extension attribute and can not keep in excel file

public void SetColumnCaption(
int column,
string caption
);

Parameters

column
Column index.
caption
The column caption. Pass null or empty string if you want cancel the caption.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetFirstVisibleColumn Method

Set the first visible column index of sheet view.

public void SetFirstVisibleColumn(
int col
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetFirstVisibleRow Method

Set the first visible row index of sheet view.

public void SetFirstVisibleRow(
int row
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


SetFocusedCell Method

Aspose.Cells for .NET

Worksheet.SetFocusedCell Method

Sets the cell focus at the specified location.

Overload List

Sets the cell focus at the specified location.

public void SetFocusedCell(CellLocation);

Sets the cell focus at the specified column and row.

public void SetFocusedCell(int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetFocusedCell Method (CellLocation)

Sets the cell focus at the specified location.

public void SetFocusedCell(
CellLocation cellLocation
);

Parameters

cellLocation
Cell location.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.SetFocusedCell Overload List


Worksheet.SetFocusedCell Method (Int32, Int32)

Sets the cell focus at the specified column and row.

public void SetFocusedCell(
int row,
int col
);

Parameters

row
Row index.
col
Column index.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.SetFocusedCell Overload List


Worksheet.SetFont Method

Sets font object to cellRange.

public void SetFont(
CellRange range,
Font font
);

Parameters

range
CellRange object.
font
Font object to be set.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetFontColor Method

Sets font color to cellRange.

public void SetFontColor(
CellRange range,
Color color
);

Parameters

range
CellRange object.
color
Font color to be set.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetIsReadonly Method

Sets whether the cell is readonly.this is an extended attribute ,it will not keep in actual excel file

public void SetIsReadonly(
GridCell cell,
bool value
);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetProtect Method

Protects worksheet.

public void SetProtect();

Remarks

This method protects worksheet without password. It can protect worksheet in all versions of Excel file.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetProtected Method

Sets cellRange whether it is protected.this is an extended method used only in Grid. This method has nothing to do with the cell.Style.CellLocked property It will not take affect after save to excel file.

public void SetProtected(
CellRange range,
bool isProtected
);

Parameters

range
CellRange object.
isProtected
Bool value to be set.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


SetStyle Method

Aspose.Cells for .NET

Worksheet.SetStyle Method

Sets style object to cellRange.

Overload List

Sets style object to cellRange.

public void SetStyle(CellRange,Style);

Sets style object to cellRange.

public void SetStyle(GridCellArea,Style);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.SetStyle Method (CellRange, Style)

Sets style object to cellRange.

public void SetStyle(
CellRange range,
Style style
);

Parameters

range
CellRange object.
style
Style object to be set.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.SetStyle Overload List


Worksheet.SetStyle Method (GridCellArea, Style)

Sets style object to cellRange.

public void SetStyle(
GridCellArea area,
Style style
);

Parameters

area
GridCellArea object.
style
Style object to be set.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.SetStyle Overload List


Worksheet.UnFreezePanes Method

Unfreezes panes in the worksheet.

public void UnFreezePanes();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


UngroupColumns Method

Aspose.Cells for .NET

Worksheet.UngroupColumns Method

Ungroups columns.

Overload List

Ungroups columns.

public void UngroupColumns(int,int);

Ungroups columns.

public void UngroupColumns(int,int,bool);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.UngroupColumns Method (Int32, Int32)

Ungroups columns.

public void UngroupColumns(
int firstColumn,
int lastColumn
);

Parameters

firstColumn
The first column index to ungrouped.
lastColumn
The last column index to ungrouped.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.UngroupColumns Overload List


Worksheet.UngroupColumns Method (Int32, Int32, Boolean)

Ungroups columns.

public void UngroupColumns(
int firstColumn,
int lastColumn,
bool addToUndo
);

Parameters

firstColumn
The first column index to ungrouped.
lastColumn
The last column index to ungrouped.
addToUndo
Specifies if this operation will be added into undo manager. And the GridDesktop's EnableUndo property must be set to true.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.UngroupColumns Overload List


UngroupRows Method

Aspose.Cells for .NET

Worksheet.UngroupRows Method

Ungroups rows.

Overload List

Ungroups rows.

public void UngroupRows(int,int);

Ungroups rows.

public void UngroupRows(int,int,bool);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.UngroupRows Method (Int32, Int32)

Ungroups rows.

public void UngroupRows(
int firstRow,
int lastRow
);

Parameters

firstRow
The first row index to be ungrouped.
lastRow
The last row index to be ungrouped.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.UngroupRows Overload List


Worksheet.UngroupRows Method (Int32, Int32, Boolean)

Ungroups rows.

public void UngroupRows(
int firstRow,
int lastRow,
bool addToUndo
);

Parameters

firstRow
The first row index to be ungrouped.
lastRow
The last row index to be ungrouped.
addToUndo
Specifies if this operation will be added into undo manager. And the GridDesktop's EnableUndo property must be set to true.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.UngroupRows Overload List


Unmerge Method

Aspose.Cells for .NET

Worksheet.Unmerge Method

Remove the specified cell location from merges.

Overload List

Remove the specified cell location from merges.

public void Unmerge(CellLocation);

Unmerges a specified range of cells into a single cell.

public void Unmerge(CellRange);

Remove the specified cell row column index from merges.

public void Unmerge(int,int);

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


Worksheet.Unmerge Method (CellLocation)

Remove the specified cell location from merges.

public void Unmerge(
CellLocation location
);

Parameters

location
Cell location.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.Unmerge Overload List


Worksheet.Unmerge Method (CellRange)

Unmerges a specified range of cells into a single cell.

public void Unmerge(
CellRange r
);

Parameters

r
CellRange of this range(zero based)

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.Unmerge Overload List


Worksheet.Unmerge Method (Int32, Int32)

Remove the specified cell row column index from merges.

public void Unmerge(
int row,
int column
);

Parameters

row
Row index.
column
Column index.

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace | Worksheet.Unmerge Overload List


Worksheet.UnProtect Method

unProtects worksheet.

public void UnProtect();

See Also

Worksheet Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection Class

Collects the objects that represent the individual rows in a worksheet.

For a list of all members of this type, see WorksheetCollection Members.

System.Object
Aspose.Cells.GridDesktop.WorksheetCollection

public class WorksheetCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

WorksheetCollection Members | Aspose.Cells.GridDesktop Namespace | Row


WorksheetCollection Members

WorksheetCollection overview

Public Instance Properties

ActiveSheetIndex |
Count |
DefaultFontName | Gets or sets the control's default font name.
Item | Overloaded. Gets the Worksheet element at the specified index.
Names | Gets the collection of all the Name objects in the spreadsheet.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
CalculateFormula | Calculates the result of formulas.
Clear | Clear all worksheets.
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Searches for the specified sheet and returns the zero-based index of the first occurrence within the entire WorksheetCollection.
Insert | Overloaded.
MoveTo |
Remove | Removes the worksheet at the specified index of the WorksheetCollection. If the specific sheet is the last sheet,after removes sheet,will add a new sheet to the WorksheetCollection.
RemoveAt | Overloaded. Removes the element at a specified index.
SetVisible | Sets the visible options.
SwapSheet | Swaps the two sheets.
ToString (inherited from Object) |

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | Row


WorksheetCollection Properties

The properties of the WorksheetCollection class are listed below. For a complete list of WorksheetCollection class members, see the WorksheetCollection Members topic.

Public Instance Properties

ActiveSheetIndex |
Count |
DefaultFontName | Gets or sets the control's default font name.
Item | Overloaded. Gets the Worksheet element at the specified index.
Names | Gets the collection of all the Name objects in the spreadsheet.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | Row


ActiveSheetIndex Property

Aspose.Cells for .NET

WorksheetCollection.ActiveSheetIndex Property

public int ActiveSheetIndex {get; set;}

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


Count Property

Aspose.Cells for .NET

WorksheetCollection.Count Property

public int Count {get;}

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


DefaultFontName Property

Aspose.Cells for .NET

WorksheetCollection.DefaultFontName Property

Gets or sets the control's default font name.

public string DefaultFontName {get; set;}

Example

[C#]
        GridWeb1.DefaultFontName = "Arial";

    [Visual Basic]
        GridWeb1.DefaultFontName = "Arial"

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


Item Property

Aspose.Cells for .NET

WorksheetCollection.Item Property

Gets the Worksheet element at the specified index.

Overload List

Gets the Worksheet element at the specified index.

public Worksheet this[int] {get;}

Gets the Worksheet element with the specified name.

public Worksheet this[string] {get;}

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


Item Property (Int32)

Aspose.Cells for .NET

WorksheetCollection.Item Property (Int32)

Gets the Worksheet element at the specified index.

public Worksheet this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

WorksheetCollection.Item Property (String)

Gets the Worksheet element with the specified name.

public Worksheet this[
string sheetName
] {get;}

Parameters

sheetName
The name of the worksheet.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.Item Overload List


Names Property

Aspose.Cells for .NET

WorksheetCollection.Names Property

Gets the collection of all the Name objects in the spreadsheet.

public GridNameCollection Names {get;}

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection Methods

The methods of the WorksheetCollection class are listed below. For a complete list of WorksheetCollection class members, see the WorksheetCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
CalculateFormula | Calculates the result of formulas.
Clear | Clear all worksheets.
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Searches for the specified sheet and returns the zero-based index of the first occurrence within the entire WorksheetCollection.
Insert | Overloaded.
MoveTo |
Remove | Removes the worksheet at the specified index of the WorksheetCollection. If the specific sheet is the last sheet,after removes sheet,will add a new sheet to the WorksheetCollection.
RemoveAt | Overloaded. Removes the element at a specified index.
SetVisible | Sets the visible options.
SwapSheet | Swaps the two sheets.
ToString (inherited from Object) |

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | Row


Add Method

Aspose.Cells for .NET

WorksheetCollection.Add Method

Adds a worksheet to the collection.

Overload List

Adds a worksheet to the collection.

public int Add();

Adds a worksheet to the collection.

public Worksheet Add(string);

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.Add Method ()

Adds a worksheet to the collection.

public int Add();

Return Value

Worksheet object index.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.Add Overload List


WorksheetCollection.Add Method (String)

Adds a worksheet to the collection.

public Worksheet Add(
string sheetName
);

Parameters

sheetName
Worksheet name

Return Value

Worksheet object.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.Add Overload List


AddCopy Method

Aspose.Cells for .NET

WorksheetCollection.AddCopy Method

Adds a worksheet to the collection and copies data from an existed worksheet.

Overload List

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(int);

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(string);

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.AddCopy Method (Int32)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
int sheetIndex
);

Parameters

sheetIndex
Index of source worksheet.

Return Value

Worksheet object index.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.AddCopy Overload List


WorksheetCollection.AddCopy Method (String)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
string sheetName
);

Parameters

sheetName
Name of source worksheet.

Return Value

Worksheet object index.

Exceptions

Exception Type | Condition
CellsException | Specifies an invalid worksheet name.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.AddCopy Overload List


WorksheetCollection.CalculateFormula Method

Calculates the result of formulas.

public void CalculateFormula();

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.Clear Method

Clear all worksheets.

public void Clear();

Remarks

A workbook must contains a worksheet.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.IndexOf Method

Searches for the specified sheet and returns the zero-based index of the first occurrence within the entire WorksheetCollection.

public int IndexOf(
Worksheet sheet
);

Parameters

sheet
The sheet to locate in the WorksheetCollection.

Return Value

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


Insert Method

Aspose.Cells for .NET

WorksheetCollection.Insert Method

Inserts an worksheet into the WorksheetCollection at the specified index. This worksheet row count is 256,column count is 32. The worksheet name will be generated by Add() method.

Overload List

Inserts an worksheet into the WorksheetCollection at the specified index. This worksheet row count is 256,column count is 32. The worksheet name will be generated by Add() method.

public void Insert(int);

public Worksheet Insert(int,string);

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.Insert Method (Int32)

Inserts an worksheet into the WorksheetCollection at the specified index. This worksheet row count is 256,column count is 32. The worksheet name will be generated by Add() method.

public void Insert(
int index
);

Parameters

index
The zero-based index at which worksheet should be inserted.

Return Value

Return Worksheet object is added.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.Insert Overload List


WorksheetCollection.Insert Method (Int32, String)

public Worksheet Insert(
int index,
string sheetName
);

Parameters

index
sheetName
The sheet name.

Return Value

Returns an inserted worksheet.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.Insert Overload List


WorksheetCollection.MoveTo Method

public void MoveTo(
int movedSheetIndex,
int destSheetIndex
);

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.Remove Method

Removes the worksheet at the specified index of the WorksheetCollection. If the specific sheet is the last sheet,after removes sheet,will add a new sheet to the WorksheetCollection.

public void Remove(
int index
);

Parameters

index
The zero-based index of the worksheet to remove.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


RemoveAt Method

Aspose.Cells for .NET

WorksheetCollection.RemoveAt Method

Removes the element at a specified index.

Overload List

Removes the element at a specified index.

public void RemoveAt(int);

Removes the element at a specified name.

public void RemoveAt(string);

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.RemoveAt Method (Int32)

Removes the element at a specified index.

public void RemoveAt(
int index
);

Parameters

index
The index value of the element to remove.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.RemoveAt Overload List


WorksheetCollection.RemoveAt Method (String)

Removes the element at a specified name.

public void RemoveAt(
string name
);

Parameters

name
The name of the element to remove.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace | WorksheetCollection.RemoveAt Overload List


WorksheetCollection.SetVisible Method

Sets the visible options.

public void SetVisible(
string name,
bool v
);

Parameters

name
v

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetCollection.SwapSheet Method

Swaps the two sheets.

public void SwapSheet(
int sheetIndex1,
int sheetIndex2
);

Parameters

sheetIndex1
The first worksheet.
sheetIndex2
The second worksheet.

See Also

WorksheetCollection Class | Aspose.Cells.GridDesktop Namespace


WorksheetEventArgs Class

Provides data for worksheet events.

For a list of all members of this type, see WorksheetEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridDesktop.WorksheetEventArgs

public class WorksheetEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

WorksheetEventArgs Members | Aspose.Cells.GridDesktop Namespace


WorksheetEventArgs Members

WorksheetEventArgs overview

Public Instance Properties

Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WorksheetEventArgs Class | Aspose.Cells.GridDesktop Namespace


WorksheetEventArgs Properties

The properties of the WorksheetEventArgs class are listed below. For a complete list of WorksheetEventArgs class members, see the WorksheetEventArgs Members topic.

Public Instance Properties

Index | Gets row or column index of worksheet
IndexArray | Gets row or column index array of worksheet
SheetEvents | Gets event category.

See Also

WorksheetEventArgs Class | Aspose.Cells.GridDesktop Namespace


Index Property

Aspose.Cells for .NET

WorksheetEventArgs.Index Property

Gets row or column index of worksheet

public int Index {get;}

See Also

WorksheetEventArgs Class | Aspose.Cells.GridDesktop Namespace


IndexArray Property

Aspose.Cells for .NET

WorksheetEventArgs.IndexArray Property

Gets row or column index array of worksheet

public int[] IndexArray {get;}

See Also

WorksheetEventArgs Class | Aspose.Cells.GridDesktop Namespace


SheetEvents Property

Aspose.Cells for .NET

WorksheetEventArgs.SheetEvents Property

Gets event category.

public WorksheetEvents SheetEvents {get;}

See Also

WorksheetEventArgs Class | Aspose.Cells.GridDesktop Namespace


WorksheetEventHandler Delegate

Represents the method that intend to handle worksheet events.

public delegate void WorksheetEventHandler(
object sender,
WorksheetEventArgs args
);

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


WorksheetEvents Enumeration

Worksheet Events category.

public enum WorksheetEvents

Members

Member Name | Description | Value
RowHeaderClick | Row header is clicked. | 0
RowHeaderDoubleClick | Row header is double clicked. | 1
ColumnHeaderClick | Column header is clicked. | 2
ColumnHeaderDoubleClick | Column header is double clicked. | 3
ColumnsHide | Columns are hidden. | 4
ColumnsUnHide | Columns are unhidden. | 5
RowsHide | Rows are hidden. | 6
RowsUnHide | Rows are unhidden. | 7
RowInserted | new row inserted. | 8
ColumnInserted | new column inserted. | 9
RowFiltered | row filtered. | 10
RowDeleted | row deleted. | 11
ColumnDeleted | column deleted. | 12

Requirements

Namespace: Aspose.Cells.GridDesktop

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop Namespace


Aspose.Cells.GridDesktop.Data

Aspose.Cells for .NET

Aspose.Cells.GridDesktop.Data Namespace

Namespace hierarchy

Classes

Class | Description
DefaultEmptyStyle |
GridCellArea | Represents an area of cells.
GridCellException | Represents a cell operation error.
GridCells | Encapsulates a collection of Cell objects.
GridColumn | Represents a single column in a worksheet.
GridColumnCollection | Collects the objects that represent the individual columns in a worksheet.
GridComment | Encapsulates the object that represents a cell comment.
GridCommentCollection | Encapsulates a collection of Comment objects.
GridFont |
GridHyperlink | Encapsulates the object that represents a hyperlink.
GridHyperlinkCollection | Encapsulates a collection of Hyperlink objects.
GridName | Encapsulates the object that represents a name object.
GridNameCollection | Encapsulates a collection of Name objects.
GridPicture | Encapsulates the object that represents a single picture in a spreadsheet.
GridPictureCollection | Encapsulates a collection of Picture objects.
GridPivotField |
GridPivotFieldCollection | Encapsulates a collection of PivotField objects.
GridPivotItem |
GridPivotItemCollection | Encapsulates a collection of PivotItem objects.
GridPivotTable | Represents a PivotTable report on a worksheet. The PivotTable object is a member of the PivotTables collection. The PivotTables collection contains all the PivotTable objects on a control.
GridPivotTableCollection | Encapsulates a collection of PivotTable objects.
GridRow | Encapsulates the object that represents a single picture in a spreadsheet.
GridRowCollection | Encapsulates a collection of Worksheet objects.
GridShapeCollection |
GridValidation |
GridValidationCollection | Encapsulates a collection of Hyperlink objects.
GridWorkbook | Represents a root object to create an Excel spreadsheet.
OnErrorActionQuery | Used in the CellError event of the GridWeb.

Delegates

Delegate | Description
CellEventHandler | Represents the interface that intend to handle cell events. void handleCellEvent(Object sender, CellEventArgs e);
CellEventStringHandler | Represents the method that intend to handle cell events. same as CellEventHandler interface,but return string result String handleCellEvent(Object sender, CellEventArgs e);
CustomCommandEventHandler | Represents the interface that intend to handle Custom Command events. void handleCellEvent(Object sender, String command);
RowColumnEventHandler | Represents the interface that intend to handle row/column events. void handleCellEvent(Object sender, RowColumnEventArgs e);
WorkbookEventHandler | Represents the interface that intend to handle workbook events. void handleCellEvent(Object sender, CellEventArgs e);

Enumerations

Enumeration | Description
GridCellErrorType | Used in WebCellException. Represents the cell error type.
GridFilterOperatorType | Custom Filter operator type.
GridImageType | Specifies the type (format) of an image.
GridMsoDrawingType |
GridOperatorType |
GridPasteType | Represents the paste special type.
GridPivotFieldFunction |
GridPivotFieldType |
GridSaveFormat | Enumerates supported file format types.
GridValidationType |
NumberType | Represents the number or datetime format type.
OnErrorActionType | Used in CellError event of the GridWeb. User set the OnErrorActionQuery.OnErrorAction to tell the control Stop processing or Ignore error.
WebCellErrorType | Used in WebCellException. Represents the cell error type.


CellEventHandler Delegate

Represents the interface that intend to handle cell events.

void handleCellEvent(Object sender, CellEventArgs e);

public delegate void CellEventHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source grid of the event.
e
The event argument. The e.Cell is the cell who fires the event. The e.Argument contains the argument of the event.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


CellEventStringHandler Delegate

Represents the method that intend to handle cell events. same as CellEventHandler interface,but return string result

String handleCellEvent(Object sender, CellEventArgs e);

public delegate string CellEventStringHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source grid of the event.
e
The event argument. The e.Cell is the cell who fires the event. The e.Argument contains the argument of the event.

Return Value

string value

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


CustomCommandEventHandler Delegate

Represents the interface that intend to handle Custom Command events.

void handleCellEvent(Object sender, String command);

public delegate void CustomCommandEventHandler(
object sender,
string command
);

Parameters

sender
The source grid of the event.
command
The command string user send.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle Class

For a list of all members of this type, see DefaultEmptyStyle Members.

System.Object
Aspose.Cells.GridDesktop.Data.DefaultEmptyStyle

public class DefaultEmptyStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

DefaultEmptyStyle Members | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle Members

DefaultEmptyStyle overview

Public Instance Constructors

DefaultEmptyStyle Constructor Style Constructor.

Public Instance Fields

Color |
Custom | Gets or sets the custom number format string.
HAlignment |
NumberFormat |
PatternColor |
Shrink | Gets or sets Shrink to fit attribute.
TextWrapped |
VAlignment |

Public Instance Methods

Equals (inherited from Object)
GetFormBordersStyle
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle Constructor

Style Constructor.

public DefaultEmptyStyle(
GridDesktop gridDesktop
);

Parameters

gridDesktop
GridDesktop object.

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle Fields

The fields of the DefaultEmptyStyle class are listed below. For a complete list of DefaultEmptyStyle class members, see the DefaultEmptyStyle Members topic.

Public Instance Fields

Color |
Custom | Gets or sets the custom number format string.
HAlignment |
NumberFormat |
PatternColor |
Shrink | Gets or sets Shrink to fit attribute.
TextWrapped |
VAlignment |

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.Color Field

public Color Color;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.Custom Field

Gets or sets the custom number format string.

public string Custom;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.HAlignment Field

public HorizontalAlignmentType HAlignment;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.NumberFormat Field

public int NumberFormat;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.PatternColor Field

public Color PatternColor;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.Shrink Field

Gets or sets Shrink to fit attribute.

public bool Shrink;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.TextWrapped Field

public bool TextWrapped;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.VAlignment Field

public VerticalAlignmentType VAlignment;

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle Methods

The methods of the DefaultEmptyStyle class are listed below. For a complete list of DefaultEmptyStyle class members, see the DefaultEmptyStyle Members topic.

Public Instance Methods

Equals (inherited from Object)
GetFormBordersStyle
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


DefaultEmptyStyle.GetFormBordersStyle Method

public void GetFormBordersStyle(
Style style
);

See Also

DefaultEmptyStyle Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea Class

Represents an area of cells.

For a list of all members of this type, see GridCellArea Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridCellArea

public class GridCellArea

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridCellArea Members | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea Members

GridCellArea overview

Public Instance Constructors

GridCellArea Constructor Initializes a new instance of the GridCellArea class.

Public Instance Fields

EndColumn | Gets or sets the end column of this area.
EndRow | Gets or sets the end row of this area.
StartColumn | Gets or sets the start column of this area.
StartRow | Gets or sets the start row of this area.

Public Instance Methods

Equals | Test if the object equals to another WebCellArea object.
GetHashCode | Get the hashcode.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea Constructor

Initializes a new instance of the GridCellArea class.

public GridCellArea();

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea Fields

The fields of the GridCellArea class are listed below. For a complete list of GridCellArea class members, see the GridCellArea Members topic.

Public Instance Fields

EndColumn | Gets or sets the end column of this area.
EndRow | Gets or sets the end row of this area.
StartColumn | Gets or sets the start column of this area.
StartRow | Gets or sets the start row of this area.

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea.EndColumn Field

Gets or sets the end column of this area.

public int EndColumn;

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea.EndRow Field

Gets or sets the end row of this area.

public int EndRow;

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea.StartColumn Field

Gets or sets the start column of this area.

public int StartColumn;

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea.StartRow Field

Gets or sets the start row of this area.

public int StartRow;

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea Methods

The methods of the GridCellArea class are listed below. For a complete list of GridCellArea class members, see the GridCellArea Members topic.

Public Instance Methods

Equals | Test if the object equals to another WebCellArea object.
GetHashCode | Get the hashcode.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea.Equals Method

Test if the object equals to another WebCellArea object.

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellArea.GetHashCode Method

Get the hashcode.

public override int GetHashCode();

Return Value

See Also

GridCellArea Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellErrorType Enumeration

Used in WebCellException. Represents the cell error type.

public enum GridCellErrorType

Members

Member Name | Description | Value
ValidationError | The cell's validation failed. | 0
DataSourceInsertError | When insert the sheet's binding row to datasource, an error occured. | 1
DataSourceUpdateError | When update the sheet's binding row or object's field, an error occured. | 2
DataSourceDeleteError | When delete the sheet's binding row to datasource, an error occured. | 3

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridCellException Class

Represents a cell operation error.

For a list of all members of this type, see GridCellException Members.

System.Object
System.Exception
Aspose.Cells.GridDesktop.Data.GridCellException

public class GridCellException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridCellException Members | Aspose.Cells.GridDesktop.Data Namespace


GridCellException Members

GridCellException overview

Public Instance Properties

Cell | Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.
Data (inherited from Exception) |
ErrorType | Gets the error type.
ErrorValue | Get the error value.
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

See Also

GridCellException Class | Aspose.Cells.GridDesktop.Data Namespace


GridCellException Properties

The properties of the GridCellException class are listed below. For a complete list of GridCellException class members, see the GridCellException Members topic.

Public Instance Properties

Cell | Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.
Data (inherited from Exception) |
ErrorType | Gets the error type.
ErrorValue | Get the error value.
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

See Also

GridCellException Class | Aspose.Cells.GridDesktop.Data Namespace


Cell Property

Aspose.Cells for .NET

GridCellException.Cell Property

Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.

public GridCell Cell {get;}

See Also

GridCellException Class | Aspose.Cells.GridDesktop.Data Namespace


ErrorType Property

Aspose.Cells for .NET

GridCellException.ErrorType Property

Gets the error type.

public GridCellErrorType ErrorType {get;}

See Also

GridCellException Class | Aspose.Cells.GridDesktop.Data Namespace


ErrorValue Property

Aspose.Cells for .NET

GridCellException.ErrorValue Property

Get the error value.

public string ErrorValue {get;}

See Also

GridCellException Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells Class

Encapsulates a collection of Cell objects.

For a list of all members of this type, see GridCells Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridCells

public class GridCells : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridCells Members | Aspose.Cells.GridDesktop.Data Namespace


GridCells Members

GridCells overview

Public Static Methods

CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.

Public Instance Properties

Columns |
Count | Gets the number of cells.
FirstCell |
Item | Overloaded. Gets Cell item within the worksheet
LastCell |
MaxColumn | Maximum column index of cell which contains data or style.
MaxDataColumn |
MaxDataRow |
MaxRow | Maximum row index of cell which contains data or style.
MergedCells | Gets the collection of merged cells.
MinColumn |
MinDataColumn |
MinDataRow |
MinRow |
RowEnumerator | Gets the rows enumerator
Rows |
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet,in unit of pixels.
StandardWidth | Gets or sets the default column width in the worksheet,in unit of characters.
StandardWidthInch |
StandardWidthPixels |

Public Instance Methods

Clear | Clear all cells in the collection.
ClearContents | Overloaded. Clears contents of a range.
ClearFormats | Overloaded. Clears formatting of a range.
ClearRange | Overloaded. Clears contents and formatting of a range.
CopyColumn | Copies data and formattings of a whole column.
CopyColumns | Copies data and formattings of a whole column.
CopyRow | Copies data and formattings of a whole row.
CopyRows | Copies data and formattings of some whole rows.
DeleteBlankColumns | Delete all blank columns which do not contain any data.
DeleteBlankRows | Delete all blank rows which do not contain any data.
DeleteColumn | Overloaded. Deletes a column.
DeleteColumns | Deletes several columns.
DeleteRow | Deletes a row.
DeleteRows | Overloaded. Deletes several rows.
Equals (inherited from Object) |
GetCell | Gets the Cell element or null at the specified cell row index and column index.
GetColumn | Gets the Column element or at the specified cell column index.
GetColumnWidth | Gets the width of the specified column
GetColumnWidthInch | Gets the width of the specified column, in units of inches.
GetColumnWidthPixel | Gets the width of the specified column, in units of pixel.
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRow | Gets the Row element or at the specified cell row index.
GetRowHeight | Gets the height of a specified row.
GetRowHeightInch | Gets the height of a specified row in unit of inches.
GetRowHeightPixel | Gets the height of a specified row in unit of pixel.
GetType (inherited from Object) |
GetViewColumnWidthPixel | Get the width in different view type.
GroupColumns | Overloaded. Groups columns.
GroupRows | Groups rows.
HideColumn | Hides a column.
HideRow | Hides a row.
InsertColumn | Overloaded. Inserts a new column into the worksheet.
InsertColumns | Overloaded. Inserts some columns into the worksheet.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Overloaded. Inserts multiple rows into the worksheet.
IsBlankColumn | Checks whether given column is blank(does not contain any data).
IsColumnHidden | Checks whether a column at given index is hidden.
IsRowHidden | Checks whether a row at given index is hidden.
Merge | Merges a specified range of cells into a single cell.
RemoveFormulas | Removes all formula and replaces with the value of the formula.
SetColumnWidth | Sets the width of the specified column.
SetColumnWidthInch | Sets column width in unit of inches.
SetColumnWidthPixel | Sets column width in unit of pixels.
SetRowHeight | Sets the height of the specified row.
SetRowHeightInch | Sets row height in unit of inches.
SetRowHeightPixel | Sets row height in unit of pixels.
SetStyle | Overloaded. Sets the style to a specified range of cells.
Sort | Overloaded. Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.
ToString (inherited from Object) |
UngroupColumns | Ungroups columns.
UngroupRows | Ungroups rows.
UnhideColumn | Unhides a column
UnhideRow | Unhides a row.
UnMerge | Unmerges a specified range of merged cells.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells Properties

The properties of the GridCells class are listed below. For a complete list of GridCells class members, see the GridCells Members topic.

Public Instance Properties

Columns |
Count | Gets the number of cells.
FirstCell |
Item | Overloaded. Gets Cell item within the worksheet
LastCell |
MaxColumn | Maximum column index of cell which contains data or style.
MaxDataColumn |
MaxDataRow |
MaxRow | Maximum row index of cell which contains data or style.
MergedCells | Gets the collection of merged cells.
MinColumn |
MinDataColumn |
MinDataRow |
MinRow |
RowEnumerator | Gets the rows enumerator
Rows |
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet,in unit of pixels.
StandardWidth | Gets or sets the default column width in the worksheet,in unit of characters.
StandardWidthInch |
StandardWidthPixels |

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


Columns Property

Aspose.Cells for .NET

GridCells.Columns Property

public GridColumnCollection Columns {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridCells.Count Property

Gets the number of cells.

public int Count {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


FirstCell Property

Aspose.Cells for .NET

GridCells.FirstCell Property

public GridCell FirstCell {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridCells.Item Property

Gets Cell item within the worksheet

Overload List

Gets Cell item within the worksheet

public Aspose.Cells.GridDesktop.GridCell this[int] {get;}

Gets the Cell element at the specified cell row index and column index.

public Aspose.Cells.GridDesktop.GridCell this[int, int] {get;}

Gets the Cell element at the specified cell name.

public Aspose.Cells.GridDesktop.GridCell this[string] {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridCells.Item Property (Int32)

Gets Cell item within the worksheet

public GridCell this[
int index
] {get;}

Parameters

index
The zero based index of the element.

Property Value

The element at the specified index.

Remarks

This is the indexer for the Cells class. Gets the cell element at the specified index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridCells.Item Property (Int32, Int32)

Gets the Cell element at the specified cell row index and column index.

public GridCell this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

Example

[C#]

 Cells cells = excel.Worksheets[0].Cells;
 Cell cell = cells[0, 0];    //Gets the cell at "A1"

 [Visual Basic]

 Dim cells As Cells =  excel.WorkSheets(0).Cells
 Dim cell As Cell =  cells(0,0)  'Gets the cell at "A1"

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.Item Overload List


Item Property (String)

Aspose.Cells for .NET

GridCells.Item Property (String)

Gets the Cell element at the specified cell name.

public GridCell this[
string cellName
] {get;}

Parameters

cellName
Cell name,including its column letter and row number, for example A5.

Example

[C#]

 Cells cells = excel.Worksheets[0].Cells;
 Cell cell = cells["A1"];    //Gets the cell at "A1"

 [Visual Basic]

 Dim cells As Cells =  excel.Worksheets(0).Cells
 Dim cell As Cell =  cells("A1")  'Gets the cell at "A1"

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.Item Overload List


LastCell Property

Aspose.Cells for .NET

GridCells.LastCell Property

public GridCell LastCell {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MaxColumn Property

Aspose.Cells for .NET

GridCells.MaxColumn Property

Maximum column index of cell which contains data or style.

public int MaxColumn {get;}

Remarks

Return -1 if ther is not cell.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MaxDataColumn Property

Aspose.Cells for .NET

GridCells.MaxDataColumn Property

public int MaxDataColumn {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MaxDataRow Property

Aspose.Cells for .NET

GridCells.MaxDataRow Property

public int MaxDataRow {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MaxRow Property

Aspose.Cells for .NET

GridCells.MaxRow Property

Maximum row index of cell which contains data or style.

public int MaxRow {get;}

Remarks

Return -1 if there is no cell whiche contains data or style in the worksheet.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MergedCells Property

Aspose.Cells for .NET

GridCells.MergedCells Property

Gets the collection of merged cells.

public ArrayList MergedCells {get;}

Remarks

In this collection, each item is a GridCellArea structure which represents an area of merged cells.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MinColumn Property

Aspose.Cells for .NET

GridCells.MinColumn Property

public int MinColumn {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MinDataColumn Property

Aspose.Cells for .NET

GridCells.MinDataColumn Property

public int MinDataColumn {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MinDataRow Property

Aspose.Cells for .NET

GridCells.MinDataRow Property

public int MinDataRow {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


MinRow Property

Aspose.Cells for .NET

GridCells.MinRow Property

public int MinRow {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


RowEnumerator Property

Aspose.Cells for .NET

GridCells.RowEnumerator Property

Gets the rows enumerator

public IEnumerator RowEnumerator {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


Rows Property

Aspose.Cells for .NET

GridCells.Rows Property

public GridRowCollection Rows {get;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


StandardHeight Property

Aspose.Cells for .NET

GridCells.StandardHeight Property

Gets or sets the default row height in this worksheet,in unit of points.

public double StandardHeight {get; set;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


StandardHeightPixels Property

Aspose.Cells for .NET

GridCells.StandardHeightPixels Property

Gets or sets the default row height in this worksheet,in unit of pixels.

public int StandardHeightPixels {get; set;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


StandardWidth Property

Aspose.Cells for .NET

GridCells.StandardWidth Property

Gets or sets the default column width in the worksheet,in unit of characters.

public double StandardWidth {get; set;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


StandardWidthInch Property

Aspose.Cells for .NET

GridCells.StandardWidthInch Property

public double StandardWidthInch {get; set;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


StandardWidthPixels Property

Aspose.Cells for .NET

GridCells.StandardWidthPixels Property

public int StandardWidthPixels {get; set;}

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells Methods

The methods of the GridCells class are listed below. For a complete list of GridCells class members, see the GridCells Members topic.

Public Static Methods

CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.

Public Instance Methods

Clear | Clear all cells in the collection.
ClearContents | Overloaded. Clears contents of a range.
ClearFormats | Overloaded. Clears formatting of a range.
ClearRange | Overloaded. Clears contents and formatting of a range.
CopyColumn | Copies data and formattings of a whole column.
CopyColumns | Copies data and formattings of a whole column.
CopyRow | Copies data and formattings of a whole row.
CopyRows | Copies data and formattings of some whole rows.
DeleteBlankColumns | Delete all blank columns which do not contain any data.
DeleteBlankRows | Delete all blank rows which do not contain any data.
DeleteColumn | Overloaded. Deletes a column.
DeleteColumns | Deletes several columns.
DeleteRow | Deletes a row.
DeleteRows | Overloaded. Deletes several rows.
Equals (inherited from Object) |
GetCell | Gets the Cell element or null at the specified cell row index and column index.
GetColumn | Gets the Column element or at the specified cell column index.
GetColumnWidth | Gets the width of the specified column
GetColumnWidthInch | Gets the width of the specified column, in units of inches.
GetColumnWidthPixel | Gets the width of the specified column, in units of pixel.
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRow | Gets the Row element or at the specified cell row index.
GetRowHeight | Gets the height of a specified row.
GetRowHeightInch | Gets the height of a specified row in unit of inches.
GetRowHeightPixel | Gets the height of a specified row in unit of pixel.
GetType (inherited from Object) |
GetViewColumnWidthPixel | Get the width in different view type.
GroupColumns | Overloaded. Groups columns.
GroupRows | Groups rows.
HideColumn | Hides a column.
HideRow | Hides a row.
InsertColumn | Overloaded. Inserts a new column into the worksheet.
InsertColumns | Overloaded. Inserts some columns into the worksheet.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Overloaded. Inserts multiple rows into the worksheet.
IsBlankColumn | Checks whether given column is blank(does not contain any data).
IsColumnHidden | Checks whether a column at given index is hidden.
IsRowHidden | Checks whether a row at given index is hidden.
Merge | Merges a specified range of cells into a single cell.
RemoveFormulas | Removes all formula and replaces with the value of the formula.
SetColumnWidth | Sets the width of the specified column.
SetColumnWidthInch | Sets column width in unit of inches.
SetColumnWidthPixel | Sets column width in unit of pixels.
SetRowHeight | Sets the height of the specified row.
SetRowHeightInch | Sets row height in unit of inches.
SetRowHeightPixel | Sets row height in unit of pixels.
SetStyle | Overloaded. Sets the style to a specified range of cells.
Sort | Overloaded. Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.
ToString (inherited from Object) |
UngroupColumns | Ungroups columns.
UngroupRows | Ungroups rows.
UnhideColumn | Unhides a column
UnhideRow | Unhides a row.
UnMerge | Unmerges a specified range of merged cells.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.CellIndexToName Method

Gets cell name according to its row and column indexes.

public static string CellIndexToName(
int row,
int column
);

Parameters

row
Row index.
column
Column index.

Return Value

Name of cell.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.CellNameToIndex Method

public static void CellNameToIndex(
string cellName,
out int row,
out int column
);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.Clear Method

Clear all cells in the collection.

public void Clear();

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


ClearContents Method

Aspose.Cells for .NET

GridCells.ClearContents Method

Clears contents of a range.

Overload List

Clears contents of a range.

public void ClearContents(GridCellArea);

Clears contents of a range.

public void ClearContents(int,int,int,int);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.ClearContents Method (GridCellArea)

Clears contents of a range.

public void ClearContents(
GridCellArea range
);

Parameters

range
Range to be cleared.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.ClearContents Overload List


GridCells.ClearContents Method (Int32, Int32, Int32, Int32)

Clears contents of a range.

public void ClearContents(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.ClearContents Overload List


ClearFormats Method

Aspose.Cells for .NET

GridCells.ClearFormats Method

Clears formatting of a range.

Overload List

Clears formatting of a range.

public void ClearFormats(GridCellArea);

Clears formatting of a range.

public void ClearFormats(int,int,int,int);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.ClearFormats Method (GridCellArea)

Clears formatting of a range.

public void ClearFormats(
GridCellArea range
);

Parameters

range
Range to be cleared.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.ClearFormats Overload List


GridCells.ClearFormats Method (Int32, Int32, Int32, Int32)

Clears formatting of a range.

public void ClearFormats(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.ClearFormats Overload List


ClearRange Method

Aspose.Cells for .NET

GridCells.ClearRange Method

Clears contents and formatting of a range.

Overload List

Clears contents and formatting of a range.

public void ClearRange(GridCellArea);

Clears contents and formatting of a range.

public void ClearRange(int,int,int,int);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.ClearRange Method (GridCellArea)

Clears contents and formatting of a range.

public void ClearRange(
GridCellArea range
);

Parameters

range
Range to be cleared.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.ClearRange Overload List


GridCells.ClearRange Method (Int32, Int32, Int32, Int32)

Clears contents and formatting of a range.

public void ClearRange(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.ClearRange Overload List


GridCells.ColumnIndexToName Method

Gets column name according to column index.

public static string ColumnIndexToName(
int column
);

Parameters

column
Column index.

Return Value

Name of column.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.ColumnNameToIndex Method

Gets column index according to column name.

public static int ColumnNameToIndex(
string columnName
);

Parameters

columnName
Column name.

Return Value

Column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.CopyColumn Method

Copies data and formattings of a whole column.

public void CopyColumn(
GridCells sourceCells,
int sourceColumnIndex,
int destinationColumnIndex
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.CopyColumns Method

Copies data and formattings of a whole column.

public void CopyColumns(
GridCells sourceCells,
int sourceColumnIndex,
int destinationColumnIndex,
int columnNumber
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.
columnNumber
The copied column number.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.CopyRow Method

Copies data and formattings of a whole row.

public void CopyRow(
GridCells sourceCells,
int sourceRowIndex,
int destinationRowIndex
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.CopyRows Method

Copies data and formattings of some whole rows.

public void CopyRows(
GridCells sourceCells,
int sourceRowIndex,
int destinationRowIndex,
int rowNumber
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.
rowNumber
The copied row number.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.DeleteBlankColumns Method

Delete all blank columns which do not contain any data.

public void DeleteBlankColumns();

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.DeleteBlankRows Method

Delete all blank rows which do not contain any data.

public void DeleteBlankRows();

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


DeleteColumn Method

Aspose.Cells for .NET

GridCells.DeleteColumn Method

Deletes a column.

Overload List

Deletes a column.

public void DeleteColumn(int);

Deletes a column.

public void DeleteColumn(int,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.DeleteColumn Method (Int32)

Deletes a column.

public void DeleteColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.DeleteColumn Overload List


GridCells.DeleteColumn Method (Int32, Boolean)

Deletes a column.

public void DeleteColumn(
int columnIndex,
bool updateReference
);

Parameters

columnIndex
Column index.
updateReference
Indicates if update references in other worksheets.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.DeleteColumn Overload List


GridCells.DeleteColumns Method

Deletes several columns.

public void DeleteColumns(
int columnIndex,
int totalColumns,
bool updateReference
);

Parameters

columnIndex
Column index.
totalColumns
Number of columns to be deleted.
updateReference
Indicates if update references in other worksheets.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.DeleteRow Method

Deletes a row.

public void DeleteRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


DeleteRows Method

Aspose.Cells for .NET

GridCells.DeleteRows Method

Deletes several rows.

Overload List

Deletes several rows.

public bool DeleteRows(int,int);

Deletes multiple rows in the worksheet.

public bool DeleteRows(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.DeleteRows Method (Int32, Int32)

Deletes several rows.

public bool DeleteRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
The first row index to be deleted.
totalRows
Number of rows to be deleted.

Remarks

If the deleted range contains the top part(not whole) of the table(ListObject), the ranged could not be deleted and nothing will be done.It works as MS Excel.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.DeleteRows Overload List


GridCells.DeleteRows Method (Int32, Int32, Boolean)

Deletes multiple rows in the worksheet.

public bool DeleteRows(
int rowIndex,
int totalRows,
bool updateReference
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be deleted.
updateReference
Indicates if update references in other worksheets.

Return Value

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.DeleteRows Overload List


GridCells.GetCell Method

Gets the Cell element or null at the specified cell row index and column index.

public GridCell GetCell(
int row,
int column
);

Parameters

row
Row index
column
Column index

Return Value

Return Cell object if a Cell object exists. Return null if the cell does not exist.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetColumn Method

Gets the Column element or at the specified cell column index.

public GridColumn GetColumn(
int column
);

Parameters

column
Column index

Return Value

If the column object does exist return column object

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetColumnWidth Method

Gets the width of the specified column

public double GetColumnWidth(
int column
);

Parameters

column
Column index

Return Value

Width of column

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetColumnWidthInch Method

Gets the width of the specified column, in units of inches.

public double GetColumnWidthInch(
int column
);

Parameters

column
Column index

Return Value

Width of column

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetColumnWidthPixel Method

Gets the width of the specified column, in units of pixel.

public int GetColumnWidthPixel(
int column
);

Parameters

column
Column index

Return Value

Width of column in normal view.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

Implements

IEnumerable.GetEnumerator

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetRow Method

Gets the Row element or at the specified cell row index.

public GridRow GetRow(
int row
);

Parameters

row
Row index

Return Value

If the row object does exist return Row object

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetRowHeight Method

Gets the height of a specified row.

public double GetRowHeight(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetRowHeightInch Method

Gets the height of a specified row in unit of inches.

public double GetRowHeightInch(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetRowHeightPixel Method

Gets the height of a specified row in unit of pixel.

public int GetRowHeightPixel(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GetViewColumnWidthPixel Method

Get the width in different view type.

public int GetViewColumnWidthPixel(
int column
);

Parameters

column
The column index.

Return Value

the column width in unit of pixels

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GroupColumns Method

Aspose.Cells for .NET

GridCells.GroupColumns Method

Groups columns.

Overload List

Groups columns.

public void GroupColumns(int,int);

Groups columns.

public void GroupColumns(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.GroupColumns Method (Int32, Int32)

Groups columns.

public void GroupColumns(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first column index to be grouped.
lastIndex
The last column index to be grouped.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.GroupColumns Overload List


GridCells.GroupColumns Method (Int32, Int32, Boolean)

Groups columns.

public void GroupColumns(
int firstIndex,
int lastIndex,
bool isHidden
);

Parameters

firstIndex
The first column index to be grouped.
lastIndex
The last column index to be grouped.
isHidden
Specifies if the grouped columns are hidden.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.GroupColumns Overload List


GridCells.GroupRows Method

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.HideColumn Method

Hides a column.

public void HideColumn(
int column
);

Parameters

column
Column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.HideRow Method

Hides a row.

public void HideRow(
int row
);

Parameters

row
Row index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


InsertColumn Method

Aspose.Cells for .NET

GridCells.InsertColumn Method

Inserts a new column into the worksheet.

Overload List

Inserts a new column into the worksheet.

public void InsertColumn(int);

Inserts a new column into the worksheet.

public void InsertColumn(int,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.InsertColumn Method (Int32)

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.InsertColumn Overload List


GridCells.InsertColumn Method (Int32, Boolean)

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex,
bool updateReference
);

Parameters

columnIndex
Column index.
updateReference
Indicates if references in other worksheets will be updated.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.InsertColumn Overload List


InsertColumns Method

Aspose.Cells for .NET

GridCells.InsertColumns Method

Inserts some columns into the worksheet.

Overload List

Inserts some columns into the worksheet.

public void InsertColumns(int,int);

Inserts some columns into the worksheet.

public void InsertColumns(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.InsertColumns Method (Int32, Int32)

Inserts some columns into the worksheet.

public void InsertColumns(
int columnIndex,
int totalColumns
);

Parameters

columnIndex
Column index.
totalColumns
The number of columns.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.InsertColumns Overload List


GridCells.InsertColumns Method (Int32, Int32, Boolean)

Inserts some columns into the worksheet.

public void InsertColumns(
int columnIndex,
int totalColumns,
bool updateReference
);

Parameters

columnIndex
Column index.
totalColumns
The number of columns.
updateReference
Indicates if references in other worksheets will be updated.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.InsertColumns Overload List


GridCells.InsertRow Method

Inserts a new row into the worksheet.

public void InsertRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


InsertRows Method

Aspose.Cells for .NET

GridCells.InsertRows Method

Inserts multiple rows into the worksheet.

Overload List

Inserts multiple rows into the worksheet.

public void InsertRows(int,int);

Inserts multiple rows into the worksheet.

public void InsertRows(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.InsertRows Method (Int32, Int32)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.InsertRows Overload List


GridCells.InsertRows Method (Int32, Int32, Boolean)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows,
bool updateReference
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.
updateReference
Indicates if references in other worksheets will be updated.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.InsertRows Overload List


GridCells.IsBlankColumn Method

Checks whether given column is blank(does not contain any data).

public bool IsBlankColumn(
int columnIndex
);

Parameters

columnIndex
the column index

Return Value

true if given column does not contain any data

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.IsColumnHidden Method

Checks whether a column at given index is hidden.

public bool IsColumnHidden(
int columnIndex
);

Parameters

columnIndex
column index

Return Value

true if the column is hidden.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.IsRowHidden Method

Checks whether a row at given index is hidden.

public bool IsRowHidden(
int rowIndex
);

Parameters

rowIndex
row index

Return Value

true if the row is hidden

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.Merge Method

Merges a specified range of cells into a single cell.

public void Merge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.RemoveFormulas Method

Removes all formula and replaces with the value of the formula.

public void RemoveFormulas();

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetColumnWidth Method

Sets the width of the specified column.

public void SetColumnWidth(
int column,
double width
);

Parameters

column
Column index.
width
Width of column.Column width must be between 0 and 255.

Remarks

To hide a column, sets column width to zero.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetColumnWidthInch Method

Sets column width in unit of inches.

public void SetColumnWidthInch(
int column,
double inches
);

Parameters

column
Column index.
inches
Number of inches.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetColumnWidthPixel Method

Sets column width in unit of pixels.

public void SetColumnWidthPixel(
int column,
int pixel
);

Parameters

column
Column index.
pixel
Number of pixels.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetRowHeight Method

Sets the height of the specified row.

public void SetRowHeight(
int row,
double height
);

Parameters

row
Row index.
height
Height of row.In unit of point It should be between 0 and 409.5.

Remarks

To hide a row, sets row height to zero.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetRowHeightInch Method

Sets row height in unit of inches.

public void SetRowHeightInch(
int row,
double inches
);

Parameters

row
Row index.
inches
Number of inches.It should be between 0 and 409.5/72.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetRowHeightPixel Method

Sets row height in unit of pixels.

public void SetRowHeightPixel(
int row,
int pixels
);

Parameters

row
Row index.
pixels
Number of pixels.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


SetStyle Method

Aspose.Cells for .NET

GridCells.SetStyle Method

Sets the style to a specified range of cells.

Overload List

Sets the style to a specified range of cells.

public void SetStyle(int,int,int,int,Style);

Sets the style to a specified range of cells.

public void SetStyle(string,Style);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.SetStyle Method (Int32, Int32, Int32, Int32, Style)

Sets the style to a specified range of cells.

public void SetStyle(
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
Style style
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
rowNumber
Number of rows(one based)
columnNumber
Number of columns(one based)
style
The style object to be set

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.SetStyle Overload List


GridCells.SetStyle Method (String, Style)

Sets the style to a specified range of cells.

public void SetStyle(
string cellRange,
Style style
);

Parameters

cellRange
The range of cells' names, like "A1:D6"
style
The style object to be set

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.SetStyle Overload List


Sort Method

Aspose.Cells for .NET

GridCells.Sort Method

Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.

Overload List

Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.

public void Sort(int,int,int,int,int,bool,bool,bool);

public void Sort(int,int,int,int,int[],SortOrder[],SortOrientation,bool);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.Sort Method (Int32, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)

Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int index,
bool isAsending,
bool isCaseSensitive,
bool islefttoright
);

Parameters

startRow
The row number of the first cell to sort.
startColumn
The column number of the first cell to sort.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
index
The column index that specifis the sort column. if the Orientation is top to bottom ,it stand for the column index that specifis the sort column. if the Orientation is from left to right,it stand for the row index that specifis the sort row.
isAsending
whether the sorting order is asending .
isCaseSensitive
whether the sort is casesensitive .
islefttoright
whether the sort orientation is from left to right

Example

[C#]

 GridWeb1.WebWorksheets[0].Cells.Sort(1,0,25,6,3,true,true,false);

 [VB]

 GridWeb1.WebWorksheets(0).Cells.Sort(1,0,25,6,3,true,true,false)

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.Sort Overload List


GridCells.Sort Method (Int32, Int32, Int32, Int32, Int32[], SortOrder[], SortOrientation, Boolean)

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int[] indexes,
SortOrder[] orders,
SortOrientation orientation,
bool isCaseSensitive
);

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace | GridCells.Sort Overload List


GridCells.UngroupColumns Method

Ungroups columns.

public void UngroupColumns(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first column index to be ungrouped.
lastIndex
The last column index to be ungrouped.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.UngroupRows Method

Ungroups rows.

public void UngroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be ungrouped.
lastIndex
The last row index to be ungrouped.

Remarks

Only removes outter group info.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.UnhideColumn Method

Unhides a column

public void UnhideColumn(
int column,
double width
);

Parameters

column
Column index.
width
Column width..Column width must be between 0 and 255

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.UnhideRow Method

Unhides a row.

public void UnhideRow(
int row
);

Parameters

row
Row index.

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridCells.UnMerge Method

Unmerges a specified range of merged cells.

public void UnMerge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

See Also

GridCells Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn Class

Represents a single column in a worksheet.

For a list of all members of this type, see GridColumn Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridColumn

public class GridColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridColumn Members | Aspose.Cells.GridDesktop.Data Namespace


GridColumn Members

GridColumn overview

Public Static Fields

DEFAULT_WIDTH Default width of gridcolumn.

Public Instance Fields

_filterValue

Public Instance Properties

CellControl | Gets the CellControl object of the column.
FilterIndex |
Header |
Hidden | Indicates whether the column is hidden.
Index | Gets the index of this column.
OutlineLevel |
Width | Gets or sets the width of column object.in unit of pixel

Public Instance Methods

AddButton | Adds a button to the column.
AddCheckBox | Adds a checkbox to the column.
AddComboBox | Overloaded. Adds a combobox to the column.
AddValidation | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetStyle |
GetType (inherited from Object) |
RemoveCellControl | Removes the CellControl object of the column.
SetStyle |
ToString (inherited from Object) |

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn Fields

The fields of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Static Fields

DEFAULT_WIDTH Default width of gridcolumn.

Public Instance Fields

_filterValue

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn._filterValue Field

public object _filterValue;

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.DEFAULT_WIDTH Field

Default width of gridcolumn.

public static int DEFAULT_WIDTH;

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn Properties

The properties of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Instance Properties

CellControl | Gets the CellControl object of the column.
FilterIndex |
Header |
Hidden | Indicates whether the column is hidden.
Index | Gets the index of this column.
OutlineLevel |
Width | Gets or sets the width of column object.in unit of pixel

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


CellControl Property

Aspose.Cells for .NET

GridColumn.CellControl Property

Gets the CellControl object of the column.

public CellControl CellControl {get;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


FilterIndex Property

Aspose.Cells for .NET

GridColumn.FilterIndex Property

public int FilterIndex {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


Header Property

Aspose.Cells for .NET

GridColumn.Header Property

public string Header {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


Hidden Property

Aspose.Cells for .NET

GridColumn.Hidden Property

Indicates whether the column is hidden.

public bool Hidden {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


Index Property

Aspose.Cells for .NET

GridColumn.Index Property

Gets the index of this column.

public int Index {get;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


OutlineLevel Property

Aspose.Cells for .NET

GridColumn.OutlineLevel Property

public byte OutlineLevel {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


Width Property

Aspose.Cells for .NET

GridColumn.Width Property

Gets or sets the width of column object.in unit of pixel

public int Width {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn Methods

The methods of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Instance Methods

AddButton | Adds a button to the column.
AddCheckBox | Adds a checkbox to the column.
AddComboBox | Overloaded. Adds a combobox to the column.
AddValidation | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetStyle |
GetType (inherited from Object) |
RemoveCellControl | Removes the CellControl object of the column.
SetStyle |
ToString (inherited from Object) |

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.AddButton Method

Adds a button to the column.

public void AddButton(
int width,
int height,
string text
);

Parameters

width
Width of button.
height
Height of button.
text
Button text.

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.AddCheckBox Method

Adds a checkbox to the column.

public void AddCheckBox();

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


AddComboBox Method

Aspose.Cells for .NET

GridColumn.AddComboBox Method

Adds a combobox to the column.

Overload List

Adds a combobox to the column.

public void AddComboBox(ICollection);

Adds a combobox to the column.

public void AddComboBox(ICollection,ICollection);

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.AddComboBox Method (ICollection)

Adds a combobox to the column.

public void AddComboBox(
ICollection items
);

Parameters

items
The collection of the items contained in ComboBox.

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace | GridColumn.AddComboBox Overload List


GridColumn.AddComboBox Method (ICollection, ICollection)

Adds a combobox to the column.

public void AddComboBox(
ICollection items,
ICollection values
);

Parameters

items
The collection of the items contained in ComboBox.
values
The collection of the values contained in ComboBox.

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace | GridColumn.AddComboBox Overload List


AddValidation Method

Aspose.Cells for .NET

GridColumn.AddValidation Method

Overload List

public void AddValidation(ICustomValidation);

Adds a validation to the column.

public void AddValidation(bool,string);

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.AddValidation Method (ICustomValidation)

public void AddValidation(
ICustomValidation val
);

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace | GridColumn.AddValidation Overload List


GridColumn.AddValidation Method (Boolean, String)

Adds a validation to the column.

public void AddValidation(
bool isRequired,
string regEx
);

Parameters

isRequired
Value indicating whether cell value of this column is required.
regEx
Regular expression.

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace | GridColumn.AddValidation Overload List


GridColumn.GetStyle Method

public Style GetStyle();

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.RemoveCellControl Method

Removes the CellControl object of the column.

public void RemoveCellControl();

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumn.SetStyle Method

public void SetStyle(
Style style
);

See Also

GridColumn Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumnCollection Class

Collects the objects that represent the individual columns in a worksheet.

For a list of all members of this type, see GridColumnCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridColumnCollection

public class GridColumnCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridColumnCollection Members | Aspose.Cells.GridDesktop.Data Namespace | Column


GridColumnCollection Members

GridColumnCollection overview

Public Instance Properties

Count |
Item | Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

Public Instance Methods

Equals (inherited from Object) |
GetColumnByIndex | Gets the Column object by the position in the list.
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace | Column


GridColumnCollection Properties

The properties of the GridColumnCollection class are listed below. For a complete list of GridColumnCollection class members, see the GridColumnCollection Members topic.

Public Instance Properties

Count |
Item | Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace | Column


Count Property

Aspose.Cells for .NET

GridColumnCollection.Count Property

public int Count {get;}

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridColumnCollection.Item Property

Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

public GridColumn this[
int columnIndex
] {get;}

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace | Column


GridColumnCollection Methods

The methods of the GridColumnCollection class are listed below. For a complete list of GridColumnCollection class members, see the GridColumnCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetColumnByIndex | Gets the Column object by the position in the list.
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace | Column


GridColumnCollection.GetColumnByIndex Method

Gets the Column object by the position in the list.

public GridColumn GetColumnByIndex(
int index
);

Parameters

index
The position in the list.

Return Value

Returns the column object.

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridColumnCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridColumnCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridComment Class

Encapsulates the object that represents a cell comment.

For a list of all members of this type, see GridComment Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridComment

public class GridComment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridComment Members | Aspose.Cells.GridDesktop.Data Namespace


GridComment Members

GridComment overview

Public Instance Properties

Author |
AutoSize |
Column |
Height | Get or set the height of the comment. Default value is 120. The input value should between 20 and 1000. It will be set to 20 if a value less than 20 is inputted. It will be set to 1000 if a value greater than 1000 is inputed.
HeightCM |
HeightInch |
HtmlNote |
IsVisible |
Note |
Row |
Text |
Visible |
Width | Get or set the width of the comment. Default value is 140. The input value should between 20 and 1000. It will be set to 20 if a value less than 20 is inputted. It will be set to 1000 if a value greater than 1000 is inputed.
WidthCM |
WidthInch |

Public Instance Methods

Equals
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


GridComment Properties

The properties of the GridComment class are listed below. For a complete list of GridComment class members, see the GridComment Members topic.

Public Instance Properties

Author |
AutoSize |
Column |
Height | Get or set the height of the comment. Default value is 120. The input value should between 20 and 1000. It will be set to 20 if a value less than 20 is inputted. It will be set to 1000 if a value greater than 1000 is inputed.
HeightCM |
HeightInch |
HtmlNote |
IsVisible |
Note |
Row |
Text |
Visible |
Width | Get or set the width of the comment. Default value is 140. The input value should between 20 and 1000. It will be set to 20 if a value less than 20 is inputted. It will be set to 1000 if a value greater than 1000 is inputed.
WidthCM |
WidthInch |

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Author Property

Aspose.Cells for .NET

GridComment.Author Property

public string Author {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


AutoSize Property

Aspose.Cells for .NET

GridComment.AutoSize Property

public bool AutoSize {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Column Property

Aspose.Cells for .NET

GridComment.Column Property

public int Column {get;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Height Property

Aspose.Cells for .NET

GridComment.Height Property

Get or set the height of the comment. Default value is 120. The input value should between 20 and 1000. It will be set to 20 if a value less than 20 is inputted. It will be set to 1000 if a value greater than 1000 is inputed.

public int Height {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


HeightCM Property

Aspose.Cells for .NET

GridComment.HeightCM Property

public double HeightCM {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


HeightInch Property

Aspose.Cells for .NET

GridComment.HeightInch Property

public double HeightInch {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


HtmlNote Property

Aspose.Cells for .NET

GridComment.HtmlNote Property

public string HtmlNote {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


IsVisible Property

Aspose.Cells for .NET

GridComment.IsVisible Property

public bool IsVisible {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Note Property

Aspose.Cells for .NET

GridComment.Note Property

public string Note {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Row Property

Aspose.Cells for .NET

GridComment.Row Property

public int Row {get;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Text Property

Aspose.Cells for .NET

GridComment.Text Property

public string Text {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Visible Property

Aspose.Cells for .NET

GridComment.Visible Property

public bool Visible {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


Width Property

Aspose.Cells for .NET

GridComment.Width Property

Get or set the width of the comment. Default value is 140. The input value should between 20 and 1000. It will be set to 20 if a value less than 20 is inputted. It will be set to 1000 if a value greater than 1000 is inputed.

public int Width {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


WidthCM Property

Aspose.Cells for .NET

GridComment.WidthCM Property

public double WidthCM {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


WidthInch Property

Aspose.Cells for .NET

GridComment.WidthInch Property

public double WidthInch {get; set;}

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


GridComment Methods

The methods of the GridComment class are listed below. For a complete list of GridComment class members, see the GridComment Members topic.

Public Instance Methods

Equals
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


GridComment.Equals Method

public override bool Equals(
object t
);

See Also

GridComment Class | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection Class

Encapsulates a collection of Comment objects.

For a list of all members of this type, see GridCommentCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridCommentCollection

public class GridCommentCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridCommentCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection Members

GridCommentCollection overview

Public Instance Properties

Count |
Item | Overloaded. Gets the Comment element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a comment to the collection.
Clear | Removes all comments;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Removes the comment at the specified row column index of the cell.
RemoveAt | Overloaded. Removes the comment of the specific cell.
ToString (inherited from Object) |

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection Properties

The properties of the GridCommentCollection class are listed below. For a complete list of GridCommentCollection class members, see the GridCommentCollection Members topic.

Public Instance Properties

Count |
Item | Overloaded. Gets the Comment element at the specified index.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridCommentCollection.Count Property

public int Count {get;}

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridCommentCollection.Item Property

Gets the Comment element at the specified index.

Overload List

Gets the Comment element at the specified index.

public GridComment this[int] {get;}

Gets the Comment element at the specified row index and column index.

public GridComment this[int, int] {get;}

Gets the Comment element at the specified cell.

public GridComment this[string] {get;}

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridCommentCollection.Item Property (Int32)

Gets the Comment element at the specified index.

public GridComment this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridCommentCollection.Item Property (Int32, Int32)

Gets the Comment element at the specified row index and column index.

public GridComment this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

GridCommentCollection.Item Property (String)

Gets the Comment element at the specified cell.

public GridComment this[
string cellName
] {get;}

Parameters

cellName
Cell name.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Item Overload List


GridCommentCollection Methods

The methods of the GridCommentCollection class are listed below. For a complete list of GridCommentCollection class members, see the GridCommentCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a comment to the collection.
Clear | Removes all comments;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Removes the comment at the specified row column index of the cell.
RemoveAt | Overloaded. Removes the comment of the specific cell.
ToString (inherited from Object) |

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Add Method

Aspose.Cells for .NET

GridCommentCollection.Add Method

Adds a comment to the collection.

Overload List

Adds a comment to the collection.

public int Add(int,int);

public void Add(int,int,string);

Adds a comment to the collection.

public int Add(string);

Adds a comment to a specified cell by cell name.

public void Add(string,string);

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection.Add Method (Int32, Int32)

Adds a comment to the collection.

public int Add(
int row,
int column
);

Parameters

row
Cell row index.
column
Cell column index.

Return Value

Comment object index.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Add Overload List


GridCommentCollection.Add Method (Int32, Int32, String)

public void Add(
int row,
int column,
string text
);

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Add Overload List


GridCommentCollection.Add Method (String)

Adds a comment to the collection.

public int Add(
string cellName
);

Parameters

cellName
Cell name.

Return Value

Comment object index.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Add Overload List


GridCommentCollection.Add Method (String, String)

Adds a comment to a specified cell by cell name.

public void Add(
string cellName,
string text
);

Parameters

cellName
Name of grid cell.
text
Text of comment.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.Add Overload List


GridCommentCollection.Clear Method

Removes all comments;

public void Clear();

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection.Remove Method

Removes the comment at the specified row column index of the cell.

public void Remove(
int row,
int col
);

Parameters

row
Row index of cell.
col
Column index of cell.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


RemoveAt Method

Aspose.Cells for .NET

GridCommentCollection.RemoveAt Method

Removes the comment of the specific cell.

Overload List

Removes the comment of the specific cell.

public void RemoveAt(int,int);

Removes the comment of the specific cell.

public void RemoveAt(string);

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridCommentCollection.RemoveAt Method (Int32, Int32)

Removes the comment of the specific cell.

public void RemoveAt(
int row,
int column
);

Parameters

row
The row index.
column
the column index.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.RemoveAt Overload List


GridCommentCollection.RemoveAt Method (String)

Removes the comment of the specific cell.

public void RemoveAt(
string cellName
);

Parameters

cellName
The name of cell which contains a comment.

See Also

GridCommentCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridCommentCollection.RemoveAt Overload List


GridFilterOperatorType Enumeration

Custom Filter operator type.

public enum GridFilterOperatorType

Members

Member Name | Description | Value
LessOrEqual | Represents LessOrEqual operator. | 0
LessThan | Represents LessThan operator. | 1
Equal | Represents Equal operator. | 2
GreaterThan | Represents GreaterThan operator. | 3
NotEqual | Represents NotEqual operator. | 4
GreaterOrEqual | Represents GreaterOrEqual operator. | 5
None | Represents no comparision. | 6
BeginsWith | Begins with the text. | 7
EndsWith | Ends with the text. | 8
Contains | Contains the text. | 9
NotContains | Doese not contains the text. | 10

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridFont Class

For a list of all members of this type, see GridFont Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridFont

public class GridFont

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridFont Members | Aspose.Cells.GridDesktop.Data Namespace


GridFont Members

GridFont overview

Public Instance Properties

color
DoubleUnderLine
font

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridFont Class | Aspose.Cells.GridDesktop.Data Namespace


GridFont Properties

The properties of the GridFont class are listed below. For a complete list of GridFont class members, see the GridFont Members topic.

Public Instance Properties

color
DoubleUnderLine
font

See Also

GridFont Class | Aspose.Cells.GridDesktop.Data Namespace


color Property

Aspose.Cells for .NET

GridFont.color Property

public Color color {get; set;}

See Also

GridFont Class | Aspose.Cells.GridDesktop.Data Namespace


DoubleUnderLine Property

Aspose.Cells for .NET

GridFont.DoubleUnderLine Property

public bool DoubleUnderLine {get; set;}

See Also

GridFont Class | Aspose.Cells.GridDesktop.Data Namespace


font Property

Aspose.Cells for .NET

GridFont.font Property

public Font font {get; set;}

See Also

GridFont Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlink Class

Encapsulates the object that represents a hyperlink.

For a list of all members of this type, see GridHyperlink Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridHyperlink

public class GridHyperlink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridHyperlink Members | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlink Members

GridHyperlink overview

Public Instance Properties

Address | Represents the address of a hyperlink.
Area | Gets the range of hyperlink.
Command | Returns or sets the self defined command value text for the specified hyperlink.
DiscardInput | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageURL | Get or Set Image URL for the link, there is no imageurl properties in hyperlink, so actually use TextToDisplay to record this value ,TextToDisplay will be set to <img src=value > so it will change the value of TextToDisplay
ScreenTip | Returns or sets the ScreenTip text for the specified hyperlink.
Target | Get or Set web link target type,please note this is an extension attribute and can not keep in excel file
TextToDisplay | Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.
Url |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlink Properties

The properties of the GridHyperlink class are listed below. For a complete list of GridHyperlink class members, see the GridHyperlink Members topic.

Public Instance Properties

Address | Represents the address of a hyperlink.
Area | Gets the range of hyperlink.
Command | Returns or sets the self defined command value text for the specified hyperlink.
DiscardInput | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageURL | Get or Set Image URL for the link, there is no imageurl properties in hyperlink, so actually use TextToDisplay to record this value ,TextToDisplay will be set to <img src=value > so it will change the value of TextToDisplay
ScreenTip | Returns or sets the ScreenTip text for the specified hyperlink.
Target | Get or Set web link target type,please note this is an extension attribute and can not keep in excel file
TextToDisplay | Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.
Url |

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


Address Property

Aspose.Cells for .NET

GridHyperlink.Address Property

Represents the address of a hyperlink.

public string Address {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


Area Property

Aspose.Cells for .NET

GridHyperlink.Area Property

Gets the range of hyperlink.

public GridCellArea Area {get;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


Command Property

Aspose.Cells for .NET

GridHyperlink.Command Property

Returns or sets the self defined command value text for the specified hyperlink.

public string Command {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


DiscardInput Property

Aspose.Cells for .NET

GridHyperlink.DiscardInput Property

Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.

public virtual bool DiscardInput {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


ImageURL Property

Aspose.Cells for .NET

GridHyperlink.ImageURL Property

Get or Set Image URL for the link, there is no imageurl properties in hyperlink, so actually use TextToDisplay to record this value ,TextToDisplay will be set to <img src=value > so it will change the value of TextToDisplay

public string ImageURL {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


ScreenTip Property

Aspose.Cells for .NET

GridHyperlink.ScreenTip Property

Returns or sets the ScreenTip text for the specified hyperlink.

public string ScreenTip {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


Target Property

Aspose.Cells for .NET

GridHyperlink.Target Property

Get or Set web link target type,please note this is an extension attribute and can not keep in excel file

public string Target {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


TextToDisplay Property

Aspose.Cells for .NET

GridHyperlink.TextToDisplay Property

Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

public string TextToDisplay {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


Url Property

Aspose.Cells for .NET

GridHyperlink.Url Property

public string Url {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlinkCollection Class

Encapsulates a collection of Hyperlink objects.

For a list of all members of this type, see GridHyperlinkCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridHyperlinkCollection

public class GridHyperlinkCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridHyperlinkCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlinkCollection Members

GridHyperlinkCollection overview

Public Instance Properties

Count |
Item | Overloaded. Gets the Hyperlink element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a hyperlink to a specified cell or a range of cells.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove |
RemoveAt | Remove the hyperlink at the specified index.
ToString (inherited from Object) |

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlinkCollection Properties

The properties of the GridHyperlinkCollection class are listed below. For a complete list of GridHyperlinkCollection class members, see the GridHyperlinkCollection Members topic.

Public Instance Properties

Count |
Item | Overloaded. Gets the Hyperlink element at the specified index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridHyperlinkCollection.Count Property

public int Count {get;}

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridHyperlinkCollection.Item Property

Gets the Hyperlink element at the specified index.

Overload List

Gets the Hyperlink element at the specified index.

public GridHyperlink this[int] {get;}

Gets the Hyperlink element at the specified cell.

public GridHyperlink this[int, int] {get;}

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridHyperlinkCollection.Item Property (Int32)

Gets the Hyperlink element at the specified index.

public GridHyperlink this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridHyperlinkCollection.Item Property (Int32, Int32)

Gets the Hyperlink element at the specified cell.

public GridHyperlink this[
int row,
int col
] {get;}

Parameters

row
The row of the cell.
col
The col of the cell.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Item Overload List


GridHyperlinkCollection Methods

The methods of the GridHyperlinkCollection class are listed below. For a complete list of GridHyperlinkCollection class members, see the GridHyperlinkCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a hyperlink to a specified cell or a range of cells.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove |
RemoveAt | Remove the hyperlink at the specified index.
ToString (inherited from Object) |

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Add Method

Aspose.Cells for .NET

GridHyperlinkCollection.Add Method

Adds a hyperlink to a specified cell or a range of cells.

Overload List

Adds a hyperlink to a specified cell or a range of cells.

public int Add(int,int,int,int,string);

Adds a hyperlink to a specified cell at row column index.

public void Add(int,int,string);

Adds a hyperlink to a specified cell or a range of cells.

public int Add(string,int,int,string);

Adds a hyperlink to a specified cell .

public int Add(string,string);

Adds a hyperlink to a specified cell or a range of cells.

public int Add(string,string,string,string,string);

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlinkCollection.Add Method (Int32, Int32, Int32, Int32, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
string address
);

Parameters

firstRow
First row of the hyperlink range.
firstColumn
First column of the hyperlink range.
totalRows
Number of rows in this hyperlink range.
totalColumns
Number of columns of this hyperlink range.
address
Address of the hyperlink.

Return Value

Hyperlink object index.

Example

[C#]

 Worksheet worksheet = excel.Worksheets[0];
 worksheet.Hyperlinks.Add("A4", 1, 1, "http://www.aspose.com");
 worksheet.Hyperlinks.Add("A5", 1, 1, "c:\\book1.xls");

 [Visual Basic]

 Dim worksheet as Worksheet = excel.Worksheets(0)
 worksheet.Hyperlinks.Add("A4", 1, 1, "http://www.aspose.com")
 worksheet.Hyperlinks.Add("A5", 1, 1, "c:\\book1.xls")

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (Int32, Int32, String)

Adds a hyperlink to a specified cell at row column index.

public void Add(
int row,
int col,
string url
);

Parameters

row
Row index of cell.
col
Column index of cell.
url
Url of hyperlink.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (String, Int32, Int32, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
string cellName,
int totalRows,
int totalColumns,
string address
);

Parameters

cellName
Cell name.
totalRows
Number of rows in this hyperlink range.
totalColumns
Number of columns of this hyperlink range.
address
Address of the hyperlink.

Return Value

Hyperlink object index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (String, String)

Adds a hyperlink to a specified cell .

public int Add(
string cellName,
string address
);

Parameters

cellName
Cell name.
address
Address of the hyperlink.

Return Value

Hyperlink object index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (String, String, String, String, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
string startCellName,
string endCellName,
string address,
string textToDisplay,
string screenTip
);

Parameters

startCellName
The top-left cell of the range.
endCellName
The bottom-right cell of the range.
address
Address of the hyperlink.
textToDisplay
The text to be displayed for the specified hyperlink.
screenTip
The screenTip text for the specified hyperlink.

Return Value

Hyperlink object index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Clear Method

Clears all hyperlinks.

public void Clear();

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlinkCollection.Remove Method

public void Remove(
int row,
int col
);

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridHyperlinkCollection.RemoveAt Method

Remove the hyperlink at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridImageType Enumeration

Specifies the type (format) of an image.

public enum GridImageType

Members

Member Name | Description | Value
Unknown | An unknown image type. | 0
Emf | Windows Enhanced Metafile. | 2
Wmf | Windows Metafile. | 3
Pict | Macintosh PICT. | 4
Jpeg | JPEG JFIF. | 5
Png | Portable Network Graphics. | 6
Bmp | Windows Bitmam | 7
Gif | Gif | 66
Tiff | Tiff | 67
Svg | Svg | 68
Svm | Svm | 69
Gltf | glTF | 70

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridMsoDrawingType Enumeration

public enum GridMsoDrawingType

Members

Member Name | Description | Value
Group |  | 0
Line |  | 1
Rectangle |  | 2
Oval |  | 3
Arc |  | 4
Chart |  | 5
TextBox |  | 6
Button |  | 7
Picture |  | 8
Polygon |  | 9
CheckBox |  | 11
RadioButton |  | 12
Label |  | 14
DialogBox |  | 15
Spinner |  | 16
ScrollBar |  | 17
ListBox |  | 18
GroupBox |  | 19
ComboBox |  | 20
Comment |  | 25
OleObject |  | 24
CellsDrawing | Only for preserving the drawing object in the template file. | 30
Unknown | Only for preserving the drawing object in the xlsx file. | 29

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridName Class

Encapsulates the object that represents a name object.

For a list of all members of this type, see GridName Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridName

public class GridName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridName Members | Aspose.Cells.GridDesktop.Data Namespace


GridName Members

GridName overview

Public Instance Properties

RefersTo | Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.
SheetIndex | Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)
Text | Gets the name text of the object.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Range object.

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


GridName Properties

The properties of the GridName class are listed below. For a complete list of GridName class members, see the GridName Members topic.

Public Instance Properties

RefersTo | Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.
SheetIndex | Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)
Text | Gets the name text of the object.

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


RefersTo Property

Aspose.Cells for .NET

GridName.RefersTo Property

Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.

public string RefersTo {get; set;}

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


SheetIndex Property

Aspose.Cells for .NET

GridName.SheetIndex Property

Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)

public int SheetIndex {get; set;}

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


Text Property

Aspose.Cells for .NET

GridName.Text Property

Gets the name text of the object.

public string Text {get; set;}

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


GridName Methods

The methods of the GridName class are listed below. For a complete list of GridName class members, see the GridName Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Range object.

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


GridName.ToString Method

Returns a string represents the current Range object.

public override string ToString();

Return Value

See Also

GridName Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection Class

Encapsulates a collection of Name objects.

For a list of all members of this type, see GridNameCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridNameCollection

public class GridNameCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridNameCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection Members

GridNameCollection overview

Public Instance Properties

Count |
Item | Gets the Name element at the specified index.

Public Instance Methods

Add | Overloaded. Defines a new global name.
Clear | Removes all Names;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Remove an array of name
RemoveAt | Remove the name at the specific index.
ToString (inherited from Object) |

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection Properties

The properties of the GridNameCollection class are listed below. For a complete list of GridNameCollection class members, see the GridNameCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Name element at the specified index.

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridNameCollection.Count Property

public int Count {get;}

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridNameCollection.Item Property

Gets the Name element at the specified index.

public GridName this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection Methods

The methods of the GridNameCollection class are listed below. For a complete list of GridNameCollection class members, see the GridNameCollection Members topic.

Public Instance Methods

Add | Overloaded. Defines a new global name.
Clear | Removes all Names;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Remove an array of name
RemoveAt | Remove the name at the specific index.
ToString (inherited from Object) |

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Add Method

Aspose.Cells for .NET

GridNameCollection.Add Method

Defines a new name in the specified sheet.

Overload List

Defines a new name in the specified sheet.

public int Add(int,string,string);

Defines a new global name.

public int Add(string,string);

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection.Add Method (Int32, String, String)

Defines a new name in the specified sheet.

public int Add(
int sheetIndex,
string text,
string refersTo
);

Parameters

sheetIndex
The sheet index that the name is applyed in.Name's SheetIndex ,the index is from 1.
text
Name text.It can not have sheetname .
refersTo
The formula that the name is defined to refer to.It must have sheetname .eg.'sheet hello!'A1:B2.

Return Value

Name object index.

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridNameCollection.Add Overload List


GridNameCollection.Add Method (String, String)

Defines a new global name.

public int Add(
string text,
string refersTo
);

Parameters

text
Name text.It can have sheetname .
refersTo
The formula that the name is defined to refer to.It must have a sheetname .eg.'sheet hello!'A1:B2.

Return Value

Name object index.

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridNameCollection.Add Overload List


GridNameCollection.Clear Method

Removes all Names;

public void Clear();

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection.Remove Method

Remove an array of name

public void Remove(
string[] names
);

Parameters

names
The names' text.

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridNameCollection.RemoveAt Method

Remove the name at the specific index.

public void RemoveAt(
int index
);

Parameters

index

Remarks

Please make sure that the name is not referred by the other formulas before calling the method. And if the name is referred,please only set Name.RefersTo as null.

See Also

GridNameCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridOperatorType Enumeration

public enum GridOperatorType

Members

Member Name | Description | Value
Between | Represents Between operator of conditional format and data validation. | 0
Equal | Represents Equal operator of conditional format and data validation. | 1
GreaterThan | Represents GreaterThan operator of conditional format and data validation. | 2
GreaterOrEqual | Represents GreaterOrEqual operator of conditional format and data validation. | 3
LessThan | Represents LessThan operator of conditional format and data validation. | 4
LessOrEqual | Represents LessOrEqual operator of conditional format and data validation. | 5
None | Represents no comparision. | 6
NotBetween | Represents NotBetween operator of conditional format and data validation. | 7
NotEqual | Represents NotEqual operator of conditional format and data validation. | 8

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridPasteType Enumeration

Represents the paste special type.

public enum GridPasteType

Members

Member Name | Description | Value
All | Copies all data of the ranage. | 0
Default | It works as "All" behavior of MS Excel. | 1
AllExceptBorders | Copies all data of the ranage withoutd the range. | 2
DefaultExceptBorders | It works as "All except borders" behavior of MS Excel. | 3
ColumnWidths | Only copies the widths of the range. | 4
RowHeights | Only copies the heights of the range. | 5
Comments |  | 6
Formats |  | 7
Formulas |  | 8
FormulasAndNumberFormats |  | 9
Validation |  | 10
Values |  | 11
ValuesAndNumberFormats |  | 12

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridPicture Class

Encapsulates the object that represents a single picture in a spreadsheet.

For a list of all members of this type, see GridPicture Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPicture

public class GridPicture

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPicture Members | Aspose.Cells.GridDesktop.Data Namespace


GridPicture Members

GridPicture overview

Public Static Methods

ToStream

Public Instance Fields

_withinCell

Public Instance Properties

ActualHeight |
ActualWidth |
AlternativeText |
BorderLineColor | Represents the Color of the border line of a picture.
BorderWeight | Gets or sets the weight of the border line of a picture in units of pt.
Bottom |
Column |
Data | Gets the data of the picture.
Height | Represents the height of shape, in unit of pixel.
HeightCM | Represents the height of the shape, in unit of inches.
HeightInch | Represents the height of the shape, in unit of inches.
HeightPt | Represents the height of the shape, in unit of points.
HeightScale | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText | Gets and sets the html string which contains data and some formattings in this textbox.
Hyperlink | Gets the hyperlink of the shape.
Image | Gets or sets the Image object.
ImageFormat | Gets the image format of the picture.
IsFlippedVertically | Gets and sets whether shape is vertically flipped .
IsHidden | Indicates whether the object is visible.
IsLockAspectRatio | True means that don't allow changes in aspect ratio.
IsLocked | True if the object is locked, False if the object can be modified when the sheet is protected.
IsOutlineVisible | Gets and sets the line border of the shape is visible.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftOffset | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftToCorner |
LinkedCell | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn | Represents lower right corner column index.
LowerRightRow | Represents lower right corner row index.
Name | Gets and sets the name of the shape.
OriginalHeight | Gets the original height of the picture.
OriginalHeightCM | Gets the original height of picture, in unit of centimeters.
OriginalHeightInch | Gets the original height of picture, in unit of inches.
OriginalWidth | Gets the original width of the picture.
OriginalWidthCM | Gets the original width of picture, in unit of centimeters.
OriginalWidthInch | Gets the original width of picture, in unit of inches.
RelativeToOriginalPictureSize | Indicates whether shape is relative to original picture size.
Right | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle | Gets and sets the rotation of the shape.
Row |
SourceFullName | Gets or sets the path and name of the source file for the linked image.
Text | Represents the string in this TextBox object.
Title |
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch | Represents the vertical offset of shape from its top row, in unit of inches.
TopOffset | Represents the vertical offset of shape from its top row, in unit of pixels.
TopToCorner |
UpperDeltaX | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
Width | Represents the width of shape, in unit of pixels.
WidthCM | Represents the width of the shape, in unit of centimeters.
WidthInch | Represents the width of the shape, in unit of inch.
WidthPt | Represents the width of the shape, in unit of point.
WidthScale | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X | Gets and sets the horizonal offset of shape from worksheet left border,in unit of pixels.
Y | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink | Adds a hyperlink to the shape.
AlignTopRightCorner | Moves the picture to the top-right corner.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsGroup | Indicates whether the shape is a group.
Move | Moves the picture to a specified location.
MoveToRange | Moves the shape to a specified range.
RemoveHyperlink | Remove the hyperlink of the shape.
ToString (inherited from Object) |

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture Fields

The fields of the GridPicture class are listed below. For a complete list of GridPicture class members, see the GridPicture Members topic.

Public Instance Fields

_withinCell

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture._withinCell Field

public bool _withinCell;

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture Properties

The properties of the GridPicture class are listed below. For a complete list of GridPicture class members, see the GridPicture Members topic.

Public Instance Properties

ActualHeight |
ActualWidth |
AlternativeText |
BorderLineColor | Represents the Color of the border line of a picture.
BorderWeight | Gets or sets the weight of the border line of a picture in units of pt.
Bottom |
Column |
Data | Gets the data of the picture.
Height | Represents the height of shape, in unit of pixel.
HeightCM | Represents the height of the shape, in unit of inches.
HeightInch | Represents the height of the shape, in unit of inches.
HeightPt | Represents the height of the shape, in unit of points.
HeightScale | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText | Gets and sets the html string which contains data and some formattings in this textbox.
Hyperlink | Gets the hyperlink of the shape.
Image | Gets or sets the Image object.
ImageFormat | Gets the image format of the picture.
IsFlippedVertically | Gets and sets whether shape is vertically flipped .
IsHidden | Indicates whether the object is visible.
IsLockAspectRatio | True means that don't allow changes in aspect ratio.
IsLocked | True if the object is locked, False if the object can be modified when the sheet is protected.
IsOutlineVisible | Gets and sets the line border of the shape is visible.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch | Represents the horizontal offset of shape from its left column, in unit of inches.
LeftOffset | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftToCorner |
LinkedCell | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn | Represents lower right corner column index.
LowerRightRow | Represents lower right corner row index.
Name | Gets and sets the name of the shape.
OriginalHeight | Gets the original height of the picture.
OriginalHeightCM | Gets the original height of picture, in unit of centimeters.
OriginalHeightInch | Gets the original height of picture, in unit of inches.
OriginalWidth | Gets the original width of the picture.
OriginalWidthCM | Gets the original width of picture, in unit of centimeters.
OriginalWidthInch | Gets the original width of picture, in unit of inches.
RelativeToOriginalPictureSize | Indicates whether shape is relative to original picture size.
Right | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle | Gets and sets the rotation of the shape.
Row |
SourceFullName | Gets or sets the path and name of the source file for the linked image.
Text | Represents the string in this TextBox object.
Title |
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch | Represents the vertical offset of shape from its top row, in unit of inches.
TopOffset | Represents the vertical offset of shape from its top row, in unit of pixels.
TopToCorner |
UpperDeltaX | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
Width | Represents the width of shape, in unit of pixels.
WidthCM | Represents the width of the shape, in unit of centimeters.
WidthInch | Represents the width of the shape, in unit of inch.
WidthPt | Represents the width of the shape, in unit of point.
WidthScale | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X | Gets and sets the horizonal offset of shape from worksheet left border,in unit of pixels.
Y | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition | Returns the position of a shape in the z-order.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


ActualHeight Property

Aspose.Cells for .NET

GridPicture.ActualHeight Property

public int ActualHeight {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


ActualWidth Property

Aspose.Cells for .NET

GridPicture.ActualWidth Property

public int ActualWidth {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


AlternativeText Property

Aspose.Cells for .NET

GridPicture.AlternativeText Property

public string AlternativeText {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


BorderLineColor Property

Aspose.Cells for .NET

GridPicture.BorderLineColor Property

Represents the Color of the border line of a picture.

public Color BorderLineColor {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


BorderWeight Property

Aspose.Cells for .NET

GridPicture.BorderWeight Property

Gets or sets the weight of the border line of a picture in units of pt.

public double BorderWeight {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Bottom Property

Aspose.Cells for .NET

GridPicture.Bottom Property

public int Bottom {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Column Property

Aspose.Cells for .NET

GridPicture.Column Property

public int Column {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Data Property

Aspose.Cells for .NET

GridPicture.Data Property

Gets the data of the picture.

public byte[] Data {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Height Property

Aspose.Cells for .NET

GridPicture.Height Property

Represents the height of shape, in unit of pixel.

public int Height {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


HeightCM Property

Aspose.Cells for .NET

GridPicture.HeightCM Property

Represents the height of the shape, in unit of inches.

public double HeightCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


HeightInch Property

Aspose.Cells for .NET

GridPicture.HeightInch Property

Represents the height of the shape, in unit of inches.

public double HeightInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


HeightPt Property

Aspose.Cells for .NET

GridPicture.HeightPt Property

Represents the height of the shape, in unit of points.

public double HeightPt {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


HeightScale Property

Aspose.Cells for .NET

GridPicture.HeightScale Property

Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;

public int HeightScale {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


HtmlText Property

Aspose.Cells for .NET

GridPicture.HtmlText Property

Gets and sets the html string which contains data and some formattings in this textbox.

public string HtmlText {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Hyperlink Property

Aspose.Cells for .NET

GridPicture.Hyperlink Property

Gets the hyperlink of the shape.

public GridHyperlink Hyperlink {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Image Property

Aspose.Cells for .NET

GridPicture.Image Property

Gets or sets the Image object.

public Image Image {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


ImageFormat Property

Aspose.Cells for .NET

GridPicture.ImageFormat Property

Gets the image format of the picture.

public GridImageType ImageFormat {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


IsFlippedVertically Property

Aspose.Cells for .NET

GridPicture.IsFlippedVertically Property

Gets and sets whether shape is vertically flipped .

public bool IsFlippedVertically {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


IsHidden Property

Aspose.Cells for .NET

GridPicture.IsHidden Property

Indicates whether the object is visible.

public bool IsHidden {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


IsLockAspectRatio Property

Aspose.Cells for .NET

GridPicture.IsLockAspectRatio Property

True means that don't allow changes in aspect ratio.

public bool IsLockAspectRatio {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


IsLocked Property

Aspose.Cells for .NET

GridPicture.IsLocked Property

True if the object is locked, False if the object can be modified when the sheet is protected.

public bool IsLocked {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


IsOutlineVisible Property

Aspose.Cells for .NET

GridPicture.IsOutlineVisible Property

Gets and sets the line border of the shape is visible.

public bool IsOutlineVisible {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


IsTextWrapped Property

Aspose.Cells for .NET

GridPicture.IsTextWrapped Property

Gets and sets the text wrapped type of the shape which contains text.

public bool IsTextWrapped {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Left Property

Aspose.Cells for .NET

GridPicture.Left Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int Left {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LeftCM Property

Aspose.Cells for .NET

GridPicture.LeftCM Property

Represents the horizontal offset of shape from its left column, in unit of centimeters.

public double LeftCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LeftInch Property

Aspose.Cells for .NET

GridPicture.LeftInch Property

Represents the horizontal offset of shape from its left column, in unit of inches.

public double LeftInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LeftOffset Property

Aspose.Cells for .NET

GridPicture.LeftOffset Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int LeftOffset {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LeftToCorner Property

Aspose.Cells for .NET

GridPicture.LeftToCorner Property

public int LeftToCorner {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LinkedCell Property

Aspose.Cells for .NET

GridPicture.LinkedCell Property

Gets or sets the worksheet range linked to the control's value.

public string LinkedCell {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LowerDeltaX Property

Aspose.Cells for .NET

GridPicture.LowerDeltaX Property

Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.

public int LowerDeltaX {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LowerDeltaY Property

Aspose.Cells for .NET

GridPicture.LowerDeltaY Property

Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.

public int LowerDeltaY {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LowerRightColumn Property

Aspose.Cells for .NET

GridPicture.LowerRightColumn Property

Represents lower right corner column index.

public int LowerRightColumn {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


LowerRightRow Property

Aspose.Cells for .NET

GridPicture.LowerRightRow Property

Represents lower right corner row index.

public int LowerRightRow {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Name Property

Aspose.Cells for .NET

GridPicture.Name Property

Gets and sets the name of the shape.

public string Name {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


OriginalHeight Property

Aspose.Cells for .NET

GridPicture.OriginalHeight Property

Gets the original height of the picture.

public int OriginalHeight {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


OriginalHeightCM Property

Aspose.Cells for .NET

GridPicture.OriginalHeightCM Property

Gets the original height of picture, in unit of centimeters.

public double OriginalHeightCM {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


OriginalHeightInch Property

Aspose.Cells for .NET

GridPicture.OriginalHeightInch Property

Gets the original height of picture, in unit of inches.

public double OriginalHeightInch {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


OriginalWidth Property

Aspose.Cells for .NET

GridPicture.OriginalWidth Property

Gets the original width of the picture.

public int OriginalWidth {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


OriginalWidthCM Property

Aspose.Cells for .NET

GridPicture.OriginalWidthCM Property

Gets the original width of picture, in unit of centimeters.

public double OriginalWidthCM {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


OriginalWidthInch Property

Aspose.Cells for .NET

GridPicture.OriginalWidthInch Property

Gets the original width of picture, in unit of inches.

public double OriginalWidthInch {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


RelativeToOriginalPictureSize Property

Aspose.Cells for .NET

GridPicture.RelativeToOriginalPictureSize Property

Indicates whether shape is relative to original picture size.

public bool RelativeToOriginalPictureSize {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Right Property

Aspose.Cells for .NET

GridPicture.Right Property

Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.

public int Right {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


RotationAngle Property

Aspose.Cells for .NET

GridPicture.RotationAngle Property

Gets and sets the rotation of the shape.

public double RotationAngle {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Row Property

Aspose.Cells for .NET

GridPicture.Row Property

public int Row {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


SourceFullName Property

Aspose.Cells for .NET

GridPicture.SourceFullName Property

Gets or sets the path and name of the source file for the linked image.

public string SourceFullName {get; set;}

Remarks

The default value is an empty string. If SourceFullName is not an empty string, the image is linked. If SourceFullName is not an empty string, but Data is null, then the image is linked and not stored in the file.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Text Property

Aspose.Cells for .NET

GridPicture.Text Property

Represents the string in this TextBox object.

public string Text {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Title Property

Aspose.Cells for .NET

GridPicture.Title Property

public string Title {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Top Property

Aspose.Cells for .NET

GridPicture.Top Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int Top {get; set;}

Remarks

If the shape is in the chart, represents the vertical offset of shape from its top border.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


TopCM Property

Aspose.Cells for .NET

GridPicture.TopCM Property

Represents the vertical offset of shape from its top row, in unit of centimeters.

public double TopCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


TopInch Property

Aspose.Cells for .NET

GridPicture.TopInch Property

Represents the vertical offset of shape from its top row, in unit of inches.

public double TopInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


TopOffset Property

Aspose.Cells for .NET

GridPicture.TopOffset Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int TopOffset {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


TopToCorner Property

Aspose.Cells for .NET

GridPicture.TopToCorner Property

public int TopToCorner {get;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


UpperDeltaX Property

Aspose.Cells for .NET

GridPicture.UpperDeltaX Property

Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.

public int UpperDeltaX {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


UpperDeltaY Property

Aspose.Cells for .NET

GridPicture.UpperDeltaY Property

Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.

public int UpperDeltaY {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


UpperLeftColumn Property

Aspose.Cells for .NET

GridPicture.UpperLeftColumn Property

Represents upper left corner column index.

public int UpperLeftColumn {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


UpperLeftRow Property

Aspose.Cells for .NET

GridPicture.UpperLeftRow Property

Represents upper left corner row index.

public int UpperLeftRow {get; set;}

Remarks

If the shape is in the shape or in the group , UpperLeftRow will be ignored.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Width Property

Aspose.Cells for .NET

GridPicture.Width Property

Represents the width of shape, in unit of pixels.

public int Width {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


WidthCM Property

Aspose.Cells for .NET

GridPicture.WidthCM Property

Represents the width of the shape, in unit of centimeters.

public double WidthCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


WidthInch Property

Aspose.Cells for .NET

GridPicture.WidthInch Property

Represents the width of the shape, in unit of inch.

public double WidthInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


WidthPt Property

Aspose.Cells for .NET

GridPicture.WidthPt Property

Represents the width of the shape, in unit of point.

public double WidthPt {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


WidthScale Property

Aspose.Cells for .NET

GridPicture.WidthScale Property

Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;

public int WidthScale {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


X Property

Aspose.Cells for .NET

GridPicture.X Property

Gets and sets the horizonal offset of shape from worksheet left border,in unit of pixels.

public int X {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


Y Property

Aspose.Cells for .NET

GridPicture.Y Property

Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.

public int Y {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


ZOrderPosition Property

Aspose.Cells for .NET

GridPicture.ZOrderPosition Property

Returns the position of a shape in the z-order.

public int ZOrderPosition {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture Methods

The methods of the GridPicture class are listed below. For a complete list of GridPicture class members, see the GridPicture Members topic.

Public Static Methods

ToStream

Public Instance Methods

AddHyperlink | Adds a hyperlink to the shape.
AlignTopRightCorner | Moves the picture to the top-right corner.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsGroup | Indicates whether the shape is a group.
Move | Moves the picture to a specified location.
MoveToRange | Moves the shape to a specified range.
RemoveHyperlink | Remove the hyperlink of the shape.
ToString (inherited from Object) |

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.AddHyperlink Method

Adds a hyperlink to the shape.

public GridHyperlink AddHyperlink(
string param_string
);

Parameters

param_string

Return Value

Return the new hyperlink object.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.AlignTopRightCorner Method

Moves the picture to the top-right corner.

public void AlignTopRightCorner(
int topRow,
int rightColumn
);

Parameters

topRow
the row index.
rightColumn
the column index.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.IsGroup Method

Indicates whether the shape is a group.

public bool IsGroup();

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.Move Method

Moves the picture to a specified location.

public void Move(
int upperLeftRow,
int upperLeftColumn
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.MoveToRange Method

Moves the shape to a specified range.

public void MoveToRange(
int param0_int,
int param1_int,
int param2_int,
int param3_int
);

Parameters

param0_int
param1_int
param2_int
param3_int

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.RemoveHyperlink Method

Remove the hyperlink of the shape.

public void RemoveHyperlink();

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPicture.ToStream Method

public static Stream ToStream(
Image image,
ImageFormat formaw
);

See Also

GridPicture Class | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection Class

Encapsulates a collection of Picture objects.

For a list of all members of this type, see GridPictureCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPictureCollection

public class GridPictureCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPictureCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection Members

GridPictureCollection overview

Public Instance Properties

Count |
Item | Overloaded. Gets the Picture element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a picture to the collection.
Clear |
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Removes the items at the specified row column index of the cell.
RemoveAt |
ToString (inherited from Object) |

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection Properties

The properties of the GridPictureCollection class are listed below. For a complete list of GridPictureCollection class members, see the GridPictureCollection Members topic.

Public Instance Properties

Count |
Item | Overloaded. Gets the Picture element at the specified index.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridPictureCollection.Count Property

public int Count {get;}

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridPictureCollection.Item Property

Gets the Picture element at the specified index.

Overload List

Gets the Picture element at the specified index.

public GridPicture this[int] {get;}

public System.Collections.ArrayList this[int, int] {get;}

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridPictureCollection.Item Property (Int32)

Gets the Picture element at the specified index.

public GridPicture this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridPictureCollection.Item Property (Int32, Int32)

public ArrayList this[
int row,
int col
] {get;}

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Item Overload List


GridPictureCollection Methods

The methods of the GridPictureCollection class are listed below. For a complete list of GridPictureCollection class members, see the GridPictureCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a picture to the collection.
Clear |
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Removes the items at the specified row column index of the cell.
RemoveAt |
ToString (inherited from Object) |

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Add Method

Aspose.Cells for .NET

GridPictureCollection.Add Method

Adds a Picture to a specified cell at row column index.

Overload List

Adds a Picture to a specified cell at row column index.

public void Add(int,int,Image);

Adds a picture to the collection.

public int Add(int,int,int,int,Stream);

Adds a picture to the collection.

public int Add(int,int,int,int,string);

Adds a picture to the collection.

public int Add(int,int,Stream);

Adds a picture to the collection.

public int Add(int,int,string);

Adds a picture to the collection.

public int Add(int,int,string,int,int);

Adds a Picture to a specified cell by cell name.

public void Add(string,string);

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection.Add Method (Int32, Int32, Image)

Adds a Picture to a specified cell at row column index.

public void Add(
int row,
int col,
Image image
);

Parameters

row
Row index of cell.
col
Column index of cell.
image
Image.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, Int32, Int32, Stream)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
stream
Stream object which contains the image data.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, Int32, Int32, String)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
string fileName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
fileName
Image filename.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, Stream)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
stream
Stream object which contains the image data.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, String)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
string fileName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
fileName
Image filename.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, String, Int32, Int32)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
string fileName,
int widthScale,
int heightScale
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
fileName
Image filename.
widthScale
Scale of image width, a percentage.
heightScale
Scale of image height, a percentage.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (String, String)

Adds a Picture to a specified cell by cell name.

public void Add(
string cellName,
string fileName
);

Parameters

cellName
Name of grid cell.
fileName
File name of picture.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Clear Method

public void Clear();

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection.Remove Method

Removes the items at the specified row column index of the cell.

public virtual void Remove(
int row,
int col
);

Parameters

row
Row index of cell.
col
Column index of cell.

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPictureCollection.RemoveAt Method

public void RemoveAt(
int index
);

See Also

GridPictureCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField Class

For a list of all members of this type, see GridPivotField Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPivotField

public class GridPivotField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPivotField Members | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField Members

GridPivotField overview

Public Instance Properties

DisplayName | Represents the PivotField display name.
Function | Represents the function used to summarize the PivotTable data field.
IsAscendSort | Indicates whether the specified PivotTable field is autosorted ascending.
IsAutoSort | Indicates whether the specified PivotTable field is automatically sorted.
Position | Represents the PivotField index in the PivotFields.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HideItem | Sets whether the specific PivotItem in a data field is hidden.
HideItemByName | Sets whether the specific PivotItem in a data field is hidden.
HideItemByValue | Sets whether the specific PivotItem in a data field is hidden.
ToString (inherited from Object) |

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField Properties

The properties of the GridPivotField class are listed below. For a complete list of GridPivotField class members, see the GridPivotField Members topic.

Public Instance Properties

DisplayName | Represents the PivotField display name.
Function | Represents the function used to summarize the PivotTable data field.
IsAscendSort | Indicates whether the specified PivotTable field is autosorted ascending.
IsAutoSort | Indicates whether the specified PivotTable field is automatically sorted.
Position | Represents the PivotField index in the PivotFields.

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


DisplayName Property

Aspose.Cells for .NET

GridPivotField.DisplayName Property

Represents the PivotField display name.

public string DisplayName {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


Function Property

Aspose.Cells for .NET

GridPivotField.Function Property

Represents the function used to summarize the PivotTable data field.

public GridPivotFieldFunction Function {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


IsAscendSort Property

Aspose.Cells for .NET

GridPivotField.IsAscendSort Property

Indicates whether the specified PivotTable field is autosorted ascending.

public bool IsAscendSort {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


IsAutoSort Property

Aspose.Cells for .NET

GridPivotField.IsAutoSort Property

Indicates whether the specified PivotTable field is automatically sorted.

public bool IsAutoSort {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


Position Property

Aspose.Cells for .NET

GridPivotField.Position Property

Represents the PivotField index in the PivotFields.

public int Position {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField Methods

The methods of the GridPivotField class are listed below. For a complete list of GridPivotField class members, see the GridPivotField Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HideItem | Sets whether the specific PivotItem in a data field is hidden.
HideItemByName | Sets whether the specific PivotItem in a data field is hidden.
HideItemByValue | Sets whether the specific PivotItem in a data field is hidden.
ToString (inherited from Object) |

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField.HideItem Method

Sets whether the specific PivotItem in a data field is hidden.

public void HideItem(
int index,
bool isHidden
);

Parameters

index
the index of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField.HideItemByName Method

Sets whether the specific PivotItem in a data field is hidden.

public void HideItemByName(
string name,
bool isHidden
);

Parameters

name
the name of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotField.HideItemByValue Method

Sets whether the specific PivotItem in a data field is hidden.

public void HideItemByValue(
string value,
bool isHidden
);

Parameters

value
the value of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

GridPivotField Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldCollection Class

Encapsulates a collection of PivotField objects.

For a list of all members of this type, see GridPivotFieldCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPivotFieldCollection

public class GridPivotFieldCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPivotFieldCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldCollection Members

GridPivotFieldCollection overview

Public Instance Properties

Count |
Item | Gets the PivotField element at the specified index.

Public Instance Methods

Add | Adds a PivotField Object to the specific type PivotFields.
Clear | Clears all PivotFields.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldCollection Properties

The properties of the GridPivotFieldCollection class are listed below. For a complete list of GridPivotFieldCollection class members, see the GridPivotFieldCollection Members topic.

Public Instance Properties

Count |
Item | Gets the PivotField element at the specified index.

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridPivotFieldCollection.Count Property

public int Count {get;}

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridPivotFieldCollection.Item Property

Gets the PivotField element at the specified index.

public GridPivotField this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldCollection Methods

The methods of the GridPivotFieldCollection class are listed below. For a complete list of GridPivotFieldCollection class members, see the GridPivotFieldCollection Members topic.

Public Instance Methods

Add | Adds a PivotField Object to the specific type PivotFields.
Clear | Clears all PivotFields.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldCollection.Add Method

Adds a PivotField Object to the specific type PivotFields.

public int Add(
GridPivotField pivotField
);

Parameters

pivotField
a PivotField Object.

Return Value

the index of the PivotField Object in this PivotFields.

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldCollection.Clear Method

Clears all PivotFields.

public void Clear();

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldFunction Enumeration

public enum GridPivotFieldFunction

Members

Member Name | Description | Value
Sum | Represents Sum function. | 0
Count | Represents Count function. | 1
Average | Represents Average function. | 2
Max | Represents Max function. | 3
Min | Represents Min function. | 4
Product | Represents Product function. | 5
CountNums | Represents Count Nums function. | 6
StdDev | Represents StdDev function. | 7
StdDevp | Represents StdDevp function. | 8
Var | Represents Var function. | 9
Varp | Represents Varp function. | 10

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridPivotFieldType Enumeration

public enum GridPivotFieldType

Members

Member Name | Description | Value
Undefined | Presents base pivot field type. | 0
Row | Presents row pivot field type. | 1
Column | Presents column pivot field type. | 2
Page | Presents page pivot field type. | 4
Data | Presents data pivot field type. | 8

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem Class

For a list of all members of this type, see GridPivotItem Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPivotItem

public class GridPivotItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPivotItem Members | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem Members

GridPivotItem overview

Public Instance Properties

Index | Gets the index of the pivot item in the pivot field
IsHidden | Gets and Sets whether the pivot item is hidden.
Name | Gets the name of the pivot item.
Value | Gets the value of the pivot item

Public Instance Methods

Equals (inherited from Object) |
GetDateTimeValue | Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue
GetDoubleValue | Gets the double value of the pivot item If the value is null or not number ,it will return 0
GetHashCode (inherited from Object) |
GetStringValue | Gets the string value of the pivot item If the value is null, it will return ""
GetType (inherited from Object) |
Move | Moves the item up or down.
ToString (inherited from Object) |

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem Properties

The properties of the GridPivotItem class are listed below. For a complete list of GridPivotItem class members, see the GridPivotItem Members topic.

Public Instance Properties

Index | Gets the index of the pivot item in the pivot field
IsHidden | Gets and Sets whether the pivot item is hidden.
Name | Gets the name of the pivot item.
Value | Gets the value of the pivot item

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


Index Property

Aspose.Cells for .NET

GridPivotItem.Index Property

Gets the index of the pivot item in the pivot field

public int Index {get; set;}

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


IsHidden Property

Aspose.Cells for .NET

GridPivotItem.IsHidden Property

Gets and Sets whether the pivot item is hidden.

public bool IsHidden {get; set;}

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


Name Property

Aspose.Cells for .NET

GridPivotItem.Name Property

Gets the name of the pivot item.

public string Name {get;}

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


Value Property

Aspose.Cells for .NET

GridPivotItem.Value Property

Gets the value of the pivot item

public object Value {get;}

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem Methods

The methods of the GridPivotItem class are listed below. For a complete list of GridPivotItem class members, see the GridPivotItem Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetDateTimeValue | Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue
GetDoubleValue | Gets the double value of the pivot item If the value is null or not number ,it will return 0
GetHashCode (inherited from Object) |
GetStringValue | Gets the string value of the pivot item If the value is null, it will return ""
GetType (inherited from Object) |
Move | Moves the item up or down.
ToString (inherited from Object) |

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem.GetDateTimeValue Method

Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue

public DateTime GetDateTimeValue();

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem.GetDoubleValue Method

Gets the double value of the pivot item If the value is null or not number ,it will return 0

public double GetDoubleValue();

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem.GetStringValue Method

Gets the string value of the pivot item If the value is null, it will return ""

public string GetStringValue();

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItem.Move Method

Moves the item up or down.

public void Move(
int count
);

Parameters

count
The number of moving up or down. Move the item up if this is less than zero; Move the item down if this is greater than zero.

See Also

GridPivotItem Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItemCollection Class

Encapsulates a collection of PivotItem objects.

For a list of all members of this type, see GridPivotItemCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPivotItemCollection

public class GridPivotItemCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPivotItemCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItemCollection Members

GridPivotItemCollection overview

Public Instance Properties

Count |
Item | Gets the PivotItem element at the specified index.

Public Instance Methods

Add | Adds a PivotItem Object to the specific type PivotItems.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotItemCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItemCollection Properties

The properties of the GridPivotItemCollection class are listed below. For a complete list of GridPivotItemCollection class members, see the GridPivotItemCollection Members topic.

Public Instance Properties

Count |
Item | Gets the PivotItem element at the specified index.

See Also

GridPivotItemCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridPivotItemCollection.Count Property

public int Count {get;}

See Also

GridPivotItemCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridPivotItemCollection.Item Property

Gets the PivotItem element at the specified index.

public GridPivotItem this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPivotItemCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItemCollection Methods

The methods of the GridPivotItemCollection class are listed below. For a complete list of GridPivotItemCollection class members, see the GridPivotItemCollection Members topic.

Public Instance Methods

Add | Adds a PivotItem Object to the specific type PivotItems.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotItemCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotItemCollection.Add Method

Adds a PivotItem Object to the specific type PivotItems.

public int Add(
GridPivotItem item
);

Parameters

item

Return Value

the index of the PivotItem Object in this PivotItems.

See Also

GridPivotItemCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTable Class

Represents a PivotTable report on a worksheet. The PivotTable object is a member of the PivotTables collection. The PivotTables collection contains all the PivotTable objects on a control.

For a list of all members of this type, see GridPivotTable Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPivotTable

public class GridPivotTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPivotTable Members | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTable Members

GridPivotTable overview

Public Instance Methods

AddFieldToArea | Overloaded. Adds the field to the specific area.
CalculateData | Calculates pivottable's data to cells.
ClearAllFields | clear all pivot fields.
Equals (inherited from Object) |
Fields | Overloaded. Gets the specific fields by the field type.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RefreshData | Refreshes pivottable's data and setting from it's data source.
ToString (inherited from Object) |

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTable Methods

The methods of the GridPivotTable class are listed below. For a complete list of GridPivotTable class members, see the GridPivotTable Members topic.

Public Instance Methods

AddFieldToArea | Overloaded. Adds the field to the specific area.
CalculateData | Calculates pivottable's data to cells.
ClearAllFields | clear all pivot fields.
Equals (inherited from Object) |
Fields | Overloaded. Gets the specific fields by the field type.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RefreshData | Refreshes pivottable's data and setting from it's data source.
ToString (inherited from Object) |

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


AddFieldToArea Method

Aspose.Cells for .NET

GridPivotTable.AddFieldToArea Method

Adds the field to the specific area.

Overload List

Adds the field to the specific area.

public int AddFieldToArea(GridPivotFieldType,int);

Adds the field to the specific area.

public int AddFieldToArea(GridPivotFieldType,string);

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTable.AddFieldToArea Method (GridPivotFieldType, Int32)

Adds the field to the specific area.

public int AddFieldToArea(
GridPivotFieldType fieldType,
int baseFieldIndex
);

Parameters

fieldType
The fields area type.
baseFieldIndex
The field index in the base fields.

Return Value

The field position in the specific fields.

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTable.AddFieldToArea Overload List


GridPivotTable.AddFieldToArea Method (GridPivotFieldType, String)

Adds the field to the specific area.

public int AddFieldToArea(
GridPivotFieldType fieldType,
string fieldName
);

Parameters

fieldType
The fields area type.
fieldName
The name in the base fields.

Return Value

The field position in the specific fields.If there is no field named as it, return -1.

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTable.AddFieldToArea Overload List


GridPivotTable.CalculateData Method

Calculates pivottable's data to cells.

public void CalculateData();

Remarks

Cell.Value in the pivot range could not return the correct result if the method is not been called. This method caclulates data with an inner pivot cache,not original data source. So if the data source is changed, please call RefreshData() method first.

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTable.ClearAllFields Method

clear all pivot fields.

public void ClearAllFields();

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


Fields Method

Aspose.Cells for .NET

GridPivotTable.Fields Method

Gets the specific fields by the field type.

Overload List

Gets the specific fields by the field type.

public GridPivotFieldCollection Fields(GridPivotFieldType);

Gets the specific field by the field name.

public GridPivotField Fields(string);

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTable.Fields Method (GridPivotFieldType)

Gets the specific fields by the field type.

public GridPivotFieldCollection Fields(
GridPivotFieldType fieldType
);

Parameters

fieldType
the field type.

Return Value

the specific fields

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTable.Fields Overload List


GridPivotTable.Fields Method (String)

Gets the specific field by the field name.

public GridPivotField Fields(
string fieldName
);

Parameters

fieldName
the field name.

Return Value

the specific field

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTable.Fields Overload List


GridPivotTable.RefreshData Method

Refreshes pivottable's data and setting from it's data source.

public void RefreshData();

Remarks

We will gather data from data source to a pivot cache ,then calcualte the data in the cache to the cells. This method is only used to gather all data to a pivot cache.

See Also

GridPivotTable Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTableCollection Class

Encapsulates a collection of PivotTable objects.

For a list of all members of this type, see GridPivotTableCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridPivotTableCollection

public class GridPivotTableCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridPivotTableCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTableCollection Members

GridPivotTableCollection overview

Public Instance Properties

Count |
Item | Gets the PivotTable element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a new PivotTable cache to a PivotCaches collection.
Clear | Clears all PivotTables.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the PivotTable at the specified index.
ToString (inherited from Object) |

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTableCollection Properties

The properties of the GridPivotTableCollection class are listed below. For a complete list of GridPivotTableCollection class members, see the GridPivotTableCollection Members topic.

Public Instance Properties

Count |
Item | Gets the PivotTable element at the specified index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridPivotTableCollection.Count Property

public int Count {get;}

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridPivotTableCollection.Item Property

Gets the PivotTable element at the specified index.

public GridPivotTable this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTableCollection Methods

The methods of the GridPivotTableCollection class are listed below. For a complete list of GridPivotTableCollection class members, see the GridPivotTableCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new PivotTable cache to a PivotCaches collection.
Clear | Clears all PivotTables.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the PivotTable at the specified index.
ToString (inherited from Object) |

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Add Method

Aspose.Cells for .NET

GridPivotTableCollection.Add Method

Adds a new PivotTable cache to a PivotCaches collection.

Overload List

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(Worksheet,GridCellArea,string,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,GridCellArea,int,int,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,GridCellArea,string,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,string,string);

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTableCollection.Add Method (Worksheet, GridCellArea, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
Worksheet sourceSheet,
GridCellArea sourceArea,
string destCellName,
string tableName
);

Parameters

sourceSheet
The source work sheet.
sourceArea
The area in the source worksheet.
destCellName
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Add Method (String, GridCellArea, Int32, Int32, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string worksheetname,
GridCellArea sourceArea,
int destRow,
int destCol,
string tableName
);

Parameters

worksheetname
The name of the source worksheet.
sourceArea
The area in the source worksheet.
destRow
The row of the cell in the upper-left corner of the PivotTable report's destination range.
destCol
The column of the cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Add Method (String, GridCellArea, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string worksheetname,
GridCellArea sourceArea,
string destCellName,
string tableName
);

Parameters

worksheetname
The name of the source worksheet.
sourceArea
The area in the source worksheet.
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Add Method (String, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string sourceData,
string destCellName,
string tableName
);

Parameters

sourceData
The data cell range for the new PivotTable.Example : Sheet1!A1:C8
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Clear Method

Clears all PivotTables.

public void Clear();

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridPivotTableCollection.RemoveAt Method

Remove the PivotTable at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow Class

Encapsulates the object that represents a single picture in a spreadsheet.

For a list of all members of this type, see GridRow Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridRow

public class GridRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridRow Members | Aspose.Cells.GridDesktop.Data Namespace


GridRow Members

GridRow overview

Public Static Fields

DEFAULT_HEIGHT Default height of gridrow.

Public Instance Properties

FirstCell |
Height | Gets or sets the height of row object.in unit of pixel
Hidden |
Index |
Item | Gets the cell.
LastCell |
LastDataCell |
OutlineLevel |

Public Instance Methods

Equals (inherited from Object) |
GetCellByIndex |
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsBlank |
ToString (inherited from Object) |

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow Fields

The fields of the GridRow class are listed below. For a complete list of GridRow class members, see the GridRow Members topic.

Public Static Fields

DEFAULT_HEIGHT Default height of gridrow.

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow.DEFAULT_HEIGHT Field

Default height of gridrow.

public static int DEFAULT_HEIGHT;

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow Properties

The properties of the GridRow class are listed below. For a complete list of GridRow class members, see the GridRow Members topic.

Public Instance Properties

FirstCell |
Height | Gets or sets the height of row object.in unit of pixel
Hidden |
Index |
Item | Gets the cell.
LastCell |
LastDataCell |
OutlineLevel |

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


FirstCell Property

Aspose.Cells for .NET

GridRow.FirstCell Property

public GridCell FirstCell {get;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


Height Property

Aspose.Cells for .NET

GridRow.Height Property

Gets or sets the height of row object.in unit of pixel

public int Height {get; set;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


Hidden Property

Aspose.Cells for .NET

GridRow.Hidden Property

public bool Hidden {get; set;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


Index Property

Aspose.Cells for .NET

GridRow.Index Property

public int Index {get;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridRow.Item Property

Gets the cell.

public GridCell this[
int column
] {get;}

Parameters

column
The column index

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


LastCell Property

Aspose.Cells for .NET

GridRow.LastCell Property

public GridCell LastCell {get;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


LastDataCell Property

Aspose.Cells for .NET

GridRow.LastDataCell Property

public GridCell LastDataCell {get;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


OutlineLevel Property

Aspose.Cells for .NET

GridRow.OutlineLevel Property

public byte OutlineLevel {get; set;}

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow Methods

The methods of the GridRow class are listed below. For a complete list of GridRow class members, see the GridRow Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetCellByIndex |
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsBlank |
ToString (inherited from Object) |

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow.GetCellByIndex Method

public GridCell GetCellByIndex(
int index
);

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow.GetEnumerator Method

Gets the cells enumerator

public IEnumerator GetEnumerator();

Return Value

The cells enumerator

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRow.IsBlank Method

public bool IsBlank();

See Also

GridRow Class | Aspose.Cells.GridDesktop.Data Namespace


GridRowCollection Class

Encapsulates a collection of Worksheet objects.

For a list of all members of this type, see GridRowCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridRowCollection

public class GridRowCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridRowCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridRowCollection Members

GridRowCollection overview

Public Instance Properties

Count |
Item | Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRowByIndex | Gets the row object by the position in the list.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridRowCollection Properties

The properties of the GridRowCollection class are listed below. For a complete list of GridRowCollection class members, see the GridRowCollection Members topic.

Public Instance Properties

Count |
Item | Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridRowCollection.Count Property

public int Count {get;}

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridRowCollection.Item Property

Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

public GridRow this[
int rowIndex
] {get;}

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace | Row


GridRowCollection Methods

The methods of the GridRowCollection class are listed below. For a complete list of GridRowCollection class members, see the GridRowCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRowByIndex | Gets the row object by the position in the list.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridRowCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridRowCollection.GetRowByIndex Method

Gets the row object by the position in the list.

public GridRow GetRowByIndex(
int index
);

Parameters

index
The position.

Return Value

The Row object at given position.

See Also

GridRowCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridSaveFormat Enumeration

Enumerates supported file format types.

public enum GridSaveFormat

Members

Member Name | Description | Value
CSV | CSV | 1
Excel2003 | Excel 2003, Excel97-2003 xls file. | 5
Excel2007 | Excel 2007 Represents an xlsx file | 6
XLSM | Excel 2007 xlsm file which enable macros | 7
XLTX | Excel Template file | 8
XLTM | Represents an Xltx file which enable macros. | 9
TABDELIMITED | Represents a tab delimited text file,txt file. | 11
HTML | Represents a html file. | 12
PDF | Represents a pdf file. | 13
ODS | Represents a ods file. | 14
SpreadsheetML | SpreadsheetML,Represents an Excel 2003 xml file. | 15
XLSB | Represents a XLSB file. | 16
MHTML | Represents a mhtml file. | 17
XPS | Represents a XPS file. | 20
TIFF | Represents a TIFF file. | 21
SVG | Represents a SVG file. | 22
DIF | Data Interchange Format. | 30

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridShapeCollection Class

For a list of all members of this type, see GridShapeCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridShapeCollection

public class GridShapeCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridShapeCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridShapeCollection Members

GridShapeCollection overview

Public Instance Properties

Count |
Item | Gets the Picture element at the specified index.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the shape.
ToString (inherited from Object) |

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridShapeCollection Properties

The properties of the GridShapeCollection class are listed below. For a complete list of GridShapeCollection class members, see the GridShapeCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Picture element at the specified index.

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridShapeCollection.Count Property

public int Count {get;}

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridShapeCollection.Item Property

Gets the Picture element at the specified index.

public Shape this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridShapeCollection Methods

The methods of the GridShapeCollection class are listed below. For a complete list of GridShapeCollection class members, see the GridShapeCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the shape.
ToString (inherited from Object) |

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridShapeCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridShapeCollection.RemoveAt Method

Remove the shape.

public void RemoveAt(
int index
);

Parameters

index
The index of the shape.

See Also

GridShapeCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation Class

For a list of all members of this type, see GridValidation Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridValidation

public class GridValidation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridValidation Members | Aspose.Cells.GridDesktop.Data Namespace


GridValidation Members

GridValidation overview

Public Instance Constructors

GridValidation Constructor Initializes a new instance of the GridValidation class.

Public Instance Properties

AreaList | Represents a collection of CellArea which contains the data validation settings.
ClientValidationFunction | Gets or sets the client validation javascript function name.
CustomMsgForStopEdit | Gets or sets the custom message to show when user edits invalid value.
CustomMsgForStopOper | Gets or sets the custom message to show when user's operation brings invalid value.
CustomMsgTitle | Gets or sets the custom message title to show when a invalid value input.
CustomValidation | Gets or sets the custom validation object.
ErrorMessage | Represents the data validation error message.
ErrorTitle | Represents the title of the data-validation error dialog box.
Formula1 | Represents the value or expression associated with the data validation.
Formula2 | Represents the value or expression associated with the second part of the data validation.
InputMessage | Represents the data validation error message.
InputTitle | Represents the title of the data-validation input dialog box.
IsRequired |
Operator | Represents the operator for the data validation.
RegEx | Gets or sets the regular expression string.
ShowError | Indicates whether the data validation error message will be displayed whenever the user enters invalid data.
ShowInput |
ValidationType | Gets or sets the validation type.
ValueList | Gets/Sets the value list object.

Public Instance Methods

AddACell | Overloaded. add the validation settings in the cell.
AddArea | Applies the validation to the area.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveACell | Remove the validation settings in the cell.
RemoveArea | Remove the validation settings in the range.
ToString (inherited from Object) |

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation Constructor

Initializes a new instance of the GridValidation class.

public GridValidation();

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation Properties

The properties of the GridValidation class are listed below. For a complete list of GridValidation class members, see the GridValidation Members topic.

Public Instance Properties

AreaList | Represents a collection of CellArea which contains the data validation settings.
ClientValidationFunction | Gets or sets the client validation javascript function name.
CustomMsgForStopEdit | Gets or sets the custom message to show when user edits invalid value.
CustomMsgForStopOper | Gets or sets the custom message to show when user's operation brings invalid value.
CustomMsgTitle | Gets or sets the custom message title to show when a invalid value input.
CustomValidation | Gets or sets the custom validation object.
ErrorMessage | Represents the data validation error message.
ErrorTitle | Represents the title of the data-validation error dialog box.
Formula1 | Represents the value or expression associated with the data validation.
Formula2 | Represents the value or expression associated with the second part of the data validation.
InputMessage | Represents the data validation error message.
InputTitle | Represents the title of the data-validation input dialog box.
IsRequired |
Operator | Represents the operator for the data validation.
RegEx | Gets or sets the regular expression string.
ShowError | Indicates whether the data validation error message will be displayed whenever the user enters invalid data.
ShowInput |
ValidationType | Gets or sets the validation type.
ValueList | Gets/Sets the value list object.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


AreaList Property

Aspose.Cells for .NET

GridValidation.AreaList Property

Represents a collection of CellArea which contains the data validation settings.

public ArrayList AreaList {get;}

Remarks

The old valvidations on the area will not be removed if directly adding are to this list.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ClientValidationFunction Property

Aspose.Cells for .NET

GridValidation.ClientValidationFunction Property

Gets or sets the client validation javascript function name.

public string ClientValidationFunction {get; set;}

Remarks

Use the ClientValidationFunction property to specify the client validation function's name. The function should be declared as this formation:
function customValicationFunction(source, value)
The parameter "source" is the cell object. The parameter "value" is the string value of a cell to be checked. The function should returns true if the value is valid.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


CustomMsgForStopEdit Property

Aspose.Cells for .NET

GridValidation.CustomMsgForStopEdit Property

Gets or sets the custom message to show when user edits invalid value.

public string CustomMsgForStopEdit {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


CustomMsgForStopOper Property

Aspose.Cells for .NET

GridValidation.CustomMsgForStopOper Property

Gets or sets the custom message to show when user's operation brings invalid value.

public string CustomMsgForStopOper {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


CustomMsgTitle Property

Aspose.Cells for .NET

GridValidation.CustomMsgTitle Property

Gets or sets the custom message title to show when a invalid value input.

public string CustomMsgTitle {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


CustomValidation Property

Aspose.Cells for .NET

GridValidation.CustomValidation Property

Gets or sets the custom validation object.

public ICustomValidation CustomValidation {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ErrorMessage Property

Aspose.Cells for .NET

GridValidation.ErrorMessage Property

Represents the data validation error message.

public string ErrorMessage {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ErrorTitle Property

Aspose.Cells for .NET

GridValidation.ErrorTitle Property

Represents the title of the data-validation error dialog box.

public string ErrorTitle {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


Formula1 Property

Aspose.Cells for .NET

GridValidation.Formula1 Property

Represents the value or expression associated with the data validation.

public string Formula1 {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


Formula2 Property

Aspose.Cells for .NET

GridValidation.Formula2 Property

Represents the value or expression associated with the second part of the data validation.

public string Formula2 {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


InputMessage Property

Aspose.Cells for .NET

GridValidation.InputMessage Property

Represents the data validation error message.

public string InputMessage {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


InputTitle Property

Aspose.Cells for .NET

GridValidation.InputTitle Property

Represents the title of the data-validation input dialog box.

public string InputTitle {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


IsRequired Property

Aspose.Cells for .NET

GridValidation.IsRequired Property

public bool IsRequired {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


Operator Property

Aspose.Cells for .NET

GridValidation.Operator Property

Represents the operator for the data validation.

public GridOperatorType Operator {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


RegEx Property

Aspose.Cells for .NET

GridValidation.RegEx Property

Gets or sets the regular expression string.

public string RegEx {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ShowError Property

Aspose.Cells for .NET

GridValidation.ShowError Property

Indicates whether the data validation error message will be displayed whenever the user enters invalid data.

public bool ShowError {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ShowInput Property

Aspose.Cells for .NET

GridValidation.ShowInput Property

public bool ShowInput {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ValidationType Property

Aspose.Cells for .NET

GridValidation.ValidationType Property

Gets or sets the validation type.

public GridValidationType ValidationType {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


ValueList Property

Aspose.Cells for .NET

GridValidation.ValueList Property

Gets/Sets the value list object.

public StringCollection ValueList {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation Methods

The methods of the GridValidation class are listed below. For a complete list of GridValidation class members, see the GridValidation Members topic.

Public Instance Methods

AddACell | Overloaded. add the validation settings in the cell.
AddArea | Applies the validation to the area.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveACell | Remove the validation settings in the cell.
RemoveArea | Remove the validation settings in the range.
ToString (inherited from Object) |

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


AddACell Method

Aspose.Cells for .NET

GridValidation.AddACell Method

add the validation settings in the cell.

Overload List

add the validation settings in the cell.

public void AddACell(int,int);

add the validation settings in the cell.

public void AddACell(string);

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation.AddACell Method (Int32, Int32)

add the validation settings in the cell.

public void AddACell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidation.AddACell Overload List


GridValidation.AddACell Method (String)

add the validation settings in the cell.

public void AddACell(
string cellname
);

Parameters

cellname
cell name.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidation.AddACell Overload List


GridValidation.AddArea Method

Applies the validation to the area.

public void AddArea(
GridCellArea cellArea
);

Parameters

cellArea
The area.

Remarks

In this method , we will remove all old validations on this area.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation.RemoveACell Method

Remove the validation settings in the cell.

public void RemoveACell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidation.RemoveArea Method

Remove the validation settings in the range.

public void RemoveArea(
GridCellArea cellArea
);

Parameters

cellArea
The range which contains the data validation settings.

See Also

GridValidation Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidationCollection Class

Encapsulates a collection of Hyperlink objects.

For a list of all members of this type, see GridValidationCollection Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridValidationCollection

public class GridValidationCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridValidationCollection Members | Aspose.Cells.GridDesktop.Data Namespace


GridValidationCollection Members

GridValidationCollection overview

Public Instance Properties

Count |
Item | Overloaded. Gets the Hyperlink element at the specified index.

Public Instance Methods

Add | Overloaded. Add a GridValidation to the collection.
Clear | Clears all validations.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the validation at the specified index.
ToString (inherited from Object) |

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidationCollection Properties

The properties of the GridValidationCollection class are listed below. For a complete list of GridValidationCollection class members, see the GridValidationCollection Members topic.

Public Instance Properties

Count |
Item | Overloaded. Gets the Hyperlink element at the specified index.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Count Property

Aspose.Cells for .NET

GridValidationCollection.Count Property

public int Count {get;}

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property

Aspose.Cells for .NET

GridValidationCollection.Item Property

Gets the Hyperlink element at the specified index.

Overload List

Gets the Hyperlink element at the specified index.

public GridValidation this[int] {get;}

Gets the GridValidation element at the specified cell.if no validation ,then return null.

public GridValidation this[int, int] {get;}

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridValidationCollection.Item Property (Int32)

Gets the Hyperlink element at the specified index.

public GridValidation this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridValidationCollection.Item Property (Int32, Int32)

Gets the GridValidation element at the specified cell.if no validation ,then return null.

public GridValidation this[
int row,
int column
] {get;}

Parameters

row
The row of the cell.
column
The column of the cell.

Remarks

If there is not a validation object at specified row column index, this will check the column validation object.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Item Overload List


GridValidationCollection Methods

The methods of the GridValidationCollection class are listed below. For a complete list of GridValidationCollection class members, see the GridValidationCollection Members topic.

Public Instance Methods

Add | Overloaded. Add a GridValidation to the collection.
Clear | Clears all validations.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the validation at the specified index.
ToString (inherited from Object) |

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


Add Method

Aspose.Cells for .NET

GridValidationCollection.Add Method

Add a GridValidation to the collection.

Overload List

Add a GridValidation to the collection.

public GridValidation Add();

Add a GridValidation to the collection.

public int Add(GridValidation);

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(int,int);

Adds a validation to a specified cell at row column index.

public void Add(int,int,ICustomValidation);

Adds a validation to a specified cell at row column index.

public void Add(int,int,bool,string);

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(string);

Adds a validation to a specified cell by cell name.

public void Add(string,ICustomValidation);

Adds a validation to a specified cell by cell name.

public void Add(string,bool,string);

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidationCollection.Add Method ()

Add a GridValidation to the collection.

public GridValidation Add();

Return Value

GridValidation the added GridValidation instance.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (GridValidation)

Add a GridValidation to the collection.

public int Add(
GridValidation validation
);

Parameters

validation
A validation object.

Return Value

GridValidation object index.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (Int32, Int32)

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(
int row,
int col
);

Parameters

row
Row index of cell.
col
Column index of cell.

Return Value

GridValidation the added GridValidation instance.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (Int32, Int32, ICustomValidation)

Adds a validation to a specified cell at row column index.

public void Add(
int row,
int col,
ICustomValidation customValidation
);

Parameters

row
Row index of cell.
col
Column index of cell.
customValidation
Custom validaton object.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (Int32, Int32, Boolean, String)

Adds a validation to a specified cell at row column index.

public void Add(
int row,
int col,
bool isRequired,
string regEx
);

Parameters

row
Row index of cell.
col
Column index of cell.
isRequired
Value indicating whether cell value is required.
regEx
Regular expression.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (String)

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(
string cellname
);

Parameters

cellname
the name of the cell.

Return Value

GridValidation the added GridValidation instance.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (String, ICustomValidation)

Adds a validation to a specified cell by cell name.

public void Add(
string cellName,
ICustomValidation customValidation
);

Parameters

cellName
Name of grid cell.
customValidation
Custom validaton object.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (String, Boolean, String)

Adds a validation to a specified cell by cell name.

public void Add(
string cellName,
bool isRequired,
string regEx
);

Parameters

cellName
Name of grid cell.
isRequired
Value indicating whether cell value is required.
regEx
Regular expression.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Clear Method

Clears all validations.

public void Clear();

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidationCollection.RemoveAt Method

Remove the validation at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

See Also

GridValidationCollection Class | Aspose.Cells.GridDesktop.Data Namespace


GridValidationType Enumeration

public enum GridValidationType

Members

Member Name | Description | Value
AnyValue | Any value validation type. | 0
WholeNumber | Whole number validation type. | 1
Decimal | Decimal validation type. | 2
List | List validation type. | 3
Date | Date validation type. | 4
Time | Time validation type. | 5
TextLength | Text length validation type. | 6
Custom | Custom validation type. | 7
DropDownList | Show dropdown list. | 8
FreeList | Free List validation type. | 9
CustomExpression | Custom validation type, using regular expression. | 10
Boolean | TRUE or FALSE | 11
DateTime | DateTime (yyyy-MM-dd or yyyy-MM-dd hh:mm:ss). | 12
CustomFunction | Custom javascript function validation. | 13
CheckBox | Display the cell as a checkbox. And the value of the cell is True of False. | 14

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


GridWorkbook Class

Represents a root object to create an Excel spreadsheet.

For a list of all members of this type, see GridWorkbook Members.

System.Object
Aspose.Cells.GridDesktop.Data.GridWorkbook

public class GridWorkbook

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

GridWorkbook Members | Aspose.Cells.GridDesktop.Data Namespace


GridWorkbook Members

GridWorkbook overview

Public Instance Properties

Worksheets

Public Instance Methods

CalculateFormula | Calculates the result of formulas.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridWorkbook Class | Aspose.Cells.GridDesktop.Data Namespace


GridWorkbook Properties

The properties of the GridWorkbook class are listed below. For a complete list of GridWorkbook class members, see the GridWorkbook Members topic.

Public Instance Properties

Worksheets

See Also

GridWorkbook Class | Aspose.Cells.GridDesktop.Data Namespace


Worksheets Property

Aspose.Cells for .NET

GridWorkbook.Worksheets Property

public WorksheetCollection Worksheets {get;}

See Also

GridWorkbook Class | Aspose.Cells.GridDesktop.Data Namespace


GridWorkbook Methods

The methods of the GridWorkbook class are listed below. For a complete list of GridWorkbook class members, see the GridWorkbook Members topic.

Public Instance Methods

CalculateFormula | Calculates the result of formulas.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridWorkbook Class | Aspose.Cells.GridDesktop.Data Namespace


GridWorkbook.CalculateFormula Method

Calculates the result of formulas.

public void CalculateFormula();

See Also

GridWorkbook Class | Aspose.Cells.GridDesktop.Data Namespace


NumberType Enumeration

Represents the number or datetime format type.

public enum NumberType

Members

Member Name | Description | Value
General | General | 0
Decimal1 | Decimal 0 | 1
Decimal2 | Decimal 0.00 | 2
Decimal3 | Decimal #,##0 | 3
Decimal4 | Decimal #,##0.00 | 4
Currency1 | Currency $#,##0;$-#,##0 | 5
Currency2 | Currency $#,##0;[Red]$-#,##0 | 6
Currency3 | Currency $#,##0.00;$-#,##0.00 | 7
Currency4 | Currency $#,##0.00;[Red]$-#,##0.00 | 8
Percentage1 | Percentage 0% | 9
Percentage2 | Percentage 0.00% | 10
Scientific1 | Scientific 0.00E+00 | 11
Fraction1 | Fraction # ?/? | 12
Fraction2 | Fraction # ??/?? | 13
Date1 | Date m/d/yyyy | 14
Date2 | Date d-mmm-yy | 15
Date3 | Date d-mmm | 16
Date4 | Date mmm-yy | 17
Time1 | Time h:mm AM/PM | 18
Time2 | Time h:mm:ss AM/PM | 19
Time3 | Time h:mm | 20
Time4 | Time h:mm:ss | 21
Time5 | Time m/d/yy h:mm | 22
Currency5 | Currency #,##0;-#,##0 | 37
Currency6 | Currency #,##0;[Red]-#,##0 | 38
Currency7 | Currency #,##0.00;-#,##0.00 | 39
Currency8 | Currency #,##0.00;[Red]-#,##0.00 | 40
Accounting1 | Accounting _ * #,##0_ ;_ * -#,##0_ ;_ * "-"_ ;_ @_ | 41
Accounting2 | Accounting _ $* #,##0_ ;_ $* -#,##0_ ;_ $* "-"_ ;_ @_ | 42
Accounting3 | Accounting _ * #,##0.00_ ;_ * -#,##0.00_ ;_ * "-"??_ ;_ @_ | 43
Accounting4 | Accounting _ $* #,##0.00_ ;_ $* -#,##0.00_ ;_ $* "-"??_ ;_ @_ | 44
Time6 | Time mm:ss | 45
Time7 | Time [h]:mm:ss | 46
Time8 | Time mm:ss.0 | 47
Scientific2 | Scientific ##0.0E+00 | 48
Text | Text @ | 49
Currency9 | Currency $#,##0;($#,##0) | 23
Currency10 | Currency $#,##0;[Red]($#,##0) | 24
Currency11 | Currency $#,##0.00;($#,##0.00) | 25
Currency12 | Currency $#,##0.00;[Red]($#,##0.00) | 26
EasternDate1 | Date YYYY?M? | 27
EasternDate2 | Date M?D? | 28
EasternDate3 | Date M?D? | 29
EasternDate4 | Date M/D/YY | 30
EasternDate5 | Date YYYY?M?D? | 31
EasternDate6 | Date YYYY?M? | 36
EasternDate7 | Date YYYY?M? | 50
EasternDate8 | Date M?D? | 51
EasternDate9 | Date YYYY?M? | 52
EasternDate10 | Date M?D? | 53
EasternDate11 | Date M?D? | 54
EasternDate12 | Date YYYY?M? | 57
EasternDate13 | Date M?D? | 58
EasternTime1 | Time h?mm? | 32
EasternTime2 | Time h?mm?ss? | 33
EasternTime3 | Time tth?mm? | 34
EasternTime4 | Time tth?mm?ss? | 35
EasternTime5 | Time tth?mm? | 55
EasternTime6 | Time tth?mm?ss? | 56

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


OnErrorActionQuery Class

Used in the CellError event of the GridWeb.

For a list of all members of this type, see OnErrorActionQuery Members.

System.Object
Aspose.Cells.GridDesktop.Data.OnErrorActionQuery

public class OnErrorActionQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
onErrorActionQuery.OnErrorAction = OnErrorActionType.Ignore;
[VB]
onErrorActionQuery.OnErrorAction = OnErrorActionType.Ignore

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

OnErrorActionQuery Members | Aspose.Cells.GridDesktop.Data Namespace


OnErrorActionQuery Members

OnErrorActionQuery overview

Public Instance Constructors

OnErrorActionQuery Constructor Initializes a new instance of the OnErrorActionQuery class.

Public Instance Properties

OnErrorAction Gets or set the action type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

OnErrorActionQuery Class | Aspose.Cells.GridDesktop.Data Namespace


OnErrorActionQuery Constructor

Initializes a new instance of the OnErrorActionQuery class.

public OnErrorActionQuery();

See Also

OnErrorActionQuery Class | Aspose.Cells.GridDesktop.Data Namespace


OnErrorActionQuery Properties

The properties of the OnErrorActionQuery class are listed below. For a complete list of OnErrorActionQuery class members, see the OnErrorActionQuery Members topic.

Public Instance Properties

OnErrorAction Gets or set the action type.

See Also

OnErrorActionQuery Class | Aspose.Cells.GridDesktop.Data Namespace


OnErrorAction Property

Aspose.Cells for .NET

OnErrorActionQuery.OnErrorAction Property

Gets or set the action type.

public OnErrorActionType OnErrorAction {get; set;}

See Also

OnErrorActionQuery Class | Aspose.Cells.GridDesktop.Data Namespace


OnErrorActionType Enumeration

Used in CellError event of the GridWeb. User set the OnErrorActionQuery.OnErrorAction to tell the control Stop processing or Ignore error.

public enum OnErrorActionType

Members

Member Name | Description | Value
Throw | Throws the current exception. | 0
Stop | Stops current processing. | 1
Ignore | Ignores the error and continue processing. | 2

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


RowColumnEventHandler Delegate

Represents the interface that intend to handle row/column events.

void handleCellEvent(Object sender, RowColumnEventArgs e);

public delegate void RowColumnEventHandler(
object sender,
RowColumnEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument. Call e.RejectOperation() if you want to cancel the deleting operation in RowDeleting or ColumnDeleting event handlers.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


WebCellErrorType Enumeration

Used in WebCellException. Represents the cell error type.

public enum WebCellErrorType

Members

Member Name | Description | Value
ValidationError | The cell's validation failed. | 0
DataSourceInsertError | When insert the sheet's binding row to datasource, an error occured. | 1
DataSourceUpdateError | When update the sheet's binding row or object's field, an error occured. | 2
DataSourceDeleteError | When delete the sheet's binding row to datasource, an error occured. | 3

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


WorkbookEventHandler Delegate

Represents the interface that intend to handle workbook events.

void handleCellEvent(Object sender, CellEventArgs e);

public delegate void WorkbookEventHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridDesktop.Data

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

Aspose.Cells.GridDesktop.Data Namespace


Aspose.Cells.GridDesktop.ToolBar

Aspose.Cells for .NET

Aspose.Cells.GridDesktop.ToolBar Namespace

Namespace hierarchy

Classes

Class | Description
FormulaBar | FormulaBar


FormulaBar Class

FormulaBar

For a list of all members of this type, see FormulaBar Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Aspose.Cells.GridDesktop.ToolBar.FormulaBar

public class FormulaBar : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridDesktop.ToolBar

Assembly: Aspose.Cells.GridDesktop (in Aspose.Cells.GridDesktop.dll)

See Also

FormulaBar Members | Aspose.Cells.GridDesktop.ToolBar Namespace


FormulaBar Members

FormulaBar overview

Public Instance Constructors

FormulaBar Overloaded. Initializes a new instance of the FormulaBar class.

Public Instance Properties

AccessibilityObject (inherited from Control) |
AccessibleDefaultActionDescription (inherited from Control) |
AccessibleDescription (inherited from Control) |
AccessibleName (inherited from Control) |
AccessibleRole (inherited from Control) |
ActiveControl (inherited from ContainerControl) |
AllowDrop (inherited from Control) |
Anchor (inherited from Control) |
AutoScaleDimensions (inherited from ContainerControl) |
AutoScaleMode (inherited from ContainerControl) |
AutoScroll (inherited from ScrollableControl) |
AutoScrollMargin (inherited from ScrollableControl) |
AutoScrollMinSize (inherited from ScrollableControl) |
AutoScrollOffset (inherited from Control) |
AutoScrollPosition (inherited from ScrollableControl) |
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) |
AutoValidate (inherited from UserControl) |
BackColor (inherited from Control) |
BackgroundImage (inherited from Control) |
BackgroundImageLayout (inherited from Control) |
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) |
Bottom (inherited from Control) |
Bounds (inherited from Control) |
CanFocus (inherited from Control) |
CanSelect (inherited from Control) |
Capture (inherited from Control) |
CausesValidation (inherited from Control) |
ClientRectangle (inherited from Control) |
ClientSize (inherited from Control) |
CompanyName (inherited from Control) |
Container (inherited from Component) |
ContainsFocus (inherited from Control) |
ContextMenu (inherited from Control) |
ContextMenuStrip (inherited from Control) |
Controls (inherited from Control) |
Created (inherited from Control) |
CurrentAutoScaleDimensions (inherited from ContainerControl) |
Cursor (inherited from Control) |
DataBindings (inherited from Control) |
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) |
Dock (inherited from Control) |
DockPadding (inherited from ScrollableControl) |
Draggable | get set Draggable for Formula Box,default value is false.
Enabled (inherited from Control) |
Focused (inherited from Control) |
Font (inherited from Control) |
ForeColor (inherited from Control) |
GridDesktop | Gets or sets a GridDesktop control that this FormalBar will apply to.
Handle (inherited from Control) |
HasChildren (inherited from Control) |
Height (inherited from Control) |
HorizontalScroll | Obsolete.
ImeMode (inherited from Control) |
InvokeRequired (inherited from Control) |
IsAccessible (inherited from Control) |
IsDisposed (inherited from Control) |
IsHandleCreated (inherited from Control) |
IsMirrored (inherited from Control) |
LayoutEngine (inherited from Control) |
Left (inherited from Control) |
Location (inherited from Control) |
Margin (inherited from Control) |
MaximumSize (inherited from Control) |
MinimumSize (inherited from Control) |
Name (inherited from Control) |
Padding (inherited from Control) |
Parent (inherited from Control) |
ParentForm (inherited from ContainerControl) |
PreferredSize (inherited from Control) |
ProductName (inherited from Control) |
ProductVersion (inherited from Control) |
RecreatingHandle (inherited from Control) |
Region (inherited from Control) |
Resizable | get set Resizable for Formula Box,default value is false. not suitable when set ScrollBars.None
Right (inherited from Control) |
RightToLeft (inherited from Control) |
ScrollBars | get or set scrollbars for Formula Box.the default value is ScrollBars.Verticals .when set ScrollBars.None the Formula Box is auto heighted.
Site (inherited from Control) |
Size (inherited from Control) |
TabIndex (inherited from Control) |
TabStop (inherited from Control) |
Tag (inherited from Control) |
Text (inherited from UserControl) |
Top (inherited from Control) |
TopLevelControl (inherited from Control) |
UseWaitCursor (inherited from Control) |
VerticalScroll | Obsolete.
Visible (inherited from Control) |
Width (inherited from Control) |
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded.
BringToFront (inherited from Control) |
Contains (inherited from Control) |
CreateControl (inherited from Control) |
CreateGraphics (inherited from Control) |
CreateObjRef (inherited from MarshalByRefObject) |
Dispose (inherited from Component) |
DoDragDrop (inherited from Control) |
DrawToBitmap (inherited from Control) |
EndInvoke (inherited from Control) |
Equals (inherited from Object) |
FindForm (inherited from Control) |
Focus (inherited from Control) |
GetChildAtPoint (inherited from Control) | Overloaded.
GetContainerControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetNextControl (inherited from Control) |
GetPreferredSize (inherited from Control) |
GetType (inherited from Object) |
Hide (inherited from Control) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
Invalidate (inherited from Control) | Overloaded.
Invoke (inherited from Control) | Overloaded.
PerformAutoScale (inherited from ContainerControl) |
PerformLayout (inherited from Control) | Overloaded.
PointToClient (inherited from Control) |
PointToScreen (inherited from Control) |
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) |
RectangleToScreen (inherited from Control) |
Refresh (inherited from Control) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) |
ResumeLayout (inherited from Control) | Overloaded.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) |
SelectNextControl (inherited from Control) |
SendToBack (inherited from Control) |
SetAutoScrollMargin (inherited from ScrollableControl) |
SetBounds (inherited from Control) | Overloaded.
Show (inherited from Control) |
SuspendLayout (inherited from Control) |
ToString (inherited from Component) |
Update (inherited from Control) |
Validate (inherited from ContainerControl) | Overloaded.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl)
AutoValidateChanged (inherited from UserControl)
BackColorChanged (inherited from Control)
BackgroundImageChanged (inherited from Control)
BackgroundImageLayoutChanged (inherited from Control)
BindingContextChanged (inherited from Control)
CausesValidationChanged (inherited from Control)
ChangeUICues (inherited from Control)
Click (inherited from Control)
ClientSizeChanged (inherited from Control)
ContextMenuChanged (inherited from Control)
ContextMenuStripChanged (inherited from Control)
ControlAdded (inherited from Control)
ControlRemoved (inherited from Control)
CursorChanged (inherited from Control)
Disposed (inherited from Component)
DockChanged (inherited from Control)
DoubleClick (inherited from Control)
DragDrop (inherited from Control)
DragEnter (inherited from Control)
DragLeave (inherited from Control)
DragOver (inherited from Control)
EnabledChanged (inherited from Control)
Enter (inherited from Control)
FontChanged (inherited from Control)
ForeColorChanged (inherited from Control)
GiveFeedback (inherited from Control)
GotFocus (inherited from Control)
HandleCreated (inherited from Control)
HandleDestroyed (inherited from Control)
HelpRequested (inherited from Control)
ImeModeChanged (inherited from Control)
Invalidated (inherited from Control)
KeyDown (inherited from Control)
KeyPress (inherited from Control)
KeyUp (inherited from Control)
Layout (inherited from Control)
Leave (inherited from Control)
Load (inherited from UserControl)
LocationChanged (inherited from Control)
LostFocus (inherited from Control)
MarginChanged (inherited from Control)
MouseCaptureChanged (inherited from Control)
MouseClick (inherited from Control)
MouseDoubleClick (inherited from Control)
MouseDown (inherited from Control)
MouseEnter (inherited from Control)
MouseHover (inherited from Control)
MouseLeave (inherited from Control)
MouseMove (inherited from Control)
MouseUp (inherited from Control)
MouseWheel (inherited from Control)
Move (inherited from Control)
PaddingChanged (inherited from Control)
Paint (inherited from Control)
ParentChanged (inherited from Control)
PreviewKeyDown (inherited from Control)
QueryAccessibilityHelp (inherited from Control)
QueryContinueDrag (inherited from Control)
RegionChanged (inherited from Control)
Resize (inherited from Control)
RightToLeftChanged (inherited from Control)
Scroll (inherited from ScrollableControl)
SizeChanged (inherited from Control)
StyleChanged (inherited from Control)
SystemColorsChanged (inherited from Control)
TabIndexChanged (inherited from Control)
TabStopChanged (inherited from Control)
TextChanged (inherited from UserControl)
Validated (inherited from Control)
Validating (inherited from Control)
VisibleChanged (inherited from Control)

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


FormulaBar Constructor

Default constructor.

Overload List

Default constructor.

public FormulaBar();

Constructs a FormulaBar with the specified GridDesktop control.

public FormulaBar(GridDesktop);

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


FormulaBar Constructor ()

Default constructor.

public FormulaBar();

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace | FormulaBar Constructor Overload List


FormulaBar Constructor (GridDesktop)

Constructs a FormulaBar with the specified GridDesktop control.

public FormulaBar(
GridDesktop gridDesktop
);

Parameters

gridDesktop

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace | FormulaBar Constructor Overload List


FormulaBar Properties

The properties of the FormulaBar class are listed below. For a complete list of FormulaBar class members, see the FormulaBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) |
AccessibleDefaultActionDescription (inherited from Control) |
AccessibleDescription (inherited from Control) |
AccessibleName (inherited from Control) |
AccessibleRole (inherited from Control) |
ActiveControl (inherited from ContainerControl) |
AllowDrop (inherited from Control) |
Anchor (inherited from Control) |
AutoScaleDimensions (inherited from ContainerControl) |
AutoScaleMode (inherited from ContainerControl) |
AutoScroll (inherited from ScrollableControl) |
AutoScrollMargin (inherited from ScrollableControl) |
AutoScrollMinSize (inherited from ScrollableControl) |
AutoScrollOffset (inherited from Control) |
AutoScrollPosition (inherited from ScrollableControl) |
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) |
AutoValidate (inherited from UserControl) |
BackColor (inherited from Control) |
BackgroundImage (inherited from Control) |
BackgroundImageLayout (inherited from Control) |
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) |
Bottom (inherited from Control) |
Bounds (inherited from Control) |
CanFocus (inherited from Control) |
CanSelect (inherited from Control) |
Capture (inherited from Control) |
CausesValidation (inherited from Control) |
ClientRectangle (inherited from Control) |
ClientSize (inherited from Control) |
CompanyName (inherited from Control) |
Container (inherited from Component) |
ContainsFocus (inherited from Control) |
ContextMenu (inherited from Control) |
ContextMenuStrip (inherited from Control) |
Controls (inherited from Control) |
Created (inherited from Control) |
CurrentAutoScaleDimensions (inherited from ContainerControl) |
Cursor (inherited from Control) |
DataBindings (inherited from Control) |
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) |
Dock (inherited from Control) |
DockPadding (inherited from ScrollableControl) |
Draggable | get set Draggable for Formula Box,default value is false.
Enabled (inherited from Control) |
Focused (inherited from Control) |
Font (inherited from Control) |
ForeColor (inherited from Control) |
GridDesktop | Gets or sets a GridDesktop control that this FormalBar will apply to.
Handle (inherited from Control) |
HasChildren (inherited from Control) |
Height (inherited from Control) |
HorizontalScroll | Obsolete.
ImeMode (inherited from Control) |
InvokeRequired (inherited from Control) |
IsAccessible (inherited from Control) |
IsDisposed (inherited from Control) |
IsHandleCreated (inherited from Control) |
IsMirrored (inherited from Control) |
LayoutEngine (inherited from Control) |
Left (inherited from Control) |
Location (inherited from Control) |
Margin (inherited from Control) |
MaximumSize (inherited from Control) |
MinimumSize (inherited from Control) |
Name (inherited from Control) |
Padding (inherited from Control) |
Parent (inherited from Control) |
ParentForm (inherited from ContainerControl) |
PreferredSize (inherited from Control) |
ProductName (inherited from Control) |
ProductVersion (inherited from Control) |
RecreatingHandle (inherited from Control) |
Region (inherited from Control) |
Resizable | get set Resizable for Formula Box,default value is false. not suitable when set ScrollBars.None
Right (inherited from Control) |
RightToLeft (inherited from Control) |
ScrollBars | get or set scrollbars for Formula Box.the default value is ScrollBars.Verticals .when set ScrollBars.None the Formula Box is auto heighted.
Site (inherited from Control) |
Size (inherited from Control) |
TabIndex (inherited from Control) |
TabStop (inherited from Control) |
Tag (inherited from Control) |
Text (inherited from UserControl) |
Top (inherited from Control) |
TopLevelControl (inherited from Control) |
UseWaitCursor (inherited from Control) |
VerticalScroll | Obsolete.
Visible (inherited from Control) |
Width (inherited from Control) |
WindowTarget (inherited from Control) |

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


Draggable Property

Aspose.Cells for .NET

FormulaBar.Draggable Property

get set Draggable for Formula Box,default value is false.

public bool Draggable {get; set;}

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


GridDesktop Property

Aspose.Cells for .NET

FormulaBar.GridDesktop Property

Gets or sets a GridDesktop control that this FormalBar will apply to.

public GridDesktop GridDesktop {get; set;}

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


HorizontalScroll Property

Aspose.Cells for .NET

FormulaBar.HorizontalScroll Property

NOTE: This property is now obsolete.

This property has been deprecated ,please use ScrollBars.Horizontal instead of,as You do not need this control for the controls that already have built-in scrolling.

new public HScrollProperties HorizontalScroll {get; set;}

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


Resizable Property

Aspose.Cells for .NET

FormulaBar.Resizable Property

get set Resizable for Formula Box,default value is false. not suitable when set ScrollBars.None

public bool Resizable {get; set;}

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


ScrollBars Property

Aspose.Cells for .NET

FormulaBar.ScrollBars Property

get or set scrollbars for Formula Box.the default value is ScrollBars.Verticals .when set ScrollBars.None the Formula Box is auto heighted.

public ScrollBars ScrollBars {get; set;}

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


VerticalScroll Property

Aspose.Cells for .NET

FormulaBar.VerticalScroll Property

NOTE: This property is now obsolete.

This property has been deprecated ,please use ScrollBars.Vertical instead of ,as You do not need this control for the controls that already have built-in scrolling.

new public VScrollProperties VerticalScroll {get; set;}

See Also

FormulaBar Class | Aspose.Cells.GridDesktop.ToolBar Namespace


Aspose.Cells.GridWeb

Aspose.Cells for .NET

Aspose.Cells.GridWeb Namespace

Namespace hierarchy

Classes

Class | Description
BindColumn | BindColumn.
BindColumnCollection | BindColumnCollection.
CellEventArgs | Provides data for cell events.
CustomCommandButton | Represents a custom command button in the tab bar of the GridWeb control.
CustomCommandButtonCollection | Represents the collection of CustomCommandButton.
ExtWebControl |
FilterHelper |
GridTableItemStyle | Inherited from System.Web.UI.WebControls.TableItemStyle. Encapsulates the styles of a WebCell.
GridTableStyle | Inherited from System.Web.UI.WebControls.TableStyle. Represents the style of a web table. Please refer to .NET SDK document about System.Web.UI.WebControls.TableStyle for further information.
GridWeb |
GridWebForm | GridWebForm control. It works with the GridWeb control. Set the GridWebControl property for it before run it.
GridWorksheetDesign | Inherited from GridWorksheet. Used in design-time only.
License |
MainWeb |
RowColumnEventArgs | Provides data for row/column events.
TableItemStyle | Obsolete.
Validation | Obsolete.
ViewerStyleTemplate | ViewerStyleTemplate.
WebBorderStyle | Encapsulates the style of web table or cell border.
WorksheetDesign | Inherited from WebWorksheet. Used in design-time only.

Enumerations

Enumeration | Description
BorderCollapseType | Collapse type of a table's border object.
CustomCommandButtonType | Represents the type of a custom command.
LayoutFixedType | Layout fixed type of a table object.
PresetStyle | Represents the preset style or an GridWeb control. By far, we provide 7 preset styles.
RowColumnType | Represents the row/column type of the row/column events.
SessionMode | Represents the session mode of the grid.
SetBorderPosition | Represents the border position to be set of a cells range.
ValidationType | Represents customer side validation type. AnyValue represents no validation.


BindColumn Class

BindColumn.

For a list of all members of this type, see BindColumn Members.

System.Object
Aspose.Cells.GridWeb.BindColumn

public class BindColumn : ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

BindColumn Members | Aspose.Cells.GridWeb Namespace


BindColumn Members

BindColumn overview

Public Instance Constructors

BindColumn Constructor Defalut constructor.

Public Instance Properties

AlternativeStyle | Gets or sets the alternative style of the column.
Caption | The caption of the column.
ColumnHeaderStyle | Gets or sets the style of the column.
CommandName | The command name of the column. A CellCommand Hyperlink will be created in the bound cell if the CommandName property is set.
CommandText | The displaying command text of the column. If set to null, the cell will use the field value as the command text.
CustomFormat | The custom format string.
DataField | Gets or sets the data field name string.
EnableSort | Indicates whether the user can click the column header to sort by this field.
ImageUrl | The image url of the command hyperlink.
IsAutoCreated | Indicates whether the column is created automatically. If true, the column will be deleted when user change the datasource in the design time.
IsReadOnly | Indicates whether the column is readonly.
Name | Design time used only.
NumberType | Gets or sets the number type of the column.
Style | Gets or sets the style of the column.
UseAlternativeStyle | Gets or sets whether to use the alternative style for the column.
Validation | Gets or sets the validation object of the column.
Width | Gets of sets the width of the column.only pixel or point accept

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


BindColumn Constructor

Defalut constructor.

public BindColumn();

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


BindColumn Properties

The properties of the BindColumn class are listed below. For a complete list of BindColumn class members, see the BindColumn Members topic.

Public Instance Properties

AlternativeStyle | Gets or sets the alternative style of the column.
Caption | The caption of the column.
ColumnHeaderStyle | Gets or sets the style of the column.
CommandName | The command name of the column. A CellCommand Hyperlink will be created in the bound cell if the CommandName property is set.
CommandText | The displaying command text of the column. If set to null, the cell will use the field value as the command text.
CustomFormat | The custom format string.
DataField | Gets or sets the data field name string.
EnableSort | Indicates whether the user can click the column header to sort by this field.
ImageUrl | The image url of the command hyperlink.
IsAutoCreated | Indicates whether the column is created automatically. If true, the column will be deleted when user change the datasource in the design time.
IsReadOnly | Indicates whether the column is readonly.
Name | Design time used only.
NumberType | Gets or sets the number type of the column.
Style | Gets or sets the style of the column.
UseAlternativeStyle | Gets or sets whether to use the alternative style for the column.
Validation | Gets or sets the validation object of the column.
Width | Gets of sets the width of the column.only pixel or point accept

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


AlternativeStyle Property

Aspose.Cells for .NET

BindColumn.AlternativeStyle Property

Gets or sets the alternative style of the column.

public TableItemStyle AlternativeStyle {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


Caption Property

Aspose.Cells for .NET

BindColumn.Caption Property

The caption of the column.

public string Caption {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


ColumnHeaderStyle Property

Aspose.Cells for .NET

BindColumn.ColumnHeaderStyle Property

Gets or sets the style of the column.

public TableItemStyle ColumnHeaderStyle {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


CommandName Property

Aspose.Cells for .NET

BindColumn.CommandName Property

The command name of the column. A CellCommand Hyperlink will be created in the bound cell if the CommandName property is set.

public string CommandName {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


CommandText Property

Aspose.Cells for .NET

BindColumn.CommandText Property

The displaying command text of the column. If set to null, the cell will use the field value as the command text.

public string CommandText {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


CustomFormat Property

Aspose.Cells for .NET

BindColumn.CustomFormat Property

The custom format string.

public string CustomFormat {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


DataField Property

Aspose.Cells for .NET

BindColumn.DataField Property

Gets or sets the data field name string.

public string DataField {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


EnableSort Property

Aspose.Cells for .NET

BindColumn.EnableSort Property

Indicates whether the user can click the column header to sort by this field.

public bool EnableSort {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


ImageUrl Property

Aspose.Cells for .NET

BindColumn.ImageUrl Property

The image url of the command hyperlink.

public string ImageUrl {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


IsAutoCreated Property

Aspose.Cells for .NET

BindColumn.IsAutoCreated Property

Indicates whether the column is created automatically. If true, the column will be deleted when user change the datasource in the design time.

public bool IsAutoCreated {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


IsReadOnly Property

Aspose.Cells for .NET

BindColumn.IsReadOnly Property

Indicates whether the column is readonly.

public bool IsReadOnly {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


Name Property

Aspose.Cells for .NET

BindColumn.Name Property

Design time used only.

public string Name {get;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


NumberType Property

Aspose.Cells for .NET

BindColumn.NumberType Property

Gets or sets the number type of the column.

public NumberType NumberType {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


Style Property

Aspose.Cells for .NET

BindColumn.Style Property

Gets or sets the style of the column.

public TableItemStyle Style {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


UseAlternativeStyle Property

Aspose.Cells for .NET

BindColumn.UseAlternativeStyle Property

Gets or sets whether to use the alternative style for the column.

public bool UseAlternativeStyle {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


Validation Property

Aspose.Cells for .NET

BindColumn.Validation Property

Gets or sets the validation object of the column.

public Validation Validation {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


Width Property

Aspose.Cells for .NET

BindColumn.Width Property

Gets of sets the width of the column.only pixel or point accept

public Unit Width {get; set;}

See Also

BindColumn Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection Class

BindColumnCollection.

For a list of all members of this type, see BindColumnCollection Members.

System.Object
Aspose.Cells.GridWeb.BindColumnCollection

public class BindColumnCollection : IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

BindColumnCollection Members | Aspose.Cells.GridWeb Namespace


BindColumnCollection Members

BindColumnCollection overview

Public Instance Properties

Count | Gets the count of the collection.
IsFixedSize | Always true.
IsReadOnly | Alway true.
IsSynchronized | Internal used only.
Item | Gets the bind column by an integer index or a data field name.
SyncRoot | Internal used only.

Public Instance Methods

Add | Adds the specified bind column object to the collection.
Clear | Clears the colleciton.
Contains | Indicates whether the bind column is in the collection.
CopyTo | Copies to an array.
Equals (inherited from Object) |
GetEnumerator | Gets a enumerator.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of the specified bind column object.
Insert | Inserts an bind column object.
Remove | Remove an bind column object.
RemoveAt | Removes at the specified index.
ToString (inherited from Object) |

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection Properties

The properties of the BindColumnCollection class are listed below. For a complete list of BindColumnCollection class members, see the BindColumnCollection Members topic.

Public Instance Properties

Count | Gets the count of the collection.
IsFixedSize | Always true.
IsReadOnly | Alway true.
IsSynchronized | Internal used only.
Item | Gets the bind column by an integer index or a data field name.
SyncRoot | Internal used only.

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


Count Property

Aspose.Cells for .NET

BindColumnCollection.Count Property

Gets the count of the collection.

public int Count {get;}

Implements

ICollection.Count

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


IsFixedSize Property

Aspose.Cells for .NET

BindColumnCollection.IsFixedSize Property

Always true.

public bool IsFixedSize {get;}

Implements

IList.IsFixedSize

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


IsReadOnly Property

Aspose.Cells for .NET

BindColumnCollection.IsReadOnly Property

Alway true.

public bool IsReadOnly {get;}

Implements

IList.IsReadOnly

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


IsSynchronized Property

Aspose.Cells for .NET

BindColumnCollection.IsSynchronized Property

Internal used only.

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


Item Property

Aspose.Cells for .NET

BindColumnCollection.Item Property

Gets the bind column by an integer index or a data field name.

public BindColumn this[
object index
] {get;}

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


SyncRoot Property

Aspose.Cells for .NET

BindColumnCollection.SyncRoot Property

Internal used only.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection Methods

The methods of the BindColumnCollection class are listed below. For a complete list of BindColumnCollection class members, see the BindColumnCollection Members topic.

Public Instance Methods

Add | Adds the specified bind column object to the collection.
Clear | Clears the colleciton.
Contains | Indicates whether the bind column is in the collection.
CopyTo | Copies to an array.
Equals (inherited from Object) |
GetEnumerator | Gets a enumerator.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of the specified bind column object.
Insert | Inserts an bind column object.
Remove | Remove an bind column object.
RemoveAt | Removes at the specified index.
ToString (inherited from Object) |

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.Add Method

Adds the specified bind column object to the collection.

public int Add(
object value
);

Parameters

value

Return Value

Implements

IList.Add

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.Clear Method

Clears the colleciton.

public void Clear();

Implements

IList.Clear

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.Contains Method

Indicates whether the bind column is in the collection.

public bool Contains(
object value
);

Parameters

value

Return Value

Implements

IList.Contains

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.CopyTo Method

Copies to an array.

public void CopyTo(
Array array,
int index
);

Parameters

array
index

Implements

ICollection.CopyTo

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.GetEnumerator Method

Gets a enumerator.

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.IndexOf Method

Gets the index of the specified bind column object.

public int IndexOf(
object value
);

Parameters

value

Return Value

Implements

IList.IndexOf

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.Insert Method

Inserts an bind column object.

public void Insert(
int index,
object value
);

Parameters

index
value

Implements

IList.Insert

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.Remove Method

Remove an bind column object.

public void Remove(
object value
);

Parameters

value

Implements

IList.Remove

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BindColumnCollection.RemoveAt Method

Removes at the specified index.

public void RemoveAt(
int index
);

Parameters

index

Implements

IList.RemoveAt

See Also

BindColumnCollection Class | Aspose.Cells.GridWeb Namespace


BorderCollapseType Enumeration

Collapse type of a table's border object.

public enum BorderCollapseType

Members

Member Name | Description | Value
NotSet | Not set. | 0
Collapse | Collapsed. | 1
Separate | Separated. | 2

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


CellEventArgs Class

Provides data for cell events.

For a list of all members of this type, see CellEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridWeb.CellEventArgs

public class CellEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

CellEventArgs Members | Aspose.Cells.GridWeb Namespace


CellEventArgs Members

CellEventArgs overview

Public Instance Constructors

CellEventArgs Constructor Initializes a new instance of the CellEventArgs class.

Public Instance Properties

Argument | The argument of the event.
Cell | The cell.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellEventArgs Class | Aspose.Cells.GridWeb Namespace


CellEventArgs Constructor

Initializes a new instance of the CellEventArgs class.

public CellEventArgs();

See Also

CellEventArgs Class | Aspose.Cells.GridWeb Namespace


CellEventArgs Properties

The properties of the CellEventArgs class are listed below. For a complete list of CellEventArgs class members, see the CellEventArgs Members topic.

Public Instance Properties

Argument | The argument of the event.
Cell | The cell.

See Also

CellEventArgs Class | Aspose.Cells.GridWeb Namespace


Argument Property

Aspose.Cells for .NET

CellEventArgs.Argument Property

The argument of the event.

public object Argument {get;}

See Also

CellEventArgs Class | Aspose.Cells.GridWeb Namespace


Cell Property

Aspose.Cells for .NET

CellEventArgs.Cell Property

The cell.

public GridCell Cell {get;}

See Also

CellEventArgs Class | Aspose.Cells.GridWeb Namespace


CustomCommandButton Class

Represents a custom command button in the tab bar of the GridWeb control.

For a list of all members of this type, see CustomCommandButton Members.

System.Object
System.Web.UI.Control
Aspose.Cells.GridWeb.CustomCommandButton

public class CustomCommandButton : Control, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
CustomCommandButton button = new CustomCommandButton();
button.Command = "MyCommand";
button.ImageUrl = "images/button1.gif";
GridWeb1.CustomCommandButtons.Add(button);
[VB]
Dim button As CustomCommandButton =  New CustomCommandButton()
button.Command = "MyCommand"
button.ImageUrl = "images/button1.gif"
GridWeb1.CustomCommandButtons.Add(button)

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

CustomCommandButton Members | Aspose.Cells.GridWeb Namespace


CustomCommandButton Members

CustomCommandButton overview

Public Instance Constructors

CustomCommandButton Constructor Default constructor.

Public Instance Properties

AppRelativeTemplateSourceDirectory (inherited from Control) |
BindingContainer (inherited from Control) |
ClientClickEvent | Gets or sets the click event handler at client side.
ClientID (inherited from Control) |
Command | Gets or sets the command name.
CommandType | Gets or sets the rendering type of the command. The type can be command button or context menu item.
Controls (inherited from Control) |
DiscardInput | Indicates whether to discard user input at client browser when user click this button. Could be used as an "undo" action.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
ID (inherited from Control) |
ImageUrl | Gets or sets the command button's image url. If sets to null or empty string, the button will only display it's text.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
Site (inherited from Control) |
SkinID (inherited from Control) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
Text | Gets or sets the alternative text of the command button.
ToolTip | Gets or sets the tooltip of the command button.
UniqueID (inherited from Control) |
Visible (inherited from Control) |
Width | Width of the button.

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetObjectData | Internal used only.
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Public Instance Events

DataBinding (inherited from Control)
Disposed (inherited from Control)
Init (inherited from Control)
Load (inherited from Control)
PreRender (inherited from Control)
Unload (inherited from Control)

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


CustomCommandButton Constructor

Default constructor.

public CustomCommandButton();

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


CustomCommandButton Properties

The properties of the CustomCommandButton class are listed below. For a complete list of CustomCommandButton class members, see the CustomCommandButton Members topic.

Public Instance Properties

AppRelativeTemplateSourceDirectory (inherited from Control) |
BindingContainer (inherited from Control) |
ClientClickEvent | Gets or sets the click event handler at client side.
ClientID (inherited from Control) |
Command | Gets or sets the command name.
CommandType | Gets or sets the rendering type of the command. The type can be command button or context menu item.
Controls (inherited from Control) |
DiscardInput | Indicates whether to discard user input at client browser when user click this button. Could be used as an "undo" action.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
ID (inherited from Control) |
ImageUrl | Gets or sets the command button's image url. If sets to null or empty string, the button will only display it's text.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
Site (inherited from Control) |
SkinID (inherited from Control) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
Text | Gets or sets the alternative text of the command button.
ToolTip | Gets or sets the tooltip of the command button.
UniqueID (inherited from Control) |
Visible (inherited from Control) |
Width | Width of the button.

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


ClientClickEvent Property

Aspose.Cells for .NET

CustomCommandButton.ClientClickEvent Property

Gets or sets the click event handler at client side.

public string ClientClickEvent {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


Command Property

Aspose.Cells for .NET

CustomCommandButton.Command Property

Gets or sets the command name.

public string Command {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


CommandType Property

Aspose.Cells for .NET

CustomCommandButton.CommandType Property

Gets or sets the rendering type of the command. The type can be command button or context menu item.

public CustomCommandButtonType CommandType {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


DiscardInput Property

Aspose.Cells for .NET

CustomCommandButton.DiscardInput Property

Indicates whether to discard user input at client browser when user click this button. Could be used as an "undo" action.

public bool DiscardInput {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


ImageUrl Property

Aspose.Cells for .NET

CustomCommandButton.ImageUrl Property

Gets or sets the command button's image url. If sets to null or empty string, the button will only display it's text.

public string ImageUrl {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


Text Property

Aspose.Cells for .NET

CustomCommandButton.Text Property

Gets or sets the alternative text of the command button.

public string Text {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


ToolTip Property

Aspose.Cells for .NET

CustomCommandButton.ToolTip Property

Gets or sets the tooltip of the command button.

public string ToolTip {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


Width Property

Aspose.Cells for .NET

CustomCommandButton.Width Property

Width of the button.

public Unit Width {get; set;}

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


CustomCommandButton Methods

The methods of the CustomCommandButton class are listed below. For a complete list of CustomCommandButton class members, see the CustomCommandButton Members topic.

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetObjectData | Internal used only.
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


CustomCommandButton.GetObjectData Method

Internal used only.

public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Implements

ISerializable.GetObjectData

See Also

CustomCommandButton Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection Class

Represents the collection of CustomCommandButton.

For a list of all members of this type, see CustomCommandButtonCollection Members.

System.Object
Aspose.Cells.GridWeb.CustomCommandButtonCollection

public class CustomCommandButtonCollection : IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
CustomCommandButton button = new CustomCommandButton();
button.Command = "MyCommand";
button.ImageUrl = "images/button1.gif";
GridWeb1.CustomCommandButtons.Add(button);
[VB]
Dim button As CustomCommandButton =  New CustomCommandButton()
button.Command = "MyCommand"
button.ImageUrl = "images/button1.gif"
GridWeb1.CustomCommandButtons.Add(button)

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

CustomCommandButtonCollection Members | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection Members

CustomCommandButtonCollection overview

Public Instance Properties

Count | Gets the count of the collection.
IsFixedSize | Internal used only.
IsReadOnly | Internal used only.
IsSynchronized | Internal used only.
Item | Gets a custom command button object at the index.
SyncRoot | Internal used only.

Public Instance Methods

Add | Add a custom command button object to the collection.
Clear | Clears the collection.
Contains | Indicates whether the custom command button object is in the collection.
CopyTo | Copies the collection to an array.
Equals (inherited from Object) |
GetEnumerator | Gets a IEnumerator object of the collection.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of the button.
Insert | Inserts a button at the index.
Remove | Removes the custom command button object.
RemoveAt | Removes at the index.
ToString (inherited from Object) |

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection Properties

The properties of the CustomCommandButtonCollection class are listed below. For a complete list of CustomCommandButtonCollection class members, see the CustomCommandButtonCollection Members topic.

Public Instance Properties

Count | Gets the count of the collection.
IsFixedSize | Internal used only.
IsReadOnly | Internal used only.
IsSynchronized | Internal used only.
Item | Gets a custom command button object at the index.
SyncRoot | Internal used only.

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


Count Property

Aspose.Cells for .NET

CustomCommandButtonCollection.Count Property

Gets the count of the collection.

public int Count {get;}

Implements

ICollection.Count

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


IsFixedSize Property

Aspose.Cells for .NET

CustomCommandButtonCollection.IsFixedSize Property

Internal used only.

public bool IsFixedSize {get;}

Implements

IList.IsFixedSize

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


IsReadOnly Property

Aspose.Cells for .NET

CustomCommandButtonCollection.IsReadOnly Property

Internal used only.

public bool IsReadOnly {get;}

Implements

IList.IsReadOnly

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


IsSynchronized Property

Aspose.Cells for .NET

CustomCommandButtonCollection.IsSynchronized Property

Internal used only.

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


Item Property

Aspose.Cells for .NET

CustomCommandButtonCollection.Item Property

Gets a custom command button object at the index.

public CustomCommandButton this[
int index
] {get; set;}

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


SyncRoot Property

Aspose.Cells for .NET

CustomCommandButtonCollection.SyncRoot Property

Internal used only.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection Methods

The methods of the CustomCommandButtonCollection class are listed below. For a complete list of CustomCommandButtonCollection class members, see the CustomCommandButtonCollection Members topic.

Public Instance Methods

Add | Add a custom command button object to the collection.
Clear | Clears the collection.
Contains | Indicates whether the custom command button object is in the collection.
CopyTo | Copies the collection to an array.
Equals (inherited from Object) |
GetEnumerator | Gets a IEnumerator object of the collection.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of the button.
Insert | Inserts a button at the index.
Remove | Removes the custom command button object.
RemoveAt | Removes at the index.
ToString (inherited from Object) |

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.Add Method

Add a custom command button object to the collection.

public int Add(
object value
);

Parameters

value
The custom command button object.

Return Value

The index.

Implements

IList.Add

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.Clear Method

Clears the collection.

public void Clear();

Implements

IList.Clear

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.Contains Method

Indicates whether the custom command button object is in the collection.

public bool Contains(
object value
);

Parameters

value
Indicates whether the custom command button object is in the collection.

Return Value

True of false.

Implements

IList.Contains

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.CopyTo Method

Copies the collection to an array.

public void CopyTo(
Array array,
int index
);

Parameters

array
The array.
index
The start index of the array.

Implements

ICollection.CopyTo

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.GetEnumerator Method

Gets a IEnumerator object of the collection.

public IEnumerator GetEnumerator();

Return Value

The IEnumerator object.

Implements

IEnumerable.GetEnumerator

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.IndexOf Method

Gets the index of the button.

public int IndexOf(
object value
);

Parameters

value
The button object.

Return Value

The index.

Implements

IList.IndexOf

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.Insert Method

Inserts a button at the index.

public void Insert(
int index,
object value
);

Parameters

index
Index.
value
The CustomCommandButton object.

Implements

IList.Insert

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.Remove Method

Removes the custom command button object.

public void Remove(
object value
);

Parameters

value
The custom command button object.

Implements

IList.Remove

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonCollection.RemoveAt Method

Removes at the index.

public void RemoveAt(
int index
);

Parameters

index
Index.

Implements

IList.RemoveAt

See Also

CustomCommandButtonCollection Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtonType Enumeration

Represents the type of a custom command.

public enum CustomCommandButtonType

Members

Member Name | Description | Value
CommandButton | The custom command will be rendered as a command button in the command bar. | 0
ContextMenuItem | The custom command will be rendered as a context menu item. | 1

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


ExtWebControl Class

For a list of all members of this type, see ExtWebControl Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Aspose.Cells.GridWeb.ExtWebControl
Aspose.Cells.GridWeb.MainWeb

public class ExtWebControl : WebControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

ExtWebControl Members | Aspose.Cells.GridWeb Namespace


ExtWebControl Members

ExtWebControl overview

Public Instance Constructors

ExtWebControl Constructor Initializes a new instance of the ExtWebControl class.

Public Instance Properties

AccessKey (inherited from WebControl)
AppRelativeTemplateSourceDirectory (inherited from Control)
Attributes (inherited from WebControl)
BackColor (inherited from WebControl)
BindingContainer (inherited from Control)
BorderColor (inherited from WebControl)
BorderStyle (inherited from WebControl)
BorderWidth (inherited from WebControl)
ClientID (inherited from Control)
Controls (inherited from Control)
ControlStyle (inherited from WebControl)
ControlStyleCreated (inherited from WebControl)
CssClass (inherited from WebControl)
Enabled (inherited from WebControl)
EnableTheming (inherited from WebControl)
EnableViewState (inherited from Control)
Font (inherited from WebControl)
ForeColor (inherited from WebControl)
HasAttributes (inherited from WebControl)
Height (inherited from WebControl)
ID (inherited from Control)
NamingContainer (inherited from Control)
Page (inherited from Control)
Parent (inherited from Control)
Site (inherited from Control)
SkinID (inherited from WebControl)
Style (inherited from WebControl)
TabIndex (inherited from WebControl)
TemplateControl (inherited from Control)
TemplateSourceDirectory (inherited from Control)
ToolTip (inherited from WebControl)
UniqueID (inherited from Control)
Visible (inherited from Control)
Width (inherited from WebControl)

Public Instance Methods

ApplyStyle (inherited from WebControl)
ApplyStyleSheetSkin (inherited from Control)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
Focus (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
ResolveClientUrl (inherited from Control)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Public Instance Events

DataBinding (inherited from Control)
Disposed (inherited from Control)
Init (inherited from Control)
Load (inherited from Control)
PreRender (inherited from Control)
Unload (inherited from Control)

See Also

ExtWebControl Class | Aspose.Cells.GridWeb Namespace


ExtWebControl Constructor

Initializes a new instance of the ExtWebControl class.

public ExtWebControl();

See Also

ExtWebControl Class | Aspose.Cells.GridWeb Namespace


FilterHelper Class

For a list of all members of this type, see FilterHelper Members.

System.Object
Aspose.Cells.GridWeb.FilterHelper

public class FilterHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

FilterHelper Members | Aspose.Cells.GridWeb Namespace


FilterHelper Members

FilterHelper overview

Public Instance Constructors

FilterHelper Constructor Initializes a new instance of the FilterHelper class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

FilterHelper Class | Aspose.Cells.GridWeb Namespace


FilterHelper Constructor

Initializes a new instance of the FilterHelper class.

public FilterHelper();

See Also

FilterHelper Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle Class

Inherited from System.Web.UI.WebControls.TableItemStyle. Encapsulates the styles of a WebCell.

For a list of all members of this type, see GridTableItemStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
System.Web.UI.WebControls.TableItemStyle
Aspose.Cells.GridWeb.GridTableItemStyle
Aspose.Cells.GridWeb.TableItemStyle

public class GridTableItemStyle : TableItemStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
 ...
 using System.Web.UI.WebControls;
 ...
 ...
 WebWorksheets sheets = GridWeb1.WebWorksheets;
    sheets.Clear();
    WebWorksheet sheet = sheets[sheets.Add("demo1")];

    WebCell cell = sheet.Cells[0,0];
    cell.StringValue = "Demo Text";

 Aspose.Cells.GridWeb.TableItemStyle style = cell.GetStyle();
    style.Font.Size = new FontUnit("72pt");
    style.Wrap = false;

    style.BackColor = Color.Gray;
    style.BorderStyle = BorderStyle.Solid;
    style.BorderWidth = new Unit(1, UnitType.Pixel);
    style.BorderColor = Color.Silver;

    style.RightBorderStyle.BorderColor = Color.Black;
    style.RightBorderStyle.BorderStyle = BorderStyle.Solid;
    style.RightBorderStyle.BorderWidth = new Unit(1, UnitType.Pixel);
    style.BottomBorderStyle.BorderColor = Color.Black;
    style.BottomBorderStyle.BorderStyle = BorderStyle.Solid;
    style.BottomBorderStyle.BorderWidth = new Unit(1, UnitType.Pixel);
 cell.SetStyle(style);

    [Visual Basic]
    ...
    Imports System.Web.UI.WebControls
    ...
    ...
    Dim sheets As WebWorksheets =  GridWeb1.WebWorksheets
    sheets.Clear()
    Dim sheet As WebWorksheet =  sheets(sheets.Add(__0__))

    Dim cell As WebCell =  sheet.Cells(0,0)
    cell.StringValue = "Demo Text"

 Dim style As Aspose.Cells.GridWeb.TableItemStyle = cell.GetStyle()
    style.Font.Size = New FontUnit("72pt")
    style.Wrap = False

    style.BackColor = Color.Gray
    style.BorderStyle = BorderStyle.Solid
    style.BorderWidth = New Unit(1, UnitType.Pixel)
    style.BorderColor = Color.Silver

    style.RightBorderStyle.BorderColor = Color.Black
    style.RightBorderStyle.BorderStyle = BorderStyle.Solid
    style.RightBorderStyle.BorderWidth = New Unit(1, UnitType.Pixel)
    style.BottomBorderStyle.BorderColor = Color.Black
    style.BottomBorderStyle.BorderStyle = BorderStyle.Solid
    style.BottomBorderStyle.BorderWidth = New Unit(1, UnitType.Pixel)
 cell.SetStyle(style)

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridTableItemStyle Members | Aspose.Cells.GridWeb Namespace


GridTableItemStyle Members

GridTableItemStyle overview

Public Instance Constructors

GridTableItemStyle Constructor Default constructor.

Public Instance Properties

BackColor (inherited from Style) |
BackImageAttributes | Background image attributes.
BackImageUrl | Background image url.
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
BottomBorderStyle | Specifies the style of the cell's bottom border.
Container (inherited from Component) |
CssClass (inherited from Style) |
Custom | Gets or sets the custom format, null or empty string means no custom format.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
HorizontalAlign (inherited from TableItemStyle) |
IndentLevel | Gets or sets indent level.
IsEmpty (inherited from Style) |
IsLocked | Gets or sets a value indicating whether a cell can be modified or not when its worksheet is protected. When its worksheet is protected and IsLocked is true, the cell can not be edit. When its worksheet is protected and IsLocked is false, the cell can be edit.
LeftBorderStyle | Specifies the style of the cell's left border.
NumberType | Gets or sets the display format of numbers and dates.
RegisteredCssClass (inherited from Style) |
RightBorderStyle | Specifies the style of the cell's right border.
RotationAngle | Gets or sets Rotation attribute.
Site (inherited from Component) |
TopBorderStyle | Specifies the style of the cell's top border.
VerticalAlign (inherited from TableItemStyle) |
Width (inherited from Style) |
Wrap (inherited from TableItemStyle) |

Public Instance Methods

AddAttributesToRender | Overloaded. Internal use only. Implementation method Do not call this method directly.
AddAttributesToRender (inherited from Style) | Overloaded.
CopyFrom | Copies from another style object.
CreateObjRef (inherited from MarshalByRefObject) |
Dispose (inherited from Component) |
Equals (inherited from Object) |
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) |
GetStyleAttributes (inherited from Style) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
MergeWith | Merges with another style object.
Reset (inherited from TableItemStyle) |
SetDirty (inherited from Style) |
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component)

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle Constructor

Default constructor.

public GridTableItemStyle();

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle Properties

The properties of the GridTableItemStyle class are listed below. For a complete list of GridTableItemStyle class members, see the GridTableItemStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) |
BackImageAttributes | Background image attributes.
BackImageUrl | Background image url.
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
BottomBorderStyle | Specifies the style of the cell's bottom border.
Container (inherited from Component) |
CssClass (inherited from Style) |
Custom | Gets or sets the custom format, null or empty string means no custom format.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
HorizontalAlign (inherited from TableItemStyle) |
IndentLevel | Gets or sets indent level.
IsEmpty (inherited from Style) |
IsLocked | Gets or sets a value indicating whether a cell can be modified or not when its worksheet is protected. When its worksheet is protected and IsLocked is true, the cell can not be edit. When its worksheet is protected and IsLocked is false, the cell can be edit.
LeftBorderStyle | Specifies the style of the cell's left border.
NumberType | Gets or sets the display format of numbers and dates.
RegisteredCssClass (inherited from Style) |
RightBorderStyle | Specifies the style of the cell's right border.
RotationAngle | Gets or sets Rotation attribute.
Site (inherited from Component) |
TopBorderStyle | Specifies the style of the cell's top border.
VerticalAlign (inherited from TableItemStyle) |
Width (inherited from Style) |
Wrap (inherited from TableItemStyle) |

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


BackImageAttributes Property

Aspose.Cells for .NET

GridTableItemStyle.BackImageAttributes Property

Background image attributes.

public string BackImageAttributes {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


BackImageUrl Property

Aspose.Cells for .NET

GridTableItemStyle.BackImageUrl Property

Background image url.

public string BackImageUrl {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


BottomBorderStyle Property

Aspose.Cells for .NET

GridTableItemStyle.BottomBorderStyle Property

Specifies the style of the cell's bottom border.

public WebBorderStyle BottomBorderStyle {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


Custom Property

Aspose.Cells for .NET

GridTableItemStyle.Custom Property

Gets or sets the custom format, null or empty string means no custom format.

public string Custom {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


IndentLevel Property

Aspose.Cells for .NET

GridTableItemStyle.IndentLevel Property

Gets or sets indent level.

public int IndentLevel {get; set;}

Remarks

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


IsLocked Property

Aspose.Cells for .NET

GridTableItemStyle.IsLocked Property

Gets or sets a value indicating whether a cell can be modified or not when its worksheet is protected. When its worksheet is protected and IsLocked is true, the cell can not be edit. When its worksheet is protected and IsLocked is false, the cell can be edit.

public bool IsLocked {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


LeftBorderStyle Property

Aspose.Cells for .NET

GridTableItemStyle.LeftBorderStyle Property

Specifies the style of the cell's left border.

public WebBorderStyle LeftBorderStyle {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


NumberType Property

Aspose.Cells for .NET

GridTableItemStyle.NumberType Property

Gets or sets the display format of numbers and dates.

public int NumberType {get; set;}

Remarks

Value | Type | Format String
0 | General | General
1 | Decimal | 0
2 | Decimal | 0.00
3 | Decimal | #,##0
4 | Decimal | #,##0.00
5 | Currency | $#,##0;($#,##0)
6 | Currency | $#,##0;[Red]($#,##0)
7 | Currency | $#,##0.00;($#,##0.00)
8 | Currency | $#,##0.00;[Red]($#,##0.00)
9 | Percentage | 0%
10 | Percentage | 0.00%
11 | Scientific | 0.00E+00
12 | Fraction | # ?/?
13 | Fraction | # ??/??
14 | Date | m/d/yyyy
15 | Date | d-mmm-yy
16 | Date | d-mmm
17 | Date | mmm-yy
18 | Time | h:mm AM/PM
19 | Time | h:mm:ss AM/PM
20 | Time | h:mm
21 | Time | h:mm:ss
22 | Time | m/d/yyyy h:mm
37 | Accounting | #,##0;(#,##0)
38 | Accounting | #,##0;[Red](#,##0)
39 | Accounting | #,##0.00;(#,##0.00)
40 | Accounting | #,##0.00;[Red](#,##0.00)
41 | Accounting | _ * #,##0_ ;_ * (#,##0)_ ;_ * "-"_ ;_ @_
42 | Currency | _ $* #,##0_ ;_ $* (#,##0)_ ;_ $* "-"_ ;_ @_
43 | Accounting | _ * #,##0.00_ ;_ * (#,##0.00)_ ;_ * "-"??_ ;_ @_
44 | Currency | _ $* #,##0.00_ ;_ $* (#,##0.00)_ ;_ $* "-"??_ ;_ @_
45 | Time | mm:ss
46 | Time | [h]:mm:ss
47 | Time | mm:ss.0
48 | Scientific | ##0.0E+00
49 | Text | @

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


RightBorderStyle Property

Aspose.Cells for .NET

GridTableItemStyle.RightBorderStyle Property

Specifies the style of the cell's right border.

public WebBorderStyle RightBorderStyle {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


RotationAngle Property

Aspose.Cells for .NET

GridTableItemStyle.RotationAngle Property

Gets or sets Rotation attribute.

public short RotationAngle {get; set;}

Remarks

0: Not rotated.

255: Top to Bottom.

-90: Downward.

90: Upward.

You can set 255 or value ranged from -90 to 90.

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


TopBorderStyle Property

Aspose.Cells for .NET

GridTableItemStyle.TopBorderStyle Property

Specifies the style of the cell's top border.

public WebBorderStyle TopBorderStyle {get; set;}

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle Methods

The methods of the GridTableItemStyle class are listed below. For a complete list of GridTableItemStyle class members, see the GridTableItemStyle Members topic.

Public Instance Methods

AddAttributesToRender | Overloaded. Internal use only. Implementation method Do not call this method directly.
AddAttributesToRender (inherited from Style) | Overloaded.
CopyFrom | Copies from another style object.
CreateObjRef (inherited from MarshalByRefObject) |
Dispose (inherited from Component) |
Equals (inherited from Object) |
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) |
GetStyleAttributes (inherited from Style) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
MergeWith | Merges with another style object.
Reset (inherited from TableItemStyle) |
SetDirty (inherited from Style) |
ToString (inherited from Component) |

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


AddAttributesToRender Method

Aspose.Cells for .NET

GridTableItemStyle.AddAttributesToRender Method

Internal use only. Implementation method Do not call this method directly.

Overload List

Inherited from Style.

public void AddAttributesToRender(HtmlTextWriter);

Internal use only. Implementation method Do not call this method directly.

public override void AddAttributesToRender(HtmlTextWriter,WebControl);

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle.AddAttributesToRender Method (HtmlTextWriter, WebControl)

Internal use only. Implementation method Do not call this method directly.

public override void AddAttributesToRender(
HtmlTextWriter writer,
WebControl owner
);

Parameters

writer
owner

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace | GridTableItemStyle.AddAttributesToRender Overload List


GridTableItemStyle.CopyFrom Method

Copies from another style object.

public override void CopyFrom(
Style s
);

Parameters

s
another style object

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

Return Value

A hash code for the current Style.

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableItemStyle.MergeWith Method

Merges with another style object.

public override void MergeWith(
Style s
);

Parameters

s
another style object

See Also

GridTableItemStyle Class | Aspose.Cells.GridWeb Namespace


GridTableStyle Class

Inherited from System.Web.UI.WebControls.TableStyle. Represents the style of a web table. Please refer to .NET SDK document about System.Web.UI.WebControls.TableStyle for further information.

For a list of all members of this type, see GridTableStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
System.Web.UI.WebControls.TableStyle
Aspose.Cells.GridWeb.GridTableStyle

public class GridTableStyle : TableStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridTableStyle Members | Aspose.Cells.GridWeb Namespace


GridTableStyle Members

GridTableStyle overview

Public Instance Constructors

GridTableStyle Constructor Default constructor.

Public Instance Properties

BackColor (inherited from Style) |
BackImageUrl | Background image url.
BorderCollapse | Specifies the border collapse feature.
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
BottomBorderStyle | Specifies the style of bottom border of the table.
CellPadding | Always returns -1.
CellSpacing | Always returns -1.
Container (inherited from Component) |
CssClass (inherited from Style) |
Font (inherited from Style) |
ForeColor (inherited from Style) |
GridLines | Grid lines.
Height (inherited from Style) |
HorizontalAlign | Horizontal align.
IsEmpty (inherited from Style) |
LayoutFixed | Specifies whether the layout of the table is fixed(not extended automatically when it contain large objects).
LeftBorderStyle | Specifies the style of left border of the table.
RegisteredCssClass (inherited from Style) |
RightBorderStyle | Specifies the style of right border of the table.
Site (inherited from Component) |
TopBorderStyle | Specifies the style of top border of the table.
Width (inherited from Style) |

Public Instance Methods

AddAttributesToRender | Overloaded. Internal use only. Do not call this method directly.
AddAttributesToRender (inherited from Style) | Overloaded.
CopyFrom | Copies from another style object.
CreateObjRef (inherited from MarshalByRefObject) |
Dispose (inherited from Component) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetStyleAttributes (inherited from Style) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
MergeWith | Merges with another style object.
Reset (inherited from TableStyle) |
SetDirty (inherited from Style) |
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component)

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridTableStyle Constructor

Default constructor.

public GridTableStyle();

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridTableStyle Properties

The properties of the GridTableStyle class are listed below. For a complete list of GridTableStyle class members, see the GridTableStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) |
BackImageUrl | Background image url.
BorderCollapse | Specifies the border collapse feature.
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
BottomBorderStyle | Specifies the style of bottom border of the table.
CellPadding | Always returns -1.
CellSpacing | Always returns -1.
Container (inherited from Component) |
CssClass (inherited from Style) |
Font (inherited from Style) |
ForeColor (inherited from Style) |
GridLines | Grid lines.
Height (inherited from Style) |
HorizontalAlign | Horizontal align.
IsEmpty (inherited from Style) |
LayoutFixed | Specifies whether the layout of the table is fixed(not extended automatically when it contain large objects).
LeftBorderStyle | Specifies the style of left border of the table.
RegisteredCssClass (inherited from Style) |
RightBorderStyle | Specifies the style of right border of the table.
Site (inherited from Component) |
TopBorderStyle | Specifies the style of top border of the table.
Width (inherited from Style) |

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


BackImageUrl Property

Aspose.Cells for .NET

GridTableStyle.BackImageUrl Property

Background image url.

public override string BackImageUrl {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


BorderCollapse Property

Aspose.Cells for .NET

GridTableStyle.BorderCollapse Property

Specifies the border collapse feature.

public BorderCollapseType BorderCollapse {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


BottomBorderStyle Property

Aspose.Cells for .NET

GridTableStyle.BottomBorderStyle Property

Specifies the style of bottom border of the table.

public WebBorderStyle BottomBorderStyle {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


CellPadding Property

Aspose.Cells for .NET

GridTableStyle.CellPadding Property

Always returns -1.

public override int CellPadding {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


CellSpacing Property

Aspose.Cells for .NET

GridTableStyle.CellSpacing Property

Always returns -1.

public override int CellSpacing {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridLines Property

Aspose.Cells for .NET

GridTableStyle.GridLines Property

Grid lines.

public override GridLines GridLines {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


HorizontalAlign Property

Aspose.Cells for .NET

GridTableStyle.HorizontalAlign Property

Horizontal align.

public override HorizontalAlign HorizontalAlign {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


LayoutFixed Property

Aspose.Cells for .NET

GridTableStyle.LayoutFixed Property

Specifies whether the layout of the table is fixed(not extended automatically when it contain large objects).

public LayoutFixedType LayoutFixed {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


LeftBorderStyle Property

Aspose.Cells for .NET

GridTableStyle.LeftBorderStyle Property

Specifies the style of left border of the table.

public WebBorderStyle LeftBorderStyle {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


RightBorderStyle Property

Aspose.Cells for .NET

GridTableStyle.RightBorderStyle Property

Specifies the style of right border of the table.

public WebBorderStyle RightBorderStyle {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


TopBorderStyle Property

Aspose.Cells for .NET

GridTableStyle.TopBorderStyle Property

Specifies the style of top border of the table.

public WebBorderStyle TopBorderStyle {get; set;}

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridTableStyle Methods

The methods of the GridTableStyle class are listed below. For a complete list of GridTableStyle class members, see the GridTableStyle Members topic.

Public Instance Methods

AddAttributesToRender | Overloaded. Internal use only. Do not call this method directly.
AddAttributesToRender (inherited from Style) | Overloaded.
CopyFrom | Copies from another style object.
CreateObjRef (inherited from MarshalByRefObject) |
Dispose (inherited from Component) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetStyleAttributes (inherited from Style) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
MergeWith | Merges with another style object.
Reset (inherited from TableStyle) |
SetDirty (inherited from Style) |
ToString (inherited from Component) |

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


AddAttributesToRender Method

Aspose.Cells for .NET

GridTableStyle.AddAttributesToRender Method

Internal use only. Do not call this method directly.

Overload List

Inherited from Style.

public void AddAttributesToRender(HtmlTextWriter);

Internal use only. Do not call this method directly.

public override void AddAttributesToRender(HtmlTextWriter,WebControl);

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridTableStyle.AddAttributesToRender Method (HtmlTextWriter, WebControl)

Internal use only. Do not call this method directly.

public override void AddAttributesToRender(
HtmlTextWriter writer,
WebControl owner
);

Parameters

writer
owner

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace | GridTableStyle.AddAttributesToRender Overload List


GridTableStyle.CopyFrom Method

Copies from another style object.

public override void CopyFrom(
Style s
);

Parameters

s
another style object.

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridTableStyle.MergeWith Method

Merges with another style object.

public override void MergeWith(
Style s
);

Parameters

s
another style object

See Also

GridTableStyle Class | Aspose.Cells.GridWeb Namespace


GridWeb Class

For a list of all members of this type, see GridWeb Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Aspose.Cells.GridWeb.ExtWebControl
Aspose.Cells.GridWeb.MainWeb
Aspose.Cells.GridWeb.GridWeb

public class GridWeb : MainWeb

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWeb Members | Aspose.Cells.GridWeb Namespace


GridWeb Members

GridWeb overview

Public Static Methods

GetVersion | Get the release version.
SetFontFolder | Sets the fonts folder
SetFontFolders | Sets the fonts folders

Public Instance Constructors

GridWeb Constructor Initializes a new instance of the GridWeb class.

Public Instance Properties

AccessKey (inherited from WebControl)
ActiveCell (inherited from MainWeb) | Gets or sets the active cell of the current sheet. Changed to be writable since version 1.9.0.1.
ActiveCellBgColor (inherited from MainWeb) | Specifies the background color of the active cell.
ActiveCellColor (inherited from MainWeb) | Specifies the color of the active cell.
ActiveHeaderBgColor (inherited from MainWeb) | Specifies the background color of the active row/column header.
ActiveHeaderColor (inherited from MainWeb) | Specifies the color of the active row/column header.
ActiveSheet (inherited from MainWeb) | Gets the active sheet
ActiveSheetIndex (inherited from MainWeb) | Gets or sets the active sheet index. Equal to the WebWorksheets.ActiveSheetIndex.
ActiveTabStyle (inherited from MainWeb) | Specifies the style of the active tab.
ACWClientPath (inherited from MainWeb) Gets or sets the web path of the script/image files of the control. For example: "http://localhost/acw_client". You may also set this value in the web.config file. Add this section to the <configuration> section:

ACWLanguageFileUrl (inherited from MainWeb) Gets or sets the web url of the language file of the control. For example: "/acw_client/lang_en.js".
AppRelativeTemplateSourceDirectory (inherited from Control)
Attributes (inherited from WebControl)
AutoRefreshChart (inherited from MainWeb) | Gets or sets whether the Chart image is updated while updating the cell value.the default is true
BackColor (inherited from WebControl)
BindingContainer (inherited from Control)
BorderColor (inherited from WebControl)
BorderStyle (inherited from WebControl)
BorderWidth (inherited from WebControl)
BottomTableStyle (inherited from MainWeb) | Gets or sets the style of the bottom bar of the control.
ClientID (inherited from Control)
Controls (inherited from Control)
ControlStyle (inherited from WebControl)
ControlStyleCreated (inherited from WebControl)
CssClass (inherited from WebControl)
CurrentPageIndex (inherited from MainWeb)
CustomCalculationEngine (inherited from MainWeb) | Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.
CustomCommandButtons (inherited from MainWeb)
CustomStyleFileName (inherited from MainWeb) | Gets or sets the custom style file name.
DefaultFontName (inherited from MainWeb) | Gets or sets the control's default font name.
DefaultFontSize (inherited from MainWeb) | Gets or sets the control's default font size.
DefaultGridLineColor (inherited from MainWeb) | Gets or sets the default grid line's color.
DisplayCellTip (inherited from MainWeb)
EditMode (inherited from MainWeb) | Gets or sets the control's edit mode.
EnableAJAX (inherited from MainWeb)
EnableAsync (inherited from MainWeb) | Gets or sets whether load cells data in asynchronous way,suggest to apply for one sheet with more than 10000 cells.
EnableClientColumnOperations (inherited from MainWeb) | Gets or sets whether to enable the client side column operations.
EnableClientFreeze (inherited from MainWeb) | Gets or sets whether to enable the client side freezing operations.
EnableClientMergeOperations (inherited from MainWeb) | Gets or sets whether to enable the client side merge operations.
EnableClientResizeColumnRow (inherited from MainWeb) | Gets or sets whether to enable the client side resize column and row.
EnableClientRowOperations (inherited from MainWeb) | Gets or sets whether to enable the client side row operations.
Enabled (inherited from WebControl)
EnableDoubleClickEvent (inherited from MainWeb) | Gets or sets whether to enable customer side double-click event.
EnableMetalLightEffect (inherited from MainWeb) | Gets or sets whether to apply metal light effect.
EnablePaging (inherited from MainWeb) | Gets or sets whether to enable the control's paging mode.
EnableStyleDialogbox (inherited from MainWeb) | Gets or sets whether to enable the client side style dialogbox.
EnableTheming (inherited from WebControl)
EnableViewState (inherited from Control)
FilteredPaging (inherited from MainWeb) | Gets or sets whether to enable the paging after data filtered,will take affect when EnablePaging is true.
Font (inherited from WebControl)
ForceValidation (inherited from MainWeb) | Gets or sets whether to force customer side validation.
ForeColor (inherited from WebControl)
FrameTableStyle (inherited from MainWeb) | Gets or sets the frame style of the control.
GoonDefaultSaveOperation (inherited from MainWeb) | Gets or sets whether GridWeb will do the default save operation ,the default value is true.
HasAttributes (inherited from WebControl)
HeaderBarHeight (inherited from MainWeb) | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the top header bar of the control.
HeaderBarStyle (inherited from MainWeb) | Gets or sets the header bar's style.
HeaderBarTableStyle (inherited from MainWeb) | Gets or sets the header bar style of the control.
HeaderBarWidth (inherited from MainWeb) | Gets or sets the width( System.Web.UI.WebControl.Unit ) or the left header bar of the control.
Height (inherited from MainWeb) | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the control.
ID (inherited from Control)
IsPostBack (inherited from MainWeb) | Gets a value indicating whether gridweb is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.
LinksTable (inherited from MainWeb)
MaxColumn (inherited from MainWeb) | Gets or sets the maximum display column index(zero based) of the web sheet. The control uses the greater value of MaxColumn and sheet data's max column.
MaxRow (inherited from MainWeb) | Gets or sets the maximum display row index(zero based) of the web sheet. The control uses the greater value of MaxRow and sheet data's max row.
Message (inherited from MainWeb)
MinColumn (inherited from MainWeb)
MinRow (inherited from MainWeb) | Gets or sets the minimum display row index(zero based) of the web sheet. The control uses the smaller value of MinRow and sheet data's min row.
ModifiedCells (inherited from MainWeb) | Gets the collection of the cells that modified by the client.
NamingContainer (inherited from Control)
NeedRenderGroupRows (inherited from MainWeb) | Gets or sets whether to show grouprows .
NoHScroll (inherited from MainWeb) | Gets or sets a value indicating whether the horizontal scroll bar is hidden.
NoScroll (inherited from MainWeb)
NoVScroll (inherited from MainWeb) | Gets or sets a value indicating whether the vertical scroll bar is hidden.
OnAjaxCallFinishedClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when ajaxcall finished. The client function should be declared like this:
function GridAjaxcallFinished()
{
alert(this.id+" ajaxcall finished ");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellErrorClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when a cell's validation is failed. The client function should be declared like this:
function MyOnCellError(cell)
{
alert(GridWeb1.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedAjaxCallBackClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCellAjaxCallBack(cell,customerdata)
{

}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUnselectedClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is unselected. The client function should be declared like this:
function MyOnUnselectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUpdatedClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when a cell's value is updated. The client function should be declared like this:
function MyOnCellUpdated(cell)
{
alert(this.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnContextMenuShowClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when the context menu will be shown. The client function should be declared like this:
function onContextMenuShow()
{
var menu = event.srcElement;
menu.setItemVisibility("Delete", "block");
menu.setItemVisibility("Update", "none");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickCellClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is double clicked. The client function should be declared like this:
function MyOnDoubleClickCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickRowClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a row is double clicked. The client function should be declared like this:
function MyOnRowDoubleClick(row)
{
alert(row);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnGridInitClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when the grid is initialized. The client function should be declared like this:
function MyOnGridInit(grid)
{
alert("The grid is initialized: " + grid.id);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageChangeClientFunction (inherited from MainWeb) Gets or sets the client side function to be called after page index changing.only take effect when EnablePaging is true. The client function should be declared like this:
function MyOnPageChange(index)
{
console.log("current page is:"+index);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageSubmitClientFunction (inherited from MainWeb) | Gets or sets the client function to be called before the page is submitted at client side.
OnShapeSelectedClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a shape is selected. The client function should be declared like this:
function MyOnSelectShape(shape)
{
var name=shape.getAttribute("namevalue")
var text=shape.getAttribute("textvalue")
var value=shape.getAttribute("controlvalue")
var type=shape.getAttribute("msotype")
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnSubmitClientFunction (inherited from MainWeb) Gets or sets the client function to be called before the control is submitted at client side. The client function should be declared like this:
function MyOnSubmit(arg, cancelEdit)
{
return true;
}
The arg is the submit argument, contains the command to be post to the server. The cancelEdit is boolean value indicates whether the control has discarded the user input before submit. The control will continue submitting if the function returns true.
Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
Page (inherited from Control)
PageSize (inherited from MainWeb) | Gets or sets the page size in paging mode.
Parent (inherited from Control)
PictureCachePath (inherited from MainWeb) | Gets or sets the image storage path for the workbook,all the shapes,images will be stored in this directory, the default path is acwcache under current application Base Directory users need to implement a schedule service to clean the files those are out of session time.
PicturesTable (inherited from MainWeb)
PresetStyle (inherited from MainWeb) | Gets or sets the preset style.
RenderHiddenRow (inherited from MainWeb) | Gets or sets whether the hidden row is rendered in GridControl,the default value is false. if you need to unhide the hidden row latter ,you shall set it as true
ScrollBarArrowColor (inherited from MainWeb) | Specifies the color of the scrollbar's arrow button.
ScrollBarBaseColor (inherited from MainWeb) | Specifies the color of the scroll bar of the control.
SelectCellBgColor (inherited from MainWeb) | Specifies the background color of the selected cells in multi-select range.
SelectCellColor (inherited from MainWeb) | Specifies the color of the selected cells in multi-select range.
SelectCells | Gets the select cells collection.
SessionLoaded (inherited from MainWeb)
SessionMode (inherited from MainWeb) Gets or sets the session mode of the grid. There are 3 type of session mode:
1. Session(default): Use system session to store sheet data.
Generally the asp.net uses InProc session state. The grid also supports "StateServer" out process session state and SQLServer session state.
2. ViewState: Use page's viewstate to store sheet data.
3. Custom: Use LoadCustomData and SheetDataUpdated events to store/recover sheet data.
SessionSaved (inherited from MainWeb)
SessionStorePath (inherited from MainWeb) | Gets or sets the session store path when session mode is File, etc: gridweb.SessionStorePath="c:/mytempdir/session"; then it will store session data in c:/mytempdir/session
ShapesTable (inherited from MainWeb)
ShowAddButton (inherited from MainWeb) | Gets or sets whether to show the add worksheet button.
ShowBottomBar (inherited from MainWeb)
ShowCellEditBox (inherited from MainWeb) | whether Gridweb shows edit box toolbar as in MS-EXCEL.if enable ,a edit box for current cell will display in Gridweb. if we enable this feature, we need to import jquery js library in your aspx files to support this new feature. all the latest jquery version is ok. etc.
ShowCommandBarAtTop (inherited from MainWeb) | Specifies whether to show the command bar(includes command bar and tab bar) at the top of the control.
ShowContextMenu (inherited from MainWeb)
ShowDefaultGridLine (inherited from MainWeb) | Gets or sets whether to show the default grid lines of the cells.
ShowHeaderBar (inherited from MainWeb)
ShowLoading (inherited from MainWeb) | Specifies whether to show a loading dialogbox while postbacking to server.
ShowLoadingPosition (inherited from MainWeb) | Specifies the left,top postion(in px) to show the loading dialogbox while postbacking to server ,etc. 100,200 means the loading dialogbox's left,top postion is at 100px,200px .
ShowSaveButton (inherited from MainWeb) | Gets or sets whether to show the save button.
ShowSubmitButton (inherited from MainWeb) | Gets or sets whether to show the submit button.
ShowTabBar (inherited from MainWeb)
ShowTabNavigation (inherited from MainWeb) | Gets or sets whether the tab navigation button is show,the default value is true.
ShowUndoButton (inherited from MainWeb) | Gets or sets whether to show the undo button.
Site (inherited from Control)
SkinID (inherited from WebControl)
SpanWrap (inherited from MainWeb) | Specifies whether to wrap content in the cell span.
Style (inherited from WebControl)
TabIndex (inherited from WebControl)
TabStyle (inherited from MainWeb) | Gets or sets the style of the tab bar.
TemplateControl (inherited from Control)
TemplateSourceDirectory (inherited from Control)
ToolTip (inherited from WebControl)
UniqueID (inherited from Control)
UseClientPageHeight (inherited from MainWeb) | Gets or sets whether gridweb use client page height as control height ,suitable for when set Height="100%",default value is false
ValidationsTable (inherited from MainWeb)
ViewPanelScrollLeft (inherited from MainWeb) | Gets or sets the position of the scroll bar of the grid's view panel.
ViewPanelScrollTop (inherited from MainWeb) | Gets or sets the position of the scroll bar of the grid's view panel.
ViewTableStyle (inherited from MainWeb) | Gets or sets the data view panel's style.
Visible (inherited from Control)
WebWorksheets (inherited from MainWeb)
Width (inherited from MainWeb) | Gets or sets the width( System.Web.UI.WebControl.Unit ) of the control.
WorkSheets (inherited from MainWeb)
XhtmlMode (inherited from MainWeb)

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ApplyStyleSheetSkin (inherited from Control) |
CalculateFormula (inherited from MainWeb) | Calculates the result of formulas.
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from MainWeb) | Bind the control and all its child contorls to the its datasource.
Dispose (inherited from MainWeb) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
ImportExcelFile (inherited from MainWeb) | Overloaded. Imports from an excel file.
LoadCSVFile (inherited from MainWeb) | Overloaded. Loads data from a CSV file.
LoadHTMLFile (inherited from MainWeb) | Overloaded. Loads data from a HTML file.
LoadSpreadSheetMLFile (inherited from MainWeb) | Overloaded. Loads data from a SpreadSheetML file.
MergeStyle (inherited from WebControl) |
RefreshChartShape (inherited from MainWeb) | refresh all the chart image for the active worksheet .
RenderBeginTag (inherited from MainWeb) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SaveCSVFile (inherited from MainWeb) | Overloaded. Saves data to a CSV file.
SaveCustomStyleFile | Saves current style data of the control to an xml file. Can be used to create your customized style file.
SaveHTMLFile (inherited from MainWeb) | Overloaded. Saves data to a HTML file.
SaveSpreadSheetMLFile (inherited from MainWeb) | Overloaded. Saves data to a SpreadSheetML file.
SaveToExcelFile (inherited from MainWeb) | Overloaded. Saves the worksheets to an excel file with Excel 2003 format.
SetCustomStyle (inherited from MainWeb) | sets the custom style file from stream including disk file stream or memory stream.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Public Instance Events

AfterColumnFilter (inherited from MainWeb) | Occurs after the column filtered.
AjaxCallFinished (inherited from MainWeb) | Fires when the ajax update of the control finished.(the EnableAJAX shall be set to true)
BeforeColumnFilter (inherited from MainWeb) | Occurs before the column to be filtered.
CellClickOnAjax (inherited from MainWeb) | Occurs when the cell is clicked,and need to do ajaxcallback for this event.
CellClientUpdate (inherited from MainWeb) | Occurs when a client cell update happen . When this event is fired, its parameter e.Argument contains the command's name.
CellCommand (inherited from MainWeb) | Occurs when a cell's command hyperlink is clicked. When this event is fired, its parameter e.Argument contains the command's name.
CellDoubleClick (inherited from MainWeb) | Occurs when the cell is double-clicked.
CellError (inherited from MainWeb) | Occurs when a cell's input value error.
CellModifiedOnAjax (inherited from MainWeb) | Occurs when the cell is modified in ajaxcall.
ColumnDeleted (inherited from MainWeb) | Occurs when user delete a column from client-side menu.
ColumnDeleting (inherited from MainWeb) | Occurs when user is trying to delete a column from the client-side menu. You may handle this event and set the cancel parameter to True to cancel a deleting operation.
ColumnDoubleClick (inherited from MainWeb) | Occurs when the column header is double-clicked.
ColumnInserted (inherited from MainWeb) | Occurs when user insert a column from client-side menu.
CustomCommand (inherited from MainWeb) | Occurs when user clicks a custom command button.
DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
LoadCustomData (inherited from MainWeb) | Fires when the control's SessionMode is set to Custom and needs to load sheet data. You may handle this event in Custom Session mode to load sheet data from file or database.
PageIndexChanged (inherited from MainWeb) | Occurs when the control's sheet page index changed.
PreRender (inherited from Control) |
RowDeleted (inherited from MainWeb) | Occurs when user has deleted a row from client-side menu.
RowDeleting (inherited from MainWeb) | Occurs when user is trying to delete a row from the client-side menu. You may handle this event and throw a RejectDeleteException exception to cancel a deleting operation.
RowDoubleClick (inherited from MainWeb) | Occurs when the row header is double-clicked.
RowInserted (inherited from MainWeb) | Occurs when user insert a row from client-side menu.
SaveCommand (inherited from MainWeb) | Occurs when the "save" button is clicked.
SheetAdded (inherited from MainWeb) | Occurs when user add a worksheet from toolbar menu.
SheetDataUpdated (inherited from MainWeb) | Occurs when the control has loaded the posted data and updated the sheet data.
SheetTabClick (inherited from MainWeb) | Occurs when the sheet tab is clicked.
SubmitCommand (inherited from MainWeb) | Occurs when the "submit" button is clicked.
UndoCommand (inherited from MainWeb) | Occurs when the "undo" button is clicked.
Unload (inherited from Control) |

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb Constructor

Initializes a new instance of the GridWeb class.

public GridWeb();

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb Properties

The properties of the GridWeb class are listed below. For a complete list of GridWeb class members, see the GridWeb Members topic.

Public Instance Properties

AccessKey (inherited from WebControl)
ActiveCell (inherited from MainWeb) | Gets or sets the active cell of the current sheet. Changed to be writable since version 1.9.0.1.
ActiveCellBgColor (inherited from MainWeb) | Specifies the background color of the active cell.
ActiveCellColor (inherited from MainWeb) | Specifies the color of the active cell.
ActiveHeaderBgColor (inherited from MainWeb) | Specifies the background color of the active row/column header.
ActiveHeaderColor (inherited from MainWeb) | Specifies the color of the active row/column header.
ActiveSheet (inherited from MainWeb) | Gets the active sheet
ActiveSheetIndex (inherited from MainWeb) | Gets or sets the active sheet index. Equal to the WebWorksheets.ActiveSheetIndex.
ActiveTabStyle (inherited from MainWeb) | Specifies the style of the active tab.
ACWClientPath (inherited from MainWeb) Gets or sets the web path of the script/image files of the control. For example: "http://localhost/acw_client". You may also set this value in the web.config file. Add this section to the <configuration> section:

ACWLanguageFileUrl (inherited from MainWeb) Gets or sets the web url of the language file of the control. For example: "/acw_client/lang_en.js".
AppRelativeTemplateSourceDirectory (inherited from Control)
Attributes (inherited from WebControl)
AutoRefreshChart (inherited from MainWeb) | Gets or sets whether the Chart image is updated while updating the cell value.the default is true
BackColor (inherited from WebControl)
BindingContainer (inherited from Control)
BorderColor (inherited from WebControl)
BorderStyle (inherited from WebControl)
BorderWidth (inherited from WebControl)
BottomTableStyle (inherited from MainWeb) | Gets or sets the style of the bottom bar of the control.
ClientID (inherited from Control)
Controls (inherited from Control)
ControlStyle (inherited from WebControl)
ControlStyleCreated (inherited from WebControl)
CssClass (inherited from WebControl)
CurrentPageIndex (inherited from MainWeb)
CustomCalculationEngine (inherited from MainWeb) | Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.
CustomCommandButtons (inherited from MainWeb)
CustomStyleFileName (inherited from MainWeb) | Gets or sets the custom style file name.
DefaultFontName (inherited from MainWeb) | Gets or sets the control's default font name.
DefaultFontSize (inherited from MainWeb) | Gets or sets the control's default font size.
DefaultGridLineColor (inherited from MainWeb) | Gets or sets the default grid line's color.
DisplayCellTip (inherited from MainWeb)
EditMode (inherited from MainWeb) | Gets or sets the control's edit mode.
EnableAJAX (inherited from MainWeb)
EnableAsync (inherited from MainWeb) | Gets or sets whether load cells data in asynchronous way,suggest to apply for one sheet with more than 10000 cells.
EnableClientColumnOperations (inherited from MainWeb) | Gets or sets whether to enable the client side column operations.
EnableClientFreeze (inherited from MainWeb) | Gets or sets whether to enable the client side freezing operations.
EnableClientMergeOperations (inherited from MainWeb) | Gets or sets whether to enable the client side merge operations.
EnableClientResizeColumnRow (inherited from MainWeb) | Gets or sets whether to enable the client side resize column and row.
EnableClientRowOperations (inherited from MainWeb) | Gets or sets whether to enable the client side row operations.
Enabled (inherited from WebControl)
EnableDoubleClickEvent (inherited from MainWeb) | Gets or sets whether to enable customer side double-click event.
EnableMetalLightEffect (inherited from MainWeb) | Gets or sets whether to apply metal light effect.
EnablePaging (inherited from MainWeb) | Gets or sets whether to enable the control's paging mode.
EnableStyleDialogbox (inherited from MainWeb) | Gets or sets whether to enable the client side style dialogbox.
EnableTheming (inherited from WebControl)
EnableViewState (inherited from Control)
FilteredPaging (inherited from MainWeb) | Gets or sets whether to enable the paging after data filtered,will take affect when EnablePaging is true.
Font (inherited from WebControl)
ForceValidation (inherited from MainWeb) | Gets or sets whether to force customer side validation.
ForeColor (inherited from WebControl)
FrameTableStyle (inherited from MainWeb) | Gets or sets the frame style of the control.
GoonDefaultSaveOperation (inherited from MainWeb) | Gets or sets whether GridWeb will do the default save operation ,the default value is true.
HasAttributes (inherited from WebControl)
HeaderBarHeight (inherited from MainWeb) | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the top header bar of the control.
HeaderBarStyle (inherited from MainWeb) | Gets or sets the header bar's style.
HeaderBarTableStyle (inherited from MainWeb) | Gets or sets the header bar style of the control.
HeaderBarWidth (inherited from MainWeb) | Gets or sets the width( System.Web.UI.WebControl.Unit ) or the left header bar of the control.
Height (inherited from MainWeb) | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the control.
ID (inherited from Control)
IsPostBack (inherited from MainWeb) | Gets a value indicating whether gridweb is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.
LinksTable (inherited from MainWeb)
MaxColumn (inherited from MainWeb) | Gets or sets the maximum display column index(zero based) of the web sheet. The control uses the greater value of MaxColumn and sheet data's max column.
MaxRow (inherited from MainWeb) | Gets or sets the maximum display row index(zero based) of the web sheet. The control uses the greater value of MaxRow and sheet data's max row.
Message (inherited from MainWeb)
MinColumn (inherited from MainWeb)
MinRow (inherited from MainWeb) | Gets or sets the minimum display row index(zero based) of the web sheet. The control uses the smaller value of MinRow and sheet data's min row.
ModifiedCells (inherited from MainWeb) | Gets the collection of the cells that modified by the client.
NamingContainer (inherited from Control)
NeedRenderGroupRows (inherited from MainWeb) | Gets or sets whether to show grouprows .
NoHScroll (inherited from MainWeb) | Gets or sets a value indicating whether the horizontal scroll bar is hidden.
NoScroll (inherited from MainWeb)
NoVScroll (inherited from MainWeb) | Gets or sets a value indicating whether the vertical scroll bar is hidden.
OnAjaxCallFinishedClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when ajaxcall finished. The client function should be declared like this:
function GridAjaxcallFinished()
{
alert(this.id+" ajaxcall finished ");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellErrorClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when a cell's validation is failed. The client function should be declared like this:
function MyOnCellError(cell)
{
alert(GridWeb1.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedAjaxCallBackClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCellAjaxCallBack(cell,customerdata)
{

}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUnselectedClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is unselected. The client function should be declared like this:
function MyOnUnselectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUpdatedClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when a cell's value is updated. The client function should be declared like this:
function MyOnCellUpdated(cell)
{
alert(this.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnContextMenuShowClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when the context menu will be shown. The client function should be declared like this:
function onContextMenuShow()
{
var menu = event.srcElement;
menu.setItemVisibility("Delete", "block");
menu.setItemVisibility("Update", "none");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickCellClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a cell is double clicked. The client function should be declared like this:
function MyOnDoubleClickCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickRowClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a row is double clicked. The client function should be declared like this:
function MyOnRowDoubleClick(row)
{
alert(row);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnGridInitClientFunction (inherited from MainWeb) Gets or sets the client side function name to be called when the grid is initialized. The client function should be declared like this:
function MyOnGridInit(grid)
{
alert("The grid is initialized: " + grid.id);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageChangeClientFunction (inherited from MainWeb) Gets or sets the client side function to be called after page index changing.only take effect when EnablePaging is true. The client function should be declared like this:
function MyOnPageChange(index)
{
console.log("current page is:"+index);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageSubmitClientFunction (inherited from MainWeb) | Gets or sets the client function to be called before the page is submitted at client side.
OnShapeSelectedClientFunction (inherited from MainWeb) Gets or sets the client side function to be called when a shape is selected. The client function should be declared like this:
function MyOnSelectShape(shape)
{
var name=shape.getAttribute("namevalue")
var text=shape.getAttribute("textvalue")
var value=shape.getAttribute("controlvalue")
var type=shape.getAttribute("msotype")
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnSubmitClientFunction (inherited from MainWeb) Gets or sets the client function to be called before the control is submitted at client side. The client function should be declared like this:
function MyOnSubmit(arg, cancelEdit)
{
return true;
}
The arg is the submit argument, contains the command to be post to the server. The cancelEdit is boolean value indicates whether the control has discarded the user input before submit. The control will continue submitting if the function returns true.
Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
Page (inherited from Control)
PageSize (inherited from MainWeb) | Gets or sets the page size in paging mode.
Parent (inherited from Control)
PictureCachePath (inherited from MainWeb) | Gets or sets the image storage path for the workbook,all the shapes,images will be stored in this directory, the default path is acwcache under current application Base Directory users need to implement a schedule service to clean the files those are out of session time.
PicturesTable (inherited from MainWeb)
PresetStyle (inherited from MainWeb) | Gets or sets the preset style.
RenderHiddenRow (inherited from MainWeb) | Gets or sets whether the hidden row is rendered in GridControl,the default value is false. if you need to unhide the hidden row latter ,you shall set it as true
ScrollBarArrowColor (inherited from MainWeb) | Specifies the color of the scrollbar's arrow button.
ScrollBarBaseColor (inherited from MainWeb) | Specifies the color of the scroll bar of the control.
SelectCellBgColor (inherited from MainWeb) | Specifies the background color of the selected cells in multi-select range.
SelectCellColor (inherited from MainWeb) | Specifies the color of the selected cells in multi-select range.
SelectCells | Gets the select cells collection.
SessionLoaded (inherited from MainWeb)
SessionMode (inherited from MainWeb) Gets or sets the session mode of the grid. There are 3 type of session mode:
1. Session(default): Use system session to store sheet data.
Generally the asp.net uses InProc session state. The grid also supports "StateServer" out process session state and SQLServer session state.
2. ViewState: Use page's viewstate to store sheet data.
3. Custom: Use LoadCustomData and SheetDataUpdated events to store/recover sheet data.
SessionSaved (inherited from MainWeb)
SessionStorePath (inherited from MainWeb) | Gets or sets the session store path when session mode is File, etc: gridweb.SessionStorePath="c:/mytempdir/session"; then it will store session data in c:/mytempdir/session
ShapesTable (inherited from MainWeb)
ShowAddButton (inherited from MainWeb) | Gets or sets whether to show the add worksheet button.
ShowBottomBar (inherited from MainWeb)
ShowCellEditBox (inherited from MainWeb) | whether Gridweb shows edit box toolbar as in MS-EXCEL.if enable ,a edit box for current cell will display in Gridweb. if we enable this feature, we need to import jquery js library in your aspx files to support this new feature. all the latest jquery version is ok. etc.
ShowCommandBarAtTop (inherited from MainWeb) | Specifies whether to show the command bar(includes command bar and tab bar) at the top of the control.
ShowContextMenu (inherited from MainWeb)
ShowDefaultGridLine (inherited from MainWeb) | Gets or sets whether to show the default grid lines of the cells.
ShowHeaderBar (inherited from MainWeb)
ShowLoading (inherited from MainWeb) | Specifies whether to show a loading dialogbox while postbacking to server.
ShowLoadingPosition (inherited from MainWeb) | Specifies the left,top postion(in px) to show the loading dialogbox while postbacking to server ,etc. 100,200 means the loading dialogbox's left,top postion is at 100px,200px .
ShowSaveButton (inherited from MainWeb) | Gets or sets whether to show the save button.
ShowSubmitButton (inherited from MainWeb) | Gets or sets whether to show the submit button.
ShowTabBar (inherited from MainWeb)
ShowTabNavigation (inherited from MainWeb) | Gets or sets whether the tab navigation button is show,the default value is true.
ShowUndoButton (inherited from MainWeb) | Gets or sets whether to show the undo button.
Site (inherited from Control)
SkinID (inherited from WebControl)
SpanWrap (inherited from MainWeb) | Specifies whether to wrap content in the cell span.
Style (inherited from WebControl)
TabIndex (inherited from WebControl)
TabStyle (inherited from MainWeb) | Gets or sets the style of the tab bar.
TemplateControl (inherited from Control)
TemplateSourceDirectory (inherited from Control)
ToolTip (inherited from WebControl)
UniqueID (inherited from Control)
UseClientPageHeight (inherited from MainWeb) | Gets or sets whether gridweb use client page height as control height ,suitable for when set Height="100%",default value is false
ValidationsTable (inherited from MainWeb)
ViewPanelScrollLeft (inherited from MainWeb) | Gets or sets the position of the scroll bar of the grid's view panel.
ViewPanelScrollTop (inherited from MainWeb) | Gets or sets the position of the scroll bar of the grid's view panel.
ViewTableStyle (inherited from MainWeb) | Gets or sets the data view panel's style.
Visible (inherited from Control)
WebWorksheets (inherited from MainWeb)
Width (inherited from MainWeb) | Gets or sets the width( System.Web.UI.WebControl.Unit ) of the control.
WorkSheets (inherited from MainWeb)
XhtmlMode (inherited from MainWeb)

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


SelectCells Property

Aspose.Cells for .NET

GridWeb.SelectCells Property

Gets the select cells collection.

public ArrayList SelectCells {get;}

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb Methods

The methods of the GridWeb class are listed below. For a complete list of GridWeb class members, see the GridWeb Members topic.

Public Static Methods

GetVersion | Get the release version.
SetFontFolder | Sets the fonts folder
SetFontFolders | Sets the fonts folders

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ApplyStyleSheetSkin (inherited from Control) |
CalculateFormula (inherited from MainWeb) | Calculates the result of formulas.
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from MainWeb) | Bind the control and all its child contorls to the its datasource.
Dispose (inherited from MainWeb) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
ImportExcelFile (inherited from MainWeb) | Overloaded. Imports from an excel file.
LoadCSVFile (inherited from MainWeb) | Overloaded. Loads data from a CSV file.
LoadHTMLFile (inherited from MainWeb) | Overloaded. Loads data from a HTML file.
LoadSpreadSheetMLFile (inherited from MainWeb) | Overloaded. Loads data from a SpreadSheetML file.
MergeStyle (inherited from WebControl) |
RefreshChartShape (inherited from MainWeb) | refresh all the chart image for the active worksheet .
RenderBeginTag (inherited from MainWeb) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SaveCSVFile (inherited from MainWeb) | Overloaded. Saves data to a CSV file.
SaveCustomStyleFile | Saves current style data of the control to an xml file. Can be used to create your customized style file.
SaveHTMLFile (inherited from MainWeb) | Overloaded. Saves data to a HTML file.
SaveSpreadSheetMLFile (inherited from MainWeb) | Overloaded. Saves data to a SpreadSheetML file.
SaveToExcelFile (inherited from MainWeb) | Overloaded. Saves the worksheets to an excel file with Excel 2003 format.
SetCustomStyle (inherited from MainWeb) | sets the custom style file from stream including disk file stream or memory stream.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb.GetVersion Method

Get the release version.

public static string GetVersion();

Return Value

The release version.

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb.SaveCustomStyleFile Method

Saves current style data of the control to an xml file. Can be used to create your customized style file.

new public void SaveCustomStyleFile(
string fileName
);

Parameters

fileName
The style file's name.

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb.SetFontFolder Method

Sets the fonts folder

public static void SetFontFolder(
string fontFolder,
bool recursive
);

Parameters

fontFolder
The folder that contains TrueType fonts.
recursive
Determines whether or not to scan subfolders.

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWeb.SetFontFolders Method

Sets the fonts folders

public static void SetFontFolders(
string[] fontFolders,
bool recursive
);

Parameters

fontFolders
The folders that contains TrueType fonts.
recursive
Determines whether or not to scan subfolders.

See Also

GridWeb Class | Aspose.Cells.GridWeb Namespace


GridWebForm Class

GridWebForm control. It works with the GridWeb control. Set the GridWebControl property for it before run it.

For a list of all members of this type, see GridWebForm Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Aspose.Cells.GridWeb.GridWebForm

public class GridWebForm : WebControl, INamingContainer, IPostBackDataHandler, IPostBackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWebForm Members | Aspose.Cells.GridWeb Namespace


GridWebForm Members

GridWebForm overview

Public Instance Constructors

GridWebForm Constructor Default constructor.

Public Instance Properties

AccessKey (inherited from WebControl) |
AppRelativeTemplateSourceDirectory (inherited from Control) |
Attributes (inherited from WebControl) |
BackColor (inherited from WebControl) |
BindingContainer (inherited from Control) |
BorderColor (inherited from WebControl) |
BorderStyle (inherited from WebControl) |
BorderWidth (inherited from WebControl) |
ClientID (inherited from Control) |
Controls (inherited from Control) |
ControlStyle (inherited from WebControl) |
ControlStyleCreated (inherited from WebControl) |
CssClass (inherited from WebControl) |
EditMode | Gets or sets the Edit Mode of the GridWebForm control.
EnableCreateCustomButtomForGridWeb | Gets or sets whether to create a switching button in the GridWeb control's command bar.
Enabled (inherited from WebControl) |
EnableTheming (inherited from WebControl) |
EnableViewState (inherited from Control) |
Font (inherited from WebControl) |
ForeColor (inherited from WebControl) |
FormName | Gets or sets the form's name.
GridWebControl | Gets or sets the linked GridWeb control.
HasAttributes (inherited from WebControl) |
Height | Gets or sets the height of the control.
ID (inherited from Control) |
LineNumber | Gets or sets the current record line number of the sheet.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
Site (inherited from Control) |
SkinID (inherited from WebControl) |
Style (inherited from WebControl) |
TabIndex (inherited from WebControl) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
ToolTip (inherited from WebControl) |
UniqueID (inherited from Control) |
Visible | Gets or sets whether to show the form control. This property is controlled by the control itself. Do not modify it manually.
Width | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ApplyStyleSheetSkin (inherited from Control) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
HideForm | Hides the Form and shows the GridWeb control.
LoadPostData | Internal used only.
MergeStyle (inherited from WebControl) |
RaisePostBackEvent | Internal used only.
RaisePostDataChangedEvent | Internal used only.
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ShowForm | Hides the GridWeb control and shows the GridWebForm control.
ToString (inherited from Object) |

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
SaveCommand | Occurs when the "save" button is clicked.
Unload (inherited from Control) |

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm Constructor

Default constructor.

public GridWebForm();

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm Properties

The properties of the GridWebForm class are listed below. For a complete list of GridWebForm class members, see the GridWebForm Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) |
AppRelativeTemplateSourceDirectory (inherited from Control) |
Attributes (inherited from WebControl) |
BackColor (inherited from WebControl) |
BindingContainer (inherited from Control) |
BorderColor (inherited from WebControl) |
BorderStyle (inherited from WebControl) |
BorderWidth (inherited from WebControl) |
ClientID (inherited from Control) |
Controls (inherited from Control) |
ControlStyle (inherited from WebControl) |
ControlStyleCreated (inherited from WebControl) |
CssClass (inherited from WebControl) |
EditMode | Gets or sets the Edit Mode of the GridWebForm control.
EnableCreateCustomButtomForGridWeb | Gets or sets whether to create a switching button in the GridWeb control's command bar.
Enabled (inherited from WebControl) |
EnableTheming (inherited from WebControl) |
EnableViewState (inherited from Control) |
Font (inherited from WebControl) |
ForeColor (inherited from WebControl) |
FormName | Gets or sets the form's name.
GridWebControl | Gets or sets the linked GridWeb control.
HasAttributes (inherited from WebControl) |
Height | Gets or sets the height of the control.
ID (inherited from Control) |
LineNumber | Gets or sets the current record line number of the sheet.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
Site (inherited from Control) |
SkinID (inherited from WebControl) |
Style (inherited from WebControl) |
TabIndex (inherited from WebControl) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
ToolTip (inherited from WebControl) |
UniqueID (inherited from Control) |
Visible | Gets or sets whether to show the form control. This property is controlled by the control itself. Do not modify it manually.
Width | Gets or sets the width of the control.

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


EditMode Property

Aspose.Cells for .NET

GridWebForm.EditMode Property

Gets or sets the Edit Mode of the GridWebForm control.

public bool EditMode {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


EnableCreateCustomButtomForGridWeb Property

Aspose.Cells for .NET

GridWebForm.EnableCreateCustomButtomForGridWeb Property

Gets or sets whether to create a switching button in the GridWeb control's command bar.

public bool EnableCreateCustomButtomForGridWeb {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


FormName Property

Aspose.Cells for .NET

GridWebForm.FormName Property

Gets or sets the form's name.

public string FormName {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebControl Property

Aspose.Cells for .NET

GridWebForm.GridWebControl Property

Gets or sets the linked GridWeb control.

public string GridWebControl {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


Height Property

Aspose.Cells for .NET

GridWebForm.Height Property

Gets or sets the height of the control.

public override Unit Height {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


LineNumber Property

Aspose.Cells for .NET

GridWebForm.LineNumber Property

Gets or sets the current record line number of the sheet.

public int LineNumber {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


Visible Property

Aspose.Cells for .NET

GridWebForm.Visible Property

Gets or sets whether to show the form control. This property is controlled by the control itself. Do not modify it manually.

public override bool Visible {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


Width Property

Aspose.Cells for .NET

GridWebForm.Width Property

Gets or sets the width of the control.

public override Unit Width {get; set;}

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm Methods

The methods of the GridWebForm class are listed below. For a complete list of GridWebForm class members, see the GridWebForm Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ApplyStyleSheetSkin (inherited from Control) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
HideForm | Hides the Form and shows the GridWeb control.
LoadPostData | Internal used only.
MergeStyle (inherited from WebControl) |
RaisePostBackEvent | Internal used only.
RaisePostDataChangedEvent | Internal used only.
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ShowForm | Hides the GridWeb control and shows the GridWebForm control.
ToString (inherited from Object) |

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm.HideForm Method

Hides the Form and shows the GridWeb control.

public void HideForm();

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm.LoadPostData Method

Internal used only.

public bool LoadPostData(
string postDataKey,
NameValueCollection postCollection
);

Parameters

postDataKey
postCollection

Return Value

Implements

IPostBackDataHandler.LoadPostData

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm.RaisePostBackEvent Method

Internal used only.

public void RaisePostBackEvent(
string eventArgument
);

Parameters

eventArgument

Implements

IPostBackEventHandler.RaisePostBackEvent

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm.RaisePostDataChangedEvent Method

Internal used only.

public void RaisePostDataChangedEvent();

Implements

IPostBackDataHandler.RaisePostDataChangedEvent

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm.ShowForm Method

Hides the GridWeb control and shows the GridWebForm control.

public void ShowForm();

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm Events

The events of the GridWebForm class are listed below. For a complete list of GridWebForm class members, see the GridWebForm Members topic.

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
SaveCommand | Occurs when the "save" button is clicked.
Unload (inherited from Control) |

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWebForm.SaveCommand Event

Occurs when the "save" button is clicked.

public event WorkbookEventHandler SaveCommand;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

GridWebForm Class | Aspose.Cells.GridWeb Namespace


GridWorksheetDesign Class

Inherited from GridWorksheet. Used in design-time only.

For a list of all members of this type, see GridWorksheetDesign Members.

System.Object
System.Web.UI.Control
Aspose.Cells.GridWeb.Data.GridWorksheet
Aspose.Cells.GridWeb.GridWorksheetDesign

public class GridWorksheetDesign : GridWorksheet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWorksheetDesign Members | Aspose.Cells.GridWeb Namespace


GridWorksheetDesign Members

GridWorksheetDesign overview

Public Instance Constructors

GridWorksheetDesign Overloaded. Initializes a new instance of the GridWorksheetDesign class.

Public Instance Properties

ActiveCell (inherited from GridWorksheet) |
AppRelativeTemplateSourceDirectory (inherited from Control) |
BackgroundImage (inherited from GridWorksheet) | Gets and sets worksheet background image.
BindColumns (inherited from GridWorksheet) | Bind columns collection.
BindingContainer (inherited from Control) |
BindingSource (inherited from GridWorksheet) | The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.
BindStartColumn (inherited from GridWorksheet) | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
BindStartRow (inherited from GridWorksheet) | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
Cells (inherited from GridWorksheet) |
ClientID (inherited from Control) |
CodeName (inherited from GridWorksheet) | Represents worksheet code name.
Comments (inherited from GridWorksheet) |
Controls (inherited from Control) |
CurrentBindRows (inherited from GridWorksheet) | Gets the binding rows number in data-binding mode.
DataMember (inherited from GridWorksheet) | Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.
DataSource (inherited from GridWorksheet) | Gets or sets the DataSource. Generally it's a DataSet object.
DisplayRightToLeft (inherited from GridWorksheet) |
DisplayZeros (inherited from GridWorksheet) | True if zero values are displayed.
EnableCreateBindColumnHeader (inherited from GridWorksheet) | In data-binding mode, indicates whether to create bind column header captions in the sheet.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
FirstVisibleColumn (inherited from GridWorksheet) |
FirstVisibleRow (inherited from GridWorksheet) |
GridActiveCell (inherited from GridWorksheet) |
Hyperlinks (inherited from GridWorksheet) | Gets the HyperlinkCollection collection.
ID (inherited from Control) |
Index (inherited from GridWorksheet) |
IsGridlinesVisible (inherited from GridWorksheet) | Gets or sets a value indicating whether the grid lines are visible.Default is true.
IsSummaryRowBelow (inherited from GridWorksheet) | Indicates if the summary row will be positioned below the detail rows in the outline.
Name (inherited from GridWorksheet) | Gets or sets the name of the worksheet.
NamingContainer (inherited from Control) |
OutlineShown (inherited from GridWorksheet) | Indicates whether show outline.
Page (inherited from Control) |
Parent (inherited from Control) |
Pictures (inherited from GridWorksheet) | Gets a Pictures collection.
PivotTables (inherited from GridWorksheet) | Gets the pivotTables in the worksheet.
Selected (inherited from GridWorksheet) | Indicates whether this worksheet is selected when the workbook is opened.
Shapes (inherited from GridWorksheet) | Gets a Pictures collection.
Site (inherited from Control) |
SkinID (inherited from Control) |
StandardHeight (inherited from GridWorksheet) | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels (inherited from GridWorksheet) | Gets or sets the default row height in this worksheet,in unit of pixels.
TabColor (inherited from GridWorksheet) | Represents worksheet tab color.
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Validations (inherited from GridWorksheet) | Gets the data validation setting collection in the worksheet.
Visible (inherited from GridWorksheet) | Indicates whether this sheet's name is shown in the sheet tabs of the control.
Workbook (inherited from GridWorksheet) |
Zoom (inherited from GridWorksheet) |

Public Instance Methods

AddAutoFilter (inherited from GridWorksheet) | Sets the range to which the specified AutoFilter applies.
AddCustomFilter (inherited from GridWorksheet) | Add custom filter for the specified row.
ApplyStyleSheetSkin (inherited from Control) |
AutoFitColumn (inherited from GridWorksheet) | Overloaded. Autofits the column width.
CalculateFormula (inherited from GridWorksheet) | Calculates a formula.
CancelNewBindRow (inherited from GridWorksheet) | Cancels and deletes the new added bind row.
ClearComments (inherited from GridWorksheet) | Clears all comments in designer spreadsheet.
CommitNewBindRow (inherited from GridWorksheet) | Commits the new added bind row and add it to the datasource.
Copy (inherited from GridWorksheet) | Copies contents and formats from another worksheet.
CreateAutoGenratedColumns (inherited from GridWorksheet) | After setting a datasource for the worksheet, call this method to generate the bind columns automatically.
CreateNewBindRow (inherited from GridWorksheet) | Creates a new bind row and bind to the datasource.
CreateSubtotal (inherited from GridWorksheet) | Overloaded. Creates subtotal in the sheet.
DataBind (inherited from GridWorksheet) | Bind the sheet to the DataSource.
DataSourceControlUpdate (inherited from GridWorksheet) | Bind the sheet to the DataSource.
DeleteBindRow (inherited from GridWorksheet) | Deletes a bind row.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FilterString (inherited from GridWorksheet) | Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc
FindControl (inherited from Control) |
Focus (inherited from Control) |
FreezePanes (inherited from GridWorksheet) | Overloaded. Freezes panes at the specified cell in the worksheet.
GetColumnCaption (inherited from GridWorksheet) | Gets the column caption. If the caption is not set, returns empty string.
GetColumnHeaderToolTip (inherited from GridWorksheet) | Gets the columnheader's tooltip text.
GetColumnReadonly (inherited from GridWorksheet) | Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetFreezedPanes (inherited from GridWorksheet) |
GetHashCode (inherited from Object) |
GetIsReadonly (inherited from GridWorksheet) | Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
GetRowCaption (inherited from GridWorksheet) | Gets the row caption. If the caption is not set, returns empty string.
GetRowHeaderToolTip (inherited from GridWorksheet) | Gets the rowheader's tooltip text.
GetRowReadonly (inherited from GridWorksheet) | Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetType (inherited from Object) |
GroupRows (inherited from GridWorksheet) | Groups rows.
HasControls (inherited from Control) |
IsProtected (inherited from GridWorksheet) | Indicates if the worksheet is protected.
MoveTo (inherited from GridWorksheet) | Moves the sheet to another location in the spreadsheet.
RefreshFilter (inherited from GridWorksheet) | Refresh auto filters to hide or unhide the rows.
RemoveAutoFilter (inherited from GridWorksheet) | Remove the auto filter of the worksheet.
RemoveSubtotal (inherited from GridWorksheet) | Removes subtotal created by the CreateSubtotal method in the sheet.
RenderControl (inherited from Control) |
ResetFilter (inherited from GridWorksheet) | The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAllCellsEditable (inherited from GridWorksheet) | Makes all cells editable.this is extended attribute
SetAllCellsReadonly (inherited from GridWorksheet) | Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect
SetColumnCaption (inherited from GridWorksheet) | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetColumnHeaderToolTip (inherited from GridWorksheet) | Sets the columnheader's tooltip text.
SetColumnReadonly (inherited from GridWorksheet) | Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetEditableRange (inherited from GridWorksheet) | Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable
SetIsReadonly (inherited from GridWorksheet) | Sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
SetProtect (inherited from GridWorksheet) | Protects worksheet.
SetReadonlyRange (inherited from GridWorksheet) | Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly
SetRenderMethodDelegate (inherited from Control) |
SetRowCaption (inherited from GridWorksheet) | Sets the caption for the row.
SetRowHeaderToolTip (inherited from GridWorksheet) | Sets the rowheader's tooltip text.
SetRowReadonly (inherited from GridWorksheet) | Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
ToString (inherited from Object) |
UnFreezePanes (inherited from GridWorksheet) | Unfreezes panes in the worksheet.
UnGroupRows (inherited from GridWorksheet) | Ungroups rows.
UnProtect (inherited from GridWorksheet) | unProtects worksheet.

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
InitializeNewBindRow (inherited from GridWorksheet) | Occurs when the worksheet has created a new bind row and need to initialize it.
Load (inherited from Control) |
PreRender (inherited from Control) |
Unload (inherited from Control) |

See Also

GridWorksheetDesign Class | Aspose.Cells.GridWeb Namespace


GridWorksheetDesign Constructor

Default constructor.

Overload List

Default constructor.

public GridWorksheetDesign();

public GridWorksheetDesign(GridWorkbook);

See Also

GridWorksheetDesign Class | Aspose.Cells.GridWeb Namespace


GridWorksheetDesign Constructor ()

Default constructor.

public GridWorksheetDesign();

See Also

GridWorksheetDesign Class | Aspose.Cells.GridWeb Namespace | GridWorksheetDesign Constructor Overload List


GridWorksheetDesign Constructor (GridWorkbook)

public GridWorksheetDesign(
GridWorkbook gwb
);

See Also

GridWorksheetDesign Class | Aspose.Cells.GridWeb Namespace | GridWorksheetDesign Constructor Overload List


LayoutFixedType Enumeration

Layout fixed type of a table object.

public enum LayoutFixedType

Members

Member Name | Description | Value
NotSet | Not set. | 0
Fixed | Fixed. | 1
Auto | Auto. | 2

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


License Class

For a list of all members of this type, see License Members.

System.Object
Aspose.Cells.GridWeb.License

public class License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

License Members | Aspose.Cells.GridWeb Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of the License class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) |

See Also

License Class | Aspose.Cells.GridWeb Namespace


License Constructor

Initializes a new instance of the License class.

public License();

See Also

License Class | Aspose.Cells.GridWeb Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) |

See Also

License Class | Aspose.Cells.GridWeb Namespace


SetLicense Method

Aspose.Cells for .NET

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Cells.GridWeb Namespace


License.SetLicense Method (Stream)

Licenses the component.

public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

[C#]

License license = new License();
license.SetLicense(myStream);

[Visual Basic]

Dim license as License = new License
license.SetLicense(myStream)

See Also

License Class | Aspose.Cells.GridWeb Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

public void SetLicense(
string licenseName
);

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder that contains the Aspose component assembly.

3. The folder that contains the client's calling assembly.

4. The folder that contains the entry (startup) assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.

See Also

License Class | Aspose.Cells.GridWeb Namespace | License.SetLicense Overload List


MainWeb Class

For a list of all members of this type, see MainWeb Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Aspose.Cells.GridWeb.ExtWebControl
Aspose.Cells.GridWeb.MainWeb
Aspose.Cells.GridWeb.GridWeb

public class MainWeb : ExtWebControl, INamingContainer, IPostBackDataHandler, IPostBackEventHandler, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

MainWeb Members | Aspose.Cells.GridWeb Namespace


MainWeb Members

MainWeb overview

Public Instance Constructors

MainWeb Constructor Initializes a new instance of the MainWeb class.

Public Instance Properties

AccessKey (inherited from WebControl)
ActiveCell | Gets or sets the active cell of the current sheet. Changed to be writable since version 1.9.0.1.
ActiveCellBgColor | Specifies the background color of the active cell.
ActiveCellColor | Specifies the color of the active cell.
ActiveHeaderBgColor | Specifies the background color of the active row/column header.
ActiveHeaderColor | Specifies the color of the active row/column header.
ActiveSheet | Gets the active sheet
ActiveSheetIndex | Gets or sets the active sheet index. Equal to the WebWorksheets.ActiveSheetIndex.
ActiveTabStyle | Specifies the style of the active tab.
ACWClientPath Gets or sets the web path of the script/image files of the control. For example: "http://localhost/acw_client". You may also set this value in the web.config file. Add this section to the <configuration> section:

ACWLanguageFileUrl Gets or sets the web url of the language file of the control. For example: "/acw_client/lang_en.js".
AppRelativeTemplateSourceDirectory (inherited from Control)
Attributes (inherited from WebControl)
AutoRefreshChart | Gets or sets whether the Chart image is updated while updating the cell value.the default is true
BackColor (inherited from WebControl)
BindingContainer (inherited from Control)
BorderColor (inherited from WebControl)
BorderStyle (inherited from WebControl)
BorderWidth (inherited from WebControl)
BottomTableStyle | Gets or sets the style of the bottom bar of the control.
ClientID (inherited from Control)
Controls (inherited from Control)
ControlStyle (inherited from WebControl)
ControlStyleCreated (inherited from WebControl)
CssClass (inherited from WebControl)
CurrentPageIndex
CustomCalculationEngine | Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.
CustomCommandButtons
CustomStyleFileName | Gets or sets the custom style file name.
DefaultFontName | Gets or sets the control's default font name.
DefaultFontSize | Gets or sets the control's default font size.
DefaultGridLineColor | Gets or sets the default grid line's color.
DisplayCellTip
EditMode | Gets or sets the control's edit mode.
EnableAJAX
EnableAsync | Gets or sets whether load cells data in asynchronous way,suggest to apply for one sheet with more than 10000 cells.
EnableClientColumnOperations | Gets or sets whether to enable the client side column operations.
EnableClientFreeze | Gets or sets whether to enable the client side freezing operations.
EnableClientMergeOperations | Gets or sets whether to enable the client side merge operations.
EnableClientResizeColumnRow | Gets or sets whether to enable the client side resize column and row.
EnableClientRowOperations | Gets or sets whether to enable the client side row operations.
Enabled (inherited from WebControl)
EnableDoubleClickEvent | Gets or sets whether to enable customer side double-click event.
EnableMetalLightEffect | Gets or sets whether to apply metal light effect.
EnablePaging | Gets or sets whether to enable the control's paging mode.
EnableStyleDialogbox | Gets or sets whether to enable the client side style dialogbox.
EnableTheming (inherited from WebControl)
EnableViewState (inherited from Control)
FilteredPaging | Gets or sets whether to enable the paging after data filtered,will take affect when EnablePaging is true.
Font (inherited from WebControl)
ForceValidation | Gets or sets whether to force customer side validation.
ForeColor (inherited from WebControl)
FrameTableStyle | Gets or sets the frame style of the control.
GoonDefaultSaveOperation | Gets or sets whether GridWeb will do the default save operation ,the default value is true.
HasAttributes (inherited from WebControl)
HeaderBarHeight | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the top header bar of the control.
HeaderBarStyle | Gets or sets the header bar's style.
HeaderBarTableStyle | Gets or sets the header bar style of the control.
HeaderBarWidth | Gets or sets the width( System.Web.UI.WebControl.Unit ) or the left header bar of the control.
Height | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the control.
ID (inherited from Control)
IsPostBack | Gets a value indicating whether gridweb is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.
LinksTable
MaxColumn | Gets or sets the maximum display column index(zero based) of the web sheet. The control uses the greater value of MaxColumn and sheet data's max column.
MaxRow | Gets or sets the maximum display row index(zero based) of the web sheet. The control uses the greater value of MaxRow and sheet data's max row.
Message
MinColumn
MinRow | Gets or sets the minimum display row index(zero based) of the web sheet. The control uses the smaller value of MinRow and sheet data's min row.
ModifiedCells | Gets the collection of the cells that modified by the client.
NamingContainer (inherited from Control)
NeedRenderGroupRows | Gets or sets whether to show grouprows .
NoHScroll | Gets or sets a value indicating whether the horizontal scroll bar is hidden.
NoScroll
NoVScroll | Gets or sets a value indicating whether the vertical scroll bar is hidden.
OnAjaxCallFinishedClientFunction Gets or sets the client side function name to be called when ajaxcall finished. The client function should be declared like this:
function GridAjaxcallFinished()
{
alert(this.id+" ajaxcall finished ");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellErrorClientFunction Gets or sets the client side function name to be called when a cell's validation is failed. The client function should be declared like this:
function MyOnCellError(cell)
{
alert(GridWeb1.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedAjaxCallBackClientFunction Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCellAjaxCallBack(cell,customerdata)
{

}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedClientFunction Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUnselectedClientFunction Gets or sets the client side function to be called when a cell is unselected. The client function should be declared like this:
function MyOnUnselectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUpdatedClientFunction Gets or sets the client side function name to be called when a cell's value is updated. The client function should be declared like this:
function MyOnCellUpdated(cell)
{
alert(this.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnContextMenuShowClientFunction Gets or sets the client side function to be called when the context menu will be shown. The client function should be declared like this:
function onContextMenuShow()
{
var menu = event.srcElement;
menu.setItemVisibility("Delete", "block");
menu.setItemVisibility("Update", "none");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickCellClientFunction Gets or sets the client side function to be called when a cell is double clicked. The client function should be declared like this:
function MyOnDoubleClickCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickRowClientFunction Gets or sets the client side function to be called when a row is double clicked. The client function should be declared like this:
function MyOnRowDoubleClick(row)
{
alert(row);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnGridInitClientFunction Gets or sets the client side function name to be called when the grid is initialized. The client function should be declared like this:
function MyOnGridInit(grid)
{
alert("The grid is initialized: " + grid.id);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageChangeClientFunction Gets or sets the client side function to be called after page index changing.only take effect when EnablePaging is true. The client function should be declared like this:
function MyOnPageChange(index)
{
console.log("current page is:"+index);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageSubmitClientFunction | Gets or sets the client function to be called before the page is submitted at client side.
OnShapeSelectedClientFunction Gets or sets the client side function to be called when a shape is selected. The client function should be declared like this:
function MyOnSelectShape(shape)
{
var name=shape.getAttribute("namevalue")
var text=shape.getAttribute("textvalue")
var value=shape.getAttribute("controlvalue")
var type=shape.getAttribute("msotype")
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnSubmitClientFunction Gets or sets the client function to be called before the control is submitted at client side. The client function should be declared like this:
function MyOnSubmit(arg, cancelEdit)
{
return true;
}
The arg is the submit argument, contains the command to be post to the server. The cancelEdit is boolean value indicates whether the control has discarded the user input before submit. The control will continue submitting if the function returns true.
Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
Page (inherited from Control)
PageSize | Gets or sets the page size in paging mode.
Parent (inherited from Control)
PictureCachePath | Gets or sets the image storage path for the workbook,all the shapes,images will be stored in this directory, the default path is acwcache under current application Base Directory users need to implement a schedule service to clean the files those are out of session time.
PicturesTable
PresetStyle | Gets or sets the preset style.
RenderHiddenRow | Gets or sets whether the hidden row is rendered in GridControl,the default value is false. if you need to unhide the hidden row latter ,you shall set it as true
ScrollBarArrowColor | Specifies the color of the scrollbar's arrow button.
ScrollBarBaseColor | Specifies the color of the scroll bar of the control.
SelectCellBgColor | Specifies the background color of the selected cells in multi-select range.
SelectCellColor | Specifies the color of the selected cells in multi-select range.
SessionLoaded
SessionMode Gets or sets the session mode of the grid. There are 3 type of session mode:
1. Session(default): Use system session to store sheet data.
Generally the asp.net uses InProc session state. The grid also supports "StateServer" out process session state and SQLServer session state.
2. ViewState: Use page's viewstate to store sheet data.
3. Custom: Use LoadCustomData and SheetDataUpdated events to store/recover sheet data.
SessionSaved
SessionStorePath | Gets or sets the session store path when session mode is File, etc: gridweb.SessionStorePath="c:/mytempdir/session"; then it will store session data in c:/mytempdir/session
ShapesTable
ShowAddButton | Gets or sets whether to show the add worksheet button.
ShowBottomBar
ShowCellEditBox | whether Gridweb shows edit box toolbar as in MS-EXCEL.if enable ,a edit box for current cell will display in Gridweb. if we enable this feature, we need to import jquery js library in your aspx files to support this new feature. all the latest jquery version is ok. etc.
ShowCommandBarAtTop | Specifies whether to show the command bar(includes command bar and tab bar) at the top of the control.
ShowContextMenu
ShowDefaultGridLine | Gets or sets whether to show the default grid lines of the cells.
ShowHeaderBar
ShowLoading | Specifies whether to show a loading dialogbox while postbacking to server.
ShowLoadingPosition | Specifies the left,top postion(in px) to show the loading dialogbox while postbacking to server ,etc. 100,200 means the loading dialogbox's left,top postion is at 100px,200px .
ShowSaveButton | Gets or sets whether to show the save button.
ShowSubmitButton | Gets or sets whether to show the submit button.
ShowTabBar
ShowTabNavigation | Gets or sets whether the tab navigation button is show,the default value is true.
ShowUndoButton | Gets or sets whether to show the undo button.
Site (inherited from Control)
SkinID (inherited from WebControl)
SpanWrap | Specifies whether to wrap content in the cell span.
Style (inherited from WebControl)
TabIndex (inherited from WebControl)
TabStyle | Gets or sets the style of the tab bar.
TemplateControl (inherited from Control)
TemplateSourceDirectory (inherited from Control)
ToolTip (inherited from WebControl)
UniqueID (inherited from Control)
UseClientPageHeight | Gets or sets whether gridweb use client page height as control height ,suitable for when set Height="100%",default value is false
ValidationsTable
ViewPanelScrollLeft | Gets or sets the position of the scroll bar of the grid's view panel.
ViewPanelScrollTop | Gets or sets the position of the scroll bar of the grid's view panel.
ViewTableStyle | Gets or sets the data view panel's style.
Visible (inherited from Control)
WebWorksheets
Width | Gets or sets the width( System.Web.UI.WebControl.Unit ) of the control.
WorkSheets
XhtmlMode

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ApplyStyleSheetSkin (inherited from Control) |
CalculateFormula | Calculates the result of formulas.
CopyBaseAttributes (inherited from WebControl) |
DataBind | Bind the control and all its child contorls to the its datasource.
Dispose |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
ImportExcelFile | Overloaded. Imports from an excel file.
LoadCSVFile | Overloaded. Loads data from a CSV file.
LoadHTMLFile | Overloaded. Loads data from a HTML file.
LoadSpreadSheetMLFile | Overloaded. Loads data from a SpreadSheetML file.
MergeStyle (inherited from WebControl) |
RefreshChartShape | refresh all the chart image for the active worksheet .
RenderBeginTag |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SaveCSVFile | Overloaded. Saves data to a CSV file.
SaveCustomStyleFile | Saves current style data of the control to an xml file. Can be used to create your customized style file.
SaveHTMLFile | Overloaded. Saves data to a HTML file.
SaveSpreadSheetMLFile | Overloaded. Saves data to a SpreadSheetML file.
SaveToExcelFile | Overloaded. Saves the worksheets to an excel file with Excel 2003 format.
SetCustomStyle | sets the custom style file from stream including disk file stream or memory stream.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Public Instance Events

AfterColumnFilter | Occurs after the column filtered.
AjaxCallFinished | Fires when the ajax update of the control finished.(the EnableAJAX shall be set to true)
BeforeColumnFilter | Occurs before the column to be filtered.
CellClickOnAjax | Occurs when the cell is clicked,and need to do ajaxcallback for this event.
CellClientUpdate | Occurs when a client cell update happen . When this event is fired, its parameter e.Argument contains the command's name.
CellCommand | Occurs when a cell's command hyperlink is clicked. When this event is fired, its parameter e.Argument contains the command's name.
CellDoubleClick | Occurs when the cell is double-clicked.
CellError | Occurs when a cell's input value error.
CellModifiedOnAjax | Occurs when the cell is modified in ajaxcall.
ColumnDeleted | Occurs when user delete a column from client-side menu.
ColumnDeleting | Occurs when user is trying to delete a column from the client-side menu. You may handle this event and set the cancel parameter to True to cancel a deleting operation.
ColumnDoubleClick | Occurs when the column header is double-clicked.
ColumnInserted | Occurs when user insert a column from client-side menu.
CustomCommand | Occurs when user clicks a custom command button.
DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
LoadCustomData | Fires when the control's SessionMode is set to Custom and needs to load sheet data. You may handle this event in Custom Session mode to load sheet data from file or database.
PageIndexChanged | Occurs when the control's sheet page index changed.
PreRender (inherited from Control) |
RowDeleted | Occurs when user has deleted a row from client-side menu.
RowDeleting | Occurs when user is trying to delete a row from the client-side menu. You may handle this event and throw a RejectDeleteException exception to cancel a deleting operation.
RowDoubleClick | Occurs when the row header is double-clicked.
RowInserted | Occurs when user insert a row from client-side menu.
SaveCommand | Occurs when the "save" button is clicked.
SheetAdded | Occurs when user add a worksheet from toolbar menu.
SheetDataUpdated | Occurs when the control has loaded the posted data and updated the sheet data.
SheetTabClick | Occurs when the sheet tab is clicked.
SubmitCommand | Occurs when the "submit" button is clicked.
UndoCommand | Occurs when the "undo" button is clicked.
Unload (inherited from Control) |

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb Constructor

Initializes a new instance of the MainWeb class.

public MainWeb();

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb Properties

The properties of the MainWeb class are listed below. For a complete list of MainWeb class members, see the MainWeb Members topic.

Public Instance Properties

AccessKey (inherited from WebControl)
ActiveCell | Gets or sets the active cell of the current sheet. Changed to be writable since version 1.9.0.1.
ActiveCellBgColor | Specifies the background color of the active cell.
ActiveCellColor | Specifies the color of the active cell.
ActiveHeaderBgColor | Specifies the background color of the active row/column header.
ActiveHeaderColor | Specifies the color of the active row/column header.
ActiveSheet | Gets the active sheet
ActiveSheetIndex | Gets or sets the active sheet index. Equal to the WebWorksheets.ActiveSheetIndex.
ActiveTabStyle | Specifies the style of the active tab.
ACWClientPath Gets or sets the web path of the script/image files of the control. For example: "http://localhost/acw_client". You may also set this value in the web.config file. Add this section to the <configuration> section:

ACWLanguageFileUrl Gets or sets the web url of the language file of the control. For example: "/acw_client/lang_en.js".
AppRelativeTemplateSourceDirectory (inherited from Control)
Attributes (inherited from WebControl)
AutoRefreshChart | Gets or sets whether the Chart image is updated while updating the cell value.the default is true
BackColor (inherited from WebControl)
BindingContainer (inherited from Control)
BorderColor (inherited from WebControl)
BorderStyle (inherited from WebControl)
BorderWidth (inherited from WebControl)
BottomTableStyle | Gets or sets the style of the bottom bar of the control.
ClientID (inherited from Control)
Controls (inherited from Control)
ControlStyle (inherited from WebControl)
ControlStyleCreated (inherited from WebControl)
CssClass (inherited from WebControl)
CurrentPageIndex
CustomCalculationEngine | Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.
CustomCommandButtons
CustomStyleFileName | Gets or sets the custom style file name.
DefaultFontName | Gets or sets the control's default font name.
DefaultFontSize | Gets or sets the control's default font size.
DefaultGridLineColor | Gets or sets the default grid line's color.
DisplayCellTip
EditMode | Gets or sets the control's edit mode.
EnableAJAX
EnableAsync | Gets or sets whether load cells data in asynchronous way,suggest to apply for one sheet with more than 10000 cells.
EnableClientColumnOperations | Gets or sets whether to enable the client side column operations.
EnableClientFreeze | Gets or sets whether to enable the client side freezing operations.
EnableClientMergeOperations | Gets or sets whether to enable the client side merge operations.
EnableClientResizeColumnRow | Gets or sets whether to enable the client side resize column and row.
EnableClientRowOperations | Gets or sets whether to enable the client side row operations.
Enabled (inherited from WebControl)
EnableDoubleClickEvent | Gets or sets whether to enable customer side double-click event.
EnableMetalLightEffect | Gets or sets whether to apply metal light effect.
EnablePaging | Gets or sets whether to enable the control's paging mode.
EnableStyleDialogbox | Gets or sets whether to enable the client side style dialogbox.
EnableTheming (inherited from WebControl)
EnableViewState (inherited from Control)
FilteredPaging | Gets or sets whether to enable the paging after data filtered,will take affect when EnablePaging is true.
Font (inherited from WebControl)
ForceValidation | Gets or sets whether to force customer side validation.
ForeColor (inherited from WebControl)
FrameTableStyle | Gets or sets the frame style of the control.
GoonDefaultSaveOperation | Gets or sets whether GridWeb will do the default save operation ,the default value is true.
HasAttributes (inherited from WebControl)
HeaderBarHeight | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the top header bar of the control.
HeaderBarStyle | Gets or sets the header bar's style.
HeaderBarTableStyle | Gets or sets the header bar style of the control.
HeaderBarWidth | Gets or sets the width( System.Web.UI.WebControl.Unit ) or the left header bar of the control.
Height | Gets or sets the height( System.Web.UI.WebControl.Unit ) of the control.
ID (inherited from Control)
IsPostBack | Gets a value indicating whether gridweb is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.
LinksTable
MaxColumn | Gets or sets the maximum display column index(zero based) of the web sheet. The control uses the greater value of MaxColumn and sheet data's max column.
MaxRow | Gets or sets the maximum display row index(zero based) of the web sheet. The control uses the greater value of MaxRow and sheet data's max row.
Message
MinColumn
MinRow | Gets or sets the minimum display row index(zero based) of the web sheet. The control uses the smaller value of MinRow and sheet data's min row.
ModifiedCells | Gets the collection of the cells that modified by the client.
NamingContainer (inherited from Control)
NeedRenderGroupRows | Gets or sets whether to show grouprows .
NoHScroll | Gets or sets a value indicating whether the horizontal scroll bar is hidden.
NoScroll
NoVScroll | Gets or sets a value indicating whether the vertical scroll bar is hidden.
OnAjaxCallFinishedClientFunction Gets or sets the client side function name to be called when ajaxcall finished. The client function should be declared like this:
function GridAjaxcallFinished()
{
alert(this.id+" ajaxcall finished ");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellErrorClientFunction Gets or sets the client side function name to be called when a cell's validation is failed. The client function should be declared like this:
function MyOnCellError(cell)
{
alert(GridWeb1.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedAjaxCallBackClientFunction Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCellAjaxCallBack(cell,customerdata)
{

}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellSelectedClientFunction Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUnselectedClientFunction Gets or sets the client side function to be called when a cell is unselected. The client function should be declared like this:
function MyOnUnselectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnCellUpdatedClientFunction Gets or sets the client side function name to be called when a cell's value is updated. The client function should be declared like this:
function MyOnCellUpdated(cell)
{
alert(this.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnContextMenuShowClientFunction Gets or sets the client side function to be called when the context menu will be shown. The client function should be declared like this:
function onContextMenuShow()
{
var menu = event.srcElement;
menu.setItemVisibility("Delete", "block");
menu.setItemVisibility("Update", "none");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickCellClientFunction Gets or sets the client side function to be called when a cell is double clicked. The client function should be declared like this:
function MyOnDoubleClickCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnDoubleClickRowClientFunction Gets or sets the client side function to be called when a row is double clicked. The client function should be declared like this:
function MyOnRowDoubleClick(row)
{
alert(row);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnGridInitClientFunction Gets or sets the client side function name to be called when the grid is initialized. The client function should be declared like this:
function MyOnGridInit(grid)
{
alert("The grid is initialized: " + grid.id);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageChangeClientFunction Gets or sets the client side function to be called after page index changing.only take effect when EnablePaging is true. The client function should be declared like this:
function MyOnPageChange(index)
{
console.log("current page is:"+index);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnPageSubmitClientFunction | Gets or sets the client function to be called before the page is submitted at client side.
OnShapeSelectedClientFunction Gets or sets the client side function to be called when a shape is selected. The client function should be declared like this:
function MyOnSelectShape(shape)
{
var name=shape.getAttribute("namevalue")
var text=shape.getAttribute("textvalue")
var value=shape.getAttribute("controlvalue")
var type=shape.getAttribute("msotype")
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
OnSubmitClientFunction Gets or sets the client function to be called before the control is submitted at client side. The client function should be declared like this:
function MyOnSubmit(arg, cancelEdit)
{
return true;
}
The arg is the submit argument, contains the command to be post to the server. The cancelEdit is boolean value indicates whether the control has discarded the user input before submit. The control will continue submitting if the function returns true.
Note: You may use the "this" pointer in the client function to point the grid control which fires the event.
Page (inherited from Control)
PageSize | Gets or sets the page size in paging mode.
Parent (inherited from Control)
PictureCachePath | Gets or sets the image storage path for the workbook,all the shapes,images will be stored in this directory, the default path is acwcache under current application Base Directory users need to implement a schedule service to clean the files those are out of session time.
PicturesTable
PresetStyle | Gets or sets the preset style.
RenderHiddenRow | Gets or sets whether the hidden row is rendered in GridControl,the default value is false. if you need to unhide the hidden row latter ,you shall set it as true
ScrollBarArrowColor | Specifies the color of the scrollbar's arrow button.
ScrollBarBaseColor | Specifies the color of the scroll bar of the control.
SelectCellBgColor | Specifies the background color of the selected cells in multi-select range.
SelectCellColor | Specifies the color of the selected cells in multi-select range.
SessionLoaded
SessionMode Gets or sets the session mode of the grid. There are 3 type of session mode:
1. Session(default): Use system session to store sheet data.
Generally the asp.net uses InProc session state. The grid also supports "StateServer" out process session state and SQLServer session state.
2. ViewState: Use page's viewstate to store sheet data.
3. Custom: Use LoadCustomData and SheetDataUpdated events to store/recover sheet data.
SessionSaved
SessionStorePath | Gets or sets the session store path when session mode is File, etc: gridweb.SessionStorePath="c:/mytempdir/session"; then it will store session data in c:/mytempdir/session
ShapesTable
ShowAddButton | Gets or sets whether to show the add worksheet button.
ShowBottomBar
ShowCellEditBox | whether Gridweb shows edit box toolbar as in MS-EXCEL.if enable ,a edit box for current cell will display in Gridweb. if we enable this feature, we need to import jquery js library in your aspx files to support this new feature. all the latest jquery version is ok. etc.
ShowCommandBarAtTop | Specifies whether to show the command bar(includes command bar and tab bar) at the top of the control.
ShowContextMenu
ShowDefaultGridLine | Gets or sets whether to show the default grid lines of the cells.
ShowHeaderBar
ShowLoading | Specifies whether to show a loading dialogbox while postbacking to server.
ShowLoadingPosition | Specifies the left,top postion(in px) to show the loading dialogbox while postbacking to server ,etc. 100,200 means the loading dialogbox's left,top postion is at 100px,200px .
ShowSaveButton | Gets or sets whether to show the save button.
ShowSubmitButton | Gets or sets whether to show the submit button.
ShowTabBar
ShowTabNavigation | Gets or sets whether the tab navigation button is show,the default value is true.
ShowUndoButton | Gets or sets whether to show the undo button.
Site (inherited from Control)
SkinID (inherited from WebControl)
SpanWrap | Specifies whether to wrap content in the cell span.
Style (inherited from WebControl)
TabIndex (inherited from WebControl)
TabStyle | Gets or sets the style of the tab bar.
TemplateControl (inherited from Control)
TemplateSourceDirectory (inherited from Control)
ToolTip (inherited from WebControl)
UniqueID (inherited from Control)
UseClientPageHeight | Gets or sets whether gridweb use client page height as control height ,suitable for when set Height="100%",default value is false
ValidationsTable
ViewPanelScrollLeft | Gets or sets the position of the scroll bar of the grid's view panel.
ViewPanelScrollTop | Gets or sets the position of the scroll bar of the grid's view panel.
ViewTableStyle | Gets or sets the data view panel's style.
Visible (inherited from Control)
WebWorksheets
Width | Gets or sets the width( System.Web.UI.WebControl.Unit ) of the control.
WorkSheets
XhtmlMode

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveCell Property

Aspose.Cells for .NET

MainWeb.ActiveCell Property

Gets or sets the active cell of the current sheet. Changed to be writable since version 1.9.0.1.

public GridCell ActiveCell {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveCellBgColor Property

Aspose.Cells for .NET

MainWeb.ActiveCellBgColor Property

Specifies the background color of the active cell.

public Color ActiveCellBgColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveCellColor Property

Aspose.Cells for .NET

MainWeb.ActiveCellColor Property

Specifies the color of the active cell.

public Color ActiveCellColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveHeaderBgColor Property

Aspose.Cells for .NET

MainWeb.ActiveHeaderBgColor Property

Specifies the background color of the active row/column header.

public Color ActiveHeaderBgColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveHeaderColor Property

Aspose.Cells for .NET

MainWeb.ActiveHeaderColor Property

Specifies the color of the active row/column header.

public Color ActiveHeaderColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveSheet Property

Aspose.Cells for .NET

MainWeb.ActiveSheet Property

Gets the active sheet

public GridWorksheet ActiveSheet {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveSheetIndex Property

Aspose.Cells for .NET

MainWeb.ActiveSheetIndex Property

Gets or sets the active sheet index. Equal to the WebWorksheets.ActiveSheetIndex.

public int ActiveSheetIndex {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ActiveTabStyle Property

Aspose.Cells for .NET

MainWeb.ActiveTabStyle Property

Specifies the style of the active tab.

public GridTableItemStyle ActiveTabStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ACWClientPath Property

Aspose.Cells for .NET

MainWeb.ACWClientPath Property

Gets or sets the web path of the script/image files of the control. For example: "http://localhost/acw_client". You may also set this value in the web.config file. Add this section to the <configuration> section:

public string ACWClientPath {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ACWLanguageFileUrl Property

Aspose.Cells for .NET

MainWeb.ACWLanguageFileUrl Property

Gets or sets the web url of the language file of the control. For example: "/acw_client/lang_en.js".

public string ACWLanguageFileUrl {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


AutoRefreshChart Property

Aspose.Cells for .NET

MainWeb.AutoRefreshChart Property

Gets or sets whether the Chart image is updated while updating the cell value.the default is true

public bool AutoRefreshChart {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


BottomTableStyle Property

Aspose.Cells for .NET

MainWeb.BottomTableStyle Property

Gets or sets the style of the bottom bar of the control.

public GridTableStyle BottomTableStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


CurrentPageIndex Property

Aspose.Cells for .NET

MainWeb.CurrentPageIndex Property

public int CurrentPageIndex {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


CustomCalculationEngine Property

Aspose.Cells for .NET

MainWeb.CustomCalculationEngine Property

Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.

public GridAbstractCalculationEngine CustomCalculationEngine {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


CustomCommandButtons Property

Aspose.Cells for .NET

MainWeb.CustomCommandButtons Property

public CustomCommandButtonCollection CustomCommandButtons {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


CustomStyleFileName Property

Aspose.Cells for .NET

MainWeb.CustomStyleFileName Property

Gets or sets the custom style file name.

public string CustomStyleFileName {get; set;}

Remarks

The custom style file is an XML file. When sets the file name, the file will be loaded immediately. Hear is the content of the "standard preset style" ------------------------------------------------------- <Aspose.Cells.GridWeb.ViewerStyleTemplate runat="server" HeaderBarWidth="30pt" ScrollBarBaseColor="" FrameTableStyle-BorderStyle="Solid" FrameTableStyle-LeftBorderStyle-BorderWidth="" FrameTableStyle-LeftBorderStyle-BorderColor="" FrameTableStyle-RightBorderStyle-BorderWidth="" FrameTableStyle-RightBorderStyle-BorderColor="" FrameTableStyle-BorderWidth="1px" FrameTableStyle-CellSpacing="0" FrameTableStyle-BorderColor="Gray" FrameTableStyle-CellPadding="0" FrameTableStyle-TopBorderStyle-BorderWidth="" FrameTableStyle-TopBorderStyle-BorderColor="" FrameTableStyle-BottomBorderStyle-BorderWidth="" FrameTableStyle-BottomBorderStyle-BorderColor="" HeaderBarStyle-LeftBorderStyle-BorderStyle="Solid" HeaderBarStyle-LeftBorderStyle-BorderWidth="1px" HeaderBarStyle-LeftBorderStyle-BorderColor="White" HeaderBarStyle-VerticalAlign="Middle" HeaderBarStyle-RightBorderStyle-BorderStyle="Solid" HeaderBarStyle-RightBorderStyle-BorderWidth="1px" HeaderBarStyle-RightBorderStyle-BorderColor="Gray" HeaderBarStyle-BorderWidth="1px" HeaderBarStyle-Font-Size="10pt" HeaderBarStyle-BorderColor="Gray" HeaderBarStyle-BorderStyle="Solid" HeaderBarStyle-HorizontalAlign="Center" HeaderBarStyle-ForeColor="Black" HeaderBarStyle-TopBorderStyle-BorderStyle="Solid" HeaderBarStyle-TopBorderStyle-BorderWidth="1px" HeaderBarStyle-TopBorderStyle-BorderColor="White" HeaderBarStyle-BackColor="#E0E0E0" HeaderBarStyle-BottomBorderStyle-BorderStyle="Solid" HeaderBarStyle-BottomBorderStyle-BorderWidth="1px" HeaderBarStyle-BottomBorderStyle-BorderColor="Gray" ViewTableStyle-LeftBorderStyle-BorderWidth="" ViewTableStyle-LeftBorderStyle-BorderColor="" ViewTableStyle-LayoutFixed="Fixed" ViewTableStyle-RightBorderStyle-BorderWidth="" ViewTableStyle-RightBorderStyle-BorderColor="" ViewTableStyle-BorderWidth="0px" ViewTableStyle-CellSpacing="0" ViewTableStyle-CellPadding="0" ViewTableStyle-TopBorderStyle-BorderWidth="" ViewTableStyle-TopBorderStyle-BorderColor="" ViewTableStyle-BottomBorderStyle-BorderWidth="" ViewTableStyle-BottomBorderStyle-BorderColor="" BottomTableStyle-LeftBorderStyle-BorderWidth="" BottomTableStyle-LeftBorderStyle-BorderColor="" BottomTableStyle-LayoutFixed="Fixed" BottomTableStyle-RightBorderStyle-BorderWidth="" BottomTableStyle-RightBorderStyle-BorderColor="" BottomTableStyle-BorderWidth="0px" BottomTableStyle-CellSpacing="0" BottomTableStyle-CellPadding="1" BottomTableStyle-TopBorderStyle-BorderStyle="Solid" BottomTableStyle-TopBorderStyle-BorderWidth="1px" BottomTableStyle-TopBorderStyle-BorderColor="Gray" BottomTableStyle-BottomBorderStyle-BorderWidth="" BottomTableStyle-BottomBorderStyle-BorderColor="" HeaderBarHeight="15pt" ActiveTabStyle-LeftBorderStyle-BorderWidth="" ActiveTabStyle-LeftBorderStyle-BorderColor="" ActiveTabStyle-RightBorderStyle-BorderWidth="" ActiveTabStyle-RightBorderStyle-BorderColor="" ActiveTabStyle-Height="15pt" ActiveTabStyle-BorderWidth="1px" ActiveTabStyle-Font-Size="10pt" ActiveTabStyle-BorderColor="Gray" ActiveTabStyle-ForeColor="Black" ActiveTabStyle-TopBorderStyle-BorderWidth="" ActiveTabStyle-TopBorderStyle-BorderColor="" ActiveTabStyle-BackColor="White" ActiveTabStyle-BottomBorderStyle-BorderWidth="" ActiveTabStyle-BottomBorderStyle-BorderColor="" HeaderBarTableStyle-LeftBorderStyle-BorderWidth="" HeaderBarTableStyle-LeftBorderStyle-BorderColor="" HeaderBarTableStyle-LayoutFixed="Fixed" HeaderBarTableStyle-RightBorderStyle-BorderWidth="" HeaderBarTableStyle-RightBorderStyle-BorderColor="" HeaderBarTableStyle-BorderWidth="0px" HeaderBarTableStyle-CellSpacing="0" HeaderBarTableStyle-BorderCollapse="Separate" HeaderBarTableStyle-CellPadding="0" HeaderBarTableStyle-TopBorderStyle-BorderWidth="" HeaderBarTableStyle-TopBorderStyle-BorderColor="" HeaderBarTableStyle-BottomBorderStyle-BorderWidth="" HeaderBarTableStyle-BottomBorderStyle-BorderColor="" TabStyle-LeftBorderStyle-BorderWidth="" TabStyle-LeftBorderStyle-BorderColor="" TabStyle-RightBorderStyle-BorderWidth="" TabStyle-RightBorderStyle-BorderColor="" TabStyle-Height="15pt" TabStyle-BorderWidth="1px" TabStyle-Font-Size="10pt" TabStyle-BorderColor="Gray" TabStyle-ForeColor="Black" TabStyle-TopBorderStyle-BorderWidth="" TabStyle-TopBorderStyle-BorderColor="" TabStyle-BackColor="#E0E0E0" TabStyle-BottomBorderStyle-BorderWidth="" TabStyle-BottomBorderStyle-BorderColor="" ScrollBarArrowColor=""></Aspose.Cells.GridWeb.ViewerStyleTemplate>

Example

[C#]
        GridWeb1.CustomStyleFileName = "c:\\style\\mystyle.xml";

    [Visual Basic]
        GridWeb1.CustomStyleFileName = "c:\\style\\mystyle.xml"

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


DefaultFontName Property

Aspose.Cells for .NET

MainWeb.DefaultFontName Property

Gets or sets the control's default font name.

public string DefaultFontName {get; set;}

Example

[C#]
        GridWeb1.DefaultFontName = "Arial";

    [Visual Basic]
        GridWeb1.DefaultFontName = "Arial"

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


DefaultFontSize Property

Aspose.Cells for .NET

MainWeb.DefaultFontSize Property

Gets or sets the control's default font size.

public FontUnit DefaultFontSize {get; set;}

Example

[C#]
        GridWeb1.DefaultFontSize = new System.Web.UI.WebControls.FontUnit("10pt");

    [Visual Basic]
        GridWeb1.DefaultFontSize = New System.Web.UI.WebControls.FontUnit("10pt")

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


DefaultGridLineColor Property

Aspose.Cells for .NET

MainWeb.DefaultGridLineColor Property

Gets or sets the default grid line's color.

public Color DefaultGridLineColor {get; set;}

Example

[C#]
        GridWeb1.DefaultGridLineColor = Color.Red;

    [Visual Basic]
        GridWeb1.DefaultGridLineColor = Color.Red

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


DisplayCellTip Property

Aspose.Cells for .NET

MainWeb.DisplayCellTip Property

public bool DisplayCellTip {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EditMode Property

Aspose.Cells for .NET

MainWeb.EditMode Property

Gets or sets the control's edit mode.

public bool EditMode {get; set;}

Remarks

When sets to true, the control's cells are editable, and the "save" and the "undo" icon are displayed. When sets to false, the control's cells are readonly, and the "save" and the "undo" icon are not displayed.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableAJAX Property

Aspose.Cells for .NET

MainWeb.EnableAJAX Property

public bool EnableAJAX {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableAsync Property

Aspose.Cells for .NET

MainWeb.EnableAsync Property

Gets or sets whether load cells data in asynchronous way,suggest to apply for one sheet with more than 10000 cells.

public bool EnableAsync {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableClientColumnOperations Property

Aspose.Cells for .NET

MainWeb.EnableClientColumnOperations Property

Gets or sets whether to enable the client side column operations.

public bool EnableClientColumnOperations {get; set;}

Remarks

When sets to true, the user can use the right-click menu to add/remove columns.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableClientFreeze Property

Aspose.Cells for .NET

MainWeb.EnableClientFreeze Property

Gets or sets whether to enable the client side freezing operations.

public bool EnableClientFreeze {get; set;}

Remarks

When sets to true, the user can use the right-click menu to freeze/unfreeze panes.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableClientMergeOperations Property

Aspose.Cells for .NET

MainWeb.EnableClientMergeOperations Property

Gets or sets whether to enable the client side merge operations.

public bool EnableClientMergeOperations {get; set;}

Remarks

When sets to true, the user can use the right-click menu to merge/unmerge cells.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableClientResizeColumnRow Property

Aspose.Cells for .NET

MainWeb.EnableClientResizeColumnRow Property

Gets or sets whether to enable the client side resize column and row.

public bool EnableClientResizeColumnRow {get; set;}

Remarks

When sets to true, the user can resize the column and row at client side.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableClientRowOperations Property

Aspose.Cells for .NET

MainWeb.EnableClientRowOperations Property

Gets or sets whether to enable the client side row operations.

public bool EnableClientRowOperations {get; set;}

Remarks

When sets to true, the user can use the right-click menu to add/remove rows.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableDoubleClickEvent Property

Aspose.Cells for .NET

MainWeb.EnableDoubleClickEvent Property

Gets or sets whether to enable customer side double-click event.

public bool EnableDoubleClickEvent {get; set;}

Remarks

When sets to true, the control will receive customer side double-click events and you may handle these events on the server side. Otherwise the control will ignore any double-click events.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableMetalLightEffect Property

Aspose.Cells for .NET

MainWeb.EnableMetalLightEffect Property

Gets or sets whether to apply metal light effect.

public bool EnableMetalLightEffect {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnablePaging Property

Aspose.Cells for .NET

MainWeb.EnablePaging Property

Gets or sets whether to enable the control's paging mode.

public bool EnablePaging {get; set;}

Remarks

When sets to true, the control will display PageSize rows of data once, and display the page select control in the tab bar.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


EnableStyleDialogbox Property

Aspose.Cells for .NET

MainWeb.EnableStyleDialogbox Property

Gets or sets whether to enable the client side style dialogbox.

public bool EnableStyleDialogbox {get; set;}

Remarks

When sets to true, the user can use the style dialogbox to set a cell's style by selecting the "Format Cell..." from the popup menu.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


FilteredPaging Property

Aspose.Cells for .NET

MainWeb.FilteredPaging Property

Gets or sets whether to enable the paging after data filtered,will take affect when EnablePaging is true.

public bool FilteredPaging {get; set;}

Remarks

When sets to true, the control will paging based on filtered data,the default value is false.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ForceValidation Property

Aspose.Cells for .NET

MainWeb.ForceValidation Property

Gets or sets whether to force customer side validation.

public bool ForceValidation {get; set;}

Remarks

When sets to true, data will not post to server until all input fields are valid.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


FrameTableStyle Property

Aspose.Cells for .NET

MainWeb.FrameTableStyle Property

Gets or sets the frame style of the control.

public GridTableStyle FrameTableStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


GoonDefaultSaveOperation Property

Aspose.Cells for .NET

MainWeb.GoonDefaultSaveOperation Property

Gets or sets whether GridWeb will do the default save operation ,the default value is true.

public bool GoonDefaultSaveOperation {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


HeaderBarHeight Property

Aspose.Cells for .NET

MainWeb.HeaderBarHeight Property

Gets or sets the height( System.Web.UI.WebControl.Unit ) of the top header bar of the control.

public Unit HeaderBarHeight {get; set;}

Example

[C#]
        GridWeb1.HeaderBarWidth = new System.Web.UI.WebControls.Unit(32, System.Web.UI.WebControls.UnitType.Point);
        GridWeb1.HeaderBarHeight = new System.Web.UI.WebControls.Unit(24, System.Web.UI.WebControls.UnitType.Point);

    [Visual Basic]
        GridWeb1.HeaderBarWidth = New System.Web.UI.WebControls.Unit(32, System.Web.UI.WebControls.UnitType.Point)
        GridWeb1.HeaderBarHeight = New System.Web.UI.WebControls.Unit(24, System.Web.UI.WebControls.UnitType.Point)

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


HeaderBarStyle Property

Aspose.Cells for .NET

MainWeb.HeaderBarStyle Property

Gets or sets the header bar's style.

public GridTableItemStyle HeaderBarStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


HeaderBarTableStyle Property

Aspose.Cells for .NET

MainWeb.HeaderBarTableStyle Property

Gets or sets the header bar style of the control.

public GridTableStyle HeaderBarTableStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


HeaderBarWidth Property

Aspose.Cells for .NET

MainWeb.HeaderBarWidth Property

Gets or sets the width( System.Web.UI.WebControl.Unit ) or the left header bar of the control.

public Unit HeaderBarWidth {get; set;}

Example

[C#]
        GridWeb1.HeaderBarWidth = new System.Web.UI.WebControls.Unit(32, System.Web.UI.WebControls.UnitType.Point);
        GridWeb1.HeaderBarHeight = new System.Web.UI.WebControls.Unit(24, System.Web.UI.WebControls.UnitType.Point);

    [Visual Basic]
        GridWeb1.HeaderBarWidth = New System.Web.UI.WebControls.Unit(32, System.Web.UI.WebControls.UnitType.Point)
        GridWeb1.HeaderBarHeight = New System.Web.UI.WebControls.Unit(24, System.Web.UI.WebControls.UnitType.Point)

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


Height Property

Aspose.Cells for .NET

MainWeb.Height Property

Gets or sets the height( System.Web.UI.WebControl.Unit ) of the control.

public override Unit Height {get; set;}

Example

[C#]
        GridWeb1.Width = new System.Web.UI.WebControls.Unit(320, System.Web.UI.WebControls.UnitType.Point);
        GridWeb1.Height = new System.Web.UI.WebControls.Unit(240, System.Web.UI.WebControls.UnitType.Point);

    [Visual Basic]
        GridWeb1.Width = New System.Web.UI.WebControls.Unit(320, System.Web.UI.WebControls.UnitType.Point)
        GridWeb1.Height = New System.Web.UI.WebControls.Unit(240, System.Web.UI.WebControls.UnitType.Point)

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


IsPostBack Property

Aspose.Cells for .NET

MainWeb.IsPostBack Property

Gets a value indicating whether gridweb is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.

public bool IsPostBack {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


LinksTable Property

Aspose.Cells for .NET

MainWeb.LinksTable Property

public Hashtable LinksTable {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MaxColumn Property

Aspose.Cells for .NET

MainWeb.MaxColumn Property

Gets or sets the maximum display column index(zero based) of the web sheet. The control uses the greater value of MaxColumn and sheet data's max column.

public int MaxColumn {get; set;}

Example

[C#]
        // Creates a 4x4 "display window".
        GridWeb1.MinRow = 2;
        GridWeb1.MaxRow = 5;
        GridWeb1.MinColumn = 3;
        GridWeb1.MaxColumn = 6;

    [Visual Basic]
        ' Creates a 4x4 "display window".
        GridWeb1.MinRow = 2
        GridWeb1.MaxRow = 5
        GridWeb1.MinColumn = 3
        GridWeb1.MaxColumn = 6

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MaxRow Property

Aspose.Cells for .NET

MainWeb.MaxRow Property

Gets or sets the maximum display row index(zero based) of the web sheet. The control uses the greater value of MaxRow and sheet data's max row.

public int MaxRow {get; set;}

Example

[C#]
        // Creates a 4x4 "display window".
        GridWeb1.MinRow = 2;
        GridWeb1.MaxRow = 5;
        GridWeb1.MinColumn = 3;
        GridWeb1.MaxColumn = 6;

    [Visual Basic]
        ' Creates a 4x4 "display window".
        GridWeb1.MinRow = 2
        GridWeb1.MaxRow = 5
        GridWeb1.MinColumn = 3
        GridWeb1.MaxColumn = 6

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


Message Property

Aspose.Cells for .NET

MainWeb.Message Property

public string Message {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MinColumn Property

Aspose.Cells for .NET

MainWeb.MinColumn Property

public int MinColumn {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MinRow Property

Aspose.Cells for .NET

MainWeb.MinRow Property

Gets or sets the minimum display row index(zero based) of the web sheet. The control uses the smaller value of MinRow and sheet data's min row.

public int MinRow {get; set;}

Example

[C#]
        // Creates a 4x4 "display window".
        GridWeb1.MinRow = 2;
        GridWeb1.MaxRow = 5;
        GridWeb1.MinColumn = 3;
        GridWeb1.MaxColumn = 6;

    [Visual Basic]
        ' Creates a 4x4 "display window".
        GridWeb1.MinRow = 2
        GridWeb1.MaxRow = 5
        GridWeb1.MinColumn = 3
        GridWeb1.MaxColumn = 6

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ModifiedCells Property

Aspose.Cells for .NET

MainWeb.ModifiedCells Property

Gets the collection of the cells that modified by the client.

public ArrayList ModifiedCells {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


NeedRenderGroupRows Property

Aspose.Cells for .NET

MainWeb.NeedRenderGroupRows Property

Gets or sets whether to show grouprows .

public bool NeedRenderGroupRows {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


NoHScroll Property

Aspose.Cells for .NET

MainWeb.NoHScroll Property

Gets or sets a value indicating whether the horizontal scroll bar is hidden.

public bool NoHScroll {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


NoScroll Property

Aspose.Cells for .NET

MainWeb.NoScroll Property

public bool NoScroll {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


NoVScroll Property

Aspose.Cells for .NET

MainWeb.NoVScroll Property

Gets or sets a value indicating whether the vertical scroll bar is hidden.

public bool NoVScroll {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnAjaxCallFinishedClientFunction Property

Aspose.Cells for .NET

MainWeb.OnAjaxCallFinishedClientFunction Property

Gets or sets the client side function name to be called when ajaxcall finished. The client function should be declared like this:
function GridAjaxcallFinished()
{
alert(this.id+" ajaxcall finished ");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnAjaxCallFinishedClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnCellErrorClientFunction Property

Aspose.Cells for .NET

MainWeb.OnCellErrorClientFunction Property

Gets or sets the client side function name to be called when a cell's validation is failed. The client function should be declared like this:
function MyOnCellError(cell)
{
alert(GridWeb1.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnCellErrorClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnCellSelectedAjaxCallBackClientFunction Property

Aspose.Cells for .NET

MainWeb.OnCellSelectedAjaxCallBackClientFunction Property

Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCellAjaxCallBack(cell,customerdata)
{

}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnCellSelectedAjaxCallBackClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnCellSelectedClientFunction Property

Aspose.Cells for .NET

MainWeb.OnCellSelectedClientFunction Property

Gets or sets the client side function to be called when a cell is selected. The client function should be declared like this:
function MyOnSelectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnCellSelectedClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnCellUnselectedClientFunction Property

Aspose.Cells for .NET

MainWeb.OnCellUnselectedClientFunction Property

Gets or sets the client side function to be called when a cell is unselected. The client function should be declared like this:
function MyOnUnselectCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnCellUnselectedClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnCellUpdatedClientFunction Property

Aspose.Cells for .NET

MainWeb.OnCellUpdatedClientFunction Property

Gets or sets the client side function name to be called when a cell's value is updated. The client function should be declared like this:
function MyOnCellUpdated(cell)
{
alert(this.getCellValueByCell(cell));
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnCellUpdatedClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnContextMenuShowClientFunction Property

Aspose.Cells for .NET

MainWeb.OnContextMenuShowClientFunction Property

Gets or sets the client side function to be called when the context menu will be shown. The client function should be declared like this:
function onContextMenuShow()
{
var menu = event.srcElement;
menu.setItemVisibility("Delete", "block");
menu.setItemVisibility("Update", "none");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnContextMenuShowClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnDoubleClickCellClientFunction Property

Aspose.Cells for .NET

MainWeb.OnDoubleClickCellClientFunction Property

Gets or sets the client side function to be called when a cell is double clicked. The client function should be declared like this:
function MyOnDoubleClickCell(cell)
{
GridWeb1.setCellValueByCell(cell, "test");
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnDoubleClickCellClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnDoubleClickRowClientFunction Property

Aspose.Cells for .NET

MainWeb.OnDoubleClickRowClientFunction Property

Gets or sets the client side function to be called when a row is double clicked. The client function should be declared like this:
function MyOnRowDoubleClick(row)
{
alert(row);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnDoubleClickRowClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnGridInitClientFunction Property

Aspose.Cells for .NET

MainWeb.OnGridInitClientFunction Property

Gets or sets the client side function name to be called when the grid is initialized. The client function should be declared like this:
function MyOnGridInit(grid)
{
alert("The grid is initialized: " + grid.id);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnGridInitClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnPageChangeClientFunction Property

Aspose.Cells for .NET

MainWeb.OnPageChangeClientFunction Property

Gets or sets the client side function to be called after page index changing.only take effect when EnablePaging is true. The client function should be declared like this:
function MyOnPageChange(index)
{
console.log("current page is:"+index);
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnPageChangeClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnPageSubmitClientFunction Property

Aspose.Cells for .NET

MainWeb.OnPageSubmitClientFunction Property

Gets or sets the client function to be called before the page is submitted at client side.

public string OnPageSubmitClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnShapeSelectedClientFunction Property

Aspose.Cells for .NET

MainWeb.OnShapeSelectedClientFunction Property

Gets or sets the client side function to be called when a shape is selected. The client function should be declared like this:
function MyOnSelectShape(shape)
{
var name=shape.getAttribute("namevalue")
var text=shape.getAttribute("textvalue")
var value=shape.getAttribute("controlvalue")
var type=shape.getAttribute("msotype")
}

Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnShapeSelectedClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


OnSubmitClientFunction Property

Aspose.Cells for .NET

MainWeb.OnSubmitClientFunction Property

Gets or sets the client function to be called before the control is submitted at client side. The client function should be declared like this:
function MyOnSubmit(arg, cancelEdit)
{
return true;
}
The arg is the submit argument, contains the command to be post to the server. The cancelEdit is boolean value indicates whether the control has discarded the user input before submit. The control will continue submitting if the function returns true.
Note: You may use the "this" pointer in the client function to point the grid control which fires the event.

public string OnSubmitClientFunction {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


PageSize Property

Aspose.Cells for .NET

MainWeb.PageSize Property

Gets or sets the page size in paging mode.

public int PageSize {get; set;}

Remarks

When in paging mode, the control will display PageSize rows of data once, and display the page select control in the tab bar.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


PictureCachePath Property

Aspose.Cells for .NET

MainWeb.PictureCachePath Property

Gets or sets the image storage path for the workbook,all the shapes,images will be stored in this directory, the default path is acwcache under current application Base Directory users need to implement a schedule service to clean the files those are out of session time.

public string PictureCachePath {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


PicturesTable Property

Aspose.Cells for .NET

MainWeb.PicturesTable Property

public Hashtable PicturesTable {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


PresetStyle Property

Aspose.Cells for .NET

MainWeb.PresetStyle Property

Gets or sets the preset style.

public PresetStyle PresetStyle {get; set;}

Example

[C#]
        GridWeb1.PresetStyle = PresetStyle.Traditional1;

    [Visual Basic]
        GridWeb1.PresetStyle = PresetStyle.Traditional1

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


RenderHiddenRow Property

Aspose.Cells for .NET

MainWeb.RenderHiddenRow Property

Gets or sets whether the hidden row is rendered in GridControl,the default value is false. if you need to unhide the hidden row latter ,you shall set it as true

public bool RenderHiddenRow {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ScrollBarArrowColor Property

Aspose.Cells for .NET

MainWeb.ScrollBarArrowColor Property

Specifies the color of the scrollbar's arrow button.

public Color ScrollBarArrowColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ScrollBarBaseColor Property

Aspose.Cells for .NET

MainWeb.ScrollBarBaseColor Property

Specifies the color of the scroll bar of the control.

public Color ScrollBarBaseColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SelectCellBgColor Property

Aspose.Cells for .NET

MainWeb.SelectCellBgColor Property

Specifies the background color of the selected cells in multi-select range.

public Color SelectCellBgColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SelectCellColor Property

Aspose.Cells for .NET

MainWeb.SelectCellColor Property

Specifies the color of the selected cells in multi-select range.

public Color SelectCellColor {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SessionLoaded Property

Aspose.Cells for .NET

MainWeb.SessionLoaded Property

public bool SessionLoaded {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SessionMode Property

Aspose.Cells for .NET

MainWeb.SessionMode Property

Gets or sets the session mode of the grid. There are 3 type of session mode:
1. Session(default): Use system session to store sheet data.
Generally the asp.net uses InProc session state. The grid also supports "StateServer" out process session state and SQLServer session state.
2. ViewState: Use page's viewstate to store sheet data.
3. Custom: Use LoadCustomData and SheetDataUpdated events to store/recover sheet data.

public SessionMode SessionMode {get; set;}

Remarks

When using SessionMode.ViewState, the grid will store sheets data in the page's view state. This will decrease the server's memory usage, but the page's size will be larger and it will impact the overall performance.

Example

[C#]
    GridWeb1.SessionMode = SessionMode.ViewState;

[Visual Basic]
    GridWeb1.SessionMode = SessionMode.ViewState

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SessionSaved Property

Aspose.Cells for .NET

MainWeb.SessionSaved Property

public bool SessionSaved {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SessionStorePath Property

Aspose.Cells for .NET

MainWeb.SessionStorePath Property

Gets or sets the session store path when session mode is File, etc: gridweb.SessionStorePath="c:/mytempdir/session"; then it will store session data in c:/mytempdir/session

public string SessionStorePath {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShapesTable Property

Aspose.Cells for .NET

MainWeb.ShapesTable Property

public Hashtable ShapesTable {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowAddButton Property

Aspose.Cells for .NET

MainWeb.ShowAddButton Property

Gets or sets whether to show the add worksheet button.

public bool ShowAddButton {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowBottomBar Property

Aspose.Cells for .NET

MainWeb.ShowBottomBar Property

public bool ShowBottomBar {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowCellEditBox Property

Aspose.Cells for .NET

MainWeb.ShowCellEditBox Property

whether Gridweb shows edit box toolbar as in MS-EXCEL.if enable ,a edit box for current cell will display in Gridweb. if we enable this feature, we need to import jquery js library in your aspx files to support this new feature. all the latest jquery version is ok. etc.

public bool ShowCellEditBox {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowCommandBarAtTop Property

Aspose.Cells for .NET

MainWeb.ShowCommandBarAtTop Property

Specifies whether to show the command bar(includes command bar and tab bar) at the top of the control.

public bool ShowCommandBarAtTop {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowContextMenu Property

Aspose.Cells for .NET

MainWeb.ShowContextMenu Property

public bool ShowContextMenu {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowDefaultGridLine Property

Aspose.Cells for .NET

MainWeb.ShowDefaultGridLine Property

Gets or sets whether to show the default grid lines of the cells.

public bool ShowDefaultGridLine {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowHeaderBar Property

Aspose.Cells for .NET

MainWeb.ShowHeaderBar Property

public bool ShowHeaderBar {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowLoading Property

Aspose.Cells for .NET

MainWeb.ShowLoading Property

Specifies whether to show a loading dialogbox while postbacking to server.

public bool ShowLoading {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowLoadingPosition Property

Aspose.Cells for .NET

MainWeb.ShowLoadingPosition Property

Specifies the left,top postion(in px) to show the loading dialogbox while postbacking to server ,etc. 100,200 means the loading dialogbox's left,top postion is at 100px,200px .

public string ShowLoadingPosition {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowSaveButton Property

Aspose.Cells for .NET

MainWeb.ShowSaveButton Property

Gets or sets whether to show the save button.

public bool ShowSaveButton {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowSubmitButton Property

Aspose.Cells for .NET

MainWeb.ShowSubmitButton Property

Gets or sets whether to show the submit button.

public bool ShowSubmitButton {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowTabBar Property

Aspose.Cells for .NET

MainWeb.ShowTabBar Property

public bool ShowTabBar {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowTabNavigation Property

Aspose.Cells for .NET

MainWeb.ShowTabNavigation Property

Gets or sets whether the tab navigation button is show,the default value is true.

public bool ShowTabNavigation {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ShowUndoButton Property

Aspose.Cells for .NET

MainWeb.ShowUndoButton Property

Gets or sets whether to show the undo button.

public bool ShowUndoButton {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SpanWrap Property

Aspose.Cells for .NET

MainWeb.SpanWrap Property

Specifies whether to wrap content in the cell span.

public bool SpanWrap {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


TabStyle Property

Aspose.Cells for .NET

MainWeb.TabStyle Property

Gets or sets the style of the tab bar.

public GridTableItemStyle TabStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


UseClientPageHeight Property

Aspose.Cells for .NET

MainWeb.UseClientPageHeight Property

Gets or sets whether gridweb use client page height as control height ,suitable for when set Height="100%",default value is false

public bool UseClientPageHeight {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ValidationsTable Property

Aspose.Cells for .NET

MainWeb.ValidationsTable Property

public Hashtable ValidationsTable {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ViewPanelScrollLeft Property

Aspose.Cells for .NET

MainWeb.ViewPanelScrollLeft Property

Gets or sets the position of the scroll bar of the grid's view panel.

public string ViewPanelScrollLeft {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ViewPanelScrollTop Property

Aspose.Cells for .NET

MainWeb.ViewPanelScrollTop Property

Gets or sets the position of the scroll bar of the grid's view panel.

public string ViewPanelScrollTop {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ViewTableStyle Property

Aspose.Cells for .NET

MainWeb.ViewTableStyle Property

Gets or sets the data view panel's style.

public GridTableStyle ViewTableStyle {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


WebWorksheets Property

Aspose.Cells for .NET

MainWeb.WebWorksheets Property

public WebWorksheets WebWorksheets {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


Width Property

Aspose.Cells for .NET

MainWeb.Width Property

Gets or sets the width( System.Web.UI.WebControl.Unit ) of the control.

public override Unit Width {get; set;}

Example

[C#]
        GridWeb1.Width = new System.Web.UI.WebControls.Unit(320, System.Web.UI.WebControls.UnitType.Point);
        GridWeb1.Height = new System.Web.UI.WebControls.Unit(240, System.Web.UI.WebControls.UnitType.Point);

    [Visual Basic]
        GridWeb1.Width = New System.Web.UI.WebControls.Unit(320, System.Web.UI.WebControls.UnitType.Point)
        GridWeb1.Height = New System.Web.UI.WebControls.Unit(240, System.Web.UI.WebControls.UnitType.Point)

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


WorkSheets Property

Aspose.Cells for .NET

MainWeb.WorkSheets Property

public GridWorksheetCollection WorkSheets {get;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


XhtmlMode Property

Aspose.Cells for .NET

MainWeb.XhtmlMode Property

public bool XhtmlMode {get; set;}

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb Methods

The methods of the MainWeb class are listed below. For a complete list of MainWeb class members, see the MainWeb Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ApplyStyleSheetSkin (inherited from Control) |
CalculateFormula | Calculates the result of formulas.
CopyBaseAttributes (inherited from WebControl) |
DataBind | Bind the control and all its child contorls to the its datasource.
Dispose |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
ImportExcelFile | Overloaded. Imports from an excel file.
LoadCSVFile | Overloaded. Loads data from a CSV file.
LoadHTMLFile | Overloaded. Loads data from a HTML file.
LoadSpreadSheetMLFile | Overloaded. Loads data from a SpreadSheetML file.
MergeStyle (inherited from WebControl) |
RefreshChartShape | refresh all the chart image for the active worksheet .
RenderBeginTag |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SaveCSVFile | Overloaded. Saves data to a CSV file.
SaveCustomStyleFile | Saves current style data of the control to an xml file. Can be used to create your customized style file.
SaveHTMLFile | Overloaded. Saves data to a HTML file.
SaveSpreadSheetMLFile | Overloaded. Saves data to a SpreadSheetML file.
SaveToExcelFile | Overloaded. Saves the worksheets to an excel file with Excel 2003 format.
SetCustomStyle | sets the custom style file from stream including disk file stream or memory stream.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CalculateFormula Method

Calculates the result of formulas.

public void CalculateFormula();

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.DataBind Method

Bind the control and all its child contorls to the its datasource.

public override void DataBind();

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.Dispose Method

public override void Dispose();

Implements

IDisposable.Dispose

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


ImportExcelFile Method

Aspose.Cells for .NET

MainWeb.ImportExcelFile Method

Imports from an excel file stream, including disk file stream or memory stream.

Overload List

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(Stream);

Imports from an excel file.

public void ImportExcelFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.ImportExcelFile Method (Stream)

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(
Stream stream
);

Parameters

stream
The excel file's stream, including disk file stream or memory stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.ImportExcelFile Overload List


MainWeb.ImportExcelFile Method (String)

Imports from an excel file.

public void ImportExcelFile(
string fileName
);

Parameters

fileName
The excel file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.ImportExcelFile Overload List


LoadCSVFile Method

Aspose.Cells for .NET

MainWeb.LoadCSVFile Method

Loads data from a CSV file stream.

Overload List

Loads data from a CSV file stream.

public void LoadCSVFile(Stream);

Loads data from a CSV file.

public void LoadCSVFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.LoadCSVFile Method (Stream)

Loads data from a CSV file stream.

public void LoadCSVFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.LoadCSVFile Overload List


MainWeb.LoadCSVFile Method (String)

Loads data from a CSV file.

public void LoadCSVFile(
string fileName
);

Parameters

fileName
The file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.LoadCSVFile Overload List


LoadHTMLFile Method

Aspose.Cells for .NET

MainWeb.LoadHTMLFile Method

Loads data from a HTML file stream.

Overload List

Loads data from a HTML file stream.

public void LoadHTMLFile(Stream);

Loads data from a HTML file.

public void LoadHTMLFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.LoadHTMLFile Method (Stream)

Loads data from a HTML file stream.

public void LoadHTMLFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.LoadHTMLFile Overload List


MainWeb.LoadHTMLFile Method (String)

Loads data from a HTML file.

public void LoadHTMLFile(
string fileName
);

Parameters

fileName
The file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.LoadHTMLFile Overload List


LoadSpreadSheetMLFile Method

Aspose.Cells for .NET

MainWeb.LoadSpreadSheetMLFile Method

Loads data from a SpreadSheetML file stream.

Overload List

Loads data from a SpreadSheetML file stream.

public void LoadSpreadSheetMLFile(Stream);

Loads data from a SpreadSheetML file.

public void LoadSpreadSheetMLFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.LoadSpreadSheetMLFile Method (Stream)

Loads data from a SpreadSheetML file stream.

public void LoadSpreadSheetMLFile(
Stream stream
);

Parameters

stream
The file's stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.LoadSpreadSheetMLFile Overload List


MainWeb.LoadSpreadSheetMLFile Method (String)

Loads data from a SpreadSheetML file.

public void LoadSpreadSheetMLFile(
string fileName
);

Parameters

fileName
The file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.LoadSpreadSheetMLFile Overload List


MainWeb.RefreshChartShape Method

refresh all the chart image for the active worksheet .

public void RefreshChartShape();

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.RenderBeginTag Method

public override void RenderBeginTag(
HtmlTextWriter writer
);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SaveCSVFile Method

Aspose.Cells for .NET

MainWeb.SaveCSVFile Method

Saves data to a CSV file stream.

Overload List

Saves data to a CSV file stream.

public void SaveCSVFile(Stream);

Saves data to a CSV file.

public void SaveCSVFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SaveCSVFile Method (Stream)

Saves data to a CSV file stream.

public void SaveCSVFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveCSVFile Overload List


MainWeb.SaveCSVFile Method (String)

Saves data to a CSV file.

public void SaveCSVFile(
string targetFile
);

Parameters

targetFile
The file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveCSVFile Overload List


MainWeb.SaveCustomStyleFile Method

Saves current style data of the control to an xml file. Can be used to create your customized style file.

public void SaveCustomStyleFile(
string fileName
);

Parameters

fileName
The style file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


SaveHTMLFile Method

Aspose.Cells for .NET

MainWeb.SaveHTMLFile Method

Saves data to a HTML file stream.

Overload List

Saves data to a HTML file stream.

public void SaveHTMLFile(Stream);

Saves data to a HTML file.

public void SaveHTMLFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SaveHTMLFile Method (Stream)

Saves data to a HTML file stream.

public void SaveHTMLFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveHTMLFile Overload List


MainWeb.SaveHTMLFile Method (String)

Saves data to a HTML file.

public void SaveHTMLFile(
string targetFile
);

Parameters

targetFile
The file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveHTMLFile Overload List


SaveSpreadSheetMLFile Method

Aspose.Cells for .NET

MainWeb.SaveSpreadSheetMLFile Method

Saves data to a SpreadSheetML file stream.

Overload List

Saves data to a SpreadSheetML file stream.

public void SaveSpreadSheetMLFile(Stream);

Saves data to a SpreadSheetML file.

public void SaveSpreadSheetMLFile(string);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SaveSpreadSheetMLFile Method (Stream)

Saves data to a SpreadSheetML file stream.

public void SaveSpreadSheetMLFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveSpreadSheetMLFile Overload List


MainWeb.SaveSpreadSheetMLFile Method (String)

Saves data to a SpreadSheetML file.

public void SaveSpreadSheetMLFile(
string targetFile
);

Parameters

targetFile
The file's name.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveSpreadSheetMLFile Overload List


SaveToExcelFile Method

Aspose.Cells for .NET

MainWeb.SaveToExcelFile Method

Saves the worksheets to an excel file.

Overload List

Saves the worksheets to an excel file.

public void SaveToExcelFile(Stream);

Saves the worksheets to an excel file.

public void SaveToExcelFile(Stream,GridSaveFormat);

Saves the worksheets to an excel file.

public void SaveToExcelFile(Stream,GridSaveOptions);

Saves the worksheets to an excel file with Excel 2003 format.

public void SaveToExcelFile(string);

Saves the worksheets to an excel file.

public void SaveToExcelFile(string,GridSaveFormat);

Saves the worksheets to an excel file.

public void SaveToExcelFile(string,GridSaveOptions);

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SaveToExcelFile Method (Stream)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
Stream stream
);

Parameters

stream
The stream to write to.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveToExcelFile Overload List


MainWeb.SaveToExcelFile Method (Stream, GridSaveFormat)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
Stream stream,
GridSaveFormat format
);

Parameters

stream
The stream to write to.
format
The file format(Excel2003, Excel2007, CSV, SpreadsheetML)

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveToExcelFile Overload List


MainWeb.SaveToExcelFile Method (Stream, GridSaveOptions)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
Stream stream,
GridSaveOptions saveOptions
);

Parameters

stream
The stream to write to.
saveOptions
The save options.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveToExcelFile Overload List


MainWeb.SaveToExcelFile Method (String)

Saves the worksheets to an excel file with Excel 2003 format.

public void SaveToExcelFile(
string targetFile
);

Parameters

targetFile
The name of the target file to write to.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveToExcelFile Overload List


MainWeb.SaveToExcelFile Method (String, GridSaveFormat)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
string targetFile,
GridSaveFormat format
);

Parameters

targetFile
The name of the target file to write to.
format
The file format(Excel2003, Excel2007, CSV, SpreadsheetML)

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveToExcelFile Overload List


MainWeb.SaveToExcelFile Method (String, GridSaveOptions)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
string targetFile,
GridSaveOptions saveOptions
);

Parameters

targetFile
The name of the target file to write to.
saveOptions
The save options.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace | MainWeb.SaveToExcelFile Overload List


MainWeb.SetCustomStyle Method

sets the custom style file from stream including disk file stream or memory stream.

public void SetCustomStyle(
Stream stream
);

Parameters

stream
The file's stream, including disk file stream or memory stream.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb Events

The events of the MainWeb class are listed below. For a complete list of MainWeb class members, see the MainWeb Members topic.

Public Instance Events

AfterColumnFilter | Occurs after the column filtered.
AjaxCallFinished | Fires when the ajax update of the control finished.(the EnableAJAX shall be set to true)
BeforeColumnFilter | Occurs before the column to be filtered.
CellClickOnAjax | Occurs when the cell is clicked,and need to do ajaxcallback for this event.
CellClientUpdate | Occurs when a client cell update happen . When this event is fired, its parameter e.Argument contains the command's name.
CellCommand | Occurs when a cell's command hyperlink is clicked. When this event is fired, its parameter e.Argument contains the command's name.
CellDoubleClick | Occurs when the cell is double-clicked.
CellError | Occurs when a cell's input value error.
CellModifiedOnAjax | Occurs when the cell is modified in ajaxcall.
ColumnDeleted | Occurs when user delete a column from client-side menu.
ColumnDeleting | Occurs when user is trying to delete a column from the client-side menu. You may handle this event and set the cancel parameter to True to cancel a deleting operation.
ColumnDoubleClick | Occurs when the column header is double-clicked.
ColumnInserted | Occurs when user insert a column from client-side menu.
CustomCommand | Occurs when user clicks a custom command button.
DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
LoadCustomData | Fires when the control's SessionMode is set to Custom and needs to load sheet data. You may handle this event in Custom Session mode to load sheet data from file or database.
PageIndexChanged | Occurs when the control's sheet page index changed.
PreRender (inherited from Control) |
RowDeleted | Occurs when user has deleted a row from client-side menu.
RowDeleting | Occurs when user is trying to delete a row from the client-side menu. You may handle this event and throw a RejectDeleteException exception to cancel a deleting operation.
RowDoubleClick | Occurs when the row header is double-clicked.
RowInserted | Occurs when user insert a row from client-side menu.
SaveCommand | Occurs when the "save" button is clicked.
SheetAdded | Occurs when user add a worksheet from toolbar menu.
SheetDataUpdated | Occurs when the control has loaded the posted data and updated the sheet data.
SheetTabClick | Occurs when the sheet tab is clicked.
SubmitCommand | Occurs when the "submit" button is clicked.
UndoCommand | Occurs when the "undo" button is clicked.
Unload (inherited from Control) |

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.AfterColumnFilter Event

Occurs after the column filtered.

public event RowColumnEventHandler AfterColumnFilter;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.AjaxCallFinished Event

Fires when the ajax update of the control finished.(the EnableAJAX shall be set to true)

public event WorkbookEventHandler AjaxCallFinished;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.BeforeColumnFilter Event

Occurs before the column to be filtered.

public event RowColumnEventHandler BeforeColumnFilter;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CellClickOnAjax Event

Occurs when the cell is clicked,and need to do ajaxcallback for this event.

public event CellEventStringHandler CellClickOnAjax;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CellClientUpdate Event

Occurs when a client cell update happen . When this event is fired, its parameter e.Argument contains the command's name.

public event CellEventHandler CellClientUpdate;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CellCommand Event

Occurs when a cell's command hyperlink is clicked. When this event is fired, its parameter e.Argument contains the command's name.

public event CellEventHandler CellCommand;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CellDoubleClick Event

Occurs when the cell is double-clicked.

public event CellEventHandler CellDoubleClick;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CellError Event

Occurs when a cell's input value error.

public event CellErrorHandler CellError;

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CellModifiedOnAjax Event

Occurs when the cell is modified in ajaxcall.

public event CellEventHandler CellModifiedOnAjax;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.ColumnDeleted Event

Occurs when user delete a column from client-side menu.

public event RowColumnEventHandler ColumnDeleted;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.ColumnDeleting Event

Occurs when user is trying to delete a column from the client-side menu. You may handle this event and set the cancel parameter to True to cancel a deleting operation.

public event RowColumnEventHandler ColumnDeleting;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.ColumnDoubleClick Event

Occurs when the column header is double-clicked.

public event RowColumnEventHandler ColumnDoubleClick;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.ColumnInserted Event

Occurs when user insert a column from client-side menu.

public event RowColumnEventHandler ColumnInserted;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.CustomCommand Event

Occurs when user clicks a custom command button.

public event CustomCommandEventHandler CustomCommand;

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.LoadCustomData Event

Fires when the control's SessionMode is set to Custom and needs to load sheet data. You may handle this event in Custom Session mode to load sheet data from file or database.

public event WorkbookEventHandler LoadCustomData;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.PageIndexChanged Event

Occurs when the control's sheet page index changed.

public event WorkbookEventHandler PageIndexChanged;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.RowDeleted Event

Occurs when user has deleted a row from client-side menu.

public event RowColumnEventHandler RowDeleted;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.RowDeleting Event

Occurs when user is trying to delete a row from the client-side menu. You may handle this event and throw a RejectDeleteException exception to cancel a deleting operation.

public event RowColumnEventHandler RowDeleting;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.RowDoubleClick Event

Occurs when the row header is double-clicked.

public event RowColumnEventHandler RowDoubleClick;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.RowInserted Event

Occurs when user insert a row from client-side menu.

public event RowColumnEventHandler RowInserted;

Event Data

The event handler receives an argument of type RowColumnEventArgs containing data related to this event. The following RowColumnEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SaveCommand Event

Occurs when the "save" button is clicked.

public event WorkbookEventHandler SaveCommand;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SheetAdded Event

Occurs when user add a worksheet from toolbar menu.

public event SheetEventHandler SheetAdded;

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SheetDataUpdated Event

Occurs when the control has loaded the posted data and updated the sheet data.

public event WorkbookEventHandler SheetDataUpdated;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SheetTabClick Event

Occurs when the sheet tab is clicked.

public event WorkbookEventHandler SheetTabClick;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.SubmitCommand Event

Occurs when the "submit" button is clicked.

public event WorkbookEventHandler SubmitCommand;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


MainWeb.UndoCommand Event

Occurs when the "undo" button is clicked.

public event WorkbookEventHandler UndoCommand;

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Argument | The argument of the event.
Cell | The cell.

See Also

MainWeb Class | Aspose.Cells.GridWeb Namespace


PresetStyle Enumeration

Represents the preset style or an GridWeb control. By far, we provide 7 preset styles.

public enum PresetStyle

Members

Member Name | Description | Value
Standard | Standard style, silver | 0
Colorful1 | Rose | 1
Colorful2 | Blue | 2
Professional1 | Cyan | 3
Professional2 | Cyan again | 4
Traditional1 | Dark | 5
Traditional2 | Gray | 6
Custom | Use your customized style | 7

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


RowColumnEventArgs Class

Provides data for row/column events.

For a list of all members of this type, see RowColumnEventArgs Members.

System.Object
System.EventArgs
Aspose.Cells.GridWeb.RowColumnEventArgs

public class RowColumnEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

RowColumnEventArgs Members | Aspose.Cells.GridWeb Namespace


RowColumnEventArgs Members

RowColumnEventArgs overview

Public Instance Properties

Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RejectOperation | Call this method in RowDeleting/ColumnDeleting event handlers to cancel the deleting operations.
ToString (inherited from Object) |

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


RowColumnEventArgs Properties

The properties of the RowColumnEventArgs class are listed below. For a complete list of RowColumnEventArgs class members, see the RowColumnEventArgs Members topic.

Public Instance Properties

Argument | The argument of the event.
IsCancel | shall we cancel the operation.
Num | The row or column number, starts from zero.
Type | The row or column type.

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


Argument Property

Aspose.Cells for .NET

RowColumnEventArgs.Argument Property

The argument of the event.

public object Argument {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


IsCancel Property

Aspose.Cells for .NET

RowColumnEventArgs.IsCancel Property

shall we cancel the operation.

public bool IsCancel {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


Num Property

Aspose.Cells for .NET

RowColumnEventArgs.Num Property

The row or column number, starts from zero.

public int Num {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


Type Property

Aspose.Cells for .NET

RowColumnEventArgs.Type Property

The row or column type.

public RowColumnType Type {get;}

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


RowColumnEventArgs Methods

The methods of the RowColumnEventArgs class are listed below. For a complete list of RowColumnEventArgs class members, see the RowColumnEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RejectOperation | Call this method in RowDeleting/ColumnDeleting event handlers to cancel the deleting operations.
ToString (inherited from Object) |

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


RowColumnEventArgs.RejectOperation Method

Call this method in RowDeleting/ColumnDeleting event handlers to cancel the deleting operations.

public void RejectOperation();

See Also

RowColumnEventArgs Class | Aspose.Cells.GridWeb Namespace


RowColumnType Enumeration

Represents the row/column type of the row/column events.

public enum RowColumnType

Members

Member Name | Description | Value
Row | Row type. | 0
Column | Column type. | 1

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


SessionMode Enumeration

Represents the session mode of the grid.

public enum SessionMode

Members

Member Name | Description | Value
Session | Uses the system session to store/recover the grid's sheet data automatically. | 0
ViewState | Uses the page's viewstate to store/recover the grid's sheet data automatically. | 1
Custom | Uses the LoadCustomData event to load the grid's sheet data manually. And uses the SheetDataUpdated event to save the grid's sheet data. | 2
File | Uses the system file to store/recover the grid's sheet data automatically,user need to set SessionStorePath to specify the file directory. | 3

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


SetBorderPosition Enumeration

Represents the border position to be set of a cells range.

public enum SetBorderPosition

Example

[C#]
    GridWeb1.WebWorksheets[0].Cells.SetBorders(0, 0, 5, 8, SetBorderPosition.Outline, borderStyle1);

[VB]
    GridWeb1.WebWorksheets(0).Cells.SetBorders(0, 0, 5, 8, SetBorderPosition.Outline, borderStyle1)

Members

Member Name | Description | Value
Top | Top border | 0
Bottom | Bottom border | 1
Left | Left border | 2
Right | Right border | 3
HorizontalMiddle | Bottom border | 4
VerticalMiddle | HorizontalMiddle borders | 5
Outline | VerticalMiddle borders | 6
Cross | Cross borders | 7
None | No borders | 8

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


TableItemStyle Class

NOTE: This class is now obsolete.

This class is obsolete; use GridTableItemStyle instead

For a list of all members of this type, see TableItemStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
System.Web.UI.WebControls.TableItemStyle
Aspose.Cells.GridWeb.GridTableItemStyle
Aspose.Cells.GridWeb.TableItemStyle

public class TableItemStyle : GridTableItemStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridTableItemStyle Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

TableItemStyle Members | Aspose.Cells.GridWeb Namespace


TableItemStyle Members

TableItemStyle overview

Public Instance Constructors

TableItemStyle Constructor Initializes a new instance of the TableItemStyle class.

Public Instance Properties

BackColor (inherited from Style) |
BackImageAttributes (inherited from GridTableItemStyle) | Background image attributes.
BackImageUrl (inherited from GridTableItemStyle) | Background image url.
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
BottomBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's bottom border.
Container (inherited from Component) |
CssClass (inherited from Style) |
Custom (inherited from GridTableItemStyle) | Gets or sets the custom format, null or empty string means no custom format.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
HorizontalAlign (inherited from TableItemStyle) |
IndentLevel (inherited from GridTableItemStyle) | Gets or sets indent level.
IsEmpty (inherited from Style) |
IsLocked (inherited from GridTableItemStyle) | Gets or sets a value indicating whether a cell can be modified or not when its worksheet is protected. When its worksheet is protected and IsLocked is true, the cell can not be edit. When its worksheet is protected and IsLocked is false, the cell can be edit.
LeftBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's left border.
NumberType | Overloaded.
RegisteredCssClass (inherited from Style) |
RightBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's right border.
RotationAngle (inherited from GridTableItemStyle) | Gets or sets Rotation attribute.
Site (inherited from Component) |
TopBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's top border.
VerticalAlign (inherited from TableItemStyle) |
Width (inherited from Style) |
Wrap (inherited from TableItemStyle) |

Public Instance Methods

AddAttributesToRender (inherited from GridTableItemStyle) | Overloaded. Internal use only. Implementation method Do not call this method directly.
AddAttributesToRender (inherited from Style) | Overloaded.
CopyFrom (inherited from GridTableItemStyle) | Copies from another style object.
CreateObjRef (inherited from MarshalByRefObject) |
Dispose (inherited from Component) |
Equals (inherited from Object) |
GetHashCode (inherited from GridTableItemStyle) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) |
GetStyleAttributes (inherited from Style) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
MergeWith (inherited from GridTableItemStyle) | Merges with another style object.
Reset (inherited from TableItemStyle) |
SetDirty (inherited from Style) |
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component)

See Also

TableItemStyle Class | Aspose.Cells.GridWeb Namespace


TableItemStyle Constructor

Initializes a new instance of the TableItemStyle class.

public TableItemStyle();

See Also

TableItemStyle Class | Aspose.Cells.GridWeb Namespace


TableItemStyle Properties

The properties of the TableItemStyle class are listed below. For a complete list of TableItemStyle class members, see the TableItemStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) |
BackImageAttributes (inherited from GridTableItemStyle) | Background image attributes.
BackImageUrl (inherited from GridTableItemStyle) | Background image url.
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
BottomBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's bottom border.
Container (inherited from Component) |
CssClass (inherited from Style) |
Custom (inherited from GridTableItemStyle) | Gets or sets the custom format, null or empty string means no custom format.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
HorizontalAlign (inherited from TableItemStyle) |
IndentLevel (inherited from GridTableItemStyle) | Gets or sets indent level.
IsEmpty (inherited from Style) |
IsLocked (inherited from GridTableItemStyle) | Gets or sets a value indicating whether a cell can be modified or not when its worksheet is protected. When its worksheet is protected and IsLocked is true, the cell can not be edit. When its worksheet is protected and IsLocked is false, the cell can be edit.
LeftBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's left border.
NumberType | Overloaded.
RegisteredCssClass (inherited from Style) |
RightBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's right border.
RotationAngle (inherited from GridTableItemStyle) | Gets or sets Rotation attribute.
Site (inherited from Component) |
TopBorderStyle (inherited from GridTableItemStyle) | Specifies the style of the cell's top border.
VerticalAlign (inherited from TableItemStyle) |
Width (inherited from Style) |
Wrap (inherited from TableItemStyle) |

See Also

TableItemStyle Class | Aspose.Cells.GridWeb Namespace


NumberType Property

Aspose.Cells for .NET

TableItemStyle.NumberType Property

new public NumberType NumberType {get; set;}

See Also

TableItemStyle Class | Aspose.Cells.GridWeb Namespace


Validation Class

NOTE: This class is now obsolete.

This class is obsolete; use GridValidation instead

For a list of all members of this type, see Validation Members.

System.Object
Aspose.Cells.GridWeb.Data.CellAttachObject
Aspose.Cells.GridWeb.Validation

public class Validation : CellAttachObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridValidation Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Validation Members | Aspose.Cells.GridWeb Namespace


Validation Members

Validation overview

Public Instance Constructors

Validation Overloaded. Initializes a new instance of the Validation class.

Public Instance Properties

Cell (inherited from CellAttachObject) | Gets the relative cell of the object.
ClientValidationFunction | Gets or sets the client validation javascript function name.
ClientValidationOpType | Gets or sets the validation op type ,Between/NotBetween/Equal/NotEqual/Greater/GreaterOrEqual/Less/LessOrEqual.
ClientValidationValue1 | Gets or sets the operator target value 1
ClientValidationValue2 | Gets or sets the operator target value 2
IsRequired | Gets or sets whether the cell value is required.
RegEx | Gets or sets the regular expression string.
ValidationType | Gets or sets the validation type.
ValueArray |
ValueList | Gets the value list object.
ValueText | Design time used only.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
LoadValueList | Loads value list from a DataView object. You can specify the value field and text field of the DataView. Each value and text pair will be combined to one string, with a comma between them.
ToString (inherited from Object) |

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


Validation Constructor

Initializes a new instance of the Validation class.

Overload List

Initializes a new instance of the Validation class.

public Validation();

public Validation(GridValidation);

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


Validation Constructor ()

Initializes a new instance of the Validation class.

public Validation();

See Also

Validation Class | Aspose.Cells.GridWeb Namespace | Validation Constructor Overload List


Validation Constructor (GridValidation)

public Validation(
GridValidation gv
);

See Also

Validation Class | Aspose.Cells.GridWeb Namespace | Validation Constructor Overload List


Validation Properties

The properties of the Validation class are listed below. For a complete list of Validation class members, see the Validation Members topic.

Public Instance Properties

Cell (inherited from CellAttachObject) | Gets the relative cell of the object.
ClientValidationFunction | Gets or sets the client validation javascript function name.
ClientValidationOpType | Gets or sets the validation op type ,Between/NotBetween/Equal/NotEqual/Greater/GreaterOrEqual/Less/LessOrEqual.
ClientValidationValue1 | Gets or sets the operator target value 1
ClientValidationValue2 | Gets or sets the operator target value 2
IsRequired | Gets or sets whether the cell value is required.
RegEx | Gets or sets the regular expression string.
ValidationType | Gets or sets the validation type.
ValueArray |
ValueList | Gets the value list object.
ValueText | Design time used only.

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ClientValidationFunction Property

Aspose.Cells for .NET

Validation.ClientValidationFunction Property

Gets or sets the client validation javascript function name.

public string ClientValidationFunction {get; set;}

Remarks

Use the ClientValidationFunction property to specify the client validation function's name. The function should be declared as this formation:
function customValicationFunction(source, value)
The parameter "source" is the cell object. The parameter "value" is the string value of a cell to be checked. The function should returns true if the value is valid.

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ClientValidationOpType Property

Aspose.Cells for .NET

Validation.ClientValidationOpType Property

Gets or sets the validation op type ,Between/NotBetween/Equal/NotEqual/Greater/GreaterOrEqual/Less/LessOrEqual.

public string ClientValidationOpType {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ClientValidationValue1 Property

Aspose.Cells for .NET

Validation.ClientValidationValue1 Property

Gets or sets the operator target value 1

public string ClientValidationValue1 {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ClientValidationValue2 Property

Aspose.Cells for .NET

Validation.ClientValidationValue2 Property

Gets or sets the operator target value 2

public string ClientValidationValue2 {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


IsRequired Property

Aspose.Cells for .NET

Validation.IsRequired Property

Gets or sets whether the cell value is required.

public bool IsRequired {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


RegEx Property

Aspose.Cells for .NET

Validation.RegEx Property

Gets or sets the regular expression string.

public string RegEx {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ValidationType Property

Aspose.Cells for .NET

Validation.ValidationType Property

Gets or sets the validation type.

public ValidationType ValidationType {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ValueArray Property

Aspose.Cells for .NET

Validation.ValueArray Property

public string[] ValueArray {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ValueList Property

Aspose.Cells for .NET

Validation.ValueList Property

Gets the value list object.

public StringCollection ValueList {get;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ValueText Property

Aspose.Cells for .NET

Validation.ValueText Property

Design time used only.

public string ValueText {get; set;}

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


Validation Methods

The methods of the Validation class are listed below. For a complete list of Validation class members, see the Validation Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
LoadValueList | Loads value list from a DataView object. You can specify the value field and text field of the DataView. Each value and text pair will be combined to one string, with a comma between them.
ToString (inherited from Object) |

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


Validation.LoadValueList Method

Loads value list from a DataView object. You can specify the value field and text field of the DataView. Each value and text pair will be combined to one string, with a comma between them.

public void LoadValueList(
DataView view,
string valueField,
string textField,
bool valuePrefixText
);

Parameters

view
The DataView object.
valueField
The value field name.
textField
The text field name.
valuePrefixText
Indicates whether to add a value prefix to each displayed text.

See Also

Validation Class | Aspose.Cells.GridWeb Namespace


ValidationType Enumeration

Represents customer side validation type. AnyValue represents no validation.

public enum ValidationType

Members

Member Name | Description | Value
AnyValue | Any value validation type. | 0
DropDownList | Show dropdown list. | 1
List | List validation type. | 2
FreeList | Free List validation type. | 3
CustomExpression | Custom validation type, using regular expression. | 4
Boolean | TRUE or FALSE | 5
Number | Number ( Integer or Double ). | 6
Integer | Integer | 7
Date | Date yyyy-MM-dd | 8
DateTime | DateTime (yyyy-MM-dd or yyyy-MM-dd hh:mm:ss). | 9
Time | Time (hh:mm:ss). | 10
TextLength | textlength | 11
CustomString | customstr | 12
CustomFunction | Custom javascript function validation. | 13
CustomServerFunction | Custom server-side function validation. | 14
CheckBox | Display the cell as a checkbox. And the value of the cell is True of False. | 15

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate Class

ViewerStyleTemplate.

For a list of all members of this type, see ViewerStyleTemplate Members.

System.Object
System.Web.UI.Control
Aspose.Cells.GridWeb.ViewerStyleTemplate

public class ViewerStyleTemplate : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

ViewerStyleTemplate Members | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate Members

ViewerStyleTemplate overview

Public Static Methods

Tridione Internal used only.

Public Instance Constructors

ViewerStyleTemplate Constructor Default constructor.

Public Instance Properties

ActiveCellBgColor | Specifies the background color of the active cell.
ActiveCellColor | Specifies the color of the active cell.
ActiveHeaderBgColor | Specifies the background color of the active row/column header.
ActiveHeaderColor | Specifies the color of the active row/column header.
ActiveTabStyle |
AppRelativeTemplateSourceDirectory (inherited from Control) |
BindingContainer (inherited from Control) |
BottomTableStyle |
ClientID (inherited from Control) |
Controls (inherited from Control) |
DefaultGridLineColor |
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
FrameTableStyle |
HeaderBarHeight |
HeaderBarStyle |
HeaderBarTableStyle |
HeaderBarWidth |
ID (inherited from Control) |
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
ScrollBarArrowColor |
ScrollBarBaseColor |
SelectCellBgColor | Specifies the background color of the selected cells in multi-select range.
SelectCellColor | Specifies the color of the selected cells in multi-select range.
Site (inherited from Control) |
SkinID (inherited from Control) |
TabStyle |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
ViewTableStyle |
Visible (inherited from Control) |

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetStylesFromControl |
GetType (inherited from Object) |
HasControls (inherited from Control) |
LoadPresetStyle | Load a preset style.
ParseFromFile |
ParseFromString |
PersistToFile |
PersistToString |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
SetStylesForControl |
ToString (inherited from Object) |

Public Instance Events

DataBinding (inherited from Control)
Disposed (inherited from Control)
Init (inherited from Control)
Load (inherited from Control)
PreRender (inherited from Control)
Unload (inherited from Control)

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate Constructor

Default constructor.

public ViewerStyleTemplate();

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate Properties

The properties of the ViewerStyleTemplate class are listed below. For a complete list of ViewerStyleTemplate class members, see the ViewerStyleTemplate Members topic.

Public Instance Properties

ActiveCellBgColor | Specifies the background color of the active cell.
ActiveCellColor | Specifies the color of the active cell.
ActiveHeaderBgColor | Specifies the background color of the active row/column header.
ActiveHeaderColor | Specifies the color of the active row/column header.
ActiveTabStyle |
AppRelativeTemplateSourceDirectory (inherited from Control) |
BindingContainer (inherited from Control) |
BottomTableStyle |
ClientID (inherited from Control) |
Controls (inherited from Control) |
DefaultGridLineColor |
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
FrameTableStyle |
HeaderBarHeight |
HeaderBarStyle |
HeaderBarTableStyle |
HeaderBarWidth |
ID (inherited from Control) |
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
ScrollBarArrowColor |
ScrollBarBaseColor |
SelectCellBgColor | Specifies the background color of the selected cells in multi-select range.
SelectCellColor | Specifies the color of the selected cells in multi-select range.
Site (inherited from Control) |
SkinID (inherited from Control) |
TabStyle |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
ViewTableStyle |
Visible (inherited from Control) |

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ActiveCellBgColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.ActiveCellBgColor Property

Specifies the background color of the active cell.

public Color ActiveCellBgColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ActiveCellColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.ActiveCellColor Property

Specifies the color of the active cell.

public Color ActiveCellColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ActiveHeaderBgColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.ActiveHeaderBgColor Property

Specifies the background color of the active row/column header.

public Color ActiveHeaderBgColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ActiveHeaderColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.ActiveHeaderColor Property

Specifies the color of the active row/column header.

public Color ActiveHeaderColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ActiveTabStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.ActiveTabStyle Property

public GridTableItemStyle ActiveTabStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


BottomTableStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.BottomTableStyle Property

public GridTableStyle BottomTableStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


DefaultGridLineColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.DefaultGridLineColor Property

public Color DefaultGridLineColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


FrameTableStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.FrameTableStyle Property

public GridTableStyle FrameTableStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


HeaderBarHeight Property

Aspose.Cells for .NET

ViewerStyleTemplate.HeaderBarHeight Property

public Unit HeaderBarHeight {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


HeaderBarStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.HeaderBarStyle Property

public GridTableItemStyle HeaderBarStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


HeaderBarTableStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.HeaderBarTableStyle Property

public GridTableStyle HeaderBarTableStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


HeaderBarWidth Property

Aspose.Cells for .NET

ViewerStyleTemplate.HeaderBarWidth Property

public Unit HeaderBarWidth {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ScrollBarArrowColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.ScrollBarArrowColor Property

public Color ScrollBarArrowColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ScrollBarBaseColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.ScrollBarBaseColor Property

public Color ScrollBarBaseColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


SelectCellBgColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.SelectCellBgColor Property

Specifies the background color of the selected cells in multi-select range.

public Color SelectCellBgColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


SelectCellColor Property

Aspose.Cells for .NET

ViewerStyleTemplate.SelectCellColor Property

Specifies the color of the selected cells in multi-select range.

public Color SelectCellColor {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


TabStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.TabStyle Property

public GridTableItemStyle TabStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewTableStyle Property

Aspose.Cells for .NET

ViewerStyleTemplate.ViewTableStyle Property

public GridTableStyle ViewTableStyle {get; set;}

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate Methods

The methods of the ViewerStyleTemplate class are listed below. For a complete list of ViewerStyleTemplate class members, see the ViewerStyleTemplate Members topic.

Public Static Methods

Tridione Internal used only.

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
GetHashCode (inherited from Object) |
GetStylesFromControl |
GetType (inherited from Object) |
HasControls (inherited from Control) |
LoadPresetStyle | Load a preset style.
ParseFromFile |
ParseFromString |
PersistToFile |
PersistToString |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
SetStylesForControl |
ToString (inherited from Object) |

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.GetStylesFromControl Method

public void GetStylesFromControl(
MainWeb control
);

Parameters

control

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.LoadPresetStyle Method

Load a preset style.

public void LoadPresetStyle(
PresetStyle presetStyle
);

Parameters

presetStyle

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.ParseFromFile Method

public void ParseFromFile(
string fileName
);

Parameters

fileName

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.ParseFromString Method

public void ParseFromString(
string xmlStr
);

Parameters

xmlStr

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.PersistToFile Method

public void PersistToFile(
string fileName
);

Parameters

fileName

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.PersistToString Method

public string PersistToString();

Return Value

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.SetStylesForControl Method

public void SetStylesForControl(
MainWeb control
);

Parameters

control

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


ViewerStyleTemplate.Tridione Method

Internal used only.

public static void Tridione();

See Also

ViewerStyleTemplate Class | Aspose.Cells.GridWeb Namespace


WebBorderStyle Class

Encapsulates the style of web table or cell border.

For a list of all members of this type, see WebBorderStyle Members.

System.Object
Aspose.Cells.GridWeb.WebBorderStyle

public class WebBorderStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Please refer to .NET SDK document for further information about System.Web.UI.WebControls namespace.

Example

[C#]
        WebCell cell1 = GridWeb1.WebWorksheets[0].Cells["A1"];
        cell1.Style.LeftBorderStyle.BorderColor = System.Drawing.Color.Red;
        cell1.Style.LeftBorderStyle.BorderStyle = System.Web.UI.WebControls.BorderStyle.Solid;
        cell1.Style.LeftBorderStyle.BorderWidth = new System.Web.UI.WebControls.Unit(16, System.Web.UI.WebControls.UnitType.Point);

    [Visual Basic]
        Dim cell1 As WebCell =  GridWeb1.WebWorksheets(0).Cells("A1")
        cell1.Style.LeftBorderStyle.BorderColor = System.Drawing.Color.Red
        cell1.Style.LeftBorderStyle.BorderStyle = System.Web.UI.WebControls.BorderStyle.Solid
        cell1.Style.LeftBorderStyle.BorderWidth = New System.Web.UI.WebControls.Unit(16, System.Web.UI.WebControls.UnitType.Point)

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebBorderStyle Members | Aspose.Cells.GridWeb Namespace


WebBorderStyle Members

WebBorderStyle overview

Public Instance Constructors

WebBorderStyle Constructor Default constructor.

Public Instance Properties

BorderColor | Gets or sets the color of the border. Please refer to System.Drawing.Color struct.
BorderStyle | Gets or sets the style of the border. Please refer to .NET SDK document about System.Web.UI.WebControls.BorderStyle enum.
BorderWidth | Gets or sets the width of the border. Please refer to System.Web.UI.WebControls.Unit struct.

Public Instance Methods

CopyFrom | Copies from another style object.
Equals (inherited from Object) |
GetHashCode |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


WebBorderStyle Constructor

Default constructor.

public WebBorderStyle();

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


WebBorderStyle Properties

The properties of the WebBorderStyle class are listed below. For a complete list of WebBorderStyle class members, see the WebBorderStyle Members topic.

Public Instance Properties

BorderColor | Gets or sets the color of the border. Please refer to System.Drawing.Color struct.
BorderStyle | Gets or sets the style of the border. Please refer to .NET SDK document about System.Web.UI.WebControls.BorderStyle enum.
BorderWidth | Gets or sets the width of the border. Please refer to System.Web.UI.WebControls.Unit struct.

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


BorderColor Property

Aspose.Cells for .NET

WebBorderStyle.BorderColor Property

Gets or sets the color of the border. Please refer to System.Drawing.Color struct.

public Color BorderColor {get; set;}

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


BorderStyle Property

Aspose.Cells for .NET

WebBorderStyle.BorderStyle Property

Gets or sets the style of the border. Please refer to .NET SDK document about System.Web.UI.WebControls.BorderStyle enum.

public BorderStyle BorderStyle {get; set;}

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


BorderWidth Property

Aspose.Cells for .NET

WebBorderStyle.BorderWidth Property

Gets or sets the width of the border. Please refer to System.Web.UI.WebControls.Unit struct.

public Unit BorderWidth {get; set;}

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


WebBorderStyle Methods

The methods of the WebBorderStyle class are listed below. For a complete list of WebBorderStyle class members, see the WebBorderStyle Members topic.

Public Instance Methods

CopyFrom | Copies from another style object.
Equals (inherited from Object) |
GetHashCode |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


WebBorderStyle.CopyFrom Method

Copies from another style object.

public void CopyFrom(
WebBorderStyle style
);

Parameters

style
The style object to be copied.

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


WebBorderStyle.GetHashCode Method

public override int GetHashCode();

See Also

WebBorderStyle Class | Aspose.Cells.GridWeb Namespace


WorksheetDesign Class

Inherited from WebWorksheet. Used in design-time only.

For a list of all members of this type, see WorksheetDesign Members.

System.Object
System.Web.UI.Control
Aspose.Cells.GridWeb.Data.WebWorksheet
Aspose.Cells.GridWeb.WorksheetDesign

public class WorksheetDesign : WebWorksheet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WorksheetDesign Members | Aspose.Cells.GridWeb Namespace


WorksheetDesign Members

WorksheetDesign overview

Public Instance Constructors

WorksheetDesign Overloaded. Initializes a new instance of the WorksheetDesign class.

Public Instance Properties

AppRelativeTemplateSourceDirectory (inherited from Control) |
BindColumns (inherited from WebWorksheet) | Bind columns collection.
BindingContainer (inherited from Control) |
BindingSource (inherited from WebWorksheet) | The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.
BindStartColumn (inherited from WebWorksheet) | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
BindStartRow (inherited from WebWorksheet) | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
CellImages (inherited from WebWorksheet) |
Cells (inherited from WebWorksheet) | Gets the WebCells.
ClientID (inherited from Control) |
Comments (inherited from WebWorksheet) |
Controls (inherited from Control) |
CurrentBindRows (inherited from WebWorksheet) | Gets the binding rows number in data-binding mode.
DataMember (inherited from WebWorksheet) | Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.
DataSource (inherited from WebWorksheet) | Gets or sets the DataSource. Generally it's a DataSet object.
EnableCreateBindColumnHeader (inherited from WebWorksheet) | In data-binding mode, indicates whether to create bind column header captions in the sheet.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
Hyperlinks (inherited from WebWorksheet) | Gets the HyperlinkCollection collection.
ID (inherited from Control) |
Index (inherited from WebWorksheet) | Gets the index of itself within the WebWorksheets.
IsProtected (inherited from WebWorksheet) | Gets or sets whether the worksheet is protected. When a worksheet is protected, all the cells can not be edit except the cell whose IsLocked property is false.
Name (inherited from WebWorksheet) | Gets or sets the name of the sheet.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
RowFilter (inherited from WebWorksheet) |
Site (inherited from Control) |
SkinID (inherited from Control) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Validations (inherited from WebWorksheet) | Gets the data validation setting collection in the worksheet.
Visible (inherited from WebWorksheet) | Indicates whether this sheet's name is shown in the sheet tabs of the control.

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
AutoFitColumn (inherited from WebWorksheet) | Overloaded. Autofits the column width. This method autofits a column based on content in a range of cells within the column from startRow to endRow. AutoFitColumn is an imprecise function.
CancelNewBindRow (inherited from WebWorksheet) | Cancels and deletes the new added bind row.
CommitNewBindRow (inherited from WebWorksheet) | Commits the new added bind row and add it to the datasource.
Copy (inherited from WebWorksheet) | Copies from another worksheet object.
CreateAutoGenratedColumns (inherited from WebWorksheet) | After setting a datasource for the worksheet, call this method to generate the bind columns automatically.
CreateNewBindRow (inherited from WebWorksheet) | Creates a new bind row and bind to the datasource.
CreateSubtotal (inherited from WebWorksheet) | Creates subtotal in the sheet.
DataBind (inherited from WebWorksheet) | Bind the sheet to the DataSource.
DataSourceControlUpdate (inherited from WebWorksheet) |
DeleteBindRow (inherited from WebWorksheet) | Deletes a bind row.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
FreezePanes (inherited from WebWorksheet) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GroupRows (inherited from WebWorksheet) | Overloaded. Groups rows.
HasControls (inherited from Control) |
RemoveSubtotal (inherited from WebWorksheet) |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAllCellsEditable (inherited from WebWorksheet) |
SetAllCellsReadonly (inherited from WebWorksheet) |
SetEditableRange (inherited from WebWorksheet) | Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable
SetReadonlyRange (inherited from WebWorksheet) | Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
UnfreezePanes (inherited from WebWorksheet) |
UngroupRows (inherited from WebWorksheet) |
UpdateBindCellValue (inherited from WebWorksheet) | Updates the binding datasource record's property value according to the cell's value.

Public Instance Events

DataBinding (inherited from Control)
Disposed (inherited from Control)
Init (inherited from Control)
Load (inherited from Control)
PreRender (inherited from Control)
Unload (inherited from Control)

See Also

WorksheetDesign Class | Aspose.Cells.GridWeb Namespace


WorksheetDesign Constructor

Default constructor.

Overload List

Default constructor.

public WorksheetDesign();

public WorksheetDesign(MainWeb,GridWorksheet);

See Also

WorksheetDesign Class | Aspose.Cells.GridWeb Namespace


WorksheetDesign Constructor ()

Default constructor.

public WorksheetDesign();

See Also

WorksheetDesign Class | Aspose.Cells.GridWeb Namespace | WorksheetDesign Constructor Overload List


WorksheetDesign Constructor (MainWeb, GridWorksheet)

public WorksheetDesign(
MainWeb mw,
GridWorksheet gwk
);

See Also

WorksheetDesign Class | Aspose.Cells.GridWeb Namespace | WorksheetDesign Constructor Overload List


Aspose.Cells.GridWeb.Data

Aspose.Cells for .NET

Aspose.Cells.GridWeb.Data Namespace

Namespace hierarchy

Classes

Class | Description
CellAttachObject | Obsolete. Represents an cell's attachment object like Comment, Hyperlink, etc.
CellImage |
GridAbstractCalculationEngine | Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.
GridCalculationData | Represents the required data when calculating one function, such as function name, parameters, ...etc.
GridCell | Represents a cell object.
GridCellArea | Represents an area of cells.
GridCellException | Represents a cell operation error.
GridCells | Encapsulates a collection of Cell objects.
GridColumn | Represents a single column in a worksheet.
GridColumnCollection | Collects the objects that represent the individual columns in a worksheet.
GridComment | Encapsulates the object that represents a cell comment.
GridCommentCollection | Encapsulates a collection of Comment objects.
GridHtmlSaveOptions | Represents the options for saving html file.
GridHyperlink | Encapsulates the object that represents a hyperlink.
GridHyperlinkCollection | Encapsulates a collection of Hyperlink objects.
GridName | Encapsulates the object that represents a name object.
GridNameCollection | Encapsulates a collection of Name objects.
GridPicture | Encapsulates the object that represents a single picture in a spreadsheet.
GridPictureCollection | Encapsulates a collection of Picture objects.
GridPivotField |
GridPivotFieldCollection | Encapsulates a collection of PivotField objects.
GridPivotItem |
GridPivotItemCollection | Encapsulates a collection of PivotItem objects.
GridPivotTable | Represents a PivotTable report on a worksheet. The PivotTable object is a member of the PivotTables collection. The PivotTables collection contains all the PivotTable objects on a control.
GridPivotTableCollection | Encapsulates a collection of PivotTable objects.
GridReferredArea | Represents a referred objcet by the formula.
GridRow | Encapsulates the object that represents a single picture in a spreadsheet.
GridRowCollection | Encapsulates a collection of Worksheet objects.
GridSaveOptions | Represents all save options
GridShape | Represents a shape object.
GridShapeCollection |
GridValidation |
GridValidationCollection | Encapsulates a collection of Hyperlink objects.
GridWebException | The exception that is thrown when Aspose.Cells.GridWeb specified error occurs.
GridWorkbook | Represents a root object to create an Excel spreadsheet.
GridWorksheet | Encapsulates the object that represents a single worksheet.
GridWorksheetCollection | Collects the objects that represent the individual rows in a worksheet.
Hyperlink | Obsolete.
Hyperlinks | Obsolete.
OnErrorActionQuery | Used in the CellError event of the GridWeb.
PivotCache | Obsolete. Represents the memory cache for a PivotTable report. The PivotCache object is a member of the PivotCaches collection.
PivotCaches | Obsolete. Represents the collection of memory caches from the PivotTable reports in a workbook. Each memory cache is represented by a PivotCache object.
PivotField | Obsolete. Represents a field in a PivotTable report. The PivotField object is a member of the PivotFields collection. NOTE: This class is now obsolete. Instead, please use GridPivotField. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.
PivotFields | Obsolete. Reprents A collection of all the PivotField objects in a PivotTable report.
PivotItem | Obsolete. Represents an item in a PivotTable field. The items are the individual data entries in a field category. The PivotItem object is a member of the PivotItems collection. The PivotItems collection contains all the items in a PivotField object.
PivotItems | Obsolete. Represents A collection of all the PivotItem objects in a PivotTable field. The items are the individual data entries in a field category.
PivotTable | Obsolete. Represents a PivotTable report on a worksheet. The PivotTable object is a member of the PivotTables collection. The PivotTables collection contains all the PivotTable objects on a control.
PivotTables | Obsolete. Represents a collection of all the PivotTable objects
RowFilterSettings | Obsolete. Summary description for RowFilter.
WebCell | Obsolete.
WebCellArea | Obsolete.
WebCellException | Represents a cell operation error.
WebCells | Obsolete.
WebComment | Obsolete.
WebComments | Obsolete.
WebWorksheet | Obsolete. Represents a web worksheet.
WebWorksheets | Obsolete.

Interfaces

Interface | Description
GridCustomServerValidation | the interface you need to implement when use server side validation. CustomServerFunction.
ICustomFilter | Summary description for ICustomFilter.

Delegates

Delegate | Description
CellErrorHandler | Represents the interface that intend to handle cell error events. void handleCellEvent(Object sender, GridCellException ex, OnErrorActionQuery query);
CellEventHandler | Represents the interface that intend to handle cell events. void handleCellEvent(Object sender, CellEventArgs e);
CellEventStringHandler | Represents the method that intend to handle cell events. same as CellEventHandler interface,but return string result String handleCellEvent(Object sender, CellEventArgs e);
CustomCommandEventHandler | Represents the interface that intend to handle Custom Command events. void handleCellEvent(Object sender, String command);
InitializeNewBindRowHandler | Represents the method that intend to handle InitializeNewBindRow event. sender: The worksheet object. bindObject: The new created bind object. Generally it's a DataRowView object.
RowColumnEventHandler | Represents the interface that intend to handle row/column events. void handleCellEvent(Object sender, RowColumnEventArgs e);
SheetEventHandler | Represents the interface that intend to handle sheet events. void handleCellEvent(Object sender, RowColumnEventArgs e);
WorkbookEventHandler | Represents the interface that intend to handle workbook events. void handleCellEvent(Object sender, CellEventArgs e);

Enumerations

Enumeration | Description
GridCellErrorType | Used in WebCellException. Represents the cell error type.
GridImageType | Specifies the type (format) of an image.
GridMsoDrawingType |
GridOperatorType |
GridPivotFieldFunction |
GridPivotFieldType |
GridSaveFormat | Enumerates supported file format types.
GridValidationType |
HyperlinkActionType | Hyperlink has two action type: UrlLink and CellCommand. UrlLink type hyperlink is an anchor in a cell, click it will navigate to another page or open a new browser window. CellCommand type hyperlink is an command button in a cell, click it will generate a server side event.
NumberType | Represents the number or datetime format type.
OnErrorActionType | Used in CellError event of the GridWeb. User set the OnErrorActionQuery.OnErrorAction to tell the control Stop processing or Ignore error.
PivotFieldFunction | Obsolete. Represents functions used to summarize the PivotTable data field
PivotFieldOrientation | Obsolete. Represents The location of the field in the specified PivotTable report.
PivotFieldSort | Represents the order used to sort the specified PivotTable field.
PivotSourceType | Represents the source data type.
SortOrder | Represents what order the data sort by.
SortOrientation | Represents sorting orientation
SubtotalFunction | Represents subtotal function type. Used in the GridWorksheet.CreateSubtotal method.
WebCellErrorType | Used in WebCellException. Represents the cell error type.


CellAttachObject Class

NOTE: This class is now obsolete.

This class is obsolete;no longer use

Represents an cell's attachment object like Comment, Hyperlink, etc.

For a list of all members of this type, see CellAttachObject Members.

System.Object
Aspose.Cells.GridWeb.Data.CellAttachObject
Aspose.Cells.GridWeb.Validation

public class CellAttachObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

CellAttachObject Members | Aspose.Cells.GridWeb.Data Namespace


CellAttachObject Members

CellAttachObject overview

Public Instance Properties

Cell Gets the relative cell of the object.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellAttachObject Class | Aspose.Cells.GridWeb.Data Namespace


CellAttachObject Properties

The properties of the CellAttachObject class are listed below. For a complete list of CellAttachObject class members, see the CellAttachObject Members topic.

Public Instance Properties

Cell Gets the relative cell of the object.

See Also

CellAttachObject Class | Aspose.Cells.GridWeb.Data Namespace


Cell Property

Aspose.Cells for .NET

CellAttachObject.Cell Property

Gets the relative cell of the object.

public WebCell Cell {get;}

See Also

CellAttachObject Class | Aspose.Cells.GridWeb.Data Namespace


CellErrorHandler Delegate

Represents the interface that intend to handle cell error events.

void handleCellEvent(Object sender, GridCellException ex, OnErrorActionQuery query);

public delegate void CellErrorHandler(
object sender,
WebCellException ex,
OnErrorActionQuery action
);

Parameters

sender
The source of the event.
ex
The cell operation error.
action
can get onerror action type information.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


CellEventHandler Delegate

Represents the interface that intend to handle cell events.

void handleCellEvent(Object sender, CellEventArgs e);

public delegate void CellEventHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source grid of the event.
e
The event argument. The e.Cell is the cell who fires the event. The e.Argument contains the argument of the event.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


CellEventStringHandler Delegate

Represents the method that intend to handle cell events. same as CellEventHandler interface,but return string result

String handleCellEvent(Object sender, CellEventArgs e);

public delegate string CellEventStringHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source grid of the event.
e
The event argument. The e.Cell is the cell who fires the event. The e.Argument contains the argument of the event.

Return Value

string value

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


CellImage Class

For a list of all members of this type, see CellImage Members.

System.Object
Aspose.Cells.GridWeb.Data.Hyperlink
Aspose.Cells.GridWeb.Data.CellImage

public class CellImage : Hyperlink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

CellImage Members | Aspose.Cells.GridWeb.Data Namespace


CellImage Members

CellImage overview

Public Instance Properties

ActionType (inherited from Hyperlink) | Gets or sets the hyperlink's action type. It may be ActionTpye.UrlLink or ActionType.CellCommand. The UrlLink Type means that the hyperlink is a link to a web page or a mail receipt. For example: "http://www.aspose.com" or "mailto:admin@aspose.com". The CellCommand Type means that the hyperlink will fire a CellCommand event, and you may handle this event.
Area (inherited from Hyperlink) | Gets the range of hyperlink.
CellCommand (inherited from Hyperlink) | Gets or sets the Cell Command name.
DiscardInput (inherited from Hyperlink) | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageUrl (inherited from Hyperlink) | Gets or sets the hyperlink's image url. If sets to null or empty string, the hyperlink will only display it's text.
Target (inherited from Hyperlink) |
Text (inherited from Hyperlink) | Gets or sets the displayed text of the hyperlink.
ToolTip (inherited from Hyperlink) | Gets or sets the tooltip of the hyperlink.
Url (inherited from Hyperlink) | Gets or sets the URL string.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CellImage Class | Aspose.Cells.GridWeb.Data Namespace


CustomCommandEventHandler Delegate

Represents the interface that intend to handle Custom Command events.

void handleCellEvent(Object sender, String command);

public delegate void CustomCommandEventHandler(
object sender,
string command
);

Parameters

sender
The source grid of the event.
command
The command string user send.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridAbstractCalculationEngine Class

Represents user's custom calculation engine to extend the default calculation engine of Aspose.Cells.

For a list of all members of this type, see GridAbstractCalculationEngine Members.

System.Object
Aspose.Cells.GridWeb.Data.GridAbstractCalculationEngine

public abstract class GridAbstractCalculationEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
public class MyEngine : GridAbstractCalculationEngine
{
    public override void Calculate(GridCalculationData data)
    {
        string funcName = data.FunctionName.ToUpper();
        if ("MYFUNC".Equals(funcName))
        {
            //do calculation for MYFUNC here
            int count = data.ParamCount;
            object res = null;
            for (int i = 0; i < count; i++)
            {
                object pv = data.GetParamValue(i);
                if (pv is ReferredArea)
                {
                    ReferredArea ra = (ReferredArea)pv;
                    pv = ra.GetValue(0, 0);
                }
                //process the parameter here
                //res = ...;
            }
            data.CalculatedValue = res;
        }
    }
}

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridAbstractCalculationEngine Members | Aspose.Cells.GridWeb.Data Namespace


GridAbstractCalculationEngine Members

GridAbstractCalculationEngine overview

Public Instance Methods

Calculate | Calculates one function with given data.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridAbstractCalculationEngine Class | Aspose.Cells.GridWeb.Data Namespace


GridAbstractCalculationEngine Methods

The methods of the GridAbstractCalculationEngine class are listed below. For a complete list of GridAbstractCalculationEngine class members, see the GridAbstractCalculationEngine Members topic.

Public Instance Methods

Calculate | Calculates one function with given data.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridAbstractCalculationEngine Class | Aspose.Cells.GridWeb.Data Namespace


GridAbstractCalculationEngine.Calculate Method

Calculates one function with given data.

public abstract void Calculate(
GridCalculationData data
);

Parameters

data
the required data to calculate function such as function name, parameters, ...etc.

Remarks

User should set the calculated value for given data for all functions(including excel native functions) that he wants to calculate by himself in this implementation.

See Also

GridAbstractCalculationEngine Class | Aspose.Cells.GridWeb.Data Namespace


GridCalculationData Class

Represents the required data when calculating one function, such as function name, parameters, ...etc.

For a list of all members of this type, see GridCalculationData Members.

System.Object
Aspose.Cells.GridWeb.Data.GridCalculationData

public class GridCalculationData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCalculationData Members | Aspose.Cells.GridWeb.Data Namespace


GridCalculationData Members

GridCalculationData overview

Public Instance Properties

CalculatedValue | Gets or sets the calculated value for this function.
Cell | Gets the Cell object where the function is in.
FunctionName | Gets the function name to be calculated.
ParamCount | Gets the count of parameters
Workbook | Gets the Workbook object where the function is in.
Worksheet | Gets the Workbook object where the function is in.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetParamText | Gets the literal text of the parameter at given index.
GetParamValue | Gets the represented value object of the parameter at given index.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


GridCalculationData Properties

The properties of the GridCalculationData class are listed below. For a complete list of GridCalculationData class members, see the GridCalculationData Members topic.

Public Instance Properties

CalculatedValue | Gets or sets the calculated value for this function.
Cell | Gets the Cell object where the function is in.
FunctionName | Gets the function name to be calculated.
ParamCount | Gets the count of parameters
Workbook | Gets the Workbook object where the function is in.
Worksheet | Gets the Workbook object where the function is in.

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


CalculatedValue Property

Aspose.Cells for .NET

GridCalculationData.CalculatedValue Property

Gets or sets the calculated value for this function.

public object CalculatedValue {get; set;}

Remarks

User should set this property in his custom calculation engine for those functions the engine supports, and the set value will be returned when getting this property. Getting this property before setting will make the function be calculated by the default calculation engine of Aspose.Cells and the calculated value will be returned.

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


Cell Property

Aspose.Cells for .NET

GridCalculationData.Cell Property

Gets the Cell object where the function is in.

public GridCell Cell {get;}

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


FunctionName Property

Aspose.Cells for .NET

GridCalculationData.FunctionName Property

Gets the function name to be calculated.

public string FunctionName {get;}

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


ParamCount Property

Aspose.Cells for .NET

GridCalculationData.ParamCount Property

Gets the count of parameters

public int ParamCount {get;}

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


Workbook Property

Aspose.Cells for .NET

GridCalculationData.Workbook Property

Gets the Workbook object where the function is in.

public GridWorkbook Workbook {get;}

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


Worksheet Property

Aspose.Cells for .NET

GridCalculationData.Worksheet Property

Gets the Workbook object where the function is in.

public GridWorksheet Worksheet {get;}

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


GridCalculationData Methods

The methods of the GridCalculationData class are listed below. For a complete list of GridCalculationData class members, see the GridCalculationData Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetParamText | Gets the literal text of the parameter at given index.
GetParamValue | Gets the represented value object of the parameter at given index.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


GridCalculationData.GetParamText Method

Gets the literal text of the parameter at given index.

public string GetParamText(
int index
);

Parameters

index
index of the parameter(0 based)

Return Value

literal text of the parameter

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


GridCalculationData.GetParamValue Method

Gets the represented value object of the parameter at given index.

public object GetParamValue(
int index
);

Parameters

index
index of the parameter(0 based)

Return Value

If the parameter is plain value, then returns the plain value. If the parameter is reference, then return ReferredArea object.

See Also

GridCalculationData Class | Aspose.Cells.GridWeb.Data Namespace


GridCell Class

Represents a cell object.

For a list of all members of this type, see GridCell Members.

System.Object
Aspose.Cells.GridWeb.Data.GridCell

public class GridCell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCell Members | Aspose.Cells.GridWeb.Data Namespace


GridCell Members

GridCell overview

Public Static Operators

Equality Operator
Inequality Operator

Public Instance Properties

BoolValue | Gets the boolean value contained in the cell.
Column | Gets column number (zero based) of the cell.
DateValue | Gets the DateTime value contained in the cell.
DisplayStringValue | Gets the formatted string value of this cell.
DoubleValue | Gets the double value contained in the cell.
FloatValue | Gets the float value contained in the cell.
Formula | Gets or sets a formula of the Cell.
HtmlString | Gets and sets the html string which contains data and some formattings in this cell.
IntValue | Gets the integer value contained in the cell.
IsStyleSet | Indicates if the cell's style is set. If return false, it means this cell has a default cell format.
Name | Gets the name of the cell. For example: A1, F102.
Row | Gets row number (zero based) of the cell.
StringValue | Gets the string value contained in the cell.
Style | Gets the copy of cell style. set the style for the cell.
Type | return the cell value type ,the meaning can see GridCellValueType.java
Value | Gets the value contained in this cell.

Public Instance Methods

ContainsExternalLink | Indicates wether this cell contains an external link. Only applies when the cell is a formula cell.
Copy | Copies data from a source cell.
CopyStyle | copy the style and set the style for the cell
CreateComment | Creates a comment object for a cell.
CreateValidation | Creates a validation object for a cell.
Equals |
GetCellArea |
GetComment | Get comment object on this cell
GetHashCode |
GetType (inherited from Object) |
GetWidthOfValue | Gets the width of the value in unit of pixels.
IsErrorValue | Checks if a formula can properly evaluate a result.
IsFormula | Represents if the specified cell contains formula.
PutValue | Overloaded. Puts a DateTime value into the cell.
PutValueAndSetFormatByValue | Sets the cell's value with a string value and set cell format by this value.
RemoveComment | Removes the comment object of the cell.
RemoveValidation | Removes the validation object of the cell.
SetBorder | Sets borders(top,bottom,left and right) for a cell,all the borders have same borderstyle.
SetCustom | sets the custom format, null or empty string means no custom format.
SetFormula | Set the formula and the value of the formula.
SetNumberType | set the display format of numbers and dates
ToString | Returns a string represents the current Cell object.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell Properties

The properties of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Instance Properties

BoolValue | Gets the boolean value contained in the cell.
Column | Gets column number (zero based) of the cell.
DateValue | Gets the DateTime value contained in the cell.
DisplayStringValue | Gets the formatted string value of this cell.
DoubleValue | Gets the double value contained in the cell.
FloatValue | Gets the float value contained in the cell.
Formula | Gets or sets a formula of the Cell.
HtmlString | Gets and sets the html string which contains data and some formattings in this cell.
IntValue | Gets the integer value contained in the cell.
IsStyleSet | Indicates if the cell's style is set. If return false, it means this cell has a default cell format.
Name | Gets the name of the cell. For example: A1, F102.
Row | Gets row number (zero based) of the cell.
StringValue | Gets the string value contained in the cell.
Style | Gets the copy of cell style. set the style for the cell.
Type | return the cell value type ,the meaning can see GridCellValueType.java
Value | Gets the value contained in this cell.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


BoolValue Property

Aspose.Cells for .NET

GridCell.BoolValue Property

Gets the boolean value contained in the cell.

public bool BoolValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Column Property

Aspose.Cells for .NET

GridCell.Column Property

Gets column number (zero based) of the cell.

public int Column {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


DateValue Property

Aspose.Cells for .NET

GridCell.DateValue Property

Gets the DateTime value contained in the cell.

public DateTime DateValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


DisplayStringValue Property

Aspose.Cells for .NET

GridCell.DisplayStringValue Property

Gets the formatted string value of this cell.

public string DisplayStringValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


DoubleValue Property

Aspose.Cells for .NET

GridCell.DoubleValue Property

Gets the double value contained in the cell.

public double DoubleValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


FloatValue Property

Aspose.Cells for .NET

GridCell.FloatValue Property

Gets the float value contained in the cell.

public float FloatValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Formula Property

Aspose.Cells for .NET

GridCell.Formula Property

Gets or sets a formula of the Cell.

public string Formula {get; set;}

Remarks

A formula string always begins with an equal sign (=). And please always use comma(,) as parameters delimeter, such as "=SUM(A1, E1, H2)".

User can set any formula in Workbook designer file. Aspose.Cells will keep all the formulas. If user use this property to set a formula to a cell, major part of Workbook built-in functions is supported. And more is coming. If you have any special need for Workbook built-in functions, please let us know.

Example

[C#]
        cell.Formula = "=SUM(A1:C3) + E6*2";
    [Visual Basic]
        cell.Formula = "=SUM(A1:C3) + E6*2"

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


HtmlString Property

Aspose.Cells for .NET

GridCell.HtmlString Property

Gets and sets the html string which contains data and some formattings in this cell.

public string HtmlString {get; set;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


IntValue Property

Aspose.Cells for .NET

GridCell.IntValue Property

Gets the integer value contained in the cell.

public int IntValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


IsStyleSet Property

Aspose.Cells for .NET

GridCell.IsStyleSet Property

Indicates if the cell's style is set. If return false, it means this cell has a default cell format.

public bool IsStyleSet {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

GridCell.Name Property

Gets the name of the cell. For example: A1, F102.

public string Name {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Row Property

Aspose.Cells for .NET

GridCell.Row Property

Gets row number (zero based) of the cell.

public int Row {get;}

Property Value

Cell row number

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


StringValue Property

Aspose.Cells for .NET

GridCell.StringValue Property

Gets the string value contained in the cell.

public string StringValue {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Style Property

Aspose.Cells for .NET

GridCell.Style Property

Gets the copy of cell style. set the style for the cell.

public GridTableItemStyle Style {get; set;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Type Property

Aspose.Cells for .NET

GridCell.Type Property

return the cell value type ,the meaning can see GridCellValueType.java

public int Type {get;}

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


Value Property

Aspose.Cells for .NET

GridCell.Value Property

Gets the value contained in this cell.

public object Value {get; set;}

Remarks

Possible type:

null,

Boolean,

DateTime,

Double,

Integer

String.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell Methods

The methods of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Instance Methods

ContainsExternalLink | Indicates wether this cell contains an external link. Only applies when the cell is a formula cell.
Copy | Copies data from a source cell.
CopyStyle | copy the style and set the style for the cell
CreateComment | Creates a comment object for a cell.
CreateValidation | Creates a validation object for a cell.
Equals |
GetCellArea |
GetComment | Get comment object on this cell
GetHashCode |
GetType (inherited from Object) |
GetWidthOfValue | Gets the width of the value in unit of pixels.
IsErrorValue | Checks if a formula can properly evaluate a result.
IsFormula | Represents if the specified cell contains formula.
PutValue | Overloaded. Puts a DateTime value into the cell.
PutValueAndSetFormatByValue | Sets the cell's value with a string value and set cell format by this value.
RemoveComment | Removes the comment object of the cell.
RemoveValidation | Removes the validation object of the cell.
SetBorder | Sets borders(top,bottom,left and right) for a cell,all the borders have same borderstyle.
SetCustom | sets the custom format, null or empty string means no custom format.
SetFormula | Set the formula and the value of the formula.
SetNumberType | set the display format of numbers and dates
ToString | Returns a string represents the current Cell object.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.ContainsExternalLink Method

Indicates wether this cell contains an external link. Only applies when the cell is a formula cell.

public bool ContainsExternalLink();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.Copy Method

Copies data from a source cell.

public void Copy(
GridCell source
);

Parameters

source
Source GridCell object.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.CopyStyle Method

copy the style and set the style for the cell

public void CopyStyle(
GridTableItemStyle style
);

Parameters

style
The source style.

Return Value

Style object.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.CreateComment Method

Creates a comment object for a cell.

public GridComment CreateComment(
string note,
string author,
bool isvisible
);

Parameters

note
comment note.
author
comment author.
isvisible
whether the comment is visible.

Return Value

GridComment object

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.CreateValidation Method

Creates a validation object for a cell.

public GridValidation CreateValidation(
GridValidationType validationType,
bool isRequried
);

Parameters

validationType
Validation type.
isRequried
Whether the cell value is required.

Return Value

Example

[C#]
    Validation v = cell1.CreateValidation(GridValidationType.CustomExpression, true);
    // Sets to number validation expression.
    v.RegEx = "\\d+";

[Visual Basic]
    Dim v As Validation =  cell1.CreateValidation(GridValidationType.CustomExpression,True)
     ' Sets to number validation expression.
    v.RegEx = "\\d+"

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.Equals Method

public override bool Equals(
object obj
);

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.GetCellArea Method

public GridCellArea GetCellArea();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.GetComment Method

Get comment object on this cell

public GridComment GetComment();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.GetHashCode Method

public override int GetHashCode();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.GetWidthOfValue Method

Gets the width of the value in unit of pixels.

public int GetWidthOfValue();

Return Value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.IsErrorValue Method

Checks if a formula can properly evaluate a result.

public bool IsErrorValue();

Remarks

Only applies to formula cell.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.IsFormula Method

Represents if the specified cell contains formula.

public bool IsFormula();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


PutValue Method

Aspose.Cells for .NET

GridCell.PutValue Method

Puts a boolean value into the cell.

Overload List

Puts a boolean value into the cell.

public void PutValue(bool);

Puts a DateTime value into the cell.

public void PutValue(DateTime);

Puts a double value into the cell.

public void PutValue(double);

Puts a int value into the cell.

public void PutValue(int);

Puts an object value into the cell.same as setValue(Object param_object)

public void PutValue(object);

Puts a String value into the cell.

public void PutValue(string);

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(string,bool);

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(string,bool,bool);

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.PutValue Method (Boolean)

Puts a boolean value into the cell.

public void PutValue(
bool param_boolean
);

Parameters

param_boolean
Input value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (DateTime)

Puts a DateTime value into the cell.

public void PutValue(
DateTime param_date
);

Parameters

param_date
Input value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (Double)

Puts a double value into the cell.

public void PutValue(
double param_double
);

Parameters

param_double
Input value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (Int32)

Puts a int value into the cell.

public void PutValue(
int param_int
);

Parameters

param_int
Input value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (Object)

Puts an object value into the cell.same as setValue(Object param_object)

public void PutValue(
object param_object
);

Parameters

param_object

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (String)

Puts a String value into the cell.

public void PutValue(
string param_string
);

Parameters

param_string
Input value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (String, Boolean)

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(
string stringValue,
bool isConverted
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValue Method (String, Boolean, Boolean)

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(
string stringValue,
bool isConverted,
bool setStyle
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.
setStyle
True: set the number format to cell's style when converting to other data type

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace | GridCell.PutValue Overload List


GridCell.PutValueAndSetFormatByValue Method

Sets the cell's value with a string value and set cell format by this value.

public void PutValueAndSetFormatByValue(
string stringValue
);

Parameters

stringValue
Input value.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.RemoveComment Method

Removes the comment object of the cell.

public void RemoveComment();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.RemoveValidation Method

Removes the validation object of the cell.

public void RemoveValidation();

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.SetBorder Method

Sets borders(top,bottom,left and right) for a cell,all the borders have same borderstyle.

public void SetBorder(
WebBorderStyle borderStyle
);

Parameters

borderStyle
The border style.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.SetCustom Method

sets the custom format, null or empty string means no custom format.

public void SetCustom(
string custom
);

Parameters

custom
the custom string presentation

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.SetFormula Method

Set the formula and the value of the formula.

public void SetFormula(
string formula,
object value
);

Parameters

formula
The formula.
value
The value of the formula.

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.SetNumberType Method

set the display format of numbers and dates

public void SetNumberType(
int numbertype
);

Parameters

numbertype
the value of ther numbertype,see GridTableItemStyle.NumberType

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell.ToString Method

Returns a string represents the current Cell object.

new public string ToString();

Return Value

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell Operators

The operators of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Static Operators

Equality Operator
Inequality Operator

See Also

GridCell Class | GridCell Members | Aspose.Cells.GridWeb.Data Namespace


GridCell Equality Operator

public static bool operator ==(
GridCell a,
GridCell b
);

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCell Inequality Operator

public static bool operator !=(
GridCell a,
GridCell b
);

See Also

GridCell Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea Class

Represents an area of cells.

For a list of all members of this type, see GridCellArea Members.

System.Object
Aspose.Cells.GridWeb.Data.GridCellArea

public class GridCellArea

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCellArea Members | Aspose.Cells.GridWeb.Data Namespace


GridCellArea Members

GridCellArea overview

Public Instance Constructors

GridCellArea Overloaded. Initializes a new instance of the GridCellArea class.

Public Instance Fields

EndColumn | Gets or sets the end column of this area.
EndRow | Gets or sets the end row of this area.
StartColumn | Gets or sets the start column of this area.
StartRow | Gets or sets the start row of this area.

Public Instance Methods

Equals | Test if the object equals to another WebCellArea object.
GetHashCode | Get the hashcode.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea Constructor

Creat a cell area.

Overload List

Creat a cell area.

public GridCellArea();

Creat a cell area.

public GridCellArea(int,int,int,int);

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea Constructor ()

Creat a cell area.

public GridCellArea();

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace | GridCellArea Constructor Overload List


GridCellArea Constructor (Int32, Int32, Int32, Int32)

Creat a cell area.

public GridCellArea(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
The start row.
startColumn
The start column.
endRow
The end row.
endColumn
The end column.

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace | GridCellArea Constructor Overload List


GridCellArea Fields

The fields of the GridCellArea class are listed below. For a complete list of GridCellArea class members, see the GridCellArea Members topic.

Public Instance Fields

EndColumn | Gets or sets the end column of this area.
EndRow | Gets or sets the end row of this area.
StartColumn | Gets or sets the start column of this area.
StartRow | Gets or sets the start row of this area.

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea.EndColumn Field

Gets or sets the end column of this area.

public int EndColumn;

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea.EndRow Field

Gets or sets the end row of this area.

public int EndRow;

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea.StartColumn Field

Gets or sets the start column of this area.

public int StartColumn;

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea.StartRow Field

Gets or sets the start row of this area.

public int StartRow;

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea Methods

The methods of the GridCellArea class are listed below. For a complete list of GridCellArea class members, see the GridCellArea Members topic.

Public Instance Methods

Equals | Test if the object equals to another WebCellArea object.
GetHashCode | Get the hashcode.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea.Equals Method

Test if the object equals to another WebCellArea object.

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellArea.GetHashCode Method

Get the hashcode.

public override int GetHashCode();

Return Value

See Also

GridCellArea Class | Aspose.Cells.GridWeb.Data Namespace


GridCellErrorType Enumeration

Used in WebCellException. Represents the cell error type.

public enum GridCellErrorType

Members

Member Name | Description | Value
ValidationError | The cell's validation failed. | 0
DataSourceInsertError | When insert the sheet's binding row to datasource, an error occured. | 1
DataSourceUpdateError | When update the sheet's binding row or object's field, an error occured. | 2
DataSourceDeleteError | When delete the sheet's binding row to datasource, an error occured. | 3

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridCellException Class

Represents a cell operation error.

For a list of all members of this type, see GridCellException Members.

System.Object
System.Exception
Aspose.Cells.GridWeb.Data.GridCellException

public class GridCellException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCellException Members | Aspose.Cells.GridWeb.Data Namespace


GridCellException Members

GridCellException overview

Public Instance Properties

Cell | Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.
Data (inherited from Exception) |
ErrorType | Gets the error type.
ErrorValue | Get the error value.
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

See Also

GridCellException Class | Aspose.Cells.GridWeb.Data Namespace


GridCellException Properties

The properties of the GridCellException class are listed below. For a complete list of GridCellException class members, see the GridCellException Members topic.

Public Instance Properties

Cell | Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.
Data (inherited from Exception) |
ErrorType | Gets the error type.
ErrorValue | Get the error value.
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

See Also

GridCellException Class | Aspose.Cells.GridWeb.Data Namespace


Cell Property

Aspose.Cells for .NET

GridCellException.Cell Property

Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.

public GridCell Cell {get;}

See Also

GridCellException Class | Aspose.Cells.GridWeb.Data Namespace


ErrorType Property

Aspose.Cells for .NET

GridCellException.ErrorType Property

Gets the error type.

public GridCellErrorType ErrorType {get;}

See Also

GridCellException Class | Aspose.Cells.GridWeb.Data Namespace


ErrorValue Property

Aspose.Cells for .NET

GridCellException.ErrorValue Property

Get the error value.

public string ErrorValue {get;}

See Also

GridCellException Class | Aspose.Cells.GridWeb.Data Namespace


GridCells Class

Encapsulates a collection of Cell objects.

For a list of all members of this type, see GridCells Members.

System.Object
Aspose.Cells.GridWeb.Data.GridCells

public class GridCells : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCells Members | Aspose.Cells.GridWeb.Data Namespace


GridCells Members

GridCells overview

Public Static Methods

CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.

Public Instance Properties

Columns |
Count | Gets the number of cells.
FirstCell |
Item | Overloaded. Gets Cell item within the worksheet
LastCell |
MaxColumn | Maximum column index of cell which contains data or style.
MaxDataColumn |
MaxDataRow |
MaxRow | Maximum row index of cell which contains data or style.
MergedCells | Gets the collection of merged cells.
MinColumn |
MinDataColumn |
MinDataRow |
MinRow |
RowEnumerator | Gets the rows enumerator
Rows |
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet,in unit of pixels.
StandardWidth | Gets or sets the default column width in the worksheet,in unit of characters.
StandardWidthInch |
StandardWidthPixels |

Public Instance Methods

Clear | Clear all cells in the collection.
ClearContents | Overloaded. Clears contents of a range.
ClearFormats | Overloaded. Clears formatting of a range.
ClearRange | Overloaded. Clears contents and formatting of a range.
CopyColumn | Copies data and formattings of a whole column.
CopyColumns | Copies data and formattings of a whole column.
CopyRow | Copies data and formattings of a whole row.
CopyRows | Copies data and formattings of some whole rows.
DeleteBlankColumns | Delete all blank columns which do not contain any data.
DeleteBlankRows | Delete all blank rows which do not contain any data.
DeleteColumn | Overloaded. Deletes a column.
DeleteColumns | Deletes several columns.
DeleteRow | Deletes a row.
DeleteRows | Overloaded. Deletes several rows.
Equals (inherited from Object) |
Export | Exports data in the Cells collection of a WebWorksheet to a new DataTable object
ExportArray | Exports data in the Cells collection to a two-dimension array object.
GetCell | Gets the Cell element or null at the specified cell row index and column index.
GetColumnWidth | Gets the width of the specified column
GetColumnWidthInch | Gets the width of the specified column, in units of inches.
GetColumnWidthPixel | Gets the width of the specified column, in units of pixel.
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRow | Gets the Row element or at the specified cell row index.
GetRowHeight | Gets the height of a specified row.
GetRowHeightInch | Gets the height of a specified row in unit of inches.
GetRowHeightPixel | Gets the height of a specified row in unit of pixel.
GetRowOutlineLevel | Gets the outline level of the row.
GetType (inherited from Object) |
GetViewColumnWidthPixel | Get the width in different view type.
GroupColumns | Overloaded. Groups columns.
GroupRows | Groups rows.
HideColumn | Hides a column.
HideRow | Hides a row.
InsertColumn | Overloaded. Inserts a new column into the worksheet.
InsertColumns | Overloaded. Inserts some columns into the worksheet.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Overloaded. Inserts multiple rows into the worksheet.
IsBlankColumn | Checks whether given column is blank(does not contain any data).
IsColumnHidden | Checks whether a column at given index is hidden.
IsRowHidden | Checks whether a row at given index is hidden.
Merge | Merges a specified range of cells into a single cell.
RemoveFormulas | Removes all formula and replaces with the value of the formula.
SetBorders | Sets borders for a cells range.
SetColumnWidth | Sets the width of the specified column.
SetColumnWidthInch | Sets column width in unit of inches.
SetColumnWidthPixel | Sets column width in unit of pixels.
SetRowHeight | Sets the height of the specified row.
SetRowHeightInch | Sets row height in unit of inches.
SetRowHeightPixel | Sets row height in unit of pixels.
SetRowOutlineLevel | Sets the outline level of the row.
SetStyle | Overloaded. Sets the style to a specified range of cells.
Sort | Overloaded. Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.
ToString (inherited from Object) |
UngroupColumns | Ungroups columns.
UngroupRows | Ungroups rows.
UnhideColumn | Unhides a column
UnhideRow | Unhides a row.
UnMerge | Unmerges a specified range of merged cells.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells Properties

The properties of the GridCells class are listed below. For a complete list of GridCells class members, see the GridCells Members topic.

Public Instance Properties

Columns |
Count | Gets the number of cells.
FirstCell |
Item | Overloaded. Gets Cell item within the worksheet
LastCell |
MaxColumn | Maximum column index of cell which contains data or style.
MaxDataColumn |
MaxDataRow |
MaxRow | Maximum row index of cell which contains data or style.
MergedCells | Gets the collection of merged cells.
MinColumn |
MinDataColumn |
MinDataRow |
MinRow |
RowEnumerator | Gets the rows enumerator
Rows |
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet,in unit of pixels.
StandardWidth | Gets or sets the default column width in the worksheet,in unit of characters.
StandardWidthInch |
StandardWidthPixels |

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


Columns Property

Aspose.Cells for .NET

GridCells.Columns Property

public GridColumnCollection Columns {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridCells.Count Property

Gets the number of cells.

public int Count {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


FirstCell Property

Aspose.Cells for .NET

GridCells.FirstCell Property

public GridCell FirstCell {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridCells.Item Property

Gets Cell item within the worksheet

Overload List

Gets Cell item within the worksheet

public GridCell this[int] {get;}

Gets the Cell element at the specified cell row index and column index.

public GridCell this[int, int] {get;}

Gets the Cell element at the specified cell name.

public GridCell this[string] {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridCells.Item Property (Int32)

Gets Cell item within the worksheet

public GridCell this[
int index
] {get;}

Parameters

index
The zero based index of the element.

Property Value

The element at the specified index.

Remarks

This is the indexer for the Cells class. Gets the cell element at the specified index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridCells.Item Property (Int32, Int32)

Gets the Cell element at the specified cell row index and column index.

public GridCell this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

Example

[C#]

 Cells cells = excel.Worksheets[0].Cells;
 //Gets the cell at "A1"
 Cell cell = cells[0, 0];

 [Visual Basic]

 Dim cells As Cells =  excel.WorkSheets(0).Cells
  'Gets the cell at "A1"
 Dim cell As Cell =  cells(0,0)

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.Item Overload List


Item Property (String)

Aspose.Cells for .NET

GridCells.Item Property (String)

Gets the Cell element at the specified cell name.

public GridCell this[
string cellName
] {get;}

Parameters

cellName
Cell name,including its column letter and row number, for example A5.

Example

[C#]

 Cells cells = excel.Worksheets[0].Cells;
 Cell cell = cells["A1"];    //Gets the cell at "A1"

 [Visual Basic]

 Dim cells As Cells =  excel.Worksheets(0).Cells
 Dim cell As Cell =  cells("A1")  'Gets the cell at "A1"

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.Item Overload List


LastCell Property

Aspose.Cells for .NET

GridCells.LastCell Property

public GridCell LastCell {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MaxColumn Property

Aspose.Cells for .NET

GridCells.MaxColumn Property

Maximum column index of cell which contains data or style.

public int MaxColumn {get;}

Remarks

Return -1 if ther is not cell.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MaxDataColumn Property

Aspose.Cells for .NET

GridCells.MaxDataColumn Property

public int MaxDataColumn {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MaxDataRow Property

Aspose.Cells for .NET

GridCells.MaxDataRow Property

public int MaxDataRow {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MaxRow Property

Aspose.Cells for .NET

GridCells.MaxRow Property

Maximum row index of cell which contains data or style.

public int MaxRow {get;}

Remarks

Return -1 if there is no cell whiche contains data or style in the worksheet.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MergedCells Property

Aspose.Cells for .NET

GridCells.MergedCells Property

Gets the collection of merged cells.

public ArrayList MergedCells {get;}

Remarks

In this collection, each item is a GridCellArea structure which represents an area of merged cells.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MinColumn Property

Aspose.Cells for .NET

GridCells.MinColumn Property

public int MinColumn {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MinDataColumn Property

Aspose.Cells for .NET

GridCells.MinDataColumn Property

public int MinDataColumn {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MinDataRow Property

Aspose.Cells for .NET

GridCells.MinDataRow Property

public int MinDataRow {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


MinRow Property

Aspose.Cells for .NET

GridCells.MinRow Property

public int MinRow {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


RowEnumerator Property

Aspose.Cells for .NET

GridCells.RowEnumerator Property

Gets the rows enumerator

public IEnumerator RowEnumerator {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


Rows Property

Aspose.Cells for .NET

GridCells.Rows Property

public GridRowCollection Rows {get;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardHeight Property

Aspose.Cells for .NET

GridCells.StandardHeight Property

Gets or sets the default row height in this worksheet,in unit of points.

public double StandardHeight {get; set;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardHeightPixels Property

Aspose.Cells for .NET

GridCells.StandardHeightPixels Property

Gets or sets the default row height in this worksheet,in unit of pixels.

public int StandardHeightPixels {get; set;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardWidth Property

Aspose.Cells for .NET

GridCells.StandardWidth Property

Gets or sets the default column width in the worksheet,in unit of characters.

public double StandardWidth {get; set;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardWidthInch Property

Aspose.Cells for .NET

GridCells.StandardWidthInch Property

public double StandardWidthInch {get; set;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardWidthPixels Property

Aspose.Cells for .NET

GridCells.StandardWidthPixels Property

public int StandardWidthPixels {get; set;}

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells Methods

The methods of the GridCells class are listed below. For a complete list of GridCells class members, see the GridCells Members topic.

Public Static Methods

CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.

Public Instance Methods

Clear | Clear all cells in the collection.
ClearContents | Overloaded. Clears contents of a range.
ClearFormats | Overloaded. Clears formatting of a range.
ClearRange | Overloaded. Clears contents and formatting of a range.
CopyColumn | Copies data and formattings of a whole column.
CopyColumns | Copies data and formattings of a whole column.
CopyRow | Copies data and formattings of a whole row.
CopyRows | Copies data and formattings of some whole rows.
DeleteBlankColumns | Delete all blank columns which do not contain any data.
DeleteBlankRows | Delete all blank rows which do not contain any data.
DeleteColumn | Overloaded. Deletes a column.
DeleteColumns | Deletes several columns.
DeleteRow | Deletes a row.
DeleteRows | Overloaded. Deletes several rows.
Equals (inherited from Object) |
Export | Exports data in the Cells collection of a WebWorksheet to a new DataTable object
ExportArray | Exports data in the Cells collection to a two-dimension array object.
GetCell | Gets the Cell element or null at the specified cell row index and column index.
GetColumnWidth | Gets the width of the specified column
GetColumnWidthInch | Gets the width of the specified column, in units of inches.
GetColumnWidthPixel | Gets the width of the specified column, in units of pixel.
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRow | Gets the Row element or at the specified cell row index.
GetRowHeight | Gets the height of a specified row.
GetRowHeightInch | Gets the height of a specified row in unit of inches.
GetRowHeightPixel | Gets the height of a specified row in unit of pixel.
GetRowOutlineLevel | Gets the outline level of the row.
GetType (inherited from Object) |
GetViewColumnWidthPixel | Get the width in different view type.
GroupColumns | Overloaded. Groups columns.
GroupRows | Groups rows.
HideColumn | Hides a column.
HideRow | Hides a row.
InsertColumn | Overloaded. Inserts a new column into the worksheet.
InsertColumns | Overloaded. Inserts some columns into the worksheet.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Overloaded. Inserts multiple rows into the worksheet.
IsBlankColumn | Checks whether given column is blank(does not contain any data).
IsColumnHidden | Checks whether a column at given index is hidden.
IsRowHidden | Checks whether a row at given index is hidden.
Merge | Merges a specified range of cells into a single cell.
RemoveFormulas | Removes all formula and replaces with the value of the formula.
SetBorders | Sets borders for a cells range.
SetColumnWidth | Sets the width of the specified column.
SetColumnWidthInch | Sets column width in unit of inches.
SetColumnWidthPixel | Sets column width in unit of pixels.
SetRowHeight | Sets the height of the specified row.
SetRowHeightInch | Sets row height in unit of inches.
SetRowHeightPixel | Sets row height in unit of pixels.
SetRowOutlineLevel | Sets the outline level of the row.
SetStyle | Overloaded. Sets the style to a specified range of cells.
Sort | Overloaded. Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.
ToString (inherited from Object) |
UngroupColumns | Ungroups columns.
UngroupRows | Ungroups rows.
UnhideColumn | Unhides a column
UnhideRow | Unhides a row.
UnMerge | Unmerges a specified range of merged cells.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.CellIndexToName Method

Gets cell name according to its row and column indexes.

public static string CellIndexToName(
int row,
int column
);

Parameters

row
Row index.
column
Column index.

Return Value

Name of cell.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.CellNameToIndex Method

public static void CellNameToIndex(
string cellName,
out int row,
out int column
);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.Clear Method

Clear all cells in the collection.

public void Clear();

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


ClearContents Method

Aspose.Cells for .NET

GridCells.ClearContents Method

Clears contents of a range.

Overload List

Clears contents of a range.

public void ClearContents(GridCellArea);

Clears contents of a range.

public void ClearContents(int,int,int,int);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.ClearContents Method (GridCellArea)

Clears contents of a range.

public void ClearContents(
GridCellArea range
);

Parameters

range
Range to be cleared.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.ClearContents Overload List


GridCells.ClearContents Method (Int32, Int32, Int32, Int32)

Clears contents of a range.

public void ClearContents(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.ClearContents Overload List


ClearFormats Method

Aspose.Cells for .NET

GridCells.ClearFormats Method

Clears formatting of a range.

Overload List

Clears formatting of a range.

public void ClearFormats(GridCellArea);

Clears formatting of a range.

public void ClearFormats(int,int,int,int);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.ClearFormats Method (GridCellArea)

Clears formatting of a range.

public void ClearFormats(
GridCellArea range
);

Parameters

range
Range to be cleared.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.ClearFormats Overload List


GridCells.ClearFormats Method (Int32, Int32, Int32, Int32)

Clears formatting of a range.

public void ClearFormats(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.ClearFormats Overload List


ClearRange Method

Aspose.Cells for .NET

GridCells.ClearRange Method

Clears contents and formatting of a range.

Overload List

Clears contents and formatting of a range.

public void ClearRange(GridCellArea);

Clears contents and formatting of a range.

public void ClearRange(int,int,int,int);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.ClearRange Method (GridCellArea)

Clears contents and formatting of a range.

public void ClearRange(
GridCellArea range
);

Parameters

range
Range to be cleared.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.ClearRange Overload List


GridCells.ClearRange Method (Int32, Int32, Int32, Int32)

Clears contents and formatting of a range.

public void ClearRange(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.ClearRange Overload List


GridCells.ColumnIndexToName Method

Gets column name according to column index.

public static string ColumnIndexToName(
int column
);

Parameters

column
Column index.

Return Value

Name of column.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.ColumnNameToIndex Method

Gets column index according to column name.

public static int ColumnNameToIndex(
string columnName
);

Parameters

columnName
Column name.

Return Value

Column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.CopyColumn Method

Copies data and formattings of a whole column.

public void CopyColumn(
GridCells sourceCells,
int sourceColumnIndex,
int destinationColumnIndex
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.CopyColumns Method

Copies data and formattings of a whole column.

public void CopyColumns(
GridCells sourceCells,
int sourceColumnIndex,
int destinationColumnIndex,
int columnNumber
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceColumnIndex
Source column index.
destinationColumnIndex
Destination column index.
columnNumber
The copied column number.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.CopyRow Method

Copies data and formattings of a whole row.

public void CopyRow(
GridCells sourceCells,
int sourceRowIndex,
int destinationRowIndex
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.CopyRows Method

Copies data and formattings of some whole rows.

public void CopyRows(
GridCells sourceCells,
int sourceRowIndex,
int destinationRowIndex,
int rowNumber
);

Parameters

sourceCells
Source Cells object contains data and formattings to copy.
sourceRowIndex
Source row index.
destinationRowIndex
Destination row index.
rowNumber
The copied row number.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.DeleteBlankColumns Method

Delete all blank columns which do not contain any data.

public void DeleteBlankColumns();

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.DeleteBlankRows Method

Delete all blank rows which do not contain any data.

public void DeleteBlankRows();

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


DeleteColumn Method

Aspose.Cells for .NET

GridCells.DeleteColumn Method

Deletes a column.

Overload List

Deletes a column.

public void DeleteColumn(int);

Deletes a column.

public void DeleteColumn(int,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.DeleteColumn Method (Int32)

Deletes a column.

public void DeleteColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.DeleteColumn Overload List


GridCells.DeleteColumn Method (Int32, Boolean)

Deletes a column.

public void DeleteColumn(
int columnIndex,
bool updateReference
);

Parameters

columnIndex
Column index.
updateReference
Indicates if update references in other worksheets.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.DeleteColumn Overload List


GridCells.DeleteColumns Method

Deletes several columns.

public void DeleteColumns(
int columnIndex,
int totalColumns,
bool updateReference
);

Parameters

columnIndex
Column index.
totalColumns
Number of columns to be deleted.
updateReference
Indicates if update references in other worksheets.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.DeleteRow Method

Deletes a row.

public void DeleteRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


DeleteRows Method

Aspose.Cells for .NET

GridCells.DeleteRows Method

Deletes several rows.

Overload List

Deletes several rows.

public bool DeleteRows(int,int);

Deletes multiple rows in the worksheet.

public bool DeleteRows(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.DeleteRows Method (Int32, Int32)

Deletes several rows.

public bool DeleteRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
The first row index to be deleted.
totalRows
Number of rows to be deleted.

Remarks

If the deleted range contains the top part(not whole) of the table(ListObject), the ranged could not be deleted and nothing will be done.It works as MS Excel.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.DeleteRows Overload List


GridCells.DeleteRows Method (Int32, Int32, Boolean)

Deletes multiple rows in the worksheet.

public bool DeleteRows(
int rowIndex,
int totalRows,
bool updateReference
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be deleted.
updateReference
Indicates if update references in other worksheets.

Return Value

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.DeleteRows Overload List


GridCells.Export Method

Exports data in the Cells collection of a WebWorksheet to a new DataTable object

public DataTable Export(
int startRow,
int startColumn,
int rows,
int columns,
bool exportColumnName,
bool isVertical
);

Parameters

startRow
The row number of the first cell to export out.
startColumn
The column number of the first cell to export out.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
exportColumnName
Indicates whether the data in the first row are exported as the column name of the DataTable
isVertical
True if a row in Excel file represents a row in DataTable. False if a column in Excel file represents a row in DataTable.

Return Value

Exported DataTable object.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.ExportArray Method

Exports data in the Cells collection to a two-dimension array object.

public object[,] ExportArray(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be exported
totalColumns
Number of columns to be exported

Return Value

Exported cell value array object.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetCell Method

Gets the Cell element or null at the specified cell row index and column index.

public GridCell GetCell(
int row,
int column
);

Parameters

row
Row index
column
Column index

Return Value

Return Cell object if a Cell object exists. Return null if the cell does not exist.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetColumnWidth Method

Gets the width of the specified column

public double GetColumnWidth(
int column
);

Parameters

column
Column index

Return Value

Width of column

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetColumnWidthInch Method

Gets the width of the specified column, in units of inches.

public double GetColumnWidthInch(
int column
);

Parameters

column
Column index

Return Value

Width of column

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetColumnWidthPixel Method

Gets the width of the specified column, in units of pixel.

public int GetColumnWidthPixel(
int column
);

Parameters

column
Column index

Return Value

Width of column in normal view.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

Implements

IEnumerable.GetEnumerator

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetRow Method

Gets the Row element or at the specified cell row index.

public GridRow GetRow(
int i
);

Parameters

i

Return Value

If the row object does exist return Row object,otherwise return null.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetRowHeight Method

Gets the height of a specified row.

public double GetRowHeight(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetRowHeightInch Method

Gets the height of a specified row in unit of inches.

public double GetRowHeightInch(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetRowHeightPixel Method

Gets the height of a specified row in unit of pixel.

public int GetRowHeightPixel(
int row
);

Parameters

row
Row index

Return Value

Height of row

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetRowOutlineLevel Method

Gets the outline level of the row.

public int GetRowOutlineLevel(
int rowIndex
);

Parameters

rowIndex
row index.

Return Value

the outline level.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GetViewColumnWidthPixel Method

Get the width in different view type.

public int GetViewColumnWidthPixel(
int column
);

Parameters

column
The column index.

Return Value

the column width in unit of pixels

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GroupColumns Method

Aspose.Cells for .NET

GridCells.GroupColumns Method

Groups columns.

Overload List

Groups columns.

public void GroupColumns(int,int);

Groups columns.

public void GroupColumns(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.GroupColumns Method (Int32, Int32)

Groups columns.

public void GroupColumns(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first column index to be grouped.
lastIndex
The last column index to be grouped.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.GroupColumns Overload List


GridCells.GroupColumns Method (Int32, Int32, Boolean)

Groups columns.

public void GroupColumns(
int firstIndex,
int lastIndex,
bool isHidden
);

Parameters

firstIndex
The first column index to be grouped.
lastIndex
The last column index to be grouped.
isHidden
Specifies if the grouped columns are hidden.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.GroupColumns Overload List


GridCells.GroupRows Method

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.HideColumn Method

Hides a column.

public void HideColumn(
int column
);

Parameters

column
Column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.HideRow Method

Hides a row.

public void HideRow(
int row
);

Parameters

row
Row index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


InsertColumn Method

Aspose.Cells for .NET

GridCells.InsertColumn Method

Inserts a new column into the worksheet.

Overload List

Inserts a new column into the worksheet.

public void InsertColumn(int);

Inserts a new column into the worksheet.

public void InsertColumn(int,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.InsertColumn Method (Int32)

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.InsertColumn Overload List


GridCells.InsertColumn Method (Int32, Boolean)

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex,
bool updateReference
);

Parameters

columnIndex
Column index.
updateReference
Indicates if references in other worksheets will be updated.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.InsertColumn Overload List


InsertColumns Method

Aspose.Cells for .NET

GridCells.InsertColumns Method

Inserts some columns into the worksheet.

Overload List

Inserts some columns into the worksheet.

public void InsertColumns(int,int);

Inserts some columns into the worksheet.

public void InsertColumns(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.InsertColumns Method (Int32, Int32)

Inserts some columns into the worksheet.

public void InsertColumns(
int columnIndex,
int totalColumns
);

Parameters

columnIndex
Column index.
totalColumns
The number of columns.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.InsertColumns Overload List


GridCells.InsertColumns Method (Int32, Int32, Boolean)

Inserts some columns into the worksheet.

public void InsertColumns(
int columnIndex,
int totalColumns,
bool updateReference
);

Parameters

columnIndex
Column index.
totalColumns
The number of columns.
updateReference
Indicates if references in other worksheets will be updated.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.InsertColumns Overload List


GridCells.InsertRow Method

Inserts a new row into the worksheet.

public void InsertRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


InsertRows Method

Aspose.Cells for .NET

GridCells.InsertRows Method

Inserts multiple rows into the worksheet.

Overload List

Inserts multiple rows into the worksheet.

public void InsertRows(int,int);

Inserts multiple rows into the worksheet.

public void InsertRows(int,int,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.InsertRows Method (Int32, Int32)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.InsertRows Overload List


GridCells.InsertRows Method (Int32, Int32, Boolean)

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows,
bool updateReference
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.
updateReference
Indicates if references in other worksheets will be updated.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.InsertRows Overload List


GridCells.IsBlankColumn Method

Checks whether given column is blank(does not contain any data).

public bool IsBlankColumn(
int columnIndex
);

Parameters

columnIndex
the column index

Return Value

true if given column does not contain any data

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.IsColumnHidden Method

Checks whether a column at given index is hidden.

public bool IsColumnHidden(
int columnIndex
);

Parameters

columnIndex
column index

Return Value

true if the column is hidden.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.IsRowHidden Method

Checks whether a row at given index is hidden.

public bool IsRowHidden(
int rowIndex
);

Parameters

rowIndex
row index

Return Value

true if the row is hidden

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.Merge Method

Merges a specified range of cells into a single cell.

public void Merge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

Remarks

Reference the merged cell via the address of the upper-left cell in the range.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.RemoveFormulas Method

Removes all formula and replaces with the value of the formula.

public void RemoveFormulas();

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetBorders Method

Sets borders for a cells range.

public void SetBorders(
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
SetBorderPosition position,
WebBorderStyle borderStyle
);

Parameters

firstRow
The first row number of the range(zero based).
firstColumn
The first column number of the range(zero based).
rowNumber
The rows number.
columnNumber
The columns number.
position
The border position.
borderStyle
The border style.

Example

[C#]
    GridWeb1.WebWorksheets[0].Cells.SetBorders(0, 0, 5, 8, SetBorderPosition.Outline, borderStyle1);

[VB]
    GridWeb1.WebWorksheets(0).Cells.SetBorders(0, 0, 5, 8, SetBorderPosition.Outline, borderStyle1)

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetColumnWidth Method

Sets the width of the specified column.

public void SetColumnWidth(
int column,
double width
);

Parameters

column
Column index.
width
Width of column.Column width must be between 0 and 255.

Remarks

To hide a column, sets column width to zero.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetColumnWidthInch Method

Sets column width in unit of inches.

public void SetColumnWidthInch(
int column,
double inches
);

Parameters

column
Column index.
inches
Number of inches.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetColumnWidthPixel Method

Sets column width in unit of pixels.

public void SetColumnWidthPixel(
int column,
int pixel
);

Parameters

column
Column index.
pixel
Number of pixels.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetRowHeight Method

Sets the height of the specified row.

public void SetRowHeight(
int row,
double height
);

Parameters

row
Row index.
height
Height of row.In unit of point It should be between 0 and 409.5.

Remarks

To hide a row, sets row height to zero.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetRowHeightInch Method

Sets row height in unit of inches.

public void SetRowHeightInch(
int row,
double inches
);

Parameters

row
Row index.
inches
Number of inches.It should be between 0 and 409.5/72.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetRowHeightPixel Method

Sets row height in unit of pixels.

public void SetRowHeightPixel(
int row,
int pixels
);

Parameters

row
Row index.
pixels
Number of pixels.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetRowOutlineLevel Method

Sets the outline level of the row.

public void SetRowOutlineLevel(
int rowIndex,
int outlineLevel
);

Parameters

rowIndex
row index.
outlineLevel
outline level.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


SetStyle Method

Aspose.Cells for .NET

GridCells.SetStyle Method

Sets the style to a specified range of cells.

Overload List

Sets the style to a specified range of cells.

public void SetStyle(int,int,int,int,GridTableItemStyle);

Sets the style to a specified range of cells.

public void SetStyle(string,GridTableItemStyle);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.SetStyle Method (Int32, Int32, Int32, Int32, GridTableItemStyle)

Sets the style to a specified range of cells.

public void SetStyle(
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
GridTableItemStyle style
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
rowNumber
Number of rows(one based)
columnNumber
Number of columns(one based)
style
The style object to be set

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.SetStyle Overload List


GridCells.SetStyle Method (String, GridTableItemStyle)

Sets the style to a specified range of cells.

public void SetStyle(
string cellRange,
GridTableItemStyle style
);

Parameters

cellRange
The range of cells' names, like "A1:D6"
style
The style object to be set

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.SetStyle Overload List


Sort Method

Aspose.Cells for .NET

GridCells.Sort Method

Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.

Overload List

Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.

public void Sort(int,int,int,int,int,bool,bool,bool);

public void Sort(int,int,int,int,int[],SortOrder[],SortOrientation,bool);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.Sort Method (Int32, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)

Sorts the datas ascend/decend top to bottom in a range of a Worksheet by specified column index. Sorts the datas ascend/decend left to right in a range of a Worksheet by specified row index.

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int index,
bool isAsending,
bool isCaseSensitive,
bool islefttoright
);

Parameters

startRow
The row number of the first cell to sort.
startColumn
The column number of the first cell to sort.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
index
The column index that specifis the sort column. if the Orientation is top to bottom ,it stand for the column index that specifis the sort column. if the Orientation is from left to right,it stand for the row index that specifis the sort row.
isAsending
whether the sorting order is asending .
isCaseSensitive
whether the sort is casesensitive .
islefttoright
whether the sort orientation is from left to right

Example

[C#]

 GridWeb1.WebWorksheets[0].Cells.Sort(1,0,25,6,3,true,true,false);

 [VB]

 GridWeb1.WebWorksheets(0).Cells.Sort(1,0,25,6,3,true,true,false)

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.Sort Overload List


GridCells.Sort Method (Int32, Int32, Int32, Int32, Int32[], SortOrder[], SortOrientation, Boolean)

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int[] indexes,
SortOrder[] orders,
SortOrientation orientation,
bool isCaseSensitive
);

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace | GridCells.Sort Overload List


GridCells.UngroupColumns Method

Ungroups columns.

public void UngroupColumns(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first column index to be ungrouped.
lastIndex
The last column index to be ungrouped.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.UngroupRows Method

Ungroups rows.

public void UngroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be ungrouped.
lastIndex
The last row index to be ungrouped.

Remarks

Only removes outter group info.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.UnhideColumn Method

Unhides a column

public void UnhideColumn(
int column,
double width
);

Parameters

column
Column index.
width
Column width..Column width must be between 0 and 255

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.UnhideRow Method

Unhides a row.

public void UnhideRow(
int row
);

Parameters

row
Row index.

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridCells.UnMerge Method

Unmerges a specified range of merged cells.

public void UnMerge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

See Also

GridCells Class | Aspose.Cells.GridWeb.Data Namespace


GridColumn Class

Represents a single column in a worksheet.

For a list of all members of this type, see GridColumn Members.

System.Object
Aspose.Cells.GridWeb.Data.GridColumn

public class GridColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridColumn Members | Aspose.Cells.GridWeb.Data Namespace


GridColumn Members

GridColumn overview

Public Instance Properties

Caption |
Hidden | Indicates whether the column is hidden.
Index | Gets the index of this column.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridColumn Class | Aspose.Cells.GridWeb.Data Namespace


GridColumn Properties

The properties of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Instance Properties

Caption |
Hidden | Indicates whether the column is hidden.
Index | Gets the index of this column.

See Also

GridColumn Class | Aspose.Cells.GridWeb.Data Namespace


Caption Property

Aspose.Cells for .NET

GridColumn.Caption Property

public string Caption {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridWeb.Data Namespace


Hidden Property

Aspose.Cells for .NET

GridColumn.Hidden Property

Indicates whether the column is hidden.

public bool Hidden {get; set;}

See Also

GridColumn Class | Aspose.Cells.GridWeb.Data Namespace


Index Property

Aspose.Cells for .NET

GridColumn.Index Property

Gets the index of this column.

public int Index {get;}

See Also

GridColumn Class | Aspose.Cells.GridWeb.Data Namespace


GridColumnCollection Class

Collects the objects that represent the individual columns in a worksheet.

For a list of all members of this type, see GridColumnCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridColumnCollection

public class GridColumnCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridColumnCollection Members | Aspose.Cells.GridWeb.Data Namespace | Column


GridColumnCollection Members

GridColumnCollection overview

Public Instance Properties

Count |
Item | Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

Public Instance Methods

Equals (inherited from Object) |
GetColumnByIndex | Gets the Column object by the position in the list.
GetEnumerator | Gets the columns enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace | Column


GridColumnCollection Properties

The properties of the GridColumnCollection class are listed below. For a complete list of GridColumnCollection class members, see the GridColumnCollection Members topic.

Public Instance Properties

Count |
Item | Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace | Column


Count Property

Aspose.Cells for .NET

GridColumnCollection.Count Property

public int Count {get;}

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridColumnCollection.Item Property

Gets a object by column index. The Column object of given column index will be instantiated if it does not exist before.

public GridColumn this[
int columnIndex
] {get;}

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace | Column


GridColumnCollection Methods

The methods of the GridColumnCollection class are listed below. For a complete list of GridColumnCollection class members, see the GridColumnCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetColumnByIndex | Gets the Column object by the position in the list.
GetEnumerator | Gets the columns enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace | Column


GridColumnCollection.GetColumnByIndex Method

Gets the Column object by the position in the list.

public GridColumn GetColumnByIndex(
int index
);

Parameters

index
The position in the list.

Return Value

Returns the column object.

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridColumnCollection.GetEnumerator Method

Gets the columns enumerator

public IEnumerator GetEnumerator();

Return Value

The columns enumerator

See Also

GridColumnCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridComment Class

Encapsulates the object that represents a cell comment.

For a list of all members of this type, see GridComment Members.

System.Object
Aspose.Cells.GridWeb.Data.GridComment

public class GridComment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridComment Members | Aspose.Cells.GridWeb.Data Namespace


GridComment Members

GridComment overview

Public Instance Properties

Author |
AutoSize |
Column |
Height | Represents the Height of the comment, in unit of pixels.
HeightCM |
HeightInch |
HtmlNote |
IsVisible |
Note |
Row |
Width | Represents the width of the comment, in unit of pixels.
WidthCM |
WidthInch |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


GridComment Properties

The properties of the GridComment class are listed below. For a complete list of GridComment class members, see the GridComment Members topic.

Public Instance Properties

Author |
AutoSize |
Column |
Height | Represents the Height of the comment, in unit of pixels.
HeightCM |
HeightInch |
HtmlNote |
IsVisible |
Note |
Row |
Width | Represents the width of the comment, in unit of pixels.
WidthCM |
WidthInch |

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


Author Property

Aspose.Cells for .NET

GridComment.Author Property

public string Author {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


AutoSize Property

Aspose.Cells for .NET

GridComment.AutoSize Property

public bool AutoSize {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


Column Property

Aspose.Cells for .NET

GridComment.Column Property

public int Column {get;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


Height Property

Aspose.Cells for .NET

GridComment.Height Property

Represents the Height of the comment, in unit of pixels.

public int Height {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


HeightCM Property

Aspose.Cells for .NET

GridComment.HeightCM Property

public double HeightCM {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


HeightInch Property

Aspose.Cells for .NET

GridComment.HeightInch Property

public double HeightInch {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


HtmlNote Property

Aspose.Cells for .NET

GridComment.HtmlNote Property

public string HtmlNote {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


IsVisible Property

Aspose.Cells for .NET

GridComment.IsVisible Property

public bool IsVisible {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


Note Property

Aspose.Cells for .NET

GridComment.Note Property

public string Note {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


Row Property

Aspose.Cells for .NET

GridComment.Row Property

public int Row {get;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


Width Property

Aspose.Cells for .NET

GridComment.Width Property

Represents the width of the comment, in unit of pixels.

public int Width {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


WidthCM Property

Aspose.Cells for .NET

GridComment.WidthCM Property

public double WidthCM {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


WidthInch Property

Aspose.Cells for .NET

GridComment.WidthInch Property

public double WidthInch {get; set;}

See Also

GridComment Class | Aspose.Cells.GridWeb.Data Namespace


GridCommentCollection Class

Encapsulates a collection of Comment objects.

For a list of all members of this type, see GridCommentCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridCommentCollection

public class GridCommentCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCommentCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridCommentCollection Members

GridCommentCollection overview

Public Instance Properties

Count |
Item | Overloaded. Gets the Comment element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a comment to the collection.
Clear | Removes all comments;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Overloaded. Removes the comment of the specific cell.
ToString (inherited from Object) |

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridCommentCollection Properties

The properties of the GridCommentCollection class are listed below. For a complete list of GridCommentCollection class members, see the GridCommentCollection Members topic.

Public Instance Properties

Count |
Item | Overloaded. Gets the Comment element at the specified index.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridCommentCollection.Count Property

public int Count {get;}

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridCommentCollection.Item Property

Gets the Comment element at the specified index.

Overload List

Gets the Comment element at the specified index.

public GridComment this[int] {get;}

Gets the Comment element at the specified row index and column index.

public GridComment this[int, int] {get;}

Gets the Comment element at the specified cell.

public GridComment this[string] {get;}

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridCommentCollection.Item Property (Int32)

Gets the Comment element at the specified index.

public GridComment this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

GridCommentCollection.Item Property (Int32, Int32)

Gets the Comment element at the specified row index and column index.

public GridComment this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

GridCommentCollection.Item Property (String)

Gets the Comment element at the specified cell.

public GridComment this[
string cellName
] {get;}

Parameters

cellName
Cell name.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.Item Overload List


GridCommentCollection Methods

The methods of the GridCommentCollection class are listed below. For a complete list of GridCommentCollection class members, see the GridCommentCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a comment to the collection.
Clear | Removes all comments;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Overloaded. Removes the comment of the specific cell.
ToString (inherited from Object) |

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

GridCommentCollection.Add Method

Adds a comment to the collection.

Overload List

Adds a comment to the collection.

public int Add(int,int);

Adds a comment to the collection.

public int Add(string);

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridCommentCollection.Add Method (Int32, Int32)

Adds a comment to the collection.

public int Add(
int row,
int column
);

Parameters

row
Cell row index.
column
Cell column index.

Return Value

Comment object index.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.Add Overload List


GridCommentCollection.Add Method (String)

Adds a comment to the collection.

public int Add(
string cellName
);

Parameters

cellName
Cell name.

Return Value

Comment object index.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.Add Overload List


GridCommentCollection.Clear Method

Removes all comments;

public void Clear();

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridCommentCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


RemoveAt Method

Aspose.Cells for .NET

GridCommentCollection.RemoveAt Method

Removes the comment of the specific cell.

Overload List

Removes the comment of the specific cell.

public void RemoveAt(int,int);

Removes the comment of the specific cell.

public void RemoveAt(string);

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridCommentCollection.RemoveAt Method (Int32, Int32)

Removes the comment of the specific cell.

public void RemoveAt(
int row,
int column
);

Parameters

row
The row index.
column
the column index.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.RemoveAt Overload List


GridCommentCollection.RemoveAt Method (String)

Removes the comment of the specific cell.

public void RemoveAt(
string cellName
);

Parameters

cellName
The name of cell which contains a comment.

See Also

GridCommentCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridCommentCollection.RemoveAt Overload List


GridCustomServerValidation Interface

the interface you need to implement when use server side validation. CustomServerFunction.

For a list of all members of this type, see GridCustomServerValidation Members.

public interface GridCustomServerValidation

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridCustomServerValidation Members | Aspose.Cells.GridWeb.Data Namespace


GridCustomServerValidation Members

GridCustomServerValidation overview

Public Instance Methods

Validate

See Also

GridCustomServerValidation Interface | Aspose.Cells.GridWeb.Data Namespace


GridCustomServerValidation Methods

The methods of the GridCustomServerValidation interface are listed below. For a complete list of GridCustomServerValidation interface members, see the GridCustomServerValidation Members topic.

Public Instance Methods

Validate

See Also

GridCustomServerValidation Interface | Aspose.Cells.GridWeb.Data Namespace


GridCustomServerValidation.Validate Method

string Validate(
GridWorksheet sheet,
int row,
int col,
string value
);

See Also

GridCustomServerValidation Interface | Aspose.Cells.GridWeb.Data Namespace


GridHtmlSaveOptions Class

Represents the options for saving html file.

For a list of all members of this type, see GridHtmlSaveOptions Members.

System.Object
Aspose.Cells.GridWeb.Data.GridSaveOptions
Aspose.Cells.GridWeb.Data.GridHtmlSaveOptions

public class GridHtmlSaveOptions : GridSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridHtmlSaveOptions Members | Aspose.Cells.GridWeb.Data Namespace


GridHtmlSaveOptions Members

GridHtmlSaveOptions overview

Public Instance Constructors

GridHtmlSaveOptions Overloaded. Initializes a new instance of the GridHtmlSaveOptions class.

Public Instance Properties

AttachedFilesDirectory | The directory that the attached files will be saved to. Only for saving to html stream.
AttachedFilesUrlPrefix | Specify the Url prefix of attached files such as image in the html file. Only for saving to html stream.
CachedFileFolder (inherited from GridSaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from GridSaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from GridSaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
DefaultFontName | Specify the default font name for exporting html, the default font will be used when the font of style is not existing, If this property is null, Aspose.Cells will use universal font which have the same family with the original font, the default value is null.
Encoding | If not set,use Encoding.UTF8 as default enconding type.
ExportActiveWorksheetOnly | Indicates if exporting the whole workbook to html file.
ExportArea | Gets or Sets the exporting CellArea of current active Worksheet. If you set this attribute, the print area of current active Worksheet will be omited. Only the specified area will be exported when saving the file to html.
ExportGridLines | Indicating whether exporting the gridlines.The default value is false.
ExportHeadings | Indicates whether exporting headings when saving file to html.The default value is false. If you want to import the html file to excel, please keep the default value.
ExportHiddenWorksheet | Indicating if exporting the hidden worksheet content.The default value is true.
ExportImagesAsBase64 | Specifies whether images are saved in Base64 format to HTML, MHTML or EPUB.
ExportPrintAreaOnly | Indicates if only exporting the print area to html file. The default value is false.
ExportSingleTab | Indicates whether exporting the single tab when the file only has one worksheet. The default value is false.
IsExportComments | Indicates if exporting comments when saving file to html, the default value is false.
IsFullPathLink | Indicating whether using full path link in sheet00x.htm,filelist.xml and tabstrip.htm. The default value is false.
MergeAreas (inherited from GridSaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PageTitle | The title of the html page. Only for saving to html stream.
ParseHtmlTagInCell | Parse html tag in cell,like ,as cell value,or as html tag,default is true
PresentationPreference | Indicating if html or mht file is presentation preference.The default value is false.if you want to get more beautiful presentation,please set the value to true.
RefreshChartCache (inherited from GridSaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from GridSaveOptions) | Gets the save file format.
SortNames (inherited from GridSaveOptions) | Indicates whether sorting defined names before saving file.
ValidateMergedAreas (inherited from GridSaveOptions) | Indicates whether validate merged cells before saving the file.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


GridHtmlSaveOptions Constructor

Creates options for saving html file.

Overload List

Creates options for saving html file.

public GridHtmlSaveOptions();

Creates options for saving htm file.

public GridHtmlSaveOptions(GridSaveFormat);

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


GridHtmlSaveOptions Constructor ()

Creates options for saving html file.

public GridHtmlSaveOptions();

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace | GridHtmlSaveOptions Constructor Overload List


GridHtmlSaveOptions Constructor (GridSaveFormat)

Creates options for saving htm file.

public GridHtmlSaveOptions(
GridSaveFormat format
);

Parameters

format
The saving file format.

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace | GridHtmlSaveOptions Constructor Overload List


GridHtmlSaveOptions Properties

The properties of the GridHtmlSaveOptions class are listed below. For a complete list of GridHtmlSaveOptions class members, see the GridHtmlSaveOptions Members topic.

Public Instance Properties

AttachedFilesDirectory | The directory that the attached files will be saved to. Only for saving to html stream.
AttachedFilesUrlPrefix | Specify the Url prefix of attached files such as image in the html file. Only for saving to html stream.
CachedFileFolder (inherited from GridSaveOptions) | The cached file folder is used to store some large data.
ClearData (inherited from GridSaveOptions) | Make the workbook empty after saving the file.
CreateDirectory (inherited from GridSaveOptions) | If true and the directory does not exist, the directory will be automatically created before saving the file.
DefaultFontName | Specify the default font name for exporting html, the default font will be used when the font of style is not existing, If this property is null, Aspose.Cells will use universal font which have the same family with the original font, the default value is null.
Encoding | If not set,use Encoding.UTF8 as default enconding type.
ExportActiveWorksheetOnly | Indicates if exporting the whole workbook to html file.
ExportArea | Gets or Sets the exporting CellArea of current active Worksheet. If you set this attribute, the print area of current active Worksheet will be omited. Only the specified area will be exported when saving the file to html.
ExportGridLines | Indicating whether exporting the gridlines.The default value is false.
ExportHeadings | Indicates whether exporting headings when saving file to html.The default value is false. If you want to import the html file to excel, please keep the default value.
ExportHiddenWorksheet | Indicating if exporting the hidden worksheet content.The default value is true.
ExportImagesAsBase64 | Specifies whether images are saved in Base64 format to HTML, MHTML or EPUB.
ExportPrintAreaOnly | Indicates if only exporting the print area to html file. The default value is false.
ExportSingleTab | Indicates whether exporting the single tab when the file only has one worksheet. The default value is false.
IsExportComments | Indicates if exporting comments when saving file to html, the default value is false.
IsFullPathLink | Indicating whether using full path link in sheet00x.htm,filelist.xml and tabstrip.htm. The default value is false.
MergeAreas (inherited from GridSaveOptions) | Indicates whether merge the areas of conditional formatting and validation before saving the file.
PageTitle | The title of the html page. Only for saving to html stream.
ParseHtmlTagInCell | Parse html tag in cell,like ,as cell value,or as html tag,default is true
PresentationPreference | Indicating if html or mht file is presentation preference.The default value is false.if you want to get more beautiful presentation,please set the value to true.
RefreshChartCache (inherited from GridSaveOptions) | Indicates whether refreshing chart cache data
SaveFormat (inherited from GridSaveOptions) | Gets the save file format.
SortNames (inherited from GridSaveOptions) | Indicates whether sorting defined names before saving file.
ValidateMergedAreas (inherited from GridSaveOptions) | Indicates whether validate merged cells before saving the file.

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


AttachedFilesDirectory Property

Aspose.Cells for .NET

GridHtmlSaveOptions.AttachedFilesDirectory Property

The directory that the attached files will be saved to. Only for saving to html stream.

public string AttachedFilesDirectory {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


AttachedFilesUrlPrefix Property

Aspose.Cells for .NET

GridHtmlSaveOptions.AttachedFilesUrlPrefix Property

Specify the Url prefix of attached files such as image in the html file. Only for saving to html stream.

public string AttachedFilesUrlPrefix {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


DefaultFontName Property

Aspose.Cells for .NET

GridHtmlSaveOptions.DefaultFontName Property

Specify the default font name for exporting html, the default font will be used when the font of style is not existing, If this property is null, Aspose.Cells will use universal font which have the same family with the original font, the default value is null.

public string DefaultFontName {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


Encoding Property

Aspose.Cells for .NET

GridHtmlSaveOptions.Encoding Property

If not set,use Encoding.UTF8 as default enconding type.

public Encoding Encoding {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportActiveWorksheetOnly Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportActiveWorksheetOnly Property

Indicates if exporting the whole workbook to html file.

public bool ExportActiveWorksheetOnly {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportArea Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportArea Property

Gets or Sets the exporting CellArea of current active Worksheet. If you set this attribute, the print area of current active Worksheet will be omited. Only the specified area will be exported when saving the file to html.

public GridCellArea ExportArea {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportGridLines Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportGridLines Property

Indicating whether exporting the gridlines.The default value is false.

public bool ExportGridLines {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportHeadings Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportHeadings Property

Indicates whether exporting headings when saving file to html.The default value is false. If you want to import the html file to excel, please keep the default value.

public bool ExportHeadings {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportHiddenWorksheet Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportHiddenWorksheet Property

Indicating if exporting the hidden worksheet content.The default value is true.

public bool ExportHiddenWorksheet {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportImagesAsBase64 Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportImagesAsBase64 Property

Specifies whether images are saved in Base64 format to HTML, MHTML or EPUB.

public bool ExportImagesAsBase64 {get; set;}

Remarks

When this property is set to true image data is exported directly on the img elements and separate files are not created.

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportPrintAreaOnly Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportPrintAreaOnly Property

Indicates if only exporting the print area to html file. The default value is false.

public bool ExportPrintAreaOnly {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ExportSingleTab Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ExportSingleTab Property

Indicates whether exporting the single tab when the file only has one worksheet. The default value is false.

public bool ExportSingleTab {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


IsExportComments Property

Aspose.Cells for .NET

GridHtmlSaveOptions.IsExportComments Property

Indicates if exporting comments when saving file to html, the default value is false.

public bool IsExportComments {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


IsFullPathLink Property

Aspose.Cells for .NET

GridHtmlSaveOptions.IsFullPathLink Property

Indicating whether using full path link in sheet00x.htm,filelist.xml and tabstrip.htm. The default value is false.

public bool IsFullPathLink {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


PageTitle Property

Aspose.Cells for .NET

GridHtmlSaveOptions.PageTitle Property

The title of the html page. Only for saving to html stream.

public string PageTitle {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ParseHtmlTagInCell Property

Aspose.Cells for .NET

GridHtmlSaveOptions.ParseHtmlTagInCell Property

Parse html tag in cell,like

,as cell value,or as html tag,default is true

public bool ParseHtmlTagInCell {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


PresentationPreference Property

Aspose.Cells for .NET

GridHtmlSaveOptions.PresentationPreference Property

Indicating if html or mht file is presentation preference.The default value is false.if you want to get more beautiful presentation,please set the value to true.

public bool PresentationPreference {get; set;}

See Also

GridHtmlSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlink Class

Encapsulates the object that represents a hyperlink.

For a list of all members of this type, see GridHyperlink Members.

System.Object
Aspose.Cells.GridWeb.Data.GridHyperlink

public class GridHyperlink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridHyperlink Members | Aspose.Cells.GridWeb.Data Namespace


GridHyperlink Members

GridHyperlink overview

Public Instance Properties

Address | Represents the address of a hyperlink.
AltText | Get or Set Alternate text for the image link,please note this is an extension attribute and can not keep in excel file
Area | Gets the range of hyperlink.
Command | Returns or sets the self defined command value text for the specified hyperlink.
DiscardInput | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageURL | Get or Set Image URL for the link, there is no imageurl properties in hyperlink, so actually use TextToDisplay to record this value ,TextToDisplay will be set to <img src=value > so it will change the value of TextToDisplay
ScreenTip | Returns or sets the ScreenTip text for the specified hyperlink.
Target | Get or Set web link target type,please note this is an extension attribute and can not keep in excel file
TextToDisplay | Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlink Properties

The properties of the GridHyperlink class are listed below. For a complete list of GridHyperlink class members, see the GridHyperlink Members topic.

Public Instance Properties

Address | Represents the address of a hyperlink.
AltText | Get or Set Alternate text for the image link,please note this is an extension attribute and can not keep in excel file
Area | Gets the range of hyperlink.
Command | Returns or sets the self defined command value text for the specified hyperlink.
DiscardInput | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageURL | Get or Set Image URL for the link, there is no imageurl properties in hyperlink, so actually use TextToDisplay to record this value ,TextToDisplay will be set to <img src=value > so it will change the value of TextToDisplay
ScreenTip | Returns or sets the ScreenTip text for the specified hyperlink.
Target | Get or Set web link target type,please note this is an extension attribute and can not keep in excel file
TextToDisplay | Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Address Property

Aspose.Cells for .NET

GridHyperlink.Address Property

Represents the address of a hyperlink.

public string Address {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


AltText Property

Aspose.Cells for .NET

GridHyperlink.AltText Property

Get or Set Alternate text for the image link,please note this is an extension attribute and can not keep in excel file

public string AltText {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Area Property

Aspose.Cells for .NET

GridHyperlink.Area Property

Gets the range of hyperlink.

public GridCellArea Area {get;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Command Property

Aspose.Cells for .NET

GridHyperlink.Command Property

Returns or sets the self defined command value text for the specified hyperlink.

public string Command {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


DiscardInput Property

Aspose.Cells for .NET

GridHyperlink.DiscardInput Property

Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.

public virtual bool DiscardInput {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


ImageURL Property

Aspose.Cells for .NET

GridHyperlink.ImageURL Property

Get or Set Image URL for the link, there is no imageurl properties in hyperlink, so actually use TextToDisplay to record this value ,TextToDisplay will be set to <img src=value > so it will change the value of TextToDisplay

public string ImageURL {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


ScreenTip Property

Aspose.Cells for .NET

GridHyperlink.ScreenTip Property

Returns or sets the ScreenTip text for the specified hyperlink.

public string ScreenTip {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Target Property

Aspose.Cells for .NET

GridHyperlink.Target Property

Get or Set web link target type,please note this is an extension attribute and can not keep in excel file

public string Target {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


TextToDisplay Property

Aspose.Cells for .NET

GridHyperlink.TextToDisplay Property

Represents the text to be displayed for the specified hyperlink. The default value is the address of the hyperlink.

public string TextToDisplay {get; set;}

See Also

GridHyperlink Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection Class

Encapsulates a collection of Hyperlink objects.

For a list of all members of this type, see GridHyperlinkCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridHyperlinkCollection

public class GridHyperlinkCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridHyperlinkCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection Members

GridHyperlinkCollection overview

Public Instance Properties

Count |
Item | Gets the Hyperlink element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a hyperlink to a specified cell or a range of cells.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetHyperlink | Overloaded. Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.
GetType (inherited from Object) |
Remove | Remove the hyperlink at the specified area.
RemoveAt | Remove the hyperlink at the specified index.
ToString (inherited from Object) |

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection Properties

The properties of the GridHyperlinkCollection class are listed below. For a complete list of GridHyperlinkCollection class members, see the GridHyperlinkCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Hyperlink element at the specified index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridHyperlinkCollection.Count Property

public int Count {get;}

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridHyperlinkCollection.Item Property

Gets the Hyperlink element at the specified index.

public GridHyperlink this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection Methods

The methods of the GridHyperlinkCollection class are listed below. For a complete list of GridHyperlinkCollection class members, see the GridHyperlinkCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a hyperlink to a specified cell or a range of cells.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetHyperlink | Overloaded. Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.
GetType (inherited from Object) |
Remove | Remove the hyperlink at the specified area.
RemoveAt | Remove the hyperlink at the specified index.
ToString (inherited from Object) |

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

GridHyperlinkCollection.Add Method

Adds a hyperlink to a specified cell or a range of cells.

Overload List

Adds a hyperlink to a specified cell or a range of cells.

public int Add(int,int,int,int,string);

Adds a hyperlink to a specified cell or a range of cells.

public int Add(string,int,int,string);

Adds a hyperlink to a specified cell .

public int Add(string,string);

Adds a hyperlink to a specified cell or a range of cells.

public int Add(string,string,string,string,string);

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection.Add Method (Int32, Int32, Int32, Int32, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns,
string address
);

Parameters

firstRow
First row of the hyperlink range.
firstColumn
First column of the hyperlink range.
totalRows
Number of rows in this hyperlink range.
totalColumns
Number of columns of this hyperlink range.
address
Address of the hyperlink.

Return Value

Hyperlink object index.

Example

[C#]

 Worksheet worksheet = excel.Worksheets[0];
 worksheet.Hyperlinks.Add("A4", 1, 1, "http://www.aspose.com");
 worksheet.Hyperlinks.Add("A5", 1, 1, "c:\\book1.xls");

 [Visual Basic]

 Dim worksheet as Worksheet = excel.Worksheets(0)
 worksheet.Hyperlinks.Add("A4", 1, 1, "http://www.aspose.com")
 worksheet.Hyperlinks.Add("A5", 1, 1, "c:\\book1.xls")

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (String, Int32, Int32, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
string cellName,
int totalRows,
int totalColumns,
string address
);

Parameters

cellName
Cell name.
totalRows
Number of rows in this hyperlink range.
totalColumns
Number of columns of this hyperlink range.
address
Address of the hyperlink.

Return Value

GridHyperlink object index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (String, String)

Adds a hyperlink to a specified cell .

public int Add(
string cellName,
string address
);

Parameters

cellName
Cell name.
address
Address of the hyperlink.

Return Value

GridHyperlink object index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Add Method (String, String, String, String, String)

Adds a hyperlink to a specified cell or a range of cells.

public int Add(
string startCellName,
string endCellName,
string address,
string textToDisplay,
string screenTip
);

Parameters

startCellName
The top-left cell of the range.
endCellName
The bottom-right cell of the range.
address
Address of the hyperlink.
textToDisplay
The text to be displayed for the specified hyperlink.
screenTip
The screenTip text for the specified hyperlink.

Return Value

GridHyperlink object index.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridHyperlinkCollection.Add Overload List


GridHyperlinkCollection.Clear Method

Clears all hyperlinks.

public void Clear();

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GetHyperlink Method

Aspose.Cells for .NET

GridHyperlinkCollection.GetHyperlink Method

Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.

Overload List

Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.

public GridHyperlink GetHyperlink(GridCell);

Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.

public GridHyperlink GetHyperlink(int,int);

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection.GetHyperlink Method (GridCell)

Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.

public GridHyperlink GetHyperlink(
GridCell cell
);

Parameters

cell
The GridCell object.

Return Value

GridHyperlink the GridHyperlink object.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridHyperlinkCollection.GetHyperlink Overload List


GridHyperlinkCollection.GetHyperlink Method (Int32, Int32)

Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.

public GridHyperlink GetHyperlink(
int row,
int column
);

Parameters

row
The row of the cell.
column
The column of the cell.

Return Value

GridHyperlink the GridHyperlink object.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridHyperlinkCollection.GetHyperlink Overload List


GridHyperlinkCollection.Remove Method

Remove the hyperlink at the specified area.

public void Remove(
GridCellArea area
);

Parameters

area
The area which contains hyperlink.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridHyperlinkCollection.RemoveAt Method

Remove the hyperlink at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

See Also

GridHyperlinkCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridImageType Enumeration

Specifies the type (format) of an image.

public enum GridImageType

Members

Member Name | Description | Value
Unknown | An unknown image type. | 0
Emf | Windows Enhanced Metafile. | 2
Wmf | Windows Metafile. | 3
Pict | Macintosh PICT. | 4
Jpeg | JPEG JFIF. | 5
Png | Portable Network Graphics. | 6
Bmp | Windows Bitmam | 7
Gif | Gif | 66
Tiff | Tiff | 67
Svg | Svg | 68
Svm | Svm | 69
Gltf | glTF | 70

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridMsoDrawingType Enumeration

public enum GridMsoDrawingType

Members

Member Name | Description | Value
Group |  | 0
Line |  | 1
Rectangle |  | 2
Oval |  | 3
Arc |  | 4
Chart |  | 5
TextBox |  | 6
Button |  | 7
Picture |  | 8
Polygon |  | 9
CheckBox |  | 11
RadioButton |  | 12
Label |  | 14
DialogBox |  | 15
Spinner |  | 16
ScrollBar |  | 17
ListBox |  | 18
GroupBox |  | 19
ComboBox |  | 20
Comment |  | 25
OleObject |  | 24
CellsDrawing | Only for preserving the drawing object in the template file. | 30
Unknown | Only for preserving the drawing object in the xlsx file. | 29

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridName Class

Encapsulates the object that represents a name object.

For a list of all members of this type, see GridName Members.

System.Object
Aspose.Cells.GridWeb.Data.GridName

public class GridName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridName Members | Aspose.Cells.GridWeb.Data Namespace


GridName Members

GridName overview

Public Instance Properties

RefersTo | Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.
SheetIndex | Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)
Text | Gets the name text of the object.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Range object.

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


GridName Properties

The properties of the GridName class are listed below. For a complete list of GridName class members, see the GridName Members topic.

Public Instance Properties

RefersTo | Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.
SheetIndex | Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)
Text | Gets the name text of the object.

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


RefersTo Property

Aspose.Cells for .NET

GridName.RefersTo Property

Returns or sets the formula that the name is defined to refer to, beginning with an equal sign.

public string RefersTo {get; set;}

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


SheetIndex Property

Aspose.Cells for .NET

GridName.SheetIndex Property

Indicates this name belongs to Workbook or Worksheet. 0 = Global name, otherwise index to sheet (one-based)

public int SheetIndex {get; set;}

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


Text Property

Aspose.Cells for .NET

GridName.Text Property

Gets the name text of the object.

public string Text {get; set;}

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


GridName Methods

The methods of the GridName class are listed below. For a complete list of GridName class members, see the GridName Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Returns a string represents the current Range object.

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


GridName.ToString Method

Returns a string represents the current Range object.

public override string ToString();

Return Value

See Also

GridName Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection Class

Encapsulates a collection of Name objects.

For a list of all members of this type, see GridNameCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridNameCollection

public class GridNameCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridNameCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection Members

GridNameCollection overview

Public Instance Properties

Count |
Item | Gets the Name element at the specified index.

Public Instance Methods

Add | Overloaded. Defines a new global name.
Clear | Removes all Names;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Remove an array of name
RemoveAt | Remove the name at the specific index.
ToString (inherited from Object) |

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection Properties

The properties of the GridNameCollection class are listed below. For a complete list of GridNameCollection class members, see the GridNameCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Name element at the specified index.

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridNameCollection.Count Property

public int Count {get;}

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridNameCollection.Item Property

Gets the Name element at the specified index.

public GridName this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection Methods

The methods of the GridNameCollection class are listed below. For a complete list of GridNameCollection class members, see the GridNameCollection Members topic.

Public Instance Methods

Add | Overloaded. Defines a new global name.
Clear | Removes all Names;
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Remove an array of name
RemoveAt | Remove the name at the specific index.
ToString (inherited from Object) |

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

GridNameCollection.Add Method

Defines a new name in the specified sheet.

Overload List

Defines a new name in the specified sheet.

public int Add(int,string,string);

Defines a new global name.

public int Add(string,string);

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection.Add Method (Int32, String, String)

Defines a new name in the specified sheet.

public int Add(
int sheetIndex,
string text,
string refersTo
);

Parameters

sheetIndex
The sheet index that the name is applyed in.Name's SheetIndex ,the index is from 1.
text
Name text.It can not have sheetname .
refersTo
The formula that the name is defined to refer to.It must have sheetname .eg.'sheet hello!'A1:B2.

Return Value

Name object index.

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridNameCollection.Add Overload List


GridNameCollection.Add Method (String, String)

Defines a new global name.

public int Add(
string text,
string refersTo
);

Parameters

text
Name text.It can have sheetname .
refersTo
The formula that the name is defined to refer to.It must have a sheetname .eg.'sheet hello!'A1:B2.

Return Value

Name object index.

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridNameCollection.Add Overload List


GridNameCollection.Clear Method

Removes all Names;

public void Clear();

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection.Remove Method

Remove an array of name

public void Remove(
string[] names
);

Parameters

names
The names' text.

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridNameCollection.RemoveAt Method

Remove the name at the specific index.

public void RemoveAt(
int index
);

Parameters

index

Remarks

Please make sure that the name is not referred by the other formulas before calling the method. And if the name is referred,please only set Name.RefersTo as null.

See Also

GridNameCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridOperatorType Enumeration

public enum GridOperatorType

Members

Member Name | Description | Value
Between | Represents Between operator of conditional format and data validation. | 0
Equal | Represents Equal operator of conditional format and data validation. | 1
GreaterThan | Represents GreaterThan operator of conditional format and data validation. | 2
GreaterOrEqual | Represents GreaterOrEqual operator of conditional format and data validation. | 3
LessThan | Represents LessThan operator of conditional format and data validation. | 4
LessOrEqual | Represents LessOrEqual operator of conditional format and data validation. | 5
None | Represents no comparision. | 6
NotBetween | Represents NotBetween operator of conditional format and data validation. | 7
NotEqual | Represents NotEqual operator of conditional format and data validation. | 8

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridPicture Class

Encapsulates the object that represents a single picture in a spreadsheet.

For a list of all members of this type, see GridPicture Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPicture

public class GridPicture

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPicture Members | Aspose.Cells.GridWeb.Data Namespace


GridPicture Members

GridPicture overview

Public Instance Properties

AlternativeText |
BorderLineColor | Represents the Color of the border line of a picture.
BorderWeight | Gets or sets the weight of the border line of a picture in units of pt.
Bottom |
Data | Gets the data of the picture.
HasLine | Gets and sets the line border of the shape is visible.
Height | Represents the height of shape, in unit of pixel.
HeightCM | Represents the height of the shape, in unit of inches.
HeightInch | Represents the height of the shape, in unit of inches.
HeightPt | Represents the height of the shape, in unit of points.
HeightScale | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText | Gets and sets the html string which contains data and some formattings in this textbox.
Hyperlink | Gets the hyperlink of the shape.
ID | Gets /Sets the ID of the picture.
Image | Gets or sets the Image object.
ImageFormat | Gets the image format of the picture.
IsFlippedVertically | Gets and sets whether shape is vertically flipped .
IsHidden | Indicates whether the object is visible.
IsLockAspectRatio | True means that don't allow changes in aspect ratio.
IsLocked | True if the object is locked, False if the object can be modified when the sheet is protected.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch | Represents the horizontal offset of shape from its left column, in unit of inches.
LinkedCell | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn | Represents lower right corner column index.
LowerRightRow | Represents lower right corner row index.
Name | Gets and sets the name of the shape.
OriginalHeight | Gets the original height of the picture.
OriginalHeightCM | Gets the original height of picture, in unit of centimeters.
OriginalHeightInch | Gets the original height of picture, in unit of inches.
OriginalWidth | Gets the original width of the picture.
OriginalWidthCM | Gets the original width of picture, in unit of centimeters.
OriginalWidthInch | Gets the original width of picture, in unit of inches.
RelativeToOriginalPictureSize | Indicates whether shape is relative to original picture size.
Right | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle | Gets and sets the rotation of the shape.
SourceFullName | Gets or sets the path and name of the source file for the linked image.
Text | Represents the string in this TextBox object.
Title |
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch | Represents the vertical offset of shape from its top row, in unit of inches.
UpperDeltaX | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
Width | Represents the width of shape, in unit of pixels.
WidthCM | Represents the width of the shape, in unit of centimeters.
WidthInch | Represents the width of the shape, in unit of inch.
WidthPt | Represents the width of the shape, in unit of point.
WidthScale | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X | Gets and sets the horizonal offset of shape from worksheet left border,in unit of pixels.
Y | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition | Returns the position of a shape in the z-order.

Public Instance Methods

AddHyperlink | Adds a hyperlink to the shape.
AlignTopRightCorner | Moves the picture to the top-right corner.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsGroup | Indicates whether the shape is a group.
Move | Moves the picture to a specified location.
MoveToRange | Moves the shape to a specified range.
RemoveHyperlink | Remove the hyperlink of the shape.
SaveToImage | Creates the image and saves it to a stream .
ToString (inherited from Object) |

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture Properties

The properties of the GridPicture class are listed below. For a complete list of GridPicture class members, see the GridPicture Members topic.

Public Instance Properties

AlternativeText |
BorderLineColor | Represents the Color of the border line of a picture.
BorderWeight | Gets or sets the weight of the border line of a picture in units of pt.
Bottom |
Data | Gets the data of the picture.
HasLine | Gets and sets the line border of the shape is visible.
Height | Represents the height of shape, in unit of pixel.
HeightCM | Represents the height of the shape, in unit of inches.
HeightInch | Represents the height of the shape, in unit of inches.
HeightPt | Represents the height of the shape, in unit of points.
HeightScale | Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;
HtmlText | Gets and sets the html string which contains data and some formattings in this textbox.
Hyperlink | Gets the hyperlink of the shape.
ID | Gets /Sets the ID of the picture.
Image | Gets or sets the Image object.
ImageFormat | Gets the image format of the picture.
IsFlippedVertically | Gets and sets whether shape is vertically flipped .
IsHidden | Indicates whether the object is visible.
IsLockAspectRatio | True means that don't allow changes in aspect ratio.
IsLocked | True if the object is locked, False if the object can be modified when the sheet is protected.
IsTextWrapped | Gets and sets the text wrapped type of the shape which contains text.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
LeftCM | Represents the horizontal offset of shape from its left column, in unit of centimeters.
LeftInch | Represents the horizontal offset of shape from its left column, in unit of inches.
LinkedCell | Gets or sets the worksheet range linked to the control's value.
LowerDeltaX | Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.
LowerDeltaY | Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.
LowerRightColumn | Represents lower right corner column index.
LowerRightRow | Represents lower right corner row index.
Name | Gets and sets the name of the shape.
OriginalHeight | Gets the original height of the picture.
OriginalHeightCM | Gets the original height of picture, in unit of centimeters.
OriginalHeightInch | Gets the original height of picture, in unit of inches.
OriginalWidth | Gets the original width of the picture.
OriginalWidthCM | Gets the original width of picture, in unit of centimeters.
OriginalWidthInch | Gets the original width of picture, in unit of inches.
RelativeToOriginalPictureSize | Indicates whether shape is relative to original picture size.
Right | Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.
RotationAngle | Gets and sets the rotation of the shape.
SourceFullName | Gets or sets the path and name of the source file for the linked image.
Text | Represents the string in this TextBox object.
Title |
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
TopCM | Represents the vertical offset of shape from its top row, in unit of centimeters.
TopInch | Represents the vertical offset of shape from its top row, in unit of inches.
UpperDeltaX | Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.
UpperDeltaY | Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
Width | Represents the width of shape, in unit of pixels.
WidthCM | Represents the width of the shape, in unit of centimeters.
WidthInch | Represents the width of the shape, in unit of inch.
WidthPt | Represents the width of the shape, in unit of point.
WidthScale | Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;
X | Gets and sets the horizonal offset of shape from worksheet left border,in unit of pixels.
Y | Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.
ZOrderPosition | Returns the position of a shape in the z-order.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


AlternativeText Property

Aspose.Cells for .NET

GridPicture.AlternativeText Property

public string AlternativeText {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


BorderLineColor Property

Aspose.Cells for .NET

GridPicture.BorderLineColor Property

Represents the Color of the border line of a picture.

public Color BorderLineColor {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


BorderWeight Property

Aspose.Cells for .NET

GridPicture.BorderWeight Property

Gets or sets the weight of the border line of a picture in units of pt.

public double BorderWeight {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Bottom Property

Aspose.Cells for .NET

GridPicture.Bottom Property

public int Bottom {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Data Property

Aspose.Cells for .NET

GridPicture.Data Property

Gets the data of the picture.

public byte[] Data {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


HasLine Property

Aspose.Cells for .NET

GridPicture.HasLine Property

Gets and sets the line border of the shape is visible.

public bool HasLine {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Height Property

Aspose.Cells for .NET

GridPicture.Height Property

Represents the height of shape, in unit of pixel.

public int Height {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


HeightCM Property

Aspose.Cells for .NET

GridPicture.HeightCM Property

Represents the height of the shape, in unit of inches.

public double HeightCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


HeightInch Property

Aspose.Cells for .NET

GridPicture.HeightInch Property

Represents the height of the shape, in unit of inches.

public double HeightInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


HeightPt Property

Aspose.Cells for .NET

GridPicture.HeightPt Property

Represents the height of the shape, in unit of points.

public double HeightPt {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


HeightScale Property

Aspose.Cells for .NET

GridPicture.HeightScale Property

Gets and sets the height scale,in unit of percent of the original picture height. If the shape is not picture ,the HeightScale property only returns 100;

public int HeightScale {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


HtmlText Property

Aspose.Cells for .NET

GridPicture.HtmlText Property

Gets and sets the html string which contains data and some formattings in this textbox.

public string HtmlText {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlink Property

Aspose.Cells for .NET

GridPicture.Hyperlink Property

Gets the hyperlink of the shape.

public GridHyperlink Hyperlink {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


ID Property

Aspose.Cells for .NET

GridPicture.ID Property

Gets /Sets the ID of the picture.

public string ID {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Image Property

Aspose.Cells for .NET

GridPicture.Image Property

Gets or sets the Image object.

public Image Image {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


ImageFormat Property

Aspose.Cells for .NET

GridPicture.ImageFormat Property

Gets the image format of the picture.

public GridImageType ImageFormat {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


IsFlippedVertically Property

Aspose.Cells for .NET

GridPicture.IsFlippedVertically Property

Gets and sets whether shape is vertically flipped .

public bool IsFlippedVertically {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


IsHidden Property

Aspose.Cells for .NET

GridPicture.IsHidden Property

Indicates whether the object is visible.

public bool IsHidden {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


IsLockAspectRatio Property

Aspose.Cells for .NET

GridPicture.IsLockAspectRatio Property

True means that don't allow changes in aspect ratio.

public bool IsLockAspectRatio {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


IsLocked Property

Aspose.Cells for .NET

GridPicture.IsLocked Property

True if the object is locked, False if the object can be modified when the sheet is protected.

public bool IsLocked {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


IsTextWrapped Property

Aspose.Cells for .NET

GridPicture.IsTextWrapped Property

Gets and sets the text wrapped type of the shape which contains text.

public bool IsTextWrapped {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Left Property

Aspose.Cells for .NET

GridPicture.Left Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int Left {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LeftCM Property

Aspose.Cells for .NET

GridPicture.LeftCM Property

Represents the horizontal offset of shape from its left column, in unit of centimeters.

public double LeftCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LeftInch Property

Aspose.Cells for .NET

GridPicture.LeftInch Property

Represents the horizontal offset of shape from its left column, in unit of inches.

public double LeftInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LinkedCell Property

Aspose.Cells for .NET

GridPicture.LinkedCell Property

Gets or sets the worksheet range linked to the control's value.

public string LinkedCell {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LowerDeltaX Property

Aspose.Cells for .NET

GridPicture.LowerDeltaX Property

Gets or sets the shape's horizontal offset from its lower right corner column. The range of value is 0 to 1024.

public int LowerDeltaX {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LowerDeltaY Property

Aspose.Cells for .NET

GridPicture.LowerDeltaY Property

Gets or sets the shape's vertical offset from its lower right corner row. The range of value is 0 to 256.

public int LowerDeltaY {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LowerRightColumn Property

Aspose.Cells for .NET

GridPicture.LowerRightColumn Property

Represents lower right corner column index.

public int LowerRightColumn {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


LowerRightRow Property

Aspose.Cells for .NET

GridPicture.LowerRightRow Property

Represents lower right corner row index.

public int LowerRightRow {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

GridPicture.Name Property

Gets and sets the name of the shape.

public string Name {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


OriginalHeight Property

Aspose.Cells for .NET

GridPicture.OriginalHeight Property

Gets the original height of the picture.

public int OriginalHeight {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


OriginalHeightCM Property

Aspose.Cells for .NET

GridPicture.OriginalHeightCM Property

Gets the original height of picture, in unit of centimeters.

public double OriginalHeightCM {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


OriginalHeightInch Property

Aspose.Cells for .NET

GridPicture.OriginalHeightInch Property

Gets the original height of picture, in unit of inches.

public double OriginalHeightInch {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


OriginalWidth Property

Aspose.Cells for .NET

GridPicture.OriginalWidth Property

Gets the original width of the picture.

public int OriginalWidth {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


OriginalWidthCM Property

Aspose.Cells for .NET

GridPicture.OriginalWidthCM Property

Gets the original width of picture, in unit of centimeters.

public double OriginalWidthCM {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


OriginalWidthInch Property

Aspose.Cells for .NET

GridPicture.OriginalWidthInch Property

Gets the original width of picture, in unit of inches.

public double OriginalWidthInch {get;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


RelativeToOriginalPictureSize Property

Aspose.Cells for .NET

GridPicture.RelativeToOriginalPictureSize Property

Indicates whether shape is relative to original picture size.

public bool RelativeToOriginalPictureSize {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Right Property

Aspose.Cells for .NET

GridPicture.Right Property

Represents the width of the shape's horizontal offset from its lower right corner column, in unit of pixels.

public int Right {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


RotationAngle Property

Aspose.Cells for .NET

GridPicture.RotationAngle Property

Gets and sets the rotation of the shape.

public double RotationAngle {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


SourceFullName Property

Aspose.Cells for .NET

GridPicture.SourceFullName Property

Gets or sets the path and name of the source file for the linked image.

public string SourceFullName {get; set;}

Remarks

The default value is an empty string. If SourceFullName is not an empty string, the image is linked. If SourceFullName is not an empty string, but Data is null, then the image is linked and not stored in the file.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Text Property

Aspose.Cells for .NET

GridPicture.Text Property

Represents the string in this TextBox object.

public string Text {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Title Property

Aspose.Cells for .NET

GridPicture.Title Property

public string Title {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Top Property

Aspose.Cells for .NET

GridPicture.Top Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int Top {get; set;}

Remarks

If the shape is in the chart, represents the vertical offset of shape from its top border.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


TopCM Property

Aspose.Cells for .NET

GridPicture.TopCM Property

Represents the vertical offset of shape from its top row, in unit of centimeters.

public double TopCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


TopInch Property

Aspose.Cells for .NET

GridPicture.TopInch Property

Represents the vertical offset of shape from its top row, in unit of inches.

public double TopInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


UpperDeltaX Property

Aspose.Cells for .NET

GridPicture.UpperDeltaX Property

Gets or sets the shape's horizontal offset from its upper left corner column. The range of value is 0 to 1024.

public int UpperDeltaX {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


UpperDeltaY Property

Aspose.Cells for .NET

GridPicture.UpperDeltaY Property

Gets or sets the shape's vertical offset from its upper left corner row. The range of value is 0 to 256.

public int UpperDeltaY {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


UpperLeftColumn Property

Aspose.Cells for .NET

GridPicture.UpperLeftColumn Property

Represents upper left corner column index.

public int UpperLeftColumn {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


UpperLeftRow Property

Aspose.Cells for .NET

GridPicture.UpperLeftRow Property

Represents upper left corner row index.

public int UpperLeftRow {get; set;}

Remarks

If the shape is in the shape or in the group , UpperLeftRow will be ignored.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Width Property

Aspose.Cells for .NET

GridPicture.Width Property

Represents the width of shape, in unit of pixels.

public int Width {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


WidthCM Property

Aspose.Cells for .NET

GridPicture.WidthCM Property

Represents the width of the shape, in unit of centimeters.

public double WidthCM {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


WidthInch Property

Aspose.Cells for .NET

GridPicture.WidthInch Property

Represents the width of the shape, in unit of inch.

public double WidthInch {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


WidthPt Property

Aspose.Cells for .NET

GridPicture.WidthPt Property

Represents the width of the shape, in unit of point.

public double WidthPt {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


WidthScale Property

Aspose.Cells for .NET

GridPicture.WidthScale Property

Gets and sets the width scale, in unit of percent of the original picture width. If the shape is not picture ,the WidthScale property only returns 100;

public int WidthScale {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


X Property

Aspose.Cells for .NET

GridPicture.X Property

Gets and sets the horizonal offset of shape from worksheet left border,in unit of pixels.

public int X {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


Y Property

Aspose.Cells for .NET

GridPicture.Y Property

Gets and sets the vertical offset of shape from worksheet top border,in unit of pixels.

public int Y {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


ZOrderPosition Property

Aspose.Cells for .NET

GridPicture.ZOrderPosition Property

Returns the position of a shape in the z-order.

public int ZOrderPosition {get; set;}

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture Methods

The methods of the GridPicture class are listed below. For a complete list of GridPicture class members, see the GridPicture Members topic.

Public Instance Methods

AddHyperlink | Adds a hyperlink to the shape.
AlignTopRightCorner | Moves the picture to the top-right corner.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsGroup | Indicates whether the shape is a group.
Move | Moves the picture to a specified location.
MoveToRange | Moves the shape to a specified range.
RemoveHyperlink | Remove the hyperlink of the shape.
SaveToImage | Creates the image and saves it to a stream .
ToString (inherited from Object) |

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.AddHyperlink Method

Adds a hyperlink to the shape.

public GridHyperlink AddHyperlink(
string param_string
);

Parameters

param_string

Return Value

Return the new hyperlink object.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.AlignTopRightCorner Method

Moves the picture to the top-right corner.

public void AlignTopRightCorner(
int topRow,
int rightColumn
);

Parameters

topRow
the row index.
rightColumn
the column index.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.IsGroup Method

Indicates whether the shape is a group.

public bool IsGroup();

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.Move Method

Moves the picture to a specified location.

public void Move(
int upperLeftRow,
int upperLeftColumn
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.MoveToRange Method

Moves the shape to a specified range.

public void MoveToRange(
int param0_int,
int param1_int,
int param2_int,
int param3_int
);

Parameters

param0_int
param1_int
param2_int
param3_int

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.RemoveHyperlink Method

Remove the hyperlink of the shape.

public void RemoveHyperlink();

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPicture.SaveToImage Method

Creates the image and saves it to a stream .

public void SaveToImage(
Stream s
);

See Also

GridPicture Class | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection Class

Encapsulates a collection of Picture objects.

For a list of all members of this type, see GridPictureCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPictureCollection

public class GridPictureCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPictureCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection Members

GridPictureCollection overview

Public Instance Properties

Count |
Item | Gets the Picture element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a picture to the collection.
Clear |
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt |
ToString (inherited from Object) |

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection Properties

The properties of the GridPictureCollection class are listed below. For a complete list of GridPictureCollection class members, see the GridPictureCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Picture element at the specified index.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridPictureCollection.Count Property

public int Count {get;}

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridPictureCollection.Item Property

Gets the Picture element at the specified index.

public GridPicture this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection Methods

The methods of the GridPictureCollection class are listed below. For a complete list of GridPictureCollection class members, see the GridPictureCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a picture to the collection.
Clear |
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt |
ToString (inherited from Object) |

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

GridPictureCollection.Add Method

Adds a picture to the collection.

Overload List

Adds a picture to the collection.

public int Add(int,int,int,int,Stream);

Adds a picture to the collection.

public int Add(int,int,int,int,string);

Adds a picture to the collection.

public int Add(int,int,Stream);

Adds a picture to the collection.

public int Add(int,int,string);

Adds a picture to the collection.

public int Add(int,int,string,int,int);

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection.Add Method (Int32, Int32, Int32, Int32, Stream)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
stream
Stream object which contains the image data.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, Int32, Int32, String)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
int lowerRightRow,
int lowerRightColumn,
string fileName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
lowerRightRow
Lower right row index
lowerRightColumn
Lower right column index
fileName
Image filename.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, Stream)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
Stream stream
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
stream
Stream object which contains the image data.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, String)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
string fileName
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
fileName
Image filename.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Add Method (Int32, Int32, String, Int32, Int32)

Adds a picture to the collection.

public int Add(
int upperLeftRow,
int upperLeftColumn,
string fileName,
int widthScale,
int heightScale
);

Parameters

upperLeftRow
Upper left row index.
upperLeftColumn
Upper left column index.
fileName
Image filename.
widthScale
Scale of image width, a percentage.
heightScale
Scale of image height, a percentage.

Return Value

Picture object index.

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPictureCollection.Add Overload List


GridPictureCollection.Clear Method

public void Clear();

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPictureCollection.RemoveAt Method

public void RemoveAt(
int param_int
);

See Also

GridPictureCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotField Class

For a list of all members of this type, see GridPivotField Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPivotField

public class GridPivotField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPivotField Members | Aspose.Cells.GridWeb.Data Namespace


GridPivotField Members

GridPivotField overview

Public Instance Properties

DisplayName | Represents the PivotField display name.
Function | Represents the function used to summarize the PivotTable data field.
IsAscendSort | Indicates whether the specified PivotTable field is autosorted ascending.
IsAutoSort | Indicates whether the specified PivotTable field is automatically sorted.
Position | Represents the PivotField index in the PivotFields.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HideItem | Sets whether the specific PivotItem in a data field is hidden.
HideItemByName | Sets whether the specific PivotItem in a data field is hidden.
HideItemByValue | Sets whether the specific PivotItem in a data field is hidden.
ToString (inherited from Object) |

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotField Properties

The properties of the GridPivotField class are listed below. For a complete list of GridPivotField class members, see the GridPivotField Members topic.

Public Instance Properties

DisplayName | Represents the PivotField display name.
Function | Represents the function used to summarize the PivotTable data field.
IsAscendSort | Indicates whether the specified PivotTable field is autosorted ascending.
IsAutoSort | Indicates whether the specified PivotTable field is automatically sorted.
Position | Represents the PivotField index in the PivotFields.

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


DisplayName Property

Aspose.Cells for .NET

GridPivotField.DisplayName Property

Represents the PivotField display name.

public string DisplayName {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


Function Property

Aspose.Cells for .NET

GridPivotField.Function Property

Represents the function used to summarize the PivotTable data field.

public GridPivotFieldFunction Function {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


IsAscendSort Property

Aspose.Cells for .NET

GridPivotField.IsAscendSort Property

Indicates whether the specified PivotTable field is autosorted ascending.

public bool IsAscendSort {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


IsAutoSort Property

Aspose.Cells for .NET

GridPivotField.IsAutoSort Property

Indicates whether the specified PivotTable field is automatically sorted.

public bool IsAutoSort {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


Position Property

Aspose.Cells for .NET

GridPivotField.Position Property

Represents the PivotField index in the PivotFields.

public int Position {get; set;}

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotField Methods

The methods of the GridPivotField class are listed below. For a complete list of GridPivotField class members, see the GridPivotField Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HideItem | Sets whether the specific PivotItem in a data field is hidden.
HideItemByName | Sets whether the specific PivotItem in a data field is hidden.
HideItemByValue | Sets whether the specific PivotItem in a data field is hidden.
ToString (inherited from Object) |

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotField.HideItem Method

Sets whether the specific PivotItem in a data field is hidden.

public void HideItem(
int index,
bool isHidden
);

Parameters

index
the index of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotField.HideItemByName Method

Sets whether the specific PivotItem in a data field is hidden.

public void HideItemByName(
string name,
bool isHidden
);

Parameters

name
the name of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotField.HideItemByValue Method

Sets whether the specific PivotItem in a data field is hidden.

public void HideItemByValue(
string value,
bool isHidden
);

Parameters

value
the value of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

GridPivotField Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldCollection Class

Encapsulates a collection of PivotField objects.

For a list of all members of this type, see GridPivotFieldCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPivotFieldCollection

public class GridPivotFieldCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPivotFieldCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldCollection Members

GridPivotFieldCollection overview

Public Instance Properties

Count |
Item | Gets the PivotField element at the specified index.

Public Instance Methods

Add | Adds a PivotField Object to the specific type PivotFields.
Clear | Clears all PivotFields.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldCollection Properties

The properties of the GridPivotFieldCollection class are listed below. For a complete list of GridPivotFieldCollection class members, see the GridPivotFieldCollection Members topic.

Public Instance Properties

Count |
Item | Gets the PivotField element at the specified index.

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridPivotFieldCollection.Count Property

public int Count {get;}

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridPivotFieldCollection.Item Property

Gets the PivotField element at the specified index.

public GridPivotField this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldCollection Methods

The methods of the GridPivotFieldCollection class are listed below. For a complete list of GridPivotFieldCollection class members, see the GridPivotFieldCollection Members topic.

Public Instance Methods

Add | Adds a PivotField Object to the specific type PivotFields.
Clear | Clears all PivotFields.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldCollection.Add Method

Adds a PivotField Object to the specific type PivotFields.

public int Add(
GridPivotField pivotField
);

Parameters

pivotField
a PivotField Object.

Return Value

the index of the PivotField Object in this PivotFields.

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldCollection.Clear Method

Clears all PivotFields.

public void Clear();

See Also

GridPivotFieldCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldFunction Enumeration

public enum GridPivotFieldFunction

Members

Member Name | Description | Value
Sum | Represents Sum function. | 0
Count | Represents Count function. | 1
Average | Represents Average function. | 2
Max | Represents Max function. | 3
Min | Represents Min function. | 4
Product | Represents Product function. | 5
CountNums | Represents Count Nums function. | 6
StdDev | Represents StdDev function. | 7
StdDevp | Represents StdDevp function. | 8
Var | Represents Var function. | 9
Varp | Represents Varp function. | 10

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridPivotFieldType Enumeration

public enum GridPivotFieldType

Members

Member Name | Description | Value
Undefined | Presents base pivot field type. | 0
Row | Presents row pivot field type. | 1
Column | Presents column pivot field type. | 2
Page | Presents page pivot field type. | 4
Data | Presents data pivot field type. | 8

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridPivotItem Class

For a list of all members of this type, see GridPivotItem Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPivotItem

public class GridPivotItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPivotItem Members | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem Members

GridPivotItem overview

Public Instance Properties

Index | Gets the index of the pivot item in the pivot field
IsHidden | Gets and Sets whether the pivot item is hidden.
Name | Gets the name of the pivot item.
Value | Gets the value of the pivot item

Public Instance Methods

Equals (inherited from Object) |
GetDateTimeValue | Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue
GetDoubleValue | Gets the double value of the pivot item If the value is null or not number ,it will return 0
GetHashCode (inherited from Object) |
GetStringValue | Gets the string value of the pivot item If the value is null, it will return ""
GetType (inherited from Object) |
Move | Moves the item up or down.
ToString (inherited from Object) |

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem Properties

The properties of the GridPivotItem class are listed below. For a complete list of GridPivotItem class members, see the GridPivotItem Members topic.

Public Instance Properties

Index | Gets the index of the pivot item in the pivot field
IsHidden | Gets and Sets whether the pivot item is hidden.
Name | Gets the name of the pivot item.
Value | Gets the value of the pivot item

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Index Property

Aspose.Cells for .NET

GridPivotItem.Index Property

Gets the index of the pivot item in the pivot field

public int Index {get; set;}

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


IsHidden Property

Aspose.Cells for .NET

GridPivotItem.IsHidden Property

Gets and Sets whether the pivot item is hidden.

public bool IsHidden {get; set;}

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

GridPivotItem.Name Property

Gets the name of the pivot item.

public string Name {get;}

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Value Property

Aspose.Cells for .NET

GridPivotItem.Value Property

Gets the value of the pivot item

public object Value {get;}

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem Methods

The methods of the GridPivotItem class are listed below. For a complete list of GridPivotItem class members, see the GridPivotItem Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetDateTimeValue | Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue
GetDoubleValue | Gets the double value of the pivot item If the value is null or not number ,it will return 0
GetHashCode (inherited from Object) |
GetStringValue | Gets the string value of the pivot item If the value is null, it will return ""
GetType (inherited from Object) |
Move | Moves the item up or down.
ToString (inherited from Object) |

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem.GetDateTimeValue Method

Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue

public DateTime GetDateTimeValue();

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem.GetDoubleValue Method

Gets the double value of the pivot item If the value is null or not number ,it will return 0

public double GetDoubleValue();

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem.GetStringValue Method

Gets the string value of the pivot item If the value is null, it will return ""

public string GetStringValue();

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItem.Move Method

Moves the item up or down.

public void Move(
int count
);

Parameters

count
The number of moving up or down. Move the item up if this is less than zero; Move the item down if this is greater than zero.

See Also

GridPivotItem Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItemCollection Class

Encapsulates a collection of PivotItem objects.

For a list of all members of this type, see GridPivotItemCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPivotItemCollection

public class GridPivotItemCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPivotItemCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridPivotItemCollection Members

GridPivotItemCollection overview

Public Instance Properties

Count |
Item | Gets the PivotItem element at the specified index.

Public Instance Methods

Add | Adds a PivotItem Object to the specific type PivotItems.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotItemCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItemCollection Properties

The properties of the GridPivotItemCollection class are listed below. For a complete list of GridPivotItemCollection class members, see the GridPivotItemCollection Members topic.

Public Instance Properties

Count |
Item | Gets the PivotItem element at the specified index.

See Also

GridPivotItemCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridPivotItemCollection.Count Property

public int Count {get;}

See Also

GridPivotItemCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridPivotItemCollection.Item Property

Gets the PivotItem element at the specified index.

public GridPivotItem this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPivotItemCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItemCollection Methods

The methods of the GridPivotItemCollection class are listed below. For a complete list of GridPivotItemCollection class members, see the GridPivotItemCollection Members topic.

Public Instance Methods

Add | Adds a PivotItem Object to the specific type PivotItems.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridPivotItemCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotItemCollection.Add Method

Adds a PivotItem Object to the specific type PivotItems.

public int Add(
GridPivotItem item
);

Parameters

item

Return Value

the index of the PivotItem Object in this PivotItems.

See Also

GridPivotItemCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTable Class

Represents a PivotTable report on a worksheet. The PivotTable object is a member of the PivotTables collection. The PivotTables collection contains all the PivotTable objects on a control.

For a list of all members of this type, see GridPivotTable Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPivotTable

public class GridPivotTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPivotTable Members | Aspose.Cells.GridWeb.Data Namespace


GridPivotTable Members

GridPivotTable overview

Public Instance Methods

AddFieldToArea | Overloaded. Adds the field to the specific area.
CalculateData | Calculates pivottable's data to cells.
ClearAllFields | clear all pivot fields.
Equals (inherited from Object) |
Fields | Overloaded. Gets the specific fields by the field type.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RefreshData | Refreshes pivottable's data and setting from it's data source.
ToString (inherited from Object) |

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTable Methods

The methods of the GridPivotTable class are listed below. For a complete list of GridPivotTable class members, see the GridPivotTable Members topic.

Public Instance Methods

AddFieldToArea | Overloaded. Adds the field to the specific area.
CalculateData | Calculates pivottable's data to cells.
ClearAllFields | clear all pivot fields.
Equals (inherited from Object) |
Fields | Overloaded. Gets the specific fields by the field type.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RefreshData | Refreshes pivottable's data and setting from it's data source.
ToString (inherited from Object) |

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


AddFieldToArea Method

Aspose.Cells for .NET

GridPivotTable.AddFieldToArea Method

Adds the field to the specific area.

Overload List

Adds the field to the specific area.

public int AddFieldToArea(GridPivotFieldType,int);

Adds the field to the specific area.

public int AddFieldToArea(GridPivotFieldType,string);

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTable.AddFieldToArea Method (GridPivotFieldType, Int32)

Adds the field to the specific area.

public int AddFieldToArea(
GridPivotFieldType fieldType,
int baseFieldIndex
);

Parameters

fieldType
The fields area type.
baseFieldIndex
The field index in the base fields.

Return Value

The field position in the specific fields.

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTable.AddFieldToArea Overload List


GridPivotTable.AddFieldToArea Method (GridPivotFieldType, String)

Adds the field to the specific area.

public int AddFieldToArea(
GridPivotFieldType fieldType,
string fieldName
);

Parameters

fieldType
The fields area type.
fieldName
The name in the base fields.

Return Value

The field position in the specific fields.If there is no field named as it, return -1.

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTable.AddFieldToArea Overload List


GridPivotTable.CalculateData Method

Calculates pivottable's data to cells.

public void CalculateData();

Remarks

Cell.Value in the pivot range could not return the correct result if the method is not been called. This method caclulates data with an inner pivot cache,not original data source. So if the data source is changed, please call RefreshData() method first.

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTable.ClearAllFields Method

clear all pivot fields.

public void ClearAllFields();

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


Fields Method

Aspose.Cells for .NET

GridPivotTable.Fields Method

Gets the specific fields by the field type.

Overload List

Gets the specific fields by the field type.

public GridPivotFieldCollection Fields(GridPivotFieldType);

Gets the specific field by the field name.

public GridPivotField Fields(string);

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTable.Fields Method (GridPivotFieldType)

Gets the specific fields by the field type.

public GridPivotFieldCollection Fields(
GridPivotFieldType fieldType
);

Parameters

fieldType
the field type.

Return Value

the specific fields

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTable.Fields Overload List


GridPivotTable.Fields Method (String)

Gets the specific field by the field name.

public GridPivotField Fields(
string fieldName
);

Parameters

fieldName
the field name.

Return Value

the specific field

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTable.Fields Overload List


GridPivotTable.RefreshData Method

Refreshes pivottable's data and setting from it's data source.

public void RefreshData();

Remarks

We will gather data from data source to a pivot cache ,then calcualte the data in the cache to the cells. This method is only used to gather all data to a pivot cache.

See Also

GridPivotTable Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTableCollection Class

Encapsulates a collection of PivotTable objects.

For a list of all members of this type, see GridPivotTableCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridPivotTableCollection

public class GridPivotTableCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridPivotTableCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridPivotTableCollection Members

GridPivotTableCollection overview

Public Instance Properties

Count |
Item | Gets the PivotTable element at the specified index.

Public Instance Methods

Add | Overloaded. Adds a new PivotTable cache to a PivotCaches collection.
Clear | Clears all PivotTables.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the PivotTable at the specified index.
ToString (inherited from Object) |

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTableCollection Properties

The properties of the GridPivotTableCollection class are listed below. For a complete list of GridPivotTableCollection class members, see the GridPivotTableCollection Members topic.

Public Instance Properties

Count |
Item | Gets the PivotTable element at the specified index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridPivotTableCollection.Count Property

public int Count {get;}

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridPivotTableCollection.Item Property

Gets the PivotTable element at the specified index.

public GridPivotTable this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTableCollection Methods

The methods of the GridPivotTableCollection class are listed below. For a complete list of GridPivotTableCollection class members, see the GridPivotTableCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new PivotTable cache to a PivotCaches collection.
Clear | Clears all PivotTables.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove the PivotTable at the specified index.
ToString (inherited from Object) |

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

GridPivotTableCollection.Add Method

Adds a new PivotTable cache to a PivotCaches collection.

Overload List

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(GridWorksheet,GridCellArea,string,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,GridCellArea,int,int,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,GridCellArea,string,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,string,string);

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTableCollection.Add Method (GridWorksheet, GridCellArea, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
GridWorksheet sourceSheet,
GridCellArea sourceArea,
string destCellName,
string tableName
);

Parameters

sourceSheet
The source work sheet.
sourceArea
The area in the source worksheet.
destCellName
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Add Method (String, GridCellArea, Int32, Int32, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string worksheetname,
GridCellArea sourceArea,
int destRow,
int destCol,
string tableName
);

Parameters

worksheetname
The name of the source worksheet.
sourceArea
The area in the source worksheet.
destRow
The row of the cell in the upper-left corner of the PivotTable report's destination range.
destCol
The column of the cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Add Method (String, GridCellArea, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string worksheetname,
GridCellArea sourceArea,
string destCellName,
string tableName
);

Parameters

worksheetname
The name of the source worksheet.
sourceArea
The area in the source worksheet.
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Add Method (String, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string sourceData,
string destCellName,
string tableName
);

Parameters

sourceData
The data cell range for the new PivotTable.Example : Sheet1!A1:C8
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridPivotTableCollection.Add Overload List


GridPivotTableCollection.Clear Method

Clears all PivotTables.

public void Clear();

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridPivotTableCollection.RemoveAt Method

Remove the PivotTable at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

See Also

GridPivotTableCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridReferredArea Class

Represents a referred objcet by the formula.

For a list of all members of this type, see GridReferredArea Members.

System.Object
Aspose.Cells.GridWeb.Data.GridReferredArea

public class GridReferredArea

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridReferredArea Members | Aspose.Cells.GridWeb.Data Namespace


GridReferredArea Members

GridReferredArea overview

Public Instance Properties

EndColumn | The end column of the area.
EndRow | The end row of the area.
ExternalFileName | this.KeepedRels = source.KeepedRels;
IsArea | Indicates whether this is an area.
IsExternalLink | Indicates whether this is an external link.
SheetName | Indicates which sheet this is in
StartColumn | The start column of the area.
StartRow | The start row of the area.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValue | Gets cell value with given offset from the top-left of this area.
GetValues | Gets cell values in this area.
ToString (inherited from Object) |

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


GridReferredArea Properties

The properties of the GridReferredArea class are listed below. For a complete list of GridReferredArea class members, see the GridReferredArea Members topic.

Public Instance Properties

EndColumn | The end column of the area.
EndRow | The end row of the area.
ExternalFileName | this.KeepedRels = source.KeepedRels;
IsArea | Indicates whether this is an area.
IsExternalLink | Indicates whether this is an external link.
SheetName | Indicates which sheet this is in
StartColumn | The start column of the area.
StartRow | The start row of the area.

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


EndColumn Property

Aspose.Cells for .NET

GridReferredArea.EndColumn Property

The end column of the area.

public int EndColumn {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


EndRow Property

Aspose.Cells for .NET

GridReferredArea.EndRow Property

The end row of the area.

public int EndRow {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


ExternalFileName Property

Aspose.Cells for .NET

GridReferredArea.ExternalFileName Property

this.KeepedRels = source.KeepedRels;

public string ExternalFileName {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


IsArea Property

Aspose.Cells for .NET

GridReferredArea.IsArea Property

Indicates whether this is an area.

public bool IsArea {get;}

Remarks

If this is not an area, only StartRow and StartColumn effect.

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


IsExternalLink Property

Aspose.Cells for .NET

GridReferredArea.IsExternalLink Property

Indicates whether this is an external link.

public bool IsExternalLink {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


SheetName Property

Aspose.Cells for .NET

GridReferredArea.SheetName Property

Indicates which sheet this is in

public string SheetName {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


StartColumn Property

Aspose.Cells for .NET

GridReferredArea.StartColumn Property

The start column of the area.

public int StartColumn {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


StartRow Property

Aspose.Cells for .NET

GridReferredArea.StartRow Property

The start row of the area.

public int StartRow {get;}

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


GridReferredArea Methods

The methods of the GridReferredArea class are listed below. For a complete list of GridReferredArea class members, see the GridReferredArea Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValue | Gets cell value with given offset from the top-left of this area.
GetValues | Gets cell values in this area.
ToString (inherited from Object) |

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


GridReferredArea.GetValue Method

Gets cell value with given offset from the top-left of this area.

public object GetValue(
int rowOffset,
int colOffset
);

Parameters

rowOffset
row offset from the start row of this area
colOffset
column offset from the start row of this area

Return Value

"#REF!" if this area is invalid; "#N/A" if given offset out of this area; Otherwise return the cell value at given position.

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


GridReferredArea.GetValues Method

Gets cell values in this area.

public object GetValues();

Return Value

If this area is invalid, "#REF!" will be returned; If this area is one single cell, then return the cell value object; Otherwise return one array for all values in this area.

See Also

GridReferredArea Class | Aspose.Cells.GridWeb.Data Namespace


GridRow Class

Encapsulates the object that represents a single picture in a spreadsheet.

For a list of all members of this type, see GridRow Members.

System.Object
Aspose.Cells.GridWeb.Data.GridRow

public class GridRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridRow Members | Aspose.Cells.GridWeb.Data Namespace


GridRow Members

GridRow overview

Public Instance Properties

FirstCell | Gets the first cell in the row.
Height | Gets and sets the row height in unit of Points.
Hidden | Indicates whether the row is hidden.
Index | Gets the index of this row.
Item | Gets the cell.
LastCell | Gets the last cell in the row.
LastDataCell | Gets the last cell in the row.
OutlineLevel | Gets and sets the outline level.

Public Instance Methods

Equals (inherited from Object) |
GetCellByIndex | Obsolete. Get the cell by specific index in the list.
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsBlank | Indicates whether the row contains any data
ToString (inherited from Object) |

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


GridRow Properties

The properties of the GridRow class are listed below. For a complete list of GridRow class members, see the GridRow Members topic.

Public Instance Properties

FirstCell | Gets the first cell in the row.
Height | Gets and sets the row height in unit of Points.
Hidden | Indicates whether the row is hidden.
Index | Gets the index of this row.
Item | Gets the cell.
LastCell | Gets the last cell in the row.
LastDataCell | Gets the last cell in the row.
OutlineLevel | Gets and sets the outline level.

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


FirstCell Property

Aspose.Cells for .NET

GridRow.FirstCell Property

Gets the first cell in the row.

public GridCell FirstCell {get;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


Height Property

Aspose.Cells for .NET

GridRow.Height Property

Gets and sets the row height in unit of Points.

public double Height {get; set;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


Hidden Property

Aspose.Cells for .NET

GridRow.Hidden Property

Indicates whether the row is hidden.

public bool Hidden {get; set;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


Index Property

Aspose.Cells for .NET

GridRow.Index Property

Gets the index of this row.

public int Index {get;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridRow.Item Property

Gets the cell.

public GridCell this[
int column
] {get;}

Parameters

column
The column index

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


LastCell Property

Aspose.Cells for .NET

GridRow.LastCell Property

Gets the last cell in the row.

public GridCell LastCell {get;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


LastDataCell Property

Aspose.Cells for .NET

GridRow.LastDataCell Property

Gets the last cell in the row.

public GridCell LastDataCell {get;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


OutlineLevel Property

Aspose.Cells for .NET

GridRow.OutlineLevel Property

Gets and sets the outline level.

public byte OutlineLevel {get; set;}

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


GridRow Methods

The methods of the GridRow class are listed below. For a complete list of GridRow class members, see the GridRow Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetCellByIndex | Obsolete. Get the cell by specific index in the list.
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsBlank | Indicates whether the row contains any data
ToString (inherited from Object) |

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


GridRow.GetCellByIndex Method

NOTE: This method is now obsolete.

Use GridRow.GetEnumerator() method to iterate all cells in this row instead.

Get the cell by specific index in the list.

public GridCell GetCellByIndex(
int index
);

Parameters

index
The position.

Return Value

The Cell object.

Remarks

NOTE: This member is now obsolete. Instead,please use Row.GetEnumerator() method to iterate all cells in this row. This property will be removed 12 months later since February 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


GridRow.GetEnumerator Method

Gets the cells enumerator

public IEnumerator GetEnumerator();

Return Value

The cells enumerator

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


GridRow.IsBlank Method

Indicates whether the row contains any data

public bool IsBlank();

See Also

GridRow Class | Aspose.Cells.GridWeb.Data Namespace


GridRowCollection Class

Encapsulates a collection of Worksheet objects.

For a list of all members of this type, see GridRowCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridRowCollection

public class GridRowCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridRowCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridRowCollection Members

GridRowCollection overview

Public Instance Properties

Count |
Item | Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRowByIndex | Gets the row object by the position in the list.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridRowCollection Properties

The properties of the GridRowCollection class are listed below. For a complete list of GridRowCollection class members, see the GridRowCollection Members topic.

Public Instance Properties

Count |
Item | Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridRowCollection.Count Property

public int Count {get;}

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridRowCollection.Item Property

Gets a object by given row index. The Row object of given row index will be instantiated if it does not exist before.

public GridRow this[
int rowIndex
] {get;}

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace | Row


GridRowCollection Methods

The methods of the GridRowCollection class are listed below. For a complete list of GridRowCollection class members, see the GridRowCollection Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetRowByIndex | Gets the row object by the position in the list.
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridRowCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridRowCollection.GetRowByIndex Method

Gets the row object by the position in the list.

public GridRow GetRowByIndex(
int index
);

Parameters

index
The position.

Return Value

The Row object at given position.

See Also

GridRowCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridSaveFormat Enumeration

Enumerates supported file format types.

public enum GridSaveFormat

Members

Member Name | Description | Value
CSV | CSV | 1
Excel2003 | Excel 2003, Excel97-2003 xls file. | 5
Excel2007 | Excel 2007 Represents an xlsx file | 6
XLSM | Excel 2007 xlsm file which enable macros | 7
XLTX | Excel Template file | 8
XLTM | Represents an Xltx file which enable macros. | 9
TABDELIMITED | Represents a tab delimited text file,txt file. | 11
HTML | Represents a html file. | 12
PDF | Represents a pdf file. | 13
ODS | Represents a ods file. | 14
SpreadsheetML | SpreadsheetML,Represents an Excel 2003 xml file. | 15
XLSB | Represents a XLSB file. | 16
MHTML | Represents a mhtml file. | 17
XPS | Represents a XPS file. | 20
TIFF | Represents a TIFF file. | 21
SVG | Represents a SVG file. | 22
DIF | Data Interchange Format. | 30

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridSaveOptions Class

Represents all save options

For a list of all members of this type, see GridSaveOptions Members.

System.Object
Aspose.Cells.GridWeb.Data.GridSaveOptions
Aspose.Cells.GridWeb.Data.GridHtmlSaveOptions

public class GridSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridSaveOptions Members | Aspose.Cells.GridWeb.Data Namespace


GridSaveOptions Members

GridSaveOptions overview

Public Instance Properties

CachedFileFolder | The cached file folder is used to store some large data.
ClearData | Make the workbook empty after saving the file.
CreateDirectory | If true and the directory does not exist, the directory will be automatically created before saving the file.
MergeAreas | Indicates whether merge the areas of conditional formatting and validation before saving the file.
RefreshChartCache | Indicates whether refreshing chart cache data
SaveFormat | Gets the save file format.
SortNames | Indicates whether sorting defined names before saving file.
ValidateMergedAreas | Indicates whether validate merged cells before saving the file.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


GridSaveOptions Properties

The properties of the GridSaveOptions class are listed below. For a complete list of GridSaveOptions class members, see the GridSaveOptions Members topic.

Public Instance Properties

CachedFileFolder | The cached file folder is used to store some large data.
ClearData | Make the workbook empty after saving the file.
CreateDirectory | If true and the directory does not exist, the directory will be automatically created before saving the file.
MergeAreas | Indicates whether merge the areas of conditional formatting and validation before saving the file.
RefreshChartCache | Indicates whether refreshing chart cache data
SaveFormat | Gets the save file format.
SortNames | Indicates whether sorting defined names before saving file.
ValidateMergedAreas | Indicates whether validate merged cells before saving the file.

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


CachedFileFolder Property

Aspose.Cells for .NET

GridSaveOptions.CachedFileFolder Property

The cached file folder is used to store some large data.

public string CachedFileFolder {get; set;}

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ClearData Property

Aspose.Cells for .NET

GridSaveOptions.ClearData Property

Make the workbook empty after saving the file.

public bool ClearData {get; set;}

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


CreateDirectory Property

Aspose.Cells for .NET

GridSaveOptions.CreateDirectory Property

If true and the directory does not exist, the directory will be automatically created before saving the file.

public bool CreateDirectory {get; set;}

Remarks

The default value is false.

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


MergeAreas Property

Aspose.Cells for .NET

GridSaveOptions.MergeAreas Property

Indicates whether merge the areas of conditional formatting and validation before saving the file.

public bool MergeAreas {get; set;}

Remarks

The default value is false.

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


RefreshChartCache Property

Aspose.Cells for .NET

GridSaveOptions.RefreshChartCache Property

Indicates whether refreshing chart cache data

public bool RefreshChartCache {get; set;}

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


SaveFormat Property

Aspose.Cells for .NET

GridSaveOptions.SaveFormat Property

Gets the save file format.

public GridSaveFormat SaveFormat {get;}

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


SortNames Property

Aspose.Cells for .NET

GridSaveOptions.SortNames Property

Indicates whether sorting defined names before saving file.

public bool SortNames {get; set;}

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


ValidateMergedAreas Property

Aspose.Cells for .NET

GridSaveOptions.ValidateMergedAreas Property

Indicates whether validate merged cells before saving the file.

public bool ValidateMergedAreas {get; set;}

Remarks

The default value is false.

See Also

GridSaveOptions Class | Aspose.Cells.GridWeb.Data Namespace


GridShape Class

Represents a shape object.

For a list of all members of this type, see GridShape Members.

System.Object
Aspose.Cells.GridWeb.Data.GridShape

public class GridShape

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridShape Members | Aspose.Cells.GridWeb.Data Namespace


GridShape Members

GridShape overview

Public Instance Properties

Buffer | Gets the Buffer of object.
ID |
ImageFormat | Gets the image format of the picture.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
MsoDrawingType | Gets and sets mso drawing type.
Name | Gets and sets the name of the shape.
Text | Represents the string in this TextBox object.
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
ZOrderPosition | Returns the position of a shape in the z-order.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SaveToImage | Creates the image and saves it to a stream in the specified png format.
ToString (inherited from Object) |

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


GridShape Properties

The properties of the GridShape class are listed below. For a complete list of GridShape class members, see the GridShape Members topic.

Public Instance Properties

Buffer | Gets the Buffer of object.
ID |
ImageFormat | Gets the image format of the picture.
Left | Represents the horizontal offset of shape from its left column, in unit of pixels.
MsoDrawingType | Gets and sets mso drawing type.
Name | Gets and sets the name of the shape.
Text | Represents the string in this TextBox object.
Top | Represents the vertical offset of shape from its top row, in unit of pixels.
UpperLeftColumn | Represents upper left corner column index.
UpperLeftRow | Represents upper left corner row index.
ZOrderPosition | Returns the position of a shape in the z-order.

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


Buffer Property

Aspose.Cells for .NET

GridShape.Buffer Property

Gets the Buffer of object.

public byte[] Buffer {get;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


ID Property

Aspose.Cells for .NET

GridShape.ID Property

public string ID {get; set;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


ImageFormat Property

Aspose.Cells for .NET

GridShape.ImageFormat Property

Gets the image format of the picture.

public ImageFormat ImageFormat {get;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


Left Property

Aspose.Cells for .NET

GridShape.Left Property

Represents the horizontal offset of shape from its left column, in unit of pixels.

public int Left {get;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


MsoDrawingType Property

Aspose.Cells for .NET

GridShape.MsoDrawingType Property

Gets and sets mso drawing type.

public GridMsoDrawingType MsoDrawingType {get;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

GridShape.Name Property

Gets and sets the name of the shape.

public string Name {get;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


Text Property

Aspose.Cells for .NET

GridShape.Text Property

Represents the string in this TextBox object.

public string Text {get; set;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


Top Property

Aspose.Cells for .NET

GridShape.Top Property

Represents the vertical offset of shape from its top row, in unit of pixels.

public int Top {get;}

Remarks

If the shape is in the chart, represents the vertical offset of shape from its top border.

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


UpperLeftColumn Property

Aspose.Cells for .NET

GridShape.UpperLeftColumn Property

Represents upper left corner column index.

public int UpperLeftColumn {get;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


UpperLeftRow Property

Aspose.Cells for .NET

GridShape.UpperLeftRow Property

Represents upper left corner row index.

public int UpperLeftRow {get;}

Remarks

If the shape is in the shape or in the group , UpperLeftRow will be ignored.

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


ZOrderPosition Property

Aspose.Cells for .NET

GridShape.ZOrderPosition Property

Returns the position of a shape in the z-order.

public int ZOrderPosition {get; set;}

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


GridShape Methods

The methods of the GridShape class are listed below. For a complete list of GridShape class members, see the GridShape Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SaveToImage | Creates the image and saves it to a stream in the specified png format.
ToString (inherited from Object) |

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


GridShape.SaveToImage Method

Creates the image and saves it to a stream in the specified png format.

public void SaveToImage(
Stream s
);

See Also

GridShape Class | Aspose.Cells.GridWeb.Data Namespace


GridShapeCollection Class

For a list of all members of this type, see GridShapeCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridShapeCollection

public class GridShapeCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridShapeCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridShapeCollection Members

GridShapeCollection overview

Public Instance Properties

Count |
Item | Gets the Picture element at the specified index.

Public Instance Methods

Clear |
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridShapeCollection Properties

The properties of the GridShapeCollection class are listed below. For a complete list of GridShapeCollection class members, see the GridShapeCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Picture element at the specified index.

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridShapeCollection.Count Property

public int Count {get;}

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridShapeCollection.Item Property

Gets the Picture element at the specified index.

public GridShape this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridShapeCollection Methods

The methods of the GridShapeCollection class are listed below. For a complete list of GridShapeCollection class members, see the GridShapeCollection Members topic.

Public Instance Methods

Clear |
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridShapeCollection.Clear Method

public void Clear();

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridShapeCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

See Also

GridShapeCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation Class

For a list of all members of this type, see GridValidation Members.

System.Object
Aspose.Cells.GridWeb.Data.GridValidation

public class GridValidation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridValidation Members | Aspose.Cells.GridWeb.Data Namespace


GridValidation Members

GridValidation overview

Public Instance Constructors

GridValidation Constructor Initializes a new instance of the GridValidation class.

Public Instance Fields

ServerValidation Gets or sets the serverside validation javascript function name.

Public Instance Properties

AreaList | Represents a collection of CellArea which contains the data validation settings.
ClientValidationFunction | Gets or sets the client validation javascript function name.
ErrorMessage | Represents the data validation error message.
ErrorTitle | Represents the title of the data-validation error dialog box.
Formula1 | Represents the value or expression associated with the data validation.
Formula2 | Represents the value or expression associated with the second part of the data validation.
InputMessage | Represents the data validation error message.
InputTitle | Represents the title of the data-validation input dialog box.
IsRequired |
Operator | Represents the operator for the data validation.
RegEx | Gets or sets the regular expression string.
ShowError | Indicates whether the data validation error message will be displayed whenever the user enters invalid data.
ShowInput |
ValidationType | Gets or sets the validation type.
Value1 | Represents the value associated with the data validation.
ValueList | Gets/Sets the value list object.

Public Instance Methods

AddACell | Overloaded. add the validation settings in the cell.
AddArea | Applies the validation to the area.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
LoadValueList | Loads value list from a DataView object. You can specify the value field and text field of the DataView. Each value and text pair will be combined to one string, with a comma between them.
RemoveACell | Remove the validation settings in the cell.
RemoveArea | Remove the validation settings in the range.
ToString (inherited from Object) |

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation Constructor

Initializes a new instance of the GridValidation class.

public GridValidation();

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation Fields

The fields of the GridValidation class are listed below. For a complete list of GridValidation class members, see the GridValidation Members topic.

Public Instance Fields

ServerValidation Gets or sets the serverside validation javascript function name.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation.ServerValidation Field

Gets or sets the serverside validation javascript function name.

public GridCustomServerValidation ServerValidation;

Remarks

Use the GridCustomServerValidation property to specify the serverside validation .

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation Properties

The properties of the GridValidation class are listed below. For a complete list of GridValidation class members, see the GridValidation Members topic.

Public Instance Properties

AreaList | Represents a collection of CellArea which contains the data validation settings.
ClientValidationFunction | Gets or sets the client validation javascript function name.
ErrorMessage | Represents the data validation error message.
ErrorTitle | Represents the title of the data-validation error dialog box.
Formula1 | Represents the value or expression associated with the data validation.
Formula2 | Represents the value or expression associated with the second part of the data validation.
InputMessage | Represents the data validation error message.
InputTitle | Represents the title of the data-validation input dialog box.
IsRequired |
Operator | Represents the operator for the data validation.
RegEx | Gets or sets the regular expression string.
ShowError | Indicates whether the data validation error message will be displayed whenever the user enters invalid data.
ShowInput |
ValidationType | Gets or sets the validation type.
Value1 | Represents the value associated with the data validation.
ValueList | Gets/Sets the value list object.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


AreaList Property

Aspose.Cells for .NET

GridValidation.AreaList Property

Represents a collection of CellArea which contains the data validation settings.

public ArrayList AreaList {get;}

Remarks

The old valvidations on the area will not be removed if directly adding are to this list.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ClientValidationFunction Property

Aspose.Cells for .NET

GridValidation.ClientValidationFunction Property

Gets or sets the client validation javascript function name.

public string ClientValidationFunction {get; set;}

Remarks

Use the ClientValidationFunction property to specify the client validation function's name. The function should be declared as this formation:
function customValicationFunction(source, value)
The parameter "source" is the cell object. The parameter "value" is the string value of a cell to be checked. The function should returns true if the value is valid.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ErrorMessage Property

Aspose.Cells for .NET

GridValidation.ErrorMessage Property

Represents the data validation error message.

public string ErrorMessage {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ErrorTitle Property

Aspose.Cells for .NET

GridValidation.ErrorTitle Property

Represents the title of the data-validation error dialog box.

public string ErrorTitle {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


Formula1 Property

Aspose.Cells for .NET

GridValidation.Formula1 Property

Represents the value or expression associated with the data validation.

public string Formula1 {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


Formula2 Property

Aspose.Cells for .NET

GridValidation.Formula2 Property

Represents the value or expression associated with the second part of the data validation.

public string Formula2 {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


InputMessage Property

Aspose.Cells for .NET

GridValidation.InputMessage Property

Represents the data validation error message.

public string InputMessage {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


InputTitle Property

Aspose.Cells for .NET

GridValidation.InputTitle Property

Represents the title of the data-validation input dialog box.

public string InputTitle {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


IsRequired Property

Aspose.Cells for .NET

GridValidation.IsRequired Property

public bool IsRequired {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


Operator Property

Aspose.Cells for .NET

GridValidation.Operator Property

Represents the operator for the data validation.

public GridOperatorType Operator {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


RegEx Property

Aspose.Cells for .NET

GridValidation.RegEx Property

Gets or sets the regular expression string.

public string RegEx {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ShowError Property

Aspose.Cells for .NET

GridValidation.ShowError Property

Indicates whether the data validation error message will be displayed whenever the user enters invalid data.

public bool ShowError {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ShowInput Property

Aspose.Cells for .NET

GridValidation.ShowInput Property

public bool ShowInput {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ValidationType Property

Aspose.Cells for .NET

GridValidation.ValidationType Property

Gets or sets the validation type.

public GridValidationType ValidationType {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


Value1 Property

Aspose.Cells for .NET

GridValidation.Value1 Property

Represents the value associated with the data validation.

public object[] Value1 {get;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


ValueList Property

Aspose.Cells for .NET

GridValidation.ValueList Property

Gets/Sets the value list object.

public StringCollection ValueList {get; set;}

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation Methods

The methods of the GridValidation class are listed below. For a complete list of GridValidation class members, see the GridValidation Members topic.

Public Instance Methods

AddACell | Overloaded. add the validation settings in the cell.
AddArea | Applies the validation to the area.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
LoadValueList | Loads value list from a DataView object. You can specify the value field and text field of the DataView. Each value and text pair will be combined to one string, with a comma between them.
RemoveACell | Remove the validation settings in the cell.
RemoveArea | Remove the validation settings in the range.
ToString (inherited from Object) |

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


AddACell Method

Aspose.Cells for .NET

GridValidation.AddACell Method

add the validation settings in the cell.

Overload List

add the validation settings in the cell.

public void AddACell(int,int);

add the validation settings in the cell.

public void AddACell(string);

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation.AddACell Method (Int32, Int32)

add the validation settings in the cell.

public void AddACell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace | GridValidation.AddACell Overload List


GridValidation.AddACell Method (String)

add the validation settings in the cell.

public void AddACell(
string cellname
);

Parameters

cellname
cell name.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace | GridValidation.AddACell Overload List


GridValidation.AddArea Method

Applies the validation to the area.

public void AddArea(
GridCellArea cellArea
);

Parameters

cellArea
The area.

Remarks

In this method , we will remove all old validations on this area.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation.LoadValueList Method

Loads value list from a DataView object. You can specify the value field and text field of the DataView. Each value and text pair will be combined to one string, with a comma between them.

public void LoadValueList(
DataView view,
string valueField,
string textField,
bool valuePrefixText
);

Parameters

view
The DataView object.
valueField
The value field name.
textField
The text field name.
valuePrefixText
Indicates whether to add a value prefix to each displayed text.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation.RemoveACell Method

Remove the validation settings in the cell.

public void RemoveACell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidation.RemoveArea Method

Remove the validation settings in the range.

public void RemoveArea(
GridCellArea cellArea
);

Parameters

cellArea
The range which contains the data validation settings.

See Also

GridValidation Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection Class

Encapsulates a collection of Hyperlink objects.

For a list of all members of this type, see GridValidationCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridValidationCollection

public class GridValidationCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridValidationCollection Members | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection Members

GridValidationCollection overview

Public Instance Properties

Count |
Item | Gets the Hyperlink element at the specified index.

Public Instance Methods

Add | Overloaded. Add a GridValidation to the collection.
Clear | Clears all validations.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValidationInCell | Gets the validation applied to given cell.
RemoveAt | Remove the validation at the specified index.
ToString (inherited from Object) |

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection Properties

The properties of the GridValidationCollection class are listed below. For a complete list of GridValidationCollection class members, see the GridValidationCollection Members topic.

Public Instance Properties

Count |
Item | Gets the Hyperlink element at the specified index.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridValidationCollection.Count Property

public int Count {get;}

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridValidationCollection.Item Property

Gets the Hyperlink element at the specified index.

public GridValidation this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection Methods

The methods of the GridValidationCollection class are listed below. For a complete list of GridValidationCollection class members, see the GridValidationCollection Members topic.

Public Instance Methods

Add | Overloaded. Add a GridValidation to the collection.
Clear | Clears all validations.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetValidationInCell | Gets the validation applied to given cell.
RemoveAt | Remove the validation at the specified index.
ToString (inherited from Object) |

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

GridValidationCollection.Add Method

NOTE: This method is now obsolete.

Use GridValidationCollection.Add(row,col) method instead.

Add a GridValidation to the collection.

Overload List

Obsolete. Add a GridValidation to the collection.

public GridValidation Add();

Adds a data validation to the collection.

public GridValidation Add(GridCellArea);

Add a GridValidation to the collection.

public int Add(GridValidation);

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(int,int);

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(string);

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection.Add Method ()

NOTE: This method is now obsolete.

Use GridValidationCollection.Add(row,col) method instead.

Add a GridValidation to the collection.

public GridValidation Add();

Return Value

GridValidation the added GridValidation instance.

Remarks

NOTE: This member is now obsolete. Instead, please use GridValidationCollection.Add(row,col) method. This property will be removed 12 months later since JANUARY 2015. Aspose apologizes for any inconvenience you may have experienced.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (GridCellArea)

Adds a data validation to the collection.

public GridValidation Add(
GridCellArea ca
);

Parameters

ca
The area contains this validation.

Return Value

GridValidation the validation.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (GridValidation)

Add a GridValidation to the collection.

public int Add(
GridValidation validation
);

Parameters

validation
A validation object.

Return Value

GridValidation object index.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (Int32, Int32)

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

GridValidation the added GridValidation instance.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Add Method (String)

Add a GridValidation to the collection.the validation is applied to the specificed cell.

public GridValidation Add(
string cellname
);

Parameters

cellname
the name of the cell.

Return Value

GridValidation the added GridValidation instance.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridValidationCollection.Add Overload List


GridValidationCollection.Clear Method

Clears all validations.

public void Clear();

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection.GetValidationInCell Method

Gets the validation applied to given cell.

public GridValidation GetValidationInCell(
int row,
int column
);

Parameters

row
The row index.
column
The column index.

Return Value

Returns a Validation object or null if there is no validation for given cell

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationCollection.RemoveAt Method

Remove the validation at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index of the element.

See Also

GridValidationCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridValidationType Enumeration

public enum GridValidationType

Members

Member Name | Description | Value
AnyValue | Any value validation type. | 0
WholeNumber | Whole number validation type. | 1
Decimal | Decimal validation type. | 2
List | List validation type. | 3
Date | Date validation type. | 4
Time | Time validation type. | 5
TextLength | Text length validation type. | 6
Custom | Custom validation type. | 7
DropDownList | Show dropdown list. | 8
FreeList | Free List validation type. | 9
CustomExpression | Custom validation type, using regular expression. | 10
Boolean | TRUE or FALSE | 11
DateTime | DateTime (yyyy-MM-dd or yyyy-MM-dd hh:mm:ss). | 12
CustomFunction | Custom javascript function validation. | 13
CustomServerFunction | Custom server-side function validation. | 14
CheckBox | Display the cell as a checkbox. And the value of the cell is True of False. | 15

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


GridWebException Class

The exception that is thrown when Aspose.Cells.GridWeb specified error occurs.

For a list of all members of this type, see GridWebException Members.

System.Object
System.Exception
System.ApplicationException
Aspose.Cells.GridWeb.Data.GridWebException

public class GridWebException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWebException Members | Aspose.Cells.GridWeb.Data Namespace


GridWebException Members

GridWebException overview

Public Instance Constructors

GridWebException Constructor

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

See Also

GridWebException Class | Aspose.Cells.GridWeb.Data Namespace


GridWebException Constructor

public GridWebException(
string m
);

See Also

GridWebException Class | Aspose.Cells.GridWeb.Data Namespace


GridWorkbook Class

Represents a root object to create an Excel spreadsheet.

For a list of all members of this type, see GridWorkbook Members.

System.Object
Aspose.Cells.GridWeb.Data.GridWorkbook

public class GridWorkbook : ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWorkbook Members | Aspose.Cells.GridWeb.Data Namespace


GridWorkbook Members

GridWorkbook overview

Public Instance Properties

Worksheets

Public Instance Methods

CalculateFormula | Calculates the result of formulas.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridWorkbook Class | Aspose.Cells.GridWeb.Data Namespace


GridWorkbook Properties

The properties of the GridWorkbook class are listed below. For a complete list of GridWorkbook class members, see the GridWorkbook Members topic.

Public Instance Properties

Worksheets

See Also

GridWorkbook Class | Aspose.Cells.GridWeb.Data Namespace


Worksheets Property

Aspose.Cells for .NET

GridWorkbook.Worksheets Property

public GridWorksheetCollection Worksheets {get;}

See Also

GridWorkbook Class | Aspose.Cells.GridWeb.Data Namespace


GridWorkbook Methods

The methods of the GridWorkbook class are listed below. For a complete list of GridWorkbook class members, see the GridWorkbook Members topic.

Public Instance Methods

CalculateFormula | Calculates the result of formulas.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

GridWorkbook Class | Aspose.Cells.GridWeb.Data Namespace


GridWorkbook.CalculateFormula Method

Calculates the result of formulas.

public void CalculateFormula();

See Also

GridWorkbook Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet Class

Encapsulates the object that represents a single worksheet.

For a list of all members of this type, see GridWorksheet Members.

System.Object
System.Web.UI.Control
Aspose.Cells.GridWeb.Data.GridWorksheet
Aspose.Cells.GridWeb.GridWorksheetDesign

public class GridWorksheet : Control, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWorksheet Members | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet Members

GridWorksheet overview

Public Instance Properties

ActiveCell |
AppRelativeTemplateSourceDirectory (inherited from Control) |
BackgroundImage | Gets and sets worksheet background image.
BindColumns | Bind columns collection.
BindingContainer (inherited from Control) |
BindingSource | The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.
BindStartColumn | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
BindStartRow | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
Cells |
ClientID (inherited from Control) |
CodeName | Represents worksheet code name.
Comments |
Controls (inherited from Control) |
CurrentBindRows | Gets the binding rows number in data-binding mode.
DataMember | Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.
DataSource | Gets or sets the DataSource. Generally it's a DataSet object.
DisplayRightToLeft |
DisplayZeros | True if zero values are displayed.
EnableCreateBindColumnHeader | In data-binding mode, indicates whether to create bind column header captions in the sheet.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
FirstVisibleColumn |
FirstVisibleRow |
GridActiveCell |
Hyperlinks | Gets the HyperlinkCollection collection.
ID (inherited from Control) |
Index |
IsGridlinesVisible | Gets or sets a value indicating whether the grid lines are visible.Default is true.
IsSummaryRowBelow | Indicates if the summary row will be positioned below the detail rows in the outline.
Name | Gets or sets the name of the worksheet.
NamingContainer (inherited from Control) |
OutlineShown | Indicates whether show outline.
Page (inherited from Control) |
Parent (inherited from Control) |
Pictures | Gets a Pictures collection.
PivotTables | Gets the pivotTables in the worksheet.
Selected | Indicates whether this worksheet is selected when the workbook is opened.
Shapes | Gets a Pictures collection.
Site (inherited from Control) |
SkinID (inherited from Control) |
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet,in unit of pixels.
TabColor | Represents worksheet tab color.
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Validations | Gets the data validation setting collection in the worksheet.
Visible | Indicates whether this sheet's name is shown in the sheet tabs of the control.
Workbook |
Zoom |

Public Instance Methods

AddAutoFilter | Sets the range to which the specified AutoFilter applies.
AddCustomFilter | Add custom filter for the specified row.
ApplyStyleSheetSkin (inherited from Control) |
AutoFitColumn | Overloaded. Autofits the column width.
CalculateFormula | Calculates a formula.
CancelNewBindRow | Cancels and deletes the new added bind row.
ClearComments | Clears all comments in designer spreadsheet.
CommitNewBindRow | Commits the new added bind row and add it to the datasource.
Copy | Copies contents and formats from another worksheet.
CreateAutoGenratedColumns | After setting a datasource for the worksheet, call this method to generate the bind columns automatically.
CreateNewBindRow | Creates a new bind row and bind to the datasource.
CreateSubtotal | Overloaded. Creates subtotal in the sheet.
DataBind | Bind the sheet to the DataSource.
DataSourceControlUpdate | Bind the sheet to the DataSource.
DeleteBindRow | Deletes a bind row.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FilterString | Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc
FindControl (inherited from Control) |
Focus (inherited from Control) |
FreezePanes | Overloaded. Freezes panes at the specified cell in the worksheet.
GetColumnCaption | Gets the column caption. If the caption is not set, returns empty string.
GetColumnHeaderToolTip | Gets the columnheader's tooltip text.
GetColumnReadonly | Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetFreezedPanes |
GetHashCode (inherited from Object) |
GetIsReadonly | Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
GetRowCaption | Gets the row caption. If the caption is not set, returns empty string.
GetRowHeaderToolTip | Gets the rowheader's tooltip text.
GetRowReadonly | Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetType (inherited from Object) |
GroupRows | Groups rows.
HasControls (inherited from Control) |
IsProtected | Indicates if the worksheet is protected.
MoveTo | Moves the sheet to another location in the spreadsheet.
RefreshFilter | Refresh auto filters to hide or unhide the rows.
RemoveAutoFilter | Remove the auto filter of the worksheet.
RemoveSubtotal | Removes subtotal created by the CreateSubtotal method in the sheet.
RenderControl (inherited from Control) |
ResetFilter | The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAllCellsEditable | Makes all cells editable.this is extended attribute
SetAllCellsReadonly | Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect
SetColumnCaption | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetColumnHeaderToolTip | Sets the columnheader's tooltip text.
SetColumnReadonly | Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetEditableRange | Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable
SetIsReadonly | Sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
SetProtect | Protects worksheet.
SetReadonlyRange | Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly
SetRenderMethodDelegate (inherited from Control) |
SetRowCaption | Sets the caption for the row.
SetRowHeaderToolTip | Sets the rowheader's tooltip text.
SetRowReadonly | Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
ToString (inherited from Object) |
UnFreezePanes | Unfreezes panes in the worksheet.
UnGroupRows | Ungroups rows.
UnProtect | unProtects worksheet.

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
InitializeNewBindRow | Occurs when the worksheet has created a new bind row and need to initialize it.
Load (inherited from Control) |
PreRender (inherited from Control) |
Unload (inherited from Control) |

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet Properties

The properties of the GridWorksheet class are listed below. For a complete list of GridWorksheet class members, see the GridWorksheet Members topic.

Public Instance Properties

ActiveCell |
AppRelativeTemplateSourceDirectory (inherited from Control) |
BackgroundImage | Gets and sets worksheet background image.
BindColumns | Bind columns collection.
BindingContainer (inherited from Control) |
BindingSource | The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.
BindStartColumn | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
BindStartRow | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
Cells |
ClientID (inherited from Control) |
CodeName | Represents worksheet code name.
Comments |
Controls (inherited from Control) |
CurrentBindRows | Gets the binding rows number in data-binding mode.
DataMember | Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.
DataSource | Gets or sets the DataSource. Generally it's a DataSet object.
DisplayRightToLeft |
DisplayZeros | True if zero values are displayed.
EnableCreateBindColumnHeader | In data-binding mode, indicates whether to create bind column header captions in the sheet.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
FirstVisibleColumn |
FirstVisibleRow |
GridActiveCell |
Hyperlinks | Gets the HyperlinkCollection collection.
ID (inherited from Control) |
Index |
IsGridlinesVisible | Gets or sets a value indicating whether the grid lines are visible.Default is true.
IsSummaryRowBelow | Indicates if the summary row will be positioned below the detail rows in the outline.
Name | Gets or sets the name of the worksheet.
NamingContainer (inherited from Control) |
OutlineShown | Indicates whether show outline.
Page (inherited from Control) |
Parent (inherited from Control) |
Pictures | Gets a Pictures collection.
PivotTables | Gets the pivotTables in the worksheet.
Selected | Indicates whether this worksheet is selected when the workbook is opened.
Shapes | Gets a Pictures collection.
Site (inherited from Control) |
SkinID (inherited from Control) |
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardHeightPixels | Gets or sets the default row height in this worksheet,in unit of pixels.
TabColor | Represents worksheet tab color.
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Validations | Gets the data validation setting collection in the worksheet.
Visible | Indicates whether this sheet's name is shown in the sheet tabs of the control.
Workbook |
Zoom |

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


ActiveCell Property

Aspose.Cells for .NET

GridWorksheet.ActiveCell Property

public string ActiveCell {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BackgroundImage Property

Aspose.Cells for .NET

GridWorksheet.BackgroundImage Property

Gets and sets worksheet background image.

public byte[] BackgroundImage {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindColumns Property

Aspose.Cells for .NET

GridWorksheet.BindColumns Property

Bind columns collection.

public BindColumnCollection BindColumns {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindingSource Property

Aspose.Cells for .NET

GridWorksheet.BindingSource Property

The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.

public IEnumerable BindingSource {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindStartColumn Property

Aspose.Cells for .NET

GridWorksheet.BindStartColumn Property

In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.

public int BindStartColumn {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindStartRow Property

Aspose.Cells for .NET

GridWorksheet.BindStartRow Property

In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.

public int BindStartRow {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Cells Property

Aspose.Cells for .NET

GridWorksheet.Cells Property

public GridCells Cells {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


CodeName Property

Aspose.Cells for .NET

GridWorksheet.CodeName Property

Represents worksheet code name.

public string CodeName {get;}

Remarks

You cannot change the code name while the template file contains VBA/macro.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Comments Property

Aspose.Cells for .NET

GridWorksheet.Comments Property

public GridCommentCollection Comments {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


CurrentBindRows Property

Aspose.Cells for .NET

GridWorksheet.CurrentBindRows Property

Gets the binding rows number in data-binding mode.

public int CurrentBindRows {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


DataMember Property

Aspose.Cells for .NET

GridWorksheet.DataMember Property

Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.

public string DataMember {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


DataSource Property

Aspose.Cells for .NET

GridWorksheet.DataSource Property

Gets or sets the DataSource. Generally it's a DataSet object.

public object DataSource {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


DisplayRightToLeft Property

Aspose.Cells for .NET

GridWorksheet.DisplayRightToLeft Property

public bool DisplayRightToLeft {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


DisplayZeros Property

Aspose.Cells for .NET

GridWorksheet.DisplayZeros Property

True if zero values are displayed.

public bool DisplayZeros {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


EnableCreateBindColumnHeader Property

Aspose.Cells for .NET

GridWorksheet.EnableCreateBindColumnHeader Property

In data-binding mode, indicates whether to create bind column header captions in the sheet.

public bool EnableCreateBindColumnHeader {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


FirstVisibleColumn Property

Aspose.Cells for .NET

GridWorksheet.FirstVisibleColumn Property

public int FirstVisibleColumn {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


FirstVisibleRow Property

Aspose.Cells for .NET

GridWorksheet.FirstVisibleRow Property

public int FirstVisibleRow {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridActiveCell Property

Aspose.Cells for .NET

GridWorksheet.GridActiveCell Property

public GridCell GridActiveCell {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks Property

Aspose.Cells for .NET

GridWorksheet.Hyperlinks Property

Gets the HyperlinkCollection collection.

public GridHyperlinkCollection Hyperlinks {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Index Property

Aspose.Cells for .NET

GridWorksheet.Index Property

public int Index {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


IsGridlinesVisible Property

Aspose.Cells for .NET

GridWorksheet.IsGridlinesVisible Property

Gets or sets a value indicating whether the grid lines are visible.Default is true.

public bool IsGridlinesVisible {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


IsSummaryRowBelow Property

Aspose.Cells for .NET

GridWorksheet.IsSummaryRowBelow Property

Indicates if the summary row will be positioned below the detail rows in the outline.

public bool IsSummaryRowBelow {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

GridWorksheet.Name Property

Gets or sets the name of the worksheet.

public string Name {get; set;}

Remarks

The max length of sheet name is 31. And you cannot assign same name(case insensitive) to two worksheets. For example, you cannot set "SheetName1" to the first worksheet and set "SHEETNAME1" to the second worksheet.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


OutlineShown Property

Aspose.Cells for .NET

GridWorksheet.OutlineShown Property

Indicates whether show outline.

public bool OutlineShown {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Pictures Property

Aspose.Cells for .NET

GridWorksheet.Pictures Property

Gets a Pictures collection.

public GridPictureCollection Pictures {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables Property

Aspose.Cells for .NET

GridWorksheet.PivotTables Property

Gets the pivotTables in the worksheet.

public GridPivotTableCollection PivotTables {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Selected Property

Aspose.Cells for .NET

GridWorksheet.Selected Property

Indicates whether this worksheet is selected when the workbook is opened.

public bool Selected {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Shapes Property

Aspose.Cells for .NET

GridWorksheet.Shapes Property

Gets a Pictures collection.

public GridShapeCollection Shapes {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


StandardHeight Property

Aspose.Cells for .NET

GridWorksheet.StandardHeight Property

Gets or sets the default row height in this worksheet,in unit of points.

public double StandardHeight {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


StandardHeightPixels Property

Aspose.Cells for .NET

GridWorksheet.StandardHeightPixels Property

Gets or sets the default row height in this worksheet,in unit of pixels.

public int StandardHeightPixels {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


TabColor Property

Aspose.Cells for .NET

GridWorksheet.TabColor Property

Represents worksheet tab color.

public Color TabColor {get; set;}

Remarks

This feature is only supported in ExcelXP(Excel2002) and above version. If you save file as Excel97 or Excel2000 format, it will be omitted.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Validations Property

Aspose.Cells for .NET

GridWorksheet.Validations Property

Gets the data validation setting collection in the worksheet.

public GridValidationCollection Validations {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Visible Property

Aspose.Cells for .NET

GridWorksheet.Visible Property

Indicates whether this sheet's name is shown in the sheet tabs of the control.

public override bool Visible {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Workbook Property

Aspose.Cells for .NET

GridWorksheet.Workbook Property

public GridWorkbook Workbook {get;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Zoom Property

Aspose.Cells for .NET

GridWorksheet.Zoom Property

public int Zoom {get; set;}

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet Methods

The methods of the GridWorksheet class are listed below. For a complete list of GridWorksheet class members, see the GridWorksheet Members topic.

Public Instance Methods

AddAutoFilter | Sets the range to which the specified AutoFilter applies.
AddCustomFilter | Add custom filter for the specified row.
ApplyStyleSheetSkin (inherited from Control) |
AutoFitColumn | Overloaded. Autofits the column width.
CalculateFormula | Calculates a formula.
CancelNewBindRow | Cancels and deletes the new added bind row.
ClearComments | Clears all comments in designer spreadsheet.
CommitNewBindRow | Commits the new added bind row and add it to the datasource.
Copy | Copies contents and formats from another worksheet.
CreateAutoGenratedColumns | After setting a datasource for the worksheet, call this method to generate the bind columns automatically.
CreateNewBindRow | Creates a new bind row and bind to the datasource.
CreateSubtotal | Overloaded. Creates subtotal in the sheet.
DataBind | Bind the sheet to the DataSource.
DataSourceControlUpdate | Bind the sheet to the DataSource.
DeleteBindRow | Deletes a bind row.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FilterString | Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc
FindControl (inherited from Control) |
Focus (inherited from Control) |
FreezePanes | Overloaded. Freezes panes at the specified cell in the worksheet.
GetColumnCaption | Gets the column caption. If the caption is not set, returns empty string.
GetColumnHeaderToolTip | Gets the columnheader's tooltip text.
GetColumnReadonly | Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetFreezedPanes |
GetHashCode (inherited from Object) |
GetIsReadonly | Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
GetRowCaption | Gets the row caption. If the caption is not set, returns empty string.
GetRowHeaderToolTip | Gets the rowheader's tooltip text.
GetRowReadonly | Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetType (inherited from Object) |
GroupRows | Groups rows.
HasControls (inherited from Control) |
IsProtected | Indicates if the worksheet is protected.
MoveTo | Moves the sheet to another location in the spreadsheet.
RefreshFilter | Refresh auto filters to hide or unhide the rows.
RemoveAutoFilter | Remove the auto filter of the worksheet.
RemoveSubtotal | Removes subtotal created by the CreateSubtotal method in the sheet.
RenderControl (inherited from Control) |
ResetFilter | The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAllCellsEditable | Makes all cells editable.this is extended attribute
SetAllCellsReadonly | Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect
SetColumnCaption | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetColumnHeaderToolTip | Sets the columnheader's tooltip text.
SetColumnReadonly | Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetEditableRange | Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable
SetIsReadonly | Sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
SetProtect | Protects worksheet.
SetReadonlyRange | Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly
SetRenderMethodDelegate (inherited from Control) |
SetRowCaption | Sets the caption for the row.
SetRowHeaderToolTip | Sets the rowheader's tooltip text.
SetRowReadonly | Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
ToString (inherited from Object) |
UnFreezePanes | Unfreezes panes in the worksheet.
UnGroupRows | Ungroups rows.
UnProtect | unProtects worksheet.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.AddAutoFilter Method

Sets the range to which the specified AutoFilter applies.

public void AddAutoFilter(
int row,
int startColumn,
int endColumn
);

Parameters

row
Row index.
startColumn
Start column index.
endColumn
End column Index.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.AddCustomFilter Method

Add custom filter for the specified row.

public void AddCustomFilter(
int row,
string critira
);

Remarks

The filter criteria string. notice we use , and ; as split char,so the cell value shall not contains with those split char below are the criteria string examples //column 0 with value 12.3 CELL0 = 12.3 //column 1 with value ABC CELL1 = ABC //column 0 with value 123 or 456 or ABC and column 1 with value ABC CELL0 = 123,456,ABC; CELL1 = ABC

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


AutoFitColumn Method

Aspose.Cells for .NET

GridWorksheet.AutoFitColumn Method

Autofits the column width.

Overload List

Autofits the column width.

public void AutoFitColumn(int);

Autofits the column width.

public void AutoFitColumn(int,int,int);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.AutoFitColumn Method (Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheet.AutoFitColumn Overload List


GridWorksheet.AutoFitColumn Method (Int32, Int32, Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex,
int firstRow,
int lastRow
);

Parameters

columnIndex
Column index.
firstRow
First row index.
lastRow
Last row index.

Remarks

This method autofits a row based on content in a range of cells within the row.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheet.AutoFitColumn Overload List


GridWorksheet.CalculateFormula Method

Calculates a formula.

public object CalculateFormula(
string formula
);

Parameters

formula

Return Value

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.CancelNewBindRow Method

Cancels and deletes the new added bind row.

public int CancelNewBindRow();

Return Value

The row index. If there is no new created bind row, returns -1.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.ClearComments Method

Clears all comments in designer spreadsheet.

public void ClearComments();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.CommitNewBindRow Method

Commits the new added bind row and add it to the datasource.

public int CommitNewBindRow();

Return Value

The row index of the new row. If no row is created, returns -1.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.Copy Method

Copies contents and formats from another worksheet.

public void Copy(
GridWorksheet sourceSheet
);

Parameters

sourceSheet
Source worksheet.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.CreateAutoGenratedColumns Method

After setting a datasource for the worksheet, call this method to generate the bind columns automatically.

public void CreateAutoGenratedColumns();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.CreateNewBindRow Method

Creates a new bind row and bind to the datasource.

public int CreateNewBindRow();

Return Value

The row index of the new row. If no row is created, returns -1.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


CreateSubtotal Method

Aspose.Cells for .NET

GridWorksheet.CreateSubtotal Method

Creates subtotal in the sheet.

Overload List

Creates subtotal in the sheet.

public void CreateSubtotal(int,int,int,SubtotalFunction,int[]);

Creates subtotal in the sheet.

public void CreateSubtotal(int,int,int,SubtotalFunction,int[],string,GridTableItemStyle,GridTableItemStyle,NumberType,string);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.CreateSubtotal Method (Int32, Int32, Int32, SubtotalFunction, Int32[])

Creates subtotal in the sheet.

public void CreateSubtotal(
int columnNameRowIndex,
int dataRows,
int groupByColumnIndex,
SubtotalFunction subtotalFunction,
int[] subtotalColumnIndexList
);

Parameters

columnNameRowIndex
The row index of the column name row.
dataRows
The number of the data rows.
groupByColumnIndex
The column index of the column to be grouped.
subtotalFunction
The subtotal function type.
subtotalColumnIndexList
The column indexes to be subtotaled.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheet.CreateSubtotal Overload List


GridWorksheet.CreateSubtotal Method (Int32, Int32, Int32, SubtotalFunction, Int32[], String, GridTableItemStyle, GridTableItemStyle, NumberType, String)

Creates subtotal in the sheet.

public void CreateSubtotal(
int columnNameRowIndex,
int dataRows,
int groupByColumnIndex,
SubtotalFunction subtotalFunction,
int[] subtotalColumnIndexList,
string functionLabel,
GridTableItemStyle grandCellStyle,
GridTableItemStyle subtotalCellStyle,
NumberType numberType,
string customString
);

Parameters

columnNameRowIndex
The row index of the column name row.
dataRows
The number of the data rows.
groupByColumnIndex
The column index of the column to be grouped.
subtotalFunction
The subtotal function type.
subtotalColumnIndexList
The column indexes to be subtotaled.
functionLabel
The label of subtotal function.
grandCellStyle
The style of the grand total line.
subtotalCellStyle
The style of the subtotal line.
numberType
The number type of the subtotal result cells.
customString
The custome format string of the subtotal result cells. Can be null.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheet.CreateSubtotal Overload List


GridWorksheet.DataBind Method

Bind the sheet to the DataSource.

public override void DataBind();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.DataSourceControlUpdate Method

Bind the sheet to the DataSource.

public void DataSourceControlUpdate(
AccessDataSource AccessDataSource1
);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.DeleteBindRow Method

Deletes a bind row.

public int DeleteBindRow(
int rowNum
);

Parameters

rowNum
The row index.

Return Value

The deleted row index. If no bind row is deleted, returns -1.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.FilterString Method

Sets the filter for the column.notice we shall call AddAutoFilter before calling of filterString The filter criteria string. notice we use comma->"," as split char,so the cell value you want to filter shall not contains with comma filterString(10,"123,456") means column 10 shall contain 123 or 456, filterString(10,"123") means column10 shall contain 123 value split with comma,eg. 123,456,789 or abc

public void FilterString(
int column,
string criteria
);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


FreezePanes Method

Aspose.Cells for .NET

GridWorksheet.FreezePanes Method

Freezes panes at the specified cell in the worksheet.

Overload List

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(int,int,int,int);

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(string,int,int);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.FreezePanes Method (Int32, Int32, Int32, Int32)

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(
int row,
int column,
int freezedRows,
int freezedColumns
);

Parameters

row
Row index.
column
Column index.
freezedRows
Number of visible rows in top pane, no more than row index.
freezedColumns
Number of visible columns in left pane, no more than column index.

Remarks

Row index and column index cannot all be zero. Number of rows and number of columns also cannot all be zero.

The first two parameters specify the freezed position and the last two parameters specify the area freezed on the left top pane.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheet.FreezePanes Overload List


GridWorksheet.FreezePanes Method (String, Int32, Int32)

Freezes panes at the specified cell in the worksheet.

public void FreezePanes(
string cellName,
int freezedRows,
int freezedColumns
);

Parameters

cellName
Cell name.
freezedRows
Number of visible rows in top pane, no more than row index.
freezedColumns
Number of visible columns in left pane, no more than column index.

Remarks

Row index and column index cannot all be zero. Number of rows and number of columns also cannot all be zero.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheet.FreezePanes Overload List


GridWorksheet.GetColumnCaption Method

Gets the column caption. If the caption is not set, returns empty string.

public string GetColumnCaption(
int column
);

Parameters

column
Column index.

Return Value

The column caption. If the caption is not set, returns empty string.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetColumnHeaderToolTip Method

Gets the columnheader's tooltip text.

public string GetColumnHeaderToolTip(
int colIndex
);

Parameters

colIndex
The column's index.

Return Value

The tooltip text.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetColumnReadonly Method

Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public bool GetColumnReadonly(
int columnIndex
);

Parameters

columnIndex
column index.

Return Value

If readonly returns true.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetFreezedPanes Method

public bool GetFreezedPanes(
out int row,
out int column,
out int freezedRows,
out int freezedColumns
);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetIsReadonly Method

Gets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file

public bool GetIsReadonly(
GridCell cell
);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetRowCaption Method

Gets the row caption. If the caption is not set, returns empty string.

public string GetRowCaption(
int row
);

Parameters

row
Row index.

Return Value

The row caption. If the caption is not set, returns empty string.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetRowHeaderToolTip Method

Gets the rowheader's tooltip text.

public string GetRowHeaderToolTip(
int rowIndex
);

Parameters

rowIndex
The row's index.

Return Value

The tooltip text.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GetRowReadonly Method

Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public bool GetRowReadonly(
int rowIndex
);

Parameters

rowIndex
row index.

Return Value

If readonly returns true.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.GroupRows Method

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex,
bool isHidden
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.
isHidden
Specifies if the grouped rows are hidden.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.IsProtected Method

Indicates if the worksheet is protected.

public bool IsProtected();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.MoveTo Method

Moves the sheet to another location in the spreadsheet.

public void MoveTo(
int index
);

Parameters

index
Destination sheet index.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.RefreshFilter Method

Refresh auto filters to hide or unhide the rows.

public void RefreshFilter();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.RemoveAutoFilter Method

Remove the auto filter of the worksheet.

public void RemoveAutoFilter();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.RemoveSubtotal Method

Removes subtotal created by the CreateSubtotal method in the sheet.

public void RemoveSubtotal();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.ResetFilter Method

The integer offset of the field on which you want to apply ,based on the first filter column (from the left of the list; the leftmost field is field 0).

public void ResetFilter(
int fieldIndex
);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetAllCellsEditable Method

Makes all cells editable.this is extended attribute

public void SetAllCellsEditable();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetAllCellsReadonly Method

Makes all cells readonly.this is extended attribute notice this attribute can not keep in actual cell,if you want to keep protect please use setProtect

public void SetAllCellsReadonly();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetColumnCaption Method

Sets the caption for the column.please note this is an extension attribute and can not keep in excel file

public void SetColumnCaption(
int column,
string caption
);

Parameters

column
Column index.
caption
The column caption. Pass null or empty string if you want cancel the caption.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetColumnHeaderToolTip Method

Sets the columnheader's tooltip text.

public void SetColumnHeaderToolTip(
int colIndex,
string toolTip
);

Parameters

colIndex
The column's index.
toolTip
The tooltip text.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetColumnReadonly Method

Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public void SetColumnReadonly(
int columnIndex,
bool isReadonly
);

Parameters

columnIndex
column index.
isReadonly
true or false.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetEditableRange Method

Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable

public void SetEditableRange(
int startRow,
int startColumn,
int rows,
int columns
);

Parameters

startRow
The start row of the range.
startColumn
The start column of the range.
rows
The number of the rows.
columns
The number of the columns.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetIsReadonly Method

Sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file

public void SetIsReadonly(
GridCell cell,
bool value
);

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetProtect Method

Protects worksheet.

public void SetProtect();

Remarks

This method protects worksheet without password. It can protect worksheet in all versions of Excel file.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetReadonlyRange Method

Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly

public void SetReadonlyRange(
int startRow,
int startColumn,
int rows,
int columns
);

Parameters

startRow
The start row of the range.
startColumn
The start column of the range.
rows
The number of the rows.
columns
The number of the columns.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetRowCaption Method

Sets the caption for the row.

public void SetRowCaption(
int row,
string caption
);

Parameters

row
Row index.
caption
The row caption. Pass null or empty string if you want cancel the caption.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetRowHeaderToolTip Method

Sets the rowheader's tooltip text.

public void SetRowHeaderToolTip(
int rowIndex,
string toolTip
);

Parameters

rowIndex
The row's index.
toolTip
The tooltip text.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.SetRowReadonly Method

Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public void SetRowReadonly(
int rowIndex,
bool isReadonly
);

Parameters

rowIndex
row index.
isReadonly
true or false.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.UnFreezePanes Method

Unfreezes panes in the worksheet.

public void UnFreezePanes();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.UnGroupRows Method

Ungroups rows.

public void UnGroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be ungrouped.
lastIndex
The last row index to be ungrouped.

Remarks

Only removes outter group info.

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.UnProtect Method

unProtects worksheet.

public void UnProtect();

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet Events

The events of the GridWorksheet class are listed below. For a complete list of GridWorksheet class members, see the GridWorksheet Members topic.

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
InitializeNewBindRow | Occurs when the worksheet has created a new bind row and need to initialize it.
Load (inherited from Control) |
PreRender (inherited from Control) |
Unload (inherited from Control) |

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheet.InitializeNewBindRow Event

Occurs when the worksheet has created a new bind row and need to initialize it.

public event InitializeNewBindRowHandler InitializeNewBindRow;

See Also

GridWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection Class

Collects the objects that represent the individual rows in a worksheet.

For a list of all members of this type, see GridWorksheetCollection Members.

System.Object
Aspose.Cells.GridWeb.Data.GridWorksheetCollection

public class GridWorksheetCollection : ICollection, IEnumerable, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

GridWorksheetCollection Members | Aspose.Cells.GridWeb.Data Namespace | Row


GridWorksheetCollection Members

GridWorksheetCollection overview

Public Instance Properties

ActiveSheetIndex |
Count |
DefaultFontName | Gets or sets the control's default font name.
DefaultFontSize | Gets or sets the control's default font size.
IsSynchronized | Gets a value indicating if access to the ICollection is synchronized (thread-safe).
Item | Overloaded. Gets the Worksheet element at the specified index.
Names | Gets the collection of all the Name objects in the spreadsheet.
NumberDecimalSeparator | Gets or sets the decimal separator for formatting/parsing numeric values. Default is the decimal separator of current Region.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
CalculateFormula | Calculates the result of formulas.
Clear | Clear all worksheets.
CopyTo | Copys contents to an array.
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ImportDataView | Overloaded. Imports from a DataView. Creates a sheet with the DataView's table name automatically.
Insert |
RemoveAt | Overloaded. Removes the element at a specified index.
SetVisible | Sets the visible options.
SwapSheet | Swaps the two sheets.
ToString (inherited from Object) |

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | Row


GridWorksheetCollection Properties

The properties of the GridWorksheetCollection class are listed below. For a complete list of GridWorksheetCollection class members, see the GridWorksheetCollection Members topic.

Public Instance Properties

ActiveSheetIndex |
Count |
DefaultFontName | Gets or sets the control's default font name.
DefaultFontSize | Gets or sets the control's default font size.
IsSynchronized | Gets a value indicating if access to the ICollection is synchronized (thread-safe).
Item | Overloaded. Gets the Worksheet element at the specified index.
Names | Gets the collection of all the Name objects in the spreadsheet.
NumberDecimalSeparator | Gets or sets the decimal separator for formatting/parsing numeric values. Default is the decimal separator of current Region.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | Row


ActiveSheetIndex Property

Aspose.Cells for .NET

GridWorksheetCollection.ActiveSheetIndex Property

public int ActiveSheetIndex {get; set;}

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

GridWorksheetCollection.Count Property

public int Count {get;}

Implements

ICollection.Count

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


DefaultFontName Property

Aspose.Cells for .NET

GridWorksheetCollection.DefaultFontName Property

Gets or sets the control's default font name.

public string DefaultFontName {get; set;}

Example

[C#]
        GridWeb1.DefaultFontName = "Arial";

    [Visual Basic]
        GridWeb1.DefaultFontName = "Arial"

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


DefaultFontSize Property

Aspose.Cells for .NET

GridWorksheetCollection.DefaultFontSize Property

Gets or sets the control's default font size.

public FontUnit DefaultFontSize {get; set;}

Example

[C#]
        GridWeb1.DefaultFontSize = new System.Web.UI.WebControls.FontUnit("10pt");

    [Visual Basic]
        GridWeb1.DefaultFontSize = New System.Web.UI.WebControls.FontUnit("10pt")

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


IsSynchronized Property

Aspose.Cells for .NET

GridWorksheetCollection.IsSynchronized Property

Gets a value indicating if access to the ICollection is synchronized (thread-safe).

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

GridWorksheetCollection.Item Property

Gets the Worksheet element at the specified index.

Overload List

Gets the Worksheet element at the specified index.

public GridWorksheet this[int] {get;}

Gets the Worksheet element with the specified name.

public GridWorksheet this[string] {get;}

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

GridWorksheetCollection.Item Property (Int32)

Gets the Worksheet element at the specified index.

public GridWorksheet this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

GridWorksheetCollection.Item Property (String)

Gets the Worksheet element with the specified name.

public GridWorksheet this[
string sheetName
] {get;}

Parameters

sheetName
The name of the worksheet.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.Item Overload List


Names Property

Aspose.Cells for .NET

GridWorksheetCollection.Names Property

Gets the collection of all the Name objects in the spreadsheet.

public GridNameCollection Names {get;}

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


NumberDecimalSeparator Property

Aspose.Cells for .NET

GridWorksheetCollection.NumberDecimalSeparator Property

Gets or sets the decimal separator for formatting/parsing numeric values. Default is the decimal separator of current Region.

public char NumberDecimalSeparator {get; set;}

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


SyncRoot Property

Aspose.Cells for .NET

GridWorksheetCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the ICollection.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection Methods

The methods of the GridWorksheetCollection class are listed below. For a complete list of GridWorksheetCollection class members, see the GridWorksheetCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
CalculateFormula | Calculates the result of formulas.
Clear | Clear all worksheets.
CopyTo | Copys contents to an array.
Equals (inherited from Object) |
GetEnumerator | Gets the rows enumerator
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ImportDataView | Overloaded. Imports from a DataView. Creates a sheet with the DataView's table name automatically.
Insert |
RemoveAt | Overloaded. Removes the element at a specified index.
SetVisible | Sets the visible options.
SwapSheet | Swaps the two sheets.
ToString (inherited from Object) |

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | Row


Add Method

Aspose.Cells for .NET

GridWorksheetCollection.Add Method

Adds a worksheet to the collection.

Overload List

Adds a worksheet to the collection.

public int Add();

Adds a sheet object.

public int Add(object);

Adds a worksheet to the collection.

public GridWorksheet Add(string);

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.Add Method ()

Adds a worksheet to the collection.

public int Add();

Return Value

Worksheet object index.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.Add Overload List


GridWorksheetCollection.Add Method (Object)

Adds a sheet object.

public int Add(
object value
);

Parameters

value
The sheet.

Return Value

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.Add Overload List


GridWorksheetCollection.Add Method (String)

Adds a worksheet to the collection.

public GridWorksheet Add(
string sheetName
);

Parameters

sheetName
Worksheet name

Return Value

Worksheet object.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.Add Overload List


AddCopy Method

Aspose.Cells for .NET

GridWorksheetCollection.AddCopy Method

Adds a worksheet to the collection and copies data from an existed worksheet.

Overload List

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(int);

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(string);

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.AddCopy Method (Int32)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
int sheetIndex
);

Parameters

sheetIndex
Index of source worksheet.

Return Value

Worksheet object index.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.AddCopy Overload List


GridWorksheetCollection.AddCopy Method (String)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
string sheetName
);

Parameters

sheetName
Name of source worksheet.

Return Value

Worksheet object index.

Exceptions

Exception Type | Condition
CellsException | Specifies an invalid worksheet name.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.AddCopy Overload List


GridWorksheetCollection.CalculateFormula Method

Calculates the result of formulas.

public void CalculateFormula();

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.Clear Method

Clear all worksheets.

public void Clear();

Remarks

A workbook must contains a worksheet.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.CopyTo Method

Copys contents to an array.

public void CopyTo(
Array array,
int index
);

Parameters

array
An array.
index
Index of the array.

Implements

ICollection.CopyTo

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.GetEnumerator Method

Gets the rows enumerator

public IEnumerator GetEnumerator();

Return Value

The rows enumerator

Implements

IEnumerable.GetEnumerator

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


ImportDataView Method

Aspose.Cells for .NET

GridWorksheetCollection.ImportDataView Method

Imports from a DataView. Creates a sheet with the DataView's table name automatically.

Overload List

Imports from a DataView. Creates a sheet with the DataView's table name automatically.

public void ImportDataView(DataView,TableItemStyle,TableItemStyle);

Imports from a DataView to the specified sheet and position.

public void ImportDataView(DataView,TableItemStyle,TableItemStyle,string,int,int);

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.ImportDataView Method (DataView, TableItemStyle, TableItemStyle)

Imports from a DataView. Creates a sheet with the DataView's table name automatically.

public void ImportDataView(
DataView dataView,
TableItemStyle colHeaderStyle,
TableItemStyle dataStyle
);

Parameters

dataView
The DataView object.
colHeaderStyle
Specifies the style of the dataview header bar.
dataStyle
Specifies the style of the data area.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.ImportDataView Overload List


GridWorksheetCollection.ImportDataView Method (DataView, TableItemStyle, TableItemStyle, String, Int32, Int32)

Imports from a DataView to the specified sheet and position.

public void ImportDataView(
DataView dataView,
TableItemStyle colHeaderStyle,
TableItemStyle dataStyle,
string sheetName,
int row,
int column
);

Parameters

dataView
The DataView object.
colHeaderStyle
Specifies the style of the dataview header bar.
dataStyle
Specifies the style of the data area.
sheetName
Specifies the sheet name. If the sheet doesn't exist, it will be created for you.
row
Specifies the import position.
column
Specifies the import postion.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.ImportDataView Overload List


GridWorksheetCollection.Insert Method

public GridWorksheet Insert(
int index,
string sheetName
);

Parameters

index
sheetName
The sheet name.

Return Value

Returns an inserted worksheet.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


RemoveAt Method

Aspose.Cells for .NET

GridWorksheetCollection.RemoveAt Method

Removes the element at a specified index.

Overload List

Removes the element at a specified index.

public void RemoveAt(int);

Removes the element at a specified name.

public void RemoveAt(string);

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.RemoveAt Method (Int32)

Removes the element at a specified index.

public void RemoveAt(
int index
);

Parameters

index
The index value of the element to remove.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.RemoveAt Overload List


GridWorksheetCollection.RemoveAt Method (String)

Removes the element at a specified name.

public void RemoveAt(
string name
);

Parameters

name
The name of the element to remove.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace | GridWorksheetCollection.RemoveAt Overload List


GridWorksheetCollection.SetVisible Method

Sets the visible options.

public void SetVisible(
string name,
bool v
);

Parameters

name
v

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


GridWorksheetCollection.SwapSheet Method

Swaps the two sheets.

public void SwapSheet(
int sheetIndex1,
int sheetIndex2
);

Parameters

sheetIndex1
The first worksheet.
sheetIndex2
The second worksheet.

See Also

GridWorksheetCollection Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlink Class

NOTE: This class is now obsolete.

This class is obsolete; use GridHyperlink instead

For a list of all members of this type, see Hyperlink Members.

System.Object
Aspose.Cells.GridWeb.Data.Hyperlink
Aspose.Cells.GridWeb.Data.CellImage

public class Hyperlink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Hyperlink Members | Aspose.Cells.GridWeb.Data Namespace


Hyperlink Members

Hyperlink overview

Public Instance Properties

ActionType | Gets or sets the hyperlink's action type. It may be ActionTpye.UrlLink or ActionType.CellCommand. The UrlLink Type means that the hyperlink is a link to a web page or a mail receipt. For example: "http://www.aspose.com" or "mailto:admin@aspose.com". The CellCommand Type means that the hyperlink will fire a CellCommand event, and you may handle this event.
Area | Gets the range of hyperlink.
CellCommand | Gets or sets the Cell Command name.
DiscardInput | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageUrl | Gets or sets the hyperlink's image url. If sets to null or empty string, the hyperlink will only display it's text.
Target |
Text | Gets or sets the displayed text of the hyperlink.
ToolTip | Gets or sets the tooltip of the hyperlink.
Url | Gets or sets the URL string.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlink Properties

The properties of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Instance Properties

ActionType | Gets or sets the hyperlink's action type. It may be ActionTpye.UrlLink or ActionType.CellCommand. The UrlLink Type means that the hyperlink is a link to a web page or a mail receipt. For example: "http://www.aspose.com" or "mailto:admin@aspose.com". The CellCommand Type means that the hyperlink will fire a CellCommand event, and you may handle this event.
Area | Gets the range of hyperlink.
CellCommand | Gets or sets the Cell Command name.
DiscardInput | Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.
ImageUrl | Gets or sets the hyperlink's image url. If sets to null or empty string, the hyperlink will only display it's text.
Target |
Text | Gets or sets the displayed text of the hyperlink.
ToolTip | Gets or sets the tooltip of the hyperlink.
Url | Gets or sets the URL string.

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


ActionType Property

Aspose.Cells for .NET

Hyperlink.ActionType Property

Gets or sets the hyperlink's action type. It may be ActionTpye.UrlLink or ActionType.CellCommand. The UrlLink Type means that the hyperlink is a link to a web page or a mail receipt. For example: "http://www.aspose.com" or "mailto:admin@aspose.com". The CellCommand Type means that the hyperlink will fire a CellCommand event, and you may handle this event.

public virtual HyperlinkActionType ActionType {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Area Property

Aspose.Cells for .NET

Hyperlink.Area Property

Gets the range of hyperlink.

public GridCellArea Area {get;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


CellCommand Property

Aspose.Cells for .NET

Hyperlink.CellCommand Property

Gets or sets the Cell Command name.

public string CellCommand {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


DiscardInput Property

Aspose.Cells for .NET

Hyperlink.DiscardInput Property

Indicates whether to discard user input at client browser when user click this CellCommand hyperlink. Could be used as an "undo" action.

public virtual bool DiscardInput {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


ImageUrl Property

Aspose.Cells for .NET

Hyperlink.ImageUrl Property

Gets or sets the hyperlink's image url. If sets to null or empty string, the hyperlink will only display it's text.

public virtual string ImageUrl {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Target Property

Aspose.Cells for .NET

Hyperlink.Target Property

public string Target {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Text Property

Aspose.Cells for .NET

Hyperlink.Text Property

Gets or sets the displayed text of the hyperlink.

public virtual string Text {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


ToolTip Property

Aspose.Cells for .NET

Hyperlink.ToolTip Property

Gets or sets the tooltip of the hyperlink.

public virtual string ToolTip {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


Url Property

Aspose.Cells for .NET

Hyperlink.Url Property

Gets or sets the URL string.

public virtual string Url {get; set;}

See Also

Hyperlink Class | Aspose.Cells.GridWeb.Data Namespace


HyperlinkActionType Enumeration

Hyperlink has two action type: UrlLink and CellCommand. UrlLink type hyperlink is an anchor in a cell, click it will navigate to another page or open a new browser window. CellCommand type hyperlink is an command button in a cell, click it will generate a server side event.

public enum HyperlinkActionType

Remarks

NOTE: This class is now obsolete. please use GridHyperlink Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Members

Member Name | Description | Value
UrlLink | Url link. An anchor in a cell. | 0
CellCommand | Cell command button. | 1
SimpleImage | just simple image | 2

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


Hyperlinks Class

NOTE: This class is now obsolete.

This class is obsolete; use GridHyperlinkCollection instead

For a list of all members of this type, see Hyperlinks Members.

System.Object
Aspose.Cells.GridWeb.Data.Hyperlinks

public class Hyperlinks

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridHyperlinkCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Hyperlinks Members | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks Members

Hyperlinks overview

Public Instance Methods

AddCellImage |
AddHyperlink | Overloaded.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetHyperlink | Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.
GetType (inherited from Object) |
RemoveHyperlink |
ToString (inherited from Object) |

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks Methods

The methods of the Hyperlinks class are listed below. For a complete list of Hyperlinks class members, see the Hyperlinks Members topic.

Public Instance Methods

AddCellImage |
AddHyperlink | Overloaded.
Clear | Clears all hyperlinks.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetHyperlink | Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.
GetType (inherited from Object) |
RemoveHyperlink |
ToString (inherited from Object) |

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks.AddCellImage Method

public CellImage AddCellImage(
string cellName
);

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


AddHyperlink Method

Aspose.Cells for .NET

Hyperlinks.AddHyperlink Method

Overload List

public Hyperlink AddHyperlink(GridCell);

public Hyperlink AddHyperlink(string);

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks.AddHyperlink Method (GridCell)

public Hyperlink AddHyperlink(
GridCell cell
);

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace | Hyperlinks.AddHyperlink Overload List


Hyperlinks.AddHyperlink Method (String)

public Hyperlink AddHyperlink(
string cellName
);

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace | Hyperlinks.AddHyperlink Overload List


Hyperlinks.Clear Method

Clears all hyperlinks.

public void Clear();

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks.GetHyperlink Method

Gets the cell's Hyperlink object. If there is no Hyperlink of the cell, returns null.

public Hyperlink GetHyperlink(
WebCell cell
);

Parameters

cell
The cell object.

Return Value

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks.RemoveHyperlink Method

public void RemoveHyperlink(
GridCell cell
);

See Also

Hyperlinks Class | Aspose.Cells.GridWeb.Data Namespace


ICustomFilter Interface

Summary description for ICustomFilter.

For a list of all members of this type, see ICustomFilter Members.

public interface ICustomFilter

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

ICustomFilter Members | Aspose.Cells.GridWeb.Data Namespace


ICustomFilter Members

ICustomFilter overview

Public Instance Methods

FilterRows | Filters data by specified column and filter index.
GetFilterValueList | Provides a value list to the specified column for filtering.

See Also

ICustomFilter Interface | Aspose.Cells.GridWeb.Data Namespace


ICustomFilter Methods

The methods of the ICustomFilter interface are listed below. For a complete list of ICustomFilter interface members, see the ICustomFilter Members topic.

Public Instance Methods

FilterRows | Filters data by specified column and filter index.
GetFilterValueList | Provides a value list to the specified column for filtering.

See Also

ICustomFilter Interface | Aspose.Cells.GridWeb.Data Namespace


ICustomFilter.FilterRows Method

Filters data by specified column and filter index.

void FilterRows(
WebWorksheet sheet,
int columnIndex,
int filterIndex
);

Parameters

sheet
WebWorksheet object.
columnIndex
Column index.
filterIndex
Filter index.

See Also

ICustomFilter Interface | Aspose.Cells.GridWeb.Data Namespace


ICustomFilter.GetFilterValueList Method

Provides a value list to the specified column for filtering.

IDictionary GetFilterValueList(
WebWorksheet sheet,
int columnIndex
);

Parameters

sheet
WebWorksheet object.
columnIndex
Column index.

Return Value

See Also

ICustomFilter Interface | Aspose.Cells.GridWeb.Data Namespace


InitializeNewBindRowHandler Delegate

Represents the method that intend to handle InitializeNewBindRow event. sender: The worksheet object. bindObject: The new created bind object. Generally it's a DataRowView object.

public delegate void InitializeNewBindRowHandler(
GridWorksheet sender,
object bindObject
);

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


NumberType Enumeration

Represents the number or datetime format type.

public enum NumberType

Members

Member Name | Description | Value
General | General | 0
Decimal1 | Decimal 0 | 1
Decimal2 | Decimal 0.00 | 2
Decimal3 | Decimal #,##0 | 3
Decimal4 | Decimal #,##0.00 | 4
Currency1 | Currency $#,##0;$-#,##0 | 5
Currency2 | Currency $#,##0;[Red]$-#,##0 | 6
Currency3 | Currency $#,##0.00;$-#,##0.00 | 7
Currency4 | Currency $#,##0.00;[Red]$-#,##0.00 | 8
Percentage1 | Percentage 0% | 9
Percentage2 | Percentage 0.00% | 10
Scientific1 | Scientific 0.00E+00 | 11
Fraction1 | Fraction # ?/? | 12
Fraction2 | Fraction # ??/?? | 13
Date1 | Date m/d/yyyy | 14
Date2 | Date d-mmm-yy | 15
Date3 | Date d-mmm | 16
Date4 | Date mmm-yy | 17
Time1 | Time h:mm AM/PM | 18
Time2 | Time h:mm:ss AM/PM | 19
Time3 | Time h:mm | 20
Time4 | Time h:mm:ss | 21
Time5 | Time m/d/yy h:mm | 22
Currency5 | Currency #,##0;-#,##0 | 37
Currency6 | Currency #,##0;[Red]-#,##0 | 38
Currency7 | Currency #,##0.00;-#,##0.00 | 39
Currency8 | Currency #,##0.00;[Red]-#,##0.00 | 40
Accounting1 | Accounting _ * #,##0_ ;_ * -#,##0_ ;_ * "-"_ ;_ @_ | 41
Accounting2 | Accounting _ $* #,##0_ ;_ $* -#,##0_ ;_ $* "-"_ ;_ @_ | 42
Accounting3 | Accounting _ * #,##0.00_ ;_ * -#,##0.00_ ;_ * "-"??_ ;_ @_ | 43
Accounting4 | Accounting _ $* #,##0.00_ ;_ $* -#,##0.00_ ;_ $* "-"??_ ;_ @_ | 44
Time6 | Time mm:ss | 45
Time7 | Time [h]:mm:ss | 46
Time8 | Time mm:ss.0 | 47
Scientific2 | Scientific ##0.0E+00 | 48
Text | Text @ | 49
Currency9 | Currency $#,##0;($#,##0) | 23
Currency10 | Currency $#,##0;[Red]($#,##0) | 24
Currency11 | Currency $#,##0.00;($#,##0.00) | 25
Currency12 | Currency $#,##0.00;[Red]($#,##0.00) | 26
EasternDate1 | Date YYYY?M? | 27
EasternDate2 | Date M?D? | 28
EasternDate3 | Date M?D? | 29
EasternDate4 | Date M/D/YY | 30
EasternDate5 | Date YYYY?M?D? | 31
EasternDate6 | Date YYYY?M? | 36
EasternDate7 | Date YYYY?M? | 50
EasternDate8 | Date M?D? | 51
EasternDate9 | Date YYYY?M? | 52
EasternDate10 | Date M?D? | 53
EasternDate11 | Date M?D? | 54
EasternDate12 | Date YYYY?M? | 57
EasternDate13 | Date M?D? | 58
EasternTime1 | Time h?mm? | 32
EasternTime2 | Time h?mm?ss? | 33
EasternTime3 | Time tth?mm? | 34
EasternTime4 | Time tth?mm?ss? | 35
EasternTime5 | Time tth?mm? | 55
EasternTime6 | Time tth?mm?ss? | 56

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


OnErrorActionQuery Class

Used in the CellError event of the GridWeb.

For a list of all members of this type, see OnErrorActionQuery Members.

System.Object
Aspose.Cells.GridWeb.Data.OnErrorActionQuery

public class OnErrorActionQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
onErrorActionQuery.OnErrorAction = OnErrorActionType.Ignore;
[VB]
onErrorActionQuery.OnErrorAction = OnErrorActionType.Ignore

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

OnErrorActionQuery Members | Aspose.Cells.GridWeb.Data Namespace


OnErrorActionQuery Members

OnErrorActionQuery overview

Public Instance Constructors

OnErrorActionQuery Constructor Initializes a new instance of the OnErrorActionQuery class.

Public Instance Properties

OnErrorAction Gets or set the action type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

OnErrorActionQuery Class | Aspose.Cells.GridWeb.Data Namespace


OnErrorActionQuery Constructor

Initializes a new instance of the OnErrorActionQuery class.

public OnErrorActionQuery();

See Also

OnErrorActionQuery Class | Aspose.Cells.GridWeb.Data Namespace


OnErrorActionQuery Properties

The properties of the OnErrorActionQuery class are listed below. For a complete list of OnErrorActionQuery class members, see the OnErrorActionQuery Members topic.

Public Instance Properties

OnErrorAction Gets or set the action type.

See Also

OnErrorActionQuery Class | Aspose.Cells.GridWeb.Data Namespace


OnErrorAction Property

Aspose.Cells for .NET

OnErrorActionQuery.OnErrorAction Property

Gets or set the action type.

public OnErrorActionType OnErrorAction {get; set;}

See Also

OnErrorActionQuery Class | Aspose.Cells.GridWeb.Data Namespace


OnErrorActionType Enumeration

Used in CellError event of the GridWeb. User set the OnErrorActionQuery.OnErrorAction to tell the control Stop processing or Ignore error.

public enum OnErrorActionType

Members

Member Name | Description | Value
Throw | Throws the current exception. | 0
Stop | Stops current processing. | 1
Ignore | Ignores the error and continue processing. | 2

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


PivotCache Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotTable instead

Represents the memory cache for a PivotTable report. The PivotCache object is a member of the PivotCaches collection.

For a list of all members of this type, see PivotCache Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotCache

public class PivotCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotTable Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced. Uses the PivotCache method to return a PivotCache object for a PivotTable report (each report has only one cache). The source data of PivotCache come from WebWorksheet, DataTable, and so on.

Example

[C#]

 //On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 WebWorksheet sourceSheet = GridWeb1.WebWorksheets["Sheet1"];
 Aspose.Cells.GridWeb.Data.WebCellArea sourceRange = new WebCellArea();
 sourceRange.StartRow = 0;
 sourceRange.StartColumn = 0;
 sourceRange.EndRow = 10;
 sourceRange.EndColumn = 5;

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet, sourceRange);

 PivotTable table = cache.CreatePivotTable();

 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[3].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.PivotFields[4].Orientation = PivotFieldOrientation.ColumnField;
 table.PivotFields[5].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;

 table.PivotFields[3].Function = PivotFieldFunction.Count;
 table.PivotFields[5].Function = PivotFieldFunction.Sum;

 table.DataBind();

 //Creates a PivotTable report from DataView or DataTable.
 DataView dataView;//Or  DataTable dataTable;
     .
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataView);
 //Or PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataTable);
 PivotTable table = cache.CreatePivotTable();
 table = GridWeb1.WebWorksheets.PivotTables["PivotTable1"];
 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.DataBind();

 [VB]

 'On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 Dim sourceSheet As WebWorksheet =  GridWeb1.WebWorksheets("Sheet1")
 Dim sourceRange As Aspose.Cells.GridWeb.Data.WebCellArea =  New WebCellArea()/
 sourceRange.StartRow = 0
 sourceRange.StartColumn = 0
 sourceRange.EndRow = 10
 sourceRange.EndColumn = 5

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet,sourceRange)

 Dim table As PivotTable =  cache.CreatePivotTable()

 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(3).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.PivotFields(4).Orientation = PivotFieldOrientation.ColumnField
 table.PivotFields(5).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField

 table.PivotFields(3).Function = PivotFieldFunction.Count
 table.PivotFields(5).Function = PivotFieldFunction.Sum

 table.DataBind()

 'Creates a PivotTable report from DataView or DataTable.

 Dim dataView As DataView ' Or Dim dataTable As DataTable
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataView)
 'Or Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataTable)
 Dim table As PivotTable =  cache.CreatePivotTable()
 table = GridWeb1.WebWorksheets.PivotTables("PivotTable1")
 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.DataBind()

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotCache Members | Aspose.Cells.GridWeb.Data Namespace


PivotCache Members

PivotCache overview

Public Instance Properties

DataTable | Returns the data source of System.Data.DataTable for the PivotTable report.
DataView | Returns the data source of System.Data.DataView for the PivotTable report.
Index | Returns the index of this object in Parent
Name | Returns the name of PivotCache.Re
Parent | Returns the parent object for the specified object(the container of PivotCache). Read-only.
SourceCellArea | Returns the range of the data source using with SourceSheet.
SourceSheet | Returns the data source of WebWorksheet for the PivotTable report.
SourceType | Represents the type of the source data

Public Instance Methods

CreatePivotTable | Overloaded. Creates PivotTable report to a new Sheet.
Equals | Determines whether two Object instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) |
ResetDataSource | Overloaded. Resets the source data
ToString | Returns a String that represents the current Object

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


PivotCache Properties

The properties of the PivotCache class are listed below. For a complete list of PivotCache class members, see the PivotCache Members topic.

Public Instance Properties

DataTable | Returns the data source of System.Data.DataTable for the PivotTable report.
DataView | Returns the data source of System.Data.DataView for the PivotTable report.
Index | Returns the index of this object in Parent
Name | Returns the name of PivotCache.Re
Parent | Returns the parent object for the specified object(the container of PivotCache). Read-only.
SourceCellArea | Returns the range of the data source using with SourceSheet.
SourceSheet | Returns the data source of WebWorksheet for the PivotTable report.
SourceType | Represents the type of the source data

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


DataTable Property

Aspose.Cells for .NET

PivotCache.DataTable Property

Returns the data source of System.Data.DataTable for the PivotTable report.

public DataTable DataTable {get;}

Remarks

DataTable.Columns will be convert to PivotTable fields.

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


DataView Property

Aspose.Cells for .NET

PivotCache.DataView Property

Returns the data source of System.Data.DataView for the PivotTable report.

public DataView DataView {get;}

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


Index Property

Aspose.Cells for .NET

PivotCache.Index Property

Returns the index of this object in Parent

public int Index {get;}

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

PivotCache.Name Property

Returns the name of PivotCache.Re

public string Name {get;}

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


Parent Property

Aspose.Cells for .NET

PivotCache.Parent Property

Returns the parent object for the specified object(the container of PivotCache). Read-only.

public PivotCaches Parent {get;}

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


SourceCellArea Property

Aspose.Cells for .NET

PivotCache.SourceCellArea Property

Returns the range of the data source using with SourceSheet.

public WebCellArea SourceCellArea {get;}

Example

[C#]

 //Changes data source range
 //Original value: StartRow=0;StartColumn=0;EndRow=10;EndColumn=4;
 PivotTable table = GridWeb1.WebWorksheets.PivotTables["myPivotTable"];
 //Adds 2 row data
 table.PivotCache.SourceCellArea.EndRow = 12;

 [VB]

 'Changes data source range
 'Original value: StartRow=0;StartColumn=0;EndRow=10;EndColumn=4;
 Dim table As PivotTable =  GridWeb1.WebWorksheets.PivotTables("myPivotTable")
  'Adds 2 row data
 table.PivotCache.SourceCellArea.EndRow = 12

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


SourceSheet Property

Aspose.Cells for .NET

PivotCache.SourceSheet Property

Returns the data source of WebWorksheet for the PivotTable report.

public WebWorksheet SourceSheet {get;}

Remarks

DataTable.Columns will be convert PivotTable fields.

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


SourceType Property

Aspose.Cells for .NET

PivotCache.SourceType Property

Represents the type of the source data

public PivotSourceType SourceType {get;}

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


PivotCache Methods

The methods of the PivotCache class are listed below. For a complete list of PivotCache class members, see the PivotCache Members topic.

Public Instance Methods

CreatePivotTable | Overloaded. Creates PivotTable report to a new Sheet.
Equals | Determines whether two Object instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) |
ResetDataSource | Overloaded. Resets the source data
ToString | Returns a String that represents the current Object

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


CreatePivotTable Method

Aspose.Cells for .NET

PivotCache.CreatePivotTable Method

Creates PivotTable report to a new Sheet.

Overload List

Creates PivotTable report to a new Sheet.

public PivotTable CreatePivotTable();

Creates PivotTable report to the targetSheet.

public PivotTable CreatePivotTable(WebWorksheet,WebCell);

Creates PivotTable report to the targetSheet.

public PivotTable CreatePivotTable(WebWorksheet,WebCell,string);

Creates PivotTable report to a new Sheet. The name of the pivotTable object

public PivotTable CreatePivotTable(string);

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


PivotCache.CreatePivotTable Method ()

Creates PivotTable report to a new Sheet.

public PivotTable CreatePivotTable();

Return Value

The PivotTable object

Remarks

Calling this method will create a PivotTable object and a new worksheet. Then adds the PivotTable object to the last location of GridWeb.Worksheets.PivotTables. If You call the PivotTable.DataBind() method, the PivotTable report will be painted to the created worksheet.

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.CreatePivotTable Overload List


PivotCache.CreatePivotTable Method (WebWorksheet, WebCell)

Creates PivotTable report to the targetSheet.

public PivotTable CreatePivotTable(
WebWorksheet targetSheet,
WebCell targetCell
);

Parameters

targetSheet
The sheet that the pivotTable report will paint to
targetCell
The start cell that the pivotTable report will paint to

Return Value

The PivotTable object

Remarks

Calling this method will create a PivotTable object Then adds the PivotTable object to the last location of GridWeb.Worksheets.PivotTables. If You call the PivotTable.DataBind() method, the PivotTable report will be painted to the targetSheet starting at the targetCell.

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.CreatePivotTable Overload List


PivotCache.CreatePivotTable Method (WebWorksheet, WebCell, String)

Creates PivotTable report to the targetSheet.

public PivotTable CreatePivotTable(
WebWorksheet targetSheet,
WebCell targetCell,
string tableName
);

Parameters

targetSheet
The sheet that the pivotTable report will paint to
targetCell
The start cell that the pivotTable report will paint to
tableName
The name of the pivotTable object

Return Value

The PivotTable object

Remarks

Calling this method will create a PivotTable object naming tableName Then adds the PivotTable object to the last location of GridWeb.Worksheets.PivotTables. If You call the PivotTable.DataBind() method, the PivotTable report will be painted to the targetSheet starting at the targetCell.

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.CreatePivotTable Overload List


PivotCache.CreatePivotTable Method (String)

Creates PivotTable report to a new Sheet. The name of the pivotTable object

public PivotTable CreatePivotTable(
string tableName
);

Return Value

The PivotTable object

Remarks

Calling this method will create a PivotTable object and a new worksheet. Then adds the PivotTable object to the last location of GridWeb.Worksheets.PivotTables. If You call the PivotTable.DataBind() method, the PivotTable report will be painted to the created worksheet.

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.CreatePivotTable Overload List


PivotCache.Equals Method

Determines whether two Object instances are equal.

public override bool Equals(
object obj
);

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


PivotCache.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


ResetDataSource Method

Aspose.Cells for .NET

PivotCache.ResetDataSource Method

Resets the source data

Overload List

Resets the source data

public void ResetDataSource(WebWorksheet,WebCellArea);

Resets the source data

public void ResetDataSource(DataTable);

Resets the source data

public void ResetDataSource(DataView);

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


PivotCache.ResetDataSource Method (WebWorksheet, WebCellArea)

Resets the source data

public void ResetDataSource(
WebWorksheet sourceSheet,
WebCellArea sourceCellArea
);

Parameters

sourceSheet
The sheet of source dat
sourceCellArea
The range of the sheet

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.ResetDataSource Overload List


PivotCache.ResetDataSource Method (DataTable)

Resets the source data

public void ResetDataSource(
DataTable dataTable
);

Parameters

dataTable
The data source

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.ResetDataSource Overload List


PivotCache.ResetDataSource Method (DataView)

Resets the source data

public void ResetDataSource(
DataView dataView
);

Parameters

dataView
The data source

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace | PivotCache.ResetDataSource Overload List


PivotCache.ToString Method

Returns a String that represents the current Object

public override string ToString();

See Also

PivotCache Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotTableCollection instead

Represents the collection of memory caches from the PivotTable reports in a workbook. Each memory cache is represented by a PivotCache object.

For a list of all members of this type, see PivotCaches Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotCaches

public class PivotCaches : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotTableCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]

 //On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 WebWorksheet sourceSheet = GridWeb1.WebWorksheets["Sheet1"];
 Aspose.Cells.GridWeb.Data.WebCellArea sourceRange = new WebCellArea();
 sourceRange.StartRow = 0;
 sourceRange.StartColumn = 0;
 sourceRange.EndRow = 10;
 sourceRange.EndColumn = 5;

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet, sourceRange);

 PivotTable table = cache.CreatePivotTable();

 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[3].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.PivotFields[4].Orientation = PivotFieldOrientation.ColumnField;
 table.PivotFields[5].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;

 table.PivotFields[3].Function = PivotFieldFunction.Count;
 table.PivotFields[5].Function = PivotFieldFunction.Sum;

 table.DataBind();

 //Creates a PivotTable report from DataView or DataTable.
 DataView dataView;//Or  DataTable dataTable;
     .
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataView);
 //Or PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataTable);
 PivotTable table = cache.CreatePivotTable();
 table = GridWeb1.WebWorksheets.PivotTables["PivotTable1"];
 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.DataBind();

 [VB]

 'On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 Dim sourceSheet As WebWorksheet =  GridWeb1.WebWorksheets("Sheet1")
 Dim sourceRange As Aspose.Cells.GridWeb.Data.WebCellArea =  New WebCellArea()/
 sourceRange.StartRow = 0
 sourceRange.StartColumn = 0
 sourceRange.EndRow = 10
 sourceRange.EndColumn = 5

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet,sourceRange)

 Dim table As PivotTable =  cache.CreatePivotTable()

 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(3).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.PivotFields(4).Orientation = PivotFieldOrientation.ColumnField
 table.PivotFields(5).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField

 table.PivotFields(3).Function = PivotFieldFunction.Count
 table.PivotFields(5).Function = PivotFieldFunction.Sum

 table.DataBind()

 'Creates a PivotTable report from DataView or DataTable.

 Dim dataView As DataView ' Or Dim dataTable As DataTable
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataView)
 'Or Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataTable)
 Dim table As PivotTable =  cache.CreatePivotTable()
 table = GridWeb1.WebWorksheets.PivotTables("PivotTable1")
 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.DataBind()

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotCaches Members | Aspose.Cells.GridWeb.Data Namespace


PivotCaches Members

PivotCaches overview

Public Instance Properties

Count | Gets the number of elements contained in the PivotCaches instance
IsSynchronized | Gets a value indicating whether access to the PivotCaches is synchronized (thread-safe).
Item | Overloaded. Gets PivotCache object by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotCaches.

Public Instance Methods

Add | Overloaded. Adds a PivotCache from DataTable.
Clear | Removes all PivotCache objects and all PivotTable objects in the control.
CopyTo | Copies the entire PivotCache to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotCaches.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Returns the index of the specified PivotCache in the collection
Remove | Removes the specified PivotCache object from the PivotCaches and the related PivotTable using the pivotCache as data source.
RemoveAt | Removes the specified PivotCache object from the PivotCaches and the related PivotTable using the pivotCache as data source.
ToString (inherited from Object) |

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches Properties

The properties of the PivotCaches class are listed below. For a complete list of PivotCaches class members, see the PivotCaches Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the PivotCaches instance
IsSynchronized | Gets a value indicating whether access to the PivotCaches is synchronized (thread-safe).
Item | Overloaded. Gets PivotCache object by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotCaches.

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

PivotCaches.Count Property

Gets the number of elements contained in the PivotCaches instance

public int Count {get;}

Implements

ICollection.Count

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


IsSynchronized Property

Aspose.Cells for .NET

PivotCaches.IsSynchronized Property

Gets a value indicating whether access to the PivotCaches is synchronized (thread-safe).

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

PivotCaches.Item Property

Gets PivotCache object by index.

Overload List

Gets PivotCache object by index.

public PivotCache this[int] {get;}

Gets PivotCache object by name.

public PivotCache this[string] {get;}

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotCaches.Item Property (Int32)

Gets PivotCache object by index.

public PivotCache this[
int index
] {get;}

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotCaches.Item Property (String)

Gets PivotCache object by name.

public PivotCache this[
string name
] {get;}

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Item Overload List


Parent Property

Aspose.Cells for .NET

PivotCaches.Parent Property

Gets the parent object for the specified object. Read-only.

public WebWorksheets Parent {get;}

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


SyncRoot Property

Aspose.Cells for .NET

PivotCaches.SyncRoot Property

Gets an object that can be used to synchronize access to the PivotCaches.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches Methods

The methods of the PivotCaches class are listed below. For a complete list of PivotCaches class members, see the PivotCaches Members topic.

Public Instance Methods

Add | Overloaded. Adds a PivotCache from DataTable.
Clear | Removes all PivotCache objects and all PivotTable objects in the control.
CopyTo | Copies the entire PivotCache to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotCaches.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Returns the index of the specified PivotCache in the collection
Remove | Removes the specified PivotCache object from the PivotCaches and the related PivotTable using the pivotCache as data source.
RemoveAt | Removes the specified PivotCache object from the PivotCaches and the related PivotTable using the pivotCache as data source.
ToString (inherited from Object) |

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

PivotCaches.Add Method

Adds a PivotCache from sheet

Overload List

Adds a PivotCache from sheet

public PivotCache Add(WebWorksheet,WebCellArea);

Adds a PivotCache from sheet using the specified name.

public PivotCache Add(WebWorksheet,WebCellArea,string);

Adds a PivotCache from DataTable.

public PivotCache Add(DataTable);

Adds a PivotCahe from DataTable using the specified name.

public PivotCache Add(DataTable,string);

Adds a PivotCache from DataView.

public PivotCache Add(DataView);

Adds a PivotCahe from DataView using the specified name.

public PivotCache Add(DataView,string);

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches.Add Method (WebWorksheet, WebCellArea)

Adds a PivotCache from sheet

public PivotCache Add(
WebWorksheet sourceSheet,
WebCellArea sourceCellArea
);

Parameters

sourceSheet
The sheet of source data
sourceCellArea
The range of the sheet

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Add Overload List


PivotCaches.Add Method (WebWorksheet, WebCellArea, String)

Adds a PivotCache from sheet using the specified name.

public PivotCache Add(
WebWorksheet sourceSheet,
WebCellArea sourceCellArea,
string cacheName
);

Parameters

sourceSheet
The sheet of source data
sourceCellArea
The range of the sheet
cacheName
The cache name

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Add Overload List


PivotCaches.Add Method (DataTable)

Adds a PivotCache from DataTable.

public PivotCache Add(
DataTable dataTable
);

Parameters

dataTable
The data source

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Add Overload List


PivotCaches.Add Method (DataTable, String)

Adds a PivotCahe from DataTable using the specified name.

public PivotCache Add(
DataTable dataTable,
string cacheName
);

Parameters

dataTable
The data source
cacheName
The cache name

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Add Overload List


PivotCaches.Add Method (DataView)

Adds a PivotCache from DataView.

public PivotCache Add(
DataView dataView
);

Parameters

dataView
The data source

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Add Overload List


PivotCaches.Add Method (DataView, String)

Adds a PivotCahe from DataView using the specified name.

public PivotCache Add(
DataView dataView,
string cacheName
);

Parameters

dataView
The data source
cacheName
The cache name

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace | PivotCaches.Add Overload List


PivotCaches.Clear Method

Removes all PivotCache objects and all PivotTable objects in the control.

public void Clear();

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches.CopyTo Method

Copies the entire PivotCache to a compatible one-dimensional Array, starting at the specified index of the target array

public void CopyTo(
Array array,
int index
);

Implements

ICollection.CopyTo

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches.GetEnumerator Method

Returns an IEnumerator for the PivotCaches.

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches.IndexOf Method

Returns the index of the specified PivotCache in the collection

public int IndexOf(
PivotCache pivotCache
);

Parameters

pivotCache

Return Value

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches.Remove Method

Removes the specified PivotCache object from the PivotCaches and the related PivotTable using the pivotCache as data source.

public void Remove(
PivotCache pivotCache
);

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotCaches.RemoveAt Method

Removes the specified PivotCache object from the PivotCaches and the related PivotTable using the pivotCache as data source.

public void RemoveAt(
int index
);

See Also

PivotCaches Class | Aspose.Cells.GridWeb.Data Namespace


PivotField Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotField instead

Represents a field in a PivotTable report. The PivotField object is a member of the PivotFields collection. NOTE: This class is now obsolete. Instead, please use GridPivotField. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

For a list of all members of this type, see PivotField Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotField

public class PivotField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Gets PivotFields of PivotTable[0]
 PivotField field1 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field1"];
 PivotField field2 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field2"];
 PivotField field3 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field3"];
 PivotField field4 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field4"];

 //Sets Location of PivotFields
 field1.Orientation = PivotFieldOrientation.RowField;
 field2.Orientation = PivotFieldOrientation.RowField;
 field3.Orientation = PivotFieldOrientation.ColumnField;
 field4.Orientation = PivotFieldOrientation.DataField;

 //Sets function of data field
 field3.Function = PivotFieldFunction.Sum;

 //Changes row fields order
 field2.Position = 1; //Or field1.Position = 2;

 [VB]

 'Gets PivotFields of PivotTable[0]
 Dim field1 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field1")
 Dim field2 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field2")
 Dim field3 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field3")
 Dim field4 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field4")

 'Sets Location of PivotFields
 field1.Orientation = PivotFieldOrientation.RowField
 field2.Orientation = PivotFieldOrientation.RowField
 field3.Orientation = PivotFieldOrientation.ColumnField
 field4.Orientation = PivotFieldOrientation.DataField

 'Sets function of data field
 field3.Function = PivotFieldFunction.Sum
 'Changes row fields order
 field2.Position = 1 'Or field1.Position = 2;

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotField Members | Aspose.Cells.GridWeb.Data Namespace


PivotField Members

PivotField overview

Public Instance Properties

Caption | The label text for the pivot field show in report. By default show the name.
FieldItems | Gets the data of the specified field.
Function | Represents function used to summarize the PivotTable field (data fields only). The default function is Count.
Name | Gets the name.
Orientation | Represents The location of the field in the specified PivotTable report.
Position | Represents Position of the field (first, second, third, and so on) among all the fields in its orientation (Rows, Columns, Pages). you shall call the get method after calling of Pivottable.DataBind
SortOrder | Represents the order used to sort the specified PivotTable field.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


PivotField Properties

The properties of the PivotField class are listed below. For a complete list of PivotField class members, see the PivotField Members topic.

Public Instance Properties

Caption | The label text for the pivot field show in report. By default show the name.
FieldItems | Gets the data of the specified field.
Function | Represents function used to summarize the PivotTable field (data fields only). The default function is Count.
Name | Gets the name.
Orientation | Represents The location of the field in the specified PivotTable report.
Position | Represents Position of the field (first, second, third, and so on) among all the fields in its orientation (Rows, Columns, Pages). you shall call the get method after calling of Pivottable.DataBind
SortOrder | Represents the order used to sort the specified PivotTable field.

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


Caption Property

Aspose.Cells for .NET

PivotField.Caption Property

The label text for the pivot field show in report. By default show the name.

public string Caption {get; set;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


FieldItems Property

Aspose.Cells for .NET

PivotField.FieldItems Property

Gets the data of the specified field.

public PivotItems FieldItems {get;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


Function Property

Aspose.Cells for .NET

PivotField.Function Property

Represents function used to summarize the PivotTable field (data fields only). The default function is Count.

public PivotFieldFunction Function {get; set;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

PivotField.Name Property

Gets the name.

public string Name {get;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


Orientation Property

Aspose.Cells for .NET

PivotField.Orientation Property

Represents The location of the field in the specified PivotTable report.

public PivotFieldOrientation Orientation {get; set;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


Position Property

Aspose.Cells for .NET

PivotField.Position Property

Represents Position of the field (first, second, third, and so on) among all the fields in its orientation (Rows, Columns, Pages). you shall call the get method after calling of Pivottable.DataBind

public int Position {get; set;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


SortOrder Property

Aspose.Cells for .NET

PivotField.SortOrder Property

Represents the order used to sort the specified PivotTable field.

public PivotFieldSort SortOrder {get; set;}

See Also

PivotField Class | Aspose.Cells.GridWeb.Data Namespace


PivotFieldFunction Enumeration

NOTE: This enumeration is now obsolete.

This class is obsolete; use GridPivotFieldFunction instead

Represents functions used to summarize the PivotTable data field

public enum PivotFieldFunction

Remarks

NOTE: This class is now obsolete. please use GridPivotFieldFunction Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Members

Member Name | Description | Value
Count | The number of data values.This is the default function. | 1
Sum | The sum of the values. | 2
Average | The average of the values. | 3
Max | The largest value. | 4
Min | The smallest value. | 5
Product | The product of the values. | 6

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


PivotFieldOrientation Enumeration

NOTE: This enumeration is now obsolete.

This class is obsolete; use GridPivotFieldType instead

Represents The location of the field in the specified PivotTable report.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum PivotFieldOrientation

Remarks

NOTE: This class is now obsolete. please use GridPivotFieldType Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Members

Member Name | Description | Value
RowField | Sets the PivotField to RowField | 1
ColumnField | Sets the PivotField to ColumnField | 2
PageField | Sets the PivotField to PageField | 4
DataField | Sets the PivotField to DataField | 8
HiddenField | Sets the PivotField to HiddenField | 16

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


PivotFields Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotFieldCollection instead

Reprents A collection of all the PivotField objects in a PivotTable report.

For a list of all members of this type, see PivotFields Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotFields

public class PivotFields : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotFieldCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]

 //Gets PivotFields of PivotTable[0]
 PivotField field1 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field1"];
 PivotField field2 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field2"];
 PivotField field3 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field3"];
 PivotField field4 = GridWeb1.WebWorksheets.PivotTables[0].PivotFields["field4"];

 //Sets Location of PivotFields
 field1.Orientation = PivotFieldOrientation.RowField;
 field2.Orientation = PivotFieldOrientation.RowField;
 field3.Orientation = PivotFieldOrientation.ColumnField;
 field4.Orientation = PivotFieldOrientation.DataField;

 //Sets function of data field
 field3.Function = PivotFieldFunction.Sum;

 //Changes row fields order
 field2.Position = 1; //Or field1.Position = 2;

 [VB]

 'Gets PivotFields of PivotTable[0]
 Dim field1 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field1")
 Dim field2 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field2")
 Dim field3 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field3")
 Dim field4 As PivotField =  GridWeb1.WebWorksheets.PivotTables(0).PivotFields("field4")

 'Sets Location of PivotFields
 field1.Orientation = PivotFieldOrientation.RowField
 field2.Orientation = PivotFieldOrientation.RowField
 field3.Orientation = PivotFieldOrientation.ColumnField
 field4.Orientation = PivotFieldOrientation.DataField

 'Sets function of data field
 field3.Function = PivotFieldFunction.Sum
 'Changes row fields order
 field2.Position = 1 'Or field1.Position = 2;

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotFields Members | Aspose.Cells.GridWeb.Data Namespace


PivotFields Members

PivotFields overview

Public Instance Properties

Count | Gets the number of elements contained in the PivotFields instance
IsSynchronized | Gets a value indicating whether access to the PivotFields is synchronized (thread-safe).
Item | Overloaded. Gets a PivotField by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotFields.

Public Instance Methods

CopyTo | Copies the entire PivotField to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotFields.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of the specified PivotField.
ToString (inherited from Object) |

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


PivotFields Properties

The properties of the PivotFields class are listed below. For a complete list of PivotFields class members, see the PivotFields Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the PivotFields instance
IsSynchronized | Gets a value indicating whether access to the PivotFields is synchronized (thread-safe).
Item | Overloaded. Gets a PivotField by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotFields.

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

PivotFields.Count Property

Gets the number of elements contained in the PivotFields instance

public int Count {get;}

Implements

ICollection.Count

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


IsSynchronized Property

Aspose.Cells for .NET

PivotFields.IsSynchronized Property

Gets a value indicating whether access to the PivotFields is synchronized (thread-safe).

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

PivotFields.Item Property

Gets a PivotField by index.

Overload List

Gets a PivotField by index.

public PivotField this[int] {get;}

Gets a PivotField by name.

public PivotField this[string] {get;}

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotFields.Item Property (Int32)

Gets a PivotField by index.

public PivotField this[
int index
] {get;}

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace | PivotFields.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotFields.Item Property (String)

Gets a PivotField by name.

public PivotField this[
string name
] {get;}

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace | PivotFields.Item Overload List


Parent Property

Aspose.Cells for .NET

PivotFields.Parent Property

Gets the parent object for the specified object. Read-only.

public PivotTable Parent {get;}

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


SyncRoot Property

Aspose.Cells for .NET

PivotFields.SyncRoot Property

Gets an object that can be used to synchronize access to the PivotFields.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


PivotFields Methods

The methods of the PivotFields class are listed below. For a complete list of PivotFields class members, see the PivotFields Members topic.

Public Instance Methods

CopyTo | Copies the entire PivotField to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotFields.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of the specified PivotField.
ToString (inherited from Object) |

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


PivotFields.CopyTo Method

Copies the entire PivotField to a compatible one-dimensional Array, starting at the specified index of the target array

public void CopyTo(
Array array,
int index
);

Implements

ICollection.CopyTo

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


PivotFields.GetEnumerator Method

Returns an IEnumerator for the PivotFields.

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


PivotFields.IndexOf Method

Gets the index of the specified PivotField.

public int IndexOf(
PivotField field
);

Parameters

field

Return Value

See Also

PivotFields Class | Aspose.Cells.GridWeb.Data Namespace


PivotFieldSort Enumeration

Represents the order used to sort the specified PivotTable field.

public enum PivotFieldSort

Members

Member Name | Description | Value
Asc | Rows or Columns organize data ascendable | 1
Desc | Rows or Columns organize data descendable | 2
Auto | Rows or Columns organize data natural | 3

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


PivotItem Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotItem instead

Represents an item in a PivotTable field. The items are the individual data entries in a field category. The PivotItem object is a member of the PivotItems collection. The PivotItems collection contains all the items in a PivotField object.

For a list of all members of this type, see PivotItem Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotItem

public class PivotItem : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotItem Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotItem Members | Aspose.Cells.GridWeb.Data Namespace


PivotItem Members

PivotItem overview

Public Instance Properties

Name | Gets the name
Parent | Gets the parent object for the specified object. Read-only.
Value | Gets the value of the specified item.
Visible | Represents whether the specified item visible.

Public Instance Methods

CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Equals | Determines whether two Object instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) |
ToString | Returns a String that represents the current Object

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItem Properties

The properties of the PivotItem class are listed below. For a complete list of PivotItem class members, see the PivotItem Members topic.

Public Instance Properties

Name | Gets the name
Parent | Gets the parent object for the specified object. Read-only.
Value | Gets the value of the specified item.
Visible | Represents whether the specified item visible.

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

PivotItem.Name Property

Gets the name

public string Name {get;}

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Parent Property

Aspose.Cells for .NET

PivotItem.Parent Property

Gets the parent object for the specified object. Read-only.

public PivotItems Parent {get;}

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Value Property

Aspose.Cells for .NET

PivotItem.Value Property

Gets the value of the specified item.

public object Value {get;}

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


Visible Property

Aspose.Cells for .NET

PivotItem.Visible Property

Represents whether the specified item visible.

public bool Visible {get; set;}

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItem Methods

The methods of the PivotItem class are listed below. For a complete list of PivotItem class members, see the PivotItem Members topic.

Public Instance Methods

CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Equals | Determines whether two Object instances are equal.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) |
ToString | Returns a String that represents the current Object

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItem.CompareTo Method

Compares this instance to a specified object and returns an indication of their relative values.

public int CompareTo(
object obj
);

Implements

IComparable.CompareTo

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItem.Equals Method

Determines whether two Object instances are equal.

public override bool Equals(
object obj
);

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItem.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

public override int GetHashCode();

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItem.ToString Method

Returns a String that represents the current Object

public override string ToString();

See Also

PivotItem Class | Aspose.Cells.GridWeb.Data Namespace


PivotItems Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotItemCollection instead

Represents A collection of all the PivotItem objects in a PivotTable field. The items are the individual data entries in a field category.

For a list of all members of this type, see PivotItems Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotItems

public class PivotItems : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotItemCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotItems Members | Aspose.Cells.GridWeb.Data Namespace


PivotItems Members

PivotItems overview

Public Instance Properties

Count | Gets the number of elements contained in the PivotItems instance
IsSynchronized | Gets a value indicating whether access to the PivotItems is synchronized (thread-safe).
Item | Overloaded. Gets a item by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotItems.

Public Instance Methods

CopyTo | Copies the entire PivotItem to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotItems.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


PivotItems Properties

The properties of the PivotItems class are listed below. For a complete list of PivotItems class members, see the PivotItems Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the PivotItems instance
IsSynchronized | Gets a value indicating whether access to the PivotItems is synchronized (thread-safe).
Item | Overloaded. Gets a item by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotItems.

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

PivotItems.Count Property

Gets the number of elements contained in the PivotItems instance

public int Count {get;}

Implements

ICollection.Count

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


IsSynchronized Property

Aspose.Cells for .NET

PivotItems.IsSynchronized Property

Gets a value indicating whether access to the PivotItems is synchronized (thread-safe).

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

PivotItems.Item Property

Gets a item by index.

Overload List

Gets a item by index.

public PivotItem this[int] {get;}

Gets a item by name.

public PivotItem this[string] {get;}

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotItems.Item Property (Int32)

Gets a item by index.

public PivotItem this[
int index
] {get;}

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace | PivotItems.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotItems.Item Property (String)

Gets a item by name.

public PivotItem this[
string pivotName
] {get;}

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace | PivotItems.Item Overload List


Parent Property

Aspose.Cells for .NET

PivotItems.Parent Property

Gets the parent object for the specified object. Read-only.

public PivotField Parent {get;}

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


SyncRoot Property

Aspose.Cells for .NET

PivotItems.SyncRoot Property

Gets an object that can be used to synchronize access to the PivotItems.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


PivotItems Methods

The methods of the PivotItems class are listed below. For a complete list of PivotItems class members, see the PivotItems Members topic.

Public Instance Methods

CopyTo | Copies the entire PivotItem to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotItems.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


PivotItems.CopyTo Method

Copies the entire PivotItem to a compatible one-dimensional Array, starting at the specified index of the target array

public void CopyTo(
Array array,
int index
);

Implements

ICollection.CopyTo

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


PivotItems.GetEnumerator Method

Returns an IEnumerator for the PivotItems.

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

PivotItems Class | Aspose.Cells.GridWeb.Data Namespace


PivotSourceType Enumeration

Represents the source data type.

public enum PivotSourceType

Members

Member Name | Description | Value
DataTable | Represents data source from a DataTable object. | 1
DataView | Represents data source from a DataView object. | 2
WorkSheet | Represents data source from a WebWorksheet objecet. | 3

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


PivotTable Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotTable instead

Represents a PivotTable report on a worksheet. The PivotTable object is a member of the PivotTables collection. The PivotTables collection contains all the PivotTable objects on a control.

For a list of all members of this type, see PivotTable Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotTable

public class PivotTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotTable Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]

 //On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 WebWorksheet sourceSheet = GridWeb1.WebWorksheets["Sheet1"];
 Aspose.Cells.GridWeb.Data.WebCellArea sourceRange = new WebCellArea();
 sourceRange.StartRow = 0;
 sourceRange.StartColumn = 0;
 sourceRange.EndRow = 10;
 sourceRange.EndColumn = 5;

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet, sourceRange);

 PivotTable table = cache.CreatePivotTable();

 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[3].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.PivotFields[4].Orientation = PivotFieldOrientation.ColumnField;
 table.PivotFields[5].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;

 table.PivotFields[3].Function = PivotFieldFunction.Count;
 table.PivotFields[5].Function = PivotFieldFunction.Sum;

 table.DataBind();

 //Creates a PivotTable report from DataView or DataTable.
 DataView dataView;//Or  DataTable dataTable;
     .
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataView);
 //Or PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataTable);
 PivotTable table = cache.CreatePivotTable();
 table = GridWeb1.WebWorksheets.PivotTables["PivotTable1"];
 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.DataBind();

 [VB]

 'On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 Dim sourceSheet As WebWorksheet =  GridWeb1.WebWorksheets("Sheet1")
 Dim sourceRange As Aspose.Cells.GridWeb.Data.WebCellArea =  New WebCellArea()/
 sourceRange.StartRow = 0
 sourceRange.StartColumn = 0
 sourceRange.EndRow = 10
 sourceRange.EndColumn = 5

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet,sourceRange)

 Dim table As PivotTable =  cache.CreatePivotTable()

 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(3).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.PivotFields(4).Orientation = PivotFieldOrientation.ColumnField
 table.PivotFields(5).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField

 table.PivotFields(3).Function = PivotFieldFunction.Count
 table.PivotFields(5).Function = PivotFieldFunction.Sum

 table.DataBind()

 'Creates a PivotTable report from DataView or DataTable.

 Dim dataView As DataView ' Or Dim dataTable As DataTable
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataView)
 'Or Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataTable)
 Dim table As PivotTable =  cache.CreatePivotTable()
 table = GridWeb1.WebWorksheets.PivotTables("PivotTable1")
 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.DataBind()

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotTable Members | Aspose.Cells.GridWeb.Data Namespace


PivotTable Members

PivotTable overview

Public Instance Properties

Name | Gets name
PivotCache | Gets PivotCache object that the report used.
PivotFields | Repesents all fields in PivotTable report.

Public Instance Methods

DataBind
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


PivotTable Properties

The properties of the PivotTable class are listed below. For a complete list of PivotTable class members, see the PivotTable Members topic.

Public Instance Properties

Name | Gets name
PivotCache | Gets PivotCache object that the report used.
PivotFields | Repesents all fields in PivotTable report.

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

PivotTable.Name Property

Gets name

public string Name {get;}

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


PivotCache Property

Aspose.Cells for .NET

PivotTable.PivotCache Property

Gets PivotCache object that the report used.

public PivotCache PivotCache {get;}

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


PivotFields Property

Aspose.Cells for .NET

PivotTable.PivotFields Property

Repesents all fields in PivotTable report.

public PivotFields PivotFields {get;}

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


PivotTable Methods

The methods of the PivotTable class are listed below. For a complete list of PivotTable class members, see the PivotTable Members topic.

Public Instance Methods

DataBind
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


PivotTable.DataBind Method

public void DataBind();

See Also

PivotTable Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables Class

NOTE: This class is now obsolete.

This class is obsolete; use GridPivotTableCollection instead

Represents a collection of all the PivotTable objects

For a list of all members of this type, see PivotTables Members.

System.Object
Aspose.Cells.GridWeb.Data.PivotTables

public class PivotTables : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridPivotTableCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]

 //On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 WebWorksheet sourceSheet = GridWeb1.WebWorksheets["Sheet1"];
 Aspose.Cells.GridWeb.Data.WebCellArea sourceRange = new WebCellArea();
 sourceRange.StartRow = 0;
 sourceRange.StartColumn = 0;
 sourceRange.EndRow = 10;
 sourceRange.EndColumn = 5;

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet, sourceRange);

 PivotTable table = cache.CreatePivotTable();

 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[3].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.PivotFields[4].Orientation = PivotFieldOrientation.ColumnField;
 table.PivotFields[5].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;

 table.PivotFields[3].Function = PivotFieldFunction.Count;
 table.PivotFields[5].Function = PivotFieldFunction.Sum;

 table.DataBind();

 //Creates a PivotTable report from DataView or DataTable.
 DataView dataView;//Or  DataTable dataTable;
     .
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataView);
 //Or PivotCache cache = GridWeb1.WebWorksheets.PivotCaches.Add(dataTable);
 PivotTable table = cache.CreatePivotTable();
 table = GridWeb1.WebWorksheets.PivotTables["PivotTable1"];
 table.PivotFields[0].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[1].Orientation = PivotFieldOrientation.RowField;
 table.PivotFields[2].Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField;
 table.DataBind();

 [VB]

 'On the assumption that worksheet "Sheet1" has datas, then creates a PivotTable report base on it.
 Dim sourceSheet As WebWorksheet =  GridWeb1.WebWorksheets("Sheet1")
 Dim sourceRange As Aspose.Cells.GridWeb.Data.WebCellArea =  New WebCellArea()/
 sourceRange.StartRow = 0
 sourceRange.StartColumn = 0
 sourceRange.EndRow = 10
 sourceRange.EndColumn = 5

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(sourceSheet,sourceRange)

 Dim table As PivotTable =  cache.CreatePivotTable()

 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(3).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.PivotFields(4).Orientation = PivotFieldOrientation.ColumnField
 table.PivotFields(5).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField

 table.PivotFields(3).Function = PivotFieldFunction.Count
 table.PivotFields(5).Function = PivotFieldFunction.Sum

 table.DataBind()

 'Creates a PivotTable report from DataView or DataTable.

 Dim dataView As DataView ' Or Dim dataTable As DataTable
     .
     .
 Sets dataView(dataTable) Value
     .
     .
     .

 Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataView)
 'Or Dim cache As PivotCache =  GridWeb1.WebWorksheets.PivotCaches.Add(dataTable)
 Dim table As PivotTable =  cache.CreatePivotTable()
 table = GridWeb1.WebWorksheets.PivotTables("PivotTable1")
 table.PivotFields(0).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(1).Orientation = PivotFieldOrientation.RowField
 table.PivotFields(2).Orientation = PivotFieldOrientation.ColumnField | PivotFieldOrientation.DataField
 table.DataBind()

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

PivotTables Members | Aspose.Cells.GridWeb.Data Namespace


PivotTables Members

PivotTables overview

Public Instance Properties

Count | Gets the number of elements contained in the PivotTables instance
IsSynchronized | Gets a value indicating whether access to the PivotTables is synchronized (thread-safe).
Item | Overloaded. Gets a PivotTable object by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotTables.

Public Instance Methods

Add | Overloaded. Adds a PivotTable object from the specified PivotCache to a new worksheet
Clear | Removes all PivotTable objects and all PivotCache objects in the control.
Contains | Returns true if exists pivottable name tableName.
CopyTo | Copies the entire PivotTable to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotTables.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Refresh | ReDataBinds data source to the PivotTable report.
RefreshAll | ReDataBinds data source to all PivotTable report.
Remove | Removes the specified PivotTable object from the PivotTables and the related PivotCache if it is not used by other PivotTable
RemoveAt | Removes the specified PivotTable object from the PivotTables and the related PivotCache if it is not used by other PivotTable
ToString (inherited from Object) |

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables Properties

The properties of the PivotTables class are listed below. For a complete list of PivotTables class members, see the PivotTables Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the PivotTables instance
IsSynchronized | Gets a value indicating whether access to the PivotTables is synchronized (thread-safe).
Item | Overloaded. Gets a PivotTable object by index.
Parent | Gets the parent object for the specified object. Read-only.
SyncRoot | Gets an object that can be used to synchronize access to the PivotTables.

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

PivotTables.Count Property

Gets the number of elements contained in the PivotTables instance

public int Count {get;}

Implements

ICollection.Count

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


IsSynchronized Property

Aspose.Cells for .NET

PivotTables.IsSynchronized Property

Gets a value indicating whether access to the PivotTables is synchronized (thread-safe).

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

PivotTables.Item Property

Gets a PivotTable object by index.

Overload List

Gets a PivotTable object by index.

public PivotTable this[int] {get;}

Gets a PivotTable object by name.

public PivotTable this[string] {get;}

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotTables.Item Property (Int32)

Gets a PivotTable object by index.

public PivotTable this[
int index
] {get;}

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace | PivotTables.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotTables.Item Property (String)

Gets a PivotTable object by name.

public PivotTable this[
string name
] {get;}

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace | PivotTables.Item Overload List


Parent Property

Aspose.Cells for .NET

PivotTables.Parent Property

Gets the parent object for the specified object. Read-only.

public WebWorksheets Parent {get;}

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


SyncRoot Property

Aspose.Cells for .NET

PivotTables.SyncRoot Property

Gets an object that can be used to synchronize access to the PivotTables.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables Methods

The methods of the PivotTables class are listed below. For a complete list of PivotTables class members, see the PivotTables Members topic.

Public Instance Methods

Add | Overloaded. Adds a PivotTable object from the specified PivotCache to a new worksheet
Clear | Removes all PivotTable objects and all PivotCache objects in the control.
Contains | Returns true if exists pivottable name tableName.
CopyTo | Copies the entire PivotTable to a compatible one-dimensional Array, starting at the specified index of the target array
Equals (inherited from Object) |
GetEnumerator | Returns an IEnumerator for the PivotTables.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Refresh | ReDataBinds data source to the PivotTable report.
RefreshAll | ReDataBinds data source to all PivotTable report.
Remove | Removes the specified PivotTable object from the PivotTables and the related PivotCache if it is not used by other PivotTable
RemoveAt | Removes the specified PivotTable object from the PivotTables and the related PivotCache if it is not used by other PivotTable
ToString (inherited from Object) |

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

PivotTables.Add Method

Adds a PivotTable object from the specified PivotCache to a new worksheet

Overload List

Adds a PivotTable object from the specified PivotCache to a new worksheet

public PivotTable Add(PivotCache);

Adds a PivotTable object from the specified PivotCache to the specified worksheet

public PivotTable Add(PivotCache,WebWorksheet,WebCell);

Adds a PivotTable object from the specified PivotCache to the specified worksheet

public PivotTable Add(PivotCache,WebWorksheet,WebCell,string);

Adds a PivotTable object from the specified PivotCache to a new worksheet

public PivotTable Add(PivotCache,string);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.Add Method (PivotCache)

Adds a PivotTable object from the specified PivotCache to a new worksheet

public PivotTable Add(
PivotCache pivotCache
);

Parameters

pivotCache
The source data

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace | PivotTables.Add Overload List


PivotTables.Add Method (PivotCache, WebWorksheet, WebCell)

Adds a PivotTable object from the specified PivotCache to the specified worksheet

public PivotTable Add(
PivotCache pivotCache,
WebWorksheet targetSheet,
WebCell targetCell
);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace | PivotTables.Add Overload List


PivotTables.Add Method (PivotCache, WebWorksheet, WebCell, String)

Adds a PivotTable object from the specified PivotCache to the specified worksheet

public PivotTable Add(
PivotCache pivotCache,
WebWorksheet targetSheet,
WebCell targetCell,
string tableName
);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace | PivotTables.Add Overload List


PivotTables.Add Method (PivotCache, String)

Adds a PivotTable object from the specified PivotCache to a new worksheet

public PivotTable Add(
PivotCache pivotCache,
string tableName
);

Parameters

pivotCache
The source data
tableName
PivotTable name

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace | PivotTables.Add Overload List


PivotTables.Clear Method

Removes all PivotTable objects and all PivotCache objects in the control.

public void Clear();

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.Contains Method

Returns true if exists pivottable name tableName.

public bool Contains(
string tableName
);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.CopyTo Method

Copies the entire PivotTable to a compatible one-dimensional Array, starting at the specified index of the target array

public void CopyTo(
Array array,
int index
);

Implements

ICollection.CopyTo

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.GetEnumerator Method

Returns an IEnumerator for the PivotTables.

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.Refresh Method

ReDataBinds data source to the PivotTable report.

public void Refresh(
PivotTable pivotTable
);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.RefreshAll Method

ReDataBinds data source to all PivotTable report.

public void RefreshAll();

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.Remove Method

Removes the specified PivotTable object from the PivotTables and the related PivotCache if it is not used by other PivotTable

public void Remove(
PivotTable pivotTable
);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables.RemoveAt Method

Removes the specified PivotTable object from the PivotTables and the related PivotCache if it is not used by other PivotTable

public void RemoveAt(
int index
);

See Also

PivotTables Class | Aspose.Cells.GridWeb.Data Namespace


RowColumnEventHandler Delegate

Represents the interface that intend to handle row/column events.

void handleCellEvent(Object sender, RowColumnEventArgs e);

public delegate void RowColumnEventHandler(
object sender,
RowColumnEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument. Call e.RejectOperation() if you want to cancel the deleting operation in RowDeleting or ColumnDeleting event handlers.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings Class

NOTE: This class is now obsolete.

This class is obsolete; use GridWorksheet.AddAutoFilter/FilterString for autofilter /custom filter settings

Summary description for RowFilter.

For a list of all members of this type, see RowFilterSettings Members.

System.Object
Aspose.Cells.GridWeb.Data.RowFilterSettings

public class RowFilterSettings : IComparer, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. This class will be removed after 6 months since Aug. 2014. you can use GridWorksheet AddAutoFilter/FilterString for autofilter /custom filter settings Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

RowFilterSettings Members | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings Members

RowFilterSettings overview

Public Instance Properties

Criteria | The filter criteria string.
EnableAutoFilter | Enables auto filtering. The HeaderRow will display dropdown buttons to let user select the column's value to be filtered.
EndColumn | The end row number of the filter range. If this value is set to -1, the last row number of the sheet is used.
HeaderRow | The header row number which will display filter dropdown buttons.
StartColumn | The start row number of the filter range.

Public Instance Methods

BuildAutoFilterCriteria | Builds criteria string from auto filter settings.
ClearFilter | Clears all filter settings and display all rows.
CustomFilter | Specifies a custom filter.
Equals (inherited from Object) |
FilterRows | Filters rows using criteria string.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings Properties

The properties of the RowFilterSettings class are listed below. For a complete list of RowFilterSettings class members, see the RowFilterSettings Members topic.

Public Instance Properties

Criteria | The filter criteria string.
EnableAutoFilter | Enables auto filtering. The HeaderRow will display dropdown buttons to let user select the column's value to be filtered.
EndColumn | The end row number of the filter range. If this value is set to -1, the last row number of the sheet is used.
HeaderRow | The header row number which will display filter dropdown buttons.
StartColumn | The start row number of the filter range.

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


Criteria Property

Aspose.Cells for .NET

RowFilterSettings.Criteria Property

The filter criteria string.

public string Criteria {get; set;}

Remarks

The filter criteria string. below are the criteria string examples: CELL0 = 12.3 CELL1 = "ABC" AND(CELL0 = 123, CELL1 = "ABC") OR(CELL0 = 123, CELL1 = "ABC") CELL0 = B1 + 4

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


EnableAutoFilter Property

Aspose.Cells for .NET

RowFilterSettings.EnableAutoFilter Property

Enables auto filtering. The HeaderRow will display dropdown buttons to let user select the column's value to be filtered.

public bool EnableAutoFilter {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


EndColumn Property

Aspose.Cells for .NET

RowFilterSettings.EndColumn Property

The end row number of the filter range. If this value is set to -1, the last row number of the sheet is used.

public int EndColumn {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


HeaderRow Property

Aspose.Cells for .NET

RowFilterSettings.HeaderRow Property

The header row number which will display filter dropdown buttons.

public int HeaderRow {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


StartColumn Property

Aspose.Cells for .NET

RowFilterSettings.StartColumn Property

The start row number of the filter range.

public int StartColumn {get; set;}

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings Methods

The methods of the RowFilterSettings class are listed below. For a complete list of RowFilterSettings class members, see the RowFilterSettings Members topic.

Public Instance Methods

BuildAutoFilterCriteria | Builds criteria string from auto filter settings.
ClearFilter | Clears all filter settings and display all rows.
CustomFilter | Specifies a custom filter.
Equals (inherited from Object) |
FilterRows | Filters rows using criteria string.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings.BuildAutoFilterCriteria Method

Builds criteria string from auto filter settings.

public void BuildAutoFilterCriteria();

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings.ClearFilter Method

Clears all filter settings and display all rows.

public void ClearFilter();

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings.CustomFilter Method

Specifies a custom filter.

public void CustomFilter(
int headerRow,
ICustomFilter customFilter
);

Parameters

headerRow
Header row index.
customFilter
An instance of ICustomFilter.

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


RowFilterSettings.FilterRows Method

Filters rows using criteria string.

public ArrayList FilterRows();

Return Value

Filtered indexes list of rows.

See Also

RowFilterSettings Class | Aspose.Cells.GridWeb.Data Namespace


SheetEventHandler Delegate

Represents the interface that intend to handle sheet events.

void handleCellEvent(Object sender, RowColumnEventArgs e);

public delegate void SheetEventHandler(
object sender,
GridWorksheet sheet
);

Parameters

sender
The source of the event.
sheet
The related worksheet.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


SortOrder Enumeration

Represents what order the data sort by.

public enum SortOrder

Members

Member Name | Description | Value
Ascending | Sorts by ascending | 1
Descending | Sorts by descending | 2

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


SortOrientation Enumeration

Represents sorting orientation

public enum SortOrientation

Remarks

SortOrientation.SortTopToBottom represents sorting datas from top to bottom and exchanging data row by row. SortOrientation.SortLeftToRight represents sorting datas from left to right and exchanging data column by column.

Members

Member Name | Description | Value
SortTopToBottom | Represents sorting datas from top to bottom and exchanging data row by row. | 1
SortLeftToRight | Represents sorting datas from left to right and exchanging data column by column. | 2

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


SubtotalFunction Enumeration

Represents subtotal function type. Used in the GridWorksheet.CreateSubtotal method.

public enum SubtotalFunction

Members

Member Name | Description | Value
AVERAGE | Average | 1
COUNT | Count the numeric cells. | 2
COUNTA | Count the non-null cells | 3
MAX | Max | 4
MIN | Min | 5
PRODUCT | Product | 6
SUM | Sum | 9

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


WebCell Class

NOTE: This class is now obsolete.

This class is obsolete; use GridCell instead

For a list of all members of this type, see WebCell Members.

System.Object
Aspose.Cells.GridWeb.Data.WebCell

public class WebCell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridCell Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebCell Members | Aspose.Cells.GridWeb.Data Namespace


WebCell Members

WebCell overview

Public Instance Properties

Column | Gets the column number of the cell.
Formula | Gets or sets the formula string of the cell. Returns null when the cell doesn't contain a formula.
IsReadonly | Gets or sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
Name |
Row | Gets the row number of the cell.
StringValue |
UnformattedStringValue | Gets the unformatted string value.
Validation |
Value |

Public Instance Methods

CreateValidation | Creates a validation object for a cell.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetStyle |
GetType (inherited from Object) |
PutValue | Overloaded. Puts a DateTime value into the cell.
PutValueAndSetFormatByValue | Sets the cell's value with a string value and set cell format by this value.
SetStyle |
ToString (inherited from Object) |

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCell Properties

The properties of the WebCell class are listed below. For a complete list of WebCell class members, see the WebCell Members topic.

Public Instance Properties

Column | Gets the column number of the cell.
Formula | Gets or sets the formula string of the cell. Returns null when the cell doesn't contain a formula.
IsReadonly | Gets or sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file
Name |
Row | Gets the row number of the cell.
StringValue |
UnformattedStringValue | Gets the unformatted string value.
Validation |
Value |

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


Column Property

Aspose.Cells for .NET

WebCell.Column Property

Gets the column number of the cell.

public int Column {get;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


Formula Property

Aspose.Cells for .NET

WebCell.Formula Property

Gets or sets the formula string of the cell. Returns null when the cell doesn't contain a formula.

public string Formula {get; set;}

Example

[C#]
    cell.Formula = "=SUM(A1:C3) + E6*2";
[Visual Basic]
    cell.Formula = "=SUM(A1:C3) + E6*2"

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


IsReadonly Property

Aspose.Cells for .NET

WebCell.IsReadonly Property

Gets or sets whether the cell is readonly.this is an extended attribute of GridWeb ,it will not keep in actual excel file

public bool IsReadonly {get; set;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

WebCell.Name Property

public string Name {get;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


Row Property

Aspose.Cells for .NET

WebCell.Row Property

Gets the row number of the cell.

public int Row {get;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


StringValue Property

Aspose.Cells for .NET

WebCell.StringValue Property

public string StringValue {get; set;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


UnformattedStringValue Property

Aspose.Cells for .NET

WebCell.UnformattedStringValue Property

Gets the unformatted string value.

public string UnformattedStringValue {get;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


Validation Property

Aspose.Cells for .NET

WebCell.Validation Property

public Validation Validation {get; set;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


Value Property

Aspose.Cells for .NET

WebCell.Value Property

public object Value {get; set;}

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCell Methods

The methods of the WebCell class are listed below. For a complete list of WebCell class members, see the WebCell Members topic.

Public Instance Methods

CreateValidation | Creates a validation object for a cell.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetStyle |
GetType (inherited from Object) |
PutValue | Overloaded. Puts a DateTime value into the cell.
PutValueAndSetFormatByValue | Sets the cell's value with a string value and set cell format by this value.
SetStyle |
ToString (inherited from Object) |

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCell.CreateValidation Method

Creates a validation object for a cell.

public Validation CreateValidation(
ValidationType validationType,
bool isRequried
);

Parameters

validationType
Validation type.
isRequried
Whether the cell value is required.

Return Value

Example

[C#]
    Validation v = cell1.CreateValidation(ValidationType.CustomExpression, true);
    // Sets to number validation expression.
    v.RegEx = "\\d+";

[Visual Basic]
    Dim v As Validation =  cell1.CreateValidation(ValidationType.CustomExpression,True)
     ' Sets to number validation expression.
    v.RegEx = "\\d+"

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCell.GetStyle Method

public TableItemStyle GetStyle();

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


PutValue Method

Aspose.Cells for .NET

WebCell.PutValue Method

Puts a boolean value into the cell.

Overload List

Puts a boolean value into the cell.

public void PutValue(bool);

Puts a DateTime value into the cell.

public void PutValue(DateTime);

Puts a double value into the cell.

public void PutValue(double);

Puts a int value into the cell.

public void PutValue(int);

Puts an object value into the cell.same as setValue(Object param_object)

public void PutValue(object);

Puts a String value into the cell.

public void PutValue(string);

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(string,bool);

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(string,bool,bool);

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCell.PutValue Method (Boolean)

Puts a boolean value into the cell.

public void PutValue(
bool param_boolean
);

Parameters

param_boolean
Input value

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (DateTime)

Puts a DateTime value into the cell.

public void PutValue(
DateTime param_date
);

Parameters

param_date
Input value

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (Double)

Puts a double value into the cell.

public void PutValue(
double param_double
);

Parameters

param_double
Input value

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (Int32)

Puts a int value into the cell.

public void PutValue(
int param_int
);

Parameters

param_int
Input value

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (Object)

Puts an object value into the cell.same as setValue(Object param_object)

public void PutValue(
object param_object
);

Parameters

param_object

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (String)

Puts a String value into the cell.

public void PutValue(
string param_string
);

Parameters

param_string
Input value

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (String, Boolean)

Puts a string value into the cell and converts the value to other data type if appropriate.

public void PutValue(
string stringValue,
bool isConverted
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValue Method (String, Boolean, Boolean)

Puts a value into the cell, if appropriate the value will be converted to other data type and cell's number format will be reset.

public void PutValue(
string stringValue,
bool isConverted,
bool setStyle
);

Parameters

stringValue
Input value
isConverted
True: converted to other data type if appropriate.
setStyle
True: set the number format to cell's style when converting to other data type

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace | WebCell.PutValue Overload List


WebCell.PutValueAndSetFormatByValue Method

Sets the cell's value with a string value and set cell format by this value.

public void PutValueAndSetFormatByValue(
string stringValue
);

Parameters

stringValue
Input value.

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCell.SetStyle Method

public void SetStyle(
TableItemStyle style
);

See Also

WebCell Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea Class

NOTE: This class is now obsolete.

This class is obsolete; use GridCellArea instead

For a list of all members of this type, see WebCellArea Members.

System.Object
Aspose.Cells.GridWeb.Data.WebCellArea

public class WebCellArea

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridCellArea Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebCellArea Members | Aspose.Cells.GridWeb.Data Namespace


WebCellArea Members

WebCellArea overview

Public Instance Constructors

WebCellArea Overloaded. Initializes a new instance of the WebCellArea class.

Public Instance Fields

EndColumn | Gets or sets the end column of this area.
EndRow | Gets or sets the end row of this area.
StartColumn | Gets or sets the start column of this area.
StartRow | Gets or sets the start row of this area.

Public Instance Methods

Equals | Test if the object equals to another WebCellArea object.
GetHashCode | Get the hashcode.
GetType (inherited from Object) |
ToGridCellArea |
ToString (inherited from Object) |

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea Constructor

Initializes a new instance of the WebCellArea class.

Overload List

Initializes a new instance of the WebCellArea class.

public WebCellArea();

public WebCellArea(GridCellArea);

public WebCellArea(int,int,int,int);

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea Constructor ()

Initializes a new instance of the WebCellArea class.

public WebCellArea();

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace | WebCellArea Constructor Overload List


WebCellArea Constructor (Int32, Int32, Int32, Int32)

public WebCellArea(
int startrow,
int startcol,
int endrow,
int endcol
);

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace | WebCellArea Constructor Overload List


WebCellArea Constructor (GridCellArea)

public WebCellArea(
GridCellArea ca
);

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace | WebCellArea Constructor Overload List


WebCellArea Fields

The fields of the WebCellArea class are listed below. For a complete list of WebCellArea class members, see the WebCellArea Members topic.

Public Instance Fields

EndColumn | Gets or sets the end column of this area.
EndRow | Gets or sets the end row of this area.
StartColumn | Gets or sets the start column of this area.
StartRow | Gets or sets the start row of this area.

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.EndColumn Field

Gets or sets the end column of this area.

public int EndColumn;

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.EndRow Field

Gets or sets the end row of this area.

public int EndRow;

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.StartColumn Field

Gets or sets the start column of this area.

public int StartColumn;

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.StartRow Field

Gets or sets the start row of this area.

public int StartRow;

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea Methods

The methods of the WebCellArea class are listed below. For a complete list of WebCellArea class members, see the WebCellArea Members topic.

Public Instance Methods

Equals | Test if the object equals to another WebCellArea object.
GetHashCode | Get the hashcode.
GetType (inherited from Object) |
ToGridCellArea |
ToString (inherited from Object) |

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.Equals Method

Test if the object equals to another WebCellArea object.

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.GetHashCode Method

Get the hashcode.

public override int GetHashCode();

Return Value

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellArea.ToGridCellArea Method

public GridCellArea ToGridCellArea();

See Also

WebCellArea Class | Aspose.Cells.GridWeb.Data Namespace


WebCellErrorType Enumeration

Used in WebCellException. Represents the cell error type.

public enum WebCellErrorType

Members

Member Name | Description | Value
ValidationError | The cell's validation failed. | 0
DataSourceInsertError | When insert the sheet's binding row to datasource, an error occured. | 1
DataSourceUpdateError | When update the sheet's binding row or object's field, an error occured. | 2
DataSourceDeleteError | When delete the sheet's binding row to datasource, an error occured. | 3

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


WebCellException Class

Represents a cell operation error.

For a list of all members of this type, see WebCellException Members.

System.Object
System.Exception
Aspose.Cells.GridWeb.Data.WebCellException

public class WebCellException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebCellException Members | Aspose.Cells.GridWeb.Data Namespace


WebCellException Members

WebCellException overview

Public Instance Properties

Cell | Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.
Data (inherited from Exception) |
ErrorType | Gets the error type.
ErrorValue | Get the error value.
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

See Also

WebCellException Class | Aspose.Cells.GridWeb.Data Namespace


WebCellException Properties

The properties of the WebCellException class are listed below. For a complete list of WebCellException class members, see the WebCellException Members topic.

Public Instance Properties

Cell | Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.
Data (inherited from Exception) |
ErrorType | Gets the error type.
ErrorValue | Get the error value.
HelpLink (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

See Also

WebCellException Class | Aspose.Cells.GridWeb.Data Namespace


Cell Property

Aspose.Cells for .NET

WebCellException.Cell Property

Gets the error cell. If the Cell is null, the error is cause by an CommitNewBindRow operation, that means the DataTable rejected the new created row.

public WebCell Cell {get;}

See Also

WebCellException Class | Aspose.Cells.GridWeb.Data Namespace


ErrorType Property

Aspose.Cells for .NET

WebCellException.ErrorType Property

Gets the error type.

public WebCellErrorType ErrorType {get;}

See Also

WebCellException Class | Aspose.Cells.GridWeb.Data Namespace


ErrorValue Property

Aspose.Cells for .NET

WebCellException.ErrorValue Property

Get the error value.

public string ErrorValue {get;}

See Also

WebCellException Class | Aspose.Cells.GridWeb.Data Namespace


WebCells Class

NOTE: This class is now obsolete.

This class is obsolete; use GridCells instead

For a list of all members of this type, see WebCells Members.

System.Object
Aspose.Cells.GridWeb.Data.WebCells

public class WebCells

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridCells Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebCells Members | Aspose.Cells.GridWeb.Data Namespace


WebCells Members

WebCells overview

Public Static Methods

CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.

Public Instance Properties

Count | Gets the number of cells.
Item | Overloaded. Gets Cell item within the worksheet
MaxColumn |
MaxRow |
MergedCells | Gets the collection of merged cells.
MinColumn | Min column number of cell which contains data or style.
MinRow | Min row number of cell which contains data or style.
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardWidth | Gets or sets the default column width in the worksheet,in unit of characters.

Public Instance Methods

Clear |
ClearContents | Clears contents of a range.
DeleteColumn | Deletes a column.
DeleteRow | Deletes a row.
DeleteRows | Deletes a number of rows. This method is much faster than DeleteRow when doing a batch row deleting.
Equals (inherited from Object) |
Export | Exports data in the Cells collection of a WebWorksheet to a new DataTable object
ExportArray | Exports data in the Cells collection to a two-dimension array object.
GetColumnCaption | Gets the column caption. If the caption is not set, returns empty string.
GetColumnReadonly | Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetColumnWidth | Gets the width of the specified column
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetRowCaption | Gets the row caption. If the caption is not set, returns empty string.
GetRowHeight | Gets the height of a specified row.
GetRowHiddenStatus | Get hidden status of a specified row.
GetRowOutlineLevel | Gets the outline level of the row.
GetRowReadonly | Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetType (inherited from Object) |
InsertColumn | Inserts a new column into the worksheet.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Inserts multiple rows into the worksheet.
Merge |
SetBorders | Sets borders for a cells range.
SetColumnCaption | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetColumnReadonly | Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetColumnWidth | Sets the width of the specified column.the accepted width type is Point,Pixel or Inch
SetRowCaption | Sets the caption for the row.
SetRowHeight | Sets the height of the specified row.the accepted width type is Point,Pixel or Inch
SetRowHiddenStatus | Set hidden status of a specified row.
SetRowOutlineLevel | Sets the outline level of the row.
SetRowOutlineLevelAndStatus | Sets the outline level of the row.
SetRowReadonly | Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetStyle | Overloaded. Sets the style to a specified range of cells.
Sort | Overloaded. Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.
ToString (inherited from Object) |
UnMerge | Unmerges a specified range of merged cells.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells Properties

The properties of the WebCells class are listed below. For a complete list of WebCells class members, see the WebCells Members topic.

Public Instance Properties

Count | Gets the number of cells.
Item | Overloaded. Gets Cell item within the worksheet
MaxColumn |
MaxRow |
MergedCells | Gets the collection of merged cells.
MinColumn | Min column number of cell which contains data or style.
MinRow | Min row number of cell which contains data or style.
StandardHeight | Gets or sets the default row height in this worksheet,in unit of points.
StandardWidth | Gets or sets the default column width in the worksheet,in unit of characters.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

WebCells.Count Property

Gets the number of cells.

public int Count {get;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

WebCells.Item Property

Gets Cell item within the worksheet

Overload List

Gets Cell item within the worksheet

public WebCell this[int] {get;}

Gets the Cell element at the specified cell row index and column index.

public WebCell this[int, int] {get;}

Gets the Cell element at the specified cell name.

public WebCell this[string] {get;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

WebCells.Item Property (Int32)

Gets Cell item within the worksheet

public WebCell this[
int cellIndex
] {get;}

Parameters

cellIndex
The zero based index of the element.

Property Value

The element at the specified index.

Remarks

This is the indexer for the Cells class. Gets the cell element at the specified index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

WebCells.Item Property (Int32, Int32)

Gets the Cell element at the specified cell row index and column index.

public WebCell this[
int row,
int column
] {get;}

Parameters

row
Row index.
column
Column index.

Example

[C#]

 Cells cells = excel.Worksheets[0].Cells;
 Cell cell = cells[0, 0];    //Gets the cell at "A1"

 [Visual Basic]

 Dim cells As Cells =  excel.WorkSheets(0).Cells
 Dim cell As Cell =  cells(0,0)  'Gets the cell at "A1"

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Item Overload List


Item Property (String)

Aspose.Cells for .NET

WebCells.Item Property (String)

Gets the Cell element at the specified cell name.

public WebCell this[
string cellName
] {get;}

Parameters

cellName
Cell name,including its column letter and row number, for example A5.

Example

[C#]

 Cells cells = excel.Worksheets[0].Cells;
 Cell cell = cells["A1"];    //Gets the cell at "A1"

 [Visual Basic]

 Dim cells As Cells =  excel.Worksheets(0).Cells
 Dim cell As Cell =  cells("A1")  'Gets the cell at "A1"

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Item Overload List


MaxColumn Property

Aspose.Cells for .NET

WebCells.MaxColumn Property

public int MaxColumn {get;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


MaxRow Property

Aspose.Cells for .NET

WebCells.MaxRow Property

public int MaxRow {get;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


MergedCells Property

Aspose.Cells for .NET

WebCells.MergedCells Property

Gets the collection of merged cells.

public ArrayList MergedCells {get;}

Remarks

In this collection, each item is a WebCellArea structure which represents an area of merged cells.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


MinColumn Property

Aspose.Cells for .NET

WebCells.MinColumn Property

Min column number of cell which contains data or style.

public int MinColumn {get;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


MinRow Property

Aspose.Cells for .NET

WebCells.MinRow Property

Min row number of cell which contains data or style.

public int MinRow {get;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardHeight Property

Aspose.Cells for .NET

WebCells.StandardHeight Property

Gets or sets the default row height in this worksheet,in unit of points.

public double StandardHeight {get; set;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


StandardWidth Property

Aspose.Cells for .NET

WebCells.StandardWidth Property

Gets or sets the default column width in the worksheet,in unit of characters.

public double StandardWidth {get; set;}

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells Methods

The methods of the WebCells class are listed below. For a complete list of WebCells class members, see the WebCells Members topic.

Public Static Methods

CellIndexToName | Gets cell name according to its row and column indexes.
CellNameToIndex |
ColumnIndexToName | Gets column name according to column index.
ColumnNameToIndex | Gets column index according to column name.

Public Instance Methods

Clear |
ClearContents | Clears contents of a range.
DeleteColumn | Deletes a column.
DeleteRow | Deletes a row.
DeleteRows | Deletes a number of rows. This method is much faster than DeleteRow when doing a batch row deleting.
Equals (inherited from Object) |
Export | Exports data in the Cells collection of a WebWorksheet to a new DataTable object
ExportArray | Exports data in the Cells collection to a two-dimension array object.
GetColumnCaption | Gets the column caption. If the caption is not set, returns empty string.
GetColumnReadonly | Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetColumnWidth | Gets the width of the specified column
GetEnumerator | Gets the cells enumerator
GetHashCode (inherited from Object) |
GetRowCaption | Gets the row caption. If the caption is not set, returns empty string.
GetRowHeight | Gets the height of a specified row.
GetRowHiddenStatus | Get hidden status of a specified row.
GetRowOutlineLevel | Gets the outline level of the row.
GetRowReadonly | Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
GetType (inherited from Object) |
InsertColumn | Inserts a new column into the worksheet.
InsertRow | Inserts a new row into the worksheet.
InsertRows | Inserts multiple rows into the worksheet.
Merge |
SetBorders | Sets borders for a cells range.
SetColumnCaption | Sets the caption for the column.please note this is an extension attribute and can not keep in excel file
SetColumnReadonly | Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetColumnWidth | Sets the width of the specified column.the accepted width type is Point,Pixel or Inch
SetRowCaption | Sets the caption for the row.
SetRowHeight | Sets the height of the specified row.the accepted width type is Point,Pixel or Inch
SetRowHiddenStatus | Set hidden status of a specified row.
SetRowOutlineLevel | Sets the outline level of the row.
SetRowOutlineLevelAndStatus | Sets the outline level of the row.
SetRowReadonly | Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file
SetStyle | Overloaded. Sets the style to a specified range of cells.
Sort | Overloaded. Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.
ToString (inherited from Object) |
UnMerge | Unmerges a specified range of merged cells.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.CellIndexToName Method

Gets cell name according to its row and column indexes.

public static string CellIndexToName(
int row,
int column
);

Parameters

row
Row index.
column
Column index.

Return Value

Name of cell.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.CellNameToIndex Method

public static void CellNameToIndex(
string cellName,
out int row,
out int column
);

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.Clear Method

public void Clear();

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.ClearContents Method

Clears contents of a range.

public void ClearContents(
int startRow,
int startColumn,
int endRow,
int endColumn
);

Parameters

startRow
Start row index.
startColumn
Start column index.
endRow
End row index.
endColumn
End column index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.ColumnIndexToName Method

Gets column name according to column index.

public static string ColumnIndexToName(
int column
);

Parameters

column
Column index.

Return Value

Name of column.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.ColumnNameToIndex Method

Gets column index according to column name.

public static int ColumnNameToIndex(
string columnName
);

Parameters

columnName
Column name.

Return Value

Column index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.DeleteColumn Method

Deletes a column.

public void DeleteColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.DeleteRow Method

Deletes a row.

public void DeleteRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.DeleteRows Method

Deletes a number of rows. This method is much faster than DeleteRow when doing a batch row deleting.

public void DeleteRows(
int rowIndex,
int rows
);

Parameters

rowIndex
rows

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.Export Method

Exports data in the Cells collection of a WebWorksheet to a new DataTable object

public DataTable Export(
int startRow,
int startColumn,
int rows,
int columns,
bool exportColumnName,
bool isVertical
);

Parameters

startRow
The row number of the first cell to export out.
startColumn
The column number of the first cell to export out.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
exportColumnName
Indicates whether the data in the first row are exported as the column name of the DataTable
isVertical
True if a row in Excel file represents a row in DataTable. False if a column in Excel file represents a row in DataTable.

Return Value

Exported DataTable object.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.ExportArray Method

Exports data in the Cells collection to a two-dimension array object.

public object[,] ExportArray(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
The row number of the first cell to export out.
firstColumn
The column number of the first cell to export out.
totalRows
Number of rows to be exported
totalColumns
Number of columns to be exported

Return Value

Exported cell value array object.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetColumnCaption Method

Gets the column caption. If the caption is not set, returns empty string.

public string GetColumnCaption(
int column
);

Parameters

column
Column index.

Return Value

The column caption. If the caption is not set, returns empty string.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetColumnReadonly Method

Gets if a column is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public bool GetColumnReadonly(
int columnIndex
);

Parameters

columnIndex
column index.

Return Value

If readonly returns true.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetColumnWidth Method

Gets the width of the specified column

public int GetColumnWidth(
int column
);

Parameters

column
Column index

Return Value

Width of column

Remarks

Only support UnitType.Pixel unit type.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetEnumerator Method

Gets the cells enumerator

public IEnumerator GetEnumerator();

Return Value

The cells enumertor

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetRowCaption Method

Gets the row caption. If the caption is not set, returns empty string.

public string GetRowCaption(
int row
);

Parameters

row
Row index.

Return Value

The row caption. If the caption is not set, returns empty string.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetRowHeight Method

Gets the height of a specified row.

public int GetRowHeight(
int row
);

Parameters

row
Row index

Return Value

Height of row

Remarks

Only support UnitType.Pixel unit type.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetRowHiddenStatus Method

Get hidden status of a specified row.

public bool GetRowHiddenStatus(
int row
);

Parameters

row
Row index.

Return Value

Hidden status of row.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetRowOutlineLevel Method

Gets the outline level of the row.

public int GetRowOutlineLevel(
int rowIndex
);

Parameters

rowIndex
row index.

Return Value

the outline level.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.GetRowReadonly Method

Gets if a row is readonly. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public bool GetRowReadonly(
int rowIndex
);

Parameters

rowIndex
row index.

Return Value

If readonly returns true.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.InsertColumn Method

Inserts a new column into the worksheet.

public void InsertColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.InsertRow Method

Inserts a new row into the worksheet.

public void InsertRow(
int rowIndex
);

Parameters

rowIndex
Row index.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.InsertRows Method

Inserts multiple rows into the worksheet.

public void InsertRows(
int rowIndex,
int totalRows
);

Parameters

rowIndex
Row index.
totalRows
Number of rows to be inserted.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.Merge Method

public void Merge(
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber
);

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetBorders Method

Sets borders for a cells range.

public void SetBorders(
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
SetBorderPosition position,
WebBorderStyle borderStyle
);

Parameters

firstRow
The first row number of the range(zero based).
firstColumn
The first column number of the range(zero based).
rowNumber
The rows number.
columnNumber
The columns number.
position
The border position.
borderStyle
The border style.

Example

[C#]
    GridWeb1.WebWorksheets[0].Cells.SetBorders(0, 0, 5, 8, SetBorderPosition.Outline, borderStyle1);

[VB]
    GridWeb1.WebWorksheets(0).Cells.SetBorders(0, 0, 5, 8, SetBorderPosition.Outline, borderStyle1)

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetColumnCaption Method

Sets the caption for the column.please note this is an extension attribute and can not keep in excel file

public void SetColumnCaption(
int column,
string caption
);

Parameters

column
Column index.
caption
The column caption. Pass null or empty string if you want cancel the caption.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetColumnReadonly Method

Sets a column to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public void SetColumnReadonly(
int columnIndex,
bool isReadonly
);

Parameters

columnIndex
column index.
isReadonly
true or false.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetColumnWidth Method

Sets the width of the specified column.the accepted width type is Point,Pixel or Inch

public void SetColumnWidth(
int column,
Unit width
);

Parameters

column
Column index.
width
Width of Column .

Remarks

To hide a column, sets column width to zero.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetRowCaption Method

Sets the caption for the row.

public void SetRowCaption(
int row,
string caption
);

Parameters

row
Row index.
caption
The row caption. Pass null or empty string if you want cancel the caption.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetRowHeight Method

Sets the height of the specified row.the accepted width type is Point,Pixel or Inch

public void SetRowHeight(
int row,
Unit height
);

Parameters

row
Row index.
height
Height of row.In unit of point It should be between 0 and 409.5.

Remarks

To hide a row, sets row height to zero.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetRowHiddenStatus Method

Set hidden status of a specified row.

public void SetRowHiddenStatus(
int row,
bool isHidden
);

Parameters

row
Row index.
isHidden
Hidden status of row.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetRowOutlineLevel Method

Sets the outline level of the row.

public void SetRowOutlineLevel(
int rowIndex,
int outlineLevel
);

Parameters

rowIndex
row index.
outlineLevel
outline level.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetRowOutlineLevelAndStatus Method

Sets the outline level of the row.

public void SetRowOutlineLevelAndStatus(
int rowIndex,
int outlineLevel,
bool isHidden
);

Parameters

rowIndex
row index.
outlineLevel
outline level.
isHidden
isHidden.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetRowReadonly Method

Sets a row to readonly so user can't delete it from client side. this is extended method of GridWeb specifically,it will not keep and take affect in actual excel file

public void SetRowReadonly(
int rowIndex,
bool isReadonly
);

Parameters

rowIndex
row index.
isReadonly
true or false.

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


SetStyle Method

Aspose.Cells for .NET

WebCells.SetStyle Method

Sets the style to a specified range of cells.

Overload List

Sets the style to a specified range of cells.

public void SetStyle(int,int,int,int,TableItemStyle);

Sets the style to a specified range of cells.

public void SetStyle(string,TableItemStyle);

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.SetStyle Method (Int32, Int32, Int32, Int32, TableItemStyle)

Sets the style to a specified range of cells.

public void SetStyle(
int firstRow,
int firstColumn,
int rowNumber,
int columnNumber,
TableItemStyle style
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
rowNumber
Number of rows(one based)
columnNumber
Number of columns(one based)
style
The style object to be set

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.SetStyle Overload List


WebCells.SetStyle Method (String, TableItemStyle)

Sets the style to a specified range of cells.

public void SetStyle(
string cellRange,
TableItemStyle style
);

Parameters

cellRange
The range of cells' names, like "A1:D6"
style
The style object to be set

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.SetStyle Overload List


Sort Method

Aspose.Cells for .NET

WebCells.Sort Method

Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.

Overload List

Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.

public void Sort(int,int,int,int,int);

Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.

public void Sort(int,int,int,int,int,SortOrder,SortOrientation,bool);

Sorts the datas ascend top to bottom in a range of a WebWorksheet by some field that are specifed by column indexes array.

public void Sort(int,int,int,int,int[]);

Sorts the datas ascend in a range of a WebWorksheet by some field that are specifed by indexes array.

public void Sort(int,int,int,int,int[],SortOrder[],SortOrientation,bool);

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebCells.Sort Method (Int32, Int32, Int32, Int32, Int32)

Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int index
);

Parameters

startRow
The row number of the first cell to sort.
startColumn
The column number of the first cell to sort.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
index
The column index that specifis the sort column.

Example

[C#]

GridWeb1.WebWorksheets[0].Cells.Sort(1,0,25,6,3);

[VB]

GridWeb1.WebWorksheets(0).Cells.Sort(1,0,25,6,3)

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Sort Overload List


WebCells.Sort Method (Int32, Int32, Int32, Int32, Int32, SortOrder, SortOrientation, Boolean)

Sorts the datas ascend top to bottom in a range of a WebWorksheet by specified column index.

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int index,
SortOrder sortOrder,
SortOrientation sortOrientation,
bool isCaseSensitive
);

Parameters

startRow
The row number of the first cell to sort.
startColumn
The column number of the first cell to sort.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
index
The column(or row) index that specifis the sort column(or row). If sort orientation is top to bottom, the index represents column index. If sort orientation is left to right, the index represents row index.
sortOrder
sortOrientation
isCaseSensitive
Indicates whether the sort data is case sensitive if the data is string.

Example

[C#]

GridWeb1.WebWorksheets[0].Cells.Sort(0,1,4,14,3,SortOrder.Ascending,SortOrientation.SortLeftToRight,true)

[VB]

GridWeb1.WebWorksheets(0).Cells.Sort(0,1,4,14,3,SortOrder.Ascending,SortOrientation.SortLeftToRight,True)

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Sort Overload List


WebCells.Sort Method (Int32, Int32, Int32, Int32, Int32[])

Sorts the datas ascend top to bottom in a range of a WebWorksheet by some field that are specifed by column indexes array.

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int[] indexes
);

Parameters

startRow
The row number of the first cell to sort.
startColumn
The column number of the first cell to sort.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
indexes
The column indexes array that specifies the data sorted by.

Example

[C#]

 int[] indexes = new int[3];
 indexes[0] = 0;
 indexes[1] = 2;
 indexes[2] = 3;
 GridWeb1.WebWorksheets[0].Cells.Sort(1,0,25,6,indexes);

 [VB]

 Dim indexes() As Integer =  New Integer(3) {}
 indexes(0) = 0
 indexes(1) = 2
 indexes(2) = 3
 GridWeb1.WebWorksheets(0).Cells.Sort(1,0,25,6,indexes)

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Sort Overload List


WebCells.Sort Method (Int32, Int32, Int32, Int32, Int32[], SortOrder[], SortOrientation, Boolean)

Sorts the datas ascend in a range of a WebWorksheet by some field that are specifed by indexes array.

public void Sort(
int startRow,
int startColumn,
int rows,
int columns,
int[] indexes,
SortOrder[] orders,
SortOrientation orientation,
bool isCaseSensitive
);

Parameters

startRow
The row number of the first cell to sort.
startColumn
The column number of the first cell to sort.
rows
Number of rows to be imported.
columns
Number of columns to be imported.
indexes
The column(or row) index that specifis the sort column(or row). If sort orientation is top to bottom, the index represents column index. If sort orientation is left to right, the index represents row index.
orders
The sort order:Ascending or Descending
orientation
The sort orientation: top to bottom or left to right.
isCaseSensitive
Indicates whether the sorting is case sensitive.

Remarks

If you use this method to sort a block of data, please be sure that length of the parameter indexes equals length of the parameter orders.

Example

 [C#] int[] indexes = new int[3]; indexes[0] = 0; indexes[1] = 1; indexes[2] = 3; SortOrder[] orders = new SortOrder[3]; orders[0] = SortOrder.Ascending; orders[1] = SortOrder.Descending; orders[2] = SortOrder.Descending; GridWeb1.WebWorksheets[0].Cells.Sort(0,1,4,14,indexes,orders,SortOrientation.SortLeftToRight,false); [VB] Dim indexes() As Integer = New Integer(3) {} indexes(0) = 0 indexes(1) = 1 indexes(2) = 3 Dim orders() As SortOrder = New SortOrder(3) {} orders(0) = SortOrder.Ascending orders(1) = SortOrder.Descending orders(2) = SortOrder.Descending GridWeb1.WebWorksheets(0).Cells.Sort(0,1,4,14,indexes,orders,SortOrientation.SortLeftToRight,False)
See Also
WebCells Class | Aspose.Cells.GridWeb.Data Namespace | WebCells.Sort Overload List


WebCells.UnMerge Method

Unmerges a specified range of merged cells.

public void UnMerge(
int firstRow,
int firstColumn,
int totalRows,
int totalColumns
);

Parameters

firstRow
First row of this range(zero based)
firstColumn
First column of this range(zero based)
totalRows
Number of rows(one based)
totalColumns
Number of columns(one based)

See Also

WebCells Class | Aspose.Cells.GridWeb.Data Namespace


WebComment Class

NOTE: This class is now obsolete.

This class is obsolete; use GridComment instead

For a list of all members of this type, see WebComment Members.

System.Object
Aspose.Cells.GridWeb.Data.WebComment

public class WebComment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridComment Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebComment Members | Aspose.Cells.GridWeb.Data Namespace


WebComment Members

WebComment overview

Public Instance Properties

Note

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebComment Class | Aspose.Cells.GridWeb.Data Namespace


WebComment Properties

The properties of the WebComment class are listed below. For a complete list of WebComment class members, see the WebComment Members topic.

Public Instance Properties

Note

See Also

WebComment Class | Aspose.Cells.GridWeb.Data Namespace


Note Property

Aspose.Cells for .NET

WebComment.Note Property

public string Note {get; set;}

See Also

WebComment Class | Aspose.Cells.GridWeb.Data Namespace


WebComments Class

NOTE: This class is now obsolete.

This class is obsolete; use GridCommentCollection instead

For a list of all members of this type, see WebComments Members.

System.Object
Aspose.Cells.GridWeb.Data.WebComments

public class WebComments

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridCommentCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebComments Members | Aspose.Cells.GridWeb.Data Namespace


WebComments Members

WebComments overview

Public Instance Methods

AddComment
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveComment
ToString (inherited from Object)

See Also

WebComments Class | Aspose.Cells.GridWeb.Data Namespace


WebComments Methods

The methods of the WebComments class are listed below. For a complete list of WebComments class members, see the WebComments Members topic.

Public Instance Methods

AddComment
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveComment
ToString (inherited from Object)

See Also

WebComments Class | Aspose.Cells.GridWeb.Data Namespace


WebComments.AddComment Method

public WebComment AddComment(
WebCell cell
);

See Also

WebComments Class | Aspose.Cells.GridWeb.Data Namespace


WebComments.RemoveComment Method

public void RemoveComment(
WebCell cell
);

See Also

WebComments Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet Class

NOTE: This class is now obsolete.

This class is obsolete; use GridWorksheet instead

Represents a web worksheet.

For a list of all members of this type, see WebWorksheet Members.

System.Object
System.Web.UI.Control
Aspose.Cells.GridWeb.Data.WebWorksheet
Aspose.Cells.GridWeb.WorksheetDesign

public class WebWorksheet : Control, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridWorksheet Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Example

[C#]
 ...
 using System.Web.UI.WebControls;
 ...
 ...

 WebWorksheets Worksheets = GridWeb1.WebWorksheets;
    WebCells cells = Worksheets[0].Cells;

    //Sets default row height
    cells.StandardHeight = new Unit(16, UnitType.Point);
    //Sets row height
    cells.SetRowHeight(2, new Unit(20, UnitType.Point));

    //Sets default colum width
    cells.StandardWidth = new Unit(50, UnitType.Point);
    //Sets column width
    cells.SetColumnWidth(3, new Unit(80, UnitType.Point));

    //Merge cells
    cells.Merge(5, 4, 2, 2);

    //Import data
    DataSet1 ds1 = new DataSet1();

    for (int i =0; i<16; i++)
    {
        DataSet1.Table1Row row = ds1.Table1.NewTable1Row();
        row["c1"] = "hello1";
        row["c2"] = i;
        row["c3"] = "data";
        ds1.Table1.AddTable1Row(row);
    }

    GridWeb1.WebWorksheets.ImportDataView(ds1.Table1.DefaultView, null, null);

 //Import from excel file
 Worksheets.ImportExcelFile("c:\\file1.xls");

 [Visual Basic]
    Imports System.Web.UI.WebControls
    ...
    ...

    Dim Worksheets As WebWorksheets =  GridWeb1.WebWorksheets
    Dim cells As WebCells =  Worksheets(0).Cells

    'Sets default row height
    cells.StandardHeight = New Unit(16, UnitType.Point)
    'Sets row height
    cells.SetRowHeight(2,New Unit(20,UnitType.Point))

    'Sets default colum width
    cells.StandardWidth = New Unit(50, UnitType.Point)
    'Sets column width
    cells.SetColumnWidth(3,New Unit(80,UnitType.Point))

    'Merge cells
    cells.Merge(5, 4, 2, 2)

    'Import data
    Dim ds1 As DataSet1 =  New DataSet1()

    Dim i As Integer
    For  i = 0 To 15
        Dim row As DataSet1.Table1Row =  ds1.Table1.NewTable1Row()
        row("c1") = "hello1"
        row("c2") = i
        row("c3") = "data"
        ds1.Table1.AddTable1Row(row)
    Next

    GridWeb1.WebWorksheets.ImportDataView(ds1.Table1.DefaultView, Nothing, Nothing)

    'Import from excel file
    Worksheets.ImportExcelFile("c:\\file1.xls")

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebWorksheet Members | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet Members

WebWorksheet overview

Public Instance Constructors

WebWorksheet Overloaded. Initializes a new instance of the WebWorksheet class.

Public Instance Properties

AppRelativeTemplateSourceDirectory (inherited from Control) |
BindColumns | Bind columns collection.
BindingContainer (inherited from Control) |
BindingSource | The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.
BindStartColumn | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
BindStartRow | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
CellImages |
Cells | Gets the WebCells.
ClientID (inherited from Control) |
Comments |
Controls (inherited from Control) |
CurrentBindRows | Gets the binding rows number in data-binding mode.
DataMember | Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.
DataSource | Gets or sets the DataSource. Generally it's a DataSet object.
EnableCreateBindColumnHeader | In data-binding mode, indicates whether to create bind column header captions in the sheet.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
Hyperlinks | Gets the HyperlinkCollection collection.
ID (inherited from Control) |
Index | Gets the index of itself within the WebWorksheets.
IsProtected | Gets or sets whether the worksheet is protected. When a worksheet is protected, all the cells can not be edit except the cell whose IsLocked property is false.
Name | Gets or sets the name of the sheet.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
RowFilter |
Site (inherited from Control) |
SkinID (inherited from Control) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Validations | Gets the data validation setting collection in the worksheet.
Visible | Indicates whether this sheet's name is shown in the sheet tabs of the control.

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
AutoFitColumn | Overloaded. Autofits the column width. This method autofits a column based on content in a range of cells within the column from startRow to endRow. AutoFitColumn is an imprecise function.
CancelNewBindRow | Cancels and deletes the new added bind row.
CommitNewBindRow | Commits the new added bind row and add it to the datasource.
Copy | Copies from another worksheet object.
CreateAutoGenratedColumns | After setting a datasource for the worksheet, call this method to generate the bind columns automatically.
CreateNewBindRow | Creates a new bind row and bind to the datasource.
CreateSubtotal | Creates subtotal in the sheet.
DataBind | Bind the sheet to the DataSource.
DataSourceControlUpdate |
DeleteBindRow | Deletes a bind row.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
FreezePanes |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GroupRows | Overloaded. Groups rows.
HasControls (inherited from Control) |
RemoveSubtotal |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAllCellsEditable |
SetAllCellsReadonly |
SetEditableRange | Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable
SetReadonlyRange | Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
UnfreezePanes |
UngroupRows |
UpdateBindCellValue | Updates the binding datasource record's property value according to the cell's value.

Public Instance Events

DataBinding (inherited from Control)
Disposed (inherited from Control)
Init (inherited from Control)
Load (inherited from Control)
PreRender (inherited from Control)
Unload (inherited from Control)

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet Constructor

Overload List

Initializes a new instance of the WebWorksheet class.

public WebWorksheet();

public WebWorksheet(MainWeb,GridWorksheet);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet Constructor (MainWeb, GridWorksheet)

public WebWorksheet(
MainWeb mw,
GridWorksheet gwk
);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheet Constructor Overload List


WebWorksheet Constructor ()

Initializes a new instance of the WebWorksheet class.

public WebWorksheet();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheet Constructor Overload List


WebWorksheet Properties

The properties of the WebWorksheet class are listed below. For a complete list of WebWorksheet class members, see the WebWorksheet Members topic.

Public Instance Properties

AppRelativeTemplateSourceDirectory (inherited from Control) |
BindColumns | Bind columns collection.
BindingContainer (inherited from Control) |
BindingSource | The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.
BindStartColumn | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
BindStartRow | In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.
CellImages |
Cells | Gets the WebCells.
ClientID (inherited from Control) |
Comments |
Controls (inherited from Control) |
CurrentBindRows | Gets the binding rows number in data-binding mode.
DataMember | Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.
DataSource | Gets or sets the DataSource. Generally it's a DataSet object.
EnableCreateBindColumnHeader | In data-binding mode, indicates whether to create bind column header captions in the sheet.
EnableTheming (inherited from Control) |
EnableViewState (inherited from Control) |
Hyperlinks | Gets the HyperlinkCollection collection.
ID (inherited from Control) |
Index | Gets the index of itself within the WebWorksheets.
IsProtected | Gets or sets whether the worksheet is protected. When a worksheet is protected, all the cells can not be edit except the cell whose IsLocked property is false.
Name | Gets or sets the name of the sheet.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
RowFilter |
Site (inherited from Control) |
SkinID (inherited from Control) |
TemplateControl (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Validations | Gets the data validation setting collection in the worksheet.
Visible | Indicates whether this sheet's name is shown in the sheet tabs of the control.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindColumns Property

Aspose.Cells for .NET

WebWorksheet.BindColumns Property

Bind columns collection.

public BindColumnCollection BindColumns {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindingSource Property

Aspose.Cells for .NET

WebWorksheet.BindingSource Property

The actually binding datasource object at run-time. It is a DataView object when the DataSource property is a DataSet, DataTable or DataView object.

public IEnumerable BindingSource {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindStartColumn Property

Aspose.Cells for .NET

WebWorksheet.BindStartColumn Property

In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.

public int BindStartColumn {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


BindStartRow Property

Aspose.Cells for .NET

WebWorksheet.BindStartRow Property

In data-binding mode, BindStartRow and BindStartColumn indicate the position of the grid to bind bo the datasource.

public int BindStartRow {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


CellImages Property

Aspose.Cells for .NET

WebWorksheet.CellImages Property

public Hyperlinks CellImages {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Cells Property

Aspose.Cells for .NET

WebWorksheet.Cells Property

Gets the WebCells.

public WebCells Cells {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Comments Property

Aspose.Cells for .NET

WebWorksheet.Comments Property

public WebComments Comments {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


CurrentBindRows Property

Aspose.Cells for .NET

WebWorksheet.CurrentBindRows Property

Gets the binding rows number in data-binding mode.

public int CurrentBindRows {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


DataMember Property

Aspose.Cells for .NET

WebWorksheet.DataMember Property

Gets or sets the DataMember from the multi-member DataSource. Generally it represents a DataTable object of a DataSet.

public string DataMember {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


DataSource Property

Aspose.Cells for .NET

WebWorksheet.DataSource Property

Gets or sets the DataSource. Generally it's a DataSet object.

public object DataSource {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


EnableCreateBindColumnHeader Property

Aspose.Cells for .NET

WebWorksheet.EnableCreateBindColumnHeader Property

In data-binding mode, indicates whether to create bind column header captions in the sheet.

public bool EnableCreateBindColumnHeader {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Hyperlinks Property

Aspose.Cells for .NET

WebWorksheet.Hyperlinks Property

Gets the HyperlinkCollection collection.

public Hyperlinks Hyperlinks {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Index Property

Aspose.Cells for .NET

WebWorksheet.Index Property

Gets the index of itself within the WebWorksheets.

public int Index {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


IsProtected Property

Aspose.Cells for .NET

WebWorksheet.IsProtected Property

Gets or sets whether the worksheet is protected. When a worksheet is protected, all the cells can not be edit except the cell whose IsLocked property is false.

public bool IsProtected {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Name Property

Aspose.Cells for .NET

WebWorksheet.Name Property

Gets or sets the name of the sheet.

public string Name {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


RowFilter Property

Aspose.Cells for .NET

WebWorksheet.RowFilter Property

public RowFilterSettings RowFilter {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Validations Property

Aspose.Cells for .NET

WebWorksheet.Validations Property

Gets the data validation setting collection in the worksheet.

public GridValidationCollection Validations {get;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


Visible Property

Aspose.Cells for .NET

WebWorksheet.Visible Property

Indicates whether this sheet's name is shown in the sheet tabs of the control.

public override bool Visible {get; set;}

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet Methods

The methods of the WebWorksheet class are listed below. For a complete list of WebWorksheet class members, see the WebWorksheet Members topic.

Public Instance Methods

ApplyStyleSheetSkin (inherited from Control) |
AutoFitColumn | Overloaded. Autofits the column width. This method autofits a column based on content in a range of cells within the column from startRow to endRow. AutoFitColumn is an imprecise function.
CancelNewBindRow | Cancels and deletes the new added bind row.
CommitNewBindRow | Commits the new added bind row and add it to the datasource.
Copy | Copies from another worksheet object.
CreateAutoGenratedColumns | After setting a datasource for the worksheet, call this method to generate the bind columns automatically.
CreateNewBindRow | Creates a new bind row and bind to the datasource.
CreateSubtotal | Creates subtotal in the sheet.
DataBind | Bind the sheet to the DataSource.
DataSourceControlUpdate |
DeleteBindRow | Deletes a bind row.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
Focus (inherited from Control) |
FreezePanes |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GroupRows | Overloaded. Groups rows.
HasControls (inherited from Control) |
RemoveSubtotal |
RenderControl (inherited from Control) |
ResolveClientUrl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAllCellsEditable |
SetAllCellsReadonly |
SetEditableRange | Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable
SetReadonlyRange | Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
UnfreezePanes |
UngroupRows |
UpdateBindCellValue | Updates the binding datasource record's property value according to the cell's value.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


AutoFitColumn Method

Aspose.Cells for .NET

WebWorksheet.AutoFitColumn Method

Autofits the column width.

Overload List

Autofits the column width.

public void AutoFitColumn(int);

Autofits the column width. This method autofits a column based on content in a range of cells within the column from startRow to endRow. AutoFitColumn is an imprecise function.

public void AutoFitColumn(int,int,int);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.AutoFitColumn Method (Int32)

Autofits the column width.

public void AutoFitColumn(
int columnIndex
);

Parameters

columnIndex
Column index.

Remarks

AutoFitColumn is an imprecise function.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheet.AutoFitColumn Overload List


WebWorksheet.AutoFitColumn Method (Int32, Int32, Int32)

Autofits the column width. This method autofits a column based on content in a range of cells within the column from startRow to endRow. AutoFitColumn is an imprecise function.

public void AutoFitColumn(
int columnIndex,
int startRow,
int endRow
);

Parameters

columnIndex
column index, zero based
startRow
start row index, zero based
endRow
end row index, zero based

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheet.AutoFitColumn Overload List


WebWorksheet.CancelNewBindRow Method

Cancels and deletes the new added bind row.

public int CancelNewBindRow();

Return Value

The row index. If there is no new created bind row, returns -1.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.CommitNewBindRow Method

Commits the new added bind row and add it to the datasource.

public int CommitNewBindRow();

Return Value

The row index of the new row. If no row is created, returns -1.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.Copy Method

Copies from another worksheet object.

public void Copy(
WebWorksheet source
);

Parameters

source
The other sheet.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.CreateAutoGenratedColumns Method

After setting a datasource for the worksheet, call this method to generate the bind columns automatically.

public void CreateAutoGenratedColumns();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.CreateNewBindRow Method

Creates a new bind row and bind to the datasource.

public int CreateNewBindRow();

Return Value

The row index of the new row. If no row is created, returns -1.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.CreateSubtotal Method

Creates subtotal in the sheet.

public void CreateSubtotal(
int columnNameRowIndex,
int dataRows,
int groupByColumnIndex,
SubtotalFunction subtotalFunction,
int[] subtotalColumnIndexList,
string functionLabel,
TableItemStyle grandCellStyle,
TableItemStyle subtotalCellStyle,
NumberType numberType,
string customString
);

Parameters

columnNameRowIndex
The row index of the column name row.
dataRows
The number of the data rows.
groupByColumnIndex
The column index of the column to be grouped.
subtotalFunction
The subtotal function type.
subtotalColumnIndexList
The column indexes to be subtotaled.
functionLabel
The label of subtotal function.
grandCellStyle
The style of the grand total line.
subtotalCellStyle
The style of the subtotal line.
numberType
The number type of the subtotal result cells.
customString
The custome format string of the subtotal result cells. Can be null.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.DataBind Method

Bind the sheet to the DataSource.

public override void DataBind();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.DataSourceControlUpdate Method

public void DataSourceControlUpdate(
AccessDataSource AccessDataSource1
);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.DeleteBindRow Method

Deletes a bind row.

public int DeleteBindRow(
int rowNum
);

Parameters

rowNum
The row index.

Return Value

The deleted row index. If no bind row is deleted, returns -1.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.FreezePanes Method

public void FreezePanes(
int row,
int column,
int freezedRows,
int freezedColumns
);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


GroupRows Method

Aspose.Cells for .NET

WebWorksheet.GroupRows Method

Groups rows.

Overload List

Groups rows.

public void GroupRows(int,int);

Groups rows.

public void GroupRows(int,int,bool);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.GroupRows Method (Int32, Int32)

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheet.GroupRows Overload List


WebWorksheet.GroupRows Method (Int32, Int32, Boolean)

Groups rows.

public void GroupRows(
int firstIndex,
int lastIndex,
bool isHidden
);

Parameters

firstIndex
The first row index to be grouped.
lastIndex
The last row index to be grouped.
isHidden
Specifies if the grouped rows are hidden.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheet.GroupRows Overload List


WebWorksheet.RemoveSubtotal Method

public void RemoveSubtotal();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.SetAllCellsEditable Method

public void SetAllCellsEditable();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.SetAllCellsReadonly Method

public void SetAllCellsReadonly();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.SetEditableRange Method

Makes a range of cells editable. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells Make all cells read only by calling the SetAllCellsReadonly method. then call this method to Specify the range of cells that to be editable

public void SetEditableRange(
int startRow,
int startColumn,
int rows,
int columns
);

Parameters

startRow
The start row of the range.
startColumn
The start column of the range.
rows
The number of the rows.
columns
The number of the columns.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.SetReadonlyRange Method

Makes a range of cells readonly. http://docs.aspose.com:8082/docs/display/cellsnet/Protecting+Cells First make all cells editable by calling the SetAllCellsEditable method. then call this method to Specify the range of cells that to be readonly

public void SetReadonlyRange(
int startRow,
int startColumn,
int rows,
int columns
);

Parameters

startRow
The start row of the range.
startColumn
The start column of the range.
rows
The number of the rows.
columns
The number of the columns.

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.UnfreezePanes Method

public void UnfreezePanes();

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.UngroupRows Method

public void UngroupRows(
int firstIndex,
int lastIndex
);

See Also

WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheet.UpdateBindCellValue Method

Updates the binding datasource record's property value according to the cell's value.

public void UpdateBindCellValue(
GridCell cell
);

Parameters

cell
The cell object.

Example

See Also
WebWorksheet Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets Class

NOTE: This class is now obsolete.

This class is obsolete; use GridWorksheetCollection instead

For a list of all members of this type, see WebWorksheets Members.

System.Object
Aspose.Cells.GridWeb.Data.WebWorksheets

public class WebWorksheets : ICollection, IEnumerable, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

NOTE: This class is now obsolete. please use GridWorksheetCollection Instead. This class will be removed after 6 months since Aug. 2014. Aspose apologizes for any inconvenience you may have experienced.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

WebWorksheets Members | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets Members

WebWorksheets overview

Public Instance Constructors

WebWorksheets Constructor

Public Instance Properties

ActiveSheet |
ActiveSheetIndex |
Count |
DefaultFontName |
DefaultFontSize |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating if access to the ICollection is synchronized (thread-safe).
Item | Overloaded. Gets the Worksheet element at the specified index.
PivotCaches | Gets the PivotCache collection object
PivotTables | Gets the pivotTable collection object.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
Clear | Clear all worksheets.
Contains | Indicates whether the collection contains the sheet.
CopyTo | Copys contents to an array.
Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ImportDataView | Overloaded. Imports from a DataView. Creates a sheet with the DataView's table name automatically.
ImportExcelFile | Overloaded. Imports from an excel file stream, including disk file stream or memory stream.
IndexOf | Gets the index of the sheet.
Insert | Inserts a sheet to the index.
LoadCSVFile | Overloaded. Loads data from a CSV file.
LoadHTMLFile | Overloaded. Loads data from a HTML file.
LoadSpreadSheetMLFile | Overloaded. Loads data from a SpreadSheetML file.
Remove | Removes a sheet.
RemoveAt | Overloaded. Removes a sheet at the index.
RunAllFormulas | Runs all the cells's formula.
SaveCSVFile | Overloaded. Saves data to a CSV file.
SaveHTMLFile | Overloaded. Saves data to a HTML file.
SaveSpreadSheetMLFile | Overloaded. Saves data to a SpreadSheetML file.
SaveToExcelFile | Overloaded. Saves the worksheets to an excel file with Excel 2003 format.
ToString (inherited from Object) |

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets Constructor

public WebWorksheets(
MainWeb mw,
GridWorksheetCollection gw
);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets Properties

The properties of the WebWorksheets class are listed below. For a complete list of WebWorksheets class members, see the WebWorksheets Members topic.

Public Instance Properties

ActiveSheet |
ActiveSheetIndex |
Count |
DefaultFontName |
DefaultFontSize |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating if access to the ICollection is synchronized (thread-safe).
Item | Overloaded. Gets the Worksheet element at the specified index.
PivotCaches | Gets the PivotCache collection object
PivotTables | Gets the pivotTable collection object.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


ActiveSheet Property

Aspose.Cells for .NET

WebWorksheets.ActiveSheet Property

public WebWorksheet ActiveSheet {get;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


ActiveSheetIndex Property

Aspose.Cells for .NET

WebWorksheets.ActiveSheetIndex Property

public int ActiveSheetIndex {get; set;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


Count Property

Aspose.Cells for .NET

WebWorksheets.Count Property

public int Count {get;}

Implements

ICollection.Count

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


DefaultFontName Property

Aspose.Cells for .NET

WebWorksheets.DefaultFontName Property

public string DefaultFontName {get; set;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


DefaultFontSize Property

Aspose.Cells for .NET

WebWorksheets.DefaultFontSize Property

public FontUnit DefaultFontSize {get; set;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


IsFixedSize Property

Aspose.Cells for .NET

WebWorksheets.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public bool IsFixedSize {get;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


IsReadOnly Property

Aspose.Cells for .NET

WebWorksheets.IsReadOnly Property

Gets a value indicating whether the IList is read-only.

public bool IsReadOnly {get;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


IsSynchronized Property

Aspose.Cells for .NET

WebWorksheets.IsSynchronized Property

Gets a value indicating if access to the ICollection is synchronized (thread-safe).

public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


Item Property

Aspose.Cells for .NET

WebWorksheets.Item Property

Gets the Worksheet element at the specified index.

Overload List

Gets the Worksheet element at the specified index.

public WebWorksheet this[int] {get;}

Gets the Worksheet element at the specified index.

public WebWorksheet this[string] {get;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


Item Property (Int32)

Aspose.Cells for .NET

WebWorksheets.Item Property (Int32)

Gets the Worksheet element at the specified index.

public WebWorksheet this[
int index
] {get;}

Parameters

index
The zero based index of the element.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.Item Overload List


Item Property (String)

Aspose.Cells for .NET

WebWorksheets.Item Property (String)

Gets the Worksheet element at the specified index.

public WebWorksheet this[
string sheetName
] {get;}

Parameters

sheetName

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.Item Overload List


PivotCaches Property

Aspose.Cells for .NET

WebWorksheets.PivotCaches Property

Gets the PivotCache collection object

public PivotCaches PivotCaches {get;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


PivotTables Property

Aspose.Cells for .NET

WebWorksheets.PivotTables Property

Gets the pivotTable collection object.

public PivotTables PivotTables {get;}

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


SyncRoot Property

Aspose.Cells for .NET

WebWorksheets.SyncRoot Property

Gets an object that can be used to synchronize access to the ICollection.

public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets Methods

The methods of the WebWorksheets class are listed below. For a complete list of WebWorksheets class members, see the WebWorksheets Members topic.

Public Instance Methods

Add | Overloaded. Adds a worksheet to the collection.
AddCopy | Overloaded. Adds a worksheet to the collection and copies data from an existed worksheet.
Clear | Clear all worksheets.
Contains | Indicates whether the collection contains the sheet.
CopyTo | Copys contents to an array.
Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ImportDataView | Overloaded. Imports from a DataView. Creates a sheet with the DataView's table name automatically.
ImportExcelFile | Overloaded. Imports from an excel file stream, including disk file stream or memory stream.
IndexOf | Gets the index of the sheet.
Insert | Inserts a sheet to the index.
LoadCSVFile | Overloaded. Loads data from a CSV file.
LoadHTMLFile | Overloaded. Loads data from a HTML file.
LoadSpreadSheetMLFile | Overloaded. Loads data from a SpreadSheetML file.
Remove | Removes a sheet.
RemoveAt | Overloaded. Removes a sheet at the index.
RunAllFormulas | Runs all the cells's formula.
SaveCSVFile | Overloaded. Saves data to a CSV file.
SaveHTMLFile | Overloaded. Saves data to a HTML file.
SaveSpreadSheetMLFile | Overloaded. Saves data to a SpreadSheetML file.
SaveToExcelFile | Overloaded. Saves the worksheets to an excel file with Excel 2003 format.
ToString (inherited from Object) |

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


Add Method

Aspose.Cells for .NET

WebWorksheets.Add Method

Adds a worksheet to the collection.

Overload List

Adds a worksheet to the collection.

public int Add();

Adds a sheet object.

public int Add(object);

Adds a worksheet to the collection.

public int Add(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.Add Method ()

Adds a worksheet to the collection.

public int Add();

Return Value

Worksheet object index.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.Add Overload List


WebWorksheets.Add Method (Object)

Adds a sheet object.

public int Add(
object value
);

Parameters

value
The sheet.

Return Value

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.Add Overload List


WebWorksheets.Add Method (String)

Adds a worksheet to the collection.

public int Add(
string sheetName
);

Parameters

sheetName
Worksheet name

Return Value

Worksheet object.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.Add Overload List


AddCopy Method

Aspose.Cells for .NET

WebWorksheets.AddCopy Method

Adds a worksheet to the collection and copys data from an existed worksheet.

Overload List

Adds a worksheet to the collection and copys data from an existed worksheet.

public int AddCopy(WebWorksheet);

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(int);

Adds a worksheet to the collection and copys data from an existed worksheet.

public int AddCopy(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.AddCopy Method (WebWorksheet)

Adds a worksheet to the collection and copys data from an existed worksheet.

public int AddCopy(
WebWorksheet srcSheet
);

Parameters

srcSheet
Source of WebWorksheet.

Return Value

WebWorksheet object index.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.AddCopy Overload List


WebWorksheets.AddCopy Method (Int32)

Adds a worksheet to the collection and copies data from an existed worksheet.

public int AddCopy(
int sheetIndex
);

Parameters

sheetIndex
Index of source worksheet.

Return Value

Worksheet object index.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.AddCopy Overload List


WebWorksheets.AddCopy Method (String)

Adds a worksheet to the collection and copys data from an existed worksheet.

public int AddCopy(
string sheetName
);

Parameters

sheetName
Name of source worksheet.

Return Value

WebWorksheet object index.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.AddCopy Overload List


WebWorksheets.Clear Method

Clear all worksheets.

public void Clear();

Remarks

A workbook must contains a worksheet.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.Contains Method

Indicates whether the collection contains the sheet.

public bool Contains(
object value
);

Parameters

value
The sheet.

Return Value

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.CopyTo Method

Copys contents to an array.

public void CopyTo(
Array array,
int index
);

Parameters

array
An array.
index
Index of the array.

Implements

ICollection.CopyTo

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


ImportDataView Method

Aspose.Cells for .NET

WebWorksheets.ImportDataView Method

Imports from a DataView. Creates a sheet with the DataView's table name automatically.

Overload List

Imports from a DataView. Creates a sheet with the DataView's table name automatically.

public void ImportDataView(DataView,TableItemStyle,TableItemStyle);

Imports from a DataView to the specified sheet and position.

public void ImportDataView(DataView,TableItemStyle,TableItemStyle,string,int,int);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.ImportDataView Method (DataView, TableItemStyle, TableItemStyle)

Imports from a DataView. Creates a sheet with the DataView's table name automatically.

public void ImportDataView(
DataView dataView,
TableItemStyle colHeaderStyle,
TableItemStyle dataStyle
);

Parameters

dataView
The DataView object.
colHeaderStyle
Specifies the style of the dataview header bar.
dataStyle
Specifies the style of the data area.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.ImportDataView Overload List


WebWorksheets.ImportDataView Method (DataView, TableItemStyle, TableItemStyle, String, Int32, Int32)

Imports from a DataView to the specified sheet and position.

public void ImportDataView(
DataView dataView,
TableItemStyle colHeaderStyle,
TableItemStyle dataStyle,
string sheetName,
int row,
int column
);

Parameters

dataView
The DataView object.
colHeaderStyle
Specifies the style of the dataview header bar.
dataStyle
Specifies the style of the data area.
sheetName
Specifies the sheet name. If the sheet doesn't exist, it will be created for you.
row
Specifies the import position.
column
Specifies the import postion.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.ImportDataView Overload List


ImportExcelFile Method

Aspose.Cells for .NET

WebWorksheets.ImportExcelFile Method

Imports from an excel file stream, including disk file stream or memory stream.

Overload List

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(Stream);

Imports from an excel file.

public void ImportExcelFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.ImportExcelFile Method (Stream)

Imports from an excel file stream, including disk file stream or memory stream.

public void ImportExcelFile(
Stream stream
);

Parameters

stream
The excel file's stream, including disk file stream or memory stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.ImportExcelFile Overload List


WebWorksheets.ImportExcelFile Method (String)

Imports from an excel file.

public void ImportExcelFile(
string fileName
);

Parameters

fileName
The excel file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.ImportExcelFile Overload List


WebWorksheets.IndexOf Method

Gets the index of the sheet.

public int IndexOf(
object value
);

Parameters

value
The sheet.

Return Value

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.Insert Method

Inserts a sheet to the index.

public void Insert(
int index,
string sheetName
);

Parameters

index
The index.
sheetName
the sheet name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


LoadCSVFile Method

Aspose.Cells for .NET

WebWorksheets.LoadCSVFile Method

Loads data from a CSV file stream.

Overload List

Loads data from a CSV file stream.

public void LoadCSVFile(Stream);

Loads data from a CSV file.

public void LoadCSVFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.LoadCSVFile Method (Stream)

Loads data from a CSV file stream.

public void LoadCSVFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.LoadCSVFile Overload List


WebWorksheets.LoadCSVFile Method (String)

Loads data from a CSV file.

public void LoadCSVFile(
string fileName
);

Parameters

fileName
The file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.LoadCSVFile Overload List


LoadHTMLFile Method

Aspose.Cells for .NET

WebWorksheets.LoadHTMLFile Method

Loads data from a HTML file stream.

Overload List

Loads data from a HTML file stream.

public void LoadHTMLFile(Stream);

Loads data from a HTML file.

public void LoadHTMLFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.LoadHTMLFile Method (Stream)

Loads data from a HTML file stream.

public void LoadHTMLFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.LoadHTMLFile Overload List


WebWorksheets.LoadHTMLFile Method (String)

Loads data from a HTML file.

public void LoadHTMLFile(
string fileName
);

Parameters

fileName
The file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.LoadHTMLFile Overload List


LoadSpreadSheetMLFile Method

Aspose.Cells for .NET

WebWorksheets.LoadSpreadSheetMLFile Method

Loads data from a SpreadSheetML file stream.

Overload List

Loads data from a SpreadSheetML file stream.

public void LoadSpreadSheetMLFile(Stream);

Loads data from a SpreadSheetML file.

public void LoadSpreadSheetMLFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.LoadSpreadSheetMLFile Method (Stream)

Loads data from a SpreadSheetML file stream.

public void LoadSpreadSheetMLFile(
Stream stream
);

Parameters

stream
The file's stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.LoadSpreadSheetMLFile Overload List


WebWorksheets.LoadSpreadSheetMLFile Method (String)

Loads data from a SpreadSheetML file.

public void LoadSpreadSheetMLFile(
string fileName
);

Parameters

fileName
The file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.LoadSpreadSheetMLFile Overload List


WebWorksheets.Remove Method

Removes a sheet.

public void Remove(
object value
);

Parameters

value
The sheet.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


RemoveAt Method

Aspose.Cells for .NET

WebWorksheets.RemoveAt Method

Removes a sheet at the index.

Overload List

Removes a sheet at the index.

public void RemoveAt(int);

Removes the element at a specified name.

public void RemoveAt(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.RemoveAt Method (Int32)

Removes a sheet at the index.

public void RemoveAt(
int index
);

Parameters

index
The sheet index.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.RemoveAt Overload List


WebWorksheets.RemoveAt Method (String)

Removes the element at a specified name.

public void RemoveAt(
string sheetName
);

Parameters

sheetName
The name of the element to remove.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.RemoveAt Overload List


WebWorksheets.RunAllFormulas Method

Runs all the cells's formula.

public void RunAllFormulas();

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


SaveCSVFile Method

Aspose.Cells for .NET

WebWorksheets.SaveCSVFile Method

Saves data to a CSV file stream.

Overload List

Saves data to a CSV file stream.

public void SaveCSVFile(Stream);

Saves data to a CSV file.

public void SaveCSVFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.SaveCSVFile Method (Stream)

Saves data to a CSV file stream.

public void SaveCSVFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveCSVFile Overload List


WebWorksheets.SaveCSVFile Method (String)

Saves data to a CSV file.

public void SaveCSVFile(
string targetFile
);

Parameters

targetFile
The file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveCSVFile Overload List


SaveHTMLFile Method

Aspose.Cells for .NET

WebWorksheets.SaveHTMLFile Method

Saves data to a HTML file stream.

Overload List

Saves data to a HTML file stream.

public void SaveHTMLFile(Stream);

Saves data to a HTML file.

public void SaveHTMLFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.SaveHTMLFile Method (Stream)

Saves data to a HTML file stream.

public void SaveHTMLFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveHTMLFile Overload List


WebWorksheets.SaveHTMLFile Method (String)

Saves data to a HTML file.

public void SaveHTMLFile(
string targetFile
);

Parameters

targetFile
The file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveHTMLFile Overload List


SaveSpreadSheetMLFile Method

Aspose.Cells for .NET

WebWorksheets.SaveSpreadSheetMLFile Method

Saves data to a SpreadSheetML file stream.

Overload List

Saves data to a SpreadSheetML file stream.

public void SaveSpreadSheetMLFile(Stream);

Saves data to a SpreadSheetML file.

public void SaveSpreadSheetMLFile(string);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.SaveSpreadSheetMLFile Method (Stream)

Saves data to a SpreadSheetML file stream.

public void SaveSpreadSheetMLFile(
Stream stream
);

Parameters

stream
The file stream.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveSpreadSheetMLFile Overload List


WebWorksheets.SaveSpreadSheetMLFile Method (String)

Saves data to a SpreadSheetML file.

public void SaveSpreadSheetMLFile(
string targetFile
);

Parameters

targetFile
The file's name.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveSpreadSheetMLFile Overload List


SaveToExcelFile Method

Aspose.Cells for .NET

WebWorksheets.SaveToExcelFile Method

Saves the worksheets to a excel file stream, including disk IO stream or memory stream.

Overload List

Saves the worksheets to a excel file stream, including disk IO stream or memory stream.

public void SaveToExcelFile(Stream);

Saves the worksheets to an excel file.

public void SaveToExcelFile(Stream,GridSaveFormat);

Saves the worksheets to an excel file with Excel 2003 format.

public void SaveToExcelFile(string);

Saves the worksheets to an excel file.

public void SaveToExcelFile(string,GridSaveFormat);

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace


WebWorksheets.SaveToExcelFile Method (Stream)

Saves the worksheets to a excel file stream, including disk IO stream or memory stream.

public void SaveToExcelFile(
Stream stream
);

Parameters

stream
The target file stream to write to.

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveToExcelFile Overload List


WebWorksheets.SaveToExcelFile Method (Stream, GridSaveFormat)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
Stream stream,
GridSaveFormat format
);

Parameters

stream
The stream to write to.
format
The file format(Excel2003, Excel2007, CSV, SpreadsheetML)

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveToExcelFile Overload List


WebWorksheets.SaveToExcelFile Method (String)

Saves the worksheets to an excel file with Excel 2003 format.

public void SaveToExcelFile(
string fileName
);

Parameters

fileName

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveToExcelFile Overload List


WebWorksheets.SaveToExcelFile Method (String, GridSaveFormat)

Saves the worksheets to an excel file.

public void SaveToExcelFile(
string targetFile,
GridSaveFormat format
);

Parameters

targetFile
The name of the target file to write to.
format
The file format(Excel2003, Excel2007, CSV, SpreadsheetML)

See Also

WebWorksheets Class | Aspose.Cells.GridWeb.Data Namespace | WebWorksheets.SaveToExcelFile Overload List


WorkbookEventHandler Delegate

Represents the interface that intend to handle workbook events.

void handleCellEvent(Object sender, CellEventArgs e);

public delegate void WorkbookEventHandler(
object sender,
CellEventArgs e
);

Parameters

sender
The source of the event.
e
The event argument.

Requirements

Namespace: Aspose.Cells.GridWeb.Data

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Data Namespace


Aspose.Cells.GridWeb.Design

Aspose.Cells for .NET

Aspose.Cells.GridWeb.Design Namespace

Namespace hierarchy

Classes

Class | Description
DesignParameters | Internal used only.

Enumerations

Enumeration | Description
DesignCmd | Internal used only.


DesignCmd Enumeration

Internal used only.

public enum DesignCmd

Members

Member Name | Description | Value
init | Internal used only. | 0
style | Internal used only. | 1
clear | Internal used only. | 2
openexcel | Internal used only. | 3
openacw | Internal used only. | 4
saveexcel | Internal used only. | 5
saveacw | Internal used only. | 6
options | Internal used only. | 7
addsheet | Internal used only. | 8
addsheetcopy | Internal used only. | 9
removesheet | Internal used only. | 10
renamesheet | Internal used only. | 11
addhyperlink | Internal used only. | 12
removehyperlink | Internal used only. | 13

Requirements

Namespace: Aspose.Cells.GridWeb.Design

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

Aspose.Cells.GridWeb.Design Namespace


DesignParameters Class

Internal used only.

For a list of all members of this type, see DesignParameters Members.

System.Object
System.MarshalByRefObject
Aspose.Cells.GridWeb.Design.DesignParameters

public class DesignParameters : MarshalByRefObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.GridWeb.Design

Assembly: Aspose.Cells.GridWeb (in Aspose.Cells.GridWeb.dll)

See Also

DesignParameters Members | Aspose.Cells.GridWeb.Design Namespace


DesignParameters Members

DesignParameters overview

Public Instance Constructors

DesignParameters Constructor Initializes a new instance of the DesignParameters class.

Public Instance Fields

ActionType | Internal used only.
ActiveSheetIndex | Internal used only.
CellCommand | Internal used only.
cmd | Internal used only.
customString | Internal used only.
EditMode | Internal used only.
EnableClientColumnOperations | Internal used only.
EnableClientFreeze | Internal used only.
EnableClientMergeOperations | Internal used only.
EnableClientRowOperations | Internal used only.
EnableDoubleClickEvent | Internal used only.
EnablePaging | Internal used only.
EnableStyleDialogbox | Internal used only.
fileName | Internal used only.
ForceValid | Internal used only.
ImageUrl | Internal used only.
MaxColumn | Internal used only.
MaxRow | Internal used only.
MinColumn | Internal used only.
MinRow | Internal used only.
PageSize | Internal used only.
presetStyle | Internal used only.
sheetName | Internal used only.
SheetNames | Internal used only.
ShowDefaultGridLine | Internal used only.
ShowHeaderBar | Internal used only.
ShowSaveButton | Internal used only.
ShowSubmitButton | Internal used only.
ShowTabBar | Internal used only.
ShowUndoButton | Internal used only.
Target | Internal used only.
Text | Internal used only.
ToolTip | Internal used only.
Url | Internal used only.

Public Instance Methods

changeActiveSheetIndex | Internal used only.
clearCmd | Internal used only.
CreateObjRef (inherited from MarshalByRefObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
loadNewSheets | Internal used only.
sendBackOptions | Internal used only.
sendBackStyle | Internal used only.
showMessage | Internal used only.
ToString (inherited from Object) |

Public Instance Events

ActiveSheetIndexChanged | Internal used only.
NewSheetsLoaded | Internal used only.
OptionsChanged | Internal used only.
StyleChanged | Internal used only.

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters Constructor

Initializes a new instance of the DesignParameters class.

public DesignParameters();

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters Fields

The fields of the DesignParameters class are listed below. For a complete list of DesignParameters class members, see the DesignParameters Members topic.

Public Instance Fields

ActionType | Internal used only.
ActiveSheetIndex | Internal used only.
CellCommand | Internal used only.
cmd | Internal used only.
customString | Internal used only.
EditMode | Internal used only.
EnableClientColumnOperations | Internal used only.
EnableClientFreeze | Internal used only.
EnableClientMergeOperations | Internal used only.
EnableClientRowOperations | Internal used only.
EnableDoubleClickEvent | Internal used only.
EnablePaging | Internal used only.
EnableStyleDialogbox | Internal used only.
fileName | Internal used only.
ForceValid | Internal used only.
ImageUrl | Internal used only.
MaxColumn | Internal used only.
MaxRow | Internal used only.
MinColumn | Internal used only.
MinRow | Internal used only.
PageSize | Internal used only.
presetStyle | Internal used only.
sheetName | Internal used only.
SheetNames | Internal used only.
ShowDefaultGridLine | Internal used only.
ShowHeaderBar | Internal used only.
ShowSaveButton | Internal used only.
ShowSubmitButton | Internal used only.
ShowTabBar | Internal used only.
ShowUndoButton | Internal used only.
Target | Internal used only.
Text | Internal used only.
ToolTip | Internal used only.
Url | Internal used only.

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ActionType Field

Internal used only.

public HyperlinkActionType ActionType;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ActiveSheetIndex Field

Internal used only.

public int ActiveSheetIndex;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.CellCommand Field

Internal used only.

public string CellCommand;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.cmd Field

Internal used only.

public DesignCmd cmd;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.customString Field

Internal used only.

public string customString;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EditMode Field

Internal used only.

public bool EditMode;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnableClientColumnOperations Field

Internal used only.

public bool EnableClientColumnOperations;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnableClientFreeze Field

Internal used only.

public bool EnableClientFreeze;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnableClientMergeOperations Field

Internal used only.

public bool EnableClientMergeOperations;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnableClientRowOperations Field

Internal used only.

public bool EnableClientRowOperations;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnableDoubleClickEvent Field

Internal used only.

public bool EnableDoubleClickEvent;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnablePaging Field

Internal used only.

public bool EnablePaging;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.EnableStyleDialogbox Field

Internal used only.

public bool EnableStyleDialogbox;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.fileName Field

Internal used only.

public string fileName;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ForceValid Field

Internal used only.

public bool ForceValid;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ImageUrl Field

Internal used only.

public string ImageUrl;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.MaxColumn Field

Internal used only.

public int MaxColumn;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.MaxRow Field

Internal used only.

public int MaxRow;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.MinColumn Field

Internal used only.

public int MinColumn;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.MinRow Field

Internal used only.

public int MinRow;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.PageSize Field

Internal used only.

public int PageSize;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.presetStyle Field

Internal used only.

public PresetStyle presetStyle;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.sheetName Field

Internal used only.

public string sheetName;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.SheetNames Field

Internal used only.

public string[] SheetNames;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ShowDefaultGridLine Field

Internal used only.

public bool ShowDefaultGridLine;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ShowHeaderBar Field

Internal used only.

public bool ShowHeaderBar;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ShowSaveButton Field

Internal used only.

public bool ShowSaveButton;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ShowSubmitButton Field

Internal used only.

public bool ShowSubmitButton;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ShowTabBar Field

Internal used only.

public bool ShowTabBar;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ShowUndoButton Field

Internal used only.

public bool ShowUndoButton;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.Target Field

Internal used only.

public string Target;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.Text Field

Internal used only.

public string Text;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ToolTip Field

Internal used only.

public string ToolTip;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.Url Field

Internal used only.

public string Url;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters Methods

The methods of the DesignParameters class are listed below. For a complete list of DesignParameters class members, see the DesignParameters Members topic.

Public Instance Methods

changeActiveSheetIndex | Internal used only.
clearCmd | Internal used only.
CreateObjRef (inherited from MarshalByRefObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetLifetimeService (inherited from MarshalByRefObject) |
GetType (inherited from Object) |
InitializeLifetimeService (inherited from MarshalByRefObject) |
loadNewSheets | Internal used only.
sendBackOptions | Internal used only.
sendBackStyle | Internal used only.
showMessage | Internal used only.
ToString (inherited from Object) |

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.changeActiveSheetIndex Method

Internal used only.

public void changeActiveSheetIndex(
int index
);

Parameters

index

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.clearCmd Method

Internal used only.

public void clearCmd();

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.loadNewSheets Method

Internal used only.

public void loadNewSheets(
string[] sheetNames
);

Parameters

sheetNames

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.sendBackOptions Method

Internal used only.

public void sendBackOptions(
bool editMode,
bool forceValid,
bool enableDoubleClickEvent,
bool showDefaultGridLine,
bool showSubmitButton,
bool showSaveButton,
bool showUndoButton,
bool enablePaging,
bool showHeaderBar,
bool showTabBar,
int minColumn,
int maxColumn,
int minRow,
int maxRow,
int pageSize,
bool enableStyleDialogbox,
bool enableClientFreeze,
bool enableClientRowOperations,
bool enableClientColumnOperations,
bool enableClientMergeOperations
);

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.sendBackStyle Method

Internal used only.

public void sendBackStyle(
PresetStyle style,
string styleStr
);

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.showMessage Method

Internal used only.

public void showMessage(
string message
);

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters Events

The events of the DesignParameters class are listed below. For a complete list of DesignParameters class members, see the DesignParameters Members topic.

Public Instance Events

ActiveSheetIndexChanged | Internal used only.
NewSheetsLoaded | Internal used only.
OptionsChanged | Internal used only.
StyleChanged | Internal used only.

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.ActiveSheetIndexChanged Event

Internal used only.

public event EventHandler ActiveSheetIndexChanged;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.NewSheetsLoaded Event

Internal used only.

public event EventHandler NewSheetsLoaded;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.OptionsChanged Event

Internal used only.

public event EventHandler OptionsChanged;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


DesignParameters.StyleChanged Event

Internal used only.

public event EventHandler StyleChanged;

See Also

DesignParameters Class | Aspose.Cells.GridWeb.Design Namespace


Aspose.Cells.Markup

Aspose.Cells for .NET

Aspose.Cells.Markup Namespace

Namespace hierarchy

Classes

Class | Description
CustomXmlPart | Represents a Custom XML Data Storage Part (custom XML data within a package).
CustomXmlPartCollection | Represents a Custom XML Data Storage Part (custom XML data within a package).
SmartTag | Represents a smart tag.
SmartTagCollection | Represents all smart tags in the cell.
SmartTagOptions | Represents the options of the smart tag.
SmartTagProperty | Represents the property of the cell smart tag.
SmartTagPropertyCollection | Represents all properties of cell smart tag.
SmartTagSetting | Represents all SmartTagCollection object in the worksheet.

Enumerations

Enumeration | Description
SmartTagShowType | Represents the show type of the smart tag.


CustomXmlPart Class

Represents a Custom XML Data Storage Part (custom XML data within a package).

For a list of all members of this type, see CustomXmlPart Members.

System.Object
Aspose.Cells.Markup.CustomXmlPart

public class CustomXmlPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomXmlPart Members | Aspose.Cells.Markup Namespace


CustomXmlPart Members

CustomXmlPart overview

Public Instance Properties

Data | Gets or sets the XML content of this Custom XML Data Storage Part.
ID | Gets and sets the id of the custom xml part.
SchemaData | Gets or sets the XML content of this Custom XML Schema Data Storage Part.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CustomXmlPart Class | Aspose.Cells.Markup Namespace


CustomXmlPart Properties

The properties of the CustomXmlPart class are listed below. For a complete list of CustomXmlPart class members, see the CustomXmlPart Members topic.

Public Instance Properties

Data | Gets or sets the XML content of this Custom XML Data Storage Part.
ID | Gets and sets the id of the custom xml part.
SchemaData | Gets or sets the XML content of this Custom XML Schema Data Storage Part.

See Also

CustomXmlPart Class | Aspose.Cells.Markup Namespace


Data Property

Aspose.Cells for .NET

CustomXmlPart.Data Property

Gets or sets the XML content of this Custom XML Data Storage Part.

public byte[] Data {get; set;}

See Also

CustomXmlPart Class | Aspose.Cells.Markup Namespace


ID Property

Aspose.Cells for .NET

CustomXmlPart.ID Property

Gets and sets the id of the custom xml part.

public string ID {get; set;}

See Also

CustomXmlPart Class | Aspose.Cells.Markup Namespace


SchemaData Property

Aspose.Cells for .NET

CustomXmlPart.SchemaData Property

Gets or sets the XML content of this Custom XML Schema Data Storage Part.

public byte[] SchemaData {get; set;}

See Also

CustomXmlPart Class | Aspose.Cells.Markup Namespace


CustomXmlPartCollection Class

Represents a Custom XML Data Storage Part (custom XML data within a package).

For a list of all members of this type, see CustomXmlPartCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Markup.CustomXmlPartCollection

public class CustomXmlPartCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomXmlPartCollection Members | Aspose.Cells.Markup Namespace


CustomXmlPartCollection Members

CustomXmlPartCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets an item at the specified index.

Public Instance Methods

Add | Adds an item to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
SelectByID | Gets an item by id.
ToString (inherited from Object) |

See Also

CustomXmlPartCollection Class | Aspose.Cells.Markup Namespace


CustomXmlPartCollection Properties

The properties of the CustomXmlPartCollection class are listed below. For a complete list of CustomXmlPartCollection class members, see the CustomXmlPartCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets an item at the specified index.

See Also

CustomXmlPartCollection Class | Aspose.Cells.Markup Namespace


Item Property

Aspose.Cells for .NET

CustomXmlPartCollection.Item Property

Gets an item at the specified index.

public CustomXmlPart this[
int index
] {get;}

Parameters

index
The index.

See Also

CustomXmlPartCollection Class | Aspose.Cells.Markup Namespace


CustomXmlPartCollection Methods

The methods of the CustomXmlPartCollection class are listed below. For a complete list of CustomXmlPartCollection class members, see the CustomXmlPartCollection Members topic.

Public Instance Methods

Add | Adds an item to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
SelectByID | Gets an item by id.
ToString (inherited from Object) |

See Also

CustomXmlPartCollection Class | Aspose.Cells.Markup Namespace


CustomXmlPartCollection.Add Method

Adds an item to the collection.

public int Add(
byte[] data,
byte[] shemaData
);

Parameters

data
The XML content of this Custom XML Data Storage Part.
shemaData
The set of XML schemas that are associated with this custom XML part.

Return Value

See Also

CustomXmlPartCollection Class | Aspose.Cells.Markup Namespace


CustomXmlPartCollection.SelectByID Method

Gets an item by id.

public CustomXmlPart SelectByID(
string id
);

Parameters

id
Contains the GUID for the custom XML part.

Return Value

See Also

CustomXmlPartCollection Class | Aspose.Cells.Markup Namespace


SmartTag Class

Represents a smart tag.

For a list of all members of this type, see SmartTag Members.

System.Object
Aspose.Cells.Markup.SmartTag

public class SmartTag

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartTag Members | Aspose.Cells.Markup Namespace


SmartTag Members

SmartTag overview

Public Instance Properties

Deleted | Indicates whether the smart tag is deleted.
Name | Gets the name of the smart tag.
Properties | Gets and set the properties of the smart tag.
Uri | Gets the namespace URI of the smart tag.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLink | Change the name and the namespace URI of the smart tag.
ToString (inherited from Object) |

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


SmartTag Properties

The properties of the SmartTag class are listed below. For a complete list of SmartTag class members, see the SmartTag Members topic.

Public Instance Properties

Deleted | Indicates whether the smart tag is deleted.
Name | Gets the name of the smart tag.
Properties | Gets and set the properties of the smart tag.
Uri | Gets the namespace URI of the smart tag.

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


Deleted Property

Aspose.Cells for .NET

SmartTag.Deleted Property

Indicates whether the smart tag is deleted.

public bool Deleted {get; set;}

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


Name Property

Aspose.Cells for .NET

SmartTag.Name Property

Gets the name of the smart tag.

public string Name {get;}

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


Properties Property

Aspose.Cells for .NET

SmartTag.Properties Property

Gets and set the properties of the smart tag.

public SmartTagPropertyCollection Properties {get; set;}

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


Uri Property

Aspose.Cells for .NET

SmartTag.Uri Property

Gets the namespace URI of the smart tag.

public string Uri {get;}

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


SmartTag Methods

The methods of the SmartTag class are listed below. For a complete list of SmartTag class members, see the SmartTag Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetLink | Change the name and the namespace URI of the smart tag.
ToString (inherited from Object) |

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


SmartTag.SetLink Method

Change the name and the namespace URI of the smart tag.

public void SetLink(
string uri,
string name
);

Parameters

uri
The namespace URI of the smart tag.
name
The name of the smart tag.

See Also

SmartTag Class | Aspose.Cells.Markup Namespace


SmartTagCollection Class

Represents all smart tags in the cell.

For a list of all members of this type, see SmartTagCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Markup.SmartTagCollection

public class SmartTagCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartTagCollection Members | Aspose.Cells.Markup Namespace


SmartTagCollection Members

SmartTagCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Column | Gets the column of the cell smart tags.
Count (inherited from CollectionBase) |
Item | Gets a SmartTag object at the specific index
Row | Gets the row of the cell smart tags.

Public Instance Methods

Add | Adds a smart tag.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


SmartTagCollection Properties

The properties of the SmartTagCollection class are listed below. For a complete list of SmartTagCollection class members, see the SmartTagCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Column | Gets the column of the cell smart tags.
Count (inherited from CollectionBase) |
Item | Gets a SmartTag object at the specific index
Row | Gets the row of the cell smart tags.

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


Column Property

Aspose.Cells for .NET

SmartTagCollection.Column Property

Gets the column of the cell smart tags.

public int Column {get;}

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


Item Property

Aspose.Cells for .NET

SmartTagCollection.Item Property

Gets a SmartTag object at the specific index

public SmartTag this[
int index
] {get;}

Parameters

index
The index.

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


Row Property

Aspose.Cells for .NET

SmartTagCollection.Row Property

Gets the row of the cell smart tags.

public int Row {get;}

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


SmartTagCollection Methods

The methods of the SmartTagCollection class are listed below. For a complete list of SmartTagCollection class members, see the SmartTagCollection Members topic.

Public Instance Methods

Add | Adds a smart tag.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


SmartTagCollection.Add Method

Adds a smart tag.

public int Add(
string uri,
string name
);

Parameters

uri
Specifies the namespace URI of the smart tag
name
Specifies the name of the smart tag.

Return Value

The index of smart tag in the list.

See Also

SmartTagCollection Class | Aspose.Cells.Markup Namespace


SmartTagOptions Class

Represents the options of the smart tag.

For a list of all members of this type, see SmartTagOptions Members.

System.Object
Aspose.Cells.Markup.SmartTagOptions

public class SmartTagOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartTagOptions Members | Aspose.Cells.Markup Namespace


SmartTagOptions Members

SmartTagOptions overview

Public Instance Constructors

SmartTagOptions Constructor Initializes a new instance of the SmartTagOptions class.

Public Instance Properties

EmbedSmartTags | Indicates whether saving smart tags with the workbook.
ShowType | Represents the show type of smart tag.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SmartTagOptions Class | Aspose.Cells.Markup Namespace


SmartTagOptions Constructor

Initializes a new instance of the SmartTagOptions class.

public SmartTagOptions();

See Also

SmartTagOptions Class | Aspose.Cells.Markup Namespace


SmartTagOptions Properties

The properties of the SmartTagOptions class are listed below. For a complete list of SmartTagOptions class members, see the SmartTagOptions Members topic.

Public Instance Properties

EmbedSmartTags | Indicates whether saving smart tags with the workbook.
ShowType | Represents the show type of smart tag.

See Also

SmartTagOptions Class | Aspose.Cells.Markup Namespace


EmbedSmartTags Property

Aspose.Cells for .NET

SmartTagOptions.EmbedSmartTags Property

Indicates whether saving smart tags with the workbook.

public bool EmbedSmartTags {get; set;}

See Also

SmartTagOptions Class | Aspose.Cells.Markup Namespace


ShowType Property

Aspose.Cells for .NET

SmartTagOptions.ShowType Property

Represents the show type of smart tag.

public SmartTagShowType ShowType {get; set;}

See Also

SmartTagOptions Class | Aspose.Cells.Markup Namespace


SmartTagProperty Class

Represents the property of the cell smart tag.

For a list of all members of this type, see SmartTagProperty Members.

System.Object
Aspose.Cells.Markup.SmartTagProperty

public class SmartTagProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartTagProperty Members | Aspose.Cells.Markup Namespace


SmartTagProperty Members

SmartTagProperty overview

Public Instance Properties

Name | Gets and sets the name of the property.
Value | Gets and sets the value of the property.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SmartTagProperty Class | Aspose.Cells.Markup Namespace


SmartTagProperty Properties

The properties of the SmartTagProperty class are listed below. For a complete list of SmartTagProperty class members, see the SmartTagProperty Members topic.

Public Instance Properties

Name | Gets and sets the name of the property.
Value | Gets and sets the value of the property.

See Also

SmartTagProperty Class | Aspose.Cells.Markup Namespace


Name Property

Aspose.Cells for .NET

SmartTagProperty.Name Property

Gets and sets the name of the property.

public string Name {get; set;}

See Also

SmartTagProperty Class | Aspose.Cells.Markup Namespace


Value Property

Aspose.Cells for .NET

SmartTagProperty.Value Property

Gets and sets the value of the property.

public string Value {get; set;}

See Also

SmartTagProperty Class | Aspose.Cells.Markup Namespace


SmartTagPropertyCollection Class

Represents all properties of cell smart tag.

For a list of all members of this type, see SmartTagPropertyCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Markup.SmartTagPropertyCollection

public class SmartTagPropertyCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartTagPropertyCollection Members | Aspose.Cells.Markup Namespace


SmartTagPropertyCollection Members

SmartTagPropertyCollection overview

Public Instance Constructors

SmartTagPropertyCollection Constructor Initializes a new instance of the SmartTagPropertyCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets a SmartTagProperty object.

Public Instance Methods

Add | Adds a property of cell's smart tag.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace


SmartTagPropertyCollection Constructor

Initializes a new instance of the SmartTagPropertyCollection class.

public SmartTagPropertyCollection();

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace


SmartTagPropertyCollection Properties

The properties of the SmartTagPropertyCollection class are listed below. For a complete list of SmartTagPropertyCollection class members, see the SmartTagPropertyCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets a SmartTagProperty object.

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace


Item Property

Aspose.Cells for .NET

SmartTagPropertyCollection.Item Property

Gets a SmartTagProperty object.

Overload List

Gets a SmartTagProperty object.

public SmartTagProperty this[int] {get;}

Gets a SmartTagProperty object by the name of the property.

public SmartTagProperty this[string] {get;}

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace


Item Property (Int32)

Aspose.Cells for .NET

SmartTagPropertyCollection.Item Property (Int32)

Gets a SmartTagProperty object.

public SmartTagProperty this[
int index
] {get;}

Parameters

index
The index

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace | SmartTagPropertyCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

SmartTagPropertyCollection.Item Property (String)

Gets a SmartTagProperty object by the name of the property.

public SmartTagProperty this[
string name
] {get;}

Parameters

name
The name of the property.

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace | SmartTagPropertyCollection.Item Overload List


SmartTagPropertyCollection Methods

The methods of the SmartTagPropertyCollection class are listed below. For a complete list of SmartTagPropertyCollection class members, see the SmartTagPropertyCollection Members topic.

Public Instance Methods

Add | Adds a property of cell's smart tag.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace


SmartTagPropertyCollection.Add Method

Adds a property of cell's smart tag.

public int Add(
string name,
string value
);

Parameters

name
The name of the property
value
The value of the property.

Return Value

return SmartTagProperty

See Also

SmartTagPropertyCollection Class | Aspose.Cells.Markup Namespace


SmartTagSetting Class

Represents all SmartTagCollection object in the worksheet.

For a list of all members of this type, see SmartTagSetting Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Markup.SmartTagSetting

public class SmartTagSetting : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SmartTagSetting Members | Aspose.Cells.Markup Namespace


SmartTagSetting Members

SmartTagSetting overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets a SmartTagCollection object by the index.

Public Instance Methods

Add | Overloaded. Adds a SmartTagCollection object to a cell.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace


SmartTagSetting Properties

The properties of the SmartTagSetting class are listed below. For a complete list of SmartTagSetting class members, see the SmartTagSetting Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets a SmartTagCollection object by the index.

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace


Item Property

Aspose.Cells for .NET

SmartTagSetting.Item Property

Gets a SmartTagCollection object by the index.

Overload List

Gets a SmartTagCollection object by the index.

public SmartTagCollection this[int] {get;}

Gets the SmartTagCollection object of the cell.

public SmartTagCollection this[int, int] {get;}

Gets the SmartTagCollection object of the cell.

public SmartTagCollection this[string] {get;}

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace


Item Property (Int32)

Aspose.Cells for .NET

SmartTagSetting.Item Property (Int32)

Gets a SmartTagCollection object by the index.

public SmartTagCollection this[
int index
] {get;}

Parameters

index
The index of the SmartTagCollection object in the list.

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace | SmartTagSetting.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

SmartTagSetting.Item Property (Int32, Int32)

Gets the SmartTagCollection object of the cell.

public SmartTagCollection this[
int row,
int column
] {get;}

Parameters

row
The row index of the cell.
column
The column index of the cell

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace | SmartTagSetting.Item Overload List


Item Property (String)

Aspose.Cells for .NET

SmartTagSetting.Item Property (String)

Gets the SmartTagCollection object of the cell.

public SmartTagCollection this[
string cellName
] {get;}

Parameters

cellName
The name of the cell.

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace | SmartTagSetting.Item Overload List


SmartTagSetting Methods

The methods of the SmartTagSetting class are listed below. For a complete list of SmartTagSetting class members, see the SmartTagSetting Members topic.

Public Instance Methods

Add | Overloaded. Adds a SmartTagCollection object to a cell.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace


Add Method

Aspose.Cells for .NET

SmartTagSetting.Add Method

Adds a SmartTagCollection object to a cell.

Overload List

Adds a SmartTagCollection object to a cell.

public int Add(int,int);

Add a cell smart tags.

public int Add(string);

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace


SmartTagSetting.Add Method (Int32, Int32)

Adds a SmartTagCollection object to a cell.

public int Add(
int row,
int column
);

Parameters

row
The row of the cell.
column
The column of the cell.

Return Value

Returns index of a SmartTagCollection object in the worksheet.

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace | SmartTagSetting.Add Overload List


SmartTagSetting.Add Method (String)

Add a cell smart tags.

public int Add(
string cellName
);

Parameters

cellName
The name of the cell.

Return Value

See Also

SmartTagSetting Class | Aspose.Cells.Markup Namespace | SmartTagSetting.Add Overload List


SmartTagShowType Enumeration

Represents the show type of the smart tag.

public enum SmartTagShowType

Members

Member Name | Description | Value
All | Indicates that smart tags are enabled and shown | 0
NoSmartTagIndicator | Indicates that the smart tags are enabled but the indicator not be shown. | 1
None | Indicates that smart tags are disabled and not displayed. | 2

Requirements

Namespace: Aspose.Cells.Markup

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Markup Namespace


Aspose.Cells.Metadata

Aspose.Cells for .NET

Aspose.Cells.Metadata Namespace

Namespace hierarchy

Classes

Class | Description
MetadataOptions | Represents the options of loading metadata of the file.
WorkbookMetadata | Represents the meta data.

Enumerations

Enumeration | Description
MetadataType | Represents the type of metadata.


MetadataOptions Class

Represents the options of loading metadata of the file.

For a list of all members of this type, see MetadataOptions Members.

System.Object
Aspose.Cells.Metadata.MetadataOptions

public class MetadataOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Metadata

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

MetadataOptions Members | Aspose.Cells.Metadata Namespace


MetadataOptions Members

MetadataOptions overview

Public Instance Constructors

MetadataOptions Constructor Creates an options of loading the metadata.

Public Instance Properties

KeyLength | The key length.
MetadataType | Gets and sets the type of the metadata which is loading.
Password | Represents Workbook file encryption password.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

MetadataOptions Class | Aspose.Cells.Metadata Namespace


MetadataOptions Constructor

Creates an options of loading the metadata.

public MetadataOptions(
MetadataType metadataType
);

Parameters

metadataType
The type of metadata.

See Also

MetadataOptions Class | Aspose.Cells.Metadata Namespace


MetadataOptions Properties

The properties of the MetadataOptions class are listed below. For a complete list of MetadataOptions class members, see the MetadataOptions Members topic.

Public Instance Properties

KeyLength | The key length.
MetadataType | Gets and sets the type of the metadata which is loading.
Password | Represents Workbook file encryption password.

See Also

MetadataOptions Class | Aspose.Cells.Metadata Namespace


KeyLength Property

Aspose.Cells for .NET

MetadataOptions.KeyLength Property

The key length.

public int KeyLength {get; set;}

See Also

MetadataOptions Class | Aspose.Cells.Metadata Namespace


MetadataType Property

Aspose.Cells for .NET

MetadataOptions.MetadataType Property

Gets and sets the type of the metadata which is loading.

public MetadataType MetadataType {get;}

See Also

MetadataOptions Class | Aspose.Cells.Metadata Namespace


Password Property

Aspose.Cells for .NET

MetadataOptions.Password Property

Represents Workbook file encryption password.

public string Password {get; set;}

See Also

MetadataOptions Class | Aspose.Cells.Metadata Namespace


MetadataType Enumeration

Represents the type of metadata.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MetadataType

Members

Member Name | Description | Value
Encryption | Encrypts the file. | 1
Decryption | Decrypts the file. | 2
DocumentProperties | Load the properties of the file. | 4

Requirements

Namespace: Aspose.Cells.Metadata

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Metadata Namespace


WorkbookMetadata Class

Represents the meta data.

For a list of all members of this type, see WorkbookMetadata Members.

System.Object
Aspose.Cells.Metadata.WorkbookMetadata

public class WorkbookMetadata

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example creates a WorkbookMetadata.

[C#]
  MetadataOptions options = new MetadataOptions(MetadataType.DocumentProperties);
  WorkbookMetadata meta = new WorkbookMetadata(path + "book1.xlsx", options);
  meta.CustomDocumentProperties.Add("test", "test");
  meta.Save(path + "book2.xlsx");

Requirements

Namespace: Aspose.Cells.Metadata

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WorkbookMetadata Members | Aspose.Cells.Metadata Namespace


WorkbookMetadata Members

WorkbookMetadata overview

Public Instance Constructors

WorkbookMetadata Overloaded. Initializes a new instance of the WorkbookMetadata class.

Public Instance Properties

BuiltInDocumentProperties | Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.
CustomDocumentProperties | Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.
Options | Gets the options of the metadata.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Save | Overloaded. Save the modified metadata to the file.
ToString (inherited from Object) |

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


WorkbookMetadata Constructor

Create the meta data object.

Overload List

Create the meta data object.

public WorkbookMetadata(Stream,MetadataOptions);

Create the meta data object.

public WorkbookMetadata(string,MetadataOptions);

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


WorkbookMetadata Constructor (String, MetadataOptions)

Create the meta data object.

public WorkbookMetadata(
string fileName,
MetadataOptions options
);

Parameters

fileName
options

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace | WorkbookMetadata Constructor Overload List


WorkbookMetadata Constructor (Stream, MetadataOptions)

Create the meta data object.

public WorkbookMetadata(
Stream stream,
MetadataOptions options
);

Parameters

stream
options

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace | WorkbookMetadata Constructor Overload List


WorkbookMetadata Properties

The properties of the WorkbookMetadata class are listed below. For a complete list of WorkbookMetadata class members, see the WorkbookMetadata Members topic.

Public Instance Properties

BuiltInDocumentProperties | Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.
CustomDocumentProperties | Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.
Options | Gets the options of the metadata.

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


BuiltInDocumentProperties Property

Aspose.Cells for .NET

WorkbookMetadata.BuiltInDocumentProperties Property

Returns a DocumentProperties collection that represents all the built-in document properties of the spreadsheet.

public BuiltInDocumentPropertyCollection BuiltInDocumentProperties {get;}

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


CustomDocumentProperties Property

Aspose.Cells for .NET

WorkbookMetadata.CustomDocumentProperties Property

Returns a DocumentProperties collection that represents all the custom document properties of the spreadsheet.

public CustomDocumentPropertyCollection CustomDocumentProperties {get;}

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


Options Property

Aspose.Cells for .NET

WorkbookMetadata.Options Property

Gets the options of the metadata.

public MetadataOptions Options {get;}

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


WorkbookMetadata Methods

The methods of the WorkbookMetadata class are listed below. For a complete list of WorkbookMetadata class members, see the WorkbookMetadata Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Save | Overloaded. Save the modified metadata to the file.
ToString (inherited from Object) |

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


Save Method

Aspose.Cells for .NET

WorkbookMetadata.Save Method

Save the modified metadata to the stream.

Overload List

Save the modified metadata to the stream.

public void Save(Stream);

Save the modified metadata to the file.

public void Save(string);

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace


WorkbookMetadata.Save Method (Stream)

Save the modified metadata to the stream.

public void Save(
Stream stream
);

Parameters

stream
The stream.

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace | WorkbookMetadata.Save Overload List


WorkbookMetadata.Save Method (String)

Save the modified metadata to the file.

public void Save(
string fileName
);

Parameters

fileName
The file name.

See Also

WorkbookMetadata Class | Aspose.Cells.Metadata Namespace | WorkbookMetadata.Save Overload List


Aspose.Cells.Ods

Aspose.Cells for .NET

Aspose.Cells.Ods Namespace

Namespace hierarchy

Classes

Class | Description
OdsCellField | Represents the cell field of ods.
OdsCellFieldCollection | Represents the fields of ODS.
OdsPageBackground | Represents the page background of ods.

Enumerations

Enumeration | Description
OdsCellFieldType | Represents the cell field type of ods.
OdsGeneratorType | Represents the type of ODS generator.
OdsPageBackgroundGraphicPositionType | Represents the position.
OdsPageBackgroundGraphicType | Represents the type of formatting page background with image.
OdsPageBackgroundType | Represents the page background type of ods.


OdsCellField Class

Represents the cell field of ods.

For a list of all members of this type, see OdsCellField Members.

System.Object
Aspose.Cells.Ods.OdsCellField

public class OdsCellField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OdsCellField Members | Aspose.Cells.Ods Namespace


OdsCellField Members

OdsCellField overview

Public Instance Properties

Column | Get and sets the column index of the cell.
CustomFormat | Represents the custom format of the field's value.
FieldType | Gets and sets the type of the field.
Row | Get and sets the row index of the cell.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

OdsCellField Class | Aspose.Cells.Ods Namespace


OdsCellField Properties

The properties of the OdsCellField class are listed below. For a complete list of OdsCellField class members, see the OdsCellField Members topic.

Public Instance Properties

Column | Get and sets the column index of the cell.
CustomFormat | Represents the custom format of the field's value.
FieldType | Gets and sets the type of the field.
Row | Get and sets the row index of the cell.

See Also

OdsCellField Class | Aspose.Cells.Ods Namespace


Column Property

Aspose.Cells for .NET

OdsCellField.Column Property

Get and sets the column index of the cell.

public int Column {get; set;}

See Also

OdsCellField Class | Aspose.Cells.Ods Namespace


CustomFormat Property

Aspose.Cells for .NET

OdsCellField.CustomFormat Property

Represents the custom format of the field's value.

public string CustomFormat {get; set;}

See Also

OdsCellField Class | Aspose.Cells.Ods Namespace


FieldType Property

Aspose.Cells for .NET

OdsCellField.FieldType Property

Gets and sets the type of the field.

public OdsCellFieldType FieldType {get; set;}

See Also

OdsCellField Class | Aspose.Cells.Ods Namespace


Row Property

Aspose.Cells for .NET

OdsCellField.Row Property

Get and sets the row index of the cell.

public int Row {get; set;}

See Also

OdsCellField Class | Aspose.Cells.Ods Namespace


OdsCellFieldCollection Class

Represents the fields of ODS.

For a list of all members of this type, see OdsCellFieldCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Ods.OdsCellFieldCollection

public class OdsCellFieldCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OdsCellFieldCollection Members | Aspose.Cells.Ods Namespace


OdsCellFieldCollection Members

OdsCellFieldCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the field by the index.

Public Instance Methods

Add | Adds a field.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |
UpdateFieldsValue | Update fields value to the cells.

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace


OdsCellFieldCollection Properties

The properties of the OdsCellFieldCollection class are listed below. For a complete list of OdsCellFieldCollection class members, see the OdsCellFieldCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the field by the index.

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace


Item Property

Aspose.Cells for .NET

OdsCellFieldCollection.Item Property

Gets the field by the index.

Overload List

Gets the field by the index.

public OdsCellField this[int] {get;}

Gets the field by row and column index.

public OdsCellField this[int, int] {get;}

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace


Item Property (Int32)

Aspose.Cells for .NET

OdsCellFieldCollection.Item Property (Int32)

Gets the field by the index.

public OdsCellField this[
int index
] {get;}

Parameters

index
The index.

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace | OdsCellFieldCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

OdsCellFieldCollection.Item Property (Int32, Int32)

Gets the field by row and column index.

public OdsCellField this[
int row,
int column
] {get;}

Parameters

row
The row index.
column
The column index.

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace | OdsCellFieldCollection.Item Overload List


OdsCellFieldCollection Methods

The methods of the OdsCellFieldCollection class are listed below. For a complete list of OdsCellFieldCollection class members, see the OdsCellFieldCollection Members topic.

Public Instance Methods

Add | Adds a field.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |
UpdateFieldsValue | Update fields value to the cells.

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace


OdsCellFieldCollection.Add Method

Adds a field.

public int Add(
int row,
int column,
OdsCellFieldType fieldType,
string format
);

Parameters

row
The row index.
column
The column index.
fieldType
The type of the field.
format
The number format of the field.

Return Value

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace


OdsCellFieldCollection.UpdateFieldsValue Method

Update fields value to the cells.

public void UpdateFieldsValue();

See Also

OdsCellFieldCollection Class | Aspose.Cells.Ods Namespace


OdsCellFieldType Enumeration

Represents the cell field type of ods.

public enum OdsCellFieldType

Members

Member Name | Description | Value
Date | Current date. | 0
SheetName | The name of the sheet. | 1
Title | The name of the file. | 2

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Ods Namespace


OdsGeneratorType Enumeration

Represents the type of ODS generator.

public enum OdsGeneratorType

Members

Member Name | Description | Value
LibreOffice | Libre Office | 0
OpenOffice | Open Office | 1

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Ods Namespace


OdsPageBackground Class

Represents the page background of ods.

For a list of all members of this type, see OdsPageBackground Members.

System.Object
Aspose.Cells.Ods.OdsPageBackground

public class OdsPageBackground

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

OdsPageBackground Members | Aspose.Cells.Ods Namespace


OdsPageBackground Members

OdsPageBackground overview

Public Instance Constructors

OdsPageBackground Constructor Initializes a new instance of the OdsPageBackground class.

Public Instance Properties

Color | Gets and sets the color of background.
GraphicData | Gets and sets the graphic data.
GraphicPositionType | Gets and set the background graphic position.
GraphicType | Gets and sets the page background graphic type.
IsLink | Indicates whether it's a linked graphic.
LinkedGraphic | Gets and sets the linked graphic path.
Type | Gets and sets the page background type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


OdsPageBackground Constructor

Initializes a new instance of the OdsPageBackground class.

public OdsPageBackground();

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


OdsPageBackground Properties

The properties of the OdsPageBackground class are listed below. For a complete list of OdsPageBackground class members, see the OdsPageBackground Members topic.

Public Instance Properties

Color | Gets and sets the color of background.
GraphicData | Gets and sets the graphic data.
GraphicPositionType | Gets and set the background graphic position.
GraphicType | Gets and sets the page background graphic type.
IsLink | Indicates whether it's a linked graphic.
LinkedGraphic | Gets and sets the linked graphic path.
Type | Gets and sets the page background type.

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


Color Property

Aspose.Cells for .NET

OdsPageBackground.Color Property

Gets and sets the color of background.

public Color Color {get; set;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


GraphicData Property

Aspose.Cells for .NET

OdsPageBackground.GraphicData Property

Gets and sets the graphic data.

public byte[] GraphicData {get; set;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


GraphicPositionType Property

Aspose.Cells for .NET

OdsPageBackground.GraphicPositionType Property

Gets and set the background graphic position.

public OdsPageBackgroundGraphicPositionType GraphicPositionType {get; set;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


GraphicType Property

Aspose.Cells for .NET

OdsPageBackground.GraphicType Property

Gets and sets the page background graphic type.

public OdsPageBackgroundGraphicType GraphicType {get; set;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


IsLink Property

Aspose.Cells for .NET

OdsPageBackground.IsLink Property

Indicates whether it's a linked graphic.

public bool IsLink {get;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


LinkedGraphic Property

Aspose.Cells for .NET

OdsPageBackground.LinkedGraphic Property

Gets and sets the linked graphic path.

public string LinkedGraphic {get; set;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


Type Property

Aspose.Cells for .NET

OdsPageBackground.Type Property

Gets and sets the page background type.

public OdsPageBackgroundType Type {get; set;}

See Also

OdsPageBackground Class | Aspose.Cells.Ods Namespace


OdsPageBackgroundGraphicPositionType Enumeration

Represents the position.

public enum OdsPageBackgroundGraphicPositionType

Members

Member Name | Description | Value
TopLeft | Top left. | 0
TopCenter | Top center. | 1
TopRight | Top right. | 2
CenterLeft | Center left. | 3
CenterCenter | Center. | 4
CenterRight | Center right. | 5
BottomLeft | Bottom left. | 6
BottomCenter | Bottom center. | 7
BottomRight | Bottom right. | 8

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Ods Namespace


OdsPageBackgroundGraphicType Enumeration

Represents the type of formatting page background with image.

public enum OdsPageBackgroundGraphicType

Members

Member Name | Description | Value
Position | Set the image at specific position. | 0
Area | Stretch the image. | 1
Tile | Repeat and repeat the image. | 2

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Ods Namespace


OdsPageBackgroundType Enumeration

Represents the page background type of ods.

public enum OdsPageBackgroundType

Members

Member Name | Description | Value
None | No background. | 0
Color | Formats the background with color. | 1
Graphic | Formats the background with image. | 2

Requirements

Namespace: Aspose.Cells.Ods

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Ods Namespace


Aspose.Cells.Pivot

Aspose.Cells for .NET

Aspose.Cells.Pivot Namespace

Namespace hierarchy

Classes

Class | Description
PivotField | Represents a field in a PivotTable report.
PivotFieldCollection | Represents a collection of all the PivotField objects in the PivotTable's specific PivotFields type.
PivotFilter | Represents a PivotFilter in PivotFilter Collection.
PivotFilterCollection | Represents a collection of all the PivotFilter objects
PivotFormatCondition | Represents a PivotTable Format Condition in PivotFormatCondition Collection.
PivotFormatConditionCollection | Represents PivotTable Format Conditions.
PivotItem | Represents a item in a PivotField report.
PivotItemCollection | Represents a collection of all the PivotItem objects in the PivotField's
PivotPageFields | Represents the pivot page field items if the pivot table data source is consolidation ranges. It only can contain up to 4 fields.
PivotTable | Summary description for PivotTable.
PivotTableCollection | Represents the collection of all the PivotTable objects on the specified worksheet.
SxRng | Represents Group Range in a PivotField.

Enumerations

Enumeration | Description
PivotConditionFormatRuleType | Represents PivotTable condition formatting rule type.
PivotConditionFormatScopeType | Represents PivotTable condition formatting scope type.
PivotFieldDataDisplayFormat | Represents data display format in the PivotTable data field.
PivotFieldSubtotalType | Summary description for PivotFieldSubtotalType.
PivotFieldType | Represents PivotTable field type.
PivotFilterType | Represents PivotTable Filter type.
PivotGroupByType | Represents PivotTable groupby type.
PivotItemPosition | Represents PivotTable base item Next/Previous/All position in the base field .
PivotMissingItemLimitType | Represents number of items to retain per field.
PivotTableAutoFormatType | Represents PivotTable auto format type.
PivotTableStyleType | Represents the pivot table style type.


PivotConditionFormatRuleType Enumeration

Represents PivotTable condition formatting rule type.

public enum PivotConditionFormatRuleType

Members

Member Name | Description | Value
None | Indicates that Top N conditional formatting is not evaluated | 0
All | Indicates that Top N conditional formatting is evaluated across the entire scope range. | 1
Row | Indicates that Top N conditional formatting is evaluated for each row. | 2
Column | Indicates that Top N conditional formatting is evaluated for each column. | 3

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotConditionFormatScopeType Enumeration

Represents PivotTable condition formatting scope type.

public enum PivotConditionFormatScopeType

Members

Member Name | Description | Value
Data | Indicates that conditional formatting is applied to the selected data fields. | 0
Field | Indicates that conditional formatting is applied to the selected PivotTable field intersections. | 1
Selection | Indicates that conditional formatting is applied to the selected cells. | 2

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotField Class

Represents a field in a PivotTable report.

For a list of all members of this type, see PivotField Members.

System.Object
Aspose.Cells.Pivot.PivotField

public class PivotField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotField Members | Aspose.Cells.Pivot Namespace


PivotField Members

PivotField overview

Public Instance Properties

AutoShowCount | Represent the number of top or bottom items that are automatically shown in the specified PivotTable field.
AutoShowField | Represents auto show field index. -1 means PivotField itself. It should be the index of the data fields.
AutoSortField | Represents auto sort field index. -1 means PivotField itself,others means the position of the data fields.
BaseFieldIndex | Represents the base field for a custom calculation.
BaseIndex | Represents the PivotField index in the base PivotFields.
BaseItemIndex | Represents the item in the base field for a custom calculation. Valid only for data fields.
BaseItemPosition | Represents the item in the base field for a custom calculation. Valid only for data fields. Because PivotItemPosition.Custom is only for read,if you need to set PivotItemPosition.Custom, please set PivotField.BaseItemIndex attribute.
CurrentPageItem | Represents the current page item showing for the page field (valid only for page fields).
DataDisplayFormat | Represents how to display the values contained in a data field.
DisplayName | Represents the PivotField display name.
DragToColumn | Indicates whether the specified field can be dragged to the column position. The default value is true.
DragToData | Indicates whether the specified field can be dragged to the data position. The default value is true.
DragToHide | Indicates whether the specified field can be dragged to the hide position. The default value is true.
DragToPage | Indicates whether the specified field can be dragged to the page position. The default value is true.
DragToRow | Indicates whether the specified field can be dragged to the row position. The default value is true.
Function | Represents the function used to summarize the PivotTable data field.
InsertBlankRow | Indicates whether inserting blank line after each item.
IsAscendShow | Indicates whether the specified PivotTable field is autoshown ascending.
IsAscendSort | Indicates whether the specified PivotTable field is autosorted ascending.
IsAutoShow | Indicates whether the specified PivotTable field is automatically shown,only valid for excel 2003.
IsAutoSort | Indicates whether the specified PivotTable field is automatically sorted.
IsAutoSubtotals | Indicates whether the specified field shows automatic subtotals. Default is true.
IsCalculatedField | Indicates whether the specified PivotTable field is calculated field.
IsIncludeNewItemsInFilter | indicates whether the field can include new items in manual filter The default value is false.
IsInsertPageBreaksBetweenItems | indicates whether the field can insert page breaks between items insert page break after each item The default value is false.
IsMultipleItemSelectionAllowed | indicates whether the field can have multiple items selected in the page field The default value is false.
IsRepeatItemLabels | indicates whether the field can repeat items labels The default value is false.
ItemCount | Gets the base item count of this pivot field.
Items | Get all base items;
Name | Represents the PivotField name.
Number | Represents the built-in display format of numbers and dates.
NumberFormat | Represents the custom display format of numbers and dates.
OriginalItems | Get the original base items;
PivotItems | Gets the pivot items of the pivot field
Position | Represents the PivotField index in the PivotFields.
Range | Gets the group range of the pivot field
ShowAllItems | Indicates whether all items in the PivotTable report are displayed, even if they don't contain summary data. show items with no data The default value is false.
ShowCompact |
ShowInOutlineForm | Indicates whether layout this field in outline form on the Pivot Table view
ShowSubtotalAtTop | when ShowInOutlineForm is true, then display subtotals at the top of the list of items instead of at the bottom

Public Instance Methods

AddCalculatedItem | Add a calculated item to the pivot field.
Equals (inherited from Object) |
GetCalculatedFieldFormula | Get the formula string of the specified calculated field .
GetHashCode (inherited from Object) |
GetPivotFilterByType | Gets the pivot filter of the pivot field by type
GetPivotFilters | Gets the pivot filters of the pivot field
GetSubtotals | Gets whether the specified field shows that subtotals.
GetType (inherited from Object) |
HideDetail | Sets whether the PivotItems in a pivot field is hidden detail.That is collapse/expand this field.
HideItem | Overloaded. Sets whether the specific PivotItem in a data field is hidden.
HideItemDetail | Sets whether the specific PivotItem in a pivot field is hidden detail.
InitPivotItems | Init the pivot items of the pivot field
IsHiddenItem | Indicates whether the specific PivotItem is hidden.
IsHiddenItemDetail | Indicates whether the specific PivotItem is hidden detail.
SetSubtotals | Sets whether the specified field shows that subtotals.
ToString (inherited from Object) |

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField Properties

The properties of the PivotField class are listed below. For a complete list of PivotField class members, see the PivotField Members topic.

Public Instance Properties

AutoShowCount | Represent the number of top or bottom items that are automatically shown in the specified PivotTable field.
AutoShowField | Represents auto show field index. -1 means PivotField itself. It should be the index of the data fields.
AutoSortField | Represents auto sort field index. -1 means PivotField itself,others means the position of the data fields.
BaseFieldIndex | Represents the base field for a custom calculation.
BaseIndex | Represents the PivotField index in the base PivotFields.
BaseItemIndex | Represents the item in the base field for a custom calculation. Valid only for data fields.
BaseItemPosition | Represents the item in the base field for a custom calculation. Valid only for data fields. Because PivotItemPosition.Custom is only for read,if you need to set PivotItemPosition.Custom, please set PivotField.BaseItemIndex attribute.
CurrentPageItem | Represents the current page item showing for the page field (valid only for page fields).
DataDisplayFormat | Represents how to display the values contained in a data field.
DisplayName | Represents the PivotField display name.
DragToColumn | Indicates whether the specified field can be dragged to the column position. The default value is true.
DragToData | Indicates whether the specified field can be dragged to the data position. The default value is true.
DragToHide | Indicates whether the specified field can be dragged to the hide position. The default value is true.
DragToPage | Indicates whether the specified field can be dragged to the page position. The default value is true.
DragToRow | Indicates whether the specified field can be dragged to the row position. The default value is true.
Function | Represents the function used to summarize the PivotTable data field.
InsertBlankRow | Indicates whether inserting blank line after each item.
IsAscendShow | Indicates whether the specified PivotTable field is autoshown ascending.
IsAscendSort | Indicates whether the specified PivotTable field is autosorted ascending.
IsAutoShow | Indicates whether the specified PivotTable field is automatically shown,only valid for excel 2003.
IsAutoSort | Indicates whether the specified PivotTable field is automatically sorted.
IsAutoSubtotals | Indicates whether the specified field shows automatic subtotals. Default is true.
IsCalculatedField | Indicates whether the specified PivotTable field is calculated field.
IsIncludeNewItemsInFilter | indicates whether the field can include new items in manual filter The default value is false.
IsInsertPageBreaksBetweenItems | indicates whether the field can insert page breaks between items insert page break after each item The default value is false.
IsMultipleItemSelectionAllowed | indicates whether the field can have multiple items selected in the page field The default value is false.
IsRepeatItemLabels | indicates whether the field can repeat items labels The default value is false.
ItemCount | Gets the base item count of this pivot field.
Items | Get all base items;
Name | Represents the PivotField name.
Number | Represents the built-in display format of numbers and dates.
NumberFormat | Represents the custom display format of numbers and dates.
OriginalItems | Get the original base items;
PivotItems | Gets the pivot items of the pivot field
Position | Represents the PivotField index in the PivotFields.
Range | Gets the group range of the pivot field
ShowAllItems | Indicates whether all items in the PivotTable report are displayed, even if they don't contain summary data. show items with no data The default value is false.
ShowCompact |
ShowInOutlineForm | Indicates whether layout this field in outline form on the Pivot Table view
ShowSubtotalAtTop | when ShowInOutlineForm is true, then display subtotals at the top of the list of items instead of at the bottom

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


AutoShowCount Property

Aspose.Cells for .NET

PivotField.AutoShowCount Property

Represent the number of top or bottom items that are automatically shown in the specified PivotTable field.

public int AutoShowCount {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


AutoShowField Property

Aspose.Cells for .NET

PivotField.AutoShowField Property

Represents auto show field index. -1 means PivotField itself. It should be the index of the data fields.

public int AutoShowField {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


AutoSortField Property

Aspose.Cells for .NET

PivotField.AutoSortField Property

Represents auto sort field index. -1 means PivotField itself,others means the position of the data fields.

public int AutoSortField {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


BaseFieldIndex Property

Aspose.Cells for .NET

PivotField.BaseFieldIndex Property

Represents the base field for a custom calculation.

public int BaseFieldIndex {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


BaseIndex Property

Aspose.Cells for .NET

PivotField.BaseIndex Property

Represents the PivotField index in the base PivotFields.

public int BaseIndex {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


BaseItemIndex Property

Aspose.Cells for .NET

PivotField.BaseItemIndex Property

Represents the item in the base field for a custom calculation. Valid only for data fields.

public int BaseItemIndex {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


BaseItemPosition Property

Aspose.Cells for .NET

PivotField.BaseItemPosition Property

Represents the item in the base field for a custom calculation. Valid only for data fields. Because PivotItemPosition.Custom is only for read,if you need to set PivotItemPosition.Custom, please set PivotField.BaseItemIndex attribute.

public PivotItemPosition BaseItemPosition {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


CurrentPageItem Property

Aspose.Cells for .NET

PivotField.CurrentPageItem Property

Represents the current page item showing for the page field (valid only for page fields).

public short CurrentPageItem {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DataDisplayFormat Property

Aspose.Cells for .NET

PivotField.DataDisplayFormat Property

Represents how to display the values contained in a data field.

public PivotFieldDataDisplayFormat DataDisplayFormat {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DisplayName Property

Aspose.Cells for .NET

PivotField.DisplayName Property

Represents the PivotField display name.

public string DisplayName {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DragToColumn Property

Aspose.Cells for .NET

PivotField.DragToColumn Property

Indicates whether the specified field can be dragged to the column position. The default value is true.

public bool DragToColumn {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DragToData Property

Aspose.Cells for .NET

PivotField.DragToData Property

Indicates whether the specified field can be dragged to the data position. The default value is true.

public bool DragToData {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DragToHide Property

Aspose.Cells for .NET

PivotField.DragToHide Property

Indicates whether the specified field can be dragged to the hide position. The default value is true.

public bool DragToHide {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DragToPage Property

Aspose.Cells for .NET

PivotField.DragToPage Property

Indicates whether the specified field can be dragged to the page position. The default value is true.

public bool DragToPage {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


DragToRow Property

Aspose.Cells for .NET

PivotField.DragToRow Property

Indicates whether the specified field can be dragged to the row position. The default value is true.

public bool DragToRow {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


Function Property

Aspose.Cells for .NET

PivotField.Function Property

Represents the function used to summarize the PivotTable data field.

public ConsolidationFunction Function {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


InsertBlankRow Property

Aspose.Cells for .NET

PivotField.InsertBlankRow Property

Indicates whether inserting blank line after each item.

public bool InsertBlankRow {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsAscendShow Property

Aspose.Cells for .NET

PivotField.IsAscendShow Property

Indicates whether the specified PivotTable field is autoshown ascending.

public bool IsAscendShow {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsAscendSort Property

Aspose.Cells for .NET

PivotField.IsAscendSort Property

Indicates whether the specified PivotTable field is autosorted ascending.

public bool IsAscendSort {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsAutoShow Property

Aspose.Cells for .NET

PivotField.IsAutoShow Property

Indicates whether the specified PivotTable field is automatically shown,only valid for excel 2003.

public bool IsAutoShow {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsAutoSort Property

Aspose.Cells for .NET

PivotField.IsAutoSort Property

Indicates whether the specified PivotTable field is automatically sorted.

public bool IsAutoSort {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsAutoSubtotals Property

Aspose.Cells for .NET

PivotField.IsAutoSubtotals Property

Indicates whether the specified field shows automatic subtotals. Default is true.

public bool IsAutoSubtotals {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsCalculatedField Property

Aspose.Cells for .NET

PivotField.IsCalculatedField Property

Indicates whether the specified PivotTable field is calculated field.

public bool IsCalculatedField {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsIncludeNewItemsInFilter Property

Aspose.Cells for .NET

PivotField.IsIncludeNewItemsInFilter Property

indicates whether the field can include new items in manual filter The default value is false.

public bool IsIncludeNewItemsInFilter {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsInsertPageBreaksBetweenItems Property

Aspose.Cells for .NET

PivotField.IsInsertPageBreaksBetweenItems Property

indicates whether the field can insert page breaks between items insert page break after each item The default value is false.

public bool IsInsertPageBreaksBetweenItems {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsMultipleItemSelectionAllowed Property

Aspose.Cells for .NET

PivotField.IsMultipleItemSelectionAllowed Property

indicates whether the field can have multiple items selected in the page field The default value is false.

public bool IsMultipleItemSelectionAllowed {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


IsRepeatItemLabels Property

Aspose.Cells for .NET

PivotField.IsRepeatItemLabels Property

indicates whether the field can repeat items labels The default value is false.

public bool IsRepeatItemLabels {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


ItemCount Property

Aspose.Cells for .NET

PivotField.ItemCount Property

Gets the base item count of this pivot field.

public int ItemCount {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


Items Property

Aspose.Cells for .NET

PivotField.Items Property

Get all base items;

public string[] Items {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


Name Property

Aspose.Cells for .NET

PivotField.Name Property

Represents the PivotField name.

public string Name {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


Number Property

Aspose.Cells for .NET

PivotField.Number Property

Represents the built-in display format of numbers and dates.

public int Number {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


NumberFormat Property

Aspose.Cells for .NET

PivotField.NumberFormat Property

Represents the custom display format of numbers and dates.

public string NumberFormat {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


OriginalItems Property

Aspose.Cells for .NET

PivotField.OriginalItems Property

Get the original base items;

public string[] OriginalItems {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotItems Property

Aspose.Cells for .NET

PivotField.PivotItems Property

Gets the pivot items of the pivot field

public PivotItemCollection PivotItems {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


Position Property

Aspose.Cells for .NET

PivotField.Position Property

Represents the PivotField index in the PivotFields.

public int Position {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


Range Property

Aspose.Cells for .NET

PivotField.Range Property

Gets the group range of the pivot field

public SxRng Range {get;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


ShowAllItems Property

Aspose.Cells for .NET

PivotField.ShowAllItems Property

Indicates whether all items in the PivotTable report are displayed, even if they don't contain summary data. show items with no data The default value is false.

public bool ShowAllItems {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


ShowCompact Property

Aspose.Cells for .NET

PivotField.ShowCompact Property

public bool ShowCompact {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


ShowInOutlineForm Property

Aspose.Cells for .NET

PivotField.ShowInOutlineForm Property

Indicates whether layout this field in outline form on the Pivot Table view

public bool ShowInOutlineForm {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


ShowSubtotalAtTop Property

Aspose.Cells for .NET

PivotField.ShowSubtotalAtTop Property

when ShowInOutlineForm is true, then display subtotals at the top of the list of items instead of at the bottom

public bool ShowSubtotalAtTop {get; set;}

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField Methods

The methods of the PivotField class are listed below. For a complete list of PivotField class members, see the PivotField Members topic.

Public Instance Methods

AddCalculatedItem | Add a calculated item to the pivot field.
Equals (inherited from Object) |
GetCalculatedFieldFormula | Get the formula string of the specified calculated field .
GetHashCode (inherited from Object) |
GetPivotFilterByType | Gets the pivot filter of the pivot field by type
GetPivotFilters | Gets the pivot filters of the pivot field
GetSubtotals | Gets whether the specified field shows that subtotals.
GetType (inherited from Object) |
HideDetail | Sets whether the PivotItems in a pivot field is hidden detail.That is collapse/expand this field.
HideItem | Overloaded. Sets whether the specific PivotItem in a data field is hidden.
HideItemDetail | Sets whether the specific PivotItem in a pivot field is hidden detail.
InitPivotItems | Init the pivot items of the pivot field
IsHiddenItem | Indicates whether the specific PivotItem is hidden.
IsHiddenItemDetail | Indicates whether the specific PivotItem is hidden detail.
SetSubtotals | Sets whether the specified field shows that subtotals.
ToString (inherited from Object) |

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.AddCalculatedItem Method

Add a calculated item to the pivot field.

public void AddCalculatedItem(
string name,
string formula
);

Parameters

name
The item's name.
formula
The item's formula

Remarks

Only supports to add calculated item to Row/Column field.

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.GetCalculatedFieldFormula Method

Get the formula string of the specified calculated field .

public string GetCalculatedFieldFormula();

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.GetPivotFilterByType Method

Gets the pivot filter of the pivot field by type

public PivotFilter GetPivotFilterByType(
PivotFilterType type
);

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.GetPivotFilters Method

Gets the pivot filters of the pivot field

public ArrayList GetPivotFilters();

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.GetSubtotals Method

Gets whether the specified field shows that subtotals.

public bool GetSubtotals(
PivotFieldSubtotalType subtotalType
);

Parameters

subtotalType
subtotals type.

Return Value

whether the specified field shows that subtotals.

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.HideDetail Method

Sets whether the PivotItems in a pivot field is hidden detail.That is collapse/expand this field.

public void HideDetail(
bool isHiddenDetail
);

Parameters

isHiddenDetail
whether the PivotItems is hidden

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


HideItem Method

Aspose.Cells for .NET

PivotField.HideItem Method

Sets whether the specific PivotItem in a data field is hidden.

Overload List

Sets whether the specific PivotItem in a data field is hidden.

public void HideItem(int,bool);

Sets whether the specific PivotItem in a data field is hidden.

public void HideItem(string,bool);

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.HideItem Method (Int32, Boolean)

Sets whether the specific PivotItem in a data field is hidden.

public void HideItem(
int index,
bool isHidden
);

Parameters

index
the index of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

PivotField Class | Aspose.Cells.Pivot Namespace | PivotField.HideItem Overload List


PivotField.HideItem Method (String, Boolean)

Sets whether the specific PivotItem in a data field is hidden.

public void HideItem(
string itemValue,
bool isHidden
);

Parameters

itemValue
the value of the pivotItem in the pivotField.
isHidden
whether the specific PivotItem is hidden

See Also

PivotField Class | Aspose.Cells.Pivot Namespace | PivotField.HideItem Overload List


PivotField.HideItemDetail Method

Sets whether the specific PivotItem in a pivot field is hidden detail.

public void HideItemDetail(
int index,
bool isHiddenDetail
);

Parameters

index
the index of the pivotItem in the pivotField.
isHiddenDetail
whether the specific PivotItem is hidden

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.InitPivotItems Method

Init the pivot items of the pivot field

public void InitPivotItems();

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.IsHiddenItem Method

Indicates whether the specific PivotItem is hidden.

public bool IsHiddenItem(
int index
);

Parameters

index
the index of the pivotItem in the pivotField.

Return Value

whether the specific PivotItem is hidden

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.IsHiddenItemDetail Method

Indicates whether the specific PivotItem is hidden detail.

public bool IsHiddenItemDetail(
int index
);

Parameters

index
the index of the pivotItem in the pivotField.

Return Value

whether the specific PivotItem is hidden detail

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotField.SetSubtotals Method

Sets whether the specified field shows that subtotals.

public void SetSubtotals(
PivotFieldSubtotalType subtotalType,
bool shown
);

Parameters

subtotalType
subtotals type.
shown
whether the specified field shows that subtotals.

See Also

PivotField Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection Class

Represents a collection of all the PivotField objects in the PivotTable's specific PivotFields type.

For a list of all members of this type, see PivotFieldCollection Members.

System.Object
Aspose.Cells.Pivot.PivotFieldCollection

public class PivotFieldCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotFieldCollection Members | Aspose.Cells.Pivot Namespace


PivotFieldCollection Members

PivotFieldCollection overview

Public Instance Properties

Count | Gets the count of the pivotFields.
Item | Overloaded. Gets the PivotField Object at the specific index.
Type | Gets the PivotFields type.

Public Instance Methods

Add | Adds a PivotField Object to the specific type PivotFields.
AddByBaseIndex | Adds a PivotField Object to the specific type PivotFields.
Clear | clear all fields of PivotFieldCollection
Equals (inherited from Object) |
GetEnumerator | Gets an enumerator over the elements in this collection in proper sequence.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection Properties

The properties of the PivotFieldCollection class are listed below. For a complete list of PivotFieldCollection class members, see the PivotFieldCollection Members topic.

Public Instance Properties

Count | Gets the count of the pivotFields.
Item | Overloaded. Gets the PivotField Object at the specific index.
Type | Gets the PivotFields type.

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


Count Property

Aspose.Cells for .NET

PivotFieldCollection.Count Property

Gets the count of the pivotFields.

public int Count {get;}

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


Item Property

Aspose.Cells for .NET

PivotFieldCollection.Item Property

Gets the PivotField Object at the specific index.

Overload List

Gets the PivotField Object at the specific index.

public PivotField this[int] {get;}

Gets the PivotField Object of the specific name.

public PivotField this[string] {get;}

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotFieldCollection.Item Property (Int32)

Gets the PivotField Object at the specific index.

public PivotField this[
int index
] {get;}

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace | PivotFieldCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotFieldCollection.Item Property (String)

Gets the PivotField Object of the specific name.

public PivotField this[
string name
] {get;}

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace | PivotFieldCollection.Item Overload List


Type Property

Aspose.Cells for .NET

PivotFieldCollection.Type Property

Gets the PivotFields type.

public PivotFieldType Type {get;}

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection Methods

The methods of the PivotFieldCollection class are listed below. For a complete list of PivotFieldCollection class members, see the PivotFieldCollection Members topic.

Public Instance Methods

Add | Adds a PivotField Object to the specific type PivotFields.
AddByBaseIndex | Adds a PivotField Object to the specific type PivotFields.
Clear | clear all fields of PivotFieldCollection
Equals (inherited from Object) |
GetEnumerator | Gets an enumerator over the elements in this collection in proper sequence.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection.Add Method

Adds a PivotField Object to the specific type PivotFields.

public int Add(
PivotField pivotField
);

Parameters

pivotField
a PivotField Object.

Return Value

the index of the PivotField Object in this PivotFields.

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection.AddByBaseIndex Method

Adds a PivotField Object to the specific type PivotFields.

public int AddByBaseIndex(
int baseFieldIndex
);

Parameters

baseFieldIndex
field index in the base PivotFields.

Return Value

the index of the PivotField Object in this PivotFields.

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection.Clear Method

clear all fields of PivotFieldCollection

public void Clear();

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldCollection.GetEnumerator Method

Gets an enumerator over the elements in this collection in proper sequence.

public IEnumerator GetEnumerator();

Return Value

enumerator

Implements

IEnumerable.GetEnumerator

See Also

PivotFieldCollection Class | Aspose.Cells.Pivot Namespace


PivotFieldDataDisplayFormat Enumeration

Represents data display format in the PivotTable data field.

public enum PivotFieldDataDisplayFormat

Members

Member Name | Description | Value
Normal | Represents normal display format. | 0
DifferenceFrom | Represents difference from display format. | 1
PercentageOf | Represents percentage of display format. | 2
PercentageDifferenceFrom | Represents percentage difference from display format. | 3
RunningTotalIn | Represents running total in display format. | 4
PercentageOfRow | Represents percentage of row display format. | 5
PercentageOfColumn | Represents percentage of column display format. | 6
PercentageOfTotal | Represents percentage of total display format. | 7
Index | Represents index display format. | 8
PercentageOfParentRowTotal | Represents percentage of parent row total display format. | 9
PercentageOfParentColumnTotal | Represents percentage of parent column total display format. | 10
PercentageOfParentTotal | Represents percentage of parent total display format. | 11
PercentageOfRunningTotalIn | Represents percentage of running total in display format. | 12
RankSmallestToLargest | Represents smallest to largest display format. | 13
RankLargestToSmallest | Represents largest to smallest display format. | 14

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotFieldSubtotalType Enumeration

Summary description for PivotFieldSubtotalType.

public enum PivotFieldSubtotalType

Members

Member Name | Description | Value
None | Represents None subtotal type. | 0
Automatic | Represents Automatic subtotal type. | 1
Sum | Represents Sum subtotal type. | 2
Count | Represents Count subtotal type. | 4
Average | Represents Average subtotal type. | 8
Max | Represents Max subtotal type. | 16
Min | Represents Min subtotal type. | 32
Product | Represents Product subtotal type. | 64
CountNums | Represents Count Nums subtotal type. | 128
Stdev | Represents Stdev subtotal type. | 256
Stdevp | Represents Stdevp subtotal type. | 512
Var | Represents Var subtotal type. | 1024
Varp | Represents Varp subtotal type. | 2048

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotFieldType Enumeration

Represents PivotTable field type.

public enum PivotFieldType

Members

Member Name | Description | Value
Undefined | Presents base pivot field type. | 0
Row | Presents row pivot field type. | 1
Column | Presents column pivot field type. | 2
Page | Presents page pivot field type. | 4
Data | Presents data pivot field type. | 8

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotFilter Class

Represents a PivotFilter in PivotFilter Collection.

For a list of all members of this type, see PivotFilter Members.

System.Object
Aspose.Cells.Pivot.PivotFilter

public class PivotFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotFilter Members | Aspose.Cells.Pivot Namespace


PivotFilter Members

PivotFilter overview

Public Instance Properties

AutoFilter | Gets the autofilter of the pivot filter.
EvaluationOrder | Gets the Evaluation Order of the pivot filter.
FieldIndex | Gets the field index of the pivot filter.
FilterType | Gets the autofilter type of the pivot filter.
MeasureFldIndex | Gets the measure field index of the pivot filter.
MemberPropertyFieldIndex | Gets the member property field index of the pivot filter.
Name | Gets the name of the pivot filter.
Value1 | Gets the string value1 of the label pivot filter.
Value2 | Gets the string value2 of the label pivot filter.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


PivotFilter Properties

The properties of the PivotFilter class are listed below. For a complete list of PivotFilter class members, see the PivotFilter Members topic.

Public Instance Properties

AutoFilter | Gets the autofilter of the pivot filter.
EvaluationOrder | Gets the Evaluation Order of the pivot filter.
FieldIndex | Gets the field index of the pivot filter.
FilterType | Gets the autofilter type of the pivot filter.
MeasureFldIndex | Gets the measure field index of the pivot filter.
MemberPropertyFieldIndex | Gets the member property field index of the pivot filter.
Name | Gets the name of the pivot filter.
Value1 | Gets the string value1 of the label pivot filter.
Value2 | Gets the string value2 of the label pivot filter.

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


AutoFilter Property

Aspose.Cells for .NET

PivotFilter.AutoFilter Property

Gets the autofilter of the pivot filter.

public AutoFilter AutoFilter {get;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


EvaluationOrder Property

Aspose.Cells for .NET

PivotFilter.EvaluationOrder Property

Gets the Evaluation Order of the pivot filter.

public int EvaluationOrder {get; set;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


FieldIndex Property

Aspose.Cells for .NET

PivotFilter.FieldIndex Property

Gets the field index of the pivot filter.

public int FieldIndex {get;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


FilterType Property

Aspose.Cells for .NET

PivotFilter.FilterType Property

Gets the autofilter type of the pivot filter.

public PivotFilterType FilterType {get;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


MeasureFldIndex Property

Aspose.Cells for .NET

PivotFilter.MeasureFldIndex Property

Gets the measure field index of the pivot filter.

public int MeasureFldIndex {get; set;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


MemberPropertyFieldIndex Property

Aspose.Cells for .NET

PivotFilter.MemberPropertyFieldIndex Property

Gets the member property field index of the pivot filter.

public int MemberPropertyFieldIndex {get; set;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


Name Property

Aspose.Cells for .NET

PivotFilter.Name Property

Gets the name of the pivot filter.

public string Name {get; set;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


Value1 Property

Aspose.Cells for .NET

PivotFilter.Value1 Property

Gets the string value1 of the label pivot filter.

public string Value1 {get; set;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


Value2 Property

Aspose.Cells for .NET

PivotFilter.Value2 Property

Gets the string value2 of the label pivot filter.

public string Value2 {get; set;}

See Also

PivotFilter Class | Aspose.Cells.Pivot Namespace


PivotFilterCollection Class

Represents a collection of all the PivotFilter objects

For a list of all members of this type, see PivotFilterCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Pivot.PivotFilterCollection

public class PivotFilterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotFilterCollection Members | Aspose.Cells.Pivot Namespace


PivotFilterCollection Members

PivotFilterCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the pivotfilter object at the specific index.

Public Instance Methods

Add | Adds a PivotFilter Object to the specific type
Clear (inherited from CollectionBase) |
ClearFilter | Clear PivotFilter from the specific PivotField
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

PivotFilterCollection Class | Aspose.Cells.Pivot Namespace


PivotFilterCollection Properties

The properties of the PivotFilterCollection class are listed below. For a complete list of PivotFilterCollection class members, see the PivotFilterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the pivotfilter object at the specific index.

See Also

PivotFilterCollection Class | Aspose.Cells.Pivot Namespace


Item Property

Aspose.Cells for .NET

PivotFilterCollection.Item Property

Gets the pivotfilter object at the specific index.

public PivotFilter this[
int index
] {get;}

See Also

PivotFilterCollection Class | Aspose.Cells.Pivot Namespace


PivotFilterCollection Methods

The methods of the PivotFilterCollection class are listed below. For a complete list of PivotFilterCollection class members, see the PivotFilterCollection Members topic.

Public Instance Methods

Add | Adds a PivotFilter Object to the specific type
Clear (inherited from CollectionBase) |
ClearFilter | Clear PivotFilter from the specific PivotField
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

PivotFilterCollection Class | Aspose.Cells.Pivot Namespace


PivotFilterCollection.Add Method

Adds a PivotFilter Object to the specific type

public int Add(
int fieldIndex,
PivotFilterType type
);

Parameters

fieldIndex
the PivotField index
type
the PivotFilter type

Return Value

the index of the PivotFilter Object in this PivotFilterCollection.

See Also

PivotFilterCollection Class | Aspose.Cells.Pivot Namespace


PivotFilterCollection.ClearFilter Method

Clear PivotFilter from the specific PivotField

public void ClearFilter(
int fieldIndex
);

Parameters

fieldIndex
the PivotField index

See Also

PivotFilterCollection Class | Aspose.Cells.Pivot Namespace


PivotFilterType Enumeration

Represents PivotTable Filter type.

public enum PivotFilterType

Members

Member Name | Description | Value
CaptionBeginsWith | Indicates the "begins with" filter for field captions. | 0
CaptionBetween | Indicates the "is between" filter for field captions. | 1
CaptionContains | Indicates the "contains" filter for field captions. | 2
CaptionEndsWith | Indicates the "ends with" filter for field captions. | 3
CaptionEqual | Indicates the "equal" filter for field captions. | 4
CaptionGreaterThan | Indicates the "is greater than" filter for field captions. | 5
CaptionGreaterThanOrEqual | Indicates the "is greater than or equal to" filter for field captions. | 6
CaptionLessThan | Indicates the "is less than" filter for field captions. | 7
CaptionLessThanOrEqual | Indicates the "is less than or equal to" filter for field captions. | 8
CaptionNotBeginsWith | Indicates the "does not begin with" filter for field captions. | 9
CaptionNotBetween | Indicates the "is not between" filter for field captions. | 10
CaptionNotContains | Indicates the "does not contain" filter for field captions. | 11
CaptionNotEndsWith | Indicates the "does not end with" filter for field captions. | 12
CaptionNotEqual | Indicates the "not equal" filter for field captions. | 13
Count | Indicates the "count" filter. | 14
DateBetween | Indicates the "between" filter for date values. | 15
DateEqual | Indicates the "equals" filter for date values. | 16
DateNewerThan | Indicates the "newer than" filter for date values. | 17
DateNewerThanOrEqual | Indicates the "newer than or equal to" filter for date values. | 18
DateNotBetween | Indicates the "not between" filter for date values. | 19
DateNotEqual | Indicates the "does not equal" filter for date values. | 20
DateOlderThan | Indicates the "older than" filter for date values. | 21
DateOlderThanOrEqual | Indicates the "older than or equal to" filter for date values. | 22
LastMonth | Indicates the "last month" filter for date values. | 23
LastQuarter | Indicates the "last quarter" filter for date values. | 24
LastWeek | Indicates the "last week" filter for date values. | 25
LastYear | Indicates the "last year" filter for date values. | 26
M1 | Indicates the "January" filter for date values. | 27
M2 | Indicates the "February" filter for date values. | 28
M3 | Indicates the "March" filter for date values. | 29
M4 | Indicates the "April" filter for date values. | 30
M5 | Indicates the "May" filter for date values. | 31
M6 | Indicates the "June" filter for date values. | 32
M7 | Indicates the "July" filter for date values. | 33
M8 | Indicates the "August" filter for date values. | 34
M9 | Indicates the "September" filter for date values. | 35
M10 | Indicates the "October" filter for date values. | 36
M11 | Indicates the "November" filter for date values. | 37
M12 | Indicates the "December" filter for date values. | 38
NextMonth | Indicates the "next month" filter for date values. | 39
NextQuarter | Indicates the "next quarter" for date values. | 40
NextWeek | Indicates the "next week" for date values. | 41
NextYear | Indicates the "next year" filter for date values. | 42
Percent | Indicates the "percent" filter for numeric values. | 43
Q1 | Indicates the "first quarter" filter for date values. | 44
Q2 | Indicates the "second quarter" filter for date values. | 45
Q3 | Indicates the "third quarter" filter for date values. | 46
Q4 | Indicates the "fourth quarter" filter for date values. | 47
Sum | Indicates the "sum" filter for numeric values. | 48
ThisMonth | Indicates the "this month" filter for date values. | 49
ThisQuarter | Indicates the "this quarter" filter for date values. | 50
ThisWeek | Indicates the "this week" filter for date values. | 51
ThisYear | Indicate the "this year" filter for date values. | 52
Today | Indicates the "today" filter for date values. | 53
Tomorrow | Indicates the "tomorrow" filter for date values. | 54
Unknown | Indicates the PivotTable filter is unknown to the application. | 55
ValueBetween | Indicates the "Value between" filter for text and numeric values. | 56
ValueEqual | Indicates the "value equal" filter for text and numeric values. | 57
ValueGreaterThan | Indicates the "value greater than" filter for text and numeric values. | 58
ValueGreaterThanOrEqual | Indicates the "value greater than or equal to" filter for text and numeric values. | 59
ValueLessThan | Indicates the "value less than" filter for text and numeric values. | 60
ValueLessThanOrEqual | Indicates the "value less than or equal to" filter for text and numeric values. | 61
ValueNotBetween | Indicates the "value not between" filter for text and numeric values. | 62
ValueNotEqual | Indicates the "value not equal" filter for text and numeric values. | 63
YearToDate | Indicates the "year-to-date" filter for date values. | 64
Yesterday | Indicates the "yesterday" filter for date values. | 65

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotFormatCondition Class

Represents a PivotTable Format Condition in PivotFormatCondition Collection.

For a list of all members of this type, see PivotFormatCondition Members.

System.Object
Aspose.Cells.Pivot.PivotFormatCondition

public class PivotFormatCondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotFormatCondition Members | Aspose.Cells.Pivot Namespace


PivotFormatCondition Members

PivotFormatCondition overview

Public Instance Properties

FormatConditions | Get formatconditions for the pivot table condition format .
RuleType | Get and set rule type for the pivot table condition format .
ScopeType | Get and set scope type for the pivot table condition format .

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PivotFormatCondition Class | Aspose.Cells.Pivot Namespace


PivotFormatCondition Properties

The properties of the PivotFormatCondition class are listed below. For a complete list of PivotFormatCondition class members, see the PivotFormatCondition Members topic.

Public Instance Properties

FormatConditions | Get formatconditions for the pivot table condition format .
RuleType | Get and set rule type for the pivot table condition format .
ScopeType | Get and set scope type for the pivot table condition format .

See Also

PivotFormatCondition Class | Aspose.Cells.Pivot Namespace


FormatConditions Property

Aspose.Cells for .NET

PivotFormatCondition.FormatConditions Property

Get formatconditions for the pivot table condition format .

public FormatConditionCollection FormatConditions {get;}

See Also

PivotFormatCondition Class | Aspose.Cells.Pivot Namespace


RuleType Property

Aspose.Cells for .NET

PivotFormatCondition.RuleType Property

Get and set rule type for the pivot table condition format .

public PivotConditionFormatRuleType RuleType {get; set;}

See Also

PivotFormatCondition Class | Aspose.Cells.Pivot Namespace


ScopeType Property

Aspose.Cells for .NET

PivotFormatCondition.ScopeType Property

Get and set scope type for the pivot table condition format .

public PivotConditionFormatScopeType ScopeType {get; set;}

See Also

PivotFormatCondition Class | Aspose.Cells.Pivot Namespace


PivotFormatConditionCollection Class

Represents PivotTable Format Conditions.

For a list of all members of this type, see PivotFormatConditionCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Pivot.PivotFormatConditionCollection

public class PivotFormatConditionCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotFormatConditionCollection Members | Aspose.Cells.Pivot Namespace


PivotFormatConditionCollection Members

PivotFormatConditionCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the pivot FormatCondition object at the specific index.

Public Instance Methods

Add | Adds a pivot FormatCondition to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

PivotFormatConditionCollection Class | Aspose.Cells.Pivot Namespace


PivotFormatConditionCollection Properties

The properties of the PivotFormatConditionCollection class are listed below. For a complete list of PivotFormatConditionCollection class members, see the PivotFormatConditionCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets the pivot FormatCondition object at the specific index.

See Also

PivotFormatConditionCollection Class | Aspose.Cells.Pivot Namespace


Item Property

Aspose.Cells for .NET

PivotFormatConditionCollection.Item Property

Gets the pivot FormatCondition object at the specific index.

public PivotFormatCondition this[
int index
] {get;}

See Also

PivotFormatConditionCollection Class | Aspose.Cells.Pivot Namespace


PivotFormatConditionCollection Methods

The methods of the PivotFormatConditionCollection class are listed below. For a complete list of PivotFormatConditionCollection class members, see the PivotFormatConditionCollection Members topic.

Public Instance Methods

Add | Adds a pivot FormatCondition to the collection.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

PivotFormatConditionCollection Class | Aspose.Cells.Pivot Namespace


PivotFormatConditionCollection.Add Method

Adds a pivot FormatCondition to the collection.

public int Add();

Return Value

pivot FormatCondition object index.

Remarks

not supported

See Also

PivotFormatConditionCollection Class | Aspose.Cells.Pivot Namespace


PivotGroupByType Enumeration

Represents PivotTable groupby type.

public enum PivotGroupByType

Members

Member Name | Description | Value
RangeOfValues | Presents range of values groupby type. | 0
Seconds | Presents Seconds groupby type. | 1
Minutes | Presents Minutes groupby type. | 2
Hours | Presents Hours groupby type. | 3
Days | Presents Days groupby type. | 4
Months | Presents Months groupby type. | 5
Quarters | Presents Quarters groupby type. | 6
Years | Presents Years groupby type. | 7

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotItem Class

Represents a item in a PivotField report.

For a list of all members of this type, see PivotItem Members.

System.Object
Aspose.Cells.Pivot.PivotItem

public class PivotItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotItem Members | Aspose.Cells.Pivot Namespace


PivotItem Members

PivotItem overview

Public Instance Properties

Index | Gets the index of the pivot item in the pivot field
IsHidden | Gets and Sets whether the pivot item is hidden.
Name | Gets the name of the pivot item.
Position | Specifying the position index in all the PivotItems,not the PivotItems under the same parent node.
PositionInSameParentNode | Specifying the position index in the PivotItems under the same parent node.
Value | Gets the value of the pivot item

Public Instance Methods

Equals (inherited from Object) |
GetDateTimeValue | Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue
GetDoubleValue | Gets the double value of the pivot item If the value is null or not number ,it will return 0
GetHashCode (inherited from Object) |
GetStringValue | Gets the string value of the pivot item If the value is null, it will return ""
GetType (inherited from Object) |
Move | Moves the item up or down
ToString (inherited from Object) |

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItem Properties

The properties of the PivotItem class are listed below. For a complete list of PivotItem class members, see the PivotItem Members topic.

Public Instance Properties

Index | Gets the index of the pivot item in the pivot field
IsHidden | Gets and Sets whether the pivot item is hidden.
Name | Gets the name of the pivot item.
Position | Specifying the position index in all the PivotItems,not the PivotItems under the same parent node.
PositionInSameParentNode | Specifying the position index in the PivotItems under the same parent node.
Value | Gets the value of the pivot item

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


Index Property

Aspose.Cells for .NET

PivotItem.Index Property

Gets the index of the pivot item in the pivot field

public int Index {get; set;}

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


IsHidden Property

Aspose.Cells for .NET

PivotItem.IsHidden Property

Gets and Sets whether the pivot item is hidden.

public bool IsHidden {get; set;}

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


Name Property

Aspose.Cells for .NET

PivotItem.Name Property

Gets the name of the pivot item.

public string Name {get;}

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


Position Property

Aspose.Cells for .NET

PivotItem.Position Property

Specifying the position index in all the PivotItems,not the PivotItems under the same parent node.

public int Position {set;}

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PositionInSameParentNode Property

Aspose.Cells for .NET

PivotItem.PositionInSameParentNode Property

Specifying the position index in the PivotItems under the same parent node.

public int PositionInSameParentNode {set;}

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


Value Property

Aspose.Cells for .NET

PivotItem.Value Property

Gets the value of the pivot item

public object Value {get;}

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItem Methods

The methods of the PivotItem class are listed below. For a complete list of PivotItem class members, see the PivotItem Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetDateTimeValue | Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue
GetDoubleValue | Gets the double value of the pivot item If the value is null or not number ,it will return 0
GetHashCode (inherited from Object) |
GetStringValue | Gets the string value of the pivot item If the value is null, it will return ""
GetType (inherited from Object) |
Move | Moves the item up or down
ToString (inherited from Object) |

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItem.GetDateTimeValue Method

Gets the date time value of the pivot item If the value is null ,it will return DateTime.MinValue

public DateTime GetDateTimeValue();

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItem.GetDoubleValue Method

Gets the double value of the pivot item If the value is null or not number ,it will return 0

public double GetDoubleValue();

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItem.GetStringValue Method

Gets the string value of the pivot item If the value is null, it will return ""

public string GetStringValue();

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItem.Move Method

Moves the item up or down

public void Move(
int count,
bool isSameParent
);

Parameters

count
The number of moving up or down. Move the item up if this is less than zero; Move the item down if this is greater than zero.
isSameParent
Specifying whether moving operation is in the same parent node or not

See Also

PivotItem Class | Aspose.Cells.Pivot Namespace


PivotItemCollection Class

Represents a collection of all the PivotItem objects in the PivotField's

For a list of all members of this type, see PivotItemCollection Members.

System.Object
Aspose.Cells.Pivot.PivotItemCollection

public class PivotItemCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotItemCollection Members | Aspose.Cells.Pivot Namespace


PivotItemCollection Members

PivotItemCollection overview

Public Instance Properties

Count | Gets the count of the pivot items.
Item | Overloaded. Gets the PivotItem Object at the specific index.

Public Instance Methods

ChangeitemsOrder | Directly changes the orders of the two items.
Equals (inherited from Object) |
GetEnumerator | Gets an enumerator over the elements in this collection in proper sequence.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


PivotItemCollection Properties

The properties of the PivotItemCollection class are listed below. For a complete list of PivotItemCollection class members, see the PivotItemCollection Members topic.

Public Instance Properties

Count | Gets the count of the pivot items.
Item | Overloaded. Gets the PivotItem Object at the specific index.

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


Count Property

Aspose.Cells for .NET

PivotItemCollection.Count Property

Gets the count of the pivot items.

public int Count {get;}

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


Item Property

Aspose.Cells for .NET

PivotItemCollection.Item Property

Gets the PivotItem Object at the specific index.

Overload List

Gets the PivotItem Object at the specific index.

public PivotItem this[int] {get;}

Gets the PivotItem Object of the specific name.

public PivotItem this[string] {get;}

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotItemCollection.Item Property (Int32)

Gets the PivotItem Object at the specific index.

public PivotItem this[
int index
] {get;}

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace | PivotItemCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotItemCollection.Item Property (String)

Gets the PivotItem Object of the specific name.

public PivotItem this[
string itemValue
] {get;}

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace | PivotItemCollection.Item Overload List


PivotItemCollection Methods

The methods of the PivotItemCollection class are listed below. For a complete list of PivotItemCollection class members, see the PivotItemCollection Members topic.

Public Instance Methods

ChangeitemsOrder | Directly changes the orders of the two items.
Equals (inherited from Object) |
GetEnumerator | Gets an enumerator over the elements in this collection in proper sequence.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


PivotItemCollection.ChangeitemsOrder Method

Directly changes the orders of the two items.

public void ChangeitemsOrder(
int sourceIndex,
int destIndex
);

Parameters

sourceIndex
The current index
destIndex
The dest index

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


PivotItemCollection.GetEnumerator Method

Gets an enumerator over the elements in this collection in proper sequence.

public IEnumerator GetEnumerator();

Return Value

enumerator

Implements

IEnumerable.GetEnumerator

See Also

PivotItemCollection Class | Aspose.Cells.Pivot Namespace


PivotItemPosition Enumeration

Represents PivotTable base item Next/Previous/All position in the base field .

public enum PivotItemPosition

Members

Member Name | Description | Value
Previous | Represents the previous pivot item in the PivotField. | 0
Next | Represents the next pivot item in the PivotField. | 1
Custom | Represents a pivot item index, as specified by Pivot Items, that specifies a pivot item in the PivotField. only read | 2

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotMissingItemLimitType Enumeration

Represents number of items to retain per field.

public enum PivotMissingItemLimitType

Members

Member Name | Description | Value
Automatic | The default number of unique items per PivotField allowed. | 0
Max | The maximum number of unique items per PivotField allowed (>32,500). | 1
None | No unique items per PivotField allowed. | 2

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotPageFields Class

Represents the pivot page field items if the pivot table data source is consolidation ranges. It only can contain up to 4 fields.

For a list of all members of this type, see PivotPageFields Members.

System.Object
Aspose.Cells.Pivot.PivotPageFields

public class PivotPageFields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotPageFields Members | Aspose.Cells.Pivot Namespace


PivotPageFields Members

PivotPageFields overview

Public Instance Constructors

PivotPageFields Constructor Represents the pivot page field items.

Public Instance Properties

PageFieldCount Gets the number of page fields.

Public Instance Methods

AddIdentify | Sets which item label in each page field to use to identify the data range. The pageItemIndex.Length must be equal to PageFieldCount, so please add the page field first.
AddPageField | Adds a page field.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PivotPageFields Constructor

Represents the pivot page field items.

public PivotPageFields();

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PivotPageFields Properties

The properties of the PivotPageFields class are listed below. For a complete list of PivotPageFields class members, see the PivotPageFields Members topic.

Public Instance Properties

PageFieldCount Gets the number of page fields.

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PageFieldCount Property

Aspose.Cells for .NET

PivotPageFields.PageFieldCount Property

Gets the number of page fields.

public int PageFieldCount {get;}

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PivotPageFields Methods

The methods of the PivotPageFields class are listed below. For a complete list of PivotPageFields class members, see the PivotPageFields Members topic.

Public Instance Methods

AddIdentify | Sets which item label in each page field to use to identify the data range. The pageItemIndex.Length must be equal to PageFieldCount, so please add the page field first.
AddPageField | Adds a page field.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PivotPageFields.AddIdentify Method

Sets which item label in each page field to use to identify the data range. The pageItemIndex.Length must be equal to PageFieldCount, so please add the page field first.

public void AddIdentify(
int rangeIndex,
int[] pageItemIndex
);

Parameters

rangeIndex
The consolidation data range index.
pageItemIndex
The page item index in the each page field. pageItemIndex[2] = 1 means the second item in the third field to use to identify this range. pageItemIndex[1] = -1 means no item in the second field to use to identify this range and MS will auto create "blank" item in the second field to identify this range.

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PivotPageFields.AddPageField Method

Adds a page field.

public void AddPageField(
string[] pageItems
);

Parameters

pageItems
Page field item label

See Also

PivotPageFields Class | Aspose.Cells.Pivot Namespace


PivotTable Class

Summary description for PivotTable.

For a list of all members of this type, see PivotTable Members.

System.Object
Aspose.Cells.Pivot.PivotTable

public class PivotTable : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotTable Members | Aspose.Cells.Pivot Namespace


PivotTable Members

PivotTable overview

Public Instance Properties

AltTextDescription | Gets the description of the alt text
AltTextTitle | Gets the title of the altertext
AutoFormatType | Gets the PivotTable auto format type.
BaseFields | Returns a PivotFields object that includes all fields in the PivotTable report
ColumnFields | Returns a PivotFields object that are currently shown as column fields.
ColumnGrand | Indicates whether the PivotTable report shows grand totals for columns.
ColumnHeaderCaption | Gets the Column Header Caption of the PivotTable.
ColumnRange | Returns a CellArea object that represents the range that contains the column area in the PivotTable report. Read-only.
CustomListSort | Indicates whether consider built-in custom list when sort data
DataBodyRange | Returns a CellArea object that represents the range that contains the data area in the list between the header row and the insert row. Read-only.
DataField | Gets a PivotField object that represents all the data fields in a PivotTable. Read-only.It would be init only when there are two or more data fields in the DataPiovtFiels. It only use to add DataPivotField to the PivotTable row/column area . Default is in row area.
DataFields | Gets a PivotField object that represents all the data fields in a PivotTable. Read-only.It would be init only when there are two or more data fields in the DataPiovtFiels. It only use to add DataPivotField to the PivotTable row/column area . Default is in row area.
DataSource | Gets and sets the data source of the pivot table.
DisplayErrorString | Indicates whether the PivotTable report displays a custom string in cells that contain errors.
DisplayImmediateItems | Indicates whether items in the row and column areas are visible when the data area of the PivotTable is empty. The default value is true.
DisplayNullString | Indicates whether the PivotTable report displays a custom string in cells that contain null values.
EnableDataValueEditing | Specifies a boolean value that indicates whether the user is allowed to edit the cells in the data area of the pivottable. Enable cell editing in the values area
EnableDrilldown | Gets whether drilldown is enabled.
EnableFieldDialog | Indicates whether the PivotTable Field dialog box is available when the user double-clicks the PivotTable field.
EnableFieldList | Gets whether enable the field list for the PivotTable.
EnableWizard | Indicates whether the PivotTable Wizard is available.
ErrorString | Gets the string displayed in cells that contain errors when the DisplayErrorString property is true.The default value is an empty string.
ExternalConnectionDataSource | Gets the external connection data source.
FieldListSortAscending | Specifies a boolean value that indicates whether fields in the PivotTable are sorted in non-default order in the field list.
GrandTotalName | Returns the text string label that is displayed in the grand total column or row heading. The default value is the string "Grand Total".
HasBlankRows | Indicates whether to add blank rows. This property only applies for the PivotTable auto format types which needs to add blank rows.
Indent | Specifies the indentation increment for compact axis and can be used to set the Report Layout to Compact Form.
IsAutoFormat | Indicates whether the PivotTable report is automatically formatted. Checkbox "autoformat table " which is in pivottable option for Excel 2003 Checkbox "autofit column width on update" which is in pivot table Options :Layout Format for Excel 2007
IsExcel2003Compatible | Specifies whether the PivotTable is compatible for Excel2003 when refreshing PivotTable, if true, a string must be less than or equal to 255 characters, so if the string is greater than 255 characters, it will be truncated. if false, a string will not have the aforementioned restriction. The default value is true.
IsGridDropZones | Indicates whether the PivotTable report displays classic pivottable layout. (enables dragging fields in the grid)
IsMultipleFieldFilters | Specifies a boolean value that indicates whether the fields of a PivotTable can have multiple filters set on them.
IsSelected | Indicates whether the PivotTable is selected.
ItemPrintTitles | A bit that specifies whether pivot item captions on the row axis are repeated on each printed page for pivot fields in tabular form.
ManualUpdate | Indicates whether the PivotTable report is recalculated only at the user's request.
MergeLabels | Indicates whether the specified PivotTable report's outer-row item, column item, subtotal, and grand total labels use merged cells.
MissingItemsLimit | Specifies a boolean value that indicates whether the fields of a PivotTable can have multiple filters set on them.
Name | Gets the name of the PivotTable
NullString | Gets the string displayed in cells that contain null values when the DisplayNullString property is true.The default value is an empty string.
PageFieldOrder | Gets the order in which page fields are added to the PivotTable report's layout.
PageFields | Returns a PivotFields object that are currently shown as page fields.
PageFieldWrapCount | Gets the number of page fields in each column or row in the PivotTable report.
PivotFilters | Returns a PivotFilterCollection object.
PivotFormatConditions | Gets the Format Conditions of the pivot table.
PivotTableStyleName | Gets and sets the pivottable style name.
PivotTableStyleType | Gets and sets the built-in pivot table style.
PreserveFormatting | Indicates whether formatting is preserved when the PivotTable is refreshed or recalculated.
PrintDrill | Specifies a boolean value that indicates whether drill indicators should be printed. print expand/collapse buttons when displayed on pivottable.
PrintTitles | Indicates whether the print titles for the worksheet are set based on the PivotTable report. The default value is false.
RefreshDataFlag | Indicates whether Refresh Data or not.
RefreshDataOnOpeningFile | Indicates whether Refresh Data when Opening File.
RefreshDate | Gets the date when the PivotTable was last refreshed.
RefreshedByWho | Gets the name of the user who last refreshed the PivotTable
RowFields | Returns a PivotFields object that are currently shown as row fields.
RowGrand | Indicates whether the PivotTable report shows grand totals for rows.
RowHeaderCaption | Gets the Row Header Caption of the PivotTable.
RowRange | Returns a CellArea object that represents the range that contains the row area in the PivotTable report. Read-only.
SaveData | Indicates whether data for the PivotTable report is saved with the workbook.
ShowDataTips | Specifies a boolean value that indicates whether tooltips should be displayed for PivotTable data cells.
ShowDrill | Gets whether expand/collapse buttons is shown.
ShowEmptyCol | Specifies a boolean value that indicates whether to include empty columns in the table
ShowEmptyRow | Specifies a boolean value that indicates whether to include empty rows in the table.
ShowMemberPropertyTips | Specifies a boolean value that indicates whether member property information should be omitted from PivotTable tooltips.
ShowPivotStyleColumnHeader | Indicates whether the column header in the pivot table should have the style applied.
ShowPivotStyleColumnStripes | Indicates whether column stripe formatting is applied.
ShowPivotStyleLastColumn | Indicates whether column stripe formatting is applied.
ShowPivotStyleRowHeader | Indicates whether the row header in the pivot table should have the style applied.
ShowPivotStyleRowStripes | Indicates whether row stripe formatting is applied.
ShowRowHeaderCaption | Indicates whether row header caption is shown in the PivotTable report Indicates whether Display field captions and filter drop downs
ShowValuesRow | Specifies a boolean value that indicates whether show values row. show the values row
SubtotalHiddenPageItems | Indicates whether hidden page field items in the PivotTable report are included in row and column subtotals, block totals, and grand totals. The default value is False.
TableRange1 | Returns a CellArea object that represents the range containing the entire PivotTable report, but doesn't include page fields. Read-only.
TableRange2 | Returns a CellArea object that represents the range containing the entire PivotTable report, includes page fields. Read-only.
Tag | Gets a string saved with the PivotTable report.

Public Instance Methods

AddCalculatedField | Overloaded. Adds a calculated field to pivot field.
AddFieldToArea | Overloaded. Adds the field to the specific area.
CalculateData | Calculates pivottable's data to cells.
CalculateRange | Calculates pivottable's range.
ChangeDataSource | Set pivottable's source data. Sheet1!$A$1:$C$3
ClearData | Clear PivotTable's data and formatting
CopyStyle | Copies named style from another pivot table.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
Fields | Gets the specific fields by the field type.
Format | Format the cell in the pivottable area
FormatAll | Format all the cell in the pivottable area
GetCellByDisplayName | Gets the Cell object by the DisplayName of PivotField
GetChildren | Gets the Children Pivot Tables which use this PivotTable data as data source.
GetHashCode (inherited from Object) |
GetHorizontalBreaks | get pivot table row index list of horizontal pagebreaks
GetSource | Get pivottable's source data.
GetType (inherited from Object) |
Move | Overloaded. Moves the PivotTable to a different location in the worksheet.
RefreshData | Refreshes pivottable's data and setting from it's data source.
RemoveField | Overloaded. Removes a field from specific field area
SetAutoGroupField | Overloaded. Sets auto field group by the PivotTable.
SetManualGroupField | Overloaded. Sets manual field group by the PivotTable.
SetUngroup | Overloaded. Sets ungroup by the PivotTable
ShowInCompactForm | Layouts the PivotTable in compact form.
ShowInOutlineForm | Layouts the PivotTable in outline form.
ShowInTabularForm | Layouts the PivotTable in tabular form.
ShowReportFilterPage | Show all the report filter pages according to PivotField, the PivotField must be located in the PageFields.
ShowReportFilterPageByIndex | Show all the report filter pages according to the position index in the PageFields
ShowReportFilterPageByName | Show all the report filter pages according to PivotField's name, the PivotField must be located in the PageFields.
ToString (inherited from Object) |

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable Properties

The properties of the PivotTable class are listed below. For a complete list of PivotTable class members, see the PivotTable Members topic.

Public Instance Properties

AltTextDescription | Gets the description of the alt text
AltTextTitle | Gets the title of the altertext
AutoFormatType | Gets the PivotTable auto format type.
BaseFields | Returns a PivotFields object that includes all fields in the PivotTable report
ColumnFields | Returns a PivotFields object that are currently shown as column fields.
ColumnGrand | Indicates whether the PivotTable report shows grand totals for columns.
ColumnHeaderCaption | Gets the Column Header Caption of the PivotTable.
ColumnRange | Returns a CellArea object that represents the range that contains the column area in the PivotTable report. Read-only.
CustomListSort | Indicates whether consider built-in custom list when sort data
DataBodyRange | Returns a CellArea object that represents the range that contains the data area in the list between the header row and the insert row. Read-only.
DataField | Gets a PivotField object that represents all the data fields in a PivotTable. Read-only.It would be init only when there are two or more data fields in the DataPiovtFiels. It only use to add DataPivotField to the PivotTable row/column area . Default is in row area.
DataFields | Gets a PivotField object that represents all the data fields in a PivotTable. Read-only.It would be init only when there are two or more data fields in the DataPiovtFiels. It only use to add DataPivotField to the PivotTable row/column area . Default is in row area.
DataSource | Gets and sets the data source of the pivot table.
DisplayErrorString | Indicates whether the PivotTable report displays a custom string in cells that contain errors.
DisplayImmediateItems | Indicates whether items in the row and column areas are visible when the data area of the PivotTable is empty. The default value is true.
DisplayNullString | Indicates whether the PivotTable report displays a custom string in cells that contain null values.
EnableDataValueEditing | Specifies a boolean value that indicates whether the user is allowed to edit the cells in the data area of the pivottable. Enable cell editing in the values area
EnableDrilldown | Gets whether drilldown is enabled.
EnableFieldDialog | Indicates whether the PivotTable Field dialog box is available when the user double-clicks the PivotTable field.
EnableFieldList | Gets whether enable the field list for the PivotTable.
EnableWizard | Indicates whether the PivotTable Wizard is available.
ErrorString | Gets the string displayed in cells that contain errors when the DisplayErrorString property is true.The default value is an empty string.
ExternalConnectionDataSource | Gets the external connection data source.
FieldListSortAscending | Specifies a boolean value that indicates whether fields in the PivotTable are sorted in non-default order in the field list.
GrandTotalName | Returns the text string label that is displayed in the grand total column or row heading. The default value is the string "Grand Total".
HasBlankRows | Indicates whether to add blank rows. This property only applies for the PivotTable auto format types which needs to add blank rows.
Indent | Specifies the indentation increment for compact axis and can be used to set the Report Layout to Compact Form.
IsAutoFormat | Indicates whether the PivotTable report is automatically formatted. Checkbox "autoformat table " which is in pivottable option for Excel 2003 Checkbox "autofit column width on update" which is in pivot table Options :Layout Format for Excel 2007
IsExcel2003Compatible | Specifies whether the PivotTable is compatible for Excel2003 when refreshing PivotTable, if true, a string must be less than or equal to 255 characters, so if the string is greater than 255 characters, it will be truncated. if false, a string will not have the aforementioned restriction. The default value is true.
IsGridDropZones | Indicates whether the PivotTable report displays classic pivottable layout. (enables dragging fields in the grid)
IsMultipleFieldFilters | Specifies a boolean value that indicates whether the fields of a PivotTable can have multiple filters set on them.
IsSelected | Indicates whether the PivotTable is selected.
ItemPrintTitles | A bit that specifies whether pivot item captions on the row axis are repeated on each printed page for pivot fields in tabular form.
ManualUpdate | Indicates whether the PivotTable report is recalculated only at the user's request.
MergeLabels | Indicates whether the specified PivotTable report's outer-row item, column item, subtotal, and grand total labels use merged cells.
MissingItemsLimit | Specifies a boolean value that indicates whether the fields of a PivotTable can have multiple filters set on them.
Name | Gets the name of the PivotTable
NullString | Gets the string displayed in cells that contain null values when the DisplayNullString property is true.The default value is an empty string.
PageFieldOrder | Gets the order in which page fields are added to the PivotTable report's layout.
PageFields | Returns a PivotFields object that are currently shown as page fields.
PageFieldWrapCount | Gets the number of page fields in each column or row in the PivotTable report.
PivotFilters | Returns a PivotFilterCollection object.
PivotFormatConditions | Gets the Format Conditions of the pivot table.
PivotTableStyleName | Gets and sets the pivottable style name.
PivotTableStyleType | Gets and sets the built-in pivot table style.
PreserveFormatting | Indicates whether formatting is preserved when the PivotTable is refreshed or recalculated.
PrintDrill | Specifies a boolean value that indicates whether drill indicators should be printed. print expand/collapse buttons when displayed on pivottable.
PrintTitles | Indicates whether the print titles for the worksheet are set based on the PivotTable report. The default value is false.
RefreshDataFlag | Indicates whether Refresh Data or not.
RefreshDataOnOpeningFile | Indicates whether Refresh Data when Opening File.
RefreshDate | Gets the date when the PivotTable was last refreshed.
RefreshedByWho | Gets the name of the user who last refreshed the PivotTable
RowFields | Returns a PivotFields object that are currently shown as row fields.
RowGrand | Indicates whether the PivotTable report shows grand totals for rows.
RowHeaderCaption | Gets the Row Header Caption of the PivotTable.
RowRange | Returns a CellArea object that represents the range that contains the row area in the PivotTable report. Read-only.
SaveData | Indicates whether data for the PivotTable report is saved with the workbook.
ShowDataTips | Specifies a boolean value that indicates whether tooltips should be displayed for PivotTable data cells.
ShowDrill | Gets whether expand/collapse buttons is shown.
ShowEmptyCol | Specifies a boolean value that indicates whether to include empty columns in the table
ShowEmptyRow | Specifies a boolean value that indicates whether to include empty rows in the table.
ShowMemberPropertyTips | Specifies a boolean value that indicates whether member property information should be omitted from PivotTable tooltips.
ShowPivotStyleColumnHeader | Indicates whether the column header in the pivot table should have the style applied.
ShowPivotStyleColumnStripes | Indicates whether column stripe formatting is applied.
ShowPivotStyleLastColumn | Indicates whether column stripe formatting is applied.
ShowPivotStyleRowHeader | Indicates whether the row header in the pivot table should have the style applied.
ShowPivotStyleRowStripes | Indicates whether row stripe formatting is applied.
ShowRowHeaderCaption | Indicates whether row header caption is shown in the PivotTable report Indicates whether Display field captions and filter drop downs
ShowValuesRow | Specifies a boolean value that indicates whether show values row. show the values row
SubtotalHiddenPageItems | Indicates whether hidden page field items in the PivotTable report are included in row and column subtotals, block totals, and grand totals. The default value is False.
TableRange1 | Returns a CellArea object that represents the range containing the entire PivotTable report, but doesn't include page fields. Read-only.
TableRange2 | Returns a CellArea object that represents the range containing the entire PivotTable report, includes page fields. Read-only.
Tag | Gets a string saved with the PivotTable report.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


AltTextDescription Property

Aspose.Cells for .NET

PivotTable.AltTextDescription Property

Gets the description of the alt text

public string AltTextDescription {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


AltTextTitle Property

Aspose.Cells for .NET

PivotTable.AltTextTitle Property

Gets the title of the altertext

public string AltTextTitle {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


AutoFormatType Property

Aspose.Cells for .NET

PivotTable.AutoFormatType Property

Gets the PivotTable auto format type.

public PivotTableAutoFormatType AutoFormatType {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


BaseFields Property

Aspose.Cells for .NET

PivotTable.BaseFields Property

Returns a PivotFields object that includes all fields in the PivotTable report

public PivotFieldCollection BaseFields {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ColumnFields Property

Aspose.Cells for .NET

PivotTable.ColumnFields Property

Returns a PivotFields object that are currently shown as column fields.

public PivotFieldCollection ColumnFields {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ColumnGrand Property

Aspose.Cells for .NET

PivotTable.ColumnGrand Property

Indicates whether the PivotTable report shows grand totals for columns.

public bool ColumnGrand {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ColumnHeaderCaption Property

Aspose.Cells for .NET

PivotTable.ColumnHeaderCaption Property

Gets the Column Header Caption of the PivotTable.

public string ColumnHeaderCaption {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ColumnRange Property

Aspose.Cells for .NET

PivotTable.ColumnRange Property

Returns a CellArea object that represents the range that contains the column area in the PivotTable report. Read-only.

public CellArea ColumnRange {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


CustomListSort Property

Aspose.Cells for .NET

PivotTable.CustomListSort Property

Indicates whether consider built-in custom list when sort data

public bool CustomListSort {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DataBodyRange Property

Aspose.Cells for .NET

PivotTable.DataBodyRange Property

Returns a CellArea object that represents the range that contains the data area in the list between the header row and the insert row. Read-only.

public CellArea DataBodyRange {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DataField Property

Aspose.Cells for .NET

PivotTable.DataField Property

Gets a PivotField object that represents all the data fields in a PivotTable. Read-only.It would be init only when there are two or more data fields in the DataPiovtFiels. It only use to add DataPivotField to the PivotTable row/column area . Default is in row area.

public PivotField DataField {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DataFields Property

Aspose.Cells for .NET

PivotTable.DataFields Property

Gets a PivotField object that represents all the data fields in a PivotTable. Read-only.It would be init only when there are two or more data fields in the DataPiovtFiels. It only use to add DataPivotField to the PivotTable row/column area . Default is in row area.

public PivotFieldCollection DataFields {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DataSource Property

Aspose.Cells for .NET

PivotTable.DataSource Property

Gets and sets the data source of the pivot table.

public string[] DataSource {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DisplayErrorString Property

Aspose.Cells for .NET

PivotTable.DisplayErrorString Property

Indicates whether the PivotTable report displays a custom string in cells that contain errors.

public bool DisplayErrorString {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DisplayImmediateItems Property

Aspose.Cells for .NET

PivotTable.DisplayImmediateItems Property

Indicates whether items in the row and column areas are visible when the data area of the PivotTable is empty. The default value is true.

public bool DisplayImmediateItems {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


DisplayNullString Property

Aspose.Cells for .NET

PivotTable.DisplayNullString Property

Indicates whether the PivotTable report displays a custom string in cells that contain null values.

public bool DisplayNullString {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


EnableDataValueEditing Property

Aspose.Cells for .NET

PivotTable.EnableDataValueEditing Property

Specifies a boolean value that indicates whether the user is allowed to edit the cells in the data area of the pivottable. Enable cell editing in the values area

public bool EnableDataValueEditing {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


EnableDrilldown Property

Aspose.Cells for .NET

PivotTable.EnableDrilldown Property

Gets whether drilldown is enabled.

public bool EnableDrilldown {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


EnableFieldDialog Property

Aspose.Cells for .NET

PivotTable.EnableFieldDialog Property

Indicates whether the PivotTable Field dialog box is available when the user double-clicks the PivotTable field.

public bool EnableFieldDialog {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


EnableFieldList Property

Aspose.Cells for .NET

PivotTable.EnableFieldList Property

Gets whether enable the field list for the PivotTable.

public bool EnableFieldList {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


EnableWizard Property

Aspose.Cells for .NET

PivotTable.EnableWizard Property

Indicates whether the PivotTable Wizard is available.

public bool EnableWizard {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ErrorString Property

Aspose.Cells for .NET

PivotTable.ErrorString Property

Gets the string displayed in cells that contain errors when the DisplayErrorString property is true.The default value is an empty string.

public string ErrorString {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ExternalConnectionDataSource Property

Aspose.Cells for .NET

PivotTable.ExternalConnectionDataSource Property

Gets the external connection data source.

public ExternalConnection ExternalConnectionDataSource {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


FieldListSortAscending Property

Aspose.Cells for .NET

PivotTable.FieldListSortAscending Property

Specifies a boolean value that indicates whether fields in the PivotTable are sorted in non-default order in the field list.

public bool FieldListSortAscending {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


GrandTotalName Property

Aspose.Cells for .NET

PivotTable.GrandTotalName Property

Returns the text string label that is displayed in the grand total column or row heading. The default value is the string "Grand Total".

public string GrandTotalName {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


HasBlankRows Property

Aspose.Cells for .NET

PivotTable.HasBlankRows Property

Indicates whether to add blank rows. This property only applies for the PivotTable auto format types which needs to add blank rows.

public bool HasBlankRows {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


Indent Property

Aspose.Cells for .NET

PivotTable.Indent Property

Specifies the indentation increment for compact axis and can be used to set the Report Layout to Compact Form.

public int Indent {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


IsAutoFormat Property

Aspose.Cells for .NET

PivotTable.IsAutoFormat Property

Indicates whether the PivotTable report is automatically formatted. Checkbox "autoformat table " which is in pivottable option for Excel 2003 Checkbox "autofit column width on update" which is in pivot table Options :Layout Format for Excel 2007

public bool IsAutoFormat {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


IsExcel2003Compatible Property

Aspose.Cells for .NET

PivotTable.IsExcel2003Compatible Property

Specifies whether the PivotTable is compatible for Excel2003 when refreshing PivotTable, if true, a string must be less than or equal to 255 characters, so if the string is greater than 255 characters, it will be truncated. if false, a string will not have the aforementioned restriction. The default value is true.

public bool IsExcel2003Compatible {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


IsGridDropZones Property

Aspose.Cells for .NET

PivotTable.IsGridDropZones Property

Indicates whether the PivotTable report displays classic pivottable layout. (enables dragging fields in the grid)

public bool IsGridDropZones {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


IsMultipleFieldFilters Property

Aspose.Cells for .NET

PivotTable.IsMultipleFieldFilters Property

Specifies a boolean value that indicates whether the fields of a PivotTable can have multiple filters set on them.

public bool IsMultipleFieldFilters {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


IsSelected Property

Aspose.Cells for .NET

PivotTable.IsSelected Property

Indicates whether the PivotTable is selected.

public bool IsSelected {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ItemPrintTitles Property

Aspose.Cells for .NET

PivotTable.ItemPrintTitles Property

A bit that specifies whether pivot item captions on the row axis are repeated on each printed page for pivot fields in tabular form.

public bool ItemPrintTitles {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ManualUpdate Property

Aspose.Cells for .NET

PivotTable.ManualUpdate Property

Indicates whether the PivotTable report is recalculated only at the user's request.

public bool ManualUpdate {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


MergeLabels Property

Aspose.Cells for .NET

PivotTable.MergeLabels Property

Indicates whether the specified PivotTable report's outer-row item, column item, subtotal, and grand total labels use merged cells.

public bool MergeLabels {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


MissingItemsLimit Property

Aspose.Cells for .NET

PivotTable.MissingItemsLimit Property

Specifies a boolean value that indicates whether the fields of a PivotTable can have multiple filters set on them.

public PivotMissingItemLimitType MissingItemsLimit {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


Name Property

Aspose.Cells for .NET

PivotTable.Name Property

Gets the name of the PivotTable

public string Name {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


NullString Property

Aspose.Cells for .NET

PivotTable.NullString Property

Gets the string displayed in cells that contain null values when the DisplayNullString property is true.The default value is an empty string.

public string NullString {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PageFieldOrder Property

Aspose.Cells for .NET

PivotTable.PageFieldOrder Property

Gets the order in which page fields are added to the PivotTable report's layout.

public PrintOrderType PageFieldOrder {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PageFields Property

Aspose.Cells for .NET

PivotTable.PageFields Property

Returns a PivotFields object that are currently shown as page fields.

public PivotFieldCollection PageFields {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PageFieldWrapCount Property

Aspose.Cells for .NET

PivotTable.PageFieldWrapCount Property

Gets the number of page fields in each column or row in the PivotTable report.

public int PageFieldWrapCount {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotFilters Property

Aspose.Cells for .NET

PivotTable.PivotFilters Property

Returns a PivotFilterCollection object.

public PivotFilterCollection PivotFilters {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotFormatConditions Property

Aspose.Cells for .NET

PivotTable.PivotFormatConditions Property

Gets the Format Conditions of the pivot table.

public PivotFormatConditionCollection PivotFormatConditions {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTableStyleName Property

Aspose.Cells for .NET

PivotTable.PivotTableStyleName Property

Gets and sets the pivottable style name.

public string PivotTableStyleName {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTableStyleType Property

Aspose.Cells for .NET

PivotTable.PivotTableStyleType Property

Gets and sets the built-in pivot table style.

public PivotTableStyleType PivotTableStyleType {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PreserveFormatting Property

Aspose.Cells for .NET

PivotTable.PreserveFormatting Property

Indicates whether formatting is preserved when the PivotTable is refreshed or recalculated.

public bool PreserveFormatting {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PrintDrill Property

Aspose.Cells for .NET

PivotTable.PrintDrill Property

Specifies a boolean value that indicates whether drill indicators should be printed. print expand/collapse buttons when displayed on pivottable.

public bool PrintDrill {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PrintTitles Property

Aspose.Cells for .NET

PivotTable.PrintTitles Property

Indicates whether the print titles for the worksheet are set based on the PivotTable report. The default value is false.

public bool PrintTitles {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RefreshDataFlag Property

Aspose.Cells for .NET

PivotTable.RefreshDataFlag Property

Indicates whether Refresh Data or not.

public bool RefreshDataFlag {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RefreshDataOnOpeningFile Property

Aspose.Cells for .NET

PivotTable.RefreshDataOnOpeningFile Property

Indicates whether Refresh Data when Opening File.

public bool RefreshDataOnOpeningFile {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RefreshDate Property

Aspose.Cells for .NET

PivotTable.RefreshDate Property

Gets the date when the PivotTable was last refreshed.

public DateTime RefreshDate {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RefreshedByWho Property

Aspose.Cells for .NET

PivotTable.RefreshedByWho Property

Gets the name of the user who last refreshed the PivotTable

public string RefreshedByWho {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RowFields Property

Aspose.Cells for .NET

PivotTable.RowFields Property

Returns a PivotFields object that are currently shown as row fields.

public PivotFieldCollection RowFields {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RowGrand Property

Aspose.Cells for .NET

PivotTable.RowGrand Property

Indicates whether the PivotTable report shows grand totals for rows.

public bool RowGrand {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RowHeaderCaption Property

Aspose.Cells for .NET

PivotTable.RowHeaderCaption Property

Gets the Row Header Caption of the PivotTable.

public string RowHeaderCaption {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RowRange Property

Aspose.Cells for .NET

PivotTable.RowRange Property

Returns a CellArea object that represents the range that contains the row area in the PivotTable report. Read-only.

public CellArea RowRange {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


SaveData Property

Aspose.Cells for .NET

PivotTable.SaveData Property

Indicates whether data for the PivotTable report is saved with the workbook.

public bool SaveData {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowDataTips Property

Aspose.Cells for .NET

PivotTable.ShowDataTips Property

Specifies a boolean value that indicates whether tooltips should be displayed for PivotTable data cells.

public bool ShowDataTips {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowDrill Property

Aspose.Cells for .NET

PivotTable.ShowDrill Property

Gets whether expand/collapse buttons is shown.

public bool ShowDrill {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowEmptyCol Property

Aspose.Cells for .NET

PivotTable.ShowEmptyCol Property

Specifies a boolean value that indicates whether to include empty columns in the table

public bool ShowEmptyCol {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowEmptyRow Property

Aspose.Cells for .NET

PivotTable.ShowEmptyRow Property

Specifies a boolean value that indicates whether to include empty rows in the table.

public bool ShowEmptyRow {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowMemberPropertyTips Property

Aspose.Cells for .NET

PivotTable.ShowMemberPropertyTips Property

Specifies a boolean value that indicates whether member property information should be omitted from PivotTable tooltips.

public bool ShowMemberPropertyTips {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowPivotStyleColumnHeader Property

Aspose.Cells for .NET

PivotTable.ShowPivotStyleColumnHeader Property

Indicates whether the column header in the pivot table should have the style applied.

public bool ShowPivotStyleColumnHeader {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowPivotStyleColumnStripes Property

Aspose.Cells for .NET

PivotTable.ShowPivotStyleColumnStripes Property

Indicates whether column stripe formatting is applied.

public bool ShowPivotStyleColumnStripes {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowPivotStyleLastColumn Property

Aspose.Cells for .NET

PivotTable.ShowPivotStyleLastColumn Property

Indicates whether column stripe formatting is applied.

public bool ShowPivotStyleLastColumn {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowPivotStyleRowHeader Property

Aspose.Cells for .NET

PivotTable.ShowPivotStyleRowHeader Property

Indicates whether the row header in the pivot table should have the style applied.

public bool ShowPivotStyleRowHeader {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowPivotStyleRowStripes Property

Aspose.Cells for .NET

PivotTable.ShowPivotStyleRowStripes Property

Indicates whether row stripe formatting is applied.

public bool ShowPivotStyleRowStripes {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowRowHeaderCaption Property

Aspose.Cells for .NET

PivotTable.ShowRowHeaderCaption Property

Indicates whether row header caption is shown in the PivotTable report Indicates whether Display field captions and filter drop downs

public bool ShowRowHeaderCaption {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


ShowValuesRow Property

Aspose.Cells for .NET

PivotTable.ShowValuesRow Property

Specifies a boolean value that indicates whether show values row. show the values row

public bool ShowValuesRow {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


SubtotalHiddenPageItems Property

Aspose.Cells for .NET

PivotTable.SubtotalHiddenPageItems Property

Indicates whether hidden page field items in the PivotTable report are included in row and column subtotals, block totals, and grand totals. The default value is False.

public bool SubtotalHiddenPageItems {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


TableRange1 Property

Aspose.Cells for .NET

PivotTable.TableRange1 Property

Returns a CellArea object that represents the range containing the entire PivotTable report, but doesn't include page fields. Read-only.

public CellArea TableRange1 {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


TableRange2 Property

Aspose.Cells for .NET

PivotTable.TableRange2 Property

Returns a CellArea object that represents the range containing the entire PivotTable report, includes page fields. Read-only.

public CellArea TableRange2 {get;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


Tag Property

Aspose.Cells for .NET

PivotTable.Tag Property

Gets a string saved with the PivotTable report.

public string Tag {get; set;}

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable Methods

The methods of the PivotTable class are listed below. For a complete list of PivotTable class members, see the PivotTable Members topic.

Public Instance Methods

AddCalculatedField | Overloaded. Adds a calculated field to pivot field.
AddFieldToArea | Overloaded. Adds the field to the specific area.
CalculateData | Calculates pivottable's data to cells.
CalculateRange | Calculates pivottable's range.
ChangeDataSource | Set pivottable's source data. Sheet1!$A$1:$C$3
ClearData | Clear PivotTable's data and formatting
CopyStyle | Copies named style from another pivot table.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
Fields | Gets the specific fields by the field type.
Format | Format the cell in the pivottable area
FormatAll | Format all the cell in the pivottable area
GetCellByDisplayName | Gets the Cell object by the DisplayName of PivotField
GetChildren | Gets the Children Pivot Tables which use this PivotTable data as data source.
GetHashCode (inherited from Object) |
GetHorizontalBreaks | get pivot table row index list of horizontal pagebreaks
GetSource | Get pivottable's source data.
GetType (inherited from Object) |
Move | Overloaded. Moves the PivotTable to a different location in the worksheet.
RefreshData | Refreshes pivottable's data and setting from it's data source.
RemoveField | Overloaded. Removes a field from specific field area
SetAutoGroupField | Overloaded. Sets auto field group by the PivotTable.
SetManualGroupField | Overloaded. Sets manual field group by the PivotTable.
SetUngroup | Overloaded. Sets ungroup by the PivotTable
ShowInCompactForm | Layouts the PivotTable in compact form.
ShowInOutlineForm | Layouts the PivotTable in outline form.
ShowInTabularForm | Layouts the PivotTable in tabular form.
ShowReportFilterPage | Show all the report filter pages according to PivotField, the PivotField must be located in the PageFields.
ShowReportFilterPageByIndex | Show all the report filter pages according to the position index in the PageFields
ShowReportFilterPageByName | Show all the report filter pages according to PivotField's name, the PivotField must be located in the PageFields.
ToString (inherited from Object) |

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


AddCalculatedField Method

Aspose.Cells for .NET

PivotTable.AddCalculatedField Method

Adds a calculated field to pivot field and drag it to data area.

Overload List

Adds a calculated field to pivot field and drag it to data area.

public void AddCalculatedField(string,string);

Adds a calculated field to pivot field.

public void AddCalculatedField(string,string,bool);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.AddCalculatedField Method (String, String)

Adds a calculated field to pivot field and drag it to data area.

public void AddCalculatedField(
string name,
string formula
);

Parameters

name
The name of the calculated field
formula
The formula of the calculated field.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.AddCalculatedField Overload List


PivotTable.AddCalculatedField Method (String, String, Boolean)

Adds a calculated field to pivot field.

public void AddCalculatedField(
string name,
string formula,
bool dragToDataArea
);

Parameters

name
The name of the calculated field
formula
The formula of the calculated field.
dragToDataArea
True,drag this field to data area immediately

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.AddCalculatedField Overload List


AddFieldToArea Method

Aspose.Cells for .NET

PivotTable.AddFieldToArea Method

Adds the field to the specific area.

Overload List

Adds the field to the specific area.

public int AddFieldToArea(PivotFieldType,PivotField);

Adds the field to the specific area.

public int AddFieldToArea(PivotFieldType,int);

Adds the field to the specific area.

public int AddFieldToArea(PivotFieldType,string);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.AddFieldToArea Method (PivotFieldType, PivotField)

Adds the field to the specific area.

public int AddFieldToArea(
PivotFieldType fieldType,
PivotField pivotField
);

Parameters

fieldType
the fields area type.It could be one of the following values:
PivotFieldType.Row
PivotFieldType.Column
PivotFieldType.Data
PivotFieldType.Page
pivotField
the field in the base fields.

Return Value

the field position in the specific fields.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.AddFieldToArea Overload List


PivotTable.AddFieldToArea Method (PivotFieldType, Int32)

Adds the field to the specific area.

public int AddFieldToArea(
PivotFieldType fieldType,
int baseFieldIndex
);

Parameters

fieldType
The fields area type.
baseFieldIndex
The field index in the base fields.

Return Value

The field position in the specific fields.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.AddFieldToArea Overload List


PivotTable.AddFieldToArea Method (PivotFieldType, String)

Adds the field to the specific area.

public int AddFieldToArea(
PivotFieldType fieldType,
string fieldName
);

Parameters

fieldType
The fields area type.
fieldName
The name in the base fields.

Return Value

The field position in the specific fields.If there is no field named as it, return -1.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.AddFieldToArea Overload List


PivotTable.CalculateData Method

Calculates pivottable's data to cells.

public void CalculateData();

Remarks

Cell.Value in the pivot range could not return the correct result if the method is not been called. This method calculates data with an inner pivot cache,not original data source. So if the data source is changed, please call RefreshData() method first.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.CalculateRange Method

Calculates pivottable's range.

public void CalculateRange();

Remarks

If this method is not been called,maybe the pivottable range is not corrected.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ChangeDataSource Method

Set pivottable's source data. Sheet1!$A$1:$C$3

public void ChangeDataSource(
string[] source
);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ClearData Method

Clear PivotTable's data and formatting

public void ClearData();

Remarks

If this method is not called before you add or delete PivotField, Maybe the PivotTable data is not corrected

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.CopyStyle Method

Copies named style from another pivot table.

public void CopyStyle(
PivotTable pivotTable
);

Parameters

pivotTable
Source pivot table.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.Fields Method

Gets the specific fields by the field type.

public PivotFieldCollection Fields(
PivotFieldType fieldType
);

Parameters

fieldType
the field type.

Return Value

the specific fields

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.Format Method

Format the cell in the pivottable area

public void Format(
int row,
int column,
Style style
);

Parameters

row
RowIndex of the cell
column
Column index of the cell
style
Style which is to format the cell

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.FormatAll Method

Format all the cell in the pivottable area

public void FormatAll(
Style style
);

Parameters

style
Style which is to format

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.GetCellByDisplayName Method

Gets the Cell object by the DisplayName of PivotField

public Cell GetCellByDisplayName(
string displayName
);

Parameters

displayName
the DisplayName of PivotField

Return Value

the Cell object

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.GetChildren Method

Gets the Children Pivot Tables which use this PivotTable data as data source.

public PivotTable[] GetChildren();

Return Value

the PivotTable array object

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.GetHorizontalBreaks Method

get pivot table row index list of horizontal pagebreaks

public ArrayList GetHorizontalBreaks();

Return Value

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.GetSource Method

Get pivottable's source data.

public string[] GetSource();

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


Move Method

Aspose.Cells for .NET

PivotTable.Move Method

Moves the PivotTable to a different location in the worksheet.

Overload List

Moves the PivotTable to a different location in the worksheet.

public void Move(int,int);

Moves the PivotTable to a different location in the worksheet.

public void Move(string);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.Move Method (Int32, Int32)

Moves the PivotTable to a different location in the worksheet.

public void Move(
int row,
int column
);

Parameters

row
row index.
column
column index.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.Move Overload List


PivotTable.Move Method (String)

Moves the PivotTable to a different location in the worksheet.

public void Move(
string destCellName
);

Parameters

destCellName
the dest cell name.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.Move Overload List


PivotTable.RefreshData Method

Refreshes pivottable's data and setting from it's data source.

public void RefreshData();

Remarks

We will gather data from data source to a pivot cache ,then calculate the data in the cache to the cells. This method is only used to gather all data to a pivot cache.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


RemoveField Method

Aspose.Cells for .NET

PivotTable.RemoveField Method

Remove field from specific field area

Overload List

Remove field from specific field area

public void RemoveField(PivotFieldType,PivotField);

Removes a field from specific field area

public void RemoveField(PivotFieldType,int);

Removes a field from specific field area

public void RemoveField(PivotFieldType,string);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.RemoveField Method (PivotFieldType, PivotField)

Remove field from specific field area

public void RemoveField(
PivotFieldType fieldType,
PivotField pivotField
);

Parameters

fieldType
the fields area type.It could be one of the following values:
PivotFieldType.Row
PivotFieldType.Column
PivotFieldType.Data
PivotFieldType.Page
pivotField
the field in the base fields.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.RemoveField Overload List


PivotTable.RemoveField Method (PivotFieldType, Int32)

Removes a field from specific field area

public void RemoveField(
PivotFieldType fieldType,
int baseFieldIndex
);

Parameters

fieldType
The fields area type.
baseFieldIndex
The field index in the base fields.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.RemoveField Overload List


PivotTable.RemoveField Method (PivotFieldType, String)

Removes a field from specific field area

public void RemoveField(
PivotFieldType fieldType,
string fieldName
);

Parameters

fieldType
The fields area type.
fieldName
The name in the base fields.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.RemoveField Overload List


SetAutoGroupField Method

Aspose.Cells for .NET

PivotTable.SetAutoGroupField Method

Sets auto field group by the PivotTable.

Overload List

Sets auto field group by the PivotTable.

public void SetAutoGroupField(PivotField);

Sets auto field group by the PivotTable.

public void SetAutoGroupField(int);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.SetAutoGroupField Method (PivotField)

Sets auto field group by the PivotTable.

public void SetAutoGroupField(
PivotField pivotField
);

Parameters

pivotField
The row or column field in the specific fields

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetAutoGroupField Overload List


PivotTable.SetAutoGroupField Method (Int32)

Sets auto field group by the PivotTable.

public void SetAutoGroupField(
int baseFieldIndex
);

Parameters

baseFieldIndex
The row or column field index in the base fields

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetAutoGroupField Overload List


SetManualGroupField Method

Aspose.Cells for .NET

PivotTable.SetManualGroupField Method

Sets manual field group by the PivotTable.

Overload List

Sets manual field group by the PivotTable.

public void SetManualGroupField(PivotField,DateTime,DateTime,ArrayList,int);

Sets manual field group by the PivotTable.

public void SetManualGroupField(PivotField,double,double,ArrayList,double);

Sets manual field group by the PivotTable.

public void SetManualGroupField(int,DateTime,DateTime,ArrayList,int);

Sets manual field group by the PivotTable.

public void SetManualGroupField(int,double,double,ArrayList,double);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.SetManualGroupField Method (PivotField, DateTime, DateTime, ArrayList, Int32)

Sets manual field group by the PivotTable.

public void SetManualGroupField(
PivotField pivotField,
DateTime startVal,
DateTime endVal,
ArrayList groupByList,
int intervalNum
);

Parameters

pivotField
The row or column field in the base fields
startVal
Specifies the starting value for date grouping.
endVal
Specifies the ending value for date grouping.
groupByList
Specifies the grouping type list. Specified by PivotTableGroupType
intervalNum
Specifies the interval number group by in days grouping.The number of days must be positive integer of nonzero

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetManualGroupField Overload List


PivotTable.SetManualGroupField Method (PivotField, Double, Double, ArrayList, Double)

Sets manual field group by the PivotTable.

public void SetManualGroupField(
PivotField pivotField,
double startVal,
double endVal,
ArrayList groupByList,
double intervalNum
);

Parameters

pivotField
The row or column field in the base fields
startVal
Specifies the starting value for numeric grouping.
endVal
Specifies the ending value for numeric grouping.
groupByList
Specifies the grouping type list. Specified by PivotTableGroupType
intervalNum
Specifies the interval number group by numeric grouping.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetManualGroupField Overload List


PivotTable.SetManualGroupField Method (Int32, DateTime, DateTime, ArrayList, Int32)

Sets manual field group by the PivotTable.

public void SetManualGroupField(
int baseFieldIndex,
DateTime startVal,
DateTime endVal,
ArrayList groupByList,
int intervalNum
);

Parameters

baseFieldIndex
The row or column field index in the base fields
startVal
Specifies the starting value for date grouping.
endVal
Specifies the ending value for date grouping.
groupByList
Specifies the grouping type list. Specified by PivotTableGroupType
intervalNum
Specifies the interval number group by in days grouping.The number of days must be positive integer of nonzero

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetManualGroupField Overload List


PivotTable.SetManualGroupField Method (Int32, Double, Double, ArrayList, Double)

Sets manual field group by the PivotTable.

public void SetManualGroupField(
int baseFieldIndex,
double startVal,
double endVal,
ArrayList groupByList,
double intervalNum
);

Parameters

baseFieldIndex
The row or column field index in the base fields
startVal
Specifies the starting value for numeric grouping.
endVal
Specifies the ending value for numeric grouping.
groupByList
Specifies the grouping type list. Specified by PivotTableGroupType
intervalNum
Specifies the interval number group by numeric grouping.

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetManualGroupField Overload List


SetUngroup Method

Aspose.Cells for .NET

PivotTable.SetUngroup Method

Sets ungroup by the PivotTable

Overload List

Sets ungroup by the PivotTable

public void SetUngroup(PivotField);

Sets ungroup by the PivotTable

public void SetUngroup(int);

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.SetUngroup Method (PivotField)

Sets ungroup by the PivotTable

public void SetUngroup(
PivotField pivotField
);

Parameters

pivotField
The row or column field in the base fields

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetUngroup Overload List


PivotTable.SetUngroup Method (Int32)

Sets ungroup by the PivotTable

public void SetUngroup(
int baseFieldIndex
);

Parameters

baseFieldIndex
The row or column field index in the base fields

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace | PivotTable.SetUngroup Overload List


PivotTable.ShowInCompactForm Method

Layouts the PivotTable in compact form.

public void ShowInCompactForm();

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ShowInOutlineForm Method

Layouts the PivotTable in outline form.

public void ShowInOutlineForm();

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ShowInTabularForm Method

Layouts the PivotTable in tabular form.

public void ShowInTabularForm();

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ShowReportFilterPage Method

Show all the report filter pages according to PivotField, the PivotField must be located in the PageFields.

public void ShowReportFilterPage(
PivotField pageField
);

Parameters

pageField
The PivotField object

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ShowReportFilterPageByIndex Method

Show all the report filter pages according to the position index in the PageFields

public void ShowReportFilterPageByIndex(
int posIndex
);

Parameters

posIndex
The position index in the PageFields

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTable.ShowReportFilterPageByName Method

Show all the report filter pages according to PivotField's name, the PivotField must be located in the PageFields.

public void ShowReportFilterPageByName(
string fieldName
);

Parameters

fieldName
The name of PivotField

See Also

PivotTable Class | Aspose.Cells.Pivot Namespace


PivotTableAutoFormatType Enumeration

Represents PivotTable auto format type.

public enum PivotTableAutoFormatType

Members

Member Name | Description | Value
None | Represents None format type. | 0
Classic | Represents Classic auto format type. | 1
Report1 | Represents Report1 format type. | 2
Report2 | Represents Report2 format type. | 3
Report3 | Represents Report3 format type. | 4
Report4 | Represents Report4 format type. | 5
Report5 | Represents Report5 format type. | 6
Report6 | Represents Report6 format type. | 7
Report7 | Represents Report7 format type. | 8
Report8 | Represents Report8 format type. | 9
Report9 | Represents Report9 format type. | 10
Report10 | Represents Report10 format type. | 11
Table1 | Represents Table1 format type. | 12
Table2 | Represents Table2 format type. | 13
Table3 | Represents Table3 format type. | 14
Table4 | Represents Table4 format type. | 15
Table5 | Represents Table5 format type. | 16
Table6 | Represents Table6 format type. | 17
Table7 | Represents Table7 format type. | 18
Table8 | Represents Table8 format type. | 19
Table9 | Represents Table9 format type. | 20
Table10 | Represents Table10 format type. | 21

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


PivotTableCollection Class

Represents the collection of all the PivotTable objects on the specified worksheet.

For a list of all members of this type, see PivotTableCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Pivot.PivotTableCollection

public class PivotTableCollection : CollectionBase, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PivotTableCollection Members | Aspose.Cells.Pivot Namespace


PivotTableCollection Members

PivotTableCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the PivotTable report by index.

Public Instance Methods

Add | Overloaded. Adds a new PivotTable cache to a PivotCaches collection.
Clear | Clear all pivot tables.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Deletes the specified PivotTable
RemoveAt | Deletes the PivotTable at the specified index
ToString (inherited from Object) |

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


PivotTableCollection Properties

The properties of the PivotTableCollection class are listed below. For a complete list of PivotTableCollection class members, see the PivotTableCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the PivotTable report by index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


Item Property

Aspose.Cells for .NET

PivotTableCollection.Item Property

Gets the PivotTable report by index.

Overload List

Gets the PivotTable report by index.

public PivotTable this[int] {get;}

Gets the PivotTable report by pivottable's position.

public PivotTable this[int, int] {get;}

Gets the PivotTable report by pivottable's name.

public PivotTable this[string] {get;}

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


Item Property (Int32)

Aspose.Cells for .NET

PivotTableCollection.Item Property (Int32)

Gets the PivotTable report by index.

public PivotTable this[
int index
] {get;}

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Item Overload List


Item Property (Int32, Int32)

Aspose.Cells for .NET

PivotTableCollection.Item Property (Int32, Int32)

Gets the PivotTable report by pivottable's position.

public PivotTable this[
int row,
int column
] {get;}

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PivotTableCollection.Item Property (String)

Gets the PivotTable report by pivottable's name.

public PivotTable this[
string name
] {get;}

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Item Overload List


PivotTableCollection Methods

The methods of the PivotTableCollection class are listed below. For a complete list of PivotTableCollection class members, see the PivotTableCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new PivotTable cache to a PivotCaches collection.
Clear | Clear all pivot tables.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Deletes the specified PivotTable
RemoveAt | Deletes the PivotTable at the specified index
ToString (inherited from Object) |

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


Add Method

Aspose.Cells for .NET

PivotTableCollection.Add Method

Adds a new PivotTable Object to the collection from another PivotTable.

Overload List

Adds a new PivotTable Object to the collection from another PivotTable.

public int Add(PivotTable,int,int,string);

Adds a new PivotTable Object to the collection from another PivotTable.

public int Add(PivotTable,string,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,int,int,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,int,int,string,bool);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,string,string);

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(string,string,string,bool);

Adds a new PivotTable Object to the collection with multiple consolidation ranges as data source.

public int Add(string[],bool,PivotPageFields,int,int,string);

Adds a new PivotTable Object to the collection with multiple consolidation ranges as data source.

public int Add(string[],bool,PivotPageFields,string,string);

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


PivotTableCollection.Add Method (PivotTable, Int32, Int32, String)

Adds a new PivotTable Object to the collection from another PivotTable.

public int Add(
PivotTable pivotTable,
int row,
int column,
string tableName
);

Parameters

pivotTable
The source pivotTable.
row
Row index of the cell in the upper-left corner of the PivotTable report's destination range.
column
Column index of the cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added PivotTable index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (PivotTable, String, String)

Adds a new PivotTable Object to the collection from another PivotTable.

public int Add(
PivotTable pivotTable,
string destCellName,
string tableName
);

Parameters

pivotTable
The source pivotTable.
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added PivotTable index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (String, Int32, Int32, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string sourceData,
int row,
int column,
string tableName
);

Parameters

sourceData
The data cell range for the new PivotTable.Example : Sheet1!A1:C8
row
Row index of the cell in the upper-left corner of the PivotTable report's destination range.
column
Column index of the cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (String, Int32, Int32, String, Boolean)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string sourceData,
int row,
int column,
string tableName,
bool useSameSource
);

Parameters

sourceData
The data cell range for the new PivotTable.Example : Sheet1!A1:C8
row
Row index of the cell in the upper-left corner of the PivotTable report's destination range.
column
Column index of the cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.
useSameSource
Indicates whether using same data source when another existing pivot table has used this data source. If the property is true, it will save memory.

Return Value

The new added cache index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (String, String, String)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string sourceData,
string destCellName,
string tableName
);

Parameters

sourceData
The data for the new PivotTable cache.
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added cache index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (String, String, String, Boolean)

Adds a new PivotTable cache to a PivotCaches collection.

public int Add(
string sourceData,
string destCellName,
string tableName,
bool useSameSource
);

Parameters

sourceData
The data for the new PivotTable cache.
destCellName
The cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.
useSameSource
Indicates whether using same data source when another existing pivot table has used this data source. If the property is true, it will save memory.

Return Value

The new added cache index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (String[], Boolean, PivotPageFields, Int32, Int32, String)

Adds a new PivotTable Object to the collection with multiple consolidation ranges as data source.

public int Add(
string[] sourceData,
bool isAutoPage,
PivotPageFields pageFields,
int row,
int column,
string tableName
);

Parameters

sourceData
The multiple consolidation ranges,such as {"Sheet1!A1:C8","Sheet2!A1:B8"}
isAutoPage
Whether auto create a single page field. If true,the following param pageFields will be ignored
pageFields
The pivot page field items.
row
Row index of the cell in the upper-left corner of the PivotTable report's destination range.
column
Column index of the cell in the upper-left corner of the PivotTable report's destination range.
tableName
The name of the new PivotTable report.

Return Value

The new added PivotTable index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Add Method (String[], Boolean, PivotPageFields, String, String)

Adds a new PivotTable Object to the collection with multiple consolidation ranges as data source.

public int Add(
string[] sourceData,
bool isAutoPage,
PivotPageFields pageFields,
string destCellName,
string tableName
);

Parameters

sourceData
The multiple consolidation ranges,such as {"Sheet1!A1:C8","Sheet2!A1:B8"}
isAutoPage
Whether auto create a single page field. If true,the following param pageFields will be ignored.
pageFields
The pivot page field items.
destCellName
destCellName The name of the new PivotTable report.
tableName
the name of the new PivotTable report.

Return Value

The new added PivotTable index.

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace | PivotTableCollection.Add Overload List


PivotTableCollection.Clear Method

Clear all pivot tables.

new public void Clear();

Implements

IList.Clear

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


PivotTableCollection.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


PivotTableCollection.Remove Method

Deletes the specified PivotTable

public void Remove(
PivotTable pivotTable
);

Parameters

pivotTable
PivotTable object

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


PivotTableCollection.RemoveAt Method

Deletes the PivotTable at the specified index

new public void RemoveAt(
int index
);

Parameters

index
the position index in PivotTable collection

Implements

IList.RemoveAt

See Also

PivotTableCollection Class | Aspose.Cells.Pivot Namespace


PivotTableStyleType Enumeration

Represents the pivot table style type.

public enum PivotTableStyleType

Members

Member Name | Description | Value
None |  | 0
PivotTableStyleLight1 |  | 1
PivotTableStyleLight2 |  | 2
PivotTableStyleLight3 |  | 3
PivotTableStyleLight4 |  | 4
PivotTableStyleLight5 |  | 5
PivotTableStyleLight6 |  | 6
PivotTableStyleLight7 |  | 7
PivotTableStyleLight8 |  | 8
PivotTableStyleLight9 |  | 9
PivotTableStyleLight10 |  | 10
PivotTableStyleLight11 |  | 11
PivotTableStyleLight12 |  | 12
PivotTableStyleLight13 |  | 13
PivotTableStyleLight14 |  | 14
PivotTableStyleLight15 |  | 15
PivotTableStyleLight16 |  | 16
PivotTableStyleLight17 |  | 17
PivotTableStyleLight18 |  | 18
PivotTableStyleLight19 |  | 19
PivotTableStyleLight20 |  | 20
PivotTableStyleLight21 |  | 21
PivotTableStyleLight22 |  | 22
PivotTableStyleLight23 |  | 23
PivotTableStyleLight24 |  | 24
PivotTableStyleLight25 |  | 25
PivotTableStyleLight26 |  | 26
PivotTableStyleLight27 |  | 27
PivotTableStyleLight28 |  | 28
PivotTableStyleMedium1 |  | 29
PivotTableStyleMedium2 |  | 30
PivotTableStyleMedium3 |  | 31
PivotTableStyleMedium4 |  | 32
PivotTableStyleMedium5 |  | 33
PivotTableStyleMedium6 |  | 34
PivotTableStyleMedium7 |  | 35
PivotTableStyleMedium8 |  | 36
PivotTableStyleMedium9 |  | 37
PivotTableStyleMedium10 |  | 38
PivotTableStyleMedium11 |  | 39
PivotTableStyleMedium12 |  | 40
PivotTableStyleMedium13 |  | 41
PivotTableStyleMedium14 |  | 42
PivotTableStyleMedium15 |  | 43
PivotTableStyleMedium16 |  | 44
PivotTableStyleMedium17 |  | 45
PivotTableStyleMedium18 |  | 46
PivotTableStyleMedium19 |  | 47
PivotTableStyleMedium20 |  | 48
PivotTableStyleMedium21 |  | 49
PivotTableStyleMedium22 |  | 50
PivotTableStyleMedium23 |  | 51
PivotTableStyleMedium24 |  | 52
PivotTableStyleMedium25 |  | 53
PivotTableStyleMedium26 |  | 54
PivotTableStyleMedium27 |  | 55
PivotTableStyleMedium28 |  | 56
PivotTableStyleDark1 |  | 57
PivotTableStyleDark2 |  | 58
PivotTableStyleDark3 |  | 59
PivotTableStyleDark4 |  | 60
PivotTableStyleDark5 |  | 61
PivotTableStyleDark6 |  | 62
PivotTableStyleDark7 |  | 63
PivotTableStyleDark8 |  | 64
PivotTableStyleDark9 |  | 65
PivotTableStyleDark10 |  | 66
PivotTableStyleDark11 |  | 67
PivotTableStyleDark12 |  | 68
PivotTableStyleDark13 |  | 69
PivotTableStyleDark14 |  | 70
PivotTableStyleDark15 |  | 71
PivotTableStyleDark16 |  | 72
PivotTableStyleDark17 |  | 73
PivotTableStyleDark18 |  | 74
PivotTableStyleDark19 |  | 75
PivotTableStyleDark20 |  | 76
PivotTableStyleDark21 |  | 77
PivotTableStyleDark22 |  | 78
PivotTableStyleDark23 |  | 79
PivotTableStyleDark24 |  | 80
PivotTableStyleDark25 |  | 81
PivotTableStyleDark26 |  | 82
PivotTableStyleDark27 |  | 83
PivotTableStyleDark28 |  | 84
Custom |  | 85

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Pivot Namespace


SxRng Class

Represents Group Range in a PivotField.

For a list of all members of this type, see SxRng Members.

System.Object
Aspose.Cells.Pivot.SxRng

public class SxRng

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Pivot

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SxRng Members | Aspose.Cells.Pivot Namespace


SxRng Members

SxRng overview

Public Instance Properties

By | Represents the interval object for the group range.
End | Represents the end object for the group range.
GroupByTypes | Represents the group type for the group range. rangeofvalue Seconds Minutes Hours Days Months Quarters Years
IsAutoEnd | Specifies a boolean value that indicates whether the application will use the source data to set the end range value.
IsAutoStart | Specifies a boolean value that indicates whether the application will use the source data to set the beginning range value.
Start | Represents the start object for the group range.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


SxRng Properties

The properties of the SxRng class are listed below. For a complete list of SxRng class members, see the SxRng Members topic.

Public Instance Properties

By | Represents the interval object for the group range.
End | Represents the end object for the group range.
GroupByTypes | Represents the group type for the group range. rangeofvalue Seconds Minutes Hours Days Months Quarters Years
IsAutoEnd | Specifies a boolean value that indicates whether the application will use the source data to set the end range value.
IsAutoStart | Specifies a boolean value that indicates whether the application will use the source data to set the beginning range value.
Start | Represents the start object for the group range.

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


By Property

Aspose.Cells for .NET

SxRng.By Property

Represents the interval object for the group range.

public object By {get;}

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


End Property

Aspose.Cells for .NET

SxRng.End Property

Represents the end object for the group range.

public object End {get;}

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


GroupByTypes Property

Aspose.Cells for .NET

SxRng.GroupByTypes Property

Represents the group type for the group range. rangeofvalue Seconds Minutes Hours Days Months Quarters Years

public bool[] GroupByTypes {get;}

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


IsAutoEnd Property

Aspose.Cells for .NET

SxRng.IsAutoEnd Property

Specifies a boolean value that indicates whether the application will use the source data to set the end range value.

public object IsAutoEnd {get;}

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


IsAutoStart Property

Aspose.Cells for .NET

SxRng.IsAutoStart Property

Specifies a boolean value that indicates whether the application will use the source data to set the beginning range value.

public object IsAutoStart {get;}

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


Start Property

Aspose.Cells for .NET

SxRng.Start Property

Represents the start object for the group range.

public object Start {get;}

See Also

SxRng Class | Aspose.Cells.Pivot Namespace


Aspose.Cells.Properties

Aspose.Cells for .NET

Aspose.Cells.Properties Namespace

Namespace hierarchy

Classes

Class | Description
BuiltInDocumentPropertyCollection | A collection of built-in document properties.
ContentTypeProperty | Represents identifier information.
ContentTypePropertyCollection | A collection of ContentTypeProperty objects that represent additional information.
CustomDocumentPropertyCollection | A collection of custom document properties.
CustomProperty | Represents identifier information.
CustomPropertyCollection | A collection of CustomProperty objects that represent additional information.
DocumentProperty | Represents a custom or built-in document property.
DocumentPropertyCollection | Base class for BuiltInDocumentPropertyCollection and CustomDocumentPropertyCollection collections.

Enumerations

Enumeration | Description
PropertyType | Specifies data type of a document property.


BuiltInDocumentPropertyCollection Class

A collection of built-in document properties.

For a list of all members of this type, see BuiltInDocumentPropertyCollection Members.

System.Object
Aspose.Cells.Properties.DocumentPropertyCollection
Aspose.Cells.Properties.BuiltInDocumentPropertyCollection

public class BuiltInDocumentPropertyCollection : DocumentPropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Provides access to DocumentProperty objects by their names (using an indexer) and via a set of typed properties that return values of appropriate types.

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

BuiltInDocumentPropertyCollection Members | Aspose.Cells.Properties Namespace


BuiltInDocumentPropertyCollection Members

BuiltInDocumentPropertyCollection overview

Public Instance Properties

Author | Gets or sets the name of the document's author.
Bytes | Obsolete. Represents an estimate of the number of bytes in the document.
Category | Gets or sets the category of the document.
Characters | Obsolete. Represents an estimate of the number of characters in the document.
CharactersWithSpaces | Obsolete. Represents an estimate of the number of characters (including spaces) in the document.
Comments | Gets or sets the document comments.
Company | Gets or sets the company property.
ContentStatus | Gets or sets the content status of the document.
ContentType | Gets or sets the content type of the document.
Count (inherited from DocumentPropertyCollection) | Gets number of items in the collection.
CreatedTime | Gets or sets date of the document creation in local timezone.
CreatedUniversalTime | Gets or sets the Universal time of the document creation.
DocumentVersion | Represents the version of the file.
HyperlinkBase | Gets or sets the hyperlinkbase property.
Item | Overloaded. Returns a DocumentProperty object by the name of the property.
Keywords | Gets or sets the document keywords.
Language | Gets or sets the document's language.
LastPrinted | Gets or sets the date when the document was last printed in local timezone.
LastPrintedUniversalTime | Gets or sets the Universal time when the document was last printed.
LastSavedBy | Gets or sets the name of the last author.
LastSavedTime | Gets or sets the time of the last save in local timezone.
LastSavedUniversalTime | Gets or sets the universal time of the last save.
Lines | Obsolete. Represents an estimate of the number of lines in the document.
LinksUpToDate | Indicates whether hyperlinks in a document are up-to-date.
Manager | Gets or sets the manager property.
NameOfApplication | Gets or sets the name of the application.
Pages | Represents an estimate of the number of pages in the document.
Paragraphs | Obsolete. Represents an estimate of the number of paragraphs in the document.
Revision | Gets or sets the document revision number.
RevisionNumber | Obsolete. Gets or sets the document revision number.
ScaleCrop | Indicates the display mode of the document thumbnail.
Subject | Gets or sets the subject of the document.
Template | Gets or sets the informational name of the document template.
Title | Gets or sets the title of the document.
TotalEditingTime | Gets or sets the total editing time in minutes.
Version | Represents the version number of the application that created the document.
Words | Represents an estimate of the number of words in the document.

Public Instance Methods

Clear (inherited from DocumentPropertyCollection) | Removes all properties from the collection.
Contains (inherited from DocumentPropertyCollection) | Returns true if a property with the specified name exists in the collection.
Equals (inherited from Object) |
GetEnumerator (inherited from DocumentPropertyCollection) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf (inherited from DocumentPropertyCollection) | Gets the index of a property by name.
Remove (inherited from DocumentPropertyCollection) | Removes a property with the specified name from the collection.
RemoveAt (inherited from DocumentPropertyCollection) | Removes a property at the specified index.
ToString (inherited from Object) |

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


BuiltInDocumentPropertyCollection Properties

The properties of the BuiltInDocumentPropertyCollection class are listed below. For a complete list of BuiltInDocumentPropertyCollection class members, see the BuiltInDocumentPropertyCollection Members topic.

Public Instance Properties

Author | Gets or sets the name of the document's author.
Bytes | Obsolete. Represents an estimate of the number of bytes in the document.
Category | Gets or sets the category of the document.
Characters | Obsolete. Represents an estimate of the number of characters in the document.
CharactersWithSpaces | Obsolete. Represents an estimate of the number of characters (including spaces) in the document.
Comments | Gets or sets the document comments.
Company | Gets or sets the company property.
ContentStatus | Gets or sets the content status of the document.
ContentType | Gets or sets the content type of the document.
Count (inherited from DocumentPropertyCollection) | Gets number of items in the collection.
CreatedTime | Gets or sets date of the document creation in local timezone.
CreatedUniversalTime | Gets or sets the Universal time of the document creation.
DocumentVersion | Represents the version of the file.
HyperlinkBase | Gets or sets the hyperlinkbase property.
Item | Overloaded. Returns a DocumentProperty object by the name of the property.
Keywords | Gets or sets the document keywords.
Language | Gets or sets the document's language.
LastPrinted | Gets or sets the date when the document was last printed in local timezone.
LastPrintedUniversalTime | Gets or sets the Universal time when the document was last printed.
LastSavedBy | Gets or sets the name of the last author.
LastSavedTime | Gets or sets the time of the last save in local timezone.
LastSavedUniversalTime | Gets or sets the universal time of the last save.
Lines | Obsolete. Represents an estimate of the number of lines in the document.
LinksUpToDate | Indicates whether hyperlinks in a document are up-to-date.
Manager | Gets or sets the manager property.
NameOfApplication | Gets or sets the name of the application.
Pages | Represents an estimate of the number of pages in the document.
Paragraphs | Obsolete. Represents an estimate of the number of paragraphs in the document.
Revision | Gets or sets the document revision number.
RevisionNumber | Obsolete. Gets or sets the document revision number.
ScaleCrop | Indicates the display mode of the document thumbnail.
Subject | Gets or sets the subject of the document.
Template | Gets or sets the informational name of the document template.
Title | Gets or sets the title of the document.
TotalEditingTime | Gets or sets the total editing time in minutes.
Version | Represents the version number of the application that created the document.
Words | Represents an estimate of the number of words in the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Author Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Author Property

Gets or sets the name of the document's author.

public string Author {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Bytes Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Bytes Property

NOTE: This property is now obsolete.

This property is written for Word and PowerPoint. Excel will omit this property

Represents an estimate of the number of bytes in the document.

public int Bytes {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Category Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Category Property

Gets or sets the category of the document.

public string Category {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Characters Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Characters Property

NOTE: This property is now obsolete.

This property is written for Word and PowerPoint. Excel will omit this property

Represents an estimate of the number of characters in the document.

public int Characters {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CharactersWithSpaces Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.CharactersWithSpaces Property

NOTE: This property is now obsolete.

This property is written for Word and PowerPoint. Excel will omit this property

Represents an estimate of the number of characters (including spaces) in the document.

public int CharactersWithSpaces {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Comments Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Comments Property

Gets or sets the document comments.

public string Comments {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Company Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Company Property

Gets or sets the company property.

public string Company {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


ContentStatus Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.ContentStatus Property

Gets or sets the content status of the document.

public string ContentStatus {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


ContentType Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.ContentType Property

Gets or sets the content type of the document.

public string ContentType {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CreatedTime Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.CreatedTime Property

Gets or sets date of the document creation in local timezone.

public DateTime CreatedTime {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CreatedUniversalTime Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.CreatedUniversalTime Property

Gets or sets the Universal time of the document creation.

public DateTime CreatedUniversalTime {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentVersion Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.DocumentVersion Property

Represents the version of the file.

public string DocumentVersion {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


HyperlinkBase Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.HyperlinkBase Property

Gets or sets the hyperlinkbase property.

public string HyperlinkBase {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Item Property

Returns a DocumentProperty object by the name of the property.

public override DocumentProperty this[
string name
] {get;}

Parameters

name
The case-insensitive name of the property to retrieve.

Remarks

The string names of the properties correspond to the names of the typed properties available from BuiltInDocumentPropertyCollection.

If you request a property that is not present in the document, but the name of the property is recognized as a valid built-in name, a new DocumentProperty is created, added to the collection and returned. The newly created property is assigned a default value (empty string, zero, false or DateTime.MinValue depending on the type of the built-in property).

If you request a property that is not present in the document and the name is not recognized as a built-in name, a null is returned.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Keywords Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Keywords Property

Gets or sets the document keywords.

public string Keywords {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Language Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Language Property

Gets or sets the document's language.

public string Language {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


LastPrinted Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.LastPrinted Property

Gets or sets the date when the document was last printed in local timezone.

public DateTime LastPrinted {get; set;}

Remarks

If the document was never printed, this property will return DateTime.MinValue.

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


LastPrintedUniversalTime Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.LastPrintedUniversalTime Property

Gets or sets the Universal time when the document was last printed.

public DateTime LastPrintedUniversalTime {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


LastSavedBy Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.LastSavedBy Property

Gets or sets the name of the last author.

public string LastSavedBy {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


LastSavedTime Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.LastSavedTime Property

Gets or sets the time of the last save in local timezone.

public DateTime LastSavedTime {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


LastSavedUniversalTime Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.LastSavedUniversalTime Property

Gets or sets the universal time of the last save.

public DateTime LastSavedUniversalTime {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Lines Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Lines Property

NOTE: This property is now obsolete.

This property is written for Word and PowerPoint. Excel will omit this property

Represents an estimate of the number of lines in the document.

public int Lines {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


LinksUpToDate Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.LinksUpToDate Property

Indicates whether hyperlinks in a document are up-to-date.

public bool LinksUpToDate {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Manager Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Manager Property

Gets or sets the manager property.

public string Manager {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


NameOfApplication Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.NameOfApplication Property

Gets or sets the name of the application.

public string NameOfApplication {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Pages Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Pages Property

Represents an estimate of the number of pages in the document.

public int Pages {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Paragraphs Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Paragraphs Property

NOTE: This property is now obsolete.

This property is written for Word and PowerPoint. Excel will omit this property

Represents an estimate of the number of paragraphs in the document.

public int Paragraphs {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Revision Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Revision Property

Gets or sets the document revision number.

public string Revision {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


RevisionNumber Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.RevisionNumber Property

NOTE: This property is now obsolete.

Use BuiltInDocumentPropertyCollection.Revision property instead.

Gets or sets the document revision number.

public int RevisionNumber {get; set;}

Remarks

Aspose.Cells does not update this property when you modify the document.

NOTE: This property is now obsolete. Instead, please use BuiltInDocumentPropertyCollection.Revision property, this property will be removed 12 months later since February 2017. Aspose apologizes for any inconvenience you may have experienced.

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


ScaleCrop Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.ScaleCrop Property

Indicates the display mode of the document thumbnail.

public bool ScaleCrop {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Subject Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Subject Property

Gets or sets the subject of the document.

public string Subject {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Template Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Template Property

Gets or sets the informational name of the document template.

public string Template {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Title Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Title Property

Gets or sets the title of the document.

public string Title {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


TotalEditingTime Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.TotalEditingTime Property

Gets or sets the total editing time in minutes.

public double TotalEditingTime {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Version Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Version Property

Represents the version number of the application that created the document.

public string Version {get; set;}

Remarks

It's format is "00.0000",for example : 12.0000

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Words Property

Aspose.Cells for .NET

BuiltInDocumentPropertyCollection.Words Property

Represents an estimate of the number of words in the document.

public int Words {get; set;}

See Also

BuiltInDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


ContentTypeProperty Class

Represents identifier information.

For a list of all members of this type, see ContentTypeProperty Members.

System.Object
Aspose.Cells.Properties.ContentTypeProperty

public class ContentTypeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ContentTypeProperty Members | Aspose.Cells.Properties Namespace


ContentTypeProperty Members

ContentTypeProperty overview

Public Instance Properties

IsNillable | Indicates whether the value could be empty.
Name | Returns or sets the name of the object.
Type | Gets and sets the type of the property.
Value | Returns or sets the value of the content type property.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ContentTypeProperty Class | Aspose.Cells.Properties Namespace


ContentTypeProperty Properties

The properties of the ContentTypeProperty class are listed below. For a complete list of ContentTypeProperty class members, see the ContentTypeProperty Members topic.

Public Instance Properties

IsNillable | Indicates whether the value could be empty.
Name | Returns or sets the name of the object.
Type | Gets and sets the type of the property.
Value | Returns or sets the value of the content type property.

See Also

ContentTypeProperty Class | Aspose.Cells.Properties Namespace


IsNillable Property

Aspose.Cells for .NET

ContentTypeProperty.IsNillable Property

Indicates whether the value could be empty.

public bool IsNillable {get; set;}

See Also

ContentTypeProperty Class | Aspose.Cells.Properties Namespace


Name Property

Aspose.Cells for .NET

ContentTypeProperty.Name Property

Returns or sets the name of the object.

public string Name {get; set;}

See Also

ContentTypeProperty Class | Aspose.Cells.Properties Namespace


Type Property

Aspose.Cells for .NET

ContentTypeProperty.Type Property

Gets and sets the type of the property.

public string Type {get; set;}

See Also

ContentTypeProperty Class | Aspose.Cells.Properties Namespace


Value Property

Aspose.Cells for .NET

ContentTypeProperty.Value Property

Returns or sets the value of the content type property.

public string Value {get; set;}

See Also

ContentTypeProperty Class | Aspose.Cells.Properties Namespace


ContentTypePropertyCollection Class

A collection of ContentTypeProperty objects that represent additional information.

For a list of all members of this type, see ContentTypePropertyCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Properties.ContentTypePropertyCollection

public class ContentTypePropertyCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ContentTypePropertyCollection Members | Aspose.Cells.Properties Namespace


ContentTypePropertyCollection Members

ContentTypePropertyCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the content type property by the specific index.

Public Instance Methods

Add | Overloaded. Adds content type property information.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace


ContentTypePropertyCollection Properties

The properties of the ContentTypePropertyCollection class are listed below. For a complete list of ContentTypePropertyCollection class members, see the ContentTypePropertyCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the content type property by the specific index.

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property

Aspose.Cells for .NET

ContentTypePropertyCollection.Item Property

Gets the content type property by the specific index.

Overload List

Gets the content type property by the specific index.

public ContentTypeProperty this[int] {get;}

Gets the content type property by the property name.

public ContentTypeProperty this[string] {get;}

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property (Int32)

Aspose.Cells for .NET

ContentTypePropertyCollection.Item Property (Int32)

Gets the content type property by the specific index.

public ContentTypeProperty this[
int index
] {get;}

Parameters

index
The index.

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace | ContentTypePropertyCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ContentTypePropertyCollection.Item Property (String)

Gets the content type property by the property name.

public ContentTypeProperty this[
string name
] {get;}

Parameters

name
The property name.

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace | ContentTypePropertyCollection.Item Overload List


ContentTypePropertyCollection Methods

The methods of the ContentTypePropertyCollection class are listed below. For a complete list of ContentTypePropertyCollection class members, see the ContentTypePropertyCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds content type property information.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace


Add Method

Aspose.Cells for .NET

ContentTypePropertyCollection.Add Method

Adds content type property information.

Overload List

Adds content type property information.

public int Add(string,string);

Adds content type property information.

public int Add(string,string,string);

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace


ContentTypePropertyCollection.Add Method (String, String)

Adds content type property information.

public int Add(
string name,
string value
);

Parameters

name
The name of the content type property.
value
The value of the content type property.

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace | ContentTypePropertyCollection.Add Overload List


ContentTypePropertyCollection.Add Method (String, String, String)

Adds content type property information.

public int Add(
string name,
string value,
string type
);

Parameters

name
The name of the content type property.
value
The value of the content type property.
type
The type of the content type property.

See Also

ContentTypePropertyCollection Class | Aspose.Cells.Properties Namespace | ContentTypePropertyCollection.Add Overload List


CustomDocumentPropertyCollection Class

A collection of custom document properties.

For a list of all members of this type, see CustomDocumentPropertyCollection Members.

System.Object
Aspose.Cells.Properties.DocumentPropertyCollection
Aspose.Cells.Properties.CustomDocumentPropertyCollection

public class CustomDocumentPropertyCollection : DocumentPropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Each DocumentProperty object represents a custom property of a container document.

Example

[C#]

 //Instantiate a Workbook object
 Workbook workbook = new Workbook("C:\\book1.xls");

 //Retrieve a list of all custom document properties of the Excel file
 CustomDocumentPropertyCollection customProperties = workbook.Worksheets.CustomDocumentProperties;

 [VB.NET]

 'Instantiate a Workbook object
 Dim workbook As New Workbook("C:\book1.xls")

 'Retrieve a list of all custom document properties of the Excel file
 Dim customProperties As CustomDocumentPropertyCollection = workbook.Worksheets.CustomDocumentProperties

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomDocumentPropertyCollection Members | Aspose.Cells.Properties Namespace


CustomDocumentPropertyCollection Members

CustomDocumentPropertyCollection overview

Public Instance Properties

Count (inherited from DocumentPropertyCollection) | Gets number of items in the collection.
Item (inherited from DocumentPropertyCollection) | Returns a DocumentProperty object by the name of the property.
Item (inherited from DocumentPropertyCollection) | Returns a DocumentProperty object by the name of the property.

Public Instance Methods

Add | Overloaded. Creates a new custom document property.
AddLinkToContent | Creates a new custom document property which links to content.
Clear (inherited from DocumentPropertyCollection) | Removes all properties from the collection.
Contains (inherited from DocumentPropertyCollection) | Returns true if a property with the specified name exists in the collection.
Equals (inherited from Object) |
GetEnumerator (inherited from DocumentPropertyCollection) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf (inherited from DocumentPropertyCollection) | Gets the index of a property by name.
Remove (inherited from DocumentPropertyCollection) | Removes a property with the specified name from the collection.
RemoveAt (inherited from DocumentPropertyCollection) | Removes a property at the specified index.
ToString (inherited from Object) |
UpdateLinkedPropertyValue | Update custom document property value which links to content.
UpdateLinkedRange | Update custom document property value to linked range.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomDocumentPropertyCollection Methods

The methods of the CustomDocumentPropertyCollection class are listed below. For a complete list of CustomDocumentPropertyCollection class members, see the CustomDocumentPropertyCollection Members topic.

Public Instance Methods

Add | Overloaded. Creates a new custom document property.
AddLinkToContent | Creates a new custom document property which links to content.
Clear (inherited from DocumentPropertyCollection) | Removes all properties from the collection.
Contains (inherited from DocumentPropertyCollection) | Returns true if a property with the specified name exists in the collection.
Equals (inherited from Object) |
GetEnumerator (inherited from DocumentPropertyCollection) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf (inherited from DocumentPropertyCollection) | Gets the index of a property by name.
Remove (inherited from DocumentPropertyCollection) | Removes a property with the specified name from the collection.
RemoveAt (inherited from DocumentPropertyCollection) | Removes a property at the specified index.
ToString (inherited from Object) |
UpdateLinkedPropertyValue | Update custom document property value which links to content.
UpdateLinkedRange | Update custom document property value to linked range.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Add Method

Aspose.Cells for .NET

CustomDocumentPropertyCollection.Add Method

Creates a new custom document property.

Overload List

Creates a new custom document property of the PropertyType.Boolean data type.

public DocumentProperty Add(string,bool);

Creates a new custom document property of the PropertyType.DateTime data type.

public DocumentProperty Add(string,DateTime);

Creates a new custom document property of the PropertyType.Float data type.

public DocumentProperty Add(string,double);

Creates a new custom document property of the PropertyType.Number data type.

public DocumentProperty Add(string,int);

Creates a new custom document property of the PropertyType.String data type.

public DocumentProperty Add(string,string);

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomDocumentPropertyCollection.Add Method (String, Boolean)

Creates a new custom document property of the PropertyType.Boolean data type.

public DocumentProperty Add(
string name,
bool value
);

Parameters

name
The name of the property.
value
The value of the property.

Return Value

The newly created property object.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomDocumentPropertyCollection.Add Overload List


CustomDocumentPropertyCollection.Add Method (String, DateTime)

Creates a new custom document property of the PropertyType.DateTime data type.

public DocumentProperty Add(
string name,
DateTime value
);

Parameters

name
The name of the property.
value
The value of the property.

Return Value

The newly created property object.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomDocumentPropertyCollection.Add Overload List


CustomDocumentPropertyCollection.Add Method (String, Double)

Creates a new custom document property of the PropertyType.Float data type.

public DocumentProperty Add(
string name,
double value
);

Parameters

name
The name of the property.
value
The value of the property.

Return Value

The newly created property object.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomDocumentPropertyCollection.Add Overload List


CustomDocumentPropertyCollection.Add Method (String, Int32)

Creates a new custom document property of the PropertyType.Number data type.

public DocumentProperty Add(
string name,
int value
);

Parameters

name
The name of the property.
value
The value of the property.

Return Value

The newly created property object.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomDocumentPropertyCollection.Add Overload List


CustomDocumentPropertyCollection.Add Method (String, String)

Creates a new custom document property of the PropertyType.String data type.

public DocumentProperty Add(
string name,
string value
);

Parameters

name
The name of the property.
value
The value of the property.

Return Value

The newly created property object.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomDocumentPropertyCollection.Add Overload List


CustomDocumentPropertyCollection.AddLinkToContent Method

Creates a new custom document property which links to content.

public DocumentProperty AddLinkToContent(
string name,
string source
);

Parameters

name
The name of the property.
source
The source of the property

Return Value

The newly created property object.

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomDocumentPropertyCollection.UpdateLinkedPropertyValue Method

Update custom document property value which links to content.

public void UpdateLinkedPropertyValue();

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomDocumentPropertyCollection.UpdateLinkedRange Method

Update custom document property value to linked range.

public void UpdateLinkedRange();

See Also

CustomDocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomProperty Class

Represents identifier information.

For a list of all members of this type, see CustomProperty Members.

System.Object
Aspose.Cells.Properties.CustomProperty

public class CustomProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomProperty Members | Aspose.Cells.Properties Namespace


CustomProperty Members

CustomProperty overview

Public Instance Constructors

CustomProperty Constructor Initializes a new instance of the CustomProperty class.

Public Instance Properties

Name | Returns or sets the name of the object.
StringValue | Obsolete. Returns or sets the value of the custom property.
Value | Returns or sets the value of the custom property.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

CustomProperty Class | Aspose.Cells.Properties Namespace


CustomProperty Constructor

Initializes a new instance of the CustomProperty class.

public CustomProperty();

See Also

CustomProperty Class | Aspose.Cells.Properties Namespace


CustomProperty Properties

The properties of the CustomProperty class are listed below. For a complete list of CustomProperty class members, see the CustomProperty Members topic.

Public Instance Properties

Name | Returns or sets the name of the object.
StringValue | Obsolete. Returns or sets the value of the custom property.
Value | Returns or sets the value of the custom property.

See Also

CustomProperty Class | Aspose.Cells.Properties Namespace


Name Property

Aspose.Cells for .NET

CustomProperty.Name Property

Returns or sets the name of the object.

public string Name {get; set;}

See Also

CustomProperty Class | Aspose.Cells.Properties Namespace


StringValue Property

Aspose.Cells for .NET

CustomProperty.StringValue Property

NOTE: This property is now obsolete.

Use CustomProperty.Value property instead.

Returns or sets the value of the custom property.

public string StringValue {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use CustomProperty.Value property. This property will be removed 12 months later since June 2010. Aspose apologizes for any inconvenience you may have experienced.

See Also

CustomProperty Class | Aspose.Cells.Properties Namespace


Value Property

Aspose.Cells for .NET

CustomProperty.Value Property

Returns or sets the value of the custom property.

public string Value {get; set;}

See Also

CustomProperty Class | Aspose.Cells.Properties Namespace


CustomPropertyCollection Class

A collection of CustomProperty objects that represent additional information.

For a list of all members of this type, see CustomPropertyCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Properties.CustomPropertyCollection

public class CustomPropertyCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

CustomPropertyCollection Members | Aspose.Cells.Properties Namespace


CustomPropertyCollection Members

CustomPropertyCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the custom property by the specific index.

Public Instance Methods

Add | Adds custom property information.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomPropertyCollection Properties

The properties of the CustomPropertyCollection class are listed below. For a complete list of CustomPropertyCollection class members, see the CustomPropertyCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the custom property by the specific index.

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property

Aspose.Cells for .NET

CustomPropertyCollection.Item Property

Gets the custom property by the specific index.

Overload List

Gets the custom property by the specific index.

public CustomProperty this[int] {get;}

Gets the custom property by the property name.

public CustomProperty this[string] {get;}

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property (Int32)

Aspose.Cells for .NET

CustomPropertyCollection.Item Property (Int32)

Gets the custom property by the specific index.

public CustomProperty this[
int index
] {get;}

Parameters

index
The index.

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomPropertyCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

CustomPropertyCollection.Item Property (String)

Gets the custom property by the property name.

public CustomProperty this[
string name
] {get;}

Parameters

name
The property name.

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace | CustomPropertyCollection.Item Overload List


CustomPropertyCollection Methods

The methods of the CustomPropertyCollection class are listed below. For a complete list of CustomPropertyCollection class members, see the CustomPropertyCollection Members topic.

Public Instance Methods

Add | Adds custom property information.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace


CustomPropertyCollection.Add Method

Adds custom property information.

public int Add(
string name,
string value
);

Parameters

name
The name of the custom property.
value
The value of the custom property.

See Also

CustomPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentProperty Class

Represents a custom or built-in document property.

For a list of all members of this type, see DocumentProperty Members.

System.Object
Aspose.Cells.Properties.DocumentProperty

public class DocumentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

 //Instantiate a Workbook object
 Workbook workbook = new Workbook("C:\\book1.xls");

 //Retrieve a list of all custom document properties of the Excel file
 DocumentPropertyCollection customProperties = workbook.Worksheets.CustomDocumentProperties;

 //Accessng a custom document property by using the property index
 DocumentProperty customProperty1 = customProperties[3];

 //Accessng a custom document property by using the property name
 DocumentProperty customProperty2 = customProperties["Owner"];

 [VB.NET]

 'Instantiate a Workbook object
 Dim workbook As Workbook = New Workbook("C:\\book1.xls")

 'Retrieve a list of all custom document properties of the Excel file
 Dim customProperties As DocumentPropertyCollection = workbook.Worksheets.CustomDocumentProperties

 'Accessng a custom document property by using the property index
 Dim customProperty1 As DocumentProperty = customProperties(3)

 'Accessng a custom document property by using the property name
 Dim customProperty2 As DocumentProperty = customProperties("Owner")

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DocumentProperty Members | Aspose.Cells.Properties Namespace


DocumentProperty Members

DocumentProperty overview

Public Instance Properties

IsGeneratedName | Returns true if this property does not have a name in the OLE2 storage and a unique name was generated only for the public API.
IsLinkedToContent | Indicates whether this property is linked to content
Name | Returns the name of the property.
Source | The linked content source.
Type | Gets the data type of the property.
Value | Gets or sets the value of the property.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToBool | Returns the property value as bool.
ToDateTime | Returns the property value as DateTime in local timezone.
ToDouble | Returns the property value as double.
ToInt | Returns the property value as integer.
ToString | Returns the property value as a string.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty Properties

The properties of the DocumentProperty class are listed below. For a complete list of DocumentProperty class members, see the DocumentProperty Members topic.

Public Instance Properties

IsGeneratedName | Returns true if this property does not have a name in the OLE2 storage and a unique name was generated only for the public API.
IsLinkedToContent | Indicates whether this property is linked to content
Name | Returns the name of the property.
Source | The linked content source.
Type | Gets the data type of the property.
Value | Gets or sets the value of the property.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


IsGeneratedName Property

Aspose.Cells for .NET

DocumentProperty.IsGeneratedName Property

Returns true if this property does not have a name in the OLE2 storage and a unique name was generated only for the public API.

public bool IsGeneratedName {get;}

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


IsLinkedToContent Property

Aspose.Cells for .NET

DocumentProperty.IsLinkedToContent Property

Indicates whether this property is linked to content

public bool IsLinkedToContent {get;}

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


Name Property

Aspose.Cells for .NET

DocumentProperty.Name Property

Returns the name of the property.

public string Name {get;}

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


Source Property

Aspose.Cells for .NET

DocumentProperty.Source Property

The linked content source.

public string Source {get;}

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


Type Property

Aspose.Cells for .NET

DocumentProperty.Type Property

Gets the data type of the property.

public PropertyType Type {get;}

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


Value Property

Aspose.Cells for .NET

DocumentProperty.Value Property

Gets or sets the value of the property.

public object Value {get; set;}

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty Methods

The methods of the DocumentProperty class are listed below. For a complete list of DocumentProperty class members, see the DocumentProperty Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToBool | Returns the property value as bool.
ToDateTime | Returns the property value as DateTime in local timezone.
ToDouble | Returns the property value as double.
ToInt | Returns the property value as integer.
ToString | Returns the property value as a string.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty.ToBool Method

Returns the property value as bool.

public bool ToBool();

Remarks

Throws an exception if the property type is not PropertyType.Boolean.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty.ToDateTime Method

Returns the property value as DateTime in local timezone.

public DateTime ToDateTime();

Remarks

Throws an exception if the property type is not PropertyType.Date.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty.ToDouble Method

Returns the property value as double.

public double ToDouble();

Remarks

Throws an exception if the property type is not PropertyType.Float.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty.ToInt Method

Returns the property value as integer.

public int ToInt();

Remarks

Throws an exception if the property type is not PropertyType.Number.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentProperty.ToString Method

Returns the property value as a string.

public override string ToString();

Remarks

Converts a number property using Object.ToString(). Converts a boolean property into "Y" or "N". Converts a date property into a short date string.

See Also

DocumentProperty Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection Class

Base class for BuiltInDocumentPropertyCollection and CustomDocumentPropertyCollection collections.

For a list of all members of this type, see DocumentPropertyCollection Members.

System.Object
Aspose.Cells.Properties.DocumentPropertyCollection
Aspose.Cells.Properties.BuiltInDocumentPropertyCollection
Aspose.Cells.Properties.CustomDocumentPropertyCollection

public abstract class DocumentPropertyCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Instantiate a Workbook object by calling its empty constructor
Workbook workbook = new Workbook("C:\\book1.xls");

//Retrieve a list of all custom document properties of the Excel file
DocumentPropertyCollection customProperties = workbook.Worksheets.CustomDocumentProperties;

//Accessng a custom document property by using the property index
DocumentProperty customProperty1 = customProperties[3];

//Accessng a custom document property by using the property name
DocumentProperty customProperty2 = customProperties["Owner"];

[VB.NET]

'Instantiate a Workbook object by calling its empty constructor
Dim workbook As Workbook = New Workbook("C:\\book1.xls")

'Retrieve a list of all custom document properties of the Excel file
Dim customProperties As DocumentPropertyCollection = workbook.Worksheets.CustomDocumentProperties

'Accessng a custom document property by using the property index
Dim customProperty1 As DocumentProperty = customProperties(3)

'Accessng a custom document property by using the property name
Dim customProperty2 As DocumentProperty = customProperties("Owner")

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DocumentPropertyCollection Members | Aspose.Cells.Properties Namespace


DocumentPropertyCollection Members

DocumentPropertyCollection overview

Public Instance Properties

Count | Gets number of items in the collection.
Item | Overloaded. Returns a DocumentProperty object.

Public Instance Methods

Clear | Removes all properties from the collection.
Contains | Returns true if a property with the specified name exists in the collection.
Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of a property by name.
Remove | Removes a property with the specified name from the collection.
RemoveAt | Removes a property at the specified index.
ToString (inherited from Object) |

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection Properties

The properties of the DocumentPropertyCollection class are listed below. For a complete list of DocumentPropertyCollection class members, see the DocumentPropertyCollection Members topic.

Public Instance Properties

Count | Gets number of items in the collection.
Item | Overloaded. Returns a DocumentProperty object.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Count Property

Aspose.Cells for .NET

DocumentPropertyCollection.Count Property

Gets number of items in the collection.

public int Count {get;}

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property

Aspose.Cells for .NET

DocumentPropertyCollection.Item Property

Returns a DocumentProperty object.

Overload List

Returns a DocumentProperty object by index.

public DocumentProperty this[int] {get;}

Returns a DocumentProperty object by the name of the property.

public virtual DocumentProperty this[string] {get;}

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


Item Property (Int32)

Aspose.Cells for .NET

DocumentPropertyCollection.Item Property (Int32)

Returns a DocumentProperty object by index.

public DocumentProperty this[
int index
] {get;}

Parameters

index
Zero-based index of the DocumentProperty to retrieve.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | DocumentPropertyCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

DocumentPropertyCollection.Item Property (String)

Returns a DocumentProperty object by the name of the property.

public virtual DocumentProperty this[
string name
] {get;}

Parameters

name
The case-insensitive name of the property to retrieve.

Remarks

Returns null if a property with the specified name is not found.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace | DocumentPropertyCollection.Item Overload List


DocumentPropertyCollection Methods

The methods of the DocumentPropertyCollection class are listed below. For a complete list of DocumentPropertyCollection class members, see the DocumentPropertyCollection Members topic.

Public Instance Methods

Clear | Removes all properties from the collection.
Contains | Returns true if a property with the specified name exists in the collection.
Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IndexOf | Gets the index of a property by name.
Remove | Removes a property with the specified name from the collection.
RemoveAt | Removes a property at the specified index.
ToString (inherited from Object) |

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection.Clear Method

Removes all properties from the collection.

public void Clear();

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection.Contains Method

Returns true if a property with the specified name exists in the collection.

public bool Contains(
string name
);

Parameters

name
The case-insensitive name of the property.

Return Value

True if the property exists in the collection; false otherwise.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection.IndexOf Method

Gets the index of a property by name.

public int IndexOf(
string name
);

Parameters

name
The case-insensitive name of the property.

Return Value

The zero based index. Negative value if not found.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection.Remove Method

Removes a property with the specified name from the collection.

public void Remove(
string name
);

Parameters

name
The case-insensitive name of the property.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


DocumentPropertyCollection.RemoveAt Method

Removes a property at the specified index.

public void RemoveAt(
int index
);

Parameters

index
The zero based index.

See Also

DocumentPropertyCollection Class | Aspose.Cells.Properties Namespace


PropertyType Enumeration

Specifies data type of a document property.

public enum PropertyType

Members

Member Name | Description | Value
Boolean | The property is a boolean value. | 0
DateTime | The property is a date time value. | 1
Double | The property is a floating number. | 2
Number | The property is an integer number. | 3
String | The property is a string value. | 4
Blob | The property is a byte array. | 5

Requirements

Namespace: Aspose.Cells.Properties

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Properties Namespace


Aspose.Cells.QueryTables

Aspose.Cells for .NET

Aspose.Cells.QueryTables Namespace

Namespace hierarchy

Classes

Class | Description
DataMashup | Represents mashup data.
PowerQueryFormula | Represents the definition of power query formula.
PowerQueryFormulaCollction | Represents all power query formulas in the mashup data.
PowerQueryFormulaFunction | Represents the function of power query.
PowerQueryFormulaItem | Represents the item of the power query formula.
PowerQueryFormulaItemCollection | Represents all item of the power query formula.
PowerQueryFormulaParameter | Represents the parameter of power query formula.
PowerQueryFormulaParameterCollection | Represents the


DataMashup Class

Represents mashup data.

For a list of all members of this type, see DataMashup Members.

System.Object
Aspose.Cells.QueryTables.DataMashup

public class DataMashup

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DataMashup Members | Aspose.Cells.QueryTables Namespace


DataMashup Members

DataMashup overview

Public Instance Properties

PowerQueryFormulaParameters | Gets all parameters of power query formulas.
PowerQueryFormulas | Gets all power query formulas.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DataMashup Class | Aspose.Cells.QueryTables Namespace


DataMashup Properties

The properties of the DataMashup class are listed below. For a complete list of DataMashup class members, see the DataMashup Members topic.

Public Instance Properties

PowerQueryFormulaParameters | Gets all parameters of power query formulas.
PowerQueryFormulas | Gets all power query formulas.

See Also

DataMashup Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameters Property

Aspose.Cells for .NET

DataMashup.PowerQueryFormulaParameters Property

Gets all parameters of power query formulas.

public PowerQueryFormulaParameterCollection PowerQueryFormulaParameters {get;}

See Also

DataMashup Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulas Property

Aspose.Cells for .NET

DataMashup.PowerQueryFormulas Property

Gets all power query formulas.

public PowerQueryFormulaCollction PowerQueryFormulas {get;}

See Also

DataMashup Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormula Class

Represents the definition of power query formula.

For a list of all members of this type, see PowerQueryFormula Members.

System.Object
Aspose.Cells.QueryTables.PowerQueryFormula
Aspose.Cells.QueryTables.PowerQueryFormulaFunction

public class PowerQueryFormula

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormula Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormula Members

PowerQueryFormula overview

Public Instance Properties

FormulaDefinition | Gets the definition of the power query formula.
Name | Gets and sets the name of the power query formula.
PowerQueryFormulaItems | Gets all items of power query formula.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PowerQueryFormula Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormula Properties

The properties of the PowerQueryFormula class are listed below. For a complete list of PowerQueryFormula class members, see the PowerQueryFormula Members topic.

Public Instance Properties

FormulaDefinition | Gets the definition of the power query formula.
Name | Gets and sets the name of the power query formula.
PowerQueryFormulaItems | Gets all items of power query formula.

See Also

PowerQueryFormula Class | Aspose.Cells.QueryTables Namespace


FormulaDefinition Property

Aspose.Cells for .NET

PowerQueryFormula.FormulaDefinition Property

Gets the definition of the power query formula.

public string FormulaDefinition {get;}

See Also

PowerQueryFormula Class | Aspose.Cells.QueryTables Namespace


Name Property

Aspose.Cells for .NET

PowerQueryFormula.Name Property

Gets and sets the name of the power query formula.

public string Name {get; set;}

See Also

PowerQueryFormula Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItems Property

Aspose.Cells for .NET

PowerQueryFormula.PowerQueryFormulaItems Property

Gets all items of power query formula.

public PowerQueryFormulaItemCollection PowerQueryFormulaItems {get;}

See Also

PowerQueryFormula Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaCollction Class

Represents all power query formulas in the mashup data.

For a list of all members of this type, see PowerQueryFormulaCollction Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.QueryTables.PowerQueryFormulaCollction

public class PowerQueryFormulaCollction : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormulaCollction Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaCollction Members

PowerQueryFormulaCollction overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets PowerQueryFormula by the index in the list.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

PowerQueryFormulaCollction Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaCollction Properties

The properties of the PowerQueryFormulaCollction class are listed below. For a complete list of PowerQueryFormulaCollction class members, see the PowerQueryFormulaCollction Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets PowerQueryFormula by the index in the list.

See Also

PowerQueryFormulaCollction Class | Aspose.Cells.QueryTables Namespace


Item Property

Aspose.Cells for .NET

PowerQueryFormulaCollction.Item Property

Gets PowerQueryFormula by the index in the list.

Overload List

Gets PowerQueryFormula by the index in the list.

public PowerQueryFormula this[int] {get;}

Gets PowerQueryFormula by the name of the power query formula.

public PowerQueryFormula this[string] {get;}

See Also

PowerQueryFormulaCollction Class | Aspose.Cells.QueryTables Namespace


Item Property (Int32)

Aspose.Cells for .NET

PowerQueryFormulaCollction.Item Property (Int32)

Gets PowerQueryFormula by the index in the list.

public PowerQueryFormula this[
int index
] {get;}

Parameters

index
The index.

See Also

PowerQueryFormulaCollction Class | Aspose.Cells.QueryTables Namespace | PowerQueryFormulaCollction.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PowerQueryFormulaCollction.Item Property (String)

Gets PowerQueryFormula by the name of the power query formula.

public PowerQueryFormula this[
string name
] {get;}

Parameters

name
The name of the item.

See Also

PowerQueryFormulaCollction Class | Aspose.Cells.QueryTables Namespace | PowerQueryFormulaCollction.Item Overload List


PowerQueryFormulaFunction Class

Represents the function of power query.

For a list of all members of this type, see PowerQueryFormulaFunction Members.

System.Object
Aspose.Cells.QueryTables.PowerQueryFormula
Aspose.Cells.QueryTables.PowerQueryFormulaFunction

public class PowerQueryFormulaFunction : PowerQueryFormula

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormulaFunction Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaFunction Members

PowerQueryFormulaFunction overview

Public Instance Properties

F | Gets and sets the definition of function.
FormulaDefinition (inherited from PowerQueryFormula) | Gets the definition of the power query formula.
Name (inherited from PowerQueryFormula) | Gets and sets the name of the power query formula.
PowerQueryFormulaItems (inherited from PowerQueryFormula) | Gets all items of power query formula.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PowerQueryFormulaFunction Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaFunction Properties

The properties of the PowerQueryFormulaFunction class are listed below. For a complete list of PowerQueryFormulaFunction class members, see the PowerQueryFormulaFunction Members topic.

Public Instance Properties

F | Gets and sets the definition of function.
FormulaDefinition (inherited from PowerQueryFormula) | Gets the definition of the power query formula.
Name (inherited from PowerQueryFormula) | Gets and sets the name of the power query formula.
PowerQueryFormulaItems (inherited from PowerQueryFormula) | Gets all items of power query formula.

See Also

PowerQueryFormulaFunction Class | Aspose.Cells.QueryTables Namespace


F Property

Aspose.Cells for .NET

PowerQueryFormulaFunction.F Property

Gets and sets the definition of function.

public string F {get; set;}

See Also

PowerQueryFormulaFunction Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItem Class

Represents the item of the power query formula.

For a list of all members of this type, see PowerQueryFormulaItem Members.

System.Object
Aspose.Cells.QueryTables.PowerQueryFormulaItem

public class PowerQueryFormulaItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormulaItem Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItem Members

PowerQueryFormulaItem overview

Public Instance Properties

Name | Gets the name of the item.
Value | Gets the value of the item.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PowerQueryFormulaItem Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItem Properties

The properties of the PowerQueryFormulaItem class are listed below. For a complete list of PowerQueryFormulaItem class members, see the PowerQueryFormulaItem Members topic.

Public Instance Properties

Name | Gets the name of the item.
Value | Gets the value of the item.

See Also

PowerQueryFormulaItem Class | Aspose.Cells.QueryTables Namespace


Name Property

Aspose.Cells for .NET

PowerQueryFormulaItem.Name Property

Gets the name of the item.

public string Name {get;}

See Also

PowerQueryFormulaItem Class | Aspose.Cells.QueryTables Namespace


Value Property

Aspose.Cells for .NET

PowerQueryFormulaItem.Value Property

Gets the value of the item.

public string Value {get; set;}

See Also

PowerQueryFormulaItem Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItemCollection Class

Represents all item of the power query formula.

For a list of all members of this type, see PowerQueryFormulaItemCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.QueryTables.PowerQueryFormulaItemCollection

public class PowerQueryFormulaItemCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormulaItemCollection Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItemCollection Members

PowerQueryFormulaItemCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets PowerQueryFormulaItem by the index in the list.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

PowerQueryFormulaItemCollection Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaItemCollection Properties

The properties of the PowerQueryFormulaItemCollection class are listed below. For a complete list of PowerQueryFormulaItemCollection class members, see the PowerQueryFormulaItemCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets PowerQueryFormulaItem by the index in the list.

See Also

PowerQueryFormulaItemCollection Class | Aspose.Cells.QueryTables Namespace


Item Property

Aspose.Cells for .NET

PowerQueryFormulaItemCollection.Item Property

Gets PowerQueryFormulaItem by the index in the list.

Overload List

Gets PowerQueryFormulaItem by the index in the list.

public PowerQueryFormulaItem this[int] {get;}

Gets PowerQueryFormulaItem by the name of the item.

public PowerQueryFormulaItem this[string] {get;}

See Also

PowerQueryFormulaItemCollection Class | Aspose.Cells.QueryTables Namespace


Item Property (Int32)

Aspose.Cells for .NET

PowerQueryFormulaItemCollection.Item Property (Int32)

Gets PowerQueryFormulaItem by the index in the list.

public PowerQueryFormulaItem this[
int index
] {get;}

Parameters

index
The index.

See Also

PowerQueryFormulaItemCollection Class | Aspose.Cells.QueryTables Namespace | PowerQueryFormulaItemCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PowerQueryFormulaItemCollection.Item Property (String)

Gets PowerQueryFormulaItem by the name of the item.

public PowerQueryFormulaItem this[
string name
] {get;}

Parameters

name
The name of the item.

See Also

PowerQueryFormulaItemCollection Class | Aspose.Cells.QueryTables Namespace | PowerQueryFormulaItemCollection.Item Overload List


PowerQueryFormulaParameter Class

Represents the parameter of power query formula.

For a list of all members of this type, see PowerQueryFormulaParameter Members.

System.Object
Aspose.Cells.QueryTables.PowerQueryFormulaParameter

public class PowerQueryFormulaParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormulaParameter Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameter Members

PowerQueryFormulaParameter overview

Public Instance Constructors

PowerQueryFormulaParameter Constructor Initializes a new instance of the PowerQueryFormulaParameter class.

Public Instance Properties

Name | Gets the name of parameter.
ParameterDefinition | Gets the definition of the parameter.
Value | Gets the value of parameter.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PowerQueryFormulaParameter Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameter Constructor

Initializes a new instance of the PowerQueryFormulaParameter class.

public PowerQueryFormulaParameter();

See Also

PowerQueryFormulaParameter Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameter Properties

The properties of the PowerQueryFormulaParameter class are listed below. For a complete list of PowerQueryFormulaParameter class members, see the PowerQueryFormulaParameter Members topic.

Public Instance Properties

Name | Gets the name of parameter.
ParameterDefinition | Gets the definition of the parameter.
Value | Gets the value of parameter.

See Also

PowerQueryFormulaParameter Class | Aspose.Cells.QueryTables Namespace


Name Property

Aspose.Cells for .NET

PowerQueryFormulaParameter.Name Property

Gets the name of parameter.

public string Name {get; set;}

See Also

PowerQueryFormulaParameter Class | Aspose.Cells.QueryTables Namespace


ParameterDefinition Property

Aspose.Cells for .NET

PowerQueryFormulaParameter.ParameterDefinition Property

Gets the definition of the parameter.

public string ParameterDefinition {get;}

See Also

PowerQueryFormulaParameter Class | Aspose.Cells.QueryTables Namespace


Value Property

Aspose.Cells for .NET

PowerQueryFormulaParameter.Value Property

Gets the value of parameter.

public string Value {get; set;}

See Also

PowerQueryFormulaParameter Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameterCollection Class

Represents the

For a list of all members of this type, see PowerQueryFormulaParameterCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.QueryTables.PowerQueryFormulaParameterCollection

public class PowerQueryFormulaParameterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.QueryTables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PowerQueryFormulaParameterCollection Members | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameterCollection Members

PowerQueryFormulaParameterCollection overview

Public Instance Constructors

PowerQueryFormulaParameterCollection Constructor Initializes a new instance of the PowerQueryFormulaParameterCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets PowerQueryFormulaParameter by the index in the list.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

PowerQueryFormulaParameterCollection Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameterCollection Constructor

Initializes a new instance of the PowerQueryFormulaParameterCollection class.

public PowerQueryFormulaParameterCollection();

See Also

PowerQueryFormulaParameterCollection Class | Aspose.Cells.QueryTables Namespace


PowerQueryFormulaParameterCollection Properties

The properties of the PowerQueryFormulaParameterCollection class are listed below. For a complete list of PowerQueryFormulaParameterCollection class members, see the PowerQueryFormulaParameterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets PowerQueryFormulaParameter by the index in the list.

See Also

PowerQueryFormulaParameterCollection Class | Aspose.Cells.QueryTables Namespace


Item Property

Aspose.Cells for .NET

PowerQueryFormulaParameterCollection.Item Property

Gets PowerQueryFormulaParameter by the index in the list.

Overload List

Gets PowerQueryFormulaParameter by the index in the list.

public PowerQueryFormulaParameter this[int] {get;}

Gets PowerQueryFormulaParameter by the name of the item.

public PowerQueryFormulaParameter this[string] {get;}

See Also

PowerQueryFormulaParameterCollection Class | Aspose.Cells.QueryTables Namespace


Item Property (Int32)

Aspose.Cells for .NET

PowerQueryFormulaParameterCollection.Item Property (Int32)

Gets PowerQueryFormulaParameter by the index in the list.

public PowerQueryFormulaParameter this[
int index
] {get;}

Parameters

index
The index.

See Also

PowerQueryFormulaParameterCollection Class | Aspose.Cells.QueryTables Namespace | PowerQueryFormulaParameterCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

PowerQueryFormulaParameterCollection.Item Property (String)

Gets PowerQueryFormulaParameter by the name of the item.

public PowerQueryFormulaParameter this[
string name
] {get;}

Parameters

name
The name of the item.

See Also

PowerQueryFormulaParameterCollection Class | Aspose.Cells.QueryTables Namespace | PowerQueryFormulaParameterCollection.Item Overload List


Aspose.Cells.Rendering

Aspose.Cells for .NET

Aspose.Cells.Rendering Namespace

Namespace hierarchy

Classes

Class | Description
DrawObject | DrawObject will be initialized and returned when rendering.
DrawObjectEventHandler | Interface to get DrawObject and Bound when rendering.
ImageOrPrintOptions | Allows to specify options when rendering worksheet to images, printing worksheet or rendering chart to image.
PageEndSavingArgs | Info for a page ends saving process.
PageSavingArgs | Info for a page saving process.
PageStartSavingArgs | Info for a page starts saving process.
PdfBookmarkEntry | PdfBookmarkEntry is an entry in pdf bookmark. if Text property of current instance is null or "", current instance will be hidden and children will be inserted on current level.
SheetPrintingPreview | Worksheet printing preview.
SheetRender | Represents a worksheet render which can render worksheet to various images such as (BMP, PNG, JPEG, TIFF..) The constructor of this class , must be used after modification of pagesetup, cell style.
WorkbookPrintingPreview | Workbook printing preview.
WorkbookRender | Represents a Workbook render. The constructor of this class , must be used after modification of pagesetup, cell style.

Interfaces

Interface | Description
IPageSavingCallback | Control/Indicate progress of page saving process.

Enumerations

Enumeration | Description
ColorDepth | Enumerates Bit Depth Type for tiff image.
DrawObjectEnum | Indicate Cell or Image of DrawObject.
PdfCompliance | Allowing user to set PDF conversion's Compatibility
PdfCompressionCore | Specifies a type of compression applied to all content in the PDF file except images.
PdfCustomPropertiesExport | Specifies the way CustomDocumentPropertyCollection are exported to PDF file.
PdfOptimizationType | Specifies a type of optimization.
TiffCompression | Specifies what type of compression to apply when saving images into TIFF format file.


ColorDepth Enumeration

Enumerates Bit Depth Type for tiff image.

public enum ColorDepth

Members

Member Name | Description | Value
Default | Default value, not set value. | 0
Format1bpp | 1 bit per pixel | 1
Format4bpp | 84 bits per pixel | 4
Format8bpp | 8 bits per pixel | 8
Format24bpp | 24 bits per pixel | 24
Format32bpp | 32 bits per pixel | 32

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


DrawObject Class

DrawObject will be initialized and returned when rendering.

For a list of all members of this type, see DrawObject Members.

System.Object
Aspose.Cells.Rendering.DrawObject

public class DrawObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DrawObject Members | Aspose.Cells.Rendering Namespace


DrawObject Members

DrawObject overview

Public Instance Properties

Cell | Indicates the Cell object when rendering. All properties of cell can be accessed.
CurrentPage | Indicates the page index of DrawObject. Page index is based on zero. One Sheet contains several pages when rendering.
ImageBytes | Indicates image bytes of rendered Chart, Shape when rendering.
Shape | Indicates the Shape object when rendering. All properties of shape can be accessed.
SheetIndex | Indicates current sheet index of DrawObject.
TotalPages | Indicates total pages in current rendering.
Type | Indicates the type of DrawObject.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


DrawObject Properties

The properties of the DrawObject class are listed below. For a complete list of DrawObject class members, see the DrawObject Members topic.

Public Instance Properties

Cell | Indicates the Cell object when rendering. All properties of cell can be accessed.
CurrentPage | Indicates the page index of DrawObject. Page index is based on zero. One Sheet contains several pages when rendering.
ImageBytes | Indicates image bytes of rendered Chart, Shape when rendering.
Shape | Indicates the Shape object when rendering. All properties of shape can be accessed.
SheetIndex | Indicates current sheet index of DrawObject.
TotalPages | Indicates total pages in current rendering.
Type | Indicates the type of DrawObject.

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


Cell Property

Aspose.Cells for .NET

DrawObject.Cell Property

Indicates the Cell object when rendering. All properties of cell can be accessed.

public Cell Cell {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


CurrentPage Property

Aspose.Cells for .NET

DrawObject.CurrentPage Property

Indicates the page index of DrawObject. Page index is based on zero. One Sheet contains several pages when rendering.

public int CurrentPage {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


ImageBytes Property

Aspose.Cells for .NET

DrawObject.ImageBytes Property

Indicates image bytes of rendered Chart, Shape when rendering.

public byte[] ImageBytes {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


Shape Property

Aspose.Cells for .NET

DrawObject.Shape Property

Indicates the Shape object when rendering. All properties of shape can be accessed.

public Shape Shape {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


SheetIndex Property

Aspose.Cells for .NET

DrawObject.SheetIndex Property

Indicates current sheet index of DrawObject.

public int SheetIndex {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


TotalPages Property

Aspose.Cells for .NET

DrawObject.TotalPages Property

Indicates total pages in current rendering.

public int TotalPages {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


Type Property

Aspose.Cells for .NET

DrawObject.Type Property

Indicates the type of DrawObject.

public DrawObjectEnum Type {get;}

See Also

DrawObject Class | Aspose.Cells.Rendering Namespace


DrawObjectEnum Enumeration

Indicate Cell or Image of DrawObject.

public enum DrawObjectEnum

Members

Member Name | Description | Value
Image | Indicate DrawObject is an Image | 0
Cell | indicate DrawObject is an Cell | 1

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


DrawObjectEventHandler Class

Interface to get DrawObject and Bound when rendering.

For a list of all members of this type, see DrawObjectEventHandler Members.

System.Object
Aspose.Cells.Rendering.DrawObjectEventHandler

public abstract class DrawObjectEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

DrawObjectEventHandler Members | Aspose.Cells.Rendering Namespace


DrawObjectEventHandler Members

DrawObjectEventHandler overview

Public Instance Methods

Draw | Implements this interface to get DrawObject and Bound when rendering.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

DrawObjectEventHandler Class | Aspose.Cells.Rendering Namespace


DrawObjectEventHandler Methods

The methods of the DrawObjectEventHandler class are listed below. For a complete list of DrawObjectEventHandler class members, see the DrawObjectEventHandler Members topic.

Public Instance Methods

Draw | Implements this interface to get DrawObject and Bound when rendering.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

See Also

DrawObjectEventHandler Class | Aspose.Cells.Rendering Namespace


DrawObjectEventHandler.Draw Method

Implements this interface to get DrawObject and Bound when rendering.

public virtual void Draw(
DrawObject drawObject,
float x,
float y,
float width,
float height
);

Parameters

drawObject
DrawObject will be initialized and returned when rendering
x
Left of DrawObject
y
Top of DrawObject
width
Width of DrawObject
height
Height of DrawObject

See Also

DrawObjectEventHandler Class | Aspose.Cells.Rendering Namespace


ImageOrPrintOptions Class

Allows to specify options when rendering worksheet to images, printing worksheet or rendering chart to image.

For a list of all members of this type, see ImageOrPrintOptions Members.

System.Object
Aspose.Cells.Rendering.ImageOrPrintOptions

public class ImageOrPrintOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

//Set Image Or Print Options
ImageOrPrintOptions options = new ImageOrPrintOptions();

//set Horizontal resolution
options.HorizontalResolution = 200;

//set Vertica; Resolution
options.VerticalResolution = 300;

//Instantiate Workbook
Workbook book = new Workbook(@"c:\test.xls");

//Save chart as Image using ImageOrPrint Options
Bitmap chartObject = book.Worksheets[0].Charts[0].ToImage(options);

[VB.NET]

'Set Image Or Print Options
Dim options As New ImageOrPrintOptions()

'set Horizontal resolution
options.HorizontalResolution = 200

'set Vertica; Resolution
options.VerticalResolution = 300

'Instantiate Workbook
Dim book As New Workbook("c:\test.xls")

'Save chart as Image using ImageOrPrint Options
Dim chartObject As Bitmap = book.Worksheets(0).Charts(0).ToImage(options)

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ImageOrPrintOptions Members | Aspose.Cells.Rendering Namespace


ImageOrPrintOptions Members

ImageOrPrintOptions overview

Public Instance Constructors

ImageOrPrintOptions Constructor Initializes a new instance of the ImageOrPrintOptions class.

Public Instance Properties

AllColumnsInOnePagePerSheet | If AllColumnsInOnePagePerSheet is true , all column content of one sheet will output to only one page in result. The width of paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
ChartImageType | Indicate the chart imagetype when converting.
CheckWorkbookDefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set this to true to try to use workbook's default font to show these characters first.
CustomPrintPageEventHandler | Client can special output to printer when print each page using this EventHandler
CustomQueryPageSettingsEventHandler | Client can control page setting of printer when print each page using this EventHandler
DefaultEditLanguage | Gets or sets default edit language.
DefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set the DefaultFont such as MingLiu or MS Gothic to show these characters. If this property is not set, Aspose.Cells will use system default font to show these unicode characters.
DrawObjectEventHandler | Implements this interface to get DrawObject and Bound when rendering.
EmbededImageNameInSvg | Indicate the filename of embedded image in svg. This should be full path with directory like "c:\\xpsEmbedded"
EmfType | Gets or sets an EmfType that specifies the format of the Metafile.. The default value is EmfPlusDual.
GridlineType | Gets or sets gridline type.
HorizontalResolution | Gets or sets the horizontal resolution for generated images, in dots per inch. Applies generating image method except Emf format images.
ImageFormat | Obsolete. Gets or sets the format of the generated images. Don't apply the method that returns a Bitmap object.
ImageType | Gets or sets the format of the generated images. Don't apply the method that returns a Bitmap object.
IsCellAutoFit | Indicates whether the width and height of the cells is automatically fitted by cell value. The default value is false.
IsFontSubstitutionCharGranularity | Indicates whether only substitute the font of character when the cell font is not compatibility for it.
IsImageFitToPage | Obsolete. When set the value to true, the page only include the cells that have data. The default value is false.
OnePagePerSheet | If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
OnlyArea | If this property is true , one Area will be output, and no scale will take effect.
OutputBlankPageWhenNothingToPrint | Indicates whether to output a blank page when there is nothing to print.
PageCount | Gets or sets the number of pages to save.
PageIndex | Gets or sets the 0-based index of the first page to save.
PageSavingCallback | Control/Indicate progress of page saving process.
PixelFormat | Gets or sets the pixel format for the generated images.
PrintingPage | Indicates which pages will not be printed.
PrintWithStatusDialog | If PrintWithStatusDialog = true , there will be a dialog that shows current print status. else no such dialog will show.
Quality | Gets or sets a value determining the quality of the generated images to apply only when saving pages to the Jpeg format. The default value is 100
SaveFormat | Gets or sets the output file format type Support Tiff/XPS
SmoothingMode | Specifies whether smoothing (antialiasing) is applied to lines and curves and the edges of filled areas. The default value is SmoothingMode.None
SVGFitToViewPort | if this property is true, the generated svg will fit to view port.
TextCrossType | Gets or sets displaying text type when the text width is larger than cell width.
TextRenderingHint | Specifies the quality of text rendering. The default value is TextRenderingHint.SystemDefault
TiffColorDepth | Gets or sets bit depth to apply only when saving pages to the Tiff format.
TiffCompression | Gets or sets the type of compression to apply only when saving pages to the Tiff format.
Transparent | Indicates if the background of generated image should be transparent.
VerticalResolution | Gets or sets the vertical resolution for generated images, in dots per inch. Applies generating image method except Emf format image.
WarningCallback | Gets or sets warning callback.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetDesiredSize | Sets desired width and height of image.
ToString (inherited from Object) |

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ImageOrPrintOptions Constructor

Initializes a new instance of the ImageOrPrintOptions class.

public ImageOrPrintOptions();

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ImageOrPrintOptions Properties

The properties of the ImageOrPrintOptions class are listed below. For a complete list of ImageOrPrintOptions class members, see the ImageOrPrintOptions Members topic.

Public Instance Properties

AllColumnsInOnePagePerSheet | If AllColumnsInOnePagePerSheet is true , all column content of one sheet will output to only one page in result. The width of paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
ChartImageType | Indicate the chart imagetype when converting.
CheckWorkbookDefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set this to true to try to use workbook's default font to show these characters first.
CustomPrintPageEventHandler | Client can special output to printer when print each page using this EventHandler
CustomQueryPageSettingsEventHandler | Client can control page setting of printer when print each page using this EventHandler
DefaultEditLanguage | Gets or sets default edit language.
DefaultFont | When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set the DefaultFont such as MingLiu or MS Gothic to show these characters. If this property is not set, Aspose.Cells will use system default font to show these unicode characters.
DrawObjectEventHandler | Implements this interface to get DrawObject and Bound when rendering.
EmbededImageNameInSvg | Indicate the filename of embedded image in svg. This should be full path with directory like "c:\\xpsEmbedded"
EmfType | Gets or sets an EmfType that specifies the format of the Metafile.. The default value is EmfPlusDual.
GridlineType | Gets or sets gridline type.
HorizontalResolution | Gets or sets the horizontal resolution for generated images, in dots per inch. Applies generating image method except Emf format images.
ImageFormat | Obsolete. Gets or sets the format of the generated images. Don't apply the method that returns a Bitmap object.
ImageType | Gets or sets the format of the generated images. Don't apply the method that returns a Bitmap object.
IsCellAutoFit | Indicates whether the width and height of the cells is automatically fitted by cell value. The default value is false.
IsFontSubstitutionCharGranularity | Indicates whether only substitute the font of character when the cell font is not compatibility for it.
IsImageFitToPage | Obsolete. When set the value to true, the page only include the cells that have data. The default value is false.
OnePagePerSheet | If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.
OnlyArea | If this property is true , one Area will be output, and no scale will take effect.
OutputBlankPageWhenNothingToPrint | Indicates whether to output a blank page when there is nothing to print.
PageCount | Gets or sets the number of pages to save.
PageIndex | Gets or sets the 0-based index of the first page to save.
PageSavingCallback | Control/Indicate progress of page saving process.
PixelFormat | Gets or sets the pixel format for the generated images.
PrintingPage | Indicates which pages will not be printed.
PrintWithStatusDialog | If PrintWithStatusDialog = true , there will be a dialog that shows current print status. else no such dialog will show.
Quality | Gets or sets a value determining the quality of the generated images to apply only when saving pages to the Jpeg format. The default value is 100
SaveFormat | Gets or sets the output file format type Support Tiff/XPS
SmoothingMode | Specifies whether smoothing (antialiasing) is applied to lines and curves and the edges of filled areas. The default value is SmoothingMode.None
SVGFitToViewPort | if this property is true, the generated svg will fit to view port.
TextCrossType | Gets or sets displaying text type when the text width is larger than cell width.
TextRenderingHint | Specifies the quality of text rendering. The default value is TextRenderingHint.SystemDefault
TiffColorDepth | Gets or sets bit depth to apply only when saving pages to the Tiff format.
TiffCompression | Gets or sets the type of compression to apply only when saving pages to the Tiff format.
Transparent | Indicates if the background of generated image should be transparent.
VerticalResolution | Gets or sets the vertical resolution for generated images, in dots per inch. Applies generating image method except Emf format image.
WarningCallback | Gets or sets warning callback.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


AllColumnsInOnePagePerSheet Property

Aspose.Cells for .NET

ImageOrPrintOptions.AllColumnsInOnePagePerSheet Property

If AllColumnsInOnePagePerSheet is true , all column content of one sheet will output to only one page in result. The width of paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.

public bool AllColumnsInOnePagePerSheet {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ChartImageType Property

Aspose.Cells for .NET

ImageOrPrintOptions.ChartImageType Property

Indicate the chart imagetype when converting.

public ImageFormat ChartImageType {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


CheckWorkbookDefaultFont Property

Aspose.Cells for .NET

ImageOrPrintOptions.CheckWorkbookDefaultFont Property

When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set this to true to try to use workbook's default font to show these characters first.

public bool CheckWorkbookDefaultFont {get; set;}

Remarks

Default is true.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


CustomPrintPageEventHandler Property

Aspose.Cells for .NET

ImageOrPrintOptions.CustomPrintPageEventHandler Property

Client can special output to printer when print each page using this EventHandler

public PrintPageEventHandler CustomPrintPageEventHandler {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


CustomQueryPageSettingsEventHandler Property

Aspose.Cells for .NET

ImageOrPrintOptions.CustomQueryPageSettingsEventHandler Property

Client can control page setting of printer when print each page using this EventHandler

public QueryPageSettingsEventHandler CustomQueryPageSettingsEventHandler {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


DefaultEditLanguage Property

Aspose.Cells for .NET

ImageOrPrintOptions.DefaultEditLanguage Property

Gets or sets default edit language.

public DefaultEditLanguage DefaultEditLanguage {get; set;}

Remarks

It may display/render different layouts for text paragraph when different edit languages is set. Default is Auto.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


DefaultFont Property

Aspose.Cells for .NET

ImageOrPrintOptions.DefaultFont Property

When characters in the Excel are unicode and not be set with correct font in cell style, They may appear as block in pdf,image. Set the DefaultFont such as MingLiu or MS Gothic to show these characters. If this property is not set, Aspose.Cells will use system default font to show these unicode characters.

public string DefaultFont {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


DrawObjectEventHandler Property

Aspose.Cells for .NET

ImageOrPrintOptions.DrawObjectEventHandler Property

Implements this interface to get DrawObject and Bound when rendering.

public DrawObjectEventHandler DrawObjectEventHandler {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


EmbededImageNameInSvg Property

Aspose.Cells for .NET

ImageOrPrintOptions.EmbededImageNameInSvg Property

Indicate the filename of embedded image in svg. This should be full path with directory like "c:\\xpsEmbedded"

public string EmbededImageNameInSvg {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


EmfType Property

Aspose.Cells for .NET

ImageOrPrintOptions.EmfType Property

Gets or sets an EmfType that specifies the format of the Metafile.. The default value is EmfPlusDual.

public EmfType EmfType {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


GridlineType Property

Aspose.Cells for .NET

ImageOrPrintOptions.GridlineType Property

Gets or sets gridline type.

public GridlineType GridlineType {get; set;}

Remarks

Default is Dotted type.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


HorizontalResolution Property

Aspose.Cells for .NET

ImageOrPrintOptions.HorizontalResolution Property

Gets or sets the horizontal resolution for generated images, in dots per inch. Applies generating image method except Emf format images.

public int HorizontalResolution {get; set;}

Remarks

The default value is 96.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ImageFormat Property

Aspose.Cells for .NET

ImageOrPrintOptions.ImageFormat Property

NOTE: This property is now obsolete.

Use ImageOrPrintOptions.ImageType property instead.

Gets or sets the format of the generated images. Don't apply the method that returns a Bitmap object.

public ImageFormat ImageFormat {get; set;}

Remarks

NOTE: This member is now obsolete. Instead, please use ImageOrPrintOptions.ImageType property. This property will be removed 12 months later since April. 2018. Aspose apologizes for any inconvenience you may have experienced.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ImageType Property

Aspose.Cells for .NET

ImageOrPrintOptions.ImageType Property

Gets or sets the format of the generated images. Don't apply the method that returns a Bitmap object.

public ImageType ImageType {get; set;}

Remarks

The default value is ImageFormat.Bmp. Don't apply the method that returns a Bitmap object.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


IsCellAutoFit Property

Aspose.Cells for .NET

ImageOrPrintOptions.IsCellAutoFit Property

Indicates whether the width and height of the cells is automatically fitted by cell value. The default value is false.

public bool IsCellAutoFit {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


IsFontSubstitutionCharGranularity Property

Aspose.Cells for .NET

ImageOrPrintOptions.IsFontSubstitutionCharGranularity Property

Indicates whether only substitute the font of character when the cell font is not compatibility for it.

public bool IsFontSubstitutionCharGranularity {get; set;}

Remarks

Default is false. We will try default font of Workbook and PdfSaveOption/system for cell font first.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


IsImageFitToPage Property

Aspose.Cells for .NET

ImageOrPrintOptions.IsImageFitToPage Property

NOTE: This property is now obsolete.

this property is obsolete

When set the value to true, the page only include the cells that have data. The default value is false.

public bool IsImageFitToPage {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


OnePagePerSheet Property

Aspose.Cells for .NET

ImageOrPrintOptions.OnePagePerSheet Property

If OnePagePerSheet is true , all content of one sheet will output to only one page in result. The paper size of pagesetup will be invalid, and the other settings of pagesetup will still take effect.

public bool OnePagePerSheet {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


OnlyArea Property

Aspose.Cells for .NET

ImageOrPrintOptions.OnlyArea Property

If this property is true , one Area will be output, and no scale will take effect.

public bool OnlyArea {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


OutputBlankPageWhenNothingToPrint Property

Aspose.Cells for .NET

ImageOrPrintOptions.OutputBlankPageWhenNothingToPrint Property

Indicates whether to output a blank page when there is nothing to print.

public bool OutputBlankPageWhenNothingToPrint {get; set;}

Remarks

Default is false.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


PageCount Property

Aspose.Cells for .NET

ImageOrPrintOptions.PageCount Property

Gets or sets the number of pages to save.

public int PageCount {get; set;}

Remarks

Default is System.Int32.MaxValue which means all pages will be rendered..

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


PageIndex Property

Aspose.Cells for .NET

ImageOrPrintOptions.PageIndex Property

Gets or sets the 0-based index of the first page to save.

public int PageIndex {get; set;}

Remarks

Default is 0.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


PageSavingCallback Property

Aspose.Cells for .NET

ImageOrPrintOptions.PageSavingCallback Property

Control/Indicate progress of page saving process.

public IPageSavingCallback PageSavingCallback {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


PixelFormat Property

Aspose.Cells for .NET

ImageOrPrintOptions.PixelFormat Property

Gets or sets the pixel format for the generated images.

public PixelFormat PixelFormat {get; set;}

Remarks

The default value is PixelFormat.Format32bppArgb.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


PrintingPage Property

Aspose.Cells for .NET

ImageOrPrintOptions.PrintingPage Property

Indicates which pages will not be printed.

public PrintingPageType PrintingPage {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


PrintWithStatusDialog Property

Aspose.Cells for .NET

ImageOrPrintOptions.PrintWithStatusDialog Property

If PrintWithStatusDialog = true , there will be a dialog that shows current print status. else no such dialog will show.

public bool PrintWithStatusDialog {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


Quality Property

Aspose.Cells for .NET

ImageOrPrintOptions.Quality Property

Gets or sets a value determining the quality of the generated images to apply only when saving pages to the Jpeg format. The default value is 100

public int Quality {get; set;}

Remarks

Has effect only when saving to JPEG. The value must be between 0 and 100. The default value is 100.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


SaveFormat Property

Aspose.Cells for .NET

ImageOrPrintOptions.SaveFormat Property

Gets or sets the output file format type Support Tiff/XPS

public SaveFormat SaveFormat {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


SmoothingMode Property

Aspose.Cells for .NET

ImageOrPrintOptions.SmoothingMode Property

Specifies whether smoothing (antialiasing) is applied to lines and curves and the edges of filled areas. The default value is SmoothingMode.None

public SmoothingMode SmoothingMode {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


SVGFitToViewPort Property

Aspose.Cells for .NET

ImageOrPrintOptions.SVGFitToViewPort Property

if this property is true, the generated svg will fit to view port.

public bool SVGFitToViewPort {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


TextCrossType Property

Aspose.Cells for .NET

ImageOrPrintOptions.TextCrossType Property

Gets or sets displaying text type when the text width is larger than cell width.

public TextCrossType TextCrossType {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


TextRenderingHint Property

Aspose.Cells for .NET

ImageOrPrintOptions.TextRenderingHint Property

Specifies the quality of text rendering. The default value is TextRenderingHint.SystemDefault

public TextRenderingHint TextRenderingHint {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


TiffColorDepth Property

Aspose.Cells for .NET

ImageOrPrintOptions.TiffColorDepth Property

Gets or sets bit depth to apply only when saving pages to the Tiff format.

public ColorDepth TiffColorDepth {get; set;}

Remarks

Has effect only when saving to TIFF. If TiffCompression is set to CCITT3, CCITT4, this will not take effect, the bit depth of the generated tiff image will be always 1.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


TiffCompression Property

Aspose.Cells for .NET

ImageOrPrintOptions.TiffCompression Property

Gets or sets the type of compression to apply only when saving pages to the Tiff format.

public TiffCompression TiffCompression {get; set;}

Remarks

Has effect only when saving to TIFF. The default value is Lzw.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


Transparent Property

Aspose.Cells for .NET

ImageOrPrintOptions.Transparent Property

Indicates if the background of generated image should be transparent.

public bool Transparent {get; set;}

Remarks

The default value is false. That means the background of the generated images is white.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


VerticalResolution Property

Aspose.Cells for .NET

ImageOrPrintOptions.VerticalResolution Property

Gets or sets the vertical resolution for generated images, in dots per inch. Applies generating image method except Emf format image.

public int VerticalResolution {get; set;}

Remarks

The default value is 96.

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


WarningCallback Property

Aspose.Cells for .NET

ImageOrPrintOptions.WarningCallback Property

Gets or sets warning callback.

public IWarningCallback WarningCallback {get; set;}

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ImageOrPrintOptions Methods

The methods of the ImageOrPrintOptions class are listed below. For a complete list of ImageOrPrintOptions class members, see the ImageOrPrintOptions Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetDesiredSize | Sets desired width and height of image.
ToString (inherited from Object) |

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


ImageOrPrintOptions.SetDesiredSize Method

Sets desired width and height of image.

public void SetDesiredSize(
int desiredWidth,
int desiredHeight
);

Parameters

desiredWidth
desired width in pixels
desiredHeight
desired height in pixels

See Also

ImageOrPrintOptions Class | Aspose.Cells.Rendering Namespace


IPageSavingCallback Interface

Control/Indicate progress of page saving process.

For a list of all members of this type, see IPageSavingCallback Members.

public interface IPageSavingCallback

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

IPageSavingCallback Members | Aspose.Cells.Rendering Namespace


IPageSavingCallback Members

IPageSavingCallback overview

Public Instance Methods

PageEndSaving | Control/Indicate a page ends to be output.
PageStartSaving | Control/Indicate a page starts to be output.

See Also

IPageSavingCallback Interface | Aspose.Cells.Rendering Namespace


IPageSavingCallback Methods

The methods of the IPageSavingCallback interface are listed below. For a complete list of IPageSavingCallback interface members, see the IPageSavingCallback Members topic.

Public Instance Methods

PageEndSaving | Control/Indicate a page ends to be output.
PageStartSaving | Control/Indicate a page starts to be output.

See Also

IPageSavingCallback Interface | Aspose.Cells.Rendering Namespace


IPageSavingCallback.PageEndSaving Method

Control/Indicate a page ends to be output.

void PageEndSaving(
PageEndSavingArgs args
);

Parameters

args
Info for a page ends saving process.

See Also

IPageSavingCallback Interface | Aspose.Cells.Rendering Namespace


IPageSavingCallback.PageStartSaving Method

Control/Indicate a page starts to be output.

void PageStartSaving(
PageStartSavingArgs args
);

Parameters

args
Info for a page starts saving process.

See Also

IPageSavingCallback Interface | Aspose.Cells.Rendering Namespace


PageEndSavingArgs Class

Info for a page ends saving process.

For a list of all members of this type, see PageEndSavingArgs Members.

System.Object
Aspose.Cells.Rendering.PageSavingArgs
Aspose.Cells.Rendering.PageEndSavingArgs

public class PageEndSavingArgs : PageSavingArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PageEndSavingArgs Members | Aspose.Cells.Rendering Namespace


PageEndSavingArgs Members

PageEndSavingArgs overview

Public Instance Properties

HasMorePages | Gets or sets a value indicating whether having more pages to be output. The default value is true.
PageCount (inherited from PageSavingArgs) | Total page count.
PageIndex (inherited from PageSavingArgs) | Current page index, zero based.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PageEndSavingArgs Class | Aspose.Cells.Rendering Namespace


PageEndSavingArgs Properties

The properties of the PageEndSavingArgs class are listed below. For a complete list of PageEndSavingArgs class members, see the PageEndSavingArgs Members topic.

Public Instance Properties

HasMorePages | Gets or sets a value indicating whether having more pages to be output. The default value is true.
PageCount (inherited from PageSavingArgs) | Total page count.
PageIndex (inherited from PageSavingArgs) | Current page index, zero based.

See Also

PageEndSavingArgs Class | Aspose.Cells.Rendering Namespace


HasMorePages Property

Aspose.Cells for .NET

PageEndSavingArgs.HasMorePages Property

Gets or sets a value indicating whether having more pages to be output. The default value is true.

public bool HasMorePages {get; set;}

See Also

PageEndSavingArgs Class | Aspose.Cells.Rendering Namespace


PageSavingArgs Class

Info for a page saving process.

For a list of all members of this type, see PageSavingArgs Members.

System.Object
Aspose.Cells.Rendering.PageSavingArgs
Aspose.Cells.Rendering.PageEndSavingArgs
Aspose.Cells.Rendering.PageStartSavingArgs

public class PageSavingArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PageSavingArgs Members | Aspose.Cells.Rendering Namespace


PageSavingArgs Members

PageSavingArgs overview

Public Instance Properties

PageCount | Total page count.
PageIndex | Current page index, zero based.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PageSavingArgs Class | Aspose.Cells.Rendering Namespace


PageSavingArgs Properties

The properties of the PageSavingArgs class are listed below. For a complete list of PageSavingArgs class members, see the PageSavingArgs Members topic.

Public Instance Properties

PageCount | Total page count.
PageIndex | Current page index, zero based.

See Also

PageSavingArgs Class | Aspose.Cells.Rendering Namespace


PageCount Property

Aspose.Cells for .NET

PageSavingArgs.PageCount Property

Total page count.

public int PageCount {get;}

See Also

PageSavingArgs Class | Aspose.Cells.Rendering Namespace


PageIndex Property

Aspose.Cells for .NET

PageSavingArgs.PageIndex Property

Current page index, zero based.

public int PageIndex {get;}

See Also

PageSavingArgs Class | Aspose.Cells.Rendering Namespace


PageStartSavingArgs Class

Info for a page starts saving process.

For a list of all members of this type, see PageStartSavingArgs Members.

System.Object
Aspose.Cells.Rendering.PageSavingArgs
Aspose.Cells.Rendering.PageStartSavingArgs

public class PageStartSavingArgs : PageSavingArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PageStartSavingArgs Members | Aspose.Cells.Rendering Namespace


PageStartSavingArgs Members

PageStartSavingArgs overview

Public Instance Properties

IsToOutput | Gets or sets a value indicating whether the page should be output. The default value is true.
PageCount (inherited from PageSavingArgs) | Total page count.
PageIndex (inherited from PageSavingArgs) | Current page index, zero based.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PageStartSavingArgs Class | Aspose.Cells.Rendering Namespace


PageStartSavingArgs Properties

The properties of the PageStartSavingArgs class are listed below. For a complete list of PageStartSavingArgs class members, see the PageStartSavingArgs Members topic.

Public Instance Properties

IsToOutput | Gets or sets a value indicating whether the page should be output. The default value is true.
PageCount (inherited from PageSavingArgs) | Total page count.
PageIndex (inherited from PageSavingArgs) | Current page index, zero based.

See Also

PageStartSavingArgs Class | Aspose.Cells.Rendering Namespace


IsToOutput Property

Aspose.Cells for .NET

PageStartSavingArgs.IsToOutput Property

Gets or sets a value indicating whether the page should be output. The default value is true.

public bool IsToOutput {get; set;}

See Also

PageStartSavingArgs Class | Aspose.Cells.Rendering Namespace


PdfBookmarkEntry Class

PdfBookmarkEntry is an entry in pdf bookmark. if Text property of current instance is null or "", current instance will be hidden and children will be inserted on current level.

For a list of all members of this type, see PdfBookmarkEntry Members.

System.Object
Aspose.Cells.Rendering.PdfBookmarkEntry

public class PdfBookmarkEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]
Workbook workbook = new Workbook();
workbook.Worksheets.Add();
workbook.Worksheets.Add();
Cell cellInPage1 = workbook.Worksheets[0].Cells["A0"];
Cell cellInPage2 = workbook.Worksheets[1].Cells["A0"];
Cell cellInPage3 = workbook.Worksheets[2].Cells["A0"];
cellInPage1.PutValue("page1");
cellInPage2.PutValue("page2");
cellInPage3.PutValue("page3");

PdfBookmarkEntry pbeRoot = new PdfBookmarkEntry();
pbeRoot.Text = "root";  // if pbeRoot.Text = null, all children of pbeRoot will be inserted on the top level in the bookmark.
pbeRoot.Destination = cellInPage1;
pbeRoot.SubEntry = new ArrayList();
pbeRoot.IsOpen = false;

PdfBookmarkEntry subPbe1 = new PdfBookmarkEntry();
subPbe1.Text = "section1";
subPbe1.Destination = cellInPage2;

PdfBookmarkEntry subPbe2 = new PdfBookmarkEntry();
subPbe2.Text = "section2";
subPbe2.Destination = cellInPage3;

pbeRoot.SubEntry.Add(subPbe1);
pbeRoot.SubEntry.Add(subPbe2);

workbook.SaveOptions.PdfBookmark = pbeRoot;
workbook.Save("c:\\Test.pdf");

 [VB]
Dim workbook As Workbook = New Workbook
workbook.Worksheets.Add("sheet2")
workbook.Worksheets.Add("sheet3")

Dim cells As Cells = workbook.Worksheets(0).Cells
Dim cellInPage1 As Cell = cells("A0")
cellInPage1.PutValue("Page1")

cells = workbook.Worksheets(1).Cells
Dim cellInPage2 As Cell = cells("A0")
cellInPage2.PutValue("Page2")

cells = workbook.Worksheets(2).Cells
Dim cellInPage3 As Cell = cells("A0")
cellInPage3.PutValue("Page3")

Dim pbeRoot As PdfBookmarkEntry = New PdfBookmarkEntry()
pbeRoot.Text = "root"
pbeRoot.Destination = cellInPage1
pbeRoot.SubEntry = New ArrayList
pbeRoot.IsOpen = False

Dim subPbe1 As PdfBookmarkEntry = New PdfBookmarkEntry()
subPbe1.Text = "section1"
subPbe1.Destination = cellInPage2

Dim subPbe2 As PdfBookmarkEntry = New PdfBookmarkEntry()
subPbe2.Text = "section2"
subPbe2.Destination = cellInPage3

pbeRoot.SubEntry.Add(subPbe1)
pbeRoot.SubEntry.Add(subPbe2)

workbook.SaveOptions.PdfBookmark = pbeRoot
workbook.Save("c:\\Test.pdf")

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PdfBookmarkEntry Members | Aspose.Cells.Rendering Namespace


PdfBookmarkEntry Members

PdfBookmarkEntry overview

Public Instance Constructors

PdfBookmarkEntry Constructor Initializes a new instance of the PdfBookmarkEntry class.

Public Instance Properties

Destination | The cell to which the bookmark link.
DestinationName | Gets or sets name of destination.
IsCollapse | When this property is true, the bookmarkentry will collapse, otherwise it will expand.
IsOpen | When this property is true, the bookmarkentry will expand, otherwise it will collapse.
SubEntry | SubEntry of a bookmark.
Text | Title of a bookmark.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


PdfBookmarkEntry Constructor

Initializes a new instance of the PdfBookmarkEntry class.

public PdfBookmarkEntry();

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


PdfBookmarkEntry Properties

The properties of the PdfBookmarkEntry class are listed below. For a complete list of PdfBookmarkEntry class members, see the PdfBookmarkEntry Members topic.

Public Instance Properties

Destination | The cell to which the bookmark link.
DestinationName | Gets or sets name of destination.
IsCollapse | When this property is true, the bookmarkentry will collapse, otherwise it will expand.
IsOpen | When this property is true, the bookmarkentry will expand, otherwise it will collapse.
SubEntry | SubEntry of a bookmark.
Text | Title of a bookmark.

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


Destination Property

Aspose.Cells for .NET

PdfBookmarkEntry.Destination Property

The cell to which the bookmark link.

public Cell Destination {get; set;}

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


DestinationName Property

Aspose.Cells for .NET

PdfBookmarkEntry.DestinationName Property

Gets or sets name of destination.

public string DestinationName {get; set;}

Remarks

If destination name is set, the destination will be defined as a named destination with this name.

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


IsCollapse Property

Aspose.Cells for .NET

PdfBookmarkEntry.IsCollapse Property

When this property is true, the bookmarkentry will collapse, otherwise it will expand.

public bool IsCollapse {get; set;}

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


IsOpen Property

Aspose.Cells for .NET

PdfBookmarkEntry.IsOpen Property

When this property is true, the bookmarkentry will expand, otherwise it will collapse.

public bool IsOpen {get; set;}

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


SubEntry Property

Aspose.Cells for .NET

PdfBookmarkEntry.SubEntry Property

SubEntry of a bookmark.

public ArrayList SubEntry {get; set;}

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


Text Property

Aspose.Cells for .NET

PdfBookmarkEntry.Text Property

Title of a bookmark.

public string Text {get; set;}

See Also

PdfBookmarkEntry Class | Aspose.Cells.Rendering Namespace


PdfCompliance Enumeration

Allowing user to set PDF conversion's Compatibility

public enum PdfCompliance

Members

Member Name | Description | Value
None | Normal pdf format | 0
PdfA1b | Pdf format compatible with PDFA-1b | 1
PdfA1a | Pdf format compatible with PDFA-1a | 2

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


PdfCompressionCore Enumeration

Specifies a type of compression applied to all content in the PDF file except images.

public enum PdfCompressionCore

Members

Member Name | Description | Value
None | None | 0
Rle | Rle | 1
Lzw | Lzw | 2
Flate | Flate | 3

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


PdfCustomPropertiesExport Enumeration

Specifies the way CustomDocumentPropertyCollection are exported to PDF file.

public enum PdfCustomPropertiesExport

Members

Member Name | Description | Value
None | No custom properties are exported. | 0
Standard | Custom properties are exported as entries in Info dictionary. | 1

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


PdfOptimizationType Enumeration

Specifies a type of optimization.

public enum PdfOptimizationType

Members

Member Name | Description | Value
Standard | High print quality | 0
MinimumSize | File size is more important than print quality | 1

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


SheetPrintingPreview Class

Worksheet printing preview.

For a list of all members of this type, see SheetPrintingPreview Members.

System.Object
Aspose.Cells.Rendering.SheetPrintingPreview

public class SheetPrintingPreview

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SheetPrintingPreview Members | Aspose.Cells.Rendering Namespace


SheetPrintingPreview Members

SheetPrintingPreview overview

Public Instance Constructors

SheetPrintingPreview Constructor The construct of SheetPrintingPreview

Public Instance Properties

EvaluatedPageCount Evaluate the total page count of this worksheet

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SheetPrintingPreview Class | Aspose.Cells.Rendering Namespace


SheetPrintingPreview Constructor

The construct of SheetPrintingPreview

public SheetPrintingPreview(
Worksheet sheet,
ImageOrPrintOptions options
);

Parameters

sheet
Indicate which spreadsheet to be printed.
options
ImageOrPrintOptions contains some property of output

See Also

SheetPrintingPreview Class | Aspose.Cells.Rendering Namespace


SheetPrintingPreview Properties

The properties of the SheetPrintingPreview class are listed below. For a complete list of SheetPrintingPreview class members, see the SheetPrintingPreview Members topic.

Public Instance Properties

EvaluatedPageCount Evaluate the total page count of this worksheet

See Also

SheetPrintingPreview Class | Aspose.Cells.Rendering Namespace


EvaluatedPageCount Property

Aspose.Cells for .NET

SheetPrintingPreview.EvaluatedPageCount Property

Evaluate the total page count of this worksheet

public int EvaluatedPageCount {get;}

See Also

SheetPrintingPreview Class | Aspose.Cells.Rendering Namespace


SheetRender Class

Represents a worksheet render which can render worksheet to various images such as (BMP, PNG, JPEG, TIFF..) The constructor of this class , must be used after modification of pagesetup, cell style.

For a list of all members of this type, see SheetRender Members.

System.Object
Aspose.Cells.Rendering.SheetRender

public class SheetRender

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SheetRender Members | Aspose.Cells.Rendering Namespace


SheetRender Members

SheetRender overview

Public Instance Constructors

SheetRender Constructor the construct of SheetRender, need worksheet and ImageOrPrintOptions as params

Public Instance Properties

PageCount | Indicate the total page count of current worksheet
PageScale | Gets calculated page scale of the sheet.

Public Instance Methods

CustomPrint | Client can control page setting of printer when print each page using this function.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetPageSize | Get page size of output image. The size unit is in pixel.
GetType (inherited from Object) |
ToImage | Overloaded. Render certain page to a Graphics
ToPrinter | Overloaded. Render worksheet to Printer
ToString (inherited from Object) |
ToTiff | Overloaded. Render whole worksheet as Tiff Image to stream.

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender Constructor

the construct of SheetRender, need worksheet and ImageOrPrintOptions as params

public SheetRender(
Worksheet worksheet,
ImageOrPrintOptions options
);

Parameters

worksheet
Indicate which spreadsheet to be rendered.
options
ImageOrPrintOptions contains some property of output image

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender Properties

The properties of the SheetRender class are listed below. For a complete list of SheetRender class members, see the SheetRender Members topic.

Public Instance Properties

PageCount | Indicate the total page count of current worksheet
PageScale | Gets calculated page scale of the sheet.

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


PageCount Property

Aspose.Cells for .NET

SheetRender.PageCount Property

Indicate the total page count of current worksheet

public int PageCount {get;}

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


PageScale Property

Aspose.Cells for .NET

SheetRender.PageScale Property

Gets calculated page scale of the sheet.

public double PageScale {get;}

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender Methods

The methods of the SheetRender class are listed below. For a complete list of SheetRender class members, see the SheetRender Members topic.

Public Instance Methods

CustomPrint | Client can control page setting of printer when print each page using this function.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetPageSize | Get page size of output image. The size unit is in pixel.
GetType (inherited from Object) |
ToImage | Overloaded. Render certain page to a Graphics
ToPrinter | Overloaded. Render worksheet to Printer
ToString (inherited from Object) |
ToTiff | Overloaded. Render whole worksheet as Tiff Image to stream.

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender.CustomPrint Method

Client can control page setting of printer when print each page using this function.

public int CustomPrint(
bool nextPageAfterPrint,
PrintPageEventArgs printPageEventArgs
);

Parameters

nextPageAfterPrint
If true , printer will go to next page after print current page
printPageEventArgs
System.Drawing.Printing.PrintPageEventArgs

Return Value

Indirect next page index, based on zero

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender.GetPageSize Method

Get page size of output image. The size unit is in pixel.

public Size GetPageSize(
int pageIndex
);

Parameters

pageIndex
The page index is based on zero.

Return Value

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


ToImage Method

Aspose.Cells for .NET

SheetRender.ToImage Method

Render certain page to a Bitmap object.

Overload List

Render certain page to a Bitmap object.

public Bitmap ToImage(int);

Render certain page to a Graphics

public void ToImage(int,Graphics,float,float);

Render certain page to a Graphics

public void ToImage(int,Graphics,float,float,float,float);

Render certain page to a stream.

public void ToImage(int,Stream);

Render certain page to a file.

public void ToImage(int,string);

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender.ToImage Method (Int32)

Render certain page to a Bitmap object.

public Bitmap ToImage(
int pageIndex
);

Parameters

pageIndex
indicate which page is to be converted

Return Value

the bitmap object of the page

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToImage Overload List


SheetRender.ToImage Method (Int32, Graphics, Single, Single)

Render certain page to a Graphics

public void ToImage(
int pageIndex,
Graphics g,
float x,
float y
);

Parameters

pageIndex
indicate which page is to be converted
g
The object where to render to.
x
The X coordinate (in pixels) of the top left corner of the rendered page.
y
The Y coordinate (in pixels) of the top left corner of the rendered page.

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToImage Overload List


SheetRender.ToImage Method (Int32, Graphics, Single, Single, Single, Single)

Render certain page to a Graphics

public void ToImage(
int pageIndex,
Graphics g,
float x,
float y,
float width,
float height
);

Parameters

pageIndex
indicate which page is to be converted
g
The object where to render to.
x
The X coordinate (in pixels) of the top left corner of the rendered page.
y
The Y coordinate (in pixels) of the top left corner of the rendered page.
width
The maximum width (in pixels) that can be occupied by the rendered page.
height
The maximum height (in pixels) that can be occupied by the rendered page.

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToImage Overload List


SheetRender.ToImage Method (Int32, Stream)

Render certain page to a stream.

public void ToImage(
int pageIndex,
Stream stream
);

Parameters

pageIndex
indicate which page is to be converted
stream
the stream of the output image

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToImage Overload List


SheetRender.ToImage Method (Int32, String)

Render certain page to a file.

public void ToImage(
int pageIndex,
string fileName
);

Parameters

pageIndex
indicate which page is to be converted
fileName
filename of the output image

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToImage Overload List


ToPrinter Method

Aspose.Cells for .NET

SheetRender.ToPrinter Method

Render worksheet to Printer

Overload List

Render worksheet to Printer

public void ToPrinter(PrinterSettings);

Render worksheet to Printer

public void ToPrinter(string);

Render worksheet to Printer

public void ToPrinter(string,int,int);

Render worksheet to Printer

public void ToPrinter(string,string);

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender.ToPrinter Method (PrinterSettings)

Render worksheet to Printer

public void ToPrinter(
PrinterSettings PrinterSettings
);

Parameters

PrinterSettings
the settings of printer, e.g. PrinterName, Duplex

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToPrinter Overload List


SheetRender.ToPrinter Method (String)

Render worksheet to Printer

public void ToPrinter(
string PrinterName
);

Parameters

PrinterName
the name of the printer , for example: "Microsoft Office Document Image Writer"

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToPrinter Overload List


SheetRender.ToPrinter Method (String, Int32, Int32)

Render worksheet to Printer

public void ToPrinter(
string PrinterName,
int PrintPageIndex,
int PrintPageCount
);

Parameters

PrinterName
the name of the printer , for example: "Microsoft Office Document Image Writer"
PrintPageIndex
the 0-based index of the first page to print, it must be in Range [0, SheetRender.PageCount-1]
PrintPageCount
the number of pages to print, it must be greater than zero

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToPrinter Overload List


SheetRender.ToPrinter Method (String, String)

Render worksheet to Printer

public void ToPrinter(
string PrinterName,
string DocumentName
);

Parameters

PrinterName
the name of the printer , for example: "Microsoft Office Document Image Writer"
DocumentName
set the print job name

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToPrinter Overload List


ToTiff Method

Aspose.Cells for .NET

SheetRender.ToTiff Method

Render whole worksheet as Tiff Image to stream.

Overload List

Render whole worksheet as Tiff Image to stream.

public void ToTiff(Stream);

Render whole worksheet as Tiff Image to a file.

public void ToTiff(string);

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace


SheetRender.ToTiff Method (Stream)

Render whole worksheet as Tiff Image to stream.

public void ToTiff(
Stream stream
);

Parameters

stream
the stream of the output image

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToTiff Overload List


SheetRender.ToTiff Method (String)

Render whole worksheet as Tiff Image to a file.

public void ToTiff(
string filename
);

Parameters

filename
the filename of the output image

See Also

SheetRender Class | Aspose.Cells.Rendering Namespace | SheetRender.ToTiff Overload List


TiffCompression Enumeration

Specifies what type of compression to apply when saving images into TIFF format file.

public enum TiffCompression

Members

Member Name | Description | Value
CompressionNone | Specifies no compression. | 0
CompressionRle | Specifies the RLE compression scheme. | 1
CompressionLZW | Specifies the LZW compression scheme. | 2
CompressionCCITT3 | Specifies the CCITT3 compression scheme. | 3
CompressionCCITT4 | Specifies the CCITT4 compression scheme. | 4

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Rendering Namespace


WorkbookPrintingPreview Class

Workbook printing preview.

For a list of all members of this type, see WorkbookPrintingPreview Members.

System.Object
Aspose.Cells.Rendering.WorkbookPrintingPreview

public class WorkbookPrintingPreview

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WorkbookPrintingPreview Members | Aspose.Cells.Rendering Namespace


WorkbookPrintingPreview Members

WorkbookPrintingPreview overview

Public Instance Constructors

WorkbookPrintingPreview Constructor The construct of WorkbookPrintingPreview

Public Instance Properties

EvaluatedPageCount Evaluate the total page count of this workbook

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WorkbookPrintingPreview Class | Aspose.Cells.Rendering Namespace


WorkbookPrintingPreview Constructor

The construct of WorkbookPrintingPreview

public WorkbookPrintingPreview(
Workbook workbook,
ImageOrPrintOptions options
);

Parameters

workbook
Indicate which workbook to be printed.
options
ImageOrPrintOptions contains some property of output

See Also

WorkbookPrintingPreview Class | Aspose.Cells.Rendering Namespace


WorkbookPrintingPreview Properties

The properties of the WorkbookPrintingPreview class are listed below. For a complete list of WorkbookPrintingPreview class members, see the WorkbookPrintingPreview Members topic.

Public Instance Properties

EvaluatedPageCount Evaluate the total page count of this workbook

See Also

WorkbookPrintingPreview Class | Aspose.Cells.Rendering Namespace


EvaluatedPageCount Property

Aspose.Cells for .NET

WorkbookPrintingPreview.EvaluatedPageCount Property

Evaluate the total page count of this workbook

public int EvaluatedPageCount {get;}

See Also

WorkbookPrintingPreview Class | Aspose.Cells.Rendering Namespace


WorkbookRender Class

Represents a Workbook render. The constructor of this class , must be used after modification of pagesetup, cell style.

For a list of all members of this type, see WorkbookRender Members.

System.Object
Aspose.Cells.Rendering.WorkbookRender

public class WorkbookRender

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Cells.Rendering

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WorkbookRender Members | Aspose.Cells.Rendering Namespace


WorkbookRender Members

WorkbookRender overview

Public Instance Constructors

WorkbookRender Constructor The construct of WorkbookRender

Public Instance Properties

PageCount Indicate the total page count of workbook

Public Instance Methods

CustomPrint | Client can control page setting of printer when print each page using this function.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetPageSize | Get page size of output image. The size unit is in pixel.
GetType (inherited from Object) |
ToImage | Overloaded. Render whole workbook as Tiff Image to stream.
ToPrinter | Overloaded. Render workbook to Printer
ToString (inherited from Object) |

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender Constructor

The construct of WorkbookRender

public WorkbookRender(
Workbook workbook,
ImageOrPrintOptions options
);

Parameters

workbook
Indicate which workbook to be rendered.
options
ImageOrPrintOptions contains some property of output image

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender Properties

The properties of the WorkbookRender class are listed below. For a complete list of WorkbookRender class members, see the WorkbookRender Members topic.

Public Instance Properties

PageCount Indicate the total page count of workbook

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


PageCount Property

Aspose.Cells for .NET

WorkbookRender.PageCount Property

Indicate the total page count of workbook

public int PageCount {get;}

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender Methods

The methods of the WorkbookRender class are listed below. For a complete list of WorkbookRender class members, see the WorkbookRender Members topic.

Public Instance Methods

CustomPrint | Client can control page setting of printer when print each page using this function.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetPageSize | Get page size of output image. The size unit is in pixel.
GetType (inherited from Object) |
ToImage | Overloaded. Render whole workbook as Tiff Image to stream.
ToPrinter | Overloaded. Render workbook to Printer
ToString (inherited from Object) |

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender.CustomPrint Method

Client can control page setting of printer when print each page using this function.

public int CustomPrint(
bool nextPageAfterPrint,
PrintPageEventArgs printPageEventArgs
);

Parameters

nextPageAfterPrint
If true , printer will go to next page after print current page
printPageEventArgs
System.Drawing.Printing.PrintPageEventArgs

Return Value

Indirect next page index, based on zero

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender.GetPageSize Method

Get page size of output image. The size unit is in pixel.

public Size GetPageSize(
int pageIndex
);

Parameters

pageIndex
The page index is based on zero.

Return Value

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


ToImage Method

Aspose.Cells for .NET

WorkbookRender.ToImage Method

Render certain page to a Bitmap object.

Overload List

Render certain page to a Bitmap object.

public Bitmap ToImage(int);

Render certain page to a stream.

public void ToImage(int,Stream);

Render certain page to a file.

public void ToImage(int,string);

Render whole workbook as Tiff Image to stream.

public void ToImage(Stream);

Render whole workbook as Tiff Image to a file.

public void ToImage(string);

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender.ToImage Method (Int32)

Render certain page to a Bitmap object.

public Bitmap ToImage(
int pageIndex
);

Parameters

pageIndex
indicate which page is to be converted

Return Value

the bitmap object of the page

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToImage Overload List


WorkbookRender.ToImage Method (Int32, Stream)

Render certain page to a stream.

public void ToImage(
int pageIndex,
Stream stream
);

Parameters

pageIndex
indicate which page is to be converted
stream
the stream of the output image

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToImage Overload List


WorkbookRender.ToImage Method (Int32, String)

Render certain page to a file.

public void ToImage(
int pageIndex,
string fileName
);

Parameters

pageIndex
indicate which page is to be converted
fileName
filename of the output image

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToImage Overload List


WorkbookRender.ToImage Method (Stream)

Render whole workbook as Tiff Image to stream.

public void ToImage(
Stream stream
);

Parameters

stream
the stream of the output image

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToImage Overload List


WorkbookRender.ToImage Method (String)

Render whole workbook as Tiff Image to a file.

public void ToImage(
string filename
);

Parameters

filename
the filename of the output image

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToImage Overload List


ToPrinter Method

Aspose.Cells for .NET

WorkbookRender.ToPrinter Method

Render workbook to Printer

Overload List

Render workbook to Printer

public void ToPrinter(PrinterSettings);

Render workbook to Printer

public void ToPrinter(string);

Render workbook to Printer

public void ToPrinter(string,int,int);

Render workbook to Printer

public void ToPrinter(string,string);

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace


WorkbookRender.ToPrinter Method (PrinterSettings)

Render workbook to Printer

public void ToPrinter(
PrinterSettings PrinterSettings
);

Parameters

PrinterSettings
the settings of printer, e.g. PrinterName, Duplex

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToPrinter Overload List


WorkbookRender.ToPrinter Method (String)

Render workbook to Printer

public void ToPrinter(
string PrinterName
);

Parameters

PrinterName
the name of the printer , for example: "Microsoft Office Document Image Writer"

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToPrinter Overload List


WorkbookRender.ToPrinter Method (String, Int32, Int32)

Render workbook to Printer

public void ToPrinter(
string PrinterName,
int PrintPageIndex,
int PrintPageCount
);

Parameters

PrinterName
the name of the printer , for example: "Microsoft Office Document Image Writer"
PrintPageIndex
the 0-based index of the first page to print, it must be in Range [0, WorkbookRender.PageCount-1]
PrintPageCount
the number of pages to print, it must be greater than zero

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToPrinter Overload List


WorkbookRender.ToPrinter Method (String, String)

Render workbook to Printer

public void ToPrinter(
string PrinterName,
string DocumentName
);

Parameters

PrinterName
the name of the printer , for example: "Microsoft Office Document Image Writer"
DocumentName
set the print job name

See Also

WorkbookRender Class | Aspose.Cells.Rendering Namespace | WorkbookRender.ToPrinter Overload List


Aspose.Cells.Rendering.PdfSecurity

Aspose.Cells for .NET

Aspose.Cells.Rendering.PdfSecurity Namespace

Namespace hierarchy

Classes

Class | Description
PdfSecurityOptions | Settings of pdf when converting excel to pdf, PDF/A does not allow security setting.


PdfSecurityOptions Class

Settings of pdf when converting excel to pdf, PDF/A does not allow security setting.

For a list of all members of this type, see PdfSecurityOptions Members.

System.Object
Aspose.Cells.Rendering.PdfSecurity.PdfSecurityOptions

public class PdfSecurityOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Rendering.PdfSecurity

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

PdfSecurityOptions Members | Aspose.Cells.Rendering.PdfSecurity Namespace


PdfSecurityOptions Members

PdfSecurityOptions overview

Public Instance Constructors

PdfSecurityOptions Constructor The constructor of PdfSecurityOptions

Public Instance Properties

AccessibilityExtractContent | Permission to copy or extract content (in support of accessibility to disabled users or for other purposes).
AnnotationsPermission | Permission to comment on the document.
AssembleDocumentPermission | Permission to insert, rotate, or delete pages and create bookmarks or thumbnail images even if ModifyDocumentPermission is not set.
ExtractContentPermission | Permission to copy or extract content.
ExtractContentPermissionObsolete | Permission to copy or extract content Obsoleted according to PDF reference.
FillFormsPermission | Permission to fill the form fields.
FullQualityPrintPermission | Permission to print in high quality.
ModifyDocumentPermission | Permission to modify pdf document
OwnerPassword | Gets or sets the owner password of the document
PrintPermission | Permission to print pdf document
UserPassword | Gets or sets the user password

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


PdfSecurityOptions Constructor

The constructor of PdfSecurityOptions

public PdfSecurityOptions();

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


PdfSecurityOptions Properties

The properties of the PdfSecurityOptions class are listed below. For a complete list of PdfSecurityOptions class members, see the PdfSecurityOptions Members topic.

Public Instance Properties

AccessibilityExtractContent | Permission to copy or extract content (in support of accessibility to disabled users or for other purposes).
AnnotationsPermission | Permission to comment on the document.
AssembleDocumentPermission | Permission to insert, rotate, or delete pages and create bookmarks or thumbnail images even if ModifyDocumentPermission is not set.
ExtractContentPermission | Permission to copy or extract content.
ExtractContentPermissionObsolete | Permission to copy or extract content Obsoleted according to PDF reference.
FillFormsPermission | Permission to fill the form fields.
FullQualityPrintPermission | Permission to print in high quality.
ModifyDocumentPermission | Permission to modify pdf document
OwnerPassword | Gets or sets the owner password of the document
PrintPermission | Permission to print pdf document
UserPassword | Gets or sets the user password

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


AccessibilityExtractContent Property

Aspose.Cells for .NET

PdfSecurityOptions.AccessibilityExtractContent Property

Permission to copy or extract content (in support of accessibility to disabled users or for other purposes).

public bool AccessibilityExtractContent {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


AnnotationsPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.AnnotationsPermission Property

Permission to comment on the document.

public bool AnnotationsPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


AssembleDocumentPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.AssembleDocumentPermission Property

Permission to insert, rotate, or delete pages and create bookmarks or thumbnail images even if ModifyDocumentPermission is not set.

public bool AssembleDocumentPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


ExtractContentPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.ExtractContentPermission Property

Permission to copy or extract content.

public bool ExtractContentPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


ExtractContentPermissionObsolete Property

Aspose.Cells for .NET

PdfSecurityOptions.ExtractContentPermissionObsolete Property

Permission to copy or extract content Obsoleted according to PDF reference.

public bool ExtractContentPermissionObsolete {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


FillFormsPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.FillFormsPermission Property

Permission to fill the form fields.

public bool FillFormsPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


FullQualityPrintPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.FullQualityPrintPermission Property

Permission to print in high quality.

public bool FullQualityPrintPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


ModifyDocumentPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.ModifyDocumentPermission Property

Permission to modify pdf document

public bool ModifyDocumentPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


OwnerPassword Property

Aspose.Cells for .NET

PdfSecurityOptions.OwnerPassword Property

Gets or sets the owner password of the document

public string OwnerPassword {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


PrintPermission Property

Aspose.Cells for .NET

PdfSecurityOptions.PrintPermission Property

Permission to print pdf document

public bool PrintPermission {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


UserPassword Property

Aspose.Cells for .NET

PdfSecurityOptions.UserPassword Property

Gets or sets the user password

public string UserPassword {get; set;}

See Also

PdfSecurityOptions Class | Aspose.Cells.Rendering.PdfSecurity Namespace


Aspose.Cells.Revisions

Aspose.Cells for .NET

Aspose.Cells.Revisions Namespace

Namespace hierarchy

Classes

Class | Description
Revision | Represents the revision.
RevisionAutoFormat | represents a revision record of information about a formatting change.
RevisionCellChange | Represents the revision that changing cells.
RevisionCellComment | Represents a revision record of a cell comment change.
RevisionCellMove | Represents a revision record on a cell(s) that moved.
RevisionCollection | Represents all revision logs.
RevisionCustomView | Represents a revision record of adding or removing a custom view to the workbook
RevisionDefinedName | Represents a revision record of a defined name change.
RevisionFormat | represents a revision record of information about a formatting change.
RevisionInsertDelete | Represents a revision record of a row/column insert/delete action.
RevisionInsertSheet | Represents a revision record of a sheet that was inserted.
RevisionLog | Represents the revision log.
RevisionLogCollection | Represents all revision logs.
RevisionMergeConflict | Represents a revision record which indicates that there was a merge conflict.
RevisionQueryTable | Represents a revision of a query table field change.
RevisionRenameSheet | Represents a revision of renaming sheet.

Enumerations

Enumeration | Description
RevisionActionType | Represents the type of revision action.
RevisionType | Represents the revision type.


Revision Class

Represents the revision.

For a list of all members of this type, see Revision Members.

System.Object
Aspose.Cells.Revisions.Revision
Derived types

public abstract class Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Revision Members | Aspose.Cells.Revisions Namespace


Revision Members

Revision overview

Public Instance Properties

Id | Gets the number of this revision.
Type | Represents the type of revision.
Worksheet | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

Revision Class | Aspose.Cells.Revisions Namespace


Revision Properties

The properties of the Revision class are listed below. For a complete list of Revision class members, see the Revision Members topic.

Public Instance Properties

Id | Gets the number of this revision.
Type | Represents the type of revision.
Worksheet | Gets the worksheet.

See Also

Revision Class | Aspose.Cells.Revisions Namespace


Id Property

Aspose.Cells for .NET

Revision.Id Property

Gets the number of this revision.

public int Id {get;}

Remarks

Zero means this revision does not contains id.

See Also

Revision Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

Revision.Type Property

Represents the type of revision.

public virtual RevisionType Type {get;}

See Also

Revision Class | Aspose.Cells.Revisions Namespace


Worksheet Property

Aspose.Cells for .NET

Revision.Worksheet Property

Gets the worksheet.

public Worksheet Worksheet {get;}

See Also

Revision Class | Aspose.Cells.Revisions Namespace


RevisionActionType Enumeration

Represents the type of revision action.

public enum RevisionActionType

Members

Member Name | Description | Value
Add | Add revision. | 0
Delete | Delete revision. | 1
DeleteColumn | Column delete revision. | 2
DeleteRow | Row delete revision. | 3
InsertColumn | Column insert revision. | 4
InsertRow | Row insert revision. | 5

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Revisions Namespace


RevisionAutoFormat Class

represents a revision record of information about a formatting change.

For a list of all members of this type, see RevisionAutoFormat Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionAutoFormat

public class RevisionAutoFormat : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionAutoFormat Members | Aspose.Cells.Revisions Namespace


RevisionAutoFormat Members

RevisionAutoFormat overview

Public Instance Properties

CellArea | Gets the location where the formatting was applied.
Id (inherited from Revision) | Gets the number of this revision.
Type | Gets the type of the revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionAutoFormat Class | Aspose.Cells.Revisions Namespace


RevisionAutoFormat Properties

The properties of the RevisionAutoFormat class are listed below. For a complete list of RevisionAutoFormat class members, see the RevisionAutoFormat Members topic.

Public Instance Properties

CellArea | Gets the location where the formatting was applied.
Id (inherited from Revision) | Gets the number of this revision.
Type | Gets the type of the revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionAutoFormat Class | Aspose.Cells.Revisions Namespace


CellArea Property

Aspose.Cells for .NET

RevisionAutoFormat.CellArea Property

Gets the location where the formatting was applied.

public CellArea CellArea {get;}

See Also

RevisionAutoFormat Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionAutoFormat.Type Property

Gets the type of the revision.

public override RevisionType Type {get;}

See Also

RevisionAutoFormat Class | Aspose.Cells.Revisions Namespace


RevisionCellChange Class

Represents the revision that changing cells.

For a list of all members of this type, see RevisionCellChange Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionCellChange

public class RevisionCellChange : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionCellChange Members | Aspose.Cells.Revisions Namespace


RevisionCellChange Members

RevisionCellChange overview

Public Instance Properties

CellName | Gets the name of the cell.
Column | Gets the column index of the cell.
Id (inherited from Revision) | Gets the number of this revision.
IsNewFormatted | Indicates whether this cell is new formatted.
IsOldFormatted | Indicates whether this cell is old formatted.
NewFormula | Gets the old formula.
NewStyle | Gets the new style of the cell.
NewValue | Gets new value of the cell.
OldFormula | Gets the old formula.
OldStyle | Gets the old style of the cell.
OldValue | Gets old value of the cell.
Row | Gets the row index of the cell.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


RevisionCellChange Properties

The properties of the RevisionCellChange class are listed below. For a complete list of RevisionCellChange class members, see the RevisionCellChange Members topic.

Public Instance Properties

CellName | Gets the name of the cell.
Column | Gets the column index of the cell.
Id (inherited from Revision) | Gets the number of this revision.
IsNewFormatted | Indicates whether this cell is new formatted.
IsOldFormatted | Indicates whether this cell is old formatted.
NewFormula | Gets the old formula.
NewStyle | Gets the new style of the cell.
NewValue | Gets new value of the cell.
OldFormula | Gets the old formula.
OldStyle | Gets the old style of the cell.
OldValue | Gets old value of the cell.
Row | Gets the row index of the cell.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


CellName Property

Aspose.Cells for .NET

RevisionCellChange.CellName Property

Gets the name of the cell.

public string CellName {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


Column Property

Aspose.Cells for .NET

RevisionCellChange.Column Property

Gets the column index of the cell.

public int Column {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


IsNewFormatted Property

Aspose.Cells for .NET

RevisionCellChange.IsNewFormatted Property

Indicates whether this cell is new formatted.

public bool IsNewFormatted {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


IsOldFormatted Property

Aspose.Cells for .NET

RevisionCellChange.IsOldFormatted Property

Indicates whether this cell is old formatted.

public bool IsOldFormatted {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


NewFormula Property

Aspose.Cells for .NET

RevisionCellChange.NewFormula Property

Gets the old formula.

public string NewFormula {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


NewStyle Property

Aspose.Cells for .NET

RevisionCellChange.NewStyle Property

Gets the new style of the cell.

public Style NewStyle {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


NewValue Property

Aspose.Cells for .NET

RevisionCellChange.NewValue Property

Gets new value of the cell.

public object NewValue {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


OldFormula Property

Aspose.Cells for .NET

RevisionCellChange.OldFormula Property

Gets the old formula.

public string OldFormula {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


OldStyle Property

Aspose.Cells for .NET

RevisionCellChange.OldStyle Property

Gets the old style of the cell.

public Style OldStyle {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


OldValue Property

Aspose.Cells for .NET

RevisionCellChange.OldValue Property

Gets old value of the cell.

public object OldValue {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


Row Property

Aspose.Cells for .NET

RevisionCellChange.Row Property

Gets the row index of the cell.

public int Row {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionCellChange.Type Property

Represents the type of revision.

public override RevisionType Type {get;}

See Also

RevisionCellChange Class | Aspose.Cells.Revisions Namespace


RevisionCellComment Class

Represents a revision record of a cell comment change.

For a list of all members of this type, see RevisionCellComment Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionCellComment

public class RevisionCellComment : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionCellComment Members | Aspose.Cells.Revisions Namespace


RevisionCellComment Members

RevisionCellComment overview

Public Instance Properties

ActionType | Gets the action type of the revision.
CellName | Gets the name of the cell.
Column | Gets the column index of the which contains a comment.
Id (inherited from Revision) | Gets the number of this revision.
IsOldComment | Indicates whether it's an old comment.
NewLength | Gets Length of the comment before this revision was made.
OldLength | Gets Length of the comment text added in this revision.
Row | Gets the row index of the which contains a comment.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


RevisionCellComment Properties

The properties of the RevisionCellComment class are listed below. For a complete list of RevisionCellComment class members, see the RevisionCellComment Members topic.

Public Instance Properties

ActionType | Gets the action type of the revision.
CellName | Gets the name of the cell.
Column | Gets the column index of the which contains a comment.
Id (inherited from Revision) | Gets the number of this revision.
IsOldComment | Indicates whether it's an old comment.
NewLength | Gets Length of the comment before this revision was made.
OldLength | Gets Length of the comment text added in this revision.
Row | Gets the row index of the which contains a comment.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


ActionType Property

Aspose.Cells for .NET

RevisionCellComment.ActionType Property

Gets the action type of the revision.

public RevisionActionType ActionType {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


CellName Property

Aspose.Cells for .NET

RevisionCellComment.CellName Property

Gets the name of the cell.

public string CellName {get; set;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


Column Property

Aspose.Cells for .NET

RevisionCellComment.Column Property

Gets the column index of the which contains a comment.

public int Column {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


IsOldComment Property

Aspose.Cells for .NET

RevisionCellComment.IsOldComment Property

Indicates whether it's an old comment.

public bool IsOldComment {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


NewLength Property

Aspose.Cells for .NET

RevisionCellComment.NewLength Property

Gets Length of the comment before this revision was made.

public int NewLength {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


OldLength Property

Aspose.Cells for .NET

RevisionCellComment.OldLength Property

Gets Length of the comment text added in this revision.

public int OldLength {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


Row Property

Aspose.Cells for .NET

RevisionCellComment.Row Property

Gets the row index of the which contains a comment.

public int Row {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionCellComment.Type Property

Gets the type of revision.

public override RevisionType Type {get;}

See Also

RevisionCellComment Class | Aspose.Cells.Revisions Namespace


RevisionCellMove Class

Represents a revision record on a cell(s) that moved.

For a list of all members of this type, see RevisionCellMove Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionCellMove

public class RevisionCellMove : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionCellMove Members | Aspose.Cells.Revisions Namespace


RevisionCellMove Members

RevisionCellMove overview

Public Instance Properties

DestinationArea | Gets the destination area.
Id (inherited from Revision) | Gets the number of this revision.
SourceArea | Gets the source area.
SourceWorksheet | Gets the source worksheet.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionCellMove Class | Aspose.Cells.Revisions Namespace


RevisionCellMove Properties

The properties of the RevisionCellMove class are listed below. For a complete list of RevisionCellMove class members, see the RevisionCellMove Members topic.

Public Instance Properties

DestinationArea | Gets the destination area.
Id (inherited from Revision) | Gets the number of this revision.
SourceArea | Gets the source area.
SourceWorksheet | Gets the source worksheet.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionCellMove Class | Aspose.Cells.Revisions Namespace


DestinationArea Property

Aspose.Cells for .NET

RevisionCellMove.DestinationArea Property

Gets the destination area.

public CellArea DestinationArea {get;}

See Also

RevisionCellMove Class | Aspose.Cells.Revisions Namespace


SourceArea Property

Aspose.Cells for .NET

RevisionCellMove.SourceArea Property

Gets the source area.

public CellArea SourceArea {get;}

See Also

RevisionCellMove Class | Aspose.Cells.Revisions Namespace


SourceWorksheet Property

Aspose.Cells for .NET

RevisionCellMove.SourceWorksheet Property

Gets the source worksheet.

public Worksheet SourceWorksheet {get;}

See Also

RevisionCellMove Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionCellMove.Type Property

Represents the type of revision.

public override RevisionType Type {get;}

See Also

RevisionCellMove Class | Aspose.Cells.Revisions Namespace


RevisionCollection Class

Represents all revision logs.

For a list of all members of this type, see RevisionCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Revisions.RevisionCollection

public class RevisionCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionCollection Members | Aspose.Cells.Revisions Namespace


RevisionCollection Members

RevisionCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets Revision by the index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

RevisionCollection Class | Aspose.Cells.Revisions Namespace


RevisionCollection Properties

The properties of the RevisionCollection class are listed below. For a complete list of RevisionCollection class members, see the RevisionCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets Revision by the index.

See Also

RevisionCollection Class | Aspose.Cells.Revisions Namespace


Item Property

Aspose.Cells for .NET

RevisionCollection.Item Property

Gets Revision by the index.

public Revision this[
int index
] {get;}

Parameters

index

See Also

RevisionCollection Class | Aspose.Cells.Revisions Namespace


RevisionCustomView Class

Represents a revision record of adding or removing a custom view to the workbook

For a list of all members of this type, see RevisionCustomView Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionCustomView

public class RevisionCustomView : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionCustomView Members | Aspose.Cells.Revisions Namespace


RevisionCustomView Members

RevisionCustomView overview

Public Instance Properties

ActionType | Gets the type of action.
Guid | Gets the globally unique identifier of the custom view.
Id (inherited from Revision) | Gets the number of this revision.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionCustomView Class | Aspose.Cells.Revisions Namespace


RevisionCustomView Properties

The properties of the RevisionCustomView class are listed below. For a complete list of RevisionCustomView class members, see the RevisionCustomView Members topic.

Public Instance Properties

ActionType | Gets the type of action.
Guid | Gets the globally unique identifier of the custom view.
Id (inherited from Revision) | Gets the number of this revision.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionCustomView Class | Aspose.Cells.Revisions Namespace


ActionType Property

Aspose.Cells for .NET

RevisionCustomView.ActionType Property

Gets the type of action.

public RevisionActionType ActionType {get;}

See Also

RevisionCustomView Class | Aspose.Cells.Revisions Namespace


Guid Property

Aspose.Cells for .NET

RevisionCustomView.Guid Property

Gets the globally unique identifier of the custom view.

public Guid Guid {get;}

See Also

RevisionCustomView Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionCustomView.Type Property

Gets the type of revision.

public override RevisionType Type {get;}

See Also

RevisionCustomView Class | Aspose.Cells.Revisions Namespace


RevisionDefinedName Class

Represents a revision record of a defined name change.

For a list of all members of this type, see RevisionDefinedName Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionDefinedName

public class RevisionDefinedName : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionDefinedName Members | Aspose.Cells.Revisions Namespace


RevisionDefinedName Members

RevisionDefinedName overview

Public Instance Properties

Id (inherited from Revision) | Gets the number of this revision.
NewFormula | Gets the formula.
OldFormula | Gets the old formula.
Text | Gets the text of the defined name.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionDefinedName Class | Aspose.Cells.Revisions Namespace


RevisionDefinedName Properties

The properties of the RevisionDefinedName class are listed below. For a complete list of RevisionDefinedName class members, see the RevisionDefinedName Members topic.

Public Instance Properties

Id (inherited from Revision) | Gets the number of this revision.
NewFormula | Gets the formula.
OldFormula | Gets the old formula.
Text | Gets the text of the defined name.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionDefinedName Class | Aspose.Cells.Revisions Namespace


NewFormula Property

Aspose.Cells for .NET

RevisionDefinedName.NewFormula Property

Gets the formula.

public string NewFormula {get;}

See Also

RevisionDefinedName Class | Aspose.Cells.Revisions Namespace


OldFormula Property

Aspose.Cells for .NET

RevisionDefinedName.OldFormula Property

Gets the old formula.

public string OldFormula {get;}

See Also

RevisionDefinedName Class | Aspose.Cells.Revisions Namespace


Text Property

Aspose.Cells for .NET

RevisionDefinedName.Text Property

Gets the text of the defined name.

public string Text {get;}

See Also

RevisionDefinedName Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionDefinedName.Type Property

Represents the type of revision.

public override RevisionType Type {get;}

See Also

RevisionDefinedName Class | Aspose.Cells.Revisions Namespace


RevisionFormat Class

represents a revision record of information about a formatting change.

For a list of all members of this type, see RevisionFormat Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionFormat

public class RevisionFormat : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionFormat Members | Aspose.Cells.Revisions Namespace


RevisionFormat Members

RevisionFormat overview

Public Instance Properties

Areas | The range to which this formatting was applied.
Id (inherited from Revision) | Gets the number of this revision.
Style | Gets the applied style.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionFormat Class | Aspose.Cells.Revisions Namespace


RevisionFormat Properties

The properties of the RevisionFormat class are listed below. For a complete list of RevisionFormat class members, see the RevisionFormat Members topic.

Public Instance Properties

Areas | The range to which this formatting was applied.
Id (inherited from Revision) | Gets the number of this revision.
Style | Gets the applied style.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionFormat Class | Aspose.Cells.Revisions Namespace


Areas Property

Aspose.Cells for .NET

RevisionFormat.Areas Property

The range to which this formatting was applied.

public CellArea[] Areas {get;}

See Also

RevisionFormat Class | Aspose.Cells.Revisions Namespace


Style Property

Aspose.Cells for .NET

RevisionFormat.Style Property

Gets the applied style.

public Style Style {get;}

See Also

RevisionFormat Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionFormat.Type Property

Gets the type of revision.

public override RevisionType Type {get;}

See Also

RevisionFormat Class | Aspose.Cells.Revisions Namespace


RevisionInsertDelete Class

Represents a revision record of a row/column insert/delete action.

For a list of all members of this type, see RevisionInsertDelete Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionInsertDelete

public class RevisionInsertDelete : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionInsertDelete Members | Aspose.Cells.Revisions Namespace


RevisionInsertDelete Members

RevisionInsertDelete overview

Public Instance Properties

ActionType | Gets the action type of this revision.
CellArea | Gets the inserting/deleting range.
Id (inherited from Revision) | Gets the number of this revision.
Revisions | Gets revision list by this operation.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionInsertDelete Class | Aspose.Cells.Revisions Namespace


RevisionInsertDelete Properties

The properties of the RevisionInsertDelete class are listed below. For a complete list of RevisionInsertDelete class members, see the RevisionInsertDelete Members topic.

Public Instance Properties

ActionType | Gets the action type of this revision.
CellArea | Gets the inserting/deleting range.
Id (inherited from Revision) | Gets the number of this revision.
Revisions | Gets revision list by this operation.
Type | Represents the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionInsertDelete Class | Aspose.Cells.Revisions Namespace


ActionType Property

Aspose.Cells for .NET

RevisionInsertDelete.ActionType Property

Gets the action type of this revision.

public RevisionActionType ActionType {get;}

See Also

RevisionInsertDelete Class | Aspose.Cells.Revisions Namespace


CellArea Property

Aspose.Cells for .NET

RevisionInsertDelete.CellArea Property

Gets the inserting/deleting range.

public CellArea CellArea {get;}

See Also

RevisionInsertDelete Class | Aspose.Cells.Revisions Namespace


Revisions Property

Aspose.Cells for .NET

RevisionInsertDelete.Revisions Property

Gets revision list by this operation.

public RevisionCollection Revisions {get;}

See Also

RevisionInsertDelete Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionInsertDelete.Type Property

Represents the type of revision.

public override RevisionType Type {get;}

See Also

RevisionInsertDelete Class | Aspose.Cells.Revisions Namespace


RevisionInsertSheet Class

Represents a revision record of a sheet that was inserted.

For a list of all members of this type, see RevisionInsertSheet Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionInsertSheet

public class RevisionInsertSheet : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionInsertSheet Members | Aspose.Cells.Revisions Namespace


RevisionInsertSheet Members

RevisionInsertSheet overview

Public Instance Properties

ActionType | Gets the action type of the revision.
Id (inherited from Revision) | Gets the number of this revision.
Name | Gets the name of the worksheet.
SheetPosition | Gets the zero based position of the new sheet in the sheet tab bar.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionInsertSheet Class | Aspose.Cells.Revisions Namespace


RevisionInsertSheet Properties

The properties of the RevisionInsertSheet class are listed below. For a complete list of RevisionInsertSheet class members, see the RevisionInsertSheet Members topic.

Public Instance Properties

ActionType | Gets the action type of the revision.
Id (inherited from Revision) | Gets the number of this revision.
Name | Gets the name of the worksheet.
SheetPosition | Gets the zero based position of the new sheet in the sheet tab bar.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionInsertSheet Class | Aspose.Cells.Revisions Namespace


ActionType Property

Aspose.Cells for .NET

RevisionInsertSheet.ActionType Property

Gets the action type of the revision.

public RevisionActionType ActionType {get;}

See Also

RevisionInsertSheet Class | Aspose.Cells.Revisions Namespace


Name Property

Aspose.Cells for .NET

RevisionInsertSheet.Name Property

Gets the name of the worksheet.

public string Name {get;}

See Also

RevisionInsertSheet Class | Aspose.Cells.Revisions Namespace


SheetPosition Property

Aspose.Cells for .NET

RevisionInsertSheet.SheetPosition Property

Gets the zero based position of the new sheet in the sheet tab bar.

public int SheetPosition {get;}

See Also

RevisionInsertSheet Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionInsertSheet.Type Property

Gets the type of revision.

public override RevisionType Type {get;}

See Also

RevisionInsertSheet Class | Aspose.Cells.Revisions Namespace


RevisionLog Class

Represents the revision log.

For a list of all members of this type, see RevisionLog Members.

System.Object
Aspose.Cells.Revisions.RevisionLog

public class RevisionLog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionLog Members | Aspose.Cells.Revisions Namespace


RevisionLog Members

RevisionLog overview

Public Instance Properties

Revisions Gets all revisions in this log.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionLog Class | Aspose.Cells.Revisions Namespace


RevisionLog Properties

The properties of the RevisionLog class are listed below. For a complete list of RevisionLog class members, see the RevisionLog Members topic.

Public Instance Properties

Revisions Gets all revisions in this log.

See Also

RevisionLog Class | Aspose.Cells.Revisions Namespace


Revisions Property

Aspose.Cells for .NET

RevisionLog.Revisions Property

Gets all revisions in this log.

public RevisionCollection Revisions {get;}

See Also

RevisionLog Class | Aspose.Cells.Revisions Namespace


RevisionLogCollection Class

Represents all revision logs.

For a list of all members of this type, see RevisionLogCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Revisions.RevisionLogCollection

public class RevisionLogCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionLogCollection Members | Aspose.Cells.Revisions Namespace


RevisionLogCollection Members

RevisionLogCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
DaysPreservingHistory | Gets and sets the number of days the spreadsheet application will keep the change history for this workbook.
Item | Gets RevisionLog by index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

RevisionLogCollection Class | Aspose.Cells.Revisions Namespace


RevisionLogCollection Properties

The properties of the RevisionLogCollection class are listed below. For a complete list of RevisionLogCollection class members, see the RevisionLogCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
DaysPreservingHistory | Gets and sets the number of days the spreadsheet application will keep the change history for this workbook.
Item | Gets RevisionLog by index.

See Also

RevisionLogCollection Class | Aspose.Cells.Revisions Namespace


DaysPreservingHistory Property

Aspose.Cells for .NET

RevisionLogCollection.DaysPreservingHistory Property

Gets and sets the number of days the spreadsheet application will keep the change history for this workbook.

public int DaysPreservingHistory {get; set;}

See Also

RevisionLogCollection Class | Aspose.Cells.Revisions Namespace


Item Property

Aspose.Cells for .NET

RevisionLogCollection.Item Property

Gets RevisionLog by index.

public RevisionLog this[
int index
] {get;}

Parameters

index
The index.

See Also

RevisionLogCollection Class | Aspose.Cells.Revisions Namespace


RevisionMergeConflict Class

Represents a revision record which indicates that there was a merge conflict.

For a list of all members of this type, see RevisionMergeConflict Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionMergeConflict

public class RevisionMergeConflict : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionMergeConflict Members | Aspose.Cells.Revisions Namespace


RevisionMergeConflict Members

RevisionMergeConflict overview

Public Instance Properties

Id (inherited from Revision) | Gets the number of this revision.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionMergeConflict Class | Aspose.Cells.Revisions Namespace


RevisionMergeConflict Properties

The properties of the RevisionMergeConflict class are listed below. For a complete list of RevisionMergeConflict class members, see the RevisionMergeConflict Members topic.

Public Instance Properties

Id (inherited from Revision) | Gets the number of this revision.
Type | Gets the type of revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionMergeConflict Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionMergeConflict.Type Property

Gets the type of revision.

public override RevisionType Type {get;}

See Also

RevisionMergeConflict Class | Aspose.Cells.Revisions Namespace


RevisionQueryTable Class

Represents a revision of a query table field change.

For a list of all members of this type, see RevisionQueryTable Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionQueryTable

public class RevisionQueryTable : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionQueryTable Members | Aspose.Cells.Revisions Namespace


RevisionQueryTable Members

RevisionQueryTable overview

Public Instance Properties

CellArea | Gets the location of the affected query table.
FieldId | Gets ID of the specific query table field that was removed.
Id (inherited from Revision) | Gets the number of this revision.
Type | Represents the type of the revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionQueryTable Class | Aspose.Cells.Revisions Namespace


RevisionQueryTable Properties

The properties of the RevisionQueryTable class are listed below. For a complete list of RevisionQueryTable class members, see the RevisionQueryTable Members topic.

Public Instance Properties

CellArea | Gets the location of the affected query table.
FieldId | Gets ID of the specific query table field that was removed.
Id (inherited from Revision) | Gets the number of this revision.
Type | Represents the type of the revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionQueryTable Class | Aspose.Cells.Revisions Namespace


CellArea Property

Aspose.Cells for .NET

RevisionQueryTable.CellArea Property

Gets the location of the affected query table.

public CellArea CellArea {get;}

See Also

RevisionQueryTable Class | Aspose.Cells.Revisions Namespace


FieldId Property

Aspose.Cells for .NET

RevisionQueryTable.FieldId Property

Gets ID of the specific query table field that was removed.

public int FieldId {get;}

See Also

RevisionQueryTable Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionQueryTable.Type Property

Represents the type of the revision.

public override RevisionType Type {get;}

See Also

RevisionQueryTable Class | Aspose.Cells.Revisions Namespace


RevisionRenameSheet Class

Represents a revision of renaming sheet.

For a list of all members of this type, see RevisionRenameSheet Members.

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionRenameSheet

public class RevisionRenameSheet : Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

RevisionRenameSheet Members | Aspose.Cells.Revisions Namespace


RevisionRenameSheet Members

RevisionRenameSheet overview

Public Instance Properties

Id (inherited from Revision) | Gets the number of this revision.
NewName | Gets the new name of the worksheet.
OldName | Gets the old name of the worksheet.
Type | Represents the type of the revision.
Worksheet (inherited from Revision) | Gets the worksheet.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

RevisionRenameSheet Class | Aspose.Cells.Revisions Namespace


RevisionRenameSheet Properties

The properties of the RevisionRenameSheet class are listed below. For a complete list of RevisionRenameSheet class members, see the RevisionRenameSheet Members topic.

Public Instance Properties

Id (inherited from Revision) | Gets the number of this revision.
NewName | Gets the new name of the worksheet.
OldName | Gets the old name of the worksheet.
Type | Represents the type of the revision.
Worksheet (inherited from Revision) | Gets the worksheet.

See Also

RevisionRenameSheet Class | Aspose.Cells.Revisions Namespace


NewName Property

Aspose.Cells for .NET

RevisionRenameSheet.NewName Property

Gets the new name of the worksheet.

public string NewName {get;}

See Also

RevisionRenameSheet Class | Aspose.Cells.Revisions Namespace


OldName Property

Aspose.Cells for .NET

RevisionRenameSheet.OldName Property

Gets the old name of the worksheet.

public string OldName {get;}

See Also

RevisionRenameSheet Class | Aspose.Cells.Revisions Namespace


Type Property

Aspose.Cells for .NET

RevisionRenameSheet.Type Property

Represents the type of the revision.

public override RevisionType Type {get;}

See Also

RevisionRenameSheet Class | Aspose.Cells.Revisions Namespace


RevisionType Enumeration

Represents the revision type.

public enum RevisionType

Members

Member Name | Description | Value
CustomView | Custom view. | 0
DefinedName | Defined name. | 1
ChangeCells | Cells change. | 2
AutoFormat | Auto format. | 3
MergeConflict | Merge conflict. | 4
Comment | Comment. | 5
Format | Format. | 6
InsertSheet | Insert worksheet. | 7
MoveCells | Move cells. | 8
Undo | Undo. | 9
QueryTable | Query table. | 10
InsertDelete | Inserting or deleting. | 11
RenameSheet | Rename worksheet. | 12
Unknown | Unknown. | 13

Requirements

Namespace: Aspose.Cells.Revisions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Revisions Namespace


Aspose.Cells.Slicers

Aspose.Cells for .NET

Aspose.Cells.Slicers Namespace

Namespace hierarchy

Classes

Class | Description
Slicer | summary description of Slicer View
SlicerCache | summary description of slicer cache
SlicerCacheItem | Represent slicer data source item
SlicerCacheItemCollection | Represent the collection of SlicerCacheItem
SlicerCollection | Specifies the collection of all the Slicer objects on the specified worksheet.

Enumerations

Enumeration | Description
SlicerCacheCrossFilterType | Represent the type of SlicerCacheCrossFilterType
SlicerCacheItemSortType | Specify the sort type of SlicerCacheItem
SlicerStyleType | Specify the style of slicer view


Slicer Class

summary description of Slicer View

For a list of all members of this type, see Slicer Members.

System.Object
Aspose.Cells.Slicers.Slicer

public class Slicer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Slicer Members | Aspose.Cells.Slicers Namespace


Slicer Members

Slicer overview

Public Instance Properties

AlternativeText | Returns or sets the descriptive (alternative) text string of the Slicer object.
Caption | Returns or sets the caption of the specified slicer.
CaptionVisible | Returns or sets whether the header that displays the slicer Caption is visible the default value is true
ColumnWidth | Returns or sets the width, in points, of each column in the slicer.
ColumnWidthPixel | Gets or sets the width in unit of pixels for each column of the slicer.
Height | Returns or sets the height of the specified slicer, in points.
HeightPixel | Returns or sets the height of the specified slicer, in pixels.
IsLocked | Indicates whether the slicer shape is locked.
IsPrintable | Indicates whether the slicer object is printable.
LeftPixel | Returns or sets the horizontal offset of slicer shape from its left column, in pixels.
LockedAspectRatio | Indicates whether locking aspect ratio.
LockedPosition | Indicates whether the specified slicer can be moved or resized by using the user interface.
Name | Returns or sets the name of the specified slicer
NumberOfColumns | Returns or sets the number of columns in the specified slicer.
Parent | Returns the Worksheet object that represents the sheet that contains the slicer. Read-only.
Placement | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
RowHeight | Returns or sets the height, in points, of each row in the specified slicer.
RowHeightPixel | Returns or sets the height, in pixels, of each row in the specified slicer.
SlicerCache | Returns the SlicerCache object associated with the slicer. Read-only.
StyleType | Specify the type of Built-in slicer style the default type is SlicerStyleLight1
Title | Specifies the title of the current Slicer object.
TopPixel | Returns or sets the vertical offset of slicer shape from its top row, in pixels.
Width | Returns or sets the width of the specified slicer, in points.
WidthPixel | Returns or sets the width of the specified slicer, in pixels.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Refresh | Refreshing the slicer.Meanwhile, Refreshing and Calculating relative PivotTables.
ToString (inherited from Object) |

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Slicer Properties

The properties of the Slicer class are listed below. For a complete list of Slicer class members, see the Slicer Members topic.

Public Instance Properties

AlternativeText | Returns or sets the descriptive (alternative) text string of the Slicer object.
Caption | Returns or sets the caption of the specified slicer.
CaptionVisible | Returns or sets whether the header that displays the slicer Caption is visible the default value is true
ColumnWidth | Returns or sets the width, in points, of each column in the slicer.
ColumnWidthPixel | Gets or sets the width in unit of pixels for each column of the slicer.
Height | Returns or sets the height of the specified slicer, in points.
HeightPixel | Returns or sets the height of the specified slicer, in pixels.
IsLocked | Indicates whether the slicer shape is locked.
IsPrintable | Indicates whether the slicer object is printable.
LeftPixel | Returns or sets the horizontal offset of slicer shape from its left column, in pixels.
LockedAspectRatio | Indicates whether locking aspect ratio.
LockedPosition | Indicates whether the specified slicer can be moved or resized by using the user interface.
Name | Returns or sets the name of the specified slicer
NumberOfColumns | Returns or sets the number of columns in the specified slicer.
Parent | Returns the Worksheet object that represents the sheet that contains the slicer. Read-only.
Placement | Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.
RowHeight | Returns or sets the height, in points, of each row in the specified slicer.
RowHeightPixel | Returns or sets the height, in pixels, of each row in the specified slicer.
SlicerCache | Returns the SlicerCache object associated with the slicer. Read-only.
StyleType | Specify the type of Built-in slicer style the default type is SlicerStyleLight1
Title | Specifies the title of the current Slicer object.
TopPixel | Returns or sets the vertical offset of slicer shape from its top row, in pixels.
Width | Returns or sets the width of the specified slicer, in points.
WidthPixel | Returns or sets the width of the specified slicer, in pixels.

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


AlternativeText Property

Aspose.Cells for .NET

Slicer.AlternativeText Property

Returns or sets the descriptive (alternative) text string of the Slicer object.

public string AlternativeText {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Caption Property

Aspose.Cells for .NET

Slicer.Caption Property

Returns or sets the caption of the specified slicer.

public string Caption {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


CaptionVisible Property

Aspose.Cells for .NET

Slicer.CaptionVisible Property

Returns or sets whether the header that displays the slicer Caption is visible the default value is true

public bool CaptionVisible {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


ColumnWidth Property

Aspose.Cells for .NET

Slicer.ColumnWidth Property

Returns or sets the width, in points, of each column in the slicer.

public double ColumnWidth {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


ColumnWidthPixel Property

Aspose.Cells for .NET

Slicer.ColumnWidthPixel Property

Gets or sets the width in unit of pixels for each column of the slicer.

public int ColumnWidthPixel {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Height Property

Aspose.Cells for .NET

Slicer.Height Property

Returns or sets the height of the specified slicer, in points.

public double Height {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


HeightPixel Property

Aspose.Cells for .NET

Slicer.HeightPixel Property

Returns or sets the height of the specified slicer, in pixels.

public int HeightPixel {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


IsLocked Property

Aspose.Cells for .NET

Slicer.IsLocked Property

Indicates whether the slicer shape is locked.

public bool IsLocked {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


IsPrintable Property

Aspose.Cells for .NET

Slicer.IsPrintable Property

Indicates whether the slicer object is printable.

public bool IsPrintable {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


LeftPixel Property

Aspose.Cells for .NET

Slicer.LeftPixel Property

Returns or sets the horizontal offset of slicer shape from its left column, in pixels.

public int LeftPixel {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


LockedAspectRatio Property

Aspose.Cells for .NET

Slicer.LockedAspectRatio Property

Indicates whether locking aspect ratio.

public bool LockedAspectRatio {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


LockedPosition Property

Aspose.Cells for .NET

Slicer.LockedPosition Property

Indicates whether the specified slicer can be moved or resized by using the user interface.

public bool LockedPosition {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Name Property

Aspose.Cells for .NET

Slicer.Name Property

Returns or sets the name of the specified slicer

public string Name {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


NumberOfColumns Property

Aspose.Cells for .NET

Slicer.NumberOfColumns Property

Returns or sets the number of columns in the specified slicer.

public int NumberOfColumns {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Parent Property

Aspose.Cells for .NET

Slicer.Parent Property

Returns the Worksheet object that represents the sheet that contains the slicer. Read-only.

public Worksheet Parent {get;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Placement Property

Aspose.Cells for .NET

Slicer.Placement Property

Represents the way the drawing object is attached to the cells below it. The property controls the placement of an object on a worksheet.

public PlacementType Placement {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


RowHeight Property

Aspose.Cells for .NET

Slicer.RowHeight Property

Returns or sets the height, in points, of each row in the specified slicer.

public double RowHeight {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


RowHeightPixel Property

Aspose.Cells for .NET

Slicer.RowHeightPixel Property

Returns or sets the height, in pixels, of each row in the specified slicer.

public int RowHeightPixel {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


SlicerCache Property

Aspose.Cells for .NET

Slicer.SlicerCache Property

Returns the SlicerCache object associated with the slicer. Read-only.

public SlicerCache SlicerCache {get;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


StyleType Property

Aspose.Cells for .NET

Slicer.StyleType Property

Specify the type of Built-in slicer style the default type is SlicerStyleLight1

public SlicerStyleType StyleType {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Title Property

Aspose.Cells for .NET

Slicer.Title Property

Specifies the title of the current Slicer object.

public string Title {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


TopPixel Property

Aspose.Cells for .NET

Slicer.TopPixel Property

Returns or sets the vertical offset of slicer shape from its top row, in pixels.

public int TopPixel {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Width Property

Aspose.Cells for .NET

Slicer.Width Property

Returns or sets the width of the specified slicer, in points.

public double Width {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


WidthPixel Property

Aspose.Cells for .NET

Slicer.WidthPixel Property

Returns or sets the width of the specified slicer, in pixels.

public int WidthPixel {get; set;}

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Slicer Methods

The methods of the Slicer class are listed below. For a complete list of Slicer class members, see the Slicer Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Refresh | Refreshing the slicer.Meanwhile, Refreshing and Calculating relative PivotTables.
ToString (inherited from Object) |

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


Slicer.Refresh Method

Refreshing the slicer.Meanwhile, Refreshing and Calculating relative PivotTables.

public void Refresh();

See Also

Slicer Class | Aspose.Cells.Slicers Namespace


SlicerCache Class

summary description of slicer cache

For a list of all members of this type, see SlicerCache Members.

System.Object
Aspose.Cells.Slicers.SlicerCache

public class SlicerCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SlicerCache Members | Aspose.Cells.Slicers Namespace


SlicerCache Members

SlicerCache overview

Public Instance Properties

CrossFilterType | Returns or sets whether a slicer is participating in cross filtering with other slicers that share the same slicer cache, and how cross filtering is displayed. Read/write
List | Returns whether the slicer associated with the specified slicer cache is based on an Non-OLAP data source. Read-only
Name | Returns the name of the slicer cache.
SlicerCacheItems | Returns a SlicerCacheItem collection that contains the collection of all items in the slicer cache. Read-only
SourceName | Returns the name of cache field

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


SlicerCache Properties

The properties of the SlicerCache class are listed below. For a complete list of SlicerCache class members, see the SlicerCache Members topic.

Public Instance Properties

CrossFilterType | Returns or sets whether a slicer is participating in cross filtering with other slicers that share the same slicer cache, and how cross filtering is displayed. Read/write
List | Returns whether the slicer associated with the specified slicer cache is based on an Non-OLAP data source. Read-only
Name | Returns the name of the slicer cache.
SlicerCacheItems | Returns a SlicerCacheItem collection that contains the collection of all items in the slicer cache. Read-only
SourceName | Returns the name of cache field

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


CrossFilterType Property

Aspose.Cells for .NET

SlicerCache.CrossFilterType Property

Returns or sets whether a slicer is participating in cross filtering with other slicers that share the same slicer cache, and how cross filtering is displayed. Read/write

public SlicerCacheCrossFilterType CrossFilterType {get; set;}

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


List Property

Aspose.Cells for .NET

SlicerCache.List Property

Returns whether the slicer associated with the specified slicer cache is based on an Non-OLAP data source. Read-only

public bool List {get;}

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


Name Property

Aspose.Cells for .NET

SlicerCache.Name Property

Returns the name of the slicer cache.

public string Name {get;}

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


SlicerCacheItems Property

Aspose.Cells for .NET

SlicerCache.SlicerCacheItems Property

Returns a SlicerCacheItem collection that contains the collection of all items in the slicer cache. Read-only

public SlicerCacheItemCollection SlicerCacheItems {get;}

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


SourceName Property

Aspose.Cells for .NET

SlicerCache.SourceName Property

Returns the name of cache field

public string SourceName {get;}

See Also

SlicerCache Class | Aspose.Cells.Slicers Namespace


SlicerCacheCrossFilterType Enumeration

Represent the type of SlicerCacheCrossFilterType

public enum SlicerCacheCrossFilterType

Members

Member Name | Description | Value
None | The table style element of the slicer style for slicer items with no data is not applied to slicer items with no data, and slicer items with no data are not sorted separately in the list of slicer items in the slicer view | 0
ShowItemsWithDataAtTop | The table style element of the slicer style for slicer items with no data is applied to slicer items with no data, and slicer items with no data are sorted at the bottom in the list of slicer items in the slicer view | 1
ShowItemsWithNoData | The table style element of the slicer style for slicer items with no data is applied to slicer items with no data, and slicer items with no data are not sorted separately in the list of slicer items in the slicer view. | 2

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Slicers Namespace


SlicerCacheItem Class

Represent slicer data source item

For a list of all members of this type, see SlicerCacheItem Members.

System.Object
Aspose.Cells.Slicers.SlicerCacheItem

public class SlicerCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SlicerCacheItem Members | Aspose.Cells.Slicers Namespace


SlicerCacheItem Members

SlicerCacheItem overview

Public Instance Properties

Selected Specifies whether the SlicerItem is selected or not.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

SlicerCacheItem Class | Aspose.Cells.Slicers Namespace


SlicerCacheItem Properties

The properties of the SlicerCacheItem class are listed below. For a complete list of SlicerCacheItem class members, see the SlicerCacheItem Members topic.

Public Instance Properties

Selected Specifies whether the SlicerItem is selected or not.

See Also

SlicerCacheItem Class | Aspose.Cells.Slicers Namespace


Selected Property

Aspose.Cells for .NET

SlicerCacheItem.Selected Property

Specifies whether the SlicerItem is selected or not.

public bool Selected {get; set;}

See Also

SlicerCacheItem Class | Aspose.Cells.Slicers Namespace


SlicerCacheItemCollection Class

Represent the collection of SlicerCacheItem

For a list of all members of this type, see SlicerCacheItemCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Slicers.SlicerCacheItemCollection

public class SlicerCacheItemCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SlicerCacheItemCollection Members | Aspose.Cells.Slicers Namespace


SlicerCacheItemCollection Members

SlicerCacheItemCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count | Gets the count of the SlicerCacheItem.
Item | Gets the SlicerCacheItem object by index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

SlicerCacheItemCollection Class | Aspose.Cells.Slicers Namespace


SlicerCacheItemCollection Properties

The properties of the SlicerCacheItemCollection class are listed below. For a complete list of SlicerCacheItemCollection class members, see the SlicerCacheItemCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count | Gets the count of the SlicerCacheItem.
Item | Gets the SlicerCacheItem object by index.

See Also

SlicerCacheItemCollection Class | Aspose.Cells.Slicers Namespace


Count Property

Aspose.Cells for .NET

SlicerCacheItemCollection.Count Property

Gets the count of the SlicerCacheItem.

new public int Count {get;}

Implements

ICollection.Count

See Also

SlicerCacheItemCollection Class | Aspose.Cells.Slicers Namespace


Item Property

Aspose.Cells for .NET

SlicerCacheItemCollection.Item Property

Gets the SlicerCacheItem object by index.

public SlicerCacheItem this[
int index
] {get;}

See Also

SlicerCacheItemCollection Class | Aspose.Cells.Slicers Namespace


SlicerCacheItemSortType Enumeration

Specify the sort type of SlicerCacheItem

public enum SlicerCacheItemSortType

Members

Member Name | Description | Value
Ascending | Ascending sort type | 0
Descending | Descending sort type | 1

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Slicers Namespace


SlicerCollection Class

Specifies the collection of all the Slicer objects on the specified worksheet.

For a list of all members of this type, see SlicerCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Slicers.SlicerCollection

public class SlicerCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

SlicerCollection Members | Aspose.Cells.Slicers Namespace


SlicerCollection Members

SlicerCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Slicer by index.

Public Instance Methods

Add | Overloaded. Add a new Slicer using PivotTable as data source
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Remove the specified Slicer
RemoveAt | Deletes the Slicer at the specified index
ToString (inherited from Object) |

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


SlicerCollection Properties

The properties of the SlicerCollection class are listed below. For a complete list of SlicerCollection class members, see the SlicerCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the Slicer by index.

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


Item Property

Aspose.Cells for .NET

SlicerCollection.Item Property

Gets the Slicer by index.

Overload List

Gets the Slicer by index.

public Slicer this[int] {get;}

Gets the Slicer by slicer's name.

public Slicer this[string] {get;}

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


Item Property (Int32)

Aspose.Cells for .NET

SlicerCollection.Item Property (Int32)

Gets the Slicer by index.

public Slicer this[
int index
] {get;}

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

SlicerCollection.Item Property (String)

Gets the Slicer by slicer's name.

public Slicer this[
string name
] {get;}

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Item Overload List


SlicerCollection Methods

The methods of the SlicerCollection class are listed below. For a complete list of SlicerCollection class members, see the SlicerCollection Members topic.

Public Instance Methods

Add | Overloaded. Add a new Slicer using PivotTable as data source
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Remove the specified Slicer
RemoveAt | Deletes the Slicer at the specified index
ToString (inherited from Object) |

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


Add Method

Aspose.Cells for .NET

SlicerCollection.Add Method

Add a new Slicer using PivotTable as data source

Overload List

Add a new Slicer using PivotTable as data source

public int Add(PivotTable,int,int,PivotField);

Add a new Slicer using PivotTable as data source

public int Add(PivotTable,int,int,int);

Add a new Slicer using PivotTable as data source

public int Add(PivotTable,int,int,string);

Add a new Slicer using PivotTable as data source

public int Add(PivotTable,string,PivotField);

Add a new Slicer using PivotTable as data source

public int Add(PivotTable,string,int);

Add a new Slicer using PivotTable as data source

public int Add(PivotTable,string,string);

Add a new Slicer using ListObjet as data source

public int Add(ListObject,ListColumn,int,int);

Add a new Slicer using ListObjet as data source

public int Add(ListObject,ListColumn,string);

Add a new Slicer using ListObjet as data source

public int Add(ListObject,int,string);

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


SlicerCollection.Add Method (PivotTable, Int32, Int32, PivotField)

Add a new Slicer using PivotTable as data source

public int Add(
PivotTable pivot,
int row,
int column,
PivotField baseField
);

Parameters

pivot
PivotTable object
row
Row index of the cell in the upper-left corner of the Slicer range.
column
Column index of the cell in the upper-left corner of the Slicer range.
baseField
The PivotField in PivotTable.BaseFields

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (PivotTable, Int32, Int32, Int32)

Add a new Slicer using PivotTable as data source

public int Add(
PivotTable pivot,
int row,
int column,
int baseFieldIndex
);

Parameters

pivot
PivotTable object
row
Row index of the cell in the upper-left corner of the Slicer range.
column
Column index of the cell in the upper-left corner of the Slicer range.
baseFieldIndex
The index of PivotField in PivotTable.BaseFields

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (PivotTable, Int32, Int32, String)

Add a new Slicer using PivotTable as data source

public int Add(
PivotTable pivot,
int row,
int column,
string baseFieldName
);

Parameters

pivot
PivotTable object
row
Row index of the cell in the upper-left corner of the Slicer range.
column
Column index of the cell in the upper-left corner of the Slicer range.
baseFieldName
The name of PivotField in PivotTable.BaseFields

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (PivotTable, String, PivotField)

Add a new Slicer using PivotTable as data source

public int Add(
PivotTable pivot,
string destCellName,
PivotField baseField
);

Parameters

pivot
PivotTable object
destCellName
The cell in the upper-left corner of the Slicer range.
baseField
The PivotField in PivotTable.BaseFields

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (PivotTable, String, Int32)

Add a new Slicer using PivotTable as data source

public int Add(
PivotTable pivot,
string destCellName,
int baseFieldIndex
);

Parameters

pivot
PivotTable object
destCellName
The cell in the upper-left corner of the Slicer range.
baseFieldIndex
The index of PivotField in PivotTable.BaseFields

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (PivotTable, String, String)

Add a new Slicer using PivotTable as data source

public int Add(
PivotTable pivot,
string destCellName,
string baseFieldName
);

Parameters

pivot
PivotTable object
destCellName
The cell in the upper-left corner of the Slicer range.
baseFieldName
The name of PivotField in PivotTable.BaseFields

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (ListObject, ListColumn, Int32, Int32)

Add a new Slicer using ListObjet as data source

public int Add(
ListObject table,
ListColumn listColumn,
int row,
int column
);

Parameters

table
ListObject object
listColumn
The ListColumn in ListObject.ListColumns
row
Row index of the cell in the upper-left corner of the Slicer range.
column
Column index of the cell in the upper-left corner of the Slicer range.

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (ListObject, ListColumn, String)

Add a new Slicer using ListObjet as data source

public int Add(
ListObject table,
ListColumn listColumn,
string destCellName
);

Parameters

table
ListObject object
listColumn
The ListColumn in ListObject.ListColumns
destCellName
The cell in the upper-left corner of the Slicer range.

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Add Method (ListObject, Int32, String)

Add a new Slicer using ListObjet as data source

public int Add(
ListObject table,
int index,
string destCellName
);

Parameters

table
ListObject object
index
The index of ListColumn in ListObject.ListColumns
destCellName
The cell in the upper-left corner of the Slicer range.

Return Value

The new add Slicer index

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace | SlicerCollection.Add Overload List


SlicerCollection.Remove Method

Remove the specified Slicer

public void Remove(
Slicer slicer
);

Parameters

slicer
The Slicer object

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


SlicerCollection.RemoveAt Method

Deletes the Slicer at the specified index

new public void RemoveAt(
int index
);

Parameters

index
The position index in Slicer collection

Implements

IList.RemoveAt

See Also

SlicerCollection Class | Aspose.Cells.Slicers Namespace


SlicerStyleType Enumeration

Specify the style of slicer view

public enum SlicerStyleType

Members

Member Name | Description | Value
SlicerStyleLight1 | built-in light style one | 0
SlicerStyleLight2 | built-in light style two | 1
SlicerStyleLight3 | built-in light style three | 2
SlicerStyleLight4 | built-in light style four | 3
SlicerStyleLight5 | built-in light style five | 4
SlicerStyleLight6 | built-in light style six | 5
SlicerStyleOther1 | built-in style other one | 6
SlicerStyleOther2 | built-in style other two | 7
SlicerStyleDark1 | built-in dark style one | 8
SlicerStyleDark2 | built-in dark style tow | 9
SlicerStyleDark3 | built-in dark style three | 10
SlicerStyleDark4 | built-in dark style four | 11
SlicerStyleDark5 | built-in dark style five | 12
SlicerStyleDark6 | built-in dark style six | 13
Custom | user-defined style, unsupported for now | 14

Requirements

Namespace: Aspose.Cells.Slicers

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Slicers Namespace


Aspose.Cells.Tables

Aspose.Cells for .NET

Aspose.Cells.Tables Namespace

Namespace hierarchy

Classes

Class | Description
ListColumn | Represents a column in a list.
ListColumnCollection | Represents A collection of all the ListColumn objects in the specified ListObject object.
ListObject | Represents a list object on a worksheet. The ListObject object is a member of the ListObjects collection. The ListObjects collection contains all the list objects on a worksheet.
ListObjectCollection | Represents a collection of ListObject objects in the worksheet.
TableStyle | Represents the table style.
TableStyleCollection | Represents all custom table styles.
TableStyleElement | Represents the element of the table style.
TableStyleElementCollection | Represents all elements of the table style.
TableToRangeOptions | Represents the options when converting table to range.

Enumerations

Enumeration | Description
TableDataSourceType | Represents the table's data source type.
TableStyleElementType | Represents the Table or PivotTable style element type.
TableStyleType | Represents the built-in table style type.
TotalsCalculation | Determines the type of calculation in the Totals row of the list column.


ListColumn Class

Represents a column in a list.

For a list of all members of this type, see ListColumn Members.

System.Object
Aspose.Cells.Tables.ListColumn

public class ListColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ListColumn Members | Aspose.Cells.Tables Namespace


ListColumn Members

ListColumn overview

Public Instance Properties

Formula | Gets and sets the formula of the list column.
Name | Gets and sets the name of the column.
Range | Gets the range of this list column.
TotalsCalculation | Gets and sets the type of calculation in the Totals row of the list column.

Public Instance Methods

Equals (inherited from Object) |
GetCustomCalculatedFormula | Gets the formula of this list column.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetCustomCalculatedFormula | Sets the formula for this list column.
ToString (inherited from Object) |

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


ListColumn Properties

The properties of the ListColumn class are listed below. For a complete list of ListColumn class members, see the ListColumn Members topic.

Public Instance Properties

Formula | Gets and sets the formula of the list column.
Name | Gets and sets the name of the column.
Range | Gets the range of this list column.
TotalsCalculation | Gets and sets the type of calculation in the Totals row of the list column.

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


Formula Property

Aspose.Cells for .NET

ListColumn.Formula Property

Gets and sets the formula of the list column.

public string Formula {get; set;}

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


Name Property

Aspose.Cells for .NET

ListColumn.Name Property

Gets and sets the name of the column.

public string Name {get; set;}

Remarks

If sets the name of the column, the according cell' value will be changed too.

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


Range Property

Aspose.Cells for .NET

ListColumn.Range Property

Gets the range of this list column.

public Range Range {get;}

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


TotalsCalculation Property

Aspose.Cells for .NET

ListColumn.TotalsCalculation Property

Gets and sets the type of calculation in the Totals row of the list column.

public TotalsCalculation TotalsCalculation {get; set;}

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


ListColumn Methods

The methods of the ListColumn class are listed below. For a complete list of ListColumn class members, see the ListColumn Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetCustomCalculatedFormula | Gets the formula of this list column.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetCustomCalculatedFormula | Sets the formula for this list column.
ToString (inherited from Object) |

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


ListColumn.GetCustomCalculatedFormula Method

Gets the formula of this list column.

public string GetCustomCalculatedFormula(
bool isR1C1,
bool isLocal
);

Parameters

isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

Return Value

The formula of this list column.

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


ListColumn.SetCustomCalculatedFormula Method

Sets the formula for this list column.

public void SetCustomCalculatedFormula(
string formula,
bool isR1C1,
bool isLocal
);

Parameters

formula
the formula for this list column.
isR1C1
Whether the formula needs to be formatted as R1C1.
isLocal
Whether the formula needs to be formatted by locale.

See Also

ListColumn Class | Aspose.Cells.Tables Namespace


ListColumnCollection Class

Represents A collection of all the ListColumn objects in the specified ListObject object.

For a list of all members of this type, see ListColumnCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Tables.ListColumnCollection

public class ListColumnCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ListColumnCollection Members | Aspose.Cells.Tables Namespace


ListColumnCollection Members

ListColumnCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ListColumn by the index.

Public Instance Methods

Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

See Also

ListColumnCollection Class | Aspose.Cells.Tables Namespace


ListColumnCollection Properties

The properties of the ListColumnCollection class are listed below. For a complete list of ListColumnCollection class members, see the ListColumnCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ListColumn by the index.

See Also

ListColumnCollection Class | Aspose.Cells.Tables Namespace


Item Property

Aspose.Cells for .NET

ListColumnCollection.Item Property

Gets the ListColumn by the index.

Overload List

Gets the ListColumn by the index.

public ListColumn this[int] {get;}

Gets the ListColumn by the name.

public ListColumn this[string] {get;}

See Also

ListColumnCollection Class | Aspose.Cells.Tables Namespace


Item Property (Int32)

Aspose.Cells for .NET

ListColumnCollection.Item Property (Int32)

Gets the ListColumn by the index.

public ListColumn this[
int index
] {get;}

Parameters

index
The index.

See Also

ListColumnCollection Class | Aspose.Cells.Tables Namespace | ListColumnCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ListColumnCollection.Item Property (String)

Gets the ListColumn by the name.

public ListColumn this[
string name
] {get;}

Parameters

name
The name of the ListColumn

See Also

ListColumnCollection Class | Aspose.Cells.Tables Namespace | ListColumnCollection.Item Overload List


ListObject Class

Represents a list object on a worksheet. The ListObject object is a member of the ListObjects collection. The ListObjects collection contains all the list objects on a worksheet.

For a list of all members of this type, see ListObject Members.

System.Object
Aspose.Cells.Tables.ListObject

public class ListObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Workbook workbook = new Workbook();
Cells cells = workbook.Worksheets[0].Cells;
for (int i = 0; i  <5; i++)
{
cells[0,i].PutValue(CellsHelper.ColumnIndexToName(i));
 }
for (int row = 1; row  <10; row++)
{
 for (int column = 0; column  <5; column++)
{
cells[row, column].PutValue(row * column);
 }
 }
ListObjectCollection tables = workbook.Worksheets[0].ListObjects;
int index = tables.Add(0, 0, 9, 4, true);
ListObject table = tables[0];
table.ShowTotals = true;
table.ListColumns[4].TotalsCalculation = Aspose.Cells.TotalsCalculation.Sum;
workbook.Save(@"C:\Book1.xlsx");

[Visual Basic]

Dim workbook As Workbook = New Workbook()
Dim cells As Cells = workbook.Worksheets(0).Cells
For i As Int32 = 0 To 4
 cells(0, i).PutValue(CellsHelper.ColumnIndexToName(i))
Next
For row As Int32 = 1 To 9
 For column As Int32 = 0 To 4
  cells(row, column).PutValue(row * column)
Next
Next
Dim tables As ListObjectCollection = workbook.Worksheets(0).ListObjects
Dim index As Int32 = tables.Add(0, 0, 9, 4, True)
Dim table As ListObject = tables(0)
table.ShowTotals = True
table.ListColumns(4).TotalsCalculation = Aspose.Cells.TotalsCalculation.Sum
workbook.Save("C:\Book1.xlsx")

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ListObject Members | Aspose.Cells.Tables Namespace


ListObject Members

ListObject overview

Public Instance Properties

AlternativeDescription | Gets and sets the alternative description.
AlternativeText | Gets and sets the alternative text.
AutoFilter | Gets auto filter.
Comment | Gets and sets the comment of the table.
DataRange | Gets the data range of the ListObject.
DataSourceType | Gets the data source type of the table.
DisplayName | Gets and sets the display name.
EndColumn | Gets the end column of the range.
EndRow | Gets the end row of the range.
ListColumns | Gets ListColumns of the ListObject.
QueryTable | Gets the linked QueryTable.
ShowHeaderRow | Gets and sets whether this ListObject show header row.
ShowTableStyleColumnStripes | Indicates whether column stripe formatting is applied.
ShowTableStyleFirstColumn | Indicates whether the first column in the table should have the style applied.
ShowTableStyleLastColumn | Indicates whether the last column in the table should have the style applied.
ShowTableStyleRowStripes | Indicates whether row stripe formatting is applied.
ShowTotals | Gets and sets whether this ListObject show total row.
StartColumn | Gets the start column of the range.
StartRow | Gets the start row of the range.
TableStyleName | Gets and sets the table style name.
TableStyleType | Gets and the built-in table style.
XmlMap | Gets an XmlMap used for this list.

Public Instance Methods

ApplyStyleToRange | Apply the table style to the range.
ConvertToRange | Overloaded. Convert the table to range.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
PutCellValue | Put the value to the cell.
Resize | Resize the range of the list object.
ToString (inherited from Object) |
UpdateColumnName | Updates all list columns' name from the worksheet.

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObject Properties

The properties of the ListObject class are listed below. For a complete list of ListObject class members, see the ListObject Members topic.

Public Instance Properties

AlternativeDescription | Gets and sets the alternative description.
AlternativeText | Gets and sets the alternative text.
AutoFilter | Gets auto filter.
Comment | Gets and sets the comment of the table.
DataRange | Gets the data range of the ListObject.
DataSourceType | Gets the data source type of the table.
DisplayName | Gets and sets the display name.
EndColumn | Gets the end column of the range.
EndRow | Gets the end row of the range.
ListColumns | Gets ListColumns of the ListObject.
QueryTable | Gets the linked QueryTable.
ShowHeaderRow | Gets and sets whether this ListObject show header row.
ShowTableStyleColumnStripes | Indicates whether column stripe formatting is applied.
ShowTableStyleFirstColumn | Indicates whether the first column in the table should have the style applied.
ShowTableStyleLastColumn | Indicates whether the last column in the table should have the style applied.
ShowTableStyleRowStripes | Indicates whether row stripe formatting is applied.
ShowTotals | Gets and sets whether this ListObject show total row.
StartColumn | Gets the start column of the range.
StartRow | Gets the start row of the range.
TableStyleName | Gets and sets the table style name.
TableStyleType | Gets and the built-in table style.
XmlMap | Gets an XmlMap used for this list.

See Also

ListObject Class | Aspose.Cells.Tables Namespace


AlternativeDescription Property

Aspose.Cells for .NET

ListObject.AlternativeDescription Property

Gets and sets the alternative description.

public string AlternativeDescription {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


AlternativeText Property

Aspose.Cells for .NET

ListObject.AlternativeText Property

Gets and sets the alternative text.

public string AlternativeText {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


AutoFilter Property

Aspose.Cells for .NET

ListObject.AutoFilter Property

Gets auto filter.

public AutoFilter AutoFilter {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


Comment Property

Aspose.Cells for .NET

ListObject.Comment Property

Gets and sets the comment of the table.

public string Comment {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


DataRange Property

Aspose.Cells for .NET

ListObject.DataRange Property

Gets the data range of the ListObject.

public Range DataRange {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


DataSourceType Property

Aspose.Cells for .NET

ListObject.DataSourceType Property

Gets the data source type of the table.

public TableDataSourceType DataSourceType {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


DisplayName Property

Aspose.Cells for .NET

ListObject.DisplayName Property

Gets and sets the display name.

public string DisplayName {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


EndColumn Property

Aspose.Cells for .NET

ListObject.EndColumn Property

Gets the end column of the range.

public int EndColumn {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


EndRow Property

Aspose.Cells for .NET

ListObject.EndRow Property

Gets the end row of the range.

public int EndRow {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListColumns Property

Aspose.Cells for .NET

ListObject.ListColumns Property

Gets ListColumns of the ListObject.

public ListColumnCollection ListColumns {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


QueryTable Property

Aspose.Cells for .NET

ListObject.QueryTable Property

Gets the linked QueryTable.

public QueryTable QueryTable {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ShowHeaderRow Property

Aspose.Cells for .NET

ListObject.ShowHeaderRow Property

Gets and sets whether this ListObject show header row.

public bool ShowHeaderRow {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ShowTableStyleColumnStripes Property

Aspose.Cells for .NET

ListObject.ShowTableStyleColumnStripes Property

Indicates whether column stripe formatting is applied.

public bool ShowTableStyleColumnStripes {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ShowTableStyleFirstColumn Property

Aspose.Cells for .NET

ListObject.ShowTableStyleFirstColumn Property

Indicates whether the first column in the table should have the style applied.

public bool ShowTableStyleFirstColumn {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ShowTableStyleLastColumn Property

Aspose.Cells for .NET

ListObject.ShowTableStyleLastColumn Property

Indicates whether the last column in the table should have the style applied.

public bool ShowTableStyleLastColumn {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ShowTableStyleRowStripes Property

Aspose.Cells for .NET

ListObject.ShowTableStyleRowStripes Property

Indicates whether row stripe formatting is applied.

public bool ShowTableStyleRowStripes {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ShowTotals Property

Aspose.Cells for .NET

ListObject.ShowTotals Property

Gets and sets whether this ListObject show total row.

public bool ShowTotals {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


StartColumn Property

Aspose.Cells for .NET

ListObject.StartColumn Property

Gets the start column of the range.

public int StartColumn {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


StartRow Property

Aspose.Cells for .NET

ListObject.StartRow Property

Gets the start row of the range.

public int StartRow {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


TableStyleName Property

Aspose.Cells for .NET

ListObject.TableStyleName Property

Gets and sets the table style name.

public string TableStyleName {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


TableStyleType Property

Aspose.Cells for .NET

ListObject.TableStyleType Property

Gets and the built-in table style.

public TableStyleType TableStyleType {get; set;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


XmlMap Property

Aspose.Cells for .NET

ListObject.XmlMap Property

Gets an XmlMap used for this list.

public XmlMap XmlMap {get;}

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObject Methods

The methods of the ListObject class are listed below. For a complete list of ListObject class members, see the ListObject Members topic.

Public Instance Methods

ApplyStyleToRange | Apply the table style to the range.
ConvertToRange | Overloaded. Convert the table to range.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
PutCellValue | Put the value to the cell.
Resize | Resize the range of the list object.
ToString (inherited from Object) |
UpdateColumnName | Updates all list columns' name from the worksheet.

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObject.ApplyStyleToRange Method

Apply the table style to the range.

public void ApplyStyleToRange();

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ConvertToRange Method

Aspose.Cells for .NET

ListObject.ConvertToRange Method

Convert the table to range.

Overload List

Convert the table to range.

public void ConvertToRange();

Convert the table to range.

public void ConvertToRange(TableToRangeOptions);

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObject.ConvertToRange Method ()

Convert the table to range.

public void ConvertToRange();

See Also

ListObject Class | Aspose.Cells.Tables Namespace | ListObject.ConvertToRange Overload List


ListObject.ConvertToRange Method (TableToRangeOptions)

Convert the table to range.

public void ConvertToRange(
TableToRangeOptions options
);

Parameters

options
the options when converting table to range.

See Also

ListObject Class | Aspose.Cells.Tables Namespace | ListObject.ConvertToRange Overload List


ListObject.PutCellValue Method

Put the value to the cell.

public void PutCellValue(
int rowOffset,
int columnOffset,
object value
);

Parameters

rowOffset
The row offset.
columnOffset
The column offset.
value
The cell value.

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObject.Resize Method

Resize the range of the list object.

public void Resize(
int startRow,
int startColumn,
int endRow,
int endColumn,
bool hasHeaders
);

Parameters

startRow
The start row index of the new range.
startColumn
The start column index of the new range.
endRow
The end row index of the new range.
endColumn
The end column index of the new range.
hasHeaders
Whether the ListObject has headers.

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObject.UpdateColumnName Method

Updates all list columns' name from the worksheet.

public void UpdateColumnName();

Remarks

The value of the cells in the header row of the table must be same as the name of the ListColumn; Cell.PutValue do not auto modify the name of the ListColumn for performance.

See Also

ListObject Class | Aspose.Cells.Tables Namespace


ListObjectCollection Class

Represents a collection of ListObject objects in the worksheet.

For a list of all members of this type, see ListObjectCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Tables.ListObjectCollection

public class ListObjectCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ListObjectCollection Members | Aspose.Cells.Tables Namespace


ListObjectCollection Members

ListObjectCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ListObject by index.

Public Instance Methods

Add | Overloaded. Adds a ListObject to the worksheet.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |
UpdateColumnName | Update all column name of the tables.

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace


ListObjectCollection Properties

The properties of the ListObjectCollection class are listed below. For a complete list of ListObjectCollection class members, see the ListObjectCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the ListObject by index.

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace


Item Property

Aspose.Cells for .NET

ListObjectCollection.Item Property

Gets the ListObject by index.

Overload List

Gets the ListObject by index.

public ListObject this[int] {get;}

Gets the ListObject by specified name.

public ListObject this[string] {get;}

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace


Item Property (Int32)

Aspose.Cells for .NET

ListObjectCollection.Item Property (Int32)

Gets the ListObject by index.

public ListObject this[
int index
] {get;}

Parameters

index
The index.

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace | ListObjectCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

ListObjectCollection.Item Property (String)

Gets the ListObject by specified name.

public ListObject this[
string tableName
] {get;}

Parameters

tableName
ListObject name.

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace | ListObjectCollection.Item Overload List


ListObjectCollection Methods

The methods of the ListObjectCollection class are listed below. For a complete list of ListObjectCollection class members, see the ListObjectCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a ListObject to the worksheet.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |
UpdateColumnName | Update all column name of the tables.

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace


Add Method

Aspose.Cells for .NET

ListObjectCollection.Add Method

Adds a ListObject to the worksheet.

Overload List

Adds a ListObject to the worksheet.

public int Add(int,int,int,int,bool);

Adds a ListObject to the worksheet.

public int Add(string,string,bool);

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace


ListObjectCollection.Add Method (Int32, Int32, Int32, Int32, Boolean)

Adds a ListObject to the worksheet.

public int Add(
int startRow,
int startColumn,
int endRow,
int endColumn,
bool hasHeaders
);

Parameters

startRow
The start row of the list range.
startColumn
The start row of the list range.
endRow
The start row of the list range.
endColumn
The start row of the list range.
hasHeaders
Whether the range has headers.

Return Value

The index of the new ListObject

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace | ListObjectCollection.Add Overload List


ListObjectCollection.Add Method (String, String, Boolean)

Adds a ListObject to the worksheet.

public int Add(
string startCell,
string endCell,
bool hasHeaders
);

Parameters

startCell
The start cell of the list range.
endCell
The end cell of the list range.
hasHeaders
Whether the range has headers.

Return Value

The index of the new ListObject

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace | ListObjectCollection.Add Overload List


ListObjectCollection.UpdateColumnName Method

Update all column name of the tables.

public void UpdateColumnName();

See Also

ListObjectCollection Class | Aspose.Cells.Tables Namespace


TableDataSourceType Enumeration

Represents the table's data source type.

public enum TableDataSourceType

Members

Member Name | Description | Value
Worksheet | Excel Worksheet Table | 0
SharePoint | Read-write SharePoint linked List | 1
XML | XML mapper Table | 2
QueryTable | Query Table | 3

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Tables Namespace


TableStyle Class

Represents the table style.

For a list of all members of this type, see TableStyle Members.

System.Object
Aspose.Cells.Tables.TableStyle

public class TableStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

[C#]

Workbook workbook = new Workbook();
Style firstColumnStyle = workbook.CreateStyle();
firstColumnStyle.Pattern = BackgroundType.Solid;
firstColumnStyle.BackgroundColor = System.Drawing.Color.Red;

Style lastColumnStyle = workbook.CreateStyle();
lastColumnStyle.Font.IsBold = true;
lastColumnStyle.Pattern = BackgroundType.Solid;
lastColumnStyle.BackgroundColor = System.Drawing.Color.Red;
string tableStyleName = "Custom1";
TableStyleCollection tableStyles = workbook.Worksheets.TableStyles;
int index1 = tableStyles.AddTableStyle(tableStyleName);
TableStyle tableStyle = tableStyles[index1];
TableStyleElementCollection elements = tableStyle.TableStyleElements;
index1 = elements.Add(TableStyleElementType.FirstColumn);
TableStyleElement element = elements[index1];
element.SetElementStyle(firstColumnStyle);
index1 = elements.Add(TableStyleElementType.LastColumn);
element = elements[index1];
element.SetElementStyle(lastColumnStyle);
Cells cells = workbook.Worksheets[0].Cells;
for (int i = 0; i  <5; i++)
{
    cells[0, i].PutValue(CellsHelper.ColumnIndexToName(i));
}
for (int row = 1; row  <10; row++)
{
    for (int column = 0; column  <5; column++)
    {
        cells[row, column].PutValue(row * column);
    }
 }
ListObjectCollection tables = workbook.Worksheets[0].ListObjects;
int index = tables.Add(0, 0, 9, 4, true);
ListObject table = tables[0];
table.ShowTableStyleFirstColumn = true;
table.ShowTableStyleLastColumn = true;
table.TableStyleName = tableStyleName;
workbook.Save(@"C:\Book1.xlsx");

[Visual Basic]

  Dim workbook As Workbook = New Workbook()
Dim firstColumnStyle As Style = workbook.CreateStyle()
firstColumnStyle.Pattern = BackgroundType.Solid
firstColumnStyle.BackgroundColor = System.Drawing.Color.Red
Dim lastColumnStyle As Style = workbook.CreateStyle()

lastColumnStyle.Font.IsBold = True
lastColumnStyle.Pattern = BackgroundType.Solid
lastColumnStyle.BackgroundColor = System.Drawing.Color.Red
Dim tableStyleName As String = "Custom1"

Dim tableStyles As TableStyleCollection = workbook.Worksheets.TableStyles
Dim index1 As Int32 = tableStyles.AddTableStyle(tableStyleName)
Dim tableStyle As TableStyle = tableStyles(index1)
Dim elements As TableStyleElementCollection = tableStyle.TableStyleElements
index1 = elements.Add(TableStyleElementType.FirstColumn)
Dim element As TableStyleElement = elements(index1)
element.SetElementStyle(firstColumnStyle)
index1 = elements.Add(TableStyleElementType.LastColumn)
element = elements(index1)
element.SetElementStyle(lastColumnStyle)
Dim cells As Cells = workbook.Worksheets(0).Cells
For i As Int32 = 0 To 4
    cells(0, i).PutValue(CellsHelper.ColumnIndexToName(i))
Next
For row As Int32 = 1 To 9
    For column As Int32 = 0 To 4
        cells(row, column).PutValue(row * column)
    Next
Next
Dim tables As ListObjectCollection = workbook.Worksheets(0).ListObjects
Dim index As Int32 = tables.Add(0, 0, 9, 4, True)
Dim table As ListObject = tables(0)
table.ShowTableStyleFirstColumn = True
table.ShowTableStyleLastColumn = True
table.TableStyleName = tableStyleName
workbook.Save("C:\Book1.xlsx")

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TableStyle Members | Aspose.Cells.Tables Namespace


TableStyle Members

TableStyle overview

Public Instance Properties

Name | Gets the name of table style.
TableStyleElements | Gets all elements of the table style.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TableStyle Class | Aspose.Cells.Tables Namespace


TableStyle Properties

The properties of the TableStyle class are listed below. For a complete list of TableStyle class members, see the TableStyle Members topic.

Public Instance Properties

Name | Gets the name of table style.
TableStyleElements | Gets all elements of the table style.

See Also

TableStyle Class | Aspose.Cells.Tables Namespace


Name Property

Aspose.Cells for .NET

TableStyle.Name Property

Gets the name of table style.

public string Name {get;}

See Also

TableStyle Class | Aspose.Cells.Tables Namespace


TableStyleElements Property

Aspose.Cells for .NET

TableStyle.TableStyleElements Property

Gets all elements of the table style.

public TableStyleElementCollection TableStyleElements {get;}

See Also

TableStyle Class | Aspose.Cells.Tables Namespace


TableStyleCollection Class

Represents all custom table styles.

For a list of all members of this type, see TableStyleCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Tables.TableStyleCollection

public class TableStyleCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TableStyleCollection Members | Aspose.Cells.Tables Namespace


TableStyleCollection Members

TableStyleCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the table style by the index.

Public Instance Methods

AddPivotTableStyle | Adds a custom pivot table style.
AddTableStyle | Adds a custom table style.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetBuiltinTableStyle | Gets the builtin table style
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


TableStyleCollection Properties

The properties of the TableStyleCollection class are listed below. For a complete list of TableStyleCollection class members, see the TableStyleCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the table style by the index.

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


Item Property

Aspose.Cells for .NET

TableStyleCollection.Item Property

Gets the table style by the index.

Overload List

Gets the table style by the index.

public TableStyle this[int] {get;}

Gets the table style by the name.

public TableStyle this[string] {get;}

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


Item Property (Int32)

Aspose.Cells for .NET

TableStyleCollection.Item Property (Int32)

Gets the table style by the index.

public TableStyle this[
int index
] {get;}

Parameters

index
The position of the table style in the list.

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace | TableStyleCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

TableStyleCollection.Item Property (String)

Gets the table style by the name.

public TableStyle this[
string name
] {get;}

Parameters

name
The table style name.

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace | TableStyleCollection.Item Overload List


TableStyleCollection Methods

The methods of the TableStyleCollection class are listed below. For a complete list of TableStyleCollection class members, see the TableStyleCollection Members topic.

Public Instance Methods

AddPivotTableStyle | Adds a custom pivot table style.
AddTableStyle | Adds a custom table style.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetBuiltinTableStyle | Gets the builtin table style
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


TableStyleCollection.AddPivotTableStyle Method

Adds a custom pivot table style.

public int AddPivotTableStyle(
string name
);

Parameters

name
The pivot table style name.

Return Value

The index of the pivot table style.

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


TableStyleCollection.AddTableStyle Method

Adds a custom table style.

public int AddTableStyle(
string name
);

Parameters

name
The table style name.

Return Value

The index of the table style.

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


TableStyleCollection.GetBuiltinTableStyle Method

Gets the builtin table style

public TableStyle GetBuiltinTableStyle(
TableStyleType type
);

Parameters

type
The builtin table style type.

Return Value

See Also

TableStyleCollection Class | Aspose.Cells.Tables Namespace


TableStyleElement Class

Represents the element of the table style.

For a list of all members of this type, see TableStyleElement Members.

System.Object
Aspose.Cells.Tables.TableStyleElement

public class TableStyleElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TableStyleElement Members | Aspose.Cells.Tables Namespace


TableStyleElement Members

TableStyleElement overview

Public Instance Properties

Size | Number of rows or columns in a single band of striping. Applies only when type is firstRowStripe, secondRowStripe, firstColumnStripe, or secondColumnStripe.
Type | Gets the element type.

Public Instance Methods

Equals (inherited from Object) |
GetElementStyle | Gets the element style.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetElementStyle | Sets the element style.
ToString (inherited from Object) |

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


TableStyleElement Properties

The properties of the TableStyleElement class are listed below. For a complete list of TableStyleElement class members, see the TableStyleElement Members topic.

Public Instance Properties

Size | Number of rows or columns in a single band of striping. Applies only when type is firstRowStripe, secondRowStripe, firstColumnStripe, or secondColumnStripe.
Type | Gets the element type.

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


Size Property

Aspose.Cells for .NET

TableStyleElement.Size Property

Number of rows or columns in a single band of striping. Applies only when type is firstRowStripe, secondRowStripe, firstColumnStripe, or secondColumnStripe.

public int Size {get; set;}

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


Type Property

Aspose.Cells for .NET

TableStyleElement.Type Property

Gets the element type.

public TableStyleElementType Type {get;}

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


TableStyleElement Methods

The methods of the TableStyleElement class are listed below. For a complete list of TableStyleElement class members, see the TableStyleElement Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetElementStyle | Gets the element style.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SetElementStyle | Sets the element style.
ToString (inherited from Object) |

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


TableStyleElement.GetElementStyle Method

Gets the element style.

public Style GetElementStyle();

Return Value

Returns the Style object.

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


TableStyleElement.SetElementStyle Method

Sets the element style.

public void SetElementStyle(
Style style
);

Parameters

style
The element style.

See Also

TableStyleElement Class | Aspose.Cells.Tables Namespace


TableStyleElementCollection Class

Represents all elements of the table style.

For a list of all members of this type, see TableStyleElementCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Tables.TableStyleElementCollection

public class TableStyleElementCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TableStyleElementCollection Members | Aspose.Cells.Tables Namespace


TableStyleElementCollection Members

TableStyleElementCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets an element of the table style by the index.

Public Instance Methods

Add | Adds an element.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace


TableStyleElementCollection Properties

The properties of the TableStyleElementCollection class are listed below. For a complete list of TableStyleElementCollection class members, see the TableStyleElementCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets an element of the table style by the index.

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace


Item Property

Aspose.Cells for .NET

TableStyleElementCollection.Item Property

Gets the element of the table style by the TableStyleElementType

Overload List

Gets the element of the table style by the TableStyleElementType

public TableStyleElement this[Aspose.Cells.Tables.TableStyleElementType] {get;}

Gets an element of the table style by the index.

public TableStyleElement this[int] {get;}

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace


Item Property (TableStyleElementType)

Aspose.Cells for .NET

TableStyleElementCollection.Item Property (TableStyleElementType)

Gets the element of the table style by the TableStyleElementType

public TableStyleElement this[
Aspose.Cells.Tables.TableStyleElementType type
] {get;}

Parameters

type
The element type.

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace | TableStyleElementCollection.Item Overload List


Item Property (Int32)

Aspose.Cells for .NET

TableStyleElementCollection.Item Property (Int32)

Gets an element of the table style by the index.

public TableStyleElement this[
int index
] {get;}

Parameters

index
The index.

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace | TableStyleElementCollection.Item Overload List


TableStyleElementCollection Methods

The methods of the TableStyleElementCollection class are listed below. For a complete list of TableStyleElementCollection class members, see the TableStyleElementCollection Members topic.

Public Instance Methods

Add | Adds an element.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace


TableStyleElementCollection.Add Method

Adds an element.

public int Add(
TableStyleElementType type
);

Parameters

type
The type of the element

Return Value

Returns the index of the element in the list.

See Also

TableStyleElementCollection Class | Aspose.Cells.Tables Namespace


TableStyleElementType Enumeration

Represents the Table or PivotTable style element type.

public enum TableStyleElementType

Members

Member Name | Description | Value
BlankRow | Table style element that applies to PivotTable's blank rows. | 18
FirstColumn | Table style element that applies to table's first column. | 8
FirstColumnStripe | Table style element that applies to table's first column stripes. | 3
FirstColumnSubheading | Table style element that applies to PivotTable's first column subheading. | 22
FirstHeaderCell | Table style element that applies to table's first header row cell. | 11
FirstRowStripe | Table style element that applies to table's first row stripes. | 5
FirstRowSubheading | Table style element that applies to PivotTable's first row subheading. | 25
FirstSubtotalColumn | Table style element that applies to PivotTable's first subtotal column. | 15
FirstSubtotalRow | Table style element that applies to pivot table's first subtotal row. | 19
GrandTotalColumn | Table style element that applies to pivot table's grand total column. | 28
GrandTotalRow | Table style element that applies to pivot table's grand total row. | 29
FirstTotalCell | Table style element that applies to table's first total row cell. | 13
HeaderRow | Table style element that applies to table's header row. | 9
LastColumn | Table style element that applies to table's last column. | 7
LastHeaderCell | Table style element that applies to table's last header row cell. | 12
LastTotalCell | Table style element that applies to table's last total row cell. | 14
PageFieldLabels | Table style element that applies to pivot table's page field labels. | 1
PageFieldValues | Table style element that applies to pivot table's page field values. | 2
SecondColumnStripe | Table style element that applies to table's second column stripes. | 4
SecondColumnSubheading | Table style element that applies to pivot table's second column subheading. | 23
SecondRowStripe | Table style element that applies to table's second row stripes. | 6
SecondRowSubheading | Table style element that applies to pivot table's second row subheading. | 26
SecondSubtotalColumn | Table style element that applies to PivotTable's second subtotal column. | 16
SecondSubtotalRow | Table style element that applies to PivotTable's second subtotal row. | 20
ThirdColumnSubheading | Table style element that applies to PivotTable's third column subheading. | 24
ThirdRowSubheading | Table style element that applies to PivotTable's third row subheading. | 27
ThirdSubtotalColumn | Table style element that applies to pivot table's third subtotal column. | 17
ThirdSubtotalRow | Table style element that applies to PivotTable's third subtotal row. | 21
TotalRow | Table style element that applies to table's total row. | 10
WholeTable | Table style element that applies to table's entire content. | 0

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Tables Namespace


TableStyleType Enumeration

Represents the built-in table style type.

public enum TableStyleType

Members

Member Name | Description | Value
None |  | 0
TableStyleLight1 |  | 1
TableStyleLight2 |  | 2
TableStyleLight3 |  | 3
TableStyleLight4 |  | 4
TableStyleLight5 |  | 5
TableStyleLight6 |  | 6
TableStyleLight7 |  | 7
TableStyleLight8 |  | 8
TableStyleLight9 |  | 9
TableStyleLight10 |  | 10
TableStyleLight11 |  | 11
TableStyleLight12 |  | 12
TableStyleLight13 |  | 13
TableStyleLight14 |  | 14
TableStyleLight15 |  | 15
TableStyleLight16 |  | 16
TableStyleLight17 |  | 17
TableStyleLight18 |  | 18
TableStyleLight19 |  | 19
TableStyleLight20 |  | 20
TableStyleLight21 |  | 21
TableStyleMedium1 |  | 22
TableStyleMedium2 |  | 23
TableStyleMedium3 |  | 24
TableStyleMedium4 |  | 25
TableStyleMedium5 |  | 26
TableStyleMedium6 |  | 27
TableStyleMedium7 |  | 28
TableStyleMedium8 |  | 29
TableStyleMedium9 |  | 30
TableStyleMedium10 |  | 31
TableStyleMedium11 |  | 32
TableStyleMedium12 |  | 33
TableStyleMedium13 |  | 34
TableStyleMedium14 |  | 35
TableStyleMedium15 |  | 36
TableStyleMedium16 |  | 37
TableStyleMedium17 |  | 38
TableStyleMedium18 |  | 39
TableStyleMedium19 |  | 40
TableStyleMedium20 |  | 41
TableStyleMedium21 |  | 42
TableStyleMedium22 |  | 43
TableStyleMedium23 |  | 44
TableStyleMedium24 |  | 45
TableStyleMedium25 |  | 46
TableStyleMedium26 |  | 47
TableStyleMedium27 |  | 48
TableStyleMedium28 |  | 49
TableStyleDark1 |  | 50
TableStyleDark2 |  | 51
TableStyleDark3 |  | 52
TableStyleDark4 |  | 53
TableStyleDark5 |  | 54
TableStyleDark6 |  | 55
TableStyleDark7 |  | 56
TableStyleDark8 |  | 57
TableStyleDark9 |  | 58
TableStyleDark10 |  | 59
TableStyleDark11 |  | 60
Custom |  | 61

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Tables Namespace


TableToRangeOptions Class

Represents the options when converting table to range.

For a list of all members of this type, see TableToRangeOptions Members.

System.Object
Aspose.Cells.Tables.TableToRangeOptions

public class TableToRangeOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

TableToRangeOptions Members | Aspose.Cells.Tables Namespace


TableToRangeOptions Members

TableToRangeOptions overview

Public Instance Constructors

TableToRangeOptions Constructor Initializes a new instance of the TableToRangeOptions class.

Public Instance Properties

LastRow Gets and sets the last row index of the table.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

TableToRangeOptions Class | Aspose.Cells.Tables Namespace


TableToRangeOptions Constructor

Initializes a new instance of the TableToRangeOptions class.

public TableToRangeOptions();

See Also

TableToRangeOptions Class | Aspose.Cells.Tables Namespace


TableToRangeOptions Properties

The properties of the TableToRangeOptions class are listed below. For a complete list of TableToRangeOptions class members, see the TableToRangeOptions Members topic.

Public Instance Properties

LastRow Gets and sets the last row index of the table.

See Also

TableToRangeOptions Class | Aspose.Cells.Tables Namespace


LastRow Property

Aspose.Cells for .NET

TableToRangeOptions.LastRow Property

Gets and sets the last row index of the table.

public int LastRow {get; set;}

See Also

TableToRangeOptions Class | Aspose.Cells.Tables Namespace


TotalsCalculation Enumeration

Determines the type of calculation in the Totals row of the list column.

public enum TotalsCalculation

Members

Member Name | Description | Value
Sum | Represents Sum totals calculation. | 6
Count | Represents Count totals calculation. | 2
Average | Represents Average totals calculation. | 1
Max | Represents Max totals calculation. | 4
Min | Represents Min totals calculation. | 5
Var | Represents Var totals calculation. | 8
CountNums | Represents Count Nums totals calculation. | 3
StdDev | Represents StdDev totals calculation. | 7
None | Represents No totals calculation. | 0
Custom | Represents custom calculation. | 9

Requirements

Namespace: Aspose.Cells.Tables

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Tables Namespace


Aspose.Cells.Utility

Aspose.Cells for .NET

Aspose.Cells.Utility Namespace

Namespace hierarchy

Classes

Class | Description
ExportRangeToJsonOptions | Indicates the options that exporting range to json.
JsonLayoutOptions | Represents the options of json layout type.
JsonUtility | Represents the utility class of processing json.


ExportRangeToJsonOptions Class

Indicates the options that exporting range to json.

For a list of all members of this type, see ExportRangeToJsonOptions Members.

System.Object
Aspose.Cells.Utility.ExportRangeToJsonOptions

public class ExportRangeToJsonOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Utility

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

ExportRangeToJsonOptions Members | Aspose.Cells.Utility Namespace


ExportRangeToJsonOptions Members

ExportRangeToJsonOptions overview

Public Instance Constructors

ExportRangeToJsonOptions Constructor Initializes a new instance of the ExportRangeToJsonOptions class.

Public Instance Properties

ExportAsString | Exports the string value of the cells to json.
HasHeaderRow | Indicates whether the range contains header row.
Indent | Indicates the indent.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

ExportRangeToJsonOptions Class | Aspose.Cells.Utility Namespace


ExportRangeToJsonOptions Constructor

Initializes a new instance of the ExportRangeToJsonOptions class.

public ExportRangeToJsonOptions();

See Also

ExportRangeToJsonOptions Class | Aspose.Cells.Utility Namespace


ExportRangeToJsonOptions Properties

The properties of the ExportRangeToJsonOptions class are listed below. For a complete list of ExportRangeToJsonOptions class members, see the ExportRangeToJsonOptions Members topic.

Public Instance Properties

ExportAsString | Exports the string value of the cells to json.
HasHeaderRow | Indicates whether the range contains header row.
Indent | Indicates the indent.

See Also

ExportRangeToJsonOptions Class | Aspose.Cells.Utility Namespace


ExportAsString Property

Aspose.Cells for .NET

ExportRangeToJsonOptions.ExportAsString Property

Exports the string value of the cells to json.

public bool ExportAsString {get; set;}

See Also

ExportRangeToJsonOptions Class | Aspose.Cells.Utility Namespace


HasHeaderRow Property

Aspose.Cells for .NET

ExportRangeToJsonOptions.HasHeaderRow Property

Indicates whether the range contains header row.

public bool HasHeaderRow {get; set;}

See Also

ExportRangeToJsonOptions Class | Aspose.Cells.Utility Namespace


Indent Property

Aspose.Cells for .NET

ExportRangeToJsonOptions.Indent Property

Indicates the indent.

public string Indent {get; set;}

Remarks

If the indent is null or empty, the exported json is not formatted.

See Also

ExportRangeToJsonOptions Class | Aspose.Cells.Utility Namespace


JsonLayoutOptions Class

Represents the options of json layout type.

For a list of all members of this type, see JsonLayoutOptions Members.

System.Object
Aspose.Cells.Utility.JsonLayoutOptions

public class JsonLayoutOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Utility

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

JsonLayoutOptions Members | Aspose.Cells.Utility Namespace


JsonLayoutOptions Members

JsonLayoutOptions overview

Public Instance Constructors

JsonLayoutOptions Constructor Initializes a new instance of the JsonLayoutOptions class.

Public Instance Properties

ArrayAsTable | Processes Array as table.
ConvertNumericOrDate | Gets or sets a value that indicates whether the string in json is converted to numeric or date.
DateFormat | Gets and sets the format of date value.
IgnoreArrayTitle | Indicates whether ignore title if array is a property of object.
IgnoreNull | Indicates whether ignoring null value.
IgnoreObjectTitle | Indicates whether ignore title if object is a property of object.
NumberFormat | Gets and sets the format of numeric value.
TitleStyle | Gets and sets the style of the title.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


JsonLayoutOptions Constructor

Initializes a new instance of the JsonLayoutOptions class.

public JsonLayoutOptions();

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


JsonLayoutOptions Properties

The properties of the JsonLayoutOptions class are listed below. For a complete list of JsonLayoutOptions class members, see the JsonLayoutOptions Members topic.

Public Instance Properties

ArrayAsTable | Processes Array as table.
ConvertNumericOrDate | Gets or sets a value that indicates whether the string in json is converted to numeric or date.
DateFormat | Gets and sets the format of date value.
IgnoreArrayTitle | Indicates whether ignore title if array is a property of object.
IgnoreNull | Indicates whether ignoring null value.
IgnoreObjectTitle | Indicates whether ignore title if object is a property of object.
NumberFormat | Gets and sets the format of numeric value.
TitleStyle | Gets and sets the style of the title.

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


ArrayAsTable Property

Aspose.Cells for .NET

JsonLayoutOptions.ArrayAsTable Property

Processes Array as table.

public bool ArrayAsTable {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


ConvertNumericOrDate Property

Aspose.Cells for .NET

JsonLayoutOptions.ConvertNumericOrDate Property

Gets or sets a value that indicates whether the string in json is converted to numeric or date.

public bool ConvertNumericOrDate {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


DateFormat Property

Aspose.Cells for .NET

JsonLayoutOptions.DateFormat Property

Gets and sets the format of date value.

public string DateFormat {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


IgnoreArrayTitle Property

Aspose.Cells for .NET

JsonLayoutOptions.IgnoreArrayTitle Property

Indicates whether ignore title if array is a property of object.

public bool IgnoreArrayTitle {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


IgnoreNull Property

Aspose.Cells for .NET

JsonLayoutOptions.IgnoreNull Property

Indicates whether ignoring null value.

public bool IgnoreNull {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


IgnoreObjectTitle Property

Aspose.Cells for .NET

JsonLayoutOptions.IgnoreObjectTitle Property

Indicates whether ignore title if object is a property of object.

public bool IgnoreObjectTitle {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


NumberFormat Property

Aspose.Cells for .NET

JsonLayoutOptions.NumberFormat Property

Gets and sets the format of numeric value.

public string NumberFormat {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


TitleStyle Property

Aspose.Cells for .NET

JsonLayoutOptions.TitleStyle Property

Gets and sets the style of the title.

public Style TitleStyle {get; set;}

See Also

JsonLayoutOptions Class | Aspose.Cells.Utility Namespace


JsonUtility Class

Represents the utility class of processing json.

For a list of all members of this type, see JsonUtility Members.

System.Object
Aspose.Cells.Utility.JsonUtility

public class JsonUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Utility

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

JsonUtility Members | Aspose.Cells.Utility Namespace


JsonUtility Members

JsonUtility overview

Public Static Methods

ExportRangeToJson | Exporting the range to json file.
ImportData | Import the json string.

Public Instance Constructors

JsonUtility Constructor Initializes a new instance of the JsonUtility class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

JsonUtility Class | Aspose.Cells.Utility Namespace


JsonUtility Constructor

Initializes a new instance of the JsonUtility class.

public JsonUtility();

See Also

JsonUtility Class | Aspose.Cells.Utility Namespace


JsonUtility Methods

The methods of the JsonUtility class are listed below. For a complete list of JsonUtility class members, see the JsonUtility Members topic.

Public Static Methods

ExportRangeToJson | Exporting the range to json file.
ImportData | Import the json string.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

JsonUtility Class | Aspose.Cells.Utility Namespace


JsonUtility.ExportRangeToJson Method

Exporting the range to json file.

public static string ExportRangeToJson(
Range range,
ExportRangeToJsonOptions options
);

Parameters

range
The range.
options
The options of exporting.

Return Value

The json string value.

See Also

JsonUtility Class | Aspose.Cells.Utility Namespace


JsonUtility.ImportData Method

Import the json string.

public static int[] ImportData(
string json,
Cells cells,
int row,
int column,
JsonLayoutOptions option
);

Parameters

json
The json string.
cells
The Cells.
row
The row index.
column
The column index.
option
The options of import json string.

See Also

JsonUtility Class | Aspose.Cells.Utility Namespace


Aspose.Cells.Vba

Aspose.Cells for .NET

Aspose.Cells.Vba Namespace

Namespace hierarchy

Classes

Class | Description
VbaModule | Represents module that is contained in VBA project.
VbaModuleCollection | Represents the list of VbaModule
VbaProject | Represents the VBA project.
VbaProjectReference | Represents the reference of VBA project.
VbaProjectReferenceCollection | Represents all references of VBA project.

Enumerations

Enumeration | Description
VbaModuleType | Represents the type of VBA module.
VbaProjectReferenceType | Represents the type of VBA project reference.


VbaModule Class

Represents module that is contained in VBA project.

For a list of all members of this type, see VbaModule Members.

System.Object
Aspose.Cells.Vba.VbaModule

public class VbaModule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VbaModule Members | Aspose.Cells.Vba Namespace


VbaModule Members

VbaModule overview

Public Instance Properties

Codes | Gets and sets the codes of module.
Name | Gets and sets the name of Module.
Type | Gets the type of module.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

VbaModule Class | Aspose.Cells.Vba Namespace


VbaModule Properties

The properties of the VbaModule class are listed below. For a complete list of VbaModule class members, see the VbaModule Members topic.

Public Instance Properties

Codes | Gets and sets the codes of module.
Name | Gets and sets the name of Module.
Type | Gets the type of module.

See Also

VbaModule Class | Aspose.Cells.Vba Namespace


Codes Property

Aspose.Cells for .NET

VbaModule.Codes Property

Gets and sets the codes of module.

public string Codes {get; set;}

See Also

VbaModule Class | Aspose.Cells.Vba Namespace


Name Property

Aspose.Cells for .NET

VbaModule.Name Property

Gets and sets the name of Module.

public string Name {get; set;}

See Also

VbaModule Class | Aspose.Cells.Vba Namespace


Type Property

Aspose.Cells for .NET

VbaModule.Type Property

Gets the type of module.

public VbaModuleType Type {get;}

See Also

VbaModule Class | Aspose.Cells.Vba Namespace


VbaModuleCollection Class

Represents the list of VbaModule

For a list of all members of this type, see VbaModuleCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Vba.VbaModuleCollection

public class VbaModuleCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VbaModuleCollection Members | Aspose.Cells.Vba Namespace


VbaModuleCollection Members

VbaModuleCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets VbaModule in the list by the index.

Public Instance Methods

Add | Overloaded. Adds module for a worksheet.
AddDesignerStorage |
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetDesignerStorage | Represents the data of Designer.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Overloaded. Removes module for a worksheet.
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


VbaModuleCollection Properties

The properties of the VbaModuleCollection class are listed below. For a complete list of VbaModuleCollection class members, see the VbaModuleCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets VbaModule in the list by the index.

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


Item Property

Aspose.Cells for .NET

VbaModuleCollection.Item Property

Gets VbaModule in the list by the index.

Overload List

Gets VbaModule in the list by the index.

public VbaModule this[int] {get;}

Gets VbaModule in the list by the name.

public VbaModule this[string] {get;}

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


Item Property (Int32)

Aspose.Cells for .NET

VbaModuleCollection.Item Property (Int32)

Gets VbaModule in the list by the index.

public VbaModule this[
int index
] {get;}

Parameters

index
The index.

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace | VbaModuleCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

VbaModuleCollection.Item Property (String)

Gets VbaModule in the list by the name.

public VbaModule this[
string name
] {get;}

Parameters

name
The name of module.

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace | VbaModuleCollection.Item Overload List


VbaModuleCollection Methods

The methods of the VbaModuleCollection class are listed below. For a complete list of VbaModuleCollection class members, see the VbaModuleCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds module for a worksheet.
AddDesignerStorage |
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetDesignerStorage | Represents the data of Designer.
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Remove | Overloaded. Removes module for a worksheet.
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


Add Method

Aspose.Cells for .NET

VbaModuleCollection.Add Method

Adds module.

Overload List

Adds module.

public int Add(VbaModuleType,string);

Adds module for a worksheet.

public int Add(Worksheet);

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


VbaModuleCollection.Add Method (VbaModuleType, String)

Adds module.

public int Add(
VbaModuleType type,
string name
);

Parameters

type
The type of module.
name
The name of module.

Return Value

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace | VbaModuleCollection.Add Overload List


VbaModuleCollection.Add Method (Worksheet)

Adds module for a worksheet.

public int Add(
Worksheet sheet
);

Parameters

sheet
The worksheet

Return Value

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace | VbaModuleCollection.Add Overload List


VbaModuleCollection.AddDesignerStorage Method

public void AddDesignerStorage(
string name,
byte[] data
);

Parameters

name
data

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


VbaModuleCollection.GetDesignerStorage Method

Represents the data of Designer.

public byte[] GetDesignerStorage(
string name
);

Remarks

We do not support to parse them. Just only for copying.

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


Remove Method

Aspose.Cells for .NET

VbaModuleCollection.Remove Method

Removes module for a worksheet.

Overload List

Removes module for a worksheet.

public void Remove(Worksheet);

Remove the module by the name

public void Remove(string);

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace


VbaModuleCollection.Remove Method (Worksheet)

Removes module for a worksheet.

public void Remove(
Worksheet sheet
);

Parameters

sheet
The worksheet

Return Value

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace | VbaModuleCollection.Remove Overload List


VbaModuleCollection.Remove Method (String)

Remove the module by the name

public void Remove(
string name
);

Parameters

name

See Also

VbaModuleCollection Class | Aspose.Cells.Vba Namespace | VbaModuleCollection.Remove Overload List


VbaModuleType Enumeration

Represents the type of VBA module.

public enum VbaModuleType

Members

Member Name | Description | Value
Procedural | Represents a procedural module. | 0
Document | Represents a document module. | 1
Class | Represents a class module. | 2
Designer | Represents a designer module. | 3

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Vba Namespace


VbaProject Class

Represents the VBA project.

For a list of all members of this type, see VbaProject Members.

System.Object
Aspose.Cells.Vba.VbaProject

public class VbaProject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VbaProject Members | Aspose.Cells.Vba Namespace


VbaProject Members

VbaProject overview

Public Instance Properties

CertRawData | Gets certificate raw data if this VBA project is signed.
IslockedForViewing | Indicates whether this VBA project is locked for viewing.
IsProtected | Indicates whether this VBA project is protected.
IsSigned | Indicates whether VBAcode is signed or not.
IsValidSigned | Indicates whether the signature of VBA project is valid or not.
Modules | Gets all VbaModule objects.
Name | Gets and sets the name of the VBA project.
References | Gets all references of VBA project.

Public Instance Methods

Copy | Copy VBA project from other file.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Protect | Protects or unprotects this VBA project.
Sign | Sign this VBA project by a DigitalSignature
ToString (inherited from Object) |

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


VbaProject Properties

The properties of the VbaProject class are listed below. For a complete list of VbaProject class members, see the VbaProject Members topic.

Public Instance Properties

CertRawData | Gets certificate raw data if this VBA project is signed.
IslockedForViewing | Indicates whether this VBA project is locked for viewing.
IsProtected | Indicates whether this VBA project is protected.
IsSigned | Indicates whether VBAcode is signed or not.
IsValidSigned | Indicates whether the signature of VBA project is valid or not.
Modules | Gets all VbaModule objects.
Name | Gets and sets the name of the VBA project.
References | Gets all references of VBA project.

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


CertRawData Property

Aspose.Cells for .NET

VbaProject.CertRawData Property

Gets certificate raw data if this VBA project is signed.

public byte[] CertRawData {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


IslockedForViewing Property

Aspose.Cells for .NET

VbaProject.IslockedForViewing Property

Indicates whether this VBA project is locked for viewing.

public bool IslockedForViewing {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


IsProtected Property

Aspose.Cells for .NET

VbaProject.IsProtected Property

Indicates whether this VBA project is protected.

public bool IsProtected {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


IsSigned Property

Aspose.Cells for .NET

VbaProject.IsSigned Property

Indicates whether VBAcode is signed or not.

public bool IsSigned {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


IsValidSigned Property

Aspose.Cells for .NET

VbaProject.IsValidSigned Property

Indicates whether the signature of VBA project is valid or not.

public bool IsValidSigned {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


Modules Property

Aspose.Cells for .NET

VbaProject.Modules Property

Gets all VbaModule objects.

public VbaModuleCollection Modules {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


Name Property

Aspose.Cells for .NET

VbaProject.Name Property

Gets and sets the name of the VBA project.

public string Name {get; set;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


References Property

Aspose.Cells for .NET

VbaProject.References Property

Gets all references of VBA project.

public VbaProjectReferenceCollection References {get;}

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


VbaProject Methods

The methods of the VbaProject class are listed below. For a complete list of VbaProject class members, see the VbaProject Members topic.

Public Instance Methods

Copy | Copy VBA project from other file.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Protect | Protects or unprotects this VBA project.
Sign | Sign this VBA project by a DigitalSignature
ToString (inherited from Object) |

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


VbaProject.Copy Method

Copy VBA project from other file.

public void Copy(
VbaProject source
);

Parameters

source

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


VbaProject.Protect Method

Protects or unprotects this VBA project.

public void Protect(
bool islockedForViewing,
string password
);

Parameters

islockedForViewing
indicates whether locks project for viewing.
password
If the value is null, unprotects this VBA project, otherwise projects the this VBA project.

Remarks

If islockedForViewing is true, the password could not be null.

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


VbaProject.Sign Method

Sign this VBA project by a DigitalSignature

public void Sign(
DigitalSignature digitalSignature
);

Parameters

digitalSignature
DigitalSignature

See Also

VbaProject Class | Aspose.Cells.Vba Namespace


VbaProjectReference Class

Represents the reference of VBA project.

For a list of all members of this type, see VbaProjectReference Members.

System.Object
Aspose.Cells.Vba.VbaProjectReference

public class VbaProjectReference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VbaProjectReference Members | Aspose.Cells.Vba Namespace


VbaProjectReference Members

VbaProjectReference overview

Public Instance Properties

ExtendedLibid | Gets and sets the extended Libid of the reference.
Libid | Gets and sets the Libid of the reference.
Name | Gets and sets the name of the reference.
RelativeLibid | Gets and sets the referenced VBA project's identifier with an relative path.
Twiddledlibid | Gets and sets the twiddled Libid of the reference.
Type | Gets the type of this reference.

Public Instance Methods

Copy
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


VbaProjectReference Properties

The properties of the VbaProjectReference class are listed below. For a complete list of VbaProjectReference class members, see the VbaProjectReference Members topic.

Public Instance Properties

ExtendedLibid | Gets and sets the extended Libid of the reference.
Libid | Gets and sets the Libid of the reference.
Name | Gets and sets the name of the reference.
RelativeLibid | Gets and sets the referenced VBA project's identifier with an relative path.
Twiddledlibid | Gets and sets the twiddled Libid of the reference.
Type | Gets the type of this reference.

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


ExtendedLibid Property

Aspose.Cells for .NET

VbaProjectReference.ExtendedLibid Property

Gets and sets the extended Libid of the reference.

public string ExtendedLibid {get; set;}

Remarks

Only for control reference.

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


Libid Property

Aspose.Cells for .NET

VbaProjectReference.Libid Property

Gets and sets the Libid of the reference.

public string Libid {get; set;}

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


Name Property

Aspose.Cells for .NET

VbaProjectReference.Name Property

Gets and sets the name of the reference.

public string Name {get; set;}

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


RelativeLibid Property

Aspose.Cells for .NET

VbaProjectReference.RelativeLibid Property

Gets and sets the referenced VBA project's identifier with an relative path.

public string RelativeLibid {get; set;}

Remarks

Only for project reference.

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


Twiddledlibid Property

Aspose.Cells for .NET

VbaProjectReference.Twiddledlibid Property

Gets and sets the twiddled Libid of the reference.

public string Twiddledlibid {get; set;}

Remarks

Only for control reference.

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


Type Property

Aspose.Cells for .NET

VbaProjectReference.Type Property

Gets the type of this reference.

public VbaProjectReferenceType Type {get;}

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


VbaProjectReference Methods

The methods of the VbaProjectReference class are listed below. For a complete list of VbaProjectReference class members, see the VbaProjectReference Members topic.

Public Instance Methods

Copy
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


VbaProjectReference.Copy Method

public void Copy(
VbaProjectReference source
);

Parameters

source

See Also

VbaProjectReference Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection Class

Represents all references of VBA project.

For a list of all members of this type, see VbaProjectReferenceCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.Vba.VbaProjectReferenceCollection

public class VbaProjectReferenceCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

VbaProjectReferenceCollection Members | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection Members

VbaProjectReferenceCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Get the reference in the list by the index.

Public Instance Methods

AddControlRefrernce | Add a reference to a twiddled type library and its extended type library.
AddProjectRefrernce | Adds a reference to an external VBA project.
AddRegisteredReference | Add a reference to an Automation type library.
Clear (inherited from CollectionBase) |
Copy | Copies references from other VBA project.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection Properties

The properties of the VbaProjectReferenceCollection class are listed below. For a complete list of VbaProjectReferenceCollection class members, see the VbaProjectReferenceCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Get the reference in the list by the index.

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


Item Property

Aspose.Cells for .NET

VbaProjectReferenceCollection.Item Property

Get the reference in the list by the index.

public VbaProjectReference this[
int i
] {get;}

Parameters

i
The index.

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection Methods

The methods of the VbaProjectReferenceCollection class are listed below. For a complete list of VbaProjectReferenceCollection class members, see the VbaProjectReferenceCollection Members topic.

Public Instance Methods

AddControlRefrernce | Add a reference to a twiddled type library and its extended type library.
AddProjectRefrernce | Adds a reference to an external VBA project.
AddRegisteredReference | Add a reference to an Automation type library.
Clear (inherited from CollectionBase) |
Copy | Copies references from other VBA project.
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection.AddControlRefrernce Method

Add a reference to a twiddled type library and its extended type library.

public int AddControlRefrernce(
string name,
string libid,
string twiddledlibid,
string extendedLibid
);

Parameters

name
The name of reference.
libid
The identifier of an Automation type library.
twiddledlibid
The identifier of a twiddled type library
extendedLibid
The identifier of an extended type library

Return Value

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection.AddProjectRefrernce Method

Adds a reference to an external VBA project.

public int AddProjectRefrernce(
string name,
string absoluteLibid,
string relativeLibid
);

Parameters

name
The name of reference.
absoluteLibid
The referenced VBA project's identifier with an absolute path.
relativeLibid
The referenced VBA project's identifier with an relative path.

Return Value

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection.AddRegisteredReference Method

Add a reference to an Automation type library.

public int AddRegisteredReference(
string name,
string libid
);

Parameters

name
The name of reference.
libid
The identifier of an Automation type library.

Return Value

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceCollection.Copy Method

Copies references from other VBA project.

public void Copy(
VbaProjectReferenceCollection source
);

Parameters

source
The source references.

See Also

VbaProjectReferenceCollection Class | Aspose.Cells.Vba Namespace


VbaProjectReferenceType Enumeration

Represents the type of VBA project reference.

public enum VbaProjectReferenceType

Members

Member Name | Description | Value
Registered | Specifies a reference to an Automation type library. | 0
Control | Specifies a reference to a twiddled type library and its extended type library. | 1
Project | Specifies a reference to an external VBA project. | 2

Requirements

Namespace: Aspose.Cells.Vba

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.Vba Namespace


Aspose.Cells.WebExtensions

Aspose.Cells for .NET

Aspose.Cells.WebExtensions Namespace

Namespace hierarchy

Classes

Class | Description
WebExtension | Represents an Office Add-in instance.
WebExtensionBinding | Represents a binding relationship between an Office Add-in and the data in the document.
WebExtensionBindingCollection | Represents the list of binding relationships between an Office Add-in and the data in the document.
WebExtensionCollection | Represents the list of web extension.
WebExtensionProperty | Represents an Office Add-in custom property.
WebExtensionPropertyCollection | Represents the list of web extension properties.
WebExtensionReference | Represents identify the provider location and version of the extension.
WebExtensionReferenceCollection | Represents the list of web extension reference.
WebExtensionTaskPane | Represents a persisted taskpane object.
WebExtensionTaskPaneCollection | Represents the list of task pane.

Enumerations

Enumeration | Description
WebExtensionStoreType | Represents the store type of web extension.


WebExtension Class

Represents an Office Add-in instance.

For a list of all members of this type, see WebExtension Members.

System.Object
Aspose.Cells.WebExtensions.WebExtension

public class WebExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtension Members | Aspose.Cells.WebExtensions Namespace


WebExtension Members

WebExtension overview

Public Instance Properties

AlterReferences | Gets a list of alter references.
Bindings | Gets all bindings relationship between an Office Add-in and the data in the document.
Id | Gets and sets the uniquely identifies the Office Add-in instance in the current document.
IsFrozen | Indicates whether the user can interact with the Office Add-in or not.
Properties | Gets all properties of web extension.
Reference | Get the primary reference to an Office Add-in.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


WebExtension Properties

The properties of the WebExtension class are listed below. For a complete list of WebExtension class members, see the WebExtension Members topic.

Public Instance Properties

AlterReferences | Gets a list of alter references.
Bindings | Gets all bindings relationship between an Office Add-in and the data in the document.
Id | Gets and sets the uniquely identifies the Office Add-in instance in the current document.
IsFrozen | Indicates whether the user can interact with the Office Add-in or not.
Properties | Gets all properties of web extension.
Reference | Get the primary reference to an Office Add-in.

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


AlterReferences Property

Aspose.Cells for .NET

WebExtension.AlterReferences Property

Gets a list of alter references.

public WebExtensionReferenceCollection AlterReferences {get;}

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


Bindings Property

Aspose.Cells for .NET

WebExtension.Bindings Property

Gets all bindings relationship between an Office Add-in and the data in the document.

public WebExtensionBindingCollection Bindings {get;}

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


Id Property

Aspose.Cells for .NET

WebExtension.Id Property

Gets and sets the uniquely identifies the Office Add-in instance in the current document.

public string Id {get; set;}

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


IsFrozen Property

Aspose.Cells for .NET

WebExtension.IsFrozen Property

Indicates whether the user can interact with the Office Add-in or not.

public bool IsFrozen {get; set;}

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


Properties Property

Aspose.Cells for .NET

WebExtension.Properties Property

Gets all properties of web extension.

public WebExtensionPropertyCollection Properties {get;}

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


Reference Property

Aspose.Cells for .NET

WebExtension.Reference Property

Get the primary reference to an Office Add-in.

public WebExtensionReference Reference {get;}

See Also

WebExtension Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBinding Class

Represents a binding relationship between an Office Add-in and the data in the document.

For a list of all members of this type, see WebExtensionBinding Members.

System.Object
Aspose.Cells.WebExtensions.WebExtensionBinding

public class WebExtensionBinding

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionBinding Members | Aspose.Cells.WebExtensions Namespace


WebExtensionBinding Members

WebExtensionBinding overview

Public Instance Constructors

WebExtensionBinding Constructor Initializes a new instance of the WebExtensionBinding class.

Public Instance Properties

Appref | Gets and sets the binding key used to map the binding entry in this list with the bound data in the document.
Id | Gets and sets the binding identifier.
Type | Gets and sets the binding type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebExtensionBinding Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBinding Constructor

Initializes a new instance of the WebExtensionBinding class.

public WebExtensionBinding();

See Also

WebExtensionBinding Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBinding Properties

The properties of the WebExtensionBinding class are listed below. For a complete list of WebExtensionBinding class members, see the WebExtensionBinding Members topic.

Public Instance Properties

Appref | Gets and sets the binding key used to map the binding entry in this list with the bound data in the document.
Id | Gets and sets the binding identifier.
Type | Gets and sets the binding type.

See Also

WebExtensionBinding Class | Aspose.Cells.WebExtensions Namespace


Appref Property

Aspose.Cells for .NET

WebExtensionBinding.Appref Property

Gets and sets the binding key used to map the binding entry in this list with the bound data in the document.

public string Appref {get; set;}

See Also

WebExtensionBinding Class | Aspose.Cells.WebExtensions Namespace


Id Property

Aspose.Cells for .NET

WebExtensionBinding.Id Property

Gets and sets the binding identifier.

public string Id {get; set;}

See Also

WebExtensionBinding Class | Aspose.Cells.WebExtensions Namespace


Type Property

Aspose.Cells for .NET

WebExtensionBinding.Type Property

Gets and sets the binding type.

public string Type {get; set;}

See Also

WebExtensionBinding Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBindingCollection Class

Represents the list of binding relationships between an Office Add-in and the data in the document.

For a list of all members of this type, see WebExtensionBindingCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.WebExtensions.WebExtensionBindingCollection

public class WebExtensionBindingCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionBindingCollection Members | Aspose.Cells.WebExtensions Namespace


WebExtensionBindingCollection Members

WebExtensionBindingCollection overview

Public Instance Constructors

WebExtensionBindingCollection Constructor Initializes a new instance of the WebExtensionBindingCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets web extension binding relationship by the specific index.

Public Instance Methods

Add | Adds an a binding relationship between an Office Add-in and the data in the document.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

WebExtensionBindingCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBindingCollection Constructor

Initializes a new instance of the WebExtensionBindingCollection class.

public WebExtensionBindingCollection();

See Also

WebExtensionBindingCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBindingCollection Properties

The properties of the WebExtensionBindingCollection class are listed below. For a complete list of WebExtensionBindingCollection class members, see the WebExtensionBindingCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets web extension binding relationship by the specific index.

See Also

WebExtensionBindingCollection Class | Aspose.Cells.WebExtensions Namespace


Item Property

Aspose.Cells for .NET

WebExtensionBindingCollection.Item Property

Gets web extension binding relationship by the specific index.

public WebExtensionBinding this[
int index
] {get;}

Parameters

index
The index.

See Also

WebExtensionBindingCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBindingCollection Methods

The methods of the WebExtensionBindingCollection class are listed below. For a complete list of WebExtensionBindingCollection class members, see the WebExtensionBindingCollection Members topic.

Public Instance Methods

Add | Adds an a binding relationship between an Office Add-in and the data in the document.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

WebExtensionBindingCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionBindingCollection.Add Method

Adds an a binding relationship between an Office Add-in and the data in the document.

public int Add();

Return Value

See Also

WebExtensionBindingCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionCollection Class

Represents the list of web extension.

For a list of all members of this type, see WebExtensionCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.WebExtensions.WebExtensionCollection

public class WebExtensionCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionCollection Members | Aspose.Cells.WebExtensions Namespace


WebExtensionCollection Members

WebExtensionCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets web extension by the specific index.

Public Instance Methods

Add | Adds a web extension.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove web extension by the index.
ToString (inherited from Object) |

See Also

WebExtensionCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionCollection Properties

The properties of the WebExtensionCollection class are listed below. For a complete list of WebExtensionCollection class members, see the WebExtensionCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets web extension by the specific index.

See Also

WebExtensionCollection Class | Aspose.Cells.WebExtensions Namespace


Item Property

Aspose.Cells for .NET

WebExtensionCollection.Item Property

Gets web extension by the specific index.

public WebExtension this[
int index
] {get;}

Parameters

index
The index.

See Also

WebExtensionCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionCollection Methods

The methods of the WebExtensionCollection class are listed below. For a complete list of WebExtensionCollection class members, see the WebExtensionCollection Members topic.

Public Instance Methods

Add | Adds a web extension.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Remove web extension by the index.
ToString (inherited from Object) |

See Also

WebExtensionCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionCollection.Add Method

Adds a web extension.

public int Add();

Return Value

The index.

See Also

WebExtensionCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionCollection.RemoveAt Method

Remove web extension by the index.

new public void RemoveAt(
int index
);

Parameters

index
The index.

Implements

IList.RemoveAt

See Also

WebExtensionCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionProperty Class

Represents an Office Add-in custom property.

For a list of all members of this type, see WebExtensionProperty Members.

System.Object
Aspose.Cells.WebExtensions.WebExtensionProperty

public class WebExtensionProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionProperty Members | Aspose.Cells.WebExtensions Namespace


WebExtensionProperty Members

WebExtensionProperty overview

Public Instance Properties

Name | Gets and set a custom property name.
Value | Gets and sets a custom property value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebExtensionProperty Class | Aspose.Cells.WebExtensions Namespace


WebExtensionProperty Properties

The properties of the WebExtensionProperty class are listed below. For a complete list of WebExtensionProperty class members, see the WebExtensionProperty Members topic.

Public Instance Properties

Name | Gets and set a custom property name.
Value | Gets and sets a custom property value.

See Also

WebExtensionProperty Class | Aspose.Cells.WebExtensions Namespace


Name Property

Aspose.Cells for .NET

WebExtensionProperty.Name Property

Gets and set a custom property name.

public string Name {get; set;}

See Also

WebExtensionProperty Class | Aspose.Cells.WebExtensions Namespace


Value Property

Aspose.Cells for .NET

WebExtensionProperty.Value Property

Gets and sets a custom property value.

public string Value {get; set;}

See Also

WebExtensionProperty Class | Aspose.Cells.WebExtensions Namespace


WebExtensionPropertyCollection Class

Represents the list of web extension properties.

For a list of all members of this type, see WebExtensionPropertyCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.WebExtensions.WebExtensionPropertyCollection

public class WebExtensionPropertyCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionPropertyCollection Members | Aspose.Cells.WebExtensions Namespace


WebExtensionPropertyCollection Members

WebExtensionPropertyCollection overview

Public Instance Constructors

WebExtensionPropertyCollection Constructor Initializes a new instance of the WebExtensionPropertyCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the property of web extension by the index.

Public Instance Methods

Add | Adds web extension property.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Overloaded. Remove the property by the name.
RemoveAt (inherited from CollectionBase) | Overloaded.
ToString (inherited from Object) |

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionPropertyCollection Constructor

Initializes a new instance of the WebExtensionPropertyCollection class.

public WebExtensionPropertyCollection();

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionPropertyCollection Properties

The properties of the WebExtensionPropertyCollection class are listed below. For a complete list of WebExtensionPropertyCollection class members, see the WebExtensionPropertyCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Overloaded. Gets the property of web extension by the index.

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


Item Property

Aspose.Cells for .NET

WebExtensionPropertyCollection.Item Property

Gets the property of web extension by the index.

Overload List

Gets the property of web extension by the index.

public WebExtensionProperty this[int] {get;}

Gets the property of web extension.

public WebExtensionProperty this[string] {get;}

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


Item Property (Int32)

Aspose.Cells for .NET

WebExtensionPropertyCollection.Item Property (Int32)

Gets the property of web extension by the index.

public WebExtensionProperty this[
int index
] {get;}

Parameters

index
The index.

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace | WebExtensionPropertyCollection.Item Overload List


Item Property (String)

Aspose.Cells for .NET

WebExtensionPropertyCollection.Item Property (String)

Gets the property of web extension.

public WebExtensionProperty this[
string name
] {get;}

Parameters

name
The name of property.

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace | WebExtensionPropertyCollection.Item Overload List


WebExtensionPropertyCollection Methods

The methods of the WebExtensionPropertyCollection class are listed below. For a complete list of WebExtensionPropertyCollection class members, see the WebExtensionPropertyCollection Members topic.

Public Instance Methods

Add | Adds web extension property.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt | Overloaded. Remove the property by the name.
RemoveAt (inherited from CollectionBase) | Overloaded.
ToString (inherited from Object) |

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionPropertyCollection.Add Method

Adds web extension property.

public int Add(
string name,
string value
);

Parameters

name
The name of property.
value
The value of property.

Return Value

The index of added property.

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


RemoveAt Method

Aspose.Cells for .NET

WebExtensionPropertyCollection.RemoveAt Method

Remove the property by the name.

Overload List

Inherited from CollectionBase.

public void RemoveAt(int);

Remove the property by the name.

public void RemoveAt(string);

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionPropertyCollection.RemoveAt Method (String)

Remove the property by the name.

public void RemoveAt(
string name
);

Parameters

name
The name of the property.

See Also

WebExtensionPropertyCollection Class | Aspose.Cells.WebExtensions Namespace | WebExtensionPropertyCollection.RemoveAt Overload List


WebExtensionReference Class

Represents identify the provider location and version of the extension.

For a list of all members of this type, see WebExtensionReference Members.

System.Object
Aspose.Cells.WebExtensions.WebExtensionReference

public class WebExtensionReference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionReference Members | Aspose.Cells.WebExtensions Namespace


WebExtensionReference Members

WebExtensionReference overview

Public Instance Properties

Id | Gets and sets the identifier associated with the Office Add-in within a catalog provider. The identifier MUST be unique within a catalog provider.
StoreName | Gets and sets the instance of the marketplace where the Office Add-in is stored. .
StoreType | Gets and sets the type of marketplace that the store attribute identifies.
Version | Gets and sets the version.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebExtensionReference Class | Aspose.Cells.WebExtensions Namespace


WebExtensionReference Properties

The properties of the WebExtensionReference class are listed below. For a complete list of WebExtensionReference class members, see the WebExtensionReference Members topic.

Public Instance Properties

Id | Gets and sets the identifier associated with the Office Add-in within a catalog provider. The identifier MUST be unique within a catalog provider.
StoreName | Gets and sets the instance of the marketplace where the Office Add-in is stored. .
StoreType | Gets and sets the type of marketplace that the store attribute identifies.
Version | Gets and sets the version.

See Also

WebExtensionReference Class | Aspose.Cells.WebExtensions Namespace


Id Property

Aspose.Cells for .NET

WebExtensionReference.Id Property

Gets and sets the identifier associated with the Office Add-in within a catalog provider. The identifier MUST be unique within a catalog provider.

public string Id {get; set;}

See Also

WebExtensionReference Class | Aspose.Cells.WebExtensions Namespace


StoreName Property

Aspose.Cells for .NET

WebExtensionReference.StoreName Property

Gets and sets the instance of the marketplace where the Office Add-in is stored. .

public string StoreName {get; set;}

See Also

WebExtensionReference Class | Aspose.Cells.WebExtensions Namespace


StoreType Property

Aspose.Cells for .NET

WebExtensionReference.StoreType Property

Gets and sets the type of marketplace that the store attribute identifies.

public WebExtensionStoreType StoreType {get; set;}

See Also

WebExtensionReference Class | Aspose.Cells.WebExtensions Namespace


Version Property

Aspose.Cells for .NET

WebExtensionReference.Version Property

Gets and sets the version.

public string Version {get; set;}

See Also

WebExtensionReference Class | Aspose.Cells.WebExtensions Namespace


WebExtensionReferenceCollection Class

Represents the list of web extension reference.

For a list of all members of this type, see WebExtensionReferenceCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.WebExtensions.WebExtensionReferenceCollection

public class WebExtensionReferenceCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionReferenceCollection Members | Aspose.Cells.WebExtensions Namespace


WebExtensionReferenceCollection Members

WebExtensionReferenceCollection overview

Public Instance Constructors

WebExtensionReferenceCollection Constructor Initializes a new instance of the WebExtensionReferenceCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets web extension by the specific index.

Public Instance Methods

Add | Adds an empty reference of web extension.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

WebExtensionReferenceCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionReferenceCollection Constructor

Initializes a new instance of the WebExtensionReferenceCollection class.

public WebExtensionReferenceCollection();

See Also

WebExtensionReferenceCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionReferenceCollection Properties

The properties of the WebExtensionReferenceCollection class are listed below. For a complete list of WebExtensionReferenceCollection class members, see the WebExtensionReferenceCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets web extension by the specific index.

See Also

WebExtensionReferenceCollection Class | Aspose.Cells.WebExtensions Namespace


Item Property

Aspose.Cells for .NET

WebExtensionReferenceCollection.Item Property

Gets web extension by the specific index.

public WebExtensionReference this[
int index
] {get;}

Parameters

index
The index.

See Also

WebExtensionReferenceCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionReferenceCollection Methods

The methods of the WebExtensionReferenceCollection class are listed below. For a complete list of WebExtensionReferenceCollection class members, see the WebExtensionReferenceCollection Members topic.

Public Instance Methods

Add | Adds an empty reference of web extension.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

WebExtensionReferenceCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionReferenceCollection.Add Method

Adds an empty reference of web extension.

public int Add();

Return Value

See Also

WebExtensionReferenceCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionStoreType Enumeration

Represents the store type of web extension.

public enum WebExtensionStoreType

Members

Member Name | Description | Value
OMEX | Specifies that the store type is Office.com. | 0
SPCatalog | Specifies that the store type is SharePoint corporate catalog. | 1
SPApp | Specifies that the store type is a SharePoint web application. | 2
Exchange | Specifies that the store type is an Exchange server. | 3
FileSystem | Specifies that the store type is a file system share. | 4
Registry | Specifies that the store type is the system registry. | 5
ExCatalog | Specifies that the store type is Centralized Deployment via Exchange. | 6

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPane Class

Represents a persisted taskpane object.

For a list of all members of this type, see WebExtensionTaskPane Members.

System.Object
Aspose.Cells.WebExtensions.WebExtensionTaskPane

public class WebExtensionTaskPane

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionTaskPane Members | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPane Members

WebExtensionTaskPane overview

Public Instance Properties

DockState | Gets and sets the last-docked location of this taskpane object.
IsLocked | Indicates whether the taskpane is locked to the document in the UI and cannot be closed by the user.
IsVisible | Indicates whether the Task Pane shows as visible by default when the document opens.
Row | Gets and sets the index, enumerating from the outside to the inside, of this taskpane among other persisted taskpanes docked in the same default location.
WebExtension | Gets and sets the web extension part associated with the taskpane instance
Width | Gets and sets the default width value for this taskpane instance.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPane Properties

The properties of the WebExtensionTaskPane class are listed below. For a complete list of WebExtensionTaskPane class members, see the WebExtensionTaskPane Members topic.

Public Instance Properties

DockState | Gets and sets the last-docked location of this taskpane object.
IsLocked | Indicates whether the taskpane is locked to the document in the UI and cannot be closed by the user.
IsVisible | Indicates whether the Task Pane shows as visible by default when the document opens.
Row | Gets and sets the index, enumerating from the outside to the inside, of this taskpane among other persisted taskpanes docked in the same default location.
WebExtension | Gets and sets the web extension part associated with the taskpane instance
Width | Gets and sets the default width value for this taskpane instance.

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


DockState Property

Aspose.Cells for .NET

WebExtensionTaskPane.DockState Property

Gets and sets the last-docked location of this taskpane object.

public string DockState {get; set;}

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


IsLocked Property

Aspose.Cells for .NET

WebExtensionTaskPane.IsLocked Property

Indicates whether the taskpane is locked to the document in the UI and cannot be closed by the user.

public bool IsLocked {get; set;}

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


IsVisible Property

Aspose.Cells for .NET

WebExtensionTaskPane.IsVisible Property

Indicates whether the Task Pane shows as visible by default when the document opens.

public bool IsVisible {get; set;}

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


Row Property

Aspose.Cells for .NET

WebExtensionTaskPane.Row Property

Gets and sets the index, enumerating from the outside to the inside, of this taskpane among other persisted taskpanes docked in the same default location.

public int Row {get; set;}

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


WebExtension Property

Aspose.Cells for .NET

WebExtensionTaskPane.WebExtension Property

Gets and sets the web extension part associated with the taskpane instance

public WebExtension WebExtension {get; set;}

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


Width Property

Aspose.Cells for .NET

WebExtensionTaskPane.Width Property

Gets and sets the default width value for this taskpane instance.

public double Width {get; set;}

See Also

WebExtensionTaskPane Class | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPaneCollection Class

Represents the list of task pane.

For a list of all members of this type, see WebExtensionTaskPaneCollection Members.

System.Object
System.Collections.CollectionBase
Aspose.Cells.WebExtensions.WebExtensionTaskPaneCollection

public class WebExtensionTaskPaneCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Cells.WebExtensions

Assembly: Aspose.Cells (in Aspose.Cells.dll)

See Also

WebExtensionTaskPaneCollection Members | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPaneCollection Members

WebExtensionTaskPaneCollection overview

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets task pane by the specific index.

Public Instance Methods

Add | Adds task pane.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

WebExtensionTaskPaneCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPaneCollection Properties

The properties of the WebExtensionTaskPaneCollection class are listed below. For a complete list of WebExtensionTaskPaneCollection class members, see the WebExtensionTaskPaneCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Gets task pane by the specific index.

See Also

WebExtensionTaskPaneCollection Class | Aspose.Cells.WebExtensions Namespace


Item Property

Aspose.Cells for .NET

WebExtensionTaskPaneCollection.Item Property

Gets task pane by the specific index.

public WebExtensionTaskPane this[
int index
] {get;}

Parameters

index
The index.

See Also

WebExtensionTaskPaneCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPaneCollection Methods

The methods of the WebExtensionTaskPaneCollection class are listed below. For a complete list of WebExtensionTaskPaneCollection class members, see the WebExtensionTaskPaneCollection Members topic.

Public Instance Methods

Add | Adds task pane.
Clear (inherited from CollectionBase) |
Equals (inherited from Object) |
GetEnumerator (inherited from CollectionBase) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
RemoveAt (inherited from CollectionBase) |
ToString (inherited from Object) |

See Also

WebExtensionTaskPaneCollection Class | Aspose.Cells.WebExtensions Namespace


WebExtensionTaskPaneCollection.Add Method

Adds task pane.

public int Add();

Return Value

The index.

See Also

WebExtensionTaskPaneCollection Class | Aspose.Cells.WebExtensions Namespace


Aspose.Cells.ChartsHierarchy

Aspose.Cells for .NET

Aspose.Cells.Charts Hierarchy

System.Object
Aspose.Cells.Charts.Axis
Aspose.Cells.Charts.Chart
Aspose.Cells.Charts.ChartDataTable
Aspose.Cells.Charts.ChartFrame
Aspose.Cells.Charts.ChartArea
Aspose.Cells.Charts.ChartTextFrame
Aspose.Cells.Charts.DataLabels
Aspose.Cells.Charts.DisplayUnitLabel
Aspose.Cells.Charts.Title
Aspose.Cells.Charts.Legend
Aspose.Cells.Charts.PlotArea
Aspose.Cells.Charts.ChartPoint
Aspose.Cells.Charts.ChartPointCollection
Aspose.Cells.Charts.DropBars
Aspose.Cells.Charts.LegendEntry
Aspose.Cells.Charts.Marker
Aspose.Cells.Charts.PivotOptions
Aspose.Cells.Charts.Series
Aspose.Cells.Charts.SeriesLayoutProperties
Aspose.Cells.Charts.Sparkline
Aspose.Cells.Charts.SparklineGroup
Aspose.Cells.Charts.TickLabels
Aspose.Cells.Drawing.Area
Aspose.Cells.Charts.Floor
Aspose.Cells.Charts.Walls
Aspose.Cells.Drawing.Line
Aspose.Cells.Charts.ErrorBar
Aspose.Cells.Charts.Trendline
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Charts.ChartCollection
Aspose.Cells.Charts.LegendEntryCollection
Aspose.Cells.Charts.SeriesCollection
Aspose.Cells.Charts.SparklineCollection
Aspose.Cells.Charts.SparklineGroupCollection
Aspose.Cells.Charts.TrendlineCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Charts.AxisType
Aspose.Cells.Charts.BackgroundMode
Aspose.Cells.Charts.Bar3DShapeType
Aspose.Cells.Charts.BubbleSizeRepresents
Aspose.Cells.Charts.CategoryType
Aspose.Cells.Charts.ChartLineFormattingType
Aspose.Cells.Charts.ChartMarkerType
Aspose.Cells.Charts.ChartSplitType
Aspose.Cells.Charts.ChartTextDirectionType
Aspose.Cells.Charts.ChartType
Aspose.Cells.Charts.CrossType
Aspose.Cells.Charts.DataLabelsSeparatorType
Aspose.Cells.Charts.DataLablesSeparatorType
Aspose.Cells.Charts.DisplayUnitType
Aspose.Cells.Charts.ErrorBarDisplayType
Aspose.Cells.Charts.ErrorBarType
Aspose.Cells.Charts.FormattingType
Aspose.Cells.Charts.LabelPositionType
Aspose.Cells.Charts.LegendPositionType
Aspose.Cells.Charts.MapChartLabelLayout
Aspose.Cells.Charts.MapChartProjectionType
Aspose.Cells.Charts.MapChartRegionType
Aspose.Cells.Charts.PlotDataByType
Aspose.Cells.Charts.PlotEmptyCellsType
Aspose.Cells.Charts.QuartileCalculationType
Aspose.Cells.Charts.SparklineAxisMinMaxType
Aspose.Cells.Charts.SparklinePresetStyleType
Aspose.Cells.Charts.SparklineType
Aspose.Cells.Charts.TickLabelPositionType
Aspose.Cells.Charts.TickMarkType
Aspose.Cells.Charts.TimeUnit
Aspose.Cells.Charts.TrendlineType

See Also

Aspose.Cells.Charts Namespace


Aspose.Cells.DigitalSignaturesHierarchy

Aspose.Cells for .NET

Aspose.Cells.DigitalSignatures Hierarchy

System.Object
Aspose.Cells.DigitalSignatures.DigitalSignature
Aspose.Cells.DigitalSignatures.DigitalSignatureCollection ---- System.Collections.IEnumerable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.DigitalSignatures.XAdESType

See Also

Aspose.Cells.DigitalSignatures Namespace


ActiveXControl Hierarchy

System.Object
ActiveXControlBase
ActiveXControl
CheckBoxActiveXControl
ComboBoxActiveXControl
CommandButtonActiveXControl
ImageActiveXControl
LabelActiveXControl
ListBoxActiveXControl
SpinButtonActiveXControl
TextBoxActiveXControl
ToggleButtonActiveXControl
UnknownControl

See Also

ActiveXControl Class | ActiveXControl Members | Aspose.Cells.Drawing.ActiveXControls Namespace


Aspose.Cells.Drawing.ActiveXControlsHierarchy

Aspose.Cells for .NET

Aspose.Cells.Drawing.ActiveXControls Hierarchy

System.Object
Aspose.Cells.Drawing.ActiveXControls.ActiveXControlBase
Aspose.Cells.Drawing.ActiveXControls.ActiveXControl
Aspose.Cells.Drawing.ActiveXControls.CheckBoxActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ComboBoxActiveXControl
Aspose.Cells.Drawing.ActiveXControls.CommandButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ImageActiveXControl
Aspose.Cells.Drawing.ActiveXControls.LabelActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ListBoxActiveXControl
Aspose.Cells.Drawing.ActiveXControls.SpinButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ScrollBarActiveXControl
Aspose.Cells.Drawing.ActiveXControls.TextBoxActiveXControl
Aspose.Cells.Drawing.ActiveXControls.ToggleButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.RadioButtonActiveXControl
Aspose.Cells.Drawing.ActiveXControls.UnknownControl
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Drawing.ActiveXControls.ActiveXPersistenceType
Aspose.Cells.Drawing.ActiveXControls.ControlBorderType
Aspose.Cells.Drawing.ActiveXControls.ControlCaptionAlignmentType
Aspose.Cells.Drawing.ActiveXControls.ControlListStyle
Aspose.Cells.Drawing.ActiveXControls.ControlMatchEntryType
Aspose.Cells.Drawing.ActiveXControls.ControlMousePointerType
Aspose.Cells.Drawing.ActiveXControls.ControlPictureAlignmentType
Aspose.Cells.Drawing.ActiveXControls.ControlPicturePositionType
Aspose.Cells.Drawing.ActiveXControls.ControlPictureSizeMode
Aspose.Cells.Drawing.ActiveXControls.ControlScrollBarType
Aspose.Cells.Drawing.ActiveXControls.ControlScrollOrientation
Aspose.Cells.Drawing.ActiveXControls.ControlSpecialEffectType
Aspose.Cells.Drawing.ActiveXControls.ControlType
Aspose.Cells.Drawing.ActiveXControls.DropButtonStyle
Aspose.Cells.Drawing.ActiveXControls.InputMethodEditorMode
Aspose.Cells.Drawing.ActiveXControls.ShowDropButtonType

See Also

Aspose.Cells.Drawing.ActiveXControls Namespace


Fill Hierarchy

System.Object
Fill
AutomaticFill
GradientFill
GroupFill
NoneFill
PatternFill
SolidFill
TextureFill

See Also

Fill Class | Fill Members | Aspose.Cells.Drawing Namespace


Shape Hierarchy

System.Object
Shape
ArcShape
Button
CellsDrawing
ChartShape
CheckBox
ComboBox
CommentShape
CustomXmlShape
DialogBox
GroupBox
GroupShape
Label
LineShape
ListBox
OleObject
Oval
Picture
RadioButton
RectangleShape
ScrollBar
SmartArtShape
Spinner
TextBox
WebExtensionShape

See Also

Shape Class | Shape Members | Aspose.Cells.Drawing Namespace


Aspose.Cells.Drawing.TextsHierarchy

Aspose.Cells for .NET

Aspose.Cells.Drawing.Texts Hierarchy

System.Object
Aspose.Cells.Drawing.Texts.Bullet
Aspose.Cells.Drawing.Texts.BulletValue
Aspose.Cells.Drawing.Texts.AutoNumberedBulletValue
Aspose.Cells.Drawing.Texts.CharacterBulletValue
Aspose.Cells.Drawing.Texts.NoneBulletValue
Aspose.Cells.Drawing.Texts.PictureBulletValue
Aspose.Cells.Drawing.Texts.ShapeTextAlignment
Aspose.Cells.Drawing.Texts.TextParagraphCollection
Aspose.Cells.Drawing.Texts.TextTabStop
Aspose.Cells.Font
Aspose.Cells.Drawing.Texts.TextOptions
Aspose.Cells.FontSetting
Aspose.Cells.Drawing.Texts.TextParagraph
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Drawing.Texts.FontSettingCollection
Aspose.Cells.Drawing.Texts.TextTabStopCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Drawing.Texts.BulletType
Aspose.Cells.Drawing.Texts.LineSpaceSizeType
Aspose.Cells.Drawing.Texts.TextAutonumberScheme
Aspose.Cells.Drawing.Texts.TextFontAlignType
Aspose.Cells.Drawing.Texts.TextNodeType
Aspose.Cells.Drawing.Texts.TextTabAlignmentType
Aspose.Cells.Drawing.Texts.TextVerticalType

See Also

Aspose.Cells.Drawing.Texts Namespace


Aspose.Cells.DrawingHierarchy

Aspose.Cells for .NET

Aspose.Cells.Drawing Hierarchy

System.Object
Aspose.Cells.Drawing.Area
Aspose.Cells.Drawing.Bevel
Aspose.Cells.Drawing.ColorHelper
Aspose.Cells.Drawing.Fill
Aspose.Cells.Drawing.AutomaticFill
Aspose.Cells.Drawing.GradientFill
Aspose.Cells.Drawing.GroupFill
Aspose.Cells.Drawing.NoneFill
Aspose.Cells.Drawing.PatternFill
Aspose.Cells.Drawing.SolidFill
Aspose.Cells.Drawing.TextureFill
Aspose.Cells.Drawing.FillFormat
Aspose.Cells.Drawing.LineFormat
Aspose.Cells.Drawing.Format3D
Aspose.Cells.Drawing.Geometry
Aspose.Cells.Drawing.CustomGeometry
Aspose.Cells.Drawing.GlowEffect
Aspose.Cells.Drawing.GradientStop
Aspose.Cells.Drawing.Line
Aspose.Cells.Drawing.MsoFillFormat
Aspose.Cells.Drawing.MsoFillFormatHelper
Aspose.Cells.Drawing.MsoFormatPicture
Aspose.Cells.Drawing.MsoLineFormat
Aspose.Cells.Drawing.MsoLineFormatHelper
Aspose.Cells.Drawing.MsoTextFrame
Aspose.Cells.Drawing.PicFormatOption
Aspose.Cells.Drawing.ReflectionEffect
Aspose.Cells.Drawing.ShadowEffect
Aspose.Cells.Drawing.Shape
Aspose.Cells.Drawing.ArcShape
Aspose.Cells.Drawing.Button
Aspose.Cells.Drawing.CellsDrawing
Aspose.Cells.Drawing.ChartShape
Aspose.Cells.Drawing.CheckBox
Aspose.Cells.Drawing.ComboBox
Aspose.Cells.Drawing.CommentShape
Aspose.Cells.Drawing.CustomXmlShape
Aspose.Cells.Drawing.DialogBox
Aspose.Cells.Drawing.GroupBox
Aspose.Cells.Drawing.GroupShape
Aspose.Cells.Drawing.Label
Aspose.Cells.Drawing.LineShape
Aspose.Cells.Drawing.ListBox
Aspose.Cells.Drawing.OleObject
Aspose.Cells.Drawing.Oval
Aspose.Cells.Drawing.Picture
Aspose.Cells.Drawing.RadioButton
Aspose.Cells.Drawing.RectangleShape
Aspose.Cells.Drawing.ScrollBar
Aspose.Cells.Drawing.SmartArtShape
Aspose.Cells.Drawing.Spinner
Aspose.Cells.Drawing.TextBox
Aspose.Cells.Drawing.WebExtensionShape
Aspose.Cells.Drawing.ShapeFormat
Aspose.Cells.Drawing.ShapeGuide
Aspose.Cells.Drawing.ShapePath
Aspose.Cells.Drawing.ShapePathPoint
Aspose.Cells.Drawing.ShapePropertyCollection
Aspose.Cells.Drawing.ShapeSegmentPath
Aspose.Cells.Drawing.SignatureLine
Aspose.Cells.Drawing.TextEffectFormat
Aspose.Cells.Drawing.ThreeDFormat
Aspose.Cells.Drawing.TilePicOption
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Drawing.CheckBoxCollection
Aspose.Cells.Drawing.GradientStopCollection
Aspose.Cells.Drawing.OleObjectCollection
Aspose.Cells.Drawing.PictureCollection
Aspose.Cells.Drawing.ShapeCollection
Aspose.Cells.Drawing.ShapeGuideCollection
Aspose.Cells.Drawing.ShapePathCollection
Aspose.Cells.Drawing.ShapePathPointCollection
Aspose.Cells.Drawing.ShapeSegmentPathCollection
Aspose.Cells.Drawing.TextBoxCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Drawing.AutoShapeType
Aspose.Cells.Drawing.BevelPresetType
Aspose.Cells.Drawing.BevelType
Aspose.Cells.Drawing.CheckValueType
Aspose.Cells.Drawing.DataLabelShapeType
Aspose.Cells.Drawing.FillPattern
Aspose.Cells.Drawing.FillPictureType
Aspose.Cells.Drawing.FillType
Aspose.Cells.Drawing.FormatSetType
Aspose.Cells.Drawing.GradientColorType
Aspose.Cells.Drawing.GradientDirectionType
Aspose.Cells.Drawing.GradientFillType
Aspose.Cells.Drawing.GradientPresetType
Aspose.Cells.Drawing.GradientStyleType
Aspose.Cells.Drawing.ImageType
Aspose.Cells.Drawing.LightRigDirectionType
Aspose.Cells.Drawing.LightRigType
Aspose.Cells.Drawing.LineCapType
Aspose.Cells.Drawing.LineJoinType
Aspose.Cells.Drawing.LineType
Aspose.Cells.Drawing.MirrorType
Aspose.Cells.Drawing.MsoArrowheadLength
Aspose.Cells.Drawing.MsoArrowheadStyle
Aspose.Cells.Drawing.MsoArrowheadWidth
Aspose.Cells.Drawing.MsoDrawingType
Aspose.Cells.Drawing.MsoLineDashStyle
Aspose.Cells.Drawing.MsoLineStyle
Aspose.Cells.Drawing.MsoPresetTextEffect
Aspose.Cells.Drawing.MsoPresetTextEffectShape
Aspose.Cells.Drawing.OleFileType
Aspose.Cells.Drawing.PlacementType
Aspose.Cells.Drawing.PresetCameraType
Aspose.Cells.Drawing.PresetMaterialType
Aspose.Cells.Drawing.PresetShadowType
Aspose.Cells.Drawing.PresetWordArtStyle
Aspose.Cells.Drawing.RectangleAlignmentType
Aspose.Cells.Drawing.ReflectionEffectType
Aspose.Cells.Drawing.SelectionType
Aspose.Cells.Drawing.ShapeLockType
Aspose.Cells.Drawing.ShapePathType
Aspose.Cells.Drawing.TextOverflowType
Aspose.Cells.Drawing.TextureType
Aspose.Cells.Drawing.WeightType

See Also

Aspose.Cells.Drawing Namespace


Aspose.Cells.ExternalConnectionsHierarchy

Aspose.Cells for .NET

Aspose.Cells.ExternalConnections Hierarchy

System.Object
Aspose.Cells.ExternalConnections.ConnectionParameter
Aspose.Cells.ExternalConnections.ExternalConnection
Aspose.Cells.ExternalConnections.DBConnection
Aspose.Cells.ExternalConnections.WebQueryConnection
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.ExternalConnections.ConnectionParameterCollection
Aspose.Cells.ExternalConnections.ExternalConnectionCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.ExternalConnections.ConnectionDataSourceType
Aspose.Cells.ExternalConnections.ConnectionParameterType
Aspose.Cells.ExternalConnections.CredentialsMethodType
Aspose.Cells.ExternalConnections.HtmlFormatHandlingType
Aspose.Cells.ExternalConnections.OLEDBCommandType
Aspose.Cells.ExternalConnections.ReConnectionMethodType
Aspose.Cells.ExternalConnections.SqlDataType

See Also

Aspose.Cells.ExternalConnections Namespace


Aspose.Cells.GridDesktop.DataHierarchy

Aspose.Cells for .NET

Aspose.Cells.GridDesktop.Data Hierarchy

System.Object
Aspose.Cells.GridDesktop.Data.DefaultEmptyStyle
Aspose.Cells.GridDesktop.Data.GridCellArea
Aspose.Cells.GridDesktop.Data.GridCells ---- System.Collections.IEnumerable
Aspose.Cells.GridDesktop.Data.GridColumn
Aspose.Cells.GridDesktop.Data.GridColumnCollection
Aspose.Cells.GridDesktop.Data.GridComment
Aspose.Cells.GridDesktop.Data.GridCommentCollection
Aspose.Cells.GridDesktop.Data.GridFont
Aspose.Cells.GridDesktop.Data.GridHyperlink
Aspose.Cells.GridDesktop.Data.GridHyperlinkCollection
Aspose.Cells.GridDesktop.Data.GridName
Aspose.Cells.GridDesktop.Data.GridNameCollection
Aspose.Cells.GridDesktop.Data.GridPicture
Aspose.Cells.GridDesktop.Data.GridPictureCollection
Aspose.Cells.GridDesktop.Data.GridPivotField
Aspose.Cells.GridDesktop.Data.GridPivotFieldCollection
Aspose.Cells.GridDesktop.Data.GridPivotItem
Aspose.Cells.GridDesktop.Data.GridPivotItemCollection
Aspose.Cells.GridDesktop.Data.GridPivotTable
Aspose.Cells.GridDesktop.Data.GridPivotTableCollection
Aspose.Cells.GridDesktop.Data.GridRow
Aspose.Cells.GridDesktop.Data.GridRowCollection
Aspose.Cells.GridDesktop.Data.GridShapeCollection
Aspose.Cells.GridDesktop.Data.GridValidation
Aspose.Cells.GridDesktop.Data.GridValidationCollection
Aspose.Cells.GridDesktop.Data.GridWorkbook
Aspose.Cells.GridDesktop.Data.OnErrorActionQuery
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Cells.GridDesktop.Data.CellEventHandler
Aspose.Cells.GridDesktop.Data.CellEventStringHandler
Aspose.Cells.GridDesktop.Data.CustomCommandEventHandler
Aspose.Cells.GridDesktop.Data.RowColumnEventHandler
Aspose.Cells.GridDesktop.Data.WorkbookEventHandler
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridDesktop.Data.GridCellException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.GridDesktop.Data.GridCellErrorType
Aspose.Cells.GridDesktop.Data.GridFilterOperatorType
Aspose.Cells.GridDesktop.Data.GridImageType
Aspose.Cells.GridDesktop.Data.GridMsoDrawingType
Aspose.Cells.GridDesktop.Data.GridOperatorType
Aspose.Cells.GridDesktop.Data.GridPasteType
Aspose.Cells.GridDesktop.Data.GridPivotFieldFunction
Aspose.Cells.GridDesktop.Data.GridPivotFieldType
Aspose.Cells.GridDesktop.Data.GridSaveFormat
Aspose.Cells.GridDesktop.Data.GridValidationType
Aspose.Cells.GridDesktop.Data.NumberType
Aspose.Cells.GridDesktop.Data.OnErrorActionType
Aspose.Cells.GridDesktop.Data.WebCellErrorType

See Also

Aspose.Cells.GridDesktop.Data Namespace


Aspose.Cells.GridDesktop.ToolBarHierarchy

Aspose.Cells for .NET

Aspose.Cells.GridDesktop.ToolBar Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.UserControl
Aspose.Cells.GridDesktop.ToolBar.FormulaBar

See Also

Aspose.Cells.GridDesktop.ToolBar Namespace


Aspose.Cells.GridDesktopHierarchy

Aspose.Cells for .NET

Aspose.Cells.GridDesktop Hierarchy

System.Object
Aspose.Cells.GridDesktop.CellLocation
Aspose.Cells.GridDesktop.CellRange
Aspose.Cells.GridDesktop.CellRelative
Aspose.Cells.GridDesktop.CellControl
Aspose.Cells.GridDesktop.Button
Aspose.Cells.GridDesktop.CheckBox
Aspose.Cells.GridDesktop.ComboBox
Aspose.Cells.GridDesktop.CellRelativeCollection
Aspose.Cells.GridDesktop.CellControlCollection
Aspose.Cells.GridDesktop.ContextMenuManager
Aspose.Cells.GridDesktop.CustomProperty
Aspose.Cells.GridDesktop.GridCell
Aspose.Cells.GridDesktop.ICustomColumnCaption
Aspose.Cells.GridDesktop.ICustomRowCaption
Aspose.Cells.GridDesktop.ICustomValidation
Aspose.Cells.GridDesktop.License
Aspose.Cells.GridDesktop.RowFilterSettings ---- System.Collections.IComparer
Aspose.Cells.GridDesktop.Shape
Aspose.Cells.GridDesktop.SortRange
Aspose.Cells.GridDesktop.Style
Aspose.Cells.GridDesktop.ThemeColor
Aspose.Cells.GridDesktop.UndoManager
Aspose.Cells.GridDesktop.Worksheet
Aspose.Cells.GridDesktop.WorksheetCollection
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.GridDesktop.CustomPropertyCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Cells.GridDesktop.CellComboBoxEventHandler
Aspose.Cells.GridDesktop.CellControlEventHandler
Aspose.Cells.GridDesktop.CellCopyComboBoxEventHandler
Aspose.Cells.GridDesktop.CellEventHandler
Aspose.Cells.GridDesktop.CellFormatEventHandler
Aspose.Cells.GridDesktop.CellKeyEventHandler
Aspose.Cells.GridDesktop.CellRangeEventHandler
Aspose.Cells.GridDesktop.CellValidationEventHandler
Aspose.Cells.GridDesktop.CommentEventHandler
Aspose.Cells.GridDesktop.WorkbookEventHandler
Aspose.Cells.GridDesktop.WorksheetEventHandler
System.EventArgs
Aspose.Cells.GridDesktop.CellControlEventArgs
Aspose.Cells.GridDesktop.CellComboBoxEventArgs
Aspose.Cells.GridDesktop.CellCopyComboBoxEventArgs
Aspose.Cells.GridDesktop.CellEventArgs
Aspose.Cells.GridDesktop.CellFormatEventArgs
Aspose.Cells.GridDesktop.CellRangeEventArgs
Aspose.Cells.GridDesktop.CellValidationEventArgs
Aspose.Cells.GridDesktop.CommentEventArgs
Aspose.Cells.GridDesktop.RowColumnEventArgs
Aspose.Cells.GridDesktop.WorksheetEventArgs
System.Windows.Forms.KeyEventArgs
Aspose.Cells.GridDesktop.CellKeyEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.UserControl
Aspose.Cells.GridDesktop.GridDesktop
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.GridDesktop.BorderLineType
Aspose.Cells.GridDesktop.BorderType
Aspose.Cells.GridDesktop.FileFormatType
Aspose.Cells.GridDesktop.FormatConditionType
Aspose.Cells.GridDesktop.GridBackgroundType
Aspose.Cells.GridDesktop.GridMemorySetting
Aspose.Cells.GridDesktop.HorizontalAlignmentType
Aspose.Cells.GridDesktop.RowColumnType
Aspose.Cells.GridDesktop.SortOrder
Aspose.Cells.GridDesktop.SortOrientation
Aspose.Cells.GridDesktop.TextDirectionType
Aspose.Cells.GridDesktop.ThemeColorType
Aspose.Cells.GridDesktop.VerticalAlignmentType
Aspose.Cells.GridDesktop.WorkBookEvents
Aspose.Cells.GridDesktop.WorksheetEvents

See Also

Aspose.Cells.GridDesktop Namespace


Aspose.Cells.GridWeb.DataHierarchy

Aspose.Cells for .NET

Aspose.Cells.GridWeb.Data Hierarchy

System.Object
Aspose.Cells.GridWeb.Data.CellAttachObject
Aspose.Cells.GridWeb.Data.GridAbstractCalculationEngine
Aspose.Cells.GridWeb.Data.GridCalculationData
Aspose.Cells.GridWeb.Data.GridCell
Aspose.Cells.GridWeb.Data.GridCellArea
Aspose.Cells.GridWeb.Data.GridCells ---- System.Collections.IEnumerable
Aspose.Cells.GridWeb.Data.GridColumn
Aspose.Cells.GridWeb.Data.GridColumnCollection
Aspose.Cells.GridWeb.Data.GridComment
Aspose.Cells.GridWeb.Data.GridCommentCollection
Aspose.Cells.GridWeb.Data.GridCustomServerValidation
Aspose.Cells.GridWeb.Data.GridHyperlink
Aspose.Cells.GridWeb.Data.GridHyperlinkCollection
Aspose.Cells.GridWeb.Data.GridName
Aspose.Cells.GridWeb.Data.GridNameCollection
Aspose.Cells.GridWeb.Data.GridPicture
Aspose.Cells.GridWeb.Data.GridPictureCollection
Aspose.Cells.GridWeb.Data.GridPivotField
Aspose.Cells.GridWeb.Data.GridPivotFieldCollection
Aspose.Cells.GridWeb.Data.GridPivotItem
Aspose.Cells.GridWeb.Data.GridPivotItemCollection
Aspose.Cells.GridWeb.Data.GridPivotTable
Aspose.Cells.GridWeb.Data.GridPivotTableCollection
Aspose.Cells.GridWeb.Data.GridReferredArea
Aspose.Cells.GridWeb.Data.GridRow
Aspose.Cells.GridWeb.Data.GridRowCollection
Aspose.Cells.GridWeb.Data.GridSaveOptions
Aspose.Cells.GridWeb.Data.GridHtmlSaveOptions
Aspose.Cells.GridWeb.Data.GridShape
Aspose.Cells.GridWeb.Data.GridShapeCollection
Aspose.Cells.GridWeb.Data.GridValidation
Aspose.Cells.GridWeb.Data.GridValidationCollection
Aspose.Cells.GridWeb.Data.GridWorkbook ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.Data.GridWorksheetCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.Data.Hyperlink
Aspose.Cells.GridWeb.Data.CellImage
Aspose.Cells.GridWeb.Data.Hyperlinks
Aspose.Cells.GridWeb.Data.ICustomFilter
Aspose.Cells.GridWeb.Data.OnErrorActionQuery
Aspose.Cells.GridWeb.Data.PivotCache
Aspose.Cells.GridWeb.Data.PivotCaches ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Cells.GridWeb.Data.PivotField
Aspose.Cells.GridWeb.Data.PivotFields ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Cells.GridWeb.Data.PivotItem ---- System.IComparable
Aspose.Cells.GridWeb.Data.PivotItems ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Cells.GridWeb.Data.PivotTable
Aspose.Cells.GridWeb.Data.PivotTables ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Cells.GridWeb.Data.RowFilterSettings ---- System.Collections.IComparer, System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.Data.WebCell
Aspose.Cells.GridWeb.Data.WebCellArea
Aspose.Cells.GridWeb.Data.WebCells
Aspose.Cells.GridWeb.Data.WebComment
Aspose.Cells.GridWeb.Data.WebComments
Aspose.Cells.GridWeb.Data.WebWorksheets ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Runtime.Serialization.ISerializable
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Cells.GridWeb.Data.CellErrorHandler
Aspose.Cells.GridWeb.Data.CellEventHandler
Aspose.Cells.GridWeb.Data.CellEventStringHandler
Aspose.Cells.GridWeb.Data.CustomCommandEventHandler
Aspose.Cells.GridWeb.Data.InitializeNewBindRowHandler
Aspose.Cells.GridWeb.Data.RowColumnEventHandler
Aspose.Cells.GridWeb.Data.SheetEventHandler
Aspose.Cells.GridWeb.Data.WorkbookEventHandler
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.Data.GridCellException
Aspose.Cells.GridWeb.Data.WebCellException
System.ApplicationException
Aspose.Cells.GridWeb.Data.GridWebException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.GridWeb.Data.GridCellErrorType
Aspose.Cells.GridWeb.Data.GridImageType
Aspose.Cells.GridWeb.Data.GridMsoDrawingType
Aspose.Cells.GridWeb.Data.GridOperatorType
Aspose.Cells.GridWeb.Data.GridPivotFieldFunction
Aspose.Cells.GridWeb.Data.GridPivotFieldType
Aspose.Cells.GridWeb.Data.GridSaveFormat
Aspose.Cells.GridWeb.Data.GridValidationType
Aspose.Cells.GridWeb.Data.HyperlinkActionType
Aspose.Cells.GridWeb.Data.NumberType
Aspose.Cells.GridWeb.Data.OnErrorActionType
Aspose.Cells.GridWeb.Data.PivotFieldFunction
Aspose.Cells.GridWeb.Data.PivotFieldOrientation
Aspose.Cells.GridWeb.Data.PivotFieldSort
Aspose.Cells.GridWeb.Data.PivotSourceType
Aspose.Cells.GridWeb.Data.SortOrder
Aspose.Cells.GridWeb.Data.SortOrientation
Aspose.Cells.GridWeb.Data.SubtotalFunction
Aspose.Cells.GridWeb.Data.WebCellErrorType
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IControlBuilderAccessor, System.Web.UI.IControlDesignerAccessor, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IExpressionsAccessor, System.Web.UI.IParserAccessor, System.Web.UI.IUrlResolutionService
Aspose.Cells.GridWeb.Data.GridWorksheet ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.Data.WebWorksheet ---- System.Runtime.Serialization.ISerializable

See Also

Aspose.Cells.GridWeb.Data Namespace


Aspose.Cells.GridWeb.DesignHierarchy

Aspose.Cells for .NET

Aspose.Cells.GridWeb.Design Hierarchy

System.Object
System.MarshalByRefObject
Aspose.Cells.GridWeb.Design.DesignParameters
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.GridWeb.Design.DesignCmd

See Also

Aspose.Cells.GridWeb.Design Namespace


Aspose.Cells.GridWebHierarchy

Aspose.Cells for .NET

Aspose.Cells.GridWeb Hierarchy

System.Object
Aspose.Cells.GridWeb.BindColumn ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.BindColumnCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.GridWeb.CustomCommandButtonCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.GridWeb.Data.CellAttachObject
Aspose.Cells.GridWeb.Validation
Aspose.Cells.GridWeb.FilterHelper
Aspose.Cells.GridWeb.License
Aspose.Cells.GridWeb.WebBorderStyle
System.EventArgs
Aspose.Cells.GridWeb.CellEventArgs
Aspose.Cells.GridWeb.RowColumnEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Web.UI.WebControls.Style ---- System.Web.UI.IStateManager
System.Web.UI.WebControls.TableItemStyle
Aspose.Cells.GridWeb.GridTableItemStyle
Aspose.Cells.GridWeb.TableItemStyle
System.Web.UI.WebControls.TableStyle
Aspose.Cells.GridWeb.GridTableStyle
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.GridWeb.BorderCollapseType
Aspose.Cells.GridWeb.CustomCommandButtonType
Aspose.Cells.GridWeb.LayoutFixedType
Aspose.Cells.GridWeb.PresetStyle
Aspose.Cells.GridWeb.RowColumnType
Aspose.Cells.GridWeb.SessionMode
Aspose.Cells.GridWeb.SetBorderPosition
Aspose.Cells.GridWeb.ValidationType
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IControlBuilderAccessor, System.Web.UI.IControlDesignerAccessor, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IExpressionsAccessor, System.Web.UI.IParserAccessor, System.Web.UI.IUrlResolutionService
Aspose.Cells.GridWeb.CustomCommandButton ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.Data.GridWorksheet ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.GridWorksheetDesign
Aspose.Cells.GridWeb.Data.WebWorksheet ---- System.Runtime.Serialization.ISerializable
Aspose.Cells.GridWeb.WorksheetDesign
Aspose.Cells.GridWeb.ViewerStyleTemplate
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
Aspose.Cells.GridWeb.ExtWebControl
Aspose.Cells.GridWeb.MainWeb ---- System.Runtime.Serialization.ISerializable, System.Web.UI.INamingContainer, System.Web.UI.IPostBackDataHandler, System.Web.UI.IPostBackEventHandler
Aspose.Cells.GridWeb.GridWeb
Aspose.Cells.GridWeb.GridWebForm ---- System.Web.UI.INamingContainer, System.Web.UI.IPostBackDataHandler, System.Web.UI.IPostBackEventHandler

See Also

Aspose.Cells.GridWeb Namespace


Aspose.Cells.MarkupHierarchy

Aspose.Cells for .NET

Aspose.Cells.Markup Hierarchy

System.Object
Aspose.Cells.Markup.CustomXmlPart
Aspose.Cells.Markup.SmartTag
Aspose.Cells.Markup.SmartTagOptions
Aspose.Cells.Markup.SmartTagProperty
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Markup.CustomXmlPartCollection
Aspose.Cells.Markup.SmartTagCollection
Aspose.Cells.Markup.SmartTagPropertyCollection
Aspose.Cells.Markup.SmartTagSetting
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Markup.SmartTagShowType

See Also

Aspose.Cells.Markup Namespace


Aspose.Cells.MetadataHierarchy

Aspose.Cells for .NET

Aspose.Cells.Metadata Hierarchy

System.Object
Aspose.Cells.Metadata.MetadataOptions
Aspose.Cells.Metadata.WorkbookMetadata
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Metadata.MetadataType

See Also

Aspose.Cells.Metadata Namespace


Aspose.Cells.OdsHierarchy

Aspose.Cells for .NET

Aspose.Cells.Ods Hierarchy

System.Object
Aspose.Cells.Ods.OdsCellField
Aspose.Cells.Ods.OdsPageBackground
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Ods.OdsCellFieldCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Ods.OdsCellFieldType
Aspose.Cells.Ods.OdsGeneratorType
Aspose.Cells.Ods.OdsPageBackgroundGraphicPositionType
Aspose.Cells.Ods.OdsPageBackgroundGraphicType
Aspose.Cells.Ods.OdsPageBackgroundType

See Also

Aspose.Cells.Ods Namespace


Aspose.Cells.PivotHierarchy

Aspose.Cells for .NET

Aspose.Cells.Pivot Hierarchy

System.Object
Aspose.Cells.Pivot.PivotField
Aspose.Cells.Pivot.PivotFieldCollection ---- System.Collections.IEnumerable
Aspose.Cells.Pivot.PivotFilter
Aspose.Cells.Pivot.PivotFormatCondition
Aspose.Cells.Pivot.PivotItem
Aspose.Cells.Pivot.PivotItemCollection ---- System.Collections.IEnumerable
Aspose.Cells.Pivot.PivotPageFields
Aspose.Cells.Pivot.PivotTable ---- System.IDisposable
Aspose.Cells.Pivot.SxRng
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Pivot.PivotFilterCollection
Aspose.Cells.Pivot.PivotFormatConditionCollection
Aspose.Cells.Pivot.PivotTableCollection ---- System.IDisposable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Pivot.PivotConditionFormatRuleType
Aspose.Cells.Pivot.PivotConditionFormatScopeType
Aspose.Cells.Pivot.PivotFieldDataDisplayFormat
Aspose.Cells.Pivot.PivotFieldSubtotalType
Aspose.Cells.Pivot.PivotFieldType
Aspose.Cells.Pivot.PivotFilterType
Aspose.Cells.Pivot.PivotGroupByType
Aspose.Cells.Pivot.PivotItemPosition
Aspose.Cells.Pivot.PivotMissingItemLimitType
Aspose.Cells.Pivot.PivotTableAutoFormatType
Aspose.Cells.Pivot.PivotTableStyleType

See Also

Aspose.Cells.Pivot Namespace


Aspose.Cells.PropertiesHierarchy

Aspose.Cells for .NET

Aspose.Cells.Properties Hierarchy

System.Object
Aspose.Cells.Properties.ContentTypeProperty
Aspose.Cells.Properties.CustomProperty
Aspose.Cells.Properties.DocumentProperty
Aspose.Cells.Properties.DocumentPropertyCollection ---- System.Collections.IEnumerable
Aspose.Cells.Properties.BuiltInDocumentPropertyCollection
Aspose.Cells.Properties.CustomDocumentPropertyCollection
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Properties.ContentTypePropertyCollection
Aspose.Cells.Properties.CustomPropertyCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Properties.PropertyType

See Also

Aspose.Cells.Properties Namespace


Aspose.Cells.QueryTablesHierarchy

Aspose.Cells for .NET

Aspose.Cells.QueryTables Hierarchy

System.Object
Aspose.Cells.QueryTables.DataMashup
Aspose.Cells.QueryTables.PowerQueryFormula
Aspose.Cells.QueryTables.PowerQueryFormulaFunction
Aspose.Cells.QueryTables.PowerQueryFormulaItem
Aspose.Cells.QueryTables.PowerQueryFormulaParameter
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.QueryTables.PowerQueryFormulaCollction
Aspose.Cells.QueryTables.PowerQueryFormulaItemCollection
Aspose.Cells.QueryTables.PowerQueryFormulaParameterCollection

See Also

Aspose.Cells.QueryTables Namespace


Aspose.Cells.Rendering.PdfSecurityHierarchy

Aspose.Cells for .NET

Aspose.Cells.Rendering.PdfSecurity Hierarchy

System.Object
Aspose.Cells.Rendering.PdfSecurity.PdfSecurityOptions

See Also

Aspose.Cells.Rendering.PdfSecurity Namespace


Aspose.Cells.RenderingHierarchy

Aspose.Cells for .NET

Aspose.Cells.Rendering Hierarchy

System.Object
Aspose.Cells.Rendering.DrawObject
Aspose.Cells.Rendering.DrawObjectEventHandler
Aspose.Cells.Rendering.ImageOrPrintOptions
Aspose.Cells.Rendering.IPageSavingCallback
Aspose.Cells.Rendering.PageSavingArgs
Aspose.Cells.Rendering.PageEndSavingArgs
Aspose.Cells.Rendering.PageStartSavingArgs
Aspose.Cells.Rendering.PdfBookmarkEntry
Aspose.Cells.Rendering.SheetPrintingPreview
Aspose.Cells.Rendering.SheetRender
Aspose.Cells.Rendering.WorkbookPrintingPreview
Aspose.Cells.Rendering.WorkbookRender
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Rendering.ColorDepth
Aspose.Cells.Rendering.DrawObjectEnum
Aspose.Cells.Rendering.PdfCompliance
Aspose.Cells.Rendering.PdfCompressionCore
Aspose.Cells.Rendering.PdfCustomPropertiesExport
Aspose.Cells.Rendering.PdfOptimizationType
Aspose.Cells.Rendering.TiffCompression

See Also

Aspose.Cells.Rendering Namespace


Revision Hierarchy

System.Object
Revision
RevisionAutoFormat
RevisionCellChange
RevisionCellComment
RevisionCellMove
RevisionCustomView
RevisionDefinedName
RevisionFormat
RevisionInsertDelete
RevisionInsertSheet
RevisionMergeConflict
RevisionQueryTable
RevisionRenameSheet

See Also

Revision Class | Revision Members | Aspose.Cells.Revisions Namespace


Aspose.Cells.RevisionsHierarchy

Aspose.Cells for .NET

Aspose.Cells.Revisions Hierarchy

System.Object
Aspose.Cells.Revisions.Revision
Aspose.Cells.Revisions.RevisionAutoFormat
Aspose.Cells.Revisions.RevisionCellChange
Aspose.Cells.Revisions.RevisionCellComment
Aspose.Cells.Revisions.RevisionCellMove
Aspose.Cells.Revisions.RevisionCustomView
Aspose.Cells.Revisions.RevisionDefinedName
Aspose.Cells.Revisions.RevisionFormat
Aspose.Cells.Revisions.RevisionInsertDelete
Aspose.Cells.Revisions.RevisionInsertSheet
Aspose.Cells.Revisions.RevisionMergeConflict
Aspose.Cells.Revisions.RevisionQueryTable
Aspose.Cells.Revisions.RevisionRenameSheet
Aspose.Cells.Revisions.RevisionLog
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Revisions.RevisionCollection
Aspose.Cells.Revisions.RevisionLogCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Revisions.RevisionActionType
Aspose.Cells.Revisions.RevisionType

See Also

Aspose.Cells.Revisions Namespace


SaveOptions Hierarchy

System.Object
SaveOptions
DifSaveOptions
DocxSaveOptions
HtmlSaveOptions
ImageSaveOptions
MarkdownSaveOptions
OdsSaveOptions
OoxmlSaveOptions
PdfSaveOptions
PptxSaveOptions
SpreadsheetML2003SaveOptions
TxtSaveOptions
XlsbSaveOptions
XlsSaveOptions
XpsSaveOptions

See Also

SaveOptions Class | SaveOptions Members | Aspose.Cells Namespace


Aspose.Cells.SlicersHierarchy

Aspose.Cells for .NET

Aspose.Cells.Slicers Hierarchy

System.Object
Aspose.Cells.Slicers.Slicer
Aspose.Cells.Slicers.SlicerCache
Aspose.Cells.Slicers.SlicerCacheItem
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Slicers.SlicerCacheItemCollection
Aspose.Cells.Slicers.SlicerCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Slicers.SlicerCacheCrossFilterType
Aspose.Cells.Slicers.SlicerCacheItemSortType
Aspose.Cells.Slicers.SlicerStyleType

See Also

Aspose.Cells.Slicers Namespace


Aspose.Cells.TablesHierarchy

Aspose.Cells for .NET

Aspose.Cells.Tables Hierarchy

System.Object
Aspose.Cells.Tables.ListColumn
Aspose.Cells.Tables.ListObject
Aspose.Cells.Tables.TableStyle
Aspose.Cells.Tables.TableStyleElement
Aspose.Cells.Tables.TableToRangeOptions
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Tables.ListColumnCollection
Aspose.Cells.Tables.ListObjectCollection
Aspose.Cells.Tables.TableStyleCollection
Aspose.Cells.Tables.TableStyleElementCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Tables.TableDataSourceType
Aspose.Cells.Tables.TableStyleElementType
Aspose.Cells.Tables.TableStyleType
Aspose.Cells.Tables.TotalsCalculation

See Also

Aspose.Cells.Tables Namespace


Aspose.Cells.UtilityHierarchy

Aspose.Cells for .NET

Aspose.Cells.Utility Hierarchy

System.Object
Aspose.Cells.Utility.ExportRangeToJsonOptions
Aspose.Cells.Utility.JsonLayoutOptions
Aspose.Cells.Utility.JsonUtility

See Also

Aspose.Cells.Utility Namespace


Aspose.Cells.VbaHierarchy

Aspose.Cells for .NET

Aspose.Cells.Vba Hierarchy

System.Object
Aspose.Cells.Vba.VbaModule
Aspose.Cells.Vba.VbaProject
Aspose.Cells.Vba.VbaProjectReference
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.Vba.VbaModuleCollection
Aspose.Cells.Vba.VbaProjectReferenceCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.Vba.VbaModuleType
Aspose.Cells.Vba.VbaProjectReferenceType

See Also

Aspose.Cells.Vba Namespace


Aspose.Cells.WebExtensionsHierarchy

Aspose.Cells for .NET

Aspose.Cells.WebExtensions Hierarchy

System.Object
Aspose.Cells.WebExtensions.WebExtension
Aspose.Cells.WebExtensions.WebExtensionBinding
Aspose.Cells.WebExtensions.WebExtensionProperty
Aspose.Cells.WebExtensions.WebExtensionReference
Aspose.Cells.WebExtensions.WebExtensionTaskPane
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.WebExtensions.WebExtensionBindingCollection
Aspose.Cells.WebExtensions.WebExtensionCollection
Aspose.Cells.WebExtensions.WebExtensionPropertyCollection
Aspose.Cells.WebExtensions.WebExtensionReferenceCollection
Aspose.Cells.WebExtensions.WebExtensionTaskPaneCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.WebExtensions.WebExtensionStoreType

See Also

Aspose.Cells.WebExtensions Namespace


Aspose.CellsHierarchy

Aspose.Cells for .NET

Aspose.Cells Hierarchy

System.Object
Aspose.Cells.AboveAverage
Aspose.Cells.AbstractCalculationEngine
Aspose.Cells.AbstractCalculationMonitor
Aspose.Cells.AutoFilter
Aspose.Cells.AutoFitterOptions
Aspose.Cells.Border
Aspose.Cells.BorderCollection
Aspose.Cells.CalculationCell
Aspose.Cells.CalculationData
Aspose.Cells.CalculationOptions
Aspose.Cells.Cell
Aspose.Cells.Cells ---- System.Collections.IEnumerable, System.IDisposable
Aspose.Cells.CellsColor
Aspose.Cells.CellsFactory
Aspose.Cells.CellsHelper
Aspose.Cells.CellWatch
Aspose.Cells.ColorFilter
Aspose.Cells.ColorScale
Aspose.Cells.Column
Aspose.Cells.Comment
Aspose.Cells.ConditionalFormattingIcon
Aspose.Cells.ConditionalFormattingResult
Aspose.Cells.ConditionalFormattingValue
Aspose.Cells.CopyOptions
Aspose.Cells.CustomFilter
Aspose.Cells.CustomImplementationFactory
Aspose.Cells.DataBar
Aspose.Cells.DataBarBorder
Aspose.Cells.DataSorter
Aspose.Cells.DataSorterKey
Aspose.Cells.DateTimeGroupItem
Aspose.Cells.DeleteOptions
Aspose.Cells.DynamicFilter
Aspose.Cells.ErrorCheckOption
Aspose.Cells.ExportObjectEvent
Aspose.Cells.ExportTableOptions
Aspose.Cells.ExternalLink
Aspose.Cells.ExternalLinkCollection
Aspose.Cells.FileFormatInfo
Aspose.Cells.FileFormatUtil
Aspose.Cells.FilterColumn
Aspose.Cells.FindOptions
Aspose.Cells.Font
Aspose.Cells.FontConfigs
Aspose.Cells.FontSetting
Aspose.Cells.FontSourceBase
Aspose.Cells.FileFontSource
Aspose.Cells.FolderFontSource
Aspose.Cells.MemoryFontSource
Aspose.Cells.FormatCondition
Aspose.Cells.FormatConditionCollection
Aspose.Cells.FormulaParseOptions
Aspose.Cells.GlobalizationSettings
Aspose.Cells.HeaderFooterCommand
Aspose.Cells.HorizontalPageBreak
Aspose.Cells.Hyperlink
Aspose.Cells.ICellsDataTable
Aspose.Cells.IconFilter
Aspose.Cells.IconSet
Aspose.Cells.ICustomFunction
Aspose.Cells.ICustomParser
Aspose.Cells.IExportObjectListener
Aspose.Cells.IFilePathProvider
Aspose.Cells.ImportTableOptions
Aspose.Cells.IndividualFontConfigs
Aspose.Cells.InsertOptions
Aspose.Cells.InterruptMonitor
Aspose.Cells.ISmartMarkerCallBack
Aspose.Cells.IStreamProvider
Aspose.Cells.IWarningCallback
Aspose.Cells.License
Aspose.Cells.LightCellsDataHandler
Aspose.Cells.LightCellsDataProvider
Aspose.Cells.LoadFilter
Aspose.Cells.LoadOptions
Aspose.Cells.AbstractTextLoadOptions
Aspose.Cells.HtmlLoadOptions
Aspose.Cells.TxtLoadOptions
Aspose.Cells.OdsLoadOptions
Aspose.Cells.Metered
Aspose.Cells.Name
Aspose.Cells.NegativeBarFormat
Aspose.Cells.Outline
Aspose.Cells.PageSetup
Aspose.Cells.PaneCollection
Aspose.Cells.PasteOptions
Aspose.Cells.ProtectedRange
Aspose.Cells.Protection
Aspose.Cells.QueryTable
Aspose.Cells.Range
Aspose.Cells.ReferredArea
Aspose.Cells.ReplaceOptions
Aspose.Cells.Row ---- System.Collections.IEnumerable
Aspose.Cells.RowCollection ---- System.Collections.IEnumerable
Aspose.Cells.SaveOptions
Aspose.Cells.DifSaveOptions
Aspose.Cells.DocxSaveOptions
Aspose.Cells.HtmlSaveOptions
Aspose.Cells.ImageSaveOptions
Aspose.Cells.SvgSaveOptions
Aspose.Cells.MarkdownSaveOptions
Aspose.Cells.OdsSaveOptions
Aspose.Cells.OoxmlSaveOptions
Aspose.Cells.PdfSaveOptions
Aspose.Cells.PptxSaveOptions
Aspose.Cells.SpreadsheetML2003SaveOptions
Aspose.Cells.TxtSaveOptions
Aspose.Cells.XlsbSaveOptions
Aspose.Cells.XlsSaveOptions
Aspose.Cells.XpsSaveOptions
Aspose.Cells.Scenario
Aspose.Cells.ScenarioInputCell
Aspose.Cells.StreamProviderOptions
Aspose.Cells.Style
Aspose.Cells.StyleCollection
Aspose.Cells.StyleFlag
Aspose.Cells.SubtotalSetting
Aspose.Cells.ThemeColor
Aspose.Cells.ThreadedComment
Aspose.Cells.ThreadedCommentAuthor
Aspose.Cells.Top10
Aspose.Cells.Top10Filter
Aspose.Cells.UnionRange
Aspose.Cells.Validation
Aspose.Cells.VerticalPageBreak
Aspose.Cells.WarningInfo
Aspose.Cells.Workbook ---- System.IDisposable
Aspose.Cells.WorkbookDesigner
Aspose.Cells.WorkbookSettings ---- System.IDisposable
Aspose.Cells.Worksheet ---- System.IDisposable
Aspose.Cells.WriteProtection
Aspose.Cells.XmlColumnProperty
Aspose.Cells.XmlDataBinding
Aspose.Cells.XmlMap
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Cells.CellWatchCollection
Aspose.Cells.ColumnCollection
Aspose.Cells.CommentCollection
Aspose.Cells.ConditionalFormattingCollection
Aspose.Cells.ConditionalFormattingIconCollection
Aspose.Cells.ConditionalFormattingValueCollection
Aspose.Cells.CustomFilterCollection
Aspose.Cells.DataSorterKeyCollection
Aspose.Cells.DxfCollection
Aspose.Cells.ErrorCheckOptionCollection
Aspose.Cells.FilterColumnCollection
Aspose.Cells.HorizontalPageBreakCollection
Aspose.Cells.HyperlinkCollection
Aspose.Cells.MultipleFilterCollection
Aspose.Cells.NameCollection
Aspose.Cells.ProtectedRangeCollection
Aspose.Cells.QueryTableCollection
Aspose.Cells.RangeCollection
Aspose.Cells.ReferredAreaCollection
Aspose.Cells.ScenarioCollection
Aspose.Cells.ScenarioInputCellCollection
Aspose.Cells.ThreadedCommentAuthorCollection
Aspose.Cells.ThreadedCommentCollection
Aspose.Cells.ValidationCollection
Aspose.Cells.VerticalPageBreakCollection
Aspose.Cells.WorksheetCollection
Aspose.Cells.XmlMapCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Aspose.Cells.CellsException
System.ValueType
Aspose.Cells.CellArea ---- System.IComparable
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Cells.AutoFitMergedCellsType
Aspose.Cells.AutoFitWrappedTextType
Aspose.Cells.BackgroundType
Aspose.Cells.BorderType
Aspose.Cells.BuiltinStyleType
Aspose.Cells.CalcModeType
Aspose.Cells.CalculationPrecisionStrategy
Aspose.Cells.CellBorderType
Aspose.Cells.CellValueFormatStrategy
Aspose.Cells.CellValueType
Aspose.Cells.ColorType
Aspose.Cells.ConsolidationFunction
Aspose.Cells.ContentDisposition
Aspose.Cells.CopyFormatType
Aspose.Cells.CountryCode
Aspose.Cells.DataBarAxisPosition
Aspose.Cells.DataBarBorderType
Aspose.Cells.DataBarFillType
Aspose.Cells.DataBarNegativeColorType
Aspose.Cells.DateTimeGroupingType
Aspose.Cells.DefaultEditLanguage
Aspose.Cells.DirectoryType
Aspose.Cells.DisplayDrawingObjects
Aspose.Cells.DynamicFilterType
Aspose.Cells.EmfRenderSetting
Aspose.Cells.EncryptionType
Aspose.Cells.ErrorCheckType
Aspose.Cells.ExceptionType
Aspose.Cells.ExternalLinkType
Aspose.Cells.FileFormatType
Aspose.Cells.FilterOperatorType
Aspose.Cells.FilterType
Aspose.Cells.FontSchemeType
Aspose.Cells.FontSourceType
Aspose.Cells.FontUnderlineType
Aspose.Cells.FormatConditionType
Aspose.Cells.FormatConditionValueType
Aspose.Cells.GridlineType
Aspose.Cells.HeaderFooterCommandType
Aspose.Cells.HtmlCrossType
Aspose.Cells.HtmlExportDataOptions
Aspose.Cells.HtmlHiddenColDisplayType
Aspose.Cells.HtmlHiddenRowDisplayType
Aspose.Cells.HtmlLinkTargetType
Aspose.Cells.IconSetType
Aspose.Cells.LoadDataFilterOptions
Aspose.Cells.LoadFormat
Aspose.Cells.LookAtType
Aspose.Cells.LookInType
Aspose.Cells.MemorySetting
Aspose.Cells.NumberCategoryType
Aspose.Cells.OoxmlCompliance
Aspose.Cells.OoxmlCompressionType
Aspose.Cells.OperatorType
Aspose.Cells.PageLayoutAlignmentType
Aspose.Cells.PageOrientationType
Aspose.Cells.PaneStateType
Aspose.Cells.PaperSizeType
Aspose.Cells.ParameterType
Aspose.Cells.PasteType
Aspose.Cells.PrintCommentsType
Aspose.Cells.PrintErrorsType
Aspose.Cells.PrintingPageType
Aspose.Cells.PrintOrderType
Aspose.Cells.PrintSizeType
Aspose.Cells.ProtectionType
Aspose.Cells.RegexType
Aspose.Cells.RenameStrategy
Aspose.Cells.ResourceLoadingType
Aspose.Cells.SaveFormat
Aspose.Cells.SheetType
Aspose.Cells.ShiftType
Aspose.Cells.SortOnType
Aspose.Cells.SortOrder
Aspose.Cells.StyleModifyFlag
Aspose.Cells.TargetModeType
Aspose.Cells.TextAlignmentType
Aspose.Cells.TextCapsType
Aspose.Cells.TextCrossType
Aspose.Cells.TextDirectionType
Aspose.Cells.TextOrientationType
Aspose.Cells.TextStrikeType
Aspose.Cells.ThemeColorType
Aspose.Cells.TimePeriodType
Aspose.Cells.TxtLoadStyleStrategy
Aspose.Cells.TxtValueQuoteType
Aspose.Cells.UpdateLinksType
Aspose.Cells.ValidationAlertType
Aspose.Cells.ValidationType
Aspose.Cells.ViewType
Aspose.Cells.VisibilityType
Aspose.Cells.WarningType

See Also

Aspose.Cells Namespace